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The purpose of this sample 
The purpose of this sample is to guide you through the process of 
building a monitor model in IBM WebSphere® Integration 
Developer, deploy it to WebSphere Business Monitor, and then view 
your monitoring data on the Monitor dashboards. 
 
This lab demonstrates the use of Business Activity Monitoring 
(BAM) that involves event-based monitoring.  With BAM, your 
monitored application can run anywhere, and can submit events to 
the Monitor server so that you can view monitored data.  Normally, 
you identify the events that will be created by the application, and 
then create a monitor model that represents the monitored data that 
you want to collect from the events. 
 

Sample requirements 
To complete this sample, you need the following software:  

• WebSphere Integration Developer, V6.0.2 and the 
Monitoring Model Editor plug-in 

• WebSphere Business Monitor, V6.0.2 – Basic 
Installation including the Dashboard Server and 
Monitor Server 

• Optionally, a Lightweight Directory Access Protocol 
(LDAP) server (for example, IBM Tivoli® Directory 
Server) if you would like to configure Action Manager 
to create alerts based on business-situation events 

 

The goal of this exercise 
At the end of this exercise you should be able to: 

• Use WebSphere Integration Developer to create the 
monitor model, and then export the monitor model as 
an enterprise archive (EAR) file. 

• Use the WebSphere Process Server administrative 
console to install the EAR file. 

• Use the WebSphere Process Server administrative 
console to run Monitor life-cycle steps for the model. 
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• Run Monitor scripts to create the Monitor Server tables 
and replication-manager artifacts, and to start 
replication manager daemons. 

• Import the cubes into Cube Views. 
• Use a sample program to create events that represent 

events from your process. 
• Use Portal to define a dashboard and to view 

monitored data. 
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Introduction 
 
In this sample you will learn how to deploy a model from end to end 
using WebSphere Integration Developer and WebSphere Business 
Monitor.  This is a complex process, and you will be performing 
many different roles — user analyst, process architect, process 
developer, database administrator, dashboard architect, and user. 
This sample will show you the basic procedure for creating and 
implementing a simple model.   
 
This sample uses the ClipsAndTacks process model, which is also 
used in the IBM Redbooks™ publication Business Process 
Management: Modeling through Monitoring Using WebSphere V6 
Products, SG247148.  This publication refers to several models, but 
uses the Future 1 Process.  In that publication, the process is 
implemented as a BPEL process running in WebSphere Process 
Server.  This lab demonstrates Business Activity Monitoring 
(BAM), which can monitor events from any source.  It simulates the 
running of the process by creating events that could have been 
sourced from anywhere: a Java™ 2 Platform, Enterprise Edition 
(J2EE) application or Business Process Execution Language 
(BPEL), or any other source.   
 
Note: Monitor accepts only events that are in the form of Common 
Base Events, which is an OASIS standard for common event format, 
and which is used by the Common Event Infrastructure (CEI) in 
WebSphere Process Server. 
 
This exercise also describes how to build a monitor model that has 
the same basic elements as the one that is defined in the Redbooks 
publication, namely, creating monitoring constructs in support of 
two key performance indicators (KPIs): 

• Average order fulfillment is 3 days or less. 
• Percentage of shipped orders is greater than 90 percent. 

 
This exercise also describes how to create an additional KPI to 
demonstrate the usage of a monetary KPI. 

• Average Order Price KPI 
  
Because the exercise describes how to create situation events if 
Declined Orders is greater than or equal to 5, it uses an additional 
KPI: 

• Declined order KPI 
 
This exercise also describes how to create situation events if the 
order fulfillment time is greater than 3 days. 
 
For dimensional analysis, the exercise describes how to create a 
Location dimension.  This allows you to drill down on country and 
city.  This exercise also describes how to add Order Status, which 
shows orders as New, Cancelled, or Shipped.  
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This sample also describes how to add measures for average order 
price, the sum of order price for all orders, and order count. 
 
See the overview document for the samples based on Clips and 
Tacks for a depiction of the process. 
 

Helpful Web addresses 
You might find the following Web addresses helpful as you use this 
sample.  Note that the port numbers for your installation might be 
different, depending on your configuration.  
 

• WebSphere Process Server administrative console (for 
deploying monitor models) 

 
http://localhost:9062/ibm/console/ 
 

• DB2 Alphablox® administrative pages (for deploying 
cubes) 

 
http://localhost:9081/AlphabloxAdmin/home 
  

• WebSphere Portal Server (for setting up and viewing 
Monitor dashboards) 

 
http://localhost:9081/wps/portal  
 

 
Note: WebSphere Business Monitor, V6.0.2 has improved support 
for concurrent versions of monitor models. In order to take 
advantage of the versioning capabilities in Monitor Server, each 
monitoring context must have a unique Common Base Event 
definition that is the single Inbound Event with the setting If no 
instances are found: Create new instance.  Think of this as one 
Inbound Event carrying Create Monitor Context semantics, and all 
others as Update Monitor Context semantics. ClipsAndTacks also 
follows this pattern.  
 
To cause the creation of the Monitoring Context, developers should 
always have a unique Inbound Event.  
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Part 1. Create the monitor model 
 
To create the monitor model, you will use the Monitoring Model 
Editor in WebSphere Integration Developer.  
  
Note: There is a Problems page that displays errors concerning the 
model. Check this view periodically to see if you have any problems 
that need to be addressed. 
 
If you would like to skip this section, a solution has been provided.  
You can import the supplied monitor model into WebSphere 
Integration Developer, using the instructions in Appendix 1, then 
proceed to the next section.  
 
____ 1. Start WebSphere Integration Developer and set up the 

environment. 
__ a. Start WebSphere Integration Developer, V6.0.2, and 

when prompted, point to a new workspace, such as 
C:\workspaces\ClipsAndTacks. 

__ b. Close the Welcome page. 
__ c. Click Window ► Close Perspective. 
__ d. By default, you are in the Business Integration 

perspective.   Open the Business Monitoring 
perspective.  To do so, click Window ► Open 
Perspective ► Other ► Show all ► Business 
Monitoring.   

1) If you are asked to confirm enablement, click 
OK. 

__ e. You should see the following Business Monitoring 
perspective.

Figure 1. The Business Monitoring perspective 
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____ 2. Create a new monitoring project. 
__ a. Right-click in the Project Explorer pane, then click 

New ► Business Monitoring Project. 
__ b. For Project name, enter ClipsAndTacks.

Figure 2. Enter the Project name ClipsAndTacks 
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 __ c. Click Finish.  You will see the new project in the 
Project Explorer pane.

Figure 3. The new project in the Project Explorer pane 
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____ 3. This exercise has already described how to create a 

Common Base Event definition to represent the event 
layout for events processed in the model.  Import the 
supplied Common Base Event for ActivityEvent. 
__ a. Right-click in the Project Explorer pane, then select 

Import. 
__ b. Select File system, and then click Next. 
__ c. Browse to the location containing the Activity Event 

Common Base Event, for example, 
C:\Labfiles602\ClipsAndTacks. 

__ d. Select ActivityEvent.cbe as follows:
Figure 4. Select ActivityEvent.cbe 
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__ e. Click Finish. 
__ f. Expand the project in the Project Explorer pane, and 

then expand Event Definitions to see the new event 
listed.

Figure 5. Expand the project and Event Definitions 
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__ g. Double-click ActivityEvent to open the event editor.  

Browse the extended data elements to familiarize 
yourself with the event data for this model.   

1) ActivityEventData contains data elements that 
relate to the activities in the process.  This 
exercise uses businessUnit and processName 
to filter out unwanted events that do not relate 
to the particular model in use. It uses 
activityName to associate an event with a 
specific activity in the process.  eventType is 
used to identify the state of the activity, either 
starting or completing. 

2) OrderBOData contains data elements that 
relate to the specifics of a customer order, such 
as orderNumber, country, city, and totalPrice.

Figure 6. OrderBOData contains data elements that relate to the customer order 
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Figure 7. Enter the name 
NewOrderEvent 

 
__ h. WebSphere Business Monitor, V6.0.2 has improved 

support for concurrent versions of monitor models. 
In order to take advantage of the versioning 
capabilities in Monitor Server, each monitoring 
context must have a unique Common Base Event 
definition that is the single Inbound Event  with the 
setting If no instances are found: Create new 
instance.  Think of this as one Inbound Event 
carrying Create Monitor Context semantics, and all 
others as Update Monitor Context semantics. 
ClipsAndTacks is a simple sample and could use a 
single event definition for the process. However, to 
satisfy the requirement of a unique Common Base 
Event definition for versioning, this exercise will 
now demonstrate how to create a simple Common 
Base Event definition. 

1) Right-click Event Definitions and select New 
► Event Definition. 

2) Enter NewOrderEvent as the name. 

 
3) Click Finish. 
4) The Event Definition editor opens, displaying 

NewOrderEvent.
Figure 8. The Event Definition editor opens 
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5) Double-click the hierarchical icon between the 
labels Parent and event.  

6) In the Select Event Definition window, double-
click ActivityEvent.

Figure 9. Double-click ActivityEvent in the Select Event Definition window  
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7) ActivityEvent is now shown as the parent of 
NewOrderEvent.

Figure 10. ActivityEvent is now shown as the parent 

 
 

 

 

 

Figure 11. Enter ClipsAndTacks for 
the File name 

8) Press Ctrl+S to save your work. 
____ 4. Create a new monitor model named ClipsAndTacks. 

__ a. Right-click in the Project Explorer pane, then click 
New ► Monitor Model. 

__ b. For the File name, enter ClipsAndTacks.  

 



         Business Activity Monitoring 
 
19 

__ c. Click Finish.  The model editor is opened, as shown 
in the following example. 

 
Note: When the model editor first opens, the model will contain 
errors. This is normal and signals that required elements are missing 
or incomplete. In the following steps, this exercise will describe how 
to complete the required elements.

Figure 12. The model will contain errors when the model editor first opens 

 
 

____ 5. Notice in the Monitor Details Model navigation pane that a 
new model is created (ClipsAndTacks) along with a 
monitoring context (ClipsAndTacks MC).  Now you need 
to specify the inbound events that will be processed by this 
model.   
 
You need to indicate which event will create a new 
monitoring context instance and which event will terminate 
the monitoring context instance.  You also need to identify 
the correlation information for the monitoring context so 
that Monitor knows which monitoring context should 
receive the events.   
 
For the ClipsAndTacks model, this sample uses one event 
definition, ActivityEvent, to represent the layout of all of 
the events to be processed. NewOrderEvent, which is used 
for versioning, is derived from ActivityEvent but does not 
include additional event elements.  In ActivityEvent,  
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ActivityName is a field used to identify specific activities 
in the ClipsAndTacks process. This sample uses 
ActivityName to determine when to terminate the 
monitoring context.   
 
You will create a correlation that is based on orderNumber, 
which is another field defined in ActivityEvent.  
 
__ a. In the Monitor Details Model navigation pane, expand 

ClipsAndTacks.  Then expand ClipsAndTacks MC.  
You will see that a key was automatically created 
when you created the model.

Figure 13. A key was automatically created when you created the model 

 
 

 

 

 

 

 
 

Figure 14 The ID is automatically set 
to the same name, but with 
underscores 

__ b. Create a new inbound event Activity Event for the 
ClipsAndTacks monitoring context. 

1) In the Monitor Details Model navigation pane, 
right-click ClipsAndTacks MC, then click 
New ► Inbound Event. 

2) For the name, type Activity Event.  Notice that 
the ID is automatically set to the same name, 
but with underscores (Activity_Event). 
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3) Click OK. 
4) For Type, navigate to ClipsAndTacks ► 

ActivityEvent.cbe ► ActivityEvent. 
5) To enter the filter condition, you can use 

Content Assist by pressing Ctrl+Space, or you 
can type the expression directly into the 
expression window.  The complete expression 
should look like the following example. Note 
the single quotation marks used for string 
handling. 
 
Activity_Event/extendedData/ActivityEve
ntData/businessUnit = 'Clips And Tacks' 
and 
Activity_Event/extendedData/ActivityEve
ntData/processName = 'Order Handling' 
 

6) To enter the correlation expression, you can use 
Content Assist by pressing Ctrl+Space, or you 
can type the expression directly into the 
expression window.  The complete expression 
should match the following example:  

 
ClipsAndTacks_Key = 
Activity_Event/extendedData/OrderBOData
/orderNumber 
 

7) For If no instances are found, select Treat as 
error. 

8) For If one instance is found, select Deliver to 
the instance. 

9) For If multiple instances are found, select 
Treat as error. 
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10) Confirm that the data you have specified 
matches the following sample:

Figure 15. The data that you specified should match this sample 

 
11) Press Ctrl+S to save your work. 

__ c. Create a new inbound event New Orders Event for the 
ClipsAndTacks monitoring context.  

1) In the Monitor Details Model navigation pane, 
right-click ClipsAndTacks MC, then select 
New ► Inbound Event. 
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Figure 16. The ID is automatically set 
to the same name with underscores 

2) For the name, type New Order Event.  Notice 
that the ID is automatically set to the same 
name, but with underscores 
(New_Order_Event). 

 

 
 
3) Click OK. 
4) For Type, navigate to ClipsAndTacks ► 

NewOrderEvent.cbe ► NewOrderEvent. 
5) To enter the filter condition, you can use 

Content Assist by pressing Ctrl+Space, or you 
can type the expression directly into the 
expression window. The complete expression 
should look like the following example.   

 
Note: Single quotation marks used for string 
handling. 

 
New_Order_Event/extendedData/ActivityEv
entData/businessUnit='Clips And Tacks' 
and 
New_Order_Event/extendedData/ActivityEv
entData/processName='Order Handling' 
 

6) To enter the correlation expression, you can use 
Content Assist by pressing Ctrl+Space, or you 
can type the expression directly into the 
expression window.  The complete expression 
should match the following example:  

 
ClipsAndTacks_Key=New_Order_Event/exten
dedData/OrderBOData/orderNumber 
 

7) For If no instances are found, select Create 
new instance. 

8) For If one instance is found, select Treat as 
error. 

9) For If multiple instances are found, select 
Treat as error. 
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10) Confirm that the data you have specified 
matches the following sample:

Figure 17. The data that you specified should match this sample 

 
11) Press Ctrl+S to save your work. 

__ d. Define an expression that will set the value of the 
key. 

1) In the Monitor Details Model navigation pane, 
double-click ClipsAndTacks Key to open the 
key in the editor. 

2) For Key Value Maps, click Add. 
3) A row is added to the table, and the expression 

cell shows << No expression specified >>.  
Click this cell of the table, then click the 
button that is displayed to open the expression 
editor.  You can use Content Assist, or type 
this expression directly into the window:  

 
New_Order_Event/extendedData/OrderBODat
a/orderNumber 
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Figure 18. The data that you specified 
should match this sample 

4) Confirm that the data you have specified 
matches the following sample: 

 

 
5) Click OK. Confirm that the information 

displayed for the key matches the following 
sample:

Figure 19. The information displayed for the key should match this sample 
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6) Press Ctrl+S to save your work. 
Note: At this point, the model should contain no errors. The errors 
were initially displayed because the monitoring context key was not 
complete. 
____ 6. Create triggers that indicate the end of the monitoring 

context. 
__ a. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Trigger.  Enter these values: 

1) For Name, type Ship Order to Customer 
Trigger. 

2) For ID, type 
Ship_Order_to_Customer_Trigger. 

3) Select the Terminate monitoring context 
check box. 

4) For Trigger Sources, click Add, then select 
Other source type ► Activity Event, then 
click OK. 

5) For Trigger condition, enter:  
Activity_Event/extendedData/ActivityEve
ntData/activityName='Ship Order to 
Customer' and 
Activity_Event/extendedData/ActivityEve
ntData/eventType='completed' 
 

__ b. Press Ctrl+S to save your work. 
__ c. Confirm that the information displayed for the trigger 

matches the following sample:
Figure 20. The information displayed for the trigger should match this sample 
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__ d. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Trigger.  Enter these values: 

1) For Name, type Cancel Trigger. 
2) For ID, type Cancel_Trigger. 
3) Select the Terminate monitoring context 

check box.  
4) For Trigger Sources, click Add, then select 

Other source type ► Activity Event, then 
click OK. 

5) For Trigger condition, enter:  
 

Activity_Event/extendedData/ActivityEve
ntData/activityName='Cancel Order and 
Send Notification' and 
Activity_Event/extendedData/ActivityEve
ntData/eventType='completed' 
 

__ e. Press Ctrl+S to save your work. 
____ 7. Create a KPI for an average fulfillment time of three days 

or less. 
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__ a. In the Monitor Details Model navigation pane, right-
click ClipsAndTacks MC, then select New ► 
Trigger.  Enter these values: 

1) For Name, type New Order Trigger. 
2) For ID, type New_Order_Trigger. 
3) For Trigger Sources, click Add, then select 

Other source type ► New Order Event, then 
click OK. 

4) For Trigger condition, enter:  
 
New_Order_Event/extendedData/ActivityEv
entData/activityName='Check Order 
Handling Policy for Automatic Approval' 
and 
New_Order_Event/extendedData/ActivityEv
entData/eventType='started' 
 

5) Press Ctrl+S to save your work.
Figure 21. Enter these values for the new trigger 
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__ b. In the Monitor Details Model navigation pane, right-
click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type Order Start Time. 
2) For ID, type Order_Start_Time. 
3) For Type, type DateTime. 
4) For Metric Value Maps, click Add. 
5) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, and 
then click Trigger type ► ClipsAndTacks 
MC ► New Order Trigger, then click OK. 

6) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text: 
New_Order_Event/extendedData/ActivityEv
entData/startTime  

7) Click OK. 
8) Press Ctrl+S to save your work.

Figure 22. Enter these values for the new metric 
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__ c. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type Order End Time. 
2) For ID, type Order_End_Time. 
3) For Type, type DateTime. 
4) For Metric Value Maps, click Add. 
5) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► Ship 
Order to Customer Trigger, then click OK. 

6) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text:  
Activity_Event/extendedData/ActivityEve
ntData/endTime  

7) Click OK.  
8) For Metric Value Maps, click Add.

Figure 23 Complete the metric value maps detail 

 



         Business Activity Monitoring 
 
31 

9) In the second row of the Metric Value Maps 
table, select the cell under the Trigger column, 
then click the button that is displayed, Click 
Trigger type ► ClipsAndTacks MC ► 
Cancel Trigger, and then click OK. 

10) In the second row of the Metric Value Maps 
table, select the cell under the Expression 
column, then click the button that is displayed 
and enter this text:  
Activity_Event/extendedData/ActivityEve
ntData/endTime  

11) Click OK. 
__ d. Press Ctrl+S to save your work. 

 
__ e. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type Order Fulfillment Duration. 
2) For ID, type Order_Fulfillment_Duration. 
3) For Type,  select Duration. 
4) For Default Value, click Edit… 
5) On the Select Duration window, click OK 
6) For Metric Value Maps, click Add. 
7) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► Ship 
Order to Customer Trigger, then click OK. 

8) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text:  

 
Order_End_Time - Order_Start_Time  

 
9) Click OK. 
10) For Metric Value Maps, click Add. 
11) In the second row of the Metric Value Maps 

table, select the cell under the Trigger column, 
then click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► 
Cancel Trigger, and then click OK. 
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12) In the second row of the Metric Value Maps 

table, select the cell under the Expression 
column, then click the button that is displayed 
and enter this text:  

 
Order_End_Time - Order_Start_Time

Figure 24. Complete the order fulfillment duration trigger 

  
13) Click OK. 

__ f. Press Ctrl+S to save your work. 
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 __ g. Click the Data Mart Model tab. 
__ h. Add Start Time as a dimension to the Data Mart 

Model.  This will be used in a subsequent step when 
creating the definition of the KPI. 

1) In the Dimensions table, click ClipsAndTacks 
MC Cube. 

2) Click Add Dimension. 
a) For Name, type Start Time 

Dimension. 
b) For ID, type Start_Time_Dimension. 

3) Click Add Attribute. 
a) For Name, type Start Time. 
b) For ID, type Start_Time. 

4) In the Dimensions table, in the row containing 
the Dimension Attribute value Start Time, 
click the cell in the Source column.  Click the 
button that is displayed, and then click 
ClipsAndTacks MC ► Order Start Time.  
Click OK. 

5) Press Ctrl+S to save your work.
Figure 25. Add Start Time as a dimension to the Data Mart Model 

 
__ i. In the Data Mart Model, add a measure for average 

order fulfillment. 
1) In the Measures table, click ClipsAndTacks 

MC Cube. 
2) Click Add Measure. 

a) For Name, type Average Order 
Fulfillment. 

b) For ID, type 
Average_Order_Fulfillment. 

3) In the Measures table, in the row containing the 
Average Order Fulfillment measure, click the 
cell in the Source column.  Click the button 
that is displayed, and then click 
ClipsAndTacks MC Fact Table► Order 
Fulfillment Duration Fact.  Click OK. 
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4) Notice that the Aggregation Function value for 
this measure properly defaults to Average. 

5) Press Ctrl+S to save your work.
Figure 26. Add a measure for average order fulfillment in the Data Mart Model  

 
__ j. Ensure that the KPI Model tab is selected. 
__ k. Create a KPI context to store KPIs. 

1) In the KPI Model navigation pane, right-click 
ClipsAndTacks, then select New ► KPI 
Context. 

a) For Name, type My KPI Context. 
b) For ID, type My_KPI_Context.

Figure 27. Create a KPI context to store KPIs 

 
 

__ l. Create the average order fulfillment KPI.   
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The following exercise addresses creation of the KPI based on 
events for August 2006.  This will work regardless of the month or 
year that you perform this lab. Because the timestamps in the test 
data are based on August 2006, your results will be the same as 
those used in these lab instructions. 
 

1) Click the KPI Model tab. 
2) In the KPI Model navigation pane, right-click 

My KPI Context, then select New ► KPI. 
a) For Name, type Average Order 

Fulfillment KPI August 2006. 
b) For ID, type 

Average_Order_Fulfillment_KPI_
August_2006. 

3) Enter these values: 
a) For Type, select Duration. 
b) In KPI Target and Ranges, for Target 

click Details. Change the value to 3 
Days, and then click OK. 

c) In KPI Target and Ranges, for Ranges 
select Actual values. 

d) In the Range table, define a range:  
(1) Click Add. 
(2) Change Name to Day 1, and 

ID to Day_1. A row is 
created in the Range table 
with a range name Day 1.   

(3) In this new row, select the 
cell in the Start value 
column and click the button 
that is displayed.  Change 
all values to 0, then click 
OK. 

(4) In this row, select the cell in 
the End value column and 
click the button that is 
displayed.  Change Days to 
1 and the other values to 0, 
then click OK. 

e) You have now created one range 
called Day 1.  Repeat the preceding 
step to create four additional ranges 
as follows: 

(1) Day 2 with start values 1 
Days and end value 2 Days 

(2) Day 3 with start values 2 
Days and end value 3 Days 

(3) Day 4 with start values 3 
Days and end value 4 Days 

(4) Day 5 with start values 4 
Days and end value 5 Days 
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(5)   
f) For Cube, click Browse, then select 

ClipsAndTacks DMM ► 
ClipsAndTacks MC Cube, then 
click OK. 

g) For Measure, click Browse, then 
select ClipsAndTacks MC Cube ► 
Average Order Fulfillment, then 
click OK. 

h) For Time dimension, click Browse, 
then select Referenced Dimension 
► Start Time Dimension, then click 
OK. 

i) For Specify time period, select Fixed. 
j) For Start date, click Edit, and then 

select 2006-08-01. 
k) For End date, click Edit, and 

then select 2006-08-31. 
Note: The Start Time Dimension is based on the startTime from the 
Common Base Event. 
 

4) Press Ctrl+S to save your work.
Figure 28. Repeat the step to create four additional ranges 

 



         Business Activity Monitoring 
 
37 

 
__ m. Note that this KPI currently averages order-

fulfillment time for shipped orders and cancelled 
orders, but this exercise has no interest in the 
cancelled orders. The sample now updates the 
average order fulfillment KPI to show the values for 
shipped orders only. 

__ n. Click the Monitor Details Model tab. 
__ o. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter the following values: 

1) For Name, type Order Status. 
2) For ID, type Order_Status. 
3) For Type, select String. 
4) For Default Value, type ‘New’. (Include the 

single quotation marks.) 
5) For Metric Value Maps, click Add. 
6) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► 
Cancel Trigger, and then click OK. 

7) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text, including the single quotation marks: 
‘Cancelled’ 

8) Click OK. 
9) For Metric Value Maps, click Add. 
10) In the second row of the Metric Value Maps 

table, select the cell under the Trigger column, 
then click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► Ship 
Order to Customer Trigger, then click OK. 

11) In the second row of the Metric Value Maps 
table, select the cell under the Expression 
column, then click the button that is displayed 
and enter this text, including the single 
quotation marks: ‘Shipped’ 
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12) Press Ctrl+S to save your work.

Figure 29. Complete trigger types in the Metric Value Map 
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__ p. Click the Data Mart Model tab. 
__ q. Add order status as a dimension to the Data Mart 

Model.   
1) In the Dimensions table, click ClipsAndTacks 

MC Cube. 
2) Click Add Dimension. 

a) For Name, type Order Status 
Dimension. 

b) For ID, type 
Order_Status_Dimension. 

c) Click OK. 
3) Click Add Attribute. 

a) For Name, type Order Status. 
b) For ID, type Order_Status. 

4) In the Dimensions table, in the row containing 
the Dimension Attribute value Order Status, 
click the cell in the Source column.  Click the 
button that is displayed, then select 
ClipsAndTacks MC ► Order Status.  Then 
click OK. 

5) Press Ctrl+S to save your work.
Figure 30. Add order status as a dimension to the Data Mart Model 
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__ r. Update the order fulfillment KPI to use the order 
status dimension as a filter. 

1) Click the KPI Model tab. 
2) In the KPI Model navigation pane, navigate to 

ClipsAndTacks ► My KPI Context ► 
Average Order Fulfillment KPI August 
2006. 

3) In the KPI Definition section for this KPI, 
underneath the Dimensions table, click Add. 

4) Navigate to ClipsAndTacks MC Cube ► 
Order Status Dimension ► Order Status, 
then click OK. 

5) In the Dimensions table, expand Order Status 
Dimension. 

6) In the row containing Attribute Order Status, 
click the cell in the Value column, then enter 
this text (without quotation marks): Shipped 

7) Press Ctrl+S to save your work.
Figure 31. Update the order fulfillment KPI to use the order status dimension as a filter 

 ____ 8. Create a KPI for number of approved orders greater than 90 
percent.  For KPIs, you cannot have user-defined functions, 
for example, ‘(Shipped Orders / Total Orders) * 100’. The 
exercise, therefore demonstrates how to accomplish this in 
another way.  
This exercise now describes how to create a metric that will 
have one of two values for each monitoring context.  For 
shipped orders it will be 100, for cancelled orders it will be 
0.  It will next describe how to average this metric across 
monitoring contexts. 
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Note: This exercise sets the value of the metric explicitly to 
100 when shipping the order. It will not be necessary to set 
it explicitly when canceling an order since this sample 
describes how to set the default for the metric to 0. 
__ a. Click the Monitor Details Model tab. 
__ b. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type Ship Percentage. 
2) For ID, type Ship_Percentage. 
3) For Type, select Integer. 
4) For Default value, type 0. 
5) For Metric Value Maps, click Add. 
6) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► Ship 
Order to Customer Trigger, then click OK. 

7) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text: 100 

8) Click OK. 
9) Press Ctrl+S to save your work.

Figure 32. Create a KPI for number of approved orders greater than 90 percent 
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__ c. Click the Data Mart Model tab. 
__ d. In the Data Mart Model, add a measure for average 

ship percentage. 
1) In the Measures table, click ClipsAndTacks 

MC Cube. 
2) Click Add Measure. 

a) For Name, type Average Ship 
Percentage. 

b) For ID, type 
Average_Ship_Percentage. 

3) In the Measures table, in the row containing 
measure Average Ship Percentage, click the 
cell in the Source column. Click the button that 
is displayed, then click this button and select 
ClipsAndTacks MC Fact Table► Ship 
Percentage Fact.  Then click OK. 

4) Notice that the default Aggregation Function 
value for this measure is properly set to 
Average. 

5) Press Ctrl+S to save your work.
Figure 33. Add a measure for average ship percentage in the Data Mart Model 

 
 

__ e. Click the KPI Model tab. 
__ f. In the KPI Model navigation pane, right-click My 

KPI Context, then select New ► KPI. 
1) For Name, type Percent of Orders Approved 

KPI. 
2) For ID, type 

Percent_of_Orders_Approved_KPI. 
__ g. Enter these values: 

1) For Type, select Decimal. 
2) For Target, type 90. 
3) For Ranges, select Actual value. 
4) In the Range table: 

a) Click Add. 
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b) Change Name to High Range, and ID 

to High_Range. A row is created in 
the Range table with a range name 
High Range. 

c) In this new row, select the cell in the 
Start value column. Click the button 
that is displayed, then change the 
value to 90, and then click OK. 

d) In this new row, select the cell in the 
End value column. Click the button 
that is displayed, then change the 
value to 100, and then click OK. 

5) You have now created one range called High 
Range.  Repeat the preceding step to create 
another range: 

a) Low Range with start value 0 and end 
value 90.

Figure 34. Complete the Range table with a range name and values 
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6) For Cube, click Browse, then select 

ClipsAndTacks DMM ► ClipsAndTacks 
MC Cube, then click OK. 

7) For Measure, click Browse, then select 
ClipsAndTacks MC Cube ► Average Ship 
Percentage, then click OK. 

8) For Time dimension, select a value if you want 
to base the KPI on a specific period of time. 

 
Note: The Start Time Dimension is based on the startTime values 
from the Common Base Event.  If you want to add a time 
dimension, review the startTime values in the Common Base Events 
to determine what range is appropriate for your testing. 
 

9) Press Ctrl+S to save your work. 
 
____ 9. You might like to see the total order price, the average 

order price and the total number of orders. You might also 
be interested in seeing this information arranged by country 
and city.  You will now create dimensions and measures 
that allow you to see this information.  In order to see the 
country and city information, you will create a multilevel 
location dimension containing country as the first level and 
city as the second level.

Figure 35. Multilevel location dimension containing country and city  
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__ a. Click the Monitor Details Model tab. 
__ b. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type country. 
2) For ID, type country. 
3) For Type, select String. 
4) For Metric Value Maps, click Add. 
5) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► New 
Order Trigger, and then click OK. 

6) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text: 

New_Order_Event/extendedData/Orde
rBOData/country 

7) Click OK. 
8) Press Ctrl+S to save your work. 
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__ c. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type city. 
2) For ID, type city. 
3) For Type, select String. 
4) For Metric Value Maps, click Add. 
5) In the first row of the Metric Value Maps table, 

select the cell under the Trigger column, then 
click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► New 
Order Trigger, and then click OK. 

6) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text: 

New_Order_Event/extendedData/OrderB
OData/city 

7) Click OK. 
8) Press Ctrl+S to save your work. 

Figure 36. Add a new order trigger - city  
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__ d. In the Monitor Details Model navigation pane, right-

click ClipsAndTacks MC, then select New ► 
Metric.  Enter these values: 

1) For Name, type totalPrice. 
2) For ID, type totalPrice. 
3) For Type, select Decimal. 
4) For Metric Value Maps, click Add. 
5) In the first row of the Metric Value Maps 

table, select the cell under the Trigger column, 
then click the button that is displayed. Click 
Trigger type ► ClipsAndTacks MC ► New 
Order Trigger, and then click OK. 

6) In the first row of the Metric Value Maps table, 
select the cell under the Expression column, 
then click the button that is displayed and enter 
this text: 

New_Order_Event/extendedData/Orde
rBOData/totalPrice 

7) Click OK. 
8) Press Ctrl+S to save your work.

Figure 37 Add a new order trigger - totalPrice 
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__ e. Click the Data Mart Model tab. 
__ f. Add location as a dimension to the Data Mart Model.   

1) In the Dimensions table, click ClipsAndTacks 
MC Cube. 

2) Click Add Dimension. 
a) For Name, type Location. 
b) For ID, type Location. 

3) Click Add Attribute. 
a) For Name, type Country. 
b) For ID, type Country. 

4) In the Dimensions table, in the row containing 
Dimension Attribute Country, click the cell in 
the Source column. Click the button that is 
displayed, and then click ClipsAndTacks MC 
► country.  Then click OK. 

5) Click Add Attribute. 
a) For Name, type City. 
b) For ID, type City. 

6) In the Dimensions table, in the row containing 
Dimension Attribute City, click the cell in the 
Source column.  Click the button that is 
displayed, then click ClipsAndTacks MC ► 
city.  Then click OK. 

7) Press Ctrl+S to save your work.
Figure 38. Add location as a dimension to the Data Mart Model 
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__ g. Ensure that the Data Mart Model tab is selected. 
__ h. In the Data Mart Model, add a measure for average 

order price. 
1) In the Measures table, click ClipsAndTacks 

MC Cube. 
2) Click Add Measure. 

a) For Name, type Average Order 
Price. 

b) For ID, type Average_Order_Price. 
3) In the Measures table, in the row containing 

measure Average Order Price, click the cell in 
the Source column.  Click the button that is 
displayed, and then click ClipsAndTacks MC 
Fact Table ► totalPrice Fact.  Then click 
OK. 

4) Notice that the Aggregation Function for this 
measure properly defaults to Average.  

__ i. In the Data Mart Model, add a measure for sum of 
order price. 

1) In the Measures table, click ClipsAndTacks 
MC Cube. 

2) Click Add Measure. 
a) For Name, type Sum Order Price. 
b) For ID, type Sum_Order_Price.  

3) In the Measures table, in the row containing 
measure Sum Order Price, click the cell in 
the Source column.  Click the button that is 
displayed, and then click ClipsAndTacks MC 
Fact Table ► totalPrice Fact.  Then click 
OK. 

4) In the Measures table, in the row containing 
measure Sum Order Price, click the cell in 
the Aggregation Function column.  Select 
Sum from the list. 
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__ j. In the Data Mart Model, add a measure for order 

count. 
1) In the Measures table, click ClipsAndTacks 

MC Cube. 
2) Click Add Measure. 

a) For Name, type Order Count. 
b) For ID, type Order_Count. 

3) In the Measures table, in the row containing 
measure Order Count, click the cell in the 
Source column. Click the button that is 
displayed, and then click ClipsAndTacks MC 
Fact Table ► ClipsAndTacks Key Fact.  
Then click OK. 

4) In the Measures table, in the row containing 
measure Order Count, click the cell in the 
Aggregation Function column. Select Count 
from the list. 

__ k. Press Ctrl+S to save your work.
Figure 39. Add a measure for order count in the Data Mart Model 

 
 

____ 10. With Average Order Price now as a measure in the Data 
Mart Model, you will now create a KPI for it. 
__ a. Click the KPI Model tab. 
__ b. In the KPI Model navigation pane, right-click My 

KPI Context, then select New ► KPI. 
1) For Name, type Average Order Price KPI 

(Dollars). 
2) For ID, type 

Average_Order_Price_KPI__x0028_Dollars
_x0029_. 

__ c. Enter these values: 
1) For Type, select Decimal. 
2) For Target, type 300. 
3) For Ranges, select Actual value. 
4) In the Range table: 

a) Click Add. 
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b) Change Name to High Range, and ID 

to High_Range. A row is created in 
the Range table with a range name 
High Range.   

c) In this new row, select the cell in the 
Start value column. Click the button 
that is displayed, then change the 
value to 300, and then click OK. 

d) In this new row, select the cell in the 
End value column. Click the button 
that is displayed, then change the 
value to 1000, and then click OK. 

5) Now you have created one range called High 
Range.  Repeat the preceding step to create 
another range: 

a) Low Range with start value 0 and end 
value 300. 

6) For Cube, click Browse, then select 
ClipsAndTacks DMM ► ClipsAndTacks 
MC Cube, then click OK. 

7) For Measure, click Browse, then select 
ClipsAndTacks MC Cube ► Average 
Order Price, then click OK. 

8) For Time dimension, select a time dimension if 
you want to base the KPI on a specific period 
of time. 

 
Note: The Start Time Dimension is based on the startTime values 
from the Common Base Event.  If you want to add a time 
dimension, check the startTime valuein the Common Base Events to 
determine what range is appropriate for your testing. 
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9) Press Ctrl+S to save your work.

Figure 40. Create KPI for Average Order Price as measure in Data Mart Model  

 
 

(Optional) The following step shows a common technique for 
counting a subset of instances. Specifically, it explains how to use a 
counter that is incremented if you ship the order (versus canceling 
the order).  For every monitoring context, this counter will either be 
zero or one depending on whether the order is cancelled or shipped.  
Counters are more useful in other scenarios, such as to count the 
number of times an iterated activity is run.   
 
____ 11. (Optional) In the Monitor Details Model navigation pane, 

right-click ClipsAndTacks MC, then select New ► 
Counter.  Enter these values: 
__ a. For Name, type Ship Counter. 
__ b. For ID, type Ship_Counter. 
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__ c. For Counter Controls, click Add, then select 

ClipsAndTacks MC ► Ship Order to Customer 
Trigger, then click OK. 

__ d. Note that the default value for Resulting Action is 
Add One, which is correct. 

__ e. Click OK.  
__ f. Press Ctrl+S to save your work.

Figure 41. Technique for counting a subset of instances 

 
 

(Optional) The following step shows how to use a stopwatch. 
Specifically, it explains how to create a timer that measures the 
duration of the monitoring context.  You might find this useful to 
quickly see which monitoring contexts have not been ended.  
 
____ 12. (Optional) In the Monitor Details Model navigation pane, 

right-click ClipsAndTacks MC, then select New ► 
Stopwatch.  Enter these values: 
__ a. For Name, type Monitoring Context Timer. 
__ b. For ID, type Monitoring_Context_Timer. 
__ c. For Stopwatch Controls, click Add, then select 

ClipsAndTacks MC ► New Order Trigger, then 
click OK. 

__ d. Note that the default value for Resulting Action is 
Start. 

__ e. For Stopwatch Controls, click Add, then select 
ClipsAndTacks MC ► Ship Order to Customer 
Trigger, then click OK. 
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__ f. Note that the default value for Resulting Action is 

Start, but you will need to change it to Stop for this 
trigger.  So click the second row in the Resulting 
Action column, and then select Stop from the list. 

__ g. For Stopwatch Controls, click Add, then select 
ClipsAndTacks MC ► Cancel Trigger, and then 
click OK. 

__ h. Note that the default value for Resulting Action is 
Start, but you need to change it to Stop for this 
trigger. Therefore, click the second row in the 
Resulting Action column, then select Stop from the 
list. 

__ i. Press Ctrl+S to save your work. 
Figure 42. Timer that measures the duration of the monitoring context 
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____ 13. Create a business-situation event when the number of 

declined orders is greater than or equal to 3. 
__ a. In the Project Explorer pane, right-click 

ClipsAndTacks and select New ► Event 
Definition. 

__ b. For Name, type DeclinedOrderEvent. 
__ c. Click Finish. 
__ d. In the Event Definition, click the Add Extended 

Data icon to add a row to the Extended Data table. 
__ e. For the new data element, change the Extended Data 

name to BusinessSituationName. 
__ f. For the new element, change the type to string. 
__ g. Press Ctrl+S to save your work.

Figure 43. Business-situation event when declined orders >= 3 

 
 
__ h. Click the KPI Model tab for the ClipsAndTacks 

model. 
__ i. In the KPI Model navigation pane, right-click My 

KPI Context, then select New ► KPI. 
1) For Name, type Declined Order KPI. 
2) For ID, type Declined_Order_KPI. 

__ j. Enter these values: 
1) For Type, select Decimal. 
2) For Target, enter 3. 
3) For Ranges, select Actual value. 
4) In the Range table: 

a) Click Add. 
b) Change Name to High Range, and ID 

to High_Range. A row is created in 
the Range table with a range name 
High Range.   
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c) In this new row, select the cell in the 

Start value column. Click the button 
that is displayed, then change the 
value to 3, and then click OK. 

d) In this new row, select the cell in the 
End value column. Click the button 
that is displayed, then change the 
value to 10, and then click OK. 

5) Now you have created one range called High 
Range.  Repeat the preceding step to create 
another range: 

Low Range with start value 0 and end 
value 3. 

6) For Cube, click Browse, then select 
ClipsAndTacks DMM ► ClipsAndTacks 
MC Cube, then click OK. 

7) For Measure, click Browse, then select 
ClipsAndTacks MC Cube ► Order Count, 
then click OK. 

8) For Time dimension, select a time dimension if 
you want to base the KPI on a specific period 
of time. 

 
Note: The Start Time Dimension is based on the startTime values 
from the Common Base Event. If you want to add a time dimension, 
check the startTime values in the Common Base Events to 
determine what range is appropriate for your testing. 

9) In the Dimensions table, click Add. 
10) Navigate to ClipsAndTacks MC Cube ► 

Order Status Dimension ► Order Status, 
then click OK. 

11) In the Dimensions table, expand Order 
Status Dimension. 

12) In the row containing Attribute Order 
Status, click the cell in the Value column, 
then enter this text (without quotation marks):  
Cancelled 
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13) Press Ctrl+S to save your work. 
Figure 44. Check the startTime values to add a time dimension  
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__ k. In the KPI Model navigation pane, right-click My 
KPI Context, then select New ► Trigger. 

1) For Name, type Declined Order Trigger. 
2) For ID, type Declined_Order_Trigger. 

__ l. Enter these values: 
1) Under Trigger Sources, click Add. 
2) Select Recurring wait time, then click OK. 
3) In the Source column you see the default wait 

time is 1 minute.  
4) In Trigger Condition, enter this text:  

Declined_Order_KPI >= 3 
__ m. Press Ctrl+S to save your work.

Figure 45. Right-click My KPI Context, then select New ► Trigger in KPI Model 
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__ n. In the KPI Model navigation pane, right-click My 
KPI Context, then select New ► Outbound Event. 

1) For Name, type Declined Order Outbound 
Event. 

2) For ID, type 
Declined_Order_Outbound_Event. 

__ o. Enter these values: 
1) For Type, select DeclinedOrderEvent. 
2) Under Event Attributes Details, click Add. 
3) Select My KPI Context ► Declined Order 

Trigger, then click OK. 
4) In the table, in the same row as 

BusinessSituationName, set Expression to 
this value (include the single quotation marks): 
'Too many orders have been declined' 

__ p. Press Ctrl+S to save your work.
Figure 46. Set Expression to 'Too many orders have been declined' 
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____ 14. Create a business-situation event when the order fulfillment 
duration is greater than 3 days. 
__ a. In the Project Explorer pane, right-click New ► 

Event Definition. 
__ b. For Name, enter LateAverageOrderShippedEvent. 
__ c. Click Finish. 
__ d. In the event definition, click the Add Extended Data 

icon to add a row to the Extended Data table. 
__ e. For the new data element, change the Extended Data 

name to BusinessSituationName. 
__ f. For the new element, change the type to string. 
__ g. In the event definition, click the Add Extended Data 

icon to add a second row to the Extended Data 
table. 

__ h. For the second data element, change the Extended 
Data name to AverageOrderProcessingDays. 

__ i. For the second element, change the type to string. 
__ j. Press Ctrl+S to save your work.

Figure 47. Business-situation event when order fulfillment duration > 3 days 

 
 
 

__ k. In the KPI Model navigation pane, right-click My 
KPI Context, then select New ► Trigger.  

1) For Name, type Order Fulfillment Timer 
Trigger. 

2) For ID, type 
Order_Fulfillment_Timer_Trigger. 

__ l. Enter these values: 
1) Under Trigger Sources, click Add. 
2) Select Recurring wait time, then click OK. 
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3) In the Source column you see the default wait 

time is 1 minute.  
4) In Trigger Condition, enter this text: 

Average_Order_Fulfillment_KPI_August_2
006 ge duration('P3DT1H') 

__ m. Press Ctrl+S to save your work.
Figure 48. Enter the trigger condition 

 
 

__ n. In the KPI Model navigation pane, right-click My 
KPI Context, then select New ► Outbound Event. 

1) For Name, type Order Fulfillment Outbound 
Event. 

2) For ID, type 
Order_Fulfillment_Outbound_Event. 

__ o. Enter these values: 
1) For Type, select 

LateAverageOrderShippedEvent. 
2) Under Event Attributes Details, click Add. 
3) Select My KPI Context ► Order Fulfillment 

Timer Trigger, then click OK. 
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 4) In the table, in the same row as 
BusinessSituationName, set Expression to 
this value (include the single quotation marks): 

'Average shipment is too late'  
5) In the table, in the same row as 

AverageOrderProcessingDays, set Expression 
to: 

string(decimal(Average_Order_Fulfill
ment_KPI_August_2006) div 86400) 

 
Note: The decimal function converts the duration to seconds, so it 
can be divided by 86400 to give you the number of days. 
 

__ p. Press Ctrl+S to save your work.
Figure 49. Select New ► Outbound Event 

 
 
 

____ 15. Before continuing, access the Problems view and resolve 
any errors. 
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 Part 2. Generate the EAR file for the monitor model 

 
This exercise describes how to use WebSphere Integration 
Developer to create the EAR file that will be deployed to the 
Monitor server. 
 
____ 1. In the Project Explorer pane, right-click ClipsAndTacks 

► Monitoring Models ► ClipsAndTacks, then select 
Generate Monitor EAR. 

____ 2. Select Overwrite existing projects, and then click Finish. 
A progress window shows the status of the operation, and it 
closes when the operation is complete:

Figure 50. Progress window showing the status of the operation 

 
 

____ 3. Select Window ► Open Perspective ► Other, then click 
J2EE. 

____ 4. In the Project Explorer pane, right-click EJB Projects ► 
ClipsAndTacksEJB, then select Build Project. (If Project 
► Build Automatically is selected, then Build Project is 
not shown in the context menu nor enabled in the Project 
menu. In this case, the project has already been built.) A 
progress window shows the status of the operation, and it 
closes when the operation is complete:

Figure 51. The progress window closes when the operation is complete 
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____ 5. Check for errors in the Problems view.  There might be 

warnings, but there should not be any errors:
Figure 52. Check for errors in the Problems view 

 
 

____ 6. In the Project Explorer pane, right-click EJB Projects ► 
ClipsAndTacksEJB, then select Deploy. A progress 
window shows the status of the operation, and it closes 
when the operation is complete:

Figure 53. A progress window shows the status of the operation 

 
 

____ 7. In the Project Explorer pane, right-click Enterprise 
Applications ► ClipsAndTacksEAR, then select Export 
► EAR file. 

____ 8. Enter the name of a destination folder, and then click 
Finish.  ClipsAndTacksEAR.ear will be created in this 
folder. 
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Part 3. Deploy the monitor model 
 
The following exercise describes how to use the WebSphere Process 
Server administrative console to complete the life-cycle steps to 
deploy the monitor model. 
 
____ 1. Start the Monitor server and then start the administrative 

console. 
__ a. In Windows, select Start ► All Programs ► IBM 

WebSphere ► Process Server 6.0 ► Profiles ► 
wbmonitor ► Start the server.  

__ b. In Windows, select Start ► All Programs ► IBM 
WebSphere ► Process Server 6.0 ► Profiles ► 
wbmonitor ► Administrative console. 

____ 2. Install the monitor model. 
__ a. In the administrative console menu, select 

Applications ► Monitor Models.
Figure 54. Complete life-cycle steps to deploy the monitor model 
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__ b. Click Install.

Figure 55. Select Applications ► Monitor Models  

 
__ c. Browse to ClipsAndTacksEAR.ear.  This is the 

EAR file that you created in WebSphere Integration 
Developer. 
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__ d. Click Next.

Figure 56. Proceed to the Next screen 
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__ e. Click Next.
Figure 57. Proceed to the Next screen 
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__ f. Click Continue.
Figure 58. Click Continue 
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__ g. To install the application using the defaults, click 
Step 11.

Figure 59. Click Step 11: Summary 
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__ h. Click Finish.
Figure 60. Click Save to Master Configuration  

 
__ i. Click Save to Master Configuration, then click 

Save. 
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____ 3. Run step 1 of the model life cycle. 
__ a. In the administrative console menu, select 

Applications ► Monitor Models.
Figure 61. Select Applications ► Monitor Models 
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__ b. Click the timestamp value that is listed in the Version 
column.

Figure 62. Click the timestamp value listed in the Version column 
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__ c. Click Setup Wizard.
Figure 63. Change the Database population interval value to 2 

 
 
 

__ d. Enter the name of the output directory, such as 
C:\ClipsAndTacks.  When you run the data services 
generation, the schemagen folder will be created in 
the specified output directory. 

__ e.  Change the Database population interval value to 2.  
For development purposes, replication should run 
often so that you do not have to wait to see the 
updates in the DATAMART database.   

 
Note: This interval number represents minutes. 
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__ f.  Click Run.

Figure 64. Click Run  

 
 
 

__ g. Click Next. 
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__ h. Confirm that you see a panel indicating the 

commands used to run the schema scripts.
Figure 65. Click Next 
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Figure 66. Browse to 
C:\ClipsAndTacks\schemagen\<timest
amp> 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 67. Extract the 
DS_DMS_setup.zip file 

 
 
 
 
 
 
 
 
 
 

____ 4. Run step 2 and step 3 of the model life cycle. 
__ a. In Windows File Explorer, browse to 

C:\ClipsAndTacks\schemagen\<timestamp>. 
 

 
 
__ b. Extract the DS_DMS_setup.zip file into this same 

folder. 
 

 
__ c.  To create the tables for the monitor model, enter the 

following commands in a DB2 command window.  
Note: Monitor and state are used interchangeably.  
The database is defined as MONITOR, but you will 
see references to state such as state.ddl, state.log, 
state_to_datamart_setup_source.bat. 

1) Open a DB2 command window: 
a) Select Start ► Run. 
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b) Enter the db2cmd command. 

2) Enter these commands into the DB2 command 
window: 

a) cd 
\ClipsAndTacks\schemagen\<times
tamp> 

b) db2 connect to MONITOR 
c) db2 +c –stvf state.ddl > 

state.log 
 

3) Open a second DB2 command window: 
a) Select Start ► Run. 
b) Enter the db2cmd command. 
 

4) Enter these commands into the second DB2 
command window: 

a) cd 
\ClipsAndTacks\schemagen\<times
tamp> 

b) db2 connect to DATAMART 
c) db2 +c –stvf datamart.ddl > 

datamart.log 
 

5) If the all the commands succeeded: 
a) Enter these commands into the first 

DB2 command window: 
(1) db2 commit 
(2) db2 disconnect MONITOR 

b) Enter these commands into the second 
DB2 command window: 

(1) db2 commit 
(2) db2 disconnect DATAMART 
 

6) If any of the commands failed:  
a) Enter these commands into the first 

DB2 command window: 
(1) db2 rollback 
(2) db2 disconnect MONITOR 

b) Enter these commands into the second 
DB2 command window: 

(1) db2 rollback 
(2) db2 disconnect DATAMART 
 

7) Close the second DB2 command window. 
__ d.  Browse the newly created state.log and datamart.log 

files to verify that they are correct. 
__ e.  Run the replication setup scripts. 

1) In the same DB2 command window, you 
should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so 
type this command: 
State_to_Datamart_setup_source.bat 
 

2) Each time that you are prompted to enter a user 
ID, press Enter. 
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3) Browse the newly created 

State_to_datamart_setup_source.log file to 
check for errors. 

4) In the same DB2 command window, you 
should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so 
type this command: 

State_to_Datamart_setup_target.bat 
5) Each time that you are prompted to enter a user 

ID, press Enter. 
6) Browse the newly created 

State_to_datamart_setup_target.log file to 
check for errors. 

__ f.  Start the replication daemons. 
1) In the same DB2 command window, you 

should still be in folder 
\ClipsAndTacks\schemagen\<timestamp>, so 
type this command: 

a) cd State_to_Datamart\source 
2) Find all scripts starting with the prefix 

StartCapture, and run them.  (For this scenario 
there will be only one.)  For example, type the 
following command: 

a) StartCapture_5.bat 
3) A new window is opened to display the status 

of the scripts as they are run. Leave this 
window open. Do not enter any commands in 
this window.

Figure 68. A window  displays the status of the scripts 

 
 

4) In the DB2 command window, type this 
command: 

a) cd ..\target 
5) Find all scripts starting with the prefix 

StartApply, and run them.  (For this scenario 
there will be only one.)  For example, type the 
following command: 

a) StartApply_10.bat 
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6) A new window is opened to display the status 

of the scripts as they are run. Leave this 
window open. Do not enter any commands in 
this window. (Three command windows are 
now open.)

Figure 69. A window  displays the status of the scripts 

 
 

 
__ g.  Close the original DB2 command window where you 

have been typing the commands. 
__ h. In the administrative console menu, select 

Applications ► Monitor Models. 
__ i. Click the timestamp value in the Version column. 
__ j. Click Setup Wizard. The administrative console 

should detect that step 2 is complete and 
automatically proceed to step 3 as follows:

Figure 70. The administrative console automatically proceeds to step 3 
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__ k. Click Confirm. 

____ 5. Run step 4 of the model life cycle. 
__ a. Click Step 4.

Figure 71. Run step 4 of the model life cycle 

 
 
__ b. Import the cubes to DB2 Cube Views. 

1) Open a DB2 command window: 
a) Select Start ► Run. 
b) Enter the db2cmd command. 

2) Enter these commands in the DB2 command 
window: 

a) cd \IBM\DB2\SQLLIB\MISC 
b) db2 connect to DATAMART 
c) db2 –tvf db2mdapi.sql 
d) db2 disconnect DATAMART 
e) cd 

\ClipsAndTacks\schemagen\<times
tamp> 
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f) db2mdapiclient -d DATAMART -i 

import_model.xml -o 
response_model_cv.xml -m 
model_cv.xml 

3) Close the command window. 
__ c.  In the administrative console, verify that you are in 

step 4 of the life cycle of the model. 
__ d.  Click Confirm. 

____ 6. Run step 5 of the model life cycle. 
__ a. Click Step 5.

Figure 72. Run step 5 of the model life cycle 

 
 

__ b. Start WebSphere Portal Server. 
1) In Windows, select Start ► All Programs ► 
IBM WebSphere ► Portal Server v5.1 ► Start 
the server. 

__ c.  Find the Portal RMI port in the Portal log. 
1) Browse the Portal log, for example, 

C:\IBM\PortalServer\log\SystemOut.log. 
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2) Search for RMI Connector. For example, in the 

following screen capture you see that Portal 
RMI is port 2810.

Figure 73. Portal RMI is port 2810 

 
 
 

  
__ d. Back in the administrative console, in step 5 of the 

model life cycle, enter localhost for Host name. 
__ e.  Enter the RMI port value that you identified in the 

Portal log.
Figure 74. Enter the RMI port value that you identified 

 
 

__ f. Click Create. 
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 If an error message indicates that there is a connection problem, you 
might need to correct the Portal configuration.  Go to Appendix 2 
now and follow the steps there as a workaround for this problem.  
After completing the workaround, please return here and proceed 
with the next step.  Here is a sample of the error message:   

Figure 75. You might need to correct the Portal configuration 
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____ 7. Run step 6 of the model life cycle. 
__ a. Click Step 6.

Figure 76. Run step 6 of the model life cycle 

 
__ b. Click Apply. 

____ 8. Run step 7 of the model life cycle. 
__ a. Click Step 7. 
__ b. Verify that the Confirm button on the window for 

step 7 is enabled.  If it is not, wait a few minutes, and 
then refresh the window.  When the Confirm button 
is enabled, continue with the following steps. 

__ c.  In the administrative console navigation pane, select 
System administration ► Save Changes to Master 
Repository, then click Save. 

__ d.  Recycle WebSphere Process Server. 
1) In Windows, select Start ► All Programs ► 

IBM WebSphere ► Process Server 6.0 ► 
Profiles ► wbmonitor ► Stop the server. 

2) In Windows, select Start ► All Programs ► 
IBM WebSphere ► Process Server 6.0 ► 
Profiles ► wbmonitor ► Start the server. 

__ e.  Re-open the administrative console for Process 
Server. 
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__ f.  In the administrative console menu, click 

Applications ► Monitor Models. 
__ g. Click the timestamp value in the Version column. 
__ h. Click Setup Wizard. The administrative console 

should detect that step 6 is complete and 
automatically proceed to step 7 as follows:

Figure 77. Proceed to step 7 of the model life cycle 

  
__ i. Click Confirm. 
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__ j. Click Finish to return to the Monitor Models window.

Figure 78. Return to the Monitor Models window 

 
  

____ 9. If the Startable column for the model shows a red circle, it 
is stopped. Wait a moment, then refresh by clicking the 
icon to the right of Status in the last column of the table. 
The column for the model should now show a green check 
mark. If this column does not show a green check mark, be 
patient and continue refreshing until it does.

Figure 79. Continue refreshing until this column displays a green check mark 
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____ 10. Check the Process Server log to ensure that there are no 

problems. For example, check 
C:\IBM\WebSphere\ProcServer\profiles\wbmonitor\logs\se
rver1\SystemOut.log. 
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Part 4. Configure Action Manager for business situation events 
 
If you have an LDAP server, follow the steps in this section to learn 
how to configure Action Manager to create alerts based on business 
situation events defined in the monitor model.  The alerts will be 
visible in the Alert view on your dashboard. 
 
If you do not have an LDAP server, skip this section.  The outgoing 
events will be created for the business situations, but they will not 
result in entries in the Alert view on your dashboard. 
 
____ 1. Configure the LDAP Server in Action Manager. 

__ a.  In the Monitor administrative console, navigate to 
Applications ► Monitor Action Manager ► 
Configuration.  

__ b.  Click the LDAP tab. 
__ c.  Add your LDAP information as in this sample:

Figure 80. Add your LDAP information 
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__ d.  You will now set up an Alert, so make sure the 

LDAP Alert field is set to the identifier for the user 
ID that you want to use from your directory server.  
You also need a user defined in Portal on the 
Dashboard Server that matches this user ID.   

 
This example recommended the definition uid = 
wpsadmin in the directory server. You will login to 
Portal with this same user ID to see the alerts. Click 
OK. 
 

__ e.  Confirm that the definition of the user ID in the 
directory server matches the following example:

Figure 81. The user ID in the directory server should match this example 

 
____ 2. Restart the Action Manager application for the 

configuration changes to take effect. 
__ a.  In the administrative console, navigate to 

Applications ► Enterprise Applications.  
__ b.  Select the IBM WB ACTIONMANAGER check 

box, and then click Stop. 
__ c.  Select the IBM WB ACTIONMANAGER check 

box, and then click Start. 
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____ 3. Add a template for declined order alerts. 
__ a.  In the administrative console, navigate to 

Applications ► Monitor Action Manager ► 
Template Definitions ► Notifications.  

__ b.  Click New. 
__ c.  Enter a name for the template and a description. 
__ d.  Select Alert. 
__ e.  Enter an LDAP Query value that will start the user 

that you want to alert.  To alert multiple users, define 
the query to match multiple users.  To start all the 
users in the directory, you could enter this:  
(&(objectclass=top)(objectClass=inetOrgPerson)). 

__ f.  Enter a subject for the message. 
__ g.  Enter the body of the message.

Figure 82. Enter the body of the message 

 
 
 

__ h. Click OK. 
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____ 4. Add a template for order processing time alerts. 

__ a.  In the administrative console, navigate to 
Applications ► Monitor Action Manager ► 
Template Definitions ► Notifications.  

__ b.  Click New. 
__ c.  Enter a name for the template and a description. 
__ d.  Select Alert. 
__ e.  Enter an LDAP Query that will start the user that you 

want to alert.  To alert multiple users, define the 
query to match multiple users.  To start all the users 
in the directory, you could enter this:  
(&(objectclass=top)(objectClass=inetOrgPerso

n)). 
__ f.  Enter a subject for the message. 
__ g.  Enter the body of the message, and optionally enter a 

substitution variable as shown in the following 
example.  For the actual alert that is sent, the average 
order processing time from the event payload will be 
substituted for %AverageOrderProcessingDays% in 
the body of the message.

Figure 83. Optionally enter a substitution variable as shown 

 
__ h.  Click OK. 
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____ 5. Add the binding from the situation event to the action type 

for declined orders. 
__ a.  In the administrative console, navigate to 

Applications ► Monitor Action Manager ► 
Installed Situation Event Bindings. 

__ b.  Click New. 
__ c.  Enter the situation event name that you defined in the 

model.  In this lab, you created a business-situation 
name Too many orders have been declined.  

Figure 84. Enter the situation event name that you defined 
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__ d.  To ensure that the situation event name exactly 

matches the value in the BusinessSituationName 
field in the outbound event, copy and paste that name 
from the model.  Here is a screen capture from the 
model showing the Declined Order Outbound Event:

Figure 85. Copy and paste the situation event name 

 
__ e.  Enter a description, and then click Apply. 
__ f.  Click Add. 
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__ g.  Select the template AlertDeclined.

Figure 86. Select the template AlertDeclined 

 
 

__ h. Click OK. 
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__ i. Notice that you now have one action defined for this 
situation event.  If you had other action templates 
defined, you could add more actions to this event.  
For example, you could send a notification for this 
situation to multiple destinations including e-mail, 
alerts and Web services.

Figure 87. One action has been defined for this situation event 
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____ 6. Add the binding from the situation event to the action type 
for order processing time. 
__ a.  In the administrative console, navigate to 

Applications ► Monitor Action Manager ► 
Installed Situation Event Bindings. 

__ b.  Click New. 
__ c.  Enter the situation event name that you defined in the 

model.  In this lab, you created a business-situation 
name Average shipment is too late.  To ensure that 
the situation event name exactly matches the value in 
the BusinessSituationName field in the outbound 
event, copy and paste the name from the model.  
Here is a screen capture from the model showing the 
Order Fulfillment Outbound Event:

Figure 88. copy and paste the situation event name from the model 

 
 

__ d. Enter a description, and then click Apply. 
__ e.  Click Add. 
__ f.  Select the template AlertLate, and then click OK. 
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____ 7. In the administrative console, navigate to Applications ► 

Monitor Action Manager ► Installed Situation Event 
Bindings.  You should see two bindings as follows:

Figure 89. You should see two bindings 

 
 

____ 8. Before continuing, make sure that your LDAP Server is 
started. 
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Part 5. Run events to exercise the model 
 
Rather than installing a J2EE application to actually create the 
events that you would like to monitor, you are going to use a 
program to simulate the submission of events from the application.   
 
The supplied program is BatchCBEWriter and it will submit the 
events to the Common Event Infrastructure.  Look for the program 
in \Labfiles602\ClipsAndTacks\BatchCBEWriter.  This program 
reads XML files that represent the Common Base Events for the 
model.   
 
____ 1. Update BatchCBEWriter.bat to point JAVA_HOME to a Java 

1.4.2 Runtime folder, such as the one in Process Server, for 
example: ‘set 
JAVA_HOME=C:\IBM\WebSphere\ProcServer\java’. 

____ 2. Update config.properties and set the serverName and 
portNumber values.  To find the port number, browse the 
Process Server log and look for bootstrap port.  For 
example, check for the log at 
C:\IBM\WebSphere\ProcServer\profiles\wbmonitor\lo

gs\server1\SystemOut.log. Here is an example of the 
config.properties settings: 

o connect.serverName = localhost 

o connect.portNumber = 2811 
____ 3. Open a command window, and then change the directory to 

the folder containing BatchCBEWriter. For example, type 
this command: 

cd 
\Labfiles602\ClipsAndTacks\BatchCBEWriter 

____ 4. Run commands to load the Common Base Events to 
Process Server.  In the following example replace <x_y> 
with the actual value in the file names: 

BatchCBEeWriter –
Dsource.filename=c:\Labfiles602\ClipsAndTa
cks\cbe\flow<x_y>.xml 

 
Note: Because there are 20 Common Base Event files, running this 
command 20 times can become tedious.  To avoid this problem, 
store all of the files in a separate folder.  Then, to process all the 
files in the folder just one time, invoke the BatchCBEWriter as 
shown in the following example: 
   

BatchCBEWriter –Dsource.filename=<path to 
folder> 
 

Substitute your folder name for <path to folder>, for 
example:  
 

BatchCBEWriter –
Dsource.filename=c:\Labfiles602\ClipsAndTa
cks\cbe 
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____ 5. When you run BatchCBEWriter, confirm that the results 
look like the following example:

Figure 90. Confirm the results as follows 

 
 

____ 6. To verify that Monitor is processing these properly, open 
the DB2 Control Center.  In Windows, select Start ► All 
Programs ► IBM DB2 ► General Administrative 
Tools ► Control Center. 
__ a.  In the MONITOR database, open table 

CTX_CLIPSANDTACKS_MC. You might see 
records as in this example.  Note, however, that the 
replication daemons are running. As a result, you 
might not see any records, because they have already 
been deleted and moved to the DATAMART 
database.  In that case proceed to the next step to 
check the DATAMART database.

Figure 91. Open table CTX_CLIPSANDTACKS_MC 
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__ b. In the DATAMART database, open table 
FCT_CLIPSANDTACKS_MC.  You should see 
records as in this example.  If you do not see the 
records, you might have to wait a few minutes for the 
Replication Manager daemons to run.  In that case, 
wait a few minutes, and then click View ► Refresh 
in the Control Center.

Figure 92. Open table FCT_CLIPSANDTACKS_MC 

 
__ c.  Close the DB2 Control Center. 
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Part 6. Create a dashboard 
 
In this section you will build a dashboard in WebSphere Portal 
Server.  You will add portlets to the dashboard and configure them. 
 
____ 1. Make copies of the portlets that you want to use: Instances, 

Dimensional View and KPI View.   
 
You should not configure the original portlets, because the 
configuration cannot be removed after it is applied.  So, you will 
first make copies of the portlets, and then you will configure the 
copies. 

__ a.  Open the Portal page, 
http://localhost:9081/wps/portal. 

Figure 93. Open the Portal page 

 
__ b. Click Log in, and then enter your Portal 

administrative user ID and password (commonly 
wpsadmin and wpsadmin). 

____ 2. Create copies of the WebSphere Business Monitor portlets. 
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 __ a. Click Administration at the top of the page, and then 
click Portlet Management ► Portlets.

Figure 94. Click Portlet Management ► Portlets 

 
 
  

__ b. Browse to page 10 by clicking the right-arrow icon or 
by entering the page number in the Jump to page 
field and then clicking the arrow icon to its right.  
This page should show the portlets for Dimensional 
View and Instances. 
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__ c. On the row containing Dimensional, click the Copy 
portlet icon.  You should see this window:

Figure 95. Click the Copy portlet icon 

 
 
__ d.  Click OK. 
__ e.  On the row containing Instances, click Copy portlet 

icon.  In the next window, click OK. 
__ f.  Browse to page 11 by clicking the arrow icons.  This 

page should show the portlet Key Performance 
Indicator (KPI) plus the copies of the portlets for 
Dimensional and Instances. 

__ g.  On the row containing Key Performance Indicator 
(KPI), click the Copy portlet icon.  In the next 
window, click OK. 

__ h.  Browse to page 10 by clicking the arrow icons.  This 
page should show the portlet Alert. 

__ i.  On the row containing Alerts, click the Copy portlet 
icon.  In the next window, click OK. 
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__ j.  Browse to page 11 by clicking the arrow icons.  This 

page should show the four portlets that you copied.
Figure 96. This page shows the four portlets that you copied 

 
 



         Business Activity Monitoring 
 
106 

____ 3. Create a page containing four views: Instances, 
Dimensional, Key Performance Indicator (KPI), Alerts. 
__ a.  Click Administration at the top of the page, and 

then click Portal User Interface ► Manage Pages.
Figure 97. Click Portal User Interface ► Manage Pages 
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__ b. Click My Portal, and then click New Page.  Enter 
Dashboard as the page title.  Under Type of Page, 
click the leftmost radio button to select one-column 
layout.  Click OK, and then click OK again.  Now 
you should see the new page in the list as follows:

Figure 98. You should see the new page in the list 

 
__ c.  To edit the Dashboard page, click the Edit Page 

Layout icon on the right side of the row for 
Dashboard.

Figure 99. Click the Edit Page Layout icon 
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__ d.  Click Add portlets.  Navigate to the last page of the 

list to locate the Copy of Dimensional, Copy of 
Instances, Copy of Key Performance Indicator 
(KPI), and Copy of Alerts portlets, and select all of 
them.

Figure 100. Select all of the recommended portlet titles 

 
 

__ e. Click OK. 
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__ f.  In the next window, confirm that the views have been 

added to the page.
Figure 101. Confirm that the views have been added 

 
 

__ g. Click Done. 
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Figure 102. Confirm that there is now 
a tab for Dashboard 

 
__ h.  Click My Portal at the top of the page.  In the new 

window, confirm that there is now a tab for 
Dashboard. 

 

 
 
____ 4. Configure the views on your new page. 

__ a.  Click the Dashboard tab.  Although you can use the 
Alert view immediately, you must configure the 
other views before you can use them.

Figure 103. Configure the other views before you  use them 
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__ b.  Click the Configure icon on the Copy of 
Dimensional portlet. 

Figure 104. Click the Configure icon 

 
__ c.  For Monitor model, select ClipsAndTacks. 
__ d.  For Cube, select CLIPSANDTACKS MC CUBE 

<timestamp>. 
__ e.  In Available dimensions, select Measures, then next 

to Page dimensions, click Add. 
__ f.  In Available dimensions, select Location, then next 

to Row dimensions, click Add.  
__ g.  In Available dimensions, select Order Status 

Dimension, then next to Column dimensions, click 
Add. 
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__ h.  Confirm that the window looks like the following 

example:
Figure 105. Confirm that the window looks like this 

 
 

__ i. Click Next, then click OK.  
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__ j. Confirm that the configured portlet looks like the 
following example:

Figure 106. Confirm that the configured portlet looks like this 

 
 
 

__ k. You are currently looking at the instances count.  To 
see other measures, click the Measures list, then 
select Average Order Price. 
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__ l.  Currently you are seeing data at the top level.  In the 

tabular view on the right, double-click all in the 
column to drill down on Order Status.  Double-click 
all in the first column to drill down on Location. 
Here is a sample:

Figure 107. Double-click all in the first column to drill down on Location 

 
 
 



         Business Activity Monitoring 
 
115 

__ m. Click the Configure icon for the Copy of 
Instances portlet. 

Figure 108. Click the Configure icon 

 
__ n.  For model, select ClipsAndTacks. 
__ o.  For monitoring context, select ClipsAndTacks MC. 
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__ p. For metrics, select All.
Figure 109. Select All for metrics 

 
 
 

__ q. Click Next. 
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__ r.  In the next window, select the Monetary Metric for 

totalPrice check box, and select USD for Currency, 
as show in the following example:

Figure 110. Select Monetary Metric totalPrice check box and USD Currency 

 
 
 

__ s. Click Next, then Next again, and then Finish. 
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__ t.  By taking the defaults, you configured the view to 

show both active instances and completed instances. 
__ u. Click the Edit icon for the Copy of Key 

Performance Indicator (KPI) portlet.
 

Figure 111. Click the Edit icon for the Copy  of  KPI portlet 

 
 

__ v.  In column Show in View, select all four check 
boxes. Then click OK. Confirm that the window 
looks like the following example.

Figure 112. Confirm that the window looks like this 
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__ w. For the Alerts portlet, no configuration is needed.  
Click one of the alerts in the Subject column to see 
the details for the alert.

Figure 113. Click one of the alerts in the Subject column 
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What you accomplished in this exercise 
 
In this exercise, you created a monitor model using WebSphere 
Integration Developer. 
 
Then you deployed the model to WebSphere Business Monitor. 
 
You ran model life-cycle steps, and created Monitor database and 
replication-manager artifacts.  You then started the replication 
manager daemons. 
 
You imported the cubes to Cube Views. 
 
If you had an LDAP server, you also configured Action Manager to 
create alerts based on business-situation events. 
 
You used the supplied program to simulate the submission of events 
from the monitored application. 
 
Finally, you configured dashboards and viewed monitored data in 
several different types of views. 
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Appendix A.  Import the solution into the WebSphere Integration 
Developer 
 
A solution has been provided so that you do not have to build the 
model from scratch.  This section shows you how to import the 
monitor model into WebSphere Integration Developer.  After 
importing the model, you can proceed to generate the EAR file and 
deploy the model. 
 
____ 1. Start WebSphere Integration Developer and set up the 

environment. 
__ a.  Start WebSphere Integration Developer, V6.0.2, and 

when prompted, point to a new workspace, such as 
C:\workspaces\ClipsAndTacks. 

__ b.  Close the Welcome page. 
__ c.  Select Window ► Preferences ► Workbench ► 

Capabilities.  Make sure that Advanced J2EE is 
selected. 

__ d.  By default, you are in the Business Integration 
perspective.   Open the Business Monitoring 
perspective.  Select Window ► Open Perspective 
► Other ► Show all ► Business Monitoring.   

__ e.  If you are asked to confirm enablement, click OK. 
____ 2. Create a new monitoring project. 

__ a.  Right-click in the Project Explorer pane, then select 
New ► Business Monitoring Project. 

__ b.  For Project name, enter ClipsAndTacks. 
__ c.  Click Finish.  You will see the new project in the 

Project Explorer pane. 
____ 3. Import the supplied .mm and .cbe files. 

__ a.  Right-click in the Project Explorer pane, and then 
select Import. 

__ b.  Select File system, and then click Next. 
__ c.  Browse to the location containing the files, for 

example, C:\Labfiles602\ClipsAndTacks. 
__ d.  Select ActivityEvent.cbe. 
__ e.  Select ClipsAndTacks.mm. 
__ f.  Select DeclinedOrderEvent.cbe. 
__ g.  Select LateAverageOrderShippedEvent.cbe. 
__ h.  Select NewOrderEvent.cbe. 
__ i.  Click Finish.  

____ 4. Expand the project in the Project Explorer pane, and then 
expand Event Definitions to see the new events listed. 
Expand Monitor Models to see the new ClipsAndTacks 
model listed. 

____ 5. Now proceed to Part 2 to generate the EAR file for the 
monitor model. 
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Appendix B. Workaround for Step 5: Manage the Alphablox cube 
 
If you receive a connection error while running step 5 of the life-
cycle steps, you can use this appendix to complete a workaround.  In 
this section you will manually import the cube into Alphablox, then 
you will mark this step complete in the life-cycle table. 
____ 1. Copy the cube name from OLAP Center. 

__ a.  In Windows, select Start ► All Programs ► IBM 
DB2 ► Business Intelligence Tools ► OLAP 
Center. 

__ b.  Enter your DB2 user ID and password. 
__ c.  Confirm that the cube model is listed as in the 

following example:
Figure 114. Confirm that the cube model is listed 

 
 

 

 

Figure 115. Select the text in the Name 
field as shown 

__ d. Right-click the cube model, and then select 
Properties. 

__ e.  Using the mouse, select the text in the Name field as 
shown in the following example: 
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__ f.  Press Ctrl+C to copy the text to the clipboard. 
__ g.  Click Cancel, and then close the OLAP Center. 

____ 2. Define the cube to Alphablox. 
__ a.  If WebSphere Portal Server is not running, start it by 

clicking Start ► All Programs ► IBM 
WebSphere ► WebSphere Portal v5.1 ► Start 
the Server. 

__ b.  To start Alphablox in a browser, click Start ► All 
Programs ► IBM DB2 Alphablox 8.4 ► 
AlphabloxAnalytics ► DB2 Alphablox 
Administrative Pages.   

 
Note: If Windows blocks your attempt to access the page, an 
information bar at the top of the window displays the following 
message. Click this bar and select Allow Blocked Content to 
continue.

Figure 116. Select Allow Blocked Content to continue 
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__ c.  In response to the prompt, enter admin for the user 

ID and password for the password.  Confirm that the 
next window looks like the following example.

Figure 117. Confirm that the next window looks like this 
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__ d.  Click the Cubes tab at the top of the Alphablox 

window, and then click Create.  You should see a 
window like this:

Figure 118. Confirm that the next window looks like this 

 
 

__ e.  Next to the DB2 Alphablox Cube Name field, select 
the Enabled check box. 

__ f.  Press Ctrl+V to replace New Cube with the correct 
cube name. 

__ g.  For Relational Data Source, select DATAMART. 
__ h.  Select the Enable DB2 Cube Views Settings check 

box. 
__ i.  From the Cube Model list, select the model. Then 

click Import Cube Definition. 
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__ j.  Confirm that the information in the window looks 

like the following example.
Figure 119. Confirm that the next window looks like this 

 
 

__ k.  The DB2 Alphablox Cube Name value must exactly 
match the Cube Model name, without the WBI 
prefix. 
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__ l.  Click OK to save the definition.  Confirm that it has 

been added to the list as follows:
Figure 120. Confirm that  the definition has been added to the list 
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__ m. Click the General tab at the top of the Alphablox 

window.  Then click Runtime Management ► DB2 
Alphablox Cubes.  

Figure 121. Click Runtime Management ► DB2 Alphablox Cubes 
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__ n.  Select the cube from the list, and then click start.  

The status of the cube should be Running, as shown 
in the following example:

Figure 122. The status of the cube should be Running 

 
 
____ 3. Update the life-cycle table for step 5. 

__ a.  Open the DB2 Control Center.  In Windows, select 
Start ► All Programs ► IBM DB2 ► General 
Administrative Tools ► Control Center. 
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__ b.  In the MONITOR database, open the LC_STEP 

table.  In the row containing createAbxCube as the 
STEPNAME value, type 1 in the ISCOMPLETE 
column.  Here is an example:

Figure 123. Open the LC_STEP table 

 
 

__ c.  Click Commit to save your changes, then click 
Close. 

__ d.  Close the DB2 Control Center. 
__ e.  If the Process Server administrative console still 

displays step 5 of the life cycle, reload the page in 
the browser. The window should indicate that step 5 
is now complete. 

__ f.  Return to the instructions for the life-cycle steps, 
starting at step 6. 
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