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Overview 
 
This sample aims to demonstrate how to monitor a Business Process 
Execution Language (BPEL) business process. The BPEL process 
that is used was built using IBM WebSphere® Integration 
Developer, V6.0.2, and runs on WebSphere Process Server, V6.0.2. 
It makes use of a number of WebSphere Process Server capabilities 
such as human tasks. 
 
This sample does not cover creating the BPEL process and 
application. Instead it shows you how to build the monitor model so 
that you can monitor the BPEL process using WebSphere Business 
Monitor, V6.0.2. The sample covers all steps from development to 
deployment. 
 
You can follow the steps provided to build the monitor model 
yourself, which will help you learn how to build monitor models for 
BPEL processes. Alternatively, you can skip the process of actually 
building the monitor model and instead look at a solution that  this 
exercise provides. 
 
When building the monitor model you will see how you first enable 
the event production for the BPEL process, then generate a monitor 
model for these events, and then augment it with specific business 
measurements such as metrics and key performance indicators 
(KPIs).  
 
The BPEL process used in this sample is the ClipsAndTacks Order 
Handling process, which is adapted from the IBM Redbooks® 
publication, Business Process Management: Modeling through 
Monitoring Using WebSphere V6 Products, SG247148.  This 
Redbooks publication refers to several models.  This sample uses the 
Order Handling Future 1 Process.  
 
The application in the Redbooks publication also includes the 
following items that you can use to test the BPEL business process:  

• A Web front-end application, 
ClipsAndTacksFrontWeb. This interface is available to 
submit orders to drive events through the 
ClipsAndTacks future 1 process. 

• Human task JSP pages in a Web application named 
ClipsAndTacksHumanCustomWeb. This application 
provides a simple interface to the handle the human 
tasks for the BPEL process.    
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For more information about the Order Handling Future1 BPEL 
application, refer to the Redbooks publication at:  
 

http://www.redbooks.ibm.com/abstracts/sg247148.html. 
 

Sample Project Interchange file and EAR files 
 

• ClipsAndTacksBPELMMPI.zip:  This Project 
Interchange file contains the complete solution for this 
sample, and can be immediately imported into 
WebSphere Integration Developer. It includes the 
BPEL application and the completed monitor model.  

• ClipsAndTacksBPELProcessPI3.zip: This file contains 
the BPEL application only, and is a starting point for 
this sample. 

• ClipsAndTacksBPELMMEAR.ear, 
ClipsAndTacksApp.ear and 
ClipsAndTacksHumanCustomEAR.ear:  These are 
generated enterprise archive (EAR) files that are ready 
to be deployed on the Monitor Server. 

• The Scalable Vector Graphics (SVG) diagrams for this 
sample: 

 
o KM_Order_Handling__x0028_Future_1_x0029__

KC.svg 
o MDM_Order_Handling__x0028_Future_1_x0029

__MC.svg 
 

Software requirements 
To complete this sample, you must have the following software 
installed: 

• WebSphere Integration Developer, V6.0.2  
• WebSphere Business Monitor, V6.0.2  

o WebSphere Business Monitor Development 
Toolkit 

o Basic Installation including the Dashboard Server 
and Monitor Server 

• Adobe SVG Viewer, a freeware browser plug-in for 
viewing SVG images within Web pages; download  
from: 

 http://www.adobe.com/svg/viewer/install/ 
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Part 1. Import the BPEL process  
If you do not want to work through this sample you can import the 
complete solution for this sample, which is provided as a Project 
Interchange file that can be immediately imported into WebSphere 
Integration Developer. It includes the BPEL application, and the 
completed monitor model. See Appendix A1 for instructions on 
importing the Project Interchange file.   
Note: There is a Problems page that displays errors concerning the 
model.  Periodically check this view to see if there are any problems 
that need to be addressed. 
____ 1. Start WebSphere Integration Developer and set up the 

environment. 
__ a. Start WebSphere Integration Developer, V6.0.2, and 

when prompted, point to a new workspace, such as 
C:\workspaces\ClipsAndTacksBPEL. 

__ b. Close the Welcome page. By default, you are in the 
Business Integration perspective.  

__ c. If you are asked to confirm enablement, click OK. 
____ 2. Import the Project Interchange file for the ClipsAndTacks 

Future 1 business process 
(ClipsAndTacksBPELProcessPI3.zip) into WebSphere 
Integration Developer, V6.0.2 as shown in the following 
example. Wait for the project to be built, which takes a few 
minutes.  This Project Interchange file also includes a Web 
front-end application to submit customer orders to the 
business process. This application allows users to select 
products and place orders that are entered into a 
Cloudscape database. This application is embedded in the 
ClipsAndTacksApp.ear file. 
__ a. Click File ► Import. 

Figure 1. Click File ► Import 
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__ b. Click Project Interchange. 

 
 

 

Figure 2. Click Project Interchange 
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__ c. Click Next.

Figure 3. Click Next 

 
__ d. In the Import Project Interchange Contents window: 

1) Browse to the location containing the Project 
Interchange file 
ClipsAndTacksBPELProcessPI3.zip.  

2) Accept the default project location or type a 
project location.  

3) Click Select All, and then click Finish. 
__ e. Right-click ClipsAndTacks and then click Refresh.  

Ensure that OrderHandlingFuture1 is listed in the 
Process view. 

__ f. If the import failed, clean the project and rebuild. 
 
____ 3. Using WebSphere Integration Developer, you can 

simultaneously generate a monitor model and event 
definitions from BPEL processes.  There is a set number of 
predefined events that it is capable of emitting. However, 
before you can generate event definitions for any 
predefined events, you must modify the Event Monitor  
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settings, so that it will emit all events and ensure that events 
carry data. 

____ 4. In the Business Integration view, expand ClipsAndTacks 
in the navigation pane.  Then expand Processes.  Double-
click OrderHAndlingFuture1 to see the process. Click the 
Event Monitor tab in the Properties view. Click All to see 
all events, and select Full from the list so that the event will 
carry business information.  
__ a. Click Order Handling (Future 1) Receive and then 

click the Properties tab. 
__ b. Click Event Monitoring. Change the Event Content 

value from Digest or Empty to Full. 
Figure 4. Change the Event Content value to Full 
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__ c. Click Global Event Settings and make sure that the 
Event Format selected is XML (WebSphere 
Business Monitor compatible).

Figure 5. Click Global Event Settings 

 
 

__ d. Select Enable default events if it is not already 
selected.  This will generate default events for the 
Process, Receive, Reply, Invoke, Scope, and Staff 
elements of Future1. 

__ e. Repeat the preceding steps for every piece of the 
process element in the assembly diagram.   

 
__ f. Press Ctrl+S to save your work.   
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Part 2. Generate the monitor model 
 
You will use the Monitor Model Editor in WebSphere Integration 
Developer generate the monitor model from the BPEL process. 
 
____ 1. Generate the ClipsAndTacks monitor model into a new 

Business Monitoring project.  
__ a. In the Business Integration navigation pane, right-

click OrderHandlingFuture1 process, then click 
Monitor Tools ► Generate Monitor Model.

Figure 6. Click  Monitor Tools ► Generate Monitor Model 
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____ 2. Specify a name for the new Business Monitoring project 

and the new model as shown in the following example, 
then click Next.

Figure 7. Specify a name for the new Business Monitoring project and model 
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____ 3. Select the BPEL events and activities to monitor.  For this 
sample all the ENTRY and EXIT events were selected as 
shown in the following example.  Select the ENTRY and 
EXIT events for the process OrderHandlingFuture1 as 
shown in the following example. Repeat this selection of 
the ENTRY and EXIT events for the Receive, Reply and 
Invoke elements of the flow.

Figure 8. Select the BPEL events and activities to monitor 
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____ 4. For each of the three BPEL variables, select the Event 
Definition check box as shown in the following example.

Figure 9. Select the Event Definition check box  for each variable 

    
 

__ a. Click Finish. You will be prompted to switch to the 
Business Monitoring perspective. 
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Part 3. Augment the monitor model with Monitor Model Editor  
 
The monitor model is a top-level container, and contains five parts:  

• The monitor details model (which contains monitoring 
contexts and their associated metrics, keys, counters, 
stopwatches, triggers, and events) 

• The data mart model (which contains cubes, 
dimensions, and measures)  

• The KPI model (which contains KPI contexts and KPIs 
with their events and triggers)  

• The visual model (which contains diagrams associated 
with monitoring contexts and KPI contexts for display 
in the dashboard)  

• The event model (which contains references to event 
definitions for all inbound and outbound events)  

 
The monitor details model holds most of the monitor model 
information. 
 
This section provides the steps required to define some of the KPIs 
in this sample.  However, it does not provide step-by-step 
instructions for all the metrics, cubes, measures, dimensions and 
KPIs defined in this sample model.  You can import the Project 
Interchange file to examine the steps that are not covered in this 
section. 
 
____ 1. Edit the monitor model with Monitor Model Editor 

(MME).  MME is an Eclipse-based tool that is used to 
author monitor models and event definitions.  Augment the 
generated monitor model in the Business Monitor 
perspective.  

 
____ 2. Notice that there are four tabs in the Business Monitor 

perspective:   
1. Monitor Details Model  
2. Data Mart Model 
3. KPI Model 
4. Visual Model 

 
____ 3. When augmenting or creating a monitor model you 

normally start with the monitor details model.  Add details 
to the model in the following order: 
1. Triggers 
2. Stopwatches 
3. Metrics 
4. Counters 

____ 4. Next, augment the model by selecting the data mart model.  
This model contains the fact tables for each metric, counter, 
and stopwatch defined in the monitor details model.  The 
facts will be used to add measures.  The cube that is 
automatically created for the sample monitoring context 
will be augmented with dimensions. 
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• Measures are aggregations performed on facts to 

combine them into a single value. For example, the 
Average Order Price measure is based on the values of 
the Order Amount metric. 

• Dimensions are categories used to organize and select 
data for monitoring and analysis.  They are composed 
of one or more attributes, which are hierarchical.  This 
sample uses a Location dimension with attributes City 
and Country. 

____ 5. Next, add KPI definitions to the KPI model. KPIs are built 
on measures and dimensions. A KPI can have a target, a set 
of ranges, or both, to measure how well a business is 
achieving its objectives. To define a KPI, choose the 
measure that you want to analyze, and the dimensions that 
you want to use to filter the retrieved data. This sample 
analyzes the Average Order Amount measure organized by 
the defined Location dimension. 

____ 6. Finally, define visualizations in the visual model. Each 
visualization is an SVG diagram that can be displayed in 
the WebSphere Business Monitor dashboards. The 
visualization can include a set of actions describing how 
and when the diagram will be modified based on the values 
of metrics and KPIs. 

 
Confirm that the Monitor Details page for the augmented 
monitor model ClipsAndTacksBPELMM looks like the 
example shown below.

Figure 10. Confirm that the Monitor Details page looks like this example 
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Defining the Average Order Price (US Dollars) KPI 
 
The Average Order Price (US Dollars) KPI tracks the average price 
of orders received by the Clips And Tacks company. The average 
price is calculated in U.S. dollars.   

• This KPI has a defined target to achieve as well as 
ranges against which it is tracked.   

• The KPI is based on the Average Order Price measure.   
• The Average Order Price measure is in turn based on 

the values of the Order Amount metric.   
• Every metric is associated with one or more maps, 

which define how the metric gets its value. Each map 
can optionally have a trigger.  The map runs when the 
trigger fires. The map on the Order Amount metric 
runs when the Received New Order Trigger fires.  The 
map expression in this sample uses the value carried by 
the event OrderHandlingFuture1_InputCriterion EXIT 
to set the value of the metric.   

 
To define the Average Order Price (US Dollars) KPI, define the 
following values in the order shown: 

1. Received New Order Trigger 
2. Order Amount metric 
3. Average Order Price measure 
4. Average Order Price (US Dollars) KPI 

 
 
____ 1. Define Received New Order Trigger.  On the Monitor 

Model Details page, right-click 
OrderHandlingFuture1_InputCriterion_Activity, and 
then click New ► Trigger.   
__ a. Enter these values: 

• For Name, type Received New Order 
Trigger. 

• For ID, type 
Received_New_Order_Trigger. 

• For Trigger Sources, click Add, then 
select Other source type. 

• Select the inbound event 
OrderHandlingFuture1_InputCriterion 
EXIT from the list. 
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 __ b. Click OK to save completed trigger as shown in the 
following example.

Figure 11. Click OK to save completed trigger 
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____ 2. Now define the Order Amount metric. In the model 
navigation pane, right-click 
OrderHandlingFuture1_Process monitoring context, 
then click New ► Metric.

Figure 12. Click New ► Metric 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
__ a. Enter the following values: 

• For Name, type Order Amount. 
• For ID, type Order_Amount. 
• For Type, select Decimal. 
• In the first row of the Metric Value Maps 

table, select the cell under the Trigger 
column, then click the button that is 
displayed. Click Trigger type ► 
OrderHandlingFuture1_process ► 
OrderHandlingFuture1_InputCriterion_A
ctivity ► Received New Order Trigger. 

__ b. Click OK. 
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__ c. In the first row of the Metric Value Maps table, select 

the cell under the Expression column, then click the 
button that is displayed and enter the following text 
(or  press Ctrl+Space for assistance):  

 
decimal(OrderHandlingFuture1_InputCriterion_Acti
vity/OrderHandlingFuture1_InputCriterion_EXIT/ex
tendedData/message/Input/TotalPrice)

Figure 13. Enter the following text  or  press Ctrl+Space 

__ d. Click OK. 
__ e. Press Ctrl+S to save your work. 

 
____ 3. Define the Average Order Price measure in the data mart 

model based on the Order Amount fact, which is 
automatically created when the Order Amount metric is 
defined. 
__ a. Click the Data Mart Model tab of the editor and 

scroll down to the Measures table. 
__ b. Select OrderHandlingFuture1 Cube and click Add 

Measure.                                                                      
Note: A data mart model contains one cube for each 
monitoring context definition. Each cube keeps track 
of all the information that the monitoring context 
collects over time. The cube can combine all the 
instances of that monitoring context so that you can 
query aggregate information. 

1) Enter the following values: 
• For Name, type Average Order Price. 
• For ID, type Average_Order_Price. 

2) Click OK. 
3) Click the Source cell and click the button that is 

displayed to open the Select Fact Attribute 
window. Select Order Amount Fact as the 
source of the measure. 

4) Click OK. 
5) Click the Aggregation Function cell and select 

the Average function from the list. 
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6) Press Ctrl+S to save your work as shown in the 
following example : 

Figure 14. Press Ctrl+S to save your work 

____ 4. Define Average Order Price KPI using the Average Order 
Price measure. 
__ a. Before defining a KPI, you must define a KPI 

context. This sample has already defined one cube 
containing at least one measure, which is also a 
prerequisite for defining a KPI.  

__ b. Click the KPI Model tab of the editor, right-click the 
monitor details model, ClipsAndTacksBPELMM, 
at the top of the tree, and click New ► KPI Context. 

__ c. For Name, type Order Handling KPI Context. 
__ d. Confirm that Order Handling KPI Context has been 

added to the model tree. 
__ e. Right-click Order Handling KPI Context and click 

New ► KPI.  
__ f. For Name, type Average Order Price (US Dollars). 
__ g. For ID, type Average_Order_Price_(US_Dollars). 
__ h. Click OK. Confirm that the KPI and its icon have 

been added to the model tree under the KPI context 
node. 

__ i. Double-click the newly created KPI to edit the 
definition. 

1) From the list of KPI types, select Decimal.  
2) For the initial target, type 300. 
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3) Specify ranges. Click Add to add a range. In 

the Add Range window, type High Range as 
the name. The name must be unique within the 
set of ranges that contain the range.  

4) Click the Start Value and End Value cells for 
High Range and specify the values 300 and 
<1000 respectively. Both values are required. 
The name of the range is displayed under the 
range set in the model tree. 
Important: The start value of each row must 
equal the end value for the previous row. After 
adding ranges, you can click Sort to sort them 
from the lowest start value to the highest start 
value.  

5) Click Add to add another range. In the Add 
Range window, type Low Range as the name.  

6) Click the Start Value and End Value cells for 
Low Range and specify the values 0 and <300 
respectively.  

7) Press Ctrl+S to save your work. 
__ j. The values for the KPIs are extracted from the cube. 

Specify the way the KPI is evaluated as follows in 
the KPI Definition section:  

 
1) Click Browse to select the 

OrderHandlingFuture1 cube to associate 
with the KPI.  

2) Click Browse to select the Average Order 
Price measure within the cube. 

 
Note: There is no Time dimension specified 
within the OrderHandlingFuture1 cube. Since 
you do not select a time dimension, the KPI 
will be evaluated using all available values. 

 
3) Press Ctrl+S to save your work. 

__ k. Some of the other KPIs in this sample can be defined 
using the same steps. 

Defining the Average Order Fulfillment Time KPI 
 
The Average Order Fulfillment Time KPI tracks the average time 
taken to fill orders received by the Clips And Tacks Company.  

• This KPI has a defined target to achieve as well as 
ranges against which it is tracked.   

• The KPI is based on the Average Order Fulfillment 
Time measure.   

• The Average Order Fulfillment Time measure is in 
turn based on the values of the Order Fulfillment 
Timer stopwatch.   

• The stopwatch is used to measure the time between 
two events. The stopwatch is started and stopped by 
triggers. 
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Figure 15. Select 
OrderHandlingFuture1 ENTRY 

 
 

 
To define the Average Order Fulfillment Time KPI, define the 
following values in the order shown: 

__ a. New Order Trigger 
__ b. Average Order Fulfillment Timer stopwatch 
__ c. Current Status metric 
__ d. Average Order Fulfillment Time measure 
__ e. Current Status dimension 
__ f. Average Order Fulfillment Time KPI 

 
____ 1. Define New Order Trigger.  In the Monitor Model Details 

view, right-click OrderHandlingFuture1_Process, and 
then click New ► Trigger.  Enter these values: 

1) For Name, type New Order Trigger. 
2) For ID, type New_Order_Trigger. 
3) For Trigger Sources, click Add, then select 

Other source type. 
4) From the list of source types, select 

OrderHandlingFuture1 ENTRY and click 
OK. 
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 5) Click OK. 
 

Figure 16. Click OK 
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____ 2. Right-click OrderHandlingFuture1_Process MC, and 

then select New ► Stopwatch.
Figure 17. Select New ► Stopwatch 

__ a. Now define the new Stopwatch information. 
1) For Name, type Order Fulfillment Timer.   
2) For ID, type Order_Fulfillment_Timer.   
3) For Stopwatch Controls, click Add, then select 

OrderHandlingFuture1_Process monitoring 
context ► New Order Trigger, then click 
OK.  
 
Note: The default value for Resulting Action 
is Start. 
 

4) For Stopwatch Controls, click Add, then select 
OrderHandlingFuture1_Process 
Monitoring Context ► 
OrderHandlingFuture1 Termination 
Trigger, and then click OK.  
 
Note: OrderHandlingFuture1 Termination 
Trigger was generated by MME. 
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5) The default value for Resulting Action is Start.  
You need to change it to Stop for this trigger.  
To do so, click the second row in Resulting 
Action column.  From the list, select Stop.

Figure 18. Select Stop 
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6) Press Ctrl+S to save your work. Confirm that 
the completed Stopwatch controls look like the 
following example.

Figure 19. Confirm that the completed Stopwatch controls look like this 

Define the Current Status metric.  The value of this metric 
reflects the status of an order in the Future1 process.  The 
status of an order can be one of the following values: 

• Started: This metric value is set when the New 
Order Trigger is fired. 

• Review Order: This metric is set when the Review 
Order Started Trigger is fired. 

• Cancel Order: This metric is set when the Cancel 
Order Started Trigger is fired. 

• Ship Order: This metric is set when the Ship Order 
Started Trigger is fired. 

• Cancelled: This metric is set when the 
CancelOrderandSendNotification_InputCriterion 
Termination Trigger is fired. 

• Shipped: This metric is set when the 
ShipOrdertoCustomer_InputCriterion Termination 
Trigger is fired. 

__ a. In the model navigation pane, right-click 
OrderHandlingFuture1_Process monitoring 
context, then select New ► Metric.   
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1) Enter these values: 

• For Name, type Current Status. 
• For ID, type Current_Status. 
• For Type, select String. 
• In the first row of the Metric Value Maps 

table, select the cell under the Trigger 
column. Then, click the button that is 
displayed. Click Trigger type ► 
OrderHandlingFuture1_process ► 
OrderHandlingFuture1_InputCriterion
_Activity ► Received New Order 
Trigger. 

• In the first row of the Metric Value Maps 
table, select the cell under the Expression 
column, then click the button that is 
displayed and enter this text, including the 
single quotation marks:  

‘Started’ 
 

__ b. Using the Metric Values Map table, define the rest of 
the entries that are listed after the new Current Status 
metric, as shown in the following example:

Figure 20. Define the rest of the entries that are listed 
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____ 3. Define the Average Order Fulfillment Time measure in the 
data mart model based on the Order Fulfillment Timer fact, 
which is automatically created when the Order Fulfillment 
Timer stopwatch is defined. 
__ a. Click the Data Mart Model tab in the business 

monitoring perspective and scroll down to the 
Measures table. 

__ b. Select the OrderHandlingFuture1 Cube and click 
Add Measure.                                                                      
Note: A data mart model contains one cube for each 
monitoring context definition. Each cube keeps track 
of all the information that the monitoring context 
collects over time. The cube can combine all the 
instances of that monitoring context so that you can 
query aggregate information. 

1) Enter the following values: 
• For Name, type Average Order 

Fulfillment Time. 
• For ID, type 

Average_Order_Fulfillment_Time. 
2) Click OK. 
3) Click the Source cell, and then click the button 

that is displayed to open the Select Fact 
Attribute window. Select the Order 
Fulfillment Timer Fact as the source of the 
measure. 

4) Click OK. 
5) Click the Aggregation Function cell and select 

the Average function from the list. 
6) Press Ctrl+S to save your work as shown in the 

following example:
Figure 21. Save your work as shown 
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____ 4. Add the Current Status dimension to the data mart model.  
This information will be used later when you create the 
definition of the KPI. 
__ a. Scroll up to the Dimensions table. 
__ b. Select the OrderHandlingFuture1 Cube and click 

Add Dimension.                                                                      
Note: A data mart model contains one cube for each 
monitoring context definition. Each cube keeps track 
of all the information that the monitoring context 
collects over time. The cube can combine all the 
instances of that monitoring context so that you can 
query aggregate information. 

 
1) Enter the following values: 

• For Name, type Current Status. 
• For ID, type Current_Status. 

2) Click Add Attribute. 
a) For Name, type Current Status. 
b) For ID, type Current_Status. 

3) In the Dimensions table, in the row containing 
Dimension Attribute Current Status, click the 
cell in the Source column.  Click the button 
that is displayed, and then click 
OrderHandlingFuture1_process ► Current 
Status.   

4) In the Dimensions table, in the row containing 
Dimension Attribute Current Status, click the 
cell in the Is Key column.  Click the button 
that is displayed, select the check box, and 
then click OK. 

5) Press Ctrl+S to save your work. 
 

____ 5. Define Average Order Fulfillment Time KPI using the 
Average Order Fulfillment Time measure. 
__ a. Select the KPI Model tab in the Business Monitoring 

perspective. 
__ b. Right-click the Order Handling KPI Context and 

select New ► KPI.  
__ c. For Name, type Average Order Fulfillment Time. 
__ d. For ID, type Average_Order_Fulfillment_Time. 
__ e. Click OK. Confirm that the KPI and its icon have 

been added to the model tree under the KPI context 
node. 

__ f. Double-click the newly created KPI to edit the 
definition. 

1) From the list of KPI types, select Duration. 
2) For the initial target, type 3 Days. 
3) Specify ranges of One Day, Two Days, Three 

Days and Four Days as shown in the following 
example.   

4) Click Add to add the One Day range. In the 
Add Range window, type One Day as the 
name. The name must be unique within the set 
of ranges that contain the range. 
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5) Click the Start Value and End Value cells for 

the One Day and specify the values 0 
Milliseconds and <1 Days respectively. Both 
values are required. The name of the range is 
displayed under the range set in the model tree.  

Important: The start value of each row must 
equal the end value for the previous row. After 
adding ranges, you can click Sort to sort them 
from the lowest start value to the highest start 
value.  
 
6) Follow the same procedure to add the Two 

Days, Three Days and Four Days ranges as 
shown in the following example:

Figure 22. Add the Two Days, Three Days and Four Days ranges 

 7) Press Ctrl+S to save your work. 
 

__ g. The values for the KPIs are extracted from the cube. 
Specify the way the KPI is evaluated as follows in 
the KPI Definition section:  

1) Click Browse to select the 
OrderHandlingFuture1 Cube to associate 
with the KPI.  

2) Click Browse to select the Average Order 
Fulfillment Time measure within the cube. 
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Note: There is no Time dimension specified 
within the OrderHandlingFuture1 Cube. Because 
you do not select a time dimension, the KPI will 
be evaluated using all available values. 
 
3) Use the Dimensions in the KPI Definition 

section to restrict the set of facts that is 
included in the KPI calculation.  For example, 
in this example you can specify a Current 
Status value of Shipped. This will restrict the 
set of facts to the Orders whose Current status 
is Shipped.   

4) In the KPI Definition section for this KPI, 
below the Dimensions table, click Add. 

5) In the window that opens, navigate to 
OrderHandlingFuture1 Cube ► Current 
Status ► Current Status, then click OK. 

6) In the Dimensions table, expand Current 
Status Dimension. 

7) In the row containing Attribute Current Status, 
click the cell in the Value column. Click the 
button that is displayed, then enter this text in 
the editor window: 

Shipped 
8) Press Ctrl+S to save your work.  

 

Visual model definitions  
 
This sample includes visual model definitions for the 
ClipsAndTacksBPELMM model. Diagram views will be used to 
display the diagrams on the Dashboard. The SVG diagrams for this 
sample were exported from the WebSphere Business Modeler, 
V6.0.2.  
  
The following files are generated by the Modeler export.  The first 
SVG diagram is for the KPI context, and the second is for the 
monitoring context. 
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• KM_Order_Handling__x0028_Future_1_x0029__KC.
svg.  If the version specified in the file is not 6.0.2, 
overwrite it as shown in the following example:  

 
<svg 
xmlns:mm="http://www.ibm.com/xmlns/prod/websphere/
monitoring/6.0.2/mm" 
xmlns:xlink="http://www.w3.org/1999/xlink" 
xmlns="http://www.w3.org/2000/svg" color-
interpolation="auto" color-rendering="auto" fill="black" 
fill-opacity="1" font-family="'sansserif'" font-size="12" 
font-style="normal" font-weight="normal" height="810" 
image-rendering="auto" shape-rendering="auto" 
stroke="black" stroke-dasharray="none" stroke-
dashoffset="0" stroke-linecap="square" stroke-
linejoin="miter" stroke-miterlimit="10" stroke-opacity="1" 
stroke-width="1" text-rendering="auto" width="2121"> 
 
• MDM_Order_Handling__x0028_Future_1_x0029__M

C.svg.  If the version specified in the file is not 6.0.2, 
overwrite it as shown in the following example:  

 
<svg 
xmlns:mm="http://www.ibm.com/xmlns/prod/websphere/
monitoring/6.0.2/mm" 
xmlns:xlink="http://www.w3.org/1999/xlink" 
xmlns="http://www.w3.org/2000/svg" color-
interpolation="auto" color-rendering="auto" fill="black" 
fill-opacity="1" font-family="'sansserif'" font-size="12" 
font-style="normal" font-weight="normal" height="810" 
image-rendering="auto" shape-rendering="auto" 
stroke="black" stroke-dasharray="none" stroke-
dashoffset="0" stroke-linecap="square" stroke-
linejoin="miter" stroke-miterlimit="10" stroke-opacity="1" 
stroke-width="1" text-rendering="auto" width="2121"> 
 
• OrderHandling(Future1).mm 

 
____ 1. Import the SVG Diagrams into WebSphere Integration 

Developer.  In the Business Monitoring perspective, select 
ClipsAndTacksBPELMM Business Monitoring project in 
Project Explorer pane. 

____ 2. Select File ► Import ► File System as shown in the 
following example.  

____ 3. Select the two SVG diagrams for import.  
____ 4. Click Finish. 
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Figure 23. Select the two SVG 
diagrams for import 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 24. Click 
OrderHandlingFuture1_Process 

 
____ 5. Press Ctrl+S to save your work. 
 

 
 
____ 6. Click the Visual Model tab in the Business Monitoring 

perspective. Click OrderHandlingFuture1_Process. 
Confirm that no SVG diagrams are displayed. 
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Figure 25. Select 
MDM_Order_Handling__x0028_Future
_1_x0029__MC.svg 

 
 

 
 
____ 7. To select the monitoring context SVG, click Browse, then 

select the following file, as shown in the following 
example: 
MDM_Order_Handling__x0028_Future_1_x0029__MC
.svg. 

____ 8. Click OK. 
____ 9. Press Ctrl+S to save your work. 
 

 
 
____ 10. To select the SVG diagram for the KPI order-handling 

context, repeat the preceding steps and select 
KM_Order_Handling__x0028_Future_1_x0029__KC.sv
g. 



    Generating a Monitor model 
 
36 

 
____ 11. Confirm that an SVG diagram is displayed when you select 

the monitoring context or KPI context in the visual model. 
Here is the diagram for the monitoring context.

Figure 26. The diagram for the monitoring context 

____ 12. Manually edit the visualization part of a monitor model.  
Click the ClipsAndTacksBPELMM.mm tab to examine the 
XML coding of the monitor model.  

____ 13. Confirm that the <visualModel> tag has been added to the 
.mm file, as shown in the following example.  

 
<visualModel id="VM"> 
  <visualization 
context="MDM/OrderHandlingFuture1_Process"> 
   <svgDocument> 
   <import 
location="/ClipsAndTacksBPELMM/MDM_Order_Handling
__x0028_Future_1_x0029__MC.svg"/> 
   </svgDocument> 
  </visualization> 
</visualModel> 
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____ 14. Using cut and paste, manually merge data from the .mm 

file produced by Modeler V6.0.2 into the existing 
ClipsAndTacksBPELMM.mm.   
__ a. For each visualization, copy the <shapeSets> and 

<actions/> tags from the 
OrderHandling(Future1).mm file into the 
corresponding <visualModel> section of the 
ClipsAndTacksBPELMM.mm.  To check how your 
updates should look, see the 
ClipsAndTacksBPELMM.mm file shipped with this 
model.  Note: this exercise did not change the 
<shapeSets> tags. 

__ b. Add the following actions for the monitoring context 
visualization in ClipsAndTacksBPELMM.mm.  The 
Added actions will highlight the tasks selected on the 
Instances view in the Dashboard.  The color will 
depend on the Current Status for the instance 
selected. The Review Order task will be highlighted 
in blue if the Current status is ‘Review Order’.

<actions>         
              <setColor condition="Current_Status = 'Review Order' " outlineColor="blue"> 
                <shapeSet ref="Review_Order" /> 
              </setColor> 
              <setColor condition="Current_Status = 'Ship Order' " outlineColor="green"> 
                <shapeSet ref="Ship_Order_to_Customer" /> 
              </setColor>                   
              <setColor condition="Current_Status = 'Shipped' " outlineColor="green"> 
                <shapeSet ref="Ship_Order_to_Customer" /> 
              </setColor>   
              <setColor condition="Current_Status = 'Cancel Order' " outlineColor="red"> 
                <shapeSet ref="Cancel_Order_and_Send_Notification" /> 
              </setColor>                   
              <setColor condition="Current_Status = 'Cancelled' " outlineColor="red"> 
                <shapeSet ref="Cancel_Order_and_Send_Notification" /> 
              </setColor>                           
</actions> 
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__ c. Add following actions for the KPI context 
visualization in ClipsAndTacksBPELMM.mm. The 
added actions will display counts  above each task in 
the KPI context diagram.

 
<actions> 

<setText textValue="concat('Review Order:', Order_Count_Review )" 
textColor="blue"> 
<shapeSet ref="Review_Order_2_top_label" /> 
</setText>             
<setText textValue="concat('Ship Order:', Order_Count_Ship )" textColor="blue"> 
  <shapeSet ref="Ship_Order_to_Customer_2_top_label" /> 
              </setText> 
<setText textValue="concat('Shipped:', Order_Count_Shipped )" textColor="blue"> 
<shapeSet ref="Ship_Order_to_Customer_2_bottom_label" /> 
              </setText>  
<setText textValue="concat('Cancel Order:', Order_Count_Cancel )" 
textColor="blue"> 
<shapeSet ref="Cancel_Order_and_Send_Notification_2_top_label" /> 
              </setText>               
<setText textValue="concat('Cancelled:', Order_Count_Cancelled )" 
textColor="blue"> 
  <shapeSet ref="Cancel_Order_and_Send_Notification_2_bottom_label" /> 

              </setText> 
</actions>

 
__ d. To confirm that you have completed your manual 

updates correctly, check your results against the 
ClipsAndTacksBPELMM.mm file shipped with this 
model. 
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Part 4. Generate the monitor model EAR file 
 
If you do not want to generate a Monitor model EAR file, you can 
skip this section and deploy the ClipsAndTacksBPELMMEAR.ear 
file supplied with this sample.   Proceed to the next section on 
deploying the monitor model on the Monitor server. 
 
____ 1. Generate the monitor model EAR file from the monitor 

model in the Business Monitoring perspective.   
__ a. Right-click the ClipsAndTacksBPELMM monitor 

model and select Generate Monitor EAR.
Figure 27. Select Generate Monitor EAR 

____ 2. Enter the following information for the project names: 
__ a. For EJB Project Name, select 

ClipsAndTacksBPELMMEJB. 
__ b. For EAR Project Name, select 

ClipsAndTacksBPELMMEAR. 
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Figure 28. Select the overwrite 
existing projects check box 

 
 

 

__ c. Select the overwrite existing projects check box, and 
then click Finish. 

 

 
____ 3.  Deploy the monitor model from the J2EE perspective. 

__ a. Open the J2EE perspective. 
__ b. In the Project Explorer pane, right-click EJB 

Projects ► ClipsAndTacksBPELMMEJB, then 
select Deploy. A progress window shows the status 
of the operation, and then closes when the operation 
is complete. 

__ c. Wait for deployment to be completed without any 
errors. 

____ 4. Deploy the EAR file using Add and Remove Projects, and 
complete the deployment on WebSphere Monitor Server 
using the WebSphere Administrative Console.  
__ a. Start the WebSphere Monitor Server from the 

Servers tab.  Wait until the status indicates Started. 
__ b. Right-click the server and select Add and remove 

project. 
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__ c. Click Add All to deploy all of the projects.

Figure 29. Click Add All to deploy all of the projects 

 
 
            



    Generating a Monitor model 
 
42 

Note: In the Monitor Unit Test Environment (UTE) there are fewer 
life cycle steps to run.  Life cycle steps 3, 4, and 5 are disabled.  
Complete steps 1, 2, 6 and 7 following the directions for each life 
cycle step as shown in the following example.

Figure 30. Follow the directions for each life cycle step as shown 

Refer to the deployment document provide with the Clips and Tacks 
samples for more-detailed instructions for each step. 
 
 
____ 5. Create data and events to monitor using the ClipsAndTacks 

application. First, follow the instructions in the Redbooks 
publication to define the CLIPTACK data source and create 
the CLIPTACK database, using information at this Web 
address:  
http://localhost:9080/ClipsAndTacksFrontWeb  
 
/CreateDatabaseServlet. (This address might be different on 
your system.) 

After completing this step, you can place orders using the Web 
front-end application, which was deployed with ClipsAndTacksApp.  
The Order Handling (Future1) process will be invoked and will 
proceed through the Check Order Handling for Automatic Approval 
activity (business rule), then will wait in the Review Order activity 
(human task) if the order amount exceeds $750.00.  Otherwise, the 
order will be approved and will wait in the ShipOrderToCutomer or 
CancelOrderAndSendNotification human tasks. 
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Run the custom human task applications to process the human tasks 
with the external browser, as specified in the Redbooks publication. 
You can review orders and approve or decline them.  You can also 
confirm shipment or cancel shipment of orders.  Run the 
applications using these Web addresses: 
 

• To place orders:  
http://localhost:9080/ClipsAndTacksFrontWeb/  

 
• To process orders:  

http://localhost:9080/ClipsAndTacksHumanCusto
mWeb/ 

 
• To see the updates in the CLIPTACK database after 

orders are placed, use this Web address: 
 
http://localhost:9080/ClipsAndTacksFrontWeb/Lis
tServlet 

 
Note: Your port number might be different from the one shown in 
the preceding Web addresses.   
To find the port number, browse the Process Server log, then search 
for the ClipsAndTacksFrontWeb and ClipsAndTacksHumanTasks 
Web modules. For example, check the SystemOut.log file at 
C:\IBM\WebSphere\ProcServer\profiles\wbmonitor\logs\server1\Sy
stemOut.log, or  
C:\IBM\WebSphere\ID\602\pf\wbmonitor\logs\server1\SystemOut.l
og if you  are using WebSphere Integration Developer and an 
embedded Process Server.  
 
[2/6/07 17:33:08:391 EST] 0000003d WebGroup      A   
SRVE0169I: Loading Web Module: ClipsAndTacksFrontWeb. 
[2/6/07 17:33:08:453 EST] 0000003d VirtualHost   I   
SRVE0250I: Web Module ClipsAndTacksFrontWeb has been 
bound to default_host[*:9081,*:80,*:9444]. 
[2/6/07 17:33:08:516 EST] 0000003d WebGroup      A   
SRVE0169I: Loading Web Module: ClipsAndTacksHumanTasks. 
[2/6/07 17:33:08:625 EST] 0000003d VirtualHost   I   
SRVE0250I: Web Module ClipsAndTacksHumanTasks has been 
bound to default_host[*:9081,*:80,*:9444]. 
 
In the preceding logs, the ClipsAndTacks sample Web modules are 
bound to port 9081. 
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____ 6. Use the WebSphere Business Monitor Unit Test 

Environment (UTE) to validate that the monitor model is 
processing events as expected.  This lightweight 
environment avoids the Dashboard prerequisites such as 
Portal, AlphaBlox and CubeViews. Use the WebSphere 
Business Monitor Dashboard to verify the deployed 
monitor model.                                                                                                           
__ a. Start WebSphere Business Monitor Server, V6.0.2 

from the Servers view if it is stopped.  Wait until the 
Server status indicates Started. 

__ b. Right-click the server and select WBM Web 
Dashboard. 

Figure 31. Select WBM Web Dashboard 
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__ c. In the Configure Active Instances view, select the 

ClipsAndTacksBPELMM model. A list of the 
monitoring contexts that are available in the model 
will be displayed.

Figure 32. A list of available monitoring contexts are displayed 
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__ d. Select 

ClipsAndTacksBPELMM.OrderHandlingFuture1
_Process. The list of business measures for the 
selected context will be displayed.

Figure 33. A list of business measures for the context are displayed 
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__ e. Select the measures to be displayed and click View. 
This view should display the instance data that was 
created using the ClipsAndTacksFrontWeb Web 
application and the 
ClipsAndTacksHumanCustomWeb JSP pages.  
Examine the order data and current status for 
accuracy as shown in the following example.  This 
example shows two active instances: one with a 
current status of Shipped and the other with a current 
status of Ship Order.  The Ship Percentage value for 
both is 100, because the Ship Order trigger has been 
fired.  You can check other defined metrics such as 
Country, City, Company Name, Order Number, 
Order Amount, and Order Date for accuracy.

Figure 34. This example shows two active instances 
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Part 5. Deploy the monitor model on the Monitor server 
 
The monitor model can be deployed on the Monitor server and 
tested with a Dashboard Server after testing in the UTE environment 
is completed.   
 

1. Export the ClipsAndTacksApp.ear, 
ClipsAndTacksHumanCustomEAR.ear, and 
ClipsAndTacksBPELMMEAR.ear files from WebSphere 
Integration Developer.  For example, right-click the 
ClipsAndTacksApp application from the J2EE perspective. 
Select Export ► EAR File. 
 

2. Deploy the ClipsAndTacksApp.ear, 
ClipsAndTacksHumanCustomEAR.ear, and 
ClipsAndTacksBPELMMEAR.ear files on a Monitor server 
using the administrative console.  See the deployment 
document provided with the Clips and Tacks samples for 
further details. 

 
3. Use the WebSphere Portal Server administrative features to 

create Dashboard pages. Configure different types of views:  
Gauge, Dimensional, Instance, and KPI.   

 
4. Assemble dashboards from the different configured views. 

See the Creating a dashboard document provided with the 
Clips and Tacks samples or further details. 

 
5. Used the Web applications available with the Order Handling 

(Future 1) project to verify execution and values of metrics 
defined in MME.         
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The following view shows a Dashboard page assembled with a 
Gauge view, a KPI view and a Dimensional 
view.  For clarity, each view is shown separately. 
 
The following figure illustrates the Dimensional view: 

Figure 35.The Dimensional view 
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The following figure illustrates the KPI view and part of the Gauge 
view: 

Figure 36. The KPI view and part of the Gauge view 
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The following figure illustrates the Gauge view:
Figure 37. The Gauge view 
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The following example shows the Dashboard page assembled with 
an Instance view and a KPI Context Diagram view.

Figure 38. Dashboard page with Instance view and KPI Context Diagram view 
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The Following SVG diagram is displayed for the KPI context on the 
same page.  The text in blue (Review Order: 2) displays the count of 
instances (2) with a given status (Review Order).  This diagram 
reflects the values in the Clips And Tacks BPEL Status KPI. 

Figure 39.Values in the Clips And Tacks BPEL Status KPI 
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The following SVG diagram is displayed for each monitoring 
context when the diagram link on an instance is clicked. The status 
box in the middle is highlighted in red to reflect the current status of 
the instance, which is Cancelled. This highlighting was defined in 
the monitor model <visualModel>. 

Figure 40. Box in the middle is highlighted to reflect current status 
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The following SVG diagram is displayed for a monitoring context 
when the diagram link on an instance is clicked. The box in the 
middle is highlighted in blue to reflect the current status of the 
instance, which is Review Order.  This highlighting was defined in 
the monitor model <visualModel>. 

Figure 41. Box in the middle is highlighted to reflect current status 
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The following dashboard shows a Dimensional view where you can 
drill up or down, as well as filter data. 

Figure 42. Dimensional view enables drilling up, down, and filter data 
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Right-click on the Canada column heading and select Drill Down 
to drill down on the data: 

Figure 43. Select to  Drill Down on the data 
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A1. Import the Project Interchange file into WebSphere Integration 
Developer 
 
A Project Interchange file has been provided so that you do not have 
to build the model from scratch.  This section shows you how to 
import the model into WebSphere Integration Developer from the 
Project Interchange file.  After importing the model you can proceed 
to generate the EAR file and deploy the model. 
 
____ 1. Start WebSphere Integration Developer and set up the 

environment. 
__ a. Start WebSphere Integration Developer, V6.0.2, and 

when prompted, point to a new workspace, such as 
C:\workspaces\ClipsAndTacks. 

__ b. Close the Welcome page. 
__ c. By default, you are in the Business Integration 

perspective.   Select File ► Import ► Project 
Interchange ► Next. 

__ d. Browse to the location containing the Project 
Interchange file, ClipsAndTacksBPELMMPI.zip.  

__ e. Type a project location for the project to be imported 
to, such as C:\SampleToolkit5. 

__ f. Click Select All, and then click Finish. 
____ 2. Wait for the build to be completed.  If there are any errors, 

clean up and build the project again. 
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