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What this sample provides 
 
To help you understand how to monitor data issued from an adapter, 
this sample provides a monitor model that is generated from a 
Service Component Architecture (SCA) interface operation and 
mediation flow, and is then completed in the Monitor Model Editor. 
The sample showcases both an SCA entry event and a mediation 
flow event-emitter’s event with payload coming from a source 
adapter.  
 
For this sample, an inbound interface operation and mediation flow 
for a Java Database Connectivity (JDBC) adapter were created in 
IBM® WebSphere® Integration Developer v6.0.2 and were used to 
generate event definitions within WebSphere Integration Developer.  
 
A monitor model was also generated from this operation and 
mediation flow. This monitor model was augmented to process the 
generated events and to calculate metrics, and then was deployed. 
The module used in this sample is the MonitorAdapter module. All 
project interchange (PI) files are available in a .zip file called 
MonitorAdapter.zip.  
 
You can import the MonitorAdapter.zip file into WebSphere 
Integration Developer and review the module, the generated events, 
and the augmented monitor model. You can then deploy the 
supplied Enterprise Archive (EAR) files, and test the monitor model 
using db2 commands. 
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Software requirements 
 
You must have the following software to run this sample: 

• WebSphere Integration Developer v6.0.2 GM Build 
and the Monitor Model Editor plug-in 

• WebSphere Business Monitor v6.0.2 GM Build – 
Basic Installation including the Dashboard Server and 
Monitor Server 

 
Note: If the WebSphere Integration Developer version is not 
consistent with WebSphere Business Monitor version, the Common 
Base Event definitions generated from WebSphere Integration 
Developer might not be consistent with the Common Base Events 
generated from WebSphere Process Server. That inconsistency will 
cause monitoring to fail. To avoid this failure, use the golden master 
(GM) build.  
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Introduction 
 
 

This document explains the major steps required to build the 
MonitorAdapter module, generate the monitor model, augment the 
monitor model, deploy the monitor model, and show results on a 
dashboard. Here is a summary of the scenario used in this sample. 
When a new customer record is added to the adapter database, a 
JDBC adapter becomes aware of it and sends customer information 
to a mediation flow to process. The mediation flow acts as a filter: 
for a non-gold customer, the mediation flow does nothing; for a gold 
customer, the mediation flow creates a record for the customer. In 
the monitor model, you define metrics to monitor the data issued by 
the JDBC adapter and display that information on a dashboard. 
 

Figure 1. Business-level diagram of the MonitorAdapter module 

 
 
 
 
 
 
 
 
Figure 2. JDBCInboundInterface and 
MediationFilter 

 
 
 
 
Figure 3. Filter determines gold 
customer 

 
 
 
 
 
 
 
 

• The MonitorAdapter module has two components: 
JDBCInboundInterface and MediationFilter. After a 
customer record is added to the adapter database, the 
JDBC inbound interface operation is activated to 
invoke the mediation flow with the payload. 

 
 

 
 
 
 

• In the mediation flow, a filter determines whether the 
record is for a gold customer. 
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Figure 4. Add metrics to monitor the 
data 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

• Based on the SCA operation and mediation flow, a 
monitor model is generated. In the Monitor Model 
Editor, you will add metrics to monitor the data from 
the adapter and mediation flow. 

 

 
 
 

• To see the monitored result, use the Instances view or 
the Dimensional view. 
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Part 1: Creating a module containing the JDBC adapter and mediation 
flow 
 
To skip the steps for creating this module, you can import the 
supplied project interchange file (MonitorAdapter.zip) into 
WebSphere Integration Developer. See Appendix A. Import the J2EE 
application solution into WebSphere Integration Developer on page 141, 
then proceed to step ____ 41 in this section. 
 
 
____ 1. Start WebSphere Integration Developer and ensure that the 

current perspective is Business Integration. 
 

___ a. If the perspective is not Business Integration, click 
Window ►Open Perspective►Other. 

___ b. In the Select Perspective window, select the Show all 
check box, select Business Integration (default), and 
click OK. 

 
Figure 5. Business Integration – IBM WebSphere Integration Developer 
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____ 2. Ensure that the Advanced J2EE setting is selected in the 
list of workbench capabilities.  Click Window ► 
Preferences ► Workbench. 

 
Figure 6. Preferences 
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____ 3. Right-click Business Integration, then click New ► 
Mediation Module. 

 

Figure 7. New  ► Mediation Module 
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____ 4. Type MonitorAdapter as the name for the new mediation 
module. 

Figure 8. New Mediation Module 
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____ 5. Click Finish to create the new module. 

 
Figure 9. The Monitor Adapter Module 
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____ 6. Click File ► Import and select RAR file. Click Next. 

Figure 10. Import and select RAR file 
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____ 7. Click Browse to find your installed JDBC adapter. If a 
JDBC adapter is not already installed, extract the supplied 
JDBC adapter build (JDBC.zip) and find the 
CWYBC_JDBC.rar in the extracted directory. Then clear 
the Add module to an EAR project check box and click 
Finish. 

Figure 11.  Finish import and select RAR file 

 

 

 

____ 8. In response to the prompt, click Yes to switch to the J2EE 
perspective. 

Figure 12. Switch to the J2EE perspective 
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____ 9. Expand Connector Projects to see the CWYBC_JDBC 
project. 

Figure 13. See the CWYBC_JDBC project 
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____ 10. To install the DB2 driver, copy the db2jcc.jar and 
db2jcc_license_cu.jar files from the <DB2 home 
directory>\SQLLIB\java\ directory into the 
connectorModule directory of your CWYBC_JDBC 
project. 

Figure 14. Copy db2jcc.jar and db2jcc_license_cu.jar files 
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____ 11. Right-click CWYBC_JDBC and click Refresh to make 
project aware of the two JAR files. 

Figure 15. Right-click CWYBC_JDBC and click Refresh 
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____ 12. Right-click CWYBC_JDBC and click Properties. Click 
the Java Build Path directory and switch to the Libraries 
tab. Click the Add JARs… button. 

Figure 16. Click the Java Build Path directory and switch to the Libraries tab  
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Figure 17. Select db2jcc.jar and 
db2jcc_license_cu.jar 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

____ 13. Select db2jcc.jar and db2jcc_license_cu.jar. Click OK. 

 

____ 14.  Now that the DB2 driver has been added into JDBC 
adapter project, you need to install the DB2 artifact that 
you will use for the sample.  

___ a. Using the DB2 wizard, create the ADAPTER 
database in DB2. 

___ b. Open a DB2 command window, then run the 
following commands: 

db2 connect to ADAPTER user 
db2admin using <db2 password> 

db2 -tvf MonitorAdapter_db2.sql 

db2 disconnect ADAPTER 
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___ c. The MonitorAdapter_db2.sql file should 
contain the following information:

CREATE TABLE customer  
( 
 pkey  VARCHAR(10) NOT NULL PRIMARY KEY, 
 fname  VARCHAR(20), 
 lname  VARCHAR(20), 
 ccode  VARCHAR(10) 
); 
 
CREATE TABLE WBIA_JDBC_EventStore  
( 
 event_id      INTEGER NOT NULL
 GENERATED ALWAYS AS IDENTITY (START WITH 1, INCREMENT BY 1, NO CACHE )
  PRIMARY KEY, 
 xid    VARCHAR(200), 
 object_key     VARCHAR(80)  NOT NULL, 
 object_name   VARCHAR(40)  NOT NULL, 
 object_function   VARCHAR(40)  NOT NULL, 
 event_priority      INTEGER   NOT NULL, 
 event_time    TIMESTAMP  default CURRENT TIMESTAMP 
NOT NULL, 
 event_status    INTEGER   NOT NULL, 
 event_comment  VARCHAR(100) 
); 
 
CREATE TRIGGER event_create  
AFTER INSERT ON CUSTOMER REFERENCING NEW AS N   
FOR EACH ROW MODE DB2SQL  
INSERT INTO wbia_jdbc_eventstore (object_key, object_name, object_function, event_priority, 
event_status)  
VALUES (N.pkey, 'Db2adminCustomerBG', 'Create', 1, 0); 
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____ 15. Return to the Business Integration perspective. Right-
click MonitorAdapter and select New ► Enterprise 
Service Discovery. 

Figure 18. New ► Enterprise Service Discovery 
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____ 16. Select JDBC EMD Adapter… and click Next. 
 

 
Figure 19. JDBC EMD Adapter selection 
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____ 17. Specify the following properties: 
• Username and password: your DB2 user name and 

password 
• Database URL: jdbc:db2://<Machine 

IP>:50000/ADAPTER 
• Jdbc Driver Class: com.ibm.db2.jcc.DB2Driver 

 
Figure 20.  Configure Settings for Discovery Agent 
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____ 18. Click Next, then click Execute Query to find the table 

lists. Select DB2ADMIN►Tables► CUSTOMER and 
click Add to import list. Click Next. 

Figure 21. DB2ADMIN ► Tables ► CUSTOMER selection 
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____ 19. Ensure that the value for Service Type is Inbound. Click 
Next. 

 

Figure 22. The value for Service Type is Inbound 
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____ 20. In the Generate Artifacts window, enter the following 
values: 

__ a. J2C Authentication Data Entry: 
NodeName/JDBCAdapter/inbound 

… where NodeName is the node name of the 
WebSphere Application Server server that will run 
this MonitorAdapter module. 

Figure 23. The Generate Artifacts window 
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__ b. Database Vendor: DB2. 

Figure 24. The Database Vendor field 
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____ 21. Click Finish. Double-click Assembly Diagram. You will 
see that there are two elements: JDBCInboundInterface, 
which was created by the preceding steps, and Mediation1, 
which was created when the module was initially created. 

Figure 25. Double-click Assembly Diagram 
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____ 22. For ease of use, rename Mediation1 to MediationFilter.

  

Figure 26. Rename Mediation1 to MediationFilter 
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____ 23. In the diagram, link JDBCInboundInterface to 

MediationFilter. In response to the prompt, click OK. 

Figure 27. Link JDBCInboundInterface to MediationFilter 

 

 
____ 24. Right-click MediationFilter and select Generate 

Implementation. 

Figure 28. Select Generate Implementation 
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 ____ 25. Select MonitorAdapter as the folder. Click OK. 

Figure 29. MonitorAdapter selected as the folder 
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____ 26. In the MediationFilter window, click 

createDb2adminCustomer. 

Figure 30. Click createDb2adminCustomer 
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____ 27. Select the EventEmitter primitive and click in the white 
space to add it into the flow. EventEmitter sends events to 
the Common Event Infrastructure. 

Figure 31. Click in the white space to add the EventEmitter primitive into the flow 
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____ 28. To configure EventEmitter1, first click EventEmitter1, 
and then access the Properties view and specify the 
following values:  

___ a. Select Description, and then change the 
Display name value to EE_BeforeFilter.  

___ b. Select Details, and then change the Label value 
to 
MonitorAdapter_MediationFilter_Req_Befo
re. 

___ c. Set the Root value to /body. 

Figure 32. Click EventEmitter1, then access the Properties view 
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 ____ 29. Add the Message Filter primitive to the flow, and then 

change the Display name value to GoldFilter. 

Figure 33. Adding the Message Filter primitive to the flow 
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____ 30. Link the Input out terminal with EE_BeforeFilter in 
terminal; link EE_BeforeFilter out terminal with 
GoldFilter in terminal. Right-click GoldFilter and select 
Add Output Terminal. 

Figure 34. Add Output Terminal selection 
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 ____ 31. Change the new terminal name to Gold. Click OK. 
Figure 35. Change the new terminal name to Gold. 
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____ 32. Click GoldFilter. In the Properties view, click Details and 
then click Add. 

Figure 36. Click Details and then click Add 
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 ____ 33. Click Custom XPath. 

Figure 37. Click Custom XPath 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

____ 34. Set the XPath expression as follows: 
___ a. In the Schema Viewer, select body ► 

createDb2adminCustomer : … ► 
createDb2adminCustomerInput : … ► 
Db2adminCustomer : … 

___ b. For the Location value for Condition, click 
Location and select ccode. 

___ c. For the Condition value, enter Gold and make 
sure to enclose the text in double quotation 
marks. 
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 ___ d. Click OK, and then click Finish. 

Figure 38. Click OK, then click Finish 

 

 

 

 

 

 

 

 

____ 35. Add another Event Emitter primitive to the flow. 
___ a. Change the Display name to EE_AfterFilter. 
___ b. Change Label to 

MonitorAdapter_MediationFilter_Req_Afte
r. 
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 ___ c. Set Root as /body. 

Figure 39. Root is set as /body 

 

 

 

 

 

 

 

 

 

____ 36. Add two Stop primitives to the flow. 
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____ 37. Link the GoldFilter default terminal with Stop1, link the 
GoldFilter Gold terminal with EE_AfterFilter, and link 
EE_AfterFilter out terminal with Stop2. As a result, the 
Gold customer will pass through the filter and be sent as 
another Common Base Event; the other customer will stop 
at filter. 

Figure 40. The Gold customer will pass through the filter 
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____ 38. Save the Mediation and then click Assembly Diagram: 
MonitorAdapter. 

____ 39. Click MediationFilter and in the Properties view select 
Details. Go to Interfaces ► JDBCInboundInterface ► 
createDb2adminCustomer ► Event Monitor, select All 
for Monitor and select Full for EventContent. 

Figure 41. Click MediationFilter and in the Properties view select Details 
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____ 40. Save the assembly diagram. 
____ 41. In the menu bar, click Project ► Clean…. In response to 

the prompt, click OK. 

Figure 42. In response, click OK 

 

 

 

____ 42. In the menu bar, click File ► Export….  
____ 43. Select EAR file as the export destination. 
____ 44. In the EAR Export window, select MonitorAdapterApp 

as EAR project and set the destination for the EAR file. 
Click Finish.

Figure 43. Select MonitorAdapterApp as EAR project 

 ____ 45. You have now finished the task of creating the EAR file for 
future deployment into WebSphere Process Server. 
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Part 2: Generating a monitor model from SCA and Mediation 
 
You will use the Monitor Model Editor in WebSphere Integration 
Developer to create a monitor model. 
 
____ 1. Right-click Assembly Diagram and select Monitor Tools 

► Generate Event Definitions. 
 

Figure 44. Select Monitor Tools ► Generate Event Definitions 
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____ 2. Right-click MediationFilter and select Monitor Tools ► 

Generate Event Definitions. 
 

Figure 45. Select Monitor Tools ► Generate Event Definitions 
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____ 3. Right-click Assembly Diagram and select Monitor Tools 

► Generate Monitor Model. 
Figure 46. Select Monitor Tools ► Generate Monitor Model 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
____ 4. In the pop-up menu, click New project.  
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____ 5. For the name of the new business monitoring project, type 
MonitorAdapterBM. Click Finish. 

Figure 47. Type the name of the new business monitoring project 

 
 
 
 

____ 6. For the name of the monitor model name, type 
MonitorAdapterMM. Click Finish. 

 
Figure 48. Type the monitor model name 
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____ 7. In response to the prompt, click Yes to switch to switch to 
the Business Monitoring perspective.  

Figure 49. Switch to switch to the Business Monitoring perspective 

 
 
 

____ 8. A seed monitor model is generated, and will be augmented 
in the following steps. 

Figure 50. Generate a seed monitor model  
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____ 9. Right-click MonitorAdapterMM MC and select New ► 

Inbound Event. 
 

 
Figure 51. Select New ► Inbound Event 
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____ 10. In the Name field, type EM BeforeFilter Data. Click OK. 

Figure 52. Type EM BeforeFilter Data in the Name field 

 
 
 
 
 
 
 
 

____ 11. On the right panel, click Inbound Event Details, and then 
click Browse… to select a value for the Type property.  

____ 12. Select MonitorAdapter ► events ► 
MonitorAdapter_MediationFilter_Req_Before_Mon…  
► MonitorAdapter_MediationFilter_Req_Before. Click 
OK. 

Figure 53. Select MonitorAdapter_MediationFilter_Req_Before 
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____ 13. The EM BeforeFilter Data inbound event will now 
represent the Common Base Event before the filter in 
mediation flow. 

 
Figure 54. The inbound event will now represent the Common Base Event 
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Figure 55. Set the Correlation 
Expression 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
____ 14. Continue working with the EM BeforeFilter Data event.  

___ a. Scroll down the right panel. 
___ b. Set Correlation Expression using one of the 

following methods: 
i. Enter the following expression directly:  

EM_BeforeFilter_Data/property
Data/WBISESSION_ID = 
MonitorAdapterMM_Key 

ii. Press Ctrl+Spacebar to use the 
content assist function. 
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___ c. For If one instance is found, select Deliver to 
the instance. 

___ d. For If multiple instances are found, select 
Treat as error.

Figure 56. Setting the Correlation Expression 

 
 

 

 

 

 

 

 

 

 

 

 

 

____ 15. Similarly, add an EM AfterFilter Data inbound event to 
represent the Common Base Event after the filter in the 
mediation flow.  

___ a. Right-click MonitorAdapterMM MC and 
select New ► Inbound Event. 

___ b. For Name, type EM AfterFilter Data. 
___ c. Select MonitorAdapter ► events ► 

MonitorAdapter_MediationFilter_Req_Afte
r_Mon… ►  
MonitorAdapter_MediationFilter_Req_Afte
r as event type. 

___ d. For Correlation Expression enter this value: 
EM_AfterFilter_Data/propertyData/WBISE
SSION_ID = MonitorAdapterMM_Key 

___ e. For If one instance is found, select Deliver to 
the instance. 

___ f. For If multiple instances are found, select 
Treat as error. 
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____ 16. Right-click MonitorAdapterMM MC and select New ► 
Trigger.

Figure 57. Select New ► Trigger 
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Figure 58. Type JDBCInbound Entry 
Trigger 

 
 
 
 
 
 
 
 
 
 
 

 
____ 17. For Name, type JDBCInbound Entry Trigger. 
 

 
____ 18. On the right panel, click Add to select 

MediationFilter.JDBCInboundInterface.createDb2admi
nCustomer ENTRY as the source event of trigger.

Figure 59. On the right panel, click Add 
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____ 19. Similarly, add trigger BeforeFilter Trigger with source 
event EM BeforeFilter Data. 

____ 20. Add trigger AfterFilter Trigger with source event EM 
AfterFilter Data.   

____ 21. Add trigger MonitorAdapterMM Termination Trigger 
with source event 
MediationFilter.JDBCInboundInterface.createDb2admi
nCustomer EXIT.  
 
Note: Select the Terminate monitoring context check 
box. This will cause the current monitor context instance to 
be terminated when the EXIT event occurs. 

Figure 60. Select the Terminate monitoring context check box 
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____ 22. Right-click MonitorAdapterMM MC and select New ► 
Metric. 

Figure 61. Select New ► Metric 

 
 ____ 23. For Name, type FName Metric. Click OK.
Figure 62. For Name, type FName Metric 
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____ 24. On the right panel, click Add under Metric Value Maps. 
____ 25. Click in the space under Trigger. Click the button that is 

displayed and select JDBCInbound Entry Trigger. Then 
click OK. 

Figure 63. Select JDBCInbound Entry Trigger 
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____ 26. Click in the space under Expression. Click the button that 
is displayed. In the Expression window, press 
Ctrl+Spacebar to use the content assist function to select 
MonitorAdapterMM ► MonitorAdapterMM MC ► 
MediationFilter.JDBCInboundInterface.createDb2admi
nCustomer ENTRY ► Extended Data ► Argument 0 
► Db2adminCustomer ► fname. 

Figure 64. Press Ctrl+Spacebar to use the content assist function 
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____ 27. Click OK. The FName Metric is finished and will be 

assigned the fname value. 

Figure 65. The FName Metric will be assigned the fname value 
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____ 28. Similarly, add LName Metric with JDBCInbound Entry 
Trigger and expression : 
 
MediationFilter.JDBCInboundInterface.createD
b2adminCustomer_ENTRY/extendedData/'Argument 
0'/Db2adminCustomer/lname. 
 

____ 29. Add CCode Metric with JDBCInbound Entry Trigger 
and expression: 

  
MediationFilter.JDBCInboundInterface.createD
b2adminCustomer_ENTRY/extendedData/'Argument 
0'/Db2adminCustomer/ccode. 
 

____ 30. Add Is Gold Customer Metric. 
___ a. On the right panel, change Type to Boolean. 
___ b. Add the following triggers: 

• BeforeFilter Trigger with Expression set 
to false() 

• AfterFilter Trigger with Expression set to 
true()  

 
Figure 66. Add Is Gold Customer Metric
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____ 31. Switch to the Data Mart Model panel by clicking Data 
Mart Model in the bottom of MonitorAdapterMM view.

Figure 67. Switch to the Data Mart Model 
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____ 32. Select MonitorAdapterMM MC Cube in the Dimensions 
view. Click Add Dimension… and type CCode 
Dimension as the name. Click OK. 

Figure 68. Click Add Dimension… 

 

 
 
 
 
 

____ 33. Click Add Attribute… button and type CCode Dimension 
Attribute as the name. 

____ 34. Click in the space on the right of CCode Dimension 
Attribute. Click the button that is displayed and select 
CCode Metric. Click OK. 

Figure 69. CCode Metric selection 
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____ 35.  Scroll down to the Measures.  
___ a. Click MonitorAdapterMM MC Cube  
___ b. Click Add Measure…. 
___ c. Set FName Count Measure as name. 
___ d. Click in the space on the right of FName Count 

Measure. Click the button that is displayed and 
select FName Metric Fact. 

___ e. From the Aggregation Function menu, select 
Count. 

Figure 70. Select Count  from the Aggregation Function menu 

 
 

 

 

 

 
 
 
 
 
 
 
 
 
 



Generate MM to monitor data from an adapter 70 

 
 
 
 

____ 36. Press Ctrl+S to save the monitor model. 
____ 37. Right-click MonitorAdapterMM and select Generate 

Monitor EAR. 

Figure 71. Generate Monitor EAR selection 
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 ____ 38. In the window that is displayed, accept the default setting 
and click Finish. 

Figure 72. Accept the default setting and click Finish 
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____ 39. Go to the J2EE perspective. 
____ 40. If Build Automatically is turned off, select and build the 

EJB project – MonitorAdapterMMEJB. 
____ 41. Right-click the EJB project MonitorAdapterMMEJB and 

select Deploy. 

 

Figure 73. Right-click the EJB project MonitorAdapterMMEJB 
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____ 42. If Build Automatically is turned off, select and build the 
EAR project – MonitorAdapterMMEAR. 

____ 43. Right-click Enterprise Applications ►  
MonitorAdapterMMEAR and select Export… ► EAR 
file. 

Figure 74. Select Export… ► EAR file 
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 ____ 44. Set the destination file name. Click Finish. 

Figure 75. Set the destination file name 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

____ 45. You now have a monitor model EAR file, which will be 
deployed in monitor server later. 
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Figure 76. Click Security ► Global 
Security 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Part 3: Deploying the Adapter and Mediation Application  
 
 

In this section you will use the WebSphere Process Server 
administrative console to install the EAR file that was created in 
Part1. To deploy this EAR file, you will use the same WebSphere 
Process Server that the WebSphere Business Monitor server resides 
in. 
____ 1. Start the Monitor server, and then bring up the 

administrative console. 
___ a. In Windows, click Start ► All Programs ► IBM 

WebSphere ► Process Server 6.0 ► Profiles ► 
wbmonitor ► Start the server. 

___ b. In Windows, click Start ► All Programs ► IBM 
WebSphere ► Process Server 6.0 ► Profiles ► 
wbmonitor ► Administrative console. 

____ 2. Click Log in to login. 
____ 3. From the left menu, click Security ► Global Security. 
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Figure 77. Authentication ►JAAS 
Configuration ►J2C Authentication 
Data 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 78. General Properties 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
____ 4. Click Authentication ►JAAS Configuration ►J2C 

Authentication Data. 
 

 
____ 5. Click New and enter the following information: 

___ a. Alias: JDBCAdapter/inbound (This should be 
consistent with the value set in Part 1: Creating a 
module containing the JDBC adapter and mediation flow 
and must not contain the node name.) 

___ b. User ID: db2admin 
___ c. Password: the password for db2admin 

 

 
 
____ 6. Click Apply. 
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Figure 79. Click Save when you 
receive this message 

 
 
 
 
 
 
 
 
Figure 80. Click Save when you 
receive this message 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
____ 7. When you see the following message, click Save. 
 

 
 

____ 8. When the next window is displayed, click Save again. 
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____ 9. Verify that the list includes the new entry. The alias name 

for the entry starts with the node name followed by a 
forward slash (such as Node01/), and the complete alias 
name matches the value set in Part 1: Creating a module 
containing the JDBC adapter and mediation flow. 

 
Figure 81. Verify that the list includes the new entry 
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____ 10. From the left menu of administrative console, click 
Applications ► Enterprise Applications. 

 
 
Figure 82. Click Applications ► Enterprise Applications 
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____ 11. Click Install button. 
____ 12. Browse to the MonitorAdapterApp.ear file, which was 

exported into WebSphere Integration Developer in Part 2: 
Generating a monitor model from SCA and Mediation, and click 
Next. 

 
Figure 83. Browse to the MonitorAdapterApp.ear file 
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____ 13. Click Next. 

Figure 84.  The subsequent screen appears 
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____ 14. To install the new application using the defaults, click Step 
9 Summary. 

Figure 85. Click Step 9 Summary to install the new application 
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____ 15. Click Finish. 
 

Figure 86. Click Finish 
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____ 16. Click Save to Master Configuration. 
 

Figure 87. Save to Master Configuration 
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Figure 88. Click Save 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
____ 17. When the following message is displayed, click Save. 
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____ 18. From the left menu on the welcome page, click 
Applications ► Enterprise Applications. The list should 
include the newly installed MonitorAdapterApp 
application. 

 
Figure 89.  See MonitorAdapterApp application 
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____ 19. To start the application, select the MonitorAdapterApp 
check box and click Start.  

Figure 90. Select the MonitorAdapterApp check box 
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____ 20. If the application does not start, check whether the IP 
address for the server where the database resides was 
changed. This problem should not occur if you followed the 
example provided by this document and used localhost, as 
the IP address for the database. But if your database is 
remote and requires a different IP address from the one 
used in Part 1: Creating a module containing the JDBC adapter 
and mediation flow, follow these steps to configure the IP 
address: 

___ a. In the administrative console, select Applications ► 
Enterprise Applications ► MonitorAdapterApp 
► Connector Modules ► CWYBC_JDBC.rar ► 
Resource Adapter ► J2C Activation specifications 
► MonitorAdapter.JDBCInboundInterface_AS ► 
J2C activation specification custom properties. 

Figure 91. Select Applications ► Enterprise Applications 

 
 
 
 
 
 
 
 
 
 
 
 

___ b. Click the arrow to proceed to Page 2. 
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___ c. Click databaseURL, and then change the IP address 
for the database. 

 
Figure 92. Click databaseURL 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ d. Then click OK, Save, and Save to finish the 

configuration. 
____ 21. To verify that the application works correctly, open a DB2 

command window. Then run the following commands: 
___ a. db2 connect to ADAPTER user db2admin using 

<db2admin password> 
___ b. db2 insert into customer values ('1', 'Yi', 'Che', 

'Regular') 
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____ 22. From the left menu of the administrative console, click 
Integration Application►Common Base Event Browser 
and wait briefly for the Common Base Event browser to be 
initialized. 

 
Figure 93. Click Integration Application ► Common Base Event Browser 
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____ 23. From the left menu of the Common Base Event browser, 
click All Events. The list should include the events related 
to the record that you just inserted. 

Figure 94. Click All Events 
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____ 24. To add a Gold customer, open a DB2 command window. 
Then run the following commands: 

 
___ a. db2 insert into customer values ('2', 'James', 'Bond', 

'Gold') 
___ b. db2 disconnect ADAPTER 

 
____ 25. From the top menu of Common Base Event browser, click 

Get Events. Wait briefly for the browser to be updated. 

Figure 95. Click Get Events 
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____ 26. Click All Events again. The list should include the 
MonitorAdapter_MediationFilter_Req_After event that 
demonstrates that the filter works well and recognizes the 
Gold customer. 

   
Figure 96. Click All Events, again 
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Part 4: Deploying the monitor model 
 
In this section you will use the WebSphere Process Server 
administrative console to perform the life-cycle steps to deploy the 
monitor model. 
 
 
____ 1. Install the monitor model. 

___ a. In the administrative console menu, select 
Applications ► Monitor Models. 

___ b. Click Install. 
 

Figure 97. Select Applications ► Monitor Models 
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___ c. Browse to MonitorAdapterMM.ear.  This is the 
EAR file that you created in WebSphere Integration 
Developer.   

___ d. Click Next. 
 

Figure 98. Browse to MonitorAdapterMM.ear 
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___ e. Click Next. 

Figure 99. Click Next on this screen 
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 ___ f. Click Continue. 
Figure 100. Click Continue on this screen 
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 ___ g. To install the application using the defaults, click 
Step 11: Summary. 

Figure 101. Click Step 11 Summary 
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 ___ h. Click Finish. 
Figure 102. Click Finish 
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 ___ i. Click Save to Master Configuration.  
Figure 103. Click Save to Master Configuration 

 
 

___ j. Then, click Save.again. 
 

Figure 104. Click Save 
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____ 2. Run step 1 of the model life cycle. 

___ a. In the administrative console menu, select 
Applications ► Monitor Models. 

___ b. Click the timestamp value that is listed in the 
Version column. 

Figure 105. Click the timestamp value 
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___ c. Click Setup Wizard. 

Figure 106. Click Setup Wizard 
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___ d. Enter the name of the output directory, such as 
C:\MonitorAdapter.  When you run the data services 
generation, the schemagen folder will be created in 
the specified output directory. 

___ e. Change the Database population interval value to 1.  
For development purposes, replication should run 
often so that you do not have to wait to see the 
updates in the DATAMART database.   
Note: This interval number represents minutes. 

___ f. Click Run. 

Figure 107. Enter the name of the output directory 
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 ___ g. Click Next. 
Figure 108. Click Next when this screen appears  
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____ 3. Run Step 2: Run Schema Create Scripts and Step 3: Run 
DMS Create Scripts of the model life cycle. 

Figure 109. Run Step 2 and Step 3 
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___ a. In Windows File Explorer, browse to 
C:\MonitorAdapter\schemagen\<timestamp>. 

 
 

Figure 110. Browse to C:\MonitorAdapter\schemagen\<timestamp> 
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 ___ b. Extract the DS_DMS_setup.zip file into this same 
folder. 

Figure 111. Extract the DS_DMS_setup.zip file 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ c. Open a DB2 command window: 
(1) Select Start ► Run. 
(2) Enter the db2cmd command.  

___ d. To create the tables for the monitor model, enter the 
following commands in the DB2 command window. 
Note:  Monitor and state are used interchangeably.  
The database is defined as MONITOR, but you will 
see references to state such as state.ddl, state.log, 
and state_to_datamart_setup_source.bat, for 
example. 

(1) cd \MonitorAdapter\schemagen\<timestamp> 
(2) db2 connect to MONITOR 
(3) db2 –tvf state.ddl > state.log 
(4) db2 disconnect MONITOR 
(5) db2 connect to DATAMART 
(6) db2 –tvf datamart.ddl > datamart.log 
(7) db2 disconnect DATAMART 

___ e. Browse the newly created state.log and datamart.log 
files to verify that they are correct. 

___ f. Run the replication setup scripts. 
(1) In the same DB2 command window, you 

should still be in folder  
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\MonitorAdapter\schemagen\<timestamp
>, so type this command: 

State_to_Datamart_setup_source.bat 
 

(2) Each time that you are prompted to enter a 
user ID, press Enter. 

(3) Browse the newly created 
State_to_datamart_setup_source.log file to 
check for errors. 

(4) In the same DB2 command window, you 
should still be in folder 
\MonitorAdapter\schemagen\<timestamp>, 
so type this command: 

State_to_Datamart_setup_target.bat 
(5) Each time that you are prompted to enter a 

user ID, press Enter. 
(6) Browse the newly created 

State_to_datamart_setup_target.log file to 
check for errors. 

(7) If any errors occurred, run the scripts again. 
They should succeed after this second 
attempt. 

___ g. Start the replication daemons. 
(1) In the same DB2 command window, you 

should still be in folder 
\MonitorAdapter\schemagen\<timestamp>, 
so type this command: 

cd State_to_Datamart\source 
(2) Find all scripts starting with the prefix 

StartCapture, and run them.  (For this scenario 
there will be only one.)  For example, type the 
following command: 

StartCapture_5.bat 
(3) A new window is opened to display the status 

of the scripts as they are run. Leave this 
window open. Do not enter any commands in 
this window. 

Figure 112. Status of the scripts as they are run 
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(4) In the DB2 command window, type this 
command: 

cd ..\target 
(5) Find all scripts starting with the prefix 

StartApply, and run them.  (For this scenario 
there will be only one.)  For example, type the 
following command: 

StartApply_10.bat 
(6) A new window is opened to display the status 

of the scripts as they are run. Leave this 
window open. Do not enter any commands in 
this window. (Three command windows are 
now open.) 

 

Figure 113. Status of the scripts as they are run 
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___ h. Close the original DB2 command window where you 
have been typing the commands. 

___ i. In the administrative console, click Refresh.  
___ j. When the window indicates that step 2 is complete, 

click Next to proceed to step 3.  
___ k. Click Confirm. 

Figure 114. Click Confirm when this window appears 
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 ____ 4. Run Step 4 of the model life cycle. 
___ a. Click Step 4. 

Figure 115. Run Step 4 

 
 
 
 
 
 

 

___ b. Open a DB2 command window: 
(1) Select Start ► Run. 
(2) Enter the db2cmd command.  
(3) Click OK. 

___ c. Import the cubes into DB2 OLAP. 
 

(1) cd \MonitorAdapter\schemagen\<timestamp> 
(2) db2mdapiclient -d datamart -i import_model.xml -

o response_model_cv.xml -m model_cv.xml
Figure 116. The DB2 command window 
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___ d. If an error occurs when the cubes are being 
imported, follow these steps to format the database 
for OLAP. Here is a sample of the error:

Figure 117. Sample error when cubes are being imported 
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(1) cd %DB2 Home%\SQLLIB\MISC 
(2) db2 connect to datamart 
(3) db2 -tvf db2mdapi.sql 
(4) db2 disconnect datamart 
(5) Repeat step c to import the cubes to DB2 OLAP 

again. 
___ e. After the cubes are imported, return to the 

administrative console and verify that you are in 
step 4 of the model life cycle. 

___ f. Click Confirm. 

Figure 118. Click Confirm in the administrative console 

 ____ 5. Run step 5 of the model life cycle. 
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 ___ a. Click Step 5: Manage Alphablox Cube. 
Figure 119. Click Step 5: Manage Alphablox Cube 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ b. Start WebSphere Portal Server. 
(1) In Windows, select Start ► All Programs ► 

IBM WebSphere ► Portal Server v5.1 ► Start 
the server. 

___ c. Find the Portal RMI port in the Portal log. 
(1) Browse the Portal log, for example, 

C:\IBM\PortalServer\log\SystemOut.log. 
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(2) Search for RMI Connector. For example, in the 
following screen capture you see that Portal RMI 
is port 2810.

Figure 120. Search for RMI Connector 

 
 
 
 
 

___ d. In the administrative console, in step 5 of the model 
life cycle, enter localhost for Host name. 

___ e. Enter your RMI port value that you found in the 
Portal log. 

___ f. Click Create.
Figure 121. Enter your RMI port value 
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If an error message indicates that there is a connection problem, you 
might need to correct the Portal configuration.  Go to Appendix B. 
Workaround for Step 5: Manage the DB2 Alphablox® cube now and 
follow the steps there as a workaround for this problem.  After 
completing the workaround, return here and proceed with the next 
step.  Here is a sample of the error:

Figure 122. Error message indicating a connection problem 
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 ____ 6. Run step 6 of the model life cycle. 
___ a. Click Step 6: Configure CEI Distribution. 

Figure 123. Run Step 6 of the model life cycle 

 
 
 
 
 

___ b. Click Apply. 
____ 7. Run Step 7: of the model life cycle. 

___ a. Click Step 7: Confirn CEI Server Reboot . 
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___ b. Confirm that the Confirm button on the window for 
step 7 is enabled.  If it is not, wait a few minutes, 
and then refresh the window.  When the Confirm 
button is enabled, continue with the following steps. 

___ c. In the navigation pane for the administrative 
console, select System administration ► Save 
Changes to Master Repository, then click Save. 

___ d. Recycle WebSphere Process Server. 
(1) In Windows, select Start ► All Programs ► 

IBM WebSphere ► Process Server 6.0 ► 
Profiles ► wbmonitor ► Stop the server. 

(2) In Windows, select Start ► All Programs ► 
IBM WebSphere ► Process Server 6.0 ► 
Profiles ► wbmonitor ► Start the server. 

___ e. Re-open the administrative console for WebSphere 
Process Server. 

___ f. In the administrative console menu, click 
Applications ► Monitor Models. 

___ g. Click the timestamp value in the Version column. 
___ h. Click Setup Wizard. The administrative console 

should detect that Step 6 is complete and 
automatically move to Step 7 as follows:

Figure 124. Run Step 7 of the model life cycle 

 
 
 

___ i. Click Confirm. 
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___ j. Click Finish to return to the Monitor Models window.

Figure 125. The Startable column for the model with red indicator 

 
 

 
 
 
 

____ 8. If the Startable column for the model shows a red circle, it 
is stopped, Wait a moment, then click Applications ► 
Monitor Models.  The Startable column for the model 
should now show a green check mark. If this column does 
not show a green check mark, be patient and continue 
refreshing until it does.

Figure 126. The Startable column for the model with green indicator 
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Part 5: Processing events to exercise the model 
As at the end of Part 3, you will now run some events to verify that 
the monitor model works correctly.  
____ 1. Open a DB2 command window. Then run the following 

commands: 

___ a. db2 connect to ADAPTER user db2admin 
using <db2admin password> 

___ b. db2 insert into customer values ('3', 
'Michael', 'Davis', 'Regular') 

___ c. db2 insert into customer values ('4', 
'Paul', 'Smith', 'Silver') 

___ d. db2 insert into customer values ('5', 
'Joe', 'Williams', 'Gold') 

___ e. db2 insert into customer values ('6', 
'Daniel', 'Johnson', 'Regular') 

___ f. db2 insert into customer values ('7', 
'Tim', 'Ross', 'Gold') 

___ g. db2 disconnect ADAPTER 

____ 2. Wait briefly so that the monitor model can process the 
events. 

____ 3. To verify that the monitor model is processing these events 
properly, open the DB2 Control Center.  In Windows, 
select Start ► All Programs ► IBM DB2 ► General 
Administrative Tools ► Control Center. 

___ a. In the MONITOR database, open table 
CTX_MONITORADAPTERMM_MC.  You might see 
records as in this example.  Note, however, that the 
replication daemons are running. As a result, you 
might not see any records, because they have already 
been deleted and moved to the DATAMART database.  
In that case, proceed to the next step to check the 
DATAMART database. 

Figure 127. CTX_MONITORADAPTERMM_MC table In the MONITOR database 
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___ b. In the DATAMART database, open table 
FCT_MONITORADAPTERMM_MC.  You should 
see records as in this example.  If you do not see the 
records, you might have to wait a few minutes for the 
Replication Manager daemons to run.  In that case, 
wait a few minutes, and then click View ► Refresh in 
the Control Center. 

Figure 128. FCT_MONITORADAPTERMM_MC table In the MONITOR database 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ c. Close the DB2 Control Center. 
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Part 6: Creating a dashboard 
In this section you will build a dashboard in WebSphere Portal 
Server.  You will add portlets to the dashboard and configure them. 
 
 
____ 1. Make copies of the portlets that you want to use: Instances 

and Dimensional View.  
 
You should not configure the original portlets, because the 
configuration cannot be removed after it is applied.  So, you will 
first make copies of the portlets, and then you will configure the 
copies. 

___ a. Open the Portal page:  
http://localhost:9081/wps/portal. 
 

___ b. Click Log in, and then enter your Portal 
administrative user ID and password (commonly 
wpsadmin and wpsadmin). 
 

Figure 129. Log in, then enter your Portal administrative user ID and password 

 
 



Generate MM to monitor data from an adapter 123 

 
 
 

____ 2. Create copies of the WebSphere Business Monitor portlets. 
___ a. Click Administration at the top of the page, and 

then click Portlet Management ► Portlets. 
Figure 130. Click Portlet Management ► Portlets 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ b. Browse to page 10 by clicking the right-arrow icon, 
or by entering the page number in the ‘Jump to 
page’ field and then clicking the arrow icon to its 
right.  This page should show the portlets for 
Dimensional View and Instances. 
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___ c. On the row containing Dimensional View, click the 
Copy portlet icon.  In the next window, enter 
MonitorAdapter_Dimensional as the new name of 
the portlet and click OK. 

Figure 131. Enter MonitorAdapter_Dimensional as the new name 
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___ d. Similarly, on the row containing Instances, click 
the Copy portlet icon.  In the next window, enter 
MonitorAdapter_Instances as the new name of the 
portlet and click OK. 

Figure 132. Enter MonitorAdapter_Instances as the new name 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ e. Now browse to page 11 by clicking the arrow icons.  

This page should show the portlet KPI View plus 
the copies of the portlets for Dimensional and 
Instances. 
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____ 3. Create a page containing the views: Instances and 
Dimensional 

___ a. Click Administration at the top of the page, 
and then click Portal User Interface ► 
Manage Pages. 

Figure 133. Click Portal User Interface ► Manage Pages 
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___ b. Click My Portal, and then click New Page.  
Enter MonitorAdapter as the page title.  Under 
Type of Page, click the leftmost radio button on 
the far left to select one-column layout. 

Figure 134. Click the leftmost radio button to select one-column layout 
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___ c. Click OK, and then click OK again.  Now you 
should see the new page in the list as follows:

Figure 135. See the new page in the list 
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___ d. To edit the Dashboard page, click the Edit 

Page Layout icon on the right side of the 
row for Dashboard.  

Figure 136. Click the Edit Page Layout icon 
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___ e. Click Add portlets. Navigate to the last page of 
the list to locate the 
MonitorAdapter_Dimensional and 
MonitorAdapter_Instances porlets, and select 
both of them.

Figure 137. Navigate to the last page of the list to select both porlets 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ f. Click OK. 
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___ g. In the next window, confirm that the views 
have been added to the page.

Figure 138.. Confirm that the views have been added 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ h. Click Done. 
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___ i. Click My Portal at the top of the page.  In the 
new window, confirm that there is now a tab for 
MonitorAdapter. 

 

Figure 139. Confirm that there is now a tab 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
____ 4. Configure the views on your new page. 

___ a. Click the tab for MonitorAdapter. 
 
___ b. Click the configure icon on the 

MonitorAdapter_Dimensional view.  
___ c. For Model, select MonitorAdapterMM. 
___ d. For Subject area, select 

MONITORADAPTERMM MC CUBE 
<timestamp>. 

___ e. In Available dimensions, select Measures, then 
next to Column dimensions, click Add. 
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___ f. In Available dimensions, select CCode 
Dimension, then next to Row dimensions, click 
Add.  

___ g. Confirm that the window looks like the 
following example.

Figure 140. The window should look like this example 

 
 ___ h. Click Next. 
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 ___ i. Right-click InstancesCount and select 
Member Filter....

Figure 141. Select Member Filter.... 

 



Generate MM to monitor data from an adapter 135 

 
 
 
 
 
 

___ j. In the Member Filter window, select FName 
Count Measure as in the following example. 
Then click OK.

Figure 142. Select FName Count Measure as in this example 
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 ___ k. Right-click all and select Drill Down.
Figure 143. Select Drill Down 
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___ l. Confirm that the view looks like the following 
example.

Figure 144. The window should look like this example 

 
 
 
 
 
 
 
 
 

___ m.  Click OK.  
___ n. Click the configure icon  for the 

MonitorAdapter_Instances view.  
___ o. For Monitor model, select 

MonitorAdapterMM. 
___ p. For Monitoring context, select 

MonitorAdapterMM MC. 
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___ q. Under Metrics, select the Select All check box, 
and then clear the MonitorAdapterMM Key 
check box under Metrics for administration. 

 
___ r. Click Next, then Next, then Next again, and 

then Finish.

Figure 145. Click Next, then Next, then Next again, then Finish 
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___ s. Confirm that the final view of MonitorAdapter 
looks like the following example.

Figure 146. The window should look like this example 
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What you accomplished in this exercise 
 
In this exercise, you created a J2EE application using WebSphere 
Integration Developer. In the application, JDBC adapter acts as an 
event resource to fetch data from a database and then send that data 
to mediation filter to distinguish gold customers from other 
customers.  
 
You then created a monitor model using the Monitor Model Editor 
and defined the metrics to monitor the data issued from JDBC 
adapter.  
 
You next deployed the application and monitor model to WebSphere 
Business Monitor. 
 
You used db2 commands to trigger the monitored application to 
submit events. 
 
Finally, you configured dashboards and viewed monitored data in 
several different views. 
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Appendix A. Import the J2EE application solution into WebSphere 
Integration Developer 
A solution has been provided so that you do not have to build the 
J2EE application from scratch.  This section shows you how to 
import the application into WebSphere Integration Developer.  After 
importing, you can proceed to generate the EAR file and deploy it. 
 
____ 1. Start WebSphere Integration Developer and set up the 

environment. 
___ a. Start WebSphere Integration Developer V 6.0.2, 

and when prompted, point to a new workspace, 
such as C:\workspaces\MonitorAdapter. 

___ b. Close the Welcome tab. 
___ c. Select Window ► Preferences ► Workbench 

► Capabilities.  Assure you have selected 
‘Advanced J2EE’. 

____ 2. Import the project interchange file MonitorAdapter.zip 
into WebSphere Integration Developer 6.0.2 as shown 
below.  Wait for the project to be built, which takes a few 
minutes. 

 

Figure 147. Import the project interchange file 
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Appendix B. Workaround for Step 5: Manage the DB2 Alphablox® 
cube 
If you receive a connection error while running step 5 of the life-
cycle steps, use this appendix to complete a workaround.  In this 
section you will manually import the cube into DB2 Alphablox, and 
then you will mark this step complete in the life cycle table. 
 
____ 1. Copy the cube name from OLAP Center. 

___ a. In Windows, select Start ► All Programs ► IBM 
DB2 ► Business Intelligence Tools ► OLAP 
Center. 

___ b. Enter your DB2 user ID and password. 
___ c. Confirm that the cube model is listed as in the 

following example.
Figure 148. Confirm that the cube model is listed 
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___ d. Right-click the cube model, then select Properties. 
___ e. Using the mouse, select the text in the Name field as 

shown in the following example.

Figure 149. Select the text in the Name field 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ f. Press Ctrl+C to copy the text to the clipboard. 
___ g. Click Cancel, and then close the OLAP Center. 

 
____ 2. Define the cube to Alphablox. 

___ a. If WebSphere Portal Server is not running, start it 
by clicking Start ► All Programs ► IBM 
WebSphere ► WebSphere Portal v5.1 ► Start 
the Server. 

___ b. To start Alphablox in a browser, click Start ► All 
Programs ► IBM DB2 Alphablox 8.4 ► 
AlphabloxAnalytics ► DB2 Alphablox 
Administrative Pages.   
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Note: If Windows blocks your attempt to access the page, an 
information bar at the top of the window displays the following 
message. Click this bar and select Allow Blocked Content to 
continue. 
 

Figure 150. Select Allow Blocked Content to continue 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ c. In response to the prompt, enter admin for the user 

ID and password for the password.   
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Confirm that the next window looks like the following 
example.

Figure 151. The window should look like this example 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ d. Click the Cubes tab at the top of the Alphablox 
window. Click Create.   
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 You should see a window like this:
Figure 152. The window should look like this example 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ e. Next to the DB2 Alphablox Cube Name field, 

select the Enabled check box. 
___ f. Press Ctrl+V to replace New Cube with the correct 

cube name. 
___ g.  For Relational Data Source, select DATAMART. 
___ h. Select the Enable DB2 Cube Views Settings check 

box. 
___ i. From the Cube Model list, select the model. Then 

click Import Cube Definition. 



Generate MM to monitor data from an adapter 147 

 
 

___ j. Confirm that the information in the window looks 
like the following example.

Figure 153. The window should look like this example 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ k. The DB2 Alphablox Cube Name must exactly 

match the Cube Model name, without the ‘WBI.’ 
prefix. 

___ l. Click OK to save the definition.   
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Confirm that it has been added to the list as follows:
Figure 154. Confirm that it has been added 
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___ m. Click the General tab at the top of the Alphablox 
window.  Then click Runtime Management ► 
DB2 Alphablox Cubes.

Figure 155. Click Runtime Management ► DB2 Alphablox Cubes 
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___ n. Select the cube in the list, and then click start.  The 
status of the cube should be running, as shown in 
the following example.

Figure 156. The status of the cube should be running as shown 
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____ 3. Update the life cycle for step 5. 
__ a. Find the ModelID value. 

1) In the administrative console, select 
Applications ► Monitor Models. 

2) The Model column lists the ModelID value. 
For example, in the following screen capture, 
the ModelID value is MonitorAdapterMM.

Figure 157. The ModelID value in this example is MonitorAdapterMM 
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__ b. Find the versionDate value. 
1) Browse the WebSphere Process Server log, for 

example, 
C:\wps602\profiles\wbmonitor\logs\server1\Sy
stemOut.log. 

2) Search for ‘ /ModelID version ’. In this 
example, you would search for 
/MonitorAdapterMM version. As shown in 
the following screen capture, the versionDate 
value is 1170240826. 

Figure 158. The versionDate value in this example is 1170240826 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___ c. Open a command prompt window 
1) In Windows, click Start > Run.  
2) Enter the cmd command. 
3) Click OK. 

___ d. Update the life cycle using an MBean method: 
1) cd 

%WAS_HOME%\profiles\wbmonitor\bin 
2) wsadmin 
3) set ls [$AdminControl 

completeObjectName 
type=LifecycleServices,*] 
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4) $AdminControl invoke $ls 
confirmCreateAlphabloxCube { 
"ModelID" versionDate "userID"} For 
example, $AdminControl invoke $ls 
confirmCreateAlphabloxCube { 
"MonitorAdapterMM" 1170240826 
"administrator"}( using ModelID and 
versionDate values that you found 
in the previous steps)

Figure 159. The window now indicates that step 5 complete  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
___ e. If the administrative console still displays step 5 of 

the life cycle, reload the page in the browser. The 
window should now indicate that step 5 is 
complete. 

___ f. Return to the instructions for the life-cycle steps, 
starting at step 6. 
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