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zCP3000 is a tool available to IBMers and entitled Business Partners to do performance analysis and capacity planning.
This document describes changes made in the November 2014 version of zCP3000, and how they can help the modeler
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evaluate the effect of configuration changes on sysplex performance.

There are several ways to evaluate the effect of configuration changes in zCP3000:

For that reason, if the primary purpose of the study is to look at CF link migration or CF Thin Interrupt dispatch mode,

In PA (Performance Analysis, yellow background), you can define alternate processors for each CPC and see the
difference from the current configuration, but you cannot move partitions or change any sysplex features (ie,
linktype).

In QM (Quick Migration, pink background), you can define alternate machine types, define a new CPC, move
partitions around, move CF structures, and you can change several sysplex features, but you cannot specify
growth over time, and you cannot move/split a z/OS workload to a different partition.

In CP (Capacity Planning, green background), you can define new CPCs and alternates, grow workload over time,
move partitions and move/split workloads, change the coupling link type, and move structures, however you
cannot change the CF dispatch mode, and the accuracy of the structure service time model decreases with each
change made, because it is no longer based on the original SMF metrics.

you should use QM (Quick Migration) mode (Figure 1. Go To QM Mode from the main zCP3000 window.).

Two key reports in QM mode that you will want to look at are the CFQ100 CF Migration Summary report, available from
the CF window, and the CFQL001 CF Link Migration Summary, available from the CF Link window. The CFQ100 report

has sections on the CF partition detail:

Sysplex ISPLEXP Coupling Facility PRODCF2

Configuration Before Migration

Configuration After Migration

CF Machine Type: 2097-710 2827-701
Lpar Utilization 16.5% 9.7%
Engines (1.0) ICF (1.0) ICF
Dynamic Dispatch Off (Polling) Thin Interrupt
Relative Share Dedicated Engines 90.0%
Effective #engines: 1.0 0.9
CFCC Busy 16.5% 10.7%

As well as partition information for all coupling facilities and members of the sysplex:

Sysplex ISPLEXP Configuration After Migration

CECID Model | Partition || SCP Level Ilgr?g:ﬁzls 5353;&6 Engine Type
PRODCF2| newCec |2827-701|PRODCF2| 16 1 90.0% ICF
PRODCF1|CPC7C8BS5| 2097-714 [PRODCF1| 16 1 D;%fﬁ;esd ICF
SYSA |CPC7C8BS5|2097-714| PROD1 || zv011100 | 10 61.0% GCP
SYSB |CPC7C8C5[2097-710| PROD2 | zvo11100 | 6 39.1% GCP



http://w3-03.ibm.com/support/americas/wsc/cpsproducts.html
https://www-304.ibm.com/partnerworld/wps/servlet/mem/ContentHandler/tech_PRS1762
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SYSY |[CPC7C8B5( 2097-714 | PROD3 || ZvV011100 5 33.9% GCP
SYSZ |[CPC7C8C5| 2097-710 | PROD4 [ ZVv011100 4 38.1% GCP

Along with before and after information about the coupling links:
Sysplex ISPLEXP Configuration After Migration

SYSID|Regs/sec[|CHPIDs|SubChannels:||Link Type:|[KM|Link Utilization
SYSA (20,465.4 2 14 IFB-12x | 0.0 3.6%
SYSB ||10,318.4 2 14 IFB-12x | 0.0 1.3%
SYSY [ 1,941.3 2 14 IFB-12x | 0.0 0.3%
SYSZ | 2,207.5 2 14 IFB-12x | 0.0 0.3%

And information about the effect of the migration on key structures on the CF:

Configuration Configuration
Before Migration | After Migration
Structures Type |[Duplexed?||Reqs/sec = =
Service Service
%Sync - %Sync .
Time Time

IMSP_VSAM CACH No 25,974.6] 100.0% 7.5 100.0%| 17.6
DSNPROB_GBP2 [[CACH Yes 2,528.7 || 98.3% 10.1 98.3% 22.3
IXCSTR4 LIST No 2,250.0 | 0.0% 28.8 0.0% 61.5
IXCSTR2 LIST No 1,488.0 || 0.0% 29.6 0.0% 61.7
DSNPROB_GBP8KO|CACH Yes 907.7 || 96.4% 13.9 96.4% 23.0

The CFQLO01 CF Link Migration Summary has similar, link-related information, but with service time information specific
to that link, not weighted over all links as in the CFQ100 report.
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Cookbook Steps for Sysplex Migration Analysis

So let’s get started: to get to QM mode from the main zCP3000 window, after loading EDF files or a 3PA input file, select
View->Go To Quick Migration.
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Figure 1. Go To QM Mode from the main zCP3000 window.

Remember, you can use menu option View->Sysplex Logical to view just the sysplex members and coupling facilities, or
you can see the connections highlighted by clicking on any CF or z/0S member of the sysplex (PROD1-4).
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Double click on a CF to see more detail. If SMF data was collected for that CF, you will see the CF Summary window. Click
on column headers to sort. Double click on a link or structure to see more detail about that. Click the Analysis button for
a list of graphs.

@ PRODCF2: Coupling Facility QM Summaryj§ ﬁﬂu

View Action Analysis
CF Name: PRODCF2
Sysplex Name:  ISPLEXP Peer Name: PRODCF1
CF Machine Type: 2087-710 CF Machine Type: 2097-714
CFlevel: 16 CFLevel: 16
Lpar Utilization 16.5% Storage Defined: 11,937 mb
Engines (1) ICF Dump Storage: 4 mb
Dynamic Dispatch Storage Available: 5,930 mb
Relative Share Dedicated Engines
EDF data missing for at least one sysplex member.

Partition SYSID: | Reqsisec |SubChann.| CF Links: | LinkType: Km |Link Uiiliza;] |
CPCFCBB..| SYSA 20,4654 14 2 ICB-4 0.0 1.7%]| ~ ||
CPC7C8C..| SYSB 10,3184 14 2 Ic 0.0 0.6%|_
CPC7CBB..| SYSY 1,9412 14 2 ICB-4 0.0 05%| |
CPC7CBC.| SYSZ 22075 14 2 Ic 0.0 0.2%|
 Study tervat[-2 5 100 |

Structure Type Size Reqgsisec * Duplexed?
IMSP_VSAM CACH 125 25,974 6 O] a
DSNPROB_GBP2 CACH 98 25287 v]

IXCSTR4 LIST 9 22500 ]
IXCSTR2 LIST 9 1488.0 ]
DSNPROB_GBPSKO CACH 55 907.7 [v]
more structures not shown
IMSE_V_RUUU .. LALH E- BV U0 :
RRS_RESTART_1 LIST 17| 04 ] =
43 Structures Totals 34,9326 6 duplexed ;1
| Cancel | | Apply |
WARMING: EDF data missing for at least one sysplex member. |

Figure 2. CF Summary Window.



Sysplex Migration Analysis using zCP3000

Change the machine type and coupling link type

When you move a coupling facility to a new machine, the service times to structures on that CF will be re-calculated,
because the engine speed of a zEC12 is faster than the old z10 machine type, and the request can be expected to
complete more quickly. Step one, add the new machine.

Add ¥ CPC

Rename | New Syg

-CPC7C8B5 add sy<| ' Add a CPC el 5] |

-F‘D1— -PD3— -F‘DG1— Add a Né Name |newCEC

Processor |232?-?ﬂ1 ‘ hd | ‘

r TESTGY ==y p TEST1 ===y p TEST3 =

Supervisor | ‘ |

r USTA1 ===y p PRODCF1 = p TESTCF1 = | Ok || Cancel | -
] N
A ||A = =

r USTACF1 = USTACF2

The new CPC will have an error flag on it, since it is empty. Step 2, click and hold PRODCF2 then drag and drop it onto
the new CPC, then do the same for TESTCF2. The process of moving will recalculate CF service times, so if you need to
undo this, use the Edit->Undo button, don’t just move it back (which would recalculate service times again, instead of
restoring them to what they were).

- CPCTCSCS F oWCEC The new CPC will still be marked in
s PROD2 == 1 PROD4 == £ PRODG2 = error because the definition needs
@ @ @ P A to change to accommodate the

’ . .
TEST2— [ TESTA— [ USTAG— , partitions that just moved there.
4 s Drag PRODCF2 and
/ TESTCF2 to newCEC newCec

P USTA2 === ¢ PRODCF2q p TESTCF2| RODCF2-||-TESTCF2-|
rUSTACF2=

Figure 4. CEC Definition needs to be fixed

on new CPC.
Figure 3. Error due to empty CPC

@ Configuration differences will cause CF request service times to be recalculated. Edit->Undo 1o réverse this change,

Figure 5. Service times are recalculated when you move the CF.
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Step 3, right click on an empty area of newCEC and select the “Definition” option to fix the CPC definition (Figure 6.
Partition definition for the new CPC). We need to change several things here:

e Define 1 physical ICF engine in the top half of the screen, then right click and apply that change to all intervals
(“All Field”).

e For PRODCF2, keep the one ICF engine, as it was on the 2097, but define the weight as 90. Right click and apply
that change to all intervals (“All Field”).

e For TESTCF2, keep the one ICF engine but define the weight as 10. Right click, “All Field”.

o Apply.

-
"# Define CPC newCec I @EIQ
File
Supervisor: I:D [] Zaap On Ziip
Interval Processor GCPs ZAAPS ZIPs ICEs IFLs PwrSav Change
4i1/13 10:00 2827-H20 1.0 0.0 0.0 C 1. nn [ ] =]
41113 11:00 2827-H20 1.0 0.0 0.0 | Field to End [] v
41113 12:00 2827-H20 1.0 0.0 0.0 0. Row to End L
41113 13:00 2827-H20 1.0 0.0 0.0 04 - L | =
41713 14:00 2827-H20 1.0 0.0 0.0 (e O
41113 15:00 2827-H20 1.0 0.0 0.0 0.1 All Row ] -
Mame CliPgm | Workload | Wkld Type | Type | Mo | Weight | Weight% | Cap | Abs Cap | MinCap | MaxCap
PRODCFZ |CFCC CFCC Default ICF 1.0 9 0.0%| [ ] 1252.8| 13920
TESTCF2 |CFCC CFCC Default ICF 1.0 10 0.0%| [ ] 139.2] 13920
‘ Cancel H Apply ‘

Figure 6. Partition definition for the new CPC

Step 4, upgrade the coupling links. The current z10 configuration uses ICB4 links, so once PRODCF2 was moved to a
ZEC12, those ICB4 links became invalid. The IC links are also invalid because the CF no longer resides on the same
machine with SYSB and SYSZ. When you upgrade the links, the service time for requests running over those links will be
recalculated. Double click an invalid link to see detail. In QM mode, you see both the original configuration, when
measurements were taken, as well as the configuration as it currently is in the model. When you click “Upgrade Link”,
the following things happen:



The “current” config fields will be enabled for changes to the linktype, chpids, and distance. Only linktypes valid
for the current configuration will be listed, so the ICB4 linktype will be dropped from the linktype drop down,
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and the first valid linktype will be selected.

A 3™ column, “Estimated” is added to the results area, which will show the estimated service time and request
rates for the linktype selected. “Average” service time is a weighted average of sync and async, which will be
affected not only by the service time change, but also by the percentage of requests running synchronously
(because a request running asynchronously *always* has a longer service time than the same request running

synchronously).

Unlike in CP mode, you will need to apply the linktype change before seeing a detail report on the change. The Analysis
button on the Edit CF Link Type window is enabled only when the current configuration is valid.

“# PRODCF2 : SYSA : Edit CF Link Type

= (S |

Analysis

Sysplex Name |SPLEXP Machine Type
SYSID |SYSA 2097-714
CF Name PRODCF2 2827-7101
CF Study Interval 2013-04-02 11:00:0...
r Link Configuration r Shared Links
Configuratio... Upgrade ® Chpids (' Adapters
Machine Type 2097-701 2827101
Link Type ICB-4 IFB-12x| w
. Shared-L Chpids SYSID
Minimum ad... 2 2 2 SYSA
Chpids 2 | 2}:|‘
Subchannels 14 14
Distance(km) 0.0 0.0|
Utilization Before Current Estimated
CF 16.5% 9.7% 9.7%
Sysid 60.3% 87.1% 60.3%
Subchannel 1.7% 2.0% 27%
Requesisisec Before Current Estimated
Sync 18,476.76 18,749.36 18,476.52
Async 1,988.67 1,716.07 1,988.91
Total 2046543 20,465.43 20,465.43
Service Time (usec Before Current Estimated
Sync 9.05 10.75 15.2
Async 3258 47.98 51.93
Average 11.33 13.87 1877
‘ Cancel ‘ ‘ Apply ‘

Step 5, repeat for all other invalid links. Until the new configuration is valid (including all links and the cec definitions),
several graphs on the CF window are disabled.
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Thin Interrupt Support

There are currently two reports (CF1027 and CF1028) available in CP mode that estimate service time for the current
machine and alternates if it were using shared engines and thin interrupt instead of dedicated engine(s). These reports
are available now also in QM mode, but additionally, you can actually change the dispatch mode in QM mode and
compare the estimated service time to the original configuration (before changing the machine type, link type, and
dispatch mode).

To see the effect of multiple changes compared with the original, measured configuration, you must use QM mode (pink
background), not CP mode (green background). Once the CF link and CEC definitions are valid, then you can change the
dispatch type to Thin Interrupt. To do this,

1. Make sure the CF is on Thin Interrupt capable hardware: zEC12 or zBC12 and above.

2. Make sure the LPAR definition for the CF partition does *not* specify dedicated engines. There does not actually
have to be another CF sharing the engines.

3. The coupling links do not have to be valid to change the dispatch mode, but you will not be able to see any
relevant reports showing the service time change until the configuration is valid. It does not matter what order
you make the changes in.

You must apply the change, and then use the CFQ100 CF Migration Summary report, available from the CF window, and
or the CFQLOO01 CF Link Migration Summary to compare the current configuration, with Thin Interrupt, to the original,
measured configuration (from PA mode).

References:

This document can be found, along with other cookbooks and technical documentation, attached to the zCP3000
download webpage at:

IBM Techdocs : http://w3-03.ibm.com/support/techdocs/atsmastr.nsf/Weblndex/PRS1772

IBM PartnerWorld : https://www-304.ibm.com/partnerworld/wps/servlet/ContentHandler/tech PRS1865

Please join the zCP3000 discussion group at https://groups.google.com/forum/#!forum/zcp3000 for notice of changes to the tool.
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