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Agenda

= Engineer for Performance
» Hardware Resources & Configuration
» Software Levels
» Systems, Subsystems, & Security
» System Topology - Client/Server placement
» Application Server Configuration Options

= Tune your Runtime
» Workload Manager Controls
» Java Tuning
» System Monitors and Application Monitors
» |Isolating Performance Problems

= Resources
» Tools
» Documentation

IBM Washington Systems Center

Hardware Configuration

= 7990 provides superior performance
> Cycle speed, Super scalar, IEEE FP, Crypto, New hw instructions

= zSeries Application Assist Processor (zAAP) reduces TCO

= More Storage required than traditional workloads
» Real storage (Paging is BAD!)
— Default working set about 350 Mb per server region (256 Mb heap)
= Minimum entry system 512 Mb (light load, sandbox)
= Real world application, 1 Gb or more
= Coupling Facility for production
» RRS Logstreams, RACF, Error logs, DB2
= Cached DASD

» System Libraries, HFS
» Application Data

= OSA Express on zSeries 990
> Speeds up to 1GbEthernet with QDIO

F
.09 |
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Software Configuration - Latest Software Levels Perform Best:

= WebSphere V5 vs. V4
> Up to 25% improved throughput with Ping Stateless Session Bean (TX req'd)
> Up to 50% improvement with "Ping Update CMP Integer” (TX Req'd)
> Improved scalability
» Reduced real storage requirements in common area

= WebSphere V 5.0.2

» Dynamic Cache enhancements
» Defered Write operations for EJB 2.0 CMPs
» Customizable PMI
= WebSphere V5.1
» EJB 2+, CMPs, AXIS, JMX, SubPool elimination
= Java 1.3.1 SDK SR-20, 21, 22,23,& 1.4.1
» JIT & GC performance enhancements

= DB2 & JDBC Drivers
» See Info APARs 1113299 (DB2) & 1113309 (JDBC)

= z/OS Release 4
» ICSF, XES (CFRM, DB2) performance enhancements

IBM Washington Systems Center

System Tuning

= 7/OS or 0S/390° Security & RACF®

= Workload Manager - éava

= UNIX System Services & HFS . GI\Fgg

= TCP/IP _

= Language Environment (LE) : I(_)ltt;]rary Search Order
= er...

= System Logger & RRS
= Tracing & Logging

= Performance Tuning guidance in the
WebSphere Application Server V5.1 "InfoCenter"

» Performance and Troubleshooting sections
> "Performance Tuning and Monitoring" PDF
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Tune for effective use of storage:

= Need large servant regions (set REGION=0M on proc)

> Biggest single affect on storage use
= Default SR heap (256 Mb requies ~350 meg)
— Also affects GC time (server delays)

> Tune your Java heaps
— Default heap size = 128 Mb for controllers, 256 Mb for servants
= See "Tuning the JVM Heap" (later)

» Tune LE heap size (app. server proc)
— HEAP(40M,5M)

» May have to control Maximum # of Servant Regions

= Define more auxilary storage (Page packs)
> Test systems with 512Mb (& lower) perform okay with good paging resources

= Put recommended libraries in LPA & LNKLST
> In the configuration dialog, indicate they are in LNKLST/LPA
» Put WebSphere libraries (SBBOLPA & SBBOLOAD) into LPA if multiple cells
> Put LE runtime library (CEE.SCEELPA) in your LPALSTxx concatenation

IBM Washington Systems Center

UNIX System Services & HFS Tuning

= Make sure you allow enough sockets

» Update BPXPRMxx parmlib member

— Set MAXFILEPROC high enough
o Impacts OMVS kernel storage, only set as high as needed
o Applies to all USS user processes
o Optionally, can set this at user level using RACF

= Set MAXSOCKETS for the AF_INET filesystem high enough
o Atleast as high as MAXFILEPROC
* No major OMVS kernel storage impact

= HFS (Hierarchical File System)

» Product HFS (/usr/lpp/WebSphere/...)
= Mount Read/Only

> Configuration HFS
— Separate HFS for each node - make sure it is owned by the right system (if sharable)
— Can be shared HFS for testing, Sharable for fail-over

> File Caching
— Use SMF 92 records for tuning

> zFS
— May improve performance

© IBM Corporation, 2003, 2004
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Security is not "free" but can be tuned . ..

= WebSphere runs with security on by default
» Always collects and carries credential information

= SAF classes can be enabled or disabled to control security
> Disabled SAF classes: negligible overhead
> Enabled SAF classes: number of profiles in class will affect performance
= Keep RACF classes and other info in memory
» RACLIST CBIND, EJBROLE, FACILITY, PTKDATA, SERVER, STARTED
> Use VLF for ACEEs, GTS, and UID/GIDs
= EJBROLE Class
» Only activate the EJBROLE class if you are using EJBROLES
» More EJBROLES on a method will give you more access checks

= Disable SAF calls for successful HFS accesses
» Define the BPX.SAFFASTPATH facility class
— Don't use if you need to audit successful HFS accesses, or use the IRRSXTOO exit

IBM Washington Systems Center

Security - authentication options

= Local (RACF) Userid and Password authentication
» Highly optimized, most efficient way to authenticate a user

= SSL security authentication
> Requires Global Security
» Use IBM @server™ zSeries™ hardware assists to improve performance on z/OS
= Cryptographic coprocessors and PCI crypto cards
» Reduce excessive SSL hand shakes for subsequent transactions in SSL sessions.
= Set session timeout value high enough: com_ibm_CSI_perform_ssl_sys_v3_timeout=
= Use the SID (SSL ID) for non-persistent sessions (e.g., .NETclients) & increase SID cache
— Activating zSeries Crytographic Services for WebSphere Techdocs TD100745
= Global Security & other mechanisms ...
> J2EE - Role-based authentication
» Java 2 - access to resources by applications
» JAAS (Java Authentication & Authoriz'n Service) - RYO authentication & authorization
> TAI (Trust Association Interceptors)- depends on what does your exit does
» SSO (Single Sign On) - LTPA or ICSF - credentials in cookies
» Performance implications vary depending on specific implementations

© IBM Corporation, 2003, 2004
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Server Topology Decisions

= Client location
» Remote vs. Local

= Server(s) location
» Number & Configuration

= Web Tier
» Cache static objects
» Firewalls for DMZ
» Authentication

http://

DNS

Web Server
(Rev Proxy) [

(Auth)

= HTTP servers N

» HTTP vs. IIOP M brapatener
» Reverse Proxies

8

» Use HTTP transport

= DNS

= D-VIPA (Sysplex Distributer)
= Database servers

IBM Washington Systems Center

Optimize application object flows

Web Server
(Rev Proxy) [

(Auth)

IBM Washington Systems Center

=

ServerA

TCP WLM MQ
VIPA

= @0 |

TCP WLM MQ
S viPA

Web Server Daemon
revrroon ] (Dacmon)

(Auth) : ServerB

-]

Deploy related applications in the same server:

— SYSA SYSB ——
[ Server1A| 1 Server2B
CR SR) CR || SR
;3 T
2]
Seryer2A Server4B
CR SR CR SR

1. Avoid application calls
from one system to
another

2. Provide a local replica
of any required
application server.

3. Deploy applications in
the same server,
because local calls are
even faster.

© IBM Corporation, 2003, 2004
Performance Tuning for WebSphere V5 on z/OS

11-12



IBM Washington Systems Center

IBM Washington Systems Center

Reduce unnecessary IIOP Flows

—— Web Tier — 2/10S
"Thin"
Client HTTP Server EJB Server

(browser) Servlets CR SR
? JSPs t EJBS

WAS Server

SR: Servlets \\
JSPs, EJBs <2IIOP

Java
Client

» Avoid IIOP calls from one system to another
» Serialization/deserialization overhead can be excessive!

» Use the 'pass by reference' check box via the admin console as follow:
» Servers->Application Servers->your_app_ server->Orb Service; check 'pass by reference'

IBM Washington Systems Center

WebSphere Application Server Configuration Options

— MVS TEST

= Base Application Server
» Easy to set up & useful for testing Server
> Responsive to server & application changes

> Not suited for production
— no clustering, single-systems config.

[ MVS SYSA —] [ MVSSYSB — |
-Daemon -Daemon
= Network Deployment (ND) o)
» Managed by Deployment Manager & Node Agents
» Multiple Application Servers

= Group multiple AppServers into Clusters

» ND Required for: (ServerlA) ("ServeriB)
— Multi-systems configuration & Clustering Clusterl
— Horizontal scaling for increased throughput CR| SR CR | SR
— Continuous availability & fail-over T Em——
= Rolling upgrades for continuous operations Server2A Server2B
Cluster2
CR || SR CR || SR
- Ji i /

© IBM Corporation, 2003, 2004
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WAS for z/OS implements two layers of clustering:

Application Server:
» Inner cluster - Server Instance PP

— Controller region - communication endpoint (HTTP, IIOP, MDB) ServerA
o Performs work classification, security processing, queues to WLM

— Servant region(s) - 1 or more address spaces (WLM managed) cr |l sr
e JVM - Web & EJB container - where applications run
— |solated for availability & performance
— Have identical runtime settings
— Confined to a single z/OS system Serve; Cluster with 4 memb%rs:

» Outer Cluster - Generic Server
— 1 or more server instances of a server.
— All servers have the same applications
May have different runtime settings
May exist on multiple z/OS systems.

| ServerA2

ServerAB]
p—

ServerA4

CR || SR

> Cell consists of one or more clusters. \_ )
= Confined to one Parallel Sysplex

[les]]

IBM Washington Systems Center

Clustered Servers

[ MVS SYSA ] [ MVSSYSB T » Multiple instances of the
same application server:
» Increases Availability:

ServerlA ServerlB » Remove single point of failure
r Il sr |||l Clusterl |1 1 o » Allows rolling updates.
) " » Can improve performance
(“Serverza) (‘ServerzB) - On multiple systems
(horizontal scaling)
CR
> [lljCluster2. ] & | 5= ]I ~ However:

» Multiple instances on the
La— same system normally won't
CRI SR improve performance.

© IBM Corporation, 2003, 2004
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connectionFactory caching for J2C Connections

= Exploit connectionFactory caching

» New J2C preference setting for Business Integration that will generate code so the
JNDI lookup for the J2C connection factory will be cached in the generated service
proxy and EJB.

» The J2C resource adapter has to be enabled to get this support; IMS™ and CICS®
ECI services takes advantage of this performance improvement.
= New setting with WAS 5.1
» Requires CTG 5.1 & IMS 2.2.0.
» Requires an updated WSIF(Web Services Invocation Framework) - J2C runtime.
= Specify in WSAD-IE 5.1:
> Select Window->Preferences
> Select Business Integration -> J2C
» Select check box for caching J2C ConnectionFactory

IBM Washington Systems Center

Replication - Managing the Number of Servant Regions

= Adminconsole: Appl. Server >> "Server Instances" App. server
» Check "Multiple Instances Enabled" Control  Server
— Otherwise, WLM will only start 1 servant region for this application server fegon - regions

> "Minimum number of Instances"
— Useful for avoiding delays to start up server regions
= To keep work from coming in thru the protocol handler before SRs are ready, use
protocol_accept_http_work_after_min_srs=1
> "Maximum number of Instances”
= Useful for limiting excessive server regions during server instance start-up or if you have
limited real storage . . .

» WLM Static Application Environments not used if DAE APAR OW54622 applied

= Caution!

> If you specify a maximum number of instances, WLM is restricted from starting
more than this number of servant regions for this server instance.

> The Maximum number must be >= number of service classes used by this
application's transactions, or transactions will time out.

» Remember to account for the default CB-type service class and enclaves that
may originate outside WebSphere servers and are classified by other
classification rules such as the IBM HTTP Server (IHS).

© IBM Corporation, 2003, 2004
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Managing the # of Threads

= Workload Profile in adminconsole:

» Servers >> Application Servers >> server_name >> ORB Service
>> Advanced Settings >> "Workload Profile"

— ISOLATE (1 thread) App. server

— NORMAL (3 threads) Control  Server
L. region region

— CPUBOUND (# of CPs, minimum of 3)

— IOBOUND (Number of CPs*3, Min=5, Max=30) qu

— LONGWAIT (40) T

e Can be over-ridden with variable: private_bboo_longwait_override
» Allow for increased concurrency
» WebSphere for z/OS doesn't need threads as placeholders for work
= WLM queues are used for that
» Plan for # of in and ready threads to be 2-3X the # of CPs
» You may have to experiment with these values and the number of
servant regions to optimize your performance.
— Too many servant regions take excessive storage
— Too many threads in a JVM creates interference & more frequent GC.

IBM Washington Systems Center

Classifying Work with WLM
= Started Tasks
= OMVS work
= Transactions (changes with WAS 5.1)
» CB work
> IWEB (IHS)
> Differentiation by URL
» MDBs
» Network QoS
- Resource 4 WLM Subsystem Type Selection List for Rulegefauu\
. Action Type Description Service
managers' . CB CB Class™"n w/WLM Trans. CLASSes  CBCLASS
» DB2 __cIcs Use Modify to enter YOUR rules
» CICS . DB2 Use Modify to enter YOUR rules
. DDF Use Modify to enter YOUR rules DB_DDF
> IMS o IMS Use Modify to enter YOUR rules
> MQ o IWEB IWEB rules IWEBFAST
o JES Batch Classification Rule BAT_MED
» other . omMvS E_Biz Classification Rule EBIZ_DEF
o STC Started Task Classification Rule OPS_DEF
\_— TSO TSO Classification Rule TSO_DEF/

© IBM Corporation, 2003, 2004
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WLM - Classifying WebSphere Address Spaces

= Control Regions (Daemon, Node Agent, Deployment Manager, App. Servers)
» Classify as SYSSTC or high velocity

= Application Server Regions

» Classify with velocity goal, high enough to get started quickly
= Work is actually classified under the application environment

= Sample STC Classification Rules:
» Use Report Classes to track important Started Tasks:

Qualifier Qualifier Starting Service Report
# type name position Class Class
1 TN WSAPP1C OPS_HI RWSAPP1C
1 TN WSAPP1S OPS_MED RWSAPP1S
1 TN WS%%%%C OPS_HI RWSCTLRG
1 TN WS%%%%S OPS MED RWSSVRRG
= OPS_HlI service class:  Importance= 1, Velocity = 70

= OPS_MED service class: Importance= 2, Velocity = 40

IBM Washington Systems Center

Controller start-up Procedure with WAS V.5.0.1:

= Additional step added to Contol Region Proc:

= APPLY step - applyPTF.sh checks to see if service has been applied to WebSphere and
run the "update files" for the new service.

— Output written to .../properties/service/logs/applyPTF.out'
— Classify server controller jobnames with WLM OMVS Classification rules.
— Performance of apply step improved in V.5.0.2

//WSACR PROC ENV=,PARMS=" " ,Z=WSACRZ

// SET ROOT="/wasvb5config/wscell”

// SET FOUT="properties/service/logs/applyPTF.out"

//APPLY EXEC PGM=BPXBATCH,REGION=0M,PARM=. ..

//STDOUT DD PATH="&ROOT./&ENV..HOME/&FOUT. " ,PATHOPTS=. ..
//STDERR DD PATH="&ROOT./&ENV._HOME/&FOUT. " ,PATHOPTS=. ..

//*

//BBOCTL EXEC PGM=BBOCTL,COND=(8,EQ),REGION=0M, TIME=MAXIMUM, . . .
//BBOENV DD PATH="&ROOT/&ENV/was.env"

// INCLUDE MEMBER=&Z

= OMVS Classification rules - see Flash10243

———————— Qualifier---—-—--—- -————---Class----—---
Type Name Start Service Report
DEFAULTS: EBIZ_DEF
1 TN T5* _ EBIZ_HI RPTACR
1 TN ws* _ EBIZ_HI RPTACR

© IBM Corporation, 2003, 2004
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WLM - Classifying WebSphere Transactions
= Subsystem type = CB using the following criteria:

> Server name (CN)

> Server instance name (SI) - not useful because instances share work

> Userid assigned to the transaction (Ul) - usually not useful

> Transaction class (TC) - assigned from env. vars or a "URI mapping file":

= server > Adv.Settings > Transaction Class Mapping =>
protocol_http_transport_class_mapping_file= (points to HFS file - see next foil)

= Percentage response time goal is recommended

> Ex. 80% of trans less than 0.5 seconds (or high velocity default service class)

» Avoid multi-period Goals - 2nd & subsequent periods are not aggressively managed.

» Response time goals better than Velocity goals in a true production environment.
= Velocity goals need to be re-calibrated with environmental changes (CPU, workload)
> Default is SYSOTHER (discretionary)

= Other considerations:

» Requests that already have enclave tokens, run under these enclaves, and with the
service class assigned for this enclave .

» Control region maintains "internal queues" based on the service class:
= A server region may switch queues if needed to, based on demand

IBM Washington Systems Center

HTTP Classification by Virtual host, Port, or URI
example (old format before WAS 5.1):

Transaction Class Mapping file format:

|_TransClassMap *

TransClassMap <host>:<port> <uritemplate>
TransClassMap www.ibm.com:80 /Webapl/myserviet
TransClassMap www.ibm.com:*  /Webapl/myserviet
TransClassMap *:443 * CLASS3
TransClassMap *:* /Webapl/myservlef/ TCLASS4
TransClassMap www.ibm.com:*  /Webap5/* TCLASS5
* TCLASS6

CB Classification Rules: //

Qualifier Qualifier Start ice Report
# type name position ass Class

: CBMED RCBDEFLT

1 CN WSPROD CBMED RWSPROD
2 . TC . TCLASS CBFAST  RWSPRD1
2 . TC . TCLASS CBMED RWSPRD2
2 . TC . TCLASS5 CBSLOW  RWSPRD5
1 CN WSTEST 1 CBSLOW  RTSTEST
2 . TC . TCLASS5 CBSLOW  RTSTST5
Examples:

a.www. ibm.com:80/Webapl/myservlet => TCLASS1 => CBFAST (RWSPRD1)
b_www. ibm.com:443/Webapl/xservlet => TCLASS2 => CBMED (RWSPRD2)

© IBM Corporation, 2003, 2004
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Classifying Network QoS

= Network Quality of Service (QoS)
> Appl. Server >> WebContainer >> Adv. Settings >> Network QoS
= HOST - host name or IP address
— URI - part of the URL after host (& port)
= HOSTURI - combination of host and URI
= TCLASS - use a transaction class mapping file (see below)
» Sets variable protocol_http_transport_network_qos

» For ...qos=TCLASS, specify a "Transaction Class Mapping" file.
= protocol_http_transport_class_mapping_file = /...

» Communication server PolicyRule classifies work based on
= ibm-ApplicationData = /account/order.html

» Routers must be able to identify QoS Type of Service (ToS)

IBM Washington Systems Center

WLM - Classifying Message Driven Beans (MDBSs)

= WLM Transaction Class based on:
» Listener Port (Endpoint), and/or
» Message Selector (XML tags) . . .

= Adminconsole: Environment >> Manage WebSphere Variables
endpoint _config file=.../MDBClassMap.xml

<?xml version="1.0" encoding="UTF-8" ?>
<IDOCTYPE InboundClassification SYSTEM "InboundClassification.dtd">
<InboundClassification type="mdb" version="1.0">
<endpoint type="messagelistenerport”
name=""1VPListenerPort"
defaultclassification="MDBX">
<classificationentry selector="Customer="Good"""
classification="MDB1'"'/>
<classificationentry selector="Customer="Bad""
classification="MDB2"/>
<classificationentry selector="Customer="Ugly""
classification="MDB3"/>
</endpoint>
</InboundClassification>

See Techdocs article WP100387 "WLM Classification of MDBs"

© IBM Corporation, 2003, 2004
10/20/04 Performance Tuning for WebSphere V5 on z/OS 25-26




10/20/04

IBM Washington Systems Center

IBM Washington Systems Center

WLM Classification of Work Requests in WAS 5.1

= New with WAS V5.1 service level W510200 (refresh PTF)

= Workload Classification document; common .xml file for

transaction classification (TC) of inbound work:

» HTTP - host, port, URI
> [IOP - application, module, component, and method name
» MDB - message listener port, selector attribute

= Migration/Coexistance:
» New classification document supercedes old MDB classification file.

> New classification document can coexist w/ old HTTP Transaction Class mapping file,
but if it contains any HTTP classification rules, the old style document will not be used.

= See Techdocs article WP100449

<?xml version="1.0" encoding="UTF-8"7?>
<IDOCTYPE Classification SYSTEM *"Classification.dtd" >
<Classification schema_version="1.0">
<I-- 110P Classification Rules -->
<InboundClassification type="iiop"
schema_version="1.0"
default_transaction_class="A0">
<iiop_classification_info transaction_class="A1"
application_name="110PStatelessSampleApp"
module_name="StatelessSample.jar"

IBM Washington Systems Center

Displaying WLM Classification of Work Requests

= MVS oper command: F <server>,DISPLAY ,WORK,CLINFO

F X5SR02A,DISPLAY ,WORK,CLINFO

BBOOO02771 CLASSIFICATION COUNTERS FOR IIOP WORK

BBOOO0278I CHECKED 14, MATCHED 14, USED 0, COST 0, DESC: IIOP Default
BBO0O0278I CHECKED 14, MATCHED 3, USED 0, COST 0, DESC: sample
BBOO0278| CHECKED 3, MATCHED 1, USED 1, COST 3, DESC: ala
BBOO0278| CHECKED 2, MATCHED 1, USED 1, COST 4, DESC: alb
BBOOO0278I CHECKED 1, MATCHED 1, USED 1, COST 5, DESC: alc
BBO00278| CHECKED 11, MATCHED 11, USED 0, COST 0, DESC: other

BBOOO0279I FOR IIOP WORK: TOTAL CLASSIFIED 14, WEIGHTED TOTAL COST 95
BBOOO02771 CLASSIFICATION COUNTERS FOR HTTP WORK

BBOO0278! CHECKED 0, MATCHED 0, USED 0, COST 0, DESC: HTTP Default
BBOO0278] CHECKED 0, MATCHED 0, USED 0, COST 0, DESC: n

BBOO02791 FOR HTTP WORK: TOTAL CLASSIFIED 0, WEIGHTED TOTAL COST 0
BBOOO0188I END OF OUTPUT FOR COMMAND DISPLAY,WORK,CLINFO

© IBM Corporation, 2003, 2004
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Java Tuning

= Java level is reported in servant region joblog
» Keep current with the latest SDK
> This also indicates if the JIT is enabled or not

= Make sure the JIT is enabled
» Ensure that Disable JIT is not selected in JVM for each server.

» Number of references (or loop iterations) before keeping JITed code in LE Heap:

- IBM_MIXED_MODE_THRESHOLD=nnnn
(default = 2000 for 131 SDK; 800-1107 for 141 SDK)

= Turn off JRAS debugging support

» Turn off in adminconsole - Set com.ibm.*=all=disable
= Note: you may be tracing and not know it if TRACEBUFFLOC=BUFFER
= Verify by looking in SYSOUT dataset

= Do not use the debug version of Java
= Make your CLASSPATH more efficient

» Make sure you only point to classes you need
» Put frequently referenced classes first

= QOther tips: www.ibm.com/servers/eserver/zseries/software/java/

IBM Washington Systems Center

New zSeries Application Assist Processor (or zAAP)

New specialty assist processor dedicated exclusively to execution of Java
workloads under z/OS°® - e.g. WebSphere®

¢ Available on IBM z990 & z890, & future zSeries servers only

» Used by workloads with Java cycles: WAS 5.1, CICS®/TS 2.3, IMS™ V8 ,DB2°
— Executes Java code with no changes to applications

e Priced significantly below General Purpose CPs.

e Up to 1 zAAP per general purpose processor in an LPAR

e Prerequisites:
=2/0OS 1.6 (or z/OS.e 1.6)

—1BM SDK for z/OS, Java 2 Technology Edition, V1.4* with PTFs UQ88783, UQ90449...

= Processor Resource/Systems Manager™ (PR/SM) must be enabled.
e Traditional IBM zSeries software charges unaffected

e Sub-capacity eligible IBM software charges can be reduced

» ZAAP feature available now; software planned for Sept. 24", 2004 w/ z/OS 1.6

bjective: \Enablelntfgratlon of\new Java based Web applications with core z/OS backend database environment
or high performance

reliability, availability, security, and lower total cost of ownership
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Always use zAAPs or not...?
= New SYS1.PARMLIB(IEAOPTxx) Options
» [FACROSSOVER =YES | NO
> IFAHONORPRIORITY = YES | NO GCP - General Purpose CP
IFA - zAAP CP
Crossover NO No IFA eligible work can run on a GCP.
(Done when software license charges are paramount]
or repeatable billing is required.)
YESl
Hgngr NO GCP selects IFA work when GCP
Priority is not busy.
(Work runs below WLM discretionary work.)
YESl
»| GCP selects GCP work & IFA work
in dispatch priority order.
(Like running without zAAPs.)
Default Setting

IBM Washington Systems Center

zAAP Planning, Tuning & Monitoring Considerations
= CROSSOVER=NO can inhibit WebSphere Applications

» Make certain you have enough zAAP CPs, or Java apps can be delayed, or "hang"
= Performance note:

» Excessive switching "java eligible" states can increase overhead.
= Monitoring CPU (GCP & zAAP) Utilization

» SMF Type 72/79 records

» RMF Workload Activity Report and RMF Monitor 1l
» SDSF shows total CPU% for all procssor types

= For z890 processors, zAAP processors run at "full speed”
» zAAPs and GCPs may run at different speeds
» Requires certain SMF data to be normalized to get correct capacity information

= zAAP Projection Tool for Java 2 Technology Edition, SDK 1.3.1
» Runs in test environment (with WAS V5 or V4)
> Useful in predicting number of zAAPs necessary for optimum configuration
» Gathers usage information on % of Java in your workloads that could execute on zAAP
> Available with Excel Workbook - See Techdocs WP100417, WP100431 & PRS929

= See earlier sessions on zAAPs (Oct. 6th)
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New JVM Perf Option - Mapping jar files in memory

= JAVA_MMAP_MAXSIZE=n
» Specifies the maximum-sized jar files (in MB) that will be memory mapped.
» Available in Java SDK 1.3.1 (SR17+) & 1.4.1
» The default is O; that is, memory mapping is not used.
» Jar files 'n" meg or smaller will be accessed using a memory mapped file
» Restrictions: no NFS

» Make sure your region size (available private area) is large to fit the Java
heap & all jar files in your classpath which fall under the max size criteria.

» Leave a little extra memory for other Java storage allocations which do not
come from the Java Heap.

» Observed performance gain with JSPs: 5x ET, 3X CPUtime using
JAVA MMAP_MAXSIZE=20

IBM Washington Systems Center

Tuning your Java heap: Collect verboseGC statistics

<AF[21]: Allocation Failure. need 32784 bytes, 32225 ms since last AF>
<AF[21]: managing allocation failure, action=1 (84320/131004928) (3145728/3145728)>
<GC(21): GC cycle started Wed Feb 27 22:46:11 2002
<GC(21): freed 99587928 bytes, 76 % free (102817976/134150656), in 118 ms>
<GC(21): mark: 103 ms, sweep: 15 ms, compact: 0 ms>
<GC(21): refs: soft 0 (age >= 32), weak 0, final 878, phantom 0>
<AF[21]: completed in 118 ms>

» Adminconsole: Server >> Process >> Servant >> JVM >> check "GC Verbose"
» Results appear in server region's //SYSOUT DD file

= Don't specify JVM LOGFILE or output from multiple SRs will be meaningless.
> Key value: % free storage after each GC: XX % free

= Run for a long time to make sure your application does not have a memory leak.
» Key value: allocated heap after each GC: free (XXXXXXXX/YYYYYYYY)

- Steady state, this is your base Java heap requirement

o Add some head room, perhaps 64meg - 128meg, to select max heap size

¢ JVM_HEAPSIZE=xxx (XXXXXXXX + 64meg)
* Normally it's best to set JVM_MINHEAPSIZE=JVM_HEAPSIZE

> Key value: % elapsed time spent in GC
= ("completed in XXX ms" / "YYYY ms since last AF") < 2% ==> Heapsize is OK
» See TD101216 Tracing and Analyzing Java Garbage Collection... on Techdocs
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Tuning HTTP Session Management

= Memory-to-memory Session Replication
» Peer-to-peer with a local replicator
> Peer-to-peer with remote/isolated replicators

Local

-

Replicate

. . . Servers Back-up ]
> Client/server with remote replicators Replcaton
. . . . omain
» Client/server with isolated replicators S
: : Ny
= (Session count, timeout, overflow)
[ eecewr ¥

= Database Session persistence
» Several DB2 Tuning options:
- Tablespace size & page sizes

— Database & Multirow Schema settings

= Replication Tuning Levels
= Very high - Only updated attribs, every 300 secs (optimized for performance)
= High-  All attribs, every 300 secs

Medium - Updated attribs, end of servlet

Low - All attribs, end of servlet (optimized for failover)

Custom - All attribs, every 10 secs

IBM Washington Systems Center

Tuning Session Management (continued)

= Best practices for using HTTP Sessions (InfoCenter)
» Enable Security integration for securing HTTP sessions (use HTTPS)
> Release HttpSession objects w/ javax.servlet.http.HttpSession.invalidate() when finished.
> Avoid trying to save and reuse the HttpSession object outside of each servlet or JSP file.
> Implement java.io.Serializable interface for new objects to be stored in the HTTP session.
» The HTTPSession API does not dictate transactional behavior for sessions. (Use EJBs.)
» Ensure the Java objects you add to a session are in the correct class path.
» Avoid storing large object graphs in the HttpSession object.
> Utilize Session Affinity to help achieve higher cache hits in the WebSphere App. Server.
> Maximize use of session affinity and avoid breaking affinity.

>

Secure all of the pages (not just some) when applying security to servlets or JSP files that
use sessions with security integration enabled, .

» Use manual update and either the sync() method or time-based write in applications that
read session data, and update infrequently.

Use EJB session beans to access EJB entity beans
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Stolen from Bob St. John's session 2566 - Tues. @ 9:30
% "Performance Monitoring and Debugging for WebSphere V5 on z/OS"

Set performance expectations for your WAS applications

= IBM rep. request pre-sale capacity sizing estimate from
Techline
» Fairly detailed input required
> Estimate is rough

= Use a client emulator program to test your application
» Determine your CPU cost per transaction
» Determine your application environment response time
> Determine your client response time (in a measurement environment)

= After your application goes into production
» Keep key historical data for the WAS application environment
= Transaction rate, response time, 90% resp time, appl %
» Keep key historical data for WAS servant region proc
= appl %
= WAS application monitors can help with keeping historical
data and with detecting problems

IBM Washington Systems Center

Performance Monitoring and Debugging

See Bob St. John's session 2566 - Tues. @ 9:30
% "Performance Monitoring and Debugging for WebSphere V5 on z/OS"

= CPU resources

» Understand where the CPU time is spent
& how to measure/account for it

= Performance Monitors
> There are many from IBM and other vendors
= Performance Problem Determination
> Response time delays
» CPU delays
» Memory useage
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Where is CPU Time Accounted?

= Controller Region
» Communications End-point: Receives IIOP/HTTP/SSL request
» Classifies & Queues Request to WLM queue
- WLMthen. ..
e Manages queued requests
e Starts/stops Servant Regions as necessary

o Monitors system resources
e Manages to installation goals

= Servant Region
» Selects work from WLM for a given Service Class
» Java Garbage Collection
> JNI calls

= Enclaves
» J2EE Application code executes under an enclave (in JVM)
» Use SDSF ENClaves panel, or RMF Monitor to display

IBM Washington Systems Center

RMF Monitor 1 Workload Activity Report

REPORT BY: ... REPORTCLASS=RWSCTLRG - Contro
TRANSACTIONS TRANS.-TIME SS.TTT ---SER'
) AVG 1.00 ACTUAL 0 10C
u MPL 1.00 EXECUTION 0 CPU
Transactions/second weL o e 0 oy
» AVG=MPL=AVG ENC = # of END/S 0.00 R/S AFFINITY 0 SRB
H i #SWAPS 0 INELIGIBLE 0 TOT
enCIaveS In the perIOd EXCTD 0 CONVERSION 0 /SEC
AVG ENC 0.00 STD DEV 0
. REM ENC 0.00
= Response times
> T ~= ; T REPORT BY: ... REPORTCLASS=RWSSRVRG - Server
Actual R.T Execution R.T TRANSACTIONS ~ TRANS.-TIME SS.TTT  ---SER
(includes time waiting on WLM AVG 2.00 ACTUAL 0o 10C
queue) MPL 2.00  EXECUTION 0 CcPU
. ENDED 0  QUEUED 0 MSO
> No delays of interest (yet) END/S ~ 0.00 R/S AFFINITY 0 SRB
#SWAPS 0  INELIGIBLE o TOT
. EXCTD 0  CONVERSION 0 /SEC
= CPU & Service Rates AVG ENC 0.00 STD DEV 0

. . REM ENC 0.00
» CPU service units, &

1 Region
VICE-- --SERVICE RATES--
0 ABSRPTN 89615
522567 TRX SERV 89615
10159K TCB 39.9
61728 SRB 4.7
10743K RCT 0.0
89630 HIT 0.0

L % 37.

Regions
VICE--  --SERVICE RATES--
0  ABSRPTN 122075
143957  TRX SERV 122075
29113K TCB 11.0
12460  SRB 1.0
29270K RCT 0.0
244192  NIT 0.0

s 100 —

Service/Sec. REPORT BY: ... REPORTCLASS=RWSAP1ENC - WebSphere Enclaves (Transactions)
— Mi TRANSACTIONS ~ TRANS.-TIME SS.TTT  ---SERVICE--  --SERVICE RATES--
> TCB/ENDED = Mips/Tran. AVG  241.52  ACTUAL 276 10C 0 ABSRPTN 115
» APPL% = # of engines (CPs) EXECUTION 272 CPU 3343K__TRX SERV—115 |
H H H NDED 1067, QUEUED T 8—_ICB 255.5
required to drive the work in the END/S 890.32 R/S AFFINITY 0 SRB 0 SRB 0.0
service (report) class #SWAPS 0  INELIGIBLE o TOT 3343K RCT 0.0
EXCTD 0  CONVERSION 0 /SEC 17 0T 0.0
AV ENC 241.52  STD DEV 66 H
] De|ays REM ENC 0.00 APPL % 212.9
" EX PERF  AVG  --USINGY-- ----- EXECUTION DELAYS % ————-
» QMPL means waiting for VEL INDX ADRSP CPU 1/0 TOTAL CPU QMPL
Servant Region (WLM GOAL ~ 40.0%
gion ( ) ACTUALS 45.3% .89 13.4 0.1 0.0 36.1 23.@

PERFWS300
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Performance Monitoring and Management Solutions

= |BM: Tivoli Performance Viewer (shipped with WAS V5)

P ]
T T e e el

= Tivoli: 1BM Tivoli Monitoring for Transaction Performance, and
IBM Tivoli Monitoring for Web Infrastructure - www.ibm.com/tivoli

= [BM/Candle: PathWAI(TM) Monitor for WebSphere Application Server - www.candle.com
= |B M/Cyan €a. Cyanea/One, WSAM - www.cyanea.com

= Wi |y Technol OQgY: Introscope® - www.wilytech.com

= BMC Software: MAINVIEW® for WebSphere Application Server - www.bmc.com

= Quest Software: performaSure (& JProbe) - www.quest.com

= & many others

» WebSphere Performance Management Business Partner Solution Finder:

http://www.ibm.com/software/webservers/pw/dhtml/wsperformance/performance bpsolutions.html

IBM Washington Systems Center

Tivoli® Decision Support for OS/390®
= Another SMF reporting tool

» Tivoli Decision Support for OS/390 + "System Performance Feature"
» Version 1.6 - Program Number 5695-101
» aka Performance Reporter (PR) for MVS, SLR, EPDM

= Two basic functions:
> Collecting systems management data into a DB2 database from SMF
= Including WebSphere Application Server V5 for z/OS
> Data Reporting: Generates graphic & tabular reports from its DB2 database.

A E [ € [ o | E [ F IE) H L]
Method Resp_time Resp time CPU_SEC [CPU_SEC [CPU_SEC
1| rmE Bean NHame METHOD HAME Calls | {Av) (Max) (Bv) (Min}) (Max)

2 1:42 PM rTestCased43B getInfo:ijava.lang.String, int 4,307 0.4465 7.487 0.073 0.ooz 1.867
I 1:42 PM QuervMgrEean getCommlevices:com.dhl.network.cust 145,756 0.oa7 0.512 0.003 o.oon 0.10%8
i 1:42 PM rTestCasellB getInfo:java.lang.String,int 6,995 0.266 4,670 0.036 o.oo0z 1.211
i 1:42 PM rTestCaseiZ3E gecInfo:java.lang.3tring, int 16,655 0.065 0.466 0.013 0.001 0.047
i 1:42 PM rTestCase?3B getInfo:java.lang.String 1,588 0.051 0.741 0.017 0.00z 0.231

7 1:42 PM rTestCase33B getlInfo:java.lang.3tring, java.lang, 16,715 0.065 o.677 0.013 0.ooz 0.z21z2
E 1:42 PM rTestCasedlB getInfo:java.lang.3tring, java.lang, 14,103 0.0z24 0.404 0.00z2 0.0o0z 0.033

g 1:42 PM rTestCaseS3B getInfo:java.lang.String, int 6,952 0.037 0.445 0.oa7 0.001 0.037
E 1:42 PM QuervMgrEean getContacts:com.dhl.network.custome 145,756 0.008 0.625 0.001 o.oon 0.z0z
L 1:42 PM CQuervyMgrBean getdddressesFirst:com.dhl.network.c 76,783 0.0z2 0,523 0.oo0z2 o.ooo0 0.138
£ 1:42 PM CuervMgrEean getlAccountBillingDetailsByEBusinesst 12,920 0.004 0.z46 0.002 0.001 0.033
i 1:42 PM CQueryMgrBean getlccounts:com.dhl.network.custome 53,104 0.046 1.587 0.004 0.001 a.197

14| 1:42 PM QueryMgrBean getCustomwerligreements:com.dhl.netuc 6,952 0.012 0.161 0.ooz 0.oo01 0.00z2
E 1:42 PM QueryMogrBean getlccountissignedTolgreementByBus: 14,103 0.021 0.404 0.00z2 0.0o0z 0.0z6

16 481,434

7

I 1 3,545 per second I
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Zero in:
Right tool for
the problem?

Isolating problems

= Memory leaks
VerboseGC

v

» Tivoli Performance Viewer (shipped with WAS 5.0.1 for z/OS)
» Jinsight (IBM Alphaworks) - www.alphaworks.ibm.com/formula/jinsight
» WSAD Profiling
» WebSphere Application Monitor §
(WSAM - Cyanea/One) E"g,%E:H:ecutiun [Coloring by bype] [ =101 x|
» JProbe (Quest) - www.quest.com/jprobe/  Options  Zoom Selected Hely Threads
» others.. .. T e e et g
— 226503 =
2,365 7=

= Time spent & Delays:
» WSAD Profiling

236645

> Jinsight
» JProbe
» WSAM |!lg!ll:=:EEj N

» Wily Introscope 4 _TwﬂJ
» SMF, others . .. inl b+ | |thread named [ravwStoreDasmon)] &

IBM Washington Systems Center

_ Zero in:
Isolating problems Right tool for

the problem?

= Time spent & CPU activity at method level:
» WSAM, and other application monitors
» SMF 120 data (turn on activity records only for diagnostics )

— General viewer: www.ibm.com/software/webservers/appserv/zos_o0s390/ - "Trials & Betas"
= Summary viewer: See PRS752 "Performance Summary Report for SMF 120 ..." on Techdocs

WSC SMF 120 Performance Summary V500 Date: Thu Oct 31 12:00:02 EDT 2003  SyslID: SYSD
- record subtypes: 1:Svr_Act. 3:Svr_Int. 5:EJB _Act. 6:EJB_Int. 7:Web_Act. 8:Web_Int.
SMF -Record Time Server  Bean/WebAppName # of El.Time(mSec) WLM_Encl_CPU_Time(uSec)
Numbr -Type hh:mm:ss Instance Method/Servlet Calls Avg Max Avg. Max - Min
e R T B B s Bt S ¢ B e et B & L e e e O
359 120.6 19:00:02 T5SRV1  MY_IVT_ApplicationMylVTStatelessSession.jar

remove: 5 1 2 758 1472 378
getContents: 5 0 0 304 338 283
create: 5 15 65 11177 31661 911
removeltem: java. lang.String 5 0 1 355 391 300
addltem:java.lang.String 15 0 0 330 609 284
360 120.8 19:00:02 T5SRV1
ivtserviet 3 1 1 845 1202 650
ivtejb 3 115 301 62691 146527 18265
SimpleFileServlet 29 33 314 2544 18659 1712
JSP 1.2 Processor 3 4041 12095 1414156 4234288 3747
/ivtDate.jsp 3 141 420 60952 179122 1587

My_IVT_Application#My 1VTWebApp.war
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Zero in:
Right tool for
the problem?

Isolating CPU problems

= CPU usage at the detailed level:
» SMF 120 records provide CPU usage at the method level

» CPU Time service (WSC program) can be used for your own detailed measurements
— See PRS621 "CPU Time-used function for Java applications on z/OS" on Techdocs
= See TD101339 "How-to find CPPU TimeUsed in your WAS V5 for z/OS"

> WAS V5 has method SMFJActivity.obtainTotalCpuTimeUsed() in pmi.jar

import com.ibm.ws390.sm.smf.SmFJActivity;

long startTime;

long stopTime;

long cpuTime;

startTime = SmfJActivity.obtainTotalCpuTimeUsed();

< main Java code or method calls here >

stopTime = SmFJActivity.obtainTotalCpuTimeUsed();
cpuTime = stopTime - startTime;
System.out.printIn("'CPU Time: "

+ cpuTime + " microseconds™™);

IBM Washington Systems Center

Zero in:
Right tool for
the problem?

Isolating problems - Delays
= WLM Delay Monitoring States:

— DISP - waiting for response from a distributed server
= LOCL - waiting for session w/ server on the local system
— SYSP - waiting for TCP/IP session establish w/ local system
— REMT - waiting for TCP/IP session establish w/ remote system
= SSLT* - waiting for SSL session in controller
= REGT* - waiting for thread in controller
— WORK?* - waiting to register work in controller
= OTHER - waiting for DNS or TCP/IP
= TYP1 - EJB Collaborator
= TYP2 - J2C Connector
= TYP3 - RMI/IIOP
— TYP4 - OTS call to RRS
* Added w/ APARS for WLM OW51848 & RMF OW52227

Adds up to 100%

RMF V1R2  Work Manager Delays - WLMGL - Workload Activity Report
RESP STATE SAMPLES BREAKDOWN (%) - ------ STATE-———--

SUB P TIME --ACTIVE-- READY IDLE ----—-- WAITING FOR---------- SWITCHED SAMPL(%)
TYPE (%)  SUB APPL TYP4 REGT LOCL LOCAL SYSPL REMOT
CB BTE 0.0/ 26.9 0.0 0.0 0.0 65.4 3.8 3.8 | 0.0 0.0 0.0
cB EXE 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0

EX PERF AVG  —-USING%-- ----- EXECUTION DELAYS % -----

VEL INDX ADRSP CPU 1/0 TOTAL CPU QWPL
GOAL 40.0%
ACTUALS 45.3% .89 13.4 0.1 0.0 36.1 23.512.6
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More Tools . ..

= Workload simulators
» WebSphere Studio Workload Simulator
= www.ibm.com/software/awdtools/studioworkloadsimulator/
» MS WAStress Tool - www.microsoft.com/technet/default. mspx
— TechNet Home > IT Solutions > Intranet > Downloads
» Loadrunner - www.mercuryinteractive.com
> Silk - www.segue.com

» Web Performance Tool (aka WPT, AKStress)
- http://www.alphaworks.ibm.com/tech/wptools

= Javatools
» Javadump formatters - see IBM SDK, Java™ 1.3.1 Diagnostics Guide
» GC awk script - see TD101216 on Techdocs

= HTTP sniffers

» tcpmon - org.apache.axis.utils

= MVS Sysprog tools

> MXI - http://www.mximvs.com/

IBM Washington Systems Center

Some Benchmark Experiences
The best tuned system cannot fix a bad application

= Java Heap required by application
» Use JVM Verbose GC reports for information
» Application requires much larger JVM heap
» Application has a memory leak

= |nefficient Application Code
» Application 'swallows' errors, making them invisible
» Application use of storage and caching, caching algorithm used
» Resource bundles or property files read for every transaction
» Frequent, Verbose logging to Un-owned HFS
» String handling, data conversions ASCII <->EBCDIC
» Check WebSphere error log for errors and correct
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Resources

IBM Washington Systems Center

\!

2

L ////4

Resources & References

= WebSphere for z/OS "home page"
» ibm.com/software/webservers/appserv/zos 0s390/
» WebSphere InfoCenter
= http://publib.boulder.ibm.com/infocenter/wasinfo/index.jsp
— Down load a copy onto your workstation - See Techdocs FQ102912
= Redbooks: www.redbooks.ibm.com
— Monitoring WebSphere Application Performance on z/OS - SG24-6825
— Writing Optimized Java Applications for OS/390 - SG24-6541
= Techdocs - White Papers, Hints & Tips
» ibm.com/support/techdocs
= Guides on Configuration, Installation, Operations, Tuning, Debugging
= Build a library of WAS & Java for z/OS pubs
> Developers & Sysprogs need access to z/OS specific information

» Information is perishable and time sensitive
— QOut of date information is like no information or bad information.

2\

i
7
N
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Education

= Courses by IBM Learning Services, ITSO, & WSC

www.ibm.com/services/learning/

» ES685 - WAS V5 Implementation Workshop (4.5 days)

» ES690 - “WebSphere for z/OS V5 Update” (2.0 days)

» 0Z850 - “Maximizing WebSphere for z/OS V5 Performance” (4.5 days)

Wildfire Workshops:

» WBSR5 - WebSphere V5 for z/OS Workshop "Gen 5" (3 days)

» WSWO5 - Security Workshop: WAS V5 for z/OS (2.5 days)

» WBIZ5 - WBISF Install and Cust'n: WAS V5.1 for z/OS (2.5 days)

= Conferences & User Group Meetings
» SHARE & Regional User Groups
» zSeries Expo
» Large Systems z/OS Update

IBM Washington Systems Center

WAS V5 for z/OS Performance articles on Techdocs

= FLASH10243 Classify the Application Control Region in WLM OMVS rules

= WP100386 Activating z990 Cryptographic Services for WebSphere
= WP100387 WLM Classification of Message Driven Bean Enclaves in WAS for zOS

= WP100395 Using J2C Connectors & WAS V5 for z/OS to access CICS or IMS Trans:
Performance Best practices

= WP100417 z/OS Performance: Capacity Planning for zZAAP Processors
= WP100431 Installing the zAAP Projection Tool Instrumented SDK in WAS for z/OS V5
= WP100449 WLM Classification of Work Requests in WebSphere for zOS V5.1.

PRS752 Performance Summary Report for SMF 120 records from WAS V.5 for z/OS
PRS804 Performance Engineering & Tuning WebSphere Version 5 for z/OS

PRS829 Configuring & Troubleshooting the WAS for z/OS V 5 HTTP Server Plugin
PRS929 zAAP processor capacity planning training : An Overview of the zAAP Tool

ATS/WSC TechDocs - http://www.ibm.com/support/techdocs
Continued . . .
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WAS V5 z/OS Performance articles on Techdocs - cont'd

TD101124 WLM Dynamic Application Environments with WebSphere for z/OS V5
TD101151 How to Classify Transactions in WebSphere for z/OS V5

TD101152 Manage the Number of Servant Regions with WebSphere for z/OS V5
TD101199 Enabling the WSAD Application Profiler in a WAS 5.0 for z/OS

TD101216 Tracing and Analyzing Java Garbage Collection in WebSphere for z/OS V5
TD101242 Setting up the Tivoli Performance Viewer with WebSphere V.5.0.1 for z/OS
TD101338 How to Display Work in WebSphere Application Server V 5

TD101339 How to find the CPU Time Usage in your WAS V5 for z/OS java programs
TD101529 Application Migration Perform Guide - Migrating to WAS 5.0.2 for z/OS
TD101645 Tivoli Performance Viewer Security for WebSphere V5 for z/OS

TD101663 Enabling WebSphere Application Server 5.0.2 for z/OS to use the DB2
Universal JDBC Driver

= TD101703 Disabling the Deployment Manager Timeout Values in WAS for z/OS V5

= FQ102864 How big should my /tmp directory for WebSphere V5 for z/0OS?
= FQ102865 How do I turn on SMF 120 recording for WebSphere V5 for z/OS?
= FQ102962 Where can | find good diagnostic guide for IBM Java SDK 1.3.17?

ATS/WSC TechDocs - http://www.ilbm.com/support/techdocs

IBM Washington Systems Center

Other Resources . ..

= Developer's Domain (WebSphere & Java Best Practices, Help, Docs & Tools)
» www-136.ibm.com/developerworks/websphere/

Java Specifications (J2EE, EJB, JSP, Servlet, JNDI) Papers

» java.sun.com/j2ee/docs/

Java Community Process

» jcp.org/

z/OS Home Page

» www.ibm.com/servers/eserver/zseries/zos

Publications on-line (view, print, order books)
» www.ibm.com/servers/eserver/zseries/zos/bkserv
» www.ibm.com/servers/eserver/zseries/softcopy
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