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Creating a J2C application for an IMS phone book transaction

This tutorial describes how to use the J2C wizard to build a simple Web application that processes an
IMS™ transaction that returns a phonebook record.

Learning objectives

This tutorial enables you to:
* Use the J2C Java bean wizard to submit a transaction to IMS. Time required
¢ Create a Java method that accepts a customer number and returns the customer’s information.

Time required

30 minutes
Related information
[View thePDF version|
[IMS phonebook sample]

Create a J2C application for an IMS phone book Phonebook
transaction introduction

This tutorial illustrates how to use the J2C wizard to build a simple Web application that processes an
IMS transaction that returns a phonebook record.

This tutorial might require some optionally installable components. To ensure that you have installed the
appropriate optional components, see the System requirements list.

This tutorial is divided into several exercises that must be completed in sequence for the tutorial to work
properly. This tutorial teaches you how to use the J2C Java'" Bean wizard to create a Java bean that runs
a transaction in IMS. While completing the exercises, you will:

* Use the J2C Java bean wizard to submit a transaction to IMS.

* Create a Java method, runPhonebook.java, which accepts a customer number and returns the
customer’s information.

Time required

This tutorial should take approximately 30 minutes to finish. If you explore other concepts related to this
tutorial, it could take longer to complete.

Skill level
Experienced
Audience

This tutorial is intended for users who are familiar with Enterprise Information systems (EIS) and IMS in
particular.


JavaScript:linkSample('com.ibm.j2c.sample.doc/topics/sample_phonebook.html')

System requirements

To complete this tutorial, you need to have the following tools and components installed:
+ IBM® WebSphere® Application Server, version 6.1
* J2EE Connector (J2C) tools

* Information about your IMS environment: In this tutorial, your application interacts with an IMS
application program in IMS. You need to obtain information such as the host name and port number of
IMS Connect and the name of the IMS datastore where the transaction will run. Contact your IMS
systems administrator for this information. Specifically, you need to perform some setup work in IMS
if you want to run the IMS\PhoneBook IMS program.

* A copy of the COBOL file ex01.cbl: You may locate this file in your product installation directory:
<installdir>\IBM\SDP70Shared \ plugins\com.ibm j2c.cheatsheet.content_7.0.0\samples\IMS\
PhoneBook. If you wish to store it locally, you can copy the code from here: |../resources/ex01.pdf|

* A clean workspace.

To use this tutorial, you must have an application server installed and configured. To verify that a server
runtime environment is available, click Window -~ Preferences, expand Server, and then click Installed
Runtimes. You can use this pane to add, remove, or edit installed server runtime definitions. You can
also download and install support for a new server.

Prerequisites

In order to complete this tutorial end to end, you should be familiar with:
* J2EE and Java programming
* Basic IMS Transaction Manager (IMS TM) concepts

Lesson 1.1: Select a resource adapter

This lesson leads you through the detailed steps to select and configure the resource adapter to connect
to the IMS server.

Connecting to the IMS server

]
1. If the J2EE icon, Ta , does not appear in the top right tab of the workspace, you need to switch to
the J2EE perspective. From the menu bar, select Window > Open Perspective > Other. The Select
Perspective window opens.

Select J2EE.

Click OK. The J2EE perspective opens.

In the J2EE perspective, select File > New > Other.

In the New page, select J2C > J2C Java Bean. Click Next

In the Resource Adapters Selection page, select the J2C 1.5 IMS resource adapter. For this tutorial
select IMS Connector for Java (IBM:9.1.0.2.3). Click Next.

In the Connection Properties page, select Managed connection.
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If you already have a JNDI connection created, click Browse to locate your JNDI. If you do not have
a JNDI connection, click New.

9. On the Server Selection page, select WebSphere Application Server v6.1.
10. Click Next.

11. On the New J2C Connection Factory page, accept the default Connection class name of
com. ibm.connector2.ims.ico.IMSManagedConnectionFactory. In the blank fields, enter all the required
connection information. Required fields, indicated by an asterisk (*), include the following:

a. For TCP/IP connection:
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1) Host name: (Required) The IP address or host name of IMS Connect.
2) Port Number: (Required) The number of the port used by the target IMS connect.

b. For local option connection:

1) IMS Connect name: (Required) The name of the target IMS connect.

c. For both:

1) Data Store Name: (Required) The name of the target IMS datastore.

12. Click Finish.

13. You may obtain the connection information from your IMS system administrator. When you have
provided the required connection information, click Next.

EXO01.cbl

Here is the code from EXO01.cbl:

EXO01.cbl

IDENTIFICATION DIVISION.

ENVIRONMENT DIVISION.
CONFIGURATION SECTION.

DATA DIVISION.

*

* IMS Connector for Java, COBOL Transaction Message Source

*

*********************************************************************/

L T R T SRR R R N I R T R

*/
(c) Copyright IBM Corp. 2003 */
A1l Rights Reserved */
Licensed Materials - Property of IBM */
*/
DISCLAIMER OF WARRANTIES. */
*/

The following (enclosed) code is provided to you solely for the */
purpose of assisting you in the development of your applications. =*/
The code is provided "AS IS." IBM MAKES NO WARRANTIES, EXPRESS OR x/
IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF  */
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, REGARDING  =*/

THE FUNCTION OR PERFORMANCE OF THIS CODE. */
IBM shall not be Tiable for any damages arising out of your use =/
of the generated code, even if they have been advised of the */
possibility of such damages. */
*

/

DISTRIBUTION. */
*/

This generated code can be freely distributed, copied, altered, */
and incorporated into other software, provided that: */
- It bears the above Copyright notice and DISCLAIMER intact */

- The software is not for resale */

*

/

*********************************************************************/

*

LINKAGE SECTION.

01 INPUT-MSG.

02
02
02

IN-LL
IN-7Z
IN-TRCD
IN-CMD
IN-NAME1
IN-NAME2
IN-EXTN
IN-ZIP

01 OUTPUT-MSG.

PICTURE
PICTURE
PICTURE
PICTURE
PICTURE
PICTURE
PICTURE
PICTURE

S9(3) COMP.
S9(3) COMP.
X(10).
X(8).
X(10).
X(10).
X(10).
X(7).
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02 OUT-LL PICTURE S9(3) COMP VALUE +0.

02 0UT-ZZ PICTURE S9(3) COMP VALUE +0.
02 OUT-MSG PICTURE X(40) VALUE SPACES.
02 OUT-CMD PICTURE X(8) VALUE SPACES.

02 OUT-NAME1 PICTURE X(10) VALUE SPACES.
02 OUT-NAME2 PICTURE X(10) VALUE SPACES.
02 OUT-EXTN PICTURE X(10) VALUE SPACES.
02 O0UT-ZIP PICTURE X(7) VALUE SPACES.
02 OUT-SEGNO PICTURE X(4) VALUE SPACES.

PROCEDURE DIVISION.

Lesson 1.2: Set up a Web project and Java interface and
implementations

This lesson leads you through setting up a Web project and Java Interface and Implementations.

Before you begin, you must complete lesson 1.1. In this lesson you will

9.

Create a J2C Java Bean
Create a dynamic Web project

. All work done in the workbench must be associated with a project. Projects provide an organized

view of the work files and directories, optimized with functions based on the type of project. In the
workbench, all files must reside in a project, so before you create the J2C Java bean, you need to
create a project to put it in. In the New J2C Java Bean page, type the value IMSPhoneBook in the
Project Name field.

Click the New button beside the Project Name field to create the new project

Now you will create a dynamic Web project. In the New Source Project Creation page, select Web
project, and click Next.

In the New Dynamic Web Project page, click Show Advanced.
Ensure that the following values are selected:

. Project name: IMSPhoneBook

. Project contents: accept default

. Configurations: accept default
. Add project to an EAR: checked
EAR Project name: IMSPhoneBookEAR
Click Finish.

A dialog box may appear asking if you would like to switch to the Dynamic Web perspective. Click
Yes.

On the J2C Java Bean Output Properties page:

a. In the Package Name field, click Browse and select the IMSPhoneBook project. Click OK.
b. Type sample.ims in the Package Name field.

c. Type PhoneBook in the Interface Name field.

a
b
c. Target runtime : WebSphere Application Server v6.1
d
e
f.

d. Type PhoneBookImpl in the Implementation Name field.
Click Finish.

Lesson 1.3: Create a Java method

Lesson 1.3 leads you through the creation of a Java method.

4
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Before you begin, you must complete Lesson 1.2: Setting up the Web project and Java Interface and
Implementations. In this lesson you will:

* Create a Java method

* Create the input and output data mapping between COBOL and Java

1.

Al A

First you will create a Java method: In the Snippets view, select J2C. Double click Add Java method
to J2C Java bean.

In the Java Methods page, click Add

In the Java method name field, type runPhoneBook for the name of the method.

Click Next.

Next you will create the input data mapping between COBOL and Java: In this step, you will
import the Ex01.cbl (COBOL) file that is needed to create your applicaion. The Ex01.cbl file is located
in <installdir>\IBM\SDP70Shared \ plugins\com.ibm.j2c.cheatsheet.content_6.0.0\Samples\IMS\
phonebook, where <installdir> is the directory where this product is installed. The COBOL file
contains the application program that runs on the IMS server. It has the definition of the structure to
be passed to the IMS server via the communications area. This structure represents the customer
records being returned from the IMS application program. Before you can work with a file, you must
import it from the file system into the workbench. In the Input type field of the Java Method page,
click New.

In the Data Import page, ensure that the Choose mapping field is COBOL_TO_JAVA. Click Browse
beside the COBOL file

Locate the Ex01.cbl file in the file system, and click Open.
Click Next.

In the COBOL Importer page, click Show Advanced.

a. Select the following options:

Table 1. COBOL Importer Parameter Settings

Parameter Value
Platform Name Z/0S
Codepage IBM-037
Floating point format name IBM Hexadecimal
External decimal sign EBCDIC
Endian name Big
Remote integer endian name Big
Quote name DOUBLE
Trunc name STD
Nsymbol name DBCS

b. Click Query to load the data.

c. A list of data structures from the Ex01.cbl file is shown. Select INPUT-MSG in the Data
structures field.

d. Click Next.

10. In the Saving properties page, select the following values for input type:

1.

a. Select Default for Generation Style.

b. Click Browse beside the Project Name and choose the Web project IMSPhoneBook .
C. In the Package Name field, type sample.ims.data.

d. In the Class Name field, accept the default INPUTMSG. Click Finish.

Next you will create the output data mapping between COBOL and Java: In the Java method page,
click New next to the Output type field.
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12. In the Data Import page, ensure that the Choose mapping field is COBOL_TO_JAVA.
13. Locate the Ex01.cb1 file in the file system, and click Open.
14. Click Next.
15. In the COBOL Importer page, click Show Advanced.
a. Select the following options:

Table 2. COBOL Importer Parameter Settings

Parameter Value
Platform Name z/0S
Codepage IBM-037
Floating point format name IBM Hexadecimal
External decimal sign EBCDIC
Endian name Big
Remote integer endian name Big
Quote name DOUBLE
Trunc name STD
Nsymbol name DBCS

b. Click Query to load the data.

c. A list of data structures from the Ex01.cbl file is shown. Select OUTPUT-MSG in the Data
structures field.

d. Click Next.
16. In the Saving Properties page,
Select Default for Generation Style.
Click Browse beside the Project Name and choose the Web project IMSPhoneBook .
In the Package Name field, type sample.ims.data.
In the Class Name field, accept the default OUTPUTMSG . ClickFinish.
Leave the Save session as Ant script unchecked.
17. On the Java Method page , click Finish.

18. In the Binding Details page, ensure that the interactionVerb is SYNC_SEND_RECEIVE(1) to
indicate that the interaction with IMS involves a send followed by a receive interaction.

19. Click Finish.

® a0 op

Lesson 1.4: Deploy your application

Lesson 1.4 leads you through the creation of a JSP and a Faces JSP to test your application.

Before you begin, you must complete Lesson 1.3. In this lesson you will:

* Create a JSP to test your Java application.

* Run the JSP in the WebSphere test environment.

* Create a Faces JSP to test your Java application.

* Run the Faces JSP in the WebSphere test environment.

First you will create a JSP: Click File > New > Other > J2C.

In the Select a wizard page, select Web Page, Web Service, or EJB from J2C Java bean.
Click Next.

In the J2C Java bean selection page, click Browse.

ok~ wnh =

In the Find ]J2C bean page, type an asterisk (*) in the Select entries field.
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11,
12.
13.
14.
15.
16.

17.

In the Matching types field, select PhoneBookImpl.

Click OK.
In the J2C Java bean selection page, click Next.

In the Deployment Information page, select Simple JSP.

Click Next.

In the JSP Creation page, select . Generate simple JSPs with default input modes.
In the JSP folder field, enter a JSP Folder name, such as Samp1eJSP.

Click Finish.

Next you will run your JSP: Right-click TestClient.jsp and select Run on Server.

A browser window with the Test Client will launch. Click on runPhoneBook method.

Use the following values as Inputs:

¢ Type IVTINO in the In__tred field.

¢ Type 0 in the In___zz field.

* Type LASTI in the In__namel field.
¢ Type DISPLAY in the In__cmd field.
* Type 59 in the In__ll field.

* Type 93 in the size field.

Click Invoke, and this output will appear in the Result field.

Result

returnp:
out segno:
put_z=z:
recordShortDescription:
out_zip
put_extn:
put msg:

out_cmd:
out_1L:
out_name2:
out_namel:
recordName:
5178

0001

0

zample.ims data OUTPUTMSG
DO1/R01

5-111-1111

ENTRY WAS

DISPLAYED

DISPLAYED

O3

FIRST1

LAST1

zample ims. data QUTPUTMSG
O3

18. Now submit another command to add a phone book entry. Click on runPhoneBookmethod.

19. Use the following values as Inputs:

¢ Type 59 in the In__11 field.
* Type 0 in the In___zz field.
e Type IVTNO in the In__tred field.

Creating a J2C application for an IMS phone book transaction
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¢ Type Add in the In__cmd field.
* Type Jane in the In__name?2 field.
e Type Doe in the In__namel field.
* Type 55555 in the In__zip field.
* Type 5-5555 in the In__extn field.
* Type 93 in the size field.
20. Click Invoke, and this output will appear in the Result field.

Result
returnp:
out_segno: 0001
out =z 0
recordShortDescription: zample ims data QUTPUTMSG
out_zip 33333
out_extn: 3-333
out_msg: E"‘-.TRE WAS ADDED
out_cmd: ADD
out 1l 03
out_namel: JANE
out_namel: DOE
recordName: zample ims data QUTPUTMSG
s1ZE; 03

21. Now submit another command to display the phone book entry you just added. Click on
runPhoneBook method.

22. Use the following values as Inputs:
* Type 59 in the In__11 field.
* Type IVINO in the In__trd field.
e Type 0 in the In___zz field.
* Type DISPLAY in the In__cmd field.
* Type Doe in the In__namel field.
* Type 93 in the size field.
23. Click Invoke, and this output will appear in the Result field.
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25.
26.

27.
28.
29.
30.

31.

32.
33.
34.
35.

36.
37.
38.
39.
40.
41.

Result
refrnp:
out_segno: 0001
out_=z=: 0
recordShortDescription: sample.ims data OUTPUTMSG
out_zip 33333
put_extn: 3-3333
out_msg: ENTRY WAS
DISPLAYED
out_cmd: DISPLAY
out 1l 03
put_namel: JANE
put_namel: DOE
recordName: zample ims data OUTPUTMSG
2i7g: 03

Now you will create a Faces JSP to deploy the J2C Java bean:
Expand the IMSPhoneBook project, and find the WebContent folder.

Right click on WebContent folder in your IMSPhoneBook project and select New > Other > Web >
Faces JSP file.

Type Test in the Name field.
Accept defaults for all other fields.
Click Finish.

Next you will add the Java bean to faces JSP: Once you have created the Faces JSP file, the page
should open Test.jsp in the Design page. If the workspace does not open in the Design page of the
editor, expand the WEB-INF folder under the WebContent folder. Right click on Test.jsp, select
Open With, and click on Page Designer. Test.jsp will open in the Design page.

The Palette view should appear on the right panel. If it does not appear, in the top menu, click on
Window > Show view > Palette.

In the Datafolder of the Palette view, click on the JavaBean option of the Palette.

Drag and drop the JavaBean to the Test.jsp editor; the Add JavaBean wizard will open.
Select Add new JavaBean.

In the Name field, type phonebookLookup.

Click the open book icon, @ , beside the Class field. The Class Selection window appears.
In the Class Selection page, type PhoneBookImpl in the Search field.

Deselect the Add input/output controls to display the JavaBean on the Web page check box.
Click Finish.

You will see PhoneBookImpl in the Page Data view.

Adding input and output controls to the faces JSP: Right-click phonebookLookup Java Bean in the
Page Data view, and click Add New JavaBean Method.
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45.
46.
47.
48.

49.
50.
51.
52.
53.
54.

55.
56.
57.

58.

59.
60.

61.
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From the list of available methods, click on runPhoneBook.
Click OK.

Expand phonebookLookup Java Bean in the Page Data view, and select the runPhoneBook()
method.

Drag and drop the runPhoneBook() method onto the editor. The Insert JavaBean wizard appears.
In the Create controls for: field, select Inputting data.

In the Fields to display field, select None, to clear the form.

In the Fields to display field, select these input fields

e arg.in__tred

* arg.in_ zz

 arg.size

* arg.in_ _namel

e arg.in__cmd

e arg.in__ll

Click Finish.

Accept defaults for the other fields.

Click Next.

In the Configure Data Controls page, select Create controls for displaying the results.
In the Fields to display field, select None, to clear the form.

In the Fields to display field, select these output fields

° out__zz

* out_ zip

* out__extn

* out__msg

e out__cmd

* out_ll

* out__name2

* out__namel

* size

Click Finish.

Save your Faces JSP page, by pressing Ctr1-S or by clicking File > Save in the toolbar.

Now you will test the Faces JSP: Select the Servers tab. Start the test server, if it is not already
running. To start the server, right click on the WebSphere Application Server v6.0 and click Start.

Right click on Test.jsp (the faces JSP that you just created) in the Project Explorer view, and select
Run < Run on Server.

Select WebSphere Application Server v6.0 and click Finish.

The browser will open to Test.jsp.Use the following values as Inputs:
e Type IVTINO in the In__tred field.

* Type 59 in the In__ll field.

e Type 0 in the In___zz field.

* Type DISPLAY in the In__cmd field.

* Type LASTI1 in the In__namel field.

* Type 93 in the size field.

Note: Ensure that there are no extra spaces in the text box before your entry.
Click Submit.
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62. You will see the output displayed in your browser.

Congratulations! You have completed the PhoneBook tutorial.

Create a J2C application for an IMS phone book transaction summary

This tutorial has taught you how to use the J2C Java bean wizard to connect to an IMS server, and return
an phonebook entry.

Lessons learned

If you have completed all of the exercises, you should now be able to
* Use the J2C Java bean wizard to create a J2C application that interfaces with an IMS transaction.

* Create a Java method, runPhoneBook.java , which accepts an individual’s name and returns the
individual’s contact information.

¢ Create a JSP to deploy the application on WebSphere Application Server.
* Create a Faces JSP to deploy the application on WebSphere Application Server.
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