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Exercise 3.a – Deploy your first application 
This exercise will show you how to deploy an application from the IBM Bluemix Web User 
Interface. 
 
In a browser navigate to http://bluemix.net 

 
 
Select ‘LOG IN’ then enter your log in information and press ‘Sign In’.  You should be 
seeing your dashboard view: 

 
Select the ‘CATALOG’ view : 
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Select the Java Cloudant Web Starter from the Boilerplates section: 
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Enter a name for your application, as shown above (host will automatically be completed).  
The host name must be unique on Bluemix, so please choose a name with your company 
name or initials to try to make a unique name.   
 
Press ‘CREATE’ 
 
After a short while your application should be running.  You can launch the application by 
clicking on the route: 

 
 



Section3 - First Deploy Exercises 

Copyright IBM Corporation 2013-2014. All rights reserved.                                                                                     
6 

 

Exercise 3.b – Deploy then update an application using the 
CLI 
In this exercise you will use the Command Line Interface tool to work with Bluemix.  You 
use this tool in a terminal or command window on your workstation. 
 
We will work with the same sample application we used in exercise 3.a.  From the 
dashboard view in Bluemix select the application to enter the application Overview 

 
Select ‘VIEW GUIDE’ then ‘2. Download the starter application package’ 
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Once the starter package has been downloaded move it to a directory on your workstation 
where you want to work, such as Bluemix directory in your Documents folder.  Then unzip 
it (double clicking or right-click and select to unarchive) .  Don’t delete the zip file – we will 
need it in Exercise 3.c 
 
You can delete the deployed application so we can deploy it from the command line.  
Select the gear wheel in the application Overview window then select ‘Delete App’ 

 
You want to delete the Service and the Route with the application, so select the checkbox 
in the services tab and the Routes tab 

    
Select OK to delete the application. 
 
Open up a command or Terminal window and change directory to the location you 
unzipped the downloaded sample application. 
 
We need to log in to Bluemix so issue the following command: 

cf l -a https://api.ng.bluemix.net 
enter your email and password that you use to sign in to the Bluemix Web UI.  Select the 
organization and space you want to work in if prompted. 
 
Before we deploy the application we need to deploy a Cloudant database, so we can look 
at the available services using  

cf marketplace 
Your will get a list of all the services, the one we are interested in is the cloudantNoSQLDB 
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to create the service use command  

cf cs cloudantNoSQLDB Shared BICloudant 
where: 

• CloudantNoSQLDB is the name of the service from the cf marketplace command 
• Shared is the name of the service plan we want to use from the cf marketplace 

command 
• BICloudant is the name of the service instance we want to use – please choose 

your own name rather than BICloudant – you will need to use this name when 
connecting (binding) the service to the application. 

If you refresh your Web UI you will now see the deployed service: 

 
 
We can now deploy the application.   
 
Ensure you are in the directory for your application you should have the following files and 
directories: 
JavaCloudantDB.war  WebContent  build.xml  instructions.md  src  README.txt   
bin  dep-jar  manifest.yml 
Enter the following command – changing the application name to a unique name 

cf push BI-MyFirstDeploy -p JavaCloudantDB.war -m 512M --
no-manifest --no-start 

where: 
• BImyFirstDeploy will be the application name and hostname 
• -p specifies the path or file (war file) containing the application 
• -m specifies the amount of memory to allocate each application instance (1GB is 

default) 
• --no-manifest instructs to CLI tool not to use the supplied manifest (will be 

explained later) 
• --no-start instructs to CLI tool not to automatically start the application 

We don’t want the application to automatically start because it needs a database to run – 
we need to link the Cloudant database instance to the application before we want the 
application to start.   
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To link the database and application we use the following command – substitute the 
application name and service instance names you used: 

cf bs BI-MyFirstDeploy BICloudant 
where: 

• BImyFirstDeploy is the application name used when deloying the application 
• BICloudant is the service instance name used when deploying the service 

If you refresh the Web UI you should see the application and service now linked, but the 
application is still stopped. 
 
To start an application use the following command – substitute the name of your 
application: 

cf start BI-MyFirstDeploy 
where: 

• BImyFirstDeploy is the application name you want to start 
 
If you refresh the Web UI you should see the application running.  You can launch the 
application from the Dashboard view  

 
 
In a text editor open up file src/example/nosql/ResourceServlet.java and modify the name 
of the fie and file content  (line 346 and 349) 

 
rebuild the WAR file by issuing the ant command in the root directory of the project 
(contains build.xml) 

ant 
Buildfile: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 3/BImyFirstDeploy/build.xml 
 
clean: 
   [delete] Deleting directory /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/bin 
   [delete] Deleting: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/JavaCloudantDB.war 
 
init: 
    [mkdir] Created dir: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/bin 
 
build-project: 
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     [echo] Java Cloudant DB Web Starter: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/build.xml 
    [javac] Compiling 1 source file to /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/bin 
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5 
    [javac] Note: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/src/example/nosql/ResourceServlet.java uses unchecked or unsafe operations. 
    [javac] Note: Recompile with -Xlint:unchecked for details. 
    [javac] 1 warning 
 
build-war: 
      [war] Building war: /Users/binnes/work/Cloud/WW_IICs/BlueMix/Workshop V2/Lab 
3/BImyFirstDeploy/JavaCloudantDB.war 
 
build: 
 
BUILD SUCCESSFUL 

 
We need to remove the sample file from the database to allow it to be populated again, so 
in the Bluemix Web UI select the Cloudant Service instance then launch the Cloudant 
Dashboard. 

 
You should see a single DB 

 
select it, then select to delete the document 
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confirm the delete when prompted. 
 
Redeploy the updated WAR file with the push command – this time no need to include the 
--no-start or memory parameter 

cf push BI-MyFirstDeploy -p JavaCloudantDB.war --no-
manifest 

Once the application has restarted test to ensure your changes are now running. 

 
 
We will finish this exercise by deleting the application and service. 

 
cf d BI-MyFirstDeploy –r 

where: 
• BImyFirstDeploy is the application name to be deleted 
• -r instructs Bluemix to also delete the routes attached to the application 

 
cf ds BICloudant 

where 
• BICloudant is the name of the service instance to be deleted 

 
Note : you will be asked to confirm the delete of the application and service answer y to 
confirm you want to delete 
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Exercise 3.c – Working with Eclipse and Bluemix 
This exercise will show you how to work with Eclipse and Bluemix. 
 
Launch Eclipse  - suggest use a new workspace, but not essential.  Switch to Java EE 
perspective. 

 
 
First task is to configure Eclipse to use Bluemix as a server, so open up Eclipse 
Preferences and select Server -> Runtime Environments 

 
select ‘Add…’ then select IBM Bluemix Runtime and select ‘Create a new local server 
checkbox’ 
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select ‘Next >’ then enter your Email and Password on the next panel – there are the 
credentials you use to log into Bluemix.  Select ‘Validate Account’ to ensure all details are 
OK then select ‘next >’.  Choose the organization and space you want to use then select 
‘Finish’.  Select OK to close the preferences page. 
 
Note: If you want to work with multiple spaces in Eclipse you need to create multiple 
server configurations. 
 
Open the Servers view in Eclipse – if it is not showing use the menu items -> Window -> 
Show View -> Servers to open the view 

 
 
We will use the same application as we used in the last session, so you should have the 
archive file you downloaded in the last exercise already on your workstation – if not, deploy 
the Java Cloudant Web Starter application from the Bluemix UI, select View Guide then 
download the starter application. 

 
 
We need to import the starter application package to Eclipse – File -> Import 
This will open up the Import dialog.  Select General -> Existing Projects into Workspace 



Section3 - First Deploy Exercises 

Copyright IBM Corporation 2013-2014. All rights reserved.                                                                                     
14 

 

 
select ‘Next >’ then select the downloaded zip file and select ‘Finish’ 
 

 
The project will be created 
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To deploy the application right-click on IBM Bluemix in the Servers view 

 
then Add and Remove 
select the ‘JavaCloudantDBApp’  in the Available column and then select ‘Add >’, which 
will move it to the Configured column 

 
Press finish – this will then launch the deploy dialog.  Change the Appication name to 
something unique then press ‘Next’, check the URL contains something that you think will 
be unique the press ‘Next >’ On the Services selection screen press the  icon to add a 
service 
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when the list of available services come up select the CloudantNoSQLDB service 

 
press Finish and Finish again to close the application Deploy dialog.  The application is 
now getting deployed to Bluemix.  Eclipse should automatically switch to the Console view 
where you will see details of the deploy.   
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Once the application is running – switch back to the server view and expand the Bluemix 
server – you should see the application listed.  You can launch the application from Eclipse 
by right-clicking on the application in the servers view and selecting ‘Open Home Page’. 
 
Note: In Eclipse you can alter the Browser used to launch applications from the menu -> 
Window -> Web Browser - then select the preferred option. 
 
We need to remove the sample file from the database to allow it to be populated again, so 
in the Bluemix Web UI select the Cloudant Service instance then launch the Cloudant 
Dashboard. 

 
You should see a single DB 

 
select it, then select to delete the document 
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confirm the delete when prompted. 
 
In a text editor open up file src/example.nosql/ResourceServlet.java  

 
and modify the name of the fie and file content  (line 346 and 349) 

 
save the change File->Save then notice in the Server view the state of the Bluemix server 
has changed to republish – telling us that an application has changed, which is not yet 
been published to Bluemix.  Select the JavaCloudntDBApp application in the Server view 
and right-click then select ‘Update and Restart’ 
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Once the application has restarted test the application to ensure the change is now live. 
 
To finish this exercise right-click the project in the Explorer view and select Delete to delete 
the project.  Select to delete project contents on disk and then press OK.  You will then be 
asked if you want to delete the cloudantNoSQLDB service – deleting a project deployed 
via Eclipse will also delete it from Bluemix!  Select the checkbox to delete the service.  In 
the Bluemix Web UI confirm that the application and server have been deleted. 
 
 


