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About this manual 

Welcome to IBM® Rational® DOORS® Microsoft Team Foundation Server 
Add On.
Rational DOORS Microsoft Team Foundation Server Add On allows you to 
transfer task information from the Team Foundation Server to the Rational 
DOORS repository. The application consists of additions to both Microsoft 
Visual Studio with Team Explorer and Rational DOORS. 
The add on relies on a combination of embedded controls and new item types. 
To set these up, you need to add new type information to the Team Foundation 
Server database forms and type definitions. 
The following is a quick synopsis of the steps required to configure and install. 

1. How to install the add on on a client machine. 

2. Download and install PowerTool 2012 so you will be able to use the Process 
Template Editor to perform steps 5 and 6.

3. Register the DoorsProxy definition in the TFS database.

4. For each TFS Project add the DOORS Link Panel control to the ‘Task’ 
workitem definition.

5. For each TFS Project add the DOORS TFS Scheduling Panel control to the 
‘Task’ workitem definition.

6. For each TFS Project define a “Doors” project area and “Doors/Deleted” 
project area.

Each step is covered in more detail later in this document. Methods to configure 
multiple projects are also discussed.

Typographical conventions
The following typographical conventions are used in this manual:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.
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About this manual
Related documentation
The following table describes where to find information in the documentation 
set:

> A menu choice. For example: Click File > Open. This means 
click the File menu, then click the Open command from it.

For information on See

How to use Rational DOORS The Rational DOORS Information 
Center

What’s new in Rational DOORS 
Microsoft Team Foundation Server Add 
On

The download document

Typeface or 
Symbol

Meaning
2    Installation and Administration Guide
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Registering the DoorsProxy definition
1 Configuring TFS Server and Projects

Before getting started you should locate the installed files on your client machine. 
Normally these files can be located in the following directory:

Registering the DoorsProxy definition
Using Process Editor Tool you can configure the server XML imports using the 
Microsoft Provided Power Tool 2012 – Process Template Editor.

1. First download and install Power Tool 2012.

2. Start Visual Studio from one of the installed client machines. Click Process 
Editor > Work Item Types > Import WIT.

3. Login into the server using the Servers button.
Installation and Administration Guide           3



Configuring TFS Server and Projects
4. Select Collection and choose the project from the list.

5. Use the Browser to select the Doors_Proxy.xml file found in the TFS Server 
folder installed on each client machine.

6. Select OK to import the file into the selected project. To verify if this 
operation completed successfully, select the same Process Editor option 
again and instead of “Import WIT” select “Open WIT From Server” and 
4    Installation and Administration Guide



Configuring multiple projects
select the project and expand. The DoorsProxy project is one of the 
WorkItem types.

Configuring multiple projects
You can use the provided “importProxy.bat” file to import the same xml file as 
in the previous procedure.

1. Edit the importProxy.bat file and change the parameters as follows:

• Update <Collection Name> to your collection i.e. /collection:http://
yourTFSServerName:8080/tfs/defaultcollection

• Update <Project Name> to you project name i.e. /project:TestProject

2. Change the Doors_Proxy.xml path if you have installed Integration on other 
than default installation path.

The final form should look something like this:
" C:\Program Files\Microsoft Visual Studio 11.0\Common7\IDE 
\witadmin.exe" importwitd /collection: http://
yourTFSServerName:8080/tfs/defaultcollection /p:TestProject  /
f:"C:\Program Files\IBM\Rational\DOORS_TFS\TFS 
Server\Doors_Proxy.xml" >message.txt

3. Run the bat file. Messages will be saved in the message.txt file.

4. You can repeat this process changing the Collection Name and Project 
Name each time or repeat the command in bat file changing the Collection 
Name and Project Name on each line.
Installation and Administration Guide           5



Configuring TFS Server and Projects
Add Embedded Integration Controls
To make the new DOORS controls to display on workitem forms you must 
modify the definition for each workitem type in your project.

Add DOORS Link Tab Control

To make the DOORS Link Tab Control display on WorkItem forms, modify the 
definition for each workitem type in your project.

1. On the server, click Process Editor > Work Item Types > Open WIT 
from File.

2. Select and expand the TFS Project you want to configure. A list of all of the 
available Work Item Types is displayed.
6    Installation and Administration Guide



Add Embedded Integration Controls
3. Select the Task Work Item Type, and then select the Layout tab to display 
the form layout editor.

4. Expand the Third ‘Group’ section and select the first ‘TabGroup’ of the 
same group.

5. Right-click TabGroup > New Tab Page.
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Configuring TFS Server and Projects
6. Name the new page “DOORS Link” and move it to where you want it to 
appear relative to the existing tab pages.

7. Under the New DOORS Link tab page add a New Control, set the Label 
to DOORS Links, and set Type to WitTabControl.
8    Installation and Administration Guide



Add Embedded Integration Controls
8. Click Save.

Add DOORS TFS Scheduling Tab Control:

To make the DOORS TFS Scheduling Tab Control display on WorkItem forms, 
modify the definition for each workitem type in your project.

1. Follow step 1 to step 5 in “Add DOORS Link Tab Control” on page 6.

2. Name the new page “DOORS TFS Scheduling” and move it to where you 
want it to appear relative to the existing tab pages.

3. Under the New DOORS TFS Scheduling tab page add a New Control, 
set the Label to DOORS TFS Scheduling, and set Type to 
SchedulerControl.

4. Click Save.

This completes the configuration of the Task Work Item Type. If you want to 
have the DOORS TFS integration controls display on other work item forms 
(Requirement, Issue, Bug, Change Request etc) repeat the process for each 
workitem type.

Create New Area Paths in Projects

Area Paths are necessary to manage the new Doors Proxy items used to store 
imported DOORS Data. The DoorsProxy type itself can be used to filter out 
these items from user’s queries. The Doors area path can be used to further limit 
user access to this data. Finally when a Doors Link is deleted using the 
integration - the Deleted Proxy item is moved to the Deleted area path. Due to 
the nature of Team System and Sarbanes Oxley compliance workItems are never 
physically removed from the database, a work around is to move them to an area 
path with limited access.
Open the TFS Project as a Project Admin user and create two new area paths 
“Doors” and “Doors/Deleted”.
To create new area paths:
1. Open the TFS Project as a Project Admin, and click the Home icon.

The Team Explorer window is displayed.

2. Click Settings and then Work Item Areas.
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Configuring TFS Server and Projects
A page opens in your default browser.

Note  If the browser does not open, follow the procedure in 
“Workaround for Creating ‘Area Path’” on page 11.

3. Click New Child, type Doors in Area Name, and click Save and Close.

4. Select the Doors area that you have just created, right-click New Child, type 
Deleted in Area Name, and click Save and Close.
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Add Embedded Integration Controls
The area hierarchy now looks like this:

This completes the configuration for path areas for a Team Project. Repeat these 
steps for each project that will use the integration.

Workaround for Creating ‘Area Path’

If you click Work Item Areas and the browser does not open, use the following 
steps to create the Area Path:

1. Open the browser.

2. Enter the URL of the Team Foundation Server with collection name. If 
necessary, enter security credentials.

3. In the Visual Studio web site that is displayed, click Browse All. A list of the 
projects in the collection are displayed.
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Configuring TFS Server and Projects
4. Select the project where you want to create the Area Path and click 
Navigate.

5. Click Configure work area.

6. Restart at step 3 on page 10.
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Prerequisites
2 Client Installation of DOORS TFS 3.0.2 
Integration on Windows Platform

This chapter describes how to install and set up DOORS TFS on a machine that 
does not have an earlier version of the integration installed.

Prerequisites
• Rational DOORS 9.3 or higher client installed

• Full Visual Studio 2012 with Team Explorer 2012 Installed

• Team Foundation Server 2012 installed

• Power Tool 2012

• Supported operating systems: Microsoft Windows 7, 8.1

• At installation time only:

• Access to create/write in folder "\Documents and Settings\All 
Users\Application Data\Microsoft\MSEnvShared\Addins or access to 
create folder if it does not already exist. This folder is located on the 
same drive as your Visual Studio installation.

• Access to create/write in folder: "C:\Documents and Settings\All 
Users\Application Data\Microsoft\Team Foundation\Work Item 
Tracking\Custom Controls\11.0” or access to create folder if it does 
not already exist. This folder is located on the same drive as your Visual 
Studio installation.

• Access to create/write in folder “Program Files/Rational /”. This folder 
is on the same drive as your DOORS installation.

Note  Use the Visual Studio 2012 Full Version that includes Team 
Explorer 2012 whereas Explicit Installation of Team 
Explorer 2012 might not work. Install Visual Studio 2012 
from scratch on clean machine. Do not upgrade from Visual 
Studio 2010 to Visual Studio 2012.

Upgrading DOORS TFS
To upgrade, please use the following order: 

1. Uninstall DOORS TFS Addin 3.0.1
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Client Installation of DOORS TFS 3.0.2 Integration on Windows Platform
2. Uninstall Power Tool 2010.
3. Uninstall VS2010.
4. Install VS 2012.
5. Install Power Tool 2012.
6. Install DOORS TFS Addin 3.0.2.
7. Restart OS.

After performing above procedure, use one of the following options to launch 
Visual studio for first time.

• Open the Visual Studio Command prompt: Start > All Programs > 
Microsoft Visual Studio 2012 > Visual Studio Tools > VS2012 X86 
Native tools command prompt, and run the following command:

devenv/ResetAddin
• Run TFS_DOORS_Migration.exe from following default path

C:\Program Files\IBM\Rational\DOORS_TFS\Migration

After completing the upgrade, open Visual Studio 2012.

Note  If you are upgrading from TFS server 2010 to 2012, it’s 
mandatory to run TFS_DOORS_Migration.exe before using 
any functionality of DOORS TFS V3.0.2

Installing the DOORS TFS Integration:
1. Execute the 'DOORS TFS' installer

2. Select the “C:/Program Files/IBM/Rational/” target directory where 
DOORS is currently installed. i.e. “C:/Program Files/IBM/”.

3. Proceed with installation wizard.

Post Installation Check List
If the integration fails to show up on the Studio Tools menu or it does not 
execute, review the below check list to possibly identify installer errors that could 
be the cause of the problem.

• Verify the ‘TFS_DOORS_addin.Addin’ file was added to the directory: 
“C:\Documents and Settings\All Users\Application 
Data\Microsoft\MSEnvShared\Addins”
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Post Installation Check List
• Verify the folder ‘DOORS_TFS’ was added to the directory: “C:\Program 
Files\IBM\Rational\”

• Verify the file ‘TFSDOORSStartup.inc’ was added to the DOORS directory: 
\Program Files\Rational\DOORS\ [DOORS 
Version]\lib\dxl\startupFiles

• Verify the folder ‘TFS’ was added to the directory: C:\Program 
Files\Rational\IBM\DOORS_TFS\addins\

• Verify file ‘TFS_DOORS_addin.AddIn’ exists: “C:\Documents and 
Settings\All Users\Application Data\Microsoft\MSEnvShared\Addins\”

• Verify file ‘WitTabControl.wicc’ exists: “C:\Documents and Settings\All 
Users\Application Data\Microsoft\Team Foundation\Work Item 
Tracking\Custom Controls\11.0\”

• Verify file ‘SchedulerContol.wicc’ exists: “C:\Documents and Settings\All 
Users\Application Data\Microsoft\Team Foundation\Work Item 
Tracking\Custom Controls\11.0\”

• Verify that these folders are created after the installation:

• Below are the more important files to verify – many other dependency 
library files are included in the install. Verify files exist: “C:\Program 
Files\IBM\Rational\DOORS_TFS\TFS_DOORS_Addin.
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Client Installation of DOORS TFS 3.0.2 Integration on Windows Platform
• Verify the below files are created after the install. Location Folder: 
“C:\Program Files\IBM\Rational\DOORS_TFS\addins\TFS”.

• Verify the below files are created after the install. Location Folder: 
“C:\Program Files\IBM\Rational\DOORS_TFS\addins\TFS\Includes”

• Start Visual Studio and verify the following:

a. Go to the Tools menu and select ‘options...’

b. Check the “show All Settings” option in the bottom left of the window.

c. Select ‘Add-in/Macros Security option as shown in the figure below.

d. Verify you have an entry 
%ALLUSERSPROFILE%\ApplicationData\Microsoft\MSEnvShared
\Addins
16    Installation and Administration Guide



Post Installation Check List
e. If not - manually add it to the Add-in File Paths and then restart Visual 
Studio

If the integration still fails to show in the forms or from the Tools menu, please 
contact support.
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Client Installation of DOORS TFS 3.0.2 Integration on Windows Platform
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3 DOORS Configuration Module

After client installation and TFS Server and Project configuration is completed, 
the integration can operate normally without further configuration of the 
DOORS environment. If the integration is executed and links are created the 
default configuration is used and the initiating operation continues normally.
To specify other default settings or define additional Attributes to be imported 
and exported, a TFS DOORS CONFIGURATION module is required. Using 
the configuration module you can specify which link type to use when creating 
links between DOORS and TFS items, define and map what data to import and 
store in both applications, define which DOORS attributes to retrieve for 
viewing on the “Real Time Data” display found on Edit Link Dialog.
The DOORS configuration module settings will apply to all DOORS modules 
with in the same folder and sub folders, similar to the DOORS inheritance 
method for access rights. This allows the ability to group common types of 
DOORS modules into a folder and have unique TFS integration settings for that 
group. At run time the integration searches first in the current Folder/Project 
for a Configuration module, then searches through all ancestor folders/Projects 
stopping at the first one it finds. If one is not found, the initiating operation 
continues in the integration, but a warning will be provided to the user indicating 
that no DOORS configuration could be found.
The configuration module is composed of 3 Sections:
1. TFS To DOORS: This section is used to map which TFS workitem attributes 
to import and store on the DOORS Object’s External Link attribute.
2. DOORS To TFS: This section is used to map additional DOORS Object 
attributes to export and store in TFS using the DoorsProxy item. Each workitem 
link to DOORS creates a new DoorsProxy item. This item is similar to the 
‘DOORS Surrogate’ object sometimes used in older DOORS integrations.
3. TFS Link Display Info: This section allows the ability to easily define 
additional DOORS Object attributes to be accessed in ‘Real Time’ when a TFS 
user is viewing a workitem to DOORS link using the new DOORS Link Editor 
dialog. These attributes are not stored in TFS and can only be scene from the 
Edit Link Editor. When viewing, the Edit Link Editor attempts to access 
DOORS and retrieve the current attribute data and display it using a dynamic 
grid list.
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DOORS Configuration Module
Create Configuration Module
To generate a configuration module:

1. Open any DOORS module in the current folder where you want the 
configuration module to apply. 

2. From the module tool bar, click TFS > Create Configuration Module.

A configuration module is created and opened for edit.

Note  To Allow multiple Configurations in same DOORS project. 
The current design allows you to place this module in the 
same project as the requirement modules that the mappings 
apply too. You may also create multiple configuration 
modules. These may be placed in the DOORS local 
container in the nearest “ancestor” container. The tool will 
then search backwards through all ancestry containers until 
the first Configuration module is found.

Adding Attribute and Field mappings

TFS To DOORS

Section 1 of the configuration module -TFS To DOORS contains attribute 
mappings for the data you want to import from a TFS work item and store in 
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Adding Attribute and Field mappings
DOORS. This data will be stored on the External Link of the DOORS Object as 
a LINK attribute.

1. Open the configuration module in EDIT mode.

2. Select the Object “TFS To DOORS” and create a new child object below.

3. Select the new object just created, and click in the “DOORS Attribute” 
column. Enter in the name of the DOORS attribute you want to use to store 
the imported data. This attribute will be created in the DOORS module 
when a link to a TFS workitem is created, Synchronize is executed, or if the 
TFS > Configure Module For Synch option is executed.

For ease of use, prefix the name with “TFS” as a mandated naming standard 
for Rational DOORS integrations. This mandate is to insure unique attribute 
names that will not conflict with other integrations. The attributes 
“Description” and “Title” are reserved names and apply to the External link 
“Description” and “Name” system attributes

4. Click in the TFS Attribute column. Enter in the name of the TFS workItem 
attribute to be imported. A list of work item attributes available can be 
viewed by using the Visual Studio TFS query results dialog Column setup 
menu option after running any TFS query.

DOORS To TFS

Section 2 of the TFS DOORS CONFIGURATION module can be used to 
define additional DOORS Object Attribute data (in addition to the Default 
attributes) to be exported to TFS and stored in a TFS DoorsProxy workitem. 
This provides the same data per link capability as External Link Attributes in 
DOORS.

Caution  Simply adding in new attribute mapping data as done in 
Section 1 WILL NOT cause the integration to import 
and store attributes as a new attribute of the DoorsProxy 
work item. As stated in section 1, the TFS attribute data 
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DOORS Configuration Module
must be an existing attribute of the TFS workitem. 
Integration uses a NEW workitem type (DoorsProxy) to 
store imported data. The DoorsProxy type definition 
must be modified to define attributes/fields to store the 
NEW attributes you wish to import. (See registering 
DoorsProxy definition for more information).

A standard Set of Attribute data is always imported into TFS from DOORS. 
These standard attributes are:

• Object URL:

• Module Name

• Object ID

• Object Text

• Object Short Text

• Last Modified On

• Last Modified By

They are stored using a new workitem type called ‘DoorsProxy’ which is created 
for each workitem to DOORS link.
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Adding Attribute and Field mappings
The standard attributes are mapped as seen below:
Installation and Administration Guide           23



DOORS Configuration Module
Configure Link Display Info

Section 3 - is used to define the DOORS Object Attributes you want to display 
in the Edit Link Editor: Real Time Report View tab panel.

Edit Link dialog is accessible from DOORS Link tab control of workitem. You 
need to select a link and click on Edit button.
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Adding Attribute and Field mappings
It will open the Edit Link dialog. 

To display Object Heading and Object Text similar to the DOORS main column 
enter ‘Object Heading and Object Text’ as the ‘DOORS Attribute’ value in 
configuration module.
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DOORS Configuration Module
Default Work Item Link Type

The integration defaults to the new ‘DoorsLinkType’ when a new configuration 
module is created or if no configuration module is found.
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Running without a TFS CONFIGURATION module
Running without a TFS CONFIGURATION module
Integration can operate with no existing Configuration Module at DOORS side. 
When a module is linked or synched without configuration the software searches 
the local folder and then all ancestor folders to locate a TFS 
CONFIGURATION module. If no configuration module is found then 
integration will show following message:

Link Creation:
“Link is/are not created because Configuration Module is not 
available.Create Configuration Module then try Create Link 
operation again.”
Task Creation:
“Task and Link are not created because Configuration Module is 
not available.Create Configuration Module then try Create Task 
operation again.”
Synchronization: 
Synchronization will not complete and it will log the message to 
log file.
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DOORS Configuration Module
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4 Configure DOORS Requirements 
Module

Before you create links it is best to configure your requirements module using 
the “Configure Module for TFS Synch” option. Configuration of a module 
attempts to create any user defined attributes identified in Section 1 of the 
nearest TFS DOORS CONFIGURATION module. The software will 
automatically attempt to create the attributes it needs at run time, but it is best to 
pre-configure each module to minimize the possibility of errors due to a user’s 
access to create new object level attributes.
To configure the Rational DOORS requirement module:
1. Open the module and click TFS > Configure Module For TFS Synch. 

A window is displayed listing all the attributes identified in the configuration 
module that apply to the current module.

2. Click Confirm.

The configured attributes will be created in the Module as Object level attributes. 
Imported TFS data will actually be stored on the Objects External Link, but in 
DOORS external links inherit the same attributes as the Object they belong to.
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Configure DOORS Requirements Module
Note  Consider prefixing the attribute name that you choose with 
“TFS” as a mandated naming standard for DOORS 
integrations. This mandate is to insure unique attribute 
names that will not conflict with other integrations. The 
attributes “Description” and “Title” are reserved names and 
apply to the External link “Description” and “Name” system 
attribute.
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5 Connect to TFS Server From Visual 
Studio

We can connect to Team Foundation Server from Visual Studio with the help of 
Team Explorer. 

1. Start Microsoft Visual Studio 2012.

2. Click Team > Connect to Team Foundation Server.
3. Click Servers, and then Add.

4. Enter the TFS Server Name and the port number.

5. Click OK, and then Close.

6. Select the Team Project Collection in the left-hand pane and the Team 
Project in the right-hand pane, and then click Connect.
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You are connected to the Team Project, and the Team Explorer is opened.

7. Click Work Items.
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Log File
6 Logging and setting the proxy

Log File
The integration also generates a log file each time it is executed. The log file will 
be placed in the directory path specified by the environmental settings in the 
%ALLUSERSPROFILE% environment variable standard on most windows 
platforms. Normally the path is similar to the example below:

C:\Documents and Settings\All Users\Application 
Data\IBM\DOORS_TFS\Log\TraceListener.log

DOORS Proxy Item
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In order to support the extended “Link Attributes” for links of 
‘DoorsLinkType’, a proxy/surrogate workitem object is used as recommended 
by Microsoft. A new WorkItem type is defined (DoorsProxy) in integration and 
will live in the same WorkItem DB Table. This design requires less configuration 
and more Reporting capability. Normally new external link types require a NEW 
SQL DB to be created to house the external proxy items.
To help isolate these proxy items from the normal Workitems, the proxy objects 
live in different area paths. The first area path is called “Doors” and is a sub area 
under the main Project area. The second area path is called “Doors\Deleted” 
and is a sub area under ‘Doors’. When a Link to DOORS is created a new Proxy 
object is created and placed into the “Doors” area. At this time the only way to 
filter these objects out of the “All Workitems” Query is to modify the query to 
not accept items of type “DoorsProxy” or not accept “Blocked” items or filter 
for “areaPath” != @Project “/Doors”
The second area “Doors\Deleted” is used when a DOORS link is deleted 
USING ONE OF THE DOORS INTEGRATION DELETE OPTIONS. 
Normal link delete will delete the workitem link but it does not modify the 
DoorsProxy item and it will remain ACTIVE until an Admin cleanup is 
performed. If the link is deleted using the integration, the DoorsProxy object 
will changed to a new STATE of ‘Deleted’ and will be moved into the 
‘Doors\Deleted’ areaPath. This area path if configured as instructed later should 
have security settings so that ‘contributors’ do not have certain access rights. 
These restricted rights will automatically filter the DELETED items from any 
future queries.
The reason for not just ‘deleting’ the proxy object from the database is because 
the TFS process does not allow any workitem deletions physically from the 
database. The reason is documented as to support Sarbanes Oxley compliance -
which restricts deletion of data for any reason through the interface or API. 
However, since TFS is hosted on SQL server, a Server Admin could clean up 
records in the WorkItem Table and bypass the TFS Server layer. Only do this to 
remove DoorsProxy objects that are in a State of Deleted or have no link to an 
existing WorkItem.
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DOORS Proxy Item
Link Attribute Change History

One of the added benefits of the DoorsProxy item is that an automatic change 
History is kept by the system.
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7 Contacting support

This chapter contains the following topics:

• Contacting IBM Rational Software Support

• Prerequisites

• Submitting problems

• Other information

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM Rational Software Support for assistance in resolving product 
issues.

Note  If you are a heritage Telelogic customer, you can go to 
http://support.telelogic.com/toolbar and download the 
IBM Rational Telelogic Software Support browser toolbar. 
This toolbar helps simplify the transition to the IBM Rational 
Telelogic product online resources. Also, a single reference 
site for all IBM Rational Telelogic support resources is 
located at 
http://www.ibm.com/software/rational/support/telelogic/

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html.

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_
quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM website) to IBM Rational 
Software Support, you must additionally:
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• Be a registered user on the IBM Rational Software Support website. For 
details about registering, go to http://www.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems
To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.

Use the following table to determine the severity level.

2. Describe your problem and gather background information. When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers 
to these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you:

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3 The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4 The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.
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Submitting problems
• Start the IBM Installation Manager and click File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number.

• Start your product, and click Help > About to see the offering 
name and version number.

• What is your operating system and version number (including any 
service packs or patches)?

• Do you have logs, traces, and messages that are related to the problem 
symptoms?

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem?

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components?

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support website at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html.

You can also open an online service request using the IBM Support 
Assistant. For more information, go to 
http://www.ibm.com/software/support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region.

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
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If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Program 
Analysis Report (APAR). The APAR describes the problem in detail. Whenever 
possible, IBM Rational Software Support provides a workaround that you can 
implement until the APAR is resolved and a fix is delivered. IBM publishes 
resolved APARs on the IBM Rational Software Support website daily, so that 
other users who experience the same problem can benefit from the same 
resolution.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software website on http://www.ibm.com/software/rational/.
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8 Notices

© Copyright IBM Corporation 2006, 2014
US Government Users Restricted Rights - Use, duplication, or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
Intellectual Property Licensing 
Legal and Intellectual Property Law 
IBM Japan Ltd. 
19-21, Nihonbashi-Hakozakicho, Chuo-ku 
Tokyo 103-8510, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
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Notices
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you.
This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice.
Any references in this information to non-IBM websites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
websites. The materials at those websites are not part of the materials for this 
IBM product and use of those websites is at your own risk.
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you.
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
5 Technology Park Drive 
Westford, Massachusetts 01886 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee.
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us.
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
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Trademarks
may vary. Users of this document should verify the applicable data for their 
specific environment.
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

A current list of IBM trademarks is available on the web at 
www.ibm.com/legal/copytrade.html.
Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both.
UNIX is a registered trademark of The Open Group in the United States and 
other countries.
Other company, product or service names may be trademarks or service marks 
of others.
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