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About this document

This document describes IBM® Rational® TestManager features that have been
introduced in the past several service releases, from version 2003.06.12 to version
7.0. The information in this document supplements the information in the IBM
Rational TestManager help and IBM Rational TestManager User’s Guide.

Who should read this document

The information in this document is intended for Rational TestManager users.

Typographical conventions

This manual uses the following typographical conventions:

© Copyright IBM Corp. 2000, 2006

ccase—home—dir represents the directory into which Rational ClearCase, Rational
ClearCase LT, or Rational ClearCase MultiSite has been installed. By default, this
directory is /opt/rational/clearcase on the UNIX system and Linux, and
C:\Program Files\Rational\ClearCase on Windows.

cquest-home-dir represents the directory into which Rational ClearQuest has been
installed. By default, this directory is /opt/rational/clearquest on the UNIX
system and Linux, and C:\Program Files\Rational\ClearQuest on Windows.

Bold is used for names the user can enter; for example, command names and
branch names.

A sans-serif font is used for file names, directory names, and file extensions.

A serif bold font is used for GUI elements; for example, menu names and
names of check boxes.

Italic is used for variables, document titles, glossary terms, and emphasis.

A monospaced font is used for examples. Where user input needs to be
distinguished from program output, bold is used for user input.

Nonprinting characters appear as follows: <EOF>, <NL>.

Key names and key combinations are capitalized and appear as follows: Shift,
Ctrl+G.

[ ] Brackets enclose optional items in format and syntax descriptions.

{ } Braces enclose a list from which you must choose an item in format and
syntax descriptions.

| A vertical bar separates items in a list of choices.

... In a syntax description, an ellipsis indicates you can repeat the preceding item
or line one or more times. Otherwise, it can indicate omitted information.

Note: In certain contexts, you can use “...” within a pathname as a wildcard,
similar to “*” or “?”. For more information, see the wildcards_ccase

reference page.

If a command or option name has a short form, a “slash” ( / ) character
indicates the shortest legal abbreviation. For example:

1sc/heckout



Contacting IBM Customer Support for Rational software products

vi

If you have questions about installing, using, or maintaining this product, contact
IBM Customer Support as follows:

The IBM software support Internet site provides you with self-help resources and
electronic problem submission. The IBM Software Support Home page for Rational
products can be found at [ttp: / /www.ibm.com /software /rational / support /}

Voice Support is available to all current contract holders by dialing a telephone
number in your country (where available). For specific country phone numbers, go
to |http:/ /www.ibm.com /planetwide /|

Note: When you contact IBM Customer Support, please be prepared to supply the
following information:

* Your name, company name, ICN number, telephone number, and e-mail
address

* Your operating system, version number, and any service packs or patches
you have applied

e Product name and release number

* Your PMR number (if you are following up on a previously reported
problem)

Downloading the IBM Support Assistant

The IBM Support Assistant (ISA) is a locally installed serviceability workbench that
makes it both easier and simpler to resolve software product problems. ISA is a
free, stand-alone application that you download from IBM and install on any
number of machines. It runs on AIX®, (RedHat Enterprise Linux® AS), HP-UX,
Solaris, and Windows® platforms.

ISA includes these features:
* Federated search

* Data collection

* Problem submission

* Education roadmaps

For more information about ISA, including instructions for downloading and
installing ISA and product plug-ins, go to the ISA Software Support page.

IBM Support Assistant: |http://www.ibm.com/software/support/isa/|
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Chapter 1. Getting started

Overview

This documentation provides the following information about Rational
TestManager features:

* |Chapter 2, “Support for VMware GSX Server version 3.0,” on page 3|

¢ |Chapter 3, “Support for Business Objects Crystal Reports,” on page 7|

¢ |Chapter 4, “Citrix and Windows Terminal Server support,” on page 9

* [Chapter 5, “Enhancements to performance testing,” on page 15

* |Chapter 6, “Enhancements to test asset management and reporting,” on page 17]

¢ [Chapter 7, “General enhancements,” on pageﬂ

Support for DB2 databases

Rational TestManager has supported IBM DB2® as a database engine for test
datastores since version 2003.06.15. DB2 UDB Components for Rational Products
version 8.2 is shipped with Rational TestManager. This database platform replaces
SQL Anywhere as the database platform offering. This release of Rational
TestManager no longer supports SQL Anywhere.

Rational TestManager supports any DB2 database created with the following
software:

* DB2 UDB Components for Rational Products version 8.2 (shipped with Rational
TestManager)

* DB2 UDB Express version 8.2
* DB2 version 8.2

Note: Only Microsoft® Windows versions of DB2 are supported.

Information about installing DB2 can be found in the IBM Rational TestManager
Installation Guide.

Upgrading test datastores

When upgrading to Rational TestManager version 7.0 or later, note the following
important information related to test datastores:

* To take advantage of new reporting functionality, Crystal Reports version 11
support, and the new Test Case tracking capability, test datastores need to be
upgraded during the process of upgrading to Rational TestManager version 7.0
or later. The upgraded clients, however, can connect to a previous
(non-upgraded) test datastore until that test datastore can be upgraded
manually.

* Datastores that are created in the version 7.0 release can be accessed only in that
release and later releases. If the majority of your site has not upgraded to the
version 7.0 release or later, do not create new datastores or upgrade existing
datastores that were created in previous releases.

* When you upgrade a test datastore, all of the default Listing reports are
overwritten. You should not make changes to the default Listing reports. If you

© Copyright IBM Corp. 2000, 2006 1



have made changes, save them with a different file name or to a different
location before you upgrade the test datastore.

To upgrade a test datastore to version 7.0 or later:

1.
2.
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Make a backup copy of the datastore.

Open the IBM Rational Administrator by Click Start > Programs > IBM
Rational > Rational Administrator.

In the project pane, select the Rational project that contains the test datastore to
be upgraded. Right-click the project and then click Upgrade Assets.

Click OK when you see the message reminding you to back up your data.

Click View Log to examine the results of the operation and ensure that it
completed successfully. Click Done.



Chapter 2. Support for VMware GSX Server version 3.0

Rational TestManager now supports VMware GSX Server version 3.0 for managing
virtual machines on Windows 2000 and Windows XP.

Using TestManager with software that manages virtual machines

To actively manage virtual machines hosting Rational Test Agents, Rational
TestManager can now work with software that manages virtual machines, such as
VMware GSX Server.

Note: Rational TestManager currently supports VMware GSX Server version 2.5.0
and version 3.0 for managing virtual machines on Windows 2000 and
Windows XP. To purchase VMware GSX Server, contact VMware sales at
sales@vmware.com or 1-877-4VMWARE.

You can designate a Rational TestManager computer asset as a virtual machine
host by adding a special descriptor to its Computer Properties Description field.
This descriptor associates the name, server, and other management parameters for
the virtual machine with the computer.

During a test suite run, the execution states of any virtual machine hosts that are
included will be automatically managed by Rational TestManager. If the run
includes more virtual machine hosts than a virtual machine server can manage
concurrently (for example, due to server resource limitations), the virtual machine
hosts will be automatically multiplexed between activated and deactivated states as
necessary until the run is completed.

To take advantage of this new function, you must perform the following tasks:

1. Install the VMware GSX Server Scripting API on the Rational TestManager
system.

2. Set up Windows Auto-Logon for Test Agent virtual machines.

3. Configure the VMware Authorization Service for servers that host Test Agent
virtual machines.

4. Add a new VMHOST_INFO descriptor in the Computer Properties Description
field.

Setting up Windows Auto-Logon

You cannot use the Rational Test Agent Service (rtpsvc.exe). Instead, you must use
the Rational Test Agent Daemon (rtprvd.exe) and you must configure the daemon
to start automatically when a virtual machine hosting a Rational Test Agent is
started. First, copy the daemon into the Startup folder of an account on the
Windows guest operating system for the virtual machine. Then configure Windows
to log on automatically using the credentials for that account, as described in the
following procedure.

To set the registry keys to enable Windows Auto-Logon:

1. Follow this procedure to open the Registry Editor:
a. From the Windows desktop, click Start > Run.
b. Type regedit and then click OK.

© Copyright IBM Corp. 2000, 2006 3



2. In the Registry Editor, expand the tree on the left to display the keys for
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\Winlogon].

3. For each of the following keys, right-click the key, click Modify, change the
value, and then click OK.

Table 1. Registry key values

Registry key Value
AutoAdminLogon 1
DefaultDomainName YourDomainName
DefaultUserName YourUserName
DefaultPassword YourPassword

4. Click File > Exit to close the Registry Editor.

5. Repeat Step through Step @ for each virtual machine that hosts a
Rational Test Agent.

Configuring the authorization service

To allow Rational TestManager access to the VMware GSX Server remote functions
that are needed by for hosting test agent virtual machines, the VMware
Authorization Service on the server must be configured with a set of user
credentials to authorize this access. All virtual machines that are started by
Rational TestManager on that server are then run as that user.

To enable this access, also known as VMware Trusted mode:

1. Run the program named authtrusted.exe in the VMware GSX Server product
folder.

2. Set the desired user credentials according to the directions provided by
VMware GSX Server.

After you have completed these steps, Rational TestManager can remotely manage
virtual machines on that server without any further configuration of the VMware
GSX Server software.

Adding a new VMHOST_INFO descriptor

For Rational TestManager to recognize that a computer asset is hosted by a virtual
machine, you must add a new VMHOST_INFO descriptor to the Description field
in the Computer Properties window for that computer.

To add the VMHOST_INFO descriptor:
1. From Rational TestManager, click the Execution tab.
2. Right-click any computer in the computer list, and click Properties.

3. Add the VMHOST_INFO descriptor by using the following format, and then
click OK.

This is the format of the descriptor:

VMHOST_INFO= vmserver-name; vm-name; final-state; redo-action
All fields are required.

VMHOST_INFO

Required descriptor. It must be spelled correctly (no space
between VMHOST_INFO and the equal sign) or the remaining
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information will be ignored and the computer will be assumed
to be a non-virtual machine host.

vmserver-name
The name of the physical machine that is running virtual
machine management software and hosting the virtual
machine. For VMware GSX Server, this is the name of the
VMware GSX Server host where the virtual machine is
registered.

vm-name The name of the virtual machine (also known as virtual host)
that is hosting the test agent associated with the computer. For
a virtual machine that is hosted by VMware GSX Server, this is
the path name to the virtual machine’s configuration file that is
registered with the VMware GSX Server host for that virtual
machine.

final-state Specifies the desired final state of the virtual machine after a
test suite has been run. This field can have one of four values:

¢ POWEREDON: The virtual machine will be left in the
powered-on (started) state.

¢ SUSPENDED: The virtual machine will be left in the
suspended (deactivated) state.

e INITIAL: The virtual machine will be returned to the state it
was in before the test suite was run.

e DEFAULT: The virtual machine will be set to the default final
state (currently INITIAL).

redo-action Specifies how virtual-disk redo logs that are associated with the
virtual machine should be handled when a decision is required
by the virtual machine management software. This can happen
when a virtual machine is placed in a started or stopped stated
and redo logs have been persisted. This field can have one of
four values:

¢ COMMIT: Any pending data for the redo log will be
committed to the virtual-disk images.

* DISCARD: Any pending data for the redo log will be
discarded. Data that has been discarded cannot be recovered.

* PRESERVE: Any pending data for the redo log data will be
preserved (neither committed nor discarded).

* DEFAULT: The default redo action will be taken (currently
PRESERVE).

Limitations of using Rational TestManager with virtual
machine management software

Rational TestManager does not support the use of virtual machines in a
powered-off initial or final state. Transitioning a virtual machine from or to a
powered-off state can result in modal blocking conditions that Rational
TestManager cannot respond to. This might cause your machine to hang or cause
other timeout-related failures.

As an alternative to the powered-off state, you should use suspended mode for
initial and final virtual machine states. This allows virtual machines to free
resources back to the host operating system when they are no longer needed
without requiring powered-off transitions.

Chapter 2. Support for VMware GSX Server version 3.0 5
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Chapter 3. Support for Business Objects Crystal Reports

Rational TestManager includes the Crystal Reports version 11 runtime libraries
(DLLs) that are required for viewing and running reports in Rational TestManager
clients. Rational TestManager installs the files automatically.

However, to author or edit reports, you must purchase a copy of Crystal Reports
Professional Edition or other Crystal Editions that contain Crystal Designer version
11. For instructions about how to install and license Crystal Reports Professional
Edition or other Crystal Editions, contact Business Objects at
fwww.businessobjects.com]

Using Rational TestManager with Crystal Reports version 11

Test datastores that were created with earlier versions of Rational TestManager are
compatible with version 7.0 of Rational TestManager. However, to benefit from the
new features provided with this release, you must upgrade your test datastores to
version 2003.06.13 or later.

Versions of Rational TestManager earlier than version 2003.06.13 use Crystal
Dictionary to run listing reports. Reports based on Crystal Dictionary are not
supported in Crystal Reports version 11, the supported Crystal version for version
2003.06.13. For this reason, version 2003.06.13 provides replacement listing reports
that do not use dictionaries. These replacement listing reports were created with
Crystal Reports version 8.5 to be fully compatible with Crystal Reports version 8.5
through version 11.

You can continue to use Crystal Reports version 8.5 to run old dictionary-based
reports and to create and run new reports that do not rely on dictionaries.

New datastores that you create do not include dictionaries. When you upgrade a
version 2003.06.12 datastore that includes dictionaries, the datastore retains those
dictionaries. If you previously modified a listing report in Crystal Reports version
8.5 and you now want to edit or run that report in Crystal Reports version 11, you
must complete these steps:

1. Upgrade the test datastore for the report to version 2003.06.13 or later, or create
a new datastore in version 2003.06.13 or later.

2. Re-create the report by copying and pasting its modified design elements to the

corresponding replacement listing report. (For instructions, see
[reports with Crystal Reports version 11.”)

Note: Before you upgrade a test datastore, you must upgrade all clients that use
that datastore. If you are not ready to upgrade all clients to version
2003.06.13 or later, do not upgrade the test datastore.

Re-creating reports with Crystal Reports version 11

To re-create a listing report that you modified with Crystal Reports version 8.5:
1. Click Start > Programs > IBM Rational > Rational TestManager.

2. In the Rational Test Login window, type the password, select the Rational
project, and then click OK.

© Copyright IBM Corp. 2000, 2006 7
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3. In the test asset workspace, click the Analysis tab to display the reports.
Expand the Listing Reports folder to display the listing reports. Find the
replacement nondictionary-based listing report that corresponds to the
dictionary-based report that you used to create the customized Crystal Reports
version 8.5 report. For example, if you created a report in version 8.5 named
Modified Build Detail Report based on the Build Detail Report, find the
nondictionary-based Build Detail report. Right-click the nondictionary-based
report and click Open.

4. In the Listing Reports window, click New. Type a name for the new report
and click OK. The report opens for editing.

5. Click Start > Programs > Crystal Reports to start Crystal Reports version 8.5.

6. In the Welcome to Crystal Reports window, select Open an Existing Report
and select the report from the list. The report opens in the Crystal Reports
version 8.5 editor.

7. In the Crystal Reports version 8.5 editor, select and copy the design elements
that you modified.

8. In the Crystal Reports version 11 editor, paste the design elements into the
new report.

9. Click File > Save to save the re-created report.
10. Click File > Close to end the editing session.

In version 2003.06.13, changes in the structure of some listing reports has
caused some assets to be renamed or moved to new tables. For example, the
Build Details report now includes two tables, Build and Iteration. In earlier
versions of Rational TestManager, the Iteration field identified an iteration
name. In version 2003.06.13, the Iteration field in the Build table identifies a
UID. The iteration name is provided by the Name field in the new Iteration
table. To determine if this type of problem exists with your report, right-click
the report in the Rational TestManager test asset workspace and click Run.
Examine the report for any unexpected field data.

 If a problem exists, continue with the next step.

* If no problems exist, you are done with this report and you can begin
recreating your remaining reports.
11. Open the new report in Crystal Reports version 11 and then click View >
Field Explorer to display the tables and field definitions for the report.

12. In general, to resolve a problem with an asset, go to that table for that asset.
For example, to resolve the Iteration field problem, go to the Iteration table
and use its Name field to replace the vfield in the report.

13. Save the changes to the report and run it again to verify that you have solved
the problem.

Uninstalling the Crystal Reports version 8.5 runtime package

By default, Rational TestManager version 2003.06.13 or later uses the Crystal
Reports version 8.5 runtime package to run your listing reports. After you re-create
all modified reports to be compatible with Crystal Reports version 11, uninstall the
Crystal Reports version 8.5 runtime package so that Rational TestManager version
2003.06.13 or later uses the Crystal Reports version 11 runtime package to run your
reports.
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Chapter 4. Citrix and Windows Terminal Server support

Rational TestManager is the central console for test activity management, execution
and reporting. Built for extensibility, it supports everything from manual test
approaches to various automated paradigms.

With the introduction of Rational TestManager with Terminal Server Support,
Rational TestManager can be accessed by disparate members of a project team,
ensuring the high visibility of test coverage information, defect trends, and
application readiness.

Lifecycle integrations

Rational TestManager can be integrated with Rational’s Team Unifying Platform
tools. Rational TestManager is configured for integration with Rational
RequisitePro® ensures seamless traceability between requirements and test cases,
resulting in clear test coverage metrics and sensitivity to requirement modification.
Rational TestManager is also configured for integration with Rational ClearQuest®,
which allows you to perform in-context defect submission directly from the
Rational TestManager Log Viewer, automatically porting test run data into the
defect report to ensure accuracy.

Supported operations

lists the software, platforms, operations, and integrations that Rational
TestManager with Terminal Server supports.

Table 2.

Header Header

Supported terminal software products « Citrix MetaFrame software Feature
Release 3

* Microsoft Window Terminal Server (WTS)
2003, version 5.2, version 2.2

* Rational TestManager version 2003.06.15
(Windows) only

Supported platforms For a list of supported platforms and
versions, see the IBM Rational TestManager
Release Notes.

© Copyright IBM Corp. 2000, 2006 9



Table 2. (continued)

Header Header

Supported operations and integrations All areas of Rational TestManager are
supported within this environment except
for the following;:

* Execution: Only execution of Rational
Robot GUI and Manual test types is
supported. All other test type execution,
such as Rational Functional Tester GUI,
VU, Java'", VB, and command line, are
not supported and are not features

planned for release.

* Execution monitoring: This is not
supported in the terminal environment.
Users needing this functionality should
run tests directly from the Rational
TestManager client as they do today
outside of the terminal environment.

» Agent playback: This is not operational,
nor is it supported for this release.

Unsupported integrations * IBM Rational Functional Tester (RFT) is
not a supported Rational TestManager
Terminal Solution integration. RFT does
not support Citrix or WTS environments.

* IBM Rational Manual Tester (RMT) is not
a supported Rational TestManager
Terminal Solution integration. RMT does
not support Citrix or WTS environments.

Installation and configuration instructions

This section provides instructions for installing and configuring Citrix and
Windows Terminal Server software for use with Rational TestManager.

Installing the software
Install the following software:
* Windows Terminal Server software

For installation and configuration guidelines, see the Citrix or Microsoft WTS
documentation.

* Rational TestManager, Rational License Server, and Rational Administrator

For installation and configuration guidelines for these products, see the

following guides:

— IBM Rational TestManager Installation Guide and the IBM Rational TestManager
Release Notes

— License Server and Rational Administrator documentation, Readme, and
Release Notes

If you are using a Rational Suite or Rational Team Unifying Platform software,
see the installation guides for these products.
* The SQL Anywhere Database

Optionally, you may either connect to your existing SQL Anywhere server or
install a new server. If you need to install the SQL Anywhere database server,
see the installation guide for the IBM Rational product.
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Attention:

is required. See |http:/ /www-1.ibm.com/support/docview.wss?rs=946|

If installing SQL Anywhere 8.0.2 on Windows Server 2003, a patch

[&uid=swg21192670] For SQL Anywhere and datastore configuration instructions,

see the readme and the release notes.

Enabling Rational TestManager terminal capabilities

Rational TestManager terminal capabilities are blocked for use. You must enable
the functionality with a registry key.

The following procedure adds a registry key to the Terminal Services client
computer to disable the functional block.

1.
2.
3.

© © N O

Click Start > Run.
In the Run field, type regedit and then click OK.

In the left pane of the Registry Editor, navigate to the following folder in the
registry tree: \HKEY_LOCAL_MACHINE \Software\Rational Software\

Select the Rational Software folder in the registry tree.
Click Edit > New > Key.

Type Rational Administrator and then press Enter.
Select the Rational Administrator folder you just created.
Click Edit > New > Key.

Type CTXS and press Enter. You should now have the following key in your
registry: \HKEY_LOCAL_MACHINE\Software\Rational Software\Rational
Administrator\CTXS.

Setting environment variables

Set environment variables as follows:

.

1.
2.
3.

0.

Right-click the My Computer icon and click Properties
Click the Advanced tab.

Click the Environment Variables button near the bottom of the Advanced
page.
In the User variables section, click New.

In the Variable name field, type RT_MASTER_SHM_KEY; in the Variable value
field, insert values from 1-255.

Note: This value needs to be unique for each end user that is concurrently
running tests, and must be in the range 0 (default) to 255. Assign
numbers beginning with 1, 2, or 3. Leave 0 unassigned in case an end
user forgets to set a value and uses value 0 by default.

Click OK.

Click New.

In the Variable name field, type RT_MASTER_MONITOR_VIEW_TIMEOUT; in the
Variable value field, insert 5 (or 10).

Click OK to set the values and then click OK on each window until all the
windows are closed.

Start Rational TestManager. (If a user was running Rational TestManager,
make sure to close and restart Rational TestManager to initiate the newly
configured variable).

Chapter 4. Citrix and Windows Terminal Server support

11


http://www-1.ibm.com/support/docview.wss?rs=946&uid=swg21192670
http://www-1.ibm.com/support/docview.wss?rs=946&uid=swg21192670

MKS NuTCRACKER platform applications in terminal
environments

NuTCRACKER is a Rational TestManager component. To ensure proper operation
of NuTCRACKER on Windows Server 2003 or Windows 2000 Service Pack 4, user
privileges may need to be updated.

With Windows Server 2003 and Windows 2000 Service Pack 4, Microsoft has
disallowed non-privileged users from creating global objects. There is a new
privilege Create Global Objects (SeGlobalName) that is needed in order to create,
but not access, a global named object.

Citrix and WTS users should reference the technote at|http://
www.mkssoftware.com /support/ tn-wints.asp}

Error messages and troubleshooting

You may see the following error messages:
* RT Master Process error

The value of RT_MASTER_SHM_KEY needs to be unique for each end user that
is concurrently running tests, and must be in the range 0 (default) to 255. Assign
numbers beginning with 1, 2, or 3. Leave 0 unassigned in case an end user
forgets to set a value and uses value 0 by default.

If this value is not set a user starting a test while another user's test is running
will get the following fatal initialization error message: "Another RTmaster
process is running."

Initializing TestManager Suite run...
[1.1.4.35]
check ipc: couldn’t remove previous shared memory segment,
key=-x99990000 [1.1.4.83]
check ipc: couldn’t remove previous semaphore #1,
key=0xaaab0000 RTmaster: fatal user initialization error [1.1.6.22]
Another RT master process is running.

Resolution: Set the RT_MASTER_SHM_KEY values following the instructions in
[“Setting environment variables” on page 11

e RT Master Monitor View error

Execution monitoring, visually monitoring execution progress, is not supported
in the terminal environment. Users needing this functionality should run tests
directly from the Rational TestManager client outside of the terminal
environment. When running tests from within the terminal environment, users
will see the following error message instead of the visual monitoring. This error
can be safely ignored.

Initializing TestManager suite run...
[1.1.4.71]

Continuing with run, although a timeout of 30031 seconds occurred
while waiting for Monitor views to initialize (perhaps due to a large user
count). To change this timeout value, set the system environment
RT_MASTER_MONITOR_VIEW_TIMEOUT to the desired timeout
value, and restart the application.

The value 30031 represents the default setting of 30 seconds. If you change it to
5 or 10, you will still see it, but the 30 will be changed to 5 or 10, respectively.
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Note: The value 30031 corresponds to the default 30 second refresh interval.
Though reducing the refresh interval will not resolve this error, the error
will be displayed to users sooner. Set the
RT_MASTER_MONITOR_VIEW_TIMEOUT values following the
instructions in [“Setting environment variables” on page 11

Chapter 4. Citrix and Windows Terminal Server support 13



14 Documentation Supplement



Chapter 5. Enhancements to performance testing

This chapter describes the enhancements to the performance testing features of
Rational TestManager.

VU scripts: Defining the maximum size for ODBC columns

You can define a maximum size (in bytes) for the ODBC columns and override the
default of 1 MB as the size for binary large object (BLOB) columns.

To define a maximum size, modify your script to specify a maximum column size
using the sqlcursor_setoption() command with the newly added option
ODBC_MAX_DEF_COLSIZE. This option should be added before the
sqlfetch_cursor() command.

The following sqlcursor_setoption() command sets a 1000-byte limit on the column
size:
stmt_2_ 1 id = sqldeclare_cursor["0DBC_001"] "", "SELECT TypeID FROM UserTable

WHERE UserID = ?";
sqlopen_cursor ["ODBC_002"] stmt 2 1 id, "12345";

sqlcursor_setoption(stmt_2_1 id, ODBC_MAX_DEF_COLSIZE, 1000); /* Limit column size
to 1000 bytes =/
sqlfetch_cursor ["ODBC_003"] EXPECT_ROWS 1, stmt 2 1 id, ALL_ROWS;

The sqlcursor_setoption() command sets the limit for every subsequent cursor for
every column. To disable the limit (restore the default of 1 MB), use -1 as the
number of bytes (the last parameter).

In selecting the limit value, be sure to choose a number large enough to
accommodate the largest expected column. If you use a value that is smaller than
the size of a column, you can cause failures such as the following error:

ERROR -1: {error} STATE=01004, CODE=0, MSG=[Microsoft] [ODBC SQL Server Driver]
String data, right truncation

Enhanced high-volume testing

You can customize your system settings for high-volume testing on a single
computer running Windows (over 2000 virtual testers for each Windows host). To
do this, you must edit the registry to increase desktop heap memory (memory
used for dynamic memory allocation). For more information, see Appendix A in
the IBM Rational TestManager User’s Guide.

© Copyright IBM Corp. 2000, 2006 15
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Chapter 6. Enhancements to test asset management and
reporting

This chapter describes the enhancements to the test asset management and
reporting features of Rational TestManager.

Selection of multiple test assets

You can now select multiple test assets in the Asset Browser Planning view and
Test Plan view.

Asset Browser Planning view

If you select multiple test plans, you can delete, copy, paste, export, and import the
multiple items simultaneously. Three commands are available from the pop-up
menu: delete, copy, and export. There is only one parcel file for multiple exported
items. When you import the parcel file, multiple items are imported.

If you select either multiple iterations or different asset types (such as a test plan
and an iteration), you can only delete them.

Test Plan view

If you select multiple assets of the same type (such as two test cases), you can
delete, copy, paste, export, and import the multiple items simultaneously. Three
commands are available from the pop-up menu: delete, copy, and export. There is
only one parcel file for multiple exported items. When you import the parcel file,
multiple items are imported.

If you select either multiple configured test cases or assets of different types, you
can only delete them.

Importing and exporting test assets

You can move or copy existing test assets between and within Rational projects,
use vendor software to create importable versions of test assets, or use vendor
software to analyze exported test assets. Importing and exporting test assets are
subject to the following restrictions:

* Logs, log details, and test case results are not supported by the Rational
TestManager import functionality.

* Rational TestManager does not support importing and exporting queries.

¢ Test Suite implementations are not imported or exported. Test Suite reference
names can be imported or exported if the reference name exists in the import
destination test datastore.

Changes to test case reports

You can now run test case reports that display test case suspicion status as
presented by the test impact analysis capability. Using the test case suspicion
feature, you can track meaningful changes to test inputs so that you can update
the associated test cases or their implementations.

© Copyright IBM Corp. 2000, 2006 17
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Chapter 7. General enhancements

The features described in this chapter have been introduced or updated since the
last revision of the standard Rational TestManager documentation.

Additional layouts for Extended Log Listing reports

The following report layouts are now available in Extended Log Listing reports:
* Configured Test Case Results Detail

* Configured Test Case Results Overview

* Configured Test Cases

* Manual Script Event Log

¢ Test Case Detailed Results Overview by Build

* Test Case Results by Suite

¢ Test Case Results Detail

* Test Case Results Overview

* Test Case Results Summary by Build

* Verification Point History

For more information about these report layouts, go to fwww.ibm.com/|
ideveloperworks /rational /library /4320.html}

Icon and splash screen

The product icon and splash screen for Rational TestManager has changed since
the last revision of standard TestManager documentation.

Tracking of test case progress using states and points

Rational TestManager can now track the execution progress of test cases using test
case states and points. See Tracking Test Case Progress Using States and Points, which
is available on the IBM Publications Center at[www.ibm.com/shop/publications/|
to find the document, Search for SY24-6181-00 on the IBM Publications
Center.

Note: If you do not want to see state identifiers next to test case names in Rational
TestManager, click Tools > Options > View Options and clear the Show
Test Case States check box.

Extracting and reporting on test log details

Rational TestManager now provides the ability to extract test log details and to
report on test log details for functional tests. The ability to extract and manage test
logs details lets you further analyze test results. You can selectively filter data to
identify trends and other valuable information. For detailed information about this
function, go to [www.ibm.com/developerworks /rational /library /4320.html| .

Note: Before you can access these new features, you must upgrade your test
datastore. If you do not upgrade the datastore, options related to extracting
and reporting on test log details are not available.

© Copyright IBM Corp. 2000, 2006 19


www.ibm.com/developerworks/rational/library/4320.html
www.ibm.com/developerworks/rational/library/4320.html
www.ibm.com/shop/publications/order
www.ibm.com/shop/publications/order
www.ibm.com/developerworks/rational/library/4320.html

To extract test log details:
1. After running a test, click the Results tab in Rational TestManager.

2. Click a test log to extract, use Ctrl + click to select multiple logs, or click a
build to extract all log detail for that build.

3. Right-click and click Extract Log Info.

To overwrite log details that were previously extracted:
1. Select the log or logs to overwrite.
2. Right-click and click Clear Log from Cache.

Creation and management of test log detail reports is much like the creation and
management of other reports.

To create a report that includes extended test log details:

1. Select the log or logs to use for the report.

2. Extract the test log details as described in the previous procedure.
3. Select Reports > New > Extended Log Data.

To specify preferences for how log details are extracted:
1. Click Tools > Options.
2. Click the Extended Log Detail Preferences tab.

From this page you can specify several choices for the management of log
details:

* The Always extract when exiting changed logs check box indicates that log
data is extracted each time a log is closed. This is applied per user.

* The options in the When overwriting a previously extracted log section
indicate whether you are asked about log extraction each time a log is closed,
or whether the log is always or never extracted without prompting. These
options also are applied on a per user basis.

* The Log Details list lets you choose which of about 80 available log details
you want to include when you extract data, on a per datastore basis. You can
choose one or all of the details, or any in between, to create truly customized
data. If you do not specifically choose any log details for extractraction,
Rational TestManager extracts the core log details.

3. When you are finished making changes, click OK. When you close the window,
Rational TestManager extracts log data for the current log according to the
options chosen or retained.

As with other reports, you can customize log detail reports through Crystal
Reports. For information about customizing reports, see the Crystal Reports
documentation.

IBM Rational Functional Tester

Rational Functional Tester (RFT) is an object-oriented automated testing tool that
you can use to test Java and HTML applications running on the Windows NT®,
Windows 2000, Windows XP, and Linux and UNIX® system platforms.

Note: Rational XDE " Tester is the old name for this product. It was first
introduced as Rational Robot] in Rational Suites Enterprise Studio, Rational
Suites TestStudio®, and Rational TeamTest version 2002.05.02. RFT is
integrated with Rational TestManager. It is a stand-alone point product, but
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it maintains the same integrations when you have the 2003.06.xx versions of
both XDE Tester and Rational TestManager installed.

RFT and Rational TestManager

When you associate an RFT datastore with a Rational project, you can perform
these tasks:

* Create and play back scripts, including RFT scripts, from Rational TestManager.
Use the Rational TestManager Agent to play back scripts on a remote computer.

* View scripts from the Test Scripts window of Rational TestManager.

You can use the Test Log window of Rational TestManager to perform these tasks:
* Open a test log to view a result.
* Filter the data of a test log to view only the information you need.

* Open the test script that generates a log event in the appropriate test-script
development tool. For example, if you create an RFT script and run it from
Rational TestManager, when you click a log event, RFT opens and displays the
script.

* Analyze the results of a test log using the Verification Point Comparator. If you
use RFT to record scripts, you can analyze the results in the Verification Point
Comparator to determine why a verification point may have failed.

e Submit a defect for a failed test case or for a failed log event. The test log
automatically fills in build, configuration, and script information in the Rational
ClearQuest defect form.

* Preview or print data displayed in the active test log in the Test Log window.

Additional built-in test input type: Microsoft Excel

You can now use one or more Microsoft Excel spreadsheets as test input sources.
This test input adapter can be useful in many ways. Many teams use Microsoft
Excel to manage information in their projects. For example, some teams may
document requirements or capture project planning information in a Microsoft
Excel spreadsheet. In either case, with the new Microsoft Excel test input adapter,
teams can track the testing effort with respect to their information in an Microsoft
Excel spreadsheet. Specifically, they can associate test cases with tasks defined in
rows of a spreadsheet so that a coverage report can be generated to show progress
or completion of those tasks.

Test impact analysis

If a test input changes, Rational TestManager now informs you of the impact of
that change on your test plan. For example, if a requirement changes in some
meaningful way, you need to know which test cases in your test plans are affected
so that you can update them to reflect requirement changes. Rational TestManager
automatically identifies and marks the affected test cases as suspect for IBM
Rational RequisitePro and Microsoft Excel test input sources.

Enhanced filtering of test input sources

You can now save test input source filters and Test Case Coverage report filters.
Test input sources and Test Case Coverage reports are unfiltered by default. When
you set a filter for a test input source, the last filter that you set persists in the Test
Inputs window and Test Input Select window. When you set a filter for a test input
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source, Rational TestManager saves the filter with the test input source. When you
set a filter for a Test Case Coverage report, Rational TestManager saves the filter
with the report.

Test scripts

This section describes new and enhanced functionality of test scripts in Rational
TestManager.

Defining test script options

You can now define additional test script options to control how test script
execution adapters run test scripts.

Test Scripts View

You can now view all your test scripts sorted by type from the Test Scripts View.
From this window, you manage test scripts. You can also perform basic version
control operations (such as check-in and check-out) on registered test scripts that
support these operations.

Additional actions in the test script console and test input
adapters

Developers of test script console adapters and test-input adapters can now add
their own custom actions or commands. You can run these custom actions or
commands in Rational TestManager.

Defining test tool options

You can now set test tool options to control how a particular test tool plays back a
test script. You can define a test tool option in the test script execution adapter that
you have written for a particular test tool.

Enhanced high-volume testing

You can customize your system settings for high-volume testing on a single
computer running Windows (over 2000 virtual testers for each Windows host). To
do this, you must edit the registry to increase desktop heap memory (memory
used for dynamic memory allocation). For more information, see Appendix A in
the IBM Rational TestManager User’s Guide.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
USA

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Department BCFB
20 Maguire Road
Lexington, MA 02421
USA

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of performance
compatibility or any other claims related to non-IBM products. Questions on the
capabilities of non-IBM products should be addressed to the suppliers of those
products.

All statements regarding IBM’s future direction or intent are subject to change
without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrates programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.
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Each copy or any portion of these sample programs or any derivative work must
include a copyright notice as follows:

(c) (your company name) (year) Portions of this code are derived from IBM Corp.
Sample Programs. (c) Copyright IBM Corp. _enter the year or years_. All rights
reserved.

Additional legal notices are described in the legal_information.html file that is
included in your Rational software documentation.

Trademarks

AIX, ClearCase®, ClearCase Attache®, ClearCase MultiSite®, ClearDDTS®,
ClearGuide®, ClearQuest, DB2, DB2 Universal Database’”, DDTS®, Domino®, IBM,
Lotus® Notes®, MVS"™, Notes, OS/390%, Passport Advantage®, ProjectConsoleTM,
PureCoverage®, Purify®, PurifyPlus"’, Quantify®, Rational, Rational Rose®, Rational
Suite®, Rational Unified Process®, RequisitePro, RUP®, S/390®, SoDA®, SP1, SP2,
Team Unifying Platform, WebSphere®, XDE, and z/0S® are trademarks of
International Business Machines Corporation in the United States, other countries,
or both.

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems,
Inc. in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

VMware is a registered trademark of VMware, Inc. in the United States and other
countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Other company, product or service names may be trademarks or service marks of
others.
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TestManager
Documentation Supplement
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