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ã  ã  ã Preface
This manual describes how to use the Rational Administrator and Rational 
repositories. This manual is intended for system administrators, application 
developers, quality assurance managers, and quality assurance engineers. 

Other Resources
ã This product contains complete online H elp. From the main toolbar, 

choose an option from the H elp menu. 

For information about context-sensitive H elp, see the following section.

ã All manuals for this product are available online in PDF format. These manuals 
are on the Rational Solutions for Windows Online Documentation CD.

ã For information about training opportunities, see the Rational U niversity 
Web site: http://www.rational.com/university.

Using Help
This product contains context-sensitive H elp for dialog boxes, menus, and toolbars.

Dialog Box Help
Most dialog box H elp includes overviews and detailed item information. 

Click th is to  see an 
overview of the d ia log box.

Click th is and then click an  
item  to see in form ation 
abou t the item .
vii



Preface
Menu Command Help
For menu command H elp, highlight the command and press F1, or click the H elp 
button on the toolbar and select the command. A brief description of the command 
also appears in the status bar. 

Toolbar Button Help
For toolbar button H elp, pause the pointer over the button. A yellow ToolTip 
appears below the button, and a brief description appears in the status bar. For more 
detailed information, click the H elp button on the toolbar, and then select the button 
for which you want more information. 

Contacting Rational Technical Publications
To send feedback about documentation for Rational products, please send e-mail 
to our technical publications department at techpubs@rational.com. 

Contacting Rational Technical Support
If you have questions about installing, using, or maintaining this product, 
contact Rational Technical Support as follows:

Rational Technical Support

Location Contact Information Notes

North America Telephone:
800-433-5444 
408-863-4000

E-mail:
support@rational.com

Please be prepared to supply 
the following information:

– Your name, telephone number, 
and company name

– Computer make and model

– Operating system and
version number

– Product release number 
and serial number

– Your Case ID number (if you 
are calling about a previously 
reported problem)

Europe Telephone:
+31 (0) 20 4546 200

E-mail:
support@europe.rational.com

Asia Pacific Telephone:
+61-2-9419-0111

E-mail:
support@apac.rational.com

World Wide Web http://www.rational.com Click the Technical Support link.
viii



ã  ã  ã C  H   A   P  T  E  R   1

About the Rational Repository
This chapter introduces the Rational repository and describes the different types 
of datastores. It includes the following topics:

ã What is a Rational repository?

ã Parts of a Rational repository

ã About Rational RequisitePro Databases

ã About Rational Test database types

ã About Rational ClearQuest databases

ã Determining a database type

What Is a Rational Repository?

A Rational repository stores software testing and development information for your 
projects. All Rational Test components on your computer update and retrieve data 
from the same active repository. 

A Rational repository can contain several different datastores. A datastore contains 
one or more databases and other types of files. A Rational repository consists of the 
following types of datastores:

ã Rational Test datastore – Stores application testing information such as test 
assets, logs, reports, builds, computers, users, and groups. For more 
information, see About the Rational Test Datastore on page 1-4.

N O TE: The type of data in a Rational repository depends on the Rational 
software that you have installed. 
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About the Rational Repository
ã Rational ClearQuest datastore – Stores change-request information for software 
development, including enhancement requests, defect reports, and 
documentation modifications. Each ClearQuest datastore consists of one 
schema and one database. In ClearQ uest, the term schem a  refers to all 
attributes associated with a database. This includes field definitions, field 
behaviors, the state transition table, actions, and forms. For more information, 
see About the Rational ClearQuest Datastore on page 1-5.

ã Rational RequisitePro datastore – Stores product or system requirements, 
software and hardware requirements, user requirements, quality assurance 
procedures, and test plans. Each datastore consists of project documents and a 
dynamically linked database. For more information, see About the 
Rational RequisitePro Datastore on page 1-6.

ã Rational Rose models – Stores visual models for business processes, software 
components, classes and objects, and distribution and deployment processes. 
For more information, see About Rational Rose Models on page 1-7.

Benefits of a Rational Repository
When you create a Rational repository, you can associate different Rational product 
datastores that are used for storing critical software development and testing 
information. In addition, within a Rational repository you can categorize this 
information by project. 

Once you associate datastores with a Rational repository, you can link specific data 
from one datastore to another by using individual product features or by using the 
Rational Synchronizer. For more information about the Rational Synchronizer, see 
About Rational Synchronizer Rules on page 1-7. 

N O TE: The Rational Synchronizer is available only in Rational Suite products.
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Parts of a Rationa l Repository
The following table provides specific examples of how you can benefit from 
associating different datastores with one another in a Rational repository as you 
design, develop, and test software applications.  

Parts of a Rational Repository

A Rational repository can consist of the following parts:

ã One Rational Test datastore

ã One ClearQuest datastore

ã One or more projects, consisting of:
– One RequisitePro datastore
– One or more Rose models
– Rational Synchronizer rules 

When you associate Then you can

A ClearQuest datastore 
with a Rational Test 
datastore

Generate a defect using Rational LogViewer, and 
automatically store the defect in the correct project in a 
ClearQuest database.

A RequisitePro database 
with a project within a 
Rational Test datastore

Create a test requirement using Rational TestManager, and 
automatically see the test requirement in the associated 
RequisitePro database. 

Create a product or software requirement using RequisitePro 
and view the same requirement from Rational TestManager. 
A quality engineer, using TestManager, can then view up-to-
date requirements for an application-under-test.

A RequisitePro database 
with a Rose model

You can also use the Rational Synchronizer to automatically 
create or update a requirement in RequisitePro based on a 
new or updated use case in a Rose model. 

N O TE: The Rational Synchronizer is available only in Rational Suite products.
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About the Rational Repository
The following figure shows the parts of a Rational repository:

About the Rational Test Datastore
The Rational Test datastore stores application testing information. Each datastore 
consists of a database and several file directories. In general, the database contains 
data entered into Rational Test applications. The non-database file directories 
contain files related to testing, such as verification points and script files.

The database contains information about: 

Builds Listing reports Queries

Computers LoadTest report output Schedules

Coverage reports LoadTest reports Scripts

Datapools Log filters Sessions

Datatypes Log folders Test analysis reports

Groups Logs Test documents

Layouts Projects U sers
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Parts of a Rationa l Repository
About the Rational ClearQuest Datastore
A Rational ClearQ uest datastore consists of one schema and one database. 
A ClearQuest database stores change-request records (such as defects) as 
well as reports, report formats, records, tables, and all other data entered by 
users. A ClearQuest schema defines the following information for each 
change-request record:

ã Forms used to submit and modify a record

ã Field types, legal values, and so on

ã States a record can be in (optional)

ã Actions used to modify or change the state of a record

ã H ooks written in Visual Basic Script that further customize legal field values, 
dependent fields, and actions (optional) 

About Projects
Projects help you categorize your software development and testing information for 
easy tracking. The number of projects in a repository depends on the complexity of 
the software development project or application-under-test. The number of projects 
also depends on the number of ongoing testing efforts. For example, you can divide 
a large testing effort into several smaller projects within one repository, or you can 
create separate repositories for unrelated testing efforts.

A project usually consists of the following:

ã Data in Rational Test datastores

ã Data in RequisitePro datastores

ã One or more Rose Models (optional)

ã Rational Synchronizer rules

For instructions about how to add or delete a project, see Managing Projects on page 
2-25. 

N O TE: A full version of Rational ClearQuest comes with Rational Suite 
TestStudio. You need the full version of ClearQ uest to add fields to a schema or to 
connect to a database to which fields have been added.

N O TE: The Rational Synchronizer is available only in Rational Suite products.
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About the Rational Repository
Rational Test Datastore Information in Projects
Some Rational Test datastore information is stored either as project-specific or as 
project-independent information.

The following table shows which type of information is project-specific and which 
type is project-independent in Rational Test:

About the Rational RequisitePro Datastore
All requirements for a project are stored in a Rational RequisitePro datastore. Each 
datastore consists of requirements documents and a dynamically-linked 
RequisitePro database. A project document can store text, graphics, or other objects 
(such as OLE objects) that identify project needs and are meaningful to users. To 
open a requirements datastore, start RequisitePro and refer to the RequisitePro 
online H elp.

Type of information Project-specific 
information

Project-
independent 
information

Baseline and actual verification point data x

Computers x

Customized terms x

DAT files x

LoadTest run schedule results x

LoadTest schedules x

LoadTest sessions x

Logs x

Queries x

Reports and report layouts x

Scripts x

SQABasic library source code x

Test requirements x

U sers and groups x
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Parts of a Rationa l Repository
Rational TestManager incorporates a baseline version of RequisitePro that lets you 
manage your test requirements. With this version of RequisitePro, you can build a 
test requirements hierarchy and associate scripts and schedules with the test 
requirements in the hierarchy.

With the full version of RequisitePro, you can customize the requirements database 
and use other advanced requirements management features such as traceability and 
requirements-attribute management. You can also manage all of your project’s 
requirements — for example, user requirements, software specifications, and use 
cases.

About Rational Rose Models
A Rose model file stores a graphical representation of a design model. A model is a 
graphical representation of the structure and relationship of the parts of a system to 
the entire system. A model can represent business processes, software components, 
classes and objects, and distribution and deployment processes.

A Rose model contains files similar to the source language files for a program. A Rose 
model can consist of the following types of text files:

ã Logical view package information 

ã Packages in the component diagram

ã Process information

ã Property files for various elements 

About Rational Synchronizer Rules
You can share or link data between applications that store data in Rational Test, 
Rational RequisitePro, or Rational Rose datastores. H owever, when you update data 
in one of these products, you often want to update this data in other products. The 
Rational Synchronizer is a software tool that lets you:

ã Ensure consistency of data across several products — a single change in one type 
of data can be updated in other types of data simultaneously.

ã Jump-start work in one product with the data from another product — for 
example, you can create requirements using the TestManager component of 
Rational Robot or Rational RequisitePro, and then import one or more of these 
requirements to a Rose model.

N O TE: For information about baseline and full versions of RequisitePro that 
ship with Rational Test products, contact your sales representative.
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About the Rational Repository
ã Conduct impact analysis — you can synchronize data in several different 
products to gain a deeper understanding of how changes in requirements or 
design changes impact your overall software development process.

You can start the Synchronizer from the Administrator. For more information about 
starting the Synchronizer from the Administrator, see How the Synchronizer Works on 
page 2-28.

About Rational RequisitePro Databases

All requirements for a project are stored in a Rational RequisitePro datastore. 
Each datastore consists of requirements documents and a dynamically-linked 
RequisitePro database. 

When you create a project in the Administrator, you can use an existing RequisitePro 
database or you can create a new RequisitePro database. If you create a new 
RequisitePro database for a project using the Administrator, the Administrator 
creates a Microsoft Access type of database. If you use an existing RequisitePro 
database, the database can be any type of RequisitePro database that RequisitePro 
allows. For information about the types of RequisitePro databases you can create 
using RequisitePro, see the Rational RequisitePro H elp.

For information about creating projects, see Adding a Project on page 2-25.

About Rational Test Database Types

A Rational Test database stores functional and performance testing information such 
as verification point data, queries, reports and report layouts, scripts, and information 
about users, computers, and groups. When you create a new repository, you can 
create two types of databases: Microsoft Access databases or Sybase SQL Anywhere 
Database Server databases. For a summary of which type of database software to 
install, see Determining a Database Type on page 1-10.

M icrosoft Access – Microsoft Access is the default database type for repositories and 
installs automatically when you install your Rational software. We recommend using 
Microsoft Access for a database with seven or fewer concurrent users. H owever, with 
more than seven users, data access is slower than for a comparably sized Sybase SQL 
Anywhere Database Server database. This type of database is virtually maintenance-
free. For example, you can back up the database simply by backing up the Rational 
repository directory. If you are accessing the database over a wide-area network, we 
recommend using Sybase SQ L Anywhere for your database.

N O TE: The Rational Synchronizer is available only in Rational Suite products.
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About Rational ClearQ uest D atabases
Sybase SQ L Anywhere D atabase Server – Sybase SQL Anywhere Database Server 
software comes with your Rational software, but does not install automatically. We 
recommend using this type of database for a database with eight or more concurrent 
users. Data access for a SQ L Anywhere Database Server database is faster than for a 
comparably sized Microsoft Access database. For information about installing this 
software, see your Rational installation manual. 

For information about managing a Rational Test database with a SQL Anywhere 
database server, see Chapter 4, Managing a SQL Anywhere Database Server.

About Rational ClearQuest Databases

Rational ClearQuest comes with special defect forms and reports to help you 
manage your functional testing efforts. These form and reports are stored in a 
ClearQ uest database. This database is different from the Rational Test database.

A ClearQuest database consists of a schema repository and a user database. 
A ClearQuest schema repository stores all schemas and all data associated with 
existing schemas in a special repository. The schema repository does not store any 
user data. A ClearQuest user database contains all user data and a copy of the schema 
associated with the database. U ser data in a ClearQuest database includes change-
request records such as defects, as well as reports, records or tables, and all data 
entered by users. 

Choosing a Rational ClearQuest Database 
When you create a ClearQuest user database, it can be either a Microsoft Access, 
Sybase SQL Anywhere Database Server, Microsoft SQL Server, or O racle database. 
For a summary of which type of database software to install, see Determining a 
Database Type on page 1-10.

Rational ClearQuest Web lets you remotely enter change-request records using a 
Web-based interface.  

N O TE: The version of ClearQuest that comes with Rational TeamTest differs 
from standard ClearQuest in one way: you cannot add a field to a ClearQuest 
schema. To add fields to a schema, you must purchase standard Rational 
ClearQ uest software.

N O TE: Rational ClearQuest Web does not support Microsoft Access databases.
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About the Rational Repository
M icrosoft Access – Microsoft Access is the default database type for Rational 
repositories and installs automatically when you install your Rational software. We 
recommend using Microsoft Access for a database with seven or fewer concurrent 
users. H owever, with more than seven users, data access is slower than for a 
comparably sized Sybase SQ L Anywhere Database Server database. This type of 
database is virtually maintenance-free. For example, you can back up the database 
simply by backing up the Rational repository directory. 

Sybase SQ L Anywhere D atabase Server – Sybase SQL Anywhere Database Server 
software comes with your Rational software, but does not install automatically. We 
recommend using this type of database for a database with eight or more concurrent 
users. Data access for a SQ L Anywhere Database Server database is faster than for a 
comparably sized Microsoft Access database. For information about installing this 
software, see your Rational installation manual. 

M icrosoft SQ L Server – Microsoft SQL Server does not come with your Rational 
software. You can use this software for ClearQuest databases; however, you must 
purchase the software and install it separately.

O racle – Oracle does not come with your Rational software. You can use this 
software for ClearQuest databases; however, you must purchase the software and 
install it separately.

Determining a Database Type

The following table summarizes which type of database software to use for a Rational 
Test database. 

If your Rational Test database Then 

H as seven or fewer concurrent 
users and is not accessed over a 
wide-area network

U se a Microsoft Access database. This is the default 
database and installs automatically when you install 
your Rational software.

H as eight or more concurrent 
users or is accessed over a wide-
area network

Install the Sybase SQ L Anywhere Database Server 
software that comes with your Rational software. For 
more information about installing Sybase SQL 
Anywhere Database Server software, see your Rational 
installation manual.
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The following table summarizes which type of database software to use for a 
ClearQ uest database. 

If your Rational ClearQuest 
database

Then 

H as seven or fewer concurrent users 
and is not accessed over a wide-are 
network

U se a Microsoft Access database. This is the 
default database and installs automatically when 
you install your Rational software.

H as eight or more concurrent users or 
is accessed over a wide-area network

Install the Sybase SQL Anywhere Database Server 
software that comes with your Rational software. 
For more information about installing Sybase 
SQL Anywhere Database Server software, see 
your Rational installation manual.

H as eight or more concurrent users 
and you want to use Microsoft SQL 
Server for your database

1 . Purchase Microsoft SQL Server software.

2 . Install Microsoft SQL Server to use with 
ClearQuest. For information about installing 
Microsoft SQ L Server for ClearQ uest, see the 
Installing Rational ClearQuest manual.

3 . Configure Microsoft SQL Server to use with 
ClearQuest. For information about 
configuring Microsoft SQL Server for 
ClearQuest, see the Administering Rational 
ClearQuest manual.

Both of these manuals are on the Rational 
online documentation CD.

H as eight or more concurrent users 
and you want to use O racle for your 
database

1 . Purchase O racle software.

2 . Install O racle to use with ClearQuest. For 
information about installing O racle for 
ClearQuest, see the Installing Rational 
ClearQuest manual.

3 . Configure Oracle to use with ClearQuest. For 
information about configuring Oracle for 
ClearQuest, see the Administering Rational 
ClearQuest manual.

Both of these manuals are on the Rational 
online documentation CD.
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Managing a Rational Repository 
This chapter explains how to use the Rational Administrator software to perform 
administrative tasks on a Rational repository. It includes the following topics:

ã About the Rational Administrator

ã Starting and exiting the Rational Administrator

ã The Rational Administrator main window

ã Rational repository privileges

ã About the Rational License Key Administrator

ã Repository tasks

ã Working with a Rational repository

ã U pgrading an SQA 6.x repository

ã Creating a repository

ã Managing projects

ã Viewing the properties of a repository

About the Rational Administrator

The Rational Administrator centralizes the management of a Rational repository. 
For more information about the Rational repository, see Chapter 1, About the Rational 
Repository. 

With the Rational Administrator, you can: 

ã Create and delete a repository.

ã Connect to a repository.

ã Configure a SQ L Anywhere database server.

ã Create and manage users, groups, and computers for a Rational Test database.
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ã Create and manage projects containing RequisitePro databases 
and Rose models.

ã Manage security privileges for the entire Rational repository.

ã Synchronize data among Rational Test datastores, Rational RequisitePro 
datastores, and Rational Rose using the Rational Synchronizer.

ã Change Rational Test and ClearQuest database types.

ã U se the centralized Rational License Key Administrator.

Starting and Exiting the Rational Administrator

To start the Rational Administrator:

ã Click Start → Program s → Rat iona l product  nam e → Rational 
Adm inistrator.

To exit the Administrator:

ã Click File → Exit.

The Administrator disconnects from all repositories before exiting.

The Rational Administrator Main Window

After you start the Rational Administrator, the main window appears:

N O TE: The Rational Synchronizer is available only in Rational Suite 
products.

D etails
pane

Vert ica l
sp lit ba r

T itle bar

M enu bar

Tools 
too lbar

Status bar

Standard 
too lbar

Repository pane
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The Repository Pane
The left pane of the main window, the Repository pane, displays a list of repositories 
and SQL Anywhere database servers. When you connect to a repository, you can add 
or delete projects. You can also add or delete users, groups, and computers from a 
Rational Test database.

The Details Pane
When you select an item in the left pane of the main window, information about the 
selected item appears in the right pane, the Details pane.

The Status Bar
The status bar at the bottom of the main window displays a description of the 
currently selected menu item or operational messages.

Rational Repository Privileges

When you log into a Rational repository, your Rational Test database privileges 
determine the privileges you have for managing a repository. For more information 
about privileges, see Rational Test Database Privileges on page 3-1.

You can set the Rational Test database privileges for a user to:

ã Perform administrator tasks for a repository — manage projects, users, groups, 
and computers, as well as delete repositories.

ã Change the database type of a ClearQ uest or Rational Test database. Attach an 
existing ClearQuest database to a Rational repository. 

ã Create, modify, and delete test assets, reports and layouts, builds, logs, and 
requirements.

ã Customize test assets and builds.

ã Create, modify, and delete logs and reports.
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About the Rational License Key Administrator

The Rational License Key Administrator is a centralized license manager that lets you 
review and manage licenses for your Rational products. 

Starting the Rational License Key Administrator
To start the Rational License Key Administrator from the Rational Administrator:

ã Click Start → Program s → Rat iona l p roduct  nam e → Rational License Key 
Adm inistrator.

For more information about using the Rational License Key Administrator, see the 
Rational License Key Administrator H elp. 

Repository Tasks

The following table provides an overview of the typical tasks that you perform to 
manage a Rational repository.

Task Description See

Start the 
Administrator.

Starting and Exiting the 
Rational Administrator on 
page 2-2

Configure ClearQuest 
or attach an already 
existing ClearQuest 
database to a 
repository.

To use ClearQuest to store defects, 
you must configure ClearQuest 
before you create a ClearQuest 
database or attach an already existing 
ClearQ uest database to a repository. 

Configuring ClearQuest on 
page 2-12 and Create or 
Attach a Rational ClearQuest 
Database on page 2-17

Register an existing 
repository.

If you have an existing repository, you 
can add it to the list of repositories 
that appear in the main window of the 
Administrator. 

Registering and Unregistering 
an Existing Repository on 
page 2-21

Create a repository. You can create a Microsoft Access or 
SQL Anywhere Server database type 
for a Rational Test database. You can 
create a Microsoft Access, Sybase 
SQL Anywhere Server, Microsoft 
SQL Server, or O racle database type 
for a ClearQuest database.

Creating a Repository on 
page 2-13
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Connect to a 
repository.

You must connect to a repository 
before you can add a project, user, 
group, or computer.

Connecting to a Repository on 
page 2-20

Add one or more 
projects to a 
repository.

A project stores data from Rational 
Test programs. Other files stored in 
the projects related to testing are 
scripts, files, and schedules.

Optionally, a project can store 
RequisitePro requirements, Rose 
models, and Synchronizer rules. 

Managing Projects on page 
2-25

Add one or more 
groups to 
a Rational Test 
database and assign 
privileges to a group.

Create a group or groups with 
privileges for a repository. When you 
add a user to a group, the user takes 
on the privileges of that group.

Rational Test Database 
Privileges on page 3-1

Add one or more users 
to a Rational Test 
database.

You must add a user to a repository 
before a user can use other 
Rational software. You must also 
make a user a member of a group to 
grant user privileges.

Managing Users on page 
3-6 and Rational Test 
Database Privileges on page 
3-1

Add one or more 
computers to a 
repository.

Managing Computers on 
page 3-9

Change a Rational 
Test database type.

You can change a Rational Test 
database from a Microsoft Access 
database to a SQL Anywhere Server 
database, or from a SQL Anywhere 
Server database to a Microsoft Access 
database.

Changing a Rational Test 
Database Type on page 2-22

 (Continued) 

Task Description See
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The tasks in the following table are optional. 

Working with a Rational Repository

Before working with a Rational application for the first time, you must create and 
connect to a Rational repository. 

When you create a new repository, you create a Rational Test database as either a 
Microsoft Access database or a SQ L Anywhere Server database. 

If you create a ClearQuest database and attach it to a repository, you create it as a 
Microsoft Access, a Sybase SQL Anywhere Server, a Microsoft SQL Server, or an 
Oracle database.

When you manage a repository, you can:

ã Create or delete a repository. To delete a repository, you must have privileges. 
For more information, Rational Test Database Privileges on page 3-1.

ã Connect or disconnect from a repository.

ã Register an existing repository so it appears in the current list of repositories 
in the left pane of the main widow.

ã Change database types for Rational Test or ClearQuest databases.

ã Attach a ClearQuest database to a repository.

Task Description See

Change a 
ClearQ uest 
database type.

You can change a ClearQ uest database to 
one of the following database types: 
Microsoft Access, Sybase SQL 
Anywhere Server, Microsoft SQ L 
Server, or Oracle.

Changing a ClearQuest 
Database Type on page 
2-23

Attach an 
existing 
ClearQ uest 
database.

You can attach an existing ClearQuest 
database to a Rational repository.

Attaching an Existing 
ClearQuest Database on 
page 2-24

Start the 
Synchronizer.

You can ensure consistency of data 
across Rational Test, Rational 
RequisitePro, and Rational Rose 
products by using Synchronizer rules. 

Starting the Synchronizer 
on page 2-28

N O TE: The Rational 
Synchronizer is available 
only in Rational Suite 
products.
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Upgrading an SQA 6.x Repository 

You can use data from an existing SQA Suite 6.x repository in a Rational repository. 
When you create a new Rational repository, the Create Repository wizard gives you 
the option of initializing a repository with data from an existing SQA Suite 6.x 
repository.

For information about creating a Rational repository with SQA Suite 6.x data, see 
Creating a Repository on page 2-13.

When to Convert SQA Suite 6.x Repository Data
We recommend that you convert SQA Suite 6.x repository data to Rational 
repository data after you finish a project. 

For information about creating a Rational repository with SQA Suite 6.x data, see 
Creating a Repository on page 2-13.

The following table lists the data that is converted from a SQA Suite 6.x repository 
to a Rational repository:

Type of SQA Suite 6.x data Converted?

Custom reports and graphs N o

Defects
(For more information about defects, see Details About 
Converting Defects on page 2-8.)

Yes

E-mail rules N o

Filters for defects or test procedures N o

Groups
(Privileges are not converted.)

Yes

List reports N o

LoadTest schedules N o

Projects Yes

Requirements Yes

Test cases
(Called verification points in a Rational repository.)

Yes

Test logs N o
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Conversion Details
When you create a Rational repository with SQA Suite 6.x data, the following 
conversion takes place:

ã A verification point ID or script file name with a period (.) in the name is 
prefixed with _REN AMED_.

ã A period (.) in a script file name or verification point ID converts to an 
underscore (_).

For example, a script named wn95.tst converts to _REN AMED_wn95_tst. 
A verification point ID named alpha.b2 converts to _REN AMED_alpha_b2.

Details About Converting Defects 
Rational testing products incorporate the change-request management technology 
of Rational ClearQ uest to track defects. For your convenience, Rational ClearQuest 
includes a specially designed defect form, the TeamTest defect form, similar to the 
SQA 6.x Manager defect form. For more information about using the TeamTest 
defect form, see the Using the Rational Robot manual.

Test plans Yes

Test procedures
(Called scripts in Rational repository.)

Yes

U sers
(Privileges are not converted.)

Yes

Virtual user test procedures 
(Called virtual user scripts in a Rational repository.)

N o

 (Continued) 

Type of SQA Suite 6.x data Converted?
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The following table lists each field of an SQA 6.x defect and the comparable 
Rational TeamTest defect field. The table also describes the conversion of each field.  

N O TE: The word List in the Description column of this table indicates that if 
you customize a list in SQA 6.x, it converts to a list in the TeamTest defect form. 

SQA 6.x 
Defect Field

TeamTest 
Defect Field

Description

ID N ew ID 
generated

The SQA 6.x ID does not appear on the defect 
form, but you can use the query feature of 
ClearQuest to find it. For more information, 
see the Rational ClearQuest H elp.

Description H eadline/
Description

Converts the first 125 characters or up to the 
first carriage return and places this text in the 
H eadline field. The entire SQA 6.x Description 
field also appears in the Description field of the 
TeamTest defect form.

Priority Priority List

Severity Severity List

Occurrences (N ot converted)

Keywords Keywords List

Symptoms Symptoms List

Build Found N otes In SQA 6.x, a Build Found field is a text field. 
The text data from the Build Found field is 
stored in N otes. In Rational 7.x, Builds are 
objects that contain log folders and logs. A Build 
object is not created for each SQA 6.x Build 
Found field. 

Build Fixed N otes In SQA 6.x, a Build Fixed field is a text field. The 
text data in the Build Fixed field is stored in 
N otes. In Rational 7.x, Builds are objects that 
contain log folders and logs. A Build object is not 
created for each SQA 6.x Build Fixed field. 

Proc Script

Case Verification 
Point

Cycle (N ot converted)
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Reported By Reported By 
Contact

Reported By 
Company

Reported By 
Company

H ardware H ardware List

Operating 
System

O perating 
System

List

Other O ther 
Environment

Test Station (N ot converted) In SQA 6.x, a Test Station field is a text field. 
In Rational 7.x the Computers field replace the 
Test Station field and is an object. A Computer 
object is not created for each SQA 6.x Test 
Station field. 

Log (N ot converted)

Custom 1 Custom 1 List

If you customized the label for this field in 
SQA 6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.

Custom 2 Custom 2 List

If you customized the label for this field in 
SQA 6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.

Custom 3 Custom 3 If you customized the label for this field in 
SQA 6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.

Attachment Attachments You can attach more than one file after you 
convert to a 7.x Rational repository.

Requirement Requirement

 (Continued) 

SQA 6.x 
Defect Field

TeamTest 
Defect Field

Description
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Troubleshooting
The convert.txt file in the converted project directory contains the conversion status 
of each verification point and script. U se this file as a diagnostic tool if you have any 
problems with your data after conversion. 

Before Creating a Repository

Before you create a repository, you must perform the following steps:

1 . Decide what type of database to use. For information about database types, 
see About Rational Test Database Types on page 1-8 and Choosing a Rational 
ClearQuest Database on page 1-9. For a summary of database types, see 
Determining a Database Type on page 1-10.

2 . We recommend that you create a shared directory for each shared database or 
repository. For more information, see Create a Shared Directory on page 2-13.

3 . If you use SQL Anywhere for a Rational Test database or a ClearQuest database, 
you must do the following before you create a repository:

a. Install the Sybase SQL Anywhere software.

For information about installing Sybase SQL Anywhere software, see the 
installation guide for your Rational product. 

b. Create a SQ L Anywhere database server.

For information about creating a SQL Anywhere database server, 
see Creating a SQL Anywhere Database Server on page 4-2.

Status H istory H istory

Resolution Resolution List

Resolution 
Description

Resolution 
N ote

Modified 
Software

(N ot converted)

 (Continued) 

SQA 6.x 
Defect Field

TeamTest 
Defect Field

Description
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4 . If your Rational software comes with ClearQuest, you must create a ClearQuest 
database to store defects for your functional testing efforts. This database is 
separate from the Rational Test database. If you use Oracle or Microsoft SQL 
Server for a ClearQuest database, do the following:

a. Purchase, install, and configure Oracle or Microsoft SQL Server database 
software. 

b. Configure ClearQ uest by creating a new schema repository or by 
connecting to an existing schema repository. For information, see the 
next section, Configuring ClearQuest.

Configuring ClearQuest 
Before you create a repository with a ClearQuest database, or attach an existing 
ClearQ uest database to a repository, you must configure ClearQuest by creating a 
new schema repository or by connecting to an existing schema repository. You only 
need to do this once for all repositories. If you attach an existing ClearQ uest database 
to a Rational repository that has an existing schema repository, you do not have to 
create a new schema repository. For more information about ClearQuest schemas, 
see About Rational ClearQuest Databases on page 1-9 and the ClearQuest H elp.

For information about attaching an existing ClearQ uest database when you create a 
repository, see Creating a Repository on page 2-13. For information about attaching an 
existing ClearQuest database to an existing repository, see Attaching an Existing 
ClearQuest Database on page 2-24.

To configure ClearQuest: 

1 . Click Tools → Rational ClearQ uest M aintenance Tool. 

2 . Follow the directions in the ClearQuest Setup Wizard to create a new schema 
repository or to connect to an existing schema repository.

3 . Optionally, create a sample database. ClearQ uest provides a sample database 
containing sample records that you can use to familiarize yourself with 
ClearQ uest.

N O TE: If you use either a Microsoft SQL Server database or an O racle 
database with ClearQuest, you must install and configure the database 
specifically for ClearQuest or you will not be able to create a repository. 
For information about installing O racle or Microsoft SQ L Server 
for ClearQ uest, see the Installing Rational ClearQuest manual. For 
information about configuring Oracle or Microsoft SQL Server for 
ClearQ uest, see the Administering Rational ClearQuest manual. Both of 
these manuals are on the Rational online documentation CD.
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For more information about the ClearQuest Setup Wizard, click H elp on the wizard. 
The wizard creates two default ClearQuest accounts. You need the user ID and 
password to log into ClearQuest. The user IDs and passwords are as follows:

ã Default administrator account – The user ID is adm in, with no password.

ã Default user account – The user ID is user, with the password, password.

Create a Shared Directory
If you want to share a database or repository, we recommend that you create a shared 
directory, as follows:

1 . Create a directory in the Windows Explorer.

2 . Right-click the directory, and then click Sharing.

3 . Click Shared As.

4 . Type the name of the shared directory in the Share N am e box.

5 . Click O K .

Creating a Repository

Before working with a Rational Test application for the first time, you use the 
Administrator to create a repository. 

There are three steps that are required to create a Rational repository:

1 . Specify a path and database type for a Rational repository.

2 . Optionally, initialize a Rational Test database with data from an existing 
SQA Suite 6.x or Rational repository. 

3 . Optionally, create or attach a ClearQuest database to the repository.

N O TE: You need at least 10 MB of disk space to create a repository.

N O TE: You can only initialize a Rational Test database with global repository 
data, such as users, groups, permissions, and computers from an existing 
Rational repository. Initializing does not copy project information.
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Specify a Path and Database Type 
To create a SQL Anywhere Server type of repository, you must create a repository 
on a server with SQL Anywhere Server software installed. 

To specify a path and database type for a Rational repository:

1 . Click Start → Program s → Rat iona l product  nam e → Rational 
Adm inistrator.

2 . Click File → Create Repository.

3 . Take one of the following actions:

a. To share a repository, we recommend that you create the repository in a 
shared directory and use the U niform N aming Convention (U N C) for the 
directory name. (For more information about creating a shared directory, 
see Create a Shared Directory on page 2-13.)

\\machinename\sharename\reponame

where machinename is the network name of the repository computer, 
sharename is the name of a networked or shared directory, and 
reponame is the name of the new repository. 

For example:
\\dell300\defects\repo1

b. If you do not need to share a repository, type the drive and pathname for the 
repository, or click Browse to select the path for the repository. 

For example:
C:\defects\repo1

4 . Click N ext to continue.
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5 . Take one of the following actions: 

6 . Proceed to the next section, Initialize a Rational Test Database with Data.

If you want to create a 
Rational Test database 
using

Then

Microsoft Access software a. In the D atabase type list, select M icrosoft Access.

b. Click N ext to continue.

Sybase SQL Anywhere 
software

N O TE: You must install Sybase SQL Anywhere Server 
software and create a SQL Anywhere database server 
before you create this type of repository. For 
information about installing SQL Server software, see 
the installation guide for your Rational product. For 
information about creating a SQL Anywhere database 
server, see Creating a SQL Anywhere Database Server on 
page 4-2.

a. In the D atabase type list, select Sybase SQ L 
Anywhere.

b. In the SQ L Anywhere database server list, select the 
name of a SQL Anywhere database server.

c. Type the database name in the D atabase name box.

d. Type the drive and pathname for new database files in 
the Location of database files box, or click Browse 
to select the path. 

N O TE: We recommend that you create a shared 
directory for database files. For more information 
about creating a shared directory, see Create a Shared 
Directory on page 2-13.

We also recommend that you use the U niform 
N aming Convention (U N C) for the directory name:

\\machinename\sharename 

where machinename is the N etwork N ame of the 
repository computer, and sharename is the name of 
a networked or shared directory. 

For example:
\\dell300\defects\

e. Click N ext to continue.
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Initialize a Rational Test Database with Data
When creating a new Rational repository, you can use data from a SQ A Suite 6.x 
repository or from another Rational repository. We recommend that you do this after 
you finish a project. 

1 . In the Create Repository wizard, take one of the actions listed in the 
following table. 

N O TE: You can only initialize a Rational Test database with global repository 
data, such as users, groups, permissions and computers from an existing 
Rational repository. Initializing does not copy project information.

If you Then

Do not want to initialize a Rational 
Test database with data from an 
existing Rational repository.

a. Click D o not initia lize the new repository 
using data  from an existing repository.

b. Click N ext to continue, and then proceed to 
step 2.

Want to initialize a Rational Test 
database with data from an existing 
Rational repository. 

a. Click Initia lize the new repository using 
data from an existing Rational 
repository.

b. Type the drive and pathname of an existing 
repository in the box, or select a repository 
from a list of registered Rational 
repositories. Alternatively, click Browse to 
select the path for an existing repository. 

c. Click N ext to continue, and then proceed to 
step 2.

Want to initialize the Rational Test 
database with data from an existing 
SQA 6.x repository. 

a. Click Initia lize the new repository using 
data from an existing SQ A 6 .x repository.

b. Type the drive and pathname of the existing 
SQ A 6.x repository in the box, or select a 
repository from a list of registered Rational 
repositories. Alternatively, click Browse to 
select the path for an existing repository. 

c. Click N ext to continue, and then proceed to 
step 2.
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2 . Take one of the following actions:

Create or Attach a Rational ClearQuest Database 
If your Rational software comes with ClearQuest, you must create a ClearQuest 
database to store defects for your functional testing efforts. This database is separate 
from the Rational Test database.

If you create a Sybase SQL Anywhere Server type of database, you must install 
Sybase SQL Anywhere Server software and create a SQL Anywhere database server 
before you create this type of database. For information about installing SQL 
Anywhere Server software, see the installation guide for your Rational product. 
For information about creating a SQL Anywhere database server, see Creating a SQL 
Anywhere Database Server on page 4-2. 

If you use either a Microsoft SQL Server database or an O racle database with 
ClearQ uest, you must install and configure the database specifically for ClearQuest 
or you will not be able to create a repository. For information about installing 
Oracle or Microsoft SQ L Server for ClearQ uest, see the Installing Rational ClearQuest 
manual. For information about configuring Oracle or Microsoft SQL Server for 
ClearQ uest, see the Administering Rational ClearQuest manual. Both of these manuals 
are on the Rational online documentation CD. 

If you Then

Do not want to create or 
attach a ClearQ uest 
database to a new 
repository.

a. Clear the Create or Attach ClearQ uest D atabase 
check box.

b. Click N ext to continue.
A summary page confirms the type and location of your 
new repository.

c. Click Finish to create the new repository.

Want to create or attach a 
ClearQ uest database to a 
new repository.

Proceed to the next section, Create or Attach a Rational 
ClearQuest Database.
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To create or attach a Rational ClearQuest database to the Rational repository that you 
are creating:

1 . In the Create Repository wizard, select the Create or Attach ClearQ uest 
D atabase check box.

2 . Log into the administrator account of the ClearQ uest schema repository. 

a. Type the U ser ID . 

b. Type the Password. 

3 . Click N ext to continue. 

4 . If you did not configure ClearQuest, the following dialog box appears: 

N O TE: The user ID for the default administrator account is adm in, with no 
password.
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a. Click one of the following:

Create or attach a  ClearQ uest schem a repository

D o not create or a ttach a  ClearQ uest schem a repository

b. Click O K .

c. If you click Create or a ttach a ClearQ uest schem a repository, follow the 
directions in the ClearQ uest Setup Wizard. For more information about the 
ClearQ uest Setup Wizard, click H elp on the wizard. The wizard creates two 
default ClearQ uest accounts, with the following user IDs and passwords:

ã Administrator account – The U ser ID is adm in, with no password.

ã U ser account – The U ser ID is user, with the password, password.

5 . Take one of the following actions:

If you want to Then

Attach an existing 
ClearQ uest database to a 
new repository. 

a. Click Attach an existing ClearQ uest database.

b. Select an existing ClearQuest database from the 
D atabase N ame column.

c. Click N ext.
A summary page confirms the type and location of your 
new repository.

d. Click Finish to create the new repository.

Create a new 
ClearQ uest database. 

a. Click Create a new ClearQ uest database.

b. Type the database name of the new database.

c. Type a description of the new database.

d. Click N ext.
e. Select an item from the D atabase type box:

M icrosoft Access
SQ L Anywhere 
SQ L Server
O racle8

f. Fill in the properties of the ClearQuest database type 
you chose, and then click N ext.

g. Type the length of time, in minutes, for ClearQuest to 
maintain an idle-connection to a ClearQuest database 
in the Timeout: M inutes box.

h. Type the length of time, in minutes, for ClearQuest to 
poll the database before disconnecting in the Poll 
Interval: M inutes box. 
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Connecting to a Repository
You must connect to a repository if you want to add a project to a repository or 
add a user, group, or computer to a Rational Test database. When you connect to a 
repository, you gain access to the entire Rational repository.

To connect to a repository:

1 . Right-click the repository to which you want to connect, and then click 
Connect .

2 . Click O K . 

If you want to Then

Create a new 
ClearQ uest database. 

N O TE: To prevent ClearQuest from disconnecting 
from a database, type 0 in the Timeout: M inutes box 
and 0 in the Poll Interval: M inutes boxes.

i. Click N ext.
j. Select an existing ClearQ uest schema from the 

Schema N ame column. For Rational testing software, 
(Rational Suite Enterprise, Rational Suite 
PerformanceStudio, Rational Suite TestStudio, or 
Rational TeamTest) we recommend that you select the 
TestStudio schema. This is the Rational schema that is 
designed to work with Rational testing software. 

N O TE: If you are using Rational TeamTest, you must 
select the TestStudio schema or ClearQuest will not 
work. The version of ClearQuest that comes with 
TeamTest differs from standard Rational ClearQuest 
and does not allow you to add a field to a schema or to 
use any schema other than the TestStudio schema. To 
add fields to a schema or to use a schema other than the 
TestStudio schema, you must purchase standard 
Rational ClearQuest software or a Rational Suite 
product that comes with standard Rational ClearQuest.

k. Click N ext.
A summary page confirms the type and location of your 
new repository.

l. Click Finish to create the new repository.

 (Continued) 
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3 . Take one of the following actions:

a. If you are logging into a repository for the first time:

i. Type Adm in for the U ser ID . The U ser ID is not case-sensitive. 

ii. Leave password blank. 

iii. Change the password of the Admin user to prevent other users from 
using the Administrators group privileges. For more information about 
changing a password, see Changing a Password on page 3-9.

b. If you are not logging in for the first time:

i. Type your U ser ID. The U ser ID is not case-sensitive.

ii. Type your password. The password is case-sensitive.

c. Click O K .

Disconnecting from a Repository
To disconnect from a repository:

ã Click File → D isconnect.

If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository that you want to disconnect 
from, and then click O K.

Registering and Unregistering an Existing Repository
If you have an existing repository, you can add it to the list of repositories that appear 
in the main window of the Administrator by registering it. 

When you unregister a repository, the Administrator removes the repository from 
the list of repositories in the main window of the Administrator. It does not delete 
the repository. 

N O TE: When you connect to a repository for the first time, you should 
define a password for the Admin user to prevent unauthorized access. The 
Admin user always has full user access privileges and cannot be deleted from 
a repository.
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To register an existing repository:

1 . Click File → Register Existing Repository.

2 . Type the drive and pathname to an existing repository, or click Browse to select 
the path to an existing repository. 

3 . Click O K . 

To unregister an existing repository:

ã Right-click the repository you want to unregister, and then click U nregister.

Deleting a Repository
When you delete a repository, the Rational Administrator deletes all parts of the 
repository created by the Administrator. If you attached a ClearQuest database or a 
Rose model not created by the Administrator, they are not deleted when you delete 
the repository. O nly the association with the repository is deleted.

To delete a repository:

1 . Make sure that no one else is using the repository that you want to delete.

2 . Select the repository you want to delete from the left pane of the main window.

3 . Click Edit  → D elete to delete the repository.

4 . If you are not connected to the repository you want to delete, you are prompted 
to log in.

a. Type your U ser ID. The U ser ID is not case-sensitive.

b. Type your password. The password is case-sensitive.

5 . The Administrator prompts you to confirm the deletion. Click Yes.

Changing a Rational Test Database Type
You must connect to a repository before you change a Rational Test database type. 
For more information about connecting to a repository, see Connecting to a Repository 
on page 2-20.

To change a Rational Test database type:

1 . Click File → Change Rational Test D atabase Type.

N O TE: You must have privileges to delete a repository. For information about 
privileges, see Rational Test Database Privileges on page 3-1. 
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2 . Depending on the type of database, take one of the following actions:

– If your Rational Test database is a SQL Anywhere database, the 
Administrator prompts you to confirm the change to Microsoft Access. 
Click O K .

– If your Rational Test database is a Microsoft Access database, the following 
dialog box appears: 

a. Fill in the information for the new type of database. 

b. Click O K .

Changing a ClearQuest Database Type 

To change a ClearQuest database type:

1 . Connect to the repository that you want to change.

2 . Click File → Change ClearQ uest D atabase Type.

N O TE: If you change your ClearQuest database to a Sybase SQ L Anywhere 
database, you must install Sybase SQ L Anywhere database server software and 
create a SQ L Anywhere database server before you change your database type. For 
information about installing SQ L Server software, see the installation guide for 
your Rational product. If you use either a Microsoft SQL Server database or an 
Oracle database with ClearQuest, you must install and configure the database 
specifically for ClearQ uest or you will not be able to change the database type. For 
information about installing Oracle or Microsoft SQL Server for ClearQuest, see 
the Installing Rational ClearQuest manual. For information about configuring 
Oracle or Microsoft SQL Server for ClearQ uest, see the Administering Rational 
ClearQuest manual. Both of these manuals are on the Rational online 
documentation CD. 
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3 . Type the U ser ID  and the Password of the administrator account of the 
ClearQ uest schema repository, and then click N ext.

4 . Select the new D atabase type. 

5 . Type the information required by your new type of database.

6 . Click N ext.

7 . Click Finish.

Attaching an Existing ClearQuest Database 
To attach a ClearQuest database to a repository:

1 . Click File → Attach ClearQ uest D atabase.

2 . Type the U ser ID  and the Password of the administrator account of the 
ClearQ uest schema repository, and then click N ext.

3 . Select the ClearQuest database from the D atabase N am e column that you 
want to associate with the Rational repository, and then click N ext .

4 . Click Finish.
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Managing Projects

When you create a repository, the Administrator creates a default project for you. 
You can add projects to a repository. The number of projects in a repository depends 
on the complexity of the work you are doing or on the number of ongoing unrelated 
efforts. For example, you could divide a large testing application into several smaller 
projects, or you could define a separate project for each unrelated testing effort.

You cannot modify the name of a project once you create it.

Adding a Project 
When you add a project to a repository, you can associate a project with one or more 
Rose models. See step 6.

When you create a project in the Administrator, you can use an existing RequisitePro 
database or you can create a new RequisitePro database. If you create a new 
RequisitePro database for a project, the Administrator creates a Microsoft Access 
type of database. If you use an existing RequisitePro database, the database can be any 
type of RequisitePro database that RequisitePro allows. For information about the 
types of RequisitePro databases that you can create using RequisitePro, see the 
Rational RequisitePro H elp. 

To add a project to a repository:

1 . Click Insert → Project. 

2 . If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository that you want to add a project 
to, and then click O K .

N O TE: You must connect to a repository before you can add a project to a 
repository. For more information about connecting to a repository, see Connecting 
to a Repository on page 2-20. You must have privileges to add a new project to a 
repository. For more information about privileges, Rational Test Database Privileges 
on page 3-1.
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3 . Type a string of up to 40 alphanumeric, double-byte, or extended ASCII 
characters in the box, and then click N ext.

4 . Take one of the following actions:

– Click Create a  new RequisitePro database.

– Click U se an existing RequisitePro database to use an existing database. 
Then type the drive and pathname for an existing Requisite database, or 
click Browse to select the path for an existing database. 

5 . Click N ext.

N O TE: If you have a ClearQ uest project with the same name, the 
Administrator prompts you to confirm that you want to use the same 
project name in the Rational repository. 
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6 . Optionally, click Attach to associate a project with one or more Rose models.
To change your selection, click D etach.

7 . Click N ext to continue.

A summary page confirms the selections you have made for a new project.

8 . Click Finish to create a new project.

The project name appears in the left pane of the main window under Projects. 
The project name and project directory appear in the right pane of the main 
window.

Project 
nam e and  
d irectory
2 -2 7



M anag ing a Rational Reposito ry
How the Synchronizer Works
You use the Rational Synchronizer to ensure consistency of data across 
Rational Test, Rational RequisitePro, and Rational Rose datastores. The Rational 
Synchronizer uses a rules-based engine to operate on data or items in one or more 
products. You select which products and which data the Synchronizer affects. You 
can preview how your selections will affect data before you use the Synchronizer. 
For more information about Synchronizer rules and where the rules are stored, see 
About Rational Synchronizer Rules on page 1-7. 

A set of default rules ship with the Rational Synchronizer. The Administrator stores 
the default Synchronizer rules in each project in a Rational repository. You can use 
the default rules, or you can customize them by adding your own rules or editing the 
existing ones. For more information about using, adding, or editing rules, see the 
Rational Synchronizer H elp.

Starting the Synchronizer 
The Rational Synchronizer is available only in Rational Suite products.

To start the Synchronizer:

1 . Connect to the repository that contains the project you want to synchronize.

2 . Select the project you want to synchronize.

3 . Click Tools → Rational Synchronizer. 

For more information about how to use the Synchronizer or how to create your own 
rules, see the Rational Synchronizer H elp.

Deleting a Project
Deleting a project removes all project data for that project from the repository. When 
you delete a project, the Administrator deletes everything in the project folder — the 
RequisitePro database, any Rose models created within a project folder, and all 
Rational Synchronizer rules in the folder.

To delete a project:

1 . Double-click Projects in the left pane of the main window to display all projects.

2 . Select the project you want to delete.

N O TE: The Rational Synchronizer is available only in Rational Suite products.
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3 . Click Edit  → D elete.

The Administrator prompts you to confirm the deletion.

4 . Click Yes to delete the project, including all project data.

Viewing the Properties of a Repository 

You can view the properties of the following parts of a repository:

ã Rational Test database

ã ClearQ uest database

ã Projects

ã RequisitePro database

ã Rose models

ã SQL Anywhere database servers

To view the properties of a repository:

ã Right-click an item in the left pane of the main window, and then 
click Properties.

See the Rational Administrator H elp for a description of the properties of each 
of these items in the repository.

To view the properties of an item in the right pane of the Administrator:

ã U nder Repositories in the left pane of the main window, click the folder that 
you want to open, and then click the item that you want to view.

The properties of the object that you select appear in the right pane of the main 
window. For more information about displaying property pages, see property pages in 
the Rational Administrator H elp.

N O TE: You must have privileges to delete a project from a repository. For 
more information about privileges, see Rational Test Database Privileges on page 
3-1.

N O TE: You must connect to a repository before you can view a project, user, 
group, or computer in a repository. For more information about connecting to a 
repository, see Connecting to a Repository on page 2-20.
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Managing a Rational Test Database
This chapter explains how to manage a Rational Test database. It includes the 
following topics:

ã Rational Test database privileges

ã Managing users

ã Managing computers

Rational Test Database Privileges

When you create a repository, the Administrator creates a Rational Test database. 
The Rational Test database contains the U sers, Groups, and Computers folders. 
The U sers folder contains an adm in user. The Groups folder contains a Public 
group and an Adm inistrators group. These default objects appear in the left pane 
of the main window.

When you log into a Rational repository, your Rational Test database privileges 
determine the privileges that you have for managing a repository. 
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You determine the security of a repository by assigning privileges to a group. Groups 
allow you to set privileges for each user. When you add a user to a group, the user 
takes on the privileges of that group. 

You can set the Rational Test database privileges for a user to:

ã Create, modify, and delete test assets, reports and layouts, builds, 
logs, and requirements.

ã Customize test assets and builds.

ã Create, modify, and delete logs and reports.

ã Perform administrator tasks for a repository: manage projects, users, 
groups, and computers, as well as delete repositories.

ã Change the database type of a ClearQ uest or Rational Test database. 
Attach an existing ClearQuest database to a Rational repository. 

Overview of the Administrators Group 
Each repository that you create comes with an Administrators group that includes 
a default user, Admin. The Admin user is a member of the Administrators group and 
takes on all privileges of the Administrators group.

For example, as administrator of a repository, you can create a group with privileges 
that allow the group to create and modify test assets, builds, logs, and reports in a 
repository, but deny the group the privilege of deleting a repository.

You can also make a group the default group. When you add a user to a Rational Test 
database, and this option is set, every user that you create takes on the privileges of 
that default group.

A member of the Administrators group can: 

ã Create, modify, and delete test assets.

ã Create, modify and delete reports and layouts, builds, logs, and requirements.

ã Customize test assets and builds.

ã Create, modify, and delete logs and reports.

N O TE: The Administrators group in every repository has privileges to add, 
modify, or delete a group. You must be a member of this group to manage groups; 
otherwise, ask your administrator for this privilege.
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ã Perform administrator tasks for a repository: manage projects, users, groups, 
and computers, as well as delete repositories.

ã Change the database type of a ClearQ uest or Rational Test database. 
Attach an existing ClearQuest database to a Rational repository. 

There is no default password for the Admin user. You can log in as an Admin user, 
and you do not need a password. This lets you log into any Rational Test component 
after you first install the software.

Setting Up Security for the Admin User
When you connect to a repository for the first time, you should define a password 
for the Admin user to prevent unauthorized access.The Admin user always has full 
user access privileges and cannot be deleted from a repository. For more information 
about modifying a password, see Changing a Password on page 3-9.

Overview of the Public Group
Each repository that you create comes with a Public group, which is set as the default 
group. Each user that you add to the Rational Test database is a member of the Public 
group and takes on all privileges of the Public group. 

If you are a member of the Administrators group, you can change the Public group 
privileges or make another group the default group for all new users. 

For more information about security, see Rational Test Database Privileges on page 3-1. 

Adding a Group
Groups allow you to set privileges for each user.

To add a group to a Rational Test database:

1 . Click Insert → Group.

2 . If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository to add a group to, and click 
O K .

N O TE: You must connect to a repository before you can add a project, user, 
group, or computer to a Rational Test database. For more information, see 
Connecting to a Repository on page 2-20.
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The Insert Group dialog box appears.

3 . Type an alphanumeric string of up to 40 characters for the name of the group.

4 . Type a description of the group.

5 . Optionally, click Set as default  group to set a group as the default group for all 
users added. 

6 . Optionally, click Select All to select all group privileges. Alternatively, add and 
remove privileges from a group by selecting or clearing the appropriate check 
boxes. Click Clear All to clear all selected privileges.

W rite Privileges – Select the appropriate check boxes to give privileges to 
a group to create, modify, or delete test assets, logs, reports and layouts, 
requirements, and builds. When you insert a group, the Builds check box is 
automatically selected with the Logs check box grayed out to ensure that you 
have access to the logs for each build that you create, modify, or delete. To clear 
the Logs check box, clear the Builds check box.
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Custom ization Privileges – Select the appropriate check boxes to give privileges 
to a group to customize test assets or builds. Test assets include scripts, and 
schedules. You can customize the properties of scripts, schedules, and build 
states using Rational TestManager. For more information about customizing 
scripts and schedules, see the chapter about planning tests in the Using Rational 
Robot manual. For more information about customizing build states, see the 
chapter about managing builds, log folders, and logs in the Using Rational Robot 
manual. 

Adm inistration Privileges – Select the appropriate check boxes to give 
privileges to a group to manage projects, users, groups, or computers.

7 . Click O K .

Modifying a Group
You must have privileges to modify a group. For more information about privileges, 
see Rational Test Database Privileges on page 3-1.

To modify existing group information:

1 . Connect to the repository that you want to modify. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.

2 . If Groups is not visible in the left pane of the main window, double-click 
Rational Test D atabase.

3 . If the group that you want to modify is not visible, double-click Groups to 
display all groups.

4 . Select the group to modify.

5 . Click Edit  → Properties.

6 . Change the group information. 

7 . Click O K  to apply your changes.

Deleting a Group
When you delete a group, you delete the group privileges for any users in the deleted 
group. You do not delete any users who are members of the deleted group. 

You must have privileges to delete a group from a Rational Test database. For more 
information about privileges, see Rational Test Database Privileges on page 3-1.

To delete a group from a Rational Test database:

1 . Connect to the repository that you want to modify. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.
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2 . If Groups is not visible in the left pane of the main window, double-click 
Rational Test D atabase.

3 . If the group that you want to delete is not visible, double-click Groups to 
display all groups.

4 . Select the group to delete, and then click Edit  → D elete. 

The Administrator prompts you to confirm the deletion.

5 . Click Yes.

RequisitePro and ClearQuest Database Security
To set security privileges for a RequisitePro or ClearQuest database, see the 
RequisitePro or ClearQ uest H elp.

Managing Users

U sers are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage scripts 
that run across a network.

If you have privileges, you can add new users and modify information for existing 
users. For each user, you can specify a user ID, password, first name, last name, 
company, title, department, phone number, and email address.

You can assign privileges to a user by adding a user to a group. When you add a user 
to a group, the user takes all privileges of that group. A user can be a member of one 
or more groups. 

You must have privileges to add new users, modify user information, and change 
user privileges. For more information about privileges, see Rational Test Database 
Privileges on page 3-1.

Adding a User

To add a user to a Rational Test database:

1 . Click Insert → U ser.

2 . If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository to add a user to, and click O K.

N O TE: You must connect to a repository before you can add a project, user, 
group, or computer to a Rational Test database. For more information, see 
Connecting to a Repository on page 2-20.
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3 . Type information about a user in the General tab of the dialog box. 

4 . Click the Groups tab to add or remove a user from a group.

5 . In the N ot A M ember O f list, select one or more groups to make the user 
a member, and click >  or > > .

6 . Click O K .

For more information about groups, see Rational Test Database Privileges on page 3-1.

For deta iled in form ation 
about an item , click the 
question m ark, and then 
click the item .
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Modifying a User 
You must have privileges to modify a user in a Rational Test database. For more 
information about privileges, see Rational Test Database Privileges on page 3-1.

To modify existing user information:

1 . Connect to the repository that you want to modify. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.

2 . If U sers is not visible in the left pane of the main window, double-click Rational 
Test D atabase.

3 . If the user that you want to modify is not visible, double-click U sers to display 
all users.

4 . Select the user to modify.

5 . Click Edit  → Properties.

6 . Click the General tab and change the general information. 

7 . Click the Groups tab and change the groups information. 

8 . Click O K  to apply your changes.

Deleting a User
You must have privileges to delete a user from a Rational Test database. For more 
information about privileges, see Rational Test Database Privileges on page 3-1.

To delete a user from a Rational Test database:

1 . Connect to the repository that you want to modify. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.

2 . If U sers is not visible in the left pane of the main window, double-click Rational 
Test D atabase.

3 . If the user that you want to delete is not visible, double-click U sers to display all 
users.

4 . Select the user to delete.

You cannot delete the adm in user.

5 . Click Edit  → D elete. 

The Administrator prompts you to confirm the deletion.

6 . Click Yes.
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Changing a Password
To change a password:

1 . Double-click Rational Test D atabase in the left pane of the main window.

2 . Double-click U sers to display all users.

3 . Select the user name of the password that you want to change.

4 . Click Edit → Properties, or right-click and then click Properties.

5 . Click the General tab of the dialog box.

6 . Select the original password (xxxxx) in the Password box, and then type a new 
password over it.

Type an alphanumeric string of up to 20 characters for the password. Passwords 
are case-sensitive. A user with a defined password must type that password and 
user ID to log into the Rational software.

7 . Click O K .

Managing Computers

To manage your testing efforts, you can add a computer to a Rational Test database, 
modify computer information, and delete a computer from a Rational Test database.

Before You Add a Computer
Before you add a computer to a Rational Test database, you must determine the 
network name of the computer.

Determining the Network Name of a Computer
To determine the network name of a Windows computer:

1 . Click Start → Settings → Control Panel → N etwork.

2 . Click the Identification tab and write down the Com puter N am e (network 
name). You will need the network name when you add the computer to a 
Rational Test database.

3 . Click O K .

To determine the network name of a U N IX computer:

1 . At the U N IX prompt, type: # hostname

2 . Write down the network name. You will need the network name when you add 
the computer to a Rational Test database.
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Adding a Computer
When you add a computer to a Rational Test database, you do the following:

ã Type the network name, operating system, and a description of the computer.

ã Optionally, define how Rational LoadTest uses the computer in a schedule.

ã Optionally, type the port name and number of the computer used for proxy 
recording with Rational LoadTest. For more information, see the Using Rational 
LoadTest manual.

Before you add a computer to the Rational Test database, you must determine the 
network name of your computer. For information about determining the network 
name of a computer, see Determining the N etwork N ame of a Computer on page 3-9. 

To add a computer to a Rational Test database:

1 . Click Insert → Com puter to add a computer.

2 . If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository to add a computer to, and 
then click O K.

3 . Click the General tab, and then type information about the computer.

N O TE: You must connect to a repository before you can add a project, user, 
group, or computer to a Rational Test database. For information about connecting 
to a repository, see Connecting to a Repository on page 2-20.
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a. Type a descriptive name of up to 40 characters in the N am e box. 
U se the N am e box to help you easily identify your computer if the network 
name is not very descriptive. For example, you can type WinNT4GUIagent 
as the name of a Windows N T 4.0 system running GU I agents.

b. Type the N etwork N am e or the TCP/IP address. For more information 
about determining a computer’s network name, see Before You Add a 
Computer on page 3-9.

c. Select an operating system from the O perating System  list. 

d. Optionally, type a description of the computer in the D escription box.

4 . Click the U sage tab and type information about how you plan to use the 
computer.

a. Select the appropriate check box under Recording uses for the type of 
LoadTest recording on your computer.

Client  – Select if you are using this computer as a client.

Server – Select if you are using this computer as a database server, proxy 
server, or Web server.

N O TE: If your operating system does not appear in the O perating System  list, 
you can add it to this list. For more information about adding an operating 
system, Customizing Operating Systems on page 3-13. 
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b. Select the appropriate check box under Playback uses for the type of 
LoadTest playback on your computer.

GU I Agent  – Select if you are using this computer to play back a GU I script.

VU  Agent – Select if you are using this computer to play back a virtual user 
script.

c. Click Add to type the port name and number of the computer for the 
application-under-test. 

i. O ptionally, type the port name. The port name helps to identify the 
computer when you are recording tests.

i. Type the port number.

ii. Click O K .

To remove a port name and number, select the port name, and then click 
Rem ove. 

5 . Click O K .

If You Have Problems Adding a Computer
The Administrator checks the network name for you. If the network cannot find 
your computer, an error message appears. 

If you typed in a valid network name for your computer and an error message still 
appears, we recommend that you type a static TCP/IP address as the N etwork N am e 
in the Insert Com puter dialog box. 

N O TE: If you use a TCP/IP address, it must be a static address. Contact your 
network administrator for the static TCP/IP address of the computer that you 
want to add to a Rational Test database.
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Customizing Operating Systems
When you add a computer to a Rational Test database, if your computer’s operating 
system does not appear in the list of operating systems, you can add it to the list.

To add an operating system to the list of operating systems: 

1 . Click Tools → Custom ize O perating System s.

2 . If you are connected to more than one repository, a dialog box appears with a list 
of all connected repositories. Select the repository to connect to, and then 
click O K .

3 . Click Add, and then type the name of the operating system that you want to add 
in the N ew List Entry box.

4 . Click O K .

5 . Click O K .
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Modifying a Computer
You can modify the following information about a computer in the Rational Test 
database:

ã N ame

ã N etwork name

ã Operating system

ã Description

ã Recording uses and playback uses 

ã Ports name and number

You must have privileges to modify computers. For more information about 
privileges, see Rational Test Database Privileges on page 3-1.

To modify existing computer information: 

1 . Connect to the repository that you want to modify. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.

2 . If Com puters is not visible in the left pane of the main window, double-click 
Rational Test D atabase.

3 . If the computer that you want to modify is not visible, double-click Com puters 
to display all computers.

4 . Select the computer to modify.

5 . Click Edit  → Properties.

6 . Click the General tab and change the general information. 

7 . Click the U sage tab and change the usage information. 

8 . Click O K  to apply your changes.

Deleting a Computer
You must have privileges to delete a computer from a Rational Test database. For 
more information about privileges, see Rational Test Database Privileges on page 3-1.

To delete a computer from a Rational Test database: 

1 . Connect to the repository that you want to delete. For more information about 
connecting to a repository, see Connecting to a Repository on page 2-20.

2 . If Com puters is not visible in the left pane of the main window, double-click 
Rational Test D atabase.
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3 . If the computer that you want to delete is not visible, double-click Com puters 
to display all computers.

4 . Select the computer to delete.

5 . Click Edit  → D elete. 

The Administrator prompts you to confirm the deletion.

6 . Click Yes.
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Managing a SQL Anywhere Database 
Server

This chapter explains how to configure and manage a SQL Anywhere database 
server. It includes the following topics:

ã N etwork server requirements

ã Server terminology

ã Creating a SQL Anywhere database server

ã Changing a SQL Anywhere database server configuration 

ã Starting a SQL Anywhere database server

ã Stopping a SQL Anywhere database server

ã Deleting a SQL Anywhere database server

ã U sing the Sybase Central database management tool 

ã U sing the Sybase ISQL utility

ã U sing the SQL Anywhere Service Manager

ã What to do next
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Network Server Requirements

If you use Sybase SQ L Anywhere software for your database, make sure that your 
network server meets the following minimum hardware and software requirements:

Server Terminology

The following table lists some terms that apply to a SQL Anywhere database server:

Creating a SQL Anywhere Database Server

To create a SQL Anywhere database server, you perform the following tasks:

1 . Install the Sybase SQL Anywhere Server software before you create a 
SQL Anywhere database server. 

For information about installing the SQL Anywhere Server software, see the 
installation guide for your product.

Operating system Windows NT 4.0 Server or Workstation 4.0 

Processor Pentium

Memory 64 MB

Disk space 100 MB 

N etwork protocol TCP/IP

Microsoft service pack 5

N O TE: N ovell N etWare is no longer supported for network servers.

Term Definition

server The computer with Sybase SQL Anywhere 
Server software installed on it

service Starts the SQL Anywhere database server

SQL Anywhere database server A service that manages database requests for 
one or more repositories
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2 . Choose a user account to run the SQL Anywhere database server and set 
privileges for that account. 

For information about setting privileges, see the next section, Setting Privileges.

3 . Create a SQ L Anywhere database server. 

For information about creating a SQL Anywhere database server, see How to 
Create a SQL Anywhere Database Server on page 4-5.

Setting Privileges
To set privileges for a user account running a SQL Anywhere database server: 

1 . Do one of the following:

If a computer is 
running

Then

Windows 2000 
Server

a. Click Start → Programs → Administra tive Tools → 
Local Security Policy.

b. Click Local Policies, and then double-click U ser Rights 
Assignment.

Windows 2000 
Professional

a. Click Start → Settings → Control Panel.

b. Click Administrative Tools.

c. Click Local Security Policy.

 N T Server a. Click Start → Programs → Administrative Tools 
(Common) → U ser M anager for D omains.

b. Click U ser → Select D omain and type the local 
machine in the D omain box, and then click O K.

c. Click Policies → U ser Rights.

d. Click Show Advanced U ser Rights.

 N T Workstation a. Click Start → Programs → Administrative Tools 
(Common) → U ser M anager.

b. Click Policies → U ser Rights.

c. Click Show Advanced U ser Rights.
4 -3



M anag ing a SQ L Anywhere D atabase Server
2 . Do the following:  

If a computer is 
running

Then

Windows 2000 a. Click Start → Settings → Control Panel.

b. Click Administrative Tools.

c. Click Local Security Policy.

 Windows N T a. Click Access this computer from  network in the 
Right  list and complete steps 3–8.

b. Click Log on as a  service in the Right  list and 
complete steps 3–8.

c. Click Log on locally in the Right list and complete 
steps 3–8.
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3 . Click Add.

4 . Click the domain of the account running the SQL Anywhere database server 
from the List N am es From  list.

5 . Click Show U sers. 

6 . Click the account running the SQL Anywhere database server from the 
N am es list.

7 . Click Add, and then click O K .

8 . Go back to step 4 to set all privileges.

9 . Click O K .

1 0 . Click U ser → Exit. 

How to Create a SQL Anywhere Database Server
To create a SQL Anywhere database server:

1 . Click Start → Program s → Rat iona l product  nam e → Rational 
Adm inistrator.

2 . Click File → N ew SQ L Anywhere D atabase Server.

3 . Type an alphanumeric string of up to 30 characters that uniquely identifies this 
database server on the network, and then click N ext . 
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4 . Type the amount of space for caching data for the SQ L Anywhere database 
server, and then click N ext.  We recommend 2048K for each Rational repository 
on the server.

5 . Select one or more protocols to communicate with the SQL Anywhere database 
server, and then click N ext.

6 . Choose the Startup options, as described in the following steps.

a. Click one of the following buttons to set the N T Service Startup options. 
These options start the SQ L Anywhere database server when you turn on 
your system.

– Click Autom atic to start the N T Service that starts the SQL Anywhere 
database server when you start your system.

– Click M anual to not start the N T Service that starts the SQL Anywhere 
database server when you start your system.

b. Select or clear the Start service im m ediately check box. This option starts 
the SQL Anywhere database server immediately after you create it. If the 
box is cleared, you must start the server manually. 

N O TE: To reduce connection time, check only those protocols that are 
actually used on your network.
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7 . Choose the Account  options:

a. Click one of the following buttons:

– Click System  Account (LocalSystem ) to run the service under a local 
account. 

– Click O ther Account to allow users access to a shared ClearQuest 
database or shared repository. We recommend that you choose this option 
because it allows users the most flexibility for accessing a database or 
repository.

i. Type a domain and user account name in the O ther Account box.

The user account name is case-sensitive. This user account must 
have the appropriate privileges to access a shared database or 
repository. For information about setting privileges, see Setting 
Privileges on page 4-3.

ii. Type the password for the account. 
The password is case-sensitive.

b. Click D isplay database m onitor to display the SQ L Anywhere database 
monitor when the SQL Anywhere database server starts. This option is not 
available when you click O ther Account. 

8 . Click N ext.

A summary appears which confirms your choices.

9 . Click Finish.

N O TE: If you choose this option, you will not be able to remotely 
configure a ClearQuest database using U N C.
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Changing a SQL Anywhere Database Server Configuration 

To change the configuration of a SQL Anywhere database server:

1 . Click Start → Program s → Rat iona l product  nam e → Rational 
Adm inistrator.

2 . In the left pane, right-click a server under SQ L Anywhere D atabase Servers, 
and then click Properties.

3 . Optionally, click the Basic tab and change any of the options. 

4 . Optionally, click the Advanced tab and change any of the advanced settings. 

5 . Click O K .

Starting a SQL Anywhere Database Server

The Rational Administrator generates a startup command that can help you start a 
SQL Anywhere database server. The Administrator lets you manually start a SQL 
Anywhere database server on a Windows N T workstation or a Windows N T server.

To start a SQL Anywhere database server:

1 . Click File � Start SQ L Anywhere D atabase Server. 

If you created more than one database server, a dialog box appears with a list of 
all database servers. 

2 . Select the SQL Anywhere database server that you want to start, and then 
click O K .

SQL Anywhere Server Startup Switches
The basic startup command syntax is:

DBSRV50 -n ServerName -c CacheMemory -x Protocols 
drive:\database\DB\RAS.DB -n Databasename

For example:

DBSRV50 c:\SQLDIR\DB\RAS.DB -n Proj1DB

N O TE: The advanced settings are intended for use by, or in close 
cooperation with, Rational Technical Support. In most cases, these settings 
do not need modification.
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or for a shared directory:

DBSRV50 \\KRANTI\SQLDIR\DB\RAS.DB -n Proj1DB

The default SQ L Anywhere startup switches are:

For complete descriptions of all SQL Anywhere switches and components, 
see the SQ L Anywhere H elp.

Stopping a SQL Anywhere Database Server
To stop a SQ L Anywhere database server:

1 . Click File → Stop SQ L Anywhere D atabase Server. 

If you have more than one database server running, a dialog box appears with a 
list of the running database servers. 

2 . Select the SQL Anywhere database server that you want to stop, and then 
click O K .

SQL Anywhere Startup 
Switches

Description

DBSRV50 The SQ L Anywhere server executable.

-n ServerName The SQ L Anywhere server name.

-c CacheMemory The amount of cache memory. (We recommend using 
the default cache memory which is set to 2048K for 
each repository.)

-x Protocols A comma-separated list of protocols.

drive:\Database or 

\\machinename\shared\

The drive and location of the repository directory. 
We recommend that you use the U niversal N aming 
Convention (U N C) here. (The \DB\RAS.DB path 
is required.)
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Deleting a SQL Anywhere Database Server

You must have privileges to delete a SQ L Anywhere database server. For more 
information about privileges, see Rational Test Database Privileges on page 3-1.

To delete a SQL Anywhere database server:

1 . Select the server to delete from the list of SQ L Anywhere D atabase Servers 
in the left pane of the main window.

2 . Click Edit  → D elete. 

The Administrator prompts you to confirm the deletion.

3 . Click Yes to delete the server.

Using the Sybase Central Database Management Tool

You can start the Sybase Central database management tool from the Administrator. 
This tool exposes SQ L Anywhere database server settings, properties, and utilities 
in a graphical user interface. For more information about using the Sybase Central 
database management tool, see the SQL Anywhere H elp.

To start the Sybase Central database management tool from the Administrator:

ã Click Tools → Sybase Centra l.

Using the Sybase ISQL Utility

The Sybase ISQL provides you with an interactive environment for database 
browsing and for sending SQL statements to a particular SQ L Anywhere database 
server. For more information, see the SQL Anywhere Help.

To start the Sybase ISQL utility from the Rational Administrator:

ã Click Tools → ISQ L.

Using the SQL Anywhere Service Manager

The SQL Anywhere Service Manager lets you start, stop, or pause a SQ L Anywhere 
Server service. You can also edit the configuration parameters of each service. For 
more information, see the SQ L Anywhere H elp.

To start the SQL Anywhere Service Manager from the Rational Administrator:

ã Click Tools → SQ L Anywhere Service M anager.
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What To Do Next

As the next step, you can create or delete a repository, or you can change the type of 
database. The following table lists the sections that provide more information about 
these tasks.  

Task See

Create a repository. Creating a Repository on page 2-13

Change a database type. Changing a Rational Test Database Type on page 
2-22 and Changing a ClearQuest Database Type 
on page 2-23

Delete a repository. Deleting a Repository on page 2-22
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Customizing Toolbars
The Rational Administrator has two default toolbars:

ã Standard – Contains buttons for choosing the most frequently used commands 
for that component.

ã Tools – Contains buttons for choosing other components. 

All toolbar buttons correspond to menu commands. Click a toolbar button to 
immediately access the menu command. The toolbar buttons are dynamic. This 
means that some toolbar buttons are enabled only when you select related menu or 
toolbar commands.

Viewing Information About Toolbar Buttons

There are several ways to view information about a toolbar button and its 
corresponding menu command:

ã To see the name of the button in a ToolTip, point to the button and pause.

ã To see a brief description in the status bar, point to the button or menu 
command.

ã To see more detailed information about the button or menu command, do one 
of the following:

– Point to the button or menu command and press F1. 

– Click the H elp Pointer icon on the right side of the Standard toolbar, and 
then point to the button or menu command and click the mouse button.

For a list of the toolbar buttons and a description of the corresponding commands, 
see the H elp for that product or component.
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Displaying Toolbars

To display or hide a toolbar:

ã Click View → Toolbars, and then click the name of the toolbar you want to 
display or hide.

A check mark appears in front of the name of each displayed toolbar.

Anchoring and Floating Toolbars

The Standard and Tools toolbars are anchored within each component’s main 
window below the menu bar. H owever, you can drag an anchored toolbar from 
within a window and make it a floating toolbar, which you can position and resize 
independently of the main window. When you do this, the toolbar remains visible 
even when you minimize a component or when the component is hidden behind 
another application. You can also drag a floating toolbar and anchor it inside of the 
window.

Floating toolbars are always on top of all other windows. This ensures that they are 
never hidden. The following figure shows a floating toolbar and an anchored toolbar.

D rag the bar to  create a float ing toolba r.

D rag the t it le bar to  m ove a float ing too lbar.

D rag an edge or corner to  change the too lbar’ s shape.

D rag the toolba r to  the m enu bar to  anchor it .

Anchored toolbar

Floating too lbar
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Setting Toolbar Options

To set the toolbar options:

1 . Click View → Toolbars → Custom ize, or right-click a toolbar and click 
Custom ize. 

2 . In the Toolbars tab, select or clear the appropriate check boxes:

Show ToolT ips – Displays a ToolTip when you point to a button and pause.

Cool Look – Changes the appearance of the toolbar buttons so that they have no 
borders. It does not change the behavior of the buttons.

Large Buttons – Changes the size of the toolbar buttons.

3 . Click O K . 

Adding, Deleting, and Moving Toolbar Buttons

To add, delete, or move a toolbar button:

1 . Click View → Toolbars → Custom ize, or right-click a toolbar and click 
Custom ize.

2 . Click the Com m ands tab. 

3 . To add a button, click a menu name from the Categories list. Each name in the 
list represents a menu in the menu bar. Click a button to see its description. Drag 
the button to the toolbar. Make sure you release the mouse button within the 
toolbar.

4 . To delete a button, drag it anywhere outside the toolbar. 

5 . To move a button, drag it to a new location.

6 . Click O K . 

Creating Your Own Toolbar

To create a custom toolbar that contains just the buttons you want:

1 . Click View → Toolbars → Custom ize, or right-click a toolbar and click 
Custom ize.

2 . Click the Toolbars tab.

3 . Click N ew.

4 . Type the name for the new toolbar and click O K .
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5 . Click the Com m ands tab.

6 . Click a menu name from Categories.

7 . Click a button to see its description. Drag the button to the new toolbar. Make 
sure you release the mouse button within the new toolbar.

8 . Repeat steps 6 and 7 until you are finished adding buttons.

9 . Click O K . 

Resetting and Deleting Toolbars

To restore a default toolbar to its original configuration or to delete a custom toolbar:

1 . Click View → Toolbars → Custom ize, or right-click a toolbar and click 
Custom ize. 

2 . In the Toolbars tab, do one of the following:

– To reset a default toolbar to its original configuration, highlight the toolbar 
in the list and click Reset.

– To delete a custom toolbar, highlight the toolbar in the list and click D elete.

This command button changes depending on the type of toolbar you selected.

3 . Click O K . 
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action object  – In TestFactory, an object in the application map that represents an 
action to which a control in the application responds. Typical actions are mouse 
left-click, mouse right-click, and mouse left-double-click; the corresponding action 
objects in the application map are LeftClick, RightClick, and LeftDoubleClick.

ActiveX  control – A reusable software control that takes advantage of Object Linking 
and Embedding (O LE) and Component Object Modeling (COM) technologies. 
Developers can use ActiveX controls to add specialized functions to applications, 
software development tools, and Web pages. Robot can test ActiveX controls in 
applications.

actual results – In a functional test, the outcome of testing an object through a 
verification point in a GU I script. Actual results that vary from the recorded baseline 
results are defects or intentional changes in the application. See also baseline results.

Adm inistrator – See Rational Administrator. 

Agent com puter – In LoadTest, a computer that has the Rational Agent software 
installed and that plays back a virtual user or GU I script. In a LoadTest schedule, 
you can identify the Agent computer on which to run a script. See also Rational Agent.

API recording – In Robot, a virtual user recording method that captures API calls 
between a specific client application and a server. These calls are captured on the 
client computer. 

application m ap – In TestFactory, a hierarchical list of controls and actions in the 
application-under-test, as well as the states of the application-under-test and the 
transitions between those states. An application map can include U I objects and 
action objects, as well as TestFactory objects such as Pilots, Test Suites, and scripts. 

application-under-test  – The software being tested. See also system-under-test.

Asset Browser – A window that displays testing resources such as builds, queries, 
scripts, schedules, reports, report output, and logs. The Asset Browser is available in 
TestManager and LoadTest. 

AU T – See application-under-test.
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autom ated testing – A testing technique in which you use software tools to replace 
repetitive and error-prone manual work. Automated testing saves time and enables a 
reliable, predictable, and accurate testing process.

AutoPilot  – In TestFactory, a tool for running scripts, Test Suites, and Pilots. The 
scripts and Test Suites can run on your local computer or on computers in the Test 
Lab. The Pilots run on your local computer, and the scripts they generate can run on 
your local computer or on computers in the Test Lab.

base state – In TestFactory, the known, stable state in which you expect the 
application-under-test to be at the start of each script segment. See also script segment.

baseline results – In a functional test, the outcome of testing an object through a 
verification point in a GU I script. The baseline results become the expected state of 
the object during playback of the script. Actual test results that vary from the baseline 
results are defects or intentional changes in the application. See also actual results.

best script  – In TestFactory, an optimized script generated by a Pilot. A best script 
contains the fewest number of script segments that provide the most coverage of the 
source code or user interface in the application-under-test. 

breakpoint  – A feature of the Robot debugger. When you assign a breakpoint to a 
line of code, and then run the script in the debugger environment, the script stops 
executing at that line of code. Control returns to you, and the breakpoint line is 
displayed. From here you can view variables, perform other debugging activities, and 
continue executing the script. 

build – A version of the application-under-test. Typically, developers add new 
features or enhancements to each incremental build. As team members test a build, 
they enter defects against those features that do not behave as expected. You use 
TestManager to define and manage builds. 

built-in data  test – A data test that comes with Robot and is used with the Object 
Data verification point. A data test uses a specific property of the object, in 
conjunction with other parameters, to determine the data to capture. Although 
built-in data tests cannot be edited, renamed, or deleted, they can be copied and then 
edited, and they can be viewed. See also custom data test.

ClearQ uest – See Rational ClearQuest. 

client/server – An architecture for cooperative processing in which the software 
tasks are split between server tasks and client tasks. The client computer sends 
requests to the server, and the server responds.

code coverage – In TestFactory, the percentage of code that is tested by a script. 
This percentage is based on the portion of the code that a script touches, relative to 
all code in the application-under-test. A Pilot can use code coverage to determine the 
best script for a run. See also UI coverage.
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com m and ID  – In LoadTest’s VU  language, an identifier for a command. Robot 
automatically assigns a unique command ID, composed of an alphanumeric prefix 
and a three-digit number, to each emulation command. Because command IDs 
appear in both the virtual user script and the LoadTest report output, they enable you 
to determine the relationship between an emulation command and its response 
times.

com m and ID  prefix – In LoadTest, a prefix for a unique emulation command ID. 
The prefix defaults to the script name (up to the first seven characters). H owever, 
you can define the prefix in the Generator tab of the Virtual U ser Record O ptions 
dialog box.

custom  data  test – A customer-defined data test used with the O bject Data 
verification point. A data test uses a specific property of the object, in conjunction 
with other parameters, to determine the data to capture. Custom data tests are 
created within your organization and are stored in the repositories that were active 
when they were created. They can be edited, renamed, and deleted. See also built-in 
data test.

data  test  – A test that captures the data of an object with the Object Data verification 
point. See also built-in data test and custom data test.

datapool – A source of test data that GU I scripts and virtual user scripts can draw 
from during playback. You can automatically generate datapools using TestManager, 
or you can import datapool data from other sources such as your database. 

dependency – In LoadTest, a method of coordinating an object in a schedule with 
an event. For example, if the script Query is dependent upon the script Connect, 
then Connect must finish executing before Query can begin executing. See also 
event.

distributed architecture – Architecture in which computer systems work together 
and communicate with each other across LAN , WAN , or other types of networks. 
A client/server system is an example of distributed architecture.

distributed functional test  – In LoadTest, a test that uses multiple Agent computers 
to execute multiple GU I scripts written in the SQ ABasic language. 

dynam ic load balancing selector – A type of selector in a LoadTest schedule. Items 
in the selector, such as scripts, are executed according to a weight that you set. 

em ulation com m ands – VU  language statements or commands that emulate client 
activity, evaluate the server’s responses, and perform communication and timing 
operations. LoadTest stores the results of emulation commands in a log file, which 
you can view from the LogViewer. 
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em ulation functions – VU  language functions that emulate client activity and 
evaluate the server’s responses. U nlike emulation commands, emulation functions 
do not perform communication and timing operations, and they are not logged.

environm ent control com m ands – VU  language commands that let you control a 
virtual user’s environment by changing the VU  environment variables. For example, 
you can set the level of detail that is logged or the number of times that virtual users 
attempt to connect to a server.

event  – An item in a LoadTest schedule upon which another item is dependent. 
For example, if the script Connect sets an event and the script Query depends on this 
event, Connect must finish executing before Query can begin executing. See also 
dependency.

external script – A script that runs a program created with any tool. You plan and 
run external scripts in TestManager.

fixed user group – In LoadTest, a group that contains a scalable number of users. 
When you create a fixed user group, you indicate the maximum number of users that 
you will run in the group. Typically, you use fixed user groups in functional tests, 
which do not add a workload to the system.

flow control statem ents – In the VU  and SQABasic languages, statements that let 
you add conditional execution structures and looping structures to a script. 

functional test  – A test to determine whether a system functions as intended. 
Functional tests are performed on GU I objects and objects such as hidden 
DataWindows and Visual Basic hidden controls. 

Grid Com parator – The Robot component for reviewing, analyzing, and editing 
data files for text and numeric verification points in grid formats. The Grid 
Comparator displays the differences between the recorded baseline data and the 
actual data captured during playback.

GU I script  – A type of script written in the SQABasic language. It contains GU I 
actions such as keystrokes and mouse clicks. Typically, a GU I script also contains 
verification points for testing objects over successive builds of the application-under-
test.

GU I user – The type of user that is emulated when a GU I script is executed. 
Only one GU I user at a time can run on a computer.

hidden object  – An object that is not visible through the user interface. H idden 
objects include objects with a visible property of False and objects with no GU I 
component.

ID E – Integrated Development Environment. This environment consists of a set of 
integrated tools that are used to develop a software application. Examples of IDEs 
supported by Robot include Oracle Forms, PowerBuilder, Visual Basic, and Java.
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Im age Com parator – The Robot component for reviewing and analyzing bitmap 
image files for Region Image and Window Image verification points. The Image 
Comparator displays differences between the recorded baseline image and the actual 
image captured during playback. The Image Comparator also displays unexpected 
active windows that appear during playback.

instrum entation – In TestFactory, the process of inserting code coverage counters 
into the application-under-test. These counters record how much code is executed 
during a script run. See also object code instrumentation and source code instrumentation.

load – See workload.

load balancing – See workload balancing. 

LoadTest – See Rational LoadTest.

log – A repository object that contains the record of events that occur while playing 
back a script or running a schedule. A log includes the results of all verification points 
executed as well as performance data that can be used to analyze the system’s 
performance.

LogViewer – See Rational LogViewer.

low-level recording – A recording mode that uses detailed mouse movements and 
keyboard actions to track screen coordinates and exact timing. During playback, all 
actions occur in real time, exactly as recorded.

m anual script  – A set of testing instructions to be run by a human tester. The 
script can consist of steps and verification points. You create manual scripts in 
TestManager.

M aster com puter – A computer that executes LoadTest. From this computer, you 
create, run, and monitor schedules. When the run is finished, you use it to analyze 
test results.

m ix-ins – See Pilot mix-ins.

network recording – In Robot, a virtual user recording method that records packet-
level traffic. This traffic is captured on the wire. 

next available selector – In LoadTest schedules, a selector that distributes each item 
such as a script, delay, or other selector to an available computer or virtual user. This 
type of selector is used in a GU I schedule. The next available selector parcels out the 
items sequentially, based on which computers or virtual users are available.
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object – An item on a screen, such as a window, dialog box, check box, label, or 
command button. An object has information (properties) associated with it and 
actions that can be performed on it. For example, information associated with the 
window object includes its type and size, and actions include clicking and scrolling. 
In some development environments, a term other than object is used. For example, 
the Java environment uses component, and the H TML environment uses element.

object code instrum entation – In TestFactory, the process of inserting code 
coverage counters into the executable file of the application-under-test. These 
counters record how much of the program a script tests. See also instrumentation and 
source code instrumentation.

O bject-O riented Recording®  – A script recording mode that examines objects in 
the application-under-test at the Windows layer. Robot uses internal object names to 
identify objects, instead of using mouse movements or absolute screen coordinates.

O bject Properties Com parator – The Robot component that you use to review, 
analyze, and edit the properties of objects captured by an Object Properties 
verification point. The Object Properties Comparator displays differences between 
recorded baseline data and the actual data captured during playback.

O bject Scripting com m ands – A set of SQABasic commands for accessing an 
application’s objects and object properties. You add Object Scripting commands 
manually when editing a script.

O bject Testing®  – A technology used by Robot to test any object in the application-
under-test, including the object’s properties and data. O bject Testing lets you test 
standard Windows objects and IDE-specific objects, whether they are visible in the 
interface or hidden.

O CI  – O bject Code Insertion. The Rational technology used in TestFactory to 
instrument object code and measure how much of the application-under-test a script 
tests. See also code coverage and object code instrumentation.

perform ance test  – A test that determines whether a multi-client system performs 
within user-defined standards under varying loads. Performance tests are always run 
from a schedule in LoadTest.

Pilot – In TestFactory, a tool for generating scripts automatically. 

Pilot m ix-ins – In TestFactory, a list of Pilots that are executed on a random basis 
during the run of a lead Pilot. Mix-ins are useful for randomly testing multiple areas 
of the application-under-test. To make tests more realistic, you can combine mix-ins 
and scenarios. 

Pilot scenario – An ordered list of Pilots that are executed during the run of a Pilot. 
A Pilot scenario is useful for testing U I objects that need to be exercised in a specific 
order. To make tests more realistic, you can combine scenarios and mix-ins.
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project  – A collection of data, including test assets, defects, requirements, and 
models, that can facilitate the development and testing of one or more software 
components. 

proxy recording – In Robot, a virtual user recording method that captures the client/
server conversation on the network wire rather than on the client computer. Proxy 
recording allows Robot to capture network packets that are not visible to it during 
network recording — for example, if the client and server are in different network 
segments.

query – A request for information stored in the repository. A query consists of a filter 
and several visible attributes — the columns of data to display, the width of the 
column, and the sort order.

random  selector – A type of selector in a LoadTest schedule. Items in the selector, 
such as scripts, are randomly executed. Random selectors can be with replacement, 
where the odds are the same, or without replacement, where the odds change with 
each iteration. 

Rational Adm inistrator – The component for creating and maintaining repositories, 
projects, users, groups, computers, and SQL Anywhere servers.

Rational Agent – The LoadTest software that resides on a shared network drive and 
runs on each computer where testing occurs. The entries specified in a schedule play 
back on the Agent computer, which reports on their progress and status as they run. 
See also Agent computer.

Rational ClearQ uest – The Rational product for tracking and managing defects and 
change requests throughout the development process. With ClearQ uest, you can 
manage every type of change activity associated with software development, 
including enhancement requests, defect reports, and documentation modifications.

Rational LoadTest  – The Rational Test component for running performance, 
stress, scalability, multi-user, and distributed functional tests on multiple Agents 
connected by a network. With LoadTest, you can initiate test runs and monitor tests 
from a master computer that manages the test process. LoadTest is available only in 
Rational Suite PerformanceStudio.

Rational LogViewer – The Robot component for displaying logs, which contain the 
record of events that occur while playing back a script or running a schedule. Also, 
the component from which you start the four Comparators.

Rational Perform anceArchitect  – The Rational component that lets you test the 
performance of COM/DCO M applications. With Rational PerformanceArchitect, 
you can create a Rose sequence or collaboration diagram, convert it to a virtual user 
script, and then use Rational Suite PerformanceStudio to edit the script and run the 
performance tests.
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Rational repository – A database that stores application testing information, such as 
test requirements, scripts, and logs. All Rational Suite TestStudio and Rational Suite 
PerformanceStudio products and components on your computer update and 
retrieve data from the same connected repository. A repository can contain either 
a Microsoft Access or a Sybase SQL Anywhere database.

Rational RequisitePro – The Rational product for organizing, managing, and 
tracking the changing requirements of your system.

Rational Robot – The Rational product for recording, playing back, debugging, and 
editing scripts. 

Rational SiteCheck – The Robot component for managing your intranet or World 
Wide Web site. You can use SiteCheck to visualize the structure of your Web site, 
and you can use it with Robot to automate Web site testing.

Rational Synchronizer – The Rational tool that ensures the consistency of data 
across several Rational products.

Rational TestAccelerator – An agent application that executes scripts. TestFactory 
uses computers running TestAccelerator as remote machines on which to run 
automated distributed tests.

Rational TestFactory – The Rational Test component for mapping an application-
under-test and generating scripts automatically. TestFactory is available in Rational 
Suite TestStudio and Rational Suite PerformanceStudio.

Rational TestM anager – The Robot component for managing the overall testing 
effort. You use it to define and store information about test documents, 
requirements, scripts, schedules, and sessions.

Report Layout Editor – The TestManager component for customizing the layout of 
reports.

repository – See Rational repository. 

RequisitePro – See Rational RequisitePro. 

Robot  – See Rational Robot.

scalable user group – In LoadTest, a group that contains a varying number of users. 
When you create a scalable user group, you assign it a percentage of the total 
workload. Assume you have a scalable user group that is 50 percent of the workload. 
If you run a test with 10 users, the group will contain 5 users. If you run a test with 
100 users, the group will contain 50 users.

scenario – In LoadTest, a modular group of scripts and other items in a schedule that 
is used by more than one user group. A scenario can contain scripts, delays, and 
synchronization points. 
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scenario – See Pilot scenario.

schedule – In LoadTest, structure that you create to specify how scripts should be 
played back. A schedule can contain GU I scripts and virtual user scripts, and can 
indicate the number of times to repeat a script and the computer on which the script 
will run. In performance testing, a schedule is used to create a workload. In 
distributed functional testing, a schedule is used to distribute scripts among various 
computers.

script  – A set of instructions used to navigate through and test an application. You 
can generate scripts in a variety of ways. You can use Robot to record scripts used in 
functional testing and performance testing. You can also use TestManager to create 
and manage manual scripts, and to manage external scripts created with a third-party 
testing tool. A script can have properties associated with it, such as the purpose of the 
script and requirements for the script. See also external script, GUI script, manual script, 
and virtual user script.

script outline – In TestFactory, the readable version of a script. A script outline 
contains a description of the actions that Robot performs while running the script.

script segm ent – In TestFactory, a section of a script that tests a particular 
element of product functionality. A Pilot generates a script segment by starting the 
application-under-test in a base state, navigating through the part of the product that 
you are testing, and returning the application-under-test to the base state. See also 
base state.

seed – An initial number fed to a random number generator. U sing the same seed 
produces the same series of random numbers. In LoadTest, you use seeds to generate 
think times.

selector – An item that you insert in a LoadTest schedule to indicate how often and 
in what order to run scripts. 

sequentia l selector – In a LoadTest schedule, a type of selector that executes each 
script, delay, or other item in the same order in which it appears in the schedule. 

session – In virtual user recording, one or more scripts that you record from the time 
you begin recording until the time you stop recording. Typically, the scripts in a 
session represent a logical flow of tasks for a particular user, with each script 
representing one task. For example, a session could be made up of three scripts: 
login, testing, and logout. In TestFactory, a session is the period of time that the 
TestFactory application or a window is open.

shared variable – An integer variable that multiple scripts and multiple virtual users 
can read and write to. You can see the value of a shared variable while monitoring a 
LoadTest schedule. For example, you can set a shared variable as a flag to end a 
playback session. Each script can check the flag to see if the session should end. When 
that flag is set, exit tasks can be performed.
Glossary-9



Glossary
shell script  – A script that calls or groups several other GU I scripts and plays them 
back in sequence. Shell scripts provide the ability to create comprehensive tests and 
then store the results in a single log.

SiteCheck – See Rational SiteCheck.

source code instrum entation – In TestFactory, the process of inserting code into 
the source code of the application-under-test. This code measures how much of the 
source code a script tests. See also instrumentation and object code instrumentation.

SQ ABasic – The Robot scripting language for recording GU I actions 
and verifying GU I objects. SQ ABasic contains most of the syntax rules and core 
commands that are contained in the Microsoft Basic language. In addition, 
SQABasic has commands that are specifically designed for automated testing. 
See also VU .

stable load – In LoadTest, a condition that occurs when a specified number of 
virtual users have logged on to the system-under-test and are active. When the stable 
load criterion is met, LoadTest begins measuring the load.

streak – When running a virtual user schedule in LoadTest, a series of successes or 
failures for emulation commands. You can see a streak while monitoring a schedule.

structura l test  – A test to determine whether the structure of a Web site is consistent 
and complete. A structural test ensures that an application’s interdependent objects 
are properly linked together. You perform a structural test using SiteCheck.

synchronization point – In LoadTest, a place where emulated virtual users stop and 
wait until all other synchronized users reach that point. When all users reach the 
synchronization point, they are released and continue executing. 

Synchronizer – See Rational Synchronizer. 

system  tuning – In LoadTest, the process of optimizing a system’s performance by 
changing hardware resources and software configuration parameters while using a 
constant workload.

system -under-test – The system being tested. This includes the computers and any 
software that can generate a load on the system, networks, user interfaces, CPU s, and 
memory. See also application-under-test.

test assets – The resources that facilitate the planning or development phases of 
the testing effort. Examples of test assets include scripts, schedules, sessions, test 
documents, and test requirements.

test developm ent  – The process of developing tests to verify the operation of a 
software application. This includes creating scripts that verify that the application-
under-test functions properly. Test development lets you establish the baseline of 
expected behavior for the application-under-test.
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test docum ents – Test plans, project schedules, resource requirements, and any 
other documents that are important to your project. You develop your test 
documents using your own word processing or scheduling program; you then 
reference the name and location of the document in TestManager. This lets 
members of the test and development team locate documents quickly.

Test Lab – A collection of computers on which TestAccelerator is running. In 
TestFactory, you can distribute the scripts associated with a Pilot, a Test Suite, or the 
AutoPilot to run on computers in the Test Lab. See also Rational TestAccelerator. 

Test Suite – In TestFactory, a tool for running a collection of scripts as a group.

TestAccelerator – See Rational TestAccelerator. 

TestFactory – See Rational TestFactory.

TestM anager – See Rational TestManager.

Text Com parator – The Robot component for reviewing, analyzing, and editing 
data files for text and numeric verification points in any format except grids. The 
Text Comparator displays the differences between the recorded baseline results and 
the actual results.

think tim e – In virtual user and GU I scripts, think times are delays that simulate a 
user’s pauses to type or think while using an application. With virtual user scripts, 
LoadTest calculates the think time at runtime, based on think time VU  environment 
variables that are set in the script. You can set a maximum think time in Robot. With 
GU I scripts, Robot uses the actual delays captured between keystrokes, menu 
choices, and other actions.

transaction – In LoadTest, a logical unit of work performed against a server. For 
example, submitting a search query or submitting a completed form to a Web server 
are both transactions.

transaction rate – In LoadTest, the playback speed calculated as a function of 
number of transactions per unit of time. For example, if a script contains one 
transaction, and each script is started at half-second intervals, your transaction rate 
would be 2 per second. 

transactor – In LoadTest, an item that you insert in a LoadTest schedule to indicate 
the number of user-defined transactions that a virtual user performs in a given time 
period.

U I coverage – In TestFactory, the percentage of objects in the application map that 
are tested by a Pilot-generated script. This percentage is the proportion of U I objects 
that the script touches, relative to all U I objects available to the Pilot. A Pilot can use 
U I coverage to determine the best script for a run. See also code coverage.
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U I object properties – Attributes of object classes and U I objects that TestFactory 
uses to map applications and generate scripts.

unexpected active window – A window that appears during script playback that 
interrupts the script playback process and prevents the expected window from being 
active. For example, an error message generated by the application-under-test is an 
unexpected active window. You can view unexpected active windows in the Image 
Comparator.

user group – In LoadTest, a collection of users that execute similar tasks and 
generate the same basic workload. Accountants and data entry operators are examples 
of user groups.

verification – The process of comparing the test results from the current build of the 
software to its baseline results. 

verification point  – A point in an SQABasic script that confirms the state of one or 
more objects. During recording, a verification point captures object information 
from the application-under-test and stores it as the baseline. During playback, a 
verification point recaptures the object information and compares it to the baseline. 
In a manual script, a verification point is a question about the state of the application-
under-test.

virtual user – In LoadTest, a type of user that is emulated when a virtual user script 
is executed. A computer can run multiple virtual users simultaneously.

virtual user script – A type of script written in the VU  language. Virtual user scripts 
contain client/server requests and responses as well as user think times.

VU  – The Robot scripting language for recording a client’s requests to a server. 
VU  provides most of the syntax rules and core commands available in the C 
programming language. In addition, VU  has emulation commands and functions 
that are specifically designed for automated performance testing. See also SQABasic.

wait state – A delay or timing condition that handles time-dependent activities.

workload – In LoadTest, the set of all activities that users perform in an actual 
production setting of the system-under-test. You can use LoadTest to emulate a 
workload.

workload balancing – In LoadTest, the act of distributing activities so no one system 
or device becomes a bottleneck.

workload m odel – In LoadTest, the workload model is represented as a schedule. 
You can play back this schedule and analyze the response times.
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