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Preface
This manual describes how to use the Rational Administrator to configure Rational 
projects. A Rational project stores software testing and development information for 
your Rational test datastores, RequisitePro projects, and ClearQuest databases.

Audience

This manual is intended for Rational system administrators, application developers, 
quality assurance managers, and quality assurance engineers.

Other Resources

■ This product contains complete online Help. From the main toolbar, 
choose an option from the Help menu. 

■ All manuals for this product are available online in PDF format. These manuals are 
on the Rational Solutions for Windows Online Documentation CD.

■ For information about training opportunities, see the Rational University 
Web site: http://www.rational.com/university.

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, please send e-mail to 
our technical publications department at techpubs@rational.com.
vii



Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Technical Support as follows:

Note:  When you contact Rational Technical Support, please be prepared to supply the 
following information:

■ Your name, telephone number, and company name

■ Your computer’s make and model

■ Your operating system and version number

■ Product release number and serial number

■ Your case ID number (if you are following up on a previously-reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4545-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
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1About the Rational 
Administrator
This chapter introduces the Rational Administrator, the Rational project, and the 
UCM project, as well as the different types of datastores. This chapter includes the 
following topics:

■ About the Rational Administrator on page 3

■ What is a Rational Project? on page 1

■ What is UCM? on page 3

■ Parts of a Rational Project on page 5

■ About the Rational Test Datastore on page 6

■ About the Rational ClearQuest Database on page 7

■ About the Rational RequisitePro Project on page 10

■ About the Rose Model on page 10

■ About Rational Synchronizer Rules on page 10

What is a Rational Project?

A Rational project stores software testing and development information for the 
following products: Rational RequisitePro, Rational ClearQuest, Rational Rose, and 
Rational testing products (Rational Robot, Rational TeamTest, and Rational 
QualityArchitect). Most of the Rational software on your computer updates and 
retrieves data from the same Rational project. 

A Rational project consists of the following items:

■ Rational Test datastore – Stores application testing information such as test assets, 
logs, reports, and builds. For more information, see About the Rational Test Datastore 
on page 6.

■ Rational RequisitePro project – Stores requirements documents and a 
dynamically-linked database. For more information, see About the Rational 
RequisitePro Project on page 10.
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■ Rational ClearQuest database – Stores change-request information for software 
development, including enhancement requests, defect reports, and documentation 
modifications. Each ClearQuest database consists of one schema and one user 
database. In ClearQuest, the term schema refers to all attributes associated with a 
database. This includes field definitions, field behaviors, the state transition table, 
actions, and forms. For more information, see About the Rational ClearQuest 
Database on page 7.

■ Rational Rose models – Stores visual models for business processes, software 
components, classes and objects, and distribution and deployment processes. For 
more information, see About the Rose Model on page 10.

Benefits of the Rational Project

When you create a Rational project, you can associate various Rational product 
datastores, databases, and projects that are used for storing critical software 
development and testing information. 

Once you associate these items with a Rational project, you can link specific data from 
one item to another by using individual product features or by using the Rational 
Synchronizer. For more information about the Rational Synchronizer, see About the 
Rational Synchronizer on page 39. 

The following table provides specific examples of how you can benefit from 
associating various items with one another in a Rational project as you design, 
develop, and test software applications.

When you associate Then you can

A RequisitePro project with a 
Rose model

Use the Integrated Use Case Management feature to 
manage use cases between Rose and RequisitePro. 

A RequisitePro project with a 
Rational Test datastore 

Create a product or software requirement using 
RequisitePro and associate that requirement with a test case 
in Rational TestManager.

Associate a test case in TestManager with a requirement in 
RequisitePro.

A ClearQuest database with a 
Rational Test datastore

Generate a defect using Rational TestManager, and 
automatically store the defect in the correct Rational project 
in a ClearQuest database.
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About the Rational Administrator

The Rational Administrator centralizes the management of a Rational project. It 
manages the association of Rational product information and the users and groups for 
Rational Test.

With the Rational Administrator, you can: 

■ Create a Rational project under configuration management.

■ Create a Rational project outside of configuration management.

■ Connect to a Rational project.

■ Work with Rational projects on the network and not on your machine (register a 
project).

■ Delete a Rational project.

■ Configure a SQL Anywhere database server.

■ Create and manage users and groups for a Rational Test datastore.

■ Create and manage Rational projects containing RequisitePro projects and Rose 
models.

■ Manage security privileges for a Rational Test datastore.

■ Synchronize data among Rational Test datastores, Rational RequisitePro projects, 
and Rational Rose using the Rational Synchronizer.

What is UCM?

Unified Change Management (UCM) is Rational Software’s approach to managing 
change in software system development from requirements to release. UCM spans the 
development lifecycle, defining how to manage change to requirements, design 
models, documentation, components, test cases, and source code.

UCM is unique because it links the activities used to plan and track Rational project 
progress to the artifacts undergoing change.
About the Rational Administrator 3



The Building Blocks

UCM focuses on these two concepts:

■ An activity is a piece of work you want to accomplish. An activity might arise from 
an issue raised in a meeting, a defect entered into a defect database, or a request for 
enhancement sent in by a customer. In fact, your development process defines 
what an activity is.

■ An artifact is an item, usually a file, that you want to place under version control. 
At a more conceptual level, artifacts can be requirements, tests, visual models, 
code, project plans, and so on.

Configuration Management (CM) in UCM is activity-based and allows you to baseline 
your test assets.

A baseline is a logical grouping of project files at a specific point in time. Baselines 
allow teams to capture the progress of software artifacts at key project milestones, 
such as releases or development iterations, in relation to each other. 

Component Management in UCM is a means of creating and manipulating a consistent 
change as a single named entity rather than a set of file versions.

One of UCM’s key strengths is that it links the activities used to plan and track project 
progress with the artifacts that are undergoing change. UCM is supported by both 
process and tools:

■ The Change Management workflow in Rational Unified Process describes the 
process of using UCM.

■ Rational ClearQuest manages a project’s activities – the tasks, defects, and requests 
for enhancement – and provides charting and reporting tools that can help you 
track project progress.

■ Rational ClearCase manages all the artifacts produced by a software project.

See the Using Unified Change Management with Rational Suite manual for more 
information about UCM and how it is implemented and used with a Rational Suite.

Why Use UCM?

Rational customers and Rational employees have successfully used ClearCase and 
ClearQuest for years. During that time, common patterns have emerged regarding 
how users set up and use the tools. Based on our experience and observations, we’ve 
created UCM, a process that helps you get started with ClearCase and ClearQuest 
quickly and easily.
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UCM raises the level of abstraction of working with software configuration 
management and change management tools. For example, in a typical software 
configuration environment, you need to track the individual files you change. With 
UCM, you work on activities, letting the tools keep track of the details for you (for 
example, which files changed).

UCM is supported by Rational tools. ClearCase and ClearQuest have built-in support 
for it, so that you can start using UCM as soon as you install the tools and set up your 
environment. In addition, the Rational Unified Process describes UCM in the 
Configuration and Change Management workflow.

What UCM Is in Relation to the Rational Administrator

Use the Rational Administrator to make a Rational project UCM-enabled if it is not yet 
under configuration management. The high-level steps are:

1 Use the Rational Administrator to configure the UCM policies for the Rational 
project. This includes the setup steps you perform in ClearCase. See Creating and 
Configuring a Rational Project on page 28 for information relating to this step.

2 Use the Rational Administrator to check in all elements under Configuration 
Management. See Configuring a Rational Project on page 32.

3 Launch the ClearCase Project Explorer from the Rational Administrator.

4 Create a baseline from the ClearCase Project Explorer. See Setting Up ClearCase for 
UCM-Enabled Projects on page 29.

UCM component baselines can include requirements, test information, source code, 
and models.

UCM support comes with every Rational Suite; ClearCase LT is one of the 
team-unifying tools.

UCM has been extended to manage change to requirements and test artifacts and to 
support UNIX. Also, UCM ClearQuest features are available to Rose developers.

Parts of a Rational Project

A Rational project can consist of the following parts:

■ No more than one Rational Test datastore

■ No more than one RequisitePro project

■ No more than one ClearQuest database

■ Any number of Rose models

■ Rational Synchronizer rules
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About the Rational Test Datastore

A Rational Test datastore is a large collection of test assets, many of which are 
represented via XML files. The XML files are grouped logically into a hierarchy of 
folders and contain test asset properties and information about the relationships 
between test assets. A TestDatastore includes assets such as test scripts, suites, 
datapools, logs, reports, test plans, build information, and more. 

Rational Test users and groups are maintained in a separate datastore named 
TestUsersAndGroups.

About Users

Test users are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage scripts 
that run across a network.

For each test user, you can specify a user ID, password, first name, last name, 
company, title, department, phone number, and e-mail address.
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You can assign privileges to a test user by adding a user to a test group. When you 
add a test user to a test group, the test user takes all privileges of that test group. A 
test user can be a member of one or more test groups. The only privilege needed to 
modify or add test users of test groups is the Rational project password.

For more information about users, see Managing Test Users on page 44.

About Groups

Each Rational Test datastore that you create comes with a default test user, Admin. The 
Admin test user is not a member of any specific test group and takes on all available 
privileges.

You can make any test group a default group. When you add a test user to a 
Rational Test datastore, and this option is set, every test user that you create takes on 
the privileges of the default test groups.

For more information about groups, see Managing Test Groups on page 42.

About the Rational ClearQuest Database

A Rational ClearQuest database consists of a schema and a user database. 
A ClearQuest schema stores all schemas and all data associated with existing 
schemas. The schema does not store any user data. A ClearQuest user database 
contains all user data and a copy of the schema associated with the database. User 
data in a ClearQuest database includes change-request records such as defects, as well 
as reports, records or tables, and all data entered by users. 

A ClearQuest schema defines the following information for each change-request 
record:

■ Forms used to submit and modify a record

■ Field types, legal values, and so on

■ States a record can be in (optional)

■ Actions used to modify or change the state of a record

■ Hooks written in Visual Basic Script that further customize legal field values, 
dependent fields, and actions (optional)

A full version of Rational ClearQuest comes with Rational Suite TestStudio. If you 
have purchased Rational TeamTest, you will need to upgrade to the full version of 
ClearQuest if you want to add fields to a schema or connect to a database to which 
fields have been added.
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Types of Rational ClearQuest Databases

When you create a ClearQuest user database, it can be either a Microsoft Access, 
Sybase SQL Anywhere Database Server, Microsoft SQL Server, or Oracle database. For 
a summary of which type of database software to install, see Determining a Database 
Type on page 9.

Rational ClearQuest Web lets you remotely enter change-request records using a 
Web-based interface. 

Note:  Rational ClearQuest Web does not support Microsoft Access databases.

Microsoft Access – Microsoft Access is the default database type and installs 
automatically when you install your Rational software. We recommend using 
Microsoft Access for a database with seven or fewer concurrent users. However, with 
more than seven users, data access is slower than for a comparably sized Sybase SQL 
Anywhere Database Server database. This type of database is virtually 
maintenance-free. For example, you can back up the database simply by backing up 
the Rational project directory. 

Sybase SQL Anywhere Database Server – Sybase SQL Anywhere Database Server 
software comes with your Rational software, but does not install automatically. We 
recommend using this type of database for a database with eight or more concurrent 
users. Data access for a SQL Anywhere Database Server database is faster than for a 
comparably sized Microsoft Access database. For information about installing this 
software, see your Rational installation manual. 

Microsoft SQL Server – Microsoft SQL Server does not come with your Rational 
software. You can use this software for ClearQuest databases; however, you must 
purchase the software and install it separately.

Oracle – Oracle does not come with your Rational software. You can use this software 
for ClearQuest databases; however, you must purchase the software and install it 
separately.
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Determining a Database Type

The following table summarizes which type of database software to use for a 
ClearQuest database. 

If your Rational ClearQuest 
database

Then 

Has seven or fewer concurrent 
users, is not accessed over a 
wide-are network, and you are 
not using Rational ClearQuest 
Web

Use a Microsoft Access database. This is the default 
database and installs automatically when you install your 
Rational software. 

Rational ClearQuest Web does not support MIcrosoft 
Access databases.

Has eight or more concurrent 
users or is accessed over a 
wide-area network

Install the Sybase SQL Anywhere Database Server software 
that comes with your Rational software. We recommend 
using a Window NT Server for your database server 
because a Windows NT Workstation allows only ten 
network connections. For more information about installing 
Sybase SQL Anywhere Database Server software, see your 
Rational installation manual.

Has eight or more concurrent 
users and you want to use 
Microsoft SQL Server for your 
database

Purchase Microsoft SQL Server software.

Install Microsoft SQL Server to use with ClearQuest. For 
information about installing Microsoft SQL Server for 
ClearQuest, see the Installing Rational ClearQuest manual.

Configure Microsoft SQL Server to use with ClearQuest. 
For information about configuring Microsoft SQL Server for 
ClearQuest, see the Administering Rational ClearQuest 
manual.

Both of these manuals are on the Rational Solutions for 
Windows Online Documentation CD.

Has eight or more concurrent 
users and you want to use 
Oracle for your database

Purchase Oracle software.

Install Oracle to use with ClearQuest. For information 
about installing Oracle for ClearQuest, see the Installing 
Rational ClearQuest manual.

Configure Oracle to use with ClearQuest. For information 
about configuring Oracle for ClearQuest, see the 
Administering Rational ClearQuest manual.

Both of these manuals are on the Rational Solutions for 
Windows Online Documentation CD.
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About the Rational RequisitePro Project

All requirements for a Rational project are stored in a RequisitePro project. Each 
RequisitePro project consists of requirements documents and a dynamically-linked 
RequisitePro database. A RequisitePro project document can store text, graphics, or 
other objects (such as OLE objects) that identify project needs and are meaningful to 
users. To open a requirements datastore, start RequisitePro and refer to the 
RequisitePro Help.

With RequisitePro, you can customize the requirements database and use other 
advanced requirements management features such as traceability and 
requirements-attribute management. You can also manage all of your Rational 
project’s requirements — for example, user requirements, software specifications, and 
use cases.

About the Rose Model

A Rose model is a graphical representation of a software system. A model can 
represent business processes, software components, classes and objects, and 
distribution and deployment processes.

About Rational Synchronizer Rules

You can share or link data between applications that store data in Rational Test, 
Rational RequisitePro, or Rational Rose. However, when you update data in one of 
these products, you often want to update this data in other products. The Rational 
Synchronizer is a software tool that lets you:

■ Ensure consistency of data across several products — a single change in one type 
of data can be updated in other types of data simultaneously.

■ Jump-start work in one product with the data from another product.

■ Conduct impact analysis — you can synchronize data in several different products 
to gain a deeper understanding of how changes in requirements or design changes 
impact your overall software development process.

You can start the Synchronizer from the Administrator. For more information, see 
Starting the Synchronizer on page 40.
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2Using the Rational 
Administrator
This chapter explains how to use the Rational Administrator software to perform 
administrative tasks on a Rational project. It includes the following topics:

■ Starting and Exiting the Rational Administrator on page 11

■ The Rational Administrator Main Window on page 12

■ Rational Project Privileges on page 12

■ Upgrading from Rational Test 7.x to 2001 on page 12

■ The following table lists the new test asset types: on page 22

■ Rational Project Tasks on page 23

■ Before Creating a Rational Project on page 26

■ Creating and Configuring a Rational Project on page 28

■ Managing a Rational Project on page 34

■ Starting Rational Products on page 37

Starting and Exiting the Rational Administrator

To start the Rational Administrator:

■ Click Start > Programs > Rational product name > Rational Administrator.

To exit the Administrator:

■ Click File > Exit.
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The Rational Administrator Main Window

After you start the Rational Administrator, the main window appears. It is composed 
of two parts: the Project pane and the Details pane.

■ The Project Pane - The left pane of the main window, the Project pane, displays a 
list of Rational projects and SQL Anywhere database servers. When you connect to 
a Rational project, you can add or delete projects. You can also add or delete users 
and groups from a Rational Test datastore.

■ The Details Pane - When you select an item in the left pane of the main window, 
information about the selected item appears in the right pane, the Details pane.

Rational Project Privileges

When you connect to a Rational project, you may be asked to enter a password if one 
has been assigned to the project on the Project Properties dialog box. You can assign a 
password to an existing project if you wish. See Displaying and Modifying the Properties 
of a Rational Project on page 36.

You can also regulate access to the Rational Test datastore by using users and groups. 
For more information about privileges, see Rational Test Datastore Privileges on page 41.

Upgrading from Rational Test 7.x to 2001

If you are upgrading from Rational Test 7.x, you must do the following tasks in order:

1 Install Rational Test 2001.

2 Upgrade your TeamTest/TestStudio-based schema from the version available in 
ClearQuest 7.x.

If you are upgrading from SQA Suite 6.x, you must first convert to a Rational 7.x 
repository. See the Installing Rational Testing Products manual for directions. 
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3 Convert your Rational 7.x repository to a project.

Before starting these procedures:

■ Back up your current repository. You will not be able to use it as a repository after 
you convert it to a project.

■ Be aware that you must have administrator permission to convert the repository. 

Upgrading the TeamTest/TestStudio Schema (from 7.x to 2001)

These procedures describe how to upgrade a TeamTest/TestStudio-based schema to 
version 2001. Because the procedures use a sample Rational schema, the packages and 
record types shown may differ somewhat from what you have at your site. For 
additional information, see the Administering Rational ClearQuest manual, which is 
available online on the Rational documentation CD.

To upgrade the TeamTest/TestStudio schema: 

Connect to Your Existing ClearQuest Master Database

To connect to your ClearQuest master database:

1 Click Start > Programs > Rational product name > Rational ClearQuest > Rational 
ClearQuest Maintenance Tool. 

2 Click Browse and navigate to your Rational ClearQuest master database or load a 
profile that points to your master database.

Upgrade the ClearQuest Schema and Database

1 Click Start > Programs > Rational product name > Rational ClearQuest > Rational 
ClearQuest Designer. 

2 If prompted, log in to ClearQuest Designer.
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3 If the Open Schema wizard appears, make sure that the schema you want to 
upgrade is not checked out, and then click Cancel. If the schema is checked out, 
check it in or undo the check out. 

4 Click Package > Package Wizard.

You must complete Step 5 through Step 10 for each of the following packages: 

❑ Repository 1.0

❑ TeamTest 2.0

❑ RequisitePro 1.4

❑ RequisitePro Supplement 1.1

❑ Email 4.0

❑ PQC 1.0
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5 Compare the packages that you have with those that appear when you click More 
Packages. If any of the packages listed above do not appear in the list, click More 
Packages to add the missing packages to the list, and then click OK.

6 Select the package, and then click Next.

7 Select a TeamTest/TestStudio-based schema to which you want to apply the 
package, and then click Next.

8 Select the record types, for example Defect and Enhancement Request, that will be 
enabled by the schema and then click Finish. 

If you have renamed these record types, select the renamed record types instead. If 
you do not see any record types listed, simply click Finish to proceed.
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This opens a new revision of the schema with the package that you applied.

9 Click File > Check In.

Add your comments, and then click OK.

10 Click OK.

11 After you finish applying the last package, do the following:

a Click File > Open Schema and open the schema that you just upgraded using 
the Open Schema wizard.

b Enter a comment (optional).

c In the ClearQuest window, expand the Record Types folder, then the Defects 
folder, and finally the Forms folder.

Expand Record Types,
then Defects, then

Forms.
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d For each of the two forms—Defect-Base and Defect-Base Submit—complete 
Step i through Step iii.

i Double-click the form.

ii Select the drop-down list next to the Repository Project box, and then 
right-click Properties.

iii Select RA Project from the Field Name list, and then click OK.

Select
Repository

Project.
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e Change the label from Repository Project to RA Project and click OK.

12 Click Package > Package Wizard.

You must complete Step a through Step g for the Resolution Upgrade package. 

a Select the Resolution Upgrade 1.0 package, and then click Next.

If this package does not appear in the list, click More Packages to add the 
missing package to the list, and then click OK.

b Select a TeamTest/TestStudio-based schema to which you want to apply the 
package, and then click Next.

c Click Defect (or if you renamed the record type, click that record type), and then 
click Next. The Setup State Types page of the Package Wizard appears.

Change the label 
from Repository 
Project to RA 
Project.
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d Under the State Type column, choose Resolved in the row of the state that you 
want to set to resolved.

e Click Finish.

f Click File > Check In.

Add your comments, and then click OK.

g Click OK.

13 After checking in the last schema revision, back up your databases.

14 Do the following to upgrade your database:

a Click Database > Upgrade Database.

b Click Yes.

c Select the database to upgrade, and then click Next.

d Select the latest version, and click Finish.

15 Click File > Check In.

Add your comments, and then click OK.

16 Click OK.

17 Click File > Exit to close the ClearQuest Designer.
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Upgrading a Rational 7.x Repository to a Project

After you have upgraded your ClearQuest schema and database, you need to convert 
your repositories to Rational projects. Rational Administrator provides a wizard that 
creates one new Rational project in the directory you specify for each 7.x project in the 
source repository.

All repository global assets, such as users, groups, and computers, get copied into 
each new Rational project. In addition, the repository conversion process upgrades 
your RequisitePro projects to Rational Test version 2001.

Use the following procedure to upgrade test repositories from Rational Suite 1.0, 1.5, 
or 2000, or from any test products marked as 7.x, such as Rational Robot 7.x.

1 In the Administrator, select File > Convert Rational Repository into Rational 
Projects.

2 In the Repository Conversion - Login screen, enter the path of the repository you 
want to convert, as well as the user ID and the password. Click Next.

3 In the Destination screen, enter the path where the new Rational project will 
reside. Click Next. 

This directory becomes the root for all new projects. One new Rational project is 
created under this directory for each 7.x project in the source repository. All 
repository global assets, such as users, groups, and computers, get copied into 
each new Rational project.

4 In the Options screen, select one of the following options and click Next:

❑ Create a test case for each RequisitePro requirement that defines test criteria 
and is associated with a test script. 

❑ Create a test case for each test script associated with a test requirement that 
describes a feature of the application-under-test. This option is recommended if 
multiple test scripts are associated with the same requirement.

For more information about test cases, see the Using Rational TestManager manual or 
the Rational TestManager Help. 

5 In the Summary screen, review your settings and click Finish.

6 Optionally, review the RepositoryConvert.txt log file that is written to your temp 
directory.
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Rational Test Asset Conversion Information

All test assets that were stored in a 7.x repository project are now stored in a Test 
Datastore. Each Test Datastore is associated with a Rational project. Any 7.x test assets 
that were global to the repository are copied into each Test Datastore created for a 7.x 
repository project. Thus, test assets within a Test Datastore are not shared with any 
other Test Datastore.

Within a Test Datastore, the test assets are persisted as a collection of files. The 
properties and relationships of each test asset are stored within an XML file. These 
files are organized via the Test Datastore directory structure. Each Test Datastore also 
uses an MS Access database for caching some of the information in the XML files for 
use by reports and queries.

Note:  Users and Groups are stored in a separate datastore called a 
UserGroupTestDatastore. This datastore is created in a sub-directory of the Rational 
Administrator project.

Test cases are a new asset type. Test cases define the individual tests that are executed 
in order to validate test inputs such as RequisitePro requirements. In a 7.x repository 
project, scripts served this purpose as well as being the actual implementation of the 
test. In the new Rational Test, scripts are only used as implementations and do not 
play any role in test coverage. In order to facilitate this new model, the conversion 
program creates test cases based on the script/requirement relationships that exist in 
the 7.x repository project. 

The following table lists the data that is converted from a v. 7.x repository to a v. 2001 
project:

Types of 7.x Rational Test Assets Converted?

Scripts Yes (including VPs and Low-Level Scripts

Schedules Yes (now called Suites)

Sessions Yes

Users Yes

Groups Yes

Computers Yes

Datapools Yes

Data Types Yes

Performance Reports Yes
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The following table lists the new test asset types:

Listing Reports No

Logs No

Builds Yes

Test Documents No

Coverage Reports No

Queries No

Log Filters No

New Test Asset Types Description

Computer List A collection of Computer assets that can be referenced 
as the execution target for Suites, Test Cases and 
Scripts.

Test Plan A collection of Test Cases which define “what” needs to 
be tested for a particular feature or set of features.

Test Case A specific “test” that needs to be planned, designed, 
and executed in order to validate some aspect of the 
System Under Test (SUT).

Configured Test Case A specific “test” that needs to be run under a specific 
configuration (i.e. Operating System, etc.).

Listing Report (based on Crystal 
Reports)

A type of report that displays information about the test 
assets that are stored in the Test Datastore.

Test Case Analysis Report A type of report that displays information about Test 
Cases and Test Case Results store in the Test Datastore.

Iteration A specific period of time during a project, which is 
typically associated with some exit criteria and 
milestones.

Test Input Identifies some aspect of the SUT that needs to be 
verified by a Test Case. Types of Test Inputs include 
Requisite Pro requirements and Rose Model elements 
as well as others that are configured as part of the 
TestManager extensible Test Input mechanism.

Test Input Type Types of test inputs, such as RequisitePro requirements 
and Rose elements.
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Upgrading a RequisitePro Project

You may need to upgrade a RequisitePro project standalone. See Upgrading a 
RequisitePro Project on page 52 for information.

Rational Project Tasks

The following table provides an overview of the typical tasks that you perform to 
manage a Rational project.

Test Script Type Types of scripts, such as GUI, VU, Java, and VB.

Configuration Attribute A specific aspect of a configuration such as OS, OS 
Version, memory, etc.

Configuration A collection of Configuration Attributes which together 
describe some environment under which some set of 
Test Cases need to execute and pass.

Task Description See

Start the 
Administrator.

Starting and Exiting the Rational 
Administrator on page 11

Upgrading a 
Rational 7.x Test 
Repository

If you already have Rational Test 
7.x repositories you would like to 
use with the current version of 
Rational Administrator, you need 
to convert the repositories to 
projects.

Upgrading from Rational Test 7.x to 
2001 on page 12

Upgrading a 
RequisitePro 
project

You can upgrade a RequisitePro 
project by itself if for some reason it 
didn’t convert when you converted 
the repositories to projects. 

Upgrading a RequisitePro Project on 
page 52

Creating a 
RequisitePro 
project

You can create a RequisitePro 
project which you can associate 
with a Rational project.

Creating a RequisitePro Project on 
page 53
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Baselining 
RequisitePro 
projects with UCM

Rational RequisitePro project 
administrators can create baselines 
of RequisitePro projects by 
performing tasks in Rational 
Administrator and Rational 
ClearCase, implementing the 
Unified Change Management 
model.

Baselining RequisitePro Projects with 
UCM on page 54

Creating a 
RequisitePro 
project from a 
baseline

You can create a RequisitePro 
project based on the established 
baseline of an existing project and 
include the data from that baseline. 
If you have a Rational RequisitePro 
project that is baselined, you can 
use that baseline to create a new 
project in RequisitePro.

Creating a RequisitePro Project from a 
Baseline on page 55

Creating a Test 
datastore

You can create a test datastore in 
the Rational Administrator.

Creating a Test Datastore on page 47

Baselining Test 
datastores with 
UCM

Rational Test datastore 
administrators can create baselines 
of RequisitePro projects by 
performing tasks in Rational 
Administrator and Rational 
ClearCase, implementing the 
Unified Change Management 
model.

Baselining Test Datastores with UCM 
on page 47

Creating a Test 
datastore from a 
baseline

You can create a test datastore 
based on the established baseline of 
an existing test datastore and 
include the data from that baseline. 
If you have a Rational Test 
datastore that is baselined, you can 
use that baseline to create a new 
Test datastore.

Creating a Test Datastore from a 
Baseline on page 48

Configure 
ClearQuest or 
attach an already 
existing 
ClearQuest 
database to a 
Rational project.

To use ClearQuest to store defects, 
you must configure ClearQuest 
before you create a ClearQuest 
database or attach an already 
existing ClearQuest database to a 
Rational project. 

Configuring ClearQuest on page 27 
and Configuring a Rational Project on 
page 32

Register an 
existing Rational 
project.

If you have an existing Rational 
project, you can add it to the list of 
projects that appear in the main 
window of the Administrator. 

Registering a Rational Project on 
page 35

Task Description See
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The tasks in the following table are optional. 

Create and 
configure a 
Rational project.

You can create and configure a 
Rational project and associate a 
Rational Test datastore, a 
RequisitePro project, and a 
ClearQuest database with the 
Rational project, as well as existing 
Rose models.

Creating and Configuring a Rational 
Project on page 28

Connect to a 
Rational project.

You must connect to a Rational 
project before you can add a user or 
group or to view properties of 
datastores and databases associated 
with the project.

Connecting to a Rational Project on 
page 34

Add one or more 
test groups to 
a Rational Test 
datastore and 
assign privileges to 
a group.

Create a test group or groups with 
privileges for a Rational test 
datastore. When you add a user to a 
group, the user takes on the 
privileges of that group.

Rational Test Datastore Privileges on 
page 41

Add one or more 
test users to a 
Rational Test 
database.

You must add a test user to a 
Rational project before a user can 
use other Rational software. You 
must also make a user a member of 
a group to grant user privileges.

Managing Test Users on page 44 and 
Rational Test Datastore Privileges on 
page 41

Task Description See

Attach an existing 
ClearQuest 
database.

You can attach an existing 
ClearQuest database to a Rational 
project.

Adding a ClearQuest Database to a 
Rational Project on page 60

Start the 
Synchronizer.

You can ensure consistency of data 
across Rational Test, Rational 
RequisitePro, and Rational Rose 
products by using Synchronizer 
rules. 

Starting the Synchronizer on page 40

Note: The Rational Synchronizer is 
available only in Rational Suite 
products.

Task Description See
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Before Creating a Rational Project

Before working with a Rational application for the first time, you must create and 
connect to a Rational project. 

When you work with Rational projects, you can:

■ Create a Rational project that is under configuration management, taking 
advantage of ClearCase’s Unified Change Management (UCM) feature, an 
out-of-the-box process that supports best practices for change management as 
described in the Rational Unified Process.

■ Configure a Rational project that associates a Test datastore, a RequisitePro project, 
and a ClearQuest database.

■ Baseline Test datastores and RequisitePro projects with UCM.

■ Create Test datastores and RequisitePro projects from an existing baseline.

■ Create Test datastores and RequisitePro projects with no baseline and not under 
configuration management.

■ Delete a Rational project. To delete a project, you must have privileges. For more 
information, see Rational Test Datastore Privileges on page 41.

■ Connect or disconnect from a Rational project.

■ Register an existing Rational project so it appears in the current list of projects 
in the left pane of the main window.

■ Attach a ClearQuest database to a Rational project.

Before you create a Rational project, you must perform the following steps:

1 Decide whether to create the Rational project under configuration management. 
For information on the steps you need to take before creating a UCM-enabled 
project, see Setting Up ClearCase for UCM-Enabled Projects on page 29.

2 Decide what type of database to use. For information about database types, 
see Types of Rational ClearQuest Databases on page 8. For a summary of database 
types, see Determining a Database Type on page 9.

3 We recommend that you create a shared directory for each shared database or 
project. For more information, see Creating a Shared Directory on page 28.

4 Decide whether to bring a RequisitePro project and Test datastore under 
configuration management, and whether you want to use an existing baseline.
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5 If you use SQL Anywhere for a ClearQuest database, you must do the following 
before you create a Rational project:

a Install the Sybase SQL Anywhere software.

For information about installing Sybase SQL Anywhere software, see the 
installation guide for your Rational product. 

b Create a SQL Anywhere database server.

For information about creating a SQL Anywhere database server, 
see Creating a SQL Anywhere Database Server on page 65.

6 If your Rational software comes with ClearQuest, you must create a ClearQuest 
database to store defects for your testing efforts. If you use Oracle or Microsoft 
SQL Server for a ClearQuest database, do the following:

a Purchase, install, and configure Oracle or Microsoft SQL Server database 
software.

Note:  If you use either a Microsoft SQL Server database or an Oracle database 
with ClearQuest, you must install and configure the database specifically for 
ClearQuest or you will not be able to create a Rational project. For information 
about installing Oracle or Microsoft SQL Server for ClearQuest, see the 
Installing Rational ClearQuest manual. For information about configuring Oracle 
or Microsoft SQL Server for ClearQuest, see the Administering Rational 
ClearQuest manual. Both of these manuals are on the Rational documentation 
CD.

b Configure ClearQuest by creating a new schema project or by connecting to an 
existing schema project. For information, see the next section, Configuring 
ClearQuest.

Configuring ClearQuest 

Before you create a Rational project with a ClearQuest database, or attach an existing 
ClearQuest database to a Rational project, you must configure ClearQuest by creating 
a new schema project or by connecting to an existing schema project. You only need to 
do this once for all projects. If you attach an existing ClearQuest database to a Rational 
project that has an existing schema project, you do not have to create a new schema 
project. For more information about ClearQuest schemas, see About the Rational 
ClearQuest Database on page 7 and the ClearQuest Help.
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For information about attaching an existing ClearQuest database when you create a 
Rational project, see Configuring a Rational Project on page 32. For information about 
attaching an existing ClearQuest database to an existing Rational project, see Adding a 
ClearQuest Database to a Rational Project on page 60.

To configure ClearQuest: 

1 Click Tools > Rational ClearQuest Maintenance Tool. 

2 Follow the directions in the ClearQuest Setup Wizard to create a new schema 
project or to connect to an existing schema project.

3 Optionally, create a sample database. ClearQuest provides a sample database 
containing sample records that you can use to familiarize yourself with 
ClearQuest.

For more information about the ClearQuest Setup Wizard, click Help on the wizard. 
The wizard creates two default ClearQuest accounts. You need the user ID and 
password to log into ClearQuest. The user IDs and passwords are as follows:

■ Default administrator account – The user ID is admin, with no password.

■ Default user account – The user ID is user, and the password is password.

Creating a Shared Directory

To create a shared directory for a database or project:

1 Create a directory in the Windows Explorer.

2 Right-click the directory, and then click Sharing.

3 Click Shared As.

4 Type the name of the shared directory in the Share Name box.

5 Click OK.

Creating and Configuring a Rational Project

This section includes the following topics:

■ Setting up ClearCase for UCM-enabled projects

■ Creating a Rational project

■ Configuring a Rational project
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Setting Up ClearCase for UCM-Enabled Projects

Before you can create a Rational project that is associated with a UCM project (that is, 
UCM-enable the Rational project), use the following steps to perform the necessary 
setup in ClearCase.

Note:  Refer to the ClearCase Help for any specific ClearCase questions you may have. 
These instructions highlight only what you need to do as it relates to creating a 
UCM-enabled project in the Rational Administrator.

1 Create a project VOB, if necessary. You can skip this step if a project VOB has 
already been created.

a Click Start > Programs > ClearCase > ClearCase Home Base.

b In the VOBs tab, select Create VOB. The VOB Creation Wizard starts and opens 
the VOB Creation Wizard - Name and Major Parameters screen.

i To create a project VOB, select UCM project data.

ii To store regular files as well, select Create VOB as a UCM component.

Note:  You may want separate VOBs for teams, products, and so on.

iii Click Next to proceed.

c In the Storage screen, enter the VOB storage location and click Next.

d In the Options screen, specify the options desired and click Finish.

2 Create a UCM component(s) in which to store requirements and test assets, if the 
necessary component(s) do not already exist. A UCM component is a ClearCase 
object that you use to group a set of related directory and file elements within a 
UCM project. A project must contain at least one component, and can contain 
multiple components.

❑ If you selected the Create VOB as a UCM component check box on the VOB 
Creation Wizard - Name and Major Parameters screen, you have already 
created a UCM component.

❑ If you did not select the Create VOB as a UCM component check box on the VOB 
Creation Wizard - Name and Major Parameters screen, you need to migrate an 
existing ClearCase configuration to a UCM project. See Convert a VOB into a 
Component in the ClearCase Help for instructions on how to do this.

You use ClearCase Project Explorer to create a UCM component.

❑ To access ClearCase Project Explorer, either select Project Explorer on the 
Projects tab of ClearCase Home Base, or select Tools > Rational ClearCase 
Project Explorer in the Rational Administrator.
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3 Create a UCM project with a reference to a UCM component at a specific baseline. 
This step creates the integration stream for the UCM project.

a Access ClearCase Project Explorer, either by selecting Project Explorer on the 
Projects tab of ClearCase Home Base, or Tools > Rational ClearCase Project 
Explorer in the Rational Administrator.

b Select File > New > Project. The New Project Wizard opens.

c Enter the name of the project and a description on the first wizard screen. Click 
Next.

d In the second New Project Wizard screen, you can create a project from scratch 
or create a project based on an existing project's baselines. 

➑ To create an original project, click No.

➑ To create a new version of an existing project, click Yes, and then navigate to 
the existing project in the folder tree. 

Click Next to proceed.

e On the third New Project Wizard screen, you specify which baselines to include 
in the project. 

➑ If you clicked Yes on the previous New Project Wizard screen, the latest 
baselines of the existing project's components appear. To use these baselines 
in the new project, click Next.

➑ If you clicked No on the previous New Project Wizard screen, no baselines 
appear. Typically, you will want to add baselines in this step.

To add a baseline, click Add. The Add Baseline dialog box opens. Select a 
component in the Component list to see its baselines in the Baselines list. 
Select the baseline that you want to add and click OK. 

f On the fourth New Project Wizard screen, you indicate which project policies to 
enforce. You may want to accept the defaults. If not, see the ClearCase Help for 
further instructions. 

Click Next to proceed.

g On the fifth New Project Wizard screen, you indicate whether to configure the 
project to work with the ClearQuest integration. Enabling ClearQuest in a 
project ties in defect reporting and associates processes with activities. This 
means that, when a tester enters a defect, the configuration management 
system ships the defect back to the developer associated with the activity in 
question.
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➑ To enable the project to work with ClearQuest, click Yes, and select a user 
database from the list. 

➑ To set ClearQuest development policies, select the policy's check box. For 
details on setting up and using the UCM-ClearQuest integration, see the 
Managing Software Projects with ClearCase manual.

Click Finish. Review the properties of the project on the New Project 
Confirmation screen.

4 Create the shared integration view that will be used to access the requirements and 
test assets.

Note:  The instructions that follow are suggestions. Be sure to consult your 
ClearCase Administrator for the options you should select when you create a 
shared integration view. You can also find information in Administering ClearCase, 
which can be found on the Rational Solutions for Windows Online Documentation 
CD.

a Select the integration for a project in the left pane of the Exploring ClearCase 
Projects window.

b Select File > New > View. The View Creation Wizard opens.

c On the View Creation Wizard - Choose a Project screen, select Yes and select a 
project. 

d In the Create a Development Stream screen, click Next.

e In the Review Types of Views screen, choose either Dynamic or Snapshot, then 
click Next.

f On the next wizard screen:

➑ If you selected a dynamic view, name the integration view and select a 
drive.

➑ If you selected a snapshot view, enter the root directory for the view.

Click Finish, then confirm that you want ClearCase to create an integration 
view for you.
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Creating a Rational Project

1 Select File > New Project.

2 Enter the project name, the project location (or browse to it), and, optionally, select 
UCM enabled to place a project under configuration management in the New 
Project – General wizard screen. 

Note:  When you UCM-enable a project, you gain the ability to baseline test assets 
and requirements through the Rational Administrator. For further information 
about baselining, see Baselining Test Datastores with UCM on page 47.

If UCM is not enabled, skip to step 4.

3 If UCM is enabled, select the UCM policies that apply to the project on the Project 
UCM Policies wizard screen.

i Select Version Control Requirements Assets to bring the RequisitePro 
requirements assets under configuration management.

ii Select Version Control Test Assets to bring the Test datastore under 
configuration management.

iii Select the UCM project you want to associate with the Rational project.

4 Optionally, enter a password and confirm it on the Security wizard screen to 
associate a password with the project. If you do not want to associate a password 
with the project, click Next.

5 Read the summary of the project settings provided. If you want to configure the 
project now, select the option on the Summary wizard screen. 

6 Click Finish. Rational Administrator validates the project information and creates 
the project with an extension of .rsp. If you enabled the UCM option, the 
Administrator establishes an association between the Rational project and the 
UCM project.

If you selected the Configure Project Now option, the Configure Project dialog box 
opens.

Configuring a Rational Project

If a ClearQuest database has already been associated with the UCM project, you will 
not be able to select or create another ClearQuest database to associate with the 
Rational project. To create or change a ClearQuest database, you must create a new 
Rational project. The ClearQuest database is predetermined by any existing 
relationship with a UCM project.
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Any UCM project that is associated with the Rational project will be enabled for 
change request management if you select a ClearQuest database on the Configure 
Project dialog box.

1 Select File > Configure.

❑ If you selected the Configure Project Now option when creating the project, the 
Configure Project dialog box opens without your having to select File > 
Configure.

❑ If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 In the Configure Project dialog box, do the following according to your situation:

❑ If you do not have an existing RequisitePro project, Test datastore or 
ClearQuest database, use the Create buttons to create them and associate them 
with the Rational project. The Create buttons are visible only when a specific 
product datastore has not been associated with the Rational project. See 
Creating a Test Datastore on page 47 and Creating a RequisitePro Project on 
page 53.

Note:  To create a RequisitePro project and a test datastore from an existing 
baseline, see Creating a RequisitePro Project from a Baseline on page 55 and 
Creating a Test Datastore from a Baseline on page 48.

❑ If you do have an existing RequisitePro project, Test datastore, or ClearQuest 
database that you want to associate with the Rational project, use the Select 
button. The Select buttons are visible only when a specific product datastore, 
project, or database has not been associated with the Rational project.

❑ Use the Add button to associate existing Rose model files with the Rational 
project. You cannot create Rose model files from the Configure Project dialog 
box.

❑ If you have already associated a RequisitePro project or Test datastore with a 
Rational project that is UCM-enabled, but have not brought the project or 
datastore under configuration management, use the Add to CM button to add it 
to configuration management. The Add to CM buttons for RequisitePro projects 
and Test datastores are enabled only if the Rational project is UCM-enabled, 
and if the project or datastore is not currently under configuration 
management.
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❑ If the RequisitePro project or Test datastore is using configuration management, 
you will see the Check In All… button. Use the Check In All… button to add and 
check-in all assets, enabling the creation of a baseline in ClearCase. See 
Baselining Test Datastores with UCM on page 47 and Creating a RequisitePro 
Project from a Baseline on page 55.

❑ If you want to disassociate RequisitePro projects or Test datastores that are 
under configuration management, use the Remove from CM button. The 
Remove from CM buttons for RequisitePro projects and Test datastores are 
enabled only if the Rational project is UCM-enabled, and the project or 
datastore is currently under configuration management.

Note:  Removing a RequisitePro project or Test datastore from configuration 
management does the following:

➑ Copies all of the files in the project or datastore to a non-version-controlled 
area

➑ Associates the Rational project with the non-version-controlled area

3 When you are finished, click Close.

Managing a Rational Project

Managing a Rational project covers certain tasks you can do with an existing project, 
such as connecting, disconnecting, registering, unregistering, and deleting. You can 
also display and modify the project’s properties.

Connecting to a Rational Project

You must connect to a Rational project before you can configure or delete it. Also, 
once you have connected to a Rational project you can view the properties of the 
product datastores, projects, and databases.

1 Select File > Connect.

2 If there is more than one disconnected Rational project, select the project you want 
to connect to and click OK. 

Only those registered Rational projects that are not already connected are in the list 
of projects.

3 Optionally, enter the Rational project’s password and click OK.
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Disconnecting from a Rational Project

1 Select File > Disconnect.

2 Select the Rational project you want to disconnect from and click OK.

Note:  If only one project is connected, Rational Administrator will disconnect you 
from the project without a selection dialog box appearing.

Only those registered projects that are not already connected are in the list of 
projects.

Registering a Rational Project

Registering a Rational project makes it appear in the project hierarchy shown in the 
left pane. You register a project when a user on one computer wants to administer a 
Rational project that was created on a different computer.

1 Select File > Register Project.

2 Enter the path of the Rational project or browse to it and click Open.

If the project is already registered, it will not be registered again when you click 
Open.

Unregistering a Rational Project

Unregistering a Rational project makes it disappear from the project hierarchy shown 
in the left pane. 

1 Select File > Unregister Project.

2 Select the project you want to unregister and click OK. 

The Administrator removes the project from the project hierarchy.

If you select a project that is currently open, the Administrator closes the project 
before removing it from the project hierarchy.

You can also select Unregister from the Project context menu to unregister a Rational 
project.
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Displaying and Modifying the Properties of a Rational Project

You must connect to a Rational project before you can display its properties.

1 Select Edit > Properties.

The General tab displays the Rational project name, location, and UCM enabled 
status.

❑ UCM enabled can be turned on only if ClearCase 4.1 or greater is installed.

❑ UCM enabled cannot be turned off unless both the Test datastore and 
Requirements project are non-UCM enabled.

❑ The project location cannot be modified.

The Project UCM Policies tab allows you to specify the configuration management 
attributes.

❑ You cannot clear the check boxes if the Rational project was under 
configuration management before opening the Project Properties dialog box.

❑ The check boxes are enabled only if:

➑ The project was non-UCM enabled before opening the Project Properties 
dialog box, and

➑ The UCM enabled check box was selected after the Project Properties dialog 
box was displayed.

The Security tab allows you to modify the Rational project’s password.

2 View or modify the properties as desired.

Deleting a Rational Project

Deleting a Rational project does the following:

■ Unregisters the project

■ Removes the associations among the various projects, datastores, and databases

■ Permanently deletes the project

However, none of the associated product projects, datastores, and databases will be 
deleted when you delete the project.
36 Chapter 2 - Using the Rational Administrator



To delete a Rational project:

1 Select the project you want to delete in the project (left) pane.

2 Select File > Delete Project.

3 To delete the project, click OK.

The Administrator permanently deletes the project.

If you select a Rational project that is currently open, the Administrator closes the 
project before deleting it.

Starting Rational Products

You can access several Rational products from the Rational Administrator, as shown 
in the following figure:
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3Using the Rational 
Synchronizer
This chapter explains how to use the Rational Synchronizer in the Rational 
Administrator. It includes the following topics:

■ About the Rational Synchronizer on page 39

■ Starting the Synchronizer on page 40

■ Viewing and Editing Synchronizer Rules on page 40

About the Rational Synchronizer

The Rational Synchronizer helps maintain Rational project consistency, resulting in 
improved team communication. The Synchronizer works by creating and updating a 
Rational project’s related items based on the existence of other items in your project.

The Synchronizer works with the requirements (Rational RequisitePro), modeling 
(Rational Rose), and test domains.

Overview of Using the Synchronizer

The Synchronizer works by using rules to determine which changes are needed. 
Rational provides some sample rules to get you started. Your administrator or project 
leader analyzes your development environment to decide which rules to use, and 
whether to write new rules or to edit existing ones.

For example, every Rose actor has a corresponding Actor requirement in 
RequisitePro. The Synchronizer can enforce this constraint with a rule. When you run 
the Synchronizer it finds each requirement for which there is no actor. When you 
instruct the Synchronizer to proceed, it creates an actor for each requirement. As a 
result, new developments in the requirements domain are communicated accurately 
and promptly to the appropriate team.
39



Tasks Related to Using the Synchronizer

You need to do certain tasks in the Synchronizer. See the Rational Synchronizer 
chapter in Configuring Rational Suite for more information on the following tasks.

■ Administration for the Synchronizer

■ Importing Rules

■ Writing Synchronizer Rules

For More Information

See Configuring Rational Suite for information on how to administer the Synchronizer, 
including how to write and import rules. See the Synchronizer Help for instructions 
on how to use the Synchronizer, including what to do first in the Synchronizer.

Starting the Synchronizer

To start the Rational Synchronizer from the Rational Administrator, select Tools > 
Rational Synchronizer.

Viewing and Editing Synchronizer Rules

To view and edit Synchronizer rules in a project, you must first connect to the project 
using File > Connect. If needed, select the project to which you want to connect.

Once you connect to the project, to view and edit Synchronizer rules, right-click the 
Synchronizer Rules item in the left (project) pane and select Edit Rules.
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4Managing a Rational Test 
Datastore
This chapter explains how to manage a Rational Test datastore. It includes the 
following topics:

■ Rational Test Datastore Privileges on page 41

■ Managing Test Groups on page 42

■ Managing Test Users on page 44

■ Displaying the Properties of a Test Datastore on page 49

■ Adding a Test Datastore to a Project on page 50

■ Removing a Test Datastore from UCM on page 50

Rational Test Datastore Privileges

When you connect to a Rational project, you may be asked to enter a password if one 
has been assigned to the project on the Project Properties dialog box. You can assign a 
password to an existing project if you wish. See Displaying and Modifying the Properties 
of a Rational Project on page 36.

When you create a project, you can use the Administrator to create a Rational Test 
datastore. Doing so also creates a Test Users and Groups folder. The Users folder 
contains an admin test user. These default objects appear in the left pane of the main 
window.

You determine the security of a Rational Test datastore by assigning privileges to test 
users and test groups. Test groups allow you to set privileges for each test user. When 
you add a test user to a test group, the test user takes on the privileges of that test 
group. 

You can set the Rational Test datastore privileges for a test user to:

■ Create, modify, and delete test planning assets.

■ Create, modify, and delete test implementation assets.

■ Create, modify, and delete test execution assets.

■ Create, modify, and delete test results analysis assets.
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Managing Test Groups

Each project that you create comes with a default test user, admin. The admin test user 
is not a member of any specific test group and takes on all available privileges.

For example, as administrator of a test database, you can create a test group with 
privileges that allow the test group to create and modify test assets, builds, logs, and 
reports.

You can also make any group a default group and have multiple default groups. 
When you add a test user to a Rational Test datastore, and this option is set, the user 
automatically becomes a member of the default groups.

An admin test user can: 

■ Create, modify, and delete test assets.

■ Create, modify and delete reports, builds, and logs.

■ Customize test assets and builds.

There is no default password for the admin test user. You can log in as an admin test 
user, and you do not need a password. This lets you log into any Rational Test 
component after you first install the software.

Setting Up Security for the Admin Test User

When you connect to a project for the first time, you should define a password for the 
Admin test user to prevent unauthorized access.The Admin test user always has full 
test user access privileges and cannot be deleted from a project. For more information 
about modifying a password, see Changing a Password on page 46.

Adding a Test Group

Test groups allow you to set privileges for each test user.

Note:  You must connect to a project before you can add a test user or test group to a 
Rational Test datastore. For more information, see Connecting to a Rational Project on 
page 34.

To add a test group to a Rational Test datastore:

1 Click Insert > Test Group.

2 If you are connected to more than one project, a dialog box opens with a list of all 
connected project. Select the project to add a test group to, and click OK.

The Insert Group dialog box opens.
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3 Type an alphanumeric string of up to 40 characters for the name of the test group.

4 Type a description of the test group.

5 Optionally, click Set as default group to set a test group as a default group for all 
test users added. 

6 Optionally, click Select All to select all test group privileges. Alternatively, add and 
remove privileges from a group by selecting or clearing the appropriate check 
boxes. Click Clear All to clear all selected privileges.

❑ Write Privileges – Select the appropriate check boxes to give privileges to 
a group to create, modify, or delete test planning assets, test implementation 
assets, test execution assets, and test results analysis assets. 

❑ Administration Privileges – Select the appropriate check boxes to give privileges 
to a test group to customize test assets. Test assets include scripts and suites.

7 Click OK.

Modifying a Test Group

You must have privileges to modify a test group. For more information about 
privileges, see Rational Test Datastore Privileges on page 41.

To modify existing test group information:

1 Connect to the project that you want to modify. For more information about 
connecting to a project, see Connecting to a Rational Project on page 34.

2 If Groups is not visible in the left pane of the main window, double-click Rational 
Test Datastore.

3 If the test group that you want to modify is not visible, double-click Groups to 
display all groups.

4 Select the test group to modify.

5 Click Edit > Properties.

6 Change the test group information. 

7 Click OK to apply your changes.

Deleting a Test Group

When you delete a test group, you delete the group privileges for any test users in the 
deleted group. You do not delete any test users who are members of the deleted 
group. 
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You must have privileges to delete a test group from a Rational Test datastore. For 
more information about privileges, see Rational Test Datastore Privileges on page 41.

To delete a test group from a Rational Test datastore:

1 Connect to the project that you want to modify. For more information about 
connecting to a project, see Connecting to a Rational Project on page 34.

2 If Groups is not visible in the left pane of the main window, double-click Rational 
Test Datastore.

3 If the test group that you want to delete is not visible, double-click Groups to 
display all groups.

4 Select the test group to delete, and then click Edit > Delete. 

The Administrator prompts you to confirm the deletion.

5 Click Yes.

RequisitePro and ClearQuest Security

To set security privileges for a RequisitePro project or ClearQuest database, see the 
RequisitePro or ClearQuest Help.

Managing Test Users

Test users are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage scripts.

For each test user, you can specify a user ID, password, first name, last name, 
company, title, department, phone number, and e-mail address.

You can assign privileges to a test user by adding a user to a test group. When you 
add a test user to a test group, the test user takes all privileges of that test group. A 
test user can be a member of one or more test groups. The only privilege needed to 
modify or add test users of test groups is the Rational project password.

Adding a Test User
Note:  You must connect to a project before you can add a test user or test group to a 
Rational Test datastore. For more information, see Connecting to a Rational Project on 
page 34.
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To add a test user to a Rational Test datastore:

1 Click Insert > Test User.

2 If you are connected to more than one project, a dialog box opens with a list of all 
connected projects. Select the project to add a test user to, and click OK.

3 Type information about a test user in the General tab of the dialog box. 

4 Click the Groups tab to add or remove a test user from a test group.

5 In the Not A Member Of list, select one or more test groups to make the test user 
a member, and click > or >>.

6 Click OK.

For more information about test groups, see Rational Test Datastore Privileges on 
page 41.

Modifying a Test User 

You must have privileges to modify a test user in a Rational Test datastore. For more 
information about privileges, see Rational Test Datastore Privileges on page 41.

To modify existing test user information:

1 Connect to the project that you want to modify. For more information about 
connecting to a project, see Connecting to a Rational Project on page 34.

2 If Users is not visible in the left pane of the main window, double-click Rational 
Test Datastore.

3 If the test user that you want to modify is not visible, double-click Users to display 
all test users.

4 Select the test user to modify.

5 Click Edit > Properties.

6 Click the General tab and change the general information. 

7 Click the Groups tab and change the test groups information. 

8 Click OK to apply your changes.
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Deleting a Test User

You must have privileges to modify a test user in a Rational Test datastore. For more 
information about privileges, see Rational Test Datastore Privileges on page 41.

To delete a test user from a Rational Test datastore:

1 Connect to the project that you want to modify. For more information about 
connecting to a project, see Connecting to a Rational Project on page 34.

2 If  Users is not visible in the left pane of the main window, double-click Rational 
Test Datastore.

3 If the test user that you want to delete is not visible, double-click Users to display 
all test users.

4 Select the test user to delete.

Note:  You cannot delete the admin user.

5 Click Edit > Delete. 

The Administrator prompts you to confirm the deletion.

6 Click Yes.

Changing a Password

To change a password:

1 Double-click Rational Test Datastore in the left pane of the main window.

2 Double-click Users to display all test users.

3 Select the user name of the password that you want to change.

4 Click Edit > Properties, or right-click and then click Properties.

5 Click the General tab of the dialog box.

6 Select the original password (xxxxx) in the Password box, and then type a new 
password over it.

Type an alphanumeric string of up to 20 characters for the password. Passwords 
are case-sensitive. A test user with a defined password must type that password 
and user ID to log into the Rational software.

7 Click OK.
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Creating a Test Datastore

You can create a test datastore in the Rational Administrator by selecting the Create 
button in the Configure Project dialog box.

1 Open the Create Test Datastore dialog box by clicking the Create button to the right 
of the Test Assets field in the Configure Project dialog box.

2 Enter or browse to the path for the new test datastore.

3 Optionally, choose the initialization options you want:

❑ To initialize the test assets from an existing test datastore, select Initialize Assets 
from the following Test Datastore. Enter or browse to the path of the existing test 
datastore.

❑ To initialize the test users and groups in the new test datastore from an existing 
Rational project, select Initialize Test Users and Groups from the Rational Project. 
Enter or browse to the path of the existing Rational project.

4 Click OK to finish creating the test datastore.

Baselining Test Datastores with UCM

Rational test datastore administrators can create baselines of test datastores by 
performing tasks in Rational Administrator and Rational ClearCase, implementing 
the Unified Change Management model.

Note:  In order to baseline a test datastore, the test datastore must be associated with a 
UCM-enabled Rational project in Rational Administrator.

To baseline the test datastore:

1 Open the Rational Administrator.

2 Right-click on the Rational project and select Configure.

3 In the Configure Project dialog box, to the right of the Associated Test Datastore 
field, click the Check In All button.

4 Confirm your selection in the messages that follow, and enter an activity to 
describe the baseline in the Check in All dialog box.

5 After the Check In All operation is completed, click Close to exit the Configure 
Project dialog box.

6 Select Tools > Rational ClearCase Project Explorer.

The ClearCase Explorer appears.
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7 Right-click on the test assets integration stream and select Make Baseline from the 
shortcut menu.

8 Enter a baseline title, select the baseline type, select a view context, and click OK.

Creating a Test Datastore from a Baseline

You may want to create a test datastore based on the established baseline of an 
existing test datastore and include the data from that baseline. If you have a Rational 
test datastore that is baselined, you can use that baseline to create a new test datastore. 
The following tasks are performed by test datastore administrators in Rational 
Administrator and Rational ClearCase, implementing the Unified Change 
Management model.

Note:  Test datastore administrators can also create baselines of test datastores if the 
test datastore is associated with a UCM-enabled Rational project in Rational 
Administrator. See Baselining projects with UCM for more information.

Creating a test datastore from a baseline requires the following tasks:

■ Create a UCM project

■ Create a Rational project

Create a UCM Project

See Setting Up ClearCase for UCM-Enabled Projects on page 29 and the Rational 
ClearCase Help for more information.

1 Create a UCM project.

2 Add a UCM component to the project that already contains a test datastore at a 
recommended baseline.

3 Set the recommended baseline for the new UCM project (by default the baseline 
specified in step 2 will be selected).

4 Create an integration view for the new UCM project.
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Create a Rational Project

See Creating and Configuring a Rational Project on page 28 for more information.

1 From Rational Administrator, click File > New Project. The New Project wizard 
opens.

2 Enter requested information in the wizard, select UCM enabled, and select Version 
Control Test Assets.

When you complete the wizard, the Configure Project dialog box opens.

3 Click the Select button to choose Test Assets.

4 Browse to the UCM view and select the test datastore path for the baselined test 
datastore.

5 Optionally, to initialize the test users and groups in the new test datastore from an 
existing Rational project, select Initialize Test Users and Groups from the Rational 
Project. Enter or browse to the path of the existing Rational project.

6 Click OK in the Configure Project dialog box.

The new test datastore contains the data and structure from the selected baselined 
datastore.

Note:  The new test datastore has the same name as the baselined test datastore.

Displaying the Properties of a Test Datastore

To see the properties of the test datastore in a project, you must first connect to the 
project using File > Connect. If needed, select the project to which you want to 
connect. You cannot change any of the properties.

To display the properties of the Test datastore:

1 Select the Test datastore in the left (project) pane.

2 Select Edit > Properties.

3 Select Close to close the dialog box.
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Adding a Test Datastore to a Project

1 Select File > Configure. 

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to associate the Test datastore with the 
Rational project. 

❑ Use the Create button to create a Test datastore and associate it with the 
Rational project. The Create button is visible only when a Test datastore has not 
been associated with the Rational project.

❑ Use the Select button to select an existing Test datastore and associate it with 
the Rational project. The Select button is visible only when a Test datastore has 
not been associated with the Rational project.

❑ Use the Add to CM button to add the Test datastore to configuration 
management. The Add to CM button is enabled only if the Rational project is 
UCM-enabled, and if the datastore is not currently under configuration 
management.

3 When you are finished, click Close.

Removing a Test Datastore from UCM

1 Select File > Configure.

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to remove the Test datastore from 
configuration management. 

Use the Remove from CM button to remove a Test datastore from configuration 
management. The Remove from CM button is enabled only if the Rational project is 
UCM-enabled, and the datastore is currently under configuration management.

3 When you are finished, click Close.
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5Managing a RequisitePro 
Project
This chapter explains how to manage a RequisitePro project in the Rational 
Administrator. It includes the following topics:

■ About RequisitePro on page 51

■ Upgrading a RequisitePro Project on page 52

■ Creating a RequisitePro Project on page 53

■ Baselining RequisitePro Projects with UCM on page 54

■ Creating a RequisitePro Project from a Baseline on page 55

■ Displaying the Properties of a RequisitePro Project on page 56

■ Adding a RequisitePro Project to a Rational Project on page 56

■ Removing a RequisitePro Project from UCM on page 57

About RequisitePro

Requirements management is the process of identifying, organizing, and 
documenting the changing requirements of a project. A requirement is one criterion 
for your project’s success. Your project’s requirements answer questions such as 
“What do customers want?” and “What new features must we absolutely ship in the 
next version?” Most project teams work with requirements. On smaller, less formal 
projects, requirements might be kept in text files or e-mail messages. Other projects 
may use more formal ways of recording and maintaining requirements.

RequisitePro is unique because it integrates a familiar environment, Microsoft Word, 
and a database to provide a powerful, yet easy-to-use framework for managing your 
requirements. You itemize requirements within requirements documents, and then 
manage them using an integrated database. Your teams can collaborate, 
communicate, and provide updates on the same project. 
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When you manage requirements, you can understand how changed requirements 
affect your project. You can effectively communicate requirements to all team 
members and to stake holders. Effective requirements management helps your 
organization ensure that its products meet their stated goals.

See About the Rational RequisitePro Project on page 10 for a high-level overview of 
RequisitePro. See your RequisitePro documentation for information on how to set up 
the RequisitePro project. 

Upgrading a RequisitePro Project

Normally, when you upgrade a Rational 7.x repository to a project, your RequisitePro 
project is upgraded automatically. (For details, see Upgrading from Rational Test 7.x to 
2001 on page 12). 

If for any reason your RequisitePro project does not get converted, you can upgrade it 
using the following procedure. Before you start, you must first connect to the Rational 
project associated with the RequisitePro project that needs to be upgraded. 

Note:  At any time while using the wizard, click Help to see the RequisitePro Help.

1 If you are not already connected to the Rational project associated with the 
RequisitePro project that needs to be upgraded, do so by selecting File > Connect, 
then selecting the Rational project you want from the selection dialog box.

2 Select File > Upgrade RequisitePro Project. 

3 Select the RequisitePro project you want to upgrade and click OK. The 
RequisitePro Project Upgrade Wizard opens.

4 In the Introduction screen, click Next to proceed after you have backed up your 
database.

5 In the Select Project screen, enter or browse to the RequisitePro project you want to 
upgrade and click Next.

6 In the Project Administrator Identification screen, if your RequisitePro project has 
security enabled, enter your Rational RequisitePro User ID and Password and click 
Next.

7 In the DBA Identification screen, if there are multiple projects in an enterprise 
database, enter the User ID and Password used to create the enterprise database 
and click Next.
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8 In the Affected Projects screen, the Affected Projects list contains the project names 
and descriptions of all RequisitePro projects in the database affected by the 
upgrade. Be sure you really want to convert all the projects listed before you click 
Next to continue.

9 In the Confirm screen, click Finish to begin the upgrade process.

10 In the Upgrading screen, click Exit to close the wizard when the database upgrade 
finishes.

Creating a RequisitePro Project

You can create a project in Rational RequisitePro by selecting the Create button in the 
Configure Project dialog box.

RequisitePro projects are created from templates. By clicking on the Create button, the 
document and requirement types, attributes, and security information of the selected 
project are copied to the new project. If want to copy all the data from another project, 
in addition to copying the structure, see Creating a RequisitePro Project from a Baseline 
on page 55.

1 Open the Create RequisitePro Project dialog box by clicking the Create button to 
the right of the Requirement Assets field in the Configure Project dialog box.

2 Select one of the following Project Templates:

❑ Select the Blank template, and individually set all the parameters for the 
project.

❑ Select Make New Template to create a template from an existing project, using 
the New Template Wizard.

❑ Select one of the default templates provided with RequisitePro.

3 Click the Create button once you select a template.

Note:  A description of each template appears in the text box at the bottom of the 
dialog box. Click the Details/No Details button to toggle the display of the template 
description box.

4 Enter information about the new project in the dialog boxes that follow. Click Help 
to refer to the RequisitePro Help for assistance in creating the new RequisitePro 
project.
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Baselining RequisitePro Projects with UCM

Rational RequisitePro project administrators can create baselines of RequisitePro 
projects by performing tasks in Rational Administrator and Rational ClearCase, 
implementing the Unified Change Management model.

For archiving projects that do not use the UCM model, refer to Archiving Projects 
with ClearCase in the RequisitePro Help.

Note:  When creating a project from a baseline, the newly created project does not 
maintain the cross-project traceability links from the original baselined project.

In order to baseline a RequisitePro project, you must have the following:

■ The RequisitePro project must be associated with a UCM-enabled Rational project 
in Rational Administrator.

■ The RequisitePro project must be closed, and all users must have exited the 
program.

To baseline the RequisitePro project:

1 Open the Rational Administrator.

2 Right-click on the Rational project and select Configure.

3 In the Configure Project dialog box, to the right of the Associated RequisitePro 
Project field, click the Check In All button.

4 Confirm your selection at the messages that follow, and enter an activity to 
describe the baseline in the Check in All dialog box.

5 After the Check In All operation is completed, click Close to exit the Configure 
Project dialog box.

6 Select Tools > Rational ClearCase Project Explorer.

The ClearCase Explorer appears.

7 Right-click on the RequisitePro Requirements Assets integration stream and select 
Make Baseline from the shortcut menu.

8 Enter a baseline title, select Full for the baseline type, select a view context, and 
click OK.
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Creating a RequisitePro Project from a Baseline

You may want to create a project based on the established baseline of an existing 
project and include the data from that baseline. If you have a Rational RequisitePro 
project that is baselined, you can use that baseline to create a new project in 
RequisitePro. The following tasks are performed by RequisitePro project 
administrators in Rational Administrator and Rational ClearCase, implementing the 
Unified Change Management model.

Note:  RequisitePro project administrators can also create baselines of RequisitePro 
projects if the RequisitePro project is associated with a UCM-enabled Rational project 
in Rational Administrator. See Baselining projects with UCM for more information.

Creating a project from a baseline requires the following tasks:

■ Creating a UCM project

■ Creating a Rational project

Creating a UCM Project

See Setting Up ClearCase for UCM-Enabled Projects on page 29 and the Rational 
ClearCase Help for more information.

1 Create a UCM project.

2 Add a UCM component to the project that already contains a versioned 
RequisitePro project at a recommended baseline.

3 Set the recommended baseline for the new UCM project (by default the baseline 
specified in step 2 will be selected).

4 Create an integration view for the new UCM project.

Creating a Rational Project

See Creating and Configuring a Rational Project on page 28 for more information.

1 From Rational Administrator, click File > New Project. The New Project wizard 
opens.

2 Enter requested information in the wizard, select UCM enabled, and select Version 
Control Requirement Assets.

When you complete the wizard, the Configure Project dialog box opens.

3 Click the Select button to choose Requirement Assets.
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4 Browse to the UCM view and select the .rqs file for the baselined RequisitePro 
project.

5 Click OK in the Configure Project dialog box.

The new RequisitePro project contains the data and structure from the selected 
baselined project.

Note:  The new project has the same name as the baselined project. You can remove 
the old baselined project from the RequisitePro list of projects in the Open Project and 
Documents dialog box.

Displaying the Properties of a RequisitePro Project

To see the properties of the RequisitePro project, you must first connect to the Rational 
project using File > Connect. If needed, select the project to which you want to 
connect.

To display the properties of the RequisitePro project:

1 Select the RequisitePro project in the left (project) pane.

2 Select Edit > Properties.

3 Select the Properties button to the right of the Database text box to see the database 
properties.

Adding a RequisitePro Project to a Rational Project

1 Select File > Configure Project.

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to associate the RequisitePro project with the 
Rational project. 

❑ Use the Create button to create a RequisitePro project and associate it with the 
Rational project. The Create button is visible only when a RequisitePro project 
has not been associated with the Rational project.

❑ Use the Select button to select an existing RequisitePro project and associate it 
with the Rational project. The Select button is visible only when a RequisitePro 
project has not been associated with the Rational project.
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❑ Use the Add to CM button to add the RequisitePro project to configuration 
management. The Add to CM button is enabled only if the Rational project is 
UCM-enabled, and if the project is not currently under configuration 
management.

3 When you are finished, click Close.

Removing a RequisitePro Project from UCM

1 Select File > Configure.

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to remove the RequisitePro project from 
configuration management. 

Use the Remove from CM button to remove a RequisitePro project from 
configuration management. The Remove from CM button is enabled only if the 
Rational project is UCM-enabled, and the RequisitePro project is currently under 
configuration management.

3 When you are finished, click Close.
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6Managing a ClearQuest 
Database
This chapter explains how to manage a ClearQuest database in the Rational 
Administrator. It includes the following topics:

■ About ClearQuest on page 59

■ Displaying the Properties of a ClearQuest Database on page 59

■ Adding a ClearQuest Database to a Rational Project on page 60

■ Removing a ClearQuest Database from a Rational Project on page 60

About ClearQuest

ClearQuest is a change request management tool that helps you track and manage all 
the change activities (such as defects and enhancement requests) associated with a 
Rational project. ClearQuest stores its information in a database, and comes with a 
ready-to-use database schema (the fields in the database). ClearQuest is easy to 
change; an administrator can customize and define queries, fields, activities, and 
states specific to your development process.

See About the Rational ClearQuest Database on page 7 for a high-level overview of 
ClearQuest. See your ClearQuest documentation for information on how to set up the 
ClearQuest database. 

Displaying the Properties of a ClearQuest Database

To see the properties of the ClearQuest database in a Rational project, you must first 
connect to the project using File > Connect. If needed, select the Rational project to 
which you want to connect.

To display the properties of the ClearQuest database:

1 Select the ClearQuest Database in the left (project) pane.

2 Select Edit > Properties.
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Adding a ClearQuest Database to a Rational Project

Any UCM project that is associated with the Rational project will be enabled for 
change request management if you select a ClearQuest database on the Configure 
Project dialog box.

1 Select File > Configure.

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the ClearQuest database with the 
Rational project. 

❑ Use the Create button to create a ClearQuest database and associate it with the 
Rational project. The Create button is visible only when a ClearQuest database 
has not been associated with the Rational project.

❑ Use the Select button to select an existing ClearQuest database and associate it 
with the Rational project. The Select button is visible only when a ClearQuest 
database has not been associated with the Rational project.

3 When you are finished, click Close.

Note:  If a ClearQuest database has already been associated with the Rational project, 
you will not be able to select or create another ClearQuest database to associate with 
the project. To create or change a ClearQuest database, you must create a new 
Rational project. The ClearQuest database is predetermined by any existing 
relationship with a UCM project.

Removing a ClearQuest Database from a Rational Project

If a ClearQuest database has already been associated with the Rational project, you 
will not be able to remove it. To create a Rational project without a ClearQuest 
database, you must create a new project. 
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7Managing Rose Models
This chapter explains how to manage a Rose model file in the Rational Administrator. 
It includes the following topics:

■ About Rational Rose on page 61

■ Adding a Rational Rose Model to a Rational Project on page 61

■ Removing a Rational Rose Model from a Rational Project on page 62

About Rational Rose

Rational Rose is a visual modeling tool for developers. Visual modeling helps you 
manage software complexity. At its simplest, visual modeling means creating a 
graphical blueprint of your system’s architecture. From this visual representation of 
your architecture, you can quickly detect problems such as inconsistencies and lack of 
modularity.

Adding a Rational Rose Model to a Rational Project

1 Select File > Configure.

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the Rose model with the Rational 
project. 

Use the Add button to associate a Rose model with the Rational project.

3 When you are finished, click Close.
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Removing a Rational Rose Model from a Rational Project

1 Select File > Configure.

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the Rose model file with the 
Rational project. 

Use the Remove button to disassociate a Rose model file from the Rational project.

3 When you are finished, click Close.
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8Managing a SQL 
Anywhere Database 
Server
This chapter explains how to configure and manage a SQL Anywhere database server. 
It includes the following topics:

■ Network Server Requirements on page 64

■ Server Terminology on page 64

■ Creating a SQL Anywhere Database Server on page 65

■ Changing a SQL Anywhere Database Server Configuration on page 70 

■ Starting a SQL Anywhere Database Server on page 71

■ Stopping a SQL Anywhere Database Server on page 72

■ Deleting a SQL Anywhere Database Server on page 73

■ Using the Sybase Central Database Management Tool on page 73 

■ Using the Sybase ISQL Utility on page 73

■ Using the SQL Anywhere Service Manager on page 73
63



Network Server Requirements

If you use Sybase SQL Anywhere software for your database, make sure that your 
network server meets the following minimum hardware and software requirements:

Note:  Novell NetWare is no longer supported for network servers.

Server Terminology

The following table lists some terms that apply to a SQL Anywhere database server:

Name of Requirement Minimum

Operating System Windows NT 4.0 Server or Workstation 4.0

Processor Pentium

Memory 64 MB

Disk space 100 MB

Network protocol TCP/IP

Microsoft service pack 5

Term Definition

server The computer with Sybase SQL Anywhere Server software 
installed on it

service Starts the SQL Anywhere database server

SQL Anywhere database server A service that manages database requests for one or more 
repositories
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Creating a SQL Anywhere Database Server

To create a SQL Anywhere database server, perform the following tasks:

1 Install the Sybase SQL Anywhere Server software before you create a 
SQL Anywhere database server. 

For information about installing the SQL Anywhere Server software, see the 
installation guide for your product.

2 Choose a user account to run the SQL Anywhere database server and set 
privileges for that account. 

For information about setting privileges, see the next section, Setting Privileges.

3 Create a SQL Anywhere database server. 

For information about creating a SQL Anywhere database server, see How to Create 
a SQL Anywhere Database Server on page 68.
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Setting Privileges

To set privileges for a user account running a SQL Anywhere database server:

1 Do one of the following:

2 Do one of the following:

If a computer is running Then

Windows 2000 Server a Click Start > Programs > Administrative Tools > 
Local Security Policy.

b Click Local Policies, and then double-click User 
Rights Assignment.

Windows 2000 Professional a Click Start > Settings > Control Panel.

b Click Administrative Tools.

c Click Local Security Policy.

NT Server a Click Start > Programs > Administrative Tools 
(Common) > User Manager for Domains.

b Click User > Select Domain and type the local 
machine in the Domain box, and then click OK.

c Click Policies > User Rights.

d Click Show Advanced User Rights.

NT Workstation a Click Start > Programs > Administrative Tools 
(Common) > User Manager.

b Click Policies > User Rights.

c Click Show Advanced User Rights.

If a computer is running Then

Windows 2000 a Click Start > Settings > Control Panel.

b Click Administrative Tools.

c Click Local Security Policy.
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3 Click Add.

4 Click the domain of the account running the SQL Anywhere database server from 
the List Names From list.

5 Click Show Users. 

Windows NT a Click Access this computer from network in the 
Right list and complete steps 3–8.

b Click Log on as a service in the Right list and 
complete steps 3–8.

c Click Log on locally in the Right list and complete 
steps 3–8.

If a computer is running Then
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6 Click the account running the SQL Anywhere database server from the Names list.

7 Click Add, and then click OK.

8 Go back to steps 2b and 2c to set all privileges.

9 Click OK.

10 Click User > Exit. 

How to Create a SQL Anywhere Database Server

To create a SQL Anywhere database server:

1 Click Start > Programs > Rational product name > Rational Administrator.

2 Click File > New SQL Anywhere Database Server.

3 Type an alphanumeric string of up to 30 characters that uniquely identifies this 
database server on the network, and then click Next. 

4 Type the amount of space for caching data for the SQL Anywhere database server, 
and then click Next.  We recommend 2048K for each Rational repository on the 
server.

5 Select one or more protocols to communicate with the SQL Anywhere database 
server, and then click Next.

Note:  To reduce connection time, check only those protocols that are actually used on 
your network.

6 Choose the Startup options, as described in the following step:
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a Click one of the following buttons to set the NT Service Startup options. These 
options start the SQL Anywhere database server when you turn on your 
system.

➑ Click Automatic to start the NT Service that starts the SQL Anywhere 
database server when you start your system.

➑ Click Manual to not start the NT Service that starts the SQL Anywhere 
database server when you start your system.

b Select or clear the Start service immediately check box. This option starts the 
SQL Anywhere database server immediately after you create it. If the box is 
cleared, you must start the server manually. 

7 Among the Account options, click one of the following buttons:

❑ Click System Account (LocalSystem) to run the service under a local account.

Note:  If you choose System Account (LocalSystem), you will not be able to 
remotely configure a ClearQuest database using UNC.

❑ Click Other Account to allow users access to a shared ClearQuest database or 
shared repository. We recommend that you choose this option because it allows 
users the most flexibility for accessing a database or repository.

i Type a domain and user account name in the Other Account box.

The user account name is case-sensitive. This user account must have the 
appropriate privileges to access a shared database or repository. For 
information about setting privileges, see Setting Privileges on page 66.

ii Enter and re-enter the password for the account. 

The password is case-sensitive.

8 Among the Account options, click Display database monitor to display the SQL 
Anywhere database monitor when the SQL Anywhere database server starts. 

Note:  This option is not available when you click Other Account. 

9 Click Next.

A summary appears that confirms your choices.

10 Click Finish.
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Changing a SQL Anywhere Database Server Configuration

To change the configuration of a SQL Anywhere database server:

1 Click Start > Programs > Rational product name > Rational Administrator.

2 In the left pane, right-click a server under SQL Anywhere Database Servers, and 
then select Edit > Properties.

3 Optionally, click the Basic tab and change any of the options. 
70 Chapter 8 - Managing a SQL Anywhere Database Server



4 Optionally, click the Advanced tab and change any of the advanced settings. 

Note:  The advanced settings are intended for use by, or in close cooperation with, 
Rational Technical Support. In most cases, these settings do not need modification.

5 Click OK.

Starting a SQL Anywhere Database Server

The Rational Administrator generates a startup command that can help you start a 
SQL Anywhere database server. The Administrator lets you manually start a SQL 
Anywhere database server on a Windows NT workstation or a Windows NT server.

To start a SQL Anywhere database server:

1 Click File > Start SQL Anywhere Database Server. 

If you created more than one database server, a dialog box appears with a list of all 
database servers. 

2 Select the SQL Anywhere database server that you want to start, and then 
click OK.
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SQL Anywhere Server Startup Switches

The basic startup command syntax is:

DBSRV50 -n ServerName -c CacheMemory -x Protocols 
drive:\database\DB\RAS.DB -n Databasename

For example:

DBSRV50 c:\SQLDIR\DB\RAS.DB -n Proj1DB

or for a shared directory:

DBSRV50 \\KRANTI\SQLDIR\DB\RAS.DB -n Proj1DB

The default SQL Anywhere startup switches are:

Table 1 SQL Anywhere Server Startup Switches

For complete descriptions of all SQL Anywhere switches and components, 
see the SQL Anywhere Help.

Stopping a SQL Anywhere Database Server

To stop a SQL Anywhere database server:

1 Click File > Stop SQL Anywhere Database Server. 

If you have more than one database server running, a dialog box appears with a 
list of the running database servers. 

2 Select the SQL Anywhere database server that you want to stop, and then 
click OK.

SQL Anywhere Startup 
Switches

Description

DBSRV50 The SQL Anywhere server executable.

-n ServerName The SQL Anywhere server name.

-c CacheMemory The amount of cache memory. (We recommend using the 
default cache memory which is set to 2048K for each 
repository.)

-x Protocols A comma-separated list of protocols.

drive:\Database or 

\\machinename\shared\

The drive and location of the repository directory. 
We recommend that you use the Universal Naming 
Convention (UNC) here. (The \DB\RAS.DB path 
is required.)
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Deleting a SQL Anywhere Database Server

You must have privileges to delete a SQL Anywhere database server. For more 
information about privileges, see Rational Test Datastore Privileges on page 41.

To delete a SQL Anywhere database server:

1 Select the server to delete from the list of SQL Anywhere Database Servers 
in the left pane of the main window.

2 Click Edit > Delete. 

The Administrator prompts you to confirm the deletion.

3 Click Yes to delete the server.

Using the Sybase Central Database Management Tool

You can start the Sybase Central database management tool from the Administrator. 
This tool exposes SQL Anywhere database server settings, properties, and utilities 
in a graphical user interface. For more information about using the Sybase Central 
database management tool, see the SQL Anywhere Help.
To start the Sybase Central database management tool from the Administrator:

■ Click Tools > Sybase Central.

Using the Sybase ISQL Utility

The Sybase ISQL provides you with an interactive environment for database 
browsing and for sending SQL statements to a particular SQL Anywhere database 
server. For more information, see the SQL Anywhere Help.
To start the Sybase ISQL utility from the Rational Administrator:

■ Click Tools > ISQL.

Using the SQL Anywhere Service Manager

The SQL Anywhere Service Manager lets you start, stop, or pause a SQL Anywhere 
Server service. You can also edit the configuration parameters of each service. For 
more information, see the SQL Anywhere Help.

To start the SQL Anywhere Service Manager from the Rational Administrator:

■ Click Tools > SQL Anywhere Service Manager.
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