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Preface
This manual describes how to use the Rational Administrator to configure Rational 
projects. A Rational project stores software testing and development information for 
your Rational Test datastores, RequisitePro projects, and ClearQuest databases.

Audience

This manual is intended for Rational system administrators, application developers, 
quality assurance managers, and quality assurance engineers.

Other Resources

■ All manuals are available online, either in HTML or PDF format. The online 
manuals are on the Rational Solutions for Windows Online Documentation CD. 

■ To send feedback about documentation for Rational products, please send e-mail 
to techpubs@rational.com.

■ For more information about Rational Software technical publications, see: 
http://www.rational.com/documentation. 

■ For more information on training opportunities, see the Rational University Web 
site: http://www.rational.com/university.

■ For articles, discussion forums, and Web-based training courses on developing 
software with Rational Suite products, join the Rational Developer Network by 
selecting Start > Rational Suite > Logon to the Rational Developer Network .
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Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Technical Support as follows:

Note:  When you contact Rational Technical Support, please be prepared to supply the 
following information:

■ Your name, company name, telephone number, and e-mail address

■ Your operating system, version number, and any service packs or patches you 
have applied

■ Product name and release number

■ Your case ID number (if you are following up on a previously reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4545-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
Contacting Rational Technical Support xi



xii Chapter  - Preface



1Introducing the Rational 
Administrator
This chapter provides a brief overview of the Rational Administrator. 

With the Rational Administrator, you can:

■ Create a Rational project, which enables integrations among Rational Suite tools

■ Incorporate Unified Change Management (UCM) into your project

■ Administer SQL Anywhere databases for use with Rational ClearQuest or Rational 
Project Console

Overview of the Rational Administrator

Rational Suite unifies your software development team with tools tailored to each 
software development role within the Rational Unified Process. However, without 
central control and management of the resources involved, a team’s potential for 
success can be significantly reduced.

The Rational Administrator enables integration among the Rational Suite tools by 
offering a central point of control through the creation and management of Rational 
projects and their associated artifacts. An artifact is a piece of information that is 
produced, modified, or used by the software development process, such as a visual 
model, source code, or a requirement. The Rational project provides the framework 
that links these artifacts together for more effective use by the team.

Let’s look at some of the components of a Rational project.

What Is a Rational Project?

A Rational project stores software testing and development information for many 
Rational Suite tools. Most of the Rational software on your computer updates and 
retrieves data from the same Rational project. 

A Rational project creates links among one or more of the following artifacts:

■ Rational Test datastore – Stores application testing information such as test assets, 
logs, reports, and builds. 
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■ Rational RequisitePro project – Stores requirements documents and a 
dynamically-linked database. 

■ Rational ClearQuest database – Stores change-request information for software 
development, including enhancement requests, defect reports, and documentation 
modifications. Each ClearQuest database consists of one schema and one or more 
user database. In ClearQuest, the term schema refers to all attributes associated 
with a database. This includes field definitions, field behaviors, the state transition 
table, actions, and forms. 

■ Rational Rose models – Stores visual models for business processes, software 
components, classes and objects, and distribution and deployment processes. 

Benefits of the Rational Project

When you create a Rational project, you can associate various Rational product 
datastores, databases, and projects that are used for storing software development 
and testing information. 

After you associate these items with a Rational project, you can link specific data from 
one item to another by using individual product features or by using the Rational 
Synchronizer. 

The following table provides examples of how you can benefit from associating items 
in a Rational project as you design, develop, and test software applications.

When you associate Then you can

A RequisitePro project with a 
Rose model

Use the Integrated Use Case Management feature to 
manage use cases between Rose and RequisitePro. In 
addition, you can use the Rational Synchronizer to associate 
other artifacts (for example Rose Actors to RequisitePro 
Actor Requirements and vice versa) in your project. Read 
more about the Synchronizer in Configuring Rational Suite.

A RequisitePro project with a 
Rational Test datastore 

Create a product or software requirement using 
RequisitePro and associate that requirement with a test case 
in Rational TestManager.

Associate a test case in TestManager with a requirement in 
RequisitePro.

A ClearQuest database with a 
Rational Test datastore

Generate a defect using Rational TestManager, and 
automatically store the defect in the correct Rational project 
in a ClearQuest database.
14 Chapter 1 - Introducing the Rational Administrator



The Rational Administrator and The Rational Project

The Rational Administrator centralizes the management of a Rational project, 
managing the association of Rational product information. In addition, it administers 
and manages users and groups for Rational Test.

With the Rational Administrator, you can: 

■ Create a Rational project under Unified Change Management (UCM), Rational 
Software’s best practices process for managing change during the software 
development lifecycle.

■ Create a Rational project without using UCM.

■ Connect to a Rational project.

■ Work with Rational projects on the network and not on your computer (register a 
project).

■ Delete a Rational project.

■ Configure a SQL Anywhere database server.

■ Create and manage users and groups for a Rational Test datastore.

■ Create and manage Rational projects containing RequisitePro projects and Rose 
models.

■ Manage security privileges for a Rational Test datastore.

■ Synchronize data among Rational RequisitePro projects, and Rational Rose using 
the Rational Synchronizer.

What Is UCM?

Unified Change Management (UCM) is Rational Software’s approach to managing 
change in software system development from requirements to release. UCM spans the 
development lifecycle, defining how to manage change to requirements, design 
models, documentation, components, test cases, and source code.

UCM is unique because it links activities used to plan and track project progress with 
the artifacts that are undergoing change. An activity might arise from an issue raised 
in a meeting, a defect entered into a defect database, or a request for enhancement 
sent in by a customer. 
The Rational Administrator and The Rational Project 15



You use the Rational Administrator to configure the UCM policies for the Rational 
project. Through integration with Rational ClearCase you can use the Rational 
Administrator to check in all elements under configuration management and to create 
project baselines. As change requests are entered or defects are discovered, your team 
can use UCM to manage change to activities and artifacts.

See the Using Unified Change Management with Rational Suite manual for more 
information about UCM and how it is implemented and used with Rational Suite.

Where Do I Go From Here?

Use the following table as a quick reference to the tasks and procedures performed to 
manage a Rational project using the Rational Administrator.

Task Description See

Upgrade a 
Rational 7.x Test 
Repository

If you already have Rational test 7.x 
repositories you want to use with 
the current version of Rational 
Administrator, you need to convert 
the repositories to projects.

Installing Rational Suite

Upgrade a 
RequisitePro 
project

You can upgrade a RequisitePro 
project by itself if for some reason it 
didn’t convert when you converted 
the repositories to projects.

Installing Rational Suite

Create a 
RequisitePro 
project

You can create a RequisitePro 
project which you can associate 
with a Rational project.

Creating a RequisitePro Project on 
page 40

Baseline 
RequisitePro 
projects with UCM

Rational RequisitePro project 
administrators can create baselines 
of RequisitePro projects by 
performing tasks in Rational 
Administrator and Rational 
ClearCase, implementing the 
Unified Change Management 
model.

Baselining the RequisitePro Project 
with UCM on page 42

Create a 
RequisitePro 
project from a 
baseline

You can create a RequisitePro 
project based on the established 
baseline of an existing project and 
include the data from that baseline. 
If you have a Rational RequisitePro 
project that is baselined, you can 
use that baseline to create a new 
project in RequisitePro.

Creating Baselines of RequisitePro 
Projects on page 40
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Create a Test 
datastore

You can create a Test datastore in 
the Rational Administrator.

Creating a Test Datastore on page 29

Baseline Test 
datastores with 
UCM

Rational Test datastore 
administrators can create baselines 
of RequisitePro projects by 
performing tasks in Rational 
Administrator and Rational 
ClearCase, implementing the 
Unified Change Management 
model.

Creating a Test Datastore from a 
Baseline on page 30

Create a Test 
datastore from a 
baseline

You can create a Test datastore 
based on the established baseline of 
an existing Test datastore and 
include the data from that baseline. 
If you have a Rational Test 
datastore that is baselined, you can 
use that baseline to create a new 
Test datastore.

Creating a Test Datastore from a 
Baseline on page 30

Configure 
ClearQuest or 
attach an existing 
ClearQuest 
database to a 
Rational project

To use ClearQuest to store defects, 
you must configure ClearQuest 
before you create a ClearQuest 
database or attach an already 
existing ClearQuest database to a 
Rational project. 

Creating and Configuring a 
ClearQuest Database on page 21 and 
Configuring a Rational Project on 
page 24

Register an 
existing Rational 
project

If you have an existing Rational 
project, you can add it to the list of 
projects maintained by the 
Administrator. 

Registering a Rational Project on 
page 26

Create and 
configure a 
Rational project

You can create and configure a 
Rational project, a Rational Test 
datastore, a RequisitePro project, 
and a ClearQuest database with the 
Rational project, as well as existing 
Rose models.

Creating and Configuring a Rational 
Project on page 22

Connect to a 
Rational project

You must connect to a Rational 
project before you can add a user or 
group, or view properties of 
datastores and databases associated 
with the project.

Connecting to a Rational Project on 
page 25

Task Description See
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Add one or more 
test groups to 
a Rational Test 
datastore and 
assign privileges to 
a group

Create a test group or groups with 
privileges for a Rational Test 
datastore. When you add a user to a 
group, the user acquires the 
privileges of that group.

Creating a Test Datastore on page 29

Add one or more 
test users to a 
Rational Test 
database

You must add a test user to a 
Rational project before a user can 
use other Rational software. You 
must also make a user a member of 
a group to grant user privileges.

Creating a Test Datastore on page 29 
and Creating a Test Datastore on 
page 29

Attach an existing 
ClearQuest 
database

You can attach an existing 
ClearQuest database to a Rational 
project.

Adding a ClearQuest Database to a 
Rational Project on page 46

Task Description See
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2Using the Rational 
Administrator
This chapter explains how to use the Rational Administrator software to perform 
administrative tasks on a Rational project. 

Use the information in this chapter to:

■ Start the Rational Administrator

■ Connect to and work with an existing Rational project

■ Set up Rational ClearCase and Rational ClearQuest for use with the Rational 
Administrator

■ Create and configure a Rational project

■ Manage and administer a Rational project

Starting the Rational Administrator

To start the Rational Administrator:

■ Click Start > Programs >  Rational Product name > Rational Administrator .
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The Rational Administrator Main Window

After you start the Rational Administrator, the main window appears. It is composed 
of two parts: the Project pane and the Details pane.

■ The Project Pane - The left pane of the main window, the Project pane, displays a 
list of Rational projects and SQL Anywhere database servers. 

■ The Details Pane - When you select an item in the left pane of the main window, 
information about the selected item appears in the right pane, the Details pane.

Rational Project Privileges

When you connect to a Rational project, you may be asked to enter a password if one 
has been assigned to the project on the Project Properties dialog box. You can assign a 
password to an existing project if you wish. See Displaying and Modifying a Rational 
Project on page 27.

You can also regulate access to the Rational Test datastore by defining users and 
groups. For more information about privileges, see Creating a Test Datastore on 
page 29.

Upgrading with the Rational Administrator 

You must use the Rational Administrator during part of the process of upgrading 
from earlier releases to this release. For more information about upgrading your 
release of Rational software, refer to the manual Installing Rational Suite.

Before Creating a Rational Project

Before working with a Rational application for the first time, you must create and 
connect to a Rational project. 
20 Chapter 2 - Using the Rational Administrator



Before creating a Rational project, perform the following steps:

1 Decide whether to create the Rational project under configuration management. 
For information on the steps to take before creating a UCM-enabled project, see 
Setting Up ClearCase for UCM-Enabled Projects on page 23.

2 Decide what type of database to use. For information about database types, 
see Displaying the Properties of a ClearQuest Database on page 46. 

3 We recommend that you create a shared directory for each shared database or 
project. For more information, see Creating a Shared Directory on page 22.

4 Decide whether to bring a RequisitePro project and Test datastore under 
configuration management, and whether you want to use an existing baseline.

Using SQL Anywhere for a ClearQuest Database

1 If you use SQL Anywhere for a ClearQuest database, do the following before you 
create the Rational project:

a Install the Sybase SQL Anywhere software.

b Create a SQL Anywhere database server.

For information about creating a SQL Anywhere database server, 
see Creating a SQL Anywhere Database Server on page 51.

Creating and Configuring a ClearQuest Database

If your Rational software comes with ClearQuest, create a ClearQuest database to 
store defects for your testing efforts. Follow the instructions in Rational ClearQuest to 
install and configure your chosen vendor database. 

Configure ClearQuest by creating a new schema project or by connecting to an 
existing schema project. Configuring ClearQuest 

You only need to configure ClearQuest once for all projects. If you attach an existing 
ClearQuest database to a Rational project that has an existing schema project, you do 
not have to create a new schema project. For more information about ClearQuest 
schemas, see About the Rational ClearQuest Database on page 45 and the ClearQuest 
Help.

For information about attaching an existing ClearQuest database when you create a 
Rational project, see Configuring a Rational Project on page 24. For information about 
attaching an existing ClearQuest database to an existing Rational project, see Adding a 
ClearQuest Database to a Rational Project on page 46.

To configure ClearQuest: 
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1 Click Tools > Rational ClearQuest Maintenance Tool . 

2 Follow the directions in the ClearQuest Setup Wizard to create a new schema 
project or to connect to an existing schema project.

3 Optionally, create a sample database. ClearQuest provides a sample database 
containing sample records that you can use to familiarize yourself with 
ClearQuest.

For more information about the ClearQuest Setup Wizard, click Help  on the wizard. 
The wizard creates five default ClearQuest accounts. You need the user ID and 
password to log into ClearQuest. The user IDs and passwords are as follows:

■ Default administrator account – The user ID is admin, with no password.

■ Default user account – The user ID is user, and the password is password.

■ Default engineer account - The user ID is engineer, and the password is 
password.

■ Default lead account - The user ID is lead, and the password is password.

■ Default QE account - The user ID is QE, and the password is password.

Creating a Shared Directory

To create a shared directory for a database or project:

1 Create a directory in the Windows Explorer.

2 Right-click the directory, then click Sharing .

3 Click Shared As or Share this folder .

4 In the Share name  box, type the name of the shared directory.

5 Click OK.

Creating and Configuring a Rational Project

This section includes the following topics:

■ Creating a Rational project

■ Configuring a Rational project
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Setting Up ClearCase for UCM-Enabled Projects

To create a Rational project that is associated with a UCM project (that is, before you 
can enable the project for use with UCM), refer to the manual Using Unified Change 
Management with Rational Suite.

Creating a Rational Project

1 Open the Rational Administrator by clicking Start > Programs > Rational Product > 
Rational Administrator.

2 Create an empty, shared directory in which to store your project.

3 Click File > New Project .

4 Enter the project name and the location of the empty directory you created in step 
2 above. The pathname should be in UNC format (for example: 
\\servername\directory...).

5 To enable the project for use with UCM, click UCM-enabled .

Note:  When you enable a project for use with UCM, you gain the ability to 
baseline test assets and requirements through the Rational Administrator. For 
more information about baselining, see Creating a Test Datastore from a Baseline on 
page 30.

Click Next .

6 If UCM is enabled, on the Project UCM Policies page, select the UCM policies that 
apply to the project on the Project UCM Policies wizard screen. 

a Click Version Control Requirement Assets  to place the RequisitePro 
requirements assets under configuration management.

b Click Version  Control Test Assets  to place the Test datastore under 
configuration management.

c Select the UCM project you want to associate with the Rational project.

7 On the Security page, optionally enter a password and confirm it to associate a 
password with the project. 

Note:  Only ASCII characters are supported within passwords. Non-ASCII 
characters, such as accented letters, are not supported in the password field.

8 On the Summary page, read the summary of the project settings. Optionally, click 
Configure Project Now . 
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9 Rational Administrator validates the project information and creates the project. If 
you enabled the UCM option, the Administrator establishes an association 
between the Rational project and the UCM project.

If you opted to configure the project, the Configure Project dialog box appears.

Configuring a Rational Project

To configure a Rational project:

1 Display the Configure Project dialog box, if it is not already visible. From the 
Rational Administrator menu, click File > Configure . If more than one Rational 
project is registered, choose the project you want to configure from the selection 
dialog box.

2 In the Configure Project dialog box, perform any of the following steps, as 
appropriate: 

❑ If you do not have an existing RequisitePro project, Test datastore or Rational 
ClearQuest database, use the Create  buttons to create them and associate them 
with the Rational project. The Create  buttons are visible only when a specific 
product datastore has not been associated with the Rational project. See 
Creating a Test Datastore on page 29 and Creating a RequisitePro Project on 
page 40.

Alternatively, to create a RequisitePro project and a Test datastore from an 
existing baseline, see Creating Baselines of RequisitePro Projects on page 40 and 
Creating a Test Datastore from a Baseline on page 30.

If a ClearQuest database has already been associated with the UCM project, 
you will not be able to select or create another ClearQuest database to associate 
with the Rational project. To create or change a ClearQuest database, you must 
create a new Rational project. The ClearQuest database is predetermined by 
any existing relationship with a UCM project.

Any UCM project that is associated with the Rational project will be enabled for 
change request management if you select a ClearQuest database in the 
Configure Project dialog box.

❑ If you do have an existing RequisitePro project, Test datastore, or Rational 
ClearQuest database that you want to associate with the Rational project, use 
the Select  button. The Select  buttons are visible only when a specific product 
datastore, project, or database has not been associated with the Rational project.
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❑ Use the Add  button to associate existing Rose model files with the Rational 
project. You cannot create Rose model files from the Configure Project dialog 
box.

❑ If you have already associated a RequisitePro project or Test datastore with a 
Rational project that is enabled for use with UCM, but have not brought the 
project or datastore under configuration management, use the Add to CM  
button to add it to configuration management. The Add to CM  buttons for 
RequisitePro projects and Test datastores are enabled only if the Rational 
project is UCM-enabled, and if the project or datastore is not currently under 
configuration management.

❑ If the RequisitePro project or Test datastore is using configuration management, 
the Check In All  button is visible. Use the Check In All  button to add and 
check-in all assets, enabling the creation of a baseline in ClearCase. See Creating 
a Test Datastore from a Baseline on page 30 and Creating Baselines of RequisitePro 
Projects on page 40.

❑ To disassociate RequisitePro projects or Test datastores that are under 
configuration management, use the Remove from CM  button. The Remove from 
CM buttons for RequisitePro projects and Test datastores are enabled only if the 
Rational project is UCM-enabled, and the project or datastore is currently 
under configuration management.

Note:  Removing a RequisitePro project or Test datastore from configuration 
management does the following:

➑ Copies all files in the project or datastore to a non-version-controlled area

➑ Associates the Rational project with the non-version-controlled area

3 When you are finished, click Close .

Managing a Rational Project

Managing a Rational project involves tasks such as connecting, disconnecting, 
registering, unregistering, and deleting. You can also display and modify the project’s 
properties.

Connecting to a Rational Project

You must connect to a Rational project before you can configure or delete it. After you 
have connected to a Rational project you can additionally view the properties of the 
product datastores, projects, and databases.
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1 From the Rational Administrator menu, click File > Connect .

2 If there is more than one disconnected Rational project, select the project to connect 
to and click OK . 

Only those registered Rational projects that are not already connected are in the list 
of projects.

3 Optionally, enter the Rational project’s password and click OK.

Disconnecting from a Rational Project

1 From the Rational Administrator menu, click File > Disconnect .

2 Select the Rational project from which to disconnect and click OK.

Note:  If only one project is connected, Rational Administrator does not display a 
selection dialog box and disconnects you from that project.

Only registered projects that are connected are in the list of projects.

Registering a Rational Project

Registering a Rational project makes it appear in the project hierarchy in the Rational 
Administrator’s left pane. You register a project when a user on one computer wants 
to administer a Rational project that was created on a different computer.

1 From the Rational Administrator menu, click File > Register Project .

2 Enter the path of the Rational project or browse to it and click Open .

If the project is already registered, it will not be registered again when you click 
Open .

Unregistering a Rational Project

Unregistering a Rational project makes it disappear from the project hierarchy in the 
left pane. 

1 From the Rational Administrator menu, click File > Unregister Project .

2 Select the project to unregister and click OK. 

The Administrator removes the project from the project hierarchy.

If you select a project that is currently open, the Administrator closes the project 
before removing it from the project hierarchy.
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Displaying and Modifying a Rational Project

To work with a project’s properties:

1 Make sure you are connected to the Rational project.

2 Click Edit > Properties .

The General tab displays the Rational project name, location, and enables the 
project for use with UCM.

❑ UCM can only be enabled if ClearCase 4.1 or greater is installed, or if you have 
installed ClearCase LT.

❑ The project cannot be removed from UCM unless both the Test datastore and 
Requirements project are not enabled for use with UCM.

❑ The project location cannot be modified.

The Project UCM Policies tab allows you to specify the configuration management 
attributes.

❑ You cannot clear the check boxes if the Rational project was under 
configuration management before you displayed the Project Properties dialog 
box.

❑ The check boxes are enabled only if:

➑ The project was not UCM-enabled before you opened the Project Properties 
dialog box, and

➑ The UCM-enabled  check box was selected after you opened the Project 
Properties dialog box.

The Security tab allows you to modify the Rational project’s password.

3 View or modify the properties as desired.

Note:  After you modify a Rational project, changes will only be reflected after you 
disconnect and then reconnect to the project.

Deleting a Rational Project

To delete a Rational project:

1 From the Rational Administrator, select the project you want to delete in the 
project (left) pane.

2 From the menu, click File > Delete Project .

3 To delete the project, click OK.
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The Rational Administrator permanently deletes the project.

Deleting a Rational project does the following:

■ Unregisters the project

■ Removes the associations among the various projects, datastores, and databases

■ Permanently deletes the project

However, none of the associated product projects, datastores, and databases will be 
deleted when you delete the project.

If you select a Rational project that is currently open, the Administrator closes the 
project before deleting it.

Starting Rational Products from the Rational Administrator

■ You can start several Rational products from the Rational Administrator by 
selecting a product from the Tools  menu.
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3Managing a Rational Test 
Datastore
This chapter describes how to manage a Rational Test datastore. 

Use the information in this chapter to:

■ Understand what Rational Test datastores are, and how to create and manage 
them

■ Perform administrative tasks for test groups and test users

■ Baseline and manage Test datastores with UCM

About the Rational Test Datastore

A Rational Test datastore is a collection of related test assets, including test scripts, 
suites, datapools, logs, reports, test plans, and build information. Rational Test users 
and groups are maintained in a datastore named TestUsersAndGroups.

.

Creating a Test Datastore

You can create a Test datastore in the Rational Administrator by selecting the Create  
button in the Configure Project dialog box.

1 Click File > Configure Project .

2 Select the appropriate project and click OK.

3 Open the Create Test datastore dialog box by clicking the Create  button to the right 
of the Test Assets  field in the Configure Project dialog box.

4 Enter or browse to the path for the new Test datastore.

5 Optionally, choose the initialization options you want:

❑ To initialize the test assets from an existing Test datastore, click Initialize Assets 
from the following Test datastore. Enter or browse to the path of the existing Test 
datastore.
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❑ To initialize the test users and groups in the new Test datastore from an existing 
Rational project, click Initialize Test Users and Groups from the Rational Project . 
Enter or browse to the path of the existing Rational project.

6 Click OK to finish creating the Test datastore.

Creating a Test Datastore from a Baseline

You may want to create a Test datastore based on the established baseline of an 
existing Test datastore and include the data from that baseline. If you have a Rational 
Test datastore that is baselined, you can use that baseline to create a new Test 
datastore. The following tasks are performed by Test datastore administrators in 
Rational Administrator and Rational ClearCase, implementing the Unified Change 
Management model.

To create a Test datastore from a baseline, perform the following tasks:

■ Create a UCM project

■ Create a Rational project

■ Baseline the Test datastore with UCM

Create a UCM Project

See Setting Up ClearCase for UCM-Enabled Projects on page 23 and the Rational 
ClearCase Help for more information.

1 Create a UCM project.

2 Add a UCM component to the project that already contains a Test datastore at a 
recommended baseline.

3 Set the recommended baseline for the new UCM project (by default the baseline 
specified in step 2 will be selected).

4 Create an integration view for the new UCM project.

Create a Rational Project

See Creating and Configuring a Rational Project on page 22 for more information.

1 From Rational Administrator, select File > New Project . The New Project wizard 
opens.

2 Enter requested information in the wizard, select UCM-enabled , and select Version 
Control Test Assets .
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When you complete the wizard, the Configure Project dialog box opens.

3 Click the Select  button to choose Test Assets.

4 Browse to the UCM view and select the Test datastore path for the baselined Test 
datastore.

5 Optionally, to initialize the test users and groups in the new Test datastore from an 
existing Rational project, select Initialize Test Users and Groups from the Rational 
Project . Enter or browse to the path of the existing Rational project.

6 Click OK in the Configure Project dialog box.

The new Test datastore contains the data and structure from the selected baselined 
datastore.

Note:  The new Test datastore has the same name as the baselined Test datastore.

Baselining Test Datastores with UCM

Rational Test datastore administrators can create baselines of Test datastores by 
performing tasks in Rational Administrator and Rational ClearCase, implementing 
the Unified Change Management model.

Note:  In order to baseline a Test datastore, the Test datastore must be associated with 
a UCM-enabled Rational project in Rational Administrator.

To baseline the Test datastore in Rational Administrator:

1 Right-click the Rational project and click Configure .

2 In the Configure Project dialog box, to the right of the Associated Test datastore 
field, click the Check In All  button.

3 Confirm your selection in the messages that follow, and enter an activity to 
describe the baseline in the Check in All dialog box.

4 After the Check In All operation is completed, click Close  to exit the Configure 
Project dialog box.

5 Click Tools > Rational ClearCase Project Explorer .

The ClearCase Project Explorer appears.

6 Right-click the test assets integration stream and click Make Baseline  from the 
shortcut menu.

7 Enter a baseline title, select the baseline type, select a view context, and click OK.
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Displaying the Properties of a Test Datastore

To see the properties of the Test datastore in a project, you must first connect to the 
project using File > Connect . If needed, select the project to which you want to 
connect. You cannot change any of the properties.

To display the properties of the Test datastore:

1 From the Rational Administrator, select the Test datastore in the left (project) pane.

2 Click Edit > Properties .

Adding a Test Datastore to a Project

1 From the Rational Administrator menu, click File > Configure . 

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to associate the Test datastore with the 
Rational project. 

❑ Use the Create  button to create a Test datastore and associate it with the 
Rational project. The Create  button is visible only when a Test datastore has not 
been associated with the Rational project.

❑ Use the Select  button to select an existing Test datastore and associate it with 
the Rational project. The Select  button is visible only when a Test datastore has 
not been associated with the Rational project.

❑ Use the Add to CM  button to add the Test datastore to configuration 
management. The Add to CM  button is enabled only if the Rational project is 
UCM-enabled, and if the datastore is not currently under configuration 
management.

3 When you are finished, click Close .

Removing a Test Datastore from UCM

1 From the Rational Administrator menu, click File > Configure .

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to remove the Test datastore from 
configuration management. 
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Use the Remove from CM  button to remove a Test datastore from configuration 
management. The Remove from CM  button is enabled only if the Rational project is 
UCM-enabled, and the datastore is currently under configuration management.

3 When you are finished, click Close .

Rational Test Datastore Privileges

You determine the security of a Rational Test datastore by assigning privileges to test 
users and test groups. Test groups allow you to set privileges for each test user. When 
you add a test user to a test group, the test user acquires the privileges of that test 
group. 

You can set the Rational Test datastore privileges for a test user to:

■ Create, modify, and delete test planning assets.

■ Create, modify, and delete test implementation assets.

■ Create, modify, and delete test execution assets.

■ Create, modify, and delete test results analysis assets.

When you create a project, you can use the Administrator to create a Rational Test 
datastore. Doing so also creates a Test Users and Groups folder. The Users folder 
contains an admin  test user. These default objects appear in the left pane of the main 
window.

Managing Test Groups and Test Users

Test Users

Test users are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage scripts 
that run across a network.

For each test user, you can specify a user ID, password, first name, last name, 
company, title, department, phone number, and e-mail address.

You can assign privileges to a test user by adding a user to a test group. When you 
add a test user to a test group, the test user acquires the privileges of that test group. A 
test user can be a member of one or more test groups. The only privilege needed to 
modify or add test users of test groups is the Rational project password.

For more information about users, see Creating a Test Datastore on page 29.
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The Admin User and Default Groups

Each Rational Test datastore that you create comes with a default test user named 
“admin”. The admin test user is not a member of any specific test group and takes on 
all available privileges.

You can make any test group a default group, and you can also create multiple default 
groups. When you add a test user to a Rational Test datastore, and this option is set, 
every test user that you create acquires the privileges of the default test groups.

For more information about groups, see Creating a Test Datastore on page 29.

An admin test user can:

■ Create, modify, and delete test assets.

■ Create, modify and delete reports, builds, and logs.

■ Customize test assets and builds.

Project Security

When you connect to a Rational project, you may be asked to enter a password if one 
has been assigned to the project on the Project Properties dialog box. You can assign a 
password to an existing project if you wish. See Displaying and Modifying a Rational 
Project on page 27

Admin Test User Security

There is no default password for the admin test user. You can log in as an admin test 
user without using a password. This lets you log into any Rational Test component 
after you first install the software.

When you connect to a project for the first time, you should define a password for the 
admin test user to prevent unauthorized access. The admin test user always has full 
test user access privileges and cannot be deleted from a project. For more information 
about modifying a password, see Changing a Password for a Test User on page 37.

RequisitePro and ClearQuest Security

To set security privileges for a RequisitePro project or ClearQuest database, see the 
RequisitePro or ClearQuest Help.
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Adding a Test Group or Test User

Test groups allow you to set privileges for each test user. To add a test group or test 
user to a Rational Test datastore using Rational Administrator:

1 Connect to the project. From the Rational administrator menu, click File > Connect . 
Select the project name and click OK. 

2 To add a test group:

a Click Insert > Test Group . 

b A dialog box opens with a list of all connected projects. Select the project to add 
a test group to, and click OK .

c The Insert Test Group dialog box opens.

d Type a name and description for the group.

e Optionally, click Set as default group  to set a test group as a default group for all 
test users added. 

f Optionally, click Select All  to select all test group privileges. Alternatively, add 
and remove privileges from a group by selecting or clearing the appropriate 
check boxes. Click Clear All  to clear all selected privileges.

➑ Write Privileges  – Select the appropriate check boxes to give privileges to 
a group to create, modify, or delete test planning assets, test implementation 
assets, test execution assets, and test results analysis assets. 

Examples of the various types of test assets include, but are not limited to:

- Test planning assets - Test plans and iterations of plans

- Test implementation assets - Tools used in the implementation of test plans

- Test execution assets - Suites, computers, and computer lists

- Test results analysis assets - Build results, test logs folders, and test logs

➑ Administration Privileges  – Select the appropriate check boxes to give 
privileges to a test group to customize test assets. Examples of 
customization include manipulation of test script sources and types, test 
input sources and types, modification of list values and modification of 
custom labels.

3 To add a test user:
Managing Test Groups and Test Users 35



a Click Insert > Test User . 

b A dialog box opens with a list of all connected projects. Select the project to add 
a test group to, and click OK .

c The Insert Test User dialog box opens.

d On the General tab, type the user’s information.

e Click the Groups tab. Select a group name in the Not a member of  pane and use 
the > (add) or < (remove) buttons and the >> (add all) or << (remove all) buttons 
to add or remove users to or from all available groups.

4 Click OK.

Modifying a Test Group or Test User

You must have privileges to modify a test group. For more information about 
privileges, see About the Rational Test Datastore on page 29.

To modify existing test group information:

1 Connect to the project. Click File > Connect . Select the project name and click OK. 

2 If Test Groups  or Test Users  are not visible in the left pane of the main window, 
double-click Rational Test datastore .

3 If the test group or user that you want to modify is not visible, double-click Test 
Groups or Test Users, respectively, to display all groups or users.

4 Select the test group or test user to modify.

5 Click Edit > Properties .

6 Change the test group or test user information on the appropriate tabs. 

7 Click OK.

Deleting a Test Group or Test User

When you delete a test group, you delete the group privileges for any test users in the 
deleted group. You do not delete any test users who are members of the deleted 
group. 

You must have privileges to delete a test group or user from a Rational Test datastore. 
For more information about privileges, see About the Rational Test Datastore on page 29.

To delete a test group or test user from a Rational Test datastore:
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1 Connect to the project. Click File > Connect . Select the project name and click OK. 

2 If Test Groups or Test Users are not visible in the left pane of the main window, 
double-click Rational Test datastore .

3 If the test group or test user that you want to delete is not visible, double-click Test 
Groups  or Test Users to display all groups or users, respectively.

4 Select the test group to delete, and then click Edit > Delete . 

The Administrator prompts you to confirm the deletion.

5 Click Yes.

Changing a Password for a Test User

To change a password:

1 Double-click Rational Test datastore  in the left pane of the Rational Administrator 
main window.

2 Double-click Test Users  to display all test users.

3 Select the user name of the password that you want to change.

4 Click Edit > Properties , or right-click and then click Properties .

5 Click the General  tab of the dialog box.

6 Select the original password (xxxxx) in the Password  box, and then type a new 
password over it.

Type an alphanumeric string of up to 20 characters for the password. Passwords 
are case-sensitive. A test user with a defined password must type that password 
and user ID to log into the Rational software.

Note:  Only ASCII characters are supported within passwords. Non-ASCII 
characters, such as accented letters, are not supported in the password field.

7 Click OK.
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4Managing a RequisitePro 
Project
This chapter describes how to manage a RequisitePro project in the Rational 
Administrator. 

Use the information in this chapter to:

■ Create a RequisitePro project, with or without a baseline

■ Baseline a RequisitePro project with UCM

■ Administer a RequisitePro project

About Rational RequisitePro 

With Rational RequisitePro, you can organize, prioritize, track, and control changing 
project requirements. You can manage all of your Rational project’s requirements — 
user requirements, software specifications, and use cases — using the RequisitePro 
database as a central repository. 

Using RequisitePro, you can effectively communicate your requirements to all team 
members and stakeholders. Effective requirements management helps your 
organization ensure that its products meet their stated goals.

RequisitePro is unique because it integrates a familiar environment, Microsoft Word, 
and a database to provide a powerful, yet easy-to-use framework for managing your 
requirements. You itemize requirements within requirements documents, and then 
manage them using an integrated database. Your teams can collaborate, 
communicate, and provide updates on the same project. 

All requirements for a Rational project are stored in a RequisitePro project. Each 
RequisitePro project consists of requirements documents and a dynamically-linked 
RequisitePro database. A RequisitePro project document can store text, graphics, or 
other objects (such as OLE objects) that identify project needs and are meaningful to 
users. 

For more information on RequisitePro, see Using Rational RequisitePro. See your 
RequisitePro documentation for information on how to set up the RequisitePro 
project. 
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Creating a RequisitePro Project

You can create a project in Rational RequisitePro by using the Rational Administrator. 

1 From the Rational Administrator menu, click File > Configure Project.

2 Click the Create  button to the right of the Requirement Assets box. The Create 
Rational RequisitePro Project dialog box appears.

3 Select one of the following Project Templates. A description of each template 
appears in the text box at the bottom of the dialog box.

❑ Select the Blank  template, and individually set all the parameters for the 
project.

❑ Select Make New Template  to create a template from an existing project, using 
the New Template Wizard.

❑ Select one of the default templates provided with RequisitePro.

4 Click the Create  button and select a template.

RequisitePro projects are created from templates. When you click on the Create  
button, the document and requirement types, attributes, and security information 
of the selected project are copied to the new project. If want to copy all the data 
from another project, in addition to copying the structure, see the next section, 
Creating Baselines of RequisitePro Projects.

5 Enter information about the new project in the dialog boxes that follow.

Creating Baselines of RequisitePro Projects

Rational RequisitePro project administrators can create baselines of RequisitePro 
projects by performing tasks in Rational Administrator and Rational ClearCase, 
implementing the Unified Change Management model.

When creating a project from a baseline, the newly created project does not maintain 
the cross-project traceability links from the original baselined project.

You may want to create a project based on the established baseline of an existing 
project and include the data from that baseline. If you have a Rational RequisitePro 
project that is baselined, you can use that baseline to create a new project in 
RequisitePro. The following tasks are performed by RequisitePro project 
administrators in Rational Administrator and Rational ClearCase, implementing the 
Unified Change Management model.
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For archiving projects that do not use the UCM model, refer to Archiving Projects 
with ClearCase in the RequisitePro online help.

To create a RequisitePro project from a baseline, perform the following tasks: 

■ Create a UCM project

■ Create a Rational project

Creating a UCM Project

See Setting Up ClearCase for UCM-Enabled Projects on page 23 and the Rational 
ClearCase Help for more information.

1 Create the Rational UCM-enabled project.

2 Add a UCM component to the project that already contains a versioned 
RequisitePro project at a recommended baseline.

3 Set the recommended baseline for the new UCM project (by default the baseline 
specified in step 2 will be selected).

4 Create an integration view for the new UCM project.

Creating a Rational Project

See Creating and Configuring a Rational Project on page 22 for more information.

1 From Rational Administrator, click File > New Project . The New Project wizard 
appears.

2 Enter requested information in the wizard, click UCM-enabled , and click Version 
Control Requirement Assets .

When you complete the wizard, the Configure Project dialog box opens.

3 Click the Select  button to choose Requirement Assets.

4 Browse to the UCM view and select the .rqs file for the baselined RequisitePro 
project.

5 Click OK in the Configure Project dialog box.

The new RequisitePro project contains the data and structure from the selected 
baselined project.

Note:  The new project has the same name as the baselined project. You can remove 
the old baselined project from the RequisitePro list of projects in the Open Project and 
Documents dialog box.
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Baselining the RequisitePro Project with UCM

To baseline a RequisitePro project with UCM:

■ A RequisitePro project must be associated with a UCM-enabled Rational project in 
Rational Administrator

■ The RequisitePro project must be closed, and all users must have exited the 
program.

To baseline the RequisitePro project:

1 Open the Rational Administrator.

2 Right-click the Rational project and click Configure .

3 In the Configure Project dialog box, to the right of the Associated RequisitePro 
Project  field, click the Check In All  button.

4 Confirm your selection at the messages that follow, and enter an activity to 
describe the baseline in the Check in All dialog box.

5 After the Check In All operation is completed, click Close  to exit the Configure 
Project dialog box.

6 Click Tools > Rational ClearCase Project Explorer .

The ClearCase Project Explorer appears.

7 Right-click the RequisitePro Requirements Assets integration stream and click 
Make Baseline  from the shortcut menu.

8 Enter a baseline title, click Full  for the baseline type, select a view context, and click 
OK.

Displaying the Properties of a RequisitePro Project

To see the properties of the RequisitePro project, you must first connect to the Rational 
project using File > Connect . If needed, select the project to which you want to 
connect.

To display the properties of the RequisitePro project:

1 Select the RequisitePro project in the left (project) pane.

2 Click Edit > Properties .

3 Click the Properties  button to the right of the Database  text box to see the database 
properties.
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Adding a RequisitePro Project to a Rational Project

1 From the Rational Administrator, click File > Configure Project .

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to associate the RequisitePro project with the 
Rational project. 

❑ Use the Create  button to create a RequisitePro project and associate it with the 
Rational project. The Create  button is visible only when a RequisitePro project 
has not been associated with the Rational project.

❑ Use the Select  button to select an existing RequisitePro project and associate it 
with the Rational project. The Select  button is visible only when a RequisitePro 
project has not been associated with the Rational project.

❑ Use the Add to CM  button to add the RequisitePro project to configuration 
management. The Add to CM  button is enabled only if the Rational project is 
UCM-enabled, and if the project is not currently under configuration 
management.

Note:  Associating a RequisitePro project with a Rational project is a permanent 
action. The association cannot be undone or reassigned, as with Test datastores 
and Rose models.

Removing a RequisitePro Project from UCM

1 Click File > Configure .

If more than one project is registered, choose the project you want to configure 
from the selection dialog box.

2 Use the Configure Project dialog box to remove the RequisitePro project from 
configuration management. 

Use the Remove from CM  button to remove a RequisitePro project from 
configuration management. The Remove from CM  button is enabled only if the 
Rational project is UCM-enabled, and the RequisitePro project is currently under 
configuration management.

3 When you are finished, click Close .
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5Managing a ClearQuest 
Database
This chapter explains how to manage a ClearQuest database in the Rational 
Administrator.

Use the information in this chapter to:

■ Learn about ClearQuest

■ Display the properties of a ClearQuest database

■ Add or remove a ClearQuest database to a Rational project

About Rational ClearQuest

Rational ClearQuest is a change request management tool that helps you track and 
manage all the change activities (such as defects and enhancement requests) 
associated with a Rational project. When used with other tools in the Rational Suite, 
ClearQuest can play a vital role in supporting change and defect management in an 
iterative software development environment.

For a detailed overview of ClearQuest, see Introducing Rational ClearQuest.

About the Rational ClearQuest Database

A Rational ClearQuest database consists of a schema repository and a user database:

■ The ClearQuest schema repository stores all schemas and all data associated with 
existing schemas. The schema repository does not store any user data. 

■ A ClearQuest user database contains all user data and a copy of the schema 
associated with the database. User data in a ClearQuest database includes 
change-request records such as defects, as well as reports, records or tables, and all 
data entered by users. 

A ClearQuest schema defines the following information for each change-request 
record:

■ Forms used to submit and modify a record

■ Field types, legal values, and so on
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■ States that a record can be in (optional)

■ Actions used to modify or change the state of a record

■ Hooks written in Visual Basic Script that further customize legal field values, 
dependent fields, and actions (optional)

A full version of Rational ClearQuest comes with Rational Suite TestStudio. If you 
have purchased Rational TeamTest, upgrade to the full version of ClearQuest if you 
want to add fields to a schema or connect to a database to which fields have been 
added.

Displaying the Properties of a ClearQuest Database

To see the properties of the ClearQuest database in a Rational project, you must first 
connect to the project using File > Connect . If needed, select the Rational project to 
which you want to connect.

From the Rational Administrator, display the properties of the ClearQuest database:

1 Select the ClearQuest Database in the left (project) pane.

2 From the Rational Administrator menu, click Edit > Properties .

Adding a ClearQuest Database to a Rational Project

Any UCM project that is associated with the Rational project will be enabled for 
change request management if you select a ClearQuest database on the Configure 
Project dialog box.

To add a ClearQuest database to a Rational project:

1 From the Rational Administrator menu, click File > Configure .

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the ClearQuest database with the 
Rational project. 

❑ Use the Create  button to create a ClearQuest database and associate it with the 
Rational project. The Create  button is visible only when a ClearQuest database 
has not been associated with the Rational project.
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❑ Use the Select  button to select an existing ClearQuest database and associate it 
with the Rational project. The Select  button is visible only when a ClearQuest 
database has not been associated with the Rational project.

3 When you are finished, click Close .

Note:  If a ClearQuest database has already been associated with the Rational project, 
you cannot select or create another ClearQuest database to associate with the project. 
To create or change a ClearQuest database, you must create a new Rational project. 
The ClearQuest database is predetermined by any existing relationship with a UCM 
project.

Removing a ClearQuest Database from a Rational Project

If a ClearQuest database has already been associated with the Rational project, you 
cannot remove it. To create a Rational project without a ClearQuest database, you 
must create a new project. 
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6Managing Rose Models
This chapter describes how to manage a Rose model file in the Rational 
Administrator. 

Use the information in this chapter to:

■ Learn about the Rose model and the Rational project

■ Add or remove a Rose model from a Rational project

About Rational Rose and the Rose Model

Rational Rose enables visual modeling of architectures, components, and data using 
the Unified Modeling Language (UML). It automatically implements the framework 
of your code in a number of popular languages and automates the process of 
maintaining consistency between a software model and its implementation.

A Rose model is a graphical representation of a software system. A model can 
represent business processes, software components, classes and objects, and 
distribution and deployment processes. 

Adding a Rational Rose Model to a Rational Project

One or more Rose models may be associated with a Rational project.

To add a Rose model to a Rational project:

1 From the Rational Administrator menu, click File > Configure .

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the Rose model with the Rational 
project. 

Use the Add  button to associate a Rose model with the Rational project.

3 When you are finished, click Close .
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Removing a Rational Rose Model from a Rational Project

1 From the Rational Administrator menu, click File > Configure .

If more than one Rational project is registered, choose the project you want to 
configure from the selection dialog box.

2 Use the Configure Project dialog box to associate the Rose model file with the 
Rational project. 

Use the Remove  button to disassociate a Rose model file from the Rational project.

3 When you are finished, click Close .
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7Managing a SQL 
Anywhere Database 
Server
This chapter describes how to configure and manage a SQL Anywhere database 
server. 

Use the information in this chapter to:

■ Create a SQL Anywhere database server

■ Change a SQL Anywhere database server configuration

■ Administer an SQL Anywhere database Server

■ Use SQL Anywhere and Sybase database utilities

Server Terminology

This section defines some important terminology used when discussing SQL 
Anywhere Database Servers.

■ A server refers to a computer with Sybase SQL Anywhere Server software 
installed. 

■ Services are program interfaces that perform specific functions, in this case, starting 
the SQL Anywhere database server. 

■ A SQL Anywhere database server is a service that manages database requests for one 
or more data repositories.

Creating a SQL Anywhere Database Server

To create a SQL Anywhere database server, perform the following tasks:

1 Install the Sybase SQL Anywhere Server software before you create a 
SQL Anywhere database server, as described in the installation guide for your 
product.

2 Choose a user account to run the SQL Anywhere database server and set 
privileges for that account, as described in the next section, Setting Privileges.
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3 Create the SQL Anywhere database server, as described in How to Create a SQL 
Anywhere Database Server on page 54.

Setting Privileges

1 To set privileges for a user account running a SQL Anywhere database server, do 
one of the following:

If a computer is running Then

Windows 2000 Server a Click Start > Programs > Administrative Tools > 
Local Security Policy .

b Click Local Policies , then double-click User 
Rights Assignment .

Windows 2000 Professional a Click Start > Settings > Control Panel .

b Click Administrative Tools .

c Click Local Security Policy .

Windows NT Server a Click Start > Programs > Administrative Tools 
(Common) > User Manager for Domains .

b Click User > Select Domain  and type the local 
computer name in the Domain  box, and then click 
OK.

c Click Policies > User Rights .

d Click Show Advanced User Rights .

Windows NT Workstation a Click Start > Programs > Administrative Tools 
(Common) > User Manager .

b Click Policies > User Rights .

c Click Show Advanced User Rights .
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2 Do one of the following:

3 Do one of the following: 

■ For Windows NT:

a In the User Rights Policy dialog box, click Add .

b Select the domain of the account running the SQL Anywhere database server 
from the List Names From  list.

c Click Show Users . 

If a computer is running Then

Windows 2000 a Click Start > Settings > Control Panel .

b Click Administrative Tools .

c Click Local Security Policy .

Windows NT a Click Access this computer from network in the 
list and complete steps 3–8.

b Click Log on as a service  in the Right  list and 
complete steps 3–8.

c Click Log on locally  in the Right  list and complete 
steps 3–8.
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d Select the account running the SQL Anywhere database server from the Names  
list.

e Click Add , then click OK.

f Go back to steps 2b and 2c to set all privileges.

g Click OK.

h Click User > Exit . 

■ For Windows 2000:

a From the right pane of the Local Security Settings window, click Local Policies,  
then click User Rights Assignment .

b In the right pane of the Local Security Settings window, double-click the policy 
you want to work with. You will need to work with at least three policies:

➑ Access this computer from the network

➑ Log on as a service

➑ Log on locally

The Local Security Setting dialog box appears when you double-click each 
policy.

c Click the Add  button to add users and groups. The Select Users or Groups 
dialog box appears.

d After selecting the appropriate server from the drop-down list at the top of the 
Select Users or groups dialog, select the domain of the account running the SQL 
Anywhere database server from the list of users and groups. Click Add , and 
type the user names you want to associate with each privilege.

How to Create a SQL Anywhere Database Server

To create a SQL Anywhere database server:

1 Click Start > Programs >  Rational product name > Rational Administrator .

2 Click File > New SQL Anywhere Database Server .

3 Type a description of up to 30 characters that uniquely identifies this database 
server on the network, and then click Next . 

4 Type the amount of space for caching data for the SQL Anywhere database server, 
then click Next . We recommend 2048K for each Rational project on the server.
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5 Select one or more protocols to communicate with the SQL Anywhere database 
server, then click Next .

Note:  To reduce connection time, check only those protocols that are actually used on 
your network.

6 Choose the Startup options, as described in the following step:

a Click one of the following buttons to set the Windows NT Service Startup 
options. These options start the SQL Anywhere database server when you turn 
on your system.

➑ Click Automatic  to start the Windows NT Service that starts the SQL 
Anywhere database server when you start your system.

➑ Click Manual  to not start the Windows NT Service that starts the SQL 
Anywhere database server when you start your system.

b Select or clear the Start service immediately  check box. This option starts the 
SQL Anywhere database server immediately after you create it. If the box is 
cleared, you must start the server manually. 

7 Among the Account options, select one of the following choices:

❑ Click System Account (LocalSystem)  to run the service under a local account.

Note:  If you choose System Account (LocalSystem) , you will not be able to 
remotely configure a ClearQuest database using UNC.

❑ Click Other Account  to allow users access to a shared ClearQuest database or 
shared repository. We recommend that you choose this option because it allows 
users the most flexibility for accessing a database or repository.
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i Type a domain and user account name in the Other Account  box.

The user account name is case-sensitive. This user account must have the 
appropriate privileges to access a shared database or repository. For 
information about setting privileges, see Setting Privileges on page 52.

ii Enter and re-enter the password for the account. 

The password is case-sensitive.

8 Among the Account options, click Display database monitor  to display the SQL 
Anywhere database monitor when the SQL Anywhere database server starts. 

Note:  This option is not available when you click Other Account . 

Click Next .

9 A summary appears that confirms your choices. Click Finish .

Changing a SQL Anywhere Database Server Configuration

To change the configuration of a SQL Anywhere database server:

1 Click Start > Programs >  Rational product name > Rational Administrator .

2 In the left pane, right-click a server under SQL Anywhere Database Servers, and 
then click Edit > Properties .
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3 Optionally, click the Basic tab and change any of the options. 

4 Optionally, click the Advanced tab and change any of the advanced settings.

Note:  The advanced settings are intended for use by, or in close cooperation with, 
Rational Technical Support. In most cases, these settings do not need modification.

5 Click OK.
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Starting a SQL Anywhere Database Server

The Rational Administrator generates a startup command that can help you start a 
SQL Anywhere database server. The Administrator lets you manually start a SQL 
Anywhere database server on a Windows NT workstation or a Windows NT server.

To start a SQL Anywhere database server:

1 Click File > Start SQL Anywhere Database Server . 

If you created more than one database server, a dialog box appears with a list of all 
database servers. 

2 Select the SQL Anywhere database server that you want to start, and then 
click OK.

SQL Anywhere Server Startup Switches

The basic startup command syntax is:

DBSRV50 -n ServerName -c CacheMemory -x Protocols 

drive:\database\DB\RAS.DB -n Databasename

For example:

DBSRV50 c:\SQLDIR\DB\RAS.DB -n Proj1DB

or for a shared directory:

DBSRV50 \\KRANTI\SQLDIR\DB\RAS.DB -n Proj1DB

The default SQL Anywhere startup switches are:

Table 1 SQL Anywhere Server Startup Switches

SQL Anywhere Startup 
Switches

Description

DBSRV50 The SQL Anywhere server executable.

-n ServerName The SQL Anywhere server name.

-c CacheMemory The amount of cache memory. (We recommend using the 
default cache memory which is set to 2048K for each 
repository.)

-x Protocols A comma-separated list of protocols.
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For complete descriptions of all SQL Anywhere switches and components, 
see the SQL Anywhere Help.

Stopping a SQL Anywhere Database Server

To stop a SQL Anywhere database server:

1 Click File > Stop SQL Anywhere Database Server . 

If you have more than one database server running, a dialog box appears with a 
list of the running database servers. 

2 Select the SQL Anywhere database server that you want to stop, and then 
click OK.

Deleting a SQL Anywhere Database Server

You must have appropriate privileges to delete a SQL Anywhere database server. 

To delete a SQL Anywhere database server:

1 Select the server to delete from the list of SQL Anywhere Database Servers 
in the left pane of the main window.

2 Click Edit > Delete . 

The Administrator prompts you to confirm the deletion.

3 Click Yes to delete the server.

Using the Sybase Central Database Management Tool

You can start the Sybase Central database management tool from the Administrator. 
This tool exposes SQL Anywhere database server settings, properties, and utilities 
in a graphical user interface. For more information about using the Sybase Central 
database management tool, see the SQL Anywhere Help.

drive:\Database or 

\\computername\shared\

The drive and location of the repository directory. 
We recommend that you use the Universal Naming 
Convention (UNC) here. (The \DB\RAS.DB path 
is required.)

SQL Anywhere Startup 
Switches

Description
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To start the Sybase Central database management tool from the Administrator:

■ Click Tools > Sybase Central.

Using the Sybase ISQL Utility

The Sybase ISQL provides you with an interactive environment for database 
browsing and for sending SQL statements to a particular SQL Anywhere database 
server. For more information, see the SQL Anywhere Help.

To start the Sybase ISQL utility from the Rational Administrator:

■ Click Tools > ISQL.

Using the SQL Anywhere Service Manager

The SQL Anywhere Service Manager lets you start, stop, or pause a SQL Anywhere 
Server service. You can also edit the configuration parameters of each service. For 
more information, see the SQL Anywhere Help.

To start the SQL Anywhere Service Manager from the Rational Administrator:

■ Click Tools > SQL Anywhere Service Manager .
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