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Preface
Preface
This guide provides a complete reference for the features and options available 
in Rational RequisitePro. RequisitePro, the premier requirements management 
tool, integrates a powerful multi-user requirements database utility with the 
familiar environment of Microsoft Word for Windows, enabling you to 
simultaneously work with a requirements database and requirements 
documents. 

Audience
The RequisitePro User’s Guide is designed to meet the diverse needs and 
responsibility levels of various types of users. Users may perform different 
roles that vary depending on the RequisitePro project they access. The roles 
listed below describe typical user functions; however, they may not correspond 
directly to RequisitePro security groups. RequisitePro administrators can 
create any number of security groups with specific permissions for creating, 
updating, and deleting projects, documents, and requirements.

Requirements viewers read documents, query the requirements database, 
and participate in discussion groups. These are common activities for all 
RequisitePro users.
Requirements contributors perform the common activities of 
requirements viewers; however, they have additional permissions to 
modify requirements attribute values. 
Requirements authors use standardized templates to write or revise 
requirements documents and add, delete, or revise requirements in the 
project database. The templates are created by the project administrators.
Project administrators create and manage all elements of a project – 
including security, document types and requirement types – and set up 
cross-project traceability.
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Preface
The RequisitePro User’s Guide is organized to initially introduce activities 
that are common to all users who view and query requirements. It then moves 
to the skills needed for creating and managing requirements. Finally it 
addresses the advanced skills required for managing projects.
Refer to the following table which recommends reading based on your level of 
use in RequisitePro:

All readers should refer to Appendix A: Keyboard Shortcuts and Mouse 
Actions, Appendix B: Customizing RequisitePro, and the Glossary, which 
defines technical terms used in RequisitePro.

Other Resources
• Online Help. You can view online help within RequisitePro whenever you 

need assistance. To display the Help Contents: Click the Help button on 
the Tool Palette, click Help > Contents and Index, or press the F1 key. 
You can also click the Help button in any dialog box.

• Let’s Go RequisitePro. This help interface that automatically appears 
when you start the application, providing prominent access to beneficial 
information about setting up RequisitePro projects and the Requirements 
Management process. Let’s Go RequisitePro guides new users through the 
various “getting started” information available in RequisitePro, including 
online help and the Learning Project. For advanced users, it provides a 
single source for accessing pertinent, in-depth documentation, including 
whitepapers, the Rational Unified Process, and Web resources.

Recommended Chapters
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Requirements
Viewers

Requirements 
Contributors

Requirements
Authors

Project
Administrators

Type of 
User
xiv
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Let’s Go RequisitePro automatically appears when you start RequisitePro, 
but you can disable it by clearing the check box on the Tools > Options 
dialog box or on the initial Let’s Go RequisitePro splash screen. You can 
launch Let’s Go RequisitePro at any time from the Help menu. Click Help 
> Let’s Go RequisitePro.

• Getting Started Tours. You can access three online help tours from either 
Let’s Go RequisitePro or the Getting Started book in the help Contents 
tab: Quick Start, a basic tour through RequisitePro’s project, document 
and requirements structure; Requirements Management Tour, an 
overview for using RequisitePro as part of a requirements management 
process; and Project Administration Tips, a guide for RequisitePro 
project administrators, who will be setting up and managing projects.

• The Learning Project Tutorial. The Learning Project is an online tutorial 
designed to help you quickly learn how to use specific RequisitePro 
features. The Learning Project automatically appears in the project list in 
the Open Project and Documents dialog box, where you can open the 
project and its documents. In the Select Document(s) list, select Welcome 
to the Learning Project and click OK.

• Rational Training Services. For more information on training 
opportunities, see the Rational University Web site: http://
www.rational.com/university.

References
To learn more about requirements management, we recommend the following 
book:
• Managing Software Requirements: A Unified Approach by Dean 

Leffingwell and Don Widrig, Addison Wesley, 2000.
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Documentation Roadmap

Contacting Rational Technical Support
If you have questions about installing, using, or maintaining this product, 
contact Rational Technical Support as follows:

Rational Technical Support Information 

Location Contact Information Notes

U.S. and 
Canada

800-433-5444
781-676-2450
support@rational.com

When sending e-mail:
– Specify the product name in 
the subject line, for example, 
“Rational Suite”. 
– For existing issues, include 
your case ID in the subject line.

Europe +31 (0) 20 4546 200
support@europe.rational.com

Asia Pacific +61-2-9419-0111
support@apac.rational.com
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Please help our Technical Support staff deliver quality customer service by 
providing complete information. The techsupport.html file, which is located in 
the RequisitePro installation directory and is also available by clicking Help > 
Contacting Technical Support, contains a Customer Information Form. You 
can use this form to document problems, questions, or suggestions and to detail 
your company and system information. The form can be copied into your e-
mail message.
Attach your error.log file (located in the RequisitePro installation directory in 
the bin folder) if you are getting an error message. Add any files, screen 
captures, and other information you feel are relevant.

Other Contacts

Joining the RequisitePro Users Mailing List 
Rational has created an open e-mail list “req_forum@rational.com” for 
customers to exchange ideas on using RequisitePro. This list is monitored to 
ensure product questions and problems are being answered. To subscribe to the 
mailing list, go to the following Web site:
http://www.rational.com/products/reqpro/usergroups.

Contacting Rational Technical Publications
To send feedback about documentation for Rational products, please send e-
mail to our technical publications department at techpubs@rational.com.
For technical problems and questions, please contact Technical Support.

World Wide 
Web 

http://www.rational.com Click the Technical Support link. 

Location Contact Information Notes
xvii
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C  H  A  P  T  E  R   1 

Fundamentals of Requirements 
Management

This chapter is an excerpt from Rational’s white paper Applying Requirements 
Management with Use Cases. To review the full version of this document, or 
many other Rational white papers, please visit our Web site at 
www.rational.com/support.

Applying Requirements Management with Use Cases
If you are new to or somewhat familiar with requirements management and are 
interested in requirements process improvement, this paper offers a framework 
with which to develop your own approach.

Software and System Development in the Age of Process
For most software and system development teams, the 1990s have been 
process-intensive when compared to the more freewheeling days of the past. 
Standards for measuring and certifying effective software development 
process have been introduced and popularized. Many books and articles on 
software development process and related material on business process 
modeling and re-engineering have been published. Increasing numbers of 
software tools have helped define and apply effective software development 
process. The global economy’s dependence on software accelerated in the past 
decade, enabling development processes and improving system quality.
So how do we explain the high incidence of the software project failure today? 
Why are many, if not most, software projects still plagued by delays, budget 
overruns, and quality problems? How can we improve the quality of the 
systems we build as our businesses, national economies, and daily activities 
become increasingly dependent on them? 
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Fundamentals of Requirements Management
The answers, as always, lie in the people, tools, and processes applied to our 
profession. Requirements management is often proposed as a solution to the 
ongoing problems of software development, yet relatively little attention has 
been focused on improving the practice of this discipline. 
This paper presents the elements of an effective requirements management 
process and highlights some of the obstacles to its successful implementation.
Requirements management applies equally to software-only projects and to 
projects in which software is only a part of the end result, or not included at all. 
For convenience, the paper will hereafter use the term “system” to mean any 
or all of these things. However, it is the abstract nature of software 
development, alone or in combination with hardware, that complicates 
requirements management, and is therefore the primary focus of this paper.

Why Manage Requirements? 
Simply put, system development teams who manage 
requirements do so because they want their projects to 
succeed. Meeting their project’s requirements defines 
success. Failing to manage requirements decreases the 
probability of meeting these objectives.
Recent evidence is supportive:
• The Standish Group’s CHAOS Reports from 1994 and 1997 established 

that the most significant contributors to project failure relate to 
requirements.1 

• In December 1997, Computer Industry Daily reported on a Sequent 
Computer Systems, Inc. study of 500 IT managers in the U.S. and U.K. that 
found 76 percent of the respondents had experienced complete project 
failure during their careers. The most frequently named cause of project 
failure was “changing user requirements.”2 

Avoiding failure should be sufficient motivation to manage requirements. 
Increasing the probability of a successful project and other benefits of 
managing requirements may be equally motivational. The Standish Group’s 
CHAOS report further established that managing requirements well was the 
factor most related to successful projects.

Meeting your
project’s
requirements defines
success.
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Applying Requirements Management with Use Cases
What is a Requirement? 
The first step towards understanding requirements management is to agree on 
a common vocabulary. Rational defines a requirement as “a condition or 
capability to which the system [being built] must conform.” The Institute of 
Electronics and Electrical Engineers uses a similar definition.
Well-known requirements engineering authors Merlin 
Dorfman and Richard H. Thayer offer a compatible and 
more refined definition that is specific - but not 
necessarily limited - to software:

“A software requirement can be defined as: 
• A software capability needed by the user to solve 

a problem or achieve an objective.
• A software capability that must be met or possessed by a system or 

system component to satisfy a contract, specification, standard, or 
other formally imposed documentation.”3

What is Requirements Management?
Since requirements are things to which the system being built must conform, 
and conformance to some set of requirements defines the success or failure of 
projects, it makes sense to find out what the requirements are, write them 
down, organize them, and track them in the event they change.
Stated another way, Requirements Management is: 
• a systematic approach to eliciting, organizing, and documenting the 

requirements of the system, and
• a process that establishes and maintains agreement between the 

customer and the project team on the changing requirements of the 
system.

This definition is similar to Dorfman and Thayer’s and the IEEE’s definition 
of “software requirements engineering.” Requirements Engineering includes 
elicitation, analysis, specification, verification, and management of the 
software requirements, with “software requirements management” being the 
planning and controlling of all these related activities4. All of these activities 
are incorporated in the definition of requirements management presented here 
and taught by Rational Software. The difference lies mainly in the choice of 
the word “management” rather than “engineering.” Management is a more 

A requirement is a
condition or
capability to which
the system must
conform.
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Fundamentals of Requirements Management
appropriate description of all the activities involved, and it accurately 
emphasizes the importance of tracking changes to maintain agreements 
between stakeholders and the project team.

The Problems of Requirements Management
So what might be 
difficult about a 
process intended to 
ensure that a system 
conforms to the 
expectations set for it? 
When put into practice 
on real projects, 
difficulties come to 
light. Figure 1 displays 
the results of a 1996 
survey of developers, 
managers, and quality 
assurance personnel. It 
shows the percentage 
of respondents who 
experienced the most frequently mentioned requirements-related problems. 
A more comprehensive list of problems includes:
• Requirements are not always obvious and have many sources.
• Requirements are not always easy to express clearly in words.
• There are many different types of requirements at different levels of detail.
• The number of requirements can become unmanageable if not controlled.
• Requirements are related to one another and to other deliverables of the 

process in a variety of ways.
• Requirements have unique properties or property values. For example, 

they are neither equally important nor equally easy to meet.
• There are many interested and responsible parties, which means 

requirements need to be managed by cross-functional groups of people.
• Requirements change.
• Requirements can be time-sensitive.

Figure 1

Common Requirements Problems

#1 Can’t track changes 71%

#2 Difficult to write

#3 Feature creep 67%

#4 Not well organized 54%

70%
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Applying Requirements Management with Use Cases
When these problems are combined with inadequate requirements 
management and process skills, and the lack of easy-to-use tools, many teams 
despair of ever managing requirements well. Rational Software has developed 
the expertise to instruct teams in requirements management skills and process. 
In addition, Rational RequisitePro is an accessible tool for automating 
effective requirements management.

Requirements Management Skills 
To resolve the problems mentioned above, Rational encourages the 
development of key skills. These skills are presented below in what appears to 
be sequential order, but in an effective requirements management process they 
are applied continuously in varied order. Here they are presented in the 
sequence one would likely apply to the first iteration of a new project.

Key Skill 1: Analyze the Problem
Problem analysis is 
conducted to understand 
business problems, target 
initial stakeholder needs, and 
propose high-level solutions. 
These acts of reasoning and 
analysis find “the problem 
behind the problem.”
During problem analysis, 
agreement is gained on a 
statement of the real 
problems and the 
stakeholders are identified. 
Initial solution boundaries and constraints are defined from both technical and 
business perspectives. If appropriate, the business case for the project analyzes 
return on investment that is expected from the system.

Key Skill 2: Understand Stakeholder Needs
Requirements have many sources. They may come from anyone with an 
interest in the outcome of the project. Customers, partners, end users, and 
domain experts are some sources of requirements. Management, project team 
members, business policies, and regulatory agencies can be others.

Figure 2

Steps in Problem Analysis
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It is important to know how to determine who the sources should be, how to 
get access to those sources, and how to elicit information from them. The 
individuals who serve as primary sources for this information are referred to as 
“stakeholders” in the project.
If you are developing an information system to be used internally within your 
company, you may include people with end-user experience and business 
domain expertise in your development team. Very often you will start the 
discussions at a business-model level rather than at a system level. If you are 
developing a product to be sold to a marketplace, you may make extensive use 
of your marketing people to better understand the needs of customers in that 
market. 
Techniques for eliciting requirements include interviews, brainstorming, 
conceptual prototyping, questionnaires, and competitive analysis. The result of 
requirements elicitation is a list of requests or needs that are described textually 
and graphically, and that have been given priority relative to one another.

Key Skill 3: Define the System 
To define the system means to translate and organize the understanding of 
stakeholder needs into a meaningful description of the system to be built. Early 
in system definition, decisions are made on what constitutes a requirement, 
documentation format, language formality, degree of requirements, request 
priority and estimated effort, technical and management risks, and scope. Part 
of this activity may include early prototypes and design models directly related 
to the most important stakeholder requests.

Principle 55
WRITE NATURAL LANGUAGE BEFORE A MORE FORMAL MODEL
If you write the formal model first, the tendency will be to write natural language that
describes the model instead of the solution system.

TO MAKE A LONG DISTANCE CALL, THE USER SHOULD LIFT THE PHONE.  THE SYSTEM SHALL
RESPOND WITH A DIAL TONE. THE USER SHOULD DIAL A “9”.  THE SYSTEM SHALL RESPOND
WITH A DISTINCTIVE DIAL TONE…

THE SYSTEM CONSISTS OF FOUR STATES: IDLE, DIAL TONE, DISTINCTIVE DIAL TONE, AND
CONNECTED.  TO GET FROM THE IDLE STATE TO THE DIAL TONE STATE, LIFT THE PHONE.
TO GET FROM THE DIAL TONE STATE TO THE DISTINCTIVE DIAL TONE STATE, DIAL A “9.”

Note that in the latter example, the text does not help the reader at all.

- Alan M. Davis, 201 Principles of Software Development, 1995
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We use the word “description” rather than “document” to avoid the perceived 
limitation inherent in the common use of the latter. A description may be a 
written document, electronic file, a picture, or any other representation meant 
to communicate system requirements.
The outcome of system definition is a description of the system that is both 
natural language and graphical. Some suggested formats for the description are 
provided in later sections.

Key Skill 4: Manage the Scope of the Project
The scope of a project is defined by the set of requirements allocated to it. 
Managing project scope to fit the available resources (time, people, and 
money) is key to managing successful projects. Managing scope is a 
continuous activity that requires iterative or incremental development, which 
breaks project scope into smaller, more manageable pieces.
Using requirement attributes, such as priority, effort, and risk, as the basis for 
negotiating the inclusion of a requirement is a particular useful technique for 
managing scope. Focusing on the attributes rather than the requirements 
themselves helps desensitize negotiations that are otherwise contentious.
It is also helpful for team leaders to be trained in negotiation skills and for the 
project to have a champion in the organization, as well as on the customer side. 
Product/project champions should have the organizational power to refuse 
scope changes beyond the available resources or to expand resources to 
accommodate additional scope.

Key Skill 5: Refine the System Definition 
With an agreed-upon high-level system definition and a fairly well understood 
initial scope, it is both possible and economical to invest resources in more 
refined system definitions. Refining the system definition includes two key 
considerations: developing more detailed descriptions of the high-level system 
definition, and verifying that the system will comply with stakeholder needs 
and behave as described.
The descriptions are often the critical reference materials for project teams. 
Descriptions are best done with the audience in mind. A common mistake is to 
represent what is complex to build with a complex definition, particularly 
when the audience may be unable or unwilling to invest the critical thinking 
necessary to gain agreement. This leads to difficulties in explaining the 
purpose of the system to people both inside and outside the project team. 
Instead, you may discover the need to produce different kinds of descriptions 
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for different audiences. This paper includes suggested formats for detailed 
natural language, formal text, and graphical descriptions. Once the description 
format is established, refinement continues throughout the project lifecycle.

Key Skill 6: Manage Changing Requirements
No matter how carefully you define your requirements, they will change. In 
fact, some requirement change is desirable! It means that your team is 
engaging your stakeholders. Accommodating changing requirements is a 
measure of your team’s stakeholder sensitivity and operational flexibility - 
team attributes that contribute to successful projects. Change is not the enemy, 
unmanaged change is.
A changed requirement means that more or less time has to be spent on 
implementing a particular feature, and a change to one requirement may have 
an impact on other requirements. Managing requirement change includes 
activities such as establishing a baseline, keeping track of the history of each 
requirement, determining which dependencies are important to trace, 
establishing traceable relationships between related items, and maintaining 
version control.

Figure 3

The Key to Managing Change
All Requests Go Through a Single Channel
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As Figure 3 illustrates, it is also important to establish a change control or 
approval process, requiring all proposed changes to be reviewed by designated 
team members. Sometimes this single channel of change control is called a 
Change Control Board (CCB).

Important Requirements Concepts
To apply requirements management skills to a project, certain requirements 
management concepts are useful for everyone on the project to understand. 
They include:
Requirement Types. The larger and more intricate the system, the more types 
of requirements appear. A requirement type is simply a class of requirements. 
By identifying types of requirements, teams can organize large numbers of 
requirements into meaningful and more manageable groups. Establishing 
different types of requirements in a project helps team members classify 
requests for changes and communicate more clearly.
Usually, one type of requirement can be broken down, or decomposed, into 
other types. Business rules and vision statements can be types of high-level 
requirements from which teams derive user needs, features, and product 
requirement types. Use cases and other forms of modeling drive design 
requirements that can be decomposed to software requirements and 
represented in analysis and design models. Test requirements are derived from 
the software requirements and decompose to specific test procedures. When 
there are hundreds, thousands, or even tens of thousands of instances of 
requirements in a given project, classifying requirements into types makes the 
project more manageable.
Cross-Functional Teams. Unlike other processes, such as testing or 
application modeling, which can be managed within a single business group, 
requirements management should involve everyone who can contribute their 
expertise to the development process. It should include people who represent 
the customer and the business expectations. Development managers, product 
administrators, analysts, systems engineers, and even customers should 
participate. Requirements teams should also include those who create the 
system solution – engineers, architects, designers, programmers, QA 
personnel, technical writers, and other technical contributors.
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Often, the responsibility for authoring and maintaining a requirement type can 
be allocated by functional area, further contributing to better large project 
management. The cross-functional nature of requirements management is one 
of the more challenging aspects of the discipline.
Traceability. As implied in the description of requirement types, no single 
expression of a requirement stands alone. Stakeholder requests are related to 
the product features proposed to meet them. Product features are related to 
individual requirements that specify the features in terms of functional and 
non-functional behavior. Test cases are related to the requirements they verify 
and validate. Requirements may be dependent on other requirements or 
mutually exclusive. 
In order for teams to determine the impact of changes and feel confident that 
the system conforms to expectations, these traceability relationships must be 
understood, documented, and maintained. While traceability is one of the most 
difficult concepts to implement in requirements management, it is essential to 
accommodating change. Establishing clear requirement types and 
incorporating cross-functional participation can make traceability easier to 
implement and maintain. For more information on different strategies for 
requirements traceability, see the white paper, Traceability Strategies for 
Managing Requirements with Use Cases.5

QA & Test
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Proj. Mgrs

Corp
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RequirementsAnalysts Tech writers
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Developers
& Designers QA & Test
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Multi-Dimensional 
Attributes. Each type of 
requirement has attributes, 
and each individual 
requirement has different 
attribute values. For 
example, requirements may 
be assigned priorities, 
identified by source and 
rationale, delegated to 
specific sub-teams within a 
functional area, given a 
degree-of-difficulty 
designation, or associated 
with a particular iteration of the system. To illustrate, Figure 6 displays 
attributes for a Feature Requirement Type from an example project in 

Figure 5
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requirements
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RequisitePro. As implied by the title of the screen, the requirement type and 
attributes for each type are defined for the entire project, ensuring usage 
consistency across the team.
In Figure 7, feature 
requirements are 
displayed for a 
specific project in 
RequisitePro. Note 
that even without 
displaying the 
entire text for each 
requirement, we 
can learn a great 
deal about each requirement from its attribute values. In this case, its priority 
and difficulty – which may be assigned by different team members – will help 
the team begin to scope the project to available resources and time, taking into 
account both stakeholder priorities and a very rough estimate of effort reflected 
in the difficulty attribute value. In more detailed types of requirements, the 
priority and effort attributes may have more specific values (e.g., estimated 
time, lines of code, etc.) with which to further refine scope. This multi-
dimensional aspect of a requirement, compounded by different types of 
requirements - each with its own attributes - is essential to organizing large 
numbers of requirements and to managing the overall scope of the project.
Change History. Both individual requirements and collections of 
requirements have histories that become meaningful over time. Change is 
inevitable and desirable to keep pace with a changing environment and 
evolving technology. Recording the versions of project requirements enables 
team leaders to capture the reasons for changing the project, such as a new 
system release. Understanding that a collection of requirements may be 
associated with a particular version of software allows you to manage change 
incrementally, reducing risk and improving the probability of meeting 
milestones. As individual requirements evolve, it is important to understand 
their history: what changed, why, when, and even by whose authorization.

Putting Requirements Management to Work
Requirements management employs the key skills and concepts presented 
above to identify and resolve the problems successfully. 

Figure 7
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To build a system that truly meets customers’ needs, the project team must first 
define the problem to be solved by the system. Next, the team must identify 
stakeholders from whom business and user needs are elicited, described, and 
prioritized. From this set of high-level expectations or needs, a set of product 
or system features should be agreed upon.

Detailed software requirements should be written in such a form as can be 
understood by both the customers and the development team. We have found 
that using the language of the customer to describe these software requirements 
is most effective in gaining the understanding and agreement. These detailed 
software requirements are then used as input for the system design 
specifications as well as for test plans and procedures needed for 
implementation and validation. Software requirements should also drive the 
initial user documentation planning and design.

Figure 8

Introduction to Requirements Management
Overview
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Effective requirements 
management includes the 
following project team 
activities: 
1. Agree on a common 

vocabulary for the project.
2. Develop a vision of the 

system that describes the 
problem to be solved by 
the system, as well as its 
primary features.

3. Elicit stakeholders needs 
in at least five important 
areas: functionality, 
usability, reliability, 
performance, and 
supportability.

4. Determine what requirement types to use.
5. Select attributes and values for each requirement type.
6. Choose the formats in which requirements are described.
7. Identify team members who will author, contribute to, or simply view one 

or more types of requirements.
8. Decide what traceability is needed.
9. Establish a procedure to propose, review, and resolve changes to 

requirements.
10. Develop a mechanism to track requirement history.
11. Create progress and status reports for team members and management
These essential requirements management activities are independent of 
industry, development methodology, or requirements tools. They are also 
flexible, enabling effective requirements management in the most rigorous and 
the most rapid application development environments.

A Few Words about Documents
The decision to describe requirements in

 
documents deserves some thought. On the
one hand, writing is a widely accepted form
of communication and, for most people, a 
natural thing to do. On the other hand, the
goal of the project is to produce a system,
not documents. Common sense and
experience teach that the decision is not
whether but how to document requirements.
Document templates provide a consistent
format for requirements management.
Rational RequisitePro offers these templates
and the additional feature of linking
requirements within a document to a database
containing all project requirements. This
unique feature allows requirements to be
documented naturally, making them more
accessible and manageable in a database.
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C  H  A  P  T  E  R   2

Introducing RequisitePro
This chapter covers key RequisitePro concepts. A complete glossary, 
Rational RequisitePro Terms, can be found at the end of this book.

Why Use RequisitePro?
Studies have shown that managing requirements is the most significant factor 
in delivering projects on time, on budget, and on target. RequisitePro helps 
projects succeed by giving teams the ability to manage all project requirements 
comprehensively, while facilitating team collaboration and communication.
Moving beyond conventional requirements management, RequisitePro 
combines both document-centric and database-centric approaches. By deeply 
integrating Microsoft Word with a multi-user database, RequisitePro organizes 
all your project requirements, providing traceability and change management 
throughout the project life cycle. 

Team Collaboration, User Satisfaction 
Requirements drive the entire project. RequisitePro’s integration with other 
industry-leading tools optimizes the flow of requirements data throughout the 
project, promoting reuse and consistency, and ensuring that what is designed, 
tested, documented, and delivered meets the users’ needs.
A product development team typically includes a large number of individuals 
with diverse roles, such as business analysts, project leaders, product 
marketing managers, development managers, QA managers, developers, 
testers and more. Giving each person on your team access to critical 
requirements information, and the ability to manage to those requirements, 
promotes team efficiency and effectiveness.
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Web Component Allows Flexibility
In addition to the Windows client version of RequisitePro, RequisiteWeb 
offers a Web-based client for RequisitePro. RequisiteWeb allows users to 
access RequisitePro requirements information across the Internet or an 
intranet. By utilizing browsers -- Netscape Navigator or Microsoft Internet 
Explorer -- RequisiteWeb provides a thin client solution to access project 
documents and data. No Rational application-specific files need to be installed 
on the user’s machine. 
Through RequisiteWeb, users cannot only view the project, but they can 
contribute significantly. It includes the ability to:
• Read requirements documents
• Create and modify requirements in the database
• Modify requirement attributes in any requirement
• Modify traceability information in any requirement
• Create and participate in discussions
• Create and save views

Change Happens – Manage it 
Change occurs in practically every development project, but it doesn’t have to 
consume project resources or throw the project off course. With RequisitePro, 
you can manage inevitable change to ensure your entire team is current as 
requirements evolve. Traceability features in RequisitePro let you establish 
and maintain dependencies between different requirements. As change occurs, 
these traceability relationships are flagged as suspect, so you can understand 
how change impacts the entire project. For each requirement a change history 
is maintained, capturing the who, what, when, and why of the change.

Comprehensive Process Support 
Whether your team follows a rigorous requirements management process, such 
as IEEE, SEI CMM or UML-driven use-case approaches, or is just beginning 
to define a formal process, RequisitePro can help you meet your objectives of 
delivering precise, quality software. RequisitePro provides industry standard 
project templates and attributes, and it can also import existing documents and 
be customized to support existing projects.
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A Quick Tour of Key Concepts in RequisitePro
This section provides an overview of RequisitePro concepts and defines some 
terms that will help you get started.

Requirement
RequistePro is a requirements repository that organizes requirements and 
provides traceability and change management throughout the project lifecycle. 
To talk about RequisitePro, we first have to decide what a requirement is. 
Rational defines a requirement as “a condition or capability to which the 
system must conform.” 
Later in this chapter we will discuss requirement types and attributes. 
(For more information on requirements, refer to Chapter 8: Working with 
Requirements.)

Project
A RequisitePro project includes a requirements database and its related 
documents. A project is usually created by a project administrator, who 
determines the project structure and sets up security permissions for the 
project’s users.
While all project users are encouraged to view and query requirements and to 
participate in discussions, a limited group of users create and manage 
requirements within a project.
(For more information on projects, refer to the following chapters: Creating 
Projects, Working with Project Security, Managing Projects, and Working 
with Project Information.)

Project Database
Each RequisitePro project has its own database, where all the requirements for 
a project are stored (An Oracle or SQL Server database may contain more than 
one project).
In the project database, requirements can be added, modified, or deleted. When 
requirements are changed in a document, the changes are updated in the 
database.
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Often a project includes a variety of requirements documents, such as a product 
requirements document, a system requirements document, software and 
hardware specifications, user requirements, quality assurance procedures and 
test plans. Information from all project documents is stored in the project 
database. The database centralizes information, so that members of the project 
team can update requirements, manage priorities and test plans, and report the 
project’s progress in one shared repository.

Project Version Control
RequisitePro’s version control lets you trace change by archiving projects. 
Version control helps you keep a record of changes to project files during the 
development cycle. You can manage multiple versions of your projects, 
retrieving, modifying, and returning revisions to the archive in an organized 
and consistent manner. Directly from RequisitePro, you can use RequisitePro’s 
Archive command or Rational ClearCase.
(For more information, refer to Archiving Projects on page 14-9.)

Project List
A RequisitePro project list is a personal library of accessible RequisitePro 
projects. Each user’s list is unique. For example, a project administrator 
monitoring the progress of all the projects scheduled for completion this 
quarter could have an extensive list of projects, while some users might have 
just one project in their lists at a time.
Project administrators store new projects in their file systems – typically in the 
RequisitePro Projects directory. In the Open Projects and Documents dialog 
box, you can add or delete projects from your project list as you need them.
(For more information, refer to Adding a RequisitePro Project to Your Project 
List on page 3-3.)

The Tool Palette, Word Workplace, and Views Workplace
RequisitePro is composed of workplaces where distinct but interrelated work 
is done. The workplaces are launched from the Tool Palette as shown in the 
figure on the following page. All requirements information is stored in the 
database whether it is displayed in the Views Workplace and/or the Word 
Workplace.
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Tool Palette
When RequisitePro is started, the Tool Palette is displayed. Menus on the Tool 
Palette contain RequisitePro commands, and provide access to project 
information, document information, requirements information, discussions, 
and views.
 The icon buttons below the menu bar are shortcuts to frequently used menu 
commands. When you position your mouse over a button, a ToolTip appears, 
describing the button’s function. Use the first button on the Tool Palette to 
open RequisitePro projects and documents.

Word Workplace
The Word Workplace is the place within RequisitePro where requirements are 
created and modified in a document. The Word Workplace contains 
requirement specifications in the form of RequisitePro documents and Word 
documents.
The Word Workplace looks like a Word document, but the menu bar has been 
modified to include a RequisitePro menu that allows you to manage 
requirements and documents. With a few exceptions, RequisitePro uses the 
same commands in the Word Workplace that are available in Microsoft Word. 
The File > Exit and Tools > Templates and Addins commands are disabled in 
the Word Workplace in order to prevent conflicts in handling RequisitePro 
documents.

Views Workplace
The Views Workplace is a window to the database. Requirements, their 
attributes, and their relationships to each other are displayed and managed in 
views. RequisitePro includes powerful query functions for filtering and sorting 
the requirements and their attributes in views.
All Views Workplace commands are located in the menu bar at the top of the 
Views Workplace. As in the Tool Palette, icon buttons are available to access 
one command at a time.
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Views
In RequisitePro, a view is accessed in the Views Workplace. Views present 
information about a project, a document, or requirements graphically in a table 
(matrix) or in an outline tree. Views display the attributes assigned to 
requirements, such as Status and Priority, or the relationships between 
different types of requirements. (For more information, refer to Chapter 4: 
Working in Views.) 
Three kinds of views can be created in the Views Workplace:
• The Attribute Matrix View displays all requirements of a specified type. 

The requirements are listed in the rows, and their attributes appear in the 
columns.

• The Traceability Matrix View displays the relationships (traceability) 
between two types of requirements.

• The Traceability Tree displays the chain of traceability to or from 
requirements of a specified type.

.

Top to bottom: Attribute Matrix, Traceability Matrix, Traceability Tree. Three views of the same 
requirements.
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Documents
 A requirements document is a specification that captures requirements, 
describes the objectives and goals of the project, and communicates product 
development efforts. Each requirements document belongs to a particular 
document type, explained below.
RequisitePro manages requirements directly in the project documents. When 
you build a requirements document, RequisitePro dynamically links it to a 
database, enabling you to manage requirements by updating and saving the 
documents. When saved, revisions are available to team members and others 
involved with the project.
With RequisitePro’s version tracking, you can easily review the change history 
for a requirement, a document, or the whole project.
Documents are created in either Word or RequisitePro format. RequisitePro 
format makes proprietary modifications to the standard Word application that 
allows RequisitePro to exercise security controls over the document. As such, 
certain Word features are disabled, and that functionality is available instead 
through commands on the RequisitePro menu in the Word Workplace and the 
RequisitePro Tool Palette. For example, Word’s File > Open command is 
executed in RequisitePro as Document > Open on the Tool Palette or 
RequisitePro > Document > Open in the Word Workplace.
Not all documents are requirements documents. Documents do not have to 
contain requirements to be included in a project. Any Word document, no 
matter where it resides in the file system, can be associated with a project and 
will be available in the document list when a project is opened. (For more 
information, refer to Chapter 7: Working with Documents.)

Document Types and Requirement Types
Document types and requirement types are two similar requirements 
management concepts and tools. Both serve as templates and define the 
appearance of two essential requirements management components, a 
document and a requirement. But where they differ is in their application. 

Document Type
A document type identifies the type of document, such as a use-case or a 
software requirements specification, and helps ensure consistency across 
documents of the same type. A document type is a template that is applied to 
your documents. The template can include the default font for your document, 
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the available heading and paragraph styles, and the default type of 
requirements for the document. Or it could encompass both formatting 
conventions and an outline that helps you organize your requirements 
information. (For more information, refer to Creating and Modifying 
Document Types on page 15-2.)
All documents of the same document type share the same file extension (for 
example, .prd). You determine document types when you create or modify 
your project. Then, when you create a document, you can associate it with a 
document type already defined in your project. The new document inherits the 
style and functional attributes associated with the document type, making it 
consistent with other documents of the same type.
RequisitePro provides standard document templates that can be used “as is” or 
customized according to your specifications. Once you have defined the 
appearance of the document and the information to include, you can use the 
document as a standard for your organization.
There are several benefits to using standards: 
• The template can be used as an example of the type of information to 

include and can serve as a comprehensive “to do” list so no information is 
overlooked.

• Expectations and procedures are clearly presented so new authors and 
team members spend less time learning to build the necessary 
requirements documents.

• Authors familiar with the template can create new documents quickly. 
• Readers familiar with the template can quickly locate and review 

information.

Requirement Type
A requirement type is a template for your requirements. Requirement types are 
used to classify similar requirements so they can be efficiently managed. When 
you define a requirement type, you define a common set of attributes, display 
style, and tag numbering. 
You can create your own requirement types appropriate for your project.
(For more information, refer to Creating and Modifying Requirement Types on 
page 15-7.)
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Requirement Attributes
Requirements in RequisitePro are classified by their type and their attributes. 
In RequisitePro, an attribute provides information to manage a requirement. 
Attributes can provide crucial information to help a team plan, communicate, 
and monitor project activities from the analysis and design phases through the 
test and release phases. 
Attribute information may include:

• The relative benefit of the requirement
• The cost of implementing the requirement
• The priority of the requirement
• The difficulty or risk associated with the requirement
• The relationship of the requirement to another requirement

RequisitePro provides several default requirement attributes, such as Priority 
(high, medium, low), Status (proposed, approved, incorporated, validated), 
Cost and Difficulty. These attributes are suggestions. You can create and 
control attributes according to your needs. Whichever attributes you use, 
RequisitePro offers the flexibility to easily customize your project documents 
and databases to define, articulate, and manage the processes and culture of 
your organization.
You can use attributes to determine which requirements to implement in the 
next release. For example, you may decide that in the first release, you will 
only implement requirements evaluated as high risk, with high difficulty. If 
you have assigned risk and difficulty attribute values to each requirement, you 
can then easily query all requirements of high risk and high difficulty.
(For more information, refer to Creating and Modifying Requirement 
Attributes on page 15-10.)

Hierarchical Relationships
Hierarchical requirement relationships are one-to-one or one-to-many, parent-
child relationships between requirements of the same type. Use hierarchical 
relationships to subdivide a general requirement into more explicit 
requirements. 
Example: 
Parent requirement:
The system shall display customer information.
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Child requirements provided for detail:
Name
Address
Date of Birth
When working with hierarchical relationships, keep the following in mind:
• Each child requirement can only have one parent, but a requirement can be 

both a parent and a child.
• The parent and child requirements must be located in the same place, either 

in the same document or no documents.
• You create hierarchical relationships in the Word Workplace or the Views 

Workplace, using the Hierarchy tab in the Requirement Properties dialog 
box. (In the Views Workplace, you can also use Requirement menu 
commands to create hierarchical relationships.)

• When you delete a parent, you can choose to delete its children or assign 
them to another parent.

• You cannot create a traceability relationship between a parent and its own 
child.

• Hierarchical relationships are a type of change-managed relationship in 
RequisitePro. If a requirement is changed, the relationships with its 
children become suspect. You can view and manage suspect relationships 
using a Traceability Matrix or a Traceability Tree in the Views Workplace.

(For more information, refer to Chapter 9: Working with Hierarchy.)

Traceability Relationships
Traceability links requirements to related requirements of same or different 
types. RequisitePro’s Traceability feature makes it easy to track changes to a 
requirement throughout the development cycle. Without traceability, each 
change would require a review of your documents to determine which, if any, 
elements need updating.
When working with traceability relationships, keep the following in mind:
• You can create a traceability relationship between requirements of the 

same or different types.
• You can create traceability relationships between requirements that exist 

in the same document, in different documents, or in the project database.
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• You can create, view, and manipulate traceability relationships in the 
Word Workplace or in the Views Workplace.

• Traceability relationships are a type of change-managed relationship in 
RequisitePro. If either end-point of the connection is changed, the 
relationship becomes suspect. If you modify the text or selected attributes 
of a requirement that is traced to or traced from another requirement, 
RequisitePro marks the relationship between the two requirements 
“suspect.”

• Traceability relationships cannot have circular references. For instance, a 
traceability relationship cannot exist between a requirement and itself, nor 
can a relationship indirectly lead back to a previously traced from node. 
RequisitePro runs a check for circular references each time you establish a 
traceability relationship. 

Note: You cannot create a traceability relationship between a parent and its 
own child, but you can create a traceability relationship between a 
parent requirement and a different parent requirement’s child.

(For more information, refer to Chapter 10: Working with Traceability.)

Traced to/Traced from Overview
There can be only one traceability relationship between any two requirements. 
The difference between calling the relationship trace to and calling it trace 
from is perspective.
For example, you might create a software requirement (Requirement A) that 
calls for a new command to be added to a particular menu in your application. 
In addition, in another requirements document, you might create a test 
requirement (Requirement B) associated with that menu item. You would thus 
create a traceability relationship in which the test requirement (B) is traced 
from the software requirement (A).
In this example, both of these statements are true:
• A is traced to B
• B is traced from A

Direct and Indirect Traceability Relationships
There are two types of traceability relationships: direct and indirect.
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In a direct traceability relationship, a requirement is physically traced to or 
from another requirement. For example, if Requirement A is traced to 
Requirement B, and Requirement B is traced to Requirement C, then the 
relationships between A and B and between B and C are direct relationships. 
The relationship between A and C is indirect (inferred). Indirect relationships 
are maintained by RequisitePro; you cannot modify them directly.

Suspect Relationships
A hierarchical relationship or a traceability relationship between requirements 
becomes suspect if RequisitePro detects that a requirement has been modified. 
If a requirement’s text is modified, all its immediate children and all direct 
relationships traced to and from it are suspect. 
When you make a change to a requirement, the suspect state is displayed in a 
Traceability Matrix or a Traceability Tree. Changes include modifications to 
the requirement text, requirement type, or attributes.
For more information about parent-child relationships or traceability 
relationships that are marked suspect, refer to Suspect Relationships on page 
9-10 and Suspect Relationships on page 10-9.
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C  H  A  P  T  E  R   3 

Getting Started
This chapter explains the basics of opening the RequisitePro application and 
accessing RequisitePro projects.

Launching RequisitePro
You can start RequisitePro in one of two ways:
• On the Start menu, click Programs. Click the installed Rational Windows 

Suite and/or RequisitePro version, and then click RequisitePro.
• In Windows Explorer, double-click any file name with the .rqs extension.

Using the RequisitePro Tool Palette
The Tool Palette is the central interface for accessing and working with 
RequisitePro projects. When RequisitePro is launched, the Tool Palette 
appears: 

• Menus on the Tool Palette contain RequisitePro commands and provide 
access to project information, requirements information, and views.

•  The icon buttons below the menu bar are shortcuts to frequently used 
menu commands. When you position your mouse over a button, a 
ToolTip appears, describing the button’s function.
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RequisitePro’s default state is to display the Tool Palette on top of other 
applications on your desktop. If you have changed the desktop to display other 
applications on top, you can view the RequisitePro Tool Palette as follows:
• In the Views Workplace, click Window > Show Tool Palette.
• In the Word Workplace, click RequisitePro > Window > Show Tool 

Palette.
• To display the Tool Palette when it is behind other applications, press Alt-

Tab to display opened applications, and then select the RequisitePro icon.
• To always keep the Tool Palette on top of all applications, change options 

in the Options dialog box. On the Tool Palette, click Tools > Options. 
Select Always On Top in the Tool Palette pane, so that a check mark 
appears in the check box.

Exiting RequisitePro
When you exit RequisitePro, the application closes the current project, 
prompting you first to save any changes you made to the project’s 
requirements documents.
1. On the Tool Palette, click Project > Exit.

If you did not modify any requirements document, a dialog box appears, 
asking you to confirm that you want to exit. Click Yes. 
If you modified one or more requirements documents, and have not yet 
saved those changes, the Document Changed dialog box appears.

2. Do one of the following:
• To save the changes you made without reviewing the changes, click Yes.

If you made changes to a requirement’s text, the Change Description 
dialog box appears and asks you to enter the reason for the changes 
before saving.

• To close the document and exit RequisitePro without saving the 
changes, click No.
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• To cancel the exit process, click Cancel.
• To review changes to the document, click Review Changes.

If you made changes to a requirement’s text, the Change Description 
dialog box appears and asks you to enter the reason for the changes.
The Document Changes dialog box appears, listing each modification 
to the document.

3. Do one of the following:
• To save the changes you made, click Yes. RequisitePro saves the 

changes in the document and in the database.
• To close the document and exit RequisitePro without saving the 

changes, click No.
• To cancel the exit process, click Cancel.

Working with Projects

Adding a RequisitePro Project to Your Project List
When you click Project > Open and the Open Project and Documents dialog 
box appears, you will notice there are names of projects listed in the Select a 
Project field. 
A RequisitePro project list is a library of accessible RequisitePro projects. 
Each user’s project list is unique. All projects are stored in the file system. 
Using the Open Project and Documents dialog box, you select projects from 
the file system for your own project list. You can add or remove projects from 
your list as you need them. 
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Before you can access a project, you must add it to the project list on your 
machine:
1. On the Tool Palette, click Project > Open.

The Open Projects and Documents dialog box appears. 

Note the list of projects in the Select a Project field.
2. Click Add. The Add Project dialog box appears:

3. Locate the project file you want to add to the list (it has a .rqs extension).
Note: If this project is included in a Rational Administrator repository using 

the Universal Naming Convention, be sure to locate the file using 
UNC to identify the project path (Browse through the Windows 
Network Neighborhood).

4. Highlight the project and click Open. 
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5. Click OK. RequisitePro adds the project to the Select a Project field. You 
can now open the project and use its associated requirements and 
documents.

Removing a Project from the Project List
Removing a project from the project list does not delete the project files, but 
removes the project from the listing. It remains in the file system and can be 
added to your project list again.
To remove a project from the project list:
1. On the Tool Palette, click Project > Open.

The Open Project and Documents dialog box appears.
2. Highlight the project name in the Select a Project list and click Remove. 

RequisitePro removes the project.
Note: You can retrieve a project you removed by clicking the Add 

button. (Refer to Adding a RequisitePro Project to Your Project 
List on the previous page.)

3. Click OK.

Opening a Project and Documents
When you open a project, you can open a document at the same time. Or, you 
can choose to open just the project without selecting a document. RequisitePro 
displays all documents associated with the project, regardless of where they are 
stored on the file system.
To open a project and a document:
1. On the Tool Palette, click Project > Open

(or click the Project button).
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The Open Project and Documents dialog box appears:

2. Highlight the project to open in the Select a Project list box.
3. When documents are created, they are assigned a document type. 

The Select Documents list displays documents by type. To see a different 
selection of documents, choose another document type from the Display 
Types drop-down menu.

4. Highlight the document to open in the Select Documents list box.
This list includes all documents you have either created in the project or 
imported into the project, regardless of whether the documents contain 
requirements. You can use a multiple select action (Ctrl-click, Shift-click, 
or drag) to open more than one document.

5. Select the user access options. If you want to be the only user who has 
access to the project and documents, mark the Exclusive check box. To 
open all selected documents in read-only mode, mark the Read Only 
check box.

6. Click OK.
Depending on the security set on the project, one of two dialog boxes appears:
• If security is set on the project, refer to Accessing a Secure Project on page 

3-8.
• If no security is set on the project, but your user name has not been 

identified in the project, the Project Logon dialog box appears.
Do one of the following:

• Accept the displayed name; or
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• Click the down arrow and select a user name from the list; or
• Type a new user name that will be added to the project.

Click OK.
The project opens, and the new name is added to the project.

Closing a Project and Documents
The Close command closes a project and its documents and any open views.
1. On the Tool Palette, click Project > Close.

If you made no changes, the Project Close dialog box appears and 
prompts you to close the project and its documents or keep it open. Click 
Yes to close the project and its documents.
If you modified but did not save a document, the Document Changed 
dialog box appears.

2. Do one of the following:
• To save the changes to the document, click Yes. If you made changes to 

a requirement’s text, the Change Description dialog box appears and 
asks you to enter the reason for the changes before saving.

• To close the project without saving the document changes, click No. 
• To cancel the close project procedure, click Cancel.
• To review document changes, click Review Changes. If you made 

changes to a requirement’s text, the Change Description dialog box 
appears and asks you to enter the reason for the changes.
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The Document Changes dialog box appears, listing each modification 
to the document.

3. Do one of the following:
• To save the changes to the document, click Yes. 
• To close the project without saving the document changes, click No. 
• To cancel the close project procedure, click Cancel.

Accessing a Secure Project
Project administrators can enable security for a project, requiring users to log 
on and provide a password. The project administrator sets up security and 
assigns a user name and password to each member of the team.

Logging on to RequisitePro
To log on and to access a secured RequisitePro project: 
1. On the Tool Palette, click Project > Open (or click the Project button). 

The Open Project and Documents dialog box appears.
2. Highlight a project in the list to open and click OK. If RequisitePro detects 

that security is enabled, the Project Logon dialog box appears:

3. Type your name in the Username text box and your password in the 
Password text box. Click OK. You are now ready to use the project. 
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Modifying Your Password, User Name, or E-mail Address
Once you are in a project you can modify your password, user name, or e-mail 
address. If you are a RequisitePro administrator or a member of a group with 
project security permissions, you also have the ability to change the password, 
user name or e-mail address for other users. See Editing User Information on 
page 13-5.
A valid e-mail address is necessary for receiving RequisitePro discussion 
messages via e-mail. For more information, see Configuring E-mail for 
Discussions on page 6-2.
1. Open a project and log on. The RequisitePro Tool Palette appears.
2. Click Project > Security.

The Edit User dialog box appears.
3. If you are a RequisitePro administrator or a member of a group with project 

security, the Project Security dialog box appears instead. Click the 
“Enable security for this project” check box. Select a user group and a user 
name, and click the Edit button. 
Then the Edit User dialog box appears:

To change your password:
1. Type your password in the Old Password text box that appears in the 

dialog box (This step applies only to users who don’t have project security 
permissions).

2. Type your new password in the New Password text box.
Passwords are case sensitive and limited to 14 alphanumeric characters.

3. Confirm the new password by typing it again in the Verify text box. 
4. Click OK. Your new password is in place and ready for use.
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To change your user name (for users with project security permissions):
1. Highlight your current name in the Username field.
2. Type a new user name. User names are limited to 20 alphanumeric 

characters and are not case sensitive.
3. Click OK. Your new name is in place and ready for use.
To change your e-mail address:
1. Highlight your current e-mail address in the E-mail field.
2. Type a new e-mail address.
3. Click OK. Your e-mail address is in place and ready for use.
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Working in Views
RequisitePro views use tables and outline trees to display requirements and 
their attributes or the traceability relationships between different requirement 
types. RequisitePro includes powerful query functions for filtering and sorting 
the requirements and their attributes in views.
The Views Workplace is an environment for analyzing and printing 
requirements, whether they are located in documents or not. You can have 
multiple views open at one time. The Views Workplace provides scroll bars to 
view all requirements and attributes in the table or tree. The number of 
requirements in the current view appears in the lower right corner of the views 
window.
You can create three kinds of views in the Views Workplace:

• The Attribute Matrix view displays all requirements and their attributes 
within a specified type.

• The Traceability Matrix view displays the relationships between 
requirements of two types.

• The Traceability Tree view displays the chain of traceability through the 
project requirements.

In the Views Workplace, you can do the following:
• Create and modify requirement attributes, requirement text, and 

traceability relationships
• Sort and filter view information
• Save a view’s query and display setup
• Save view information to other formats
• Print views
4-1



Working in Views
Accessing Functions and Navigating in Views
• All Views Workplace commands are located in the menu bar at the top of 

the Views Workplace. Unless stated otherwise, this manual refers to the 
commands in the Views Workplace when working with views.

• To navigate in a view quickly, use the ARROW keys, the PAGE UP or PAGE 
DOWN keys, and the HOME and END keys. For more information, refer to 
Mouse Actions and Shortcuts in the Views Workplace in Appendix A.

• Use the right button on the mouse as a shortcut to commands that are 
specific to requirements and attributes. Move the mouse over the 
requirements and attribute labels and click the right button to access these 
shortcut menus. For more information, refer to Mouse Actions and 
Shortcuts in the Views Workplace in Appendix A.

• The full text of the selected requirement is displayed in the text pane at the 
bottom of the view. To resize a text pane, position the mouse on the upper 
border and drag upward.

Viewing Current Data
While a view is open, other users may add, delete, or modify requirements that 
are displayed in your view. These changes are not automatically reflected in 
your open view.
To update the data displayed in the view for requirements that were modified 
by other users, click View > Refresh All (or the Refresh button) in the Views 
Workplace. The Refresh All command affects all open views and 
automatically updates the data in each view.
The View > Query Now command in the Views Workplace reruns a view’s 
query criteria against the database and updates your requirement set. (For more 
information on queries, refer to Querying and Searching on page 5-1.) 
Requirements that have been deleted or no longer match the query are removed 
from the view. New requirements that match the query are added to the view. 
Query Now does not refresh the data for requirements that are already in your 
view. 
Note: If there are many requirements in the database, Refresh All can take 

some time to complete. If you just need to see a fresh requirement set, 
without updating the text and attributes for each requirement, use 
Query Now.
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Traceability in the Views Workplace
The Traceability Matrix and Traceability Tree views display traceability 
relationships, and the Traced-to or Traced-from attributes appear in the 
Attribute Matrix. Traceability relationships are displayed as suspect when you 
make a change to a requirement. For more information about traceability 
relationships between requirements, refer to Working with Traceability on 
page 10-1. 
• Arrows are used to indicate direct traceability relationships in the 

Traceability Matrix and Traceability Tree views. If the arrow points from 
A to B, then the following two statements are true: A is traced to B and B 
is traced from A.

• In the Traceability Tree and Traceability Matrix views, suspect 
traceability relationships are marked as lines through the arrows. 
In an Attribute Matrix, an (s) appears after the requirement tag in the 
Traced-to or Traced-from column.

• A requirements relationship is indirect if the relationship is derived by 
traversing the requirements relationships. An arrow outlined by a dotted 
line, lighter in color than a direct relationship arrow, indicates an indirect 
traceability relationship in the Traceability Tree and the Traceability 
Matrix.

Hierarchy in the Views Workplace
All views display hierarchical relationships, and you can use the Traceability 
Matrix and Traceability Tree to display hierarchical relationships that are 
marked suspect. For more information about hierarchical relationships 
between requirements, refer to Working with Hierarchy on page 9-1.
• You can create hierarchical relationships in the Views Workplace by using 

Requirement menu commands or editing the requirement properties in the 
Hierarchy tab of the Requirement Properties dialog box.

• When you modify a parent requirement, RequisitePro marks the 
relationships between the parent and all its immediate children as suspect.

• When you modify a child requirement, the relationship with its parent is 
not marked as suspect.
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• When a child requirement is assigned to a new parent, all hierarchical 
relationships between the new parent and its immediate children are 
automatically marked suspect. The relationships between the children and 
their children are not marked as suspect.

• In the Traceability Tree, you can manually mark a hierarchical relationship 
as suspect or clear a suspect relationship.

The Attribute Matrix
This view displays requirements and their attributes for a specific requirement 
type. Requirements are arranged in rows and listed by tag number. Attributes 
are arranged in columns. The Attribute Matrix displays all requirements, but 
only database requirements can be created in this view.

Requirements
In this view, a requirement is displayed in a single row, showing the 
requirement tag followed by requirement text. When requirement text exceeds 
the width of the row, the last character is followed by an ellipsis (...), signifying 
the presence of additional text. An arrow marker at the beginning of a row 
indicates a selected row. An * and <Click here to create a requirement> marks 
the beginning of the empty row at the bottom of the matrix, where you can 
insert a new requirement. A pencil icon at the beginning of a row indicates the 
requirement information you are entering, which has not yet been saved.
The row height and width can be changed.

attribute
labels

attribute
values

requirement
tag 

text
pane

and text
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Attributes
Attribute labels are listed at the top of each column. Corresponding attribute 
values are listed beneath the attribute labels. Query information is displayed 
here as well. 
If there are suspect traceability relationships, an (s) appears after the 
requirement tag in the Traced-to or Traced-from column.
Columns can be resized.

Text Pane
The text pane displays the description of a requirement in its entirety. This field 
is located at the bottom of the matrix and is blank when a requirement is not 
selected. “Multiple requirements selected” appears in the text pane if you have 
selected more than one requirement. Graphics or OLE objects in requirements 
are displayed as small rectangular symbols. The default size of the text pane is 
two lines, but its height can be increased to as many lines as you need.

The Traceability Matrix
This view displays and manipulates the relationships between two requirement 
types. The requirements can be of the same type or different types. Use this 
view to create, modify, and delete traceability relationships and to view 
indirect relationships. The Traceability Matrix also shows traceability 
relationships that are marked suspect. If you display a Traceability Matrix of 
requirements of the same type, it shows hierarchical relationships that are 
marked as suspect.
In this view, a requirement is traced to or traced from another requirement. For 
example, requirement B is traced from requirement A if it was directly or 
indirectly derived from requirement A. If requirement A is the basis of several 
other requirements, Requirement A is traced to these requirements.
An arrow pointing from one requirement to another indicates that a direct 
traceability relationship exists between the requirements. A dotted line arrow 
indicates an indirect relationship.
Rows and columns can be resized. The intersection between a row and column 
is called a cell.
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Cells
•  If the intersection is blank, no relationship exists.
•  If an arrow points upward to a column requirement, the 

requirement is traced to that requirement
•  If an arrow points down toward a row requirement, the 

requirement is traced from that requirement
•  If a dotted line arrow is displayed, an indirect 

relationship exists.
•  If an arrow with a red diagonal line through it is 

displayed, the traceability relationship is suspect.
•  If a triangle with a red diagonal line through it is 

displayed, the hierarchical relationship is suspect.

Text Panes
The Traceability Matrix displays two text panes. These panes let you review 
the requirements in each area, so you can easily create, modify, and delete 
traceability relationships. The default size of each pane is set to one line and 
can be resized. The top text pane displays the complete text of the currently 
selected row requirement and the bottom pane displays the text of the currently 
selected column requirement. “Multiple requirements selected” appears in the 
text pane if you have selected more than one requirement.

Traced to arrow

Traced from arrow

Indirect relationship

Suspect relationship

Suspect relationship

selected

rows

cell

row
requirement

selected
column
requirement

columns
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The Traceability Tree
The Traceability Tree provides a graphical view of relationships to or from 
requirements of one specific requirement type, including direct, indirect and 
suspect traceability relationships. Although direct and suspect relationships are 
modified in this view, RequisitePro permits read-only access to indirect 
relationships.
In addition, the Traceability Tree displays hierarchical relationships and shows 
parent-child relationships that have been marked as suspect.
Requirement text appears at the bottom of the view and associated attributes to 
the right of the view of the currently selected requirement. 

When creating a Traceability Tree, you can choose one that displays all 
requirements traced to the requirements the tree is based on, or one that shows 
all requirements traced from the requirements the tree is based on. 

Tree Pane
Select a specific requirement type on which to base the view. Traceability 
relationships for root-level requirements are indented and preceded by an 
arrow. Child requirements are indented below their parents and preceded by a 
triangle. The pane on the right side of the view displays requirement attributes.

attribute
pane

text
pane

tree
pane

branch-level
requirement
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Note: To resize the tree pane, click the border between the tree and attribute 
panes. Press the left button on the mouse and drag it left or right to the 
desired size. This does not affect the length of the lines set in the 
Row/Column Sizing dialog box.

If the arrow points toward a branch-level requirement, the root is traced 
to this requirement.
If the arrow points away from the branch-level requirement, the 
requirements on the branches are traced from the requirement. 
If an arrow with a red diagonal line is displayed, the traceability 
relationship is suspect. 
If a triangle with a red diagonal line is displayed, the hierarchical 
relationship is suspect.

Attribute Pane
This pane displays the attributes associated with the currently selected 
requirement. To display the attributes of a particular requirement, click the 
requirement in the tree pane. This is a read-only text box and cannot be edited.
If you have more than one requirement selected, the pane displays the 
attributes for the first requirement selected.

Text Pane
The text pane is located in the lower section of the Traceability Tree. To 
display the full text of a particular requirement, click the requirement in the tree 
pane. To adjust the height of the pane, click its upper border and drag the pane 
to the desired size.
“Multiple requirements selected” appears in the text pane if you have selected 
more than one requirement.
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Working with Views
This section presents the fundamentals of working in the Views Workplace, 
including the following:
• Creating a view
• Expanding and collapsing in the Views Workplace
• Saving a view
• Opening a saved view
• Closing a view
• Renaming a view
• Duplicating a view
• Printing a view
• Deleting a view

Creating a View
1. On the Tool Palette, click Window >Show Views (or the Show the views 

workplace button). The Views Workplace opens.
2. In the Views Workplace, click File > New View (or the New View button). 

The New View dialog box appears:

3. Select a view type to display.
4. Select a requirement type to display in the view. The Traceability Matrix 

requires both row and column requirement types.
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5. Click OK. The view is displayed.
Note: The Traceability Matrix displays more than one requirement type. 

The Attribute Matrix displays a single requirement type, and the 
Traceability Tree displays a single requirement type at the root level. 
Only requirements associated with the selected requirement types 
appear in the view.

Expanding and Collapsing in the Views Workplace
The Expand All and Collapse All commands on the View menu are used to 
expand and collapse hierarchical relationships in all views and traceability 
relationships in the Traceability Tree. An expanded view shows the root 
requirement and all its sub-level requirements. Collapse the view to show just 
the root level requirements.
The Expand All command expands all relationships in a view. When you 
select this command in a Traceability Tree, a requirement that has a traceability 
relationship with a root requirement appears as a branch of the root 
requirement. This command also expands all parent requirements, displaying 
all children, in all views.
The Collapse All command collapses all relationships in a view. When you 
select this command in a Traceability Tree, a requirement that has a traceability 
relationship with a root requirement is no longer displayed. This command also 
collapses all parent requirements, hiding all children, in all views.
To expand the Traceability Tree or hierarchical relationships:

• Click the View menu and choose Expand All. 
To collapse the Traceability Tree or hierarchical relationships:

• Click the View menu and choose Collapse All.

Saving a View
When you save a view, the layout of the view and the query criteria are also 
saved. The data within the view is not saved as part of the view, but is part of 
the database instead. Thus, when you open a saved view, current information 
is displayed in a saved view format.
Note: The saved view is not a snapshot of requirement information for a 

particular date. The way to save the results of a query is to print the 
view. For more information on queries, refer to Querying and 
Searching on page 5-1.
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A view must be active in the Views Workplace to be saved. To make an open 
view active and display the view in the active color, click the title bar of the 
view or select it from the Windows menu.
To save a view:
1. In the Views Workplace, click File > Save View As. (or the Save button). 

The Save View As dialog box appears:

2. Click the Name text box and type a name of up to 64 characters.
3. Make the view available to all users (Project-wide availability) or for your 

own use (Personal) by marking the corresponding button.
Note: Only the author or a member of the Administrators group can 

modify project-wide views.
4. RequisitePro populates the following fields, which cannot be edited:

• The Author text box displays the name of the RequisitePro user who 
saved the view.

• The Date text box displays the date the view was saved.
• The Time text box displays the time the view was saved.

5. Click OK to save the view.
RequisitePro organizes views by view type in the Previously Saved Views list 
box in the Open View dialog box. When a view is saved, it is added to this list.
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Opening a Saved View
To display a saved project-wide or personal view:
1. In the Views Workplace, click File > Open View (or the Open a 

previously saved view button).
The Open View dialog box appears:

2. Choose a project-wide or personal view by marking the corresponding 
button. A list of saved views appears.

3. Highlight the desired view from the list. The author, date of creation, and 
time of creation appears below the list. 
Note: You can select more than one view to open by using Ctrl-click or 

Shift-click.
4. Click OK. RequisitePro displays the selected view(s).

Closing a View
1. In the Views Workplace, click File > Close View. 
Note: If the Prompt for save option is activated (the check box is marked 

in the Tools > Options dialog box), and you have changed any of the 
view’s properties, a dialog box appears asking if you want to save the 
view. Click Yes or No.

2. RequisitePro closes the view.
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Renaming a View
Renaming can be used to change the name of an open view window. You might 
want to give a view a longer, descriptive name before you print the view, so 
that the new name appears on the printed page. You can still retain the original 
name in the file system. Renaming a view does not save the renamed view to 
the database until the view is saved again.
1. In the Views Workplace, click View > Rename.

The Rename View dialog box appears.

2. Type a new name for the view in the Name text box and click OK.
Note: Use the Save option on the File menu to save the renamed view.

Duplicating a View
Duplicating a view opens another window with the same view properties as the 
active window. This is especially useful for creating copies of the view with 
different sorting and filter options.
To duplicate a view:

• Click View > Duplicate. 
• RequisitePro renames the view with the suffix 2; for example, “Product 

Requirement Description View2.”
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Printing a View
In the Views Workplace, you can print any active view. When you print a view, 
you can choose to print the entire matrix or selected items.
To print an open view:
1. If you want to print only a selected requirement or relationship, click the 

requirement(s) or relationship(s) in the matrix. (Use a multiple select 
action to select multiple requirements or relationships.)

2. Click File > Print.
The Print dialog box appears.

3. If you are printing selected requirements or relationships, click Selection.
4. Make any other necessary changes to the Print dialog box, and then click 

OK.
Note: Use the Print button on the Views Workplace toolbar to print directly 

to the default printer. In this case, the entire view is printed using the 
default printer selections.

Tip: You can also export a view to a CSV and use another application, such 
as Excel, to open the data and arrange it for printing. See Exporting a 
View as a CSV File on page 11-18 for more information.
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Deleting a View
A personal view can only be deleted by the person who created it. A project-
wide view can be deleted by the person who created it or by a member of the 
Administrators Group.
To delete a view:
1. Click File > Delete View.

The Delete View dialog box appears. 

2. Choose a project-wide or personal view to delete by clicking the 
corresponding button. A list of saved views appears.

3. Highlight the desired view from the list. The author, date of creation, and 
time of creation appear below the list.

Note: You can select more than one view to delete by using Ctrl-click or 
Shift-click.

4. Click OK. RequisitePro deletes the selected view(s).
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Customizing Views
Customizing a view defines its look and content. You can: 
• adjust the size of rows and columns; 
• filter and sort data according to query criteria;
• select specific view properties to display. 
Once a view is defined, it can be saved for future use. Saving a view saves the 
view properties that were customized. When a saved view is opened, it 
displays in the state in which it was saved. 

Adjusting Row Height
Adjusting row height affects all rows in the view.
1. Click View > Row/Column Sizing.

The Row/Column Sizing dialog box appears.:

2. Type the number of lines to display for each requirement. The maximum 
number of lines depends on a monitor’s display resolution. 

3. Click OK. The view is modified according to your specifications.
Shortcut: Click and hold the mouse on any border in the requirement area, 
then drag the row up or down according to the desired height. If the row 
height is already set at one line, RequisitePro will not let you drag the row 
up to less than one line. The Traceability Tree does not have a shortcut. 
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Adjusting Column Width
1. Click View > Row/Column Sizing.

The Row/Column Sizing dialog box appears, as shown above.
2. Type the number of pixels (in the Attribute Matrix) or lines (in the 

Traceability Matrix) to display for each requirement or attribute. 
Parameters for column widths in different views follow.
• Attribute Matrix: To set a different width for each column, drag the 

column to the desired width. To set an equal width for all columns, use 
the View menu, Row/Column Sizing dialog. The maximum screen 
height varies based on your screen’s resolution.

• Traceability Matrix: RequisitePro determines the maximum width based 
on your screen’s resolution.

• Traceability Tree: The column width is represented by the amount of 
indentation or each branch. RequisitePro dynamically changes the 
maximum number of pixels allowed in these columns according to the 
width of the requirement pane and the size of the view. Any change to 
the column width affects all of the columns in this view.

3. Click OK to commit these changes. 
Shortcut: Click and hold the mouse on any border in the attribute label 
area or the requirement area (the gray area at the top of each column) in an 
Attribute or Traceability Matrix. Drag the width left or right to the desired 
size. The Traceability Tree does not have a shortcut.
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Resizing and Arranging Views
Use the menu commands or the buttons on the toolbar in the Views Workplace 
to define the size and arrange the order of a view.

Creating Cascaded Views
This feature overlaps views. Each view is displayed to the right and slightly 
below the preceding view. If many views are open, RequisitePro may overlap 
the first cascade of views with a second cascade until all open views are 
arranged. 
Click Window > Cascade. RequisitePro cascades the views.
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Creating Tiled Views
This view arranges open views next to each other without overlap. 
Click Window > Tile. RequisitePro tiles the views.

Arranging Icons
This feature arranges the icons for all minimized views from left to right, 
beginning at the bottom left corner of the Views Workplace. 
Click Window > Arrange Icons. RequisitePro arranges the minimized views.
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Displaying View Properties
Use the Properties command to display properties associated with an active 
view. Each view displays distinct properties. These properties affect how the 
view appears and not the information contained therein.
1. Click View > Properties. Click the following properties to display them 

in the view. If they are marked on the menu with a check mark, they appear 
in the active view.

• Attribute Matrix:
1. Show Buttons displays a button to the left of requirements and any 

hierarchical relationships. The button is used to expand or collapse the 
requirement.

2. Show Discussions displays a red triangle to the right of the 
requirement text, indicating there are one or more discussions 
associated with a requirement.

3. Show Text displays the first line of the requirement text.
• Traceability Tree:

1. Show Buttons displays a button to the left of requirements and any 
traceability and hierarchical relationships. The button is used to 
expand or collapse the requirement.

2. Show Discussions displays an icon indicating there are one or more 
discussions associated with a requirement.

3. Show Lines displays lines in the Traceability Tree that connect 
relationships.

4. Show Images displays traceability relationships with arrows.
5. Show Root Images displays an arrow at the root of hierarchical 

requirements.
6. Show Text displays the first line of the requirement text.
7. Show Trace To and Trace From display arrows in the direction of 

either trace to or trace from relationships, depending on your 
selection.
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• Traceability Matrix:
1. Show Buttons displays a small box or button to the left of 

requirements with children.
2. Show Discussions displays an icon indicating there are one or more 

discussions associated with a requirement.
3. Show Expand Indicators displays an icon next to each requirement 

that has one or more child requirements. The box contains a + or a -, 
indicating whether or not the requirement or discussion is displayed in 
an expanded or collapsed state.

4. Show Text displays the first line of the requirement text (You can 
define the number of lines displayed using the View > Row/Column 
Sizing command).

5. Show Trace To and Trace From displays arrows in the direction of 
either trace to or trace from relationships, depending on your 
selection.

6. Show Indirect displays both direct and indirect traceability 
relationships.

Saving View Properties as Default
The Save As Default command saves a view layout and any properties 
displayed as the default when opening views of that type. This command is 
available for all view types. To save a view and its displayed properties as the 
default for views of that type:

• Click View > Properties > Save As Default.
• RequisitePro saves the view, layout, and properties for views of that 

type.
Note: Use the Reset Default command to reset any view properties that 

have been changed back to the saved default settings.
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Querying and Searching

Creating and Using Queried Views
Once you have created a view, you can save it as is, or you can refine the view 
by querying (filtering and sorting) its information in a variety of ways.
You can filter requirements in views by limiting the values of one or more 
attributes or by limiting traceability. You can query requirements displayed in 
rows in an Attribute Matrix or Traceability Matrix, columns in a Traceability 
Matrix, or root requirements in a Traceability Tree.

Querying (Filtering and Sorting) Overview
Filtering restricts the information being displayed. Sorting determines the 
order in which information is displayed. For example, in an Attribute Matrix, 
you may want to view only those requirements assigned to you (filter criteria) 
and order requirements information from highest to lowest priority (sort 
criteria).
You filter and sort requirements by applying query criteria to the attributes. 
These criteria limit the values of the attributes and/or limit the traceability 
relationships. You can create a singular attribute query, so that you can see the 
results of each query criteria. Or you can create a query that filters and sorts all 
at once for several attributes. 
Note: You cannot query hierarchical requirement relationships that are 

suspect. Parent requirements are automatically grouped with child 
requirements in unsorted and unfiltered views. 
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Note: RequisitePro does not automatically update views after you have 
queried. If other users have been changing data while a view is open, 
you can use Query Now or Refresh All to reflect those changes in 
your open view. Refer to Viewing Current Data on page 4-2 for more 
information.

Note: If you use Oracle and SQL Server databases, the following query 
restrictions apply in an Attribute Matrix only:
Cross-project traceability queries (queries for “trace to” or “trace 
from” relationships) are not supported between projects in the 
following database types:
• SQL and SQL (across servers)
• Oracle and SQL Server
• Access and Oracle
• Access and SQL Server
Cross-project traceability queries are supported between projects in 

the following database types:
• SQL and SQL (between projects on the same server)
• Oracle and Oracle
• Access and Access 

Filtering
Filtering data is a process by which you can limit the amount of information 
displayed in a view in the Views Workplace. You specify the criteria for 
filtering the information. You can filter requirements by specifying distinct 
criteria for any or all of their attributes. For example, instead of displaying all 
requirements, you might apply a filter such that only requirements having a 
high priority are displayed.

Sorting
By default, the sort order in a view is ascending by requirement tag. When you 
create a query that includes multiple query criteria, you can sort the criteria to 
determine the order in which the requirements are displayed in a view. You can 
also modify the sort order after you have created a query. For example, you 
might sort requirements by priority, high to low. Then, within priority, you 
might sort by date.
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Working with Queries
Use the Query command to extract data from the database and present it for 
use in any of the three views. You can save, open, edit, print, and export 
queried views. 
Queried views range from simple to complex. When querying most attributes 
in a view, you choose one requirement type at a time. If you base a query on 
the Trace to or Trace from attributes, you have the ability to select more than 
one requirement type for targets.
You control the query. To ensure the information in a queried view is current, 
especially if other users are working in the database being queried, refresh the 
database with new data (click View > Refresh the Refresh button), then 
reapply the query criteria.
• By default, the Attribute Matrix view displays all attributes for any 

requirement type and all requirements of that type. You can display only 
the most necessary attributes when querying this view.

• The Traceability Matrix view displays two requirement types and the 
interrelationships between them.

Note: When an Attribute Matrix view or a Traceability Matrix view is 
queried, a filter and/or a sort is applied to the row and/or column 
requirements in the view.

• The Traceability Tree view displays all requirements of one type (root) and 
all requirements related to/from them.
When a Traceability Tree view is queried, the filter and/or sort criteria are 
applied to the root requirements in the view.

Creating Queries
1. In the Views Workplace, open an Attribute Matrix, Traceability Matrix, or 

Traceability Tree view (For more information on views, refer to Chapter 
4: Working in Views.)

2. Click the View menu in the Views Workplace.
The command displayed in the View menu depends on the active view:
• To query row requirements in an Attribute or Traceability Matrix,

select Query Row Requirements.
• To query column requirements in a Traceability Matrix,

select Query Column Requirements.
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• To query the root requirements in a Traceability Tree view,
select Query Root Requirements.

The Select Attribute dialog box appears.

Note: Both requirement attributes you have created and system attributes 
created by default in RequisitePro are included in the list.

3. Select the attribute that you want to use to query, and click OK.
The Query Requirements dialog box appears. Depending on the type of 
attribute you selected (list-type or entry-type), the box contains a specific 
set of criteria for you to define.

4. For list-type attributes, select one or more values.
For entry-type attributes, mark an option (i.e. includes, equal to) and type 
in the value.
Tip: When querying on a date, enter the date in the same format as 

specified for your computer under Regional Settings in your 
Microsoft Windows Control Panel.

5. Enter a Sort Order: None, Ascending, or Descending.
Note: To temporarily sort attribute values in ascending or descending order 

in an Attribute Matrix, you can right-click on the attribute label and 
select Sort Ascending or Sort Descending on the shortcut menu. 
This sorting does not change an existing filter, and the sort order will 
be reset if you create or modify a query.

6. Enter When Traced criteria, if applicable. The When Traced option is only 
available when trace to or trace from attributes are queried. For 
hierarchical requirements, traceability queries automatically include the 
parent if the child participates in a traceability relationship (You cannot 
query for suspect hierarchical relationships).
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Note: You cannot create a traceability query between two external 
requirements.

7. Click OK. The Query [Row/Column/Root] Requirements dialog box 
reappears.

8. To add other query criteria, click Add and repeat steps 3 through 7.
Note: The logical operator and is assumed between multiple attributes.

9. Click the Retain Hierarchical Display check box to include the parents 
of child requirements that match the filter criteria, even though the parents 
do not match.

Note: The query engine ignores hierarchical relationships, unless you mark 
the Retain hierarchical display check box. (For more information 
on parent-child requirements, refer to Working with Hierarchy on 
page 9-1.)

10. When the query is built, click OK in the dialog box. RequisitePro updates 
the view with the query results.
Note: To run the query again, click the View menu and click Query 

Now. (For more information on Query Now, refer to Viewing 
Current Data on page 4-2.)

Modifying Queries
After you have created a query, you can make changes to the query criteria. 
With the view open, do the following:
1. To open the Query [Row/Column/Root] Requirements dialog box 

(depending on your displayed view), click the View menu and choose 
Query Row Requirements, Query Column Requirements, or Query 
Root Requirements.

2. Select the query criteria you want to modify and click Modify.
3. The Query Requirements dialog box appears. (The dialog box that 

appears depends on whether the attribute is a list-type or entry-type.) 
Follow steps 4-10 above in Creating Queries.
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Deleting Queries
1. In the Views Workplace, click the View menu and choose Query Row 

Requirements, Query Column Requirements, or Query Root 
Requirements.
The Query [Row/Column/Root] Requirements dialog box appears 
(depending on your displayed view.

2. In the Query Criteria list, select the query criteria you want to delete.
Note: The order of this list determines the order in which RequisitePro 

filters and sorts the criteria. Be aware that deleting a query from 
the list may affect the results of subsequent queries.

3. Click Remove. Click OK to close the dialog box.

Searching for Requirements in the Database, 
Documents, and Views

RequisitePro provides two methods for finding requirements: 
• The Go To command launches a global search of the database, quickly 

finds a requirement, and displays it in its location (document or view). 
• The Find Requirement command launches a search for a requirement in 

the active view or document.

Using Go To to Search the Database for a Requirement
1. Do one of the following:

• On the Tool Palette, click Requirement > Go To.
• In the Word Workplace, click RequisitePro > Requirement > Go To.
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The Go To Requirement dialog box appears:

2. Select the requirement type from the Requirements of Type list box. If 
you do not know the requirement type, select All Requirement Types. 

3. Select the location of the requirement from the drop-down list in the 
Located in edit box. Choose All locations, Database only, or a specific 
document from the list.
Note: Click the Find button to open the Find Requirement dialog box, 

which you can use to locate a specific tag number and/or 
requirement text.

4. Highlight the requirement and click OK. RequisitePro performs one of the 
following operations: 
• If the requirement is in an unopened document, RequisitePro opens the 

document and highlights the requirement.
• If the requirement is in an open document, the Word Workplace appears 

with the document active and the requirement highlighted.
• If the requirement is in the database only, the Requirement Properties 

dialog box appears so you can examine or modify its description, 
attribute values, or traceability relationships.

Using Find Requirement to Search an Active Document or View
1. Do one of the following:

• To search in a document, click Requirement > Find on the Tool Palette, 
or click RequisitePro > Requirement > Find in the Word Workplace.
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• To search in a view, click Requirement > Find (or the Find 
requirement button) in the Views Workplace.

The Find Requirement dialog box appears: 

2. Type the text of the requirement in the Text Search field.
3. The next step is to establish a search parameter. The dialog box offers three 

different ways to search for text:
• Mark the Match case check box for a case-sensitive search.
• Mark the Use * as wildcard check box for a wildcard search. The 

asterisk matches 0 or more characters.
• Mark the Find whole words only check box for an exact word match.

4. Mark the Up or Down button to specify a direction to search the view or 
document.

5. Click Find Next to launch the search. RequisitePro searches the current 
view or document for the requirement that satisfies the parameters 
established in the dialog box.
• If the requirement is found, RequisitePro highlights the requirement and 

displays it in context. 
• If the search is performed in a view and all requirements in the view are 

not expanded, RequisitePro expands the requirements in the view to 
display the results of the search.

• If the requirement is not found, RequisitePro returns to the requirement 
from which the search began.
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Shortcuts from a View to a Requirement in a Document
When you are working in the Views Workplace, you can switch to the Word 
Workplace to view a requirement within a document.
In the Views Workplace, highlight the requirement to display and do the 
following:

• Press the right button on the mouse and choose Go To from the shortcut 
menu that appears, or

• Double-click the requirement.
Note: This shortcut works only if the default Double-click to go to 

document option is marked in the Tools > Options dialog box.
RequisitePro opens the Word Workplace and highlights the requirement in 
the document.

Reviewing a Project with Cross-Project Traceability
Sometimes, when you open a project, RequisitePro connects to an external 
project and displays both projects. In this case, the projects have been 
connected to one another, and cross-project traceability relationships may 
exist. You can review the requirements in both projects and their change-
managed relationships in the Views Workplace.
Cross-project traceability creates traceability relationships between 
requirements that reside in different projects. This feature establishes 
connectivity among projects that were divided into subprojects or projects that 
relate to each other or share a set of requirements. (For more information on 
cross-project traceability, see Setting Up and Modifying Cross-Project 
Traceability on page 15-14.)

Results of Cross-Project Traceability
Once cross-project traceability relationships are established, the following can 
occur:
• External requirement types can be queried for display in views. 
• If a requirement that is traced to requirements in other projects is deleted, 

RequisitePro updates the other projects to reflect the change. If the 
traceability relationship in the external project cannot be deleted, the 
relationship is updated when connectivity is established between the 
projects.
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• If a requirement modification causes the relationship to become suspect, 
and the requirement is traced to or traced from requirements in other 
projects, RequisitePro updates the projects to reflect the suspect link. If the 
traceability relationship in the external project cannot be modified, the 
relationship is updated when connectivity is established between the 
projects.

• If a link between an internal and external requirement is marked as suspect, 
cleared as suspect, or created or removed by the user, RequisitePro updates 
both the internal and external projects to reflect the change.

• RequisitePro checks for circularity when external relationships are 
created. The circular check references internal requirements and first-level 
external requirements.

Displaying External Requirements
Requirements in the current project are distinguished from requirements in 
external projects by the project prefix. External requirements appear as 
follows:
• The Traceability tab in the Requirement Properties dialog box displays 

only the relationships that are related to the current project. The General 
tab displays external requirement information as read-only.

• The Find Requirement dialog box displays a list of requirement types for 
the current project and each externally mapped project. 

• The New View dialog box displays requirement types from the current 
project and any external projects. If the Attribute Matrix view is selected, 
only the internal requirement types are available for selection. A full 
Attribute Matrix view of external requirements is not provided because of 
performance considerations.

• The Attribute Matrix displays all internal and external traceability 
relationships in the Trace-to-from columns.

• The Traceability Matrix displays all internally and externally mapped 
requirements of a single requirement type in the rows and columns. 

• The Traceability Tree displays all internal and external requirements 
traced to or traced from a requirement. The first level cross-project 
traceability level displays. So, if an internal requirement is traced to an 
external requirement, the external requirement is displayed in the tree. 
Other requirements the external requirement traces to do not appear.
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Displaying Requirement Relationships in Exported Views 
Requirements in exported views with cross-project traceability appear as 
follows:
• An exported CSV file indicates that a traced to/from requirement exists as 

displayed in the view.
• An exported Microsoft Word file indicates a traced to/from requirement 

exists as displayed in the view. 
For more information on exported views, refer to Exporting Requirements on 
page 11-18.

RequisitePro Extensibility Interface
For advanced querying capabilities, the RequisitePro Extensibility Interface 
provides a fully documented COM-based API, giving customers and third-
party solution providers direct access to the requirement data.
The Extensibility Interface includes complete documentation for the 
RequisitePro Query Engine and the associated query language syntax. The 
Query Engine provides a programmatic interface and utilizes objects to 
retrieve RequisitePro project data for requirements and discussions. You can 
optimize queries to load only necessary information, enhancing the 
performance of your application.
Launch the documentation for the RequisitePro Extensibility Interface by 
clicking Help > Extensibility Interface Reference.

Requirement Metrics
Requirement Metrics provides project administrators and analysts with the 
capability of reporting statistics on RequisitePro requirements text, attributes, 
relationships, and revisions. These report results are displayed in Microsoft 
Excel and can be manipulated using Excel’s charting capabilities.
You begin by creating one or more filters. A filter creates criteria for retrieving 
requirement information. For example, you would use an Attribute Count 
Filter to determine how many requirements in the project have a priority with 
the value “High”. You then combine one or more filters to produce a query. A 
query combines the criteria from multiple filters to analyze requirements. The 
filters that compose a query are joined with the AND statement. Finally, you 
combine one or more queries to produce a report.
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There are two types of reports that are available in Requirement Metrics:
• A static report uses static filters and shows results about the project at the 

present time. 
• A trend analysis report uses time-sensitive filters that analyze changes in 

requirement text, attributes, traceability, and hierarchical relationships. 
Trend analysis reports require that you specify an increment for displaying 
revisions.

Access Requirement Metrics with the Tools > Metrics command on the Tool 
Palette.
For more information, refer to Using Requirement Metrics on page 14-3.
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Working with Discussions
Discussions let you address comments, issues, and questions to a group of 
participants that you define. Discussions can be associated with one or more 
specific requirements, or refer to the project in general. A discussion item is 
either the initial discussion topic or a response. A participant can respond to 
either the initial discussion text or to another response.

Understanding Discussions

Viewing Discussions
All project users can read discussion items in RequisitePro, whether they are 
discussion participants or not. Any participants who have an e-mail address 
specified in their user information can read discussion items via e-mail. See 
Configuring E-mail for Discussions on page 6-2 for more information.
When a user opens a project, RequisitePro displays an icon on the Tool Palette 
status bar to indicate that there are new discussions or responses associated 
with that project or its requirements.

Responding to Discussions
When a user responds to the discussion, the response is added to the project in 
RequisitePro. In addition, the response is sent to all participants who have an 
e-mail address specified in their user information.
If you are the discussion author or a project administrator, you can restrict the 
discussion to participants. In this case, all project users can still read discussion 
items, but only participants can respond to the discussion.
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Configuring E-mail for Discussions
RequisitePro offers the capability of communicating with a group of 
discussion participants regarding comments, issues, and questions related to 
one or more requirements, or related to the project in general. When enabled 
for e-mail, this feature will automatically generate an e-mail copy of any 
discussion item you enter (a new discussion or a reply) and send it to all 
discussion participants with valid e-mail addresses.
Discussion e-mail is enabled and configured in several ways:
• Enter an e-mail address in Project Security on the Project menu.
• Configure an notification e-mail service on the Tools menu.
• Configure participation and notification mail for all users with e-mail 

addresses using the Rational E-mail Reader application.

Entering E-mail Addresses in Project Security
All RequisitePro users can add or edit their own e-mail addresses within 
RequisitePro; however, only project administrators (who have administrator 
permissions) can add or edit other users’ information. 
See the procedure Modifying Your Password, User Name, or E-mail Address 
on page 3-9 for information on entering your own e-mail address in Project 
Security. Administrators can use the same procedure for entering or modifying 
all users’ e-mail addresses.

Configuring Notification E-mail for Discussions
Use the E-mail Setup option to configure an e-mail service for your 
notification e-mail to other discussion participants. When you initiate or reply 
to a discussion item from within the RequisitePro Discussions dialog box, this 
feature automatically sends copies of the discussion items to the RequisitePro 
database and to all participants with a valid e-mail address in their 
RequisitePro user information. 
Note: The E-mail Setup option is not required if your system administrator 

has configured participation and notification e-mail using the 
Rational E-mail Reader. See Configuring E-mail Using the Rational 
E-mail Reader on the following page.
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To configure your notification e-mail:
1. On the Tool Palette, click Tools > E-mail Setup.

The E-mail Setup dialog box appears.
2. Click the Enable E-mail Notification check box to automatically generate 

notification e-mail (messages from you to other discussion group 
participants) when you create or reply to a discussion item in RequisitePro. 
Clear the check box to disable notification e-mail messages.

3. Click the down-arrow at the E-mail Provider field and select the e-mail 
protocol that is used on your LAN:
• SMTP/POP3
• MAPI

4. For SMTP/POP3, type the following:
• your SMTP server name
• your e-mail address, such as “yourname@yourcompany.com”
• your name as it should appear in discussion group notices

5. For MAPI, type your MAPI profile. 
6. Click OK.

Configuring E-mail Using the Rational E-mail Reader
The Rational E-mail Reader offers full e-mail integration with RequisitePro by 
associating an e-mail handler with each RequisitePro project. The Rational E-
mail Reader application allows discussion participants to reply to the 
discussion items using their e-mail, as well as from within RequisitePro. Initial 
discussion items and replies are automatically stored in the RequisitePro 
database and sent to discussion participants via e-mail. Participants can reply 
to the discussion items using their e-mail, as well as from within RequisitePro. 
Discussion participants must have an e-mail address specified in their 
RequisitePro user information in order to receive discussion-related e-mail. 
To configure e-mail using the Rational E-mail Reader, refer to Configuring E-
mail for Discussions in the “Rational RequisitePro Installation” chapter of the 
Rational RequisitePro Installation Guide. This configuration is typically 
performed by a system administrator.
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Creating Discussions
You can create a new discussion at any time.
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears:

2. Click Create. The Discussion Properties dialog box appears:

3. Click the General tab.
4. Enter a subject (required). The subject should be brief, but descriptive 

enough to inform other users of the discussion’s contents.
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5. Enter text. The text you enter will become the first item in the discussion. 
Open the discussion by raising an issue, making a comment, or asking a 
question.

6. Click the Participants tab. Add users and groups. (See Creating and 
Modifying Discussion Participants Information on page 6-15.)

7. Click the Requirements tab and add requirements. (See Creating and 
Modifying a Discussion's Requirement Information on page 6-17.)

Note: If you have filtered or displayed only discussions associated with 
specific requirements, those requirements are automatically listed 
on the Requirements tab. (See Displaying, Filtering, and Sorting 
Discussions on page 6-11.)
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8. Click OK.
The discussion is opened and the message is sent to all participants who 
have an e-mail address specified in their user information. An icon on the 
Tool Palette also notifies users that there is a new discussion associated 
with that project.

Viewing and Modifying Discussion Properties
To view discussion properties:

1.On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears

2. Select a discussion and click the Properties button.
Note: Only the originator of the discussion and an administrator can 

modify a discussion’s properties.
The Discussion Properties dialog box lets you do the following:

• Use the General tab to view the discussion subject and text, or enter 
subject and text when you are creating a new discussion.

• Use the Attributes tab to view the discussion’s author, the date and time 
the discussion was created, and the discussion’s current priority and 
status. Only the priority and status can be modified.

• Use the Participants tab to view or modify listings of the discussion’s 
participants, divided by users and groups, and whether or not the 
discussion is restricted to participants. 

• Use the Requirements tab to determine which requirements are 
associated with a discussion. Note that a discussion does not need to 
address any requirements specifically. However, if a specific 
requirement is addressed, it should be associated using this tab.

Notifying Participants about a New Discussion
When you create a new discussion, you do not have to do anything to notify 
participants about the discussion, provided that you have:

• entered a subject and topic text in the Discussion Properties dialog box 
at the General tab, and

• specified participants in the Discussion Properties dialog box at the 
Participants tab.
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Note: In a new discussion, the discussion author is automatically included 
as a participant.

After you have completed these two tasks and clicked OK in the Discussion 
Properties dialog box, RequisitePro adds the discussion to the project and 
sends an e-mail message to each participant for whom an e-mail address has 
been specified in the participant’s user information. The message contains the 
subject and text you entered at the General tab.
Participants can also read the discussion and its responses in RequisitePro. 
When a user opens a project, RequisitePro displays an icon on the Tool Palette 
to indicate that there are new discussions or responses associated with that 
project and/or its requirements.

Reading Discussions
The Discussions dialog box helps you keep track of which discussion items 
you have read and which you have not.
1. On the Tool Palette, click Project > View Discussions.

(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click a discussion.
An expand/collapse indicator is displayed to the left of discussions with 
responses. Unread discussion items are shown as bold text. Items you have 
read are shown as normal text.

3. Click an item to read it. The item’s text displays in the lower portion of the 
dialog box.
After approximately 5 seconds, RequisitePro changes the item from bold 
to normal text, indicating that it has been read. If you select another item 
before approximately 5 seconds elapse, RequisitePro leaves the previously 
selected item bold, indicating that it is still unread.

4. To manually mark an item as read or unread, right-click the item and select 
Mark Read or Mark Unread on the shortcut menu that appears.
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Responding to Discussions
You can respond to a discussion either in RequisitePro or in your e-mail 
application. 
Note: If you are not a discussion participant, you can respond to the 

discussion only if the Restrict To Participants check box is cleared 
in the Discussion Properties dialog box at the Participants tab. Only 
the discussion author and members of the Administrators group can 
modify this option.

Responding to Discussions in RequisitePro
To respond to a discussion using the Discussions dialog box in RequisitePro:
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears:

2. In the discussions list, click a discussion or response to a discussion.
The discussion text appears in the lower portion of the Discussions dialog 
box.

3. Click Reply. 
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The Discussion Response dialog box appears:

The default subject is “RE: [previous discussion item's subject].” You can 
change the subject.

4. Enter the text of your response. 
The text automatically wraps at the end of each line you type. You can use 
Ctrl-C to copy selected text from another application or document, and 
Ctrl-V to paste it into the response text box. Text formatting, such as bold 
and underline, is not available in the Discussion Response dialog box. 
You cannot attach files to the response.

5. Click OK. The Discussions dialog box is displayed again. RequisitePro 
updates the associated project and discussion, and then sends your 
response to all participants who have an e-mail address specified in their 
user information.

Responding to Discussions Using E-mail
You can respond to a discussion using your e-mail application. Depending on 
whether your system administrator has enabled participation e-mail using the 
Rational E-mail Reader, one of two conditions apply:
• If participation e-mail is enabled, your reply is delivered to all discussion 

participants and stored in the RequisitePro database. It is then accessible 
from within RequisitePro. 

• If participation e-mail is not configured, your reply is delivered to the 
recipients you select, but it is not stored in the RequisitePro database.
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To respond to a discussion using your e-mail application:
1. In your e-mail application, open the message containing the discussion 

item to which you wish to reply.
2. Select the reply option.
3. Use the default recipient provided.

Note: If participation e-mail is enabled, messages will arrive from an e-
mail handler that is specific to a RequisitePro project. In this case, 
simply reply to the sender. If participation e-mail is not enabled, 
you can reply to all recipients; however, in this case, your 
message will not be stored in the RequisitePro discussion. You 
can add recipients in either case.

4. Use the default subject provided. Do not modify the subject.
5. Enter the text of your response. Do not type below the line: “Text below 

this line is not included in the discussion response.” In addition, do not 
delete this line or anything below it.
RequisitePro uses this line to indicate which text is your response and 
which text is already included in the discussion. If you delete the line, your 
reply includes both your new text and any text that was below the deleted 
line.
Note: Attachments are not supported in discussions. Any attachments 

you include will not be added to the discussion in the 
RequisitePro database.

6. Send the e-mail message. The message is sent to RequisitePro, which 
updates the associated project and discussion, and then sends your 
response to all participants who have e-mail.
Note: Discussion replies cannot be modified after they have been sent. 

This prevents conflicts when the reply text is included in another 
reply. If you want to add an explanation regarding your message, 
you can do so by creating another reply.
6-10



Displaying, Filtering, and Sorting Discussions
Displaying, Filtering, and Sorting Discussions

Displaying Discussions Associated with a Single Requirement
You can open the Discussions dialog box to display only the discussions 
associated with a specific requirement. Or, you can open the Discussions 
dialog box to display all open discussions.
To display only discussions associated with a requirement:
1. Select a requirement.
2. Open a discussion.

• In the Views Workplace, select a requirement and then do one of the 
following:

• Click Requirement > Discussions.

• Click the Discussions icon to the right of the requirement.
• Right-click the requirement, and then click Discussions in the 

shortcut menu that appears.
• In the Word Workplace, select a requirement and then do one of the 

following:
• Click RequisitePro > Requirement > Discussions.
• Click Requirement > Discussions on the Tool Palette.

3. The Discussions dialog box appears, showing only those discussions 
associated with the specified requirement.

Note: To display all discussions, do one of the following:
• click Filter, clear the Requirement check box, and then click OK, or
• close the dialog box, and click Project > View Discussions on the Tool 

Palette.
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Filtering Discussions
You can specify which discussions you wish to view in the Discussions dialog 
box, based on text, requirement, users, priority, and status.
To filter discussions, do the following:
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears, showing all open discussions:

2. Click Filter. The Discussion Filter dialog box appears:

3. To display discussions containing specific text in their subjects, select the 
Subject Text check box, and then enter the text in the text box.
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Use % in the text if you want RequisitePro to find discussions using the 
wildcard character % to match one or more characters in the search text. 
For example, if this check box is selected and you enter the text 
%document%, RequisitePro finds discussions containing document, 
documents, documented, undocumented, etc.

4. To display discussions with which one or more requirements are 
associated, mark the Requirement check box, and then enter the 
requirements by which you wish to filter (separated by commas) in the text 
box. For example, enter PR1, SR22, TST114 to include all discussions 
with which the requirements PR1, SR22, or TST114 are associated.
Note: Alternatively, click the adjacent ... button to open the Select 

Requirements dialog box, which you can use to select 
requirements by name.

5. To display discussions for which a particular user is a participant, select 
the Participant check box, and then select the desired user name in the list.
Note: You can select the name of a user who is a member of a group. 

RequisitePro will find discussions for which that group’s 
members are participants, including the selected user.

6. To display discussions with a specific priority, select the Priority check 
box, and then select High, Medium, or Low in the list. 

7. To display open or closed discussions, select the Status check box, and 
then select Open or Closed in the list.

8. Filter by more than one option by repeating any of steps 3 - 7 above.
9. Click OK.

The Discussions dialog box is displayed again, showing only the 
discussions that match the filters set above. The filter settings are displayed 
next to the Filter button in the dialog box.
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Sorting Discussions
In the Discussions dialog box, you can change the sort order in which 
discussions appear.
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click the column heading by which you want to sort 
the discussions.
For example, to sort discussions alphabetically by subject, click the 
Subject column heading.

3. To reverse the sort order, click the column heading again.

Printing Discussions
You can print discussion items. The printout shows the discussion item’s 
subject, text, author, and creation date and time. The printout also shows 
information about the associated discussion, including the discussion’s 
priority, status, requirements, and participants.
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click one or more discussion items. (Use a multiple 
select action to select more than one item.)

3. Click the Print button. A Print dialog box appears.
4. Click OK.

Modifying Discussions

Viewing and Modifying Discussion Attributes
The Attributes tab in the Discussion Properties dialog box shows the 
discussion’s author, the date and time the discussion was created, and its 
current priority and status. These properties can be modified by the discussion 
author and project administrators only.
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To modify discussion attributes:
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears.

2. Select a discussion, and then click Properties.
Alternatively, click Create to create a new discussion.

3. Click the Attributes tab.
4. Click the down arrow at the Priority field and select a priority from the 

drop-down list.
Note: You can only change a discussion’s priority if the discussion is 

open.
5. If you are modifying a discussion, change Status to Open or Closed. (You 

cannot change the status of a new discussion.)

Creating and Modifying Discussion Participants Information
The Discussion Properties dialog box, Participants tab lets you determine 
which users and groups are included in the discussion, and whether or not the 
discussion is restricted to participants. 
Any user can view the Participants tab, but only the discussion author and 
project administrators can modify its options, with the following two 
exceptions:

• If the Restrict To Participants check box is cleared, you can add 
yourself to the Users list.

• Regardless of whether or not the Restrict To Participants check box is 
selected, you can remove yourself from the Users list. 

Note: However, if you are a member of a group that participates in the 
discussion, you cannot remove yourself from the group. A 
RequisitePro administrator must remove you from the group.

The options in this dialog box can be modified only if the discussion is open.
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To modify participants information:
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click an open discussion and click Properties; or 
click Create to create a new discussion. The Discussion Properties dialog 
box appears:

3. Click the Participants tab.
4. To add a user, click Add below the Users list. The Project Users dialog 

box appears:

5. Select a user from the list, then click OK. (Use a multiple select action to 
select more than one user.)
Note: For a new discussion, the discussion author is automatically 

included as a participant.
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6. To add a group, click Add below the Groups list. The Project Groups 
dialog box appears:

7. Select a group from the list, then click OK. (Use a multiple select action to 
select more than one group.)
Note: If a user is a member of a group and you add the group to the 

Groups list, you do not need to add the user individually to the 
Users list.

8. To remove users, click the user names in the Users list, then click Remove 
below the Users list.

9. To remove groups, click the group names in the Groups list, then click 
Remove below the Groups list.

10. To restrict the discussion to participants only, select the Restrict To 
Participants check box. Only participants will be able to respond to the 
discussion, although all users can read it in RequisitePro.

11. Click OK to close the dialog box.

Creating and Modifying a Discussion's Requirement 
Information

The Discussion Properties dialog box, Requirements tab lets you determine 
which requirements are associated with a discussion. Note that a discussion 
does not need to address any requirement specifically. However, if a specific 
requirement is addressed, it should be associated using this tab.
Any user can view the Requirements tab, but only the discussion author and 
members of the Administrators group can modify its options. The options in 
this dialog box can be modified only if the discussion is open.
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To modify a discussion’s requirement information:
1. On the Tool Palette, click Project > View Discussions

(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, select an open discussion and click Properties, or 
click Create to create a new discussion. The Discussion Properties dialog 
box appears.

3. Click the Requirements tab.
4. To add a requirement, click Add. 

The Select Requirements dialog box appears:

5. Select a requirement type from the Requirements of type list.
Note: Requirements with pending tag numbers do not appear in this list. 

6. Select a location from the “Located in” list.
7. Select a requirement from the list. (Use a multiple select action to select 

multiple requirements.) 
8. To locate a specific requirement, click Find.
9. When you have finished selecting requirements, click OK. 
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The Discussion Properties dialog box reappears with the specified 
requirement shown in the Associated Requirements list:

10. To remove a requirement, click the requirement in the Associated 
Requirements list, then click Remove.

11. To display a requirement’s properties, click Properties. The Requirement 
Properties dialog box appears, showing the selected requirement's 
properties. 

12. Click OK. To close the Discussion Properties dialog box, click OK.

Creating and Modifying a Requirement’s Discussion 
Information

You can view and create discussions from within the Requirement Properties 
dialog box at the Discussions tab.
1. Do one of the following to open the Requirement Properties dialog box:

• In the Word Workplace, select the requirement in an opened document 
and click RequisitePro > Requirement > Properties.

• In the Word Workplace, select the requirement in an opened document. 
On the Tool Palette, click Requirement > Properties.

• In the Views Workplace, select the requirement in a view. Click 
Requirement > Properties.

2. Click the Discussions tab. A list of all discussions associated with the 
requirement is displayed.

3. To create a new discussion associated with this requirement, click Create.
4. To read a discussion item, select the discussion, and then click View.
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5. To view the properties for a selected discussion, select the discussion and 
click Properties.

Note: If the requirement is not saved in the database yet, the Create, View, 
and Properties buttons are disabled, regardless of how you accessed 
the Requirement Properties dialog box. Save the document containing 
the requirement, then open the dialog box again.

Closing Discussions
If you are the discussion author or a project administrator, you can close a 
discussion if it is no longer needed. Closed discussions are filtered out of the 
Discussions dialog box by default. A discussion must be closed before you can 
delete it.
1. On the Tool Palette, click Project > View Discussions

(or click the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click the open discussion.
3. Click Properties. The Discussion Properties dialog box appears.
4. Click the Attributes tab.
5. Click the down arrow at the Status field and select Closed from the

drop-down list.
6. Click OK. The Discussions dialog box reappears. When the discussion is 

selected, the Delete button is enabled, indicating that the discussion is 
closed and can be deleted.

Deleting Closed Discussions
If you are the discussion author or a project administrator, you can delete a 
closed discussion. A discussion must be closed before you can delete it.
1. On the Tool Palette, click Project > View Discussions

(or click the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click a closed discussion.
3. Click Delete. A message appears, asking you to confirm the deletion.
4. Click Yes.
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Working with Documents
A RequisitePro requirements document is a Microsoft Word file created in 
RequisitePro and integrated with the project database. Requirements created 
outside of a project document can be imported or copied into a project 
document. 
When you create a new project document, RequisitePro associates the 
document with the project that is open. This association is used to update the 
database and synchronize the revision numbering of the project and document. 
The document’s name, location, document type, and revision information are 
stored in the project database. 

Creating a Project Document
To create a document in a project:
1. On the Tool Palette, click Document > New; or 

in the Word Workplace, click RequisitePro > Document > New.
The Document Properties dialog box appears:
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2. Type the name of the document in the Name field (64 characters 
maximum).

3. Type a a brief description of the document’s purpose or contents in the 
Description field. 

4. In the Filename field, enter, modify or view the name of the document. 
The file name defaults to be the same as the name you typed above in step 
2. You do not need to give it an extension; RequisitePro assigns an 
extension according to the Document Type selected.

5. Click the Show Tags check box to display requirement tags in the new 
document. Clear this box to hide the tag text. 
Selecting this check box sets options in Microsoft Word to ensure that the 
requirement tags are visible both on your display and in the printed 
document. The check box “Hidden Text” is marked in both the View tab 
and the Print tab in the Microsoft Word Tools > Options dialog box.

6. Type a location for the file in the Directory field, or click Browse to select 
a directory.

7. Click the down arrow at the Document Type list and select a document 
type to assign to the new document.

8. Click OK. The new document is open and ready to be edited.
Note: The document must be saved for the requirements to be 

committed to the database.

Saving a Project Document
When a document is saved in RequisitePro, all modifications to the document 
properties, such as its logical name, revision number, label and change 
description, are saved to the project database. New requirements and changes 
made to existing requirements are committed to the database and are retained 
in the document. Requirements that were deleted from the document are 
deleted from the database.
To save a project document:
1. Do one of the following:

• click the Save the current document button on the Tool Palette; or
• click Document > Save on the Tool Palette; or 
• in the Word Workplace, click RequisitePro > Document > Save.
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Opening a Document After a Project is Open
If a requirement in the document was modified, the Change Description 
dialog box appears and prompts you to type a reason for the change:

2. Type an explanation of the modifications in the Change Description field.
3. Click the Apply to all... check box, if the change description applies to all 

requirements that were changed in the document. 
4. Click OK.

Opening a Document After a Project is Open
To open a project document:
1. Do one of the following:

• on the Tool Palette, click the Open a project and documents button, or
• click Document > Open, or
• in the Word Workplace, click RequisitePro > Document > Open.
The Open Project and Documents dialog box appears.
7-3



Working with Documents
The Open Project and Documents dialog box displays a list of projects 
available in your project list.

Beneath the Projects list box, a second list box displays the documents that 
are associated with project you select. You can click the Properties button 
to view a read-only version of the Document Properties dialog box for the 
selected document in the list.

2. Select a project from the project list. A list of the project’s documents 
appears in the document list. This list includes all documents you have 
either created in the project or imported into the project, regardless of 
whether the documents contain requirements.
Only one project can be open at a time. If you try to open another project 
and its documents while working in a project, RequisitePro prompts you to 
save any modifications, closes the current project and its associated 
documents before opening the new project and documents.

Note: For more information on options for controlling access by other users 
when the project and documents are open, refer to Controlling User 
Access to a Document on page 14-1.

3. Select one or more documents to open and click OK. 
RequisitePro launches Word and opens the documents.
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Closing and Saving a Project Document
To close a project document:
1. On the Tool Palette, click Document > Close, or

in the Word Workplace, click RequisitePro > Document > Close.
If modifications were made to the document that were not saved, the 
Document Changed dialog box appears:

2. Do one of the following:
• To accept the modifications and save the document, click Yes. 
• To abandon the modifications and leave the document as is, click No. 
• To return to the document without closing, click Cancel.
• To review changes to the document, click the Review Changes button. 

The Document Changes dialog box lists changes, as described below.
Note: If you changed one or more requirements in the document, the 

Change Description dialog box appears (whether you selected Yes 
or Review Changes above). You have the option to record reasons 
for changing each requirement.

Reviewing and Changes Before Closing a Document
When closing a document that has been modified, the Document Changed 
dialog box presents you the option of reviewing the changes.
To review modifications to a document:
1. Follow steps 1 and 2 above and click the Review Changes button. 

If you have changed one or more requirements in the document, the 
Change Description dialog box appears. You have the option to record 
reasons for changing each requirement. 
Then the Document Changes dialog box lists all modifications to the 
document. 

2. Click OK to save the changes once you have reviewed them.
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Changing the Location of a Project Document
New documents are stored in the project directory by default. Documents can 
be created in or moved to any directory on the file system. All documents 
associated with the project are included in your project list regardless of where 
they are stored.
To change the location of a project document:
1. On the Tool Palette, click Document > Properties, or

in the Word Workplace, click RequisitePro > Document > Properties.
The Document Properties dialog box appears. On the General tab, the 
document file name and location appear in the Directory edit box.

2. Click Browse to change the location of the file. The Browse for Folder 
dialog box appears:

3. Select a new location for the document. Click a folder to open it.
4. Click OK to accept the location and close the Browse for Folder dialog 

box. 
5. Click OK to close the Document Properties dialog box.
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Modifying Document Information
To modify information in an open project document:
1. Open the Document Properties dialog box, in one of the following ways:

• In the Word Workplace, click RequisitePro > Document > Properties.
• On the Tool Palette, click Document > Properties.

2. Modify the document’s information:
• On the General tab, you can change the name of the document, its 

description, and the directory in which it is stored. You cannot change 
its logical name or its document type.

• On the Revision tab, you can enter a Change description. All other fields 
are populated by RequisitePro.

3. Click OK to close the Document Properties dialog box. 
4. To save your changes to the document, do one of the following:

• In the Word Workplace, click RequisitePro > Document >Save.
• On the Tool Palette, click Document >Save. 

Working With Microsoft Word

Saving a RequisitePro Document as a Word Document
RequisitePro includes an option to save a project document as a Microsoft 
Word document that is independent of the project. This allows you to attach 
the document to e-mail or share the document with someone outside of your 
work group. 
When you choose this option, RequisitePro makes a copy of the active 
requirements document and saves it as a Word file. The resulting Word 
document retains the look and feel of the original requirements document and 
even includes bookmarks and tags used by RequisitePro to identify 
requirements.
To save a project document as a Word document:
1. Do one of the following to open the Save As dialog box:

• On the Tool Palette, click Document > Save As.
• In the Word Workplace, click RequisitePro > Document > Save As.
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2. Specify a destination for the new copy of the document. 
3. Accept the default name in the File name field, or type a file name and .doc 

extension for the document.
4. Click Save.

Managing Microsoft Word Documents
While working in RequisitePro, you can create, open, modify, save, and close 
Word documents that are independent from RequisitePro. Use the standard 
File menu commands to manage these Word documents (The Save As and Exit 
commands are disabled in the Word Workplace in order to prevent conflicts in 
handling RequisitePro documents).
Note: RequisitePro documents are associated with projects, managed from 

the Document menu on the Tool Palette or the RequisitePro menu in 
the Word Workplace, and saved in RequisitePro format by default.

Closing Microsoft Word
To close Word without closing RequisitePro, click the Window menu on the 
Tool Palette and choose Close Word.

Tips for Using Word in RequisitePro

Do Not Use
Do not use the Microsoft Word File > Versions feature. The Word logic of 
identifying a base version with subsequent revisions conflicts with 
RequisitePro’s document revision history features. Version changes in Word 
can conflict with the RequisitePro requirements database. In addition, multiple 
versions greatly increase your document file size.
Do not use the Cut command in Microsoft Word to cut requirement text. When 
you use the Word Cut command, it is possible the requirement could be deleted 
from the project. In addition, if you cut a requirement from a document using 
the Cut command in Word, you cannot paste the requirement into the project 
database.
Do not use the fast saves option in Word. Remove the check mark in the Allow 
fast saves check box in Microsoft Word’s Options dialog box.
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Use With Caution
While you can use Word’s automatic paragraph numbering (the Format > 
Bullets and Numbering command) within requirement text in a requirements 
document, this feature can produce inconvenient and unexpected results. 
Automatic numbering changes caused by the addition or deletion of 
paragraphs require you to confirm changes to all subsequent numbered 
requirements in the document. This also adds a revision history entry for each 
requirement, resulting in cluttered revision history list. Changes in 
autonumbering can also impact the requirement tag numbering.
If you are using Word 2000 and choose to clear the Trust all installed add-ins 
and templates check box on the Tools > Macro > Security dialog box, you 
must click Enable at the Microsoft Word message box each time you open the 
RequisitePro Word Workplace.

Improving Word Performance
The following tips can improved Microsoft Word's performance with 
RequisitePro documents:
• Create small RequisitePro documents. Since large documents can take 

significant time to open, close and manipulate, documents less than 5 MB 
or about 50 pages are optimal. 

• View documents in Normal mode. Documents in Page Layout mode are 
constantly being repaginated.

• Open documents selectively. Many Word documents open at once 
decreases performance.

Working with Word Styles
If you press Enter after a marked requirement in a document, the requirement 
style (such as double underline) and color are carried to the next line. Press 
Ctrl and the Spacebar before typing, and the Word style is reset to Normal.

Using Word Options for “Hidden” Requirements
You can set options in the Microsoft Word Tools > Options dialog box to 
affect how requirements are displayed in RequisitePro documents:
• If you clear the Bookmarks check box, you will not see the bookmarks 

around the requirement in RequisitePro documents.
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• The requirement tag in a RequisitePro document is hidden text in 
Microsoft Word. If you clear the Hidden text check box, you will not see 
the tag in the text of the requirement in the RequisitePro document. 

Note: When editing a RequisitePro document offline, note that Microsoft 
Word turns off the bookmarks and hidden text features by default. 
Before editing the requirement text in an offline document, we 
recommend marking the hidden text and bookmarks for display.

For information about setting color and style for requirements, refer to the 
Creating and Modifying Requirement Types on page 15-7.

Editing a Requirements Document Outside of RequisitePro
To edit a document in Word outside of RequisitePro and merge it back in later, 
use RequisitePro’s offline authoring feature rather than the Save As command.

Creating a Word Document from a RequisitePro 
Requirements Document
Use the Document > Save As command to save a copy of your requirements 
document with a .doc file extension. The resulting Word document will not 
appear in the project documents list.

Managing External Word Documents
To manage a Microsoft Word document that is not part of a RequisitePro 
project, use the File menu commands in the Word Workplace.

Disabled Word Commands
The File > Save As and File > Exit commands are disabled in the Word 
Workplace in order to prevent conflicts in handling RequisitePro documents. 
On the RequisitePro Tool Palette, use the Window > Close Word command 
to close the Word Workplace.
The Tools > Templates and Addins command is disabled to prevent deletion 
of the RequisitePro template, which is required for proper functioning of 
RequisitePro.
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Working With Documents Offline 
Offline authoring lets requirements authors and project administrators use a 
document outside of RequisitePro (i.e., offline).
When you take a document offline, RequisitePro creates a copy of the 
document in the directory you specify. The original is still stored in 
RequisitePro, but it is changed to a read-only document. Other users can view 
the document in RequisitePro, but they cannot edit it until you bring it back 
online.
When you take a document offline, RequisitePro includes Microsoft Word 
macros in the document. These macros allow you to add and delete 
requirements in the offline document.
Note: In Word 2000, you may need to adjust your macro security levels to 

use the Requirement > Create and Delete menu commands in offline 
authoring. Word 2000 defaults to the highest level for macro security. 
This setting prevents the enabling of the RequisitePro offline 
authoring macros. Reset the macro security in Word 2000 to medium 
on the Security dialog box, which is available by clicking Tools > 
Macro > Security.

Do not rename documents while they are offline. The original file name is 
necessary for recognizing the offline document within RequisitePro. When 
you bring the document back online, RequisitePro replaces the read-only 
document with the modified document. Alternatively, you can elect to cancel 
the offline process. In this case, RequisitePro restores the original document, 
removing its read-only state, so all requirements authors and members of the 
Administrators group can again modify it within RequisitePro.

Taking Documents Offline
Before taking a document offline, make sure all changes made to requirement 
text outside the document (such as in the Attribute Matrix, or in RequisiteWeb) 
have been saved in the document.
1. To take a document offline, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents.

• Or, on the Tool Palette, click Document > Offline Documents.
2.  In the Display Types list, select a document type.
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3. Click the document you want to take offline. (Use a multiple select action 
to select more than one document.)

4. Click Take Offline. 
The Take Offline Information dialog box appears:

5. In the Reason text box, type a reason for taking the document offline.
6. In the Location field, enter the directory path where you want to store the 

document. Or, click Browse to locate the directory.
7. Click OK. 

Determining Whether a Document is Offline
To check whether a document is offline:
• Open the Open Project and Documents dialog box:

• On Tool Palette, click Document > Open; or
• In the Word Workplace, click RequisitePro > Document > Open.

• In the Select Documents list, offline documents are followed by the word 
“(offline).”

To learn more about an offline document:
• Click the document in the Select Documents list, and then click Offline 

Info button.
• The Offline Information dialog box appears, showing the document 

name, the user who took the document offline, offline date and time, 
location, and reason the document was taken offline.
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Modifying Offline Documents
You modify an offline document in the same manner as you would any other 
Microsoft Word document. All Word features and options are available for 
your use when editing a RequisitePro offline document. In addition, you can 
add and delete RequisitePro requirements in an offline document.
When you open the offline document in Word, make sure that you enable the 
Word macros. These macros allows you to add and delete requirements in the 
offline document.
You can modify requirement text in an offline document. When you bring the 
document back online and open it in RequisitePro, RequisitePro prompts you 
to enter a reason for the changes to the requirement text.
Note: Microsoft Word turns off the bookmarks and hidden text features by 

default. Before editing the requirement text in an offline document, 
we recommend marking the hidden text and bookmarks for display. 
Click Tools > Options in Microsoft Word to open the Options dialog 
box, and mark the hidden text and bookmarks check boxes on the 
Views tab.
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Note: Do not rename documents while they are offline. The original file 
name is necessary for recognizing the offline document within 
RequisitePro.

Creating Requirements in Offline Documents
Mark requirement text in an offline document in the same way you would if 
the document were online. The RequisitePro macro stylizes the requirement 
text with a double underline and notifies you that a requirement was created. 
When you bring the document back online, RequisitePro gives the requirement 
a number and default attributes. You can then modify the requirement in the 
Requirement Properties dialog box.
To mark text as a requirement in an offline document:
1. Highlight the information to define the requirement.
2. Click RequisitePro > Requirement > Create. 

Deleting Requirements in Offline Documents
Delete a requirement in an offline document in the same way you would if the 
document were online. When you delete a requirement, RequisitePro does not 
remove the requirement text from the document, but it is no longer recognized 
as a requirement. RequisitePro removes the requirement color and style 
settings and replaces them with the document default style.
When you bring the document back online, RequisitePro notifies you 
regarding the requirements you have deleted, and asks you if you want to 
update the online document with the changes. If you decline, RequisitePro 
does not bring the document back online.
To delete a requirement in an offline document:
1. In the offline document, click anywhere in a requirement.
2. Click RequisitePro > Requirement > Delete (Unmark).
3. To undo a delete operation, click Edit > Undo. Click Undo until the 

requirement is completely restored.
In an offline document, you can delete only one requirement at a time.
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Bringing Offline Documents Back Online
If you are the offline author or an administrator, you can bring an offline 
document back online.
1. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents, or

• On the Tool Palette, click Document > Offline Documents.
The Offline Documents dialog box appears:

2. In the Offline documents list, select the document you want to bring back 
online. (Use a multiple select action to select more than one document.)
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3. Click Bring Online. The Bring Online Information dialog box appears:

4. In the Description of Changes box, enter a description of the changes made 
to the currently selected document while it was offline (if any).

5. If you are bringing multiple documents back online and the changes apply 
to all subsequent documents, select the Apply to All check box.
If you do not select the Apply to All check box, the Bring Online 
Information dialog box appears for each subsequent document you bring 
online in this session, and you must enter changes for each document 
individually. You can select Apply to All for any document you bring 
online in the session to apply the changes to all subsequent documents.
For example, if you are bringing back online four documents named Doc1, 
Doc2, Doc3, and Doc4, and you do not select Apply to All while entering 
information for Doc1, but you do select Apply to All while entering 
information for Doc2, the Bring Online Information dialog box does not 
appear for Doc3 or Doc4.

6. Click OK. 
Note: A Microsoft Word warning message states that the document you are 

bringing online contains macros. Click the Enable Macros button.
If you have deleted requirements in an offline document, RequisitePro 
notifies you how many requirements you have deleted, and asks if you 
want to update the online document with the changes.

7. Click Yes to accept updating the document, or click No to decline updating 
the document.
If you decline updating the document, RequisitePro does not bring the 
document back online.
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Bringing Documents Online Without Saving Changes
If you are the offline author or a member of the Administrators group, you can 
bring a document back online without saving any changes you made while it 
was offline.
1. To open the Offline Documents dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents.

• On the Tool Palette, click Document > Offline Documents.
The Offline Documents dialog box appears.

2. In the Offline documents list, select the document you want to bring back 
online without saving offline changes to them. (Use a multiple select 
action to select more than one document.)

3. Click Cancel Offline. A message appears, asking you to confirm the 
deletion of the offline changes.
If you are bringing multiple documents back online, this message appears 
only once for all documents.

4. Select the Remove offline document files check box to delete the offline 
documents from the directory in which they were stored. 

5. Click Yes. The online version of the documents are restored.
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Reading Offline Documents
You can read a document that another user has taken offline. RequisitePro 
displays the document in read-only mode in the state it was in before the other 
user took it offline.
If you are the offline author or a member of the Administrators group, when 
you open the document in RequisitePro, you can choose to bring it back online 
or open it in the state it was in before it was taken offline.
1. To open the Open Project and Documents dialog box, do one of the 

following:
• On Tool Palette, click Document > Open; or
• In the Word Workplace, click RequisitePro > Document > Open.

2. Click the offline document in the Select Document(s) list that you want to 
open.

3. Click OK. The Offline Document Open dialog box appears, identifying 
the user who took the document offline:

4. Do one of the following:
• If you are the offline author or an administrator, click Bring Online to 

bring the document back online, or Open Read Only to open it in the 
state is was in before you took it offline.

Note: You cannot access the Bring Online button if you are not the 
offline author or an administrator.

• If another user took the document offline, click Open Read Only to 
open the document for reading.
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Using Word Master Documents
Using master documents in Microsoft Word can be very helpful for viewing 
and printing a collection of smaller subdocuments as one document. All 
subdocuments within the master document can be printed with consistent page 
numbering. Master documents are a feature of Microsoft Word. You should 
not attempt to create, import, or manage master documents from within 
RequisitePro.
Consider the following guidelines when using master documents:

• Archive the project before creating subdocuments. (For information on 
archiving projects, refer to Archiving Projects on page 14-9.)

• The master document should not be a RequisitePro document; the 
subdocuments can be RequisitePro documents. This prevents redundant 
requirements and broken traceability links.

• Do not edit requirement text in the subdocuments outside of 
RequisitePro.

• Do not edit the subdocuments in RequisitePro while viewing the master 
document in Microsoft Word. 

To prepare RequisitePro documents to be used as subdocuments, save them in 
Word format:
1. On the Tool Palette, click Project > Properties. 
2. On the General tab of the Project Properties dialog box, clear the check 

box Save documents in Requisite format.
Note: This removes all project security from these requirements documents 

and they can be modified outside RequisitePro, so only clear this 
check box when you are preparing subdocuments for viewing or 
printing from a Microsoft Word master document. 

3. Open and save the documents in the project that you want to use as 
subdocuments. 

Important: After viewing and printing the master document in Microsoft 
Word, open the Project Properties dialog box again and select the check box 
Save documents in Requisite format. Open the subdocuments and save them. 
This reestablishes project security for those documents.
For more information on using master and subdocuments, refer to the 
Microsoft Word documentation. 
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C  H  A  P  T  E  R   8 

Working with Requirements
A requirement is a condition or capability to which your project must conform. 
Requirements are written to be meaningful to the user of the system. Each 
requirement includes visible behavior and benefit. In RequisitePro, 
requirements are located in a requirements document or directly in the 
database. The Word Workplace is used to define requirements, and the Views 
Workplace is used to analyze them, but you can create requirements in either 
workplace.
A requirement’s text, attributes and relationships can be modified in both the 
Views and Word Workplaces. Requirement viewers can read the information 
in context and add information that supports and justifies the requirements.
Using the in-view editing feature, you can edit and create requirements directly 
within an Attribute Matrix view. Simply click on a selected requirement in the 
view to start editing the requirement text in place. You can also create 
requirements from Traceability Tree and Traceability Matrix views using the 
Requirement Properties dialog box.
When you create a requirement in a document, RequisitePro places hidden text 
at the beginning of the description to hold the requirement’s tag. This hidden 
text is underlined with a dotted line. If information is typed in this tag area, it 
is formatted as hidden text and is visible only when Microsoft Word’s Hidden 
Text feature is turned on. To reformat the text to normal, use Word’s Format 
> Font feature. The text of the requirement should be in normal text only.
Extended editing of documents allows you to change requirement text outside 
a document: from a view, from RequisiteWeb, from the RequisitePro 
Extensibility Interface, or from integrated tools. You can update requirement 
text without having to open the document. This allows multiple people to 
simultaneously edit requirements within a single document. All changes are 
tracked in the database.
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Creating Requirements
All requirements that are created in RequisitePro are stored in the project’s 
database. Once created, a requirement can be modified, moved and copied 
within the project and traced to and from other requirements in the same 
project or across projects. 
When a requirement is created, RequisitePro stores the following information 
in the database.
• The requirement’s description. In a document, this may include any 

combination of text, graphics, or OLE objects. In the project database, the 
requirement description is limited to text. 

• Attribute values. 

Creating a Requirement in a Document
When you create a requirement in a document, RequisitePro performs the 
following operations:
• The selected information is bracketed with bookmarks.
• The following information is associated with the new requirement:

• Requirement tag identifier. A requirement tag is comprised of a prefix 
and a number

• Color and style format. If the requirement type has color and style, the 
new requirement is formatted with these settings.

• Requirement attributes. The new requirement is associated with the 
attributes established for the requirement type.

• For hierarchical relationships, the requirement is assigned a parent based 
on the parent you select in the Requirement Properties dialog box, 
Hierarchy tab. (For more information on parent-child relationships, refer 
to Working with Hierarchy on page 9-1.)

Note: The requirement and its attribute values are not saved to the project 
database until you save the document.
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To create a requirement in a document:
1. Open a requirements document and type the text of the requirement in the 

document. 
2. Highlight the information (text, graphics, OLE objects) that will become 

part of the requirement. (If you don’t highlight text, you will be prompted 
to enter text for the requirement.)

3. Do one of the following:
• Click RequisitePro > Requirement > Create in the Word Workplace.
• Click Requirement > Create on the Tool Palette.
• Right-click and select Create Requirement from the shortcut menu.
• Or, click the Create requirement button on the Tool Palette.
The Requirement Properties dialog box appears:

4. Click the down arrow in the Type field and select a requirement type with 
which to associate the requirement. The Tag text at the beginning of the 
requirement text automatically includes the Pending tag. 

5. Click OK.
6. To save your changes, click RequisitePro > Document > Save in the 

Word Workplace or Document > Save on the Tool Palette.
RequisitePro saves the document, updates the database, and assigns a 
requirement number to the requirement (in place of the Pending tag).

Note: If you press Enter after a marked requirement, the requirement style 
(such as double underline) and color are carried to the next line. Press 
Ctrl and the Spacebar before typing, and the Word style is reset to 
Normal.
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Using Fast Create
Use RequisitePro’s Fast Create feature to create a requirement without 
opening the Requirement Properties dialog box. 
1. Highlight the text in the document that will become the requirement.

(If you don’t highlight text, the Requirement Properties dialog box opens. 
Refer to To create a requirement in a document: on page 8-3.)

2. Press the Shift key and click the Create a requirement button on the Tool 
Palette. 
RequisitePro bypasses the Requirement Properties dialog box and creates 
the requirement based on the default requirement type chosen for the 
requirements document.

Creating Multiple Requirements 
Use the Requirement > Block Create command to create multiple 
requirements from a block of selected text in a document. When you select this 
command, the Requirement Block Create wizard guides you through creating 
the requirements step-by-step. You specify the keywords to use for the 
requirements and indicate whether the requirements are in sentences or a 
paragraph.
RequisitePro uses three methods to distinguish individual requirements in the 
highlighted block of text:
• Key words – RequisitePro searches for a specific word, such as “shall” (the 

default), or any word you specify in each sentence or paragraph (according 
to the options you select. 

• Text delimiters – RequisitePro searches for text contained within specific 
text delimiters, such as < >, { }, [ ], BEGINREQ ENDREQ. You can designate 
text to become a requirement by surrounding the text with any delimiters 
you choose. We recommend you use a different character on each end of 
the text, such as open and close brackets [ ]. 

• Word style – RequisitePro searches the text for specified style settings, 
such as “Heading 1” or “Body text” or highlighted text. The styles in your 
current document template are loaded into the Styles box.
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To create multiple requirements from a block of text:
1. Create or open a requirements document and type the text of the 

requirements. 
2. Highlight the information (text, graphics, OLE objects) that will become 

requirements. 
3. On the Tool Palette, click Requirement > Block Create.

The Requirement Block Create dialog box appears.
4. Click the down arrow at the Requirement Type field and select a 

requirement type with which to associate the block of requirements. 
5. Click the Set Defaults button to open the Set Requirement Defaults dialog 

box, where you can enter default attributes, hierarchy, traceability and a 
change description for the requirements you create.

6. Click on one of the following options to indicate a method of 
distinguishing each requirement in the block of text:
• Keywords – Type keywords in the Keywords field and click Add to add 

the keywords to the requirements criteria field. Select the Match case 
check box to make the keyword match the case of the text you enter in 
the Keyword box OR select the Use * as wildcard check box if you want 
to use the * as a wildcard character in the Keyword field.

Note: If you want to create requirements from the selected text for each 
sentence or for each paragraph without parsing based on a 
keyword, enter only an * and mark the Use * as wildcard check 
box.

• Text delimiters – Type a beginning and end delimiter in the indicated 
field and click Add.

• Word styles – Select a style from the styles list and click Add.
Note: The dialog box changes to include specific options for each of the 

above choices.
You can use more than one criteria to differentiate the individual 
requirements. Add keywords, text delimiters, and Word styles to 
the search list by clicking each button in turn. Keep in mind that 
RequisitePro searches the document in the order listed above: 
keywords first, text delimiters second and word styles last.

7. Select a source, sentence or paragraph, from which RequisitePro will 
search for keywords to differentiate the requirements.
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8. When you have finished adding requirements criteria, click Create.
RequisitePro checks the highlighted text for the selected criteria and 
reports any text that matches your criteria in the Requirement Found 
dialog box: 
• Click Yes to accept the proposed requirement.
• Click No to reject the proposed requirement.
• Click Yes to All to accept all proposed requirements.

9. When all proposed requirements have been reviewed, the Status dialog 
box appears.

10. Click Close.

Troubleshooting While Creating Requirements
If you experience problems while creating requirements in a project document, 
check for the following conditions to identify and solve the problem:
• Verify the highlighted selection does not contain hidden text at the 

beginning or the end of the selection. Because RequisitePro uses hidden 
text to delineate requirements, it prevents the creation of a requirement 
with hidden text at its beginning or end.

• Verify the highlighted selection is not inside or overlapping another 
requirement. Requirements cannot be nested or overlap one another.

Creating a Requirement in a View
You can create requirements in any view. In a Traceability Matrix or a 
Traceability Tree, you can enter data in the Requirement Properties dialog box. 
In an Attribute Matrix, you can insert a new requirement directly into the 
matrix and set requirement attributes before saving it.
When you create a requirement in the database, RequisitePro performs the 
following operations:
• The following information is associated with the new requirement:

• Requirement tag identifier. A requirement tag is composed of a prefix 
and a number.

• Requirement attributes. The new requirement is associated with the 
attributes established for the requirement type.
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• Using the Requirement > Create command in a view creates a 
requirement at the root level (it has no parent). To create child or sibling 
requirements, refer to Creating Child Requirements in a View on page 9-2 
and Creating Peer Requirements on page 9-3.

Creating Requirements in a Traceability Tree or Traceability 
Matrix
You create requirements in a Traceability Tree or Traceability Matrix by using 
the Requirement > Create menu command and entering data in the 
Requirement Properties dialog box.
1. In the Views Workplace, open a Traceability Tree of Traceability Matrix 

based on the requirement type for the requirement you want to create.
2. Click Requirement > Create; or

Right-click and select Create from the shortcut menu.

The Requirement Properties dialog box appears: 

RequisitePro populates the Type and Location fields:
• The new requirement inherits the requirement type displayed in the 

view. Select another requirement type from the Type list to change the 
requirement’s type.

• The Location text box indicates the requirement is located in the 
database only and not in a document. 

3. Type the new requirement in the Text box and click OK.
RequisitePro creates a requirement tag based on the requirement type’s 
prefix. A sequential number is assigned to the requirement based on the 
numbering scheme assigned to that requirement type.
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Creating Requirements in an Attribute Matrix
In an Attribute Matrix, you can create a requirement in the database by directly 
inserting the requirement into the matrix.
1. Open an Attribute Matrix based on the requirement type for the 

requirement you want to create.
2. Do one of the following to create a requirement in the matrix:

• Select the last row (marked <click here to create a requirement>) and 
double-click or press the SPACEBAR.

• Click Requirement > Create.
• Press the INSERT key.
The Text Edit drop-down box appears.

Note: The In-view requirements creation (without dialog box) check box 
must be marked in the Options dialog box if you want the 
Requirement > Create and INSERT key options to create 
requirements directly in the matrix in the Text box. Otherwise, the 
Requirement Properties dialog box appears (See page 7).

3. Enter text describing the requirement.
Note: If you are planning to use this project in conjunction with MS Project, 

limit the text description of the requirement to 255 characters; this 
will accommodate the length limitation of a task description in MS 
Project. 

4. Do one of the following to save the information:
• Press the TAB key.
• Click in another cell.
• Press ENTER key (Note: check settings in the Options dialog box. The 

ENTER key inserts new line check box must be cleared if you want to 
use the ENTER key to save requirement information in the Attribute 
Matrix).

RequisitePro creates a new empty row (marked with an * and <click here 
to create a requirement>) below the row you are editing and moves the 
cursor over to the first attribute cell for the new requirement you are 
inserting. A pencil icon appears at the beginning of the row, indicating the 
requirement is in edit mode and changes are not yet saved.

5. Select or enter an attribute, and tab to other attribute columns to make any 
changes from the default attribute values.
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6. Tab to the next row, or click outside the row, when you are finished setting 
information about the new requirement.
RequisitePro creates a new requirement and assigns the next available tag 
to the requirement.

7. Enter data for a new requirement or press ESC to cancel the edit mode in 
the Attribute Matrix.

Revising Requirement Properties
Use the Requirement Properties dialog box to view or modify requirement 
information, including attribute values, traceability relationships, hierarchical 
relationships, discussions, and change descriptions. (For more information, 
refer to Chapter 6: Working with Discussions, Chapter 9: Working with 
Hierarchy, and Chapter 10: Working with Traceability.)

Opening the Requirement Properties Dialog Box
From a requirements document:
1. Place the cursor inside the text of the requirement.
2. Do one of the following to open the Requirement > Properties dialog 

box:
• In the Word Workplace, click RequisitePro > Requirement > 

Properties. 
• Right-click and select Requirement Properties from the shortcut menu.
• On the Tool Palette, click Requirement > Properties. 
• Or, click the Display properties button on the Tool Palette. 

From a view:
1. Click the requirement to highlight it.
2. Do one of the following to open the Requirement Properties dialog box:

• In the Views Workplace, click Requirement > Properties. 
• Right-click and select Properties from the shortcut menu.
• Click the Display properties button on the Views Workplace toolbar.
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Accessing Revision Information
Use the Revision tab in the Requirement Properties dialog box to record and 
monitor revision information about the requirement. 

• RequisitePro automatically generates an internal revision number for the 
requirement in the Revision text box whenever a requirement is 
modified and saved. This text box is read-only.

• If a change has been made, click the Label text box to associate a logical 
name with a revision number. This step is optional. Any specific revision 
can be named in this text box, using any combination of 20 alpha-
numeric characters, such as Beta Release. The label is added to the 
requirement’s change history. Once applied, it cannot be changed or 
removed.

• Use the Change Description text box to record changes made to a 
requirement. This text box can contain up to 2,048 characters. 
This step is optional. 

• The Date, Time, and Author text boxes are populated by RequisitePro 
and cannot be modified.

• Click the History button to display the requirement’s change history.
• Any modifications made to requirements are pending until the document 

is saved. When a requirement is committed to the database, its status 
changes from Proposed changes... to Last Saved. 
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Recording Requirement Changes in Documents
When you modify a requirement’s text in a document, you must describe the 
reason for the change. 
After you have modified the requirement’s text, make sure the cursor is still in 
the requirement and then do the following:
1. To open the Change Description dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > 
Annotate Change.

• On the Tool Palette, click Requirement > Annotate Change.
2. Type the reason for changes.
3. Click OK. 
If you attempt to close a document that contains requirement changes without 
annotating the changes, RequisitePro displays the Change Description dialog 
box, scrolls to the requirement, and prompts you to record a rationale for the 
change. 
8-11



Working with Requirements
Modifying Attribute Values
Attributes and their corresponding list of default values are defined by the 
requirement type of the requirement. Use the Attributes tab in the 
Requirement Properties dialog box to assign values to the attributes for a 
requirement. 
1. Open the Requirement Properties dialog box by following one of the op-

tions on page 8-9.
2. Click the Attributes tab. The attributes for the requirement are displayed.

3. Enter attribute values: 
• For list-type attributes, select a value in the list.
• For entry-type attributes, enter a value in the text box.
Note: To move between fields, use the scroll bar or the Tab key.

4. Click OK.

Modifying Attribute Values from an Attribute Matrix
You can use shortcuts for changing the attribute values or requirement text in 
an Attribute Matrix.
1. In an Attribute Matrix, do one of the following:

• Double-click an attribute value or requirement text.
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Associating Requirements with New Types
(Note: Make sure the Double-click to go to source check box in the 
Options dialog box is cleared if you want this option for editing directly in 
the Attribute Matrix. If the Double-click to go to source check box is 
marked, double-clicking will open the Requirement Properties dialog box 
or a document (if the requirement resides in a document).
• Click an attribute value or requirement text, and then press the 

SPACEBAR.
2. For list-type attributes, select a value in the list. (For multiple value list-

type attributes, select one or more values in the list.)
For entry-type attributes and requirement text, enter data in the text box. 
Note: In order to modify the requirement text, you must open the 

project exclusively and close any open documents that may 
contain the requirements you are editing. The Enable Extended 
Editing of documents check box must be marked in the Project 
Properties dialog box: Documents tab.

3. Press the TAB key to move to other rows that can be edited.
4. To accept the changes, click outside the row or press ENTER.

Note: To cancel the editing process without saving changes, press ESC.
Note: You can also use a multiple select action in an Attribute Matrix to 

select more than one attribute value, and then right-click and select 
Set Value from the shortcut menu. The Set Value dialog box appears, 
allowing you to select a value to use for all selected requirements.

Associating Requirements with New Types
When you change a requirement’s type, several things can happen:
• Any attribute values associated with the requirement will be changed to the 

default attribute values of the new requirement type. 
• If the requirement is a parent, the requirement type is also changed for all 

of its child requirements.
• If the requirement is a child, the requirement is moved to the root for the 

new requirement type, and the requirement no longer has a parent.
For more information on parent and child requirements, see Chapter 9, 
Working with Hierarchy.
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Associating a Single Requirement with a New Type
1. Open the Requirement Properties dialog box by following one of the op-

tions page 9.
2. Click the General tab.
3. Click the down arrow in the Types field and select a new requirement type.

A dialog box appears, explaining the change process.

4. Click Yes. The requirement type is changed in the Requirement Properties 
dialog box.

5. Click OK.

Associating Multiple Requirements with a New Type
When you change the requirement type, several things can happen:
• Any attribute values associated with the requirements will be changed to 

the default attribute values of the new requirement type.
• If the requirements are parents, the requirement type is also changed for all 

of their child requirements.
• If the requirement are children, they are moved to the root for the new 

requirement type, and the requirements no longer have a parent.
Note: Resetting attribute values is a separate procedure after you change the 

requirement type and save the document.
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Associating Requirements with New Types
1. In the Views Workplace, open an Attribute Matrix and use a multiple 
select action to select multiple requirements.
If any of the requirements you want to change are located in documents, 
the documents must be opened in RequisitePro before you begin the 
following procedure.

2. Click Requirement > Change Type.
A dialog box appears, explaining the change process.

3. Click Yes. The Change Requirement Type dialog box appears.
4. In the New Requirement Type list, click the down arrow and select a new 

requirement type.
5. Click OK.
The requirements and their children are removed from the Attribute Matrix. 
When you display a matrix of the new requirement type, the requirements and 
their children are added at the end of the matrix by default. 
For requirements in documents, you must save the open document to commit 
requirements to the database.
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Relocating Requirements
You can move or copy requirements within the same requirements document, 
between documents, and between a document and the database. Requirements 
are moved by using RequisitePro’s Cut, Copy, and Paste commands. 
Caution: Do not use the Microsoft Word Cut, Copy, and Paste commands to 

move requirements. When you use the Word Cut command, it is 
possible the requirement could be deleted from the project. In addition, 
if you cut a requirement from a document using the Cut command in 
Word, you cannot paste the requirement into the project database.

Note: The RequisitePro Cut/Paste commands move the original 
requirements. The Copy/Paste commands create new requirements. 
If pasted in a document, new pending requirements are inserted. If 
pasted in a database, new requirements are created in the database.

Cutting or Copying from a Document 
To cut or copy from a requirements document:
1. Place the cursor in a requirement. 
2. Click Requirement on the Tool Palette, or on the RequisitePro menu in 

the Word Workplace, and click Cut or Copy.
RequisitePro cuts or copies the requirement (and its child requirements) 
from the requirements document.

Pasting the requirement in a document:
You can move or copy the requirement to a new position in the current 
document or to another requirements document.
1. Open or click the destination document and place your cursor in the 

location where you want to paste the requirement.
2. On the Tool Palette, click Requirement > Paste.

RequisitePro inserts the requirement (and its child requirements) in the 
specified location.

Pasting a cut requirement into the database:
You may want to remove a requirement from a document and locate it only in 
the database. You can paste a requirement into an Attribute Matrix view if it is 
based on the same requirement type as the cut requirement. A requirement 
cannot be pasted into a Traceability Matrix or a Traceability Tree view. 
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1. Open or create an Attribute Matrix view based on the same requirement 
type as the cut requirement.

2. In the Views Workplace, click Requirement > Paste. 
RequisitePro pastes the requirements into the database.

Cutting or Copying in a View
In order to move a requirement in the database to a document, you can cut it 
from an Attribute Matrix and paste it into a requirements document.
• Use the RequisitePro Cut command to move a requirement, with all of its 

relationships, into a document.
• Use the RequisitePro Copy command to make a copy of a database 

requirement and paste it into a document. This option creates a new 
requirement when you save the requirements document. Copying a 
requirement duplicates its text and its attributes, but not its traceability 
relationships. 
Note: For hierarchical requirements, RequisitePro copies the 

requirement as a peer requirement at the same level in the parent/
child hierarchy. (For more information, see Working with 
Hierarchy on page 9-1).

To cut or copy a requirement from the database:
1. In the Views Workplace, open an Attribute Matrix containing the 

requirement.
2. Select a requirement that is not already located in a document.

(Use a multiple select action to select multiple requirements.)
3. Click Requirement > Cut or Requirement > Copy.
To paste the requirement into a requirements document:
1. Open the requirements document and click the location to paste the 

requirement.
2. In the Word Workplace, click RequisitePro > Requirement > Paste. Or, 

on the Tool Palette, click Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in the 
specified location.
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Rules for Relocating Requirements
Consider the following rules when moving requirements using the 
RequisitePro Cut, Copy, and Paste commands:

1 If you cut a requirement from a document and do not paste it into the database, it is 
removed from both the document and the database when you save the document.
2 For parent-child requirement hierarchies: When pasting from a document to the 
same document, you can only cut and paste a root requirement or a leaf (the lowest-
level child requirement). When pasting from a document to a different document, you 
can move a root requirement and all its children. For more information about parent-
child requirements, refer to Working with Hierarchy on page 9-1.
3 For parent-child requirement hierarchies: When pasting from the database to a 
document, you can only move a root requirement. For more information about parent-
child requirements, refer to Working with Hierarchy on page 9-1.

• Do not use Microsoft Word’s Cut/Paste commands. We recommend you 
do not use Word’s Cut command to cut requirement text for two reasons. 
The risk of not capturing the entire requirement (including its bookmarks 

Requirement 
Location Function

Requirement Destination

Paste to Database Paste to Document

Document Cut Removes the 
requirement from the 
document but saves 
it in the database.1

Relocates the 
requirement in the 
document.2

Copy Creates a new 
requirement in the 
database.

Creates a new 
requirement in the 
document.

Database Cut Not Applicable Relocates the 
requirement in the 
document.3

Copy Creates a new 
requirement in the 
database.

Creates a new 
requirement in the 
document.3
8-18



Refreshing Requirement Color and Style in a Document
and tag) and accidentally deleting the requirement from the project 
database is greater in Word. In addition, a requirement cannot be moved 
from a document into the project database with Word’s Cut command.

• Using the buffer with the RequisitePro Cut command. Requirements you 
cut using RequisitePro’s Cut command go into a proprietary cut buffer. 
You should paste a requirement to its new location before cutting or 
copying another requirement. If requirements are in the buffer and you cut 
or copy another requirement, the first requirements are placed back in their 
original location in the database. If you want to cut or copy multiple 
requirements, you can do so in the Attribute Matrix only.
Note: The buffer used in RequisitePro is not the Windows Clipboard. 

Any information currently on the Windows Clipboard is 
preserved when you cut or copy a requirement in RequisitePro.

• Avoid losing OLE objects. If you move a requirement that includes an OLE 
object from a requirements document into the project database, the OLE 
object is lost. RequisitePro does not currently support OLE objects in its 
database. Because the loss of the object is considered a change to the 
requirement description, the requirement’s direct traceability relationships 
become suspect.

Refreshing Requirement Color and Style in a 
Document

A specific color and style distinguishes requirements that belong to a specific 
requirement type. For example, you might mark all requirements that belong 
to the requirement type feature with a dark green requirement color and a 
double underline style. This helps you easily recognize all feature 
requirements regardless of their location. Refreshing the color and styles of 
requirements is useful for restoring requirements to their proper state when 
their color and style have been overwritten.
To refresh requirement color and style in a requirements document:
1. Highlight the requirements to refresh. 
2. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Refresh 
Requirements.

• On the Tool Palette, click Document > Refresh Requirements.
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RequisitePro checks the color and style settings of the requirements in the 
document and, if necessary, resets them to the proper settings for the 
requirement type. 

Note: To remove color and styling and convert the requirement back to 
plain text, see Unmarking Requirements in a Document on page 8-22.

Rebuilding Requirement Tags in a Document
When a requirement is created in a document, the requirement information is 
bracketed by bookmarks and assigned a requirement tag. Mark the Show Tags 
check box in the Document Properties dialog box to ensure that the 
requirement tags are visible both on your display and in the printed document.
Tags can be accidentally corrupted or deleted while editing a requirements 
document. Use the Rebuild Tags command to rebuild a requirement tag that 
is partially or completely deleted or corrupted. RequisitePro rebuilds the 
affected tags, then provides a list of rebuilt requirement tags.
To rebuild requirement tags in a document:
1. Highlight the requirement tags to rebuild. 
2. Do one of the following

• In the Word Workplace, click RequisitePro > Document > Rebuild 
Tags.

• On the Tool Palette, click Document > Rebuild Tags.
RequisitePro rebuilds the requirement’s tags.

Renumbering Requirements
Use the Renumber Requirements command to renumber all requirements of 
a specified type in a project. This feature is useful to eliminate the “holes” in a 
numbering scheme that result when you delete or move requirements. You can 
renumber one or several requirement types in one operation. Requirements are 
renumbered in the database and in requirements documents. You can select 
which requirement type you want to renumber and the order in which you want 
the documents processed (Requirements in documents are renumbered in the 
order in which they appear in the document).
The project must be opened in exclusive mode to use this command. If security 
is enabled, you must have project structure permission to renumber 
requirements.
8-20



Renumbering Requirements
To renumber all requirements in a project:
1. On the Tool Palette, click Project > Renumber Requirements.

The Renumber Requirements dialog box appears:

2. In the Requirement Type list, select the requirement type that you want 
to renumber. 

3. Click the Renumber Requirements of this type check box to mark the 
type. 
Note: To renumber requirements of more than one requirement type,

repeat steps 2 and 3.
4. In the Initial Requirement Number text box, enter the initial requirement 

number that you want to set. The default number is 1.
5. To change the order of renumbering for database requirements and 

documents, select Database or a document name. Click the Move Up and 
Move Down buttons to put the database and documents in the order in 
which you want them to be processed. The requirements in the first item 
listed (the database or a document) are renumbered first, followed 
sequentially by the requirements in the second item, and so on. 
Note: A document appears in the Order of Processing list only if it 

contains requirements of the selected type. 
6. Click OK.
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Deleting Requirements
In general, we recommend against deleting any requirements after you archive 
a project, since deleting a requirement deletes the complete information related 
to that requirement including its history.
RequisitePro does provide a Delete Requirement function that should only be 
used prior to archiving a project, when you are getting familiar with the tool. 
Once the project is archived, if a requirement is to be deleted, use a requirement 
attribute (for instance: Deactivated, Retired, or Inactive) to indicate that a 
requirement is no longer valid.
When you delete a requirement that is linked to requirements that reside in 
other projects, the other projects are updated to remove the relationships to/
from the deleted requirement.
Note: Deleting a requirement causes its history and traceability 

relationships to be permanently removed from the project database.

Unmarking Requirements in a Document
You have the option of leaving the text in a document when you delete a 
requirement:
• Use the Delete (Unmark) or Block Delete (Unmark) command to delete 

requirements from the document where they reside and from the project 
database without disrupting the text of the document. The requirement 
text, graphics, or OLE objects are not removed from the document, but 
they are no longer recognized as a requirement. The color and style 
settings of the requirement are removed and replaced with the document 
default style. 

• The Delete (Remove) command deletes the requirement text from the 
requirements document, as well as removing it from the database. 

To unmark a requirement in a document:
1. In the requirements document, click in the requirement text or highlight a 

contiguous block of requirements.
2. Do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > Delete 
(Unmark).

• On the Tool Palette, click Requirement > Delete (Unmark).
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Note: To delete multiple requirements, use the Block Delete (Unmark) 
command.

A message appears, asking you to confirm the deletion.
3. Click Yes. The RequisitePro formatting is removed and the requirement 

text is converted to the default text style.
Note: If you do a Block Delete of a parent requirement with child 

requirements, the Delete Requirement dialog box appears, asking 
what you want to do with the remaining child requirements. If 
you click Cancel, then it cancels the entire Block Delete process.

4. To save your changes, do one of the following:
• In the Word Workplace, click RequisitePro > Document > Save. 
• On the Tool Palette, click Document > Save. 
The requirement is removed from the database.

Note: To undo an unmark operation, use the Edit/Undo option in Word 
repeatedly until the styling, bookmarks and tags reappear.

Deleting Requirements from the Database
You can delete a requirement from the database in the Views Workplace, 
provided the requirement is not located in a document. (Check the Location 
attribute in an Attribute Matrix; requirements have a location listed as 
“Database” or the file name of the requirements document.)
When you delete a requirement that is linked to requirements that reside in 
other projects, the other projects are updated to remove the relationships to/
from the deleted requirement. Unlike cut requirements, which are placed into 
a buffer for pasting within RequisitePro, a deleted requirement is completely 
removed from the database.
Note: Deleting a requirement causes its history and traceability 

relationships to be permanently removed from the project database.
1. In the Views Workplace, open the Attribute Matrix containing the 

requirement.
2. Select the requirement in the matrix. (Use a multiple select action to select 

more than one requirement.)
3. Click Requirement > Delete. A message asks you to confirm the deletion.
4. Click Yes.
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Working with Hierarchy
Hierarchical requirement relationships are parent-child relationships that 
reflect direct dependencies between requirements. In addition, these 
associations provide powerful tools for change management. With hierarchical 
requirements, you can support a requirement with a number of sub-
requirements by establishing a parent requirement and creating child 
requirements of that parent. 
Like traceability relationships (see Working with Traceability on page 10-1), 
hierarchical relationships are a type of change-managed relationship in 
RequisitePro. If a requirement is changed, the relationships with its children 
become suspect. You can view and manage suspect relationships using a 
Traceability Matrix or a Traceability Tree in the Views Workplace.

Creating Child Requirements
A child requirement is any requirement that has a parent. Hierarchical 
relationships are created in a requirements document or in a view. The parent 
and child requirements must both reside in the same document or in no 
documents. The parent requirement and all of its children must be of the same 
requirement type.
These relationships are created using the Hierarchy tab in the Requirement 
Properties dialog box, directly in a requirements document using the 
RequisitePro > Requirement menu commands in the Word Workplace, or 
directly inserted in an Attribute Matrix.
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Creating Child Requirements in a View
1. In the Views Workplace, open the view containing the requirement that 

you intend to be a parent.
2. Click the requirement. (You can only create a child for one requirement at 

a time.)
3. Click Requirement > Create Child.
Note: You cannot create a child in a view if the currently selected 

requirement (which will become the child's parent) is located in a 
document.

In an Attribute Matrix, a new row appears directly following the last 
requirement with the selected parent, and the Text Edit box appears, 
allowing you to add information. See Creating Requirements in an 
Attribute Matrix on page 8-8 for more information.
In a Traceability Matrix and a Traceability Tree, the Requirement 
Properties dialog box appears. Click the following tabs to define the child 
requirement, and enter the appropriate information:
• General 
• Revision 
• Attributes 
• Traceability 
• Discussions
Note in the Hierarchy tab that the parent requirement is pre-defined as the 
requirement you selected in step 2. (If you want to, you can change the 
parent.)

4. Tab to the next row or click outside the row in an Attribute Matrix, or click 
OK in the Requirement Properties dialog box.
RequisitePro creates the child requirement in the database. RequisitePro 
generates a requirement tag for the child requirement based on the parent 
requirement’s number.

Note: After creating child requirements, review saved views to make sure 
both child and parent requirements are displayed. You can modify the 
query on a saved view and mark the Retain Hierarchical Display 
check box to include hierarchical requirements in the view. Then save 
the view again to keep those changes. Refer to Modifying Queries on 
page 5-5.
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Creating Child Requirements in a Document
You can create child requirements in a requirements document by assigning a 
parent. The assignment is committed to the database when the document is 
saved.
1. In a requirements document, highlight the requirement that you intend to 

be a child requirement. 
2. To open the Requirement Properties dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > 
Properties.

• On the Tool Palette, click Requirement > Properties.
• On the Tool Palette, click the Display the properties... button.

3. Click the Hierarchy tab.
4. Select a parent from the Parent list box.

Note: The default is the last parent selected in the document.
5. Click OK. 

The requirement changes to a pending child requirement of the parent you 
selected. 

Note: To save the new parent-child relationship in the database, click 
Document > Save on the Tool Palette or on the RequisitePro menu in 
the Word Workplace. RequisitePro generates a requirement tag for 
the child requirement based on the parent requirement’s number.

Note: After creating child requirements, review saved views to make sure 
both child and parent requirements are displayed. You can modify the 
query on a saved view and mark the Retain Hierarchical Display 
check box to include hierarchical requirements in the view. Then save 
the view again to keep those changes. Refer to Modifying Queries on 
page 5-5.

Creating Peer Requirements
Requirements have a peer relationship when they are at the same level in the 
requirement hierarchy. For example, two requirements are peer requirements 
when they are children of the same parent. All requirements at the root level 
are peer requirements of one another.
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When a requirement is created in a document, it is automatically placed at the 
same level as the requirement above it. Refer to Creating a Requirement in a 
Document on page 8-2. To create peer requirements in a view, refer to the 
following section.

Creating Sibling Requirements in a View
In the Views Workplace (an Attribute Matrix, a Traceability Tree, or a 
Traceability Matrix), the automatic creation of a requirement is at the root 
level. Refer to Creating a Requirement in a View on page 8-6. To create a peer 
requirement of a requirement that has a parent, use the Create Sibling 
command.
To create a sibling requirement:
1. In the Views Workplace, open the view containing the requirement you 

have chosen for a sibling.
2. Select the requirement.
3. Click Requirement > Create Sibling.

Note: You cannot create a sibling in a view if the parent of the siblings 
resides in a document.

In an Attribute Matrix, a new row appears directly following the last 
requirement with the same parent, and the Text Edit box appears, allowing 
you to add information. See Creating Requirements in an Attribute Matrix 
on page 8-8 for more information.
In a Traceability Matrix and a Traceability Tree, the Requirement 
Properties dialog box appears. Click the following tabs to define the child 
requirement, and enter the appropriate information:
• General
• Revision
• Attributes
• Traceability
• Discussions
Note in the Hierarchy tab that the parent requirement is pre-defined as the 
parent of the requirement you selected in step 2. (If you want to, you can 
change the parent.)

4. Tab to the next row or click outside the row in an Attribute Matrix, or click 
OK in the Requirement Properties dialog box.
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Changing Parent Requirements
RequisitePro creates the sibling requirement in the database. RequisitePro 
generates a requirement tag for the new requirement based on the parent 
requirement’s number.
Note: After creating sibling requirements, review saved views to make sure 

both child and parent requirements are displayed. You can modify the 
query on a saved view and mark the Retain Hierarchical Display 
check box to include hierarchical requirements in the view. Then save 
the view again to keep those changes. Refer to Modifying Queries on 
page 5-5.

Changing Parent Requirements
In a requirements document or an Attribute Matrix or Traceability Tree, you 
can assign single or multiple hierarchical requirements to a different parent. 
When you assign a requirement to a new parent, its entire sub-tree of children 
is also moved to that parent.
When children are assigned to a different parent, all hierarchical relationships 
between the new parent and its immediate children are marked suspect. The 
relationships between the children and their children are not marked as suspect. 
(See also Suspect Relationships on page 10-9.)
Note: After creating new child requirements, review saved views to make 

sure both child and parent requirements are displayed. You can 
modify the query on a saved view and mark the Retain Hierarchical 
Display check box to include hierarchical requirements in the view. 
Then save the view again to keep those changes. Refer to Modifying 
Queries on page 5-5.

Assigning a New Parent to a Single Requirement
You can reassociate a hierarchical requirement with a new parent of the same 
requirement type using the Hierarchy tab in the Requirement Properties 
dialog box.
Note: To change parents of requirements located in documents from the 

Views Workplace, the document must be opened (and you must have 
the ability to edit it) before you begin the following procedure.
9-5



Working with Hierarchy
To assign a new parent:
1. Do one of the following:

• In the Word Workplace, click anywhere in the requirement text. Click 
RequisitePro > Requirement > Properties. 

• In the Word Workplace, click anywhere in the requirement text. On the 
Tool Palette, click Requirement > Properties. 

• In the Views Workplace, open a view and select the requirement. From 
the Views Workplace toolbar, click Requirement > Properties.

The Requirement Properties dialog box appears.
2. Click the Hierarchy tab.

3. Select a parent from the Parent list.
4. If the parent is not displayed in the list, select <choose parent...>. 
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Changing Parent Requirements
The Parent Requirement Browser dialog box appears: 

5. Select a parent requirement from the list. To locate a specific requirement, 
click the Find button. 

6. After selecting the parent requirement, click OK.
7. In the Requirement Properties dialog box, click OK.

The requirement changes to a child requirement of the parent you selected. 
New requirement tags are generated for the child requirement and its sub-
tree of children, based on the new parent requirement’s number. 

Note: For requirements in documents, you must save the open document to 
commit requirements to the database.

Assigning a New Parent to Multiple Requirements
In an Attribute Matrix, you can reassociate more than one hierarchical 
requirement with a new parent of the same requirement type. All selected 
requirements are assigned to the same new parent.
Note: If any of the requirements you want to change are in documents, the 
document must be opened (and you must have the ability to edit it) before you 
begin the following procedure.
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To assign a new parent to more than one requirement:
1. In the Views Workplace, open an Attribute Matrix and then select the 

requirements.
2. Click Requirement > Change Parent.

The Select New Parent dialog box appears:

3. In the New Parent list, select a parent.
4. If the parent is not displayed in the list, select <choose parent...>. The 

Parent Requirement Browser dialog box appears, as shown on the 
previous page. 

5. Select a parent requirement from the list. To locate a specific requirement, 
click the Find button. 

6. After selecting the parent requirement, click OK.
7. In the Select New Parent dialog box, click OK.

The requirements become child requirements of the parent you chose. A 
new requirement tag is generated for the child requirements and their sub-
trees of children, based on the new parent requirement’s number. 
Note: For requirements in documents, you must save the open 

document to commit requirements to the database.

Deleting Hierarchical Requirements
In general, we recommend against deleting any requirements after you archive 
a project, since deleting a requirement deletes the complete information related 
to that requirement including its history (Refer to Deleting Requirements on 
page 8-22).
To delete requirements that are located in documents, go to the Word 
Workplace. To delete requirements that are located only in the database, go to 
an Attribute Matrix in the Views Workplace.
When you delete a requirement that is traced to/from requirements that reside 
in other projects, the other projects are updated to remove the relationships.
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Deleting Hierarchical Requirements
Unlike cut requirements, which are placed into a buffer for pasting within 
RequisitePro, a deleted requirement is completely removed from the database.
To delete a hierarchical requirement:
1. Do one of the following:

• In the View Workplace, open the Attribute Matrix and click the 
requirement to delete. (Use a multiple select action to select multiple 
requirements.) Click Requirement > Delete.

• In the Word Workplace, open the document and highlight the 
requirement to delete.
Click RequisitePro > Requirement > Delete (Remove), or 
On the Tool Palette, click Requirement > Delete (Remove).

A dialog box appears, asking you to confirm the deletion.
2. Click Yes to delete the requirement.

If the requirement has children, the Delete Requirement dialog box 
appears:

Note: If you are deleting multiple requirements in the Attribute Matrix, 
the Delete Requirement dialog appears for each parent 
requirement.

3. Do one of the following:
• Select the Delete all child requirements recursively option to delete 

the requirement and all its children. This option removes all traceability 
and hierarchical relationships.

• Or, select the Assign all child requirements to a new parent option to 
delete the requirement and save its children. This option reassigns all 
children to a new parent you select in the list. When the children are 
reassigned, all hierarchical relationships between the new parent and its 
immediate children are marked suspect.

4. When you have made your selection, click OK. 
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If you are working in the Views Workplace, the requirement is deleted 
immediately when you click the Delete button. If you are working in the 
Word Workplace, save the requirements document to commit the deletion 
to the database.

Suspect Relationships
A relationship between requirements becomes questionable or suspect if 
RequisitePro detects a requirement has been modified. In the Views 
Workplace, you can manually mark a hierarchical relationship suspect or clear 
a suspect relationship.
• When you modify a parent requirement, RequisitePro marks the 

relationship between the parent and all its immediate children suspect. 
• When you modify a child requirement, RequisitePro does not mark the 

relationship between the child and its parent suspect, although the child’s 
relationship with other requirements is marked suspect.

• When children are reparented, all hierarchical relationships between the 
new parent and its immediate children are automatically marked suspect. 
The relationships between the children and their children are not marked 
as suspect.

Displaying Suspect Hierarchical Relationships
You can display suspect hierarchical relationships using the Traceability 
Matrix and the Traceability Tree views. In the Views Workplace, the suspect 
relationship is identified by a red diagonal line through the requirement icon. 

Auto Suspect
The Auto Suspect command monitors a requirement’s change history and 
displays a suspect signal when requirements are changed. Use the Project > 
Auto Suspect command to enable or disable automatic checking for changes 
that affect the traceability or hierarchical relationships between requirements 
in the project.
If Auto Suspect is disabled, RequisitePro does not monitor changes in 
requirements, and does not mark relationships as suspect. There are times 
when this mode is desirable. For example, when you are revising spelling 
mistakes in your documents and do not want those revisions to cause your 
relationships to become suspect, you can disable Auto Suspect.
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Suspect Relationships
With Auto Suspect enabled, RequisitePro constantly monitors requirements 
for changes that may affect traceability or hierarchical relationships. If there is 
a change in a requirement, the state of the requirement’s relationships is 
automatically changed to suspect. If you have cross-project traceability active, 
requirements in external projects are also monitored.
Auto Suspect is enabled by default. If you disable Auto Suspect, it is 
automatically re-enabled the next time the project is opened. Or, enable it with 
the Project > Auto Suspect command.

Clearing Suspect Relationships
You can reset a parent-child relationship that has been marked suspect by 
manually clearing it in the Traceability Matrix or Traceability Tree:
1. Do one of the following: 

• In a Traceability Matrix, select one or more intersection points in the 
matrix where a traceability link has been created. 

• In the Traceability Tree, select one or more requirements to modify. 
2. In the Views Workplace, click Requirement > Clear Suspect.
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Working with Traceability
In RequisitePro, traceability is a dependency relationship between two 
requirements. Traceability is a methodical approach to managing change by 
linking requirements that are related to each other.
Like hierarchical relationships (see Working with Hierarchy on page 9-1), 
traceability relationships are change-managed relationships in RequisitePro. If 
either end-point of the connection is changed, the relationship becomes 
suspect.
RequisitePro makes it easy to track changes to a requirement throughout the 
development cycle, so you don’t need to review all your documents 
individually to determine which elements need updating. You can view and 
manage suspect relationships using a Traceability Matrix or a Traceability Tree 
in the Views Workplace.
This chapter addresses traceability between requirements in the same project. 
For information about cross-project traceability, see Setting Up and Modifying 
Cross-Project Traceability on page 15-14.
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Creating Traceability in the Word Workplace
Use the Requirement Properties dialog box or the RequisitePro > 
Requirement menu command in the Word Workplace to trace a requirement 
to or from other requirements in a document. A common traceability 
relationship is one in which one requirement is derived from another.

Creating a Traceability Relationship in a Requirements 
Document

To create a traceability relationship in a requirements document:
1. Place the cursor in the text of the requirement.
2. Open the Requirement Properties dialog box by doing one of the 

following:
• Click RequisitePro > Requirement > Properties in the Word 

Workplace.
• Click Requirement > Properties on the Tool Palette.
• Click the Display properties button on the Tool Palette.

3. Click the Traceabilty tab on the dialog box. 

The From field lists requirements from which the selected requirement is 
traced. The To field list requirements to which the selected requirement is 
traced. An (s) after the requirement tag represents a suspect relationship.

Note: Double-click a requirement to view a read-only version of its dialog 
box.

4. Click the Add button adjacent to the To or From field.
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Creating Traceability in the Word Workplace
The Trace To Requirement or the Trace From Requirement dialog box 
appears.

5. From the Requirements of type list box, select the requirement type with 
which the requirement is associated.

6. If you know the location of the requirement (document or database), select 
it from the Located in list box. If not, select All locations.

7. Highlight a requirement to trace to or trace from in the list box and click 
OK. RequisitePro adds this requirement to the To or From field on the 
Traceability tab.

8. Click OK. 

Creating Traceability Using the Requirements Menu
To create traceability using the Requirements menu:
1. In a requirements document, place the cursor in the text of the requirement.
2. In the Word Workplace, click RequisitePro > Requirement, or on the 

Tool Palette, click Requirement. Then click either the Trace To or the 
Trace From command.
The Trace To Requirement(s) dialog box or the Trace From 
Requirement(s) dialog box appears.
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3. From the Requirements of type list box, select the requirement type with 
which the requirement is associated.

4. Select the location (document or database) of the requirement from the 
Located in list box if you know it, otherwise set the list box to All 
locations.

5. Highlight a requirement to trace to or trace from in the list box and click 
OK. RequisitePro creates a traceability relationship between the two 
requirements.

Creating Traceability in the Views Workplace
You can create traceability relationships in the Attribute Matrix, the 
Traceability Matrix, and the Traceability Tree. (For more information on 
navigating in the Views Workplace, refer back to Working in Views on page 
4-1)

Creating Traceability Relationships in an Attribute Matrix
1. Create an Attribute Matrix, or open an existing one and select a 

requirement.
2. Click Requirement > Properties.

The Requirement Properties dialog box appears.
3. Click the Traceability tab.

4. Click the Add button adjacent to the To or From field. 
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Creating Traceability in the Views Workplace
The Trace To Requirement(s) or the Trace From Requirement(s) 
dialog box appears.

5. From the Requirements of type list box, select the requirement type with 
which the requirement is associated.

6. Select the location (document or database) of the requirement from the 
Located in list box if you know it, otherwise select All locations.

7. Highlight a requirement to trace to or trace from in the list box and click 
OK. RequisitePro adds this requirement to the To or From field on the 
Traceability tab.

8. Click OK on the Requirement Properties dialog box. 

Creating and Deleting Traceability in a Traceability Matrix

To create a traceability relationship:
1. Open a Traceability Matrix and select the cell that intersects the two 

requirements for which you want to create a traceability relationship. (Use 
a multiple select action to select more than one cell.)

2. In the Views Workplace, click Requirement > Trace To or 
Requirement > Trace From.
An arrow displays in the cell, signifying the relationship.

Trace To

Trace From
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To delete the traceability relationship:
1. Highlight the arrow in a Traceability Matrix cell. (Use a multiple select ac-

tion to select multiple cells.)
2. Click Requirement > Delete Trace, or press the Delete key on the 

keyboard. A dialog box appears asking you to confirm the deletion.
3. Click Yes.

To apply traceability to a row or column:
1. Select the rows or columns to fill in a Traceability Matrix. 
2. Click the View menu in the Views Workplace, and then click:

• Select All Rows in Selected Columns, or 
• Select All Columns in Selected Rows.
For example, if you selected a column in step 1, click Select All Rows in 
Selected Columns. All of the rows are selected. The intersection cells of 
the selected column and all of the rows are also selected. 

3. Optionally, use a multiple select action to clear the requirements you do 
not want to assign to the traceability state.

4. Click Requirement > Set Traceability.
The Set Traceability dialog box appears.

5. Select a Traceability Function from the list.
6. Click OK. For lengthy operations, the status bar shows the progress of the 

operation.

Creating Traceability Relationships in the Traceability Tree
There are two methods for creating traceability relationships in the 
Traceability Tree:

• Using drag and drop
• Using Requirement commands
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Drag and Drop
1. Open a Traceability Tree and select the requirements (displayed by their 

tags) to or from which you want to create a traceability relationship. (Use 
a multiple select action to select more than one requirement.)

2. Press the Ctrl key and hold down the right mouse button, dragging up or 
down the Traceability Tree until the cursor is on the requirement with 
which you want to create a traceability relationship to or from the selected 
requirements, and then release the mouse button. A shortcut menu appears.

3. Do one of the following:
• To delete the traceability relationship between the selected requirements 

and the requirements to or from which they were traced, and create a 
traceability relationship between the selected requirements and the 
requirement the cursor was on when you released the mouse button, 
click Move Here.

• To maintain the traceability relationship between the selected 
requirements and the requirements to or from which they were traced, 
and create an additional traceability relationship between the selected 
requirements and the requirement the cursor was on when you released 
the mouse button, click Copy Here.

• To cancel the operation, without moving, deleting, or creating any 
traceability relationships, click Cancel.

Tip: To copy or move a traceability relationship, you can also press the 
Ctrl key (to copy) or the Alt key (to move) and hold down the left mouse 
button, dragging up or down the Traceability Tree until the cursor is on the 
desired requirement, and then releasing the mouse button. Note that if you 
use this method to copy a traceability relationship, you are not given the 
option to cancel before the copy occurs. You are given the option to cancel 
when you use this method to move a traceability relationship.
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Requirements Commands
1. Select the requirements (displayed by their tags) to or from which you 

want to create a traceability relationship. (Use a multiple select action to 
select more than one requirement.)

2. Click Requirement > Trace To or Requirement > Trace From.
(The command available depends on the type of Traceability Tree in the 
active window.) 
The Trace To Requirements or Trace From Requirements dialog box 
appears.

3. Select the requirements in the list. (Use a multiple select action to select 
more than one requirement.)

4. Click OK.

Troubleshooting Failed Multiple Select Actions
In the Views Workplace, when you select more than one relationship or 
requirement in a view, and then perform an operation on the multiple selection 
(such as creating traceability or deleting), the operation may fail for one or 
more requirements or relationships. 
For example, the operation may fail if you do not have rights to perform the 
operation on the requirements or relationships, or if some of the requirements 
are located in documents and the operation is permitted only for requirements 
in the database.
RequisitePro notifies you of such failures, providing an exception log (separate 
from the error log file) that shows the requirements or relationships for which 
the operation failed, and the reason for the failure.
1. In a view, perform the desired operation on a selected group of 

requirements or relationships.
• If the operation is successful, the modifications are shown in the view, 

and no dialog box appears.
• If the operation fails for one or more requirements or relationships, or if 

you stop the operation before it is completed by pressing the Esc key, the 
Exception Report dialog box appears, providing the number of 
requirements or relationships for which the operation failed.

2. Click Details to learn more about the failed operation. The dialog box is 
expanded, showing the reason for the failure.
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3. To copy the text in the text box, select the text and press Ctrl-C. You can 
then paste the text into a text document.

4. Click Close.

Suspect Relationships
A relationship between requirements becomes questionable or suspect if 
RequisitePro detects a requirement has been modified. If a requirement’s text 
is modified, all direct relationships to and from it are suspect. 
You can define attributes that, when modified, cause traceability relationships 
to become suspect. You also can manually mark requirement relationships as 
suspect in the Views Workplace.

Displaying Suspect Traceability Relationships
The suspect state is reflected in the Requirement Properties dialog box as well 
as in views. In the Traceability Tree and Traceability Matrix views, suspect 
traceability relationships are marked as lines through the arrows.  
In an Attribute Matrix, an (s) appears after the requirement tag in the Traced-
to or Traced-from column.
On the Traceability tab of the Requirement Properties dialog box, an (s) 
displayed after the requirement tag in the To and From fields represents a 
suspect relationship. In the Views Workplace, the suspect relationship is 
identified by a red diagonal line through the traceability arrow. 

Auto Suspect
The Auto Suspect command monitors a requirement’s change history and 
displays a suspect signal when requirements are changed. Use the Project > 
Auto Suspect command to enable or disable automatic checking for changes 
that affect the traceability or hierarchical relationships between requirements 
in the project.
If Auto Suspect is disabled, RequisitePro does not monitor changes in 
requirements, and does not mark relationships as suspect. There are times 
when this mode is desirable. For example, when you are revising spelling 
mistakes in your documents and do not want those revisions to cause your 
relationships to become suspect, you can disable Auto Suspect.
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With Auto Suspect enabled, RequisitePro constantly monitors requirements 
for changes that may affect traceability or hierarchical relationships. If there is 
a change in a requirement, the state of the requirement’s relationships is 
automatically changed to suspect. If you have cross-project traceability active, 
requirements in external projects are also monitored.
Auto Suspect is enabled by default. If you disable Auto Suspect, it is 
automatically re-enabled the next time the project is opened. Or, enable it with 
the Project > Auto Suspect command.

Clearing Suspect Traceability Relationships
You can reset a requirement relationship that has been changed to a suspect 
state by manually clearing it. The relationship is reset to its previous state, 
traced to or traced from. Suspect relationships are cleared in the Traceability 
Matrix view or Traceability Tree in the Views workplace.
To clear one or more suspect relationships:
1. Do one of the following: 

• In a Traceability Matrix, select one or more intersection points in the 
matrix where a traceability link has been created. 

• In the Traceability Tree, select one or more requirements to modify. 
2. In the Views Workplace, click Requirement > Clear Suspect.
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Importing Requirements and 
Documents

Use the Import Wizard to import requirements from a Microsoft Word 
document or a comma-separated value (CSV) file into a project. 
The import process is recommended for:
• Importing non-project documents into the active project.
• Importing new requirements into an existing project.
• Updating existing requirement attributes with new information.
The Import Wizard can import requirements and attributes into your project 
from several sources: 
• Requirement documents created in other RequisitePro projects.
• Microsoft Word documents created outside of RequisitePro.
• Any database that supports export of data in CSV format, such as SQL 

Server, Oracle, Excel, or Access.

Before You Begin

Project Setup
You will be importing an external document or CSV file into a RequisitePro 
project. If the project administrator has not already set up a project, you will 
need to create one now (refer to Creating Projects on page 12-1). Minimally, 
the project must have at least one requirement type and one document type 
defined.
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Importing Requirements and Documents
Import Logs
RequisitePro creates a log file each time you import a file. The log file is a 
written record of the import process. The log file records these operations: 
matching of requirement types, how conflicts were resolved, attribute 
mappings, the success or failure of search criteria, canceled operations, value 
errors, and whether or not the import was successful. The log file is saved in 
the directory where the project is stored, and is named import#.log, where # is 
a number representing sequential order of creation. If a log file is deleted, the 
next one created will receive the old number to fill in the gap.

Importing RequisitePro Documents
To successfully import RequisitePro documents from one project to another, 
you must first save the documents in Microsoft Word format. The resulting 
Word document retains the appearance of the original requirements document, 
including the bookmarks and tags that are used in RequisitePro.

About RequisitePro format
When the Save documents in RequisitePro format check box on the 
Documents tab of the Project Properties dialog box is marked, all documents 
within the project will be saved in RequisitePro format. 
Documents saved in RequisitePro format cannot be modified and saved in 
Word outside of RequisitePro. This allows RequisitePro projects to be secure. 
When this option is cleared, documents will be saved in Word format. 
Documents that are saved in Word format can be modified in Word outside of 
RequisitePro, and are not secure. 
To ensure that the documents are once again brought under RequisitePro 
control after they are imported into a new project, mark the Save documents 
in RequisitePro format check box on the Project Properties dialog box for 
that project. If security is not an issue for a particular project, you can clear the 
check box.
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Importing RequisitePro Documents
Converting All the Documents in a Project to Word
If you want to import all the documents from one project into another, they can 
all be converted to Microsoft Word format at once.
To convert all documents to Word at once:
1. Open the project.
2. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears.
3. On the Documents tab, clear the Save documents in RequisitePro 

format check box.

4. Click OK. When the project is closed, all documents will be converted to 
Word format, but will remain in the RequisitePro system. The documents 
will retain their RequisitePro extensions.

The newly formatted documents are ready to import into another project. 
Follow the instructions in Importing from Word on page 11-5.
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Converting an Individual Document to Word
To import a single document from an existing project:
1. Open the project:

• On the Tool Palette, click Project > Open.
• Or, click the Open project button.
The Open Project and Documents dialog box appears:

2. Select a project and document and click OK. RequisitePro opens the 
document.

3. On the Document menu, click Save As. The Document Save As dialog 
box displays the file name with its extension changed to .doc:

4. Click Save. The document is converted from RequisitePro format to Word 
format.
The file management system automatically saves the new Word document 
(*.doc) into the same folder as the project.

The new Word document is ready to import into another project. Follow the 
instructions in the Importing from Word section, beginning on page 11-5.
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Importing from Word
Saving or Removing Bookmarks
Bookmarks in a RequisitePro document are requirement indicators. They 
appear as heavy square brackets, to distinguish them from the square bracket 
character normally found in Microsoft Word. When you create a requirement 
in a RequisitePro document, RequisitePro automatically inserts bookmarks 
that surround and specify the text of the requirement.
When a document is imported, the Import Wizard finds strings of text in the 
document (that is, the Wizard parses the document) and imports them into the 
project as requirements. In the import process, you define the criteria that the 
Wizard uses to parse the text. The criteria can be keywords, text delimiters, or 
Word styles.
If RequisitePro detects bookmarks in the document being imported, the 
Remove Bookmarks information box appears (This information box appears 
after you have responded to the Document Properties dialog box at the 
beginning of a Word import.)

• Click Yes to remove bookmarks and include all the document’s text in 
the parsing process.

• Click No to leave the bookmarks in place. RequisitePro recognizes any 
bookmarks that were previously created in a RequisitePro document and 
brings that text into the new document as new requirements. The 
bookmarked text is ignored in the parsing process.

Importing from Word
Use the Import Wizard to import requirements from a Microsoft Word 
document into a RequisitePro document, or to import a Microsoft Word 
document in its entirety into a RequisitePro project.
The document you are importing must be in Word format. If your document 
was created in an application other than Word, refer to the Microsoft Word 
documentation to save the file in Word format.
Turn off Word’s spelling, grammar and background repagination options (in 
the Options dialog box) before importing a Word document.
Note: If you are importing a Word document that uses a template other than 

Word’s normal.dot template or an existing RequisitePro outline, you 
should set up that template as a RequisitePro outline prior to 
importing the document. RequisitePro will overwrite any 
unrecognized formatting with the normal.dot formatting.
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If you have customized the formatting within the Word document, 
you should save the document as a Word template and copy it to the 
RequisitePro outlines directory. Then create document types based on 
that outline in the project into which you plan to import the document. 
Refer to the Microsoft Word documentation for help in creating Word 
templates. Refer to the RequisitePro online help topic “Creating 
outlines” for help in managing RequisitePro outlines.

Importing Word Documents and Requirements
To use the Import Wizard to import Word documents:
1. On the Tool Palette, click Project > Open.

The Open Project and Documents dialog box appears.
2. Select the project into which you will be importing the Word document.
3. Click the Project menu and choose Import. The Import Wizard opens, 

and the Select a Source screen appears.
4. Select the Microsoft Word Document option.
5. Type the path and name of the Word document you want to import, or click 

Browse to select a file.
The Browse command displays the Open dialog box. Navigate to the 
desired document and click Open. (If the desired document is not found in 
the list, try changing the file type to All files.) The Open dialog box closes 
and the selected document is loaded into the Import Wizard.

6. Click Next to continue. The Select Import Content screen appears.
7. Designate the import content by clicking the appropriate option. Select 

Requirements and document, Requirements only, or Document only.
11-6



Importing from Word
Depending on your choice, you will take one of three paths. The following 
table demonstrates the trade-offs between the different import options: 

Importing Both Requirements and the Document
If you select the Requirements and Document option on the Select Import 
Content screen, the Import Wizard imports the entire document and the 
requirements created by parsing the text. The Word document is imported into 
a new RequisitePro requirements document, and requirements are 
automatically generated in the new document. The Requirements and 
document option works well if your document already contains a well-defined 
requirement structure. The Import Wizard parses the document for 
requirements based on key words, text delimiters, or Word styles.
1. Select the Requirements and Document option on the Select Import 

Content screen and click Next.
The Document Properties dialog box appears.

Requirements 
and Document

Requirements 
only Document only

Requirement 
definition Automatic Automatic Manual

Requirement 
destination New document

Database or
New document or
Existing 
document

New document
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2. Complete the following information:
• Type the document Name (any length up to 64 characters).
• Type the Filename (RequisitePro will assign an extension according to 

the Document Type selected).
• Mark the Show Tags check box if you want to display requirement tags 

in your document.
• Select a Document Type from the list.
• Click the Revision tab to enter a change description or create a user-

defined label (optional). Revision number, date, time, and author are 
generated by the system and cannot be edited here.

3. Click OK to continue.
Note: If the document type you selected is associated with an outline 

(or template) that contains special formatting and text, the 
Outline has text dialog box appears. You must indicate if you 
want to preserve the text and formatting from the outline for 
this document type. Click Yes to retain the style settings and 
text from the document outline. Click No to import the basic 
Word document only.

The Requirement screen appears
4. Select a type for the new requirements in the Requirement Type list.

The Wizard provides a default requirement type by matching it to the 
document type you selected earlier. 
Note: Occasionally, you may want to include requirements of multiple 

types in a single document. For example, any sentence containing 
the word “shall” could become a product requirement, and any 
sentence containing the word “will” could become a software 
requirement. As you create search criteria in the step below, you 
can use the Requirement Type list to select which requirement 
types you want to apply.

5. Click the Set Defaults button to open the Set Requirement Defaults dialog 
box, where you can enter default attributes, hierarchy, traceability and a 
change description for the requirements you create.

6. Mark one of three methods for differentiating or parsing the Word 
document. The Import Wizard finds strings of text in the Word document 
and imports them into the project as requirements.
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• Keywords - Import Wizard searches the Word document for a specific 
word, such as “shall” (the default). Type keywords in the Keywords 
field and click Add to add the keywords to the requirements criteria 
field. Select the Match case check box to make the keyword match the 
case of the text you enter in the Keyword box OR select the Use * as 
wildcard check box if you want to use the * as a wildcard character in 
the Keyword field. Enter the word and click Add.

Note: If you want to create requirements from the selected text for each 
sentence or for each paragraph without parsing based on a 
keyword, enter only an * and mark the Use * as wildcard check 
box

• Text delimiters - Import Wizard searches the Word document for text 
contained within specific text delimiters, such as < >, { }, [ ]. When you 
have entered both the starting and ending delimeters, click Add.

• Word style - Import Wizard searches the Word document for specified 
style settings, such as “Heading 1” or “Body text” or highlighted text. 
Select the appropriate styles and click Add. 

Note: You do not need to limit the search to one criteria only. You can 
add keywords, text delimiters, and Word styles to the search list 
by marking each button in turn. Use Remove to delete a criteria 
from the search list.

7. Click Next to continue.
RequisitePro parses the document using the differentiation methods you 
selected. When a requirement is located, the Requirement found dialog 
box appears.

8. Indicate whether the text found is a valid requirement: Click Yes or No for 
each. Choose Yes to all to automatically accept all requirements found in 
the document.
Each requirement is added to the Requirements to import box on the 
Import Wizard screen. Each new requirement begins with a pending tag, 
followed by the initial text of the requirement.

9. When you are satisfied with your selection, click Next to continue.
The Import Wizard displays the final Status screen.

10. Click Commit to accept the import or click Cancel to cancel the import in 
its entirety.
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Importing Requirements Only
Select Requirements only at the Select Import Content screen if you want to 
extract requirements from a document without importing the rest of the text. If 
your document already contains a well-defined requirement structure such as 
keywords, styles, or delimiters, this option automatically creates your 
requirements during the import process. The Import Wizard parses the 
document for requirements, based on key words, text delimiters, or Word 
styles. It creates requirements from the text it finds and leaves the rest of the 
document behind. You have flexibility in the location of the new requirements. 
You can create requirements in the current project (directly in the database), in 
an existing RequisitePro document, or in a new document. 
1. Select the Requirements only option on the Select Import Content screen 

and click Next. The Select a Destination screen appears.
2. Choose one of the following destinations for the imported requirements:

• Select Current project database to import the requirements into the 
database of the open project.

• Select New RequisitePro document to import the requirements into a 
new document you define. (The Document Properties dialog box 
appears and prompts you for information about the new document before 
proceeding to the next step.)

• Select Existing RequisitePro document to choose from a list of 
existing project documents. (If the document you choose is not already 
open, RequisitePro opens it for you.)

3. Click Next to continue. The Requirement screen appears. 
4. Follows step 4-9 above in Importing Both Requirements and the 

Document.
Note: At step 7, when the Requirements to import dialog box appears, you 

have the following options:
• If you want to read the full text of the requirement, click the View 

button.
• To remove a requirement from the list, select it and click the 

Remove button. (It is saved in an Add requirements box.) Click 
Add to view the box.
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Importing the Document Only
The Import Wizard imports the entire document into a new RequisitePro 
document without parsing the text. Choose Document only if your 
requirement structure is not defined or you want to manually create the 
requirements after importing. No requirements are created during the import 
process. This option gives you the most flexibility in creating requirements in 
documents.
1. Select the Document only option on the Select Import Content screen and 

click Next. The Document Properties dialog box appears. 
2. Complete information about the new document. (See step 2 above in 

Importing Both Requirements and the Document on page 11-7.) 
Note: If the document type you selected is associated with an outline 

(or template) that contains special formatting and text, the 
Outline has text dialog box appears. You must indicate if you 
want to preserve the text and formatting from the outline for 
this document type. Click Yes to retain the style settings and 
text from the document outline. Click No to import the basic 
Word document only.

The Import Wizard displays the final Status screen. 
3. Click Commit to accept the import, or click Cancel to cancel the import 

in its entirety.
Note: If you are importing a RequisitePro document from one project to 

another, this process includes an extra dialog box (Refer to Saving or 
Removing Bookmarks on page 11-5).

Importing a CSV File
RequisitePro can import requirements and attributes into your project from any 
database that supports export of data in CSV format, such as SQL Server, 
Oracle, Excel, or Access.
The CSV import process is recommended for:
• Importing requirements from a non-RequisitePro database into the active 

project.
• Updating existing requirement attributes with new information.
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A CSV (comma-separated value) file is a data file consisting of fields and 
records, stored as text, in which the fields are separated from each other by 
commas. If the data in a field contains a comma, the field is further surrounded 
with quotation marks. Using a comma-delimited file format allows data to be 
shared between database systems that use different formats.

Requirement Numbers
When a new requirement is added to the database, it is assigned a new root 
requirement number. If a requirement has a tag or a number in the external 
CSV file, that number is not preserved. RequisitePro will recognize a 
hierarchical numbering scheme and will import lower-level requirements as 
children of a higher-level requirement.

Requirements in a CSV file are renumbered when they are imported into the project database.

Preparing a CSV File for the Import Wizard
The CSV file and RequisitePro must be configured properly to successfully 
import all information:
• The CSV file must contain a header in RequisitePro format. RequisitePro 

uses the following header format: 
<Tag>, “Requirement text”, <Attribute 1>,<Attribute 2>, <Attribute 3>.
The requirement type specified in the <Tag> field, determines the default 
requirement type that will be assigned during the import process. You can 
change this requirement type assignment in the Import wizard.
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• All attributes that are included in the CSV file must exist in the 
corresponding RequisitePro requirement type in the current project. If the 
attributes don’t match, the default values for the requirement type are 
inserted during the import process. See Creating and Modifying 
Requirement Attributes on page 15-10.

• All list-type attribute values in the CSV file must exactly match the 
predefined list-type attribute values in the RequisitePro requirement type 
definition. Edit the attribute values in the CSV file or modify the list-type 
values in your RequisitePro project. See Working with Requirement 
Attribute Values on page 15-13.
Note: Multiple-value list attributes appear in a CSV file in quotes, 

separated by commas (e.g. “Chris, Sarah, John”).
• If the CSV file contains null values (blank spaces) for any list-type 

requirement attributes, those attributes will be assigned the default value 
as defined in the Project Properties dialog box (Project > Properties). To 
retain a null value, remove the default setting in RequisitePro before 
importing the CSV file. You can reassign the default value after the import 
process is complete.See Working with Requirement Attribute Values on 
page 15-13.

• All requirements in the CSV file will be converted to the requirement type 
specified in the import process (in the header <Tag> field, by default). If 
the CSV file contains requirements with different requirement type tags, 
such as “PR1” and “SR2”, those requirements will be renumbered with the 
assigned requirement tag, and some hierarchical relationships may be lost.

Defining a Header for a CSV File
RequisitePro uses the following header format:
<Tag>, Requirement text, <Attribute 1>,<Attribute 2>, <Attribute 3>...

A sample CSV file with a correctly formatted header row.
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1. To begin creating a header, type a tag that describes a requirement type, 
such as PR, SR, TST, or any other tag you created in your project, followed 
by a comma. The word tag can be added in the header, but is not required. 
For example, SR and SR tag are both acceptable.
• The tag field in the header is used to set the default Requirement Type 

used in the import. If the tag field does not match any requirement type 
in the project, the Match Requirement Type screen appears, prompting 
you to choose one manually.

• The first column in the CSV file must be the tag column. The tag column 
cannot contain any empty cells. If a cell is empty, type in any character 
to fill it.

• If the tag column in the CSV file contains numbers, the numbers will not 
be preserved. Imported requirements will be added to the project’s 
requirements list and renumbered accordingly. Hierarchical 
relationships will be retained.

2. The literal string Requirement text must be the second field of the header, 
followed by a comma.
• The second column in the CSV file must be the text of the requirements.

3. For the remaining fields in the header, type a heading for each column in 
the CSV file, separated by commas. The column headings in the header 
can be anything you like, but if you use names (i.e. labels) of attributes as 
they appear in your project you will save yourself some time later.
• RequisitePro will look at the header in the CSV file and try to match the 

column heading to an attribute in the project. During the import process 
you will be asked to review the attribute matching and make corrections.

• The columns under the attribute headings must contain attribute values.
Note: As an alternate to typing the CSV header, you can copy a header from 

another CSV file. Exporting an existing RequisitePro file to a CSV 
file will create a tag in the correct format. Open an Attribute Matrix of 
the requirement type you plan to import and use the File > Export > 
Export to CSV command. Then copy the header from the newly 
exported file and paste it into the file you plan to import. (For more 
information, refer to Exporting a View as a CSV File on page 18.)
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Using the Import Wizard to Import a CSV File
Open a project, then do the following:
1. On the Tool Palette, click Project > Import, or

from the Views Workplace, click File > Import.
The Import Wizard opens, and Select a Source screen appears.

2. Complete the following information:
• Click the CSV button to import requirements from a comma-separated 

value text file. 
• Type the name of the CSV file to import, or click Browse to select a file 

from the list. (The Browse command displays the Open dialog box. 
Navigate to the desired document and click Open. The Open dialog box 
closes and the selected document is loaded into the Import Wizard.)

3. Click Next to continue. The Match Requirement Types screen appears.
The Import Wizard, by default, selects the RequisitePro requirement type 
that matches the requirement types in the CSV file that you are importing. 
You can override the default selection. 

4. Click Next to continue. The Match Attributes screen appears.
5. Click Match Manually to check that RequisitePro mapped the attributes 

correctly. The Match Attributes dialog box appears.
6. Complete the following information:

• If you want to change the mapping, click and hold the mouse while 
dragging a new line from an imported attribute to an existing attribute. 
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• If RequisitePro could not make a match, the imported attribute will be 
listed but will have no line connecting it to an existing RequisitePro 
attribute. You can make the match manually if you recognize an attribute 
with the same meaning. Requisite Pro will ignore any attributes left 
unconnected. Only matched attributes are imported.

When you are satisfied with the attribute matching, click OK to return to 
the Wizard.

7. Click Next to continue. The Select A Resolution dialog box appears.
When attribute values in the imported requirements conflict with the 
values in existing requirements, RequisitePro can resolve the conflict in 
one of two ways:
• add the imported requirements as new requirements in your document or 

database
• overwrite your existing attribute values with those in the imported CSV 

file.
Depending on your choice, you will take one of two paths: Defining New 
RequisitePro Requirements on page 11-17 or Updating Attributes of 
Existing Requirements on page 11-18.
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Defining New RequisitePro Requirements
The Wizard imports the text of the requirements as written in the CSV file. You 
can accept or delete the requirements before importing.
1. In the Select A Resolution dialog box, select Define new RequisitePro 

requirements and click Next. The Requirements to Import screen 
appears.

2. Review requirements in the list and revise the list as needed:
• Click View to read the full text of the requirement. The Edit Imported 

Requirements dialog box appears. Select a requirement from the list. 
The full text of the requirement displays in the text pane at the bottom of 
the dialog box. To make changes to any of the list-type attribute values, 
double-click on the cell and select a new value from the drop-down list. 
To make changes to entry-type attribute values, select the value and type 
the new value. Click Accept for Import.

• Click Remove to remove a selected requirement. (A requirement that 
was removed is not entirely deleted. It is moved into the Add 
requirements dialog box.)

• Click Add to review a list of requirements you have removed. If you 
would like to add a requirement back into the list, select it and click OK.

3. Click Next to continue.The Select A Destination screen appears.
4. Choose a destination for the new imported requirements:

• Select Current project database to bring the requirements into the 
database of the open project.

• Select New RequisitePro document to create a new document (based 
on the document type of your choosing) and bring the requirements into 
the new document. The Document Properties dialog box appears and 
prompts you to record the document name, filename, and document 
type.

• Select Existing RequisitePro document to choose from a list of 
existing project documents. If the file you choose is not open, 
RequisitePro opens it for you.

5. Click Next to continue. The final Status screen appears.
6. Click Commit to accept the import or click Cancel to cancel the import in 

its entirety.
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Updating Attributes of Existing Requirements
The new imported requirement attributes overwrite the requirement attributes 
in the open project. The text of the imported requirements will not be imported. 
You can accept or delete the requirements before importing.
1. In the Select A Resolution dialog box, select Update attributes of 

existing requirements and click Next.
The Requirements to Import screen appears. The list box shows tag 
numbers, followed by the comment:
[text will not be imported].

2. Review requirements in the list and revise the list as needed:
• Click the View button to access the Edit Imported Requirements 

dialog box. Only tag numbers are displayed, as the text will not be 
imported. (To view the text of the requirements associated with the tag 
numbers, refer back to the Attribute Matrix in the Views Workplace.) 

• Click the Remove button to remove requirements from the list and store 
them in an Add requirements dialog box.

3. Click Next. The Import Wizard displays the final Status screen.
4. Click Commit to accept the import, or click Cancel to cancel the import 

in its entirety.

Exporting Requirements
Requirements are exported from RequisitePro in the Views Workplace.
• An Attribute Matrix can be exported as a CSV file or as a Microsoft Word 

document.
• A Traceability Matrix can be exported as a CSV file only.
• A Traceability Tree can be exported as a CSV file or as a Microsoft Word 

document.

Exporting a View as a CSV File
As described above in Importing a CSV File on page 11, a CSV file is a data 
file consisting of fields and records, stored as text, in which the fields are 
separated from each other by commas. If the data in a field contains a comma, 
the field is further surrounded with quotation marks.
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To export a view as a CSV file:
1. Open the Attribute Matrix, the Traceability Matrix, or the Traceability 

Tree that you want to export.
2. In the Views Workplace, click File > Export > Export to CSV. The 

Export to CSV dialog box appears.
3. Complete the following information:

• Choose a location to save the exported file in the Save in drop-down list.
• Type a name for the exported file in the File name text box.
• Do not modify the .csv file selection in the Save as type text box.

4. Click Save. 
RequisitePro exports the View as a comma separated value file (*.csv), 
which is readable by such applications as SQL Server, Oracle, Excel, and 
Access.

Exporting a View as a Word Document
To export a view as a Word document:
1. Open an Attribute Matrix or a Traceability Tree that you want to export.
2. In the Views Workplace, click File > Export > Export to Word.

The Export to Word dialog box appears. 
3. Complete the following information:

• Choose a location to save the exported file in the Save in drop-down list.
• Type a name for the exported file in the File name text box.
• Do not modify the .doc file selection in the Save as type text box.

4. Click Save.
RequisitePro exports the View as a Word document (*.doc), then opens 
Word and displays the exported View as a Word document table.
Note: When a Traceability Tree is exported to a Word document, 

RequisitePro creates a new document based on a template created 
especially for this export (treexprt.dot). You can modify this 
template and its styles to suit your needs. Heading styles 1-9 can 
be modified, but they must be retained.
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Creating Projects
Project administrators create and manage all elements of projects.
This chapter provides instructions for performing the following tasks:
• Creating a project using a blank project database
• Creating a project using the Project Wizard
• Creating a project using an existing project as a template
• Converting earlier versions of RequisitePro projects to the latest release

RequisitePro Project File Types
When you create a RequisitePro project, the following types of files are 
created: 

File Extension Definition

.def An outline’s definition file.

.doc A Word document.

.dot A Word template.

.hlp A Windows application help file.

.txt

.mnu

Plain text menu files used to add 
commands to Tool Palette menus.

.rqs A text file for project information.
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Creating a Project Using a Blank Project Database
This feature is intended for use by knowledgeable users who want the most 
flexibility when creating a new project. To use this feature effectively, it is 
important that you know how to work with each of the tabs in the Project 
Properties dialog box.
1. On the Tool Palette, click Project > New.

The New Project dialog box appears. 

2. Select Blank Project database and click OK. 
The Project Properties dialog box appears, with the General tab in front. 
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3. Click the Name text box and type a unique name of up to 64 characters, or 
accept the default name provided by RequisitePro. The first eight 
characters of the project prefix are used to identify the project if the project 
is used for cross-project traceability. RequisitePro automatically populates 
the Creator text box with your RequisitePro user’s name. This text box is 
read-only and cannot be edited.

4. In the Directory text box, specify a path for RequisitePro to store the 
project. Accept the default or click Browse to select a directory. The path 
cannot exceed 256 characters. Once the project is created, you cannot 
change this field.
Note: You can later relocate a project by moving the project directory to 

another location in the file system. To access the project in its 
new location, users must add it to their project lists.

5. In the Database field, click the down arrow to select a database for storing 
the project. You have the option to create projects in Microsoft Access, 
Microsoft SQL Server, or Oracle.

6. If you select the Microsoft SQL Server or Oracle database, click 
Properties to configure your access to that database.

Note: For more information on configuring SQL Server or Oracle, see the 
guide Installing Rational RequisitePro.
If you have installed the Oracle Setup and the SQL Server Setup 
under the Custom / Full installation process, you can access the 
following instructions in your RequisitePro Help directory:
• Configuring Oracle for RequisitePro (oraclesetup.html)
• Configuring SQL Server for RequisitePro (sqlsetup.html)

If the directory specified does not exist, the Project message box appears, 
prompting you to create the directory. Click Yes to create the directory. 

7. Use the other tabs in the Project Properties dialog box to create settings and 
record more information about the project. See Chapter 15, Working with 
Project Information, for further instructions about using the tabs in the 
Project Properties dialog box.

8. Click OK in the Project Properties dialog box to create the project.
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Recording Revision Information About the Project
Use the Revision tab in the Project Properties dialog box to view information 
about the most recent revision of the project. Enter optional information about 
the most recent revision, and access the project’s revision history.
Open the Project Properties dialog box by clicking Project > Properties, and 
click the Revision tab.
• The Revision text box contains the revision number. This read-only text 

box cannot be edited unless the project is archived using RequisitePro’s 
Archive command (or checked into ClearCase). You can only override the 
revision number when the project is archived. The new revision number 
that you use must be greater than the existing number and must be 
expressed in an N.m format, for example, 2.5.

• The Label text box contains a descriptive name for the revision. This field 
is optional and only available if changes have been made to project 
properties.

• The Date text box is read-only and displays the date the project was 
modified.

• The Time text box is read-only and displays the time the project was 
modified.

• The Change Description text box displays changes made to the project. 
You can type information into the field if changes have been made to 
project properties in other tabs of the dialog box. Otherwise, the field is 
read-only.

• The History button opens a dialog box that displays the change history of 
the project.

Creating a Project Using the Project Wizard
The Project Wizard simplifies the process of creating a project by guiding you 
through each step of the procedure. 
1. On the Tool Palette, click Project > New.
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The New Project dialog box appears. 

2. Select Use the project wizard and click OK. RequisitePro starts the 
Project Wizard and the Welcome screen appears. 

3. Click Next. The Project screen appears.
4. Complete the information:

• In the Name text box, type a name for the project, or accept the default 
name provided by RequisitePro. 

• In the Description text box, type a description of the project (this step is 
optional).

• In the Directory text box, specify a location for storing the project. By 
default, RequisitePro creates a directory name that matches the name in 
typed in the Name text box above. Accept the default path or click 
Browse and select a directory from the Browse for Folder dialog box.

• In the Database field, click the down arrow to select a database for 
storing the project.You have the option to create projects in Microsoft 
Access, Microsoft SQL Server, or Oracle.
If you select the Microsoft SQL Server or Oracle database, click 
Properties to configure your access to that database.

Note: For more information on configuring SQL Server or Oracle, see the 
guide Installing Rational RequisitePro.
If you have installed the Oracle Setup and the SQL Server Setup 
under the Custom / Full installation process, you can access the 
following instructions in your RequisitePro Help directory:
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• Configuring Oracle for RequisitePro (oraclesetup.html)
• Configuring SQL Server for RequisitePro (sqlsetup.html)

5. Click Next to continue.
If the directory specified does not exist, the Project Properties message 
box appears, prompting you to create the directory. Click Yes to create the 
directory and go to the Document Type information screen. Click No to 
close the message box and return to the Project screen to select another 
directory.

6. Read the information on the Document Type information screen, and 
click Next to continue. The Create the First Document Type screen 
appears.

7. Complete the information:
• In the Name text box, type a name for the document type, or accept the 

default provided by RequisitePro.
• In the Tag text box, specify a tag to label requirements created in this 

document type, or accept the default provided by RequisitePro.
• In the Description text box, type a description of the document type. 
• To indicate that any requirements created in the document must contain 

the word “shall,” mark the Requirements must contain the word 
“shall” check box.

Note: This step is optional. Once you have created the project, you can 
assign any “must contain” word, or change a “shall” to a different 
word.

• Select an outline to be used with the document type. See Using 
RequisitePro Outlines on page 15-4 for more information on outlines. If 
you choose the default selection, None, RequisitePro uses the 
normal.dot Word template.

8. Click Next to continue. 
The Defined Document Types screen appears.

9. Do one of the following if needed:
• To add more document types, click Add, and repeat step 7 above. 
• To edit a document type, click Edit. Complete the information in the 

Edit a document type screen and click Next.
• To remove a document type, click Remove. 
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10. Click Next to continue. The Document description screen appears. 
11. Read the information in the pane and click Next to continue. The Create 

the First Document screen appears. 
12. Complete the information:

• In the Description text box, type a description of the document. 
• In the Document Type list, select a document type. 
• To create a RequisitePro document from an existing Microsoft Word 

document, type the document name in the Document to import text 
box, or click Browse to find the document. 

13. Click Next to continue. The Documents Defined screen appears. 
14. Do one of the following:

• To add more documents, click Add and repeat step 12.
• To edit a document, click Edit. 
• To remove a document from the list, click Remove. 

15. Click Next to continue.
The Congratulations screen appears. 

16. Click Finish to complete the process.

Creating a Project Using an Existing Project as a 
Template

When you use an existing project as a template, RequisitePro creates the new 
project using the same structure and database type as the existing project. 
Document types, requirement types, view definitions, attributes, user and 
group permissions are all copied. Documents, requirements, history 
information, and traceability relationships are not copied.
Note that you can copy the basic structure of another project but make 
modifications to requirement types, document types and attributes. 
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1. On the Tool Palette, click Project > New.
The New Project dialog box appears. 

2. Click Use an existing project as a template.
3. In the projects list, select the name of the project to use as a template.
Note: You can use the RequisitePro Project Template, which provides 

standard document types and requirement types for your new project. 
This project template is located in your project list 
(and at the following location: <install drive>\Program Files\ 
Rational\common\OutOfTheBox\requirements\rstemplate.rqs).

4. Click OK.
RequisitePro opens the project, duplicates the project structure and opens 
the Project Properties dialog box with the General tab displayed in front.

5. In the Name text box, type a name for the project, or accept the default 
name provided by RequisitePro. 

6. In the Description text box, type a description of the project (this step is 
optional).

7. In the Directory text box, specify a location for storing the project. Accept 
the default or click Browse and select a path from the Browse for Folder 
dialog box.

8. In the Database field, click the down arrow to select a database for storing 
the project. You have the option to create projects in Microsoft Access, 
Microsoft SQL Server, or Oracle.
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Note: For more information on configuring SQL Server or Oracle, see the 
guide Installing Rational RequisitePro.
If you have installed the Oracle Setup and the SQL Server Setup 
under the Custom / Full installation process, you can access the 
following instructions in your RequisitePro Help directory:
• Configuring Oracle for RequisitePro (oraclesetup.html)
• Configuring SQL Server for RequisitePro (sqlsetup.html)

9. If you want to modify the cloned project properties, use the other tabs in 
the Project Properties dialog box to change settings and record more 
information about the project. See Chapter 15, Working with Project 
Information, for further instructions about using the tabs in the Project 
Properties dialog box.

10. Click OK. The project is added to your project list and ready for use.

Converting RequisitePro Projects to the Latest Version
If you try to open a project created in a RequisitePro release earlier than version 
4.0, the Project Conversion Wizard automatically appears and guides you 
through the project conversion. Projects created in version 4.0 and later are 
automatically converted to the latest version without running the wizard.
Note: You cannot open projects that were created in versions of 

RequisitePro earlier than 2.0, including Requisite Baseline.
Prior to conversion, the project is archived in its original form in a backup 
subdirectory in the project directory. You can use this archive to open the 
project in the earlier version of RequisitePro. You cannot open RequisitePro 
2000.02.10 versions of projects in earlier versions of RequisitePro.
Conversion includes the following:
• Conversion to 32-bit format (versions 2.0 and 2.1).
• Conversion to allow for the new features in RequisitePro version 

2000.02.10:
• In-View editing
• Extended editing
• Traceability security
• Requirement authoring via the Web
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To convert to RequisitePro version 2000.02.10:
1. On the Tool Palette, click Project > Open. 

The Open Project and Documents screen appears.

2. Select the project to open and click OK.
If the project was created in a RequisitePro release earlier than version 4.0, 
the Project Conversion Wizard Introduction screen appears.

3. Click Next. 
The Project Archive screen appears.

4. In the Archive Location text box, specify the location for the archived 
project.
RequisitePro makes a copy of the project and its documents and stores it 
in the archive directory before converting the project to RequisitePro 
version 2000.02.10. 

5. If you started the conversion process from the command line, the Project 
Selection screen appears, prompting you for the location of the project to 
convert. In the Selected Project text box, specify a location for the project.

6. Click Archive to continue.
RequisitePro archives the project. 
The Project Conversion screen appears. 

7. Click Convert to convert the project. 
The Congratulations screen appears.

8. Click Exit to complete the process.
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When you run the Project Conversion Wizard from within RequisitePro, the 
converted project opens when you click Exit.
Note: If the converted project is connected to an external project that is in a 

previous project format, the converted project opens; however, the 
connection to the external project is disabled. Open the external 
project and convert it to the current format in order to re-establish a 
connection for cross-project traceability.
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Working with Project Security
Because RequisitePro allows multiple users to access the same project 
documents and database simultaneously, project security is crucial. You can 
enable or disable security in a project, depending on the needs of the group. 
With security enabled, users belong to groups. RequisitePro administrators 
assign group-specific permissions. The permissions determine the amount or 
kind of access users have to projects. 
Any RequisitePro user can create a new project. When you create a new 
project, you are considered the project administrator and are automatically 
placed in the Administrators group. After you create the project, you (and other 
project administrators) can define other users and groups. 
If security is not enabled, any user can open the RequisitePro project. When 
first opening an unsecured project, RequisitePro allows you to log on as one of 
the following: the user name specified in the Options dialog box (click Tools 
> Options) Default Project Logon field; your Windows logon name; or as a 
user name of your choice. The user name is added to the Administrators group 
list for the project.
If security is enabled, the Project Logon dialog box appears each time you or 
another user opens the project. The project administrator who enabled security 
can assign passwords for other users.
13-1



Working with Project Security
Setting Security
To enable or disable security for a project:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears.

2. Click the Enable security for this project check box. Mark the check box 
to enable security; clear the box to disable security.

3. Select groups and users by following the steps in the next section.
4. Click OK.

Creating and Modifying Groups and Users
RequisitePro provides three default security groups: Deleted Users, 
Administrators, and Users. Remember that all security permissions are 
assigned at the group level only, and a user can be in only one group. 
• Deleted Users. This group contains users who have been deleted from 

other groups, have no permissions, and cannot log on to RequisitePro. This 
group is maintained by RequisitePro for project history.

• Administrators. Members of this group have full permissions to work in a 
project. They can change a project structure, create and modify data, and 
set and maintain security permissions. You can add and remove users from 
this group, but you cannot modify Administrators group permissions.

• Users. By default, members of the Users group have full permissions to 
create and modify all documents, requirements, attributes, and traceability. 
You can modify Users group permissions to limit the type of permissions 
granted for each document type and requirement type.
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You can add and delete groups, add users to groups, move a user to a different 
group, and edit a user’s information, such as user name, password, and e-mail 
address.

Creating a New Security Group
To create a new security group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. Click Add below the Groups list box.
The Group Permissions dialog box appears.

3. In the Name text box, type a name for the group.
4. Set the group permissions and click OK. 

For more information on setting and editing group permissions, see 
Assigning Permissions to a Security Group on page 13-6.

5. Click OK to save and close the Project Security dialog box.
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Deleting a Security Group
If all users have been removed from a group, you can remove the group.
To delete a group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list box, select the group to delete.
3. Click Delete. RequisitePro prompts you to confirm the deletion.
4. Click OK. 
5. Click OK in the Project Security to save and close.

Adding a User to a Security Group
To add a user to a group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Users of Group list, select the group to add the user to, and click 
Add next to the Users of Group list. The Add User dialog box appears.

3. In the Username text box, type the user’s name (up to 20 alphanumeric 
characters, not case sensitive). 

4. In the New Password text box, type the user’s password
Note: This field and the Verify field below are encrypted, displaying a 

symbol for each of the 14 maximum possible characters.
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Remember: Passwords are case-sensitive (for example, Mycomputer, 
MYCOMPUTER, and mycomputer are treated as different passwords).

5. In the Verify text box, type the password again.
6. In the E-Mail Address text box, type the user’s e-mail address.

This e-mail address is necessary for participating in RequisitePro 
discussions via e-mail. For more information, see Configuring E-mail for 
Discussions on page 6-2.

7. Click OK. RequisitePro adds the new user to the group.
8. Click OK to save and close the Project Security dialog box.

Editing User Information
To edit user information:
1. On the Tool Palette, click Project > Security. 

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the security group to which the user belongs.
3. In the Users of Group list, select the user name.
4. Click Edit next to the Users of Group list.

The Edit User dialog box appears.
5. Edit the user name, password, or e-mail address.
6. Click OK.
7. Click OK to save and close the Project Security dialog box.

Deleting a User from a Security Group
When you delete a user from a security group, RequisitePro moves the user to 
the <Deleted Users> group. All records associated with the user are 
maintained. If you reinstate a user with the same name as a deleted user, 
RequisitePro prompts you to confirm whether it is the same person before 
RequisitePro reinstates the user.
To delete a user:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the group containing the user.
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3. Select the user in the Users of Group list.
4. Click Delete below the Groups list. A dialog box appears, prompting you 

to confirm deletion of the user. 
5. Click Yes to move the user from the current group to the <Deleted Users> 

group.
6. Click OK to save your changes and close the Project Security dialog box.

Moving a User to Another Security Group 
To move a user to another security group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the group containing the user.
3. Select the user in the Users of Group list.
4. Click Move. The Move User dialog box appears. 

5. Select the group to move the user to.
6. Click OK.
7. Click OK to save your changes and close the Project Security dialog box.

Assigning Permissions to a Security Group
Each security group has its own set of permissions, and all members of the 
group share the same permissions. The following list shows all possible 
permissions that can be assigned to a group:
• Project permissions: access the project, manage project structure, manage 

project security.
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• Document type permissions: read, update, create, delete documents.
• Requirement type permissions: read, update, create, delete requirements.
• Attribute permissions: read, update attributes.
• Attribute value permissions: read, update attribute values.
• Traceability permissions: set and clear suspect relationships, create and 

delete traceability relationships.
Members of the Administrators group and groups with project security 
permissions can create group accounts, assign permissions to the groups, and 
add, move, edit, and delete users in groups.
To assign permissions:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the group.
3. Click Edit below the Groups list.

The Group Permissions dialog box appears.

Note: The Administrators group has full permissions. You cannot edit this 
group’s permissions, although you can add and remove users from the 
Administrators group.
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4. To assign project structure modification permissions to the group, mark 
the Can manage project structure check box. Groups with these 
permissions have complete access to all tabs and information in the Project 
Properties dialog box for this project. To remove a group’s permissions, 
clear the check box.

5. To assign project security permissions to the group, mark the Can manage 
project security check box. Groups with these permissions can change 
group and user permissions for this project. To remove a group’s 
permissions, clear the check box.

6. Assign document, requirement, traceability, attribute and attribute value 
permissions, as described in the following sections.

7. Click OK.

Assigning Document Type Permissions
To assign document-type permissions to a group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the group.
3. Click Edit below the Groups list. The Group Permissions dialog box 

appears.
4. In the Document Types list, select the document type for which you want 

to assign permissions. 
5. Click Edit Permissions below the Document Types list.

The Document Type Permissions dialog box appears. 
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6. Assign document permissions by marking the corresponding check box. 
Groups can have read, update, create, and delete permissions. To remove 
a permission assigned to a group, clear the check box that corresponds to 
the permission. If you do not want the group to have any permissions for 
this document type, clear all selections. 
• Read permissions: Members of the group can view documents of this 

type. If Read is the only permission selected, members of the group 
cannot modify documents of this type. 

• Update permissions: Members of the group can modify documents of 
this type. If Update is selected, Read is also automatically selected.

• Create permissions: Members of the group can create documents of this 
type. If Create is selected, Read and Update are also automatically 
selected.

• Delete permissions: Members of the group can delete documents of this 
type. If Delete is selected, Read, Update, and Create are also 
automatically selected.

7. Click OK to save the modifications.

Assigning Requirement Type and Traceability Permissions
To assign requirement-type and traceability permissions to a group:
1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears (make sure the Enable security 
for this project check box is marked).

2. In the Groups list, select the group.
3. Click Edit below the Groups list. The Group Permissions dialog box 

appears.
4. In the Requirement Types list, click the requirement type for which you 

want to assign permissions and click Edit Permissions. 
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The Requirement Type Permissions dialog box appears. 

5. Assign requirement type permissions by marking the corresponding check 
box. Groups can have read, update, create, and delete permissions for a 
requirement type. To remove one of the other permissions assigned to a 
group, clear the check box that corresponds to the permission.
• Read permissions: Members of the group can view all requirements of 

this type. If Read is the only permission selected, members of the group 
cannot modify requirements of this type. This permission is 
automatically selected, and the box cannot be cleared. 

• Update permissions: Members of the group can modify all requirements 
of this type.

• Create permissions: Members of the group can create requirements of 
this type. If Create is selected, Update is also automatically selected.

• Delete permissions: Members of the group can delete requirements of 
this type. If Delete is selected, Update and Create are also automatically 
selected.

6. To add permissions for traceability relationships to and from requirements 
of the selected type, select check boxes for the following:
• Read permissions: Members of the group can view all traceability 

relationships between requirements of this type. This permission is 
automatically selected and the box cannot be cleared. 
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• Mark Suspect permissions: Members of the group can set suspect 
traceability relationships to and from requirements of this type. If the 
Clear Suspect check box is marked, this check box is automatically 
marked.

• Clear Suspect permissions: Members of the group can clear suspect 
traceability relationships to and from requirements of this type.

• Create permissions: Members of the group can create traceability 
relationships to and from requirements of this type. If the Delete check 
box is marked, this check box is automatically marked.

• Delete permissions: Members of the group can delete traceability 
relationships to and from requirements of this type.

7. If desired, select a requirement attribute and click Edit Permissions to 
assign attribute permissions to the security group. For more information, 
see the following section.

8. Click OK in each dialog box to save the modifications.

Assigning Attribute Permissions
To assign permissions for an attribute or requirement text:
1. Select the requirement type, as described in steps 1 through  in Assigning 

Requirement Type and Traceability Permissions on page 13-9.
2. In the Requirement Type Permissions dialog box, select the attribute (or 

Text) for which you want to set permissions.
3. Click Edit Permissions. 

The Attribute Permissions dialog box appears. 
• For list-type attributes, the dialog box pictured below appears.
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The Read permission check box is automatically marked and cannot be 
cleared. To allow users to modify attributes of the selected type, mark 
the Update check box and refer to the section on page 12 for more 
information on assigning permissions to modify specific attribute 
values.

• For entry-type attributes or Text, the dialog box pictured below 
appears. 

The Read permission check box is automatically marked and cannot be 
cleared.

4. Mark the Update check box to give members of the group permissions to 
modify the attributes. Clear the box to allow default Read permissions 
only.

5. Click OK.
6. Click OK in the Requirement Type Permissions and Group 

Permissions dialog boxes.

Assigning Permissions for Attribute Values
For list-type attributes, you can assign permissions for specific attribute 
values:
1. Select an attribute, as described in steps 1 through 3 in Assigning Attribute 

Permissions on page 11.
2. Mark the Update check box in the Attribute Permissions dialog box for 

a list-type attribute. 
The attribute values in the list box and the Edit Permissions button are 
enabled.

3. Select and attribute value in the list and click Edit Permissions. 
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The Attribute Value Permissions dialog box appears. 

The Read permission check box is automatically marked and cannot be 
cleared.

4. Mark the Update check box to give members of the group permissions to 
modify the attribute value. Clear the box to allow default Read 
permissions only for the attribute value.

5. Click OK.
6. Repeat steps 3 and 4 to set or remove group permissions for other attribute 

values.
7. Click OK in the Attribute Permissions, Requirement Type 

Permissions, and Group Permissions dialog boxes.
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C  H  A  P  T  E  R   14 

Managing Projects
This chapter provides instructions for the following tasks for managing 
projects:

• Controlling user access to a project and its documents
• Renumbering requirements
• Printing project summaries and reports
• Using Requirement Metrics
• Archiving projects
• Removing a project’s revision information
• Removing documents and requirements from a database
• Moving projects
• Copying projects
• Converting a database

Controlling User Access to a Document
When opening projects and documents, you have several options for 
controlling access by other users when the project and documents are open:

• Exclusive access limits access to the project and documents to the user 
who opens the project. Exclusive access is needed to renumber 
requirements, change tag prefixes, change requirement color and style, 
remove an attribute, remove revision information and propagate a 
revision number. 

• Read-only access lets a user open a project for viewing only.
• Document read-only access lets a user open a document for viewing 

only.
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For information on setting up read-only, create, and delete permissions for 
projects and requirements documents, refer to chapter 13, Working with 
Project Security on page 13-1.

Protecting Documents
When you protect a document for revisions, you can electronically distribute 
the document or make it available in a shared directory for reviewers to 
suggest changes. You can then merge the revisions in one document.
Use the commands on the Microsoft Word Tools menu in the Word 
Workplace to track changes and protect RequisitePro documents:
• Track Changes
• Protect Document
Note: Use RequisitePro’s offline authoring feature to edit a document in 

Word outside of RequisitePro. Or, to make a copy of a requirements 
document, use the Document > Save As command. 
(Refer to Working With Documents Offline on page 7-11 and Saving a 
RequisitePro Document as a Word Document on page 7-7.)

Renumbering Requirements
If the project is opened in exclusive mode, you can renumber all requirements 
of one or more specified types in the requirements document and database. 
This feature is useful to eliminate the “holes” in a numbering scheme that result 
when you delete or move requirements.
For more information, refer to Renumbering Requirements on page 8-20.

Printing Project Summaries and Reports

Printing a Project Summary in RequisitePro
1. On the Tool Palette, click Project > Print Summary.
2. Verify that the correct printer is selected.
3. Click OK.
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Using Rational SoDA with RequisitePro
RequisitePro is integrated with SoDA, Rational’s software documentation 
automation tool.
Using SoDA and RequisitePro, you can:

• Modify and generate SoDA reports and documents from an open 
RequisitePro project. 

• Create a report that consolidates RequisitePro requirements information 
and Rose modeling information. 

• Create a use case report that includes all use case requirements and Rose 
use case diagrams.

Before you begin the following procedure, make sure the current version of 
SoDA for Word is installed and a RequisitePro project is open.
1. On the Tool Palette, click Project > Generate SoDA Report. The SoDA 

dialog box appears, showing a list of templates for use with RequisitePro.
2. Select a template from the list and click OK. SoDA for Word appears. The 

SoDA menu is active and the selected template is open.
3. Use the template to create a SoDA report from the open RequisitePro 

project. Refer to the SoDA documentation for more information about 
generating SoDA reports.

Refer to SoDA documentation for more information about generating SoDA 
reports.
Note: Do not begin generating a second SoDA report while the progress 

indicator is active.

Using Requirement Metrics
Requirement Metrics provides project administrators and analysts with 
statistics concerning a RequisitePro project’s attributes, relationships, 
requirements and revisions. These statistics are displayed in Microsoft Excel.
You can use Requirement Metrics to retrieve information that is vital for 
evaluating:
• the progress of a project
• priorities, workloads, and deadlines
• the addition of new requirements
• changing or unstable requirements
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• approved and incorporated features
You begin by creating one or more filters. A filter creates criteria for retrieving 
requirement information. For example, you would use an Attribute Count 
Filter to determine how many requirements in the project have a priority with 
the value “High”. You then combine one or more filters to produce a query. A 
query combines the criteria from multiple filters to analyze requirements. The 
filters that compose a query are joined with the AND statement. Finally, you 
combine one or more queries to produce a report. 
There are two types of reports that are available in Requirement Metrics:
• A static report uses static filters and shows results about the project at the 

present time. 
• A trend analysis report uses time-sensitive filters that analyze changes in 

requirement text, attributes, traceability, and hierarchical relationships. 
Trend analysis reports require that you specify an increment for displaying 
revisions.

Your report can address the following questions by using the corresponding 
sample queries:

Question Query

How many requirements were 
created since the last release?

• Requirements Creation filter
• Options/Time Period > 10/15/99

How many High Priority 
requirements do I have?

• Attribute Value filter
• Priority = High

How many requirements went from 
Low Priority to High Priority in the 
last month?

• Attribute Value Change filter
• Priority Before = Low
• Priority After = High
• Options/Time Period/Last Month

How many requirements contain 
text that has changed more than 
three times since the last iteration?

• Requirement Text Change filter
• Number of changes > 3
• Options/Time Period > 10/15/99

What is the level of detail 
associated with my requirements?

• Children filter: > 0 children
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The Requirement Metrics main window is the primary user interface for the 
application. This window allows you to select a requirement type for your 
report, choose filters and filter criteria, build queries and add them to your 
report. As you add filters to your queries, you limit the requirements in your 
report to only those requirements that match your filter criteria.
Access Requirement Metrics with the Tools > Metrics command or the 
Metrics button on the Tool Palette. For more information, refer to the online 
help included with Requirement Metrics.

Main Window Query Pane
The Query pane in the Requirement Metrics main window provides features 
for selecting multiple filters in order to build a single query. The query 
concatenates the filters when it is added to the Report pane, below.
The Query pane contains the following fields and controls:
Choose a Requirement View
Select one of the predefined views, which are designated by angle brackets <> 
around their names, or select a saved view from the RequisitePro project.
Note: Saved views for external projects are not supported in the list of saved 

views.
Types: Indicates each filter type included in your query. All queries include the 
Base filter, which returns all requirements of the selected requirement type. 
Criteria: Displays the criteria you have selected for each filter in the query.
Add Filter: Presents the Add Filter dialog box, which allows you select 
another filter to add to the query.
Delete Filter: Removes the selected filter from the query.

How stable is the organization of 
my requirements?

• Parent Change filter
• Before = Select All
• After = Select All

Are my associations with other 
requirements stable?

• Traceability Change filter: Select 
All

• Relationship = Trace To and From
• Action = Added or Removed
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Add to Report: Combines all the filters you've selected into a single query and 
adds it to the Report's query list, below.

Main Window Report Pane
The Report pane in the Requirement Metrics main window provides features 
for managing the queries that you have added to your report.
The Reports pane contains the following fields and controls:
Names: Displays the label for each query in the report. To change the label 
text, click the query once, click once more, and then type a label.
Criteria: Summarizes the filter criteria contained in each filer.
Move Up: Moves the selected query up in the list of queries. The order to the 
queries determines the order in which they appear in the report.
Move Down: Moves the selected query down in the list of queries.
Delete Query: Removes the selected query from the report.
Create: Run the report with the displayed query criteria.

Creating a Filter and Query
1. Select a view from the Choose a RequisitePro View drop-down list. This 

can either be a view that you have previously created in the Views 
Workplace, or it can be a predefined view that includes all the 
requirements of a requirement type. The view defines the requirement type 
that the filter uses.

2. Next click the Add Filter button. The Add Filter dialog box appears and 
displays a list of possible filters. 

3. Select a filter and click OK. 
Tip: You can also select a filter by double-clicking on it.
An appropriate dialog box for the filter appears. 
4. When you have finished making your selections, click OK to add the filter 

to the filter list. 
5. Add more filters to the list until your query is complete.

Adding a Query to a Report
When you add the query to the report, Requirement Metrics builds all filters in 
the filter list into a single query and adds that query to the report's list of 
queries. Filters are joined in the query with the “AND” logical operator.
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1. Click Add to Report button The query is added to the report's list of queries 
with a default label. 

2. To change this label, select the query in the list, then single-click the query 
again. The cursor changes into edit mode over the label. 

3. Type your new label and press Enter to save the changes.
4. To rearrange the order of the queries in the query list, select a query and 

click Move Up or Move Down. The order to the queries determines the 
order in which they appear in the report.

5. Click the menu command Options > Output Requirements Detail to 
display the requirement tags, text, and attribute values (when applicable) 
in the report.

A separate worksheet is created in Microsoft Excel for each query in the report.

Setting the Time Controls
When you add any time-sensitive filters to the report, the Options > Time 
Period command is enabled. You can use this feature to filter for a relative time 
period, such as “last week”, or you can select a specific beginning and/or 
ending date for the report.
In addition, if the report consists of only time-sensitive queries, you can show 
revisions in intervals of days, weeks, months, quarters, or years. This option 
enables you to create a Trend Analysis report.
To set the time controls:
1. Click the Time Controls button on the toolbar. The Report Time Period 

dialog box appears.
2. Do one of the following:

• Click Relative Time Period and select a relative time period from the 
drop-down list.

• Click Specific Time Period, and select an operator (such as “>”) and a 
date from the drop-down lists. When you select the “Between” operator, 
you must select a beginning and ending date.

3. For reports with only time-sensitive filters, mark the Trend Intervals check 
box and select an interval from the drop-down list. 

Note: The check box is not enabled if you select “Any Time” as your 
relative time period. This is because there is no end date associated 
with this selection. 
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4. Mark the Show Cumulative Counts check box to show the cumulative 
number of requirements for each time interval.

Running the Report
After you have added queries to the report, you are ready to run it.
Do one of the following:
• Click the Create button.
• Click the File > Create Report menu command.
The program opens Microsoft Excel and presents the requested statistics in a 
new workbook. The results are also presented in a default graph. To reformat 
the graph, use Microsoft Excel’s Graph Wizard. 

Saving the Report
After you have added queries to your report, you can save it for repeated use. 
You can open and edit saved reports in Requirement Metrics or run them from 
the Windows command line.
1. To save the current report, click the File > Save Report As menu com-

mand. 
The Save As dialog box appears.

2. Browse to a directory and type a file name for the report. Click Save.
Requirement Metrics saves the report, including all queries and settings, to 
a *.rqm file.

Opening and Editing a Saved Report
1. To open a saved report, click the File > Open Report menu command.
The Open dialog box appears.
2. Browse to a directory, select a saved report (with a .rqm extension), and 

click Open.
Note: When editing saved reports, if you change any of the requirement 

types or attributes, the saved report may become obsolete. An error 
message appears if you try to run an obsolete report. 
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Running from the Command Line
You can run Requirement Metrics from the command line outside of 
RequisitePro. Click the Start button on the taskbar and choose the Run 
command.
The command line syntax is: 
rqmetricsgui.exe ReportFile [user:=Username] [pass:=Password] 
[save:=Filename]
If any element of an argument contains any spaces, then you must enclose the 
entire argument in double quotes.
Include the full path of the rqmetricsgui.exe. Typically this is “C:\Program 
Files\Rational\RequisitePro\bin\rqmetricsgui.exe”.
The ReportFile argument should include the path and file name of the .rqm file 
you want to run. 
The argument user:=Username is required for all projects that have project 
security set. If this project has security enabled, you must use a valid user name 
for the project. If this is not a secured project, you must first successfully log 
into the project (this adds your user name to the project). You can now use the 
same user name to run Requirement Metrics from the command line. (Your 
current user name is specified in your Tools > Options dialog box in 
RequisitePro.)
The optional argument pass:=Password specifies the password needed for the 
user name. If either of these arguments is incorrect, you cannot access the 
project or run the report you requested.
The optional argument save:=Filename specifies a name for an output file in 
Excel format. This is useful for uninterrupted batch processing. 
Note: If an Excel file with the file name already exists, Requirement 

Metrics overwrites the file.

Archiving Projects
In RequisitePro, you can archive projects using either the RequisitePro 
Archive command or Rational ClearCase.
You can use a variety of configuration management tools, such as PVCS 
Version Manager or Microsoft Visual SourceSafe, to archive your 
RequisitePro projects. If your project uses a Microsoft Access database, first 
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use the RequisitePro Archive command to create an archive directory and files; 
then archive this directory (and files) using your configuration management 
tool. Be sure to include all project documents in your archive.
Note: When archiving a project that uses cross-project traceability, be sure 

to archive the other projects at the same time so that you can recreate 
a complete set of projects when you restore the archive.

For special instructions for archiving projects that use Oracle or SQL Server 
databases, refer to Archiving and Backing up Enterprise Database Projects on 
page 14-12.

Archiving Projects with the Archive Command
Using the Archive command in RequisitePro, you can store a project and make 
a backup copy of a project.
To archive projects with RequisitePro’s Archive command:
1. On the Tool Palette, click Project > Archive > RequisitePro Archive. 

The Archive Project dialog box appears:

2. Select the directory where you want the backup copy stored. Click Browse 
to open the Browse for Folder dialog box. Navigate to a directory, select a 
folder, and click OK.
You return to the Archive Project dialog box.
Note: To add a new subdirectory to an existing directory path, click at 

the end of the Directory field and type a forward slash (/) and a 
new subdirectory name.
14-10



Archiving Projects
3. If you want to enter a new revision number for the project, type it in the 
Revision # text box. The number must be greater than or equal to the 
current revision number (in the form xxxx.yyyy).

4. To apply the revision number to the requirement documents, select the 
Propagate to all documents check box.
Note: If security is enabled, you must have project structure permission 

to propagate the revision number. You must also have the project 
opened exclusively.

5. If you want to track a version number for this archive, enter the a name for 
the archived version in the Version Label text box and a description for it 
in the Change Description text box.

Note: To retrieve a project archived with the Archive command, add the 
archived project to your project list (click Project > Open and then 
click the Add button) and then open the project in RequisitePro.

Archiving Projects with Rational ClearCase
Integration with Rational ClearCase works at the project level by making a 
RequisitePro Access database and associated documents a part of an existing 
ClearCase Versioned Object Base (VOB).
Note: For special instructions for archiving projects that use Oracle or SQL 

Server databases, refer to Archiving and Backing up Enterprise 
Database Projects on page 14-12.

Setting Configurations to Use ClearCase
Before archiving RequisitePro projects using integration with ClearCase, you 
must set a default ClearCase view. Create a target VOB in ClearCase, or check 
with your ClearCase administrator to learn which VOB and view your team 
will be using.
Set the default ClearCase view in RequisitePro:
1. From the RequisitePro Tool Palette, click Tools > Options.
2. In the Options dialog box, fill in the ClearCase View field with the target 

VOB location (drive, viewname, vobname, directory). 
Use UNC naming conventions for a shared drive. This step defines the 
view to which the RequisitePro database and documents will be copied 
during the archive functions.

3. Click OK.
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Archiving Projects with ClearCase
1. On the Tool Palette, click Project > Archive > Rational ClearCase. The 

Archive with ClearCase dialog box appears.
2. Select the directory where you want the backup copy stored. Click Browse 

to open the Browse for Folder dialog box. Navigate to a directory, select a 
folder, and click OK.
You return to the Archive Project dialog box.

3. To add a new subdirectory to an existing directory path, click at the end of 
the Directory field and type a forward slash (/) and a new subdirectory 
name.

4. If desired, enter a new revision number for the project.
5. To apply the revision number to the requirement documents, select the 

Propagate to all documents check box.
Note: If security is enabled, you must have project structure permission to 

propagate the revision number. You must also have the project 
opened exclusively.

6. If desired, enter a name for the archived version in the Version Label text 
box and a description for it in the Change Description text box.

Archiving and Backing up Enterprise Database Projects
A small initial investment of your time in designing, performing and testing 
backup or archive operations will benefit your organization. Following these 
steps will guide RequisitePro project administrators, database administrators 
(DBAs) and system administrators in archiving or backing up SQL Server or 
Oracle projects so that no data is lost and that archives of your projects can be 
created quickly and dependably. 
Concepts described in this section require intermediate DBA skills. The 
RequisitePro project administrator will need to forward this information to the 
DBA, who can ensure that the data is copied from the database to a location 
that can be backed up by the system administrator. It is recommended that the 
RequisitePro project administrator verify that the process is working correctly 
and make corrections or enhancements to the process for site-specific 
configuration issues.
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Backups and Archives 
A backup provides a way to recover a project in the event of a failure such as 
media failure, user error, or other catastrophic event. Backup operations must 
occur on a regular basis. Regular backups generate a large amount of data and 
for this reason, backup media is cycled relatively quickly (6-8 weeks). Backups 
have a limited ability to re-create how your project looked several months 
prior.
By contrast, archive operations happen infrequently and are by designed to be 
kept long term. An archive is a 'snapshot' in time of a RequisitePro project 
(a.k.a. requirements artifacts). It provides an official standard on which 
subsequent work is to be based, and to which only authorized changes can be 
made. After an initial archive is established every subsequent change to an 
archive is recorded as a delta until the next archive is set.
RequisitePro tightly couples information in documents to information stored in 
a database. Parts of the requirement information are stored in the documents 
(requirement text and contextual information) while other parts (attributes, 
traceability relationships, discussions, etc.) are stored in the database. Together 
the database and the documents make a complete requirement set. For that 
reason, it is very important that you treat the project documents and the project 
database as a unit. You cannot mix and match projects documents with 
different databases. You also should avoid archiving the documents and 
database at different times.

Logical Backups
A logical backup (import/export) of a database exports the database objects 
independent of the physical location of those objects. In other words, a logical 
backup exports the data stored in a table regardless of the location of the table 
(tablespace or datafile, or otherwise). The Oracle Export Utility can create a 
file that contains all the objects in a particular schema. The file that is created 
can then be imported to the same schema to recover from a failure, or to a 
different instance or schema for archiving purposes.
Similarly, SQL Server can export all the database objects to another SQL 
Server. Unlike the Oracle Export Utility, the SQL Server Import/Export Utility 
cannot export all the database objects to a file. However, all the objects 
residing in a SQL Server database can be stored in a backup file giving a 
similar result to the Oracle Export Utility. To create a backup file in this 
manner, use the Enterprise Manager for SQL Server and select the database 
that contains RequisitePro data in the left pane and select the Backup database 
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option in the right pane. On the SQL Server Backup dialog box make sure to 
select “Database - Complete” for this type of backup. The resulting Backup file 
will contain all of the objects stored in the RequisitePro database.
Advantages of logical backups:
• Logical backups are highly recommended before any upgrade to new 

version of Oracle, SQL Server or RequisitePro. Prior to an upgrade, a 
logical backup will provide the latest data in the event of a failure. Oracle 
may require a logical backup if the newer database format is not 
compatible with the older database format. For SQL Server, we 
recommend creating a physical backup (Database - Complete) through the 
SQL Server Enterprise Manager.

• Oracle only: Logical backups can be used to detect block corruptions. If a 
corrupt block is detected during an export the export will fail. The corrupt 
blocks will need to be repaired before a successful export can be obtained.

• Logical backups can be used to provide a test or development copy of your 
RequisitePro projects. The test or development copy can be used to test a 
new release of RequisitePro, or train new users.

• Oracle only: Logical backups can be used to in conjunction with 
COALESCE to defragment extents.

• Logical backups can be used to significantly alter your database structure 
such as moving the RequisitePro Oracle schema from one Oracle 
tablespace to another or using a different Oracle schema name. It can also 
be used to move RequisitePro data to a different database in SQL Server.

• Logical backups are very useful when changing database servers.
Disadvantages of logical backups:
• The biggest disadvantage of logical backups is the amount of time they 

take to perform. For large RequisitePro schemas or databases, it may take 
several hours to perform a complete a logical backup. For high-availability 
databases that are used around the clock in different parts of the world, the 
time it takes to perform a logical backup can have a serious implication on 
the database usability. For Oracle, consider using a combination of 
incremental, cumulative and complete logical backups to provide 
flexibility to your users. SQL Server users might not be as affected by a 
logical backup as Oracle users are.
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• Ideally sessions should be restricted during a logical backup. The 
following sequence of commands will allow you to put your database in 
restricted mode during a logical backup. For Oracle, the following 
example demonstrates how to put the database in restricted mode during 
an export.
SVRMGR> shutdown immediate
SVRMGR> startup restrict open
exp userid=reqpro/reqpro...
SVRMGR> alter system disable restricted session;
SQL Server databases can be put in single user mode by right clicking on 
the database and selecting Properties. Once the RequisitePro Database 
Properties dialog box appears, select “Single user” under “Access” on the 
“Options” tab.

Image Backups
Image backups (physical backups) are an alternative to logical backups for 
backing up a RequisitePro databases. However, they cannot be used if you 
want to archive RequisitePro databases. Unlike logical backups, image 
backups make physical copies of the database files. Image backups are by 
nature more tightly coupled to the database and its current operating state. For 
example, Oracle keeps track of the current log sequence file number that is 
being used and a backup must contain all the redo log files necessary to build 
the database back to the correct log sequence file number. Image backups 
should not be used if the RequisitePro projects share an instance with data from 
any other application.
Offline image backup (or cold backups) refers to making physical copies of 
the database files while the database is shutdown. Offline image backups can 
be used with RequisitePro data as long as whenever an offline image backup is 
created, a backup of the RequisitePro project file(s) and documents is also 
created.
Online image backup (or hot backups) refers to making a copy of the database 
files (offline image backup) and then making copies of the redo logs for Oracle 
or the transaction logs for SQL Server. For Oracle, the database will need to be 
running in ARCHIVELOG mode to create online image backups. For SQL 
Server, an administrative task will need to be established to backup the 
transaction log for the SQL Server database that contains RequisitePro data. 
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Verify that no one is using RequisitePro while you are performing an online 
image backup to ensure that the data stored in the database matches the project 
documents.

Database Considerations
When using RequisitePro, the physical database can use one of three 
commercial databases: Microsoft Access, Oracle or SQL Server. The various 
options to archive RequisitePro projects vary depending on the database used.
In a Microsoft Access-based RequisitePro project, there is only one 
RequisitePro project per physical Access database (.mdb file). Access-based 
projects can be archived or backed up by using the RequisitePro Project > 
Archive command. Projects that participate in cross-project-traceability 
should be archived or backed up at the same point in time to maintain 
consistent traceability links between them.

Archiving an Oracle Project
In Oracle-based RequisitePro projects, the project administrator has the option 
to store either one or many RequisitePro projects in the same Oracle instance 
or schema.
Sharing a Oracle instance with applications other than RequisitePro: 
RequisitePro projects can potentially share an Oracle instance with other 
applications at your site. The primary advantage of sharing the same instance 
between applications is that it reduces the amount of database administration 
required. However, RequisitePro data must be synchronized with the 
RequisitePro documents it is not recommended to share the instance used for 
the RequisitePro project with other applications. If it is necessary to share an 
instance, the only way that you can backup your RequisitePro data is through 
logical backups. Image (physical) backups will not work in a shared instance 
because anytime the data for one application needs to be recovered; the data 
for all applications will need to be recovered. This could create a situation 
where an application independent of RequisitePro, would need to restore 
RequisitePro data that is older and/or not in sync with the RequisitePro 
documents associated with your project.
All RequisitePro Projects in one schema: Putting all the RequisitePro 
projects in one Oracle schema is the most effective way to store your projects. 
Because all the projects are stored together, all projects are backed up together. 
However, if a project needs to be restored, all projects stored in that schema, 
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will need to be restored together. This can potentially cause problems: work 
done on another project can be lost because the restore operation will overwrite 
the project with the restored backup from a week ago.
One RequisitePro project per schema: Each project can be stored in its own 
individual schema. This maximizes flexibility, but also requires the most 
amount of administrative work. Projects stored in their own individual schema 
can be backed up and restored without affecting other projects. Storing each 
project in its own schema is not recommended if you use cross-project 
traceability. Projects that utilize cross-project traceability need to be in sync 
with each other. Restoring a project that participates in cross-project 
traceability while not restoring all the projects that participate in cross-project 
traceability would be detrimental to all projects involved.
Storing external projects in the same schema: Projects that utilize cross-
project traceability need to be in sync with each other. Restoring one project 
while not restoring all the projects linked with cross-project traceability would 
be detrimental to all projects involved. This is the best compromise to the 
above situations. Storing all related projects will minimize the administration 
required and project corruption due to desynchronizing. It is recommended that 
you put the set of project files linked with linked with cross-project traceability 
in one directory structure. This will not only keep these projects in sync, but 
after the database export file is created, it can be copied to the root directory of 
all the projects and the backed up at once. In this directory structure, each 
project will need to be stored in a separate subdirectory of the root directory.

Archiving a SQL Server Project
In Microsoft SQL Server-based RequisitePro projects, the project 
administrator has the option to store either one or many RequisitePro projects 
in the same SQL Server database.
Storing all RequisitePro projects in one SQL Server database: Putting all 
the RequisitePro projects in one SQL Server database is the most effective way 
to store your projects. Because all the projects are stored together, all projects 
are backed up together. However, if a project needs to be restored, all projects 
stored in that SQL Server database will need to be restored together. This can 
potentially cause problems: work done on another project can be lost because 
the restore operation will overwrite the project with the restored backup from 
a week ago.
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One RequisitePro project per SQL Server database: Each RequisitePro 
project can be stored in its own SQL Server database. This maximizes 
flexibility, but also requires the most amount of administrative work. The 
advantage of this solution is that projects stored in their own SQL Server 
database can be backed up and restored without affecting other projects. 
However, storing each project in its own SQL Server database is not 
recommended if you use cross-project traceability.
Storing cross-project traceability projects in the same SQL Server 
database: Projects that utilize cross-project traceability need to be in sync with 
each other. Restoring a project that participates in cross-project traceability 
while not restoring all the projects that participate in cross-project traceability, 
could create inconsistent traceability links. Storing cross-project traceability 
projects in the same SQL Server database is the best compromise to these 
situations. It will minimize the administration required and minimize project 
corruption due to de-synchronizing cross-project traceability projects. It is 
recommended that you put the set of project files that communicate via cross-
project traceability in one directory structure. This will not only keep these 
projects in sync, but once the database export file is created, it can be copied to 
the root directory of all the cross-project traceability projects and be backed up 
as a package. To organize project files participating in cross-project 
traceability, you can store each project in a subdirectory of a common 
directory.

Verifying the Success of the Archiving or Backup Operations
Before it becomes necessary to archive or restore a project, it is a good idea to 
practice. It would be unfortunate to realize that the restoration process is not 
working correctly when you need to restore project data. To what extent you 
practice restoring an archive or backup depends on your situation.
To be 99% sure the operation is working correctly we recommend an archive 
or backup for production and development. On a nightly basis, backup or 
archive the production server in the manner described above. Once the archive 
or backup “package” is created, it is immediately restored to the development 
server. If the operation fails, the problem is remedied and the process is started 
again. The development server can then act as a test bed for attempting project 
modifications before they are attempted on production data. The development 
server could also be used as a “hot backup” server, which can be accessed 
quickly in the event of a production server failure. We strongly recommend 
you verify the success of the backup and archive operations on a regular basis.
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Restoring Enterprise Database Projects from an Archive
To restore a project from an archive, follow these steps:
1. Create a directory to hold the project.
2. If the RequisitePro Archive command was used, copy all the files from 

the archive directory to this new directory.
3. If the ClearCase Archive command was used to archive the project check 

all the files out into this directory. Also, you may want to use the “-ptime” 
option when checking out the files. This will preserve the time stamp of the 
original files and RequisitePro will not prompt you for modifications 
outside of the product. The “-ptime” option is only available in ClearCase 
4.0.

4. If the project is Microsoft Access-based, you can start using the project 
from this new location.

5. If the project is Oracle-based or SQL Server-based, you will need to 
restore the file containing the logical backup through the SQL Server 
Enterprise Manager or the Oracle Import Utility. Depending on how you 
are restoring the project, you may need to create database objects such as 
an instance, tablespaces, a user, a SQL Server database or a role.

6. On Oracle-based or SQL Server-based projects, modifications to the 
project information file may be required based on changes in instance 
name, server name, and user name. These changes can be performed by 
using the Project > Open command, then adding the project, and with the 
project selected, clicking the Properties button. 

7. Once the Oracle-based or SQL Server-based project is opened, references 
to document that were not located in the original project directory (before 
the project was archived) will need to be updated to reflect the new 
location. The references can be updated by opening the document in 
RequisitePro, and when the Locate document dialog box appears use the 
Browse button to open the document in the new directory.

Note: Be aware that any changes that you make to an archived project 
cannot be merged into any other project.
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Removing Documents and Requirements from a 
Project Database

When a document and its requirements are removed from the project 
database, the requirement formatting and the requirements are deleted 
(although the text remains) and the document can only be referenced outside 
RequisitePro as a Word document. The project must be opened exclusively to 
perform this operation (for more information about the exclusive option, refer 
to Opening a Project and Documents on page 3-5).
To remove documents and requirements:
1. Open the document in RequisitePro. 
2. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Remove.
• On the Tool Palette, click Document > Remove. 

A confirmation dialog box appears.

3. To remove the document, click Yes. To cancel the operation, click No.

Moving Projects
If you are using an Access database for your RequisitePro project, you can 
move the project to a new location, such as a different server.
To move the project:
1. Remove the project from your list of projects. Click Project > Open, se-

lect the project name in the Select a Project field and click Remove.
2. Copy the project files to your new location using Windows Explorer.
3. Add the project in its new location to the list of projects. Click Project > 

Open, and click Add at the Select a Project field.
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4. Rename the original project directory and all directories that contain 
project documents. This way you have a backup in case anything goes 
wrong. You can delete this directory once you are comfortable that the 
move was successful.

Note: If you want to save a copy, of the original directory, don’t delete it. 
See Copying Projects below.

5. Open your project in RequisitePro. The first time you open a project 
document that is not stored in the project directory, you will be prompted 
to locate the document. Select it from the new location.

Note: If you have documents that are not stored in the project directory, 
when you open a document, you may be prompted to find it, and 
select it from the new location.

If you are using an Oracle or SQL Server database for your RequisitePro 
project, consider the following:
Do you need to move an individual project or are you moving the entire Oracle 
or SQL Server database?

• If you need to move the database, you should consult your database 
administrator.

• If you need to move an individual RequisitePro project, consult Rational 
Technical Support.

Copying Projects
Do not attempt to copy or move a RequisitePro project by copying the project 
directory from one location to another. In this case, internal unique identifiers 
may cause conflicts if the project uses cross-project traceability.
If you are using an Access database for your RequisitePro project, there are two 
types of copying functions you can perform:
• You can move a project to another location and keep a backup copy. Refer 

to Moving Projects on page 14-20.
• You can create a new project that uses an existing project as a template. 

Document types, requirement types, attributes, user and group 
permissions, and views are all copied to the new project. Refer to Creating 
a Project Using an Existing Project as a Template on page 12-7. 

You can also split a project. Before you begin, we strongly recommend you 
archive your original project.
14-21



Managing Projects
1. Use the Project > Archive command to make a physical copy (B) of your 
RequisitePro project (A).

2. Open your copy (B) in RequisitePro and change the project name under the 
General tab of the Project Properties dialog box.

3. You can then delete requirements in each project to be left with one copy 
of each requirement in each project. See deleting requirements for more 
information.

Note: When performing any of the above procedures, note that you cannot 
merge the two copies of projects back together into one project.

If you are using an Oracle or SQL Server database for your RequisitePro 
project, do not attempt to create a copy of the project. In this case, copying the 
project directory does not copy the project database. Both copies of the project 
will continue to point to the same enterprise database instance. Conflicts 
between document and requirement updates will result.

Converting a Database
The Database Type Conversion Wizard is included with RequisitePro. It 
enables you to convert a RequisitePro project from one database type to 
another.
In most cases, the wizard is used to convert a project that uses a Microsoft 
Access database to an enterprise database (Oracle or Microsoft SQL Server); 
however, the wizard also supports the conversion of a project from an 
enterprise database to Access.
The Database Type Conversion Wizard requires that the following conditions 
be met prior to performing the database type conversion. The wizard displays 
messages to alert you if any conditions are not met.
• The project must be saved in the current version of RequisitePro. 
• You must have administrator permissions for the project.
• You must have log on and write permissions for the target database.
• Your database administrator must supply you with the user name and 

password, a server name, and a schema name in order to access the 
enterprise database.
14-22



Converting a Database
Note: For more information on configuring SQL Server or Oracle, see the 
guide Installing Rational RequisitePro.
If you have installed the Oracle Setup and the SQL Server Setup 
under the Custom / Full installation process, you can access the 
following instructions in your RequisitePro Help directory:
• Configuring Oracle for RequisitePro (oraclesetup.html)
• Configuring SQL Server for RequisitePro (sqlsetup.html)

Caution: It is strongly recommended that you archive or backup both the 
source and the destination database and related documents before continuing 
with the database type conversion (Refer to Archiving Projects on page 14-9).
To start the Database Type Conversion Wizard:
Note: Prior to running the wizard, you must open RequisitePro once. You 

can then close RequisitePro or leave it open. Be sure that the project 
you want to convert is not open in RequisitePro when you begin the 
conversion.

• Open the Database Type Conversion Wizard in Windows Explorer. The 
executable, rqdbtypewiz.exe, is located in the Rational\RequisitePro\bin\ 
directory.

• The Database Type Conversion Wizard introduction screen appears. Each 
screen of the wizard includes a Help button. To view step-by-step 
instructions about using the screen, click the Help button in that screen.
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Working with Project Information
Project administrators can modify information about a project, including:

• Document types
• Requirement types
• Requirement attributes
• Attribute values
• Cross-project traceability

Working with Document Types
You can create document types and modify existing document types. If you no 
longer need a document type, you can delete it.
A document type defines descriptive and operational information associated 
with a requirements document. The document type serves as a template for 
each document you create of that type.
The document type defines the document’s file extension, such as .prd; all 
documents of the same document type share the same file extension. The 
document type identifies a default requirement type; each new requirement you 
create in the document will be based on the default requirement type unless you 
indicate otherwise. The document type also identities an outline (or template) 
for the document, which controls its page layout, heading and paragraph styles, 
and a default font.
When you create or modify your project, you determine the document types to 
use in the project. Each document in your project must be associated with a 
document type. More than one document can be associated with the same 
document type.
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When you create a document, you associate it with a document type that you 
have already defined in your project. The document type defines the 
characteristics of the documents associated with the document type. This 
makes all documents of the same type consistent.
To help you define a common format for your document types, you can choose 
outlines included with RequisitePro to associate with new or existing 
document types.

Creating and Modifying Document Types
1. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears. 
2. Click the Document Types tab.

3. Do one of the following:
• To add a new document type, click Add.
• To modify an existing document type, select the requirement type in the 

list, and then click Edit.
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The Document Type dialog box appears.

4. In the Name text box, type a unique name for the document type.
5. In the Description text box, type a description. 
6. In the File Extension text box, type a file extension. Enter a three-

character text string, or, if long file names are supported, a longer 
extension. The file extension is applied to all documents associated with 
the document type.

7. Select a requirement type in the Default Requirement Type list. The 
default requirement type is used to specify the type of requirement that is 
created when Fast Create is used. 

8. In the Name text box below Outline, select an outline to associate with the 
document type. See Using RequisitePro Outlines on page 15-4 for more 
information on available outlines. If you use the default selection, None, 
Microsoft Word’s normal.dot template is used.

Note: If you select a new outline, the new outline applies to new documents 
only. Existing documents are not affected by the change. 

9. Click OK. The new or modified document type appears in the list box.
10. Click OK in the Project Properties dialog box.
Note: You can edit the .dot files associated with your document types to 

include your company name and other information specific to your 
organization. You can enter the company name, etc. in the Microsoft 
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Word File > Properties dialog box. Then in the document itself, 
right-click on the Company-Name field, and select Update Field. 
To create your own outline, see the next section.

Deleting Document Types
If no documents of a particular document type exist in a project, you can delete 
the document type.
1. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears.
2. Click the Document Types tab. 
3. In the Document Type list, select the document type you want to delete.
4. Click Delete.

Using RequisitePro Outlines
Outlines are templates that are useful for maintaining consistency across 
documents of the same type. Outlines can help you quickly create user-needs 
documents, specifications, and test plans. 
Every new document in RequisitePro includes default formatting information. 
New documents are based on document types, which include a default file 
extension, a default requirement type, and an associated outline. You can 
assign outlines to a document type in the Project Properties dialog box: 
Document Types tab.
RequisitePro includes the following outlines that can be used when creating 
document types in your project: 
• Product Requirements Outline
• Software Requirements Outline
• Test Design Outline
• Functional Test Case Specification
RequisitePro also includes these Rational Unified Process templates for 
requirements management:
• RUP Requirements Management Plan
• RUP Glossary
• RUP Vision Document
• RUP Stakeholder Requests
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• RUP Use Case Specification
• RUP Use Case Software Requirements Specification
• RUP Software Requirements Specification (Non-Use Case)
• RUP Supplementary Specification
• RUP Test Plan
RequisitePro includes these additional templates for business modeling:
• RUP Business Glossary
• RUP Business Rules
• RUP Business Vision
• RUP Business Use Case Specification
• RUP Business Use Case Realization Specification
• RUP Supplementary Business Specification
You can edit the .dot files associated with your document types to include your 
company name and other information specific to your organization. You can 
enter the company name, etc. in the Microsoft Word File > Properties dialog 
box. Then in the document itself, right-click on the Company-Name field, and 
select Update Field. To create your own outline, see the next section.

Creating Your Own Outlines
1. Start Microsoft Word outside of RequisitePro.
2. Create a new template. (See the Word documentation for more information 

about creating templates.)
3. Move the new template and help file to the RequisitePro Outlines 

directory.
Note: Templates are automatically stored in the RequisitePro Outlines 

subdirectory. You can set a second location for additional templates, 
such as those shared on a network or used by a particular project:
Use the Tools > Options command on the Tool Palette to specify a 
secondary location for the outlines. Type the full path and 
subdirectory name in the Outline Path field, and click OK.

4. In a text editor, create a new text file containing the following three lines 
of information, separated by carriage returns (<CR>):
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• The outline’s full name, up to 64 characters
Important: Be sure that this logical name is unique in the Outlines 
directory.

• A description of the outline, up to 256 characters
• The Word template’s DOS filename
For example:
Acme Enterprises Standard Software Requirement Specifications<CR>

Standard outline used for Software Requirements Specifications at 

Acme Enterprises<CR>

acme_srs.dot

In the Outlines directory, save the text file, using the same file name as the 
template and the extension .def (for example, acme_srs.def).

Working with Requirement Types
You can create requirement types and modify existing requirement types. If 
you no longer need a requirement type, you can delete it.
A requirement type defines descriptive and operational information associated 
with a requirement. A requirement type serves as a template for all 
requirements of the same type and is useful for ensuring consistency and 
classifying or grouping similar requirements in a project. Requirement types 
can specify: the initial numbering of the requirements; required terms, such as 
“must” or “shall”; a standard prefix, such as PR; and color and text formatting. 
Each requirement type has a unique set of user-defined attributes. 
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Creating and Modifying Requirement Types
1. On the Tool Palette, click Project > Properties.

The Project Properties dialog box appears.
2. Click the Requirement Types tab.

3. Do one of the following:
• To add a new requirement type, click Add.
• To modify an existing requirement type, select the requirement type in 

the list, and then click Edit.
4. The Requirement Type dialog box appears.

5. In the Name text box, type or edit a name for the requirement type.
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6. In the Description text box, type or edit a description. 
7. To enable external traceability between requirements of this type in this 

project and other projects, select the Allow External Traceability check 
box.

8. To specify the starting number for the first requirement of the defined type, 
click the Initial Requirement Number text box and type a positive 
integer to start this sequence. RequisitePro automatically numbers 
requirements when they are created. 
The default value for this text box is 1. The initial number sequence can be 
modified any time before the first requirement of this type is created. Once 
the first requirement of this type has been saved, you must use the 
Renumber Requirements dialog box to change the sequence. 

9. In the Requirement Must Contain text box, type a single word or phrase 
that must be included in every requirement of this type that is created. This 
field is optional and is not case-sensitive.

Note: Exclusive access to a project is necessary to modify the values in the 
following three steps for an existing requirement type. These options 
can be modified at any time.

10. In the Requirement Tag Prefix text box, type or edit a tag prefix. 
Examples of tag prefixes are SR, PR and TST. 

11. In the Requirement Color list, click the down arrow and select a color. 
The color is assigned to a requirement of this type when it is displayed in 
a document. The default color is blue.

12. In the Requirement Style list, click the down arrow and select a style. The 
style is assigned to a requirement of this type when it is displayed in a 
document. The default style for this text box is Double Underline. You 
can also select Normal (no styling) or Small Capitals. 

13. Click OK. In the Project Properties dialog box, Requirement Types tab, 
RequisitePro displays the new or edited requirement type with its tag 
prefix and logical name. For example, TEST: Test Plan.

14. Click OK to close the Project Properties dialog box.

Deleting Requirement Types
You can delete a requirement type if there are no requirements of this type in 
the project and if document types do not reference it as a default. You must 
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have the project opened in exclusive mode to delete requirement types.
1. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears.
2. Click the Requirement Types tab.
3. Select the requirement type you want to delete.
4. Click Delete.
5. Click OK.

Working with Requirement Attributes
Use the Attributes tab in the Project Properties dialog box to add an attribute. 
You can also use this tab to modify an existing attribute.
The following table shows suggested attributes that can be helpful for defining 
your requirements in RequisitePro. These attributes are suggestions, not rules. 
You can use these suggested attributes, which are provided with RequisitePro, 
or you can define and use any attributes that are appropriate for your project 
and business.

Attribute Use to identify requirements by

Priority Importance to the project. Helps team members prioritize their 
efforts and use their time more effectively.

Status Progress.

• If a requirement’s status is Proposed, the requirement 
is currently being discussed by the project team. 

• If a requirement’s status is Approved, the requirement 
has been discussed and agreed upon.

• If a requirement’s status is Incorporated, the 
requirement has been added to the appropriate 
specification.

Authors Individual or team that created or changed the requirement’s 
text or attributes.

Responsible Party Individual or team responsible for ensuring the requirement is 
satisfied.
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Note: The list of requirement attributes above provides examples. Other 
common attributes include Difficulty, Stability, Risk, Security, Safety, 
Release Implemented and Functional Area.
In addition to the attributes mentioned above, RequisitePro maintains 
system attributes for all requirement, including date, version and 
relationship to other requirements.

You can create and control attributes according to your needs. Regardless of 
the attributes you use, RequisitePro offers the flexibility to easily customize 
your project documents and databases to define, articulate and manage the 
processes and culture of your organization.
You cannot delete requirement attributes if requirements of the requirement 
type already exist, or if the requirement type is the default of a document type. 

Creating and Modifying Requirement Attributes
Use the Attributes tab in the Project Properties dialog box to describe the 
characteristics or properties of a requirement type. 
1. On the Tool Palette, click Project > Properties. 

The Project Properties dialog box appears.
2. Click the Attributes tab.
The attributes for the selected type are displayed in the same order as in the 
Requirement Properties dialog box

Rationale Text of or reference to an explanation. For example, the 
reference might be to a page and line number of a product 
requirement specification, or to a minute marker on a video 
tape of an important customer interview.

Cost Cost to implement the requirement. The attribute value for this 
attribute can be logical (high, medium, low) or numerical.

Attribute Use to identify requirements by
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.

3. To reorder attributes, select the attribute in the Labels list and then click 
the Move Up or Move Down button. 

4. For list-type attributes, to designate a value as the default value, select the 
attribute in the Label box. In the Values per Attribute box, select the 
value and click Default.

5. To add an attribute, click Add.
The Add Attribute dialog box appears. 

6. In the Type list, select a type. The following data types are supported:

Data Type Allows Example

List (Single 
Value)

A set of values from which a single 
value can be selected. Each List value 
can be up to 20 characters in length.

High, Medium or Low

List (Multiple 
Value)

A set of values from which more than 
one value can be selected. Each List 
value can be up to 20 characters in 
length. 

Sue, Bob, John

Text A text string. John Smith

Integer Whole numbers in the field. 5 or 1500

Real Real numbers in the field. 1.345 or 6.7

Date A date in the format defined by the 
user’s Windows setting. 

mm/dd/yy
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The dialog box changes, depending on the type you select. If you select 
List (Single Value) or List (Multiple Value), the dialog box contains a 
List Values text box. If you select one of the other types, the dialog box 
contains a Default Value text box.

7. In the Label text box, type a name.
8. If the data type is a list-type, in the List Values text box, type the values. 
9. If the data type is an entry-type, enter a default value (optional). If a new 

requirement is created and a value is not specified for the attribute, 
RequisitePro uses the default value.

10. To hide attributes of the selected requirement type from general 
RequisitePro users in the Views Workplace and in the Requirement 
Properties dialog box, select the Hidden from display check box.

11. To ensure traceability relationships are marked as Suspect when attributes 
are changed, mark the Change Affects Suspect check box. When this 
check box is selected, RequisitePro monitors all requirements (based on 
this requirement type) and ensures that the status of all relationships 
labeled Traced to and Traced from for this requirement is changed to 
Traced-Suspect if the attribute value is changed.

12. Click OK. The new or edited attribute appears in the Attributes tab of the 
Project Properties dialog box.

13. Click OK to close the Project Properties dialog box and save the changes.

Time A time in the format defined by a 
user’s Windows setting. 

10:00 AM

Data Type Allows Example
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Working with Requirement Attribute Values
You can add and edit the values assigned to a particular list-type attribute. Or, 
you can delete an attribute value.

Modifying Attribute Values
1. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears.
2. Click the Attributes tab.
3. In the Requirement Type list, select the requirement type.
4. In the Labels for Attributes list, select a single or multiple-value list-type 

attribute.
5. In the Values per Attribute list, select the value that you want to edit.
6. Click Edit. The Attribute Value dialog box appears. 

7. In the Value text box, modify the value.
8. To use the value as the default value, mark the Use as default check box.
9. Click OK. The changes to the attribute values appear in the Attributes tab 

of the Project Properties dialog box.
10. Click OK to close the Project Properties dialog box.

Deleting Attribute Values
To delete attribute values, you must have the project opened exclusively.
1. On the Tool Palette, click Project > Properties. The Project Properties 

dialog box appears.
2. Click the Attributes tab.
3. In the Requirement Type list, select the requirement type.
4. In the Labels for Attributes list, select the list-type attribute.
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5. In the Values per Attribute list, select the value that you want to delete.
6. Click Delete. 

If the value is not assigned to any requirements in the project, the value is 
deleted.
If the value is assigned to any requirements in the project, the Remove 
Value dialog box appears:

• In the list, select a value to use as a replacement for the removed value.
• Click OK. The value is removed from the Values per Attribute list.

7. Click OK to close the Project Properties dialog box.

Setting Up and Modifying Cross-Project Traceability
Cross-project traceability enables direct traceability relationships between 
requirements in different RequisitePro projects. This RequisitePro feature 
eliminates duplication by allowing reuse of requirements among various 
teams working on related projects. Often a set of requirements is common to 
multiple projects. These requirements can be created in their own 
RequisitePro projects and traced to system-specific requirements located in 
their respective RequisitePro projects.
Projects must be created prior to setting up cross-project traceability. You can 
configure projects to automatically connect to external projects when a 
project with externally traced requirements is opened. You can also connect 
external projects manually.
After you connect an external project, all externally traced requirement types 
are available for traceability relationships. External requirement types are 
displayed in the RequisitePro dialog boxes used to create traceability 
relationships. External requirements are identified with a project prefix set in 
the General tab of the Project Properties dialog box for the external project.
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Marking Requirement Types for Cross-Project Traceability
To allow cross-project traceability for requirements in a project, you must do 
the following:

• Assign a project prefix so you can distinguish between requirements in 
different projects.

• Manually mark requirement types in the project as externally available. 
Only requirements of these types will be available for cross-project 
traceability.

1. On the Tool Palette, click Project > Properties. The Project Properties 
dialog box appears.

2. If it is not already displayed, click the General tab.
3. If the project does not have a prefix, enter a prefix for the project (up to 8 

characters). The prefix is stored in uppercase letters. You can change it at 
any time.

4. Click the Requirement Types tab.
5. In the Requirement Type list box, select the requirement type to mark for 

external traceability.
6. Click Edit.

The Requirement Type dialog box appears.

7. Mark the Allow External Traceability check box.
8. Click OK. 
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RequisitePro marks the requirement type for cross-project traceability.
9. Repeat steps 5 through 8 for any other requirement types.
10. Click OK to close the Project Properties dialog box.

Connecting Projects
Once the requirement types in the external projects have been marked for 
external traceability, connect the external projects to the currently open 
project. 
To view external projects, click Project > External Projects.
The External Projects dialog box appears.

It displays the following:
• Prefix - an identifier for the project. In an external project, the project 

prefix appears before the requirement tag, separated from the tag by a 
decimal. For example, if a requirement’s tag is PR234 and the project’s 
prefix is GLOBAL, then the external requirement is displayed as 
GLOBAL.PR234. The prefix can be up to 8 characters, and must be 
uppercase letters. You can change the prefix at any time in the General 
tab of the Project Properties dialog box.

• Name - the name of the external project.
• Status - indicates whether the project is currently connected or 

disconnected.
• Location - indicates the location of the project.
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To add a project as an external project:
1. In the External Projects dialog box, click Add. The Add External Project 

dialog box appears.
2. Locate the project and click Open.
3. To automatically open the external project when the current project is 

opened, click the Connect to the external projects at project open check 
box.
Note: In this case, when you open the project, one of several conditions 

apply:
• If neither project is secured, you are not required to log on to the 
project.
• If the project is secured and your user name and password are 
different than those used to log on to the secured project, the 
Project Logon dialog box appears. Log on to the project as you 
normally would. (If your user name and password are the same in 
both projects, you will not be required to log on multiple times.)
• If the project is not secured and the external project is secured, 
the Project Logon dialog box appears. Log on to the project as 
you normally would. 

4. To connect other external projects, repeat the above steps.
5. To remove a project from the External Projects dialog box, select the 

project and click the Remove button.
Note: If you remove a project with requirements that participate in 

external traceability, RequisitePro warns you about deleting the 
references. 
If the external project is not accessible, RequisitePro warns you 
the current project will be updated and the external project will 
contain invalid references until it is opened and synchronized.
If an external project is moved, an error message appears, 
indicating that the project cannot be found. 

6. Select the project from the External Project References list, and click 
Browse to relocate the project. Locate the project and click Open. 
Note: The Browse button is only active when a project has been moved 

or cannot be located.
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Disconnecting Projects
You can disconnect external projects when they are not needed or are 
unavailable. For example, you may want to disconnect projects when you are 
working in a distributed mode and the database is unavailable. 
If you are not currently working on traceability relationships, disconnecting 
will increase system performance. A project must be disconnected before you 
can relocate it.
1. On the Tool Palette, click Project > External Projects.

The External Projects dialog box appears. 
2. Select the project and click Disconnect. This temporarily disconnects the 

project. 
3. To reconnect the project, select the project and click Connect (the 

Disconnect button automatically changes to a Connect button when you 
select a disconnected project, and the Connect button automatically 
changes to a Disconnect button when you select a connected project).

Results of Disconnecting an External Project
When you disconnect an external project:
• Requirements display in the traceability matrix and attribute matrix with a 

label marking them as disconnected external requirements.
• You cannot create traceability relationships with requirements in the 

disconnected project.
• You cannot change traceability relationships with requirements in the 

disconnected project.
• If you delete a requirement or its traceability state changes to Suspect, 

external requirements relationships are updated with the new state. 
• Any changes to requirements in the external project are updated in the 

disconnected project when the project is opened. You can see these 
changes, but you cannot update them.
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Relocating an External Project
To relocate an external project, you must first disconnect it.
1. On the Tool Palette, click Project > External Projects.

The External Projects dialog box appears.
2. Select the project, and then click Disconnect.
3. In File Manager or Windows Explorer, move the project’s .rqs file to the 

new location.
4. In the External Projects dialog box, in the External Project References 

listing, select the project.
5. Click Browse.
6. Click Open.
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Integrating with Other Products
RequisitePro is integrated out-of-the-box with several tools:
• Microsoft Project
• Rational ClearQuest
• Rational Rose 
• Rational TestManager
• Rational SoDA
• Rational ClearCase
• Rational Unified Process
• Rational Synchronizer
In addition, RequisitePro is included in all Rational Suite products as part of 
the Rational Team Unifying Platform, which also includes: Rational 
ClearQuest, Rational SoDA, and the Rational Unified Process.

Using Microsoft Project with RequisitePro
The MS Project Integration Wizard manages traceability from requirements in 
RequisitePro projects to tasks in Microsoft Project schedules. You can use the 
wizard to:
• Create tasks from requirements and establish traceability relationships 

from those requirements to the tasks.
• Add or remove traceability from requirements to existing tasks.
After you have established traceability you can:
• Refresh MSPT requirement information within RequisitePro that links to 

the traced tasks in Microsoft Project. 
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• Review suspect traceability relationships between requirements and tasks 
in a RequisitePro Traceability Tree or Traceability Matrix.

• Analyze the impact on the requirements, the tasks, the project, and the 
schedule as changes occur.

Tips for using MS Project with RequisitePro
Follow these guidelines when using the MS Project integration:
• Create a task from any requirement that generates tasks you wish to track 

in MS Project. For example, if a Feature requirement needs to have a 
document, go through a review, for approval, you might want to generate 
a task for this requirement. 

• If you follow the Rational Unified Process, a use case is probably the main 
item that should appear in your schedule. It may also make sense to trace 
each alternative flow, and/or each individual step in a use case. 
Supplementary requirements are also candidates for the schedule, but the 
process associated with a supplementary requirement is highly dependent 
on the nature of the requirement - e.g. performance constraints have one 
set of tasks, usability constraints have a different set of tasks. 

• Whatever level of requirements are handed off to the development team is 
the level that should appear in the schedule. 

• Map the requirements that have activities associated with them. For 
example, if you have a parent requirement and all the children are 
approved for a release, you might want to generate a task linked to the 
parent. If only one of the children is approved, just link the child. If the 
children are sufficiently weighty, then you may want to bring over the 
parent and children as a task hierarchy. 

• If you have a requirement attribute to designate a product release number, 
you might want a schedule just for requirements assigned to the same 
release number. 

• If you have an “assigned-to” requirement attribute, you might want to 
generate a schedule for everything assigned to each developer.
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Requirements

Software Requirements
Microsoft Project 98 must be installed on your system in order to use the MS 
Project Integration Wizard. If not, the Start Microsoft Project and Integration 
Wizard options are disabled on your RequisitePro Tools menu.

Security Requirements
In order to initially integrate a RequisitePro project with Microsoft Project 
using the wizard, you must have RequisitePro administrator permissions.
In order to use the MS Project Integration Wizard in subsequent sessions:
• You must have create and delete permissions for the MSPT requirement 

type. 
• You must have attribute update permissions for all attributes associated 

with the MSPT requirement type.

MSPT Requirement Types
Requirements and tasks are linked using a special requirement type, the MSPT 
requirement type. This requirement type is a place holder in a RequisitePro 
project that represents a task in a schedule. The MSPT requirement type is 
linked to a task in a schedule. It contains, as requirement attributes, the 
Microsoft Project file name and a unique ID of the task it represents.
The MSPT requirement type also includes default attributes that are based on 
task fields in Microsoft Project. These default attributes are Cost, Duration, 
Finish, Milestone, Priority, Resource Names, and Start.
You can also map Microsoft Project fields to RequisitePro attributes for the 
MSPT requirement type in the .rqs file of your RequisitePro project. For more 
information about the MSPT requirement type, see Working with the MSPT 
Requirement Type on page 16-8.

Starting the Wizard and Adding the MSPT Requirement Type
You can start the MS Project Integration Wizard from within RequisitePro or 
run it as an independent application. These instructions explain how to start the 
wizard from within RequisitePro. 
Note: Make sure that you have closed any open dialog boxes in Microsoft 

Project before you use the MS Project Integration Wizard.
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To start the MS Project Integration Wizard:
1. On the Tool Palette, click Tools > Microsoft Project Integration 

Wizard. The introduction screen appears.
2. Click Next. The Select Project Files screen appears.
3. Select a project. The list displays all projects in your RequisitePro project 

list.
4. Do one of the following:

• Enter the name and path of an existing Microsoft Project schedule.
• Click Browse to locate, select, and open an existing schedule in 

Microsoft Project.
• Click New to create a new schedule. The Project Info dialog box 

appears. When you are finished creating the new schedule, click OK in 
the Project Info dialog box. A dialog box appears, prompting you to 
save the new project. After saving the schedule, the wizard minimizes 
Microsoft Project, returns to this screen, and adds the new schedule 
name to the Microsoft Project Schedule text box.

5. Click Next. If the project you selected has security enabled, the Logon 
dialog box appears. Log on as you would to a secured RequisitePro project.
The wizard checks the project and searches for the MSPT requirement 
type. If the wizard does not find the MSPT requirement type, the wizard 
adds it and displays the MSPT Info screen. Click Next.
The wizard opens the project and schedule and displays the Select an 
Action screen.

Creating Tasks from Requirements
The following instructions assume the wizard is started and the Select An 
Action screen is displayed. Use this feature to select requirements in 
RequisitePro in order to create new tasks in Microsoft Project that are linked 
to the RequisitePro requirements.
Note: The first time the “Select An Action” screen appears after you select a 

new schedule, only the first option is available. After tasks have been 
created, the other options become available.

1. Select the option “Select requirements to create tasks, or add and 
remove traceability to existing tasks.”

2. Click Next.
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3. In the Requirement Type list, select a requirement type.
4. Click one of the following:

• All requirements of selected type. 
• Requirements of this attribute value. 

- In the Attribute list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example, the 
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supported.

5. Click Next. The screen displays the Task Traceability Tree for the 
requirements that you filtered in the previous screen.

6. Select one or more requirements and select Create Tasks. 
7. Click Next. At the next screen, click Finish.
Note: Each time you make a change to a schedule, a dialog box appears, 

prompting you to save with or without a baseline. We recommend 
saving with a baseline for each change. See the Microsoft Project 
documentation for more information about baselines.

8. Click Exit to close the wizard, or click Another Action to return to the 
“Select an Action” screen where you can create more tasks, add or remove 
traceability, and refresh requirement information from Microsoft Project.

Adding or Removing Traceability
The following instructions assume the wizard is started and the Select An 
Action screen is displayed and that you have created tasks in Microsoft Project 
that are linked to requirements in RequisitePro.
You have two options for modifying traceability in the MS Project Integration 
Wizard. You can:
• select a RequisitePro requirement and link it to a Microsoft Project task, or
• select a Microsoft Project task and link it to a RequisitePro requirement.
Both option are covered in the two procedures below.
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Selecting Requirements to Modify Traceability
At the Select An Action screen:
1. Select the option “Select requirements to create tasks, or add and re-

move traceability to existing tasks.” 
2. Click Next. 
3. In the Requirement Type list, select a requirement type.
4. Click one of the following:

• All requirements of selected type. 
• Requirements of this attribute value. 

- In the Attribute list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example, the 
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supported.

5. Click Next.
The screen displays the task traceability tree for the requirements that you 
filtered in the previous screen.
To remove traceability between the selected task and requirement:
1. Select one or more tasks and then click Remove traceability, and click 

Finish. The traceability between the selected tasks and requirement is re-
moved. Note that the tasks remain in the Microsoft Project schedule.

2. Click Exit to close the wizard, or click Another Action to return to the 
“Select an Action” screen where you can create more tasks, add or remove 
traceability, and refresh requirement information from Microsoft Project.

To add traceability between the selected requirements and a task:
1. Select a requirement and click Add Traceability. Traceability is created 

for one requirement at a time. 
2. Click Next to advance to the next screen and select a task.
3. Do one of the following:

• If you are satisfied with the current task selection, click Finish.
• To change the selection, click MS Project to display the schedule and 

select one or more tasks. Return to the Integration Wizard and click 
Refresh Task List to refresh the task display. Then click Finish.
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Selecting Tasks to Modify Traceability
At the Select An Action screen:
1. Select the option “Select tasks to add or remove traceability” and click 

Next.
The Select Tasks screen appears.

2. Do one of the following:
• If you are satisfied with the current task selection, click Next.
• To modify the selection, click MS Project to display the schedule and 

select one or more tasks. Return to the Integration Wizard and click the 
Refresh Task List to refresh the task display. Then click Next.

This screen displays the Task Traceability Tree for the tasks you selected 
in the previous screen and the requirements from which the tasks are 
traced.

3. Do one of the following:
• To display the task in the Microsoft Project schedule, select a task and 

click Go to Task. In the schedule, you can view the task or make 
modifications. When you are finished, return to the Integration Wizard. 

• Select a requirement and the Remove traceability option. Then click 
Finish. The traceability between the selected task and requirement is 
removed.

• Select a task and the Add Traceability option. Then click Next. The 
Select a Requirement Type screen appears. Continue to the step 4.

4. In the Requirement Type list, select a requirement type.
5. Click one of the following:

• All requirements of selected type. 
• Requirements of this attribute value. 

- In the Attribute list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example, the 
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supported.

6. To go to the next screen of the wizard, click Next. The screen displays the 
requirements that you filtered in the previous screen.
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7. Select a requirement. To display the requirements without tasks, select the 
Show only requirements with no tasks check box.

8. Click Finish.

Refreshing MSPT Requirement Information from Tasks
The following instructions assume the Select An Action screen in the MS 
Project Integration Wizard is displayed and that you have created tasks in 
Microsoft Project that are linked to MSPT requirements, which represent the 
tasks in RequisitePro. Traceability should be established between your product 
requirements and the MSPT requirements.
When the values in the Microsoft Project task fields are changed, you need to 
use the refresh feature in the MS Project Integration Wizard to update the 
corresponding attribute values in the MSPT requirements. The resulting 
changes to the MSPT attribute values cause the traceability relationships 
between your product requirements and the MSPT requirements to be marked 
as suspect. This suspect condition alerts you of changes in the Microsoft 
Project schedule.
You can then view the suspect relationships in a Traceability Matrix that 
includes your product requirements and the MSPT requirements; or you can 
review the changes to the MSPT attribute values using an Attribute Matrix of 
the MSPT requirement type.
To refresh the MSPT requirements from the Microsoft Project tasks:
1. At the Select an Action screen, select the option “Refresh MSPT 

information from MS Project tasks” and click Next.
The Update screen displays the list of changes to occur when RequisitePro 
is updated with a Microsoft Project tasks.

2. To proceed with the integration, click Finish.

Working with the MSPT Requirement Type

Viewing the MSPT Requirement Type
You can view the MSPT requirement type in a view in RequisitePro.
1. In the Views Workplace, click File > New View, or click the New View 

icon.
2. Select one of the following views:
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• Select an Attribute Matrix and the MSPT requirement type to review 
the changes to the MSPT attribute values.

• Select a Traceability Matrix. Select the requirement types for your 
product requirements (in the row requirements) and the MSPT 
requirements (in the column requirements). The traceability is displayed 
between the requirement types.

• Select a Traceability Tree. Select the product requirement type and 
expand the display to view the traceability relationships to the MSPT 
requirements.

3. Click OK.

Mapping Fields to Attributes for the MSPT Requirement Type
Unlike other requirement types, you cannot add a new attribute to the MSPT 
requirement type using the Attributes tab on the Project Properties dialog box. 
You can, however, create attributes for the MSPT requirement type in the .rqs 
file for the RequisitePro project in which you are working. For example, if the 
name of the project you are working on is “blueproject,” then you use the 
blueproject.rqs file to create new attributes for the MSPT requirement type.
If security is enabled, you must have project structure permission to map a field 
to an attribute for an MSPT requirement type.
To map fields to attributes:
1. Refer to Microsoft Project Field IDs on page 16-10 to locate the task field 

which you want to map to an attribute for the MSPT requirement type.
2. In a text editor, open the .rqs file for the project with which you are 

working. 
3. In the [MSProjectMappings] section of the .rqs file, enter the following:

field ID=attribute name
where field ID is the field ID listed in Microsoft Project Field IDs on page 
16-10 and attribute name is the label you want to give the attribute in 
RequisitePro.

4. Save the .rqs file.
The MS Project Integration Wizard will create an attribute for the MSPT 
requirement type based on the information entered.
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Microsoft Project Field IDs
Use the following Microsoft Project field IDs to map attributes for the MSPT 
requirement type in RequisitePro to corresponding constants in Microsoft 
Project. Add your entries to the [MSProjectMappings] section in <project 
name>.rqs file using a text editor. 
Use the following format:

field ID=attribute name 
where field ID is the numeric constant listed below and the attribute name is 
the label you want to give the attribute in RequisitePro. Field IDs shown in 
bold are already provided as default attributes for the MSPT requirement type.
Actual Cost = 7 Actual Duration = 28 Actual Finish = 42
Actual Start = 41 Actual Work = 2 Baseline Cost = 6
Baseline Duration = 27 Baseline Finish = 44 Baseline Start = 43
Baseline Work = 1 BCWP = 11 BCWS = 12
Confirmed = 110 Constraint Date = 18 Constraint Type = 17
Contact = 112 Cost = 5 Cost1 = 106
Cost2 = 107 Cost3 = 108 Cost Variance = 9
Created = 93 Critical = 19 CV = 83
Delay = 20 Duration = 29 Duration1 = 103
Duration2 = 104 Duration3 = 105 Duration Variance = 30
Early Finish = 38 Early Start = 37 Finish = 36
Finish1 = 53 Finish2 = 56 Finish3 = 59
Finish4 = 62 Finish5 = 65 Finish Variance = 46
Fixed Cost = 8 Fixed (Duration) = 34 Flag1 = 72
Flag10 = 81 Flag2 = 73 Flag3 = 74
Flag4 = 75 Flag5=76 Flag6 = 77
Flag7 = 78 Flag8 = 79 Flag9 = 80
Free Slack = 21 Hide Bar = 109 ID = 23
Late Finish = 40 Late Start = 39 Linked Fields = 98
Marked = 71 Milestone = 24 Name = 14
Notes = 15 Number1 = 87 Number2 = 88
Number3 = 89 Number4 = 90 Number5 = 91
Objects = 97 Outline Level = 85 Outline Number = 102
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% Complete = 32 % Work Complete = 33 Predecessors = 47
Priority = 25 Project = 84 Remaining Cost = 10
Remaining Duration = 31 Remaining Work = 4 Resource Group = 113
Resource Initials = 50 Resource Names = 49 Resume = 99
Resume No Earlier Than = 101Rollup = 82 Sheet Notes = 94
Start = 35 Start1 = 52 Start2 = 55
Start3  = 58 Start4 = 61 Start5 = 64
Start Variance = 45 Stop = 100 Subproject File = 26
Successors = 48 Summary = 92 SV = 13
Text1 = 51 Text10 = 70 Text2 = 54
Text3 = 57 Text4 = 60 Text5 = 63
Text6 = 66 Text7 = 67 Text8 = 68
Text9 = 69 Total Slack = 22 Unique ID = 86
Unique ID Predecessors = 95 Unique ID Successors = 96 Update Needed = 111
WBS = 16 Work = 0 Work Variance = 3

Deleting Attributes for MSPT Requirement Types
To delete an attribute for an MSPT requirement type, you must have project 
structure permission to remove a requirement type (if security is enabled).
To delete attributes:
1. Open the RequisitePro project file (projectname.rqs) with a text editor.
2. In the project file, under the heading [MSProjectMappings], locate the 

requirement attribute that you want to delete. Attributes are listed with the 
Microsoft Project field ID, followed by an equal sign (=), and the attribute 
name; for example, 5=Cost.

3. Delete the entire line that contains the attribute. Save and close the project 
file.

4. In the RequisitePro Tool Palette, click Project > Open.
5. Select the project, check the Exclusive check box, and click OK. Log on 

to the project, if necessary.
6. On the Tool Palette, click the Tools > Microsoft Project > Integration 

Wizard.
7. Click Next. Be sure that the current RequisitePro project and related 

Microsoft Project are selected. Click Next.
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8. Select the option “Refresh MSPT information from MS Project tasks.” 
Click Next. 

9. After the processing is complete, click Finish. Click Exit and Yes at the 
confirmation prompt.

Using Rational ClearQuest with RequisitePro
If you have ClearQuest or any Rational Suites product installed on your PC, 
you can launch ClearQuest directly from the RequisitePro Tools menu (click 
Tools > Rational ClearQuest).
ClearQuest is a Windows change request management product designed for 
the dynamic and evolving nature of software development. ClearQuest offers 
a flexible approach to track and manage all the change activities that are 
associated with an organization. With it, team members can customize and 
define queries, fields, activities, and states specific to their environment. This 
expanded level of customization makes the process of managing change easy 
for a team to implement, deploy, and maintain. 
If you have Rational Suite AnalystStudio, you can collect enhancement 
requests and defects in ClearQuest and associate them with new or existing 
requirements in RequisitePro. From RequisitePro, you can use custom 
requirement attributes to associate a requirement with one or many ClearQuest 
records. Refer to Getting Started with Rational Suite AnalystStudio and the 
Using Rational ClearQuest and RequisitePro for Analysts white paper for 
more information on this integration. For information on configuring this 
integration, refer to the book Configuring Rational Suites on the Rational 
Suites documentation CD.

Using Rational Rose with RequisitePro
Rational Rose offers powerful tools for object-oriented analysis, modeling, 
design, and construction. As the world’s leading visual modeling tool, Rational 
Rose enables system analysts to start modeling requirements with use cases 
and actors and enables developers to define and communicate a software 
architecture. 
You can open Rose directly from RequisitePro by clicking Tools > Rational 
Rose, and you can associate Rose use cases with RequisitePro requirements 
and documents using Integrated Use Case Management.
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Integrated Use Case Management
Rational’s integrated management of use cases between Rational Rose and 
RequisitePro allows you to start or work in either environment, according to 
your process.
Integrated Use Case Management allows you to manage use cases using 
attributes, such as Priority, Risk, Status, and Iteration, by associating Rose use 
cases with RequisitePro documents and requirements. You can easily navigate 
from Rose use-case models to RequisitePro use-case documents and 
requirements and vice versa.
Use-case management in RequisitePro adds depth and relational information 
to your Rose use cases with support for:
• textual definitions of use cases in a Microsoft Word documents; 
• detailed descriptions of flows of events, special requirements, 

preconditions and postconditions; 
• hierarchical (parent/child) relationships between use-case names and 

actions within the use-case flow of events; 
• traceability to and from other use cases, associated design features, and test 

plans. 
We recommend that you initially develop your use cases in Rose and then 
detail and manage them in RequisitePro using Integrated Use Case 
Management. This approach accomplishes associations between Rose and 
RequisitePro with several easy menu selections.
To associate a Rose model or package with a RequisitePro project, open the 
model or package in Rose and use the commands on the Tools > RequisitePro 
menu. Refer to online help in Rose for more information on Integrated Use 
Case Management.
Refer to Getting Started with Rational Suite AnalystStudio for more 
information on Integrated Use Case Management.

Using Rational Robot’s TestManager Component with 
RequisitePro

If you have Rational Robot installed, you can launch the TestManager 
component directly from the RequisitePro Tools menu (click Tools > Rational 
TestManager).
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Rational Robot is part of Rational TeamTest, Rational Suite TestStudio, and 
Rational Suite PerformanceStudio. The TestManager component is an 
information management tool for software development and testing 
professionals, designed to help track software testing information through all 
phases of the software development, test, and revision cycles. You can use 
TestManager to plan testing strategies, and to track information related to test 
execution. TestManager has features that can be used by all members of the 
software development and testing team and lets you manage the software 
quality assurance process from the beginning of product development all the 
way through product delivery.
The integration between RequisitePro and TestManager is set up through a 
shared Rational Repository using Rational Administrator. Test requirements 
defined in TestManager are stored in a shared RequisitePro database. Once you 
have opened TestManager, you can click File > Open Requirements to view 
RequisitePro requirements. You can set the requirement type by clicking View 
> Select Requirement Type.

Using Rational SoDA with RequisitePro
RequisitePro is a supported domain for Rational SoDA. This allows you to 
create reports that extract information from various data sources, including a 
RequisitePro database. 
Using SoDA and RequisitePro, you can:
• Use SoDA to modify and generate SoDA reports and documents from an 

open RequisitePro project. 
• Use SoDA and RequisitePro to create a report that consolidates 

RequisitePro requirements information and Rose modeling information. 
For more information, refer to Printing Project Summaries and Reports on 
page 14-2.

Using Rational ClearCase with RequisitePro
You can archive RequisitePro projects with Rational ClearCase using the 
Project > Archive > Rational ClearCase command on the Tool Palette. 
For more information, refer to Archiving Projects with Rational ClearCase on 
page 14-11.
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Using the Rational Unified Process with RequisitePro
The Rational Unified Process is an online knowledge base of proven software-
development principles. As a software engineering process, RUP provides a 
disciplined approach to assigning tasks and responsibilities within a 
development organization. Its goal is to ensure the production of high-quality 
software that meets the needs of its end users, within a predictable schedule and 
budget. The Rational Unified Process captures many of the best practices in 
modern software development in a form that can be tailored to a wide range of 
projects and organizations. Many activities in the Rational Unified Process are 
supported by software-engineering tools. Tool Mentors provide descriptions 
on how Rational Software tools can be used to support particular steps and 
activities.
The RequisitePro Project Template provides a basic project structure that uses 
the Rational Unified Process. The project template provides requirement types, 
suggested attributes, default attribute values, and related document types.

Using the Rational Synchronizer with RequisitePro
The Rational Synchronizer automates the creation and updating of items in 
your project. The Synchronizer works with items in RequisitePro (such as, 
requirements), items in Rose (such as actors), and items in TestStudio (such 
as scripts). The Synchronizer uses either predefined or user-defined rules to 
determine which items to create or update. You can use the Synchronizer to 
update items in Rational Products that are not linked by other integrations 
listed above.
For example, your project may contain a rule that says “For every actor 
requirement in RequisitePro, create a corresponding actor in Rose, if one does 
not already exist.” When requirements change, this rule communicates 
changes accurately and promptly to the team that is working on design and 
analysis in Rose. 
With Rose, the Rational Synchronizer allows you to automatically create Rose 
items (such as actors and classes) from existing requirements, and maintain the 
Rose items and their matching RequisitePro requirements in sync. 
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Integrating with Other Products
The Synchronizer is shipped with RequisitePro but the option to install it is not 
checked by default when you are installing RequisitePro. You must select the 
Custom / Full option and then mark the Rational Synchronizer check box. 
Once it is installed, you can launch the Synchronizer from RequisitePro by 
clicking Tools > Rational Synchronizer.
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Keyboard Shortcuts and Mouse Actions

Dialog Box Shortcuts
You can use keyboard combinations to move to tabs, fields, and buttons in a 
RequisitePro dialog box. To use a dialog box shortcut, press the ALT key while 
simultaneously pressing the underlined letter in a dialog box tab, field, or 
button. For example, in the Project Properties, Document Properties, or 
Requirement Properties dialog box, press ALT-G to open the General tab.

Menu Shortcuts
You can use combinations of keyboard shortcuts to open a menu in the Tool 
Palette or Views Workplace. To use a menu shortcut, press the ALT key while 
simultaneously pressing the underlined letter in the menu. For example, to 
open the Requirement menu, press ALT-R. Once a menu is displayed, you can 
select a command by pressing the underlined letter in the command.

Selecting Multiple Items in RequisitePro
You can use mouse actions and combinations of keyboard and mouse actions 
to select more than one item in various RequisitePro lists.
The following are referred to as multiple select actions in RequisitePro 
documentation:

• SHIFT-click: To click the mouse button while holding down the SHIFT 
key.

• CTRL-click: To click the mouse button while holding down the Control 
key.
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• Drag: To hold down the right mouse button while moving the mouse and 
then releasing the button.

You can use the actions in the following ways:
• To select adjacent items, use SHIFT-click or drag.
• To select nonadjacent items, use CTRL-click.

The anchor is the first item you click when using multiple select actions to 
select a range of items. In RequisitePro, the term “anchor” is generally used to 
mean the first cell you click in a view in the Views Workplace. You use the 
anchor to select a range of cells. For example, if you click the cell in row 1, 
column 1 of a Traceability Matrix, that cell becomes the anchor. If you then 
SHIFT-click the cell in row 10, column 3 of the matrix, all of the cells in rows 
1 through 10, columns 1 through 3, are selected. To reset the anchor, click 
anywhere outside the range. The cell you click is the new anchor. You can also 
use an anchor to select a range of items in documents and in certain dialog 
boxes that support multiple select actions.
A-2



Mouse Actions and Shortcuts in the Views Workplace
Mouse Actions and Shortcuts in the Views Workplace
You can use keyboard shortcuts and mouse actions to quickly move around 
and select information in the Views Workplace. The keyboard shortcuts and 
mouse actions differ in each view. 
The following tables provide specific shortcuts for selecting items in an 
Attribute Matrix, a Traceability Matrix, or a Traceability Tree.

Attribute Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this

Select the requirement in the row in which 
you click. 

(This action also clears all selected items 
and sets the selected row as the anchor. 
Clicking in cell also changes the selected 
column to the column in which you 
clicked.)

Click row label

OR

Click cell

Select the requirements between the anchor 
row and the row in which you SHIFT-click.

(This action clears any rows that are not in 
the range.)

SHIFT-click row label

OR

SHIFT-click cell in selected column

Set the selected row as the anchor, while 
keeping previously selected items selected.

OR

Clear a previously selected row while 
keeping others selected.

CTRL-click row label

Switch the column selection to the column 
in which you click.

(Clicking in cell also selects the row in 
which you clicked.)

Click column label

OR

CTRL-click column label

OR

CTRL-click in cell

Select a range of requirements

(This action clears any rows that are not in 
the range.)

drag
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Keyboard Shortcuts

If you want to Do this

Move to the right one column. TAB

OR

RIGHT ARROW

Move to the right one column when 
viewing requirement data.

TAB

Move to the left one column. SHIFT-TAB

OR

LEFT ARROW

Move down one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

ENTER

OR

DOWN ARROW

Commit the new or modified requirement 
to the database when in edit mode.

ENTER

OR

TAB (when cursor is in last column of a 
requirement’s row)

Move up one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

SHIFT-ENTER

OR

UP ARROW

Activate the field for data entry, in the 
currently selected cell.

(This action is only available when a single 
cell is selected.)

SPACEBAR

Cancel the edit mode in the currently 
selected cell.

(This action is only available when a single 
cell is selected.)

ESC

Move to the top of the view and select the 
first row.

(This action sets the first row as the anchor 
and clears all other selected items.) 

HOME
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Move to the top of the view and select all 
items between the anchor row and the first 
row of the view.

(This action clears all other selected items.)

SHIFT-HOME

Move to the top of the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and select 
the last row.

(This action sets the last row as the anchor 
and clears all other selected items.) 

END

Move to the bottom of the view and select 
all items between the anchor row and the 
last row of the view.

(This action clears all other selected items.)

SHIFT-END

Move to the bottom of the view, without 
changing the selection or the anchor. 

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the first row if the 
view is positioned on the top page. The 
newly selected row is the new anchor.)

PAGE UP

Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from top to anchor if the view is positioned 
at the top of the page.)

SHIFT-PAGE UP

Move up one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE UP

If you want to Do this
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Move the view one page left. 

(This action selects the column that is in the 
same horizontal position as the previously 
selected column was when its page was 
displayed, or selects the first column if the 
view is positioned on the far left page.)

ALT-PAGE UP

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the last row if the view 
is positioned on the bottom page. The 
newly selected row is the new anchor.)

PAGE DOWN

Move down one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the bottom to the anchor if the view is 
positioned at the bottom of the page.)

SHIFT-PAGE DOWN

Move down one page in the view, without 
changing the selection or the anchor. 

CTRL-PAGE DOWN

Move the view one page right. 

(This action selects the column that is in the 
same horizontal position as the previously 
selected column was when its page was 
displayed, or selects the last column if the 
view is positioned on the far right page.)

ALT-PAGE DOWN

Expand the selected row requirement to 
show its children in the view. 

SHIFT-PLUS SIGN

Collapse the selected row requirement to 
hide its children in the view. 

MINUS SIGN

Select every row in the view. CTRL-A

Cut text of any non-list attribute. SHIFT-DELETE

If you want to Do this
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Traceability Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

Copy text of any non-list attribute. CTRL-INSERT

Paste text of any non-list attribute. SHIFT-INSERT

If you want to Do this

If you want to Do this

Select a cell.

(This action clears all other selected cells.) 

Click cell

Select all cells in the rectangle formed by 
the anchor cell and the clicked cell.

SHIFT-click cell

Set the cell as the anchor, while keeping 
previously selected cells selected.

OR

Clear a previously selected cell while 
keeping others selected.

CTRL-click cell

Select the cell in the clicked row and the 
anchor column.

(This action clears all other selected cells 
and sets the selected cell as the anchor.)

Click row label

Select the cells in all rows between the 
clicked row and the anchor row, in all 
selected columns.

(This action clears any rows and columns 
that are not in the range.)

SHIFT-click row label

Select all cells that intersect with selected 
columns, without clearing previously 
selected cells.

CTRL-click row label

Select the cell in the clicked column and all 
selected rows.

Click column label
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Keyboard Shortcuts

Select the cells in all columns between the 
clicked column and the anchor column, in 
all selected rows.

SHIFT-click column label

Select all cells that intersect with selected 
rows, without clearing previously selected 
cells.

CTRL-click column label

If you want to Do this

If you want to Do this

Move to the right one column. TAB

OR

RIGHT ARROW

Move to the left one column. SHIFT-TAB

OR

LEFT ARROW

Move down one row. ENTER

OR

DOWN ARROW

Move up one row. SHIFT-ENTER

OR

UP ARROW

Display a shortcut menu for the currently 
selected cells.

SPACEBAR

Close the shortcut menu for the currently 
selected cells.

ESC

Move to the top of the view and select all 
cells in the selected columns in the top row.

(This action clears all other selected rows 
and sets the top row as the anchor.)

HOME
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Move to the top of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the top row to the anchor 
row.)

SHIFT-HOME

Move to the top of the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and select 
all cells in the selected columns in the last 
row.

 (This action clears all other selected rows 
and sets the last row as the anchor.)

END

Move to the bottom of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the bottom row to the 
anchor row.)

SHIFT-END

Move to the bottom of the view, without 
changing the selection or the anchor.

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously selected row, or 
selects the top row if the view is already on 
the top page. The newly selected row is the 
new anchor.)

PAGE UP

Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed.)

SHIFT-PAGE UP

Moves up one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE UP

If you want to Do this
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Move the view one page left, while 
changing the anchor.

(This action selects the selected rows and 
the column that is in the same horizontal 
position as the previously selected column 
was when its page was displayed, or selects 
the first column if the view is positioned on 
the far left page.)

ALT-PAGE UP

Move the view one page left, without 
changing the anchor.

(This action selects the cells in selected 
rows and the columns between the anchor 
column and the column that is in the same 
horizontal position as the anchor column 
was when its page was displayed, or selects 
the first column if the view is already on the 
far left page.)

ALT-SHIFT-PAGE UP

Moves left one page in the view, without 
changing the selection or the anchor.

ALT-CTRL-PAGE UP

Move the view down one page, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously selected row was 
when its page was displayed, or selects the 
last row if the view is already on the bottom 
page. The newly selected row is the new 
anchor.)

PAGE DOWN

Move down one page, without changing 
the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed.)

SHIFT-PAGE DOWN

Move down one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE DOWN

If you want to Do this
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Move the view one page right, while 
changing the anchor.

(This action selects the selected rows and 
the column that is in the same horizontal 
position as the previously selected column 
was when its page was displayed, or selects 
the last column if the view is already on the 
far right page.)

ALT-PAGE DOWN

Move the view one page right without 
changing the anchor.

(This action selects the selected rows and 
the columns between the anchor column 
and the column that is in the same 
horizontal position as the anchor was when 
its page was displayed, or selects the last 
column if the view is already on the far 
right page.)

ALT-SHIFT-PAGE DOWN

Moves right one page in the view, without 
changing the selection or the anchor.

ALT-CTRL-PAGE DOWN

Expand the selected requirement to show 
its relationships. Preserve the previous row 
selection. 

PLUS SIGN

Collapse the selected requirement to hide 
its relationships. 

MINUS SIGN 

Select every cell in the view. CTRL-A

If you want to Do this
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Traceability Tree Mouse Actions and Keyboard Shortcuts

Mouse Actions

Keyboard Shortcuts

If you want to Do this

Select the clicked item.

(This action clears all selects items and sets 
the selected row as the anchor.)

Click row

Select the items between the anchor row 
and the row in which you click. 

(This action clears any rows that are not in 
the range.)

SHIFT-click row

Set the selected row as the anchor, while 
keeping previously highlighted text 
selected.

OR

Clear a previously selected row while 
keeping others selected.

CTRL-click row

Copy a selected row's requirement to a new 
position

CTRL-click row, then drag

OR

Right-click, then drag, and select Copy here 
from context menu

Move a selected row's requirement ALT-click row, then drag

OR

Right-click, then drag, and select Move here 
from context menu

If you want to Do this

Move down one row DOWN ARROW

Move up one row UP ARROW

Display a shortcut menu for the currently 
selected requirements.

SPACEBAR

Close the shortcut menu for the currently 
selected requirements.

ESC
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Move to the top of the view and select the 
first row. 

(This action sets the first row as the anchor 
and clears all other selected items.)

HOME

Move to the top of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the first row of the view.)

SHIFT-HOME

Move up one page in the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and select 
the last row. 

(This action sets the last row as the anchor 
and clears all other selected items.)

END

Move to the bottom of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the last row of the view.)

SHIFT-END

Move down one page in the view, without 
changing the selection or the anchor.

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the top row if the view 
is positioned on the top page. The newly 
selected row is the new anchor.)

PAGE UP

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the last row if the view 
is positioned on the bottom page. The 
newly selected row is the new anchor.)

PAGE DOWN

If you want to Do this
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Move to the top of the view and select the 
first row. 

(This action sets the first row as the anchor 
and clears all other selected items.)

HOME

Move to the top of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the first row of the view.)

SHIFT-HOME

Move up one page in the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and select 
the last row. 

(This action sets the last row as the anchor 
and clears all other selected items.)

END

Move to the bottom of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the last row of the view.)

SHIFT-END

Move down one page in the view, without 
changing the selection or the anchor.

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the top row if the view 
is positioned on the top page. The newly 
selected row is the new anchor.)

PAGE UP

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or selects the last row if the view 
is positioned on the bottom page. The 
newly selected row is the new anchor.)

PAGE DOWN

If you want to Do this
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Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the top to the anchor if the view is 
positioned at the top of the page.)

SHIFT-PAGE UP

Move down one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the bottom to the anchor if the view is 
positioned at the bottom of the page.)

SHIFT-PAGE DOWN

Move up one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE UP

Move down one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE DOWN

Expand the item to show its relationships. PLUS SIGN

Collapse the item to hide its relationships. MINUS SIGN 

Highlight every item in the view. CTRL-A

If you want to Do this
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Customizing RequisitePro

Configuring RequisitePro
You can use the Tools > Options command on the Tool Palette to configure 
the appearance and behavior of RequisitePro.
1. On the Tool Palette, click the Tools > Options.

The Options dialog box appears.
2. Type or mark the following options as needed:

Tool Palette
• Show Buttons: Mark this check box to display the Tool Palette buttons.
• Show Status: Mark this check box to display the status line on the Tool 

Palette. This displays project and document status as you work in 
RequisitePro.

• Show Tool Tips: Mark this check box to display a button definition 
when you hold the pointer over a button on a RequisitePro toolbar.

• Always on Top: Mark this check box to display the Tool Palette and 
open dialog boxes in the foreground of your screen, regardless of how 
many applications you have open.

• Let's Go RequisitePro at startup: Mark this check box to display the 
Let's Go RequisitePro splash screen each time you start RequisitePro.

Views
• Prompt for save: Mark this check box if you want RequisitePro to 

prompt you to save changes to display options and view properties when 
you close an unsaved view. Changes to requirements and other data 
within the view are not affected. 
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• Double-click to go to source: Mark this check box for the option to 
double-click on a requirement in a view to access its source. For 
requirements located in documents, the appropriate document opens. 
Otherwise, the Requirement Properties dialog box opens. If this check 
box is cleared, double-clicking expands and collapses the requirement 
hierarchy.

• ENTER key inserts new line (multi-line only): Mark this check box if 
you want to use the ENTER key to create a new line in an Attribute 
Matrix.

• In-view requirements creation (without dialog box): Mark this check 
box if you want to create requirements directly in the Attribute Matrix 
using the Requirement > Create command or the INSERT key. If this 
check box is cleared, the Requirement Properties dialog box appears 
when you click Requirement > Create or the INSERT key.

• Font: Lists the font displayed in the Views Workplace.
• Change: Click this button to change the font.
Traceability
• Warn on remove: Mark this check box if you want Requisite Pro to 

warn you when you remove requirement traceability.
• Changes logged in history: Mark this check box to display changes to 

requirement traceability on the revision history list in the Requirement 
Properties dialog box.

Default Project Logon
• Username: Type your RequisitePro user name. This is used as your 

default logon name for all RequisitePro projects.
Microsoft Word
• Version: Click the down arrow to select your preferred version of 

Microsoft Word when you have more than one version installed. The 
option “<Use Default>” uses the current version of the application, 
which is recorded in the Windows registry.

Directories
• Outline Path: Defines a secondary location for accessing document 

type outlines. If RequisitePro is installed locally on your PC, the default 
path is ...RequisitePro\outlines. Use this option to define an alternate 
location for outlines, for example, a directory on the server for shared 
outlines.
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• ClearCase View: Defines the directory for ClearCase archiving in 
RequisitePro. This needs to be a shared view for all RequisitePro users.

• Working Path: Displays the working directory for RequisitePro. Write 
permission must be enabled for this directory in order for RequisitePro 
to create new projects and write temporary files.

3. Click OK.

Customizing Tool Palette Menus
The Add-in option on the Tool Palette Tools menu allows you to add your own 
customized menu items to any menu on the RequisitePro Tool Palette. These 
menu options can be used to start external applications, such as e-mail or the 
Windows Notepad, directly from RequisitePro. In addition, you can configure 
an option to open an individual file with the application of your choice.
You can add either a project-wide menu item for use by all members of the 
project team or a menu item that appears only when you open RequisitePro on 
your PC. The Add-in option prompts you to specify an external menu file that 
defines your customized menu options.
To add custom menu items:
1. On the Tool Palette, click Tools > Add-ins.

The Add-ins dialog box appears.
2. Click the Add button to add a customized menu option. The Add-in dialog 

box appears.
3. Type a name for the menu option. This name identifies the menu file on 

your add-ins list.
4. Click the Browse button. The Select a RequisitePro Menu File dialog 

box appears.
5. Select a file type to display: All Files, Menu Files, or Text Files.
6. Navigate to a menu file and click Open.
7. Leave the Active check box as marked.
8. Mark one of the following:

• Local to apply the menu items to your Tool Palette only.
• Project to apply the menu items to the Tool Palette of all users who 

access the project.
9. Click OK to close the Add-in dialog box.
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10. Click OK to close the Add-ins dialog box.
The options defined in the menu file are added to the specified Tool Palette 
menu.

Creating A Menu File
Using any text editor, you can create a file to add menu options to any 
RequisitePro Tool Palette menu. The entries will appear on the RequisitePro 
menu in the order in which you specify them. 
As you add menu entries, you will specify:
• Keywords that determine items on the menu (a submenu, a menu option, a 

separator)
• Menu actions that execute an application or open a specific external file, 

such as a readme file.
Pay close attention to the syntax rules that apply to your entries to the menu 
file. For example, the syntax of the menu specifications includes opening and 
closing braces {...}.
Note: Rational Rose users may be familiar with creating menu specification 

files for extending the Rose Tools menu. RequisitePro menu files use 
the same syntax with a subset of the Rose functions.
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Menu File Template
Create your menu file in a text editor, based on the following template. Save 
your file with a .TXT extension or a .MNU extension to help locate the file 
easily in your file structure.
Menu <RequisitePro menu name>
{

Separator
Option <menu item>
{

Exec <command line>
Status <status text>

}
Menu <submenu name>
{

Option <menu item>{
Exec <command line>
Status <status text>

}
Option <menu item>
{

Exec <command line>
Status <status text>

}
}

}
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Key Words
Use the following table to define the key words to copy into the menu file:

Notes
1. Menu names, submenu names, option names, and statuses need double 

quotes if they include more than one word.
2. Separators can be in menus or submenus.
3. Can include more than one menu item in a file.
4. Add an ampersand (&) directly before a character in the menu name to 

create a underlined letter signifying an access key in the menu option.
5. You can create a maximum of five levels of submenus (indented one below 

another).

Keywords and Variables Definitions and Valid Entries

Menu keyword to specify the Tool Palette menu or 
submenu to which you want add the menu 
items

Separator keyword to place a separator in the menu

Option keyword to specify the name of the item as it 
will appear on the menu

Exec keyword to identify the command line to be run 
when the menu item is chosen

Status keyword to identify the text for the status line 
of the Tool Palette

<RequisitePro menu name> Project, Document, Requirement, Tools, 
Window, or Help

<menu item> user-defined text for an item on the menu or 
submenu

<submenu name> user-defined text identifying the name of the 
submenu

<command line> user-defined text identifying the commands to 
execute when the menu item is chosen

<status line> user-defined text identifying the text for the 
status line of the Tool Palette
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Sample Menu File
The following example shows a simple menu definition file. After you create 
a menu file, reference using the Add-ins option on the Tool Palette Tools 
menu. This feature allows you to add customized menu options to the 
RequisitePro menus.
The following menu file instructs RequisitePro to add the options “Open 
readme file” and “Open Windows Notepad” to the Tool Palette Window menu.
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G L O S S A R Y

Rational RequisitePro Terms
The terms that follow are used throughout the RequisitePro User’s Guide. 
Most are specific to RequisitePro. 
Active document: The current document in the Word Workplace, which has 
processing focus. The Word Workplace is the Microsoft Word implementation 
within RequisitePro where you view, create, and modify project documents. 
You can have many documents open at one time; however, only one of these 
documents is active.
Active view: The current view in the Views Workplace, which has processing 
focus. You can have many views open at one time; however, only one of these 
views is active. See also Views Workplace.
Actor: Someone or something outside the system that interacts with the 
system.
Add-in command: An option on the Tool Palette Tools menu that allows you 
to add your own customized menu options to any Tool Palette menu. These 
menu options can be used to start external applications, such as e-mail or the 
Windows Notepad, directly from RequisitePro. In addition, you can configure 
an option to open an individual file with the application of your choice.
Administrators group: A group of users with full permissions to work in a 
project. They can change a project structure, create and modify data, modify 
and delete project-wide views, and set and maintain security permissions. 
Users can be added and removed from this group, but this group cannot be 
deleted. Administrator group permissions cannot be modified.
Analyst: See System analyst.
Anchor: The first item you click when using multiple select actions to select a 
range of items. In RequisitePro, the term “anchor” is generally used to mean 
the first cell you click in a view in the Views Workplace. You use the anchor 
to select a range of cells. For example, if you click the cell in row 1, column 1 
of a Traceability Matrix, that cell becomes the anchor. If you then Shift-click 
the cell in row 10, column 3 of the matrix, all of the cells in rows 1 through 10, 
columns 1 through 3, are selected. To reset the anchor, click anywhere outside 
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the range. The cell you click is the new anchor. You can also use an anchor to 
select a range of items in documents and in certain dialog boxes that support 
multiple select actions. See Multiple select actions.
Archiving: The process of maintaining a database of all the source code and 
related files in a software development project to keep track of changes made 
during the project.
Attribute: Descriptive information that provides important details about a 
requirement or discussion. See also Requirement attribute.
Attribute label: The name of the requirement attribute, such as risk, priority 
or author. Also referred to as requirement attribute label.
Attribute Matrix: A spreadsheet-like table View that displays requirements in 
rows and the attributes that describe the requirements in columns. You can add 
or change values in the attribute fields. Also referred to as Requirement 
Attribute Matrix.
Attribute type: A set of descriptive and operational information associated 
with a requirement attribute when the attribute is created. Attribute values can 
be list-type or entry-type. For list-type attributes, you select a textual attribute 
value from a drop-down list. For entry-type attributes, you type in a value, such 
as a number, text string, date, or time. Also referred to as requirement attribute 
type.
Attribute value: Information assigned to a requirement attribute. Attribute 
values can be text or numbers. For example, the attribute priority can be 
assigned the values Low, Medium and High. Also referred to as requirement 
attribute value.
Author: The user responsible for creating or modifying a document or 
requirement.
Author (version information): User responsible for the changes associated 
with a given revision.
.bak file: A backup of a document file. A new .bak file is created in the same 
directory each time a document is saved and contains a version of the 
document before it was saved. You can delete .bak files at any time; they will 
be created again next time the original documents are saved.
Baselining: See Archiving.
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Bookmark: A marker inserted at a specific point in a document to which the 
user may return for later reference. In Microsoft Word, a bookmark is a 
location or selection of text named for reference purposes. Bookmarks are 
implemented in RequisitePro documents to designate requirement text. 
Bookmarks are designated by square brackets, as in the following: [example].
Change description (version information): Textual information that 
specifies the justification or reasoning behind the changes associated with a 
given revision of a project, document, or requirement. See also Version 
information.
Change-managed relationship: A connection between two requirements that 
implies dependency or a logical relationship. RequisitePro tracks two types of 
change-managed relationships: hierarchical relationships and traceability 
relationships. Changes to either of the requirements can cause a “suspect” 
condition in the relationship. See also Suspect relationship.
Child requirement: A requirement that participates in a hierarchical 
relationship with a parent requirement. A child can have only one parent 
requirement. See also Parent requirement, Hierarchical requirement.
Circular traceability relationship: A relationship between a requirement and 
itself, or an indirect relationship that leads back to a previously traced-from 
node. Traceability relationships cannot have circular references. RequisitePro 
checks for circular references each time you establish a traceability 
relationship. RequisitePro also checks for circularity when you create an 
external relationship. The circular check only references internal requirements 
and first-level external requirements.
ClearCase: See Rational ClearCase. 
ClearQuest: See Rational ClearQuest.
CMM: The Software Engineering Institute’s Capability Maturity Model, a 
framework for effective software process developed at Carnegie-Mellon. 
CMM for Software describes increasing levels of process maturity, from an ad-
hoc, immature process to a mature, disciplined one.
Collapse indicator: See Expand/collapse indicator.
Concurrency: A condition in which two or more users can access the same 
project at the same time. See also Exclusive access.
Cross-project traceability: A RequisitePro feature that allows you to 
establish traceability relationships between requirements that reside in 
different projects. See also External traceability.
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CSV file: A comma-separated value text file, commonly used to exchange files 
between database systems that use different formats. Sometimes called 
comma-delimited files, CSV files can be imported into RequisitePro.
Ctrl-click: See Multiple select actions.
Current project: The project that is open, or active. A user can have only one 
RequisitePro project open at a time. Also referred to as the active project or the 
open project.
Database: A collection of data stored in a repository. By using specific 
commands, you can search and sort a database for the retrieval of specific 
information. RequisitePro stores your projects in a database. Use the views and 
queries in the RequisitePro Views Workplace to search the project database. 
See also Project database.
.def file: A file, located in the RequisitePro outlines directory, that specifies 
information about a particular outline used by RequisitePro. 
Deleted Users group: A security group of users who have been deleted from 
other groups, have no permissions, and cannot log on to RequisitePro. This 
group is maintained by the project administrator for project history.
Dialog box: An interactive window displayed on the screen that solicits a 
response from the user.
Dialog box shortcut: See Keyboard shortcuts.
Directory: A catalog for file names and other directories. A directory is an 
organization of files (or folders) grouped for the user’s convenience. The 
topmost directory is called the root directory. The directories within a directory 
are called subdirectories.
Discussion: A RequisitePro feature that lets you address comments, issues, 
and questions to a group of discussion participants. Discussions can be 
associated with one or more specific requirements, or refer to the project in 
general.
Discussion item: A discussion item is either the initial discussion topic or a 
response. A response can be either to the initial discussion text or to another 
response.
.doc file: A DOS file name extension for Microsoft Word documents. Do not 
use the .doc file name extension as a file name extension for document types.
Document: Any Microsoft Word document, whether it is part of the 
RequisitePro project or outside the project, whether it contains requirements or 
not. See also Requirements document.
Glossary-4



Rational RequisitePro Terms
Document properties: Specific items of information about a RequisitePro 
document. Documents have attributes associated with them such as author, 
date and time of last revision and file name.
Document type: Defines descriptive and operational information associated 
with a requirements document. The document type serves as a template for 
each requirements document you create of that type.
The document type defines the document’s file extension, such as .prd; all 
documents of the same document type share the same file extension. The 
document type identifies a default requirement type; each new requirement 
you create in the document will be based on the default requirement type unless 
you indicate otherwise. The document type also identifies an outline (or 
template) for the document which controls its page layout, default text, 
paragraph styles, etc.
Document version: A revision of a RequisitePro document, identified in the 
document properties revision history. A new version is created when a 
document is changed and saved. See Revision.
.dot file: A DOS file name extension for Microsoft Word template files. Do not 
use the .dot file name extension as a file name extension for RequisitePro 
document types.You can edit the .dot files associated with your document 
types to include your company name and other information specific to your 
organization. You can enter the company name, etc. in the Microsoft Word 
File > Properties dialog box. Then in the document itself, right-click on the 
Company-Name field, and select Update Field.
Drag: See Multiple select actions.
Drop-down menu: A list that appears below a menu bar or field when the user 
clicks the down arrow. The menu remains open without further action until the 
user closes it or chooses a menu item.
Enhancement request: A type of stakeholder request that specifies a new 
feature or functionality of the system. Certain RequisitePro requirement types 
have attributes that associate the requirement with specific records in Rational 
ClearQuest. By default, the feature (FEAT) requirement type includes an 
Enhancement Request attribute that can associate the feature requirement with 
enhancement request records in ClearQuest. Other associations can be created 
using the ClearQuest/RequisitePro Integration Setup. Refer to Getting Started 
with Rational Suite AnalystStudio for more information.
Entry-type attributes: Entry-type attributes are numeric, text, time, or date 
values that are entered by project users. An entry-type attribute can be 
configured with a default value which users can accept or replace as they create 
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or modify requirements. For example, you could format the entry-type 
attribute “Cost” to accept integer values and have a default value of 20. You 
define attributes in the Attributes tab of the Project Properties dialog box. 
Requirement attributes can be of entry or list-type. See also Attribute types, 
Attribute values. Compare List-type attributes.
Exclusive access: A condition by which access to a RequisitePro project and 
its documents is only available to the user who opens the project. Exclusive 
access is required to change a variety of project characteristics. You set access 
when you open a project. See also Concurrency.
Expand/collapse indicator: A small box displayed in one of the following 
locations: next to a requirement in a view, indicating that the requirement has 
one or more child requirements; or next to a discussion item in the Discussions 
dialog box, indicating that the discussion item has responses. The box contains 
a + or a -, indicating whether or not the requirement or discussion is displayed 
in an expanded or collapsed state.
Export: To move information from one system or program to another. You can 
export requirements from a RequisitePro view to Microsoft Word documents 
and to CSV files.
Extension: See File name extension.
External project: A project containing requirements used to establish 
traceability relationships with requirements in a currently open project.
External requirement: A requirement residing in an external project. You can 
create traceability relationships between requirements in different projects.
External traceability: Traceability relationships between requirements in two 
different projects. See also Traceability.
File name extension: A DOS file name extension (for example, .prd). File 
name extensions are used in RequisitePro to indicate document type and can 
contain a maximum of 20 characters.
Filtering: A process by which you can change the amount of information 
displayed in a view in the Views Workplace. You specify certain criteria on 
which to filter information. You can filter requirements by specifying certain 
distinct criteria for any or all of their attributes. For example, instead of 
displaying all requirements, you might apply a filter such that only 
requirements having a high priority are displayed. See also Sorting, Queried 
view.
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Graphic: Electronic line art or bitmapped artwork. You can use graphic 
formats such as Enhanced Metafile (.emf), Joint Photographic Experts Group 
(.jpg), Portable Network Graphics (.png), Windows Bitmap (.bmp, .rle, .dib), 
and Windows Metafile (.wmf) in your RequisitePro documents. 
Group: A list of users, defined in project security and organized by the 
operations they have privileges to perform. For example, members of the 
Administrators group can create group accounts and add users to groups.
Hidden text: A Microsoft Word feature used to hide text within a document. 
Hidden text is delineated with a dotted underline. In RequisitePro, a 
requirement within a document begins with a requirement tag formatted in 
hidden text style.You can hide the tags for improved readability. On the 
Microsoft Word menu bar, click Tools, then Options, and then click the View 
tab. Clear the Hidden text check box and click OK.
Hierarchical requirement: A requirement that is included within an ordered 
relationship with other requirements of the same type. Use hierarchical 
relationships to subdivide a general requirement into more explicit 
requirements. Child requirements provide additional detail for their parent 
requirement. For example: 
Parent requirement: The system shall display customer information.
Child requirements provided for detail: Name, Address, Date of Birth.
Each child requirement can only have one parent, but a requirement can be 
both a parent and a child. If a parent requirement is changed, the relationships 
with its children become suspect.
Icon: A graphical representation of a RequisitePro command or process. When 
used in RequisitePro on toolbars in the Tool Palette and Views Workplace, 
icons are typically referred to as buttons.
IEEE: (“I triple E”) Institute of Electronics and Electrical Engineers, the 
hardware and software standards body, sets standards for such measurable 
items as acceptability criteria, performance benchmarks, and configuration 
management.
Import: To bring information from one system or program into another. In 
RequisitePro, you can import documents and requirements, from Microsoft 
Word files and from CSV files.
Integrated Use Case Management: A Rational integration between 
RequisitePro and Rose that allows you to associate use cases in Rose with 
RequisitePro documents and requirements. You can easily navigate from Rose 
use-case models to RequisitePro use-case documents and requirements and 
vice versa.
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Internationalization: The process of developing a program core whose 
feature and code designs don't make assumptions based on a single language 
or locale and whose source code base simplifies the creation of different 
language editions of a program.
Keyboard shortcuts: A dialog box shortcut is a keyboard combination you 
can use to move to tabs, fields, and buttons in a RequisitePro dialog box. To 
use a dialog box shortcut, press the Alt key while simultaneously pressing the 
underlined letter in a dialog tab, field, or button. For example, in the Project 
Properties, Document Properties, or Requirement Properties dialog boxes, 
press Alt-G to open the General tab.
A menu shortcut is a keyboard combination you can use to open a menu in the 
Tool Palette or Views Workplace. To use a menu shortcut, press the Alt key 
while simultaneously pressing the underlined letter in the menu. For example, 
to open the Requirement menu, press Alt-R. Once a menu is displayed, you can 
select a command by pressing the key for the underlined letter in the command.
Keyword: Words that are used to help specify and define requirements. Many 
organizations use words such as “shall,” “must,” or “will” in their 
requirements, making it easier to separate a requirement from surrounding text 
in the document. Keywords are a part of the definition of a requirement type. 
You enter keywords in the Requirement Must Contain field in the Requirement 
Type dialog box. See also Requirement type.
Label (version information): A string that contains user-defined revision 
information, up to 20 characters. You can use a revision label for noting 
requirement, document, or project/archive version information.
Leaf tag: The last (rightmost) number in a requirement’s tag number. For 
example, the leaf tag number for Requirement PRD201.7.9 is 9. See also Root 
tag.
Licensed user: A RequisitePro user. Each user that is associated with a license 
of RequisitePro is a licensed RequisitePro user. See also User.
List-type attributes: Requirement attributes are either list-type or entry-type. 
List-type attributes are sets of descriptive values (for example, Status, which 
may contain the list values Proposed, Approved, In progress, and Complete). 
You can assign single values or multiple values for list-type attributes. You 
define attribute values in the Attributes tab in the Project Properties dialog box. 
See also Attribute types, Attribute values. Compare Entry-type attributes.
Matrix: An arrangement of rows and columns used for organizing related 
items in the Views Workplace. See Attribute Matrix, Traceability Matrix.
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Menu: A list of options from which a user can make a selection in order to 
perform a desired action. In RequisitePro, menus are available from the menu 
bar found above the buttons on the Tool Palette and in a View window. The 
Word Workplace includes a RequisitePro menu with access to document, 
requirement, and window commands.
Menu file: A text file with specific syntax that is used to add menu commands 
to any RequisitePro Tool Palette menu. Menu files typically have an MNU or 
TXT file extension. Menu files are referenced using the Add-ins command on 
the Tools menu. The commands appear on the RequisitePro menus in the order 
in which they are specified in the menu file.
Menu shortcuts: See Keyboard shortcuts.
Metrics: See Requirement Metrics.
Multiple select actions: Mouse actions and combination keyboard/mouse 
actions that you use to select multiple items in RequisitePro. Use Ctrl-Click to 
select multiple items that are not adjacent to each other. Hold down the Ctrl key 
and click the mouse.(You can also use Ctrl-click to clear a selected item.) Use 
Shift-click to select a range of items. Hold down the Shift key and click the 
mouse. Use Drag to select a range of items. With one item selected, drag the 
mouse. Release the mouse when the range is selected.
Multiple value list: An attribute type that supports one-to-many associations. 
You can use a multiple value list when you want to assign a requirement more 
than one value for a specific attribute.
For example, you might create an attribute type called Owner, with multiple 
values Bob, John, and Sue, representing different users working on the same 
project. For this attribute, you might then assign only the values Bob and Sue 
to a particular requirement, indicating that Bob and Sue are responsible for this 
particular requirement, but John is not.
Offline author: A user who takes a RequisitePro document offline.
Offline authoring: A RequisitePro feature that lets users read and modify a 
document in Microsoft Word outside of RequisitePro (i.e., offline). When you 
take a document offline, RequisitePro creates a copy of the document in the 
directory you specify. The original is still stored in RequisitePro, but it is 
changed to a read-only document. Other users can view the document in 
RequisitePro, but they cannot edit it until you bring it back online.
OLE: Object linking and embedding. You can create an OLE object in one 
application (original application) and insert it into files in other, source 
applications. If you modify the OLE object in its original application, the 
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changes are automatically reflected in any files containing the OLE object in a 
source application. You can only modify an OLE object in its original 
application. You can use OLE objects in RequisitePro requirements 
documents.
Open project: See Current project.
Outline: A reference document or template used to create documents in 
RequisitePro. An outline can include formats, page layout information, 
attributes, attribute definitions and system defaults. An outline is useful for 
maintaining consistency across documents of the same type. An outline is 
stored in a .def file. It includes the outline’s full name, a description of the 
outline, and the associated Microsoft Word template’s DOS filename. See also 
Template, Document type.
Parent requirement: A requirement that participates in a hierarchical 
relationship with one or more child requirements. A parent can reside at the 
root level, or it can be nested in the hierarchy with a parent of its own. In either 
case, parents reside above their children in the hierarchy. See also Child 
requirement, Hierarchical requirement.
Parse: To break information into component parts so that a program can act 
upon it. Used by the Import Wizard to separate requirements in a document.
Peer requirement: A requirement that is at the same hierarchical level as 
another requirement. For example, two requirements are peer requirements 
when they are children of the same parent. In addition, all requirements at the 
root level are peer requirements of one another. See also Parent requirement, 
Child requirement, Hierarchical requirement.
Pending requirement: A newly created requirement in a document or a view 
that has not yet been saved in the database.
Pending tag number: A tag number for a newly created requirement in a 
RequisitePro document. The requirement maintains the pending tag number 
until the document is saved. See also Requirement tag.
Permissions: The RequisitePro privileges granted to a group of RequisitePro 
users. RequisitePro administrators or members of a group with project security 
permissions can assign permissions to groups. Also referred to as privileges or 
rights. See also Security.
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Project: A RequisitePro project. A project includes a database, documents, 
document types, requirements and their attributes, requirement types, 
requirement traceability, discussions, and user and group security. Within 
RequisitePro, you create a project first. You then create requirement 
documents and requirements in each document.
Project database: The requirements database managed by RequisitePro. All 
requirements in the project are stored in the project database, including those 
created in requirement documents. Changes you make to requirements in the 
documents are reflected in the project database. Microsoft Access, Oracle and 
Microsoft SQL Server databases are available to user for RequisitePro 
projects. See also Database.
Project directory: A directory that contains information for a single 
RequisitePro project. You define the project directory when you create a new 
project (By default, RequisitePro creates a directory name that matches what 
is typed in the Name text box in the Project Wizard). For projects that use the 
Microsoft Access database, the database is stored in the project directory. The 
project directory does not store the database for projects that use an Oracle or 
SQL Server database. Requirements documents for the project may be stored 
in another directory. The project directory path can contain up to 256 
characters. See also Directory.
Project prefix: An identifier used for requirements in cross-project 
traceability. In an external project, the prefix is displayed before the tag 
requirement, separated from the tag by a period. For example, if a 
requirement’s tag is PR234 and the project’s prefix is GLOBAL, then the 
external requirement is displayed as GLOBAL.PR234. The prefix can be up to 
8 characters, and must be uppercase letters. You can change the prefix at any 
time in the Project Properties dialog box, General tab.
Project properties: The characteristics that make up a project, such as 
document types, requirement types, requirement attributes, the date a project 
was created, the user who created it, and the file location where the project is 
stored.
Project summary report: A report that displays the project’s entire structure 
in report form. The requirement types (and their attributes, including multiple 
value lists), document types, and document details are included in the printout.
Query: A method for filtering and sorting requirements in views by limiting 
the values of one or more attributes or by limiting traceability, and specifying 
the order in which the filtered requirements display.
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For example, you might create a query such that only requirements having a 
high or medium priority are displayed. Within that filter, you might sort 
requirements first by priority, and then by cost.
Rational ClearCase: A version control product by Rational, which can be 
used to store backup copies of RequisitePro projects. Alternately, projects can 
archived directly from RequisitePro using the RequisitePro Archive command.
Rational ClearQuest: Rational’s change-request management software. 
ClearQuest offers a flexible approach to track and manage all the change 
activities that are associated with an organization, such as defects and 
enhancement requests. In RequisitePro, the terms ClearQuest and Rational 
ClearQuest are used interchangeably.
Rational Rose: Rational’s visual modeling tool for designing and visualizing 
object-oriented and component-based applications. RequisitePro is integrated 
with Rose through Integrated Use Case Management.
Rational TestManager: Rational’s information management tool for software 
development and testing professionals, designed to help track software testing 
information through all phases of the software development, test, and revision 
cycles. In RequisitePro, the terms TestManager and Rational TestManager are 
used interchangeably.
Rational Unified Process: Rational’s online knowledge base of proven 
software-development principles. RUP captures many of the best practices in 
modern software development in a form that can be tailored to a wide range of 
projects and organizations. RUP includes Tool Mentors, which provide 
descriptions on how Rational Software tools can be used to support particular 
steps and activities.
Read-only access: An option by which a RequisitePro project or document is 
restricted to viewing only.
Renumbering: The process of assigning new numbers to requirements. The 
renumber feature is useful for eliminating “holes” in a numbering scheme, can 
result when you delete requirements. To renumber requirements, you must 
open the project in exclusive mode. In addition, if security is enabled, you must 
have project structure permission to renumber requirements. To renumber 
requirements in documents, all documents that contain requirements of that 
type must be open.
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Reparenting: The process of reassociating a hierarchical requirement with a 
new parent of the same requirement type. When you reparent a requirement, 
the entire sub-tree of children is also moved to the new parent. The reparented 
requirements are renumbered as if they were newly created for the new parent. 
See also Child requirement, Parent requirement, Hierarchy.
Report: A formatted and organized presentation of data. In RequisitePro, you 
can use Requirement Metrics and the RequisitePro Extensibility Interface to 
create reports using data in the requirements database.
Repository: A collection of data; a database.
Requirement: A condition or capability to which the system being built must 
conform. 
Requirement attribute: A descriptive field of information associated with a 
requirement. RequisitePro requirement attributes are either system attributes 
(defined by RequisitePro) or user-defined (defined by the project owner). See 
Attribute.
Requirement attribute label: The name of the requirement attribute, such as 
risk, priority, or author. See Attribute label. 
Requirement Attribute Matrix: See Attribute Matrix.
Requirement attribute type: See Attribute type.
Requirement attribute value: See Attribute value.
Requirement location: The location where a requirement was created or the 
location to which it was last moved. The location can be either a specific 
requirements document or the project database.
Requirement Metrics: A RequisitePro feature for compiling statistics on 
RequisitePro requirements text, attributes, relationships, and revisions. These 
report results are displayed in Microsoft Excel and can be manipulated using 
Excel’s charting capabilities. Two types of reports are available: static reports 
(which show results about the project at the present time) and trend analysis 
reports (which use time-sensitive filters that analyze changes in requirement 
text, attributes, traceability, and hierarchical relationships).
Requirement tag: The unique identifier of each requirement in a project. A 
requirement tag is composed of a tag prefix and a unique numerical value, such 
as “PR100.1.2.” The tag prefix is always the requirement type, as defined in 
the Project Properties dialog box. The numerical value is generated by 
RequisitePro. The tag prefix can contain a maximum of 20 characters. Each 
requirement type in your project has a different tag prefix (for example, FEAT, 
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SR, TST) that you determine when you create a new project or add a new 
requirement type. When you add a requirement to a requirements document or 
database, RequisitePro assigns the requirement the appropriate tag prefix, 
dependent on its requirement type, and an incremental numerical value. See 
also Leaf tag, Root tag, Pending tag number.
Requirement type: A set of descriptive and operational information 
associated with a requirement when the requirement is created. A requirement 
type serves as a template for all requirements of the same type and is useful for 
classifying and grouping similar requirements in a project. Each requirement 
type can its own set of user-defined attributes. See also Requirement attribute.
Requirement version: A requirement attribute that shows the version of the 
requirement. As a requirement evolves, it is helpful to identify the version 
numbers (and history) of requirements changes.
Requirements document: A document created in Microsoft Word or 
RequisitePro that captures requirements and is used to communicate product 
development efforts. Each requirements document addresses a particular 
requirement type. A RequisitePro requirements document differs from a Word 
document in that you can access requirement attributes and other information 
directly from within the requirements document. Also referred to as a 
document or a RequisitePro document.
Requirements management: A systematic approach to eliciting, organizing, 
documenting, and managing the changing requirements of a software 
application.
RequisitePro document: A Microsoft Word document that is part of a 
RequisitePro project. Most Word functionality is available within 
RequisitePro documents.
RequisiteWeb: Rational’s Web interface that allows clients to access 
RequisitePro requirements information across the Internet or an intranet. By 
utilizing browsers -- Netscape Navigator or Microsoft Internet Explorer -- 
RequisiteWeb provides a thin client solution to access project documents and 
data. No Requisite application-specific files need to be installed on individual 
machines.
Response: An answer to a discussion item. You can respond to the initial 
discussion topic or to other, previous responses. In RequisitePro, the terms 
“response” and “discussion response” are used interchangeably.
Revision: A distinct version of a project, document, or requirement. A revision 
is identified by a unique internal revision number, generated by RequisitePro.
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Revision number: The number identifying a revision. Revision numbers are 
automatically incremented each time you or another user changes and saves a 
project, document, or requirement.
Root requirement: A requirement at the uppermost level of the requirements 
hierarchy. A root requirement does not have a parent requirement. See also 
Parent requirement, Child requirement, Hierarchical requirement.
Rose: See Rational Rose.
.rqs file: A text file, created and updated automatically by RequisitePro, that 
stores project-specific information. Every RequisitePro project has an .rqs file, 
which resides in the project directory. Do not modify any section of this file, 
except the [MSProjectMappings] section, as described in RequisitePro Online 
Help.
RUP: See Rational Unified Process.
Security: Prevention of system use, potential harm, or data loss by 
unauthorized individuals. In RequisitePro, users are given specific permissions 
that determine the amount or kind of access they have to projects. If you are a 
RequisitePro administrator or a member of a group with project security 
permissions, you can assign permissions. See also Permissions.
Shift-click: See Multiple select actions.
SoDA: Rational’s Software Documentation Automation tool.
Sorting: The process of establishing a specific order for the information in a 
RequisitePro View. You can sort requirements using one or many requirement 
attributes. For example, you might sort requirements first by priority (high, 
medium, or low). Then, within priority, you might sub-sort by unique ID 
number. See also Filtering, Query.
.~sr file: A text file created for each user who accesses a project. When a 
project is opened, a file will be written to the project directory with a unique 
system generated file name and an extension of *.~sr. This file simply records 
the user ID, the type of access the user has to the project and a session ID. The 
exclusive lock file name will always be exclusive.~sr. All other file names will 
begin with a prefix that indicates the type of project access reflected by the user 
in the project: RO indicates “read only” access, and RW indicates “read/write” 
access.
Suspect relationship state: A state applied to a traceability or hierarchical 
relationship when a change occurs to one or both of the requirements in the 
relationship. A suspect relationship state indicates that, because of the 
modification to one or both requirements, the relationship may need 
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modification as well. When suspect relationships are displayed in an Attribute 
Matrix, an (s) appears after the requirement tag in the Traced-to or Traced-
from column. See also Change-managed relationship, Traceability Matrix.
System analyst: An individual who leads and coordinates requirements 
elicitation and use-case modeling by outlining the system’s functionality and 
delimiting the system.
Tag: See Requirement tag.
Tag prefix: The prefix for a requirement type. The prefix can be up to 20 
characters. A tag is a unique identifier assigned to each requirement you create. 
The tag prefix is defined as a part of the requirement type.
Template: A reference file used to create new Microsoft Word documents. A 
template can include formats, page layout information, attributes, and attribute 
definitions. Templates are used in RequisitePro for requirements specification 
standards. In both Word and RequisitePro, templates use the file extension 
.dot. A Word template is part of a RequisitePro outline, which also includes the 
outline's full name and a description of the outline. Outlines are stored in .def 
files. In RequisitePro, the terms template and Word template are used 
interchangeably. See also Word template, Outline.
TestManager: See Rational TestManager.
Tip revision: The current version of a project. If a project is not open, a tip 
revision is the most recent version of the project.
Tool Palette: The main interface for accessing and working with RequisitePro 
projects. Tool Palette buttons provide quick access to project information, 
requirements information, and views. You also use the Tool Palette menu 
commands to perform requirements management operations in a RequisitePro 
project.
Trace to/trace from relationship: A relationship between two requirements 
that implies the source, derivation, or dependencies between the requirements. 
The trace to/trace from state appears in a Traceability Matrix or Traceability 
Tree when you create a relationship between two requirements.
For example, you might create a software requirement (Requirement A) that 
calls for a new command to be added to a particular menu in your application. 
Creating this requirement might cause you to create a test requirement 
(Requirement B) associated with that menu item. You would thus create a 
traceability relationship in which the test requirement (B) is traced from the 
software requirement (A). There can only be one traceability relationship 
between any two requirements.
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Traceability: A relationship between two requirements that implies the 
source, derivation, or dependencies between the requirements using the “trace 
to” and “trace from” features.
Traceability Matrix: A view that illustrates the relationships between 
requirements of the same or different types. You use this matrix to create, 
modify, and delete traceability relationships and view indirect relationships 
and traceability relationships with a suspect state. You can also use the 
Traceability Matrix to filter and sort the row requirements and column 
requirements separately. See also View. 
Traceability relationship: See Trace to/trace from relationship.
Traceability Tree: A view that displays all internal and external requirements 
traced to or from a requirement (depending on the direction of the tree). The 
traceability tree only displays the first level cross-project traceability. For 
example, if an internal requirement is traced to an external requirement, the 
external requirement displays in the traceability tree, but other requirements 
that the external requirement is traced do not displayed in the tree. Also 
referred to as a Tree view. See also View. 
Tree view: See Traceability Tree.
Type: See Requirement type.
Use case: A sequence of actions that a system performs, yielding an observable 
result of value (a work output) to a particular actor (someone or something 
outside the system that interacts with the system).
User: See Licensed user.
User information: A RequisitePro user’s user name, password, and e-mail 
address. If you are a member of a group with project security permissions, you 
can edit another user’s information. In addition, a user can edit his or her own 
user information.
Users group: A security group that can, by default, read documents and 
requirements, create views, and participate in discussions. Administrators can 
modify Users group permissions.
Version information: Unique, identifying information associated with a 
project, document, or requirement each time it is modified. The internally 
generated revision number, combined with information about the author, date, 
time, and reason for modification, constitute version information. See also 
Revision.
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View: A window in the Views Workplace that displays requirements, the 
attributes assigned to requirements, and the relationships between 
requirements. A view displays information in spreadsheet-like tables or in 
outline trees. In RequisitePro, the terms view and view window are used 
interchangeably. See also Attribute Matrix, Traceability Matrix, Traceability 
Tree.
Views Workplace: An area in RequisitePro where you analyze and print 
requirements information. The workplace displays and manages three types of 
views: Attribute Matrix, Traceability Matrix, and Traceability Tree.
Wildcard character: A keyboard character that can be used to represent one 
or many characters. Typically the asterisk (*) represents one or more 
characters and the question mark (?) represents a single character. For 
example, the file specification *.* (pronounced star-dot-star) uses the asterisk 
wildcard to mean “any combination of file name and extension.” When 
filtering the subject of discussions, the percent symbol (%) is the wildcard 
character used to represent one or more characters.
Web: See RequisiteWeb.
Word application: Microsoft Word. The word processor used to author 
requirement documents and edit requirements in RequisitePro documents. The 
integrated implementation of Word in RequisitePro is referred to as the Word 
Workplace.
Word document: A document created in Microsoft Word or RequisitePro that 
is saved in Word format. See also RequisitePro document.
Word Template: See Template.
Word Workplace: A Microsoft Word window within RequisitePro where you 
view, create, and modify documents. RequisitePro uses the Word functionality 
to provide powerful features for viewing, editing, and formatting documents. 
You can open several documents at a time, apply character styles, and insert 
objects into your documents. The Word Workplace includes a RequisitePro 
menu for managing RequisitePro requirements and documents from within 
Word. Also referred to as Word window.
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revision information 8-10
searching for 5-6
sibling requirements 9-4
sorting 5-2
style, refreshing 8-22
suspect relationships 9-10, 10-9
text delimiters 8-4
traceability relationships 10-1
troubleshooting 8-6
Index-9
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unmarking 8-22
Word style 8-4

requirements authors xvi
requirements contributors xvi
requirements documents, see documents
requirements management 1-2, 1-3, 1-12

fundamentals 1-1
Managing Software Requirements book xvii
problems 1-4
skills 1-5–1-8
tour xvii

Requirements Management Tour xvii
requirements menu 10-3
requirements only import option 11-10
requirements viewers xvi
RequisitePro Extensibility Interface 5-11
RequisitePro format 11-2
RequisitePro Project Template 12-8
RequisiteWeb 2-2, 8-1
resizing

tree pane 4-8
views 4-18

responding to discussions 6-8
using e-mail 6-9
using RequisitePro 6-8

restoring
backups 14-19
enterprise database backups 14-19

retrieving archived projects 14-11
reviewing

changes in a document 7-5
revising requirement properties 8-9
revision information 12-4
revision tab 7-7

document properties dialog box 7-7
project properties dialog box 12-4
requirement properties dialog box 8-10

revisions
protect for revisions 14-2

Robot 16-13
Rose 16-12
row height in views 4-16
RUP 16-15

S
saving

bookmarks 11-5
documents 7-2, 7-5
requirements document as Word file 7-7
view properties 4-21
views 4-10

searching
active view 5-7
database 5-6
documents 5-7
find requirement command 5-7
for requirements 5-6
go to command 5-6
views 5-7

security 13-1
disabling 13-2
enabling 13-2
groups and users 13-2

security groups
adding users 13-4
creating 13-3
deleting 13-4
deleting users 13-5
moving users 13-6

selecting
items in a traceability matrix A-7
items in a traceability tree A-12
items in an attribute matrix A-3

selecting multiple items A-1
setting up project security 14-1
shortcuts A-1

dialog box A-1
menu A-1

sibling requirements 9-4
SoDA 14-3, 16-14
sort ascending 5-4
sort descending 5-4
sorting

discussions 6-14
requirements 5-2
sort order 5-4

sorting and filtering 5-1
Index-10
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see also querying, queries
SQL Server 11-1, 11-11, 11-19, 12-3, 12-5,

12-9, 14-22, 14-23
archiving 14-17
archiving projects 14-12

starting
RequisitePro 3-1

Suite products 16-1
suspect relationships 2-13, 4-6, 4-8, 9-10, 10-

9
change affects suspect option 15-12
clearing 9-11, 10-10
displaying 9-10, 10-9

T
tags, rebuilding 8-20
TeamTest 16-13
technical support xviii
template

RequisitePro Project Template 12-8
terminating

discussions 6-20
terms Glossary-1
TestStudio 16-13
text delimiters 8-4
text pane 4-8
tile view 4-19
tip revisions

using with ClearCase 14-11
tool palette 2-5, 3-1

customizing menus B-3
discussions icon 6-1, 6-6
menus B-3

traceability 1-10, 2-11, 4-3, 10-1
clearing suspect relationships 10-10
creating

in attribute matrix 10-4
in requirements document 10-2
in traceability matrix 10-5
in traceability tree 10-6
in views workplace 10-4
in Word workplace 10-2

using requirements menu 10-3
cross-project 15-14
direct and indirect 2-12
in MS Project 16-5
overview 10-1
suspect relationships 10-9

traceability matrix 2-7, 4-5, 5-3
cells 4-6
definition 2-7, 4-1
displaying properties 4-21
keyboard shortcuts A-8
mouse actions A-7
querying in the 5-3
text panes 4-6

traceability tab 10-2
traceability tree 2-7, 4-7, 5-3

attribute pane 4-8
definition 2-7, 4-1
displaying properties 4-20
keyboard shortcuts A-12
mouse actions A-12
querying in the 5-3
text pane 4-8

traced from 4-5
traced to 4-5
traced to/traced from 2-12
track changes 14-2
training xvii
tree pane 4-7
troubleshooting

failed multiple select actions 10-8
when creating requirements 8-6

U
unlocking

project documents 14-2
unmarking

requirements 8-22
Use Case Management, Integrated 16-13
user access to projects and documents 14-1
user name

changing 3-9
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editing 13-5
modifying 3-9
restrictions 13-4

users group 13-2

V
view

copying requirements in 8-17
cutting requirements in 8-17

view properties
displaying 4-20
saving as default 4-21

viewing, see also displaying
discussion attributes 6-14
discussion participants 6-15
discussion properties 6-6
discussions 6-1, 6-7, 6-12, 6-14
offline documents 7-18

views 2-7, 4-1
arranging 4-18
arranging icons 4-19
attribute matrix 2-7
cascade 4-18
closing 4-12
collapse all 4-10
column width 4-17
creating 4-9
cross-project traceability 5-10
customizing 4-16
definitions 4-1
deleting 4-15
displaying properties 4-20
duplicating 4-13
expand all 4-10
exported 5-11
exporting as Word document 11-19
navigating 4-2
opening 4-12
printing 4-14
properties command 4-20
query now 4-2
refresh all 4-2

renaming 4-13
resizing 4-18
row height 4-16
saving 4-10
searching 5-7
tile 4-19
traceability matrix 2-7
traceability tree 2-7

views workplace 2-5

W
web 2-2
web site xix
wizards

Database Type Conversion Wizard 14-22
Import Wizard 11-1
Project Conversion Wizard 12-9
Project Wizard 12-4

Word format 11-2
Word style 8-4
word workplace 2-5
Word, see Microsoft Word
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