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This document and its associated software may be used as stated in the underlying license agreement.
Rational Software Corporation expressly disclaims all other warranties, express or implied, with respect to
the media and software product and its documentation, including without limitation, the warranties of
merchantability or fitness for a particular purpose or arising from a course of deali



cqin.book Page iv Thursday, October 4, 2001 4:07 PM



cqin.book Page v Thursday, October 4, 2001 4:07 PM
Contents
Preface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xi
Audience. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xi

Other ClearQuest documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xi

ClearQuest documentation roadmap . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xiii

Contacting Rational Technical Publications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xiii

Contacting Rational Technical Support. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xiv

1 Installing ClearQuest. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Before you begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Understanding the ClearQuest install process . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Understanding ClearQuest MultiSite master site installation . . . . . . . . . . . . . . . . . . . 4

Understanding ClearQuest MultiSite replica site installation . . . . . . . . . . . . . . . . . . . 5

2 Configuring vendor databases. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Choosing a database vendor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Database case sensitivity. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

Setting up Microsoft Access . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Setting up SQL Anywhere . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Defining user privileges . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11
Creating an SQL Anywhere Database Server . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Setting up Microsoft SQL Server 7 and 2000 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Registering your SQL Server 7 machine . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Creating a new SQL Server 7 database . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Creating a new SQL Server 2000 database . . . . . . . . . . . . . . . . . . . . . . . . 15

Creating SQL Server logins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Migrating from SQL Server 6.5 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Ensuring SQL Server 7 Client connectivity . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Setting up the Oracle Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Enhancing Oracle search capabilities . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

ConText Cartridge Personality Masks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Enabling an Oracle 8.0.5 multiline search . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Enabling Oracle 8.1.x multiline search . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Installing and configuring an Oracle client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Creating an Oracle database alias. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Setting up IBM DB2 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Creating a new DB2 database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
v



cqin.book Page vi Thursday, October 4, 2001 4:07 PM
Installing DB2 client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
Creating a DB2 database alias . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

3 Installing and configuring ClearQuest for an administrator. . . . . . . 29
Installing ClearQuest. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

What do you do next? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Configuring ClearQuest. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Creating ClearQuest databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Creating a schema repository . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Creating a user database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Licensing Rational software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Licensing ClearQuest MultiSite . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

Installing Crystal Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

4 Installing and configuring ClearQuest MultiSite . . . . . . . . . . . . . . . . 37
ClearQuest MultiSite overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38

Understanding the architecture of ClearQuest MultiSite . . . . . . . . . . . . . . . . . . . . . . 38
Using clans . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

Understanding the role of the working schema repository site . . . . . . . . . . 40
What software needs to be installed?. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
Installing the Rational Shipping Server. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

Installing the Rational Shipping Server from the ClearCase CD-ROM . . . . 42

Installing ClearQuest MultiSite for the administrator . . . . . . . . . . . . . . . . . . . . . . . . . 43

Installing Rational Shipping Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Configuring ClearQuest MultiSite . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Creating ClearQuest databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Creating a MultiSite schema repository . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Setting up mastership for records. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

Creating a user database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

5 Installing and configuring ClearQuest Windows for users. . . . . . . . 49
Installing ClearQuest for the Windows user . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Connecting to ClearQuest databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Creating a new connection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Using connection profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Creating a connection profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Importing a connection profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Enabling e-mail notification for the Windows user . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Installing Collaboration Data Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
vi Contents



cqin.book Page vii Thursday, October 4, 2001 4:07 PM
6 Installing and configuring ClearQuest Web . . . . . . . . . . . . . . . . . . . . 55
Understanding the installation process. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56

Installing ClearQuest Web software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Setting up ClearQuest Web for IIS 4 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Setting up an anonymous user account for IIS 4 . . . . . . . . . . . . . . . . . . . . . . . . 58

Create the anonymous user account. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58
Set up the registry key access privileges. . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Set up read access permission . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Creating a cache directory for IIS 4 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Configuring IIS 4.0 to serve ClearQuest Web pages . . . . . . . . . . . . . . . . . . . . . 61

Create a virtual directory for IIS 4 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Edit the properties of the virtual directory for IIS 4. . . . . . . . . . . . . . . . . . . . 63
Edit the properties of the cache directory for IIS 4 . . . . . . . . . . . . . . . . . . . 67
Edit the properties of the images directory for IIS 4. . . . . . . . . . . . . . . . . . . 67
Restart the web server for IIS 4 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

Setting Up ClearQuest Web for IIS 5 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Setting up an anonymous user account for IIS 5 . . . . . . . . . . . . . . . . . . . . . . . . 68

Create the anonymous user account. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Set up the registry key access privileges. . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Set up read access permission . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Creating a cache directory for IIS 5 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72
Configuring IIS 5 to serve ClearQuest Web pages . . . . . . . . . . . . . . . . . . . . . . 73

Create a virtual directory for IIS 5 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Edit the properties of the virtual directory for IIS 5. . . . . . . . . . . . . . . . . . . . 76
Editing the properties of the cache directory for IIS 5 . . . . . . . . . . . . . . . . . 80
Edit the properties of the images directory for IIS 5. . . . . . . . . . . . . . . . . . . 80
Restart the web server for IIS 5 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Enabling e-mail notification for web users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Installing Collaboration Data Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Configuring web browsers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Configuring the Internet Explorer browser . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
Configuring the Netscape browser. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Accessing ClearQuest Web . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86
Using the Advanced Query Editor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

7 Installing and configuring ClearQuest UNIX for users . . . . . . . . . . . 87
Understanding the install process. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

The database server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
The Windows administrator workstation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
The UNIX file server. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
Contents vii



cqin.book Page viii Thursday, October 4, 2001 4:07 PM
The UNIX user machine . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Installing the ClearQuest UNIX client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Configuring database connectivity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
Installing OpenLink Request Broker with Microsoft SQL Server . . . . . . . . . . . . 95
Installing OpenLink Request Broker with Oracle . . . . . . . . . . . . . . . . . . . . . . . . 96

Installing the OpenLink ODBC catalog views for Oracle 7 or Oracle 8 . . . . 97
Automating startup on reboot for Solaris . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
Automating startup on reboot for HP-UX . . . . . . . . . . . . . . . . . . . . . . . . . . 100
Automating startup on reboot for Linux . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
Automating startup on reboot for AIX. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Configuring DB2 databases for ClearQuest UNIX . . . . . . . . . . . . . . . . . . . . . . 103

Configuring ClearQuest UNIX. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Enabling e-mail notification for UNIX users. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

8 Silent ClearQuest installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Overview of silent installations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Recording the software installation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Example . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Specifying a post-installation command . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
Performing a silent installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Preparing multiple response files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
Examples . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Command line utilities . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113
RSSetup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Syntax . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113
License Key Administrator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Syntax . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
Example . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 116

9 Upgrading ClearQuest . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
Understanding the upgrade process . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

ClearQuest for the administrator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
ClearQuest for the user . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
Connecting to a schema repository . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Upgrading packages basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120
Analyzing your current package version. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
Applying package upgrades . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Applying schema changes to user databases. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124

Upgrading feature levels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Overview of feature level upgrade process . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
viii Contents



cqin.book Page ix Thursday, October 4, 2001 4:07 PM
Preparing your testbed. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Upgrading your databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

To perform an upgrade on an existing connection: . . . . . . . . . . . . . . . . . . 129
To upgrade a schema repository that you are not connected to:. . . . . . . . 131

Preparing your production databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132

Some helpful utilities. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
Unlocking databases . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
Creating database copies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134

installutil convertschemarepo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
Syntax:. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
installutil convertuserdb . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
Syntax:. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
Sample data by vendor type . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Troubleshooting tips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
Contents ix



cqin.book Page x Thursday, October 4, 2001 4:07 PM
x Contents



cqin.book Page xi Thursday, October 4, 2001 4:07 PM
Preface
This manual provides detailed instructions on how to install Rational
ClearQuest. Rational ClearQuest is a highly flexible defect and change
tracking system that captures and tracks all types of change, for any type of
project. This guide explains how to install ClearQuest, ClearQuest Designer,
vendor databases, and related tools.

Audience

This guide is intended for the ClearQuest administrator. It assumes that you
have read Introduction for Rational ClearQuest, the Rational ClearQuest Release
Notes, Administrator’s Guide for Rational ClearQuest and the Administrator’s
Guide for Rational ClearQuest MultiSite. It also assumes that you have
experience administering relational databases, and know how to write scripts
in VBScript or Perl.

You, the ClearQuest administrator, set up the databases to use with
ClearQuest, install ClearQuest, and provide the required set up information
to each client user. You (or your client user) can then install ClearQuest on the
client machines.

Other ClearQuest documentation

In addition to this guide, ClearQuest includes the following printed
documentation:

■ Introduction for Rational ClearQuest: Provides an overview of how to use
ClearQuest, and a brief example of how you can customize ClearQuest to
fit your organization’s workflow.

■ License Management Guide for Rational Suite: Provides you with the
technical information you need to install floating and node-locked license
keys, install and configure the Rational license server software, and
troubleshoot problems related to licensing Rational Software products.
xi
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■ Administrator’s Guide for Rational ClearQuest: This guide is for ClearQuest
administrators. It assumes that you have read Introduction for Rational
ClearQuest, have experience administering relational databases, and know
how to write scripts in VBScript or Perl.

■ Administrator’s Guide for Rational ClearQuest MultiSite: This manual is for
all MultiSite administrators. It assumes you have experience with
ClearQuest. The manual provides an overview of MultiSite, describes how
to set up and use it, and gives troubleshooting suggestions.

ClearQuest includes the following online documentation:

■ Rational ClearQuest Release Notes, located in
\Rational\doc\clearquest_readme.htm

■ Rational ClearQuest online Help: Online Help for ClearQuest.

■ Rational ClearQuest Designer online Help: Online Help for ClearQuest
Designer.

■ Rational ClearQuest Designer Tutorial: Introduction to the basic tasks of a
ClearQuest administrator.

■ Rational ClearQuest API Reference: Online reference guide explaining the
syntax for writing hooks and external applications.

■ Rational ClearQuest Web Help: Online Help for the ClearQuest web-based
client.

■ Rational ClearQuest Maintenance Tool Help: Online Help for the ClearQuest
Maintenance Tool.

■ Rational ClearQuest Import Tool Help: Online Help for the ClearQuest
Import Tool.

■ Rational ClearQuest Microsoft Project Tracker Guide: Online user guide
providing instructions on installing and using the Rational ClearQuest
Microsoft Project Tracker.
xii Preface
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ClearQuest documentation roadmap

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, please send
e-mail to our technical publications department at techpubs@rational.com.

ClearQuest Introduction
ClearQuest Help
ClearQuest Designer Tutor ial

ClearQuest Release Notes
ClearQuest Installation
ClearQuest Administrator's Guide
ClearQuest MultiSite Administrator's Guide
ClearQuest Multiuti l  Help

ClearQuest Adminstrator's Guide
ClearQuest API Reference

Star t Here

AdministratorsDesigners
ClearQuest documentation roadmap xiii
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Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product,
contact Rational Technical Support as follows:

Note: When you contact Rational Technical Support, please be prepared to
supply the following information:

■ Your name, telephone number, and company name

■ Your computer’s make and model

■ Your operating system and version number

■ Product release number and serial number

■ Your case ID number (if you are following up on a previously reported
problem)

Location Telephone Facsimile e-mail

North America (800) 433-5444
(toll free)
(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com

Europe,
Middle East,
Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4545-202
Netherlands

support@europe.rational.com

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com
xiv Preface
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1Installing ClearQuest
This chapter describes how to install ClearQuest. You, the ClearQuest
administrator, set up the databases to use with ClearQuest, install
ClearQuest, and provide the required set up information to each client user.
You (or your client user) can then install ClearQuest on the client machines.

Warning: If you are using multiple products from Rational Suite, all
products must be from the same Suite version (installed from the same
CD-ROM). To upgrade a product from the Suite, uninstall all Rational
Suite products and install the desired products from the newer Suite
CD-ROM. For more information, refer to Installation Guide for Rational
Suite.

It’s important that you review all the necessary steps before beginning.

This chapter covers the following topics:

■ “Before you begin” on page 2

■ “Understanding the ClearQuest install process” on page 3

■ “Understanding ClearQuest MultiSite master site installation” on page 4

■ “Understanding ClearQuest MultiSite replica site installation” on page 5
1
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Before you begin

Warning: Rational Suite installation does not support the automated
installation upgrade of Rational software versions prior to Version 2000.
Contact Rational Technical Support for instructions on upgrading with
earlier versions. If you attempt to install the latest version of Rational
software from a version prior to Version 2000, the installation program
will display the following messages:

Caution: Read carefully before proceeding!

You have Rational software installed on your computer from

Version 2000 or earlier. If you continue with this

installation, you can damage the software or Rational

repositories that you use with Rational products.

To protect your Rational environment, first upgrade your software and
repositories to Version 2001A, then upgrade software and repositories to the
current version. For more information, see “Upgrading from Earlier Versions
of Rational Suite” in the Installation Guide for Rational Suite.

Before you install ClearQuest, read the following:

■ Rational ClearQuest Release Notes: An HTML file that contains the most current
system requirements information (including platform version support).

■ For Windows: <d>:\ClearQuest\clearquest_readme.htm
(where <d> is your CD-ROM drive).

■ For UNIX:
<d>:/products/ClearQuestClient/clearquest_readme.htm
(where <d> is your CD-ROM drive).

■ Introduction for Rational ClearQuest: An overview of ClearQuest
components and how to use them.

■ Administrator’s Guide for Rational ClearQuest: A guide on how to customize
ClearQuest to meet your needs.

■ Administrator’s Guide for Rational ClearQuest MultiSite: A guide on how to
create and administer ClearQuest MultiSite database replicas.
2 Chapter 1 - Installing ClearQuest
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Understanding the ClearQuest install process

The following is an overview of the installation process.

1 Set up your database product. As the ClearQuest administrator, you are
responsible for setting up the databases your user will use with
ClearQuest. See “Configuring vendor databases” on page 7.

2 Optionally, install Seagate’s Crystal Reports Professional EditionTM. If you
or any of your ClearQuest users will be authoring ClearQuest report
formats, install Crystal Reports. If you currently have Crystal Reports 6.0
installed, uninstall it and install Crystal Reports 8.0 before installing
Rational ClearQuest. The Crystal Reports Installation CD-ROM is
included with your ClearQuest Media Kit. For more information on report
creating and authoring, refer to Introduction for Rational ClearQuest and the
ClearQuest online help systems.

3 Set up your license server. See “Licensing Rational software” on page 34. If
you are installing ClearQuest MultiSite, set up a license server for both
ClearQuest and ClearQuest MultiSite.

4 Install ClearQuest on the administrator’s machine and create the
ClearQuest databases. See “Installing ClearQuest” on page 30.

An administrative installation of ClearQuest involves the following steps:

■ “Installing ClearQuest” on page 30.

■ “Creating ClearQuest databases” on page 31.

5 If you are installing ClearQuest MultiSite and want to use the Rational
Shipping Server, follow these steps:

■ If you have ClearCase installed, install the Rational Shipping Server
from the ClearCase Installation CD-ROM.

■ If you do not have ClearCase installed, install the Rational Shipping
Server from the ClearQuest Installation CD-ROM.

See “Installing Rational Shipping Server” on page 43.

6 If this installation is an upgrade from a previous release of ClearQuest,
upgrade your existing databases to enable access to the new features. If
this is the case, see “Upgrading ClearQuest” on page 117.

7 Optionally, customize your installation. See the Administrator’s Guide for
Rational ClearQuest for details on customizing ClearQuest.
Understanding the ClearQuest install process 3
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8 If you are installing ClearQuest MultiSite, install ClearQuest at the replica
sites and create the ClearQuest database set replicas.

9 Install ClearQuest on the client machines and provide your user with the
information they need to connect to ClearQuest. See “Installing and
configuring ClearQuest Windows for users” on page 49 and “Installing
and configuring ClearQuest UNIX for users” on page 87.

10 If you are installing ClearQuest Web, see “Installing and configuring
ClearQuest Web” on page 55.

Understanding ClearQuest MultiSite master site installation

The installation of ClearQuest MultiSite at a master or working repository site
is performed by completing the following steps:

1 Set up your database product. As the ClearQuest administrator, you are
responsible for setting up the databases your user will use with
ClearQuest. See “Configuring vendor databases” on page 7.

2 Set up your license server. See “Licensing Rational software” on page 34.

3 Install ClearQuest MultiSite, see Chapter 4, “Installing and configuring
ClearQuest MultiSite” and optionally, the Rational Shipping Server, see
“Installing Rational Shipping Server” on page 43.

4 Configure the MultiSite Control Panel on the host machine. See
Administrator’s Guide for Rational ClearQuest MultiSite for detailed
instructions.

5 Customize your schema to use MultiSite mastership features and upgrade
your user database(s). See “Setting up mastership for records” on page 47.

6 Create replicas of your user databases and send export packets to
respective sites. See Chapter 3, “Creating Replicas” in manual,
Administrator’s Guide for Rational ClearQuest MultiSite.

7 Install ClearQuest on the client machines and provide your user with the
ClearQuest database connection information. See “Installing and
configuring ClearQuest Windows for users” on page 49 and “Installing
and configuring ClearQuest UNIX for users” on page 87.

8 If you are installing ClearQuest Web, see “Installing and configuring
ClearQuest Web” on page 55.
4 Chapter 1 - Installing ClearQuest
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Understanding ClearQuest MultiSite replica site installation

The installation of ClearQuest MultiSite at a replica site is performed by
completing the following steps:

1 Set up your database product. As the ClearQuest administrator, you are
responsible for setting up the databases your user will use with
ClearQuest. See “Configuring vendor databases” on page 7.

2 Set up your license server. See “Licensing Rational software” on page 34
and “Licensing ClearQuest MultiSite” on page 35.

3 Install ClearQuest MultiSite, see Chapter 4, “Installing and configuring
ClearQuest MultiSite” and optionally, the Rational Shipping Server, see
“Installing Rational Shipping Server” on page 43.

4 DO NOT create ClearQuest databases.

Warning: Do NOT create a ClearQuest database before receiving a database
replica. A ClearQuest database is automatically created when you import
a replica packet into an empty vendor database. If you have created a
ClearQuest database with the Maintenance Tool or ClearQuest Designer,
the replica import will fail. Delete the vendor databases and create them
again.

5 Configure the MultiSite Control Panel on the host machine. See
Administrator’s Guide for Rational ClearQuest MultiSite for detailed
instructions.

6 After receiving replica-creation packets from the working master site,
import replica-creation packets into empty vendor databases. See Chapter
5 “Creating Replicas” in the Administrator’s Guide for Rational ClearQuest
MultiSite for more information.

7 Install ClearQuest on the client machines and provide your users with the
ClearQuest database connection information. See “Installing and
configuring ClearQuest Windows for users” on page 49 and “Installing
and configuring ClearQuest UNIX for users” on page 87.

8 If you are installing ClearQuest Web, see “Installing and configuring
ClearQuest Web” on page 55.
Understanding ClearQuest MultiSite replica site installation 5
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2Configuring vendor databases
Before you install Rational ClearQuest, you need to create and configure the
vendor databases for ClearQuest and ClearQuest MultiSite.

ClearQuest and ClearQuest MultiSite require at least two databases:

■ A schema repository: This is the master database where ClearQuest and
ClearQuest MultiSite store the schema.

■ A user database: This is where data entered by ClearQuest users is stored.
You can have as many user databases as you need.

This chapter covers the following topics:

■ “Choosing a database vendor” on page 8

■ “Setting up Microsoft Access” on page 10

■ “Setting up SQL Anywhere” on page 10

■ “Setting up Microsoft SQL Server 7 and 2000” on page 13

■ “Setting up the Oracle Server” on page 17

■ “Setting up IBM DB2” on page 24
7
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Choosing a database vendor

Warning: If you are installing ClearQuest MultiSite, do not create additional
databases at the replica site. For more information see “Installing and
configuring ClearQuest MultiSite” on page 37.

ClearQuest Windows supports the following databases:

■ Microsoft Access (supplied with ClearQuest).

■ Sybase SQL Anywhere (supplied with ClearQuest).

■ Microsoft SQL Server.

■ Oracle (NT and UNIX).

■ IBM DB2 (Windows).

ClearQuest UNIX supports the following databases:

■ Microsoft SQL Server.

■ Oracle (UNIX).

■ IBM DB2 (Windows).

ClearQuest MultiSite supports the following databases:

■ Microsoft SQL Server.

■ Oracle (NT* and UNIX).

■ IBM DB2 (Windows).

Note: If you are using the ClearQuest UNIX client, with ClearQuest
MultiSite, you cannot use a Oracle NT database.

For specific supported versions, see the ClearQuest Release Notes:

■ For Windows: <d>:\ClearQuest\clearquest_readme.htm
(where <d> is your CD-ROM drive).

■ For UNIX: <d>:/products/ClearQuestClient/
ClearquestReleaseNotes.htm
(where <d> is your CD-ROM drive).

Note: You can use more than one database vendor for ClearQuest databases.
For example, you might want to use Oracle or Microsoft SQL Server
databases for your schema repository and user databases, then use a
Microsoft Access database for your test database. However, we do not
8 Chapter 2 - Configuring vendor databases
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recommend using multiple database vendors when you are using ClearQuest
MultiSite due to case sensitivity rules that are not consistent between
vendors.

Database case sensitivity

There are two scenarios when it is mandatory that your database sensitivity
settings are consistent:

■ When you are moving a database from one database vendor type to
another.

■ When you are using ClearQuest MultiSite and are employing multiple
synchronized databases created from different database vendor products.

Review the following case sensitivity properties before determining which
database vendor product to use.

Database
Vendor

Default Setting Possible Settings Comments

MS ACCESS Case-insensitive Case-insensitive MS Access databases are
case-insensitive.

SQL
ANYWHERE

Case-insensitive Case-insensitive,
Case-sensitive

All databases are created as
case-insensitive, this setting can
be changed to make it
case-sensitive.

DB2 Case-sensitive Case-sensitive The case sensitivity is applicable
to data only and not database
object names.

SQL SERVER Case-insensitive,
Case-sensitive

Case-insensitive,
Case-sensitive

The case sensitivity can be
decided either by using the
installation time option or database
creation time option.
Note: Case sensitivity applies to
database object names as well as
data.

Oracle Case-sensitive Case-sensitive The case sensitivity is applicable
to data only and not database
object names.
Choosing a database vendor 9
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Setting up Microsoft Access

Note: ClearQuest Web and ClearQuest MultiSite do not support Microsoft
Access databases.

If you are using ClearQuest with Microsoft Access:

1 Create one shared directory on the machine for the directory that will
contain your Microsoft Access databases.

2 Make a note of the UNC path of the share directory. The path should be of
the form:
\\<machine_name>\<share_name>\<database_directory>\

For example:
\\developmentserver\project34share\clearquestdbs\

The first time you run ClearQuest, you are asked to create a schema
repository. Specify this pathname and provide a filename for the schema
repository. ClearQuest then creates and initializes the appropriate Access
databases in this directory.

Now that you have set up the Access databases, proceed to “Installing and
configuring ClearQuest for an administrator” on page 29.

Setting up SQL Anywhere

To create an SQL Anywhere database server, complete the following tasks:

■ Install the Sybase SQL Anywhere Server software.

Note: SQL Anywhere is available on the ClearQuest CD-ROM and can be
installed using the Rational Software Setup wizard.

■ Choose or create a user account to run the SQL Anywhere database server
and set user privileges for that account. See Defining user privileges
below.

■ Create an SQL Anywhere database server. See “Creating an SQL
Anywhere Database Server” on page 12.

Note: SQL Anywhere databases are created as case-insensitive databases.
To migrate to a different database vendor, evaluate your database case
sensitivity settings. See “Database case sensitivity” on page 9 for more
information.
10 Chapter 2 - Configuring vendor databases
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Defining user privileges

To define privileges for a user account running an SQL Anywhere database
server:

1 Make sure you have installed the Sybase SQL Anywhere Server software.

2 Do one of the following:

a If your Windows NT computer is running Windows NT Workstation
software, click
Start > Programs > Administrative Tools (Common) > User Manager.

b If your Windows 2000 computer is running Windows 2000 Workstation
software, click
Start > Settings > Control Panel > Users and Passwords.

c If your Windows NT computer is running Windows NT Server
software:

i Click Start > Programs > Administrative Tools (Common) > User
Manager for Domains.

ii Click User > Select Domain and type the local machine name in the
Domain box, and then click OK.

Note: If the user does not already exist, create the user (User > New
User).

d If your Windows 2000 computer is running Windows 2000 Server
software:

i Click Start > Settings > Control Panel > Local Users and Groups.

ii Click User > Action > New User and type the local machine name in
the Domain box, and then click OK.

3 Click Policies > User Rights to open the User Rights Policy dialog box.

4 Select Show Advanced User Rights.

5 In the Right list box of the User Rights Policy dialog box, select Access this
computer from network.

6 Click Add.

7 For List Names From, select the domain of the account running the SQL
Anywhere database server.

8 Click Show Users.
Setting up SQL Anywhere 11
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9 In the Names list, select the account running the SQL Anywhere database
server.

10 Click Add, and then click OK.

11 In the Right list box of the User Rights Policy dialog box, select
Log on as a service.

12 Repeat Steps 6 through 10.

13 In the Right list box of the User Rights Policy dialog box, select
Log on locally.

14 Repeat Steps 6 through 10.

15 Click OK.

16 Click User > Exit. 

Creating an SQL Anywhere Database Server

An SQL Anywhere database server is a process that runs on the database
server machine. Its function is to coordinate all activity against your SQL
Anywhere databases. You can create one SQL Anywhere server to provide
access to all of your database files, including all of the ones in your test
datastore(s).

To create an SQL Anywhere database server:

1 Open Rational Administrator.

2 Click Tools > Sybase Central.

3 In the left pane, click Services under Sybase SQL Anywhere.

4 In the right pane, double-click Add Service to launch the Create New
Service wizard and click Next.

5 In the Choose Service Type dialog box, select Network Server and click
Next.

6 In the Choose Name and Startup dialog box, enter the name of the service,
select the manner in which the service will be started (we recommend
Automatic), and click Next.
12 Chapter 2 - Configuring vendor databases
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7 The Choose Path Name dialog box displays the default path for the
executable file for the new service. This is the path to the SQL Anywhere
database server executable (DBSRV50.EXE) that exists in the
SQLANY50\WIN32 subdirectory within the Rational install directory.
This should be set by default.

Note: A Windows 2000 defect causes the path to display incorrectly on
the Choose Path Name dialog box. In that case, click Browse to locate the
DBSRV50.EXE and click Next.

8 In the Specify Parameters dialog box use the -n flag and enter the database
server name; for example:

-n MyDBServer

The database server name is the only required parameter for Rational
tools. The name you enter here is required when creating a ClearQuest
database or Rational test datastore.

9 In the Choose Account dialog box, click Other, select Administrator, enter a
password, enter the same password again to confirm, and click Next.

Note: The account you specify must have Log on as a Service privilege. If
the account does not have this privilege, Sybase displays a message to that
affect. Click Yes to grant the privilege when the service is intalled.

10 In the Choose Options dialog box, we recommend that you select Start
service when created and click Next.

11 The Ready to Create New Service dialog box displays the settings you
have selected. Confirm that the settings are correct and click Finish.

Setting up Microsoft SQL Server 7 and 2000

Note: When you install SQL Server, select one of the following sort-order
options:

■ Dictionary order, case-sensitive.

■ Dictionary order, case-insensitive.

If you change sort orders after installing SQL Server, you must rebuild the
SQL databases and reload the data.

Note: This will affect case sensitivity of ClearQuest queries. If you want
ClearQuest queries to be case-insensitive, set the order here. See “Database
case sensitivity” on page 9 for more information.
Setting up Microsoft SQL Server 7 and 2000 13
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You need to set up one empty SQL Server database for the ClearQuest schema
repository, and one empty SQL Server database for each ClearQuest Client
user database (such as the optional SAMPL database). For each SQL Server
database, complete the following tasks:

■ (Verify) server registration.

■ Create an empty database.

■ Set up a backup procedure for the database.

■ Create an SQL Server login with the db_owner role to use for the
ClearQuest database logins (the same login is used by ClearQuest for all
connections).

Note: Do not use the SA (system administrator) login. During an upgrade or
move process, ClearQuest requires empty databases. However, if the SA login
is used, ClearQuest is able to see the System Tables, assumes the database is
not empty, and does not allow the upgrade/move process to continue.

Note: When installing SQL Server 2000, it is important to select the default
registration name for your database server. This will make the registration
name the same as your server’s machine name.

To add more user databases to ClearQuest, repeat the succeeding tasks for
each new database.

Registering your SQL Server 7 machine

1 In the SQL Server Enterprise Manager, select your Windows NT server in
the SQL Server Group.

If your server is not shown, register it now by going to Step 2. If your
server is already registered, go to “Creating a new SQL Server 7 database”
on page 15.

2 Right-click the SQL Server Group and select New SQL Server Registration.
The Register SQL Server Wizard displays.

3 Select a server name, and click Next.

Note: Make a note of the server name because you will need it during the
ClearQuest installation.

4 For Authentication Mode, select SQL Server Authentication, then click
Next.

5 For Login ID, type SA and for Password, type your SA password. Then click
Next. (The SA user has the privilege to create logins and databases.)
14 Chapter 2 - Configuring vendor databases
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6 Add this server to an existing group, or create a new group. Then click
Next.

7 Click Finish. The server will appear in the list of servers.

8 Verify from the status window that registration has been completed
successfully and then Close.

Creating a new SQL Server 7 database

1 From the Getting Started Taskpad, select Administer SQL Server > Create a
database.

Note: Do not use spaces or non-alphanumeric characters in the database
name. (Underscores are acceptable.)

2 In the wizard, specify a file system location for the database and the log.
You can accept the defaults for the growth rate of the database and the log.

Note: To give the databases larger initial values, allocate at least 50 MB for
the schema repository and at least 15 MB for every 1,000 records expected
for your user databases.

3 After you create a database, you are prompted to create a Database
Maintenance Plan. The Database Maintenance Plan Wizard allows you to
set up a database backup routine. It is strongly recommended that you set
up automated nightly backups for all your ClearQuest databases.

4 Set database properties for the new database:

a Select the new database from the server’s databases folder.

b Right-click the database and select Properties.

c On the Options tab, select these settings:

■ Select into / bulk copy.

■ Truncate log on checkpoint.

d Click OK.

Creating a new SQL Server 2000 database
Note: When installing SQL Server 2000, it is important to select the default
registration name for your database server. This will make the registration
name the same as your server’s machine name.
Setting up Microsoft SQL Server 7 and 2000 15
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1 Open the SQL Server Enterprise Manager, right-click the server name and
select View > Taskpad.

2 Click the Wizards, go to Setup a Database, click Create a Database Wizard.

3 In the wizard, specify a file system location for the database and the log.
You can accept the defaults for the growth rate of the database and the log.

Note: Do not use spaces or non-alphanumeric characters in the database
name. (Underscores are acceptable.)

Note: To give the databases larger initial values, allocate at least 50 MB for
the schema repository and at least 15 MB for every 1,000 records expected
for your user databases.

4 After you create a database, you are prompted to create a Database
Maintenance Plan. The Database Maintenance Plan Wizard allows you to
set up a database backup routine. It is strongly recommended that you set
up automated nightly backups for all your ClearQuest databases.

Creating SQL Server logins

Create a db_owner login for each ClearQuest database (schema repository and
each user database) by selecting the db_owner role for each of the logins you
create.

Note: Do not use the SA (system administrator) as the owner login of a
ClearQuest database. During an upgrade or move process, ClearQuest
requires empty databases. However, if the SA login is used, ClearQuest is able
to see the System Tables, assumes the database is not empty, and does not
allow the upgrade/move process to continue.

1 Expand the Security folder, then right-click Logins and click New Login.
The SQL Server Login Properties - New Login dialog box displays.

2 On the General tab, select SQL Server Authentication because ClearQuest
does not support Windows authentication.

Note: Because ClearQuest requires an SQL Server login for each database
and does not support Windows NT Authentication, your must configure
the SQL Server to operate in Mixed Mode (Windows NT Authentication
and SQL Server Authentication). This property can be set via Enterprise
Manager. Right-click the server and select Properties menu, Security tab.

3 Enter a name and password.

4 In the Defaults area, select your database and leave the Language set to
<default>.
16 Chapter 2 - Configuring vendor databases
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5 On the Server Roles tab, do not grant any server roles.

6 Grant db_owner privileges to the login in the new database.

a On the Database Access tab, select from the Permit list the new
database to grant the login permission.

b Under Permit in database role, check db_owner and public. Do not
grant this user any other privileges.

7 Click OK and verify your password.

Migrating from SQL Server 6.5

Use the ClearQuest Maintenance Tool to migrate your schema repository to
an SQL Server 7 database. Then use ClearQuest Designer to move previous
SQL Server 6.5 user databases to SQL Server 7. You do this by using the
Properties dialog box to change the properties of the user database.

Warning: When migrating from SQL Server 6.5 to SQL Server 7, do NOT use
the SQL Server 7 Upgrade Wizard to upgrade your schema repository and
user databases. You need to use the ClearQuest Maintenance Tool and
ClearQuest Designer.

Ensuring SQL Server 7 Client connectivity

SQL Server 7 client machines require SQL Server ODBC driver number 3.7x.
To update the ODBC driver for a client machine:

1 Go to that machine, insert the SQL Server 7 CD-ROM, and run
D:\x86\other\mdac_type.exe

where D: is the letter of your CD-ROM drive.

2 Choose the Custom install option when prompted.

3 Select ODBC Driver for Microsoft SQL Server (and unselect other options
such as Microsoft JetEngine).

Now that you have set up your SQL Server databases, proceed to “Installing
and configuring ClearQuest for an administrator” on page 29.

Setting up the Oracle Server

If you are using ClearQuest with Oracle databases, install and create the
databases according to Oracle’s documentation. Follow these guidelines
when you set up your Oracle databases:
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■ Create a specific Oracle database instance, or identify an existing Oracle
instance, to use for ClearQuest data.

■ Create two or more separate Oracle database user accounts (each with its
login):

■ The ClearQuest schema repository user login.

■ One user login for each ClearQuest user database.

■ Grant each user login the Connect and Resource roles only.

Note: We recommend that you associate each Oracle database user with a
unique default tablespace that is separate from all other users. In the Oracle
database, users can share the temporary tablespace(s), but the temporary
tablespace(s) for these users must be separate from the Oracle system
tablespace.

Note: Oracle is a case-sensitive database. If you are employing ClearQuest
MultiSite or you want to migrate to a different database vendor, you need to
evaluate your database case sensitivity settings. See “Database case
sensitivity” on page 9 for more information.

Enhancing Oracle search capabilities

With a standard Oracle installation, you cannot perform a string search on
multiline text fields. For example, in ClearQuest you cannot search for text in
a multiline Notes field.

Oracle does provide an option called the ConText Cartridge (Oracle 8.0.5) or
interMediaText (Oracle 8.1.x) that enables string searches in multiline text
fields. When installed, multiline text fields become available for queries in
ClearQuest.

ConText Cartridge Personality Masks

The collection of all the personalities for a ConText server is called the
personality mask. When a ConText server is started, it is assigned a default
personality mask consisting of the DDL (D), DML (M), and Query (Q)
personalities. The ones pertinent to ClearQuest are described below:
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DDL (D) Personality

The DDL personality enables a ConText server to process requests for
creating, optimizing, and dropping text indexes. The text index on a column
allows the user to query the text stored in the column. This personality is
required to run the setup script, setup_cq_ctx_policy.sql for multiline
searches in ClearQuest.

DML (M) Personality

The DML personality enables a ConText server to automatically update the
text index for a table when changes to the table are made that require the text
index to be updated. Such changes include inserting new records, updating
existing records, and deleting existing records.

Without it, text searches are based on text data that was indexed when the
ConText server with M personality was last executed.

Note: When systems have a high volume of text inserts, updates, and deletes,
assign the DML personality to multiple servers to better distribute the system
load.

Note: The DML personality server should always be running to avoid
searching on obsolete text data.

Query (Q) Personality

The Query personality enables a ConText server to process queries for text
searches. If no running ConText servers have the Query personality, queries
submitted to ConText will fail. In ClearQuest, an error message will be
generated if there are no ConText servers with Q personality running at the
time the query is executed.

Note: When systems have a high volume of text queries, assign Query
personality to multiple servers to better distribute the system load. In some
cases where more than one text search is executed simultaneously, a query
may fail if there is not enough servers running.

Note: Run at least two ConText servers with all three personalities.

interMediaText Personality Masks

The DML (M) is the only personality used in ConText server for
interMediaText. This means a running ConText server is not required to run
text searches (In version 8.0.5, you need to have a ConText server with Query
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personality to perform text searches). However, there are some issues on not
searching with the most current text data. Refer to Oracle interMediaText
documentation for more details.

Note: When systems have a high volume of text inserts, updates, and deletes,
run multiple servers to better distribute the system load.

Note: The ConText server should always be running to avoid searching on
obsolete text data.

Enabling an Oracle 8.0.5 multiline search

To enable Oracle multiline text search for Oracle 8.0.5 with ClearQuest, do the
following.

1 Install the ConText Cartridge according to the Oracle documentation.

2 Start at least two ConText servers. Be sure to use the QDM (Query, DDL,
DML) personality options. For example:
% ctxsrv -user ctxsys/ctxsys -personality QDM -logfile
$ORACLE_HOME/ctx/log/ctxsrv1.log &
% ctxsrv -user ctxsys/ctxsys -personality QDM -logfile
$ORACLE_HOME/ctx/log/ctxsrv2.log &

where ctxsys/ctxsys is the default username/password.

Note: You may have to create that ctx/log directory. You'll also want to
run this in the background. Oracle doesn't provide anything to start this
automatically at boot time, so you will either have to run these processes
manually or develop a shell script for that purpose. Refer to your Oracle
user manuals for additional information.

3 To set up the ClearQuest Oracle user to have the necessary privileges, run
the following SQL script using Oracle's SQLPlus utility as the Oracle
ctxsys user.

The SQL script (setup_cq_ora_user.sql) can be found in the ClearQuest
installation directory (\\Rational Software\ClearQuest\).
sqlplus ctxsys/<password>@<tnsname>
@setup_cq_ora_user.sql <cquser>

where <cquser> is the name of the Oracle login used for creating the
ClearQuest database.

4 To set up the text indexes required to perform multiline searches, run the
SQL script setup_cq_ctx_policy.sql located in your ClearQuest
installation directory. For example:
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sqlplus <cquser>/<password>@<tnsname>
@setup_cq_ctx_policy.sql

where <cquser> is the name of the Oracle login used for creating the
ClearQuest database.

Note: This script needs to be executed for each user database only after the
database has been created (either in ClearQuest Maintenance Tool or
ClearQuest Designer). Otherwise, the script will not find the necessary
ClearQuest tables that it needs.

Enabling Oracle 8.1.x multiline search

To enable Oracle multiline text search for Oracle 8.1.x with ClearQuest, do the
following.

1 Install interMediaText according to the Oracle documentation. Generally,
this is installed by default when the Oracle server is installed.

2 Perform the Post-Installation Setup procedures documented in Oracle
interMediaText 8.1.5 Technical Overview. You can find this guide at:
http://www.oracle.com/support/

3 Start at least one ConText server. The personality parameter is optional.
For example run the following command:
ctxsrv -user ctxsys/ctxsys -personality M -logfile \
$ORACLE_HOME/ctx/log/ctxsrv.log &

where ctxsys/ctxsys is the default username/password.

Note: You may have to create that ctx/log directory. You will also want
to run this in the background. Oracle doesn’t provide anything to start this
automatically, say at boot time, so you will either have to run these
processes manually or develop a shell script for that purpose.

4 Start at least one ConText server. For example:
% ctxsrv -user ctxsys/<password> -log ctx.log1 &
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5 To set up the ClearQuest Oracle user to have the necessary privileges, run
the following SQL script using Oracle’s SQLPlus utility as the Oracle
ctxsys user.

The SQL script (setup_cq_ora_user.sql) can be found in the
ClearQuest installation directory
(\\Rational Software\ClearQuest\).

sqlplus ctxsys/<password>@<tnsname>
@setup_cq_ora_user.sql \ <cquser>

where <cquser> is the name of the Oracle login used for creating the
ClearQuest database.

6 To set up the text indexes required to perform multiline searches, run the
SQL script setup_cq_intermedia.sql located in your ClearQuest
installation directory. For example:
sqlplus <cquser>/<password>@<tnsname>
@setup_cq_intermedia.sql

where <cquser> is the name of the Oracle login used for creating the
ClearQuest database.

Note: This script needs to be executed for each user database only after the
database has been created (either in ClearQuest Maintenance Tool or
ClearQuest Designer). Otherwise, the script will not find the necessary
ClearQuest tables that it needs.

Installing and configuring an Oracle client

The ClearQuest administrator and all ClearQuest Windows users must install
Oracle Client Software on their local machines before they can install and use
ClearQuest. To install Oracle Client Software, follow the Oracle Networking
Products documentation.

Note: If you are using Oracle 8.0.x and 8.1.x clients, you must have the latest
patch installed to operate successfully with ClearQuest Web. For more
information, see your latest ClearQuest release notes located at:

■ For Windows: <d>:\ClearQuest\clearquest_readme.htm
where <d> is your CD-ROM drive

■ For UNIX:
<d>:/products/ClearQuestClient/clearquest_readme.htm
where <d> is your CD-ROM drive
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Creating an Oracle database alias

Before using ClearQuest Windows, all users must use the SQL8*Net Easy
Configuration program to configure their computers to access Oracle
databases.

Note: Even if you will only be using ClearQuest UNIX clients, you need to
use the SQL*Net Easy Configuration tool to configure the administrator’s NT
workstation to access the Oracle database. ClearQuest UNIX requires that the
administrator machine be a Windows machine.

1 From the Start menu, click Oracle for Windows NT > SQL8*Net Easy
Configuration if using Oracle 8.x and complete these steps:

a Select View Configuration Information to see if your Oracle database
administrator configured a Database Alias for you. If not, go to the next
step.

b Add a new database alias by selecting Add Database Alias. Click OK.

c Type an SQL8*Net Database Alias (database name your Oracle
database administrator set up previously). Make a note of the Database
Alias; you will need it during the ClearQuest database setup. Click OK.

Note: All ClearQuest users must use the same Database Alias.

d Select TCP/IP as the network protocol to use to communicate with the
database. Click OK.

e Type the Host Name (the name of database server machine) and the
Database Instance (the system ID or SID). See “Setting up the Oracle
Server” on page 17.

f All ClearQuest users must use the same Database Alias, Database
Instance (system ID or SID), TCP/IP protocol, and Host Name (Oracle
server machine).

g When you click OK, the SQLNet8 Easy Configuration program asks
you to confirm your choices. Click Yes to confirm the current
configuration information.

h After configuring your database, the installer displays the initial
opening screen so that you can configure additional aliases. To quit the
program, click Cancel.
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Setting up IBM DB2

To use ClearQuest with IBM DB2 databases, you need to install IBM DB2 7.1
on your database server.

Note: Please see the ClearQuest release notes before proceeding for more
information about using DB2 databases with ClearQuest.

Start > Programs > Rational > Rational ClearQuest > Rational ClearQuest
Release Notes).

Note: DB2 is a case-sensitive database. If you are employing ClearQuest
MultiSite or you want to migrate to a different database vendor, you need to
evaluate your database case sensitivity settings. See “Database case
sensitivity” on page 9 for more information.

Creating a new DB2 database

You need to set up one empty DB2 database for the ClearQuest schema
repository, and one empty DB2 database for each ClearQuest user database
(such as the optional SAMPL database). For each DB2 database, complete the
following tasks.

1 From the Start menu, click IBM DB2 > Control Center.

2 Enter the login name and password for the DB2 administrator account and
click OK.

3 From the DB2 Control Center, expand the machine name that corresponds
to the database server name.

4 Right-click the Databases folder and choose Create > Database using
Wizard.

Note: Make sure all DB2 services are running, otherwise this utility will
not work.

5 Enter a name of the database.

Note: DB2 supports database names with eight characters or less.

6 Click Finish.

7 Expand the database name folder.

8 Right-click the Buffer Pools folder and choose Create…

9 On the Create Buffer Pool dialog box, enter a name for Buffer pool name
(such as BFP16K), select Page size = 16 and click OK.
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10 Right-click the DB2 folder, and choose Stop (remember to mark the
checkbox Disconnect all applications), and then Start to restart the database
with buffer pool activated.

11 Right-click the Table Spaces folder and choose Create > Table space…

a Enter a name for Table space name (in other words: TSPRGR16K),
select Type of table space = Regular, and Space management = System.

b In the Container name section, select Add button and enter a name for
Container (in other words: cntr1a_16K). Click OK to close the dialog
box.

c In the Create Table Space dialog box, click the Advanced button.

d Select Page size = 16, and select the buffer pool name created earlier for
Buffer pool, then click OK.

e Click OK to close Create Table Space dialog box.

12 Right-click the Table Spaces folder again and choose Create > Table space…

a Enter a name for Table space name (in other words: TSPTMP16K). Then
enter the data in the table below depending on your database version.
In the Container name section, select Add button.

b In the Add Container dialog box, enter a name for Container (in other
words: cntr1b_16K), click OK to return to the Create Table Space dialog
box.

Note: Make sure a unique name is used for each container created.

c Click the Advanced button of the Create Table Space dialog box.

d On the Advanced dialog box, select Page size = 16, and select the buffer
pool name created earlier for Buffer pool. Then click OK.

e Click OK to close the Create Table Space dialog box.

13 Right-click the database name and select Configure.

Table space entries DB2 6.1 DB2 6.1

Type of table space = Temporary System Temporary

Space management = System System
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a Select the Performance tab, set the value for the parameter Application
heap size = 512 and the parameter Application control heap size = 512.

b Select Log tab, set value for the parameter Log File size = 1000, the
Number of Primary Log Files = 15, and Number of Secondary Log Files =
10.

c Click OK to save changes.

14 Right-click the DB2 folder, and choose Stop. Then click Start to restart the
database and make the configuration parameters effective.

Installing DB2 client

All ClearQuest Windows client users (including the ClearQuest
administrator) must install DB2 client software on their local machines before
they can install and use ClearQuest. To install DB2 client software, follow the
IBM documentation.

Note: If the client and server machines are the same, you can skip this step.

Creating a DB2 database alias

Before using ClearQuest Windows client, all users must use the Client
Configuration Assistant to create a DB2 alias for each ClearQuest schema
repository and user database they will use.

1 Install DB2 Client Software according to the IBM DB2 documentation.

2 From the Start menu, choose IBM DB2 > Client Configuration Assistant. The
Welcome dialog box appears.

3 Click Add database.

4 Click Search the network.

5 Click Next.

6 Expand the Known Systems folder, if you see the database server machine
on which the ClearQuest database resides, expand it and select the
database name for which you want to create an alias.

Note: If you don’t see the machine you need, try expanding the Other

Systems folder. If you don’t see the machine you need in the Other Systems
folder, talk to your database administrator. There may be a network
problem.

7 Expand the database server machine folder you need and select the
database for which you need to create an alias.
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8 Click Next.

9 Repeat steps 1 - 8 for each schema repository and user database.

Now that you have set up your DB2 databases, proceed to “Installing and
configuring ClearQuest for an administrator” on page 29.
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3Installing and configuring
ClearQuest for an administrator
Before installing ClearQuest on client machines you must install it on the
administrator’s machine, set up licensing, and set up your schema repository
and user databases.

If you are using an Oracle or DB2 database, install the Oracle or DB2 client
software before installing ClearQuest. See “Setting up the Oracle Server” on
page 17 or see “Setting up IBM DB2” on page 24 for more information.

This chapter covers the following topics:

■ “Installing ClearQuest” on page 30

■ “Configuring ClearQuest” on page 31

■ “Licensing Rational software” on page 34

■ “Installing Crystal Reports” on page 36
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Installing ClearQuest

To install ClearQuest for administrators:

1 Load the ClearQuest CD-ROM on the machine you want to administer
ClearQuest.

2 If the setup program does not run automatically, navigate to the top level
directory of the CD-ROM and double-click setup.exe.

3 Click the button Configure License and enter your ClearQuest license
information and if applicable, your ClearQuest MultiSite license
information. Follow the instructions on your License Certificate and in the
online Help for the License Key Administrator.

Note: Rational ClearQuest uses a license server. If you don’t already have
a license server installed, it is available on the Rational Solutions for
Windows CD-ROM. For more information, see License Management Guide
for Rational Suite, available on the Rational Solutions for Windows Online
Documentation CD-ROM.

4 To install ClearQuest for the administrator do one of the following:

a To perform a standard installation of ClearQuest, select the Typical
install option.

b To include an evaluation database with your ClearQuest installation,
select the Custom install option, expand the ClearQuest node and check
the Evaluation Database Installation box.

The Rational Software Setup wizard prompts you through the ClearQuest
Windows installation.

What do you do next?
■ “Configuring ClearQuest” on page 31.

■ “Installing and configuring ClearQuest Windows for users” on page 49.
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Configuring ClearQuest

Creating ClearQuest databases

After you install ClearQuest and have created the necessary empty vendor
databases (see “Installing and configuring ClearQuest for an administrator”
on page 29), you must create the ClearQuest databases (schema repository
and user databases). Initially you can create a sample user database to use
while you familiarize yourself with the product. You can create your
production user databases later.

Creating a schema repository

Before you create a new schema repository, you must create a vendor
database to use for your schema repository. If you are using Microsoft Access
or SQL Anywhere, you are prompted to make a share.

To create a new schema repository, use the ClearQuest Maintenance Tool.

1 Select Schema Repository > Create.

2 In the Existing Connections area, type a name for the schema repository
connection, then press ENTER.

3 In the Schema Repository Properties area, enter the properties of the
vendor database designated for the schema repository.

a Choose a vendor database from the drop-down list.

b Enter the required vendor database properties. The information to
enter is as follows:

■ MS_ACCESS

■ Enter a name for the schema repository. Enter the entire path to the
file using a UNC style path. For example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory where you want to create the database.
Be sure to browse using the Network Neighborhood to preserve the
UNC style path name.

■ SQL_ANYWHERE

■ Enter a name for the schema repository. Enter the entire path to the
file using a UNC style path. For example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.db
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You can browse to the directory where you want to create the database.
Be sure to browse using the Network Neighborhood to preserve the
UNC style path name.

■ Enter the name of the database server.

■ Enter the protocols used to communicate with the SQL Anywhere
server.

■ Enter the database host name. The database host machine must be
visible to the client machines via network share and via one or more
of the communication protocols. For TCP/IP, this can also be the IP
address.

■ SQL_SERVER

■ Enter an SQL Server database name for the database that will
contain the schema repository.

■ Enter the name of the database server.

Note: If you are using ClearQuest UNIX, each UNIX client must be able
to access this server host name exactly as it appears in this entry.

■ Enter the database owner (DBO or Administrator) login.

■ Enter the password for the database owner (DBO or Administrator)
login.

■ Enter the general purpose or read/write login.

■ Enter the password for the general purpose or read/write user
login.

■ Enter the schema repository or read-only user login.

■ Enter the password for the schema repository or read-only login.

■ ORACLE

■ Enter the TNS name (SQL*Net Alias pointing to the Oracle
instance).

■ Enter the Oracle login you created for the schema respository.

■ Enter the password for the login.

■ The following options need to be entered in the Connect Options
field, delimited by semi-colons. For example,
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Host=<name>; SID=<name>; Server_ver=8.0; Client_ver=7;
Lob_type=LONG

Note: All ClearQuest users must use the same SQL*Net Alias (TNSname),
Database Instance (system ID or SID), TCP/IP protocol, and Host Name
(Oracle server machine).

■ DB2

■ Enter the Database Alias name (alias pointing to the DB2 database).

■ Enter the DB2 login created for the schema repository.

■ Enter the password for the login.

4 Click Next.

5 In the Sample Database area:

a Select the Create sample database check box.

b In the Sample DB Schema list, choose a schema to use for your sample
database.

c Optionally, in the Description box, enter a description.

6 In the Sample User Database area, enter the properties of the vendor
database designated for the sample database, see Step 3 for information
about database properties.

7 Click Finish.

Option Definition

Host The name of the database server machine. If your ClearQuest deployment
will include both UNIX and Windows clients, the Host name is mandatory.

SID The name of the Database Instance. If your ClearQuest deployment will
include both UNIX and Windows clients the SID name is mandatory.
On UNIX, the SID is case-sensitive.

Server_ver Provide the version of the Oracle server you are using. Possible values are
7, 8.0, and 8.1. (For Oracle 8i, use 8.1.)

Client_ver Provide the version of the Oracle client software you are using. Possible
values are 7, 8.0, and 8.1. (For Oracle 8i, use 8.1.)
If ClearQuest client users want to use a different Oracle client version than
what is entered here by the administrator, they’ll need to override the set
options manually. The default setting is 7.
See Release Notes for details.

Lob_type Set the type of data you’ll be using. The valid data type is LONG.
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8 Optionally, you can create connection profiles for your users to use when
connecting to ClearQuest, see “Using connection profiles” on page 52.

Creating a user database

You create ClearQuest user databases with the ClearQuest Designer, after you
have successfully created and connected to a schema repository.

Note: Unless you are using MS Access, you must have first created empty
vendor databases before you can create the ClearQuest databases.

1 From the Start menu, choose Programs > Rational ClearQuest > ClearQuest
Designer.

2 Click Next when the Rational Schema Repository dialog box appears.

3 Click OK when the ClearQuest Designer Login dialog box appears.

Note: When you click OK, you will be logging in with the default
ClearQuest administrator login name and password. The default user
name is “admin”; the password is null and should be left blank. You
should change this password and create a new login at your earliest
convenience.

4 Click Cancel when the Open Schema dialog box appears.

5 Choose Database > New Database.

6 Enter a logical name for the database you want to create. This name must
be five characters or less. Click Next.

7 Select the vendor database you plan to use, enter the properties
appropriate for that vendor, then click Next. For more information about
the required parameters for vendor databases, see step 3 under “Creating
a schema repository” on page 31. Click Next.

8 Click Next to accept the default polling parameters.

9 Choose a schema with which to associate your database. You must
associate the database with a schema.

10 Click Finish.

Licensing Rational software

ClearQuest administrator sets up and maintains licenses using the Rational
License Administrator.
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For more information about licensing Rational Software products, see the
book License Management Guide for Rational Suite.

Rational Software product licensing provides two types of licenses:

■ Node-locked license: Enables a single user to install and use a Rational
Software product on a specific system.

■ Floating license: Enables a specified number of users to install and use a
Rational Software product on their systems. Floating licenses are shared
among all users of the licensed software.

Note: If you purchase ClearQuest with a node-locked license, your
ClearQuest Web functionality is limited to the ability to submit defects and to
run one query (predefined by your ClearQuest administrator). To get full
ClearQuest Web functionality, you need to purchase a floating license.

The license key certificate included with your purchase of ClearQuest
indicates the type of licenses you are working with and the license keys you
need to install.

Rational Software makes it easy to install and maintain licenses by providing
the Rational License Administrator. Rational Software also provides
GLOBEtrotter Inc.’s FLEXlm License Manager for administering floating
licenses.

The Rational License Administrator is automatically installed when you
install ClearQuest. To use the Rational License Administrator, select Rational
ClearQuest > License Administrator from the Start menu. For information
about installing your product licenses so you can get started using
ClearQuest, see the Rational License Administrator online help.

To install the FLEXlm License Manager, select GLOBEtrotter FLEXlm License
Server from the list of products displayed in the Rational Software Setup
program. For additional information about FLEXlm licensing, see the
Rational License Administrator online help.

Licensing ClearQuest MultiSite

ClearQuest MultiSite requires both a ClearQuest license and a ClearQuest
MultiSite license. Any access to a replicated database requires both a
ClearQuest and a ClearQuest MultiSite license, see the Administrator’s Guide
for Rational ClearQuest MultiSite.

You can calculate the number of ClearQuest MultiSite licenses your site needs
by determining how many developers will access replicated databases. If all
of your developers will access replicated databases, you need the same
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number of ClearQuest MultiSite licenses as ClearQuest licenses. If not all
developers will access replicated databases, you can purchase fewer
ClearQuest MultiSite licenses.

For example, a company has two sites, with 20 developers at site A and 5
developers at site B. The company has three databases at site A; two of them
will be replicated to site B and one will not be replicated. Five of the
developers at site A will access only the unreplicated database, and the
remaining 15 will work in all databases. Therefore, the company needs to
purchase the following numbers of licenses:

Note: This example assumes that you purchase a ClearQuest license for each
user. If you have fewer ClearQuest licenses than users, you can purchase a
proportionate number of ClearQuest MultiSite licenses. For example, if site B
purchased three ClearQuest licenses, they would also purchase three
ClearQuest MultiSite licenses.

Installing Crystal Reports

To customize the defect reports that ship with ClearQuest, you must install
Crystal Reports Professional Edition 8.0. If you currently have Crystal
Reports 6.0 installed, you will need to uninstall it and install Crystal Reports
8.0 before installing Rational ClearQuest. The Crystal Reports Installation
CD-ROM is included with your ClearQuest Media Kit. For more information
on report creating and authoring, refer to Introduction for Rational ClearQuest
and the ClearQuest online help systems.

To install Crystal Reports, use the Crystal Reports installation directions that
come with the CD-ROM.

Note: Users who will not be editing existing or creating new report formats,
do not need to install Crystal Reports.

Site
Number of ClearQuest
Licenses

Number of ClearQuest MultiSite
Licenses

A 20 15

B 5 5
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4Installing and configuring
ClearQuest MultiSite
This chapter describes how to install ClearQuest MultiSite. You install
ClearQuest MultiSite using the same steps you follow when installing
ClearQuest (see “Installing ClearQuest” on page 30), with several additional
considerations. It’s important to read this chapter before installing ClearQuest
MultiSite.

Note: If you are installing ClearQuest MultiSite, be very careful when
designing a system that utilizes databases created through different database
vendors. Case sensitivity conflicts between database vendors may cause your
MultiSite synchronization operations to fail (see “Database case sensitivity”
on page 9). SQL language differences between vendors may cause certain
queries to be unreadable by the ClearQuest client. See the Administrator’s
Guide for Rational ClearQuest MultiSite for more information.

Before installing, you should read the following chapters in Administrator’s
Guide for Rational ClearQuest MultiSite, Chapter 1,“Introducing ClearQuest
MultiSite” and Chapter 2, “Deploying ClearQuest MultiSite.”

This chapter covers the following topics:

■ “ClearQuest MultiSite overview” on page 38

■ “Installing ClearQuest MultiSite for the administrator” on page 43

■ “Installing Rational Shipping Server” on page 43

■ “Configuring ClearQuest MultiSite” on page 45
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ClearQuest MultiSite overview

ClearQuest MultiSite adds a powerful capability to Rational ClearQuest. With
ClearQuest MultiSite, developers at different locations can use the same
schema and user database. Each location (site) has synchronized copies
(replicas) of the user database and its respective schema repository. At any
time, a site can propagate the changes made in its particular replicas to other
sites, by sending update packets. The update process can be scheduled by any
number of methods to be automatic or can be started manually.

An organization can use ClearQuest MultiSite to distribute independent, but
related development efforts across multiple cities, nations, or continents. For
example, a company in the United States has development and testing sites in
India, Argentina, Japan, and Australia. Because it is impractical for all
engineers to access the ClearQuest database in the United States, the
company uses ClearQuest MultiSite to distribute the database.

Understanding the architecture of ClearQuest MultiSite

Before you start using ClearQuest MultiSite, you should be familiar with the
architecture of ClearQuest.

In summary, ClearQuest uses database sets to organize data. A database set
consists of a schema repository and each of its associated user databases. A
schema repository holds the metadata that defines user databases (schemas),
while a user database is where record information is stored and is what the
user accesses to submit and modify records. One schema repository can
support multiple user databases. For more information about ClearQuest
architecture, see the Administrator’s Guide for Rational ClearQuest.

ClearQuest MultiSite replicates both a schema repository and an associated
user database when it creates a replica site. Consequently, when you work
with ClearQuest replicas, you are working with two database replicas, a
replicated schema repository and a user database replica.

A replica is a named set of one replicated schema repository and one user
database replica. Replicas reside at physical sites.

Term Definition

Clan A clan represents a group of replicas that use the same schema repository (a
database set). A clan consists of one or more replica families.
Replicas originating from the same database set use the same clan name. The clan
is named when the first replica is activated. The clan name must be unique.
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ClearQuest MultiSite organizes replicas in three ways:

■ clans

■ families

■ sites

Using clans

A clan represents all the replicas of a single schema repository and its
associated databases. Within a clan, a working schema repository is used to
propagate changes to schemas and to create additional user databases which
can then be replicated.

Note: There can be only one master site in a ClearQuest MultiSite clan.

Family A family consists of one or more replicas of the same schema repository or user
database. The family name is the same name as the five-character logical
database name of the originating ClearQuest database.

Site A named collection of replicas at the same location consisting of a replicated
schema repository and one or more of its user databases.

Replica A copy of a ClearQuest database and its associated schema repository.

Host The LAN name or IP address of the network node that has access to a site.
The host name is used with the Rational Shipping Server and refers to the machine
where the storage bays for the respective replica are located and must be
consistent with the name of the host specified when you configured the MultiSite
Control Panel.

Term Definition
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Understanding the role of the working schema repository
site

Within a ClearQuest MultiSite clan, there are two types of sites: a working
schema repository site and a replicated schema repository site. Each site can
perform different tasks and has a different role within MultiSite.

The working repository site within a clan is used to propagate changes to
schemas and to create additional user databases which can then be replicated.
Only the working schema repository can make schema changes and a clan
can have only one working schema repository.

Type of site Supported tasks

Working schema
repository site

Modifies clan schemas.
Creates new ClearQuest clan schema repository and user databases.
Submits new records.
Creates synchronization packages.
Administers MultiSite activities.
Administers users of which it has mastership.

Replicated schema
repository site

Submits new records.
Modifies records of which it has mastership.
Administers MultiSite activities.
Administers users of which it has mastership.
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What software needs to be installed?

Consult the following table for software installation requirements per role.
We recommend that you co-locate the ClearQuest MultiSite Administrator
and Shipping Server roles. We also recommend that you use a stand-alone
machine for the database server.

* If you are installing ClearQuest MultiSite on UNIX, the MultiSite
multiutil commands can be executed on the UNIX server if you have the
appropriate licenses.

Installing the Rational Shipping Server

Both ClearQuest MultiSite and ClearCase MultiSite use the same
store-and-forward components (called the Rational Shipping Server) to
transfer update packets. If you are installing ClearQuest MultiSite on a
machine where ClearCase or ClearCase MultiSite is already installed, the

Role Purpose Install ...

ClearQuest
MultiSite
Administrator*

For ClearQuest and
ClearQuest MultiSite
administration.

If applicable, Shipping
server.

“Installing ClearQuest MultiSite for the
administrator” on page 43.
“Configuring ClearQuest MultiSite” on page
45.
“Installing Rational Shipping Server” on page
43. To configure the shipping server see
“Configuring Store and Forward” in
Administrator’s Guide for Rational ClearQuest
MultiSite.

ClearQuest client For viewing and
submitting ClearQuest
records.

“Installing and configuring ClearQuest
Windows for users” on page 49.

ClearQuest web
server

Serves the ClearQuest
Web client to users.

“Installing and configuring ClearQuest Web”
on page 55.

Database server Holds all ClearQuest
schema repository and
user databases.

“Configuring vendor databases” on page 7.

ClearQuest
MultiSite UNIX

For viewing and
submitting ClearQuest
records.
For ClearQuest MultiSite
administration.

“Installing and configuring ClearQuest UNIX
for users” on page 87.

“Configuring ClearQuest MultiSite” on page
45.
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shipping server is already installed and the installation option will be
deactivated in the ClearQuest installation program. This is to ensure integrity
with your ClearCase installation.

Warning: Do not attempt to install the Rational Shipping Server on a
machine that has ClearCase LT Client installed. If you attempt to do this,
an error message will be displayed during the installation process.

Consult the following table for installation conditions:

Installing the Rational Shipping Server from the ClearCase
CD-ROM

If you are installing ClearQuest MultiSite on a machine where ClearCase is
already installed, you cannot use the Rational ClearQuest CD-ROM to install
the Rational Shipping Server. You will need to install Rational ClearCase
MultiSite from the ClearCase installation CD-ROM.

Note: You need either a ClearQuest MultiSite license or a ClearCase
MultiSite license to use the Rational Shipping Server or the MultiSite Control
Panel. Although you are allowed to install Rational ClearCase MultiSite, you
cannot use it unless you have a license.

Condition: Action:

If ClearCase or ClearCase
MultiSite is not installed on
the machine.

Install Rational Shipping Server from the ClearQuest or Rational
Suite Installation CD-ROM.
Configure the MultiSite Control Panel for use with ClearQuest
MultiSite, (see Administrator’s Guide for Rational ClearQuest
MultiSite).

If ClearCase MultiSite is
already installed on the
machine.

The MultiSite Control Panel and Rational Shipping Server are
already installed.
Configure the MultiSite Control Panel for use with ClearQuest
MultiSite, (see Administrator’s Guide for Rational ClearQuest
MultiSite).

If ClearCase is already
installed on the machine.

Install the ClearCase MultiSite component from the ClearCase
CD-ROM, (see “Installing the Rational Shipping Server from the
ClearCase CD-ROM” on page 42).

If ClearCase LT Server is
installed on the machine.

Install Rational Shipping Server from the ClearQuest or Rational
Suite Installation CD-ROM.
Configure the MultiSite Control Panel for use with ClearQuest
MultiSite, (see Administrator’s Guide for Rational ClearQuest
MultiSite).

If ClearCase LT Client is
installed on the machine.

Do not install the Rational Shipping Server on this machine.
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Installing ClearQuest MultiSite for the administrator

If you are performing this installation at the master site, you need to create
your vendor database. For more information refer to “Installing and
configuring ClearQuest MultiSite” on page 37.

Note: If you are installing ClearQuest MultiSite on the same machine as your
SQL Server 7.0 or 2000 database, the ClearQuest MultiSite commands may
fail if the SQL Server Client software is not also installed.

1 Load the ClearQuest CD-ROM on the machine you want to designate as
the ClearQuest MultiSite Administrator.

2 If the setup program does not run automatically, navigate to the top level
directory of the CD-ROM and double-click setup.exe.

3 Click the Configure License button and enter your ClearQuest license and
if applicable, your ClearQuest MultiSite license information. Follow the
instructions on your License Certificate and in the online help for the
License Key Administrator.

Rational ClearQuest uses a license server. If you don’t already have a
license server installed, it is available on the Rational Solutions for
Windows CD-ROM. For more information, see the License Management
Guide for Rational Suite, available on the Rational Solutions for Windows
Online Documentation CD-ROM.

4 To install ClearQuest MultiSite, select the Custom install option, expand
the ClearQuest node and check the following boxes:

■ MultiSite Administration Tools

■ ClearQuest Administration Tools

■ Required Files

Installing Rational Shipping Server

If you have ClearCase MultiSite installed on your machine, the Rational
Shipping Server is already installed. If you have ClearCase installed without
the MultiSite features, you will have to install the Rational Shipping Server
from your ClearCase CD-ROM.

Note: If you are installing ClearQuest MultiSite on a UNIX platform, you
will have to have an installation of ClearCase MultiSite to use the Rational
Shipping Server.
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1 Load the ClearQuest CD-ROM on the machine you want to designate as
the ClearQuest MultiSite Administrator.

2 If the setup program does not run automatically, navigate to the top level
directory of the CD-ROM and double-click setup.exe.

3 Click the Configure License button and enter your ClearQuest license and
if applicable, your ClearQuest MultiSite license information. Follow the
instructions on your License Certificate and in the online help for the
License Key Administrator.

Note: Rational ClearQuest uses a license server. If you don’t already have
a license server installed, it is available on the Rational Solutions for
Windows CD-ROM. For more information, see License Management Guide
for Rational Suite, available on the Rational Solutions for Windows Online
Documentation CD-ROM.

4 To install ClearQuest MultiSite, select the Custom install option, expand
the ClearQuest node and check the Rational Shipping Server box.

Note: If the Rational Shipping Server box is not shown as a node, you
already have ClearCase installed on your computer. If you have ClearCase
MultiSite installed on your machine, nothing further is required. If you
have ClearCase installed without the MultiSite features, you will have to
install the Rational Shipping Server from your ClearCase CD-ROM. For
instructions on how to complete this, consult your Installing Rational
ClearCase guide.

The Rational Software Setup wizard prompts you through the ClearQuest
MultiSite installation.

What do you do next?

■ “Configuring ClearQuest MultiSite” on page 45

■ “Installing and configuring ClearQuest Windows for users” on page 49

■ Optional, “Installing and configuring ClearQuest Web” on page 55

■ Optional, “Installing and configuring ClearQuest UNIX for users” on
page 87
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Configuring ClearQuest MultiSite

Creating ClearQuest databases

After you install ClearQuest and have created the necessary empty vendor
databases (see “Configuring vendor databases” on page 7), you must create
the ClearQuest databases (schema repository and user databases). Initially
you can create a sample user database to use while you familiarize yourself
with the product. You can create your production user databases later.

Creating a MultiSite schema repository

1 Launch the ClearQuest Maintenance Tool.
Start > Programs > Rational ClearQuest > ClearQuest Maintenance Tool

Note: The first time you launch ClearQuest, the Maintenance Tool runs
automatically.

2 Select Create a new schema repository and click Next.

3 Select the vendor database you plan to use, enter the properties
appropriate for that vendor, then click Next. Save this information for
clients to use when they connect to the databases. The information to enter
is as follows:

■ SQL_SERVER

■ Enter the SQL Server database name for the database that will
contain the schema repository.

■ Enter the name of the database server.

Note: If you are using ClearQuest UNIX, each UNIX client must be
able to access this server host name exactly as it appears in this entry.

■ Enter the database owner (DBO or Administrator) login.

■ Enter the password for the database owner (DBO or Administrator)
login.

■ Enter the general purpose or read/write login.

■ Enter the password for the general purpose or read/write user
login.

■ Enter the schema repository or read-only user login.

■ Enter the password for the schema repository or read-only login.
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■ ORACLE

■ Enter the TNS name (SQL*Net Alias pointing to the Oracle
instance).

■ Enter the Oracle login you created for the schema respository.

■ Enter the password for the login.

■ The following options need to be entered in the Connect Options
field, delimited by semi-colons. For example,

Host=<name>;SID=<name>;Server_ver=8.0;Client_ver=7;
Lob_type=LONG

Note: All ClearQuest users must use the same SQL*Net Alias (TNSname),
Database Instance (system ID or SID), TCP/IP protocol, and Host Name
(Oracle server machine).

4 We recommend that you create a sample database using one of the
provided schemas. Select a schema, give the sample database a name, then
click Next.

5 If you created a sample database, you must select a vendor and enter the
database properties. When you are finished, click Next.

Option Definition

Host The name of the database server machine. If your ClearQuest deployment
will include both UNIX and Windows clients, the Host name is mandatory.

SID The name of the Database Instance. If your ClearQuest deployment will
include both UNIX and Windows clients, the SID name is mandatory.
On UNIX, the SID is case-sensitive.

Server_ver Provide the version of the Oracle server you are using. Possible values are
7, 8.0, and 8.1. (For Oracle 8i, use 8.1.)

Client_ver Provide the version of the Oracle client software you are using. Possible
values are 7, 8.0, and 8.1. (For Oracle 8i, use 8.1.)
If ClearQuest client users want to use a different Oracle client version than
what is entered here by the administrator, they’ll need to override the set
options manually. The default setting is 7.
See Release Notes for details.

Lob_type Set the type of data you’ll be using. The valid data type is LONG.
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6 You can save these settings as a default profile, or click Finish to complete
the setup. The profile records the entries you made and saves them to a file
(the default name is cqprofile.ini). Clients can connect to the
database by using the profile file instead by typing the connection
information.

Setting up mastership for records

At the master site, you’ll need to modify your schema and add the
ratl_mastership field to the record form of any record type you will use
with ClearQuest MultiSite. By allowing the user to access this field (adding it
to your record form), any ClearQuest user can change the mastership of any
record, if they are at the mastering replica site of the respective record.

For details, see Chapter 7 “Understanding Mastership” in Administrator’s
Guide for Rational ClearQuest MultiSite.

Creating a user database

You can create ClearQuest user databases with the ClearQuest Designer, after
you have successfully created a schema repository.

Note: You must have first created empty vendor databases before you can
create ClearQuest databases.

1 From the Start menu, choose Programs > Rational ClearQuest > ClearQuest
Designer.

2 Click Next when the Rational Schema Repository dialog box appears.

3 Click OK when the ClearQuest Designer Login dialog box appears.

Note: When you click OK, you will be logging in with the default
ClearQuest administrator login name and password. The default user
name is “admin”, the password is null and should be left blank. You
should change this password and create a new login at your earliest
convenience.

4 Click Cancel when the Open Schema dialog box appears.

5 Choose Database > New Database.

6 Enter a logical name for the database you want to create. This name must
be five characters or less.

7 Click Next.
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8 Select the vendor database you plan to use, enter the properties
appropriate for that vendor, then click Next. For more information about
the required parameters for vendor databases, see step 3 under “Creating
a MultiSite schema repository” on page 45.

9 Click Next.

10 Click Next to accept the default polling parameters.

11 Choose a schema with which to associate your database. You must
associate the database with a schema.

12 Click Finish.
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5Installing and configuring
ClearQuest Windows for users
ClearQuest Windows must be installed on each users machine. When
ClearQuest Windows is installed and connected to the database, your users
can enter and modify records.

Note: It is also possible to allow the user to install the ClearQuest Windows
client from a network location, (for more information see “Silent ClearQuest
installation” on page 109).

This chapter covers the following topics:

■ “Installing ClearQuest for the Windows user” on page 50

■ “Connecting to ClearQuest databases” on page 50

■ “Enabling e-mail notification for the Windows user” on page 53
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Installing ClearQuest for the Windows user

To install ClearQuest Windows for the user:

1 Load the ClearQuest CD-ROM.

2 If the setup program does not run automatically, navigate to the top level
directory of the CD-ROM and double-click setup.exe.

The Rational Software Setup wizard prompts you through the ClearQuest
Windows installation.

3 Choose the Typical installation.

4 Launch the License Administrator to enter your ClearQuest licenses.

Connecting to ClearQuest databases

After installing ClearQuest Windows for your users, (either for an initial or an
upgrade installation) they will need to connect (or re-connect) to an existing
schema repository. You must provide them with the database properties
information.

You can create a connection profile for users to use to connect to the schema
repository, (see “Using connection profiles” on page 52).

Note: If you are using Oracle or DB2, your users will need to install the
respective client software before installing ClearQuest. For more information,
see “Installing and configuring an Oracle client” on page 22 or see “Creating
a DB2 database alias” on page 26.

To connect the ClearQuest Windows user to a schema repository, use the
ClearQuest Maintenance Tool.

Creating a new connection

1 Select Connection > New.

2 In the Existing Connections area, name the alias by typing a name in the
highlighted item.

3 In the Schema Repository Properties group box, enter the properties of the
vendor database designated for the schema repository.

a Choose a vendor database from the drop-down list.

b Enter the required vendor database properties.
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■ MS_ACCESS

■ Enter the entire path to the schema repository using a UNC style
path. For example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory containing the database. Be sure to
browse using the Network Neighborhood to preserve the UNC style
path name.

■ SQL_ANYWHERE

■ Enter the path to the schema repository using a UNC style path. For
example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory containing the database by using
Network Neighborhood, which preserves the UNC style path name. To
do so:

■ Enter the name of the database server.

■ Enter the protocols used to communicate with the SQL Anywhere
server.

■ Enter the database host name.

■ SQL_SERVER

■ Enter the SQL Server database name for the database containing the
schema repository.

■ Enter the name of the database server.

■ Enter the schema repository or read-only user login.

■ Enter the password for the schema repository or read-only login.

■ ORACLE

■ Enter the SQL*Net Alias (alias pointing to the Oracle instance).

■ Enter the Oracle login created for the schema respository.

■ Enter the password for the login.

■ DB2

■ Enter the Database Alias name (alias pointing to the DB2 database).

■ Enter the DB2 login created for the schema repository.
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■ Enter the password for the login.

4 Click Finish to complete the connection.

Using connection profiles

Rather than asking users to enter database connection information when they
need to connect to a schema repository, you can create connection profiles
that can be used as shortcuts.

Use the ClearQuest Maintenance Tool to export and import connection
profiles.

Connection profiles allow you to save database settings for later use, or for
distribution to a team, to make it easier to reconnect to a ClearQuest schema
repository.

Both ClearQuest administrators and ClearQuest client users can import and
export connection profiles for later use.

Creating a connection profile

When you create a connection profile, you “export” your connection
information to a file that can later be imported.

1 Select File > Export Profile.

2 In the Export Connection area, select the connections that you would like
to include in your profile.

3 In the File Name box, enter the pathname and file name for the profile.
Connection profiles must be saved with a .ini extension.

Optionally, you can use the browse button to browse to a location to which
to save the profile.

Importing a connection profile

To use a previously-created connection profile, you need to import a
connection profile.

1 Select File > Import Profile.

2 In the Import Profile Information area, enter the path and file name of the
profile you would like to import.

3 Click Finish.
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Enabling e-mail notification for the Windows user

After installing ClearQuest Windows (either for an initial or an upgrade
install), the user must enable e-mail notification if they want to receive
automatic e-mail messages from ClearQuest Windows. To do this:

1 Launch ClearQuest Windows.

Start > Programs > Rational ClearQuest > Rational ClearQuest

2 Choose View > E-mail Options. This opens the E-mail Setup dialog box.

3 Select Enable E-mail Notification.

4 Select either SMTP or MAPI.

5 If you entered SMTP:

■ Enter the SMTP host address of your mail server.

■ Enter your e-mail address.

■ Click Finish.

6 If you entered MAPI:

■ Choose a MAPI profile from the list.

■ Click Finish.

Note: MAPI notification will not work without Collaboration Data Objects
installed. If you do not have Collaboration Data Objects installed, perform the
steps in “Installing Collaboration Data Objects” on page 53.

Installing Collaboration Data Objects

Collaboration Data Objects must be installed in Microsoft Outlook 2000 for
ClearQuest MAPI notification to work properly. If you have not already
installed Microsoft Outlook 2000, follow the steps below.

If you have Microsoft Outlook 2000 already installed, follow these steps:

1 From the Start menu select Settings > Control Panel and double-click
Add/Remove Programs.

2 Select Outlook 2000 (or Office 2000 if that’s how Outlook was installed),
and click the Change button.

3 Expand Microsoft Office and click the icon for Collaboration Data Objects.

4 Select Run from my computer from the drop down list.
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5 When you are finished, click Update Now.

If you do not have Microsoft Outlook 2000 installed, follow the recommended
Microsoft Outlook 2000 installation procedures/guidelines. Be sure to check
the option to install the Collaboration Data Objects.
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6Installing and configuring
ClearQuest Web
This chapter covers the following topics:

■ “Understanding the installation process” on page 56

■ “Installing ClearQuest Web software” on page 57

■ “Setting up ClearQuest Web for IIS 4” on page 58

■ “Setting Up ClearQuest Web for IIS 5” on page 68

■ “Enabling e-mail notification for web users” on page 82

■ “Configuring web browsers” on page 83

■ “Accessing ClearQuest Web” on page 86
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Understanding the installation process

Note: If you are using Oracle 8.0.x and 8.1.x clients, you must have the latest
patch installed to operate successfully with ClearQuest Web. For more
information, see your latest ClearQuest release notes located at:

■ For Windows: <d>:\ClearQuest\clearquest_readme.htm
(where <d> is your CD-ROM drive)

■ For UNIX:
<d>:/products/ClearQuestClient/clearquest_readme.htm
(where <d> is your CD-ROM drive)

The following are special considerations for using ClearQuest Web:

■ ClearQuest Web does not support Microsoft Access databases.

■ Your browser must have cookies enabled when using ClearQuest Web. See
“Configuring web browsers” on page 83.

■ Make sure your web server is set to display 256 colors. This is necessary
for generating charts.

■ You must have first set up the vendor database that ClearQuest will use.
See “Configuring vendor databases” on page 7.

To install and configure ClearQuest Web on your Windows server, you must
complete the following tasks:

1 Verify that you have either IIS 4.0 or 5.0 installed on your web server
machine.

2 Install ClearQuest on the Web server. See, “Installing and configuring
ClearQuest for an administrator” on page 29. Make sure you select a
Custom installation and expand Web Server Components and check
Rational ClearQuest Web.

Note: We recommend, for improved performance, security, and
reliability, that the Web server machine and the database server machine
be two different machines, each with its software installed onto an NTFS
partition.

3 Install the ClearQuest Web software on your web server machine. See
“Installing ClearQuest Web software” on page 57

4 Configure Microsoft Internet Information Server to serve the ClearQuest
Web pages. See “Setting up ClearQuest Web for IIS 4” on page 58 or
“Setting Up ClearQuest Web for IIS 5” on page 68.
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5 Configure the web server so that web clients can take advantage of
ClearQuest’s e-mail notification feature. See “Enabling e-mail notification
for web users” on page 82.

6 Verify that the security settings are enabled to provide full ClearQuest
functionality. See “Configuring web browsers” on page 83.

7 Provide the path to ClearQuest Web to your users. See “Accessing
ClearQuest Web” on page 86.

Installing ClearQuest Web software

To install ClearQuest Web:

1 Load the ClearQuest CD-ROM in the web server machine.

2 If the setup program does not run automatically, navigate to the top level
directory of the CD-ROM and double-click setup.exe.

3 Click the button Configure License and enter your ClearQuest license
information and if applicable, your ClearQuest MultiSite license
information. Follow the instructions on your License Certificate and in the
online Help for the License Key Administrator.

Note: Rational ClearQuest uses a license server. If you don’t already have
a license server installed, it is available on the Rational Solutions for
Windows CD-ROM. For more information, see the License Management
Guide for Rational Suite, available on the Rational Solutions for Windows
Online Documentation CD-ROM.

4 To install ClearQuest Web select the Custom install option, expand the
Web Server Components and check the box for Rational ClearQuest Web.

The Rational Software Setup wizard prompts you through the ClearQuest
Web installation.
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Setting up ClearQuest Web for IIS 4

This section is for configuring your web server on a machine using Windows
NT (Workstation or Server) with IIS 4. If your web server is on a Windows
2000 Server, which has IIS 5 as an embedded component, see “Setting Up
ClearQuest Web for IIS 5” on page 68.

This section contains the following:

■ “Setting up an anonymous user account for IIS 4” on page 58

■ “Creating a cache directory for IIS 4” on page 61

■ “Configuring IIS 4.0 to serve ClearQuest Web pages” on page 61

Setting up an anonymous user account for IIS 4

Create an anonymous user account for IIS to use when it serves the
ClearQuest pages. If you are using an SQL Server database, the anonymous
user account should be known in the domain that contains the ClearQuest
database, and should have full access to that database.

Create the anonymous user account

Create the anonymous user account as follows:

1 Log on as a Windows NT administrator.

2 If the web server belongs to a Windows NT domain, ask your Windows
NT system administrator to create a domain user and provide you with
the user name and password. (If not, go to Step 4.)

3 Run the User Manager.

Start > Programs > Administrative Tools > User Manager

4 Select Policies > User Rights, select the Show Advanced Rights checkbox,
and give this user the following privileges on the Web server:

■ Access this computer from network

■ Log on locally

■ Log on as a service

Also provide access to any other resources used by your hook scripts such
as mail accounts or auxiliary databases. Skip to Step 6.
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5 If the web server operates in stand-alone mode (does not belong to a
Windows NT domain), use the default anonymous account created by the
IIS installation (IUSR_<machine_name>) for Step 5.

6 Run the User Manager.

Start > Programs > Administrative Tools > User Manager

7 Select Policies > User Rights, select the Show Advanced Rights checkbox,
and give the IUSR_<machine_name> account the following privileges:

■ Access this computer from network

■ Log on locally

■ Log on as a service

Also provide access to any other resources used by your hook scripts such
as mail accounts or auxiliary databases.

8 Verify that the anonymous user account has a specific, known password
(you will need it later). Make sure there are no password policies in effect
such as “User must change password at next login,” because these prevent
the anonymous user account from functioning properly.

Note: If you are using SQL/Anywhere as your database server, please
ensure that the IIS anonymous user account has read/write privileges to the
directory containing the SQL/Anywhere databases, see “Defining user
privileges” on page 11 for details.

Set up the registry key access privileges

Give the web client anonymous user account full access privileges to
following registry keys:

■ HKEY_LOCAL_MACHINE\Software\Rational
Software\ClearQuest

■ HKEY_USERS\.Default\Software\Rational
Software\ClearQuest

1 Select Run from the Start menu and type REGEDT32 to start the Registry
Editor.

2 In the HKEY_LOCAL_MACHINE MDI window, select
Software > Rational Software > ClearQuest.

3 From the Registry Editor menu, select Security > Permissions.
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4 In the Registry Key Permissions dialog box, select the anonymous user.
For the type of access, select Full Control. Select Replace Permission on
Existing Subkeys so that the anonymous user can update the entire
registry tree below ClearQuest.

5 In the HKEY_USERS MDI window, select
.Default > Software > Rational Software > ClearQuest.

6 On the Registry Editor menu, select Security > Permissions.

7 In the Registry Key Permissions dialog box, select the anonymous user.
For the type of access, select Full Control. Select
Replace Permission on Existing Subkeys so that the anonymous user can
update the entire registry tree below ClearQuest.

8 Close the REGEDT32 program.

Set up read access permission

Give the anonymous user account read-access permission to the directory tree
containing the ClearQuest web files (this is the WWW directory in the
ClearQuest installation area).

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS
partition, you will not see a Security tab and can skip this section.

1 Use the Windows Explorer to locate the directory in which you installed
ClearQuest. Right-click the WWW directory and select Properties from the
shortcut menu.

2 On the Properties dialog box, click the Security tab. Click Permissions and
select Replace Permissions on Subdirectories.

3 On the Directory Permissions dialog box, click Add.

4 Select the anonymous user account.

■ If you chose the default local anonymous user name in Step 2, set List
Names From to the name of the local machine, click Show Users below
the Names list, then select the IUSR_machinename account from the
Names list.

■ If you are using a domain account, select that domain in the List
Names From field, click Show Users, and select the domain account
from the Names list.

5 Click Add.

6 Set Type of Access to Read.
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7 Click OK to close the Add Users and Groups dialog box.

8 Click OK to close the Directory Permissions dialog box.

9 Click OK to close the WWW Properties dialog box.

Creating a cache directory for IIS 4

To create a cache directory in the ClearQuest Web directory hierarchy:

1 At the top of the web directory tree, there should be a directory called
cache. If a cache directory does not exist, create one under the
ClearQuest WWW directory. For example:
C:\Program Files\Rational\ClearQuest\www\cache

2 Give the anonymous user full access to everything in this directory tree.

Configuring IIS 4.0 to serve ClearQuest Web pages

This section describes how to configure the IIS 4.0 web server to serve
ClearQuest Web pages.

■ “Create a virtual directory for IIS 4” on page 61

■ “Edit the properties of the virtual directory for IIS 4” on page 63

■ “Edit the properties of the cache directory for IIS 4” on page 67

■ “Edit the properties of the images directory for IIS 4” on page 67

■ “Restart the web server for IIS 4” on page 67

Note: If the Internet Service Manager is not available, you must install the
Windows NT 4.0 Option Pack. When installing the Option pack, be sure to
explicitly select the Internet Service Manager.

Create a virtual directory for IIS 4

The first step in setting up IIS 4.0 is to create a virtual directory for the web. To
create this directory, you use the Internet Service Manager program
(Microsoft Management Console) that comes with IIS 4.0.

1 Start the Microsoft Management Console program (Internet Service
Manager):

Start > Programs > Windows NT 4.0 Option Pack > Microsoft Internet
Information Server > Internet Service Manager
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2 In the Navigator window, right-click Default Web Site, then click New >
Virtual Directory from the shortcut menu.

3 In the New Virtual Directory Wizard, type an alias name, such as
“CqWeb.” Do not use a “/” character in the alias name.

In the Navigator
window, right-click
Default Web Site

Type an alias

Click Next
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4 Type or browse to the name of the directory containing the ClearQuest
Web files. These files are located in the WWW subdirectory of the
ClearQuest installation directory. For example:
C:\Program Files\Rational\ClearQuest\www

5 Select the default permissions for the virtual directory:

Edit the properties of the virtual directory for IIS 4

Edit the properties of the virtual directory as follows:

1 In the Microsoft Management Console left pane, navigate to the virtual
directory you created earlier.

2 Right-click the virtual directory and select Properties from the shortcut
menu.

Type the name of
the directory

containing the
ClearQuest

Web file

Click Next

Select
Allow Execute Access
(includes Script Access)

Click Finish
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3 In the Properties dialog box, click the Virtual Directory tab.

Note: You should not run ClearQuest Web in a separate memory space (as
an isolated process). If you do so, e-mail rules will not work. If you need to
run ClearQuest Web in a separate memory space, see the ClearQuest
Release Notes (\\ClearQuest\readme.htm) for more information.

4 In the same Properties dialog box, click Configuration. In the Application
Configuration dialog box, click the App Mappings tab.

Clear all of
these boxes

Select Execute
(including script)

Do Not select the
run in separate

memory space box

Verify that
Cache ISAPI

applications is
selected

Verify that .asa
and .asp

are mapped to
asp.dll
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5 In the same Application Configuration dialog box, click the App Options
tab.

6 Click OK to return to the Properties dialog box.

7 In the Properties dialog box, click the Documents tab.

Select Enable
session state and

set the timeout

Select Enable
parent paths

Click to add the
Default.asp
document to the list

If necessary, add
the Default.asp
document to the

list of documents -
then remove any
other documents

and select
Default.asp

as the default
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8 In the same Properties dialog box, click the Directory Security tab. In the
Anonymous Access and Authentication Control, click Edit to open the
Authentication Methods dialog box.

9 Define the anonymous user account:

Note: ClearQuest Web does not work if Enable Automatic Password
Synchronization is selected.

10 Click OK.

11 Type the password in the Confirm Password dialog box and click OK.

12 Click OK again to close the Properties dialog box.

Select Allow
Anonymous

Access

Important: Verify
that Windows NT

Challenge/Response
is NOT selected -

if the box has a
check mark be
sure to clear it

Then click Edit
to define the
anonymous user
account

Clear Enable
Automatic
Password

Synchronization
and type the

password

Select the
anonymous user

account created on
on page 58
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Edit the properties of the cache directory for IIS 4

Edit the properties of the cache subdirectory as follows:

1 In the Microsoft Management Console left pane, navigate to the cache
directory under the virtual directory name.

2 Right-click the cache directory.

3 Click Properties from the shortcut menu.

4 In the Properties dialog box, click the Directory tab.

5 For Access Permissions, select only Read. Verify that no other options are
selected.

6 For Permissions, select None.

7 Click OK.

Edit the properties of the images directory for IIS 4

Edit the properties of the images subdirectory as follows:

1 In the Navigator window of the Microsoft Management Console, expand
the directory tree of the Default Web Site until you locate the images
directory under your alias name.

2 Right-click the images directory.

3 Click Properties from the shortcut menu.

4 In the Properties dialog box, click the Directory tab.

5 For Access Permissions, select only Read. Verify that no other options are
selected.

6 For Permissions, select None.

7 Click OK.

Restart the web server for IIS 4

Close the Microsoft Management Console, saving your console settings, then
restart the web server.
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You have completed installing and configuring the ClearQuest web server for
IIS 4.

Note: Please remember to use the Maintenance Tool to connect to your
ClearQuest Schema Repository. For detailed instructions, see “Connecting to
a schema repository” on page 119.

Setting Up ClearQuest Web for IIS 5

This section describes how to set up the ClearQuest Web server for Windows
2000 Server, which includes Microsoft Internet Information Server version 5
as an embedded component. If you are using Windows NT, see “Setting up
ClearQuest Web for IIS 4” on page 58.

This section contains the following:

■ “Setting up an anonymous user account for IIS 5” on page 68

■ “Creating a cache directory for IIS 5” on page 72

■ “Configuring IIS 5 to serve ClearQuest Web pages” on page 73

Setting up an anonymous user account for IIS 5

Create an anonymous user account for IIS to use when it serves the
ClearQuest pages. If you are using an SQL Server database, the anonymous
user account should be known in the domain that contains the ClearQuest
database, and should have full access to that database.

Create the anonymous user account

Create the anonymous user account as follows:

1 Log on as a Windows 2000 administrator.

2 If the web server belongs to a Windows domain, ask your Windows
system administrator to create a domain user and provide you with the
user name and password. (If not, go to Step 4.)

3 For this domain user, click Start > Settings> Control Panel > Administrative
Tools > Local Security Policy, select Local Policies > User Rights
Assignment. For each of the following double-click to view the Local
Security Setting dialog box then use the Add button to grant this user the
following privileges on the Web server:

■ Access this computer from network.
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■ Log on as a service.

■ Log on locally.

Also provide access to any other resources used by your hook scripts, such
as mail accounts. (Go to Step 6.)

4 If the web server operates in stand-alone mode (does not belong to a
Windows NT domain), use the default anonymous account created by the
IIS installation (IUSR_<machine_name>).

Click Start > Settings > Control Panel > Administrative Tools > Local Security
Policy

5 Select Local Policies > User Rights Assignment, and use the Add button to
grant this user the following privileges on the Web server:

■ Access this computer from network.

■ Log on as a service.

■ Log on locally.

Also provide access to any other resources used by your hook scripts, such
as mail accounts.

6 Verify that the anonymous user account has a specific, known password
(you will need it later). Make sure there are no password policies in effect
such as “User must change password at next login,” because these prevent
the anonymous user account from functioning properly.

Note: If you are using SQL/Anywhere as your database server, please
ensure that the IIS anonymous user account has read/write privileges to the
directory containing the SQL/Anywhere databases, (see“Defining user
privileges” on page 11 for details).

Set up the registry key access privileges

Give the web client anonymous user account full access privileges to
following registry keys:

■ HKEY_LOCAL_MACHINE\Software\Rational
Software\ClearQuest

■ HKEY_USERS\.Default\Software\Rational
Software\ClearQuest
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1 Select Run from the Start menu and type REGEDT32 to start the Registry
Editor.

2 In the HKEY_LOCAL_MACHINE MDI window, select
Software > Rational Software > ClearQuest.

3 From the Registry Editor menu, select Security > Permissions.

4 Click Add to add the anonymous user account.

5 In the Select Users, Computers, or Groups dialog box, do one of the
following:

■ If you chose the default local anonymous username, set Look In to the
name of the local machine and select the IUSR_machinename account
from the Name list.

■ If you are using a domain account, select that domain in the Look in to
name of the domain and select the domain account name from the
Name list.

6 Click Add, and then click OK to close the Select Users, Computers, or
Groups dialog box.

7 Highlight the new added account, and in the Permissions: area, check
Allow for Full Control box.

8 Select Allow inheritable permissions. Click OK.

Select Allow
inheritable
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9 In the HKEY_USERS MDI window, select
\.Default > Software > Rational Software > ClearQuest

10 Repeat Step 3 through Step 8 for the HKEY_USERS.

11 Close the REGEDT32 program.

Set up read access permission

Give the anonymous user account read access permission to the directory tree
containing the ClearQuest web files (this is the WWW directory in the
ClearQuest installation area).

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS
partition, you will not see a Security tab and can skip this section.

1 Use Windows Explorer to locate the directory in which you installed
ClearQuest. Right-click the WWW directory and select Properties from the
shortcut menu.

2 On the Properties dialog box, click the Security tab and select
Allow inheritable permissions.

3 On the Security tab, click Add.

4 Select the anonymous user account:

Select Allow
inheritable
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■ If you chose the default local anonymous username in Step 2, set Look
in to the name of the local machine, then select the IUSR_machinename
account from the Name list.

■ If you are using a domain account, select that domain in the Look in
field, and select the domain account from the Name list.

5 Click Add, then click OK.

6 On the Security tab, in the Permissions section, select the checkbox to
allow Read, then click OK.

Creating a cache directory for IIS 5

Create a cache directory in the ClearQuest Web directory hierarchy.

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS
partition, you will not see a Security tab and can skip this section.

1 At the top of the web directory tree, there should be a directory called
cache. If a cache directory does not exist, create one on your ClearQuest
WWW directory. For example:
C:\Program Files\Rational\ClearQuest\www\cache

2 Right-click the cache directory to see its properties.

3 On the Properties dialog box, click the Security tab.

4 Select the anonymous user account:

■ If you chose the default local anonymous username in Step 2, set Look
in to the name of the local machine, then select the IUSR_machinename
account from the Name list.

■ If you are using a domain account, select that domain in the Look in
field, and select the domain account from the Name list.

5 Click Add, then click OK.

6 In the Permissions section, select the checkbox to allow Full Control, then
click OK.
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Configuring IIS 5 to serve ClearQuest Web pages

This section describes how to configure the IIS 5 web server to serve
ClearQuest Web pages.

■ “Create a virtual directory for IIS 5” on page 74

■ “Edit the properties of the virtual directory for IIS 5” on page 76

■ “Editing the properties of the cache directory for IIS 5” on page 80

■ “Edit the properties of the images directory for IIS 5” on page 80

■ “Restart the web server for IIS 5” on page 81
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Create a virtual directory for IIS 5

Create a virtual directory for the web as follows:

1 Start the Internet Services Manager.

Start > Settings > Control Panel > Administrative Tools > Internet Services
Manager.

2 In the Navigator window, right-click Default Web Site.

3 On the shortcut menu, click New > Virtual Directory and Next.

In the Navigator
window, right-click
Default Web Site
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4 Type an alias name, such as CqWeb. Do not use a “/” character in the alias
name. Then click Next.

5 Type or browse to the name of the directory containing the ClearQuest
Web files. These files are located in the WWW subdirectory of the
ClearQuest installation directory. For example:
C:\Program Files\Rational\ClearQuest\www

Type or browse to
the directory

containing the
ClearQuest

Web files

Then click Next
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6 Clear Read, clear Run scripts, and select Execute. Then click Next.

7 Click Finish to complete the Wizard.

Edit the properties of the virtual directory for IIS 5

Edit the properties of the virtual directory as follows:

1 In the Internet Information Services left pane, navigate to the virtual
directory you created earlier.

2 Right-click the virtual directory and select Properties from the shortcut
menu.

Click Next

Select Execute,
and verify that
nothing else is

selected
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3 In the Properties dialog box, click the Virtual Directory tab.

4 In the same Virtual Directory tab, click Configuration. In the Application
Configuration dialog box, click the App Mappings tab.

Verify that Scripts and
Executables

is selected

Verify that
Low (IIS Process) is

selected

Verify that
Cache ISAPI
applications

is selected

Verify that .asa
and .asp are

mapped to
asp.dll
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5 In the same Application Configuration dialog box, click the App Options
tab.

6 In the Properties dialog box, click the Documents tab.

Select Enable
session state

and set the
timeout interval

Select Enable
parent paths

Click OK

If necessary, add
the Default.asp

document
to the list of

documents -
then remove any
other documents

and select
Default.asp

as the
default

Click to add the
Default.asp
document to the
list
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7 In the same Properties dialog box, click the Directory Security tab. In the
Anonymous Access and Authentication Control, click Edit to open the
Authentication Methods dialog box.

8 Define the anonymous user account:

9 Click OK.

10 Type the password in the Confirm Password dialog box, then click OK.

11 Click OK, then click OK again to close the Properties dialog box.

Select Allow
Anonymous

Access

Then click Edit
to define the
anonymous user
account

Verify that
Integrated
Windows

authentication is
NOT selected - if

the box has a
check mark, be
sure to clear it

Clear Allow IIS to
control password,

and type the
password

Select the
anonymous user

account created on
page 58
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Editing the properties of the cache directory for IIS 5

Edit the properties of the cache subdirectory as follows:

1 In the Internet Information Services left pane, navigate to the cache
directory under the virtual directory name.

2 Right-click the cache directory.

3 Click Properties from the shortcut menu.

4 In the Properties dialog box, click the Directory tab.

5 Select the Read check box. Verify that no other options are selected.

6 For Execute Permissions, select None.

7 Click OK.

Edit the properties of the images directory for IIS 5

Edit the properties of the images subdirectory as follows:

1 In the Navigator window of Internet Information Services, expand the
directory tree of the Default Web Site until you locate the images directory
under your alias name.

2 Right-click the images directory.

3 Click Properties from the shortcut menu.

4 In the Properties dialog box, click the Directory tab.

5 Select the Read check box. Verify that no other options are selected.
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6 For Execute Permissions, select None.

7 Click OK.

Restart the web server for IIS 5

Close Internet Information Services, saving your console settings, then restart
the web server.

You have completed installing and configuring the ClearQuest web server for
IIS 5.

Note: Please remember to use the Maintenance Tool to connect to your
ClearQuest Schema Repository. For detailed instructions, see “Connecting to
a schema repository” on page 119.

Select Read, and
verify that the
others are not

selected

For Execute
Permissions
select None
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Enabling e-mail notification for web users

After installing ClearQuest Web (either for an initial or an upgrade install),
you can set up your ClearQuest web clients to have e-mail notification
according to the business rules of your schema.

1 Log in to your ClearQuest Web Client with administrator privileges.

2 In the tool bar, select Operations and then Edit Web Settings.

3 Scroll down to Enable E-Mail Notification.

4 Enter your e-mail settings.

Note: For e-mail notification to work, you must have added the e-mail
package to your schema and set up record types for packages. For more
information on adding packages and setting up record types, see
Administrator’s Guide for Rational ClearQuest or the ClearQuest Designer
help system.

Setting Description

Send Active Enter 1 to enable e-mail notification. Enter 0 to disable it.

Mail Transport Specify SMTP or MAPI depending on your mail transport type.

MAPI Server If you are using MAPI, enter the mail server name.

MAPI Profile Alias If you are using MAPI, enter the profile alias name.

SMTP Host If you are using SMTP, enter the host name.

Real Names Enter your web server machine name or leave blank. If you enter
a web server name, messages will display the server name in the
From field.

Reply To Enter generic reply-to address for this web server or leave blank.
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5 At the top of the web page click OK to commit your changes.

Note: MAPI notification will not work without Collaboration Data Objects
installed. If you do not have Collaboration Data Objects installed, perform the
steps in “Installing Collaboration Data Objects” on page 83.

Installing Collaboration Data Objects

Collaboration Data Objects must be installed in Microsoft Outlook 2000 for
ClearQuest MAPI notification to work properly. If you have not already
installed Microsoft Outlook 2000, follow the steps below.

If you have Microsoft Outlook 2000 already installed:

1 From the Start menu select Settings > Control Panel and double-click
Add/Remove Programs.

2 Select Outlook 2000 (or Office 2000 if that’s how Outlook was installed),
and click the Change button.

3 Expand Microsoft Office and click the icon for Collaboration Data Objects.

4 Select Run from my computer from the drop down list.

5 When you are finished, click Update Now.

If you do not have Microsoft Outlook 2000 installed, follow the recommended
Microsoft Outlook 2000 installation procedures/guidelines. Be sure to check
the option to install the Collaboration Data Objects.

Configuring web browsers

To provide full ClearQuest functionality to your web users, you will need to
verify that the following options have been enabled on each of the users web
browsers. Follow the appropriate steps depending on whether your web user
is invoking an Internet Explorer browser, (see “Configuring the Internet
Explorer browser” on page 84) or a Netscape browser, (see “Configuring the
Netscape browser” on page 85).
Configuring web browsers 83



cqin.book Page 84 Thursday, October 4, 2001 4:07 PM
Configuring the Internet Explorer browser

To configure your Internet Explorer:

1 Launch the Internet Explorer browser from the web user’s desktop.

2 Select Tools > Internet Options from the browser tool bar.

3 Click the Security tab and enable the following nodes:

a For ActiveX controls and plug-ins, enable the following options:

■ Download signed ActiveX controls

■ Run ActiveX controls and plug-ins (this is for the ClearQuest
Advanced query editor)

■ Script ActiveX controls marked safe for scripting

b For the Cookies node, Enable for the following functionality:

■ All cookies that are stored on your computer and

■ All per-session cookies (not stored)

c For Microsoft VM, enable Java permissions by clicking on any of the
following conditions:

■ Custom

■ High Safety
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■ Medium Safety

■ Low Safety

Configuring the Netscape browser

To configure your Netscape browser:

1 Launch the Netscape browser from the web user’s desktop.

2 Select Edit > Preferences from the browser tool bar.

3 Expand the Advanced node in the left pane tree and verify that the
following options as a minimum are enabled:

■ Enable Java

■ Enable JavaScript

■ Accept only cookies that get sent back to original server

OR

Accept all cookies
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Accessing ClearQuest Web

To enable web users to access ClearQuest over the web, tell them to enter the
URL:

http://<host>/<alias>

where:

<host> is the host name of the ClearQuest Web server machine, and

<alias> is the directory containing the ClearQuest Web files.

Using the Advanced Query Editor

ClearQuest Web’s advanced query editor requires Java Runtime (JRE)
plug-in. For Windows platforms, this plug-in is provided by ClearQuest Web
if it is not already installed on the client machine. For UNIX platforms, users
are directed to the JavaSoft web site which may or may not have a download
for the desired platform.

Note: Only users with Query Editor privileges or Super User privileges can
access this function.

Note: The Java Runtime Environment is under active development by
JavaSoft, and may not be available for all platforms. Consult the JavaSoft and
Netscape web sites for details. On platforms where the JRE is not available,
clients will not be able to use the Advanced Query Editor function of
ClearQuest Web.
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7Installing and configuring
ClearQuest UNIX for users
This chapter describes how to install ClearQuest UNIX. You, the ClearQuest
administrator, set up the databases to use with ClearQuest, install
ClearQuest, and provide the required set up information to each client user.

This chapter covers the following topics:

■ “Understanding the install process” on page 88

■ “Installing the ClearQuest UNIX client” on page 90

■ “Configuring database connectivity” on page 94

■ “Configuring ClearQuest UNIX” on page 104

■ “Enabling e-mail notification for UNIX users” on page 107
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Understanding the install process

A standard ClearQuest UNIX installation requires setup and installation
procedures performed on the following platforms:

■ “The database server” on page 88

■ “The Windows administrator workstation” on page 89

■ “The UNIX file server” on page 89

■ “The UNIX user machine” on page 90

The database server

1 Set up your database product on your database server. As the ClearQuest
administrator, you are responsible for setting up the databases your users
will use with ClearQuest. See “Choosing a database vendor” on page 8.

2 Install and configure your vendor database alias. See “Creating an Oracle
database alias” on page 23, and “Creating a DB2 database alias” on
page 26.

Note: You do not have to create an alias for a Microsoft SQL Server
database.

3 Optionally, if you are using Oracle as your database vendor, you can
enable multiline searches by installing Oracle search options. See
“Enhancing Oracle search capabilities” on page 18.

4 Configure the database connectivity:

a If you are using Oracle as your database vendor, install OpenLink
Request Broker to enable database connections. See “Installing
OpenLink Request Broker with Oracle” on page 96.

b If you are using Microsoft SQL Server as your database vendor, see
“Installing OpenLink Request Broker with Microsoft SQL Server” on
page 95.

c If you are using DB2 as your database vendor, use the DB2
administrator tool, see “Configuring DB2 databases for ClearQuest
UNIX” on page 103.

Note: The OpenLink Request Broker software can instead be installed on
the UNIX file server if the UNIX file server is NFS mountable by the
database server, however, it needs to execute locally on the database
server.
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The Windows administrator workstation

1 Install the database vendor client software. See “Installing and configuring
an Oracle client” on page 22 and “Installing DB2 client” on page 26. If you
are using Microsoft SQL Server as your database vendor, you do not need
to install client software.

2 Install ClearQuest for Windows on the administrator’s workstation and
create the ClearQuest databases. See “Installing and configuring
ClearQuest for an administrator” on page 29.

Note: The ClearQuest administrator version must be installed on a
Windows machine. All ClearQuest customizations are done with the
ClearQuest Designer, a Windows-only application.

3 Create a schema repository and the user databases. See “Creating
ClearQuest databases” on page 31.

4 Optionally, customize your installation. See the Administrator’s Guide for
Rational ClearQuest for details on customizing ClearQuest.

5 Optionally, install Crystal Reports. “Installing Crystal Reports” on
page 36.

6 Optionally, install and configure ClearQuest Windows Workstations.
“Installing and configuring ClearQuest Windows for users” on page 49.

The UNIX file server

If you choose to do a network install, the UNIX file server must be NFS
mountable by all the UNIX ClearQuest client machines and by the Oracle
database server.

1 If you are using DB2 as database vendor you will need to install the DB2
client software on the UNIX file server. Follow the DB2 instructions for
installing the client.

2 Install ClearQuest UNIX client. See “Installing the ClearQuest UNIX
client” on page 90.
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The UNIX user machine

1 If you are using DB2 as database vendor you will need to install the DB2
client software on the UNIX user machine. Follow the DB2 instructions for
installing the client.

2 If you are not doing a network install, you will need to install ClearQuest
UNIX client on the UNIX user machine. See “Installing the ClearQuest
UNIX client” on page 90.

3 Launch the ClearQuest UNIX client and connect the client to the database.
See “Configuring ClearQuest UNIX” on page 104.

Installing the ClearQuest UNIX client

For ClearQuest UNIX, the system administrator needs to install the
ClearQuest client software and let the user know where to find the
installation.

Note: When you install the ClearQuest UNIX client, you also install all the
ClearQuest MultiSite functionality. This functionality will be available to the
user only if a ClearQuest MultiSite license is enabled.

To install the ClearQuest client, do the following:

1 Log in as the user who will own the ClearQuest installation. This user will
perform administrative functions such as managing the database registry.

Note: All other users need read-only access to the installation directories.

2 From the ClearQuest CD-ROM, run rs_install. The License Agreement
menu will be displayed. Read the license agreement and enter y or yes to
accept the agreement.

3 The next prompt will ask if you want this license agreement displayed the
next time you run rs_install. Enter y[es] or n[o].
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4 The rs_install utility has an extensive online help system. To access
the help system, enter ? at anytime during the installation process.

5 You can enter q, q!, or ?, at any time during the installation process. Press
Enter to continue with the installation process.

6 The Enter Install Location screen opens. From here you are asked to define
the location of your Rational directory.

.

7 This directory must be accessible from all the UNIX client machines. The
script will locate earlier directories. Press Enter to display the locations.

8 The default option for installation is identified by an arrow. To select the
default setting, press Enter. To install in a new location type 0 and press
Enter.

9 Select e to get a description of the three types of licensing options available
for ClearQuest from the Licensing Options Menu agreement. The
available options are:

Default Setting
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■ Use an existing Flexlm license

■ Set up a new permanent license server

■ Set up a temporary license server

10 Select the appropriate option and press Enter. For this scenario the option
1) was selected.

Note: If you selected to set up a new license, the script will ask you for a
directory location.

11 Select which parts of the UNIX installation to install from the
Configuration Selection Menu. If this is a new installation, select option s1).

Note: If you are not using Oracle as the ClearQuest UNIX database
vendor, you do not have to install the Oracle Support module. If this is the
case, select option s2).

Note: If you are using an Oracle database for the ClearQuest schema
repository and user databases, you need to install the Oracle Support
module. This module includes the OpenLink Request Broker application.
See “Installing OpenLink Request Broker with Oracle” on page 96.
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12 Select a license file to use from the next screen. Enter the port@hostname
name. For example,
27000@server

where “port” is 27000 and “host” is the name of the Windows license
server.

The “host” name needs to be a permanent name; if your network uses
DHCP, you may need a variation or special form of the host name. Check
with your network administrator.

13 Optionally, you can choose to test the license server at this time. Select
option 3) to test the license server. This step may install a small part of the
UNIX license server software in order to perform the check. If the check
fails, you may still proceed with the installation, but you will have to
repeat the licensing set up at a later time.

14 The status will be reported to your screen, press Enter to continue, and
Enter again to forward the menu.

15 A list of the modules and products that will be installed with the default
installation will be displayed on your screen in the Product Customization
Menu. To omit installation for a product, enter the number (or sequence of
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numbers) to the left of the product description. Example: if you already
have Adobe Acrobat and Netscape 4.7, you can omit the additional
installation by entering 3-4, and pressing Enter.

The product list will be displayed with the modifications you entered. For
example, items 3 and 4 would have a “no” in the first column to the right
and no space requirements would be displayed. Press Enter to continue.

Note: Installing Adobe Acrobat and Netscape 4.7 are optional, however:

■ Acrobat is useful for reading ClearQuest pdf files provided in the
$CQ_HOME/books directory.

■ ClearQuest UNIX help system requires Netscape 4.7 or higher.

16 Select the mode option in the Install Mode menu. Available options are:

■ ask

■ skip

■ reinstall

17 Select f) Forward to start the install process.

18 When the installation finishes, the Database Registry Menu will ask you to
enter the location of where to store the registry information regarding the
schema repository.

Note: This directory must be readable by all machines and users that will
run this installation of ClearQuest. It must also be writable by the user
who will be the ClearQuest administrator.

Configuring database connectivity

If your ClearQuest installation will include ClearQuest UNIX clients, your
vendor database can be either MS SQL, Oracle, or DB2.
94 Chapter 7 - Installing and configuring ClearQuest UNIX for users



cqin.book Page 95 Thursday, October 4, 2001 4:07 PM
You will have to establish the connectivity between your database vendor and
your UNIX user. The way you do this is dependent on which database vendor
you have used to create your ClearQuest databases.

■ If you are using Microsoft SQL Server or Oracle databases the OpenLink
Request Broker is used as the agent. The OpenLink Request Broker
application is provided with the ClearQuest UNIX installation CD-ROM.
See “Installing OpenLink Request Broker with Microsoft SQL Server” on
page 95, and “Installing OpenLink Request Broker with Oracle” on
page 96.

■ If you are using DB2, use the DB2 command line administrator tool to
establish connectivity. See “Configuring DB2 databases for ClearQuest
UNIX” on page 103.

Depending on which database vendor product you are using, proceed to the
following sections:

■ “Installing OpenLink Request Broker with Microsoft SQL Server” on
page 95

■ “Installing OpenLink Request Broker with Oracle” on page 96

■ “Configuring DB2 databases for ClearQuest UNIX” on page 103

Installing OpenLink Request Broker with Microsoft SQL Server

To enable Microsoft SQL Server databases to run on a Windows machine as a
back-end database, you will need to install the OpenLink Request Broker on
the SQL Server machine. The OpenLink Request Broker software is provided
on the ClearQuest UNIX Installation CD-ROM.

1 Insert the ClearQuest UNIX CD-ROM into the Windows SQL Server
database server machine.

2 Run the opl.exe file in the openlink subdirectory on the ClearQuest
installation CD-ROM. This is a self extracting zip file that has a default
directory location defined as C:\Program Files\OpenLink. You can change the
location to the directory name of your choice.

3 Execute the following at the command line:
cqperl oplrqb.pl

4 The perl script will prompt you for the directory where you unzipped the
data. Type in the directory path and select Enter. The request broker will be
installed and the oplrqb service will be registered. No other server
configuration is necessary.
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5 Connect to it from the UNIX client as you would the Windows client. The
following information is required to successfully connect.

Note: The Windows Server host name that you enter must be accessible
from all UNIX clients. When in doubt, use the ping command to verify
connectivity.

■ Vendor: SQLSERVER

■ Server: <Server hostname>

■ Database: <Database name for Master Schema Repository>

■ User Name: <SQL Server User Name created for Master Schema
Repository>

■ Password: <SQL Server Password created for Master Schema
Repository>

Installing OpenLink Request Broker with Oracle

After setting up your database server, (see “Configuring vendor databases”
on page 7), you must also install OpenLink Request Broker to facilitate
database connections. For instruction on installing the OpenLink Request
Broker software, see Step 11 on page 92.

1 Log in to the Oracle server as the same user ID you will use when
installing ClearQuest.

2 Change to the openlink_server directory in the Rational root directory
that was created when you installed the ClearQuest components.
cd [Rational_dir]/releases/ClearQuestOracleSupport.
[version]/openlink_server/[arch]

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

arch

is the hardware system. Use one of the following options depending on
your system:

■ hp11_pa

■ sun5
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■ aix

■ linux

3 Run the installation script by entering the following at the command line:
sh install.sh

4 The script will prompt you for the installation information. Accept default
values when they are available.

5 After the installation script is complete, execute the post_install.sh at the
command line to configure your oracle settings:

sh post_install.sh

6 The post_install shell program will prompt you to enter the values for
your Oracle home directory (ORACLE_HOME) and your oracle system id
(ORACLE_SID).

Note: You may rerun this script to reset the options at any time.

7 The configuration process is complete. Type Quit to close the OpenLink
Configuration Utility.

Installing the OpenLink ODBC catalog views for Oracle 7 or
Oracle 8

This task is done while connected to the internal database. Run the Oracle
svrmgrl with the corresponding sql script, and use odbccat7.sql for
Oracle 7 or odbccat8.sql for Oracle 8. The scripts are located in the newly
created bin directory.

1 Log in as the Oracle database administrator.

2 Change to the directory containing the odbccat7.sql or
odbccat8.sql script:
cd [Rational_dir]/releases/ClearQuestSupport.[
version]/openlink_server/[arch]/bin

where

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00
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arch

is the hardware system. Use one of the following options depending on
your system:

■ hp11_pa

■ sun5

■ aix

■ linux

3 Enter the following:

For more information, see the comments in the odbccat*.sql file.

After installing the OPenLInk Request Broker for Oracle, you should
configure it to automatically start up at boot time. See:

■ “Automating startup on reboot for Solaris” on page 99

■ “Automating startup on reboot for HP-UX” on page 100

■ “Automating startup on reboot for Linux” on page 101

■ “Automating startup on reboot for AIX” on page 102

Letter “l” not number “1”

If you are using Oracle7

If you are using Oracle8

> svrmgrl lmode=y
SVRMGR> CONNECT internal

SVRMGR> @odbccat7.sql
--or--

SVRMGR> @odbccat8.sql
SVRMGR> EXIT
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Automating startup on reboot for Solaris

The following instructions assume your UNIX installation uses the typical
directories for startup and shutdown scripts. To automatically restart the
OpenLink Request Broker after rebooting the server:

1 Log in as root (root privileges are required for this step).

2 After installing the cd-image, there will be a file named
rc.OpenLinkBroker in:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/sun5

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

3 Copy the rc.OpenLinkBroker script to the /etc/init.d directory.
cp rc.OpenLinkBroker /etc/init.d/openlinkbroker

4 Edit the /etc/init.d/openlinkbroker script to change the value of
BIN_DIR to be:
[Rational_dir]/releases/ClearQuestSupport.[version]/op
enlink_server/sun5/bin

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

5 Make the script executable:
chmod +x /etc/init.d/openlinkbroker

6 Make symbolic links for startup and shutdown as follows. Note that the
example uses “98” for startup and “02” for shutdown. You may need to
use different numbers so that the startup script is invoked after any Oracle
and NFS start up scripts.
>ln -s /etc/init.d/openlinkbroker /etc/rc2.d/
S98openlinkbroker
>ln -s /etc/init.d/openlinkbroker /etc/rc2.d/
K02openlinkbroker
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Automating startup on reboot for HP-UX

1 Log in as root (root privileges are required for this step).

Note: After installing the cd-image, there will be a file named
rc.OpenLinkBroker in:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/hp11_pa

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

2 Copy the rc.OpenLinkBroker script to the /sbin/init.d/ directory.

cp rc.OpenLinkBroker /sbin/init.d/openlinkbroker

3 Edit the /sbin/init.d/openlinkbroker script to change the value of
BIN_DIR to be:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/hp11_pa/bin

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

4 Make the script executable.
chmod +x /sbin/init.d/openlinkbroker

5 Make symbolic links for startup and shutdown as follows. Note that the
example uses “98” for startup and “02” for shutdown. You may need to
use different numbers so that the startup script is invoked after any Oracle
and NFS start up scripts.
>ln -s /sbin/init.d/openlinkbroker/sbin/rc2.d/
S98openlinkbroker
>ln -s /sbin/init.d/openlinkbroker/sbin/rc2.d/
K02openlinkbroker
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Automating startup on reboot for Linux

1 Log in as root (root privileges are required for this step).

2 After installing the cd-image, there will be a file named
rc.OpenLinkBroker in:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/linux

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

3 Copy the rc.OpenLinkBroker script to the /etc/rc.d/init.d
directory.
cp rc.OpenLinkBroker /etc/rc.d/init.d/openlinkbroker

4 Edit the /etc/rc.d/init.d/openlinkbroker script to change the
value of BIN_DIR to be:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/linux/bin

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

5 Make the script executable:
chmod +x /etc/rc.d/init.d/openlinkbroker

6 Make symbolic links for startup and shutdown as follows. Note that the
example uses “98” for startup and “02” for shutdown. You may need to
use different numbers so that the startup script is invoked after any Oracle
and NFS start up scripts.
>ln-s/etc/rc.d/init.d/openlinkbroker/etc/rc.d/rc3.d/
S98openlinkbroker
>ln -s /etc/rc.d/init.d/openlinkbroker/etc/rc.d/rc3.d/
K02openlinkbroker
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Automating startup on reboot for AIX

1 Log in as root (root privileges are typically required for this step).

2 After installing the cd-image, there will be a file named
rc.OpenLinkBroker in:
[Rational_dir]/releases/ClearQuestSupport.[version]/
openlink_server/aix

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

3 Copy the rc.OpenLinkBroker script to the /etc directory.
cp rc.OpenLinkBroker /etc/rc.openlinkbroker

4 Edit the /etc/rc.Openlinkbroker script to change the value of
BIN_DIR to be:
[Rational_dir]/releases/ClearQuestSupport.[version]/op
enlink_server/aix/bin

where:

Rational_dir

is the Rational installation directory.

version

is the Rational installation version number. Example: 2001A.04.00

5 Make the script executable:
chmod +x /etc/rc.openlinkbroker

6 Edit /etc/inittab and add the line:
openlinkbroker:2:wait:/etc/rc.openlinkbroker
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Configuring DB2 databases for ClearQuest UNIX

Once the DB2 client software is installed on the ClearQuest UNIX client
machine, perform the following steps:

1 Log in to the ClearQuest UNIX client machine as a user with privileges to
modify the database instance (perhaps the UNIX user that created the DB2
instance).

2 Ensure that the DB2INSTANCE environment variable is set to the correct
DB2 instance. This is very important. The IBM DB2 ODBC driver requires
that this environment variable be set for all operations. ClearQuest UNIX
will not operate properly with DB2 if the DB2INSTANCE environment
variable is not set. A typical symptom of the DB2INSTANCE environment
variable not being set is that the IBM DB2 ODBC driver will cause a
Segmentation Fault after attempting to log in to the DB2 database.

3 Run the DB2 command line administration tool, db2.

4 Create a DB2 TCP/IP NODE for use by ClearQuest UNIX. The node alias
needs to be the same for all DB2 clients. The port number is the TCP/IP
port used by the DB2 service. This is typically set to 51164.
db2> CATALOG TCPIP NODE <nodealias> REMOTE
<serverhostname> SERVER <port number>

5 Create a DB2 database alias for both the Master Schema Repository and a
User database. The database alias needs to be the same for all DB2 clients.
db2> CATALOG DATABASE <database name> AS <database
alias> AT NODE <node alias>

6 Test the connection to the DB2 database. The CONNECT command should
succeed.
db2> CONNECT TO <database alias> USER <Windows user id>
USING <Windows password>
db2> DISCONNECT CURRENT
db2> QUIT

7 Create a symbolic link from the ClearQuest install area into the IBM DB2
installation area for the IBM DB2 ODBC device driver. This is required
because ClearQuest UNIX does not redistribute the IBM DB2 device
driver. A typical symptom of this step being omitted is that ClearQuest
UNIX will indicate that the specified driver could not be loaded while
attempting to log in to the DB2 database. This step needs to be completed
for every ClearQuest UNIX install area that will access DB2.
cd <rational directory>/releases/
ClearQuestClient.2001.03.00
cd <architecture >/shlib
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ln -fs <IBM DB2 Install Dir>/V6.1/lib/libdb2.so
db_IBMDB2

8 Launch ClearQuest UNIX and configure the connection as follows:

■ Vendor: DB2

■ Server: <server host name>

■ Database: <database alias for Master Schema Repository>

■ User Name: <Windows user id>

■ Password: <Windows password>

■ Repeat steps 1 - 8 for each schema repository and user database.

Configuring ClearQuest UNIX

You should tell the ClearQuest UNIX user where ClearQuest is installed.
They can then run ClearQuest directly, or source a configuration file that will
modify their path.

To run ClearQuest UNIX:

1 Add the ClearQuest home directory to the client machines’ path:
[Rational_dir]/releases/ClearQuestClient.2001A.04.00/
bin

or use the source command on the cq_setup.csh file to set the
ClearQuest home environment variable ($CQ_HOME):

source [Rational_dir]/cq_setup.csh

OR

source [Rational_dir]/cq_setup.sh

2 To run ClearQuest UNIX, type clearquest.
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3 The first time you run the ClearQuest/UNIX client, the Register Database
dialog box displays. Enter the information to connect to the schema
repository. Refer to the following table for examples of database
connection data.

Example screen for an Oracle database:

Parameter SQL Server Oracle DB2

Vendor SQLSERVER ORACLE DB2

Server host name SQL*Net alias host name

Database schema repository
database name

Not Required schema repository
database alias

SID Not Required Instance ID for the
Oracle database
server. This is
case-sensitive.

Not Required

User Name user name user name user name

Password password password password

Connect Options Not Required HOST=host
SID= sid
SERVER_VER=8.0
CLIENT_VER=7.0

Not Required

SQL*Net Alias
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Example screen for a DB2 database:

Example screen for an SQL Server database:

4 Click Apply and then Close.
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Enabling e-mail notification for UNIX users

After installing ClearQuest (either for an initial or an upgrade install), the
user must enable e-mail notification if they want to send automatic e-mail
messages from ClearQuest. To do this:

1 Launch ClearQuest. Type clearquest at a UNIX shell prompt.

2 Within ClearQuest, choose View > E-mail Options. This opens the E-mail
Setup dialog box.

3 Select Enable E-mail Notification.

4 Enter your e-mail address.

5 Click OK.
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8Silent ClearQuest installation
You can configure Rational Software Setup to perform silent installations of
Windows versions of Rational software. Silent installations allow you to
perform an installation of a Rational Software product, using the same
parameters, repeatedly on a number of systems.

The following sections provide a brief summary of the silent installation
features.

We recommend you read Rational’s Silent Installation White Paper before you
attempt a silent installation. The white paper is available from the Rational
Web site at http://www.rational.com/products/whitepapers/101458.jsp/.
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Overview of silent installations

This section describes how to perform a silent install. The basic steps,
explained below, are:

1 Record an installation session.

2 Optionally, add a post-installation command to the recorded installation.

3 Execute the installation procedure.

Recording the software installation

You can record a software installation session and then use the responses that
you provide to replay the installation. At the end of the recorded installation
procedure, you will be given the option to exit without installing the product.

1 Insert the Rational ClearQuest software CD-ROM in a CD-ROM drive.

2 Open a command window on your system and run RSSetup with the
-autocapture switch. For example:
<Install Location>\setup\rssetup -autocapture

Where <Install Location> is the location of the Rational ClearQuest
software CD-ROM.

3 When the Rational Software Setup program starts, proceed with the
installation procedure on “Understanding the ClearQuest install process”
on page 3. Your responses will be recorded in the responses file which is
named as follows:
<Install Path>\RSSetup\response.ini

Note: The option to use a temporary license is not supported when using
the -autocapture switch. The silent installation procedure will not
support the capture of license certificate information into the
response.ini file.

4 After you have answered all of the questions related to the installation,
you will be prompted to continue with the installation of the product or to
exit from the setup program. Click OK to proceed with the installation or
Cancel to exit. Even if you cancel at this point, your answers are still saved.
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Example

The following example shows how to record an installation of Rational
ClearQuest.

<Install Location>\setup\rssetup -autocapture /product
ClearQuest-1.1

Specifying a post-installation command

You can specify a command that will be performed after the silent installation
has completed.

1 After you have completed preparation for a silent installation, perform the
following step:

■ Edit the response file by appending lines with the label
[PostInstallCmd] to the end of the file.

[PostInstallCmd]

Command=post-installation-commands.bat

where, the post-installation-commands.bat is a batch
file that contains the commands you want to execute. Such a
file might contain the following commands:

licadmin -fserver.txt

net send administrator “Installation Complete”

In this example, the License Key Administrator, licadmin,
starts and uses the information in server.txt to specify
the name of the license server that the current system will
use. The batch file then sends a message to the
administrator, indicating that the installation procedure
is complete.

2 Save the response file to a unique name (to ensure that is it not overwritten
by subsequent autocaptures). For example, save the response file with a
name such as C:\responses\ent-w-post.ini.

Performing a silent installation

After you have recorded your responses, use the response file to replay the
installation. For example:

<Install Location>\setup\rssetup -silent
-response:response-path

Where response-path is the path of the response file. The default path is as
follows:
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“C:\Program Files\Rational\RSSetup\response.ini”

Note: If a response file is in the default location, that response file will be
used each time you run the installation procedure. Specifying a response file,
using the -response:response-path parameter, will override the default
response file.

If you specify -autocapture on the RSSetup command line, your
installation will initially select the product name identified in the previous
response.ini file, but will allow you to select a new product for
installation. A new response.ini file will be saved at the end of the
installation procedure.

Preparing multiple response files

You can save multiple response files to support attended installation of
different products.

1 Identify a directory where you will store your response files. The
following examples use a directory named as follows:
C:\responses

2 Record the response file for each product you want to install.

3 Rename the response file with a unique file name. For example, save the
ClearQuest 2.0 response file as:
C:\responses\ClearQuest2_0responses.ini

4 Perform the installation and specify the path to the response file as a
parameter to the -response switch. For example:
<Install Location>\setup\rssetup -silent
-response:C:\response\ClearQuest2_0response.ini

Examples

To record an installation of Rational ClearQuest version 2.0:
<Install Location>\setup\rssetup -autocapture /product
ClearQuest-2.0

To remove Rational ClearQuest version 2.0:
<Install Location>\setup\rssetup /uninstall /product
ClearQuest-2.0
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Command line utilities

RSSetup

This section provides the syntax for RSSetup, as well as a table of RSSetup
command parameters.

Syntax
RSSetup [-silent [-response:response-path]]|

[-verbose [-response:response-path]] |
[-autocapture]
[/product <product>] [/install /uninstall /update]

RSSetup Command Parameter Description

-silent Performs a silent (unattended) installation.

-verbose Replays a previously recorded installation,
allowing you to override the recorded
responses.
Note: If you override the responses, those
changes are not written to the response file.

-response:response-path Specifies the path to the response file.
response-path is the path for the response
file. You must specify the response-path.
The default path is <Install Location>\Setup\
RSSetup\response.ini, where
<Install Location> is the location of the
installation files.

-autocapture Records your responses to a software
installation, storing the responses in a file for
later replay.

/product product-identifier Specifies the product you are installing.
This parameter does not apply for silent
installations. For a silent installation, you
specify the product name in the response file.
Look on page 114 for the list of identifiers you
can use with this switch.

/install Installs the product you specified with the
/product switch.
This switch cannot be combined with /uninstall
or /update.
This parameter does not apply for silent
installations. For a silent installation, you
specify the product name in the response file.

/uninstall Removes the product you specified with the
/product switch.
This switch cannot be combined with /install or
/update.
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The table below lists the product identifiers you must use with the /product
switch.

/update Updates the product you specified with the
/product switch.
This switch cannot be combined with /install or
/uninstall.
This parameter does not apply for silent
installations.

Product Name Product Identifiers

Rational LoadTest atbuLoadTest

Rational Suite Performance Studio Agent atbuPSAgent

Rational Suite Performance Studio atbuRSuitePerformanceStudio

Rational Test Enablers atbuSetupEnablers

Rational TeamTest atbuTeamTest

Rational TestAccelerator atbuTestAccelerator

Rational Robot atbuTSRobot

Rational ClearQuest ClearQuest-1.1

Rational PureCoverage coverageNT

Rational Suite DevelopmentStudio for UNIX dsbuRSDSU

Rational Developer Kit dsbuDeveloperKit

Rational Purify purifyNT

Rational Quantify quantifyNT

Rational RequisitePro rmbuRequisitePro

Rational RequisiteWeb rmbuRequisiteWeb

Rational Rose Inline EJB Addin Inline

Rational Rose Enterprise Edition Rose98i

Rational Rose Professional C++ Edition Rose98iC++Professional

Rational Rose Professional J Edition Rose98iJavaProfessional

Rational Rose Modeler Edition Rose98iModeler

Rational Rose Professional Visual Basic Edition Rose98iVBProfessional

RSSetup Command Parameter Description
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License Key Administrator

You can run the Rational License Key Administrator from a command line or
batch file to automate your license key installations and configuration.

For more information about the License Key Administrator command line
options and usage, refer to your License Management Guide for Rational Suite
manual.

Syntax
licadmin -ffilename.ext

The status of the execution of this command is written to a file named
filename.ext_STATUS, where filename.ext is the name of the license
parameter file you used. The status file is created in the directory where you
executed the licadmin command.

Rational Rose Professional Data Modeler Edition RoseDataModelerProfessional

Rational Unified Process ruObjectory51

Rational SoDA for Word SoDA

Rational Suite AnalystStudio wsbuAnalystEdition

Rational Suite DevelopmentStudio wsbuDevelopmentStudio

Rational Suite Development Studio - RealTime
Edition

wsbuDevelopmentStudioRT

Rational Suite Enterprise wsbuEnterprise

Rational License Server wsbuFLEXlmServer

Sybase SQL Anywhere Database Server wsbuSQLAnywhereServer

Rational Suite TestStudio wsbuTestStudio

Rational Suite Web Server Components wsbuWebComponents

Product Name Product Identifiers

Parameter Description

-ffilename.ext Specifies the path to the license parameter file.
The license parameter file specifies the name of the
license key server that you will use. For example:
Server:group-license-server
The keyword Server is case-sensitive.
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Example

1 Create a file that contains the following line:
Server:group-license-server.

where group-license-server is the name of your License Server
system.

2 Save the file as server-info.txt.

3 In a command window, run the following command:
licadmin -fserver-info.txt.

Your system will be configured to use floating license keys from
group-license-server.
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9Upgrading ClearQuest
This chapter describes how to upgrade your ClearQuest databases and
packages created with a previous installation.

Note: If this is your first installation of ClearQuest, no upgrading is required.

Before you begin the upgrade, read the release notes to become familiar with
what has changed in this release.

Start > Programs > Rational > Rational ClearQuest > Rational ClearQuest
Release Notes

Topics covered in this chapter include:

■ “Understanding the upgrade process” on page 118

■ “Upgrading packages basics” on page 120

■ “Applying schema changes to user databases” on page 124

■ “Upgrading feature levels” on page 126

■ “Some helpful utilities” on page 133
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Understanding the upgrade process

The upgrade process is dependent on the complexity of your system and the
extent to which you have customized your schema. Review the following
conditions for applicability to your ClearQuest system.

■ If you have designed your ClearQuest system based on the ClearQuest
predefined schemas or have added packages to your customized schema,
apply the latest packages. To determine whether packages have been
installed in your schema, see “Analyzing your current package version”
on page 121. See “Applying package upgrades” on page 122 to apply the
package upgrades.

■ If you have integrations with other Rational products embedded in your
ClearQuest system, install the latest version of the integration product and
then upgrade the integrations with ClearQuest to the latest packages.

■ If you want to use the latest ClearQuest features or if you have a
ClearQuest release prior to release 2.0, upgrade your feature level, see
“Upgrading feature levels” on page 126.

■ If you are upgrading a ClearQuest installation or integration that was
installed from the Rational Suite CD-ROM, refer to “Upgrading from
Earlier Versions of Rational Suite in the Installation Guide for Rational Suite.

If you are starting from this version Then upgrade as follows

Rational 2001A or 2001 Follow the procedures in this chapter.

Rational 2000 1 Upgrade to version 2001A.04.00, following
the procedure supplied by Rational
Technical Support.

2 Upgrade from version 2001A.04.00 to the
current version by following the procedures
in this chapter.

Rational 1.5, 1.1, or 1.0 1 Upgrade to version 2000.02.10, following
the procedure supplied by Rational
Technical Support.

2 Upgrade from version 2000.02.10 to version
2001A.04.00, following the procedure
supplied by Rational Technical Support.

3 Upgrade from version 2001A.04.00 to the
current version by following the procedures
in this chapter.

A Rational point product, any version Contact Technical Support for more
information.
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ClearQuest for the administrator

The following steps summarize the upgrade procedure for the administrator.

■ If you want to author report formats, upgrade to Crystal ReportsTM 8.0.

■ Install ClearQuest. It is not necessary to uninstall previous versions of
ClearQuest before installing ClearQuest. See “Installing and configuring
ClearQuest for an administrator” on page 29.

■ Installing ClearQuest may reset the connection to the ClearQuest
database. Launch the Rational ClearQuest Maintenance Tool to establish a
new connection to your ClearQuest database. See “Connecting to a
schema repository” on page 119.

■ If you have added integrations or packages to your ClearQuest schema,
upgrade the packages, see “Upgrading packages basics” on page 120.

■ Configure ClearQuest Web as needed. See “Installing and configuring
ClearQuest Web” on page 55.

ClearQuest for the user
■ Install ClearQuest client software. It is not necessary to uninstall previous

versions of ClearQuest before installing ClearQuest. See “Installing and
configuring ClearQuest Windows for users” on page 49.

■ Installing ClearQuest resets the connection to the ClearQuest database.
Run ClearQuest Maintenance Tool to establish a new connection to your
ClearQuest database. See “Connecting to a schema repository” on
page 119.

Connecting to a schema repository

After you have installed the latest ClearQuest release, you may have to
reconnect to your schema repository.

1 Launch the ClearQuest Maintenance Tool.

Start > Programs > Rational > Rational ClearQuest > Rational ClearQuest
Maintenance Tool

2 Select Connection > New from the menu.

3 Enter your database properties in the right panel and give your connect
node a new name in the left panel.

4 Alternatively, if you saved a profile that includes all the information you
need before you install the latest ClearQuest version you can:
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a Select File > Import Profile from the menu.

b Enter the path and filename in the File Name text field. Click Next.

Note: A profile file has an *.ini extension.
For example: dev_profile.ini.

c Check the databases you want to load into ClearQuest.

5 Click Finish. Your database will be connected to ClearQuest and be
displayed in the left panel tree node.

Upgrading packages basics

If any of the following conditions apply, upgrade the packages installed in
your schema:

■ You are currently using or have built your schema based on any of the
following predefined schemas:

■ Defect Tracking

■ AnalystStudio

■ DeveloperStudio

■ TestStudio

■ UnifiedChangeManagement

■ Enterprise

■ You have customized your schema by adding integrations or individual
packages.

If you do not have any ClearQuest packages installed, proceed to the
“Upgrading feature levels” on page 126. For more information on adding
integrations and packages, refer to Administrator’s Guide for Rational
ClearQuest.

At a high level, the steps you should follow to upgrade packages are:

1 Find out whether you need to upgrade any existing packages. See
“Analyzing your current package version” on page 121.

2 Upgrade your ClearQuest packages. See “Applying package upgrades”
on page 122.

3 Upgrade your user databases. See “Applying schema changes to user
databases” on page 124.
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Analyzing your current package version

To find out whether packages have been added to your schema repository
perform the following:

1 Log on to ClearQuest Designer with Super User or Schema Designer
privileges.

2 Click Cancel in the Open Schema Dialog box.

3 Choose View > Schema Summary to determine the packages are currently
applied to the schema.

4 Open the folder with your schema name and select the appropriate
version. If multiple databases are associated with this schema they will be
displayed in the central list display.

5 The list in the right scroll area will display every package name and
version currently installed in your schema. If no package names are
present, no additional upgrade is required.
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6 The following table contains the latest version numbers for the packages
upgraded with this release. If your packages are not updated to the latest
release, upgrade them now. Refer to “Applying package upgrades” on
page 122.

Applying package upgrades
Note: If you are upgrading a RequisitePro integration with ClearQuest,
consult the “Upgrading ClearQuest” section of the Installation Guide for
Rational Suites.

To upgrade all your existing packages:

1 Log in to ClearQuest Designer with Super User or Schema Designer
privileges.

2 If the Open Schema Dialog box is displayed, click Cancel.

3 Select Package > Upgrade Installed Packages from the ClearQuest Designer
menu.

4 Select the schema name from the list of schema repositories. Click Next.

5 The list of all the packages that need to be applied will be shown. To
continue, click Upgrade.

Package Name Latest Version

E-mail 6.0

Repository 3.0

RequisitePro 1.6

RequisitePro 1.6 Upgrade

TeamTest 4.0

UnifiedChange
Management

4.0
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6 Once the upgrade is complete, click Exit.

If you are upgrading a UCM integration from release 2000.02.10, map the
UCM state types prior to testing the upgrade in Step 7. To do so:

a From the ClearQuest Designer menu, select
Package > Setup State Types.

b In the Package Wizard, select AMStateTypes from the scroll down
Packages menu and accept the default value for the Record Type.

c Map each of the ClearQuest states (shown in the right column) to the
appropriate State Type from the pull down menus in the State Type or
left column.

d If you have UCM integrations with additional record types, they will
be listed in the Record Type scroll down menu. Select the next record
type and repeat the mapping process for each of the record types.

Note: For more information on mapping State Types refer to
Administrator’s Guide for Rational ClearQuest.

7 Verify your work by selecting File > Test Work from the ClearQuest
Designer menu. Select the test database associated with the chosen schema
and click OK to continue. For more information on testing schema changes
refer to “Administrator’s Guide for Rational ClearQuest.”

8 After the testing is complete and you verify that there are no errors, click
Next.

Note: If the upgrade process fails, the errors will be displayed in the
status window.
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9 Check in your changes by selecting File > Check in from the menu and
click OK.

Applying schema changes to user databases

Warning: This action cannot be reversed. Back up your schema repository
and user databases. For back up procedures refer to your database vendor
documentation.

Note: Perform a database upgrade on a test database before updating your
user databases. For instructions on creating a test database, see “Working
with test databases” in the Administrator’s Guide for Rational ClearQuest.

To upgrade your user database integrations:

1 Log in to your ClearQuest Designer with Super User or Designer
privileges.

2 Select Database > Upgrade Database.

A message warns that this action cannot be reversed, recommends that
you back up your databases before proceeding and asks for confirmation
to continue. If you have backed up your databases, click Yes.

3 Select the user database from the list presented in the Upgrade Database
wizard. Click Next.

4 Select the schema version from the list. If your most recent version is not
shown in this list, it probably hasn’t been checked in. In that case, cancel
this wizard. Open the schema from the File menu and check it in. Then
restart this process.
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5 Click Finish. When the user database upgrade completes, a message will
be displayed saying the database has been upgraded successfully.

.
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Upgrading feature levels

If you want to use the new features available with the latest ClearQuest
version (see the ClearQuest Release Notes for new features), or if you have a
ClearQuest version prior to 2.0 currently installed, you must upgrade your
databases.

ClearQuest now maintains backward compatibility making it possible for you
to incrementally install the new ClearQuest release. However, prior to
upgrading your schema repositories and user databases to the latest feature
level, all ClearQuest users must have the latest ClearQuest installation.

The following table depicts when a database upgrade is required.

Note: If you are upgrading Oracle databases, you can speed up the upgrade
process significantly by running the Oracle ANALYZE command. Refer to
your Oracle documentation for detailed instructions.

Overview of feature level upgrade process

Because it is important to minimize your production system down time, we
strongly recommend that you first perform the feature level upgrade on a test
system. Here are the steps:

1 Perform a test upgrade:

a Create a testbed from a copy of your production databases.

b Create an upgrade database set for the testbed.

c Upgrade the testbed.

Current Release version Upgrade requirements
Downward
Compatibility

1.0 Must upgrade to 2001A 1.0

1.1 and 1.1 Service Packs Must upgrade to 2001A 1.1

2.0 Upgrade for new features 2.0

2000 Upgrade for new features 2.0

2001 Upgrade for new features 2.0
2000

2001A New features are:
Security
ClearQuest MultiSite

2.0
2000
2001
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d Verify that the test upgrade was successful.

2 Upgrade the production databases.

a Create an upgrade database set for the production databases.

b Upgrade the production databases.

c Verify that the production upgrade was successful.

d Connect users to the new upgraded databases.

Preparing your testbed

Because it is important to minimize your production system down time, we
strongly recommend that you first perform the feature level upgrade on a test
system. The feature level test upgrade process is represented in the following
diagram.

1 Create a new empty database for each of your schema repositories and
user databases. This set of databases will be referred to as the testbed. For
information on creating vendor databases see:

■ “Setting up Microsoft Access” on page 10

■ “Setting up SQL Anywhere” on page 10
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■ “Setting up Microsoft SQL Server 7 and 2000” on page 13

■ “Setting up the Oracle Server” on page 17

■ “Setting up IBM DB2” on page 24

Warning: Create empty databases only. Do not use your vendor database
tools to move or copy the data.

2 Log off all of your users to ensure database consistency.

3 Copy existing production schema repository and user databases to your
testbed databases and establish a connection to ClearQuest. Use the
ClearQuest installutil utility with options convertschemarepo
and convertuserdb. For detailed usage of these options refer to
“Creating database copies” on page 134.

4 The convert options for installutil also locks the production database.
To allow users to continue using the production database while you are
upgrading the testbed, unlock the production database. See “Unlocking
databases” on page 133.

5 Create another new empty “upgrade” database for each of the databases
in your testbed. This set of databases will be referred to as the upgrade
databases.

6 Launch the ClearQuest Maintenance Tool and begin the upgrade process.
See “Upgrading your databases” on page 129.

7 Verify that the upgrade process completed successfully:

■ Verify through the ClearQuest Maintenance Tool upgrade dialog box
that the upgrade was completed successfully. Alternately, you can view
the log file created in your \Temp directory.

■ Enter a few test records of each record type and move them through
your entire state model to be sure the upgrade is working correctly.
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Upgrading your databases

The upgrade steps are the same whether you are performing a test upgrade or
the final production upgrade.

To perform an upgrade on an existing connection:

1 In the Existing Connections area, select the connection you need to
upgrade.

2 In the ClearQuest Maintenance Tool, click Schema Repository > Upgrade >
Selected Connection.

3 In the Schema Repository Properties area, verify the properties of the
schema repository you wish to upgrade.

4 Click Next.

5 When asked if you want to upgrade the user databases associated with the
schema repository, select Yes or No. Keep in mind that user databases are
locked during the upgrade process.

6 In the Login Information area, enter your login name and password. You
must have Super User privileges to upgrade a schema repository and/or
user databases.

7 Click Next.

8 If you chose to upgrade a user databases, select the user database(s) you’d
like to upgrade and click Next.

9 In the New Schema Repository Properties area, enter the database
properties of the new vendor database that will contain the upgraded
schema repository and click Next.

10 If you chose to upgrade a user database(s), in the New User Database area,
enter the database properties of the new vendor database that will contain
the upgraded user database.

11 If you are upgrading more than one user database, click Next and repeat
Step 10. If not, click Finish.

12 Verify that the upgrade process completed successfully:

■ Verify that the upgrade was completed successfully. You can view the
log file created in your \Temp directory.

■ Enter a few test records and move them through your entire state
model to be sure the upgrade is working correctly.
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13 Do one of the following depending on what databases you are upgrading:

■ If this completes your testbed upgrade process, proceed to “Preparing
your production databases” on page 132.

■ If this completes your production database upgrade, inform users of
the new connection information.
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To upgrade a schema repository that you are not connected
to:

1 In the ClearQuest Maintenance Tool, click Schema Repository > Upgrade >
Other.

2 In the Schema Repository Properties area, enter the properties of the
schema repository you wish to upgrade.

3 Click Next.

4 When asked if you want to upgrade the user databases associated with the
schema repository, select Yes or No. Keep in mind that user databases are
locked during the upgrade process.

5 In the Login Information area, enter your login name and password. You
must have Super User privileges to upgrade a schema repository and/or
user databases.

6 Click Next.

7 If you chose to upgrade a user databases, select the user database(s) you’d
like to upgrade and click Next.

8 In the New Schema Repository Properties area, enter the database
properties of the new vendor database that will contain the upgraded
schema repository and click Next.

9 If you chose to upgrade a user database(s), in the New User Database area,
enter the database properties of the new vendor database that will contain
the upgraded user database.

10 If you are upgrading more than one user database, click Next and repeat
Step 10. If not, click Finish.

11 Verify that the upgrade process completed successfully:

■ Verify that the upgrade was completed successfully. You can view the
log file created in your \Temp directory.

■ Enter a few test records and move them through your entire state
model to be sure the upgrade is working correctly.

12 Do one of the following depending on what databases you are upgrading:

■ If this completes your testbed upgrade process, proceed to “Preparing
your production databases” on page 132.

■ If this completes your production database upgrade, inform users of
the new connection information.
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Preparing your production databases

After you have verified that the test upgrade was successful, perform the
following steps on your production databases.

Note: You may discard your testbed and test upgrade databases after
completion of the validation process.

1 Create a new empty database for each of your schema repositories and
user databases. For information on creating vendor databases see:

■ “Setting up Microsoft Access” on page 10

■ “Setting up SQL Anywhere” on page 10

■ “Setting up Microsoft SQL Server 7 and 2000” on page 13

■ “Setting up the Oracle Server” on page 17

■ “Setting up IBM DB2” on page 24

Warning: Create empty databases only. Do not use your vendor database
tools to move or copy the data. ClearQuest updates the data structure and
moves it into the new databases as part of the upgrade process.

2 Log off all of your users.

3 Launch the ClearQuest Maintenance Tool and begin the upgrade process.
See “Upgrading your databases” on page 129.
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Some helpful utilities

Unlocking databases

When you create database copies using the installutil, the
convertschemarepo option locks your production database prior to
copying it to your testbed. To allow users to continue using your original
databases while you test the upgrade, unlock the database.

Note: After completion of final upgrade, do not unlock your original
databases. Keeping the original databases locked prevents your users from
accessing the wrong databases.

1 Open a command line window (a DOS prompt).

2 To unlock the schema repository, enter the following command at the
command line for your vendor database:
installutil unlockschemarepo <db_vendor> <server>
<database> <dbo_login> <dbo_password> “”
where:

3 To unlock user databases, repeat the above steps with the following
exceptions:

■ The installutil subcommand to use is unlockuserdb instead of
unlockschemarepo.

■ Point to the vendor database containing the original user database, not
the schema repository.

Variable Access SQL Anywhere MS SQL Oracle DB2

db_vendor MS_ACCESS SQL_ANYWHERE SQL_SERVER ORACLE DB2

server “” (Empty
String)

database server
name

host name SQL*Net
alias

not
required

database full path to the
schema
repository
database

full path to the
schema repository
database

schema
repository
database
name

schema
repository
database
name

schema
repository
database
alias

dbo_login admin admin db owner user
name

db owner
user name

db owner
user name

dbo_password admin admin db owner
password

db owner
password

db owner
password

connect_options ““ ““ ““ HOST=host
SID= sid

““
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Creating database copies

To copy your schema repository and create a sample database for testing the
upgrade process use the installutil command line utility with the
convertschemarepo option. This option will:

■ Copy the original database to a new database.

■ Connect ClearQuest to the database copy.

■ Lock the original database.

Note: Before executing this command, perform a database backup and
create new database(s) using your database vendor tools.

To create a copy of your databases to test the upgrade process in an off line
environment:

1 Create new test databases following the instructions for your vendor in
“Configuring vendor databases” on page 7.

2 Use the installutil convertschemarepo to copy your existing
schema repository and connect it to ClearQuest. See “installutil
convertuserdb” on page 136 for sample input parameters by vendor type.

3 Use the installutil convertuserdb to copy each of your existing
user databases and connect them to ClearQuest. See “installutil
convertuserdb” on page 136 for sample input parameters by vendor type.
134 Chapter 9 - Upgrading ClearQuest



cqin.book Page 135 Thursday, October 4, 2001 4:07 PM
installutil convertschemarepo

Syntax:
installutil convertschemarepo <cq_login> <cq_password>
<to_db_vendor> <to_server> <to_database> <to_dbo_login>
<to_dbo_password> <to_rw_login> <to_rw_password>
<to_ro_login> <to_ro_password> <to_connect_options>
[tcpip,ipx,netbios,namedpipes] [host1,host2,...]

Where:

Parameter Description

cq_login The user login name to ClearQuest databases that you want to
copy. The user must have Super User privileges.

cq_password The user login password to ClearQuest that has Super User
privileges.

to_db_vendor The new upgrade database vendor name. Available choices are
MS_ACCESS, SQL_ANYWHERE, SQL_SERVER, ORACLE,
DB2.

to_server The new upgrade database server name.

to_database The new upgrade database name.

to_dbo_login A String containing the new empty database owner's login
name.

to_dbo_password A String containing the new empty database owner's login
password.

to_rw_login A String containing the empty database read/write login name.

to_rw_password A String containing the new empty database read/write login
password.

to_ro_login A String containing the new empty database read only login
name.

to_ro_password A String containing the new empty database read only login
name.

to_connect_options This is only required for Oracle where the parameters are:
(HOST=host;SID=sid; server_ver=server_version_number;
client_ver=client_version_number).

[tcpip,ipx,netbios,
namedpipes]

These are optional parameters for specifying networks.

[host1,host2,...] These are optional parameters for identifying multiple host
machines.
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installutil convertuserdb

Syntax:
installutil convertuserdb <cq_login> <cq_password>
<user_dbname> <to_user_db_vendor> <to_user_server>
<to_user_database> <to_user_dbo_login>
<to_user_dbo_password> <to_user_rw_login>
<to_user_rw_password> <to_user_connect_options>
[tcpip,ipx,netbios,namedpipes] [host1,host2,...]

Where:

Parameter Description

cq_login The user login name to ClearQuest databases that you want to
copy. The user must have Super User privileges.

cq_password The user login password to ClearQuest that has Super User
privileges.

user_dbname The name of the userdb that you want to convert.

to_user_db_vendor The new upgrade user database vendor name. Available choices
are MS_ACCESS, SQL_ANYWHERE, SQL_SERVER, ORACLE,
DB2.

to_user_server The new upgrade user database server name.

to_user_database The new upgrade user database name.

to_user_dbo_login A String containing the new empty user database owner’s login
name.

to_user_dbo_password A String containing the new empty user database owner’s login
password.

to_user_rw_login A String containing the empty user database read/write login
name.

to_user_rw_password A String containing the new empty user database read/write login
password.

to_user_connect_options This is only required for Oracle where the parameters are:
(HOST=host;SID=sid; server_ver=server_version_number;
client_ver=client_version_number).

[tcpip,ipx,netbios,
namedpipes]

These are optional parameters for specifying networks.

[host1,host2,...] These are optional parameters for identifying multiple host
machines.
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Sample data by vendor type

The following table provides example command line input parameters by
database type.

Parameter Access SQL Anywhere MS SQL Oracle DB2

db_vendor MS_ACCESS SQL_ANYWHERE SQL_SERVER ORACLE DB2

server “” (Empty
String)

database server
name

host name SQL*Net alias not required

database full path to the
schema
repository
database

full path to the
schema repository
database

schema
repository
database
name

schema repository
database name

schema
repository
database
alias

dbo_login admin admin db owner user
name

db owner user
name

db owner
user name

dbo_password admin admin db owner
password

db owner password db owner
password

rw_login admin admin read/write
owner user
name

read/write owner
user name

db owner
user name

rw_password admin admin read/write
owner
password

read/write owner
password

db owner
password

ro_login admin admin read only
owner user
name

read only owner
user name

db owner
user name

ro_password admin admin read only
owner
password

read only owner
password

db owner
password

connect_options ““ ““ ““ HOST=host
SID= sid
SERVER_VER=8.0
CLIENT_VER=7.0

““
Some helpful utilities 137



cqin.book Page 138 Thursday, October 4, 2001 4:07 PM
Troubleshooting tips
Warning: Your database upgrade will fail if any of the following conditions

apply:

■ You currently have a ClearQuest schema checked out.

Solution: Check in your ClearQuest schema.

■ You currently have your ClearQuest database locked.

Solution: Unlock your database. For instructions on how to unlock your
database, see “Unlocking databases” on page 133.

■ You have customized your schema to include Record Types or fields that
have a ratl_ prefix. The prefix ratl_ is a system owned prefix name for both
record type and field names; you will no longer be able to create using this
as a prefix.

Solution: Contact Rational Technical Support. They will walk you through
the process to correct this condition.
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