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Preface
This manual provides an overview of the typical tasks that an administrator needs to 
perform to set up a Rational Suite environment. This manual describes some topics in 
more detail and provides pointers to other resources.

This manual replaces Configuring Rational Suite and Using the Rational Administrator.

Audience

This guide is intended for Rational Suite administrators.

Other Resources

■ All manuals are available online, either in HTML or PDF format. The online 
manuals are on the Rational Solutions for Windows Online Documentation CD. 

■ To send feedback about documentation for Rational products, please send e-mail 
to techpubs@rational.com.

■ For more information about Rational Software technical publications, see: 
http://www.rational.com/documentation. 

■ For more information on training opportunities, see the Rational University Web 
site: http://www.rational.com/university.

■ For articles, discussion forums, and Web-based training courses on developing 
software with Rational Suite products, join the Rational Developer Network by 
selecting Start > Programs > Rational Suite > Logon to the Rational Developer Network.
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Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Technical Support as follows:

Note:  When you contact Rational Technical Support, please be prepared to supply the 
following information:

■ Your name, company name, telephone number, and e-mail address

■ Your operating system, version number, and any service packs or patches you 
have applied

■ Product name and release number

■ Your case ID number (if you are following up on a previously reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4546-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
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1Setting Up a Rational 
Suite Environment
This chapter describes the tasks to perform to set up a Rational Suite environment 
when:

■ You are installing Rational Suite for the first time on your network.

■ You are upgrading from an earlier version of Rational Suite.

This chapter does not provide instructions for performing each task; rather, it gives an 
overview of the tasks and tells you where you can find more information.

Rational Suite Installation Guide for the First Time

When you install Rational Suite for the first time, you perform these tasks:

■ Plan network resources.

■ Configure licenses.

■ Install Rational Suite software on servers.

■ Configure servers and files.

■ Configure integrations.

■ Install Rational Suite software on clients.

Plan Network Resources

During planning, you work in these areas, as described in this section:

■ Planning for UCM (Unified Change Management).

■ Designating servers.

■ Developing a database plan.

■ Configuring databases.

■ Configuring security.
13



Planning for UCM

Unified Change Management is the Rational Software process of managing change in 
software development from requirements to release. Configuring a network to work 
with UCM requires special considerations. If you plan to use UCM in your 
development environment, see Using Unified Change Management with Rational Suite.

Designating Servers

Before you install Rational Suite, you need to determine which computers you will 
use as servers. Servers need to be highly available, and may need extra memory and 
disk space. Table 1 describes types of servers you may want to include in your 
environment. Note that you may be able to combine several servers on one computer.

Table 1 Servers Used with Rational Suite

Type of Server Description

License server If you use floating licenses, you need to set up a server to administer 
the licenses. For more information, see Rational Suite License 
Management Guide.

Web server Some Rational tools include a Web component. You can set up a Web 
server for these tools:
■ ClearCase LT. See Rational ClearCase LT Administrator’s Guide.
■ ClearQuest. See Rational ClearQuest Installation Guide.
■ RequisitePro. See Rational RequisitePro Installation Guide.
■ Rational Test. See Rational Robot, Rational TeamTest, and Rational 

TestManager Installation Guide.

Database server If you are using commercial databases with Rational Suite products, 
you probably want to install those databases on dedicated servers. 
See Developing a Database Plan on page 15.

ClearCase LT server ClearCase LT is a client/server product. To use a ClearCase LT client, 
a ClearCase LT server must be installed in the same network domain 
as the clients. A client can work with exactly one server. For 
guidelines about selecting a ClearCase LT server system, see Rational 
ClearCase LT Installation Guide.

ClearQuest 
administrator’s system

To use ClearQuest, you need to designate one computer as the 
administrator’s system. See Rational ClearQuest Installation Guide.
14 Chapter 1 - Setting Up a Rational Suite Environment



Developing a Database Plan

For each Suite product you are using, you need to decide which database 
management system to use with Rational Suite. Table 2 summarizes choices based on 
the size of the user group planned for each product. 

Table 2 Commercial Database Choices

Microsoft Access Runtime is automatically installed when you install at least one 
Rational Suite product on your computer. (The Access development environment is 
not installed.) Also, Sybase SQL Anywhere is available on the product CD, but it is 
configured to work only with Rational products.

When using Oracle or SQL Server for storing RequisitePro projects, there may be 
multiple projects within one SQL Server database or one Oracle schema.

Concurrency is determined by the total number of current users accessing the 
database or schema, regardless of the number of RequisitePro projects.

Database performance depends on factors such as: number of users, network 
response time, number of records in the database, and database tuning. Refer to 
product documentation for more details about each choice.

Rational Suite Installation Guide, included with your Rational Suite media kit, provides 
an overview of the installation, configuration, and administration of different 
database management systems, particularly for use with ClearQuest.

Rational ClearQuest Rational RequisitePro Rational Test

Microsoft Access
Fewer than 7 
concurrent users

5 or fewer concurrent 
users per RequisitePro 
project

No more than one 
concurrent user

Sybase SQL 
Anywhere Server

5 to 20 concurrent 
users

N/A One or more 
concurrent users

Microsoft SQL 
Server

More than 20 
concurrent users

6 or more concurrent 
users per database

N/A

Oracle More than 20 
concurrent users

6 or more concurrent 
users per schema

N/A

IBM DB2 More than 20 
concurrent users

N/A N/A
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Configuring Databases

For Rational products that work with commercial databases, install and configure 
those databases before installing Rational products. 

Configuring Security

You set security for some Rational Suite products by using the Rational Administrator 
to set up authorization for users and groups. However, you set most security 
parameters through individual point products.

Table 3 provides an overview of how to set up security in each Rational tool.

Configuring Licenses

Rational Suite uses Rational Common Licensing Services. Before installing Rational 
software, decide what types of licenses you want to use and, if necessary, configure 
licenses for the software you will install. For more information about licensing, see 
Rational Suite License Management Guide, included with your Rational Suite media kit.

Installing Rational Suite Software on Servers

Use the Rational Software Setup program to install Rational Suite on your network 
servers. The Rational Software Setup program allows you to install Rational Suite and 
other Rational Software products. 

For assistance while using the program, see the Rational Windows Setup Help.

Table 3 Summary: Setting Up Security for Rational Tools

Tool Comments

Rational ClearQuest The ClearQuest administrator uses the ClearQuest Designer to set up 
user and group access to the ClearQuest database. See Rational 
ClearQuest User’s Guide.

Rational 
RequisitePro

The RequisitePro administrator sets up RequisitePro users and groups 
by setting project security for the RequisitePro database. See Rational 
RequisitePro User’s Guide.

Rational Rose Rational Rose does not support user lists. To set security for Rose, 
secure the directory containing the Rose models.

Rational Test Use the Rational Administrator to add users and groups to the test 
datastore. See Managing Test Users and Groups on page 39.

Rational Project Supply an optional password to secure the Rational project. See 
Creating the Rational Project on page 28.
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Installing Rational ClearCase LT 

To use ClearCase LT, you must have a ClearCase LT server installed and configured. 

If you want to use your ClearCase LT server as a client computer as well, follow these 
guidelines:

■ Install ClearCase LT server on the computer before installing Rational Suite.

■ Install ClearCase LT server before you install ClearCase LT clients. This enables 
you to specify the server name during client install, rather than having to 
configure a pointer to the server at a later time.

Configuring Servers and Files

After you install Rational software, perform other tasks to configure the servers, 
including Web servers, and files that you will use with Rational tools. Table 1 on 
page 14 lists the types of servers that you may need to configure. Rational Suite 
Installation Guide provides an overview of procedures to follow after you install 
Rational software. 

Configuring Integrations

Configure integrations that you plan to use, as described in Table 4.

Table 4 Rational Suite Integrations

Integration Comment

Rational project A Rational project associates datastores from Rational products, 
enabling integrations across Rational Suite. For an overview, see 
Creating the Rational Project on page 27.

UCM UCM is a process related to configuration management. Tool 
support for UCM is included in Rational ClearCase and Rational 
ClearQuest. See Using Unified Change Management with Rational Suite.

UCM and ClearQuest To learn about requirements for adding ClearQuest to a 
UCM-enabled project, see the “Enabling ClearQuest for UCM” 
chapter in Rational ClearQuest Administrator’s Guide. 

RequisitePro and 
ClearQuest

This integration allows you to link defect and enhancement requests 
to requirements, allowing you to trace back to a report’s origin. See 
Configuring the Integration for ClearQuest and RequisitePro on page 45.

Integrations with 
ClearQuest

To learn about configuring integrations that work with ClearQuest, 
see the “ClearQuest Schemas and Packages” chapter in Rational 
ClearQuest Administrator’s Guide.
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Installing Rational Suite Software on Client Computers

After you set up the server environment for Rational Suite, you can install Rational 
software on client computers. The Rational Suite Installation Guide contains more 
information, including information about prerequisites, how to install on a client 
computer, and activities to perform after you install.

Upgrading from an Earlier Release

When you upgrade from an earlier release of Rational software, you need to perform 
updates to related software, including databases and datastores for Rational products. 
You may also need to upgrade the commercial database you are using. General steps 
are as follows:

1 Back up existing data. Make sure that you keep a safe copy of your data so that 
you can revert to it if you run into problems during the upgrade.

2 If necessary, upgrade the databases used for your data. Depending on the database 
you have decided to use, there may be a newer version available.

3 Install the new version of Rational software and perform other upgrade tasks. 

For more information, read “Upgrading from Earlier Versions of Rational Suite” in 
Rational Suite Installation Guide. 

Extended Help Extended Help, available from all Rational Suite tools, allows you to 
view relevant topics in the Rational Unified Process, depending on 
the context from which you start. You can also customize Extended 
Help to include information relevant to your team. See Working with 
and Configuring Extended Help on page 63.

Integrations with 
RequisitePro

To learn about configuring integrations that work with RequisitePro, 
see the “Integrating with Other Products” chapter in Rational 
RequisitePro User’s Guide.

Table 4 Rational Suite Integrations (continued)

Integration Comment
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2Understanding a Rational 
Project
This chapter provides background information about Rational projects so you can 
work with them more effectively. This chapter helps you understand:

■ The structure of a Rational project 

■ Unified Change Management (UCM), in the context of a Rational project

■ The Rational Suite artifacts that can be associated with a project, and the artifacts’ 
relationship to the Rational project

What Is a Rational Project?

A Rational project is a logical collection of databases and datastores that associates the 
data you use when working with Rational Suite. A Rational project consists of the 
following artifacts:

■ Zero or one RequisitePro project
■ Zero or one Test datastore 
■ Zero or one ClearQuest database
■ Unlimited Rose model files

You use the Rational Administrator to create a Rational Project. With the 
Administrator, you can optionally place these artifacts under configuration 
management using Rational ClearCase.

Why Work with Rational Projects?

Creating a Rational project allows you to take advantage of many of the integrations 
among Rational Suite tools. For example: 

■ From the Test Log window of the Rational Test Manager, you can generate a defect 
in ClearQuest.

■ You can associate RequisitePro requirements with Rational Test datastores.

■ You can associate Rose data models with RequisitePro requirements through all 
iterations of the model design.
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■ By associating a ClearQuest and RequisitePro database, you can tie defects to the 
requirements from which they originate.

What Is UCM?

Unified Change Management (UCM) is the Rational Software process of managing 
change in software system development from requirements to release. UCM spans the 
development lifecycle, defining how to manage change to requirements, design 
models, documentation, components, test cases, and source code.

UCM is unique because it links activities used to plan and track project progress with 
the artifacts that are undergoing change. An activity might arise from an issue raised 
in a meeting, a defect entered into a defect database, or a request for enhancement 
sent in by a customer. 

Many development teams use UCM to manage change to source code. You can also 
use UCM to manage change to these elements of a Rational project: RequisitePro 
projects, Rational Test datastores, and Rose model files.

You use the Rational Administrator to enable UCM to work with a Rational project; 
for complete information on using UCM with Rational Suite, see Using Unified Change 
Management with Rational Suite.

Understanding Rational Projects and Related Artifacts

This section describes each type of artifact you can associate with a Rational project 
and its relationship to the Rational project.

RequisitePro Projects

Using a Rational RequisitePro project, you can organize, prioritize, track, and control 
changing requirements. You can manage all of your software development project’s 
requirements — user requirements, software specifications, and use cases — using the 
RequisitePro database as a central repository. 

You itemize requirements within requirements documents, and then manage them 
using an integrated database. Each RequisitePro project consists of requirements 
documents and a dynamically-linked RequisitePro database. Your teams can 
collaborate, communicate, and provide updates on the same project. A RequisitePro 
project document can store text, graphics, or other objects (such as OLE objects) that 
identify project needs and are meaningful to users.
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There can be several RequisitePro projects within one RequisitePro database, each one 
associated with a separate Rational project. 

There can be only one Rational project associated with each RequisitePro project. If a 
RequisitePro project is associated with a Rational project, and you associate the same 
RequisitePro project with another Rational project, the association with the first 
Rational project will be removed.

Figure 1 shows the relationship of RequisitePro Projects to Rational Projects. 

Figure 1 The Relationship of RequisitePro Projects to Rational Projects

Read about setting up RequisitePro in Rational RequisitePro Installation Guide. Read 
about using RequisitePro in Rational RequisitePro User’s Guide. 

Test Datastores

ARational Test datastore is a collection of related test assets including test scripts, 
suites, datapools, logs, reports, test plans, and build information. 

People generally want to test and report on the work involved in a project through the 
same shared resources, for example, the same Test datastore or the same ClearQuest 
defect database. There can be only one Test datastore for each Rational Project.

RequisitePro
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Project
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Each test artifact in a test datastore can be associated with at most one RequisitePro 
project. However, a test datastore can contain artifacts that point to different 
RequisitePro projects. So, for example, you can associate requirements from many 
RequisitePro projects with test cases in the same Test datastore.

Figure 2 shows the relationship between a Test datastore and a Rational project. 

Figure 2 Relationship Between a Test Datastore and a Rational Project

See Rational TestManager User’s Guide for more information.

ClearQuest Databases

Rational ClearQuest is a change request management tool that helps you track and 
manage all change activities (such as defects and enhancement requests) associated 
with a Rational project. When used with other tools in the Rational Suite, ClearQuest 
can play an important role in supporting change and defect management in an 
iterative software development environment.

A Rational ClearQuest database consists of a schema repository and a user database:

■ The ClearQuest schema repository stores all schemas and all system data 
associated with existing schemas. The schema repository does not store any user 
data. 
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Artifact

Test
Artifact

RequisitePro RequisiteProRational
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■ A ClearQuest user database contains all user data and a copy of the schema 
associated with the database. User data in a ClearQuest database includes 
change-request records (such as defects), as well as reports, records or tables, and 
all data entered by users. 

One ClearQuest database can be used by multiple Rational projects.

Figure 3 shows the relationship between a ClearQuest database and a Rational project.

Figure 3 Relationship Between a ClearQuest Database and a Rational Project

For a detailed overview of ClearQuest, see Rational ClearQuest Introduction.

Rose Model Files

Rational Rose enables visual modeling of architectures, components, and data using 
the Unified Modeling Language (UML). From a Rose model, you can automatically 
implement the framework of your code in a number of popular languages. Rose also 
helps you maintain consistency between a software model and its implementation in 
code. A Rational project can be associated with an unlimited number of Rose models.

Figure 4 shows the relationship between Rose models and a Rational project.
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Figure 4 Relationship Between Rose Models and a Rational Project

Relating Rational Artifacts to a Rational Project

Figure 5 shows the possible relationships between a Rational project and associated 
artifacts. Multiple instances of the Rational project indicate that more than one project 
can be associated with the attached artifact.
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Figure 5 Relationship Between Rational Artifacts and a Rational Project
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3Creating and Configuring 
a Rational Project
This chapter shows you how to create and configure a Rational project.

Creating the Rational Project

To create a Rational project, perform the following steps as described in the remainder 
of this section:

1 Decide where to locate the project.

2 Create a shared directory in which you will store the project.

3 Create the project.

A later section describes how to configure a project.

Deciding Where to Locate the Project 

Determine where the project will reside, following these guidelines:

■ The Rational project contains only pointers to the Rational Suite tools’ databases. 
Therefore, these databases can reside anywhere on your network system.

■ Before proceeding, create the top-level directory of the project. Make sure the 
directory is empty and make it a shared directory. Read about Creating a Shared 
Directory on page 27. If you do not share the directory, the project will not be 
available to members of your team.

■ If you are using UCM, there may be special considerations for locating the 
Rational project. See Using Unified Change Management with Rational Suite.

Creating a Shared Directory

Before you create the Rational project, create a share name pointing to the directory 
that will contain the project’s files:
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1 Create a directory on the computer where you will create the Rational project. 
Choose an area that is not under version control. In other words, the area should 
not be part of a VOB. 

2 Create a share name pointing to the directory you created in Step 1:

a In Windows Explorer, navigate to the directory and select the directory name.

b Click File > Sharing .

3 On the directory’s Properties page, on the Sharing  tab:

a Select Shared As .

b In the Share Name field, enter a meaningful name describing the directory, for 
example, rational-project.

c Click OK.

Now, users and other programs can get access to these project views by using a UNC 
pathname, for example, \\computer name\rational-project.

Creating the Rational Project

To create a Rational project, perform the following steps:

1 Start the Rational Administrator: click Start , then click Programs > Rational Suite > 
Rational Administrator . 

2 Start the New Project Wizard by clicking File > New Project  on the Administrator 
menu. 

3 On the wizard’s first page:

a Supply a name for your project, for example, revenue. The dialog box prevents 
you from typing illegal characters.

b In the Project Location field, specify a UNC path to the root of the project, 
referring to the share name you created in Creating a Shared Directory on 
page 27. For example, \\computer-name\rational-project\revenue. Make sure that 
you specify a path that is at least in a subdirectory of the share; in this example, 
rational-project is the share, so you need to specify a directory at least one level 
lower. 

c Clear the check box Use ClearCase and Unified Change Management to baseline 
project assets  because you aren’t working with a UCM-enabled project.

4 If you do create a password for the Rational project, supply the password on the 
Security page. If you do not create a password, then leave the fields blank on this 
page.
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5 On the Summary page, select Configure Project Now . The Configure Project dialog 
box appears.

Configuring the Rational Project

To configure a Rational project, you associate the project with the following artifacts:

■ Zero or one RequisitePro project
■ Zero or one Test datastore 
■ Zero or one ClearQuest database
■ Unlimited Rose model files

If the Configure Project dialog box is not already started, display it as follows:

1 In the Rational Administrator, select the project you want to configure and click 
File > Connect . Supply a password if one is required. 

2 Select the project to configure and click File > Configure Project . The Configure 
Project dialog box appears as shown in Figure 6.

Figure 6 The Configure Project dialog box
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Working with ClearQuest MultiSite

Using ClearQuest MultiSite, you can share access to a ClearQuest database between 
multiple sites. However, one site must have ownership, or “mastership,” of the 
database.

If ClearQuest MultiSite is installed, you can only configure Rational projects if the site 
has mastership of the RA_Project record. 

You must set up integrations individually for each database at each different site. You 
can enable the integration with the originating ClearQuest schema repository and 
user database, or with a local replica. To integrate with any ClearQuest database, that 
database must have mastership of the RA_Project record and of the ClearQuest 
records you want to associate.

To ensure proper set up of ClearQuest MultiSite, ensure that the RA_Project record 
type mastership is not shared between sites.

Associating Requirements

A RequisitePro project organizes and helps you manage a related set of requirements. 
Each RequisitePro project includes a requirements database, documents, discussions, 
histories, and other management-related and administrative items.

You can create a new RequisitePro database or associate an existing database.

Creating a New RequisitePro Project

To create a new RequisitePro project:

1 On the Configure Project dialog box, click Create  in the Requirements Assets area. 
RequisitePro displays the Create Rational RequisitePro Project dialog box.

2 Select a Project Template, for example, Use-Case Template, then click Create . 

3 On the Project Properties dialog box:

a In the Name field, specify a name for the RequisitePro project.

b In the Directory  field, use a UNC pathname to specify the location where you’d 
like the requirements to reside. For example, you might specify: 
\\computerA\project-directory\requirements. 

c In the Database field, specify the type of database you plan to use with your 
RequisitePro project. You configured this database in Configuring Databases on 
page 16. 

d Optionally, provide a comment describing the RequisitePro project.
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e Click OK. RequisitePro creates the project.

Associating an Existing RequisitePro Project with the Rational 
Project

To associate an existing RequisitePro project with your project, perform these steps:

1 On the Configure Project dialog box, click Select  in the Requirements Assets area. 
The Select RequisitePro Project File dialog box appears.

2 Navigate to the RequisitePro project file you want to associate with the Rational 
project.

Associating a Test Datastore

A Rational Test datastore is a collection of related test assets, including test scripts, 
suites, datapools, logs, reports, test plans, and build information. 

You can create a new Test datastore or associate an existing Test datastore.

Creating a New Test Datastore

To create a new test datastore:

1 On the Configure Project dialog box, click Create  in the Test Assets area. The 
Create Test Datastore tool appears. 

2 On the Create Test Datastore dialog box:

a In the New Test Datastore Path  field, use a UNC pathname to specify an area 
where you’d like the tests to reside. For example, you might specify: 
\\computerA\project-directory\tests.

b Select initialization options as appropriate. 

c Click Advanced Database Setup  and select the type of database engine for the 
Test datastore.

d Click OK. 

Associating an Existing Test Datastore with the Project

To associate an existing test datastore with your project:

1 On the Configure Project dialog box, click Select  in the Test Assets area. The Select 
Test Datastore dialog box appears.

2 Navigate to the Test datastore you wish to associate with the Rational project, or 
enter the UNC pathname where the Test datastore resides.
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Associating a ClearQuest Database

Rational ClearQuest is a change request management tool that helps you track and 
manage all the change activities (such as defects and enhancement requests) 
associated with a Rational project.

To enable Rational Suite integrations, ensure that you perform the following steps:

■ Create the default database set connection.

■ Associate the ClearQuest database with the Rational project.

Creating the Default Database Set Connection

To enable Rational Suite integrations, the user database and schema repository must 
be associated with the default database set, 2002.05.00. 

If the database you want to associate with the Rational project has a connection name 
other than the default connection name 2002.05.00, perform the following steps to 
rename the existing connection name to the default connection name:

1 Start the ClearQuest Maintenance Tool from the Rational Administrator by 
clicking Tools > Rational ClearQuest Maintenance Tool . The Rational ClearQuest 
Maintenance Tool appears.

2 In the left pane of the ClearQuest Maintenance Tool, select the database set 
connection name you need to rename.

3 Click Connection > Rename .

4 Type 2002.05.00 to rename the connection, and press Enter to exit edit mode. The 
connection is renamed.

Associating a ClearQuest Database with the Rational Project

Perform the following steps to associate an existing ClearQuest user database with the 
Rational project:

1 Follow the steps in Configuring the Rational Project on page 29 to display and work 
with the Configure Project dialog box.

2 In the Configure Project dialog box, click Select  in the Change Requests area. 

3 Navigate to the ClearQuest user database you created.
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Associating Rose Models

Rational Rose enables visual modeling of architectures, components, and data, 
automating the process of maintaining consistency between a software model and its 
implementation.

Before you associate Rose models with the project, read Establishing a Virtual Path Map 
in Rose on page 33.

Establishing a Virtual Path Map in Rose

Rose maintains internal absolute pathnames to models and parts of models. This 
means that to share a Rose model with another developer, you need to use exactly the 
same paths, including drive letters, to get access to the same Rose model. To work 
around this restriction, set up a virtual path map as follows:

1 Start Rose: click Start , then click Programs > Rational Suite > Rational Rose .

2 Open the Rose model you will be working with.

3 From the Rose menu, choose File > Edit Path Map  to display the Virtual Path Map 
dialog box.

4 On the Virtual Path Map dialog box:

a In the Symbol field, type CURDIR.

b In the Actual Path field, type &.

c Click Add .

The following line appears in the Virtual Symbol to Actual Path Mapping list:

$CURDIR =&

d Click Close .

5 Quit Rose.

6 Start Rose again, open the Rose model, and quit Rose. 

For more information about virtual path maps, view the Rose help for the Virtual Path 
Map dialog box.

Associating Rose Files with the Rational Project

To associate an existing Rose model with the Rational project:
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1 On the Configure Project dialog box, click Add  in the Models area. The Add Rose 
Model dialog box appears.

2 Navigate to the Rose model you will be working with.
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4Working with a Rational 
Project
This chapter describes additional administrative tasks you may want to perform 
while working with a Rational project.

Connecting to a Rational Project

You must connect to a Rational project before you can configure it, or delete it, or 
manage Rational Test users and groups. After you connect to a Rational project, you 
can view the properties of the associated datastores, projects, and databases.

To connect to a Rational project:

1 From the Rational Administrator menu, click File > Connect .

2 A list of all Rational projects that are not already connected appear in the Connect 
dialog box. Select the project you want to connect to and click OK. 

3 If necessary, enter the Rational project’s password and click OK.

Registering a Rational Project

If you plan to administer a Rational project on a computer other than the one on 
which it was created, register the project after creating and configuring it. You register 
the Rational project on the same computer you used to create and configure the 
project.

1 From the Rational Administrator menu, click File > Register Project .

2 In the Select Rational Project dialog box, navigate to the location of the Rational 
project and click Open .

After a project is registered, the project name appears in the project hierarchy in the 
Rational Administrator’s left pane.
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Unregistering a Rational Project

After there is no longer a need to administer a Rational project from a computer other 
than the one on which it was created, remove the project name and details from the 
Rational Administrator by unregistering the project. Unregistering a Rational project 
does not delete a Rational project. After you unregister a project, you can register it 
again and resume using it.

1 From the Rational Administrator menu, click File > Unregister Project .

2 Select the project to unregister and click OK. 

Working with the Properties of a Rational Project

While you are working with a Rational project, you can display and edit the project 
name and password by performing the following steps:

1 Connect to the Rational project. See Connecting to a Rational Project on page 35.

2 Click Edit > Properties .

The General tab allows you to view, but not edit, the Rational project name and 
location.

The Security  tab allows you to modify the Rational project’s password.

3 View or modify properties and click OK .

4 For changes to take effect:

a Disconnect from the project.

b Connect to the project.

Disconnecting from a Rational Project

After you finish working with a Rational project, disconnect from the Rational project. 
Disconnecting from the project, followed by reconnecting to the project, allows you to 
view changes you may have made to project properties.

1 From the Rational Administrator menu, click File > Disconnect .

2 A list of Rational projects that are registered and connected appear in the 
Disconnect dialog box. Select the Rational project from which to disconnect and 
click OK.
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Deleting a Rational Project

There may be times when you wish to delete a Rational project. As artifacts that are 
associated with the Rational project become obsolete or change location, it may be 
easier to delete the project and create a new one.

Before you delete a Rational project:

■ Consider carefully the effects of deleting the project. Are there any integrations 
between Rational Suite artifacts that need to be preserved? Do you have a recovery 
plan in place, if needed?

■ Communicate your intention to delete the project with all members of your team, 
especially those responsible for maintaining other Rational products.

■ Make a backup copy of the Rational project. See the Backup and Restore Whitepaper 
for Rational Software for information on how to backup a Rational project.

When you delete a Rational project:

■ The project is unregistered.

■ The associations among the various projects, datastores, and databases are 
removed, but the artifacts themselves are not removed.

■ The project is permanently deleted.

To permanently delete a Rational project, follow these steps:

1 From the Rational Administrator, select the project you want to delete in the 
project (left) pane.

2 From the menu, click File > Delete Project .

3 To delete the project, click OK.

Working with ClearQuest MultiSite

If ClearQuest MultiSite is installed, you can only delete Rational projects if the site has 
mastership of the RA_Project record. 

You must set up integrations individually for each database at each different site. You 
can enable the integration with the originating ClearQuest schema repository and 
user database, or with a local replica. To integrate with any ClearQuest database, that 
database must have mastership of the RA_Project record and of the ClearQuest 
records you want to associate.

To ensure proper set up of ClearQuest MultiSite, ensure that the RA_Project record 
type mastership is not shared between sites.
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Working with SQL Anywhere Functions

From the Rational Administrator, you may access Sybase Central and ISQL, Sybase 
tools that enable you to work with a SQL Anywhere database.

Sybase Central 

Use the Sybase Central tool to perform Sybase SQL Anywhere functions, such as 
creating, backing up, and compressing a SQL Anywhere database.

To use the Sybase Central tool, click Tools  > Sybase Central .

ISQL

Use the ISQL tool to generate interactive SQL queries on an SQL Anywhere database.

To use the ISQL tool, click Tools >  ISQL.

For more information about using Sybase Central or ISQL, see the Sybase Central 
database management tool Help.
38 Chapter 4 - Working with a Rational Project



5Managing Test Users and 
Groups
This chapter provides information about Rational Test users and groups. This chapter 
helps you:

■ Understand the structure of Rational Test users and groups

■ Administer Rational Test users, groups, and assets

Understanding Rational Test Users and Groups

This section describes Test users and groups. This information is a prerequisite for 
administering Test users, groups, and associated assets.

Test Users

Test users are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage test 
scripts.

For each test user, you can specify:

■ User ID
■ Password
■ First name
■ Last name
■ Company
■ Title
■ Department
■ Phone number
■ E-mail address

You can set the Rational Test datastore privileges for a test user to create, modify and 
delete:

■ Test planning assets
■ Test implementation assets
■ Test execution assets
■ Test results analysis assets
39



Test Groups

You set privileges for groups of users (called test groups), then assign privileges to each 
user by adding the user to a test group. When you add a test user to a test group, the 
test user acquires the privileges of that test group. A test user can be a member of one 
or more test groups. 

You can define any test group as a default group, and you can also create multiple 
default groups. Every test user that you create acquires the privileges of the default 
groups.

When you create a Rational project using the Rational Administrator, a Test Users 
folder and a Test Groups folder is created by default. This folder appears in the left 
pane of the Rational Administrator window, under the Rational Test datastore object.

Admin Test User

When you create the Rational Test datastore, the Admin Test User is also created. The 
Admin Test User is located within the Test Users folder. The Admin Test User is not a 
member of any specific test group and takes on all available privileges.

The Admin Test User can:

■ Create, modify, and delete test assets, reports, builds and logs.

■ Customize test assets and builds.

Admin Test Security

There is no default password for the Admin Test User. You can log in as an Admin 
Test User without using a password. This lets you log into any Rational Test 
component after you first install the software.

When you connect to a project for the first time, you should define a password for the 
Admin Test User to prevent unauthorized access. The Admin Test User always has 
full test user access privileges and cannot be deleted from a project.

Administering Test Users and Groups

Use the following procedures to administer and maintain users and groups for the 
Rational Test datastores you have defined.

Adding a Test Group or Test User

You must have Admin Test User privileges to add a Test group or Test user. To add a 
test group or test user to a Rational Test datastore:
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1 Use the Rational Administrator to connect to the project. From the Rational 
Administrator menu, click File > Connect . Select the project name and click OK. 

2 To add a Test group:

a Click Insert > Test Group . 

b A dialog box displays a list of all connected projects. Select the project to add a 
test group to, and click OK.

The Insert Test Group dialog box opens.

c Type a name and description for the group.

d Optionally, click Set as default group  to set a test group as a default group for all 
test users you will add to the project. 

e Set the privileges for the Test group by selecting or clearing the appropriate 
check boxes. 

➑ Write Privileges  – Select the appropriate check boxes to give privileges to a 
group to create, modify, or delete Test planning assets, Test implementation 
assets, Test execution assets, and Test results analysis assets. 

➑ Administration Privileges  – Select the appropriate check boxes to give 
privileges to a Test group to customize Test assets. Test assets include scripts 
and suites.

See Table 5 for examples of types of Test assets.

Table 5 Examples of Test Assets

f Click OK.

3 To add a Test user:

Test Asset Types Examples

Test planning assets Test plans and iterations of plans

Test implementation 
assets

Tools used in the implementation of test plans

Test execution assets Suites, computers, and computer lists

Test results analysis 
assets

Build results, test log folders, and test logs
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a Click Insert > Test User . 

b A dialog box displays a list of all connected projects. Select the project to add a 
Test user to, and click OK.

The Insert Test User dialog box opens.

c On the General tab, type the user’s information.

d On the Groups tab, add to or remove users from the available groups.

e Click OK.

Modifying a Test Group or Test User

You must have Admin Test User privileges to modify a test group. To modify existing 
test group information:

1 From the Rational Administrator menu, connect to the project. Click File > 
Connect . Select the project name and click OK. 

2 If Test Groups or Test Users are not listed in the left pane of the main window, 
double-click the Rational Test datastore object.

3 If the test group or user that you want to modify is not listed, double-click Test 
Groups or Test Users, respectively, to display all groups or users.

4 Select the test group or test user to modify.

5 Click Edit > Properties .

6 Change the test group or test user information on the appropriate tabs. 

7 Click OK.

Deleting a Test Group or Test User

When you delete a test group, you delete the group privileges for any test users in the 
deleted group. Deleting a Test group does not delete Test users. 

To delete a test group or test user from a Rational Test datastore:

1 Use the Rational Administrator to connect to the project. From the Rational 
Administrator menu, connect to the project. Click File > Connect . Select the project 
name and click OK. 

2 If Test Groups or Test Users are not listed in the left pane of the main window, 
double-click the Rational Test datastore object.

3 If the test group or test user that you want to delete is not listed, double-click Test 
Groups or Test Users to display all groups or users respectively.
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4 Select the test group or test user to delete, then click Edit > Delete . 

The Rational Administrator prompts you to confirm the deletion. 

5 Click Yes.

Changing a Password for a Test User

Follow these steps to change a password for a test user:

1 In the left pane of the Rational Administrator main window, double-click Rational 
Test Datastore .

2 Double-click Test Users  to display all test users.

3 Select the user name of the password that you want to change.

4 Click Edit > Properties .

5 On the General  tab of the Properties box, select the original password in the 
Password  box, then type a new password.

Passwords are alphanumeric strings (ASCII characters only) of up to 20 characters 
and are case-sensitive. Non-ASCII characters, such as accented letters, are not 
supported in the password field.

6 Click OK.
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6Configuring the 
Integration for ClearQuest 
and RequisitePro
This chapter provides the steps for configuring the integration of Rational ClearQuest 
and Rational RequisitePro. This integration allows you to associate ClearQuest 
enhancement request and defect records with Feature requirements in RequisitePro. 
The majority of the administrative tasks involve configuration of ClearQuest, so we 
strongly recommend that the Rational tools administrator have ClearQuest 
administration experience.

To learn about using the integration between RequisitePro and ClearQuest, refer to 
the Let’s Go AnalystStudio application provided with your software.

Overview of the Configuration Process

When configuring the integration, you perform the following steps:

1 Verify the configuration.

2 Configure a ClearQuest schema. 

3 Configure a RequisitePro project.

4 Configure a Rational project.

5 Set up the integration mapping.

6 Optionally, customize your integration.

If you are enabling the integration for the first time, Rational provides components to 
help you get started. These preconfigured components are:

■ Rational ClearQuest database schemas
■ Rational RequisitePro project templates
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How to Use this Chapter

Verifying the Configuration Settings

This section describes the minimal configuration settings you need before you 
configure the integration between ClearQuest and RequisitePro. Most project 
templates and schemas supplied by Rational already use these minimal configuration 
settings as defaults and require no action on your part. 

However, if you have created your ClearQuest database using a custom schema or the 
Blank schema, your ClearQuest database may lack the record types, actions, and states 
necessary for the integration. Similarly, if you created your RequisitePro project using 
a custom template or the Blank template, your project may lack the appropriate 
requirement type and attributes necessary for the integration. 

Deciding Whether to Customize the Configuration Settings

If your ClearQuest schema or RequisitePro project does not conform to the standard 
record and requirement types in this section, choose one of the following sets of steps. 

■ Create the appropriate record types, actions, states, and requirement types that 
match the default settings in the ASCQISetup.bat file, as described in this section. 
For additional information on these default settings, refer to ASCQISetup.exe 
Command Argument Descriptions on page 60. 

If you are Then

Installing Rational Software for the first 
time.

Follow the instructions in this chapter.

Upgrading from an earlier version of 
Rational Software and configuring this 
integration for the first time.

Ensure that you have followed the 
instructions in “Upgrading from Earlier 
Versions of Rational Suite” in the Rational 
Suite Installation Guide, then follow the 
instructions in this chapter.

Upgrading from an earlier version of 
Rational Software and you configured this 
integration in that earlier version.

Ensure that you have followed the 
instructions in “Upgrading from Earlier 
Versions of Rational Suite” in the Rational 
Suite Installation Guide. That chapter 
describes how to upgrade the existing 
configuration between RequisitePro and 
ClearQuest. 
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■ Revise the ASCQISetup.bat file to reflect your custom record types, actions, states, 
and requirement types. In this case, skip the following sections regarding the 
default integration settings and refer to Customizing Your Integration on page 58. 
Plan your custom integration thoroughly before proceeding to configure your 
schema. When your customizations are properly reflected in the ASCQISetup.bat 
file, proceed to configure your schema as described in Configuring a ClearQuest 
Schema on page 48.

ClearQuest Minimal Configuration Settings

To confirm that your schema conforms to the default integration settings: 

1 Verify that your schema has the following record types:

❑ A Defect record type with a Submit form and a Record form.

❑ An EnhancementRequest record type with a Submit form and a Record form.

2 Verify that each record type has the following actions of the appropriate type:

3 Verify that the state transition charts are appropriately updated to reflect your 
actions.

For more information on how to create record types, actions, and states in ClearQuest, 
refer to ClearQuest Designer Help.

RequisitePro Minimal Configuration Settings

The RequisitePro project must have at least one requirement type with at least one 
attribute. To conform with the default information in the ASCQISetup.bat file, 
configure the requirement type and attributes according to the following procedure:

1 Create one requirement type with prefix FEAT. 

2 Give that requirement type two attributes of the ClearQuest Integration type: 
Defect and EnhancementRequest. 

Action Type

Submit State transition

Open State transition

Close State transition

Modify Modify
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For more information on how to create requirement and attribute types, refer to 
Working with Requirement Types in RequisitePro Help. For more information on how to 
enable custom requirement and attribute types in the integration, refer to Changing the 
Default RequisitePro Requirement Types on page 58.

Configuring a ClearQuest Schema

No schema configuration is necessary if you used one of the following Rational Suite 
schemas supplied with this release of your software when creating your ClearQuest 
user database:

■ Rational Suite AnalystStudio schema
■ Rational Suite DevelopmentStudio schema
■ Rational Suite Enterprise schema
■ Rational Suite TestStudio schema

If you used one of these schemas to create your user database, proceed to Configuring 
a RequisitePro Project on page 52.

Applying ClearQuest Packages

If your schema is not based on one of the Rational Suite schemas, apply the 
RequisitePro and Repository packages to enable the integration between RequisitePro 
and ClearQuest. These packages add fields, forms, and scripts to the schema to 
support the integration. 

Determining Which Packages Are Applied

Before applying the package, verify which packages have already been applied to 
your schema.

1 Launch the Rational ClearQuest Designer from the Start menu. Log on to your 
schema database with an administrator profile. The Open Schema window 
appears. Click Cancel.

2 Click View > Schema Summary. The Schema Summary dialog box appears.

3 Open the appropriate version of the schema in the folder.
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4 In the Associated Packages list, note whether the RequisitePro and Repository 
packages are present:

❑ If the Repository package is not present, apply the Repository package in the 
following procedure.

❑ If the RequisitePro package is not present, apply the RequisitePro package in 
the following procedure.

❑ If both packages are present, do not apply them again. Instead, proceed to 
Upgrading the Repository and RequisitePro Packages on page 50.

5 Click OK to close the Schema Summary dialog box.

Applying the Repository and RequisitePro Packages

To apply the Repository and RequisitePro packages: 

1 From the ClearQuest Designer menu, click Package > Package Wizard. The Package 
Wizard window appears.

2 In the Select a Package list, select the latest version of the Repository package. Click 
OK.

3 In the Package Wizard, click Next. Select your schema. Click Next again.

4 Select all record types that you will use in the integration. 

Note:  If a previous version of the Repository package has been applied, some 
record types in your schema may not appear because they have already been 
selected. We recommend that you select at least Defect and EnhancementRequest, if 
they are present.

5 Click Finish.

6 Repeat steps 1–6 for the RequisitePro package.

7 From the ClearQuest menu, select File > Checkin to check in the schema. Click OK 
after verifying your choice. Click OK again in the ClearQuest Checkin 
Confirmation dialog box.
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Upgrading the Repository and RequisitePro Packages

To confirm that all the packages in your schema are of the latest version, run the 
Upgrade Installed Packages tool. This tool automatically detects and upgrades all 
existing packages to the latest version. Take the following steps to upgrade existing 
packages to the most recent version.

1 Click Package > Upgrade Installed Packages. 

2 Select the appropriate schema from the list and click Next. The tool displays the 
packages that need to be upgraded.

3 Click Upgrade, then Exit, to complete the process.

Adding Required Schema Entries 

The integration between RequisitePro and ClearQuest requires a Back Reference field 
on your Requirements_List field for each of the record types you selected when you 
applied the RequisitePro package, such as Defect and EnhancementRequest. The name 
of this record type must match the Back Reference field name in the ASCQISetup.exe 
command line exactly. For more information on the ASCQISetup.exe command line, 
refer to ASCQISetup.exe Command Argument Descriptions on page 60.

To add a Back Reference field to your schema, do the following:

1 In the ClearQuest Designer, click File > Open Schema. The Open Schema dialog box 
appears.

2 Select the option Checkout a schema to edit.

3 Select your schema from the list and click Next. Click Finish.

4 In the schema browser, open the Record Types folder.

5 In a record type you selected when you applied the RequisitePro package, 
double-click Fields. The list of fields appears.

6 Right-click the Requirements_List field name and select Field Properties. The 
Properties dialog box appears. 
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7 At the Back Reference field, type the name of the appropriate record type, such as 
EnhancementRequests_List. This name must match the Back Reference field name 
in the ASCQISetup.exe command line exactly, as described in Adding Your 
Customizations to the ASCQISetup.bat file on page 59. For some schemas, this field 
may already contain a value. In some cases this field may be read-only. If so, no 
action is required.

Note:  If you enter a custom name at this field, you must edit the Back Reference 
field name in the ASCQISetup.exe command to match it, as described in Adding 
Your Customizations to the ASCQISetup.bat file on page 59. 

8 Close the Properties dialog box.

9 Repeat steps 5–8 for each of the record types you selected when you applied the 
RequisitePro package.

10 Click File > Check In. ClearQuest validates the schema and displays a Check In 
dialog box.

11 Type a comment describing the schema changes and click OK.

Applying the Changes to the ClearQuest User Database 

To apply the changes you have made to your packages to the ClearQuest user 
database:

1 Back up your database.

2 From the ClearQuest Designer menu, select Database > Upgrade Database and click 
Yes to continue. 

3 In the Upgrade Database window, select the database instance that is included in 
your Rational project. Click Next .

4 Select the latest version of the schema (the schema with the highest version 
number). Click Finish.

5 Click OK and close the ClearQuest Designer.

Your ClearQuest database is now upgraded to use the current integration between 
RequisitePro and ClearQuest.
Configuring a ClearQuest Schema 51



Maintaining Record Visibility

The ClearQuest record visibility feature allows you to limit access to certain 
ClearQuest records. This limited access applies to selected ClearQuest user groups, 
and is based on criteria defined by an administrator. The criteria specify that records 
are visible for a user group depending on the value of a specific ClearQuest reference 
field. To use the integration between RequisitePro and ClearQuest, RequisitePro users 
must have record visibility throughout the life of all integrated records.

We recommend that you define record visibility for user groups based on the value of 
the RAProject field, which is required for integration with RequisitePro. If you use 
this criterion, you preserve the integration between RequisitePro and ClearQuest, 
because you cannot change the value of the RAProject field without first removing all 
associations to RequisitePro requirements. In addition, this criterion ensures that all 
RequisitePro project users have visibility for the same ClearQuest records.

Using the Integration with ClearQuest MultiSite

To integrate with any ClearQuest database, that database must have mastership of the 
RAProject record and of the ClearQuest records you want to associate. To save time, 
we recommend you create a query that filters records in your database by 
mastership.Use it to screen records prior to associating them with requirements in the 
Associate [Attribute Type] dialog box. For more information on this dialog box, refer to 
RequisitePro Help.

A RequisitePro project may be associated with no more than one database at a time. A 
ClearQuest database may be simultaneously associated with multiple RequisitePro 
Projectseach record with only one requirement at a time, the ClearQuest database 
containing that record with multiple RequisitePro projects.

Note:  For more information, see Rational ClearQuest MultiSite Administrator’s Guide on 
the Rational Solutions for Windows Products Online Documentation CD.

Configuring a RequisitePro Project

This section describes the steps necessary to prepare your RequisitePro project for 
integration with a ClearQuest database. You do not need to take these steps if you 
created your project from one of the following project templates provided with the 
current release of RequisitePro:

■ Composite Template

■ Traditional Template

■ Use-Case Template
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If you used one of these templates to create your RequisitePro project, proceed to 
Configuring a Rational Project. If not, you must configure RequisitePro requirement 
types attributes to enable the integration. Refer to Changing the Default RequisitePro 
Project Attributes on page 58.

Configuring a Rational Project

If your ClearQuest database and RequisitePro project are already associated with a 
single Rational project, proceed to Setting Up the Integration Mapping on page 53.

If you are not upgrading a Rational repository or project, use the Rational 
Administrator to create a project. When configuring the Rational project, select the 
ClearQuest database and the RequisitePro project that you’ve configured for the 
integration. For more information, see Creating and Configuring a Rational Project on 
page 27.

Setting Up the Integration Mapping

To enable the integration of ClearQuest and RequisitePro, associate ClearQuest record 
types with RequisitePro requirement types. This association is created by editing and 
running a batch file. This section details the necessary steps.
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Collecting Setup Information

To enable the integration in your specific environment, edit the ASCQISetup batch file 
to reflect your configuration settings. This file contains the command arguments 
shown in Table 6. Use this table to record the values of each variable for your project. 
You will use this information to edit the batch file. 

Note:  If your installation spans multiple computers, use Universal Naming 
Conventions (UNC) paths, as noted in Table 6.
 

Table 6 Variables Describing Your Environment 

Batch Command Description Must Edit Your Values

set CQDatabaseName 
=user database name

The internal name of 
the ClearQuest User 
database (for 
example, SAMPL), 
available from the 
ClearQuest Designer 
menu View > 
Database 
Summary . 

You must edit this 
entry.

set H =hard drive letter The hard drive letter 
where RequisitePro 
is installed, followed 
by a colon (for 
example C:). This 
refers to the 
Administrator’s 
installation, not the 
client installation.

The default value is 
C. Edit this entry 
only if you installed 
RequisitePro on a 
drive other than the 
C drive.

set U = logon name The logon name for 
the ClearQuest 
database, the 
RequisitePro project, 
and the Rational 
Project. This logon 
name has Super User 
privileges.

By default, the logon 
name admin has 
Super User 
privileges for 
ClearQuest. If you 
are using a logon 
name other than 
admin for 
RequisitePro, 
ClearQuest, or the 
Rational Project, edit 
this field. 

set P = path The path to the 
administrator’s local 
Rational installation 
directory.

You must edit this 
field. 
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Editing the ASCQISetup.bat File

Now use the information in Table 6 to modify the ASCQISetup.bat file for your specific 
environment. The file is in the directory Install\Program Files\Rational\Common. The 
ASCQISetup.bat file is designed to be run only by the administrator and all settings in 
this file should reflect those of the administrator’s installation. After the file runs, it 
does not need to run again unless one of the above variables changes. Edit and run 
this file once for each RequisitePro and ClearQuest project that you want to integrate.

1 Use a text editor such as Notepad to open the file. 

2 Save a copy of the ASCQISetup.bat file with a name that corresponds to your 
Rational project (you use the Rational Administrator to create a Rational project). 
For example, you might create a copy named ASCQI_RA_project_name.bat. Edit this 
copy to include the data specific to your ClearQuest database and RequisitePro 
project environment as follows:

3 At each set command, replace the variable, including the angle brackets, with the 
value containing the project-specific information you supplied in Table 6.

set RP = “project name” The name of the 
RequisitePro project 
as displayed in the 
RequisitePro Project > 
Open dialog box. 

You must edit this 
field.

set RQS = “full directory 
path”

The full directory 
path to the 
RequisitePro *.rqs 
file 

You must edit this 
field. If your 
installation spans 
multiple computers, 
use a UNC path.

set Help= “full directory 
path”

The full path to the 
ClearQuest/ 
RequisitePro 
Integration help file 
(Program Files\ 

Rational\ 
RequisitePro\ 
Help\CQI.hlp).

You must edit this 
field if the CQI.hlp 
file is in a location 
other than the 
default location 
listed in the 
ASCQISetup.bat file. 
If your installation 
spans multiple 
computers, use a 
UNC path.

Table 6 Variables Describing Your Environment  (continued)

Batch Command Description Must Edit Your Values
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Example ASCQISetup.bat File

The following example of a modified ASCQISetup.bat file was edited to work with the 
integration for the Rational Suite Tutorial data, which is used throughout the 
document, Getting Started: Rational Suite AnalystStudio. This sample batch file reflects a 
local installation of RequisitePro and an unmodified help file. Remember to use UNC 
paths when necessary to reflect your installation environment. 

Note:  The REM command precedes a comment. Fields that you are required to edit 
are in bold. When editing to reflect your project specifications, replace the bold text 
with information about your administrator’s project installation.

REM Before you launch this batch file, please update the following 
information:

REM **** INFORMATION TO UPDATE ****

REM Update the name of the ClearQuest database.

set CQDatabaseName=CLSIC

REM Update the hard drive letter where your local Rational products are 
installed.

set H=C:

REM Update the Super User login name for ClearQuest database and 
RequisitePro project.

set U=admin

REM Update the path to your local Rational installation directory.

set P=\\Server_Name\Program Files\Rational\

REM Update the name of your RequisitePro project.

set RP=Order Processing and Fulfillment System

REM Update the full name to your RequisitePro .rqs file.

REM Use a UNC path for a project on a nonlocal computer.

set RQS=\\Server_Name\Program Files\Rational\Classics Demo\ 
ClassicsRepo\Project\ClassicsPOS\Requisite\requisite.rqs

REM Update the path to the cqi.hlp file.
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REM Use a UNC path for a project on a nonlocal computer.

set Help=\\Server_Name\Program Files\Rational\RequisitePro 
\help\cqi.hlp

REM **** BEGINNING OF THE SCRIPT ****

%H%

cd %P%\common

REM Create the association between the 'Defect' ClearQuest record type 
and the RequisitePro attribute 'Defect' of the Feature requirement 
type.

ASCQISetup.exe -c %U% %CQDatabaseName% Defect Requirements_List 
Defects_list RAProject Modify "Associate Defects" "%Help%" 1 "%RP%" 
"%RQS%" FEAT Defect 2

pause

REM Create the association between the 'EnhancementRequest' ClearQuest 
record type and the attribute 'EnhancementRequest' of the Feature 
requirement type.

ASCQISetup.exe -c %U% %CQDatabaseName% EnhancementRequest 
Requirements_List EnhancementRequests_list RAProject Modify "Associate 
Enhancement Requests" "%Help%" 1 "%RP%" "%RQS%" FEAT 
EnhancementRequest 2

pause

Note:  If the RequisitePro project does not have security enabled, the RequisitePro 
default project logon user name must be set to the Super User logon name specified in 
the ASCQISetup.bat file. This setting is available through the RequisitePro Tools > 
Options menu command.

Running the Batch File

Run the ASCQISetup batch file. As the batch file runs, it pauses every time it creates a 
setup record and prompts you to Press any key to continue. Press ENTER until 
the batch file ends.

Your integration has now been enabled and you are ready to associate ClearQuest 
enhancement request and defect records with Feature requirements in RequisitePro.
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After the file runs, it does not need to run again unless one of the above variables 
changes. Edit and run this file once for each RequisitePro and ClearQuest project that 
you want to integrate.

Customizing Your Integration

The ClearQuest and RequisitePro integration is configured with the following default 
types:

■ Defect and EnhancementRequest ClearQuest record types 
■ Feature RequisitePro requirement type 

You can use your own types to fit your development process. To do so, modify the 
ClearQuest database schema and the RequisitePro project structure, and then edit the 
ASCQISetup.bat file to contain your new values in the command arguments. The 
following components can be customized:

■ The RequisitePro requirement types
■ The RequisitePro requirement attribute labels
■ The ClearQuest record types

Changing the Default RequisitePro Requirement Types

The ASCQISetup.bat file contains a default requirement type of FEAT (Feature) to use 
in associating a requirement with a ClearQuest record. If your development team uses 
a different requirement type to track the product features, you can change this 
requirement type. For instructions on adding a new requirement type, see the 
RequisitePro Help. 

Changing the Default RequisitePro Project Attributes

If you add a new requirement type for use by the integration, you need to ensure that 
the requirement type contains a ClearQuest Integration attribute. This attribute 
displays the ClearQuest record ID associated with the requirement in RequisitePro. 

To add the ClearQuest Integration attribute to a RequisitePro requirement type:

1 Back up your RequisitePro project.

2 Start RequisitePro and open the related project.

3 Click File > Project Administration > Properties.
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4 On the Attributes tab, from the Requirement Type list, click the requirement type 
you have selected to use for the integration. Click Add.  The Add Attribute dialog box 
appears.

5 In the Label field, enter a name for your new attribute. 

6 From the Type list, select ClearQuest integration . Click OK.

7 Repeat steps 3–6 to add an attribute for each ClearQuest record type that you want 
to associate in the integration.

8 Save and close the RequisitePro project. 

Changing the Default ClearQuest Records

The ASCQISetup.bat file contains the following default ClearQuest records that the 
integration uses when the batch file is run:

■ EnhancementRequest
■ Defect

These records can be changed to suit your development environment. Begin by 
changing the record type names in ClearQuest, or by adding your own new record 
types. For more information on adding or changing ClearQuest records, refer to the 
manual, Rational ClearQuest Administrator’s Guide, on your documentation CD. 

Adding Your Customizations to the ASCQISetup.bat file

After customizing your RequisitePro requirement types and attributes and your 
ClearQuest records, edit the entire ASCQISetup.exe command in the ASCQISetup.bat 
batch file as follows:

1 Replace FEAT with your requirement type, and Defect or EnhancementRequest 
with your customized attribute label or record. 

2 Copy and update this command for each requirement type and attribute name to 
include in the integration. 

3 Verify that the Back Reference field value, which is the fifth argument in the 
ASCQISetup.exe command, matches the value you used for the corresponding 
record type in your ClearQuest schema. For example, the ASCQISetup.bat file might 
contain lines similar to the following: 

ASCQISetup.exe -c %U% %CQDatabaseName% Defect 
Requirements_List Defects_list RAProject Modify "Associate 

Defects" "%Help%" 1 "%RP%" "%RQS%" FEAT Defect 2
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In this case, Defects_list is the value of the Back Reference field associated with the 
Requirements_List field of a Defect record. To change the back reference to your 
custom value, simply rename it to match the value of the record type your 
ClearQuest schema.

4 Run the ASCQISetup.bat file to activate the new values.

For more information about command line arguments for ASCQISetup.exe, see 
ASCQISetup.exe Command Argument Descriptions on page 60. 

ASCQISetup.exe Command Argument Descriptions

At the end of the ASCQISetup.bat file, there are two calls to the routine ASCQISetup.exe. 
The following tables list the arguments of ASCQISetup.exe in the order in which they 
appear in the command. Table 7 describes the Rational ClearQuest arguments; Table 8 
describes Rational RequisitePro arguments. If you do not plan to customize the 
integration, you do not need to refer to this section.

Table 7 Rational ClearQuest Related ASCQISetup.exe Arguments

Command Line 
Argument

Description Comments

%U% Name of Super User in ClearQuest, a 
user in RequisitePro, and a user in the 
Rational project to which your 
ClearQuest database and RequisitePro 
project belong.

This variable is defined in the 
ASCQISetup.bat file. If the Super 
User has different accounts in each 
tool, you will be prompted to log into 
each tool as necessary.

%CQDatabaseName% Name of the ClearQuest database in 
which you want to create associations 
to requirements.

This variable is defined in the 
ASCQISetup.bat file. 

Defect Name of the ClearQuest record type 
whose records you want to associate 
with requirements.

Requirements_List Name of the ClearQuest record type 
field that stores references to associated 
requirements. This field must be of 
type Reference_List and reference the 
Requirement record type.

Defects_List Name of the Back Reference field 
defined for the previous field. This field 
automatically stores references of 
ClearQuest records associated with a 
requirement.
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Table 8 Rational RequisitePro Related ASCQISetup.exe Arguments

Command Line 
Argument

Description Comments

RAProject Name of the ClearQuest record type field that 
stores the Rational project containing the 
requirements you want to associate with the 
current ClearQuest record. This field must be 
of type Reference and refer to the Requirement 
record type.

Modify Name of an action of type MODIFY that 
operates on the 
ClearQuest_Record_Type_Name.

Associate Defects Title of the association dialog window that 
appears when the integration is called from 
RequisitePro. This title can mention, for 
example, the record type name of the 
ClearQuest records that will be associated.

%Help% Full path to the Help file used by both 
association dialog windows (either when the 
integration is called from RequisitePro or 
ClearQuest) in which you want to create 
associations.

This variable is defined in the 
ASCQISetup.bat file. 

2 Context ID in the help file. This file is called 
from the Help button of the association dialog 
window, which appears when the integration 
is called from RequisitePro.

%RP% Name of the RequisitePro project in which you 
want to create associations to ClearQuest 
records.

This variable is defined in the 
ASCQISetup.bat file. 

%RQS% Full path to the RequisitePro project file in 
which you want to create associations.

This variable is defined in the 
ASCQISetup.bat file. 

FEAT Prefix of the requirement type you want to 
associate with 
ClearQuest_Record_Type_Name.

Defect Name of the attribute type in which the list of 
associated ClearQuest record IDs is stored.

3 Context ID in the help file. This file is called 
from the Help button of the association dialog 
window, which appears when the integration 
is called from RequisitePro.
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7Working with and 
Configuring Extended 
Help
Extended Help gives you access to the Rational Unified Process and other information 
databases (including ones that you create). You typically start Extended Help from a 
Rational Suite tool, so you can get information about process and policy without 
interrupting your work flow. You can customize Extended Help to include topics 
related to your own process or environment.

The remainder of this chapter tells you how to use Extended Help and how to 
customize it and perform other administrative tasks.

Using Extended Help

This section describes how to get the most out of using Extended Help. It describes 
how to start Extended Help, how to change context, and how to add or remove 
databases.

Starting Extended Help

To use Extended Help:

1 Go to a Rational tool and select Help > Extended Help  from the tool's menu. 

The Extended Help browser appears, listing topics in a tree browser on the left.

2 To view a topic, navigate to, and double-click on, a topic title in the tree browser.

Changing Context

In Extended Help, the context determines how many, and which, topics Extended 
Help can display. You can check your current context by looking at the right side of 
the status bar. For example:

■ The context (Any, Any) means that Extended Help is displaying all topics for the 
databases that are currently active. 

■ The context (Rose, Any) filters the topics to just those that are relevant to Rose.

■ The context (Rose, Use Case Diagram) filters topics further so that they are 
relevant to Use Case Diagrams within Rose.
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When you start Extended Help, a context is established by determining what tool and 
sub-area you started from. 

After you start Extended Help, you can reset the context to view more, fewer, or 
different topics. For example, say that Extended Help starts with the context (Rose, 
Use Case Diagram). You might want to change the context to (Rose, Activity 
Diagram), (ReqPro, Any), or even (Any, Any). To do so:

1 From the Extended Help menu, select Edit > Context .

2 Make selections from the Product  list and the Subtool  list. Notice that the value of 
Product  affects the options listed under Subtool . 

3 Click OK.

Adding or Removing Databases

A database contains the topics that you view in Extended Help. You can make more 
than one database available at any time. Changing the databases available changes 
the list of topics available to you. There are two ways to add or remove databases 
from Extended Help:

■ Make a database active or inactive

■ Add or delete Extended Help databases 

Making a Database Active or Inactive

The effect of making a database active in Extended Help is to load all its topics into 
the Extended Help browser. Similarly, making a database inactive unloads its topics. 

To make a database active or inactive:

1 From the Extended Help menu, select Edit > Options .

2 In the list of databases, locate the one you want to change.

3 Clear or select the check box in the Active  column. 

The change takes effect the next time you start Extended Help.

Adding or Deleting an Extended Help Database

When you add a database to Extended Help, you make its topics potentially available 
for viewing. (The database must also be active for you to see its topics.) Similarly, 
when you delete a database, you make its topics unavailable for viewing, but you 
don’t physically delete the database from the disk. You can always re-add a deleted 
database back into Extended Help.
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To add a database:

1 If you used this database in an earlier version of Rational Suite, or if you have not 
yet prepared the database for use with Extended Help, perform the steps listed in 
Upgrading or Converting an Extended Help Database on page 66.

2 From the Extended Help menu, select Edit > Options .

3 Click the Add  button, then fill in the tables cells, pressing Enter  or Tab after 
entering a value in each column:

a Determine whether the database should be active, and if so, set the Active  check 
box.

b In the Name column, enter a human-readable and unique name that will help 
you remember the purpose of the database.

c In the Path  column, accurately enter the path to the database.

4 Click OK.

To delete a database:

1 From the Extended Help menu, select Edit > Options .

2 Select the row containing the database you want to delete. 

3 Click the Delete  button.

4 Click OK.

The change will take effect the next time you start Extended Help.

Administering Extended Help

This section describes administrative tasks to perform with Extended Help:

■ How to upgrade or convert a database used with an earlier version of Rational 
Suite.

■ How to create an Extended Help database (this allows you to customize the 
information displayed by Extended Help).

■ How to use translation strings to make database information more portable across 
multiple systems.
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Upgrading or Converting an Extended Help Database

Before you add a database to Extended Help, ensure that it is in the correct format. 
You need to perform the tasks described in this section if:

■ You are creating a new database (described on page 67).

■ You are upgrading from an earlier version of Rational Suite.

To prepare a database for use with Extended Help:

1 Start with a correctly structured file in comma-separated variable format (CSV):

❑ See Creating an Extended Help Database on page 67 to learn how to structure this 
file. 

❑ If you are starting with a Microsoft Access database, read about Converting from 
a Microsoft Access Database to a .csv File on page 66. 

2 Start the EHelpUpdate program. In Windows Explorer, go to 
install directory\common, where by default, install directory is c:\Program Files\Rational. 

3 Double-click EHelpUpdate.bat. The EHelpUpdate window appears.

4 In the Input  file field, type or browse to the CSV file you've prepared.

5 In the Output  file field, type or browse to a file whose type is .ehd, for example, 
c:\temp\myExtendedHelp.ehd 

6 Click OK.

7 Continue with the steps in Adding or Removing Databases on page 64.

Converting from a Microsoft Access Database to a .csv File

If you used an earlier version of Rational Suite, you may have an existing Extended 
Help database. This database is most likely written in Microsoft Access. For this 
version of Rational Suite, you need to convert the Access database to a .csv file (a file 
in comma-separated values format) before you can use it.

To convert an Extended Help database from Access to a .csv file:

1 Go to a view of the database fields by opening the Access database and then 
opening the Help Table.

2 From the Access menu, select File > Export . 
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3 In the Export Table dialog box:

a Save the table to a filename with a .csv extension.

b Clear the Save Formatted  check box.

c Click Save All .

4 The Export Text Wizard appears. On the first page of the wizard, select the 
Delimited  export format.

5 On the next page, select the Comma  delimiter to separate fields. Under Text 
Qualifier , select {none}  or the quotation mark ("). Click Finish .

6 Use Microsoft Excel to open the resulting .csv file.

7 Select the third and fourth columns – Columns C and D. These columns should be 
empty. Delete them by selecting Edit > Delete  from the Access menu.

8 Save the file again, keeping the same .csv extension.

9 Continue with the instructions in Upgrading or Converting an Extended Help 
Database on page 66.

Creating an Extended Help Database

If you create an Extended Help database, users at your site will have easy, desktop 
access to information important to your project, for example, policies and procedures. 
In fact, you can create an Extended Help database containing any information 
accessible by a URL. In some cases, individual users create Extended Help databases 
to provide a quick reference to important information.

High-Level Process

The high-level view of the creation process is: 

1 Populate the database: use Microsoft Excel to create and enter pointers to the data 
(described in this section).

2 Add the database to Extended Help or tell your users to add it (described  on 
page 64).

3 Tell your users how to use translation strings (described on page 70).
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Populating the Database

To populate an Extended Help database:

1 Start Microsoft Excel. 

2 For each database record, enter the following information in the first six columns: 

3 Save the file in the comma-separated values (.csv) format (use File > Save as ).

4 Continue by adding the database to Extended Help (described on page 64).

Column Field Name Description

A product The name of the Rational product from which a query is 
invoked. See list of valid values on page 69. 

B subtool The specific context within a product. See list of valid values 
on page 69. 

C query This value becomes a folder name in the Extended Help 
browser. Think of it as a category for the information pointed 
to by this record, for example, "Requirements Traceability.” 
You can use any value, up to 100 characters, but we 
recommend that you keep the length relatively short.

D target A URL pointing to the information for this record. The URL 
can be:
■ A URL using an absolute value (example: 

http://www.rational.com) 
■ A URL using a translation string – described on page 70 

(example: corpinfo\requirements\traceability.html) 
■ A file name (example: file:d:\myfile.html) 

The maximum length of this field is 255 characters.

E short_description The description that appears for the record under the folder 
in the Extended Help browser. The maximum length of this 
field is 50 characters.

F description A longer description that appears when the cursor is held 
over the item (the information appears in a tool tip). The 
maximum length of this field is 255 characters.
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Valid Product and Subtool Values

Table 9 describes valid combinations for values of Product and Subtool. A database 
record must have one of these valid combinations for Extended Help to find the 
record.

Note:  You can use the value Any for the subtool or for the product and subtool. A 
value of Any indicates that any context matches. For example, the values (ReqPro, Any) 
match (ReqPro, Toolbar) or (ReqPro, View).

Table 9 Valid Products and Subtool Values

Product Subtool

ClearQuest Client

ClearQuest Designer

RationalTest Administrator

RationalTest LoadTest

RationalTest LogViewer

RationalTest Robot

RationalTest TestFactory

RationalTest TestManager

ReqPro Toolbar

ReqPro View 

Rose Activity Diagram

Rose Class Diagram

Rose Collaboration Diagram

Rose Deployment Diagram

Rose Other Tool

Rose Package Diagram

Rose Sequence Diagram

Rose Statechart Diagram

Rose Use Case Diagram

SoDA tool
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You can also use these products with the subtool, Any (for example, (product, Any)):

■ Purify
■ VisualPurify
■ VisualQuantify

Working with Translation Strings

A translation string is a variable that stands for part of a URL. It makes your Extended 
Help database portable to multiple systems. 

Say that in a geographically distributed project, there exist local copies of the HTML 
pages pointed to by the Extended Help database. If you use absolute URLs, each set of 
HTML pages must be saved in exactly the same location. By using translation strings, 
however, you can store the HTML pages in a location appropriate to each site. 

For example, you might have a set of HTML pages that are all under a single 
directory, say \myProject. You could define a translation string, <project>. On various 
systems, <project> might point to:

■ c:\program files\myProject 
■ d:\temp\HTML pages\projects\myProject 
■ h:\myVOB\projects\myProject 

Then, when you create records in an Extended Help database, you can use a 
translation string to refer to a URL, for example: <project>\index\index.htm 

Defining Translation Strings on User Systems

On a user's system, define a translation string as follows:

1 From the Extended Help menu, choose Edit > Options . 

2 Click the Translation Strings  tab.

3 Click Add . A new blank line appears.

4 Under String , type the name of the translation string, for example, <rup>.

5 Under Replacement , type the path that the string should translate to, for example, 
file:c:\Program Files\Rational\RationalUnifiedProcess. Make sure that you do not 
include a final slash.

6 Click OK.
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Deleting a Translation String

To delete a translation string:

1 From the Extended Help menu, choose Edit > Options . 

2 Click the Translation Strings  tab.

3 Select a translation string to delete.

4 Click Delete , then click OK. 
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8Troubleshooting
This chapter provides pointers to information about troubleshooting, available 
throughout the Rational documentation set.

Troubleshooting Integrations with Rational ClearQuest

Many Rational tools have integrations with Rational ClearQuest.

To enable the integration, you either use a specialized ClearQuest schema, or apply a 
ClearQuest package to your existing schema. In some cases, you then perform 
additional tasks.

For more information about enabling integrations with ClearQuest, see “ClearQuest 
Schemas and Packages” in Rational ClearQuest Administrator’s Guide.

Note:  When you customize a ClearQuest package or schema, you can sometimes 
unintentionally disable either the integration you are trying to achieve or the 
integrations between other Rational products. Customize packages or schemas only 
as directed by Rational Technical and Field Engineers. If you have questions, contact 
Technical Support before proceeding with integrations.

Rational Suite and ClearCase LT Considerations

To use ClearCase LT, you must have a ClearCase LT server installed in your 
environment. 

If you want to use your ClearCase LT server as a client computer as well, follow these 
guidelines:

■ Install ClearCase LT server on the computer before installing Rational Suite.

■ Install ClearCase LT server before you install ClearCase LT clients. This enables 
you to specify the server name during client install, rather than having to 
configure a pointer to the server at a later time.
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For More Troubleshooting Information

Table 10 provides information on troubleshooting other Rational products.

Table 10 Rational Troubleshooting Information

Topic Source of Troubleshooting Information

Rational Suite licenses “Troubleshooting Licenses” chapter of Rational Suite License 
Management Guide 

Rational Suite installations “Troubleshooting” chapter of Rational Suite Installation Guide 

ClearCase LT Administration “Troubleshooting” chapter of Rational ClearCase LT 
Administrator’s Guide

RequisitePro installation “Troubleshooting” chapter of Rational RequisitePro Installation 
Guide

RequisitePro use “Troubleshooting” chapter of Rational RequisitePro User’s 
Guide
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