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Preface

The Rational Suite License Management Guide provides comprehensive information
about Rational Common Licensing for Rational’s Windows products. It provides you
with the technical information you need to install floating and node-locked license
keys, install and configure the Rational license server software, and troubleshoot
problems related to licensing Rational Software products.

This manual is divided into two sections: client user tasks and administrator tasks. If
you are licensing Rational products on a client, refer to the client licensing section. If
you are the license administrator or a user who manages the license keys, refer to the
license administrator section to order permanent license keys, set up the license server
(if your company has purchased floating licenses), and advanced features.

Rational Suite delivers a comprehensive set of integrated tools that embody software
engineering best practices and span the entire software development lifecycle.
Rational Suite's unparalleled level of integration improves communication both
within teams and across team boundaries, reducing development time and improving
software quality.

Audience

This guide is intended for client users and system administrators. This book assumes
knowledge of Microsoft Windows and its conventions and experience with
client-server environments.

Other Resources

= All manuals are available online, either in HTML or PDF format. The online
manuals are on the Rational Solutions for Windows Online Documentation CD.

= To send feedback about documentation for Rational products, please send e-mail
10 techpubserational . com.

» For more information about Rational Software technical publications, see:
http://www.rational .com/documentation.

Xi


http://www.rational.com/documentation/

= For more information on training opportunities, see the Rational University Web

Site: http: //www.rational.com/university.

= For articles, discussion forums, and Web-based training courses on developing
software with Rational Suite products, join the Rational Developer Network by
selecting Start > Programs > Rational Suite > Logon to the Rational Developer Network.
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Rational Technical Support

When you contact Rational Technical Support, please be prepared to supply the
following information:

* Your name, company name, telephone number, and e-mail address

= Your operating system, version number, and any service packs or patches you

have applied

= Product name and release number

* Your case ID number (if you are following up on a previously reported problem)

Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact

Rational Technical Support as follows:

Your Location

Telephone

Facsimile

E-mail

North America

(800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com

Europe, Middle
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4546-201
Netherlands

support@europe.rational.com

Asia Pacific

+61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com

Contacting Rational Licensing Technical Support

If you have questions about acquiring license keys for your Rational Software
products, contact Rational Licensing Technical Support as follows:

Your Location

Telephone

Facsimile

E-mail

Asia Pacific

+61-2-9419-0111

+61-2-9419-0123

license@apac.rational.com

Asia Pacific
(Japan)

+61-2-9419-0111

+61-2-9419-0123

license@japan.rational.com

Asia Pacific
(Korea)

+82-2-556-9420

+82-2-556-9426

license@apac.rational.com
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Your Location

Telephone

Facsimile

E-mail

Asia Pacific
(Mainland China,
Hong Kong, and
Taiwan)

+61-2-9419-0111

+61-2-9419-0123

license@china.rational.com

Europe
Middle East
Africa

+31 20 4546 200

+31 20 4546 202

license@europe.rational.com

North American
(East Coast) and
South America

800-433-5444

(toll free, USA only)

+1 (408) 863 4000

781-676-2460

license@rational.com

North America
(West Coast) and
Central America

800-433-5444

(toll free, USA only)

+1 (408) 863 4000

408-863-4001

license@rational.com

Rational Technical Support xv
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Before Installing License
Keys

This chapter describes the Rational License Key Administrator (LKAD), license key

upgrades and removal, and basic Common Licensing terms. Although much of the

information in this chapter is similiar to information in Before Requesting License Keys
on page 41, this chapter is intended for client users.

The LKAD helps you, the user, perform all of your client licensing tasks. If you are
familiar with the LKAD and already have permanent license keys installed on your
system, see Upgrading Licenses on page 22 to find out whether you need updated
license keys.

To find definitions of additional Rational Common Licensing terms, see the Licensing
Glossary on page 99.
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Table 1 helps you find procedures for client licensing tasks.

Table 1

Roadmap for Client Tasks

To

See

Understand the Rational
License Key Administrator
features

Using the Rational License Key Administrator (LKAD) on page 20

Understand basic Rational
Common Licensing terms,
such as node-locked and
floating

License Types and License Key Types on page 23

Configure the clients to use
floating license keys

Configuring Clients to Use Floating Licenses on page 33

Install node-locked license
keys on a client

Installing Node-Locked Licenses on page 29

Enter a temporary key for
evaluating a Rational product

Installing Node-Locked Licenses on page 29
Installing Floating and Named-User Licenses on page 55

Upgrading licenses or adding
products to licenses

Upgrading Licenses on page 22

Change the order in which
Rational products use licenses

Changing License Usage Order on page 37

Move or return license keys

Removing or Moving License Keys on page 22

Change port values

Changing the Imgrd Port on page 76

Using the Rational License Key Administrator (LKAD)

The Rational License Key Administrator (LKAD) is installed with your Rational
software and with your Rational license server software. This Rational program
provides an interface to Rational Common Licensing features. Use the LKAD to enter
or import license keys and change your license configuration.

= To access the LKAD on a client system, click Start > Programs > Rational product
name > Rational License Key Administrator.

= To access the LKAD on a license server system, click Start > Programs > Rational
License Server > Rational License Key Administrator.

20 Chapter 1 - Before Installing License Keys




The Help explains how to use the LKAD to review and modify your license
configuration. The LKAD Help also provides information about configuring the
license server software. To access the Help, click Help in the License Key
Administrator’s main menu or open <Install Path>\Rationa\Common\licadmin.hlp.

Using the LKAD During the Rational Software Setup Program

To take care of licensing tasks before you install a product, open the Rational License
Key Administrator from the Rational Software Setup program. The Rational Software
Setup offers a Configure Licenses button in the Choose Product dialog box. When you see
the License Key Administrator appear, import a node-locked license key, enter an
evaluation license key, and specify a license server. After you configure product
licensing, return to the Rational Software Setup program and install the product.

Reviewing Your License Information in the LKAD

By default, you should see complete information about your license keys in the main
window of the License Key Administrator. If you do not see this information in the
window, use the View > Show menu to display information about your licenses.

Table 2 defines each of the options in the View > Show menu.

Table 2 Show Licenses

License Shows

Invalid and Expired Licenses | All expired node-locked, floating, and served licenses
on the system that you are using

Floating Licenses All floating licenses on the system that you are using

Node Locked Licenses All node-locked licenses on the system that you are
using

Served Licenses All floating licenses that Rational software on your

system could request from the license server

Administrator Privileges for the LKAD

The Rational License Key Administrator (LKAD) is installed with every Rational
product and with the Rational license server software. What you can do in the LKAD
depends on the privileges that you have. Grayed out menu options in the LKAD
Wizard, menu bar, or button bar indicate limited privileges.

Using the Rational License Key Administrator (LKAD) 21



1 To see which privileges are missing, select Help > About Rational License Key
Administrator. You will see one or more of the following statements

Statement Explanation

Cannot write to HKEY_LOCAL_MACHINE in | You cannot specify a license server.
the Windows Registry.

Cannot Start and Stop a Windows Service. You cannot start the license server.

Cannot create a file. You cannot import a license key file on
to your system.

Cannot modify a file. You cannot enter a temporary license
key in your system.

2 Request the missing NT administrator privileges from your system administrator.

Upgrading Licenses

If you are upgrading from an earlier version of a Rational Suite or point product,
reuse your current Rational Suite and point-product license keys.

Adding Rational Suites or Point Products to Licenses

This section describes the conditions under which you must order new license keys.

= If you have purchased a different type of Rational Suite from the one you are
currently using, request a new license file that includes the new Rational Suite key.

= If you are adding a new product to your system, request a new license file that
includes the new point product license key.

If any of the above applies to your system, ask your administrator to perform the
required node-locked license transactions in AccountLink. See Removing or Moving
License Keys on page 22 for the tasks you must perform on the client after each license
transaction. If you must perform the transactions yourself, see Requesting License Keys
on page 49.

Removing or Moving License Keys

The following instructions assume that a license administrator performs licensing
transactions in AccountLink, and you, as the client user, import the license keys on
your system.
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Removing License Keys

When you need new node-locked license keys, return the old license keys to your
company’s Rational account in AccountLink before you or your license administrator
orders new ones.

To return a license key:
1 Your license administrator performs the return transaction in AccountLink.

2 When you receive the update file from AccountLink, import the file on your
system. For more information, see Importing Permanent or Term License Agreement
(TLA) Keys on page 29.
Moving License Keys

Moving a node-locked license key from one system to another requires a return
transaction and a new license key transaction in Rational AccountLink. To help
prevent you from confusing the license key update file for the old system with the
license key file for the new system, ask your license administrator to order license
keys for the new system after you complete the return process on the old client.

To move a license key from one system to another:
1 Your license administrator performs the return transaction in AccountLink.

2 When you receive the update file from AccountLink, import the file on your
system. For more information, see Importing Permanent or Term License Agreement
(TLA) Keys on page 29. Importing the update file completes the return transaction.

3 Install the Rational software on the new system.

4 The license administrator orders a new license key file for the new system in
AccountLink.

5 Import the license key file on the new system. For more information, see Importing
Permanent or Term License Agreement (TLA) Keys on page 29.

License Types and License Key Types

What Are Node-Locked and Floating Licenses?

Rational supports both node-locked and floating licenses. Node-locked licenses are
created only for a specific system. Floating licenses can be shared by multiple users on
multiple systems. A Rational license server controls use of the floating licenses.

Removing or Moving License Keys 23



When users install Rational products on their systems, the Rational Software Setup
program automatically installs the Rational licensing software (Rational license server
software is not installed automatically). The licensing software lets these systems use
either node-locked or floating licenses.

Note: Users need floating license keys from a Web server to run Rational ClearQuest
Web and Rational RequisiteWeb on Web clients.

The following table explains the types of licenses in detail.

Table 3 License Types

License Type | Description Notes
Node-locked |= A node-locked license is Rational also issues node-locked
configured for a specific licenses for Rational products that run

system. It allows a user to run a | on UNIX platforms. Node-locked
Rational product only on that | Rational products on UNIX (that use
specified system. Rational Common Licensing) are
licensed with counted node-locked
license keys. You manage counted
node-locked licenses with a license

= Rational supports uncounted
node-locked licenses for
Windows products. Rational

refers to uncounted server.

node-locked license keys for Clients connect to the Rational license
Windows products as server and acquire a counted
node-locked license keys. node-locked license specific to their

system. This process is the same as the
one used to acquire floating license
keys.

= Because these license keys do
not use a Rational license
server, the user may run
multiple sessions of a Rational | Essentially, a counted node-locked

product concurrently using a license key is a floating license key
single license key. that can only be used on a specific
host.

= To move a node-locked license
to another system, you must
return the license key from the
old system and request a new
license key for the new system.
For a more detailed
explanation, see Returning or
Moving License Keys on page 69.
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Table 3

License Types (continued)

License Type

Description

Notes

Floating

A system administrator installs
the Rational license server
software on one or redundant
systems. The administrator
then installs the floating
licenses on the license server.

The pool of floating licenses are
shared among all users of
Rational products.

Client systems obtain licenses
from the license server system
when they need to run a copy
of Rational software. One
license is granted per client per
product

To move a floating license to
another license server, you
must “return” the license key
from the old license server and
request a new license key for
the new license server. For a
more detailed explanation, see
Returning or Moving License
Keys on page 69.

Rational also supports Named-User
floating licenses for Rational Purify,
Quantify, and PureCoverage. This
configuration assigns licenses to
specific users. That is, only specific

users can request floating license keys

from the license server. For more
information, see Importing
Named-User and Floating License Keys
on page 61.

Using Multiple Floating or Node-Locked License Keys

A client system can check out multiple floating or node-locked licenses.

What Are Permanent and Temporary License Keys?

When you register Rational products to a system (license server or client) in
AccountLink, Rational generates license keys for that system. These permanent

license keys are sent through e-mail in a license file to you. The permanent keys let

you use the Rational products for an indefinite period of time. However, Rational
assigns an expiration date to the license keys if your company has negotiated a Term
License Agreement (TLA). Technically, TLA keys are not permanent, but Rational
groups TLA licenses in the permanent license key category.

Removing or Moving License Keys

25



To use Rational products for an evaluation period or if you expect a delay in receiving
your permanent keys, you can install the temporary license key provided in your
Rational License Key Certificate. Because Rational has not generated the temporary
key for a specific system, you can use it on any system until the specified expiration
date.

Permanent and temporary license keys can be floating or node-locked. The difference
is that a temporary key is not generated for a specific system and a permanent key is
generated for a specific system.

The following table defines the types of license keys used by Rational licensing.

Table 4 License Key Types

License Key Description Notes

Type

Permanent = A license issued to a customer for Rational issues permanent
running Rational products. Permanent | node-locked or floating keys
licenses are keyed to a specific upon request. Use
Rational product and specific system. | AccountLink at

= Permanent license keys can be www.rational.com
node-locked or floating. The user /accountlink to acquire your
installs a node-locked permanent key | lcense keys.
on a system on which the user runs
Rational software. Floating permanent
keys are installed on a Rational license
server.

Temporary = A time-limited license issued to a The expiration date for a
customer for running Rational temporary key is noted on
products. Temporary licenses are not | the License Key Certificate
keyed to a specific system. included with the Rational

= Temporary license keys can be product shipment.
node-locked or floating. The user
installs a node-locked temporary key
on a system on which the user runs
Rational software. Floating temporary
keys are installed on a Rational license
server.

TLA (Term = Variation of a Permanent Key. TLAs TLAs are issued by the

License are issued to allow users access to Rational Sales Team. To

Agreement) Rational software for a negotiated obtain TLAs for your
period of time. organization, contact your

local Rational Sales Team.
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What Are Emergency and Evaluation License Keys?

Emergency and evaluation license keys are temporary license keys. They can be
floating or node-locked. They are short-term licenses that are not generated for a
specific system.

What Are Suite Licenses and Point-Product Licenses?

A Rational license key indicates whether it is a Rational Suite license, such as Rational
Suite Enterprise, or a point-product license, such as Rational Purify. A node-locked or
floating Rational license file can contain multiple suite and point-product license keys.

Using Suite License Keys

A Rational Suite license key lets you run all of the products contained within a
Rational Suite at the same time on a single system. The Rational Suite checks out a
single floating or node-locked suite license key.

Using a Different Suite License from the Suite Edition Installed

You can install a Rational Suite on a client and specify that products within the Suite
check out a different type of Rational Suite license. For example, you can install
Rational Suite Enterprise on the client and have the point products within the
Rational Suite check out a Rational Suite AnalystStudio license from the Rational
license server.

To select a different license for a product, use the License Key Administrator’s License
Usage Mapper. See Changing License Usage Order on page 37 for more information.
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Installing Node-Locked
Licenses

A node-locked license key is created for a specific client. You cannot use Rational
software on any other client with that node-locked key. A node-locked key does not
require a license server; you simply install license keys on the client. This license type
allows for portability, especially for customers who have isolated systems or laptops.

This chapter describes how to install permanent or temporary node-locked license
keys on clients.

If you are using floating license keys, see Configuring Clients to Use Floating Licenses on
page 33.

Importing Permanent or Term License Agreement (TLA) Keys

After your license administrator requests your permanent license keys from
AccountLink, Rational sends you a permanent node-locked license file. This file
contains license keys for the client that your license administrator specified in
AccountLink. Use the Rational License Key Administrator (LKAD) to import the
license key file on the client before or after you install the Rational product.

= To open the LKAD during the Rational Software Setup program (before you install
the product), click Configure Licenses in the Choose Product to Install dialog box.
The License Key Administrator main window and the License Key Administrator
Wizard dialog box appear.

= To open the LKAD after you have installed the Rational product, click Start >
Programs > Rational product name > Rational License Key Administrator. The
License Key Administrator main window and the License Key Administrator
Wizard dialog box appeatr.

To import a license key file:
1 Select License > Import License Key(s) on the menu bar.

2 Inthe Import License Key(s) dialog box, find the .upd or .txt file (license key file) and
highlight it.

3 Click Open. The default location for the license key file is
<Install Path>\Rational\common.
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4 The Restart License Server dialog box will ask you whether you want to restart
the license server. Stop and restart the license server to make the latest license key
available for license requests.

Other Methods

» If your e-mail program supports launching programs from file attachments,
double-click the .upd or .txt attachment in the e-mail notification you received
from Rational Software. Select Open it in the Opening Mail Attachment dialog
box. Click the Import button in the Confirm Import dialog box.

= Save the file attachment to any folder and double-click the license file.
Entering Temporary or Evaluation License Keys

Use the temporary license key if you are evaluating the product or AccountLink is
unavailable. The temporary or evaluation license key information, including the
expiration date, is on your License Key Certificate. The License Key Certificate is
enclosed in a large green envelope in your Rational Software product shipment.

Use the Rational License Key Administrator (LKAD) to enter the temporary license
key information on the client before or after you install the Rational product.

» To open the LKAD during the Rational Software Setup program (before you install
the product), click Configure Licenses in the Choose Product to Install dialog box.
The License Key Administrator main window and the License Key Administrator
Wizard dialog box appear.

= To open the LKAD after you have installed the Rational product, click Start >
Programs > Rational product name > Rational License Key Administrator. The
License Key Administrator main window and the License Key Administrator
Wizard dialog box appeatr.

To enter temporary license information:
1 Select License > Enter a License in the menu bar of the License Key Administrator.

2 Choose the type of license you are installing: a Node-Locked License Key or a Floating
License Key.

3 Inthe next dialog box, enter the following information from your License Key
Certificate:

= Product
= Expiration Date

2 License Key

(s}

Quantity (if you are installing a floating license key)
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4 Click Finish. The License Key Administrator creates a *. dat file for the license key
in <Install Path>\Rational\common.

Importing Permanent or Term License Agreement (TLA) Keys 31
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Configuring Clients to
Use Floating Licenses

Rational products on client systems can check out floating licenses, including
named-user floating licenses, from a floating license server.

This chapter explains how to specify a license server in your client’s License Key
Administrator after your license administrator has set up the Rational license server.
If you are using node-locked licenses, see Installing Node-Locked Licenses on page 29.

Configuring Clients to Use Rational License Servers

Enter the license server’s host name in the License Key Administrator (LKAD) of the
client before or after you install the Rational product. Your license administrator
should tell you whether the Rational license server is ready to use before you specify
the license server.

Note: In the case of ClearQuest Web and RequisiteWeb, the Web server is the client of
the license server. When a user opens these applications on a Web client, the
ClearQuest Web server or the RequisiteWeb Requirements server, on behalf of the
user, requests the floating license from the license server.

» To open the LKAD during the Rational Software Setup program (before you install
the product), click Configure Licenses in the Choose Product to Install dialog box.
The License Key Administrator main window and the License Key Administrator
Wizard dialog box appeatr.

= To open the LKAD when you have installed the Rational product, click Start >
Programs > Rational product name > Rational License Key Administrator. The
License Key Administrator main window and the License Key Administrator
Wizard dialog box appeatr.
Configuring Clients to Use Single or Multiple License Servers

The following procedure lets you specify one or two license servers in your client. Do
not use the following procedure to enter redundant servers in the client LKAD.

To enter the license server(s) on a client:
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1 Select Settings > Service Configuration.

2 Click the Servers tab.

3 Select the Use License Server box.

4 Select Single Server.

5 Enter the hostname of the license server.
Use Additional Server

If your system administator has given you the hostname of an additional license
server, your client can request license keys from that system by selecting Use
Additional Server and entering the name of that server.

Note: Do not use Additional Server for a redundant server environment.

6 Click OK.

Configuring Clients to Use Redundant License Servers

Redundant servers are a system of three servers that work as a team to manage a
single pool of floating license keys. If one of the server systems goes down, the other
two license servers automatically continue managing the license pool.

To enter the redundant license servers on a client:

1 Click Settings > Service Configuration.

2 Select Use License Server.

3 Click the Servers tab and select Redundant servers.

4 Enter the Primary, Secondary, and Tertiary (Backup) license server hostnames in
the order in which the license administrator requested them in AccountLink.

5 Click OK.

Entering a Port Value to Support a Firewall

Assigning a value to the port in your License Key Administrator is necessary in
firewall situations. Do not assign a value to this port unless your administrator
instructs you. To learn more about Rational licensing and firewalls, see Using Floating
Licenses with a Firewall on page 74. The following procedure assumes the license
administrator has given you the Rational Vendor port value.

To enter a port value on a client:
1 Select Settings > Service Configuration.

2 Click the Servers tab.
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Enter the value in the Port (Optional) field next to the Single Server hostname.

Enter the value in the Port (Optional) field next to the Additional Server hostname,
if applicable.

Enter the value in the Port (Optional) field under the hostnames of the redundant
servers, if applicable.

Click OK.

Configuring Clients to Use Rational License Servers 35
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Changing License Usage
Order

Rational products request licenses in a specific order. If you have a combination of
node-locked, floating, suite, or point-product license keys in your environment, you
need to understand this order and how you can change it.

A Rational product, whether it is installed as part of a Rational Suite or installed as a
point product, requests licenses in this order, by default:

1 Node-locked before floating license.

2 Suite license of the last Rational Suite installed.

3 Suite license of the Rational Suite installed before the last Rational Suite installed.
4 Point-product license.

A Rational product requests a node-locked license before a floating license, regardless
of whether it is a suite or point-product license. Then the product requests a suite
license before a point-product license from a group of floating or node-locked
licenses. For example, Rational Purify is sold as part of a Rational Suite and as a
stand-alone product. It will request the Rational Suite license before it requests a
Rational Purify license.

Rational RequisiteWeb and ClearQuest Web
Rational RequisiteWeb and ClearQuest Web require floating licenses. Unlike other
Rational products, they request the point-product license before the suite license.

Examples

To get a better understanding of how Rational products use licenses, read the
following examples. If you would like to change how your Rational products use
Suite and point-product licenses, see Changing License Usage on Your System (License
Usage Mapper) on page 38.
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Rational Suite and Point-Product Floating Licenses

A customer installs several Rational Suite Enterprise licenses and Rational ClearQuest
licenses on its license server. A user installs Rational Suite Enterprise on a client
system. When this user starts ClearQuest, which is a part of Rational Suite Enterprise,
the product requests the Rational Suite Enterprise license before the ClearQuest
license.

Multiple Rational Suite Floating Licenses

A customer installs several Rational Suite DevelopmentStudio and TestStudio licenses
on its license server. Then installs TestStudio and then DevelopmentStudio on clients.
Because DevelopmentStudio was installed last on the client systems, a product
common to both Rational Suites requests the DevelopmentStudio suite license first.

Changing License Usage on Your System (License Usage Mapper)

To change the order in which a product on your system requests suite and
point-product licenses, use the License Key Administrator’s License Usage Mapper.

Note: You can change license usage order on each client. You cannot use the Rational
license server to change license usage order for all clients.

To change the license usage order on a desktop:
1 Select Settings > License Usage Mapper in the menu bar.

2 Inthe License Usage Mapping dialog box, make sure the correct product is
highlighted in the Installed Products box.

3 Move the product license above the suite license in the License Usage Order box.

4 Click OK.
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Before Requesting
License Keys

This chapter describes the Rational Common Licensing model, basic Common
Licensing terms, and supported configurations. This information will help you
understand Rational Common Licensing and plan the licensing configuration for
your environment. If you already have license keys installed on your Rational license
server, see Upgrading Licenses on page 46 to find out whether these license keys need
to be replaced.

To find definitions of additional Rational Common Licensing terms, see the Licensing
Glossary on page 99.

Table 5 helps you find procedures for administrator licensing tasks.

Table 5 Roadmap for Administrator Tasks

To See

Understand basic Rational Before Requesting License Keys on page 41
Common Licensing terms, such as
node-locked and floating

Find out which licensing Before Requesting License Keys on page 41
configurations Rational supports

Request and receive permanent Requesting License Keys on page 49
(floating or node-locked) license
keys

Set up the floating license server Installing Floating and Named-User Licenses on page 55
and install floating and floating
named-user license keys

Install named-user floating license | Installing Floating and Named-User Licenses on page 55
keys

Enter a temporary floating key for | Installing Floating and Named-User Licenses on page 55
evaluating a Rational product

Configure redundant Rational Installing Floating and Named-User Licenses on page 55
license servers

Remove the Rational license server | Installing Floating and Named-User Licenses on page 55
software
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Table 5 Roadmap for Administrator Tasks (continued)

To See

Use other supported Rational Using Other License Configurations on page 71
licensing features and
configurations, such as settingup a
UNIX license server for Windows
clients

Understand license installation Troubleshooting Licenses on page 89
problems and error messages

Understand the mechanics of Understanding Rational Licensing Components on page 79
Rational Licensing

The Rational Common Licensing Model

Rational Software uses a software-based license management tool from GLOBEtrotter,
Inc. FLEXIm provides users with a powerful and flexible mechanism for managing
licensing. This allows vendors, such as Rational Software, to build a customized
licensing model by implementing the FLEXIm features that best meets their business
needs.

License Types and License Key Types

What Are Node-Locked and Floating Licenses?

Rational supports both node-locked and floating licenses. Node-locked licenses are
created only for a specific system. Floating licenses can be shared by multiple users on
multiple systems. A Rational license server controls use of the floating licenses.

When users install Rational products on their systems, the Rational Software Setup
program automatically installs the Rational licensing software (Rational license server
software is not installed automatically). The licensing software lets these systems use
either node-locked or floating licenses.

Note: Users need floating license keys from a Web server to run Rational ClearQuest
Web and Rational RequisiteWeb on Web clients.
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The following table explains the types of licenses in detail.

Table 6

License Types

License Type

Description

Notes

Node-locked

A node-locked license is
configured for a specific
system. It allows a user to run a
Rational product only on that
specified system.

Rational supports uncounted
node-locked licenses for
Windows products. Rational
refers to uncounted
node-locked license keys for
Windows products as
node-locked license keys.

Because these license keys do
not use a Rational license
server, the user may run
multiple sessions of a Rational
product concurrently using a
single license key.

To move a node-locked license
to another system, you must
return the license key from the
old system and request a new
license key for the new system.
For a more detailed
explanation, see Returning or
Moving License Keys on page 69.

Rational also issues node-locked
licenses for Rational products that run
on UNIX platforms. Node-locked
Rational products on UNIX (that use
Rational Common Licensing) are
licensed with counted node-locked
license keys. You manage counted
node-locked licenses with a license
server.

Clients connect to the Rational license
server and acquire a counted
node-locked license specific to their
system. This process is the same as the
one used to acquire floating license
keys.

Essentially, a counted node-locked
license key is a floating license key
that can only be used on a specific
host.

The Rational Common Licensing Model
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Table 6 License Types (continued)

License Type

Description

Notes

Floating

A system administrator installs
the Rational license server
software on one or redundant
systems. The administrator
then installs the floating
licenses on the license server.

The pool of floating licenses are
shared among all users of
Rational products.

Client systems obtain licenses
from the license server system
when they need to run a copy
of Rational software. One
license is granted per client per
product

To move a floating license to
another license server, you
must “return” the license key
from the old license server and
request a new license key for
the new license server. For a
more detailed explanation, see
Returning or Moving License
Keys on page 69.

Rational also supports Named-User
floating licenses for Rational Purify,
Quantify, and PureCoverage. This
configuration assigns licenses to
specific users. That is, only specific
users can request floating license keys
from the license server. For more
information, see Importing
Named-User and Floating License Keys
on page 61.

Using Multiple Floating or Node-Locked License Keys

A client system can check out multiple floating or node-locked licenses.

What Are Permanent and Temporary License Keys?

When you register Rational products to a system (license server or client) in
AccountLink, Rational generates license keys for that system. These permanent
license keys are sent through e-mail in a license file to you. The permanent keys let
you use the Rational products for an indefinite period of time. However, Rational
assigns an expiration date to the license keys if your company has negotiated a Term
License Agreement (TLA). Technically, TLA keys are not permanent, but Rational
groups TLA licenses in the permanent license key category.
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To use Rational products for an evaluation period or if you expect a delay in receiving
your permanent keys, you can install the temporary license key provided in your

Rational License Key Certificate. Because Rational has not generated the temporary
key for a specific system, you can use it on any system until the specified expiration

date.

Permanent and temporary license keys can be floating or node-locked. The difference
is that a temporary key is not generated for a specific system and a permanent key is
generated for a specific system.

The following table defines the types of license keys used by Rational licensing.

Table 7 License Key Types

License Key Description Notes

Type

Permanent = A license issued to a customer for Rational issues permanent
running Rational products. Permanent | node-locked or floating keys
licenses are keyed to a specific upon request. Use
Rational product and specific system. | AccountLink at

= Permanent license keys can be www.rational.com
node-locked or floating. The user /accountlink to acquire your
installs a node-locked permanent key | lcense keys.
on a system on which the user runs
Rational software. Floating permanent
keys are installed on a Rational license
server.

Temporary = A time-limited license issued to a The expiration date for a
customer for running Rational temporary key is noted on
products. Temporary licenses are not | the License Key Certificate
keyed to a specific system. included with the Rational

» Temporary license keys can be product shipment.
node-locked or floating. The user
installs a node-locked temporary key
on a system on which the user runs
Rational software. Floating temporary
keys are installed on a Rational license
server.

TLA (Term = Variation of a Permanent Key. TLAs TLAs are issued by the

License are issued to allow users access to Rational Sales Team. To

Agreement) Rational software for a negotiated obtain TLAs for your
period of time. organization, contact your

local Rational Sales Team.

The Rational Common Licensing Model
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What Are Emergency and Evaluation License Keys?

Emergency and evaluation license keys are temporary license keys. They can be
floating or node-locked. They are short-term licenses that are not generated for a
specific system.

What Are Suite Licenses and Point-Product Licenses?

A Rational license key indicates whether it is a Rational Suite license, such as Rational
Suite Enterprise, or a point-product license, such as Rational Purify. A node-locked or
floating Rational license file can contain multiple suite and point-product license keys.

Using Suite License Keys

A Rational Suite license key lets you run all of the products contained within a
Rational Suite at the same time on a single system. The Rational Suite checks out a
single floating or node-locked suite license key.

Using a Different Suite License from the Suite Edition Installed

You can install a Rational Suite on a client and specify that products within the Suite
check out a different type of Rational Suite license. For example, you can install
Rational Suite Enterprise on the client and have the point products within the
Rational Suite check out a Rational Suite AnalystStudio license from the Rational
license server.

To select a different license for a product, use the License Key Administrator’s License
Usage Mapper. See Changing License Usage Order on page 37 for more information.

Upgrading Licenses

If you are upgrading from an earlier version of a Rational Suite or point product,
reuse your current Rational Suite and point-product license keys.

Adding Rational Suites or Point Products to Licenses

46

This section describes the conditions under which you must order new license keys.

= |f you have purchased a different type of Rational Suite from the one you are
currently using, request a new license file that includes the new Rational Suite key.

= If you are adding a new product to your system, request a new license file that
includes the new point product license key.
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Rational Licensing Configurations

This section describes licensing configurations supported by Rational Software. The
term supported refers to a licensing configuration that Rational has tested and
guarantees will work under normal operating conditions. This applies to
configurations that the software was designed to handle. This also applies to
configurations for which the software was not specifically designed, but with which it
will work with some manual intervention.

Table 8 lists license configurations that Rational does support.

Table 8 Rational Licensing Configurations
. . S ted
Configuration upporte Notes
Platforms
Node-locked license key in a file Windows This configuration is fully
supported starting with Rational
Common Licensing 1.0.
Node-locked license key in a file UNIX This configuration is fully
supported starting with Rational
Common Licensing 1.0.
Rational license server and Rational | Windows This configuration is fully
Windows products installed on a supported starting with Rational
single system Common Licensing 1.5.
Rational license server and Rational | UNIX This configuration is fully
UNIX products installed on a single supported starting with Rational
system Common Licensing 1.0.
Floating licenses for Windows UNIX system This configuration is supported

products.

serving licenses to
Windows clients

starting with Rational Common
Licensing 1.5.

Floating licenses with redundant
license servers

Windows system
serving licenses to

This configuration is not yet
officially supported by Rational.

UNIX clients
Floating licenses with redundant UNIX system This configuration is not yet fully
license servers serving licenses to | supported by Rational Common
UNIX clients Licensing.

Rational Licensing Configurations 47
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Requesting License Keys

Permanent (or Term License Agreement) license keys are managed through the Web
tool AccountLink (https://www.rational.com/accountlink). You, as the license
administrator, order or return permanent license keys in AccountLink.

The information in this chapter is intended for system administrators or users who
manage licenses. It provides information about the following license administrator
tasks:

= Requesting and receiving permanent license keys from AccountLink
= Upgrading permanent license keys
= Adding products to permanent license keys

Setting up the Rational license server and importing the license keys on the server are
covered in Installing Floating and Named-User Licenses on page 55.

Using AccountLink to Request Permanent License Keys

To use AccountLink, you need the License Key Certificate that Rational includes in your
product shipment. This certificate, enclosed in a large green envelope, provides your
license information. The Rational Account Number on this certificate verifies your
company has purchased licenses to run Rational products.

In AccountLink, you can order and return permanent license keys for Windows and
UNIX products. AccountLink supports all license types: floating, named-user
floating, and node-locked licenses. For more information about license types, see
License Types and License Key Types on page 42.

Note: AccountLink does not support temporary license key transactions.
AccountLink’s interface offers three license transactions:

1 Get License Key(s) — Order your permanent license key by registering your Rational
software to a specific system. To order a permanent license key, you need your
Rational License Key Certificate and the hostname or ethernet address of the
license server or client system.

You can register:
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o Rational Windows or UNIX products that will be served from a Rational license
server.

2 Single, multiple, or redundant Rational license servers on Windows or UNIX
systems.

s Remote Windows or UNIX systems; you do not need to sit at the system you
are requesting license keys for.

To find out more about the host ID, see Finding the HOST ID on page 50. To order
permanent license keys for a redundant server environment, specify the
redundant servers’ host IDs in the following order:

a Primary license server

b Secondary license server

c Tertiary (Backup) license server

The client systems communicate with the redundant servers in that order.

2 Return License Key(s) — Return the existing license key to your Rational account and
then order a license key for the new system. This adjusts the count of registered
products in your account and allows you to get the license key for the new system.
To learn more about returning license keys, see Returning or Moving License Keyson
page 69.

3 Request a Copy of a License File — Get a copy of a license key file for any system that
has license keys already registered to it. You will need this transaction when your
hard disk is reformatted, you need to restore the software on your system, or your
license keys become corrupt. It does not require you to return or add license keys.

Using Getting Started

The Getting Started Web pages provide step-by-step instructions, examples, and
graphics for obtaining and installing Rational license keys. Click the Getting Started
link on the AccountLink Web page.

Finding the HOST ID

The term host ID is a generic term that is used to signify to specify the host or system’s
disk serial number or ethernet address.

The HOST ID field is used to associate the key with other entities; the most common
are the system’s DISK_SERIAL_NUM (disk serial number) or the ethernet address
(network id).
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With Rational Common Licensing, the default HOST ID value on Windows systems is
the disk serial number of the user’s boot drive. In this case the HOST ID field appears
as: DISK SERIAL NUM=nnnnnnn. Example: DISK SERIAL NUM=12345678.

The default HOST ID value on UNIX systems is the ethernet address of the system
written in the format HOSTID=nnnnnnnnnnnn. Do not confuse the format
HOSTID=nnnnnnnnnnnn With the disk serial number format

DISK SERIAL NUM=nnnnnnnn thatis referred to in Rational Software
documentation, online Help, and AccountLink as the host ID.

Rational does not allow for multiple values of HOST ID to be defined within a single
key.
Finding the Host ID on a Windows System

To get the hostname, host ID, or ethernet address of a Windows system, select License
> Host Data in the Rational License Key Administrator’s menu bar.

Note: If Rational software is not installed on the license server or client, Rational
AccountLink provides a tool to help you find this information.

What if the Host ID on My System Changes Frequently?

Registering the host ID of the boot drive may not be optimal if you have dual boot
systems, you frequently reformat your disks, or you ghost your disk images because
these processes change the host ID of the boot drive. Because the products and license
keys are registered to a specific host ID, you cannot use your Rational products if the
host ID changes.

To avoid this situation, use one of the following approaches:
= Use floating licenses served by a license server with a constant host ID.
= Use the address of the ethernet card in the system as a host ID instead.

a To find the ethernet address, see Finding the Ethernet Address on a UNIX System
on page 52 and Using the Ethernet Address on a Windows System on page 52.

b If you are using a Rational product release earlier than 2001 on a Windows
system, you also need to change a registry setting. To change the setting, see
Using the Ethernet Address on a Windows System on page 52.

= Make sure that when images are created to refresh the system you keep the disk
serial number of the boot drive constant.
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Using the Ethernet Address on a Windows System

On Windows systems, the License Key Administrator (LKAD) can be forced to use the
ethernet address instead of the disk serial number. This will allow the LKAD to
import the license key file correctly. Add the registry setting “UseNIC=TRUE” to
HKEY_LOCAL_MACHINE\SOFTWARE\Rational Software\Licensing\1.0.

Note: You do not need to add this setting if you have installed Release 2001 of
Rational software and of the Rational license server.

Finding the Ethernet Address on a UNIX System

On UNIX systems, use GLOBEtrotter’s 1mhostid command to find the ethernet
address of the system. On Sun systems, 1mhostid returns the value of the Sun
hostid command.

Requesting License Keys (Without an Internet Connection)

This section summarizes the steps for getting a node-locked or floating permanent
license key when you do not have an internet connection or when Rational
AccountLink is unavailable.

1 Find your License Key Certificate in your Rational product shipment.

Print the license request form. To print the form, either install the Rational product
that you purchased and open the license request form in the Rational common
directory or open the file in the Rational Solutions for Windows installation
CD-ROM. The Chinese, French, German, and Japanese versions of this fax form
are in the same location.

»  <Rational_directory>\common\License Fax Form - English.htm

»  <cd_drive>\commonl\License Fax Form - English.htm

=  <Rational_directory>\common\License Fax Form - Chinese.htm

= <cd_drive>\common\License Fax Form - Chinese.htm

= <Rational_directory>\common\License Fax Form - French.htm

<cd_drive>\commonl\License Fax Form - French.htm
<Rational_directory>\common\License Fax Form - German.htm
<cd_drive>\common\License Fax Form - German.htm
<Rational_directory>\common\License Fax Form - Japanese.htm
<cd_drive>\common\License Fax Form - Japanese.htm

2 Use the License Key Certificate to fill out the form. Make sure that the contact,
Rational account number, product, licensing, and host information are correct.
Any errors will cause delays in receiving your license keys.
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3 Fax the request to Rational. See Contacting Rational Licensing Technical Support on
page xiv for phone and fax numbers.

Call Rational Licensing Support if you cannot use Rational AccountLink or the fax
form to order your permanent license keys. See Contacting Rational Licensing Technical
Support on page xiv for phone numbers.

Receiving Permanent License Keys

After you register your Rational products to a specific system in AccountLink,
Rational generates a license file that contains the license key(s). The file is sent
through e-mail to the contact e-mail address that you designate in AccountLink’s
License Contact page.

If you request a permanent license key by fax and you have specified an e-mail
address in your contact information, you will receive a license key file through e-mail.
You can copy the permanent license file from the e-mail enabled system and install it
on the system that is not e-mail enabled.

If you cannot provide an e-mail address, contact Rational Licensing Support. See
Contacting Rational Licensing Technical Support on page xiv for the phone numbers.

After you receive the license key file:
= Import the floating license key file on the license server that you specified, or
» Send the node-locked license key file to the client system you specified.

For more information about importing a license key file on a license server, see
Installing Floating and Named-User Licenses on page 55.
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Installing Floating and
Named-User Licenses

Floating licenses, including named-user floating licenses, let you manage and
maintain licenses on a single license server or redundant license servers.

This chapter describes how to set up and run Rational’s floating license services. The
information in this chapter is intended for system administrators or users who
manage licenses. If you are using node-locked licenses, see Installing Node-Locked

Licenses on page 29.

Setting Up Floating and Named-User Floating Licenses

The steps required to set up floating (temporary or permanent) licenses are described

in Table 9.

Table 9 Guide to Setting Up Floating Licenses

To

Procedures

Set up floating licenses

1 Make sure your license server and clients can work
with the network configuration that you have set up.
See Working with a Supported Network Configuration on
page 56.

2 Install the Rational license server software on the
license server system. See Installing the Rational License
Server Software on page 57.

3 Install the evaluation or permanent floating license
keys on the license server system. See Importing
Named-User and Floating License Keys on page 61.

4 Start the license server software. See Starting the License
Server on page 63.

5 Tell client users to specify the Rational license server in
their clients.
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Table 9 Guide to Setting Up Floating Licenses (continued)

To Procedures

Set up named-user floating 1 Make sure your license server and clients can work
licenses (only applies to Rational with the network configuration that you have set up.
Purify, Quantify, and See Working with a Supported Network Configuration on
PureCoverage) page 56.

2 Install the Rational license server software on the
license server system. See Installing the Rational License
Server Software on page 57.

3 Install the named-user floating license keys on the
license server system. See Importing Named-User and
Floating License Keys on page 61.

4 Edit the rational.opt file with the names of specific
users. See Editing the Options File (rational.opt) on
page 63.

5 Start the license server software. See Starting the License
Server on page 63.

6 Tell client users to specify the Rational license servers
in their clients.

Configure redundant license See Setting Up Rational Redundant Servers on page 65.

servers

Modify the time-out period See Modifying the Floating License Time-Out Period on
page 64.

Remove the license server See Removing the Rational License Server Software on

software page 66.

Working with a Supported Network Configuration

This section provides important information about network configurations.

Dial-Up Support

You can use floating licenses with a dial-up network connection that supports a
constant TCP/IP connection to the Rational license server. Any client must have a
constant TCP/IP connection to the license server.
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If the dial-up connection is lost while a client has checked out a floating license, the
server will automatically reclaim the floating license. When the connection is lost, the
client cannot periodically “talk” to the license server to refresh its license. Because the
client cannot refresh its license, the Rational product will run for a limited period of
time. This time period is product dependent.

WAN Support

Rational floating licenses can be used over a wide area network if this is in compliance
with the geographical allowance of the License Agreement.

If you choose to run licenses over a WAN, be aware of how your systems resolve
hostnames. Rational recommends, but does not require, that you always use the fully
qualified domain names in the SERVER line and on the clients. This technique tends
to reduce the number of issues with hostname resolution.

Novell Support

Rational’s licensing implementation does not support Novell Netware 5.0 or later
directly with floating licenses. Rational floating licenses can be used in a Novell 5.0
environment that is configured with TCP/IP and/or IPX.

Node-locked licenses with Novell 5.0 are supported.

Installing the Rational License Server Software

This section describes how to use the Rational Software Setup program to install the
license server software, software that allows you to flexibly install and manage license
keys. You do not have to have a license key to operate the Rational license server
software.

Before You Install the License Server Software

The following sections provide requirements for installing the license server.
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Installation Requirements

Table 10 lists the system and software requirements for installing the Rational license
server software.

Table 10 Rational License Server Requirements

Item Requirement

Operating System Microsoft Windows NT 4.0, Service Pack 2 or greater
Microsoft Windows 2000

The Windows systems must have a C drive.

On UNIX systems, the Rational license server is available
on all platforms that support Rational’s products.

Processor 133 MHz or greater

Memory 64 MB

Disk space 73 MB

Privileges Windows administrator privileges on the local system

Note: Make sure that you have a current backup of your Registry and system
directories before running the Rational Software Setup program.

Default Installation Path

The Rational Software Setup program uses C:\Program Files\Rational as the default
installation path. If your C:\ drive lacks sufficient free disk space, you may either
specify another drive or make space available on the default drive.

Warning: Interrupting an installation that is in progress may leave your system in an
indeterminate state. If you try to close the Rational Software Setup window while
the installation is in progress, the Setup program asks you to confirm that you
want to exit from the incomplete installation.

Using the Rational Software Setup Procedure
This section describes a Typical installation of the Rational license server software.

1 Insert one of the Rational Solutions for Windows Discs into your system’s
CD-ROM drive.

The Rational Software Setup program starts automatically.

If autorun is disabled on your system, click Start > Run and enter
drive: \Setup.exe where drive is the letter of the CD-ROM drive.
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The Rational Software Setup dialog box provides general information about the
software installation.

On the Choose Product dialog box, choose Rational FLEXIm License Server.

Choose to accept or not accept the Rational Software license agreement in the
License Agreement dialog box.

2 If you accept the license agreement, the Setup program continues.

= If you do not accept the license agreement, you cannot continue with the Setup
program. Exit the Setup program by clicking Finish or Cancel. The Setup
program exits and makes no changes to the system.

The Select Configuration dialog box displays the setup options for the software.
The only choice available for the license server is Typical.

The Upgrade Compatibility dialog box appears if you have earlier versions of
Rational products already installed on the system. When you have earlier versions
of Rational products installed on your system, ensure that all Rational products on
that system are upgraded to the same version. Because Rational tools share files
and components, a new installation can cause the older Rational products to stop
working.

For each of the Rational products listed in the Upgrade Compatibility dialog box, we
strongly recommend that you do one of the following:

2 Upgrade it: Complete the installation, and then restart the Setup program to
upgrade the earlier versions of Rational products. For example, if you have
stand-alone installations of Rational point products on your system, upgrade
each product. If you have a Rational Suite and a point product on the same
system, upgrade both Rational products to the same version. Upgrading each
product updates all necessary files, registry entries, startup menu items, and
shared components on your system.

s Remove it: Complete this installation, and then see the Rational Suite Installation
Guide for the removal procedure.

The Confirmation dialog box displays the product features that will be installed.

The Error Summary dialog box displays errors from the first part of the Setup
program. If the installation is successful, you do not see this dialog box.

The Rational Software Setup program writes a log of installation activities. The log
file is located in <Install Path>\Rationa\RSSetup\RSsetup.log.
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Possible Reboot Required

If files required for the installation are in use during the Rational Software Setup
program, and if the program needs to install shared components on your system, the
Setup program may need to reboot your system. After rebooting, do the following:

1 Log on as the same administrator to complete the installation procedure. If you do
not log on as the same administrator, the installation does not complete correctly.

The installation process completes on your system.
2 Click Finish.

Note: Install the floating license keys on the license server before you start the license
server.

Using the Rational License Key Administrator (LKAD)

The Rational License Key Administrator (LKAD) is installed with your Rational
software and with your Rational license server software. This Rational program
provides an interface to Rational Common Licensing features. Use the LKAD to enter
or import license keys and change your license configuration.

= To access the LKAD on a client system, click Start > Programs > Rational product
name > Rational License Key Administrator.

= To access the LKAD on a license server system, click Start > Programs > Rational
License Server > Rational License Key Administrator.

The Help explains how to use the LKAD to review and modify your license
configuration. The LKAD Help also provides information about configuring the
license server software. To access the Help, click Help in the License Key
Administrator’s main menu or open <Install Path>\Rationa\Common\licadmin.hlp.

Using the LKAD During the Rational Software Setup Program

To take care of licensing tasks before you install a product, open the Rational License
Key Administrator from the Rational Software Setup program. The Rational Software
Setup offers a Configure Licenses button in the Choose Product dialog box. When you see
the License Key Administrator appear, import a node-locked license key, enter an
evaluation license key, and specify a license server. After you configure product
licensing, return to the Rational Software Setup program and install the product.
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Reviewing Your License Information in the LKAD

By default, you should see complete information about your license keys in the main
window of the License Key Administrator. If you do not see this information in the
window, use the View > Show menu to display information about your licenses.

Table 11 defines each of the options in the View > Show menu.

Table 11  Show Licenses

License Shows

Invalid and Expired Licenses | All expired node-locked, floating, and served licenses
on the system that you are using

Floating Licenses All floating licenses on the system that you are using

Node Locked Licenses All node-locked licenses on the system that you are
using

Served Licenses All floating licenses that Rational software on your

system could request from the license server

Importing Named-User and Floating License Keys

This section describes how to install permanent or evaluation license keys on the
Rational license server.
Importing Permanent or Term License Agreement (TLA) License Keys

Import the permanent license key file on the license server by using the Rational
License Key Administrator (LKAD).

To import a license key file:
1 Select License > Import License Key(s) on the menu bar.

2 Inthe Import License Key(s) dialog box, find the .upd or .txt file (license key file) and
highlight it.

3 Click Open. The default location for the license key file is
<Install Path>\Rational\common.

4 The Restart License Server dialog box will ask you whether you want to restart
the license server. Stop and restart the license server to make the latest license key
available for license requests.
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Other Methods

= If your e-mail program supports launching programs from file attachments,
double-click the .upd or .txt attachment in the e-mail notification you received
from Rational Software. Select Open it in the Opening Mail Attachment dialog
box. Click the Import button in the Confirm Import dialog box.

= Save the file attachment to any folder and double-click the license file.

Entering Temporary or Evaluation License Keys

You may enter a temporary or evaluation license key on the license server if you are
evaluating the product or AccountLink is unavailable.

The temporary or evaluation license key information, including the expiration date, is
on your License Key Certificate. The License Key Certificate is enclosed in a large
green envelope in your Rational Software product shipment.

Enter the temporary license key information on the license server by using the
Rational License Key Administrator (LKAD).

» To open the LKAD during the Rational Software Setup program (before you install
the product), click Configure Licenses in the Choose Product to Install dialog box.
The License Key Administrator main window and the License Key Administrator
Wizard dialog box appear.

= To open the LKAD after you have installed the Rational product, click Start >
Programs > Rational product name > Rational License Key Administrator. The
License Key Administrator main window and the License Key Administrator
Wizard dialog box appear.

To enter temporary license information:
1 Select License > Enter a License in the menu bar of the License Key Administrator.

2 Choose the type of license you are installing: a Node-Locked License Key or a Floating
License Key.

3 Inthe next dialog box, enter the following information from your License Key
Certificate:

s Product
2 Expiration Date
2 License Key

2 Quantity (if you are installing a floating license key)
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4 Click Finish. The License Key Administrator creates a *. dat file for the license key
in <Install Path>\Rational\common.

Importing Named-User Floating License Keys

Named-user license keys behave like floating license keys except the License Key
Administrator (LKAD) offers you the opportunity to specify a user for each license
key. You assign a user to a key by editing the rational.opt file. The options file locks the
floating license key to the user; allowing the user to run Rational Purify, Quantify, or
PureCoverage on multiple systems.

Editing the Options File (rational.opt)

Beginning with Release 2002.05, the LKAD provides an options file in which you can
assign named-user license keys. As soon as you import the license key file, the Edit
Options File dialog box appears. If you choose to edit the file:

1 The options file automatically appears in a text editor. Follow the instructions in
the file for the correct syntax in assigning user ids to license keys.

2 After you edit the file, save it, and then close the file.

Note: You can edit the options file while the license server is running, but stop and
restart the license server after you have edited the file. See Starting the License Server on
page 63 for the Stop and Start buttons.

Starting the License Server

Start the Rational license server after you have imported or entered the floating
license keys.

Note: The Rational license server will not start until floating license keys are installed.

Starting the License Server on Windows 2000

1 Click Start and select Settings > Control Panel > Administrative Tools > Services >
FLEXIm License Manager.

2 In the General tab, click the Start button under Service Status.
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Starting the License Server on Windows NT
1 Click Start and select Settings > Control Panel > Services.

2 Select the FLEXIm License Manager in the Services dialog box and click the Start
button.

Note: Although the control panel applet may still appear on your system from an
earlier release of Rational server software, version 2001 does not use the FLEXIm
control panel applet.

Switching to Manual Startup

The Rational license server software is automatically set as a Windows NT service.
The default Startup type is automatic, which means the license server starts
automatically each time you start the system. If you prefer to manually start the
license server, switch the startup type.

Switching Startup Type on Windows 2000

1 Click start and select Settings > Control Panel > Administrative Tools > Services >
FLEXIm License Manager.

2 Inthe General tab, select manual under Startup type.

Switching Startup Type on Windows NT

1 Click Start and select Settings > Control Panel > Services > FLEXIm License
Manager.

2 Inthe dialog box, select manual under Startup type.

Modifying the Floating License Time-Out Period

The Rational license server will reclaim a floating license when the product has not
been used for a default period of 120 minutes. If you use the product again after the
server has reclaimed its license, the product will check out the license again from the
server.

To change the time-out period, create a text file called rational.opt in the <rational flexim
dir-\common directory. Enter one of the following two commands in the text file:
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1 TIMEOUT feature seconds directs the license server to reclaim the feature
(the product as it is listed in your license key file) after the number of seconds that
you enter into the file.

2 TIMEOUTALL seconds directs the license server to reclaim all products after the
number of seconds that you enter into the file.

The value for each of these options must be greater than 7200 seconds (or 120
minutes).

Modifying the Time-Out Period to Stop Disconnected Mode

The disconnected mode lets you use Rational software at home within a 3 day period
of acquiring a license key and disconnecting from the network at work. However, if
you have a slow network at work, your software automatically goes into disconnected
use mode if it does not receive a response from the Rational license server within 5
seconds. You then see a dialog box that states you are in disconnected use mode after
the 5 seconds.

Starting with release 2001A, you can change the time-out period before your Rational
application goes into disconnected use mode. The default setting is 5 seconds. To
change the setting:

1 Create a DWORD key: HKEY_LOCAL_MACHINE\SOFTWARE\Rational
Software\Licensing\1.0\DisconnectTimeout

2 Modify the value (decimal) to be larger than 5 seconds.

Setting Up Rational Redundant Servers

Rational license servers can be set up to run in a fault-tolerant configuration known as
redundant servers. Redundant servers are a system of three servers that work as a team
to manage a single pool of floating license keys. If one of the server systems goes
down, the other two license servers automatically continue managing the license
pool.

Example

You have purchased 25 floating licenses of Enterprise Suite and wish to set up a
redundant server configuration on three Windows systems. You request permanent
keys for the redundant servers using AccountLink. You install the Rational license
server software on each of the three redundant server partners; servers A, B, and C.
When you receive the license file of 25 permanent floating keys, you install the license
file on each server.
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The three servers work as a team to manage all 25 floating licenses in unison. When
you have 20 license keys checked out to your users and server A crashes, servers B
and C continue to manage the 25 licenses.

Warning: It is a common misperception that separating redundant servers across
multiple sites (for example, one in US, one in Europe, one in Asia) provides
maximum fault tolerance. This is not the case. Redundant servers should always
be at the same site and on the same subnet.

To configure redundant license servers:

1 Install license server software on three systems. See Working with a Supported
Network Configuration on page 56 and Installing the Rational License Server Software
on page 57.

2 Import a license file that you receive from Rational on each license server. See
Importing Named-User and Floating License Keys on page 61 for more information.

3 Start the license servers. The sequence is unimportant, but you should start the
servers soon after one another. See Starting the License Server on page 63 for
instructions.

4 Give users the Primary, Secondary, and Tertiary (Backup) license server hosthames
in the order in which you requested them in AccountLink.

Removing the Rational License Server Software

This section describes how to remove the license server software from the system.

Before You Remove the License Server Software
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1 Make sure that no one is using the license server or any associated files. You
cannot remove files that are in use.

2 Return the license keys to your Rational Account through AccountLink
(www.rational.com/accountlink), the online license management tool. For more
information about moving or returning licenses, see Returning or Moving License
Keys on page 69.

3 To remove the software from a Windows NT system, you must have Windows NT
administrator privileges on the local system.
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Removing the License Server Software

Use the Windows Add/Remove Programs control panel to select and remove the
license server software. The Rational Software Setup program removes the files from
your system. It does not remove directories that contain files that you created while
you were using the software. It also does not remove the license key files from the

system.
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Returning or Moving
License Keys

You may need to replace an old system or decide another system should act as the
new Rational license server. Because permanent license keys are tied to a system’s
host ID, Rational products will not work on another system until you register the
products to the new system.

Returning or Removing License Keys

When you return a license key from a registered system, you do not physically give
the license key back to Rational. Instead, you use the return transaction in
AccountLink. This transaction updates Rational’s records to indicate that you are no
longer using a Rational product on that system. This adjusts the count of registered
products in your account.

After AccountLink makes the adjustments to your account, Rational sends you a
license key file that contains updated license keys. If you have returned all the license
keys for a system, the updated license file is empty. To comply with your License
Agreement, import this updated license file (whether it is empty or not) on the
system.

To return a license key:
1 Use AccountLink to return the license keys to your Rational account.

2 To complete the return process, import the license key update file that you receive
from AccountLink on the license server or node-locked system from which you
returned the license key.

Moving License Keys

If you want to move Rational software to a new system, return the existing license
keys from the old system to your Rational account. Then order license keys for the
new system.

To move license keys from one system to another:
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1 Use AccountLink to return the license keys to your Rational account.

Note: To help prevent you from confusing the license key update file for the old
system with the license key file for the new system, you may want to complete the
return process before you order license keys for the new system.

2 Import the updated license key file that you receive from AccountLink on the old
system.

3 Remove the Rational software or license server software from the old system. See
the Rational Suite Installation Guide for the removal procedures.

4 Install the Rational software or license server software on the new system.
5 Request new license keys for the new system in AccountLink.
6 Import the license key file on the new system.

7 If you moved the license keys to a new license server, give users the name of the
new license server.
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Using Other License
Configurations

This chapter describes additional configurations that Rational Common Licensing
supports. The first section provides additional procedures for license server
configurations. The second section explains additional license file options. A table in
the beginning of each section provides pointers to specific topics.

Many of the tasks in this chapter are not recommended for the casual or novice user.
Attempt them only if you are familiar with your operating system and Rational
Common Licensing.

Other License Server Configurations

Table 12 provides pointers to information in this chapter about additional license
server configurations.

Table 12  License Server Configurations

For more information about See
Monitoring Rational license server License Monitoring on page 71
activity

Windows clients using a UNIX server | Windows Clients Using a UNIX License Server on
page 72

Running multiple license servers on Rational and GLOBEtrotter recommend running a
the same system separate 1mgrd instance for each vendor daemon
and keeping license keys in separate files.

Using floating licenses with a firewall | Using Floating Licenses with a Firewall on page 74

Changing the 1mgrd port Changing the Imgrd Port on page 76

License Monitoring

You may need to monitor and report on license usage. GLOBEtrotter offers a robust
solution for license usage reporting called SAMreport. SAMreport is designed
specifically for reporting on license server activity. SAMreport offers a full set of
administrative tools that generates reports, graphs, high-water marks, and even sets
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alarms to notify individuals when a server has gone down or the license pool is nearly
exhausted. SAMreport works with any vendor's FLEXIm server. It is available only
through GLOBEtrotter. Detailed information on SAMreport can be found at:
http://www.globetrotter.com/samreport.htm.

Windows Clients Using a UNIX License Server

You can set up a UNIX license server to serve floating licenses to Windows clients. If
you have purchased DevelopmentStudio for UNIX in addition to the Rational
Windows products, see the Rational Suite UNIX installation manual or a UNIX
point-product installation manual for information about configuring a UNIX Rational
license server. You can also find UNIX installation manuals at www.rational.com. Select
Support > Documentation. Click on Install Guides under Documentation.

If you do not have access to a Rational UNIX installation manual, read the following
overview.

1 Go to AccountLink (http://www.rational.com/accountlink) to get license keys for the
products on your Windows clients. Use the Getting Started link to help you order
the license keys.

2 You need FLEXIm 6.0 or higher software and the Rational daemon to set up the
Rational license server on a UNIX system. If you not purchased Rational UNIX
products, you can download the Rational licensing executables and files from our
ftp site at:

ftp://ftp.rational.com/public/tools/flexim

When you decompress and expand the TAR files on your UNIX system, they
create this directory:

flexim.<version>/<arch_os>

You should see the following executables in the FLEXIm directory:

Name Description
lmgrd FLEXIm license server executable
rational Rational's license vendor daemon executable
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The rest of the files correspond to system-administrator commands, which the
license manager (lLmgrd) supports.

Command Description

lmdiag Allows you to diagnose problems when you cannot
checkout a license

1mdown Shuts down license and vendor daemons

lmhostid Reports license manager host ID of workstation

lmremove Returns specific licenses to license pool (for example, after
a system crashes)

lmreread Rereads license file, starts new vendor daemons

lmstat Reports status on daemons and feature usage

exinstal Reports on licenses in license file you specify on the
command line

3 After you install the Rational license server software and files on the UNIX system,
save the license file that you receive from AccountLink as a license.dat in a
directory (where you would like to maintain your licensing information). Ensure
that you do not overwrite any existing license.dat files that you may currently

have in this directory.

The default location is:

/usr/local/flexIm/licenses/license.dat

We strongly recommend that you do not set LM_LICENSE_FILE. You will not
typically need to set the LM_LICENSE_FILE variable to use Rational software

products.

4 Start the Rational license server by using the command:

Imgrd -c <licenseFilelList> -1 <logfile>

s lmgrd is the license manager that you downloaded from our ftp site to the
Rational license server host.

2 licenseFileList is the path to the license file or a list of license files.

2 logfileisthe path to alog file.

If you already have a UNIX Rational license server set up, use the lmreread
command to restart the server.

Other License Server Configurations
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5 [For convenience, you probably want to augment a system initialization script on
your license server to automatically start the license daemon each time the license
server boots.

The names, locations, organization, and contents of system initialization scripts
varies from UNIX system to UNIX system.

6 To verify that your license manager is operational, enter these commands on your
license server to see if its daemons are running:

[)

% ps axw | grep -v grep | egrep "lmgrd|rational"
or

[)

% ps -e | grep -v grep | egrep "lmgrd|rational"

7 Install the Rational products on the Windows clients and configure them to acquire
license keys from the UNIX server.

Using Floating Licenses with a Firewall

Rational’s licensing implementation supports a firewall. To configure licensing with a
firewall, give the 1mgrd daemon (license manager) and the vendor daemon (Rational
vendor or rational.exe) TCP/IP port numbers. The TCP/IP port is used for
client/server communication for floating licenses.

In a non-firewall situation, the 1mgrd daemon starts on TCP/IP port 27000 when you
start the server. (You will have to change this number if another application is using
this port number.) The 1mgrd daemon assigns a random TCP/IP port number to the
vendor daemon.

In a firewall situation, the client cannot communicate with the daemons on the license
server because the ports on which they are running are blocked. To allow license
requests to pass through the firewall, assign numbers to the vendor and 1mgrd ports.
The vendor daemon and 1mgrd daemon must start on the same ports each time a
client makes a license request and checks out a floating license from the server. The
specified ports or connections remain open until the client returns the license to the
server.

Note: The vendor daemon and the 1mgrd daemon cannot be set to the same port
number.
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The following diagram displays a sample firewall situation. The Rational product on
the right-hand side can communicate with the lmgrd daemon and rational.exe
(vendor daemon) on the license server through the firewall because the numbers
27000 and 8000 have been assigned to the ports.

Rational License File

Firewall
Imgrd running on TCRAP port 27000 I/
‘I\_‘ Rational
rational.exe running on TCRAP port 2000 / Product

When you specify the port information, the Rational License Key Administrator stores
the port information in the rational_redirect.dat file, located by default in \Program
Files\Rational\Common.

The following procedures let you change the 1mgrd and vendor ports in single,
multiple server, or redundant server environments. They assume that you have
already started the license server(s) and entered the hostname(s) of the license
server(s) in the License Key Administrator of each client.

Assigning Port Numbers in the Rational License Server

To allow clients to communicate with the license server, enter values in the 1mgrd
port and the Rational Vendor port.

To enter port numbers on a license server or redundant license servers:
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Select Settings > Service Configuration in the Rational License Key Administrator.
In the Service Configuration dialog box, click the Ports tab.

Enter values in the 1mgrd port and the Rational Vendor port, but do not set them
to the same value.

Click OK.

If the server is a redundant server, enter the same port values in the other license
servers by repeating Steps 1-4.

Give users the Rational Vendor Port value to enter into the License Key
Administrators of their systems.

Changing the Imgrd Port

When another application is using the TCP/IP port 27000 that is used by 1mgrd
(license manager daemon), change the 1mgrd port. You do not need to enter a value
in the Rational Vendor because it runs on a random TCP/IP port.

The following procedures let you change the Imgrd port in single, multiple, or
redundant server environments. They assume that you have already started the
license server(s) and entered the hostname(s) of the license server(s) in the License
Key Administrator of each client.

To change the 1mgrd port value on a license server or redundant license server:

1
2
3
4
5

Select Settings > Service Configuration in the Rational License Key Administrator.
In the Service Configuration dialog box, click the Ports tab.

Enter a value in the 1mgrd port.

Click OK.

If the server is a redundant server, enter the same 1mgrd port value in the other
license servers by repeating Steps 1-4.

Note: Do not enter a port value in each client.
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Other License File Options

Table 13 provides information about additional license file configurations.

Table 13 License File Configurations and Options

For more information about

See

Combining license files

Rational and GLOBEtrotter recommend
keeping the license keys in separate files.

Home use or travel

= Rational recommends that you contact a
Technical Support Engineer about the
disconnected use of floating licenses. See
Contacting Rational Licensing Technical
Support on page xiv for phone numbers.

Or
= |nstalling Node-Locked Licenses on page 29

= Modifying the Time-Out Period to Stop
Disconnected Mode on page 65

Disconnected use of floating licenses on
Windows systems

Contacting Rational Licensing Technical Support
on page xiv. Rational supports this feature,
but recommends that you contact a Technical
Support Engineer for instructions.

Other License File Options 77



78 Chapter 9 - Using Other License Configurations



Understanding Rational
Licensing Components

This chapter describes how Rational Software has implemented FLEXIm features and
options in Rational Common Licensing.

Locating the Licensing Components

All Rational software files and Rational license key files are installed in <Install
Path>\Rational\Common\ unless otherwise noted.

Understanding the Rational License Server Process

The following sections provide information about the Rational license server,
including descriptions of the license daemons running on the server systems.
License Server Components

The Rational license configuration includes these major components, which are
described in the following sections:

= License key file
* License manager daemon (1mgrd)

= \endor daemon

License Key File

License key definitions are stored in a text file called the license key file. Rational creates
the license key file based on the data that you provided in Rational AccountLink. The
license file can contain license key data for several Rational products and is created for
a specific host. The Rational License Key Administrator that is installed with every
Rational product edits and installs the license key file.

The license key definition contains information about the server nodes and vendor
daemons, and at least one line of data (called FEATURE or INCREMENT lines) for
each licensed product. Each FEATURE line contains a license key based on the data in
that line, the host IDs specified in the SERVER lines, and other vendor-specific data.
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License File Names

Table 14 describes the types of Rational license key files.

Table 14

License Key Files

File Name

Description

Notes

rational_temp.dat

Contains all node-locked
temporary license keys.

You must obtain a permanent
license key to continue to use your
Rational Software product past the
temporary key expiration date.

rational_perm.dat

Contains all node-locked
permanent license keys.

Go to Rational AccountLink to
request permanent keys.

rational_redirect.dat

Used on a client to specify
the name of the license
server system that
manages floating licenses.
The Rational License Key
Administrator creates or
updates this file when you
specify a license server
name on the client.

This file is initially empty. The
Rational License Key Administrator
updates this file with the name of
your license server(s) when you
select server-based licensing.

rational_server_temp.dat

Contains all temporary
floating license keys on a
license server.

You must obtain a permanent
license key to continue to use your
Rational Software product.

rational_server_perm.dat

Contains all permanent
floating license keys on a
license server.

Go to Rational AccountLink to
request new permanent license keys.
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The Floating License Server Line
This section explains the line used to set up a license server in the license key file.

A typical Rational SERVER line is similar to the following example:

SERVER curley DISK SERIAL NUM=12345678

Item in SERVER Line | Description

SERVER Tells the server that the license file will be used for floating or
counted node-locked licenses. This is needed in a floating license
file along with a VENDOR or DAEMON line.

curley The hostname of the license server system.

Allows the license server’s hostname or IP address to populate the
hostname field in the SERVER line. Rational also allows both
values. The hostname value is not encrypted into floating license
keys.

12345678 The host ID of the license server system.

The default value is the disk serial number (DISK_SERIAL_NUM)
of the user’s boot drive. The HOST ID value is encrypted into
floating license keys.

Entering the License Server Name on the Client

When you enter the name of the license server in the License Key Administrator
(LKAD) of the client, the LKAD writes the hostname of the license server to an empty
license file in the <rational>\common directory on the client.

License Manager Daemon (Imgrd)

Rational uses two daemons (or processes) to manage floating licenses:
* 1mgrd, the license manager daemon

» vendor daemon

The 1mgrd daemon and the vendor daemon work together to manage the license keys.
The 1mgrd handles the initial contact with the client application programs, passing the
connection on to the appropriate vendor daemon. It also starts and restarts vendor
daemons.

By default, the 1mgrd on Windows is a Windows NT service.

The 1mgrd daemon starts on TCP/IP port 27000 (default) when you start the server.
The 1mgrd daemon will assign a random vendor TCP/IP port number (unless you set
up a firewall) to the vendor daemon and start the vendor daemon on that port.
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License Manager Version

Rational currently ships 1mgrd version 7.0 or later with Rational Common Licensing
on Windows and version 6.0 or later with UNIX products.

Vendor Daemon

The vendor daemon is a program developed by Rational implementing FLEXIm. The
vendor daemon keeps track of how many licenses are checked out and who has them.
Rational’s vendor daemon (rational.exe) is customized to behave in a specific manner.

Rational specifies the path to the rational.exe vendor daemon using the DAEMON line
in the license key file. Rational also supports specifying the path to the options file on
the DAEMON line after the path to the vendor daemon.

A typical Rational DAEMON line for Windows appears as:

DAEMON rational D:\Rational\common\rational.exe

Where:

Item in DAEMON Line Description

DAEMON Rational’s license daemon name and path are specified
in this line.

rational The name of the Rational license server daemon. Both
floating and node-locked licenses have this value
defined in the DAEMON string.

<install path>\ The path to Rational’s license server executable.

Rational\common\rational.exe

Licenses are granted by running processes(unless they’re node-locked, uncounted, in
which case they only need to read the license key file to run). There is one process or
vendor daemon for Rational which has a licensed product on the network.

If the vendor daemon terminates for any reason, all users lose their licenses (They do
not see a warning dialog box that the vendor daemon has terminated). However, this
does not mean the applications suddenly stop running. Users can continue working,
save their work, and exit safely, because the 1mgrd (license manager) automatically
restarts the vendor daemon.

The application program communicates with the vendor daemon, usually through
TCP/IP network communications. The application program and the daemon
processes (the license server) can run on separate nodes on your network, across any
size wide-area network.
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The format of the traffic between the client and the vendor daemon is
system-independent, allowing for heterogeneous networks. This means the license
server and the system running an application can use different hardware platforms or
even different operating systems (for example, Windows NT as a server system and
Windows 98 as a client).

License Server Process

When you run a counted licensed application, such as a Rational Suite product that
uses a floating license, the following occurs:

1

The license module in the client application finds the license key file on the license
server, which lists the hostname of the license server and the port number of the
license manager daemon (Imgrd.exe).

The client establishes a connection with the license manager daemon (Imgrd.exe)
and specifies the vendor daemon (rational.exe).

The Imgrd.exe determines which system and port correspond to rational.exe and
returns that information to the client.

The client establishes a connection with rational.exe and sends its license request.

The vendor daemon (rational.exe) checks in its memory to see if any licenses are
available and sends a grant or denial back to the client.

The license module in the application grants or denies use of the feature, as
appropriate.

Uncounted features, where the number of licenses is 0 (zero), do not require a server
and the Rational common licensing library in the client grant or deny usage based
solely upon the license contents. Node-locked licenses, for example, set the license
number to 0 (zero).
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The following diagram provides an overview of the interaction between the Rational
Common Licensing Library on the client and Imgrd.exe, rational.exe, and the license key
file on the Rational license server.

Client

Rational Product - -
Rational License Server

Licensing Client Imgrd.exe *
Module {license manager dasrnaorn)

rational.exe *
wendaor daemaon)

Rational Commaon Licensing Library Rational License Key File™

Network

* Companents installed in <install pat=\Rationalicomman

The Options File for Floating Licenses

Rational provides the least restrictive licensing environment possible. By default, the
server does not restrict access to any client requesting a license key. This configuration
works best for most customers.

If you want a more controlled floating license environment, you can use the options
file to reserve or deny licenses for certain users, hosts, displays, groups, or IP
addresses. You can also limit the number of licenses each user or group can access.
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Setting Up the Options File
Create a text file, rational.opt, in the <rational flexim dir>\common directory.

Note: For the server to recognize the file or any changes made to it, restart the license
server. You will have to stop and then start the license server. The 1mreread
diagnostic tool will not work.

Enter the following commands in the file. See examples 1 and 2 for the correct syntax.

Options File Commands Description

RESERVE Tells the server to reserve a license

1 Is the number of licenses to reserve

ClearQuest Is the name of the license to reserve

USER Tells the licensing software to reserve a license for a
specific user id

greg Is the userid for which the license will be reserved

Example 1

You may have 10 floating licenses of Rational ClearQuest. You want to ensure that
users Greg and Peter always have a license of ClearQuest available for their use. Set
up the options file as follows:

RESERVE 1 ClearQuest USER greg
RESERVE 1 ClearQuest USER peter
Example 2

You have 10 floating licenses of Rational ClearQuest. You want to ensure that user Bob
does not have access to a ClearQuest license. Set up the options file as follows:

EXCLUDE ClearQuest USER bob

Diagnostic Tools

Imtools

The 1mtools application is designed to help diagnose licensing problems. It is
available on Windows only. Rational installs this application with all products in the
<rational>\common directory:. If the license server is installed, you can use the License
Tools Start menu shortcut to the 1mtools GUI.
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Imutil

By default, Rational installs the 1mutil program in the <rational>\common directory.
1mutil is fully supported with Rational’s implementation and has a number of useful

options. More information can be found at http://www.globetrotter.com/chap7.htm.

Imreread

The 1mutil 1mreread command is a supported option that forces the server to source

the license file without having to shut down the server. This allows systems

administrators to make changes to the license file without stopping and restarting the

SEerver.

Note: The Imutil lmreread command does not detect changes to the Options File on

page 84.

Windows Registry Information

This section describes the Windows Registry settings for Rational Software licensing.

Warning: Use extreme caution when editing the Windows Registry! Incorrect edits

can render your system unusable!

Windows Registry entries are located in:

HKEY_LOCAL_MACHINE\SOFTWARE\Rational Software\Licensing\1.0

The <Install Path> in Table 15 refers to the path specified during installation. The
default value is C:\Program Files\Rational.

Table 15 Rational Licensing Registry Entries

Key and Description

Default Value

UseLicense Server

Is this system using a license server to
obtain its license keys?

FALSE

LicenseRequest
Path of license request file

<Install Path>\common\rational_request.dat

LicenseTemp
Path of temporary license key file

<Install Path>\common\rational_temp.dat

LicensePerm
Path of permanent license key file

<Install Path>\common\rational_perm.dat
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Table 15 Rational Licensing Registry Entries (continued)

Key and Description

Default Value

LicenseServer

Path of file containing name of license
server

<Install Path>\common\rational_redirect.dat

LicenseServerName
Name of system used as a license server

This registry entry appears when the system
points to a license server.

Is this system a license server?

Clientinstalled TRUE
Does this system have client software

installed?

Serverlnstalled FALSE

Windows Registry Information
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Troubleshooting
Licenses

This chapter provides possible solutions based on commonly asked questions and
error messages.

The commonly asked questions are sorted into the following topics:
» Node-Locked Licenses on page 89.

= License Server and Floating Licenses on page 90.

= Requesting a License Key on page 91.

» Moving License Keys on page 92.

» AccountLink Data Entry on page 92.

= Host ID on page 93.

= Upgrades on page 93.

A short list of error messages and possible solutions are in Table 16 on page 94.

Node-Locked Licenses

What exactly is a node-locked license? How many users does it support at one
time? Does each additional user cost as much as the first?

A node-locked license supports a single user on a single system. For more
information, see What Are Node-Locked and Floating Licenses? on page 23.

Contact your Rational Sales office for information about pricing for node-locked
licenses.

Does a change in the IP address and internet address affect the node-locked
license?

Node-locked licenses use the host ID or disk_serial_num of the licensed system.
Therefore, a change in the IP address or a change in Internet address does not affect
your Rational Software license. However, you should notify Rational Licensing
Support if the e-mail address of the license contact has changed.
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License Server and Floating Licenses

How do | identify who checked out a license?

It is possible to find out who used which license and when the user did so. If the
license server is installed, click Start > Programs > Rational FLEXIm License Server >
License Tools. License Tools starts the 1mtools GUI.

1 Select Configuration using Services in the Mode menu.

2 Click the Server Status tab and the Perform Status Enquiry button in the Server
Status dialog box.

How do | set up the license server?

Set up a server by installing license server software on a system. Then request and
install permanent floating license keys. See Using AccountLink to Request Permanent
License Keys on page 49 and Receiving Permanent License Keys on page 53.

Can ClearQuest on aclient in one NT domain obtain licenses from a license
server that is on a different NT domain?

Yes, it is possible. If the client can see the license server by hostname, the request will
work. Rational licensing also supports using the fully qualified domain name or using
the IP address of the license server instead of the hostname.

How do Il install licensed software on a second disk? | have a second disk on my
system and | have requested a floating license for <product>.

As long as you have provided the correct hosthame and hostid for the second disk on
which you will install the software, you will receive a license key for the software
from AccountLink.

How do | restart my master license server? | have redundant servers and |
cannot restart my master server.

To restart a server in a redundant server configuration, restart all the servers in no
particular order. You cannot just restart the server that has gone down.

90 Chapter 11 - Troubleshooting Licenses



Requesting a License Key

How do | submit fax requests for license keys? Please give me the fax number
to which | can send my request for permanent node-locked licenses. Not all
team members have internet or e-mail so requests need to be centrally
controlled.

See Contacting Rational Licensing Technical Support on page xiv for the appropriate fax
number.

Can we request permanent license keys without entering a temporary key?
Yes, you can use AccountLink (http://www.rational.com/accountlink) to request
permanent license keys without first installing your temporary license key.

How long does it take to obtain the permanent license key?

Rational AccountLink (http://www.rational.com/accountlink) will send you the license
keys through e-mail after you submit your transaction. The speed and reliability of
your internet connection will affect when you will receive your permanent keys.
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Moving License Keys

How do we move or transfer a license to another system?

To move a license (floating or node-locked) from one system to another, see Returning
or Moving License Keys on page 69.

How long does it take to move a license key to another system?

The requests for returning and getting a new license key usually take no longer than
your initial license request.

What would happen if | did a clean installation of the operating system on my
system (which would wipe out all the license keys currently on it) without
deleting the license key first? Would it be easy to obtain a new license key or a
replacement for this key?

If you install a new version of the operating system or initialize the disk where your
license keys are stored, you can request a replacement license key from Rational. To
request a replacement, go to Rational AccountLink
(http://www.rational.com/accountlink) and select Request Copy of a License File. This
transaction does not require you to return the license key that was deleted from your
system.

How do | move a node-locked license mistakenly installed on a
database/repository server to a client system? We purchased two node-locked
licenses for two client systems. | made a mistake and requested and installed
one of the licenses on the database/repository server. | cannot install this
license on the second client because it is system-specific.

To move and return license keys, see Returning or Moving License Keys on page 69.

AccountLink Data Entry

What is my Rational Account Number? | just downloaded the upgrade to
<product>. | am now unable to run the software. | do not know my “Rational
Account Number” which is arequired field in AccountLink.

Use the Rational Account number specified on your License Key Certificate.
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Host ID

Why isn’t host ID ffffffff valid? ffffffff is the value listed in the host ID field in the
License Manager.

When you initialized your disk, your disk did not receive a disk_serial_num.
Although the software accepted this entry, Rational's licensing services regards this
value as invalid.

You can reset your host ID by using third-party disk utility tools such as those by
Norton. Another option is to use the Ethernet card address instead of the host ID.

| changed my file system from FAT to NTFS, which changed my host ID. Could
you please change my key to make it work again? | changed my system disk
and the licenses no longer work.

The license keys are generated for a specific hostname and host ID. You have to return
the license keys to your Rational account and then request license keys for the new
host ID. To perform these transactions, go to AccountLink
(http://lwww.rational.com/accountlink).

Upgrades

We received two upgrade packets but chose not to upgrade immediately
because we were in the middle of pre-release testing. The License Key
Certificate says, however, that the key expires on <date>.

Contact your Rational Sales Office to obtain temporary license keys that will work
until you are ready to upgrade your system.

Error Messages

Table 16 lists licensing error messages and their solutions.
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Table 16

Licensing Error Messages

Message or Description

Action

Cannot find SERVER hostname

Cannot find SERVER hostname in
network database

Cannot connect to SERVER
NO SUCH FEATURE EXISTS

Failed to check out a
<product-name> key

Floating Licenses
Confirm on the client:

= You have entered the correct name for the license
server (in the Service Configuration dialog box
of the License Key Administrator). For more
information, see Checking Client Licensing Set Up
on page 95.

= You have entered the correct Rational vendor
port number if there is a firewall between the
client and the license server. For more
information, see Using Floating Licenses with a
Firewall on page 74.

= Your system is connected to the license server
(that you specified in the Service Configuration
dialog box of the License Key Administrator).
See Checking the Network Connection on page 96.

Confirm on the Rational license server:

= The license server (lmgrd) and the rational.exe
or vendor daemon are running. See Checking the
License Server on page 97.

= There are numbers assigned to the 1mgrd and
vendor ports on the license server (if there is a
firewall between the license server and the
client). For more information, see Using Floating
Licenses with a Firewall on page 74.

Floating and Node-Locked Licenses

In all cases, if you do not see any problems with the
network connection or the license file, yet
applications cannot acquire license keys, stop and
start the license server from the FLEXIm License
Manager (Starting the License Server on page 63). It
may also be helpful to reboot the server,
particularly if the license manager is running as an
NT service. If all else fails, contact Rational
Technical Support.
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Table 16 Licensing Error Messages (continued)

Message or Description

Action

The license was not intended for this
Server.

License keys are not for this
machine.

= You are installing the license key on a system
other than the one for which the license key was
generated. The license.upd file specifies the
system name and host ID that you entered in the
license key request to Rational (AccountLink).
Import the file on the correct system.

= Confirm that the license key file you received
contains the correct hostid and hostname of the
license server or client system. To find this
information, use a text editor to view the license
key (*.dat) file in <Install
Path>\Rationa\Common\.

Compare the Disk Volume Serial Number found
in License Tools > System Settings, with what
appears in the Server line in the license key file.
These two numbers should match. Occasionally
a 0 or a dash will be found in the license file.

The license for this product will
expire...

Your temporary or Term License Agreement (TLA)
license key is nearing its expiration date. To
continue using the product, contact your Rational
Software sales representative to purchase the
product or extend your TLA.

Click OK to run the product.

This warning message appears each time you start
the application until you install a permanent license
key or another TLA license key.

You can turn off the warning by clicking Settings
> Display Expiration Warnings in the Rational
License Key Administrator.

Checking Client Licensing Set Up

The following list lets you check whether your client is correctly configured for

Rational Common Licensing.

» Check the entry or entries for the license server(s) in the Service Configuration
dialog box of the LKAD. If you are unsure about the format in which the server

hostname should be entered, go to your Rational license server and click Rational
FLEXIm License Server > License Tools. This brings up LMTools, a FLEXIm utility

that is a GUI version of the command line utility lmutil.

Click the System Settings tab in the LMTools dialog box. Check the entry next to
Computer/Hostname under Hostid Settings.
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= |ninstall_directory\Rational\common look for the file rational_redirect.dat. Make sure
that the contents of the file are:

SERVER server hostname ANY
USE_SERVER

* In the Windows registry, look under HKEY_LOCAL_MACHINE\SOFTWARE\Rational
Software\Licensing\1.0. The value "LicenseServer" should be set to the complete
path to rational_redirect.dat.

Example: install_ directory\Rational\common\rational_redirect.dat

Checking the Network Connection

The following procedures lets you check the network connection between the license
server and the client system.

1 Ontheclient, bring up an MS-DOS window by clicking Start > Run and typing cmd
in the Open text box.

2 Typeping server hostname at the command prompt.

If you see an IP address appear, a system of that hostname has responded. There
may be more than one system on the network with the same hostname. To make
sure the IP address that you see in the Window is the license server’s IP address,
check the IP address of the server.

To find the IP address of the license server:

a Go to your Rational license server and click Rational FLEXIm License Server >
License Tools.

b Click the System Settings tab in the LMTools dialog box.
¢ Check the IP address under Hostid Settings.

If you cannot ping the license server by hosthame, ping it by its IP address. If this
is successful, you will have to either correct the name resolution problem on your
network or replace the hostname with the IP address in the license key file.

To replace the hostname in the license key file:

a Ininstall_directory\Rational\common of the license server, look for the file
rational_server_perm.dat.

b Replace the hostname with the IP address in the line that begins with SERVER:

SERVER server hostname server hostid...
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Cc

Do not change the server hostidand the vendor daemon information on
this line.

Enter the IP address of the server in the LKAD’s Service Configuration dialog
box.

Checking the License Server

Use the following procedure to determine whether one or both of the license
daemons, Imgrd.exe and rational.exe, on the license server are not running.

1 Click Start > Programs > Rational FLEXIm License Server > License Tools. This
brings up Imtools, a FLEXIm utility that is a GUI version of the command line
utility Imutil.

2 Inthe Servicel/License File tab, select Configuration using License File and enter the
complete path (including drive letter) to the license file on the license server in the
text box.

3 Go to the Server Status tab. Select Display Everything and click Perform Status
Inquiry button.

a

If the license server is running, you will see the following lines in the status
output window:

server hostname: license server UP (MASTER) v_number

Vendor daemon status (on server hostname) :
rational: UP v_number

The first line refers to the status of Imgrd.exe, the second line to the status of
rational.exe.

Since the Rational license server software is running, the problem may be the
network communication between client and server. See Checking the Network
Connection on page 96.

If Imgrd.exe is running, but rational.exe is not, the following lines will appear in
the status output window:

server hostname: license server UP (MASTER) v_number

Vendor daemon status (on server hostname) :
rational: The desired vendor daemon is down.

Use the following methods to start the rational.exe:
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o The daemon rational was unexpectedly terminated and 1mgrd has not yet
restarted it. Select the Stop/Reread tab in the License Tools utility. Expand the
Remote Server List and select rational. Click the Reread License File button.

2 The license file does not correctly specify the path to rational.exe in the line:
DAEMON rational [complete path to rational.exe, including drive letter].

s The version of Imgrd.exe may be incompatible with rational.exe. You already
have FLEXIm (Imgrd.exe) installed on the license server system. Confirm that
the date and size of the file install_directory\common\imgrd.exe matches the
Imgrd.exe found on the Rational Solutions for Windows CD-ROM in \common.

¢ If both Imgrd.exe and rational.exe are not running, the resulting status output
window will contain the lines:

lmgrd is not running: Cannot connect to server and
FLEX1Im error: -15.10.

Use the following methods to start the Imgrd.exe and the rational.exe:
2 Review the setup and start instructions for the Rational license server.

s There may be a phantom "rational" process running. This occurs when the
1mgrd process is terminated unexpectedly. Press CTRL-ALT-DEL to bring up
the Task Manager. On the Processes tab, look for rational.exe and/or Imgrd.exe.
Terminate these processes. Start the license server (see Starting the License Server
on page 63) and check the Server Status in Rational FLEXIm License Server >
License Tools. If the license server is still not running, and it is configured to
run as an NT service, restart the system twice.

2 The FLEXIm License Manager application may be out of date or corrupted.

Technical Notes

The Rational Web site contains Technical Notes about licensing issues. For example,
you can use a Technical Note to find out how to:

= Use the options file to exclude certain users.
= Troubleshoot the license server functions.

New Technical Notes appear on a regular basis. Go to http://www.rational.com. Click
Support > Technical Notes > Licensing (Technical Notes Index) to see the Technical
Notes about Rational Common Licensing.

For more technical notes related to licensing Rational Suite, click General or Rational
Suite Enterprise, under Rational Suite (Technical Notes Index).
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Licensing Glossary

AccountLink. The Rational Web-based license management tool. Customers can use this tool to request
and return licenses to their Rational accounts.

ANY-HOST. A license key issued for ANY-HOST will run on any system, and is not tied to the
customer's system ID. Startup, Evaluation, and Emergency Keys must be configured to run on any
system, since the Back Office won't yet have the necessary information to encrypt into a specific key.

Emergency Key. A temporary key that lets a customer use Rational software for a fixed period of time if
they cannot use their own license for some reason. The duration of the Emergency Key is five days.
Emergency Keys can be node-locked or floating. Emergency Keys are distributed by the Licensing
Support Group and run on any host.

Evaluation Key. A temporary key that lets a customer use and evaluate Rational software for a fixed
period of time. Rational Software determines the duration of the Evaluation Key. Evaluation Keys can be
node-locked or floating. Evaluation Keys are distributed by the Sales team and run on any host.

Floating License. A license type that links products to a license server system. Client systems obtain
licenses from the license server when they need to run a copy of Rational software. Multiple clients can
share the pool of floating licenses; one license is granted per client per product. Floating licenses on
license servers are typically administered by system administrators.

Key Type. Node-locked and floating licenses can be enforced by different types of license keys. The
types of license keys are Startup and Permanent. Evaluation and Emergency keys are variations of
Startup keys, and Term License Agreements (TLAS) are a variation of Permanent keys. Each type of key
has different business rules and policies.

License. A legal right to use a product. A customer receives a license when they purchase the product.
However, they need a license key to actually associate the product and the system on which it is running
with a license.

License Key. Generic term used in this document to describe keys that enable licenses on a customer
system. The types of license keys are: permanent, temporary, evaluation, emergency, and Term License
Agreement (TLA).

License Key Administrator. A program written by Rational Software which provides a customer
interface to Rational's Licensing system. The License Key Administrator is installed whenever a Rational
software product is installed on a Windows system. For hosting floating licenses, the License Key
Administrator is installed when the Rational license server software is installed on a system.

License Key Code. An encrypted code used to enforce a license agreement.

License Type. The valid types of licenses are node-locked licenses and floating licenses. See also Key
Type.

LKAD. Abbreviation for License Key Administrator.

Node-Locked License. A type of license that links a product to a system. Typically, one node-locked
license is issued for each software copy.
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Permanent Key. A license that lets customers run Rational products indefinitely. Permanent Keys can be
node-locked or floating. Node-locked Permanent Keys are installed on a client system. Floating
Permanent Keys are installed on a license server. Obtain Permanent Keys from the Rational Back Office.
Note: A Term License Agreement, a variation of a permanent key, does have an expiration date. See Term
License Agreement.

Permanent Key Code. The encrypted code that lets a customer run a particular Rational product using a
Permanent Key.

Temporary Key. A short-term license key that lets a customer run Rational software products.
Temporary licenses are not keyed to a specific system. Temporary Keys can be node-locked or floating.
Node-locked Temporary Keys are installed on a client system. Floating Temporary Keys are installed on
a license server. Temporary Keys are issued by the Rational Back Office and run on any host until the
specified expiration date.

Temporary Key Code. The encrypted code that lets a customer run a particular Rational product using a
Temporary Key.

Temporary License Key Certificate. A piece of paper or an electronic file that contains information a
customer needs to begin using Rational software with a license. The temporary License Key Certificate is
shipped to the customer with the software installation media.

Term License Agreements (TLAS). Variation of a Permanent Key. TLAs are issued to a site to let their
employees use Rational software for a negotiated period of time. TLAs are issued by Rational Sales and
have an expiration date.
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