Try it!
For Performance Testing
of SAP Applications

Welcome to Rational TestManager SAP

If you use SAP R/3 applications, you need Rational TestManager, a component of
Rational Suite TestStudio— the easy-to-use, automated performance testing solution
for client/server, Web, and ERP applications. Rational TestManager lets you plan,
develop, and execute performance tests against your SAP R/3 application, regardless
of your R/3 hardware platform or database server type.

As you use these testing tips on your SAP application, you will quickly discover how
easy it is to plan and run tests using TestManager.

To find out more about TestManager, see Using Rational TestManager, as well as the
other TestStudio and TestManager documentation and online Help.

Create a Project and Log In

Before you begin testing your SAP application, create a project. A project contains all
of the information about your testing effort, including test plans, test cases,
requirements, test scripts, logs, defects, queries, and reports.

Try this:

1 Install Rational Robot according to the instructions in the Installing Rational Testing
Products manual.

2 Click Start > Programs > Rational product-name > Rational Administrator.



3 Click File > New Project.

Mew Project - General [ 2] ]

Please specify the name of the new project. an emply directory in which to
create it and whether or not the project is LIC enabled.

Type SapProject for the name of the (Bt i

project. \Iﬁappln\e:t
Project location:

C:\Projects' S apProject
Type C:\Projects\SapProject as the /|
location of the project.

™ UCM-enabled

< Back Mest > Cancel Help

Note: You do not need to make the project UNC-enabled.

4 Click Next until you see New Project - Summary.

Mew Project - Summary HE

A new Rational Project will be created. If you want to review or change any
settings, click Back. |f you are satisfied with the settings. click Finish

Current Settings:

& nevs project with & name of 5apProject will be created in the directary B
C:M\Projects\S apProject:

The project will not be UCK enabled.

The praject will not be password protected

Make sure that the Configure Project Now
box is selected, and then click Finish.

< Back I Finish I Cancel Help
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5 At the Configure Project dialog box, click Create in the Test Assets section.

Configure Project

— Requirements
Azsociated RequizitePra Project:

Create | Select. |

i Test Asset:
Agsociated Test D atastore:

Click Create. I

— Change Requ

Agsociated Clearfuest Database:

Create | Select |

~ Model

Associated Ross Models

Add

Remove |

Close Help

6 Verify the location of the datastore in the directory of the current project.

Create Test Datastore

The default location of the datastore - New Test Datastors Path

directory is within the current project

- IC:\F’roiects\S apPrajectsT estDatastore

Browse. |

directory.

r Initiglization O ption:

™ Initidlize Assets from the follawing Test Datastore:

™ Initialize Test Users and Groups from the Bational Project:

Browse... |

j Browse |

Click OK.

ak. I Cancel | Help |

Rational Administrator displays some status messages, and then tells you that it

created the Test Datastore successfully.

Rational Administrator

@ The Test Datastore has been successiully created.

Click OK.

7 Click Close at the Configure Project dialog box.

Create a Project and Log In
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Determine the SAP Host Name and System Number

Before you test your SAP application, you also need to determine your host name and
system number. Follow the steps on this page to make a copy of the host name. Ask
your system administrator for the system number.

Try this:

1 Rightclick the SAPGUI icon for your application, and then click Properties.

E _I
E
DOpen

Scan for Yises
Buick View
AddtoZip

Send To 3

Cut
Copy

Create Shortcut
Delete
Rename

2 In the Properties dialog box, click the Shortcut tab.

3 Copy the host name by highlighting it and pressing CTRL+C.

207.121.200.200 Propeities H

General Shortcut |

R/3
207.121.200.200
mﬂ

Target type: Application

The host name is a series of one or more

L. Target location: SAPGUI
computer names and/or IP addresses delimited

by slashes and uppercase letters, often with = [00.200/H/204.79.189.6/H
a trailing port number. 1% [ i S epcrate b emon Space
Start in: ID'\SAF‘gu\ HR\TEMP

Sharteut Key: |N one

Bun: INnrmaI winde j

Find Target... | Qhamgalcom...l

’TI Cancel | Aol |

You need the exact host name to connect to the application in the next set of steps.
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Capture a VU Test Script

When you use Rational TestManager to test the performance of your application, you
record a test script that emulates an actual user working with the SAP application.
The test script, called a VU test script, captures the requests and responses that occur
between the client application and the database server.

For more information about creating VU test scripts, see the Using Rational
TestManager manual and the online Help. For information about the VU scripting
language, see the VU Language Reference and the corresponding online Help.

Try this:

1 Click Start > Programs > Rational product-name > Rational Test> ERP> Rational ERP
VU to display two dialog boxes.

Save script file as: HE

Save jn: Ia Rational Test j ﬁl

Api [Dinchude @ SetupSamples
AssitDI (21 JavaEnabler (D shiin

bin D msg [Z0 SiteCheck
build306projsct 20 rutz L3 5itelnfa

driver @ quelies 5] sqabaszd2
drivertk (0 rtsdk @ techange
drivenn2k (23 Samples [ Templates

Before you record a test

script, name it to create a |
placeholder for it. Then — Filname:  [C\Projects\SapProject:ERFYL Save I
save it in your project. Save astype: |5 = Cancel

2 In the File name box, do not accept the default path. Instead, type the following
path: C:\Projects\SapProject\TestDatastore\DefaultTestScript\Datastore\TMS.Scripts

\ERPVU.s where SapProject is the project that you created, and ERPVU is the name
of the test script you to record.

3 Click Save.

4 In the Host name box, paste the host name that you just copied by pressing
CTRL+YV, enter the system number, and then click Connect.

If the program path is part of the host name, delete the path to the SAPGO01

executable.
Press CTRL+V. Hostname: [;+4,207.121.200.200/H/204.79.133 244/H/204 72.199.37/5/3200 B
Enter the system number. ———————  System Number: [og
Click Connect. [ comex | Cancel |
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6 Navigate through the application. Rational ERP vu records all actions against the
user interface.

Note: The interface of your SAP application may differ from the screen shots
displayed here.

Note: To record VU test scripts other than SAP VU test scripts, use Rational Robot.

» Personnel Events

Enter keystrokes and
transactions that reflect
what your users do.

]
B
B
[
[
_J
[
_J
[
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7 Turn Exception Handling on if an unexpected, unwanted window appears during
recording. You can turn it on in two ways:

a Click Yes if a dialog box appears that says, “An error or a warning condition was
detected. Do you want to activate exception handling mode?”

b Or click this icon:

"

8 Click the icon to turn Exception Handling off after you dismiss the unexpected
window.

".}'Sameiect - Rational Robot - [ERPYU =]
File Edt ‘“iew Becord Debug I[nset Tools 'wWindow Help = |

|22 rBES Bz i NE | [sp@hD

VYuErp_Exit(-1,"VUuErp_VerifyEvent [\"GetEvent_SAPMSDYPBAE\"] failed™); =l

F% AHSW_YES =/
emulate [“RatlErp@27"] VuErpSetCurPosByIndex(2), VuErp_log_message;

emulate [“SendReturnB88"] UuErpSendReturn(), UuErp_log_message;
datapool_close{VuErp_DP};

pop Think_awg;

-

* % ok

Datapool variables and values

w K KK

[

DATAPOOL_CONFIG “"RatlErp” DP_SHARED OVERRIDE —
i | _'lJ

Turning on Exception Handling inserts an ‘if’ statement in the VU test script to
indicate the code for the unwanted window. If the unwanted window doesn’t
appear during playback, playback will still succeed.

9 After you finish recording the test script, log off from Rational ERP vu.

Build a TestManager Suite

A TestManager suite represents the workload that you want to apply to your
application. A suite contains one or more user groups to emulate the types of people
who use your application, as well as the number of users in each group. The suite also
contains test scripts that emulate the activities that the users perform.
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Try this:
1 Start > Programs > Rational product-name > Rational TestManager.

Rational Test Login

Accept admin as the User Name
User Name and do e
not enter a password. Password
H Project
Select the project you
created — SapProject |SepPropc o _gowe. |
Laocation

IE'\F‘rn|ecls\5 apProject\S apProject.rsp

Click OK to log in. Cancel |

2 On the TestManager toolbar, click New Suite.

(e

ICIick New Suite.

B &

Elﬁ|.§éﬁ1

e 0 r N

3 Select Blank Performance Testing suite, and then click OK to continue.

New Suite

Create 3 hew suite using
" Performance Testing ‘wizard
" Functional Testing ‘wizard

€ Egisting session

" Blark Functional Testing suite

™ Don't show in future

oK I Cancel | Help |

4 Right-click User Groups, and then click Insert > User Group.

B Suite 1° 0] x]
A user group represents one type of Btz [ Een Dependencies
person who will use the application. 75 B |Usen Grougs
f[HHD Scenarios
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5 Accept User Groupl as the name and 1 as the number of users, and then click OK.

Start with one user to test the suite
and add more users to add a

Run Properties of User Group [x]
Mame:
IUSE[ Groupl
r~ User Count

take user count

workload to the application.

1+ Fired
Murber. 1 _I:j
" Scalable

PBercentage: %

r— Computer
|Loca\ compter j
Multiple Computers. ..
0k I Cancel | Help |

6 Right-click User Group1:1user(s), and then click Insert > Test Script.

Run Properties of Test Scrpt
. Test sciipt source IVU - [Rational Test Datastore] d
ERPVU was the test script that you
saved and created a placeholder Testsgiptname: [ AP
for before you started to record. - Select
Quey |Standard ol Hew
Mame | Script Type | Dezcription |
Select All |
™ Precondition
Ewent:
Iterations: IW _Ijj Delay between iterations: 0 _Ijj Seconds
r~ Scheduling method
Method: I(Nona> -I
Dependencies: I d Iultiple Dependencies... |
ok I Cancel I Properties... | Help |

7 Select VU- (Rational Test Datastore) as the Test script source.

8 Type ERPVU for the test script name, and click OK.
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9 Click Yes when TestManager asks if you want to create the script.

10 Click File > Save As, accept the default suite name, and then click OK.

Play Back the Test Script

Before running the test with the full user load, make sure that one virtual tester
completes the test correctly and successfully. As the suite runs, TestManager provides
numerous views so you can watch the progress of the test

Try this:

1 From TestManager, click File > Run Suite, accept Suitel as the suite name, and then
click OK.

2 After the suite starts to run, click Monitor > Script. TestManager displays the
individual test script commands as they execute.

3 After the suite finishes running, click File > Exit to close TestManager.

What's Next

You have just recorded an SAP R/3 session and played it back with one virtual tester.
You can record test scripts with different types of virtual testers. Or you can increase
the number of testers for each group and build them into suites to form a real-life
performance test.

The value of suites becomes even more apparent when you scale up the number of
virtual testers in your test — to hundreds or thousands of virtual testers — by
increasing the number of testers in a suite. This lets you identify system performance
errors and bottlenecks before you deploy your application.

For detailed playback instructions and more information about suites, see the Using
Rational TestManager manual and the online Help.
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