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Getting Started with RUP Organizer

This “getting started” guide aims at giving you an initial understanding of why you should use the RUP Organizer to customize the IBM Rational Unified Process (RUP)  framework, and how to get started with the application. It does not serve as the complete guide to Process Authoring of a RUP Plug-in. Detailed information can be found in the Process Authoring component of the Process Engineering Process (PEP), a sub-component of the IBM Rational Process Workbench (RPW). However, the recommended way of getting up-to-speed with RUP Plug-in development is to attend the RUP Plug-in Workshop given by the IBM Rational field.

RUP Organizer is a component of the RPW product, positioned as a stand-alone application that allows you to describe your plug-in’s elements. The RUP Organizer provides an intuitive user interface based on dragging files from a content explorer, and dropping them over process elements presented in the layout explorer. These elements are representations of the process elements defined in RUP Modeler, either from your own plug-ins process model, or from the process model which you base your plug-in upon (most commonly the RUP process model). 

There are two usage scenarios for RUP Organizer :

1. You add process content to describe the elements of your structural plug-in produced by the RUP Modeler component of RPW. A structural plug-in adds structural elements to the RUP in terms of artifacts, activities, roles, disciplines, etc. When working with structural plug-ins, you’ll usually work with RUP Organizer and RUP Modeler side-by-side. We recommend that you read the “Getting Started with RUP Modeler” document prior to start working with the structural plug-in.

2. You can add your development organization’s process assets, such as examples, templates, and guidelines to elements in existing plug-ins or RUP itself. The resulting plug-in is categorized as a thin plug-in. This differs from a structural plug-in in that it is not based on a separate process model. When working with thin plug-ins, you always work with the RUP Organizer in stand-alone mode. 

The goal of using the RUP Organizer is to produce a plug-in in a consumable format for RUP Builder to include in a process repository.

Preparing the process authoring environment

Before you can start working with RUP Organizer to describe your process extension, you should verify that the required software is properly installed. 

Here are the steps you go through to set up your process authoring environment.

1. Verify that all the “bits” are installed. The applications needed for describing a RUP plug-in is RUP itself (includes RUP Builder) and Rational Process Workbench, both products should be version 2003 or later. Verify that these are installed by inspecting the ‘Rational Software’ group under Start Menu > Programs. 

2. Select and install an html editor for developing the process content. This can be any product that supports the html format.

3. Check that the RUP process models and content libraries are installed (this defaults to c:\program files\rational\rpw, later referred to as the rpw-folder). If not, install now by executing the installable located at 

Start > Programs > Rational Software > Rational Process Workbench > Install RUP Model and Content Library

4. Launch RUP Organizer (see sections below for details) to define which applications you want to use for viewing and editing the content files.

Options > Editor options and Options > Preview options 

Depending on whether you work with RUP Organizer in stand-alone mode or not, the start-up experience will appear a little different. This is discussed in the following two sections.

Starting RUP Organizer from inside RUP Modeler 

To launch the RUP Organizer from inside the RUP Modeler, right-click on the plug-in’s process model and select RUP Modeler > Organize Process Content. This starts the RUP Organizer, which in turn loads the layout defined for the content library of this plug-in. If this is the first time you start RUP Organizer from this process model, the layout will be initially created and placed under the layout folder of the plug-in’s content library. It will take the name of the process model. If you have followed the recommendations with respect to plug-in naming and file system location as outlined in the getting started guide for RUP Modeler, RUP Organizer creates the initial layout as : 

rpw-folder\MyPlugin\content_library\layout\MyPlugin.layout

Note that RUP Organizer does not check if there are any changes to the process model since last time the layout was loaded, it simply reads the last saved layout file. To synchronize with any model changes, you have to perform the “Refresh from Model” command after the layout is loaded.

Starting RUP Organizer from the start menu

If you are producing a thin plug-in (or if you are working with your structural plug-in’s content isolated from the model), you launch the RUP Organizer application in stand-alone mode. This is done from the start menu :

Start Menu > Programs > Rational Software > Rational Process Workbench > RUP Organizer

When the RUP Organizer is launched in stand-alone mode, you have the option to create a new plug-in layout, or edit an existing, with the last edited layout selected by default. 
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Figure 1. Selecting a layout in stand-alone mode

This dialog is also presented if you select File > Layout > Open from inside the RUP Organizer.

If you want to create a new plug-in layout (File > Layout > New), you will be asked to point to the layout on which you want to base yours. This is usually the base RUP layout, but can also be the layout of another plug-in.

Key Concepts in process authoring

The task of authoring a plug-in includes developing process content and structuring this content using the well known RUP treebrowser organization. Below is a diagram presenting the key concepts of the process authoring domain.
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Figure 2. The Process Authoring domain

The structural part of a plug-in is defined by a number of process elements, structured inside a process model. These are created in the process modeling space (RUP Modeler), but they play important roles as inputs to the activities in the process authoring domain.

The process elements are described by the content files in the model’s designated content library.  In RUP Organizer, you describe a mapping between the files and the elements. This mapping is manifested in the plug-in’s layout. Physically, the layout is a file on a proprietary format, located inside the plug-in’s content library. Each process element is represented by a node in the layout. This node is described by one or more content files.

A content library also contains the system files required for the resulting RUP website to function. This includes applets and data files required to run utilities, such as  the treebrowser, the search, the MyRUP feature, and more.

The RUP Organizer Workspace

The RUP Organizer workspace is divided into two distinct parts; the content explorer and the layout explorer. The main activity in RUP Organizer is to drag files from the content explorer, and drop them over the respective elements in the layout tree. Below is a screen capture of the RUP Organizer workspace.
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Figure 3. The RUP Organizer application

The content explorer

The content explorer is similar to the Windows File Explorer both with regards to look & feel, and functionality. It enables you to browse all the files and folders in a specific content library. You can also browse the files and folders of the dependent content library. For a structural plug-in, this is the content library with which the dependent process model (e.g. the RUP process model) is associated. For a thin plug-in, this is the content library owning the layout you pointed out as the base for this plug-in.

The content library browser uses the split-window mechanism to show folders in one pane, and files of the selected folder in the other pane. The latter is the pane you will drag files from.

The file list will visualize the file type of each file using an icon and a file type name, for example “Activity Description”. If RUP Organizer does not recognize the file, then it will display the file using a question mark icon.

The layout explorer

The right hand side pane displays a tree organization of the plug-in’s model. This tree represents the plug-in’s layout, and will be the starting point for associating files from the content library. The initial organization of the layout will directly reflect the underlying process model defined in RUP Modeler.  The layout of a structural plug-in displays it’s elements by their model name, using predefined icons. If you’re defining a thin plug-in, this layout will initially only contain the top-level folder (for example MyPlugin). 

You can re-arrange the layout by re-ordering elements, create or remove folders, change the names of the nodes etc. 

Make special note of the visual clue of indicating background (shaded) and foreground (not shaded) layouts. This indicates which is your working layout and which is the layout your plug-in depends on. 

Organizing your plug-in

There are a number of activities involved in organizing your plug-in’s content. In large, we can say that the overall goal is to map process content to the individual model elements, either from your own plug-in process model, or from a dependent process model. Below is an illustration of the activities involved.
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Figure 4. The activities of organizing your plug-in content

The rest of this introductory guide will briefly describe each of these activities, just enough to get you started. As mentioned in the introduction of this document,  refer to the Process Authoring component of the PEP, or the RUP Plug-in workshop delivered by the IBM Rational field, if you want more in-depth guidance on RUP plug-ins.

Create new content files

When you first select to organize your plug-in’s process model, it’s likely that you start with an empty content library. When this is the case, you’ll find yourself spending a fair amount of time in RUP Organizer, instantiating content files from the supplied templates. 

Such RPW Templates exist for each of the different file types, of which “artifact description” and “guideline” are two examples. When a configuration eventually gets published from RUP Builder, the documents created from these templates will be processed. The templates contain commands that, when processed, extract information from the underlying process model to describe relationships with other process elements. For example, in an artifact description page, there will be commands to collect model information, such as the artifact’s responsible role, which activities update it, and so on. These commands are called RPW commands.

To create a new content file based on a RPW template, you simply right-click on the actual element in the layout, and select Create New from the context menu. From a list of valid file types for this specific element, you get to choose which kind of file you want to create. You can also use the main menu under the Layout option to create a new content file, but then you must associate it with a layout element using the drag & drop feature.

Develop content

The actual content authoring activity takes place outside the RUP Organizer application. You can use any html editor to edit your files, and by pointing RUP Organizer to the chosen application (see section named “Preparing the process authoring environment” for details), you can launch the application on a given file by selecting the Edit option from the context menu of Organizer’s layout explorer. 

Make sure you don’t modify the RPW commands carried forward from the template instantiation.

Associating existing content with process elements

Some file types do not have templates, for example graphic files. Some files might even already exist in the content library when you enter RUP Organizer. These files can be associated with the process elements by dragging them from the content library browser, and dropping them onto the relevant element in the layout.

Re-structure the layout

You have several options to influence the structure of your plug-in directly in RUP Organizer. You can re-order the elements within it’s parent, for example, you can change the order of activities under their performing role. You are also free to add or remove folders to influence the grouping of elements in your plug-in.

Synchronize with model changes

Just like with any software project, we recommend that you work incrementally when developing a plug-in. The RUP tool family is defined to support this type of development. Particularly you can switch between RUP Modeler and RUP Organizer with no added overhead. RUP Organizer has a feature that updates an existing layout based on the changes in the process model since last synchronization. This is the Refresh From Model command. New elements will be displayed with their model name, and any moved or removed elements will appear unsynchronized as shown below, so that you can analyze the change and potentially remove the entry from the layout.
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Figure 5. Synchronization of process model and layout

 The example above shows how RUP Organizer presents the Artifact: Wireframe as unsynchronized after it has been moved to a different component in the process model. Note the propagation of the warning icon to ease the search for violating nodes.

Supporting activities

RUP Organizer has a number of features to support the process engineer / process author in the work of organizing a plug-in’s content. For example, you can preview individual content pages to see how they will look like when they appear in the final published website. This preview will make use of the underlying model to translate any RPW commands into the resulting html text.

You can also ask  to see the properties of an element in the layout, by invoking the Properties command from the element’s context menu. This will display information like file type, path in the file system, model name etc.

The integrity of your file associations can be tested by running the Check Files command. 

RUP Organizer also offers search capabilities to look up files that matches certain criteria. 

Export the plug-in

When the content files are created and associated with the elements, the plug-in is ready to be exported into a process repository in RUP Builder, the configuration tool of the RUP tool set.  This allows process / project managers to include the plug-in in future configurations. Exporting a plug-in means technically that RUP Organizer will produce a configuration unit file (with extension .cfu) in a user specified location. 

Configure the Process

The result of the work you do in the RUP Organizer feeds into the Process Configuration activities. This domain and related activities are described in the document titled Getting Started with RUP Builder.  Refer to this document, or the Process Configuration component of the PEP, for further details.
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