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Introduction

This ProjectConsole tutorial has a modular design that allows you to complete or skip sections, depending on your role in your project and your interest in the various data sources.  

If you plan to use ProjectConsole to navigate through project artifacts as well as view project metrics, then you only need to go through Section 1, Navigating ProjectConsole and Dashboard.

If you’re responsible for setting up the ProjectConsole Web site or would like to learn more about navigating the ProjectConsole Web site, you should go through Section 2, Understanding Web Reporting and Templates and Section 12 – How to Build Tables in Template Builder.
If you’re responsible for defining the ProjectConsole metrics warehouse, setting up the automated metrics collections, or navigating the ProjectConsole Dashboard tool, you’ll find Sections 3 through 15 useful.  Sections 3 through 8 show you how to use ProjectConsole to gather project data and store it in the ProjectConsole metrics warehouse for ClearQuest, RequisitePro, Rose, Purify, Coverage, and ClearCase.  Section 9 shows you how to publish Dashboard views to the ProjectConsole Web site.  In Section 10, you’ll learn how to migrating from the sample site data included with ProjectConsole to your own project data.  Section 11 shows you how to add a field to your metrics warehouse. Section 13 shows you how to gather data for Microsoft Project. Section 14 shows you how to gather data from TestManager.  Sections 15 and 16 address the subject of data transformations. Section 15 shows you how to use transformations for data cleansing.  Section 16 shows you how to use transformations to obtain derived data.
This tutorial shows you how to set up a template to utilize a “traffic light” indicator instead of a value.  The example will be to show the status of the tasks from Microsoft Project based on the percent complete for that task.  If the task is less than 30% complete the light will be red, if it is between 30% and 60% the light will be yellow, and if the percent complete is more than 59% complete it will show green.

PC Setup

Install the .gif files into a temporary location the *wte.gif files have the letter in the traffic light in white, the *light.gif files have the letter in black.

Note where you install these files, they will be used later in this tutorial

The following directory references are used throughout the tutorial:  

· SuitesDir refers to the installation path for your Rational Suite product (for example, C:\Program Files\Rational).

· InstallDir refers to the installation path for Rational ProjectConsole (for example, C:\Program Files\Rational\ProjectConsole).

· ClassicsDir refers to the installation path for the Classics sample application (for example, C:\Classics).

For information about installing the Rational Suites ClassicsCD demo and the ProjectConsole product, see the section Preparing for the Tutorial. 

Note:  The graphics used to illustrate the Microsoft Word user interface were captured using Microsoft Word 2000. Depending on the version of Word you use, these dialog boxes may look somewhat different.


Creating Template Builder templates that contain data tables

Part 1 – Creating a template that contains a table

You can use Template Builder to create a template that contains a table, and use it to generate Web page reports. To insert the commands used to populate the table cells, you use the ProjectConsole menu rather than the Template View.  In this exercise, you’ll create a report template that contains a table for use case requirements data collected from RequisitePro.

	Step
	Use Case Steps
	Details
	Display

	1.1.1 
	Start ProjectConsole Template Builder.
	From your desktop, click Start > Programs > Rational Suite Enterprise > Rational ProjectConsole Template Builder.
Microsoft Word starts, with a new document open and the ProjectConsole menu displayed in the menu bar.
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	1.1.2 
	Show formatting marks in the document.
	In the new document, press enter. 

If you can’t see the paragraph formatting mark, then, on the Word toolbar, click Show/Hide ¶.
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	1.1.3 
	A source domain must be selected.  In this tutorial the source will be a Microsoft Project (MSProject)
	Click ProjectConsole > Add Command.
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	1.1.4 
	
	The Select Command To Add dialog box is displayed.

Click OPEN Command. 

Click OK.
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	1.1.5 
	
	The OPEN Command dialog box is displayed.

In the Select Class to OPEN list, expand MicrosoftProject, and then click Project.
	[image: image6.png]OPEN Command

Select Classto OPEN. Arguments IE el

G Cratase Name Ve Cancel

B e E o |
@ FieSysten Hep

@ MitosofPriect

@ Raonalciisiator
@ RequistePro

@ Rose

@ TestManager

G Mitoscitword

L —






	1.1.6 
	Select the Microsoft Project > Project Class.
	The Arguments list now displays the default ProjectPath argument for the OPEN command.

In the center pane, to the right of the ProjectPath argument name, click Browse.
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	1.1.7 
	For testing purposes, connect to a MSProject file.
	The Open dialog box is displayed.

Browse to and open the detail_inception_iter.mpp file, which is located in the following directory:

C:\Classics\projects\Webshop\MSProject\ detail_inception_iter.mpp
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	1.1.8 
	
	In the Arguments list, the Value column for ProjectPath now displays the full path to the Microsoft Project source file.

Click OK.
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	1.1.9 
	The template is ready to start adding commands related to the MSProject source.
	The project name and path are now loaded into the OPEN command and the Word template document displays the ProjectConsole OPEN annotation.

In the template document, click just after the OPEN command annotation, press enter four or five times, and then click the second or third line below the annotation.
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	1.1.10 
	Insert a table in the document.
	Click Table > Insert > Table.
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	1.1.11 
	Specify the number of columns and rows for the table.

In a dynamic table such as the one you’re creating, you must specify the exact number of columns for the table.  Although rows are created dynamically when the table is populated with data, you must specify either one row or two rows to start. A one-row table has no heading. A two-row table can have a heading.
	The Insert Table dialog box is displayed.

Under Table size, in the Number of columns box, set the value to 3.

Under Table size, in the Number of rows box, set the value to 2.
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	1.1.12 
	If a table format other than the default (none) is desired, select the AutoFormat button.
	Select the AutoFormat… button.

A dialog box opens with a list of the defined formats available.

Using the scroll button on the left pane, scroll down to Web 1.

Click OK.
	[image: image13.png]B 1 i ) B D D T |

]
DEEasRY|[calo- ey e -@

&

|====[a 044!

Jan |[Feb | [Mar [Total
East 19
West 17
South B [7 3 [24
Total 21 [18_[21 60

Formats to apply

¥ gorders ¥ Eont IV AutoFt
¥ shading ¥ Color
Apply specialformats to
¥ Heading rows T~ Last row
¥ First column T Last column

Concel

“lo]w ]«

EREER >
[Page 1 seci Frrl e ) s sl
S BDHRHR aeram

Hstart || 1] & MESYRe e @@ D0 || Eshore..| @i tu...|[@ooc.






	1.1.13 
	Note in the Insert Table dialog box that the Table format is now set to Web 1.
	Click OK.
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	1.1.14 
	A blank table is created.
	Word creates the three-column, two-row table.

Note:  You can apply a style such as shading to control the appearance of this table. 
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	1.1.15 
	Add a ProjectConsole REPEAT command to the table.
	Select the second row in the table.

Do not select the end of row marker ( [image: image16.bmp] ), located to the right of the table.

With the row selected, click ProjectConsole > Add Command.
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	1.1.16 
	Select the Repeat Command.
	The Select Command To Add dialog box is displayed.

Click REPEAT Command.

Click OK.

You may notice that, in the template document, the end-of-cell marker is now highlighted.  This is done automatically and is expected behavior.
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	1.1.17 
	Select the Tasks to REPEAT.
	The REPEAT Command dialog box is displayed.

In the Select Objects to REPEAT list, MSProject_Project is already expanded.

Use the default selection – Tasks

Click OK.
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	1.1.18 
	The REPEAT command has been inserted into the table.

Check the locations of the annotations.  This is critical to successful table generation.
	Check to see that the following annotations are in the correct locations in the template document: 

· MASTER must be located above the table.

· REPEAT must be in the first cell of the repeating row (second row).

· ENDREP must be in the last cell of the repeating row.

· ENDMAST must be located below the table.

Warning:  You cannot cut and paste these commands into the correct locations.  If your table does not look like this at this point, delete the table and all associated commands and start over.
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	1.1.19 
	Insert the LIMITs to include the Traffic light into the first cell of the second row.
	In the first cell of the second row, click to the right of the REPEAT3 annotation, but before the end-of-cell marker ( [image: image21.bmp] ),.

Click ProjectConsole > Add Command. 
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	1.1.20 
	
	Click LIMIT Command
Click OK.
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	1.1.21 
	Set the parameters for the “Traffic Light” in state Green.
	The LIMIT Command dialog box is displayed.
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	1.1.22 
	Define the name for the LIMIT.
	Type GreenLight in the Name field.
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	1.1.23 
	Set the And Where filter.
	In the And Where section, under the Left Operand in the green area, Click.

A drop down menu selection is displayed.
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	1.1.24 
	
	Expand the node called Self by clicking on the plus (+) sign to the left of the node.
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	1.1.25 
	
	Using the scroll bar located to the right of this drop down menu, scroll down to PercentComplete.
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	1.1.26 
	
	Click PercentComplete 

Notice that it displays this selection and adds a “new” row.
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	1.1.27 
	If you have another artifact that you wish to compare to, using the nodes will allow you to select that artifact.  This tutorial will not cover this type of usage.
	In the And Where section, under the Right Operand in the green area, Click.

A drop down menu selection is displayed.

Literal is by default highlighted.
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	1.1.28 
	
	Click on Literal.

The cursor will now be positioned in the Right Operand’s field.
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	1.1.29 
	ProjectConsole looks at all data as strings regardless of what the actual artifact format is.
	Type in 60%
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	1.1.30 
	
	Click on the equal sign for this filter
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	1.1.31 
	
	Select >=

Notice that it automatically inserts this new selection into the line.
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	1.1.32 
	ProjectConsole looks at all data as strings regardless of what the actual artifact format is.  Because of this, a 2nd level of filtering needs to be added for any Tasks that are 100% complete, as we want that to show up as a “Green” light.
	Add a second filter for Self>Filter = 100%

Location

Value

Left Operand

Self > PercentComplete

Operator

=

Right Operand

100%

Refer to steps 1.1.23 through 1.1.31.
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	1.1.33 
	Change the logical Operator from the default AND to OR.
	Using the pull down menu, Click OR
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	1.1.34 
	The first limit is now complete
	Click OK.
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	1.1.35 
	
	The LIMIT has been inserted into the first cell.
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	1.1.36 
	Add the Greenlight.gif to the LIMIT.
	With the cursor between the [LIMIT4] and [ENDLIM5], select Insert > Picture > From File.
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	1.1.37 
	
	Traverse to the location the *light*.gif files.

Select greenlight.gif
Click Insert.
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	1.1.38 
	
	The graphic file is now visible between the [LIMIT4] and [LIMIT5].
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	1.1.39 
	Insert into this same cell a LIMT for the “Yellow” light.
	Place the cursor outside the existing Limit – to the right of {ENDLIM5]

Set the following fields:

Name = YellowLight

And Where:

Self>PercentComplete >= 30%

AND

Self > PercentComplete < 60%

Refer to steps 1.1.19 through 1.1.35, if further assistance is needed.
	[image: image42.png]il pic_tutorial_new._trafficlights.doc - Microsoft Word
| £

T Documents - Microsoft word

LT Command

Select Dbjects to LIMIT: Wherels A
B Task Task
@
¢ OulineParent Name: Help
@ Project [rellonLight

W3 MicrosoftProject_Project

AndWihere: Logical Operator [AND <]

Let Operand Gperstor Flght Operand
Selt>PercentCamplete B
o

PICICIEY

Getting Dynanic Domains. o

the-“Vellow” light = the-right-of (ENDLIMS]{

Setthe-following fields ]

- Name-=YellowLightf

AndWhereq]

Self>-PercentComplete-
ANDY

30%)

Self->PercentComplete-<-60%=

o]z )
Jomwe Iy & | agoshopes- N N\OOE 4B & -£-A-=S=E04.
[Pase2z  secz 2o [ag s Cot  [mec [iww 57 ove [ O |

Hstart || 1] & FESDRe e @B@P D06 || Eshoe.| T tu.|[@oocu. | Fluntie.

l«lof» ]«

S BDHTHR 12ssem





	1.1.40 
	Insert the gif for the yellow light.
	Traverse to the location the *light*.gif files.

Select yellowlight.gif
Click Insert.
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	1.1.41 
	
	There are now two LIMITs in the first cell.
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	1.1.42 
	Insert into this same cell a LIMT for the “Red” light.
	Place the cursor outside the existing Limit – to the right of [ENDLIM7]

Set the following fields:

Name = RedLight

And Where:

Self > PercentComplete < 30%

AND

Self > PercentComplete != 100%

Refer to steps 1.1.19 through 1.1.35, if further assistance is needed.
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	1.1.43 
	Insert the gif for the red light.
	Traverse to the location the *light*.gif files.

Select redlight.gif
Click Insert.
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	1.1.44 
	
	There are now three LIMITs in the first cell.

Note  The cursor does not automatically advance to the next table cell.
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	1.1.45 
	Resize the column
	Using Microsoft functions, remove Paragraph markers in this cell, and resize column to the gif size.

Note:  You may need to remove automatic sizing on the table properties.
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	1.1.46 
	Insert a DISPLAY for the Task Name.
	Move the cursor to the second cell in the last row.
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	1.1.47 
	
	Click ProjectConsole > Add Command. 
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	1.1.48 
	
	Leave the selector on the default option, DISPLAY Command.  

Click OK.
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	1.1.49 
	
	The DISPLAY Command dialog box is displayed.

In the Select Attribute to DISPLAY list, under Task, select Name.

Leave all other default settings as they are. 

Click OK.
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	1.1.50 
	
	The DISPLAY for the task name is now in the table.
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	1.1.51 
	Add a DISPLAY command to the third column to show the actual value for the Percent Complete.
	In the last cell (second row, third column), place your cursor to the left of the [ENDREP12] annotation (on the inside of the REPEAT command). To do this, you’ll use your arrow keys.
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	1.1.52 
	Create a DISPLAY for the Task Percent Complete.
	Click ProjectConsole > Add Command. 
In the Select Command to Add dialog box, click DISPLAY Command, and then click OK.

Using the Scroll function, scroll down to PercentComplete.  Click on PercentComplete.
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	1.1.53 
	
	The DISPLAY is now inserted into the last cell.
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	1.1.54 
	Add Column Headings.
	Place the cursor in the first cell of the first Row of the table and type Status
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	1.1.55 
	
	Add column Headings:

Column

Heading

2

Task Name

3

Percent Complete
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	1.1.56 
	
	Apply Formatting and Shading to the Table Headings
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	1.1.57 
	Save the template document.
	Click File > Save As.
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	1.1.58 
	
	The Save As dialog box is displayed.

Browse to and open the InstallDir\templates\Custom\MSProject directory.

Note:  If this directory does not exist, using the new folder option to create it.

In the File name box, type “MSProjectTrafficLight.doc.”

Click OK.
	[image: image61.png]2l Document3.doc - Microsoft Word ~=lolx|

| Bl Edi View Insert Format Tooks Table ProjectConsole Window Help
DZda8RY[) eI o-- @BEOEEH R w: -0.

[toms < st 12 < | B 2 0

R s s E— %

save as 21|

savein tutorials Y « @@ X CiE - Tok -

1 ~gc_tutorial_new_trafficlghts.doc
| gcument3.doc
occments.doc
i tukorial_new_raffights doc
Using_PIC_Tutorel_Templatedoc

Fie o ERCED
Save as type: |word Document (*.doc) hd Cancel

wlolw e

| ELIE

[Pz secd [ = ezl 2 T

st | E ) P & BeBOhBRABOOY
| @ration...| ETomca...| & Ration...| ‘upies...| Epic se...| Eoero... | GyoTes...|[#pocu..  Blpie_tu...|

SE@B e
oY)






	1.1.59 
	Save the document in the Web format
	Select ProjectConsole > Save as Web page
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	1.1.60 
	
	The acknowledgment screen is displayed once the template has been converted.

Note that this path is relative to the stored location of the doc version.
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	1.1.61 
	Test the Web page to see what the generated report will look like on the ProjectConsole Web site.
	Click ProjectConsole > Test Web Page.

ProjectConsole generates the Web page and displays it in a Web browser window.

Close the Web browser window.
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	1.1.62 
	Verify the results are displayed as desired.
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	1.1.63 
	Close the .html file
	Select File > Close
	

	1.1.64 
	Remove the reference to the project.

When you specify a project to OPEN, you can only use the template to display artifacts in that project.  To make the template generic so that you can use it for multiple ProjectConsole projects, remove the reference to the specific project from the OPEN statement.

Note  If you need to make changes, you must make them in the template (*.doc) file, save the file, and then save the file as a Web page. 
	Click to the right of the OPEN statement and then click ProjectConsole > Modify Command.

Note  In Part 2, you’ll use the ProjectConsole Administrator to add the reference to the project.
	[image: image66.png]-1o) x|
J'Fle Edt vew Insert Format ook Table Proectconsole. Window Help

DBEE|8RY |4 2@ svewobrae OB Bqwe -0,
Test WebPage mad < Tinestewkonen < 1z < | B 2 ]
|« @ @ ravortes Tempae Ve conalProfectconsaetempiatesiCustomiisp = |
o Conmand,
[ : : 2 4 : s L AR 3
pr— Dokte Command,
i —
[Stauss  [TaskNames  [PercentCompleten o
|<Task Name> <Task. Percen [0
tComplete> ENDDISFIZ
1
1
r
o
|EEE 5
[Facz. Sec 1 B I Gz |[rec firk | JouR | [
Hstart| | 1) € 16y P &

BeRehTABOI D
| @rational...| ETomcat ...| & Rational...| ‘upiesti...| EWPic ser... | Eloiprog... | G)oTest.. | [@Mspre

LE@B essan
| Bads






	1.1.65 
	
	The OPEN Command dialog opens showing the current values set.
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	1.1.66 
	
	In the Arguments list, click the project path in the Value column, and then press delete.

Press enter.

Click OK.
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	1.1.67 
	Save the template document and then save the Web page.
	Click File > Save.

Click ProjectConsole > Save Web Page.
	

	1.1.68 
	Acknowledge the Web page save and quit Word.
	Word displays a message to let you know that the MSProjectTrafficLight.htm file was created.

Click OK.

Quit Word.
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Part 2 – Adding a node for a template to the ProjectConsole navigation tree 

The template created in the above section is now ready for use in the ProjectConsole Web site.  This tutorial will not go through the steps required to do this.  For more information see tutorial Section 12 – Building Tables in ProjectConsole Template Builder.
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