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Preface

Welcome to the Rational® XDE™ Professional v2002 Release 2.1 - .NET Edition Evaluators Guide.  This guide was created to help you evaluate Rational XDE Professional v2002 Release 2.1 - .NET Edition (Rational XDE or XDE for short) and outlines the unique values that Rational XDE brings to developers.  Exercises in this guide let you experience the product first-hand.  Each exercise is independent of the previous one and takes about 30 min to complete.  For a better introduction to Rational XDE, we recommend you follow this guide sequentially.

This guide is divided into the following sections:

· Welcome to Rational XDE 

· Overview of Rational XDE and instructions for installing Rational XDE and getting ready to perform the exercises in this guide.  In this section you will create a Visual Studio .NET solution that will hold the projects created in the exercises of this guide.

· Rational XDE Key Differentiators 

· Description of key benefits provided by Rational XDE to developers:

· Integrated design and development environment

· Automatic creation of UML models from code

· Web services 

· Patterns 

· Best practices for .NET development 

· Getting more return form your models

· Step by step directions and exercises for you to experience the key benefits.

· Flexible Team Development and Configuration Management

· Overview of the integration between the Rational ClearCase family of products and Rational XDE illustrating the ability to distribute the development of models and code across your team based on your needs.

· Integrated Use-Case Management (IUCM)

· Overview of the integration between Rational RequisitePro and Rational XDE illustrating the ability to manage software requirements documented in use cases.
· eXtending your Development Experience

· Overview of the Rational Developer Network, a unique Web site that provides a wealth of information for software professionals, including Rational XDE and Microsoft Visual Studio .NET information.   If you already are a Rational customer with an active maintenance agreement, you can register to get access to the Rational Developer Network at www.rational.net.
We hope this guide is a convenient resource for learning about Rational XDE Professional .NET Edition.

Welcome to Rational XDE

Rational XDE has been designed from the ground-up for developers as an eXtended Development Environment (XDE).  Fully integrated into the Microsoft Visual Studio .NET Integrated Development Environment (IDE), Rational XDE allows developers to design and code within a single environment, avoiding the need to switch between different, non-integrated tools.  
If you are familiar with the Microsoft Visual Studio .NET IDE, you will find the Rational XDE user interface very familiar.  If this is your first exposure to the Microsoft IDE you may want to visit the appendix of this guide for an overview of the common windows you will be manipulating in the exercises.

Before installing Rational XDE, you must install Microsoft Visual Studio .NET.  If you do not have a copy of Microsoft Visual Studio .NET, you may want to download the trial edition from http://msdn.microsoft.com/vstudio/productinfo/trial.asp or contact Microsoft to purchase your copy.

Installing Rational XDE 

First ensure that your system complies with the system requirements for Rational XDE:

	Operating System
	Windows 2000 Professional SP2 or SP3, or

Windows 2000 Server, or

Windows 2000 Advanced Server, or

Windows XP Professional, or

Windows NT 4.0 Workstation SP6a

	Processor
	Pentium II-class processor, 450 MHz  

  Recommended: Pentium-III class, 700 MHz

	RAM
	Minimum:  256 MB; Recommended:  512 MB 

	Disk Space
	Minimum:  400 MB for installation directory; 50 MB for workspace Recommended:  2-4 GB for workspace 

	Video
	Minimum screen resolution: 800 x 600 pixels, 256 colors Recommended: 1024 x 768 pixels, 16-bit color


If you do not already own Rational XDE Professional, you can download the evaluation software from our Web site or request a copy of the Rational Software Solution for Microsoft .NET Developers CD.  

· To download the evaluation software, go to http://www.rational.com/tryit/xde/dotnet.jsp. Click Download Evaluation Software. Scroll down until you see a [image: image1.png]e 1



 icon

· To request the CD, go to http://www.rational.com/tryit/xde/dotnet.jsp#netcd. Click on the [image: image2.png]|ordertt [ |



 icon

To install the Rational XDE evaluation software:

· From the Web, click on the [image: image3.png]e 1



 icon.  
· Or from the CD main page, select Try It > Rational XDE Professional. 
· Follow the directions to save the installation software to disk.
· Extract the content of the ZIP file you saved to a temporary directory.  Double-click on Setup.exe.

· In the Rational Software Setup wizard, click Next.

· In the Choose Product screen, select Rational XDE Professional .NET Edition and click Next. 

· Read and accept the agreement.  Click Next. 

· On the Select Configuration screen, provided you do not have other Rational tools installed, you may browse to select a different installation location than the default directory.  Click Next.

· Click Next until you reach the last pane of the installation wizard.

NOTE: The Rational XDE evaluation software is controlled by NetQuartz software and requires an Internet connection. The release version of Rational XDE does not have these dependencies.

NOTE2:  If you have installed a product, which relies upon J-Integra by Intrinsyc Software Inc., you may experience a conflict resulting in Rational XDE reporting errors upon startup.  To avoid this, simply edit your system environmental PATH variable and ensure that the entry \Program Files\Rational\common is ahead of any J-Integra entry.  After a system restart, you should be on your way!

Getting Started

In this section, you will create a Microsoft Visual Studio .NET blank solution that will hold the projects created in the subsequent exercises.  

1. Select Start > Programs > Microsoft Visual Studio .NET > Microsoft Visual Studio .NET to start Microsoft Visual Studio .NET and Rational XDE. 
2. Select File > New > Blank Solution…. 

3. Keep the default selection:  Visual Studio Solutions as project type and Blank Solution as template. 


4. Name the solution Test Drive and accept the default location.  Click OK.
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You are now ready to experience the power of Rational XDE!  The Test Drive solution will be your starting point for the upcoming four exercises in this guide.

Integrated Design and Development Environment

Rational XDE combines design and development into a seamless, tightly integrated experience.  This eXtended Development Environment provides essential developer capabilities that are fully integrated into the Microsoft Visual Studio .NET technology, thereby providing one consistent look and feel and experience.  

Modeling is now as much a part of your IDE as your code editor, compiler and debugger.  With this combined environment, your primary development tools follow the same menus, gestures, and usage metaphors, which accelerate your learning curve and promote the use of design, code generation and code synchronization as a daily function.  

Ultimately, this leads to developing better software faster!
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Figure 1.  Design and development within one environment – Access code and model simultaneously.

In this section you will experience the following key Rational XDE features:
· Creating model from code
· Automatic or manual code synchronization
While creating a simple C# application, you will see Rational XDE build the visual model for the application and you will use this model to understand how the application fits within the Microsoft Visual Studio .NET Framework.  Along the way, you will also experience the effectiveness of Rational XDE to quickly change properties of multiple elements.  Finally, you will experience the automatic synchronization in action by modifying your model and watching your code update and then by modifying your code and watching your model update.

1. This exercise assumes that model to code auto synchronization is turned off. If you have experimented with auto synchronization prior to reaching this exercise, please follow these steps first: 
Select Tools > Options.  On the left side, scroll down, click the Rational XDE folder, then the Round-Trip Engineering folder to see the Auto Synchronization options.

2. With the Test Drive solution open, select File > New > Project….

3. Select Visual C# Projects as project type and Windows Application as template. 

4. Click the Add to Solution radio button 

5. Rename the project DateAndTime and keep the default location.  Click OK.
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The DateAndTime project is added to the Test Drive Solution.
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6. Click on the Toolbox [image: image8.bmp] located the left side.  If the Toolbox is not visible, select View>Toolbox.
7. Add a Button [image: image9.png]sb| Button



, and a textbox [image: image10.png][abi TextBox



 to the Form 1.

8. Double click on button1 to open the source code window for the button.

9. Complete the button1_Click() method with the following call:

textBox1.Text = DateTime.Now.ToString();


10. In the Solution Explorer, right click on the DateAndTime project and select Debug > Start new instance to build and execute the application.  

11. Verify that your application displays the date and time in TextBox1 when you click button1. 
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12. Close the application by closing the Form1 window.

Creating UML Models from Code

13. In the Solution Explorer, select the DateAndTime project, and click on the Synchronize icon [image: image12.png]


.
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14. A Rational XDE model is added to the DateAndTime project in the Solution Explorer.
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15. Click on the Model Explorer tab and notice the DateAndTime model.
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16. Expand the [image: image16.png]{} DateaAndTime



namespace, and the Form1 class, to view the UML representation of the Form class that was created during synchronization.
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Key Benefit
Rational XDE and Microsoft Visual Studio .NET work together using shared technology and a tight integration to create a UML design model of your application with just one click from within the Visual Studio .NET IDE.  You can now visually model your code without ever leaving your favorite development environment, making designing your applications easier than ever.
Visualizing the .NET Framework Classes

17. From the Model Explorer, drag the Form1 class ([image: image18.png]= Rrormi ]



) onto the drawing surface where the [image: image19.bmp] Main diagram should already be opened.
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18. Right click on Form1 in the diagram and select [image: image21.png]Add Related Shapes.



.  This adds to the current diagram additional model elements that are related to the element(s) currently selected in the diagram.
19. In the Add Related Shapes dialog, set Select in Model(s) to All Models.  Keep the Expands to N Levels to 1.  Click OK.  

Key Benefit
Through a visual model, Rational XDE helps you learn about the .NET Framework and understand how your application uses the .NET Framework components. By expanding your classes, you can quickly see which .NET Framework components your application depends on.  Relationships between your application classes and .NET Framework components help you visualize how your application uses these components.  This information gives you quick access to the system library details you need while building your application.
20. Select Edit > Select All Shapes to select all the shapes in the diagram.
21. In the Properties view [image: image22.bmp] located at the bottom right, scroll down to the View section and enter 4000 for Height and 3000 for Width.  Click away to effect the change on the diagram.
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NOTE: Only the properties common to all selected elements are displayed.

Key Benefit
Rational XDE’s tight integration with Microsoft Visual Studio .NET provides a seamless way to modify properties of multiple model elements in one gesture, the same gesture that you use while you develop your software application.
22. Click on the diagram tab [image: image24.png]


 to give the focus to the diagram.

23. Click the [image: image25.bmp] Arrange All Elements icon on the toolbar. 
24. Change the Zoom factor to 75% [image: image26.png]EN



 for better viewing
25. Use the cross hair [image: image27.bmp] in the bottom right corner of the diagram to view all classes with a bird’s eye view. 
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26. Using the Ctrl key, select three of the classes displayed in the Main diagram.

27. Click on the fill color [image: image29.png]


 icon on the main toolbar and select a new color.  The classes background change to that color for easy and quick identification.
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Key Benefit
With Rational XDE you can leverage formatting options, like colors, to make your models easier to read and understand.
Viewing Code And Model Simultaneously

28. At the top of the drawing area, select the [image: image31.bmp] tab representing the code view for the Form1 class.

29. Drag the tab down to the middle of the IDE.  You will notice an icon resembling a document as you do this.  Release the mouse and select New Horizontal Tab Group. 
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Key Benefit
You can customize your work area to see both the visual model and your code at the same time, allowing you to work on either the code or the model and see how your changes impact each area.
30. With Form1 selected on the diagram, select Format > Auto Resize to better view the text of attributes and operations.

31. Right click on Form1 in the Main diagram and select Browse Code to view the code for that form in the Visual Studio IDE code editor window.

[image: image33.png]private System.Uindous.Forms.Bucton buctont;
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Key Benefit

Rational XDE conveniently takes you to the location in the code that applies to your selection context. 

Synchronizing Code and Model Automatically 

32. Select Tools > Options.  On the left side, scroll down, click the Rational XDE folder, then the Round-Trip Engineering folder to see the Auto Synchronization options.  

33. Check the Automatic Synchronization checkbox.   Keep the default settings.  Click OK.

Key Benefit
With Rational XDE, you can leave the burden of maintaining code and model in sync to the tool. Turning auto synchronization on will then free you from the hassle of manually synchronizing your code with your model.  Additionally, Rational XDE lets you to decide when synchronization occurs and how conflicts between code and model are handled.   Because auto synchronization upon each and every change can be distracting, you can turn it off until you are ready to generate code from your model.  
34. In the Main diagram, right click on the Form1 class, select Add UML > Operation.

35. Type GetFormNumber.  Click away from the class.  Notice that the Model Explorer automatically displays the new operation.
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Key Benefit
Rational XDE provides multiple representations of model elements and maintains them in sync at all times.
36. With Form1 selected on the diagram, choose Format > Signature > Operation Signature to display the operation signatures on the diagram.

37. Click on the [image: image36.bmp] Arrange All Elements icon.

38. Click on the Form1.cs window tab. Because auto synchronization is on, this action automatically updates the Form1 code with the new GetFormNumber() operation.
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39. Modify the source code as follows: 


[image: image38.png]public class Forml : System.Windows.Forms.Form
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40. Click in the Main diagram.  Because auto synchronization is on, this automatically initiates the synchronization between code and model, as indicated by the Synchronize icon [image: image39.bmp] pulsing on the Rational XDE status bar.  
41. Wait until the pulsing icon disappears. This is your indication that the synchronization is complete.  

Once code and model are synchronized, you can see the changes you made to the Form1 class automatically updated in the model diagram. 
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Key Benefit
With auto sync turned on, changes in your source code are automatically updated in your model.  Because Rational XDE keeps the visual representation of your application current, you can work the way you feel most comfortable, either in the model or in the source code, without the hassle of having to manually synchronize the two.
42. In the Solution Explorer, right click the DateAndTime project and select Save DateAndTime.

43. Close the [image: image41.png]DateAndTime....ndTime



, [image: image42.png]Forml.cs



 and [image: image43.png]Form1.cs [Design]



 windows.

Integrated design and development increases developers’ productivity by providing an extended development environment where code and model are kept synchronized at all times.

With Rational XDE, developers work the way they feel most productive, either in the model or in the code because Rational XDE handles the hassle of maintaining code and model synchronized.  Developers simply specify how they want conflicts between code and model to be resolved and Rational XDE handles the rest!  

Additionally, Rational XDE maximized your efficiency by allowing you to decide when to turn on automated synchronization.  When you want to test a few designs or apply some patterns without committing the model changes to code, you simply turn off the auto synchronization option.  You don’t have to wait for the tool to synchronize code and models. Other times when you don’t want to have to think about your code and model being out of sync, you turn on the auto synchronization option, and at any change, in model or code, will be automatically synchronized. 

The tight and seamless integration of Rational XDE with Microsoft Visual Studio .NET makes modeling as much a part of the IDE as the code editor and debugger, which accelerates the learning curve and promotes the use of design, code generation, and code synchronization as a daily function.  With Rational XDE developers use the same menus, gestures, and usage metaphors as in the Microsoft’s Visual Studio .NET IDE to effectively work on model elements.  

Automatic Creation of UML Models from Code

The Unified Modeling Language (UML) is the industry standard notation for software development.  With this common language, communication is better, development time is shorter, complex systems are more easily understood, and designs are cleaner and more maintainable.  However becoming proficient at UML can be time consuming.  To help developers learn UML while they code, Rational XDE automatically generates the UML representation of your code directly from your source files!  The generated models are beneficial for documenting your work, understanding complex projects through visualization and harvesting your work for future reuse.  
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Figure 2.  Learn UML While You Code – As developers work in their code, XDE instantly reflects any changes in the corresponding UML model.

In this exercise you will use one of the examples that ships with Visual Studio .NET to experience the following key Rational XDE features:

· Code visualization
· Model references to the .NET Framework
· Learning UML as you code
NOTE:  Because the Visual Studio .NET samples do not typically get installed when installing Visual Studio .NET, you likely will be asked for your Visual Studio CD (or a network location from where you installed Visual Studio .NET) at the start of the exercise.

1. If you have not followed this guide sequentially or have experimented with the synchronization options, please enable auto synchronization at this time: Select Tools > Options.  Expand the Rational XDE folder on the left, and select Round-Trip Engineering.  Check the Automatic Synchronization checkbox on the right.  Click OK.
2. From the Start Page, click on the Find Samples tab [image: image45.png]Find Samples.



. If the Start Page is not visible, select Help > Show Start page.
3. Select Visual C# Developer from the Samples Profile drop down list.

4. Keep the Keyword default value selected for the Filter by field.  Type scribble and click Go.

5. Click on the [image: image46.png]Scribble Sample: Visual C# MDI Drawing Application:Visual C# Samples




 search result. At this time you may be asked to locate the sample solution file.  You can either load your Visual Studio .NET CD or point to the network location from which you installed

6. Click [image: image47.png]Copy All Files



 and accept the default location of MyDocuments. 

NOTE:  This exercise has you copy the sample files, rather than load them, to remain within one instance of Visual Studio .NET.  Loading the files would invoke another instance of Visual Studio .NET, and running multiple instances of Visual Studio .NET can become memory intensive. 

7. Select File > [image: image48.bmp] Open Solution and navigate to the MyDocuments\samples\VCSharp\General\Scribble directory.

8. Select Scribble.sln and click Open.  If asked to save changes to the Test Drive solution, click Yes.

9. In the Solution Explorer, using the Ctrl key, multi-select the three C# files:  Scribble.cs, ScribbleDoc.cs, and ScribbleView.cs.
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Key Benefit

Rational XDE is flexible enough to support model-code synchronization at the class, file, project or solution level.  This allows you to quickly visualize only the code that interests you. 

10. Click the Synchronize icon [image: image50.png]


 in the Solution Explorer toolbar.  

11. Wait for the synchronization to complete. Notice the synchronization icon [image: image51.bmp], progress bar and status in the Rational XDE status bar.  During synchronization, Rational XDE automatically created a[image: image52.bmp]Scribble model in the Model Explorer and opened the model Main diagram (Scribble.mdx::Main).

12. In the Model Explorer, expand the [image: image53.bmp]Scribble namespace.  Rational XDE has added four UML classes [image: image54.bmp] (MainWindow, ScribbleDoc, ScribbleView and Stroke) from the Scribble C# code.  It also added [image: image55.bmp] references to the .NET Framework components that are referenced by the Scribble project. 

Visualizing Code with UML

13. From the Model Explorer, drag the MainWindow class onto the [image: image56.png]Scribble.mdx [Scribble:




 diagram.


14. On the diagram, right click on MainWindow and select Add Related Shapes….  


15. Verify that the Scribble model is selected in the Select in Models drop down list.  Increase the Expand to N Levels to 2.  Click OK.

Key Benefit 

When displaying relationships between elements, you can select the specific models to add elements to your diagrams, as well as the direction and type of the relationships between these elements and elements already on your diagrams.  This level of flexibility allows you to visualize your code at the right level of abstraction, quickly and easily.  
16. Increase diagram readability using the Arrange All Elements icon [image: image57.bmp], the Zoom factor [image: image58.png]N



, and the cross hair [image: image59.bmp].

Understanding References to Visual Studio .NET Framework Classes

17. In the Main diagram, right click the ScribbleDoc class and select Add Related Shapes…


18. From the Select in Models drop down list, select the System.Drawing model.  Set Expand to N levels to 1.  Click OK.

19. Click the Arrange All Elements icon.  Notice the System.Drawing Pen class is added to the diagram.


Key Benefit 

Rational XDE creates a reference model for each .NET Framework component referenced in your project.  By visualizing the relationships between your classes and the .NET Framework, these reference models make it easy to learn the .NET Framework classes as you develop code. 

Assisted Modeling 

Now let’s add a C# property to your ScribbleDoc class so that you can query the class to determine if the associated document is currently the active document.

20. Use the cross hair [image: image60.bmp] to view the ScribbleDoc class on the diagram.

21. Open the Toolbox [image: image61.bmp].  If you do not see a Toolbox, select View > ToolBox. 

22. From the Toolbox, click the [image: image62.png]


 category in the Toolbox.

23. Click on [image: image63.bmp] and click ScribbleDoc on the drawing surface.  
The XDE Add C# Property dialog is displayed.
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Key Benefit

Rational XDE accelerates your UML learning curve by leveraging what you already know, C#, Visual Basic.NET and ASP.NET.  Drag and drop language specific elements from the Rational XDE C#, Visual Basic or Web Toolbox to create UML models using a vocabulary you already understand. 

24. Enter pActive as the Property Name.  Leave the Property Access as public.

25. Select bool from the Property Type drop down list, as the form will either be active or inactive.

Key Benefit

Rational XDE conveniently lists all C# primitive types, saving you time associated with correcting typing errors.  User-defined types may also be typed into the edit box. 

26. Check the box Create field to store property value.

27.  Enter bStatus as the Field Name.  bStatus will be a private variable.  Click OK.  

NOTE: notice on the diagram the bStatus variable and pActive property added to the ScribbleDoc class. C# properties are represented in UML as stereotyped attributes (<<property>>); ‘+/-’ indicates the attribute visibility (public/private).

28. Right-click ScribbleDoc and select Synchronize.

29. Wait until the synchronization process completes.

30. Right-click ScribbleDoc and select Browse Code.  Notice the new pActive property, the bStatus variable and its associated get/set methods.
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Key Benefit

The ‘Add C# Property’ and ‘Add Visual Basic Property’ dialogs provided in Rational XDE supplement the standard Visual Studio .NET dialogs with the ability to create a private field to store the value of the property internally.  In this example, pStatus stores the active state of ScribbleDoc.  This is especially useful when developing Web services where fields may only be accessed via methods. Get and set methods for the new property are also automatically included in the generated code.   

Learn UML as you Code

31. Select the Scribble::Main diagram tab ([image: image66.png]Scribble.mdsx [Scribble:




) to make it the active view. 

32. Right-click the ScribbleDoc class and select Select in Model Explorer. 

33. In the Model Explorer, expand the ScribbleDoc class, and select the pActive property.  

34. In the Properties View, change the Visibility from PUBLIC to PRIVATE.  The change in visibility is reflected in the diagram; pActive as well as its get and set associated operations now display the UML PRIVATE visibility prefix. 
NOTE: UML provides 4 options for Visibility:  PUBLIC, PROTECTED, PRIVATE, and PACKAGE.  These options map to language-specific keywords when code is generated from models.
35. Change OwnerScope from INSTANCE (non-static) to CLASSIFIER (static).  The pActive property is now underlined on the diagram, indicating a static property.

Key Benefit 

Rational XDE facilitates learning UML by visually representing UML properties on the diagram itself.  

36. Select View >Other Windows > Code Properties.  The XDE Code Properties view is displayed over the Properties view.  

37. Click pActive in the Model Explorer.

38. Set the Access property to public. Notice the pActive visibility change on the diagram. 

NOTE: C# provides 5 options for Access: private, public, protected, protected internal and internal.

39. Change Static from True to False.  Notice that pActive is no longer underlined on the diagram.

40. Select the Properties view.

41. Locate the OwnerScope property.  Note that its value is now INSTANCE (indicating a non-static variable).
Key Benefit

Rational XDE helps you learn UML as it relates to the tasks you are doing, at your own speed.  In the Code Properties view of Rational XDE you can modify your code using familiar language terms rather than UML. If you are comfortable using UML, you could accomplish these same tasks using the Properties window and modifying the UML-specific properties. In essence, Rational XDE facilitates learning UML by automatically mapping familiar language-specific terminology to UML terminology.   In this exercise, the OwnerScope UML property was kept in sync with the equivalent C# static property. 

42. To gain a quick understanding of how C# maps to UML, select any class on the Main diagram or in the Model Explorer and view its UML properties in the Properties view.  Select the Code Properties view and alter C# values. Note the changes on the Main diagram and in the Properties view.

43. When you are finished with this exercise, select File > Close Solution to close the Scribble solution. 

44. Close the [image: image67.png]Scribble Sample




 window.

If you want to keep the Scribble sample the way it ships with Visual Studio .NET, do not save your changes when asked. 

Because learning a new notation can be a daunting and time-consuming task, Rational XDE provides language specific assisted modeling (for both C# ad Visual Basic .NET), which allows you to leverage your knowledge of your favorite language to learn the UML.

Visualizing your code in UML models helps you quickly understand the relationships and dependencies between your code and the .NET Framework components it uses.  Rational XDE provides flexible options for expanding, arranging and navigating model elements so that you can instantly visualize specific areas of interest.  You can accelerate your learning curve of the .NET framework by using this same functionality to manipulate visual models of the .NET assemblies provided by Rational XDE.

The combination of the Code Properties View, the Properties View and code generation help you learn UML as you code, making leaning UML a part of your developer day.

With the automatic generation of UML models from code, you become more productive and learn UML as you go, without any downtime.

Web Services

Rational XDE’s support for Web services allows you to visualize your existing systems, new applications and the interfaces they will each require.

As a member of an IT organization, you are rarely faced with the ease of developing an isolated application.  A more typical scenario is that you are not only concerned with the system you are building, but also with a number of existing systems your organization already has developed, and how the new system will fit into your overall system architecture.  

Using Rational XDE’s support for Web services, you can visualize the overall architecture, understand what interfaces exist today and what new interfaces need to be created.  The interfaces can be with legacy COBOL code, Visual Basic or even a C# application created a few days ago.  They can be written in native code or based on industry standards like Web services.  
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Figure 3.  Creating Web services – When developing Web services, Rational XDE creates stereotyped UML classes to represent the Web service elements.
In this section you will learn how to do the following with Rational XDE:
· Model Web services with ASP.NET and Visual Basic.NET

· Model key client relationships with the Web services 

· Conveniently view WSDL files as UML classes

Today, Web Services are used predominantly to interface with legacy systems developed with varying technologies, such as Visual Basic or COBOL.   Web services provide a standard protocol using SOAP, WSDL and UDDI to interface between the same and different technologies rather than create language specific interfaces.  In this exercise you will create a new web service that retrieves the current time.  You will then update a legacy application, the DateAndTime application, to take advantage of your new web service.

NOTE: 
Please ensure you have successfully completed the Integrated Design and Development exercise before beginning this exercise.  Also, if you are performing this exercise for the second time, be sure to remove the existing TimeService Web service by deleting the TimeService folder under your /Inetpub/wwwroot/ directory.
1. If you have not followed this guide sequentially or have experimented with the synchronization options, ensure auto synchronization is disabled: Select Tools > Options.  On the left side, if not l already selected, click the Rational XDE folder, then the Round-Trip Engineering folder to see the Auto Synchronization options.  Ensure that the Automatic Synchronization checkbox is unchecked.  Click OK.
2. Select File > Open Solution… Browse to your Test Drive solution at /My Documents/Visual Studio Projects/ Test Drive/Test Drive.sln.  Click Open.

3. Select File > New > Project….
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4. Select Visual Basic Projects as project type and ASP.NET Web Service as template. 

5. Rename the location http://localhost/TimeService.  

6. Verify that the Add to Solution radio button is checked. Click OK.

After the Create New Web dialog disappears, the Web service is created.
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Creating a Web Service

7. In the Solution Explorer, select the TimeService project and click the Synchronize icon [image: image71.png]


.

8. The Model Explorer is automatically open, and a TimeService model is created.

9. In the Model Explorer, right click the TimeService model ([image: image72.bmp]), and select Add Diagram > Class.  Keep the Diagram1 default name.

10. Expand the [image: image73.png]A} TimeService



 namespace to view the UML model that was created during synchronization.
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11. Drag the Service1 class [image: image75.bmp] and the Service1 Web service[image: image76.bmp] onto the class diagram. Keep the Service1 default name.
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Key Benefit

Upon synchronization of your Visual Studio Web service project, Rational XDE creates two UML classes.  The first class represents the XML Web service entry point, the .asmx file, and is easily recognized by the <<NETWebService>> stereotype.  The second class represents the actual implementation of the Web service.  Visual Studio .NET refers to this as the ‘code behind’ file.  Rational XDE conveniently maintains a <<NETWebServiceProxy>> stereotyped relationship between the Web service class and the code behind file.  Using the UML class representations of these Web service files, you can easily model Web service functionality and even begin to create customized Web service patterns.

12. In the class diagram, right click the Service1 class (the one without the stereotype <<NETWebService>>) and select Add UML > Operation. Name the operation getTime.

13. In the Model Explorer, expand the Service1 class [image: image78.bmp] and select the getTime() operation.

14. In the Code Properties view, locate the ReturnType property and click in the value column.  

15. Click the [image: image79.bmp] button and select System.DateTime. Click OK.
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16. In the Code Properties view, scroll down to the Attributes property.  Type WebMethod.
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17. In the Model Explorer, expand the getTime() operation to see that it has been updated to return the System.DateTime type.
NOTE: In the Code Properties window, the Attributes value is expanded to System.Web.Services.WebMethod.
18. In the Model Explorer, select the [image: image82.png](TimeService) TimeService



 model and click the Synchronize icon. After the synchronization completes, the Service1 Visual Basic .NET code behind file automatically opens.
NOTE:  In the Model Explorer, right click the Service1 class [image: image83.bmp], and select Browse Code will also open the .asmx.vb code behind file.
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19. In the Model Explorer right click the getTime() operation and select Browse Code.

20. Add the following code to the getTime() operation:


[image: image85.png]<System.Ueb.Services.WebMethod()> Public Function getTime() Ais System.DateTime
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21. In the Solution Explorer, right click the TimeService project and select Save TimeService.

Congratulations! You have just created a Web service. Next you will test this new Web service.

Testing a Web Service

22. In the Solution Explorer, right click on the TimeService project and select Debug >Start new instance. Visual Studio .NET automatically creates a test harness to test your Web service.

23. In the browser window that comes up, click [image: image86.png]o getTime



.


[image: image87]


24. Click the Invoke button.  The following display (with the current date and time) indicates your Web service has been successfully created. Congratulations!


25. Close both browser windows that were opened by this exercise.

Leveraging Web services in Your Legacy Applications

Previously you created a C# application, DateAndTime, to get the current date and time.  You will now update this existing application to obtain the current date and time using your new Web service.  

26. In the Solution Explorer, right click on the DateAndTime project and select Add Web Reference…

Key Benefit

Reviewing a WSDL XML document to determine Web service functionality can be a tedious task. Rational XDE conveniently displays the WSDL XML document as a UML class so that you can quickly identify and understand functionality available from the Web service.  When you add a Web reference in Visual Studio .NET, Rational XDE creates two new UML classes.  The first class represents the WSDL document.  The second class represents the proxy class generated by Visual Studio .NET.  Using the UML representation of the proxy class you can model client interactions with the Web service as if it were a locally available component
27. In the Address field, enter http://localhost/TimeService/Service1.asmx and hit Enter.

28. Click the Add Reference button.

NOTE: In the Solution Explorer, notice that the DateAndTime project now includes a Web reference to the TimeService Web service.
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29. In the Solution Explorer, select the DateAndTime project and click the Synchronize icon.  

30. In the Model Explorer, notice the update to the DateAndTime model.
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31. In the Model Explorer, right click the DateAndTime model file ([image: image90.png][5] (DateandTime) DateAndTime*



) and select Add Diagram > Class.  Name the diagram TimeService.

32. Expand the [image: image91.png]A} DateandTime



 namespace and drag the Form1 class ([image: image92.bmp]) onto the diagram.

33. Expand the [image: image93.png]{} localhost



 namespace and drag the Service1 class ([image: image94.bmp]) onto the diagram.

34. From the Toolbox, select the [image: image95.bmp] Directed Association and drag from Form1 to Service1.
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35. While the association is still highlighted, go the Code Properties view and set the following values:


	Name
	mTimeService
	XDE will generate a new member variable in Form1, mTimeService of type Service1. 

	Initial Value
	new DateAndTime.localhost.Service1()
	XDE allows you to set the initial value of the variable.  In this case you will use a fully qualified name to assign mTimeService to a new instance of the Service1 class, which implements your TimeService Web service.
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36. In the Model Explorer, select the DateAndTime model and click the Synchronize button.

37. Right click Form1 and select Browse Code.   Notice the new member, mTimeService and its initial value is exactly what you specified in step 35.
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38. In the Model Explorer, right click Form1 button1_Click() operation and select Browse Code.

39. Replace the function body to invoke the Web service call instead:


40. In the Solution Explorer, right click the DateAndTime project and select Debug->Start new instance.

NOTE: If you run into a namespace compile error, verify in step 35 above that your mTimeService member variable is initialized as follows: 
localhost.Service1 mTimeService = new DateAndTime.localhost.Service1();
41. Click on the DateAndTime application button to see your Web service in action. Close the application.

42. Close the windows associated with the DateAndTime project.

Congratulations!  You just integrated a Web service into your existing application using Rational XDE.


Rational XDE helps speed your learning and adoption of Web services, by reverse engineering a WSDL XML document into a UML class to quickly identify and understand Web service functionality.  When creating Web services in Visual Studio .NET, Rational XDE creates UML classes to represent the .asmx file as well as the ‘code behind’ implementation file and maintains a stereotyped relationship between them.  Using these UML classes, you can model Web services as you would any other component of your application.  

You can even take advantage of customized patterns that incorporate your Web service.  Patterns are the focus of the next exercise.

Integrating with legacy applications, learning new technologies such as Visual Basic .NET and adopting industry standards such as UML and Web services are just some of the challenges you face daily.  Rational XDE facilitates each of these tasks so that your models can truly represent your system and all of its components, helping you meet the biggest challenge IT organizations face today: integrating disparate legacy systems.

Customized Patterns

Patterns are valuable reusable assets that jumpstart the development effort and leverage expertise so that you can finally experience reuse from previous project investments.  Reusing development assets is also critical in jumpstarting any software development effort and ensuring quality designs.   

Included in Rational XDE are well-known industry patterns, like the Gang of Four (see “Design Patterns: Elements of Reusable Object-Oriented Software”, Erich Gamma et al.).  Additional patterns are available for download from the Rational Developer Network. But the true power of Rational XDE is in allowing you to visualize and leverage your own patterns.

In Rational XDE, patterns can be visually developed using the UML and a built-in pattern engine. Additionally, a user-friendly pattern wizard makes applying patterns easier than ever.

Patterns can also be extended by binding code templates, which eliminates the hassle of rewriting the same code over and over.  This binding allows you to supplement patterns with code that is generated anytime you apply the pattern.  This mechanism jumpstarts your coding efforts and improves the quality of your software by reusing proven code contained in code templates.
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Figure 4.  Patterns – Create and apply patterns to maximize developer efficiency and effectiveness, as well as increase your software quality.

In this section you will design a computerized version of a board game and experience the following key Rational XDE features:

· User-defined patterns
· Code templates 
The board game has a single instance of a GameBoard class.  When you need to ensure that an application has one instance of a given class, that instance is called a Singleton.  The Singleton pattern ensures that a class has only one instance, and provides a global point of access to it.  The Singleton participant defines an Instance operation that lets clients access its unique instance.

In this exercise you will create your own version of the Gang of Four Singleton pattern.  You will then create a custom code template and bind it to your pattern to generate code each time your pattern is applied.

You will start by creating a new Rational XDE model to store your pattern.  We recommend storing pattern specifications in models that are separate from your main development models to be able to reuse the patterns in different projects and solutions.

1. If you have not followed this guide sequentially or have experimented with the synchronization options, please enable auto synchronization at this time: Select Tools > Options.  Expand the Rational XDE folder on the left, and select Round-Trip Engineering.  Check the Automatic Synchronization checkbox on the right.  Click OK.
2. In the Solution Explorer, right click on the Test Drive solution and select Add > Add New Item…
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3. Select Rational XDE as category and Blank Model as template. Name the model MyFirstPattern.mdx.  Click Open.  The Model Explorer displays the MyFirstPattern model with its Main diagram.
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Key Benefit
Rational XDE automatically adds a project to the solution when you create a new model file in that solution.  XDE models are shareable between Visual Studio .NET projects and solutions.  Sharing models and Rational XDE's multi-model support ease the creation of enterprise solutions by providing a.) an easy way for everyone to share and build upon the same system architecture and b.) a way to cleanly partition your architecture and manage system / development complexity.

4. In the Model Explorer, right click on the (Solution Items) MyFirstPattern model and select Properties Window.

5. In the Property View, select the AppliedProfiles property and type CodeTemplates (one word) in the value column.  Make sure to respect the capitalization. Click away to effect the property setting.  This setting will allow you to extend the pattern with code generation capabilities to the model.
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Creating a New Pattern


6. In the Model Explorer, right click on the MyFirstPattern model ([image: image103.png]& (Solution Items) MyFirstPattern®



) and select Add UML > Pattern Asset.  A pattern asset is a pattern that is written and packaged to be reusable.


7. In the Add Pattern Asset dialog, set the Pattern Name to MySingletonPattern.


8. Under Asset Name, replace RASPackage1 with MySingletonPatternAsset.
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9. Leave the remaining fields as default.  Click OK.

Key Benefit

Rational XDE assets consist of models written and packaged to be reusable. A software asset is a collection of relevant artifacts that provide a solution to a problem.  In Rational XDE, you can export and import Rational XDE assets stored in the Reusable Asset Specifications (RAS) standard format (see www.rational.com/rda), which is provided to assist in easy pattern exchange, facilitate user application, and provide for documentation of patterns.

10. In the Model Explorer, expand [image: image105.png]P «hssets MySingletonPatternAsset



.  Notice that MySingletonPattern is displayed with a collaboration icon [image: image106.png]i M yFirstPattern 1



.  A pattern is represented in Rational XDE as a parameterized collaboration.


Key Benefit

Rational XDE goes beyond providing the ability to reuse existing patterns.  It allows you to create your own patterns.

Defining Pattern Parameters

After creating a new pattern, you define the pattern input parameters.  Rational XDE records pattern parameters in Template Parameters.  

11. In the Model Explorer, right click on MySingletonPattern ([image: image107.png]<> MySingletonPattern



) and select 
Add UML > [image: image108.bmp] Template Parameter.  Rename the template parameter to InputClass.

12. Right click [image: image109.png]@ Inputdss



and select Add UML > Type > Class.  The template parameter type determines the type of input the pattern will expect, which in this case is a class.  

13. Rename the default name to PatternClass.  PatternClass will define the results of applying the MySingletonPattern to classes.

14. Right click PatternClass and select Add UML> Attribute.  Leave the default name Attribute1.
15. With Attribute1 selected, go to the Properties View and set the following properties:

	Name
	mInstance
	Attribute name

	DefaultValueExpression
	null
	Make sure to use lowercase!

	OwnerScope
	CLASSIFIER

	Attribute qualifier (CLASSIFIER = static)

	TypeExpression
	<%=InputClass%>
	Scriptlet (see explanation below)

	Visibility
	PRIVATE
	


When the pattern is applied, Rational XDE will evaluate the scriptlet specified in the TypeExpression property to substitute the word ‘InputClass’ with the name of the class specified as the input of the pattern.  As a result, applying the pattern to a class of type X will create a new mInstance attribute of type X.

16. In the Model Explorer, right click PatternClass and select Add UML > Operation.  Rename the operation to <%=InputClass%>.
Using the same substitution mechanism, when the pattern is applied, Rational XDE will create a new constructor for the class on which the pattern is applied.

Later in this exercise you will apply the MySingletonPattern to a GameBoard class which, as specified by the scriptlet, will result in a new mInstance attribute and a new GameBoard() constructor for that class.
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Congratulations! You have just created a new pattern!

Testing Your Pattern

Now it is time to test your pattern.  You typically create a pattern as a separate, reusable artifact to be shared across projects, so now you will create a separate test project to test the pattern.

Since the template parameter (InputClass) for MySingletonPattern was defined with a type Class, the pattern requires a class as input, so you will first create a new class.

17. From the Solution Explorer, right click on the Test Drive solution and select Add > New Project…
18. Select the Visual C# Projects project type and the Empty Project template.  Rename the project MyPatternTest.  Click OK.  The MyPatternTest project is added to the Test Drive solution. 

Testing your pattern will not require user interface controls therefore you want to choose a project type other than “Windows Application” since it includes a Windows Form class by default.  A Class Library project is recommended for windowless applications, as it does not include a Windows Form class.  If you are not familiar with building class libraries in .NET, you may want to turn to the .NET Development Best Practices section of this guide.

19. In the Solution Explorer, right click the MyPatternTest project and choose Properties.


20. If not already selected, select Common Properties [image: image111.bmp] General on the left.


21. On the right, change the application Output Type property from Console Application to Class Library.  Click OK.
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22. With the MyPatternTest project selected in the Solution Explorer, click the Synchronize icon [image: image113.png]


 to generate a UML model for the MyPatternTest project. 
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The MyPatternTest model is displayed in the Model Explorer, and the model main diagram is automatically open.

23. With the MyPatternTest:: Main diagram active, right click on the drawing surface and select Add UML>Class. 

24. With Class1 selected, type GameBoard to rename the class.  Click away to deselect the class.

25. Right click on the GameBoard class and select Add UML>Operation.  Keep the default name of Operation1( ).
[image: image115.png]GameBoard

+ Operationt ( )





Applying Your Pattern 

You can now apply your MySingletonPattern pattern on the GameBoard class you just created.  When applying a pattern, you need to specify the pattern input parameters as well as the expansion location (i.e., where you want the results of the pattern application to be stored).

26. In the Model Explorer, right click on the MySingletonPattern pattern ([image: image116.png]<> MySingletonPattern



). Notice the Add to Pattern Favorites option. Using [image: image117.png][} Addto Pattern Eavorites



you can add any pattern to your list of favorites to make it quickly accessible. 

Key Benefit 

The Rational XDE interface is customizable to help you build software faster.

27. Select Apply This Pattern….  The Pattern Wizard is displayed with a short detailed description for your pattern.  Since we did not take the time to enter any description when we created the pattern, you only view the boilerplate text provided by Rational XDE.  Click Next.

Key Benefit
The Pattern Wizard provides an easy and friendly way to reuse patterns.  By simply entering pattern parameters via a succession of wizard panes, developers can accelerate their development and ensure higher quality code. 

28. In the InputClass pane, expand the [image: image118.png][ MyPattemTest) «Cts MyPattemTe:



 and select the GameBoard class.  Click the Select>> button to use the GameBoard class as the pattern input for MySingletonPattern.  Click Next.  

Key Benefit
The Pattern Wizard adapts to the various patterns by displaying different panes depending on the specific input parameters for the pattern you selected to apply.

29. In the Expansion Location pane, select [image: image119.png][ MyPattemTest) «Cts MyPattemTe:



and click the Select>> button to specify your MyPatternTest project as the project in which to expand the pattern. 

30. Click Finish.  Click OK in the Pattern expansion succeeded dialog.


The results of applying the MySingletonPattern pattern to the GameBoard class are a new mInstance static attribute (mInstance:Gameboard = null) and a new GameBoard() operation.  Notice that the pattern also preserved the original GameBoard class operation, Operation1( ).
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Key Benefit 

The behavior when patterns are applied is configurable so that patterns can merge, replace or preserve existing elements.  Pattern behaviors can be explored further in the Pattern Explorer and Pattern Properties windows (available from View > Other Windows > Pattern Explorer). 

Binding Code Templates to Patterns

Now that you’ve validated that your pattern works as expected, you will include some reusable code to the pattern by attaching a custom code template to the Instance operation of the MySingletonPattern pattern.  Code templates can be bound to UML elements to specify the code to be generated for that UML element, in particular, method bodies.  

Key Benefit 

Used in conjunction with patterns, code templates provide a powerful way to get more code from your models. 

31. In the Model Explorer, right click the PatternClass class and select Add UML>Operation.  Rename the operation to Instance.
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32. Right click on Instance() and select Add UML > Parameter.  Keep the default Parameter1 name.

You will use this parameter to specify the return value of the Instance() method.

33. With Parameter1 selected in the Model Explorer, go to the Properties View and set the following properties for Parameter1:

	Name
	Delete Parameter1.
Leave blank.
	When the Kind property is set to RETURN, the name of the parameter is not used for code generation. 

	Kind
	RETURN
	Instance( ) does not take any input parameters but needs to return one.

	TypeExpression
	<%=InputClass%>
	The code template will substitute ‘InputClass’ with the name of the class to which the pattern is applied.



Because the Instance( ) method will need to return a type, but that type will vary depending on the type of class the MySingletonPattern pattern is applied to, you use a scriptlet to define the type dynamically.  When applying the pattern to a Foo class for example, the Foo.Instance( ) operation will return a Foo type. 
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Key Benefit 
Every time the pattern is applied to a class, that class will automatically be assigned the information stored in the pattern definition (in this exercise, an attribute and a constructor).

34. In the Model Explorer, right-click on the Instance() operation and select Code Templates > Bind….  This will bind a code template to the pattern Instance( ) method.


35. In the Bind Code Template dialog, click New….  The Create Code Template wizard appears.  In the Name text box, enter MyFirstCodeTemplate. 

36. Optionally enter some descriptive text for the code template in the Description box.  Click Next.

37. On the Step 2 of 2 pane, click Add… 

38. Fill in the Template Parameter dialog as follows:

	Name
	InputClass
	The InputClass template parameter will be used by the code template to get information.

	Type
	String
	The value extracted from the InputClass template parameter will be of type String.

	Default
	<%=InputClass%>
	The default value will be the result of the <%=InputClass%> scriptlet evaluation which, in this case, is the name of the input class when applying the pattern.


39. Click OK.


40. In the Body text box, enter the following code:





41. Click Finish.
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42. Click Bind.  The code template is bound to your MySingletonPattern pattern.


Congratulations!  You just created a code template and furthermore, bound it to a pattern.  Now every time you apply the MySingletonPattern pattern to a class and generate code, Rational XDE will generate this code for you!

Key Benefit 

Customizable patterns and code templates are a powerful option for code generation.  Using proven patterns and automating mundane coding through code templates saves you time.  These assets make it possible to share your expertise and custom solutions with other members of your team.  Additionally, pattern bindings make it simple to update classes when a pattern changes. 

Generating Code from Code Templates

To see the result of binding a code template to your pattern, let’s reapply MySingletonPattern to the GameBoard class and generate code for that class.

43. In the Model Explorer, scroll down to view MySingletonPattern_Binding [image: image124.png]1> MySingletonPattern Binding



.


44. Right click MySingletonPattern_Binding and select Reapply Pattern.  
45. Click OK to dismiss the Pattern expansion succeeded confirmation dialog. 

Notice the Instance() operation added to the GameBoard class.
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46. In the Model Explorer, right click on the GameBoard class and select Synchronize.  The synchronization process will add the Instance() operation to the GameBoard class in the code and keep the code and model consistent with one another.

47. Wait until the synchronization is complete.

48. In the diagram or from the Model Explorer, right click the GameBoard class and select Browse Code.  The code appears as follows:
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As a result of the <%=InputClass%> scriptlet substitution in the code template body, Rational XDE added the code defined in the code template to the GameBoard Instance( ) method, using GameBoard as the return type. 


49. From the main menu, select File > Save All to save your solution with all projects and model files.

The pattern support in Rational XDE is flexible in various ways:

· Via a binding between the pattern and its expansions, Rational XDE allows you to quickly update classes to which the pattern was applied when the pattern changes.  
· Rational XDE allows you to expand a pattern in any model.

· Patterns can be applied via UML stereotypes, which are a powerful way to classify model elements into categories.  By binding a pattern to a stereotype, applying the stereotype to the model element will automatically expand the pattern. 

· Rational XDE provides binding between patterns and parameterized code templates so that code is generated when you apply a pattern.  

In short, Rational XDE’s complete patterns engine and code templates accelerate early development, ensure efficiency and quality throughout the lifecycle, and encourage code reuse for more consistent, reliable projects.  You can now better utilize your creative capabilities to design your own patterns and avoid repetitive and tedious tasks. 

Besides providing you with a set of industry proven design patterns, Rational XDE adds unprecedented support for developing your own patterns.  For more pattern examples, visit the RDA Exchange section of the Rational Developer Network at www.rational.net.

Best Practices for .NET Development 

The previous exercise had you created a .NET class library.  If you were not already familiar with developing class libraries in .NET, you can turn to Rational XDE .NET development best practices to learn more about the topic.  Rational XDE Professional includes the Rational Unified Process Configuration for .NET Developers, a streamlined version of the Rational Unified Process customized specifically for .NET development.  
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Figure 5.  RUP for .NET Developers –.NET developers have online guidance at their fingertips.
The following exercise steps demonstrate how to navigate the RUP best practices for .NET development to find information pertinent to your .NET project.

1. Select Start > Programs > Rational XDE Professional .NET Edition > 
RUP® Configuration for Microsoft® .NET Developers.
2. In the Rational Unified Process (RUP) tree on the left, expand Disciplines ([image: image128.bmp]).

3. Expand Analysis & Design.  Note that you could also have clicked on Analysis & Design in the diagram.

4. On the blue banner at the top, click [image: image129.png]Q. search



. In the Enter Query field, type class library and click the Search button.

5. Click Guidelines:  Developing Class Libraries in .NET and close the Search window.

6. Scroll through the information on that page. 
7. Close the Rational Unified Process browser page.
The RUP Configuration for .NET Developers makes applying process practical by providing concrete examples specifically for .NET development in an easy to navigate, HTML format.  For instance, if you are involved in migrating COM-based applications, the RUP .NET Configuration provides information about .NET Web Service Applications, Windows Forms, and COM object interoperability. 

Getting More Return From Your Models
Rational XDE unites the strength of a semantically-rich UML tool with the freedom and flexibility of free-form diagramming.  As they say, a picture is worth a thousand words.  With free-form diagramming, you can annotate your model as well as diagram non-traditional design elements.  This flexibility makes your models more understandable to project team members who are not familiar with the UML notation.  

Rational XDE’s multi-model environment allows you to cleanly separate and reuse the various parts of your design.  Using multiple models and inter-model relationships you can effectively communicate your system at many levels of abstraction to all project team members.

Rational XDE further enhances communication amongst team members by providing a single environment that integrates developers, architects and database designers. Using a common language, the UML, Rational XDE brings together data modelers, architects and developers ensuring consistent communication throughout project implementation.  Multiple models can be used to communicate application architecture, database design and their dependencies.  Unlike traditional data modeling tools, Rational XDE provides UML-based data modeling capabilities to facilitate communication amongst all team members who require an understanding of database constructs and how they relate to the system design.
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Figure 6.  Free-form Modeling – Model in ways that increase communication effectiveness and enhance designs.

With Rational XDE, you can publish your models to the Web and generate HTML reports.  These reports allow you to communicate system details to all project stakeholders, including those not using Rational XDE.  Rational XDE provides four predefined model reports (Summary, Summary with Diagrams, Use Case, and Class reports).
In this section you will model a simple payroll system and experience the following key Rational XDE features:

· Multi-model support

· References across models

You will use Rational XDE’s unique multi-model functionality to express a small part of an order entry system to your non-UML adept team members.  Then you will document the same system in more detail for a member of your development team.  One of the system requirements is that a sales person and the warehouse receive notification when a customer account has changed (e.g., an order has been added or removed).  For simplicity, we purposely ignore order edits in this exercise.

1. If you have not followed this guide sequentially or have experimented with the synchronization options, please enable auto synchronization at this time: Select Tools > Options.  On the left side, click the Rational XDE folder, then the Round-Trip Engineering folder to see the Auto Synchronization options.  Ensure that the Automatic Synchronization checkbox is checked.  Click OK.
2. In the Solution Explorer, right click on the Test Drive Solution and select Add > New Project…

3. Select Visual C# Projects as project type and Windows Application as template.


4. Rename the project to MultiModel.  Click OK.

Adding an Analysis Model to Your Project

You will use an analysis model for the analysis-level classes and high-level diagrams.  Using a separate analysis model from the design model makes it convenient for modeling and documenting various aspects of your system without disturbing the implementation classes and code that reside in a separate model.

5. In the Solution Explorer, right click the MultiModel project and select Add > Add New Item…


6. Select Rational XDE as category and Blank Model as template.  Set the model name to AnalysisModel.mdx.  Click Open. 

The AnalysisModel model is added to the Model Explorer and its Main diagram is opened. 


Modeling Your System for Your Manager

Your manager needs to sign off on the high-level design you are proposing but is not interested in the details of your design.  In this section, you will utilize Rational XDE free-form modeling to effectively express and communicate your solution to your manager or any project team members who are not as familiar with UML as your design team.

7. Right click on the Main diagram drawing area and select Add UML>Class. Name the class Customer.

8. Repeat the previous step and rename the class to Account.

9. In the Toolbox, select the UML Deployment category.

10. Scroll down [image: image131.bmp] to select MainFrame [image: image132.bmp]and click onto the diagram.  Enter Order System to rename the new element.

11. From the Toolbox, select Cloud [image: image133.bmp] and click onto the diagram.  Rename it to Warehouse System.


12. From the Toolbox, select Ethernet [image: image134.bmp] and click onto the diagram.  Rename it to Mail System.

Key Benefit
Rational XDE provides a standard set of icons representing real world objects.  These icons help you create diagrams that better communicate your design and architecture.  A complete set of free-form geometrical shapes is also included in Rational XDE. 
13. From the Toolbox, click the UML Class category, hit the Ctrl key (to make the Toolbox selection stick), select the Directed Association arrow [image: image135.bmp] and connect the classes on the diagram to document the following flow:  

· Arrow from Customer to the Order System (the customer places an order with the Order System)

· Arrow from Order System to Account (the Order System updates the Account)
· Arrow from Account to Warehouse System (the Account updates the Warehouse System)
· Arrow from Account to Mail System (the Account updates the Mail System)
14. In the Toolbox, select the Pointer [image: image136.png]N Painter




15. Using the Ctrl key, select the four association lines, right click on the selection and select Hide Connector Labels.
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Key Benefit
Free-form modeling allows you to combine strong semantic content with unrestricted content to better convey your designs, even to those who do not understand UML or the technology details of your design.   With free-form modeling, Rational XDE gives you a way to model your system at different levels of abstraction to adapt the granularity of your models to your audience.
Modeling Your System for Your Development Team

Your manager may not be interested in the details of your design, but these details are crucial to your development team.  In this example, there may be more than one type of account (e.g., government or institutional).  To model this detail of your design, you will create a UserAccount class, which is a specialization of the Account class displayed above.  The UserAccount class will be stored in your design model (MultiModel) MultiModel.

16. Navigate to the Solution Explorer.  Because auto synchronization is on, this will open the MultiModel main diagram. 

17. Right click on the diagram and select Add UML> Class.  Rename it to UserAccount.  Click away to deselect the class.

18. Right click on UserAccount and select Add UML>Operation.  Rename it to AddNewOrder.


19. Repeat the above step and name the operation RemoveOrder.
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Applying a Pattern


Now it is time to discuss how you will implement the UserAccount class.  Let’s assume that you will need to inform several systems every time orders change (e.g. an order is added or removed), so you need the ability to observe changes made to the UserAccount class. The Observer pattern described by the Gang Of Four provides an implementation for such a need.  The Gang of Four Observer pattern defines a one-to-many dependency between objects so that when one object changes state, all its dependents are notified and updated automatically.

20. In the diagram, right click on UserAccount and select 
Apply Favorite Pattern > (GOF Patterns) Observer.   If an upgrade dialog is displayed, click Upgrade.


Key Benefit 

Rational XDE ships with industry-proven patterns, like the Gang of Four patterns, for you to leverage design best practices.  This saves you time and improves the quality of your designs. 
21. The Pattern Wizard is displayed.  It provides a user-friendly way to specify input parameters for the pattern.  After reading the description and usage for this pattern, click Next.  

22. Follow the table below to enter or select the parameters on each pane. Click Next to move to the next pane.

	Pane
	radiobutton selection
	Enter (E) or Select (S)
	Explanation

	Subject
	Generated Value
	(E) 

AccountSubject
	AccountSubject will manage the list of subjects being observed.

	ConcreteSubject
	Selected Element
	(S) 

UserAccount class in the <<C#>>MultiModel

Click Select >>


	UserAccount is the class to which we apply the Observer pattern.

	Observer
	Generated Value
	(E) AccountUpdateManager 
	AccountUpdateManager will be an interface that all the ‘observers’ have to implement if they want to be notified when the UserAccount class changes.

	ConcreteObserver
	Generated Value
	(E) 

MailSystemObserver 

Click Add>>
	MailSystemObserver will be added to the list of observers who should be informed when the UserAccount class changes.

	Object
	Generated Value
	(E) AccountUpdateObject
	AccountUpdateObject stores the nature of the change.  For example, the Mail System will need to know whether the order was removed or added, as well as the order number.  Access to this sort of data is contained in the Object parameter for the Observer pattern.

	Expansion Location
	
	(S) 

MultiModel) <<C#>>(
MultiModel model

Click Select>>
	The expansion location determines the location of where the pattern expansion will occur.


23. Click Finish.  Click OK to dismiss the Pattern expansion succeeded confirmation dialog.  Notice the result of applying the Observer pattern to the UserAccount class: a new attribute and three new operations have been added to that class.
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Congratulations! You just applied the Gang Of Four Observer pattern.  Let’s take a look at the results of applying this pattern.

24. In the Model Explorer, scroll up and double click the (MultiModel) MultiModel > [image: image140.bmp] Observer Participants diagram to open it.

Key Benefit
Rational XDE conveniently creates a new diagram laying out the classes that participate in the Observer pattern.  Applying patterns jumpstarts your implementation and ensures that your code follows modern coding practices by taking advantage of a proven solution.
Setting Properties for Multiple Objects

Using the Pattern Wizard, you have established the Mail System as an observer.  Here you will add the Warehouse System as an additional observer.
25. In the Model Explorer, right click the MailSystemObserver class and select Copy.

26. In the Model Explorer, right click the (MultiModel) MultiModel model and select Paste.

27. Rename MailSystemObserver_1 to WarehouseSystemObserver.

28. Drag the WarehouseSystemObserver onto the Observer Participants diagram (which should be open).

NOTE:  the relationships between WarehouseSystemObserver and other classes are automatically added.

29. On the diagram, using the Ctrl key, select the WarehouseSystemObserver and MailSystemObserver classes.

30. In the Properties view, on the Properties tab, locate the UML section.  For the Stereotype property, enter observer.  Click away.
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Notice the class stereotype displayed on the diagram. If necessary click the Arrange All elements icon.
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Key Benefit
The Properties View speeds the setting of object properties by supporting the selection of multiple elements to modify common properties in one action.  Changes in the Properties View are automatically reflected on diagrams.  The Properties View helps you gain an understanding of your models as it keeps the element properties visible and in correct context as you navigate through your model. 
Iterative Development Using Multiple Models 

Since UserAccount is a specialization of the Account class, you will now display the relationship between the two classes.  Remember that the two classes live in two different models!  Rational XDE allows you to set relationships between elements belonging to different models.

31. Open the (MultiModel) MultiModel Main diagram.  Recall that applying the Observer pattern has added an attribute and three operations to the UserAccount class.

32. In the Model Explorer, in the (MultiModel) AnalysisModel model, select the Account class and drag it onto the diagram.

33. From the Toolbox, under UML class, select Generalization [image: image143.bmp] and drag from the UserAccount to the Account class.  The generalization relationship indicates that UserAccount is a specialization of the Account class.
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34. In the diagram, right click the Account class and select Add UML> Operation.  Rename the operation to RemoveOrder.

35. Repeat above step and rename the operation AddNewOrder.
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36. In the Model Explorer, in the (MultiModel)AnalysisModel, expand the Account class.  

NOTE: the two new operations have been added to the Account class.  Even though you added the two operations to the Account class from the MultiModel diagram, the AnalysisModel model, which contains the Account class, has automatically been updated with the two new operations.
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Key Benefit

Using familiar drag and drop gestures, Rational XDE allows you create relationships between model elements contained in separate models.   Model elements created in one model can be quickly updated from a different model so that you can incorporate change as you work and propagate that change to maintain model consistency.  
37. Select the Solution Explorer. If you still have auto synchronization on, simply switching to the Solution Explorer will initiate the synchronization process to ensure that your code and model are synchronized.

38. Right click the MultiModel project and select Save MultiModel.  

Key Benefit

Multiple models make it convenient to express different views of a system that contain differing levels of abstraction.  You can view your code and model, but you can also easily create references to other models to express that information in various levels of detail.  Rational XDE multi-model flexibility and free-form modeling allow you to express your ideas in a manner that is appropriate for any target audience.
With Rational XDE, you can communicate your designs using free-form modeling without the constraints of the UML notation.  The Model Explorer facilitates organizing and managing model elements.  Using familiar drag and drop concepts, you can easily relocate and reference elements in multiple models.  

Rational XDE multi-model support provides the following key benefits:

· Separate analysis models from design and development models

· Facilitate reuse of architectural components by separating the reusable parts of your architecture
· Design freely by representing your system in multiple models 
· Organize your designs the way you want

· Facilitate parallel development by making models more manageable
Rational XDE goes beyond the ability to store your designs in multiple models – it maintains live references across models.  Model references allow you to remain in your current model to make updates to elements located in other models, eliminating duplicate work.  References across models are then dynamically updated.  Full search and replace capabilities across models ensure that you can maintain model integrity and consistency without added effort. 

Flexible Team Development and Configuration Management 
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	Rational XDE Professional .NET Edition works in conjunction with Rational ClearCase, Rational ClearCase LT, Visual Source Safe, as well as any SCC-compliant configuration management tools, such as Microsoft Visual SourceSafe, to provide source control, versioning, and for some CM tools, branch/merge capabilities.

You can fully utilize Rational ClearCase directly within your development environment for versioning your code or model artifacts.  The result is easier, faster, more comprehensive development.  Large models can be divided into multiple files making them easier to work with, and thereby facilitate working with teams and configuration management systems.  For maximum control of your development process and increasing the effectiveness of parallel development, you can even maintain versions of your models down to the class level.  On-demand storage unit loading lets you access model elements without worrying whether or not they are currently loaded; the unit simply loads automatically when you access an element that requires it.

Also, you can set your preferences to automatically check out controlled units when you edit them, or to automatically add newly created storage units to your configuration management system.  Using Rational XDE's Compare and Merge capability, you can view the differences and conflicts among model or storage unit files, manually or automatically resolve conflicts, and then merge the files to produce a single output model.  This is critical in a parallel development environment where more than one person is allowed to work on the same controlled units simultaneously.

NOTE:  Rational ClearCase and Rational ClearCase LT are separate products that are not included with Rational XDE.


Integrated Use-Case Management (IUCM) 

Not only does Rational XDE extend your development environment, but Rational XDE itself can be extended to provide integrated use-case management, through an integration with Rational RequisitePro, the Requirements Management solution from Rational Software.  

Integrated use-case management extends use cases in Rational XDE with requirements information.  This benefits the Rational XDE user by establishing a real-time window to modify use case attributes, traceability and view revision history from Rational XDE.  Integrated use-case management allows Rational XDE users to establish and maintain a bi-directional link between a use case in Rational XDE and the textual definition of the use case in a RequisitePro document.  The RequisitePro use case documents contain the descriptions, flows of events, special requirements, preconditions and post conditions of use cases.  These documents are immediately accessible from Rational XDE’s contextual menus; simply right clicking on a use case in a diagram or from the Model Explorer brings up the use case document associated with the selected use case.  In addition, use case attributes, such as priority and status, can be set from Rational XDE, which allows for sorting and filtering of use cases in RequisitePro.  Finally, a change to a use case in Rational XDE will flag potentially impacted requirements - by generating, automatically and in real-time, suspect traceability links in RequisitePro.

By managing use cases in conjunction with other requirements, the scope of software development projects are better managed, change is controlled, and the project’s business needs can be verified.  In short, integrated use-case management helps ensure that your team is implementing the functionality agreed upon with your customers, and that this functionality appropriately evolves as the business drivers change.
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For information on IUCM, consult the white paper at http://www.rational.com/products/whitepapers/433.jsp. 

Rational Developer Network 

Beyond providing valuable development tools that are integrated right into your IDE, Rational provides a central place with powerful resources for Rational XDE practitioners.  The Rational Developer Network, which is securely accessed directly from Rational XDE, aggregates all the essential Rational XDE content and provides access to the XDE development community with specific content and skill building resources to help increase your development efficiency and master Rational tools and software best practices.  
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Figure 7.  Rational Developer Network – Getting Started with Rational XDE Professional.

Some of the Rational XDE-related items you will find on the Rational Developer Network include:
· A Rational XDE Knowledge Center where you will find all Rational XDE-related content as well as specific threads addressing the needs of the developer using the Microsoft .NET Platform.  
· An exclusive Rational XDE tutorial.

· Getting started technical articles for .NET written by developers using Rational XDE to build real-world solutions.

· Technical articles and Rational Development Accelerators that provide developers quick access to tested artifacts that they can incorporate into their projects.  Rational Development Accelerators (RDA) provide software assets that extend the capabilities of the core Rational solution.   RDA focuses on helping you manage and apply reusable assets so that you gain maximum leverage from your precious organizational and technical knowledge.  RDA includes sample and reference assets, which make best practices tangible, and provide a path towards systematic reuse of software assets

· A Rational XDE Discussion Center that will provide a central place for Rational XDE customers to exchange ideas and experiences.  

· Rational Unified Process configurations for developers. 

· Self-paced Web-based training.

Conclusion

We hope this guide has given you a good overview of the benefits that Rational XDE provides to Microsoft Visual Studio .NET developers.  

Rational XDE Professional enables software developers to build better software faster by extending their development environment with essential, fully integrated tools.  This revolutionary tool from the leader in software development combines the expressiveness of visual modeling with the power of a .NET development environment.  

Rational XDE Professional improves the way you work in the following ways:

· Experience true developer convenience with a single design-to-code experience – No longer do you need to constantly switch between applications to design and code.  It is all encapsulated within one environment, eliminating the need to be a master at arranging your application workspace on your computer.  

· Communicate effectively – Within one tool you can draw any type of diagram, depict system architectures, designs and more by selecting from a large collection of shapes and figures.  Also, you have the freedom to create your own shapes and figures, as well as have on-demand UML conformance validation. 
· Organize models to meet your team’s needs in a parallel development environment – Cross-model referencing and versioning of elements (down to the granularity you desire) enables development teams to minimize redundant work, maintain the integrity of models, and partition solutions into manageable units so that developers can work on various pieces in parallel.

· Code-centric or design-centric development – No longer do you need to model first, then code or vice versa.  You have the freedom to work as you need.  Additionally, as you work with either the design or the code, the integrity of both is maintained synchronously.

· Develop higher quality software faster by reusing patterns and code templates – Define your own patterns and code templates, or modify existing patterns supplied in Rational XDE as well as through the Rational Developer Network to jumpstart your development process.  Reusing these assets eliminates mundane, repetitive tasks and ensures higher quality by using patterns that are proven.
Lastly, Rational XDE is created and supported by Rational Software, a premier Microsoft partner.

If this guide has not quenched your thirst for Rational XDE, you will find additional evaluator materials on the Rational Developer Network, under the Development Resources >Rational Tools >Rational XDE section:

· Getting Started Guide for Rational XDE for .NET, which includes a product tutorial and commonly asked questions about XDE,

· Rational XDE Knowledge Center, which includes reusable assets (under RDA Exchange), Rational XDE training, and Microsoft.NET process guidance (under RUP Exchange). 

You may also want to browse the XDE section of the Rational Web site at http://www.rational.com/products/xde/.
Appendix

This section provides a quick and visual overview of the Rational XDE interface in the Microsoft Visual Studio .NET IDE and the various windows referred to in this guide.  
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Figure 8.  Rational XDE– Rational XDE is tightly embedded in the Microsoft Visual Studio .NET IDE.

A. The Toolbox is graphical representation of all the possible modeling elements the user may drag/drop onto a modeling diagram.  The Toolbox is grouped by modeling categories such as UML diagram types and General objects used in free-form models.  The up/down arrows provide navigation for lengthy lists of modeling elements.  Users can add their own Toolbox categories as well as move elements between categories.

B. The Solution Explorer provides a view of the entire project or solution.  Multiple projects can be viewed at any time.  A project stores a collection of files that can include references, models, source code, storage units, text files, and other project-related artifacts.

C. The Model Explorer displays all elements that can be associated with a project which range from pattern assets, diagrams, other model and external documentation.  Users may drag and drop model elements from the Model Explorer onto a diagram.  Similar to the Solution Explorer, the Model Explorer allows the user to view and modify multiple models at any given time.

D. The Properties View is context sensitive and will display all the given properties for a selected element.  These properties can be modified from within the Properties View.  When creating patterns, a Properties View specific to pattern creation is opened.

E. The Task Window shows model validation, compilation and build errors.  Users can also enter their own tasks.  The tasks that appear in the window are context sensitive.  When viewing source code, the task window will display compilation and build errors and warnings.  When viewing model diagrams, model validation errors and warnings will be displayed.

F. The Output Window is a log window that displays results of various program actions, such as the creation or modification of a new project, model file, model element, etc.

G. The Model Documentation Window displays documentation at the model element level.  
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private void button1_Click(object sender, System.EventArgs e)


{


	textBox1.Text = mTimeService.getTime().ToString();


}
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if ( mInstance == null )


{


	mInstance = new <%=InputClass%>();


}


return mInstance;
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