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Preface
Welcome to the IBM Rational® RequisitePro® evaluators guide.  

This guide is intended to help you understand IBM’s requirements  

management approach and our product offerings.

About IBM Rational software and the full lifecycle 

solution

The IBM Rational RequisitePro requirements man- 

agement tool is written, supported and maintained 

by IBM Rational, which helps organizations create 

business value by helping to improve their software 

delivery capability. Partnering with a leader like 

IBM helps ensure that you receive high-quality 

support and mentoring for your projects—a key 

ingredient of successful software delivery.

The IBM Rational group is unique in that it 

provides not just software tools, but also a set 

of software engineering best practices; an inte-

grated set of software tools spanning the entire 

development lifecycle; and services to help indi-

viduals, teams and organizations accelerate their 

software delivery by leveraging lessons learned.

As you experiment with the Rational RequisitePro 

application, keep in mind that, while the software 

addresses your immediate requirements manage-

ment needs, it is also included in several IBM 

Rational offerings, most notably the IBM Rational 

Team Unifying Platform™, which is an open and inte-

grated set of collaborative tools for software teams.

Because requirements should not live in a silo,  

the Rational Team Unifying Platform solution 

helps provide tight integrations between Rational 

RequisitePro and the other components of the 

Rational Team Unifying Platform solution. Depend-

ing on your needs, you should consider either  

the Rational RequisitePro or the Rational Team  

Unifying Platform solution as a core component  

of your software delivery solution.
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Requirements management overview
Application development is a complex undertak-

ing. The software technologies you apply to this 

challenge are becoming more powerful, yet com-

plexity still remains. To streamline and manage this 

complexity, you must clearly define the problem 

you are facing and the solution to that problem. 

Only then can you develop and deliver solutions 

that satisfy real customer needs.

Unfortunately, most project teams tend to forge 

ahead building solutions to problems that are not 

clearly understood. Studies repeatedly show that 

neglecting to carefully solicit user input and poorly 

managing project requirements are significant 

reasons why many projects fail.

Getting a handle on the front end of the software 

development lifecycle is an essential first step to 

delivering a product or application that is of value 

to its users. Understanding real-world problems, 

and recording user needs associated with these 

problems, is key to delivering business value to 

your customers. Without such understanding, your 

team is likely to develop an off-target solution, miss 

a critical window of opportunity or be overrun by 

the competition. The better your team understands 

the problem space, the firmer the foundation upon 

which you can build a solution.

As a natural and logical outcome of problem 

analysis, project teams define requirements for 

a system. Just as careful directions can help you 

reach a particular geographic destination, clearly 

defined system requirements can be critical in get-

ting a software project to its target. Beyond defining 

requirements, effective requirements management is 

essential to keeping a project on track.
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An effective requirements management process 

reduces project risks by systematically collecting, 

managing and communicating the changing require-

ments of any project. The purpose of requirements 

management is to establish a common understand-

ing between your team and your customer on what 

you are going to build. A well-implemented require-

ments management process not only helps your 

team deliver a quality product on time and within 

budget, it also helps ensure the viability of the 

entire project.

Studies have shown that most software teams 

document requirements in the Microsoft® Word 

application. Yet documents are limited in their 

ability to organize requirements, and it’s dif-

ficult to track information other than the text of 

requirements. So the challenge of a successful 

requirements management tool is to combine 

the communicative power of documents with the 

analytical capabilities of requirements tracking. 

IBM Rational RequisitePro has gained popularity 

as a requirements management tool because it is 

designed to achieve this dual goal.

The Rational RequisitePro central requirements 

repository stores valuable requirements information 

such as requirement attributes, requirement status, 

relationships between requirements and revision 

history, helping to provide the capability to sort, 

query and track requirements. Without this ability, 

it is nearly impossible to track project status and 

achieve project success.

With the right requirements management tool, any 

organization’s chance of success can increase 

dramatically. Nowhere is this more true than in soft-

ware development, where the pressure to deliver 

high-quality applications in the least amount of time 

has become a make-or-break factor for thousands 

of companies.
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Key benefits of IBM Rational RequisitePro software

1	Dynamic integration between the  
Microsoft Word application and a  
requirements database

Pain

Requirements stored only in a database lack 

context and are difficult for stakeholders to 

understand. Requirements stored only in docu-

ments are hard to organize, prioritize and track.

Benefit

With Rational RequisitePro there is little to 

no learning curve because requirements 

can be created and updated directly in the 

Microsoft Word application, a familiar environ-

ment for most people. The Word documents 

contain requirements and contextual text 

that is vital for understanding requirements. 

The integrated database (IBM DB2®, Oracle, 

Microsoft SQL Server or Microsoft Access) 

helps enable you to organize, prioritize and 

track project requirements, something the 

Word application alone cannot do well. All of 

this means that Rational RequisitePro can be 

adopted fast, potentially leading to a quicker 

return on investment.



☺

2	Integrations with lifecycle software  
development tools

Pain

Business analysts, designers, developers and 

testers should be able to view the latest state 

of requirements. Yet it is inefficient and error 

prone to duplicate requirements in develop-

ment, testing and business modeling tools.

Benefit

Rational RequisitePro is integrated with IBM 

Rational Software Architect, IBM Rational 

Software Modeler, IBM Rational TestManager, 

IBM Rational SoDA®, IBM Rational Unified 

Process® (IBM RUP®), IBM Rational  

ClearQuest®, IBM WebSphere® Modeler  

and IBM WebSphere Integration Developer, 

as well as Microsoft Project software. Inte-

grated tools can help provide a smooth 

workflow and help eliminate errors due to 

requirement discrepancies across tools. 

Integrations can help keep the entire project 

team in sync and improve team productivity. 

Easy access to requirements from other tools 

helps encourage all team members to view 

the requirements before starting their work.



☺

Features alone add no 

value unless they ease  

a pain and solve a prob-

lem. The following list 

presents the software 

pains addressed and 

the benefits potentially 

provided by IBM Rational 

RequisitePro.
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Key benefits

3	Distributed access to requirements

Pain

Distributed team members are not provided 

the latest requirements information and, when 

pressed for time, may keep working with 

obsolete information.

Benefit

The Web interface of IBM Rational RequisitePro 

provides most of the Rational RequisitePro 

functionality. Anyone with Web access can view 

and edit requirements, attributes and traceabil-

ity links as well as create and edit documents 

quickly and efficiently. Rational RequisitePro 

projects can be administered via the Web too.



☺

4	Requirements traceability and coverage 
analysis

Pain

End users are disappointed that the func-

tionality they expected is not present in the 

delivered product because not all require-

ments were implemented.

Benefit

IBM Rational RequisitePro support for trace-

ability allows you to easily set up and track 

relationships between requirements to verify 

whether high-level requirements are associ-

ated with detailed software requirements. 

Querying these relationships provides cover-

age analysis to help ensure completeness, 

and potentially make sure time is not wasted 

building irrelevant functionality. Integrations 

with other software tools mean that require-

ments can trace to other artifacts too, including 

business models, enhancement requests, 

designs and test cases.



☺
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Key benefits of IBM Rational RequisitePro software

5	Impact of requirements changes

Pain

Requirements change, and it’s difficult to 

understand the impact a change has on the 

system and on other requirements.

Benefit

With Rational RequisitePro, when traceability 

is established between requirements, and one 

of the requirements changes, suspect links 

automatically appear. This helps you identify 

other requirements that may be affected by the 

change. When using IBM Rational Software 

Architect or other integrated products, suspect 

links are displayed between changing require-

ments and their associated elements, so it’s 

clear what parts of the system are affected. 

Understanding the impact of change helps 

you more accurately assess the potential cost 

in time and money of changing requirements.



☺

6	Requirements attributes and query  
capability

Pain

When requirements are prioritized on an ad hoc 

basis, the resulting system may not provide the 

best solution for your customers or your busi-

ness. Without documenting the risk, priority and 

difficulty associated with each requirement, you 

cannot objectively define which requirements 

should be implemented first.

Benefit

With IBM Rational RequisitePro, defining 

attributes like priority, difficulty and cost, and 

having the ability to sort and filter requirements 

based on these attribute values, helps enable 

project managers to objectively identify the 

highest-value requirements.



☺
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Key benefits

7	Requirements audit trail

Pain

It is impossible to tell who created or modified 

a requirement and why.

Benefit

Rational RequisitePro is designed to automati-

cally keep track of all changes to requirements, 

including who made the change, when and 

why it was made, and what the change was. 

It is often important for scoping purposes 

to understand why specific features are 

included and how the decision was reached. 

Requirements revision histories can record 

the rationale behind project decisions so that 

valuable time isn’t wasted revisiting the same 

issues over again.



☺

8	Central repository for all requirement 
assets

Pain

Requirements are updated with no ver-

sion history; requirements documents are 

e-mailed around, and team members are 

unsure which version is the latest; or team 

members work with different versions of  

the requirements.

Benefit

Rational RequisitePro stores requirement 

information in a database that acts as a central 

repository to all team members. The information 

in the repository can be linked to documents to 

allow quick access to the most current version 

of a document.



☺
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Key benefits of IBM Rational RequisitePro software

9	Controlled access to requirements  
information

Pain

Requirements are modified by unauthorized 

team members, resulting in requirements  

that are no longer representative of cus-

tomers’ needs.

Benefit

The integrity of requirements can be assured 

because requirements can only be created 

and modified by those with permission privi-

leges. Security can be established at various 

levels, from groups of requirements to individual 

attributes and even specific attribute values.



☺

10	 Customizable requirement structure

Pain

Numerous requirements that are not logi-

cally organized cause confusion and limit 

their usefulness.

Benefit

User-defined requirement types help you 

organize requirements into various cate- 

gories, making the requirements easier to 

understand and report. Each requirement 

type has a unique set of attributes associ- 

ated with it (such as priority, status and risk) 

to weigh each requirement and facilitate 

scope management. Document types specify 

user-defined document templates to pro-

mote consistency across all documents. 

Your project structure should map to your 

own requirements management process.



☺

IBM Rational RequisitePro evaluators guide.IBM Rational RequisitePro evaluators guide.10 IBM Rational RequisitePro evaluators guide.



11	Requirements project templates

Pain

Setting up the requirements management tool 

to map to your requirements management 

process—in other words, creating a proj- 

ect structure (requirement types, attributes, 

document types, users, etc.)—can be time 

consuming and awkward.

Benefit

The out-of-the-box and user-defined project 

templates in Rational RequisitePro can help 

speed the creation of new projects, poten-

tially reducing project development time. 

You can also leverage reusable requirements 

assets between your projects by creating 

new project templates from existing Rational 

RequisitePro projects.



☺

With IBM Rational RequisitePro, you can:

Capture, track, manage and analyze different 

types of requirements.

Specify who is authorized to modify requirements, 

attributes and documents.

Understand the impact of changing requirements.

Support distributed team members via the Web.

Integrate with marketplace-leading lifecycle tools— 

including solutions for business modeling, defect 

and change tracking, visual modeling, automated 

testing, configuration management and process 

guidelines—that support the entire software 

development team as well as the software devel-

opment process.

•

•

•

•

•

Key benefits
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IBM Rational RequisitePro test drive
In this test drive, you’ll follow step-by-step instructions to create a new Rational  

RequisitePro project. Let’s get started!

The test drive assumes basic knowledge of the Microsoft Windows® operating system.

Menu selections, button clicks and other actions are represented with the  symbol.

Explanations and unique features are highlighted in call-out boxes.

Install IBM Rational RequisitePro software
Go to the IBM trials and beta site for Rational RequistePro (ibm.com/developerworks/downloads/r/

rrp/?S_TACT=105AGX14&S_CMP=DWNL). You will be guided through the registration download and 

installation process.

Once the software is installed, you  

are ready to start using the Rational  

RequisitePro application!

•

•

•
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Using IBM Rational RequisitePro software
For more information than what is provided in this 

simple test drive, visit the IBM developerWorks®: 

Rational network site (ibm.com/developerworks/ 

rational/products/requisitepro).

Follow these steps to begin using Rational  

RequisitePro:

1	Set up a new project.

Select Start > Programs > IBM Rational > 

Rational RequisitePro.

Rational RequisitePro starts with the Let’s Go 

Rational RequisitePro window, which provides 

access to help and guidance on various topics 

about requirements management and Rational 

RequisitePro.

Click the Go! button and browse the 

information available. Note that the Let’s 

Go Rational RequisitePro window links to 

online Rational RequisitePro resources. 

When you are ready to proceed, close the 

window. You can display this window at any 

time using the Rational RequisitePro Help > 

Let’s Go Rational RequisitePro menu.

Select File > New > Project.

Every Rational RequisitePro project is  

created from a project template. Several 

project templates are provided, or, using  

the Make New Template option, you can 

create your own template from existing 

Rational RequisitePro projects.







Click the Use-Case Template icon. Click  

the OK button.

Notice the database options available  

and enter “Test drive” as the project name. 

Click OK.

When asked if you want to create a new 

directory for the project, click Yes.

When the project is successfully created, 

click Close in the confirmation dialog.

Without any special setup, you can start 

capturing your requirements in Rational  

RequisitePro. New projects can automatically 

create a Microsoft Access database to store 

requirements. You can later migrate the data-

base to the DB2 platform, an Oracle database 

or a Microsoft SQL Server database using a 

migration wizard provided by IBM.









Key benefit

Rational RequisitePro project 

templates simplify and 

jump-start the project setup 

process. Out-of-the-box proj-

ect templates include those 

for a use-case methodology, 

traditional methodology or 

hybrid methodology. Use 

cases are a user-oriented 

way of defining require-

ments that have been found 

to be easy to understand 

by customers, users and 

the development team. In 

addition to the predefined 

templates, new templates 

can be easily set up and 

customized to the needs of 

your organization.

Test drive
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Using IBM Rational RequisitePro software

You’re now ready to enter new requirements.

If your user name is not identified in the project, 

the Project Logon dialog is displayed to identify 

you as a user. Select the “Unknown” username 

and replace it with “Alex.”

Once the project is open, right-click the name 

of your new project (next to the pyramid in the 

requirements explorer on the left side of the 

screen), and choose Properties. This will show 

the structure of the project you just created.

Explore the various tabs on the Project Properties 

dialog box. Of particular interest are the Document 

Types, Requirement Types and Attributes tabs.

Click the Help button to learn more about proj-

ect properties. Users with appropriate privileges 

have the ability to customize all of these items to 

meet the needs of the project.

Click Cancel when you’re finished browsing the 

Project Properties dialog box.

From the menu, select File > Close Project. Click 

Yes when asked to confirm.











2	Open an existing project.

You have just seen how easy it is to set up a 

new project. Next, you will open an existing 

project already populated with requirements.

Pull down the File menu and choose  

Open Project.

In the Open Project dialog box, select the  

Learning Project – Use Cases project.

The Project Logon dialog may display the 

name you entered previously. Click OK.

This test drive uses the Learning Project – Use 

Cases project, which includes product features, 

use cases (to document functional software 

requirements) and supplementary requirements 

(to document nonfunctional software require-

ments, such as performance, reliability, etc.).

Once the project is open, the Requirements 

Explorer, on the left, displays all requirement 

assets (documents, requirements, views) and 

allows you to navigate through the project.







Key benefit

Customization of Rational 

RequisitePro projects  

allows you to create proj-

ects that best map to 

your specific requirement 

management process— 

from document templates 

and requirement attributes 

to requirement types and 

requirement categories.
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3	Create a new requirement.

Expand the package (folder) called Features 

and Vision. Rational RequisitePro packages 

can help you organize requirements infor-

mation to provide quick access to your 

users. A package can contain require-

ments documents, views (queries) and 

individual requirements.

Double-click Vision Document to open the 

document in the Microsoft Word application. 

Click Yes if a dialog is displayed. Notice the 

RequisitePro menu and toolbar now avail-

able in the Microsoft Word application (if the 

toolbar is not automatically displayed, select 

View > Toolbars > Rational RequisitePro). 

Depending on your preference, you may want 

to dock the floating Rational RequisitePro 

toolbar to the main toolbar.





Rational RequisitePro is designed to seamlessly 

integrate into the Microsoft Word application, 

the most popular environment to document 

requirements. Rational RequisitePro also ships 

with the industry-proven Rational Unified  

Process requirement templates, such as a 

Vision document, to record the project-stated 

problem definition and high-level features of 

the proposed solution to a problem.

In the Vision document, scroll down to sec-

tion 4, labeled Product Features. Features 

are statements of capabilities of the system 

often used for marketing and product posi-

tioning purposes, as a shorthand for a set  

of behaviors of the system.



Test drive
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Using IBM Rational RequisitePro software

Colored text indicates information you want to 

track—the requirements—differentiating that text 

from the contextual information around it. These 

marked requirements are stored in the database.

Position your cursor anywhere in the colored text, 

right-click and select Requirement Properties. 

From the Word application, you can see that the 

Requirement Properties dialog displays infor-

mation stored in the database. Click Cancel to 

dismiss the dialog.

Position your cursor at the end of the 4.2.  

ClassicsCD.com Administration System  

section (after FEAT14) and enter the fol- 

lowing text: “Ability to alert customers about  

new offerings.”

With your mouse, select your new text.

Right-click on your selection and select  

New Requirement…. Alternatively, you  

can click the New Requirement icon on  

the Rational RequisitePro toolbar, or pull  

down the RequisitePro menu and click  

Requirement > New.









The Requirement Properties: FEATpending1 

dialog box appears. Notice the selected text 

listed as the requirement text property.

Enter “New offerings” in the name field.

Click the Attributes tab. Pull down the list 

box for the type attribute and choose  

Functional. Then set the priority attribute  

to Must.

Click OK to accept the changes you’ve made 

in the Requirement Properties dialog box. The 

selected text is now colored with the FEAT 

color and prefixed with a FEATpending1 tag.

Click on the Save Requirements Document 

icon in the Rational RequisitePro toolbar or 

pull down the RequisitePro menu and select 

Document > Save. The new requirement is 

permanently tagged (FEAT16) and stored in 

the database.

From the RequisitePro menu, select  

Document > Close.

Upon requirement creation, Rational 

RequisitePro automatically assigns per- 

manent requirement numbers (numbered  

in the order of requirement creation).

You have just created a new product feature of 

high priority. Rational RequisitePro automati-

cally stores that information in the database 

upon saving your document.











Key benefit

Integration between Rational 

RequisitePro and Microsoft 

Word software helps enable 

members of your team to 

work in a familiar environ-

ment, making it easy to 

adopt requirements. Docu-

ments are a natural way to 

communicate requirements 

but, because they are not as 

good for querying and sort-

ing, Rational RequisitePro 

supplements Microsoft Word 

documents with a database 

linked to the documents.
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Test drive

4	Navigate and organize requirements.

In the Microsoft Word application, from the 

Rational RequisitePro toolbar, click the icon, 

or pull down the RequisitePro menu and 

select Show RequisitePro Explorer.

In the Features and Vision folder, notice 

the new requirement (FEAT16) is selected. 

Double-click it. Even though the Word docu-

ment is closed, this action takes you directly 

to the location in the Vision document where 

you created the requirement.

Go back to the Rational RequisitePro Explorer 

(by clicking the icon).

At the top of the explorer, right-click the 

Learning Project – Use Cases project; 

choose New > Package.

In the Package Properties dialog box, type 

“My new package” in the name field and  

click OK. Your new package is added to  

the explorer.











Key benefit

The unique dynamic link 

between a database of 

requirements and Word 

documents provides quick 

access to the contextual 

information (in Word docu-

ments) about requirements, 

while still providing the pow-

erful analytical capabilities 

of a database.

With Rational RequisitePro, 

you can have the freedom to 

organize requirements (and 

documents and views) how 

you like. User-definable pack-

ages help provide an easy 

and flexible way of organizing 

your requirement artifacts. 

This flexibility can help users 

quickly access the require-

ments that most interest them, 

which helps team members 

work more efficiently.
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Using IBM Rational RequisitePro software

5	Create a new requirement without  
a document.

With “My new package” highlighted, right-

click and select New > Requirement.  

The Requirement Properties: pending 

dialog box appears.

Select FEAT: feature in the type field.

Type “My new requirement” in the  

name field.

Type “The text of my new requirement”  

in the text field.

Click the Attributes tab and set the type to 

functional and the difficulty to low.

Click OK.

Notice your new requirement (FEAT17) is added 

to the My new package you created above.

In the Features and Vision package,  

double-click the All Features view.















Rational RequisitePro views display results of 

database queries. This particular view displays 

all product features currently stored in the 

Rational RequisitePro project.

For a better view, drag the divider line 

between the explorer and the view. Scroll 

to the bottom of the view. The two require-

ments you created earlier (FEAT16 and 

FEAT17) appear at the bottom of the view.

Right-click on the row displaying FEAT17 

and choose Select in Explorer.

From the requirements explorer, drag FEAT17 

onto the Features and Vision package icon.

You have just created a new requirement 

that does not have Word document context. 

FEAT17 is only stored in the database. Cus-

tomers who prefer not to work in the Microsoft 

Word application have the option of entering 

requirements directly into the database, and 

generating requirements reports by exporting 

views to the Microsoft Word application.







Key benefit

Being able to work directly 

in a Microsoft Word docu-

ment or in the Rational 

RequisitePro database 

views can add flexibility, 

allowing team members to 

work in an environment in 

which they are comfortable. 

This potentially encourages 

greater tool usage and 

greater efficiency.
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Test drive

6	View requirements history.

Pull down the Edit menu and select Find.

Enter “Response” as the text and click Find 

Next. The requirement SUPP7: Response 

Time is located in the explorer.

Click Close in the Find dialog.

Right-click on the SUPP7 requirement  

and select Properties.

Click the Revision tab. Information about  

the last change made to that requirement  

is displayed.

Click the History button.













The Revision History dialog box appears. 

You can see the history of each version of 

the requirement, including who made the 

change and when it was made. As you click 

each version line, the Change description and 

Requirement text fields update with the infor-

mation pertinent to that requirement version.

Click Close on the Revision History dialog 

box. Click OK on the Requirement Properties 

dialog box.

Requirement history helps provide visibility into 

the evolution of each requirement and can indi-

cate how stable each requirement is.

Key benefit

Having access to the audit 

trail of each requirement 

provides a sense of how 

often requirements change, 

and it can help minimize 

unnecessary changes. 

Recording the who, when, 

what and why of every 

requirement change can 

facilitate understanding of 

the project evolution.




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Using IBM Rational RequisitePro software

7	View requirements priority by sorting and 
querying.

The All Features view should be active in the 

right-hand pane, and it should be displaying 

all the product features and their correspond-

ing attributes.

Right-click twice in the priority cell of any 

visible requirement. A drop-down list appears 

and allows you to choose a new value for pri-

ority. Change the priority value and click away 

to commit that change to the database.

Right-click the heading of the priority column 

and choose Sort Descending. The list of 

feature requirements will be reordered in 

descending order of priority.

Next you will create a view to more finely tune 

the prioritization filter.

Right-click the Features and Vision package 

in the explorer and choose New > View. The 

View Properties dialog box appears.

Enter “Must have features” in the name field.

Leave the Attribute Matrix view type default.

Select FEAT:feature for the row requirement 

type field.

Click the Query… button.















In the Select Attribute dialog box, select 

Priority and then click OK. The Query 

Requirements dialog box appears.

In the Select to Display zone, click None. 

Choose Must in the list, and click OK.

The query you created is displayed in the 

Query Row Requirements dialog box. Click 

the Add button and choose Difficulty in the 

Select Attribute dialog box; click OK. Next, 

click the None button and then choose Low 

from the list. Click OK.

The Query Row Requirements dialog box 

now displays both queries. Click OK. In the 

View Properties dialog box, click OK. Product 

features matching the query criteria are dis-

played in the view area.

Right-click on the Must have features view  

in the explorer and select Save View to 

reapply this query later.

You have now created a query that finds all 

product features that have a must priority 

and a low difficulty. As new requirements are 

created in Rational RequisitePro, this view is 

designed to display the set of requirements 

that matches these criteria.











Key benefit

The intuitive sorting and 

querying interface can 

make it easy to show which 

requirements are most 

important. Prioritization of 

requirements helps ensure 

that the most important 

things get built first. Views 

can be saved so that the 

query is available and easy 

to run. Being able to 

determine which require-

ments make more business 

sense to implement for 

each release can ultimately 

lead to improved customer 

satisfaction.
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Test drive

8	View requirements coverage.

Coverage refers to the idea that each high-

level requirement should have lower-level 

requirements associated with it in order to 

help ensure that developers actually build  

all agreed-upon high-level functionality.

Right-click My new package and choose 

New > View….

The View Properties dialog box appears. In 

the name field, type “Features to use cases.”

For view type, select Traceability Matrix. For 

row requirement type, select FEAT: Feature. 

For column requirement type, select UC: 

Use Case. Click OK.







The new view is added to the explorer and 

displayed on the right.

For a better view, drag the divider line 

between the explorer and the view.

From the menu, select View > Collapse 

All and drag the use-case column header 

divider lines between the use-case require-

ments to increase the column widths.

Right-click on the explorer view and select 

Save View.






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Using IBM Rational RequisitePro software

Traceability links are shown as blue arrows, 

which indicate relationships between product 

features and use cases and show that a use 

case is fulfilling a specific product feature.

From the Rational RequisitePro toolbar, click 

the Query Row Requirements icon.

In the Select Attribute dialog, scroll down and 

select Trace-from. Click OK.

Select UC: Use Case and the Not Traced 

radio button. Click OK.

Click Add… and select Status. Click OK. 

Now click None. Select Incorporated and 

click OK twice.

In the view, drag row and column dividers 

for better viewing.

From the menu, select File > Save View As… 

and enter “Features not traced to use cases.” 

Click OK.













The resulting view only shows product features 

that are not linked to use cases, which helps 

provide a sense of how much work is left to do 

on the project, as features incorporated in a 

release should be elaborated in use cases to 

actually be implemented in the software being 

developed. You just saw how to filter a trace-

ability matrix, but notice that a similar view was 

already provided in the Coverage Analysis pack-

age, included in the provided project templates.

Key benefit

Coverage analysis helps 

ensure that nothing inad-

vertently gets left out of a 

release. The intuitive query-

ing mechanism in Rational 

RequisitePro helps you 

create requirement cover-

age reports. And saved 

views can help speed 

access to those reports.
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9	See the impact of changing requirements.

You will modify a requirement and see what 

impact the change has on other requirements.

Under My new package, double-click the 

Features to use cases view. Notice the blue 

traceability link between FEAT4 and UC2.

Right-click FEAT4: Ability to check status… 

in the row and select Properties….

Click the General tab.

Change the text to “Ability to check the status 

of customer-specific orders.” Click OK.

Notice the requirement text is immediately 

updated in the Vision document where this 

feature is displayed, and a red line is now 

slashing the traceability link between FEAT4 

and UC2. This red line indicates a suspect link 

and is a warning that the change in the feature 

could affect the requirement specified in the 

use case. This same behavior occurs when 

you open the Word document to change the 

requirement text.

Expand the Impact Analysis package in the 

explorer and double-click the Use Cases 

Impacted by Feature Changes view, which 

stores the query you created manually in the 

above steps.

Project templates from which new projects are 

created include impact analysis views to help 

eliminate the need to re-create new templates 

in each project.

To speed access to suspect links, Rational 

RequisitePro provides predefined impact 

analysis views.

Key benefit

Rational RequisitePro lets 

users modify the text of 

requirements identified in 

Word documents without 

requiring users to open 

the document. Next time 

the document is opened, 

changes made directly in 

the views are reflected in 

the document.

Test drive









Suspect links in Rational 

RequisitePro are your 

notification that some 

requirements may need 

to be updated because 

other requirements have 

changed. Understanding 

the impact of a change 

can mean the difference 

between the project being 

delivered on time or late. 

This type of analysis is very 

difficult without the ability to 

do sophisticated queries.


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Congratulations!  
You have completed the Rational RequisitePro test drive.  
Feel free to browse the product further or close the application.
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Web interface

IBM Rational RequisitePro Web interface
Rational RequisitePro provides two interfaces: the 

standard Windows GUI you used in the test drive 

and the Web-based interface. The Web interface 

is the tool of choice for teams doing geographi-

cally distributed development.

Through your Web browser, and without installing 

any client software, you can use the Web interface 

to create, modify, query and sort requirements. 

You may also create new documents, view existing 

documents, modify traceability relationships and 

attributes, query and sort requirements, and create 

and save views. If you have access to the Microsoft 

Word application, you can also take documents 

offline to edit them and bring them back online so 

that others can view your changes. In addition, you 

can perform Rational RequisitePro project adminis-

tration via the Web.

The Web interface is included with every floating 

license of Rational RequisitePro. Because it requires 

setting up a Web server, which may be more than 

you are ready to do right now, IBM provides a self- 

running demo (ibm.com/software/awdtools/

resources/reqpro.html?S_CMP=rnav) for you to 

experience the Rational RequisitePro Web capability.

The Web interface allows distributed teams to 

stay in sync. Direct Web access helps ensure 

that remote users are seeing the most up-to-date 

requirements—which helps ensure that code is 

never written to an out-of-date specification.

Key benefit

Using any standard Web 

browser, the Rational 

RequisitePro Web tool 

provides all the user 

functionality available in 

Rational RequisitePro, 

without requiring the instal-

lation of any client software 

(the Microsoft Word appli-

cation is required to edit 

documents), and using an 

interface that’s similar to 

the Rational RequisitePro 

interface.
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Conclusion
We hope this test drive has given you a sense 

of the benefits the Rational RequisitePro and Web 

interface tools can bring to your team. Additional 

features not included in this test drive include:

Managing requirement changes by:

–	 Accessing requirements that are common  

to multiple projects through links to exter- 

nal projects.

–	 Creating and comparing baselines, and  

creating new projects from baselines.

Using e-mail notification for requirement changes.

Setting project security. To do so, go to File > 

Project Administration > Security…. Click the 

Help button in the Project Security window.

Extending functionality with scripting through  

a Component Object Model (COM)-based 

extensibility interface. Scripts are available  

through the IBM developerWorks: Rational site  

(ibm.com/developerworks/rational/library/ 

2070.html?S_TACT=105AGX15&S_CMP=LP).

Mapping your Rational RequisitePro project 

structure to your requirements management 

process by adding new document types, 

requirement types and attributes.

•

•

•

•

•

Importing requirements using File > Import. The 

import wizard can provide a quick way to import 

existing requirements either from an existing 

Microsoft Word document or from a comma 

separated value (CSV) file. Most customers 

adopt Rational RequisitePro in the midst of their 

projects; the import facility provides a way to 

help migrate requirements information to the 

Rational RequisitePro application.

Engaging in discussions about the project or 

requirements, to help ensure that all decisions 

are documented in one place as historical data 

and that the number of times you revisit issues  

is minimized.

Integrating with Rational Software Architect, 

Rational Software Modeler, Rational TestManager, 

Rational SoDA, Rational Unified Process, Rational 

ClearQuest, WebSphere Modeler, WebSphere  

Integration Developer and Rational Data Architect 

software. These integrations are key to keeping 

a software development team in sync (by pro-

viding access to requirements from other IBM 

Rational tools).

•

•

•
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Rational RequisitePro can provide a centralized, 

secure, reliable environment for capturing, storing, 

organizing, tracking and analyzing requirements. 

It is designed to capture user and customer needs 

and track changes as they evolve to help ensure 

that when you deliver your software, it meets 

users’ expectations. With Rational RequisitePro, 

managers can have instant insight into the status 

of specific requirements, as well as the ability to 

view overall project status and analyze trends—

critical information for planning, allocating and 

prioritizing resources.

The unique architecture of Rational RequisitePro—

namely, the product’s ability to link live requirements 

documents to a database—makes it an attractive 

offering to any team currently using the Microsoft 

Word application to document requirements.

For more information

To learn more about IBM Rational RequisitePro 

software and its Web interface, contact your IBM 

sales representative or visit:

ibm.com/software/awdtools/reqpro
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