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Introduction

This Rational ProjectConsole tutorial has a modular design so that you can complete sections or skip sections, based on the development tools your team uses and how you plan to use Rational ProjectConsole.  This section is intended for Rational ProjectConsole administrators who want to learn how to create metrics displays and publish them for viewing on the Rational ProjectConsole Web site.
In this section, you’ll perform the following tasks:

1. Create a panel and add trend chart to it.

2. Publish your panel.

3. Set up security for viewing the charts on the Rational ProjectConsole Web site.

4. Manually run the publish task.

5. View the chart.

6. Create a Rational ProjectConsole Template Builder template to display your charts in a Web page report.

7. Create a new report node in the Rational ProjectConsole navigation tree and associate it with your Template Builder template.
PC setup

This tutorial uses data from a ClearQuest collection.  You can use the sample warehouse data for this tutorial. To complete the exercises in this section, you must have Rational ProjectConsole installed and configured for the sample Web site.

Note  The directory reference InstallDir is used throughout the document. It refers to the installation path for Rational ProjectConsole (C:\Program Files\Rational\Rational ProjectConsole is the default installation path).

Part 1 –  Creating a metrics panel

In this exercise, you will create a metrics panel that you can use to view ClearQuest defect data for the ClassicsCD.com sample project. You will add a distribution chart and a code churn trend chart to the panel to display the metrics graphically.

	
	Use Case Steps
	Details
	Display

	5.1.1 
	Start your Web browser and log in to the Rational ProjectConsole Web site.  

Note You can log in to the Web site from the Rational ProjectConsole Web server or from a client.
	Start your Web browser, and then type the following URL:

http://server_machine/ProjectConsole
where server_machine is the name of your Rational ProjectConsole Web server.
	

	5.1.2 
	
	In the User ID box, type “admin.”

In the Password box, type “changeit.”
Click Log In.
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	5.1.3 
	
	The start page for the sample project ClassicsCD.com is displayed in the right frame.

The left frame displays the Rational ProjectConsole navigation tree.
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	5.1.4 
	Start the Rational ProjectConsole Dashboard.
	On the Rational ProjectConsole Operations toolbar, click Dashboard.
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	5.1.5 
	
	The Dashboard starts in a new browser window.
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	5.1.6 
	Create new metrics panel.


	In the Dashboard navigation tree:

· Expand ClassicsCD.com Projects.

· Expand Point of Sale (POS).

· Expand Functional Teams.

· Click Management.

· Right-click Management, and click New Metrics Panel.
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	5.1.7 
	
	A new metrics panel is in the right frame.

In the navigation tree, right-click the new panel node, and click Rename.

In the active text box select the default panel label, type “Weekly Report,” and then press enter.
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	5.1.8 
	Create a distribution chart that shows the number of outstanding defects as a function of severity. 

Distribution charts show a breakdown of measures based on an attribute at a given point in time. Trend charts show measures across time.  
	In the navigation tree, click Weekly Report.

On the Dashboard toolbar, click Insert Chart. 
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	5.1.9 
	Change the chart name and relabel the x and y axes.
	In the Chart Type list, select Distribution.

In the Y-Axis list, select Num Change Requests.  

In the X-Axis list, select Severity.

Under Current Selection, click Filters.
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	5.1.10 
	Create a filter for measures displayed in the chart.
For this distribution chart, you’ll set up a filter so the chart displays data only for the Classics Point of Sale project.
	In the Select Field list, double-click project.

The Define Filters table now displays project as a filter field.

To the right of the table, click Values.
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	5.1.11 
	
	In the list of values, select ClassicsPOS.

Click OK.
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	5.1.12 
	
	The Define Filters table displays ClassicsPOS as the value for the project filter field.
Click OK.
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	5.1.13 
	
	Click the Labels tab.
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	5.1.14 
	Change the chart name and relabel the x and y axes.
	In the Chart Properties window, click the Labels tab.

In the Title box, select the default text, and then type “Defects by Severity.”

In the X-Axis box, select the default text, and then type “Severity.”

In the Y-Axis box, select the default text, and then type “# Defects.”

Click the Format tab.
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	5.1.15 
	
	In the Display Type list, select Bar Chart.

Click OK.
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	5.1.16 
	You now have a chart that displays the distribution of all defects by severity.
	In the right frame of the Dashboard, your Weekly Report metrics panel contains the new Defects by Severity distribution chart. 

To enlarge the chart, in the lower right corner of the chart, drag the crosshairs down and to the right.
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	5.1.17 
	Create a second chart in your new metrics panel to display code churn measures collected from ClearCase.

A code churn chart provides an indication of project progress and quality.  Ideally, the chart will show code churn decreasing over time, which suggests the software is stabilizing.
	In the navigation tree, click Weekly Report.  
On the Dashboard toolbar, click Insert Chart.  
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	5.1.18 
	
	In the Chart Type list, leave Trend selected.

Under Available Fields, do the following:

In the Y-Axis list, scroll to and select the following:

· linesChanged

· linesDeleted
· linesInserted
In the X-Axis list, scroll to and select opdate.  

Opdate is the date on which a ClearCase operation, such as a file check-in or check-out, was performed.

Click the Labels tab.
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	5.1.19 
	Change the chart name to “Code Churn” and relabel the axes.
	In the Title box, select the default text, and then type “Code Churn.”

In the X-Axis box, select the default text, and then type “Date.”

In the Y-Axis box, select the default text, and then type “SLOC.” (SLOC represents source lines of code.)

Click OK.
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	5.1.20 
	You now have a second chart displaying code churn. 

Move the chart to the right of the Defects by Severity chart.
	After a short wait, the Weekly Report metrics panel shows the new Code Churn chart.

Using the title bar, drag the Code Churn chart to the right of the Defects by Severity chart. (See graphic for placement.)
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	5.1.21 
	Save your Weekly Report panel.
	On the Dashboard File menu, click Save or, on the Dashboard toolbar, click Save.
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	5.1.22 
	
	The Weekly Report panel closes.
	


Publishing a panel
In this exercise, you will publish the Weekly Report metrics panel you created in the Part 1 so that your team members can see it on the main Rational ProjectConsole Web site.

	
	Use case steps
	Details
	Display

	5.1.23 
	In the Dashboard navigation tree, select the view to publish.

When you choose to publish a panel on schedule, you’re creating a scheduled publish task.  After you set up the task, you’ll see it listed in the Designer navigation tree under Scheduled Tasks. 

Note  To modify the properties of a publish task, you must use the Designer.
By default, the publisher creates a PNG file for each chart in the panel.  If you want to, you can publish a single chart.
	In the Dashboard navigation tree, under Management, click Weekly Report.

After the panel is displayed in the right frame, on the Dashboard View menu, click Publish on Schedule.
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	5.1.24 
	The directory in which a panel exists in the Dashboard determines where the charts are published on the main Rational ProjectConsole Web site.  The Dashboard directory structure is duplicated in the Published Metrics directory.

	The Create Publish Schedule Task window is displayed. 

Under General Schedule Information, in the Perform this task list, select Weekly.
The Weekly Schedule Information group box becomes available.

Note  By default, the task does not run (the run time is set to 12AM on the current day, which is in the past).  To run the task, you must either set a schedule to run it later, or run it manually from the Designer.
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	5.1.25 
	Set a start date and time to publish the Weekly Report panel.
	Under General Schedule Information, next to Starting on, click the calendar button.
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	5.1.26 
	Set the publish time to 6:00AM.
	In the Hour list, select 06.
Click OK.
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	5.1.27 
	Select Monday as the day to run the publish task.

Rational ProjectConsole will publish the Weekly Report panel at 6 AM every Monday.
	Under Weekly Schedule Information, select the Monday check box.  

Click OK.
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In the next exercise, you will specify security settings for the new charts.
Part 2 –  Setting security for published charts

As a Rational ProjectConsole administrator, you can authorize the users and groups to view your published charts.  In this exercise, you will specify the security settings for the charts in your metrics panel.

	
	Use case steps
	Details
	Display

	5.2.1 
	Open the properties window for the Weekly Report panel.
	In the Dashboard navigation tree, under Management, click Weekly Report.
Right-click Weekly Report, and click Properties.
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	5.2.2 
	
	You can use the Description box to type a description of the panel and its contents. This is optional.

Click the Security tab.
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	5.2.3 
	Use the Security tab to add users and groups who are authorized to view the Weekly Report metrics panel.
	On the Security tab, click Add.
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	5.2.4 
	Any group authorized to access a metrics panel and the metrics displays it contains, has read-only access to the selected panel and displays.

An individual authorized to access the selected panel, can also cut and paste elements in the area of the Dashboard navigation tree to which he or she has access.
	In the Groups list, select Developers.

In the Users list, select user.

Click Add.

Click OK.
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	5.2.5 
	After you complete this step, four groups – Administrator, Developers, and Overseers  – and one individual (user) will have access to the published charts on the main Rational ProjectConsole Web site.
	The Authorized Users and Groups list now includes Developer and user.

Click OK.
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	5.2.6 
	Close the panel window and the close the Dashboard.
	In the right frame, close the Weekly Report panel.

On your browser File menu, click Close.
	


Next, you will run the publish task manually from the Rational ProjectConsole Designer.  



Part 3 –  Running a publish task

In this exercise, you will use the Rational ProjectConsole Designer to run the publishing task that you set up.

	
	Use Case Steps
	Details
	Display

	5.3.1 
	Start the Rational ProjectConsole Designer.
	On the main Rational ProjectConsole Web site, on the Operations toolbar, click Designer.
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	5.3.2 
	
	The Designer starts in a new browser window.
	[image: image35.png]e





	5.3.3 
	Select and publish the task that you created.
	In the Designer navigation tree, expand Scheduled Tasks, and then click publish_dashboardsystem_Weekly Report.

The publish_dashboardsystem_Weekly Report [Task] window is displayed in the right frame.
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	5.3.4 
	Run the publish task.
	Click Task > Run.
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	5.3.5 
	Acknowledge the task run start.
	The Task Scheduler message window is displayed to let you know that the task run has started.

Click OK.
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	5.3.6 
	Open the Scheduled Task Logs table.
	In the right frame, close the task window.

At the bottom of the Designer navigation tree, click Scheduled Task Logs.

The Scheduled Task Logs window is in the right frame.

Information about the publish_dashboardsystem_Weekly Report task run is displayed in the first row of the table.
Double-click this first row.
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	5.3.7 
	
	The publish_dashboardsystem_Weekly Report_<start date and time> [Task Log] window is in the right frame.

As long as the task is running, the Status box displays the “ACTIVE” value.  After the task run is complete, it displays “SUCCESS” or “ERROR.”
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	5.3.8 
	After the run is complete, close the Designer.
	After the Status box displays “SUCCESS,” the task run is completed. 

Close the task log window.
On your browser File menu, click Close.
	


Part 4 –   Viewing published charts from the main Rational ProjectConsole Web Site
In this exercise, you will view the metrics panel you published in the last exercise.

	
	Use case steps
	Details
	Display

	5.4.1 
	Now you will view your charts on the Rational ProjectConsole Web site.

By default, the publisher creates a portable network graphics (PNG) file for each chart in a panel. 
Rational ProjectConsole includes templates and navigation tree nodes to view these charts under the All Published Measures node, in the Rational ProjectConsole, ClassicsCD.com Projects, Point of Sale (POS), Functional Teams, Management, Release 1.0, Sensitive Information, Measurement Reports directory.
	Return to the main Rational ProjectConsole Web site.

In the navigation tree expand the following nodes:

· ClassicsCD.com Projects

· Point of Sale (POS)

· Functional Teams

· Management.

· Release 1.0

· Sensitive Information

· Measurement Reports

Under Measurement Reports, click All Published Measures.
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	5.4.2 
	Use the link on the Metrics Directory page link to metrics folders for the functional teams.
	The Metrics Directory page for the Point of Sale project is in the right frame. 
On this page, click the Functional Teams link. 
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	5.4.3 
	
	On this page, click the Management link.
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	5.4.4 
	
	Your Code Churn and Defects by Severity charts are listed under Charts.

On this page, click the Defects by Severity link.
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	5.4.5 
	
	The Defects by Severity distribution chart is in the right frame.
After reviewing the chart, click the Home button on the Rational ProjectConsole Operations toolbar.
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	5.4.6 
	You can also use the navigation tree to view the subdirectories and charts under All Published Measures.

Use the navigation tree to display the Code Churn chart.
	In the navigation tree: 

· Expand All Published Measures.

· Expand Functional Teams.

· Expand Management.

Under Management, click Code Churn.
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	5.4.7 
	
	The Code Churn trend chart you created in Part 1 is in the right pane.
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Creating a new template

Rational ProjectConsole creates separate PNG files for your distribution and trend charts.  In this exercise, you will use Rational ProjectConsole Template Builder to create a template that displays both charts in a single document. (You can also use the Dashboard to publish the charts in a single PDF file.)

	
	Use case steps
	Details
	Display

	5.4.8 
	Start Rational ProjectConsole Template Builder.
	Click Start > Programs > Rational Software > ProjectConsole Template Builder.

Microsoft Word starts, with the Rational ProjectConsole menu in the menu bar and a new document opens.
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	5.4.9 
	Show paragraph marks in the document.
	If you cann0t see the paragraph formatting mark at the top of the document, you must make them visible.

To view the paragraph marks ( ¶ ) in the document:

· If you are using Word 2000, on the toolbar, click Show/Hide (¶), or use CTRL+*.

· If you are using Word 2002, click Rational ProjectConsole > Show/Hide Commands.
	

	5.4.10 
	Start the Template View.
	Insert a couple of returns in the document. 

Click Rational ProjectConsole > Template View.
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	5.4.11 
	
	The Template View window is displayed.
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	5.4.12 
	Add a command to open the Defects by Severity PNG file.
	On the Template View toolbar, click OPEN.
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	5.4.13 
	Browse to the PublishedViews directory.
	Under Select Class to OPEN, expand FileSystem, and then click File.

Under Arguments, next to FileName, click Browse.
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	5.4.14 
	Locate and select the Defects by State.png file. 

Note When Rational ProjectConsole charts are published, they are published to a folder under the InstallDir\webfiles folder.  
An alias is created  on the Rational ProjectConsole Web site so that the published charts can be accessed using a URL beginning with http:// server_machine/ProjectConsole/PublishedViews/...
Replace server_machine with the name of your Rational ProjectConsole Web server.
	Browse to and open the following directory:

InstallDir\webfiles\PublishedViews\Dashboard\ClassicsCD.com Projects\Point of Sale(POS)\Functional Teams\Management
In the Name column, click Defects by Severity.png.

Click Open.
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	5.4.15 
	
	In the OPEN Command window, Arguments displays the path to the Defects by Severity.png file.

Click OK.
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	5.4.16 
	
	The Template View displays the OPEN command in the left frame.
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	5.4.17 
	Add a DISPLAY command to display the graphic.
	To display the chart in the document, you must add the DISPLAY Graphic command.

In the Select values from FileSystem_File list, click D Graphic. 

Note  The “D” indicates that this is a DISPLAY command.
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	5.4.18 
	Add a command to display the full name.
	In the Select values from FileSystem_File list, click D FullName.
Note  As you select commands in the right pane, the left pane is updated to reflect each added command.  The left pane lists all of the Template Builder commands in hierarchical order (with no textual information).
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	5.4.19 
	Repeat the previous steps, starting with the OPEN command to add the Code Churn chart.

Close the Template View.
	Repeat steps 5.6.5 through 5.6.11 for the Code Churn.png file.

Close the Template View window.
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	5.4.20 
	Add a heading to the Weekly Progress Report document.
	Click your cursor in the first line of the document.

On the Word formatting toolbar, in the Style list, select Heading 1.

Type “Weekly Progress Report.”
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	5.4.21 
	Save the Word template document (.doc file) in the templates folder in the Rational ProjectConsole installation directory.
	Click File > Save As.
	

	5.4.22 
	
	In the File name box, type “Weekly Progress Report.”

Save the file to the following directory:

InstallDir\templates\Metrics
	

	5.4.23 
	Now that you saved the template, you must also save the HTML template page.
	Click ProjectConsole > Save Web Page.
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	5.4.24 
	Acknowledge the creation of the Web page.
	In the Microsoft Word window, click OK.
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	5.4.25 
	Quit Word.
	Click File > Exit.
	


Creating a new navigation tree node

To view the generated Web page you created in Part 6, you must create a node for it in the Rational ProjectConsole navigation tree. In this exercise, you will create this node and use it to display your Weekly Progress Report Web page.

	
	Use case steps
	Details
	Display

	5.4.26 
	Return to the Rational ProjectConsole main Web site.
	In the navigation tree, expand Point of Sale (POS) if it is not already expanded.
	

	5.4.27 
	Choose the location for a new report node in the navigation tree.
	In the navigation tree, right-click Project Information, and click Add.
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	5.4.28 
	Specify the properties of the new node and associate it with your Weekly Progress Report template.
	The Add Node form is in the right frame.

Under Node Type, click Report.

Under Properties:

· In the Label box, type “Weekly Progress Report.”

· Leave the User ID, Password, and Icon boxes empty.

· In the Template box, type “Metrics\Weekly Progress Report.”

· In the Artifact ID box, type “Metrics:root:*.”

Click Save.
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	5.4.29 
	
	The text “Action has been completed successfully” is in the right frame.
	

	5.4.30 
	
	In the navigation tree, the new Weekly Progress Report node is displayed under Project Information.
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	5.4.31 
	Use your new navigation tree node to view the Weekly Progress Report Web page.
	In the navigation tree, click Weekly Progress Report.

The Weekly Progress Report Web page is displayed in the right frame.  It shows both of the charts you created in the Dashboard.
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Conclusion

In this exercise, you learned how to create and publish charts, create a template to combine the charts in a single document, add a report node to the navigation tree on the Rational ProjectConsole Web site, and, finally use the new navigation tree node to view your charts.
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