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Introduction

This Rational ProjectConsole tutorial has a modular design so that you can complete or skip sections of the tutorial, depending on your role in your project and your interest in the various data sources.  This section shows you how to use Rational ProjectConsole Template Builder to display data from a Rational XDE model. 

Part 1 describes how to create the template for reporting on the Rational XDE model.

Part 2 describes how to add the commands that access a use case within a Rational XDE model and display the name of the use case.

Part 3 describes how to define the sections in the Use-Case Realization template.

Part 4 describes how to add the commands that display the brief description of a use case.

Part 5 describes how to add the commands that display the interaction instance diagrams of a use case. 

Part 6 describes how to add the commands that display the participating objects of a use case. 

Part 7 describes how to add the commands that display the class diagrams of a use case. 

Part 8 describes how to add bookmarks to mark sections in the Use-Case Realization template. 

Part 9 describes how to update the Table of Contents in the Use-Case Realization template. 

Part 10 describes how to test the template.

Directory References

The following directory references are used in this section:

· InstallDir refers to the installation path for Rational ProjectConsole (C:\Program Files\Rational\ProjectConsole is the default path).

· XDEModelsDir refers to the default location for saving Rational XDE models (C:\Documents and Settings\User\My Documents\XDE Workspace\Miscellaneous Models).

Creating a template for reporting on a Rational XDE model

Part 1 –  Creating a template for Rational XDE
In this first exercise, you will create the template that will be used to report on a Rational XDE model.

	
	Use case steps
	Details
	Display

	14.1.1 
	Start Rational ProjectConsole Template Builder (loaded as a Microsoft Word add-in).
	Click Start > Programs > Rational Software > Rational ProjectConsole Template Builder.


	

	14.1.2 
	Show paragraph marks in the document.
	If you cannot see the paragraph mark ( ¶ ) in the document area, on the Word Standard toolbar, click Show/Hide ¶.
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	14.1.3 
	Modify Tools > Options so that the template is saved as Unicode (UTF-8).
	Click Tools > Options. 

On the General tab, click Web Options.
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	14.1.4 
	
	Click the Encoding tab.

In the Save this document as list, select Unicode (UTF-8).

Click OK.

To close the Options window, click OK.
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	14.1.5 
	Create a folder to contain the Rational XDE templates.
	Click File > Save. 

In the Save In list, browse to InstallDir\templates.

If InstallDir\templates already contains a folder named XDE, go to step 14.1.8.
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	14.1.6 
	
	In the toolbar, click Create New Folder.
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	14.1.7 
	
	In the Name box, type “XDE.” 

Click OK.
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	14.1.8 
	Save the template in the Rational XDE folder.
	The Save in list now shows “XDE.”
In the File name box, type “RUP_UC_Realization_Tutorial.doc.” 

Click Save.
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Part 2 –  Accessing the Rational XDE Domain

In this exercise, you will add the commands to access a use case within a Rational XDE model and display the use case name.

	
	Use Case Steps
	Details
	Display

	14.2.1 
	Add an OPEN command to the template.
	Click ProjectConsole > Add Command.

Click OPEN Command, and then click OK.
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	14.2.2 
	Access a use case within a Rational XDE model.
	In the Select Class to OPEN list, expand the XDE folder, and then select UseCase.

Click OK.
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	14.2.3 
	Add a report title to the template.
	Position the insertion point after the [OPEN1] comment added in steps 14.2.1 and 14.2.2.

Type “Use–Case Realization Report:  ”, and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Page Titles.

Click Apply.
	[image: image11.png]DeEds SgRBEA - & B 2w

@ @ Fovorts + | o+ | 1| CiProgram

Ele Edt Vew Insert Format Tooks Table ProjectConsole Winc

. g ' f ' 2 ' 3

JE i Use-Case-Realization-Report:-
1





	14.2.4 
	Add a DISPLAY command to the template.
	Press the Right arrow key to position the insertion point after the Use-Case Realization Report:  text.

Click ProjectConsole > Add Command.

Click DISPLAY Command, and then click OK.
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	14.2.5 
	Display the name of the use case.
	In the Select Attribute to DISPLAY list, under XDE_UseCase, scroll down and click Name.

Click OK.
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	14.2.6 
	Apply a style to the text that displays the use case name.
	Position the insertion point immediately after the [DISPLAY2] comment, and then use the Shift and Right arrow keys to select the text “<XDE_UseCase.Name>.”

Click Format > Style.

In the Styles list, select PjC Page Titles.

Click Apply. 
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	14.2.7 
	Underline the title.
	Position the insertion point just before the [OPEN1] comment, and then click Format > Borders and Shading.

Click the Borders tab.
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	14.2.8 
	
	In the Width list, select 1/4 pt.

In the Preview diagram, click the bottom line.

Click OK.
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	14.2.9 
	The Rational XDE template should resemble the picture shown here on the right.
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Part 3 –  Defining sections in the Use-Case Realization Report 

In this exercise, you will define the issue number and the sections to include in the Use-Case Realization Report.

	
	Use Case Steps
	Details
	Display

	14.3.1 
	Add the issue number.
	Position the insertion point on the second line below the title.

Type “Issue <1.0>,” and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Labels.

Click Apply.
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	14.3.2 
	Add the Table of Contents label.
	Use the Right arrow key to position the insertion point just after the “Issue <1.0>” text.

Press the Enter key twice to insert a new line.

Type “Table of Contents,” and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Content Headings.

Click Apply.
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	14.3.3 
	Add the Use-Case Realization Report label.
	Use the Right arrow key to position the insertion point just after the text “Table of Contents.”

Press the Enter key twice to insert a new line. 

Type “Use-Case Realization Report:  .”
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	14.3.4 
	Add a DISPLAY command to the template.
	Click ProjectConsole > Add Command.

Click DISPLAY Command, and click OK.
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	14.3.5 
	Display the name of the use case.
	In the Select Attribute to DISPLAY list, under XDE_UseCase, scroll and click Name.

Click OK.
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	14.3.6 
	Apply a style to the text that displays the use case name.
	Position the insertion point immediately after the [DISPLAY4] comment, and use the Shift and Right arrow keys to select the text “<XDE_UseCase.Name>.”

Click Format > Style.

In the Styles list, select PjC Content Headings.

Click Apply.
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	14.3.7 
	Reposition the insertion point.
	Press the Down arrow key to position the insertion point below the text “<XDE_UseCase.Name>.”
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	14.3.8 
	Add a label.
	Press Enter to insert a blank line.

Type “Brief Description.”

Press Enter three times to insert two blank lines.
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	14.3.9 
	Add the remaining labels.
	Repeat step 14.3.8 to add the following labels:

· Interaction Instance Diagrams

· Participating Objects

· Class Diagrams
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	14.3.10 
	Apply a style to the last four labels you added.
	Position the insertion point immediately before the text “Brief Description,” and then use the Shift and Down arrow keys to select the remaining text in the document.

Click Format > Style.

In the Styles list, select PjC Labels.

Click Apply.

Press the Down arrow key to reposition the insertion point.
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Part 4 –  Adding the Brief Description

In this exercise, you will add a command to display the use case description.

	
	Use case steps
	Details
	Display

	14.4.1 
	Create a new Rational ProjectConsole template. 
	Start Microsoft Word.

Click File > New.

In the New window, on the General tab, click ProjectConsole.dot, and click OK.
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	14.4.2 
	Add a DISPLAY command to the template.
	Click ProjectConsole > Add Command.

Click DISPLAY Command, and click OK.
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	14.4.3 
	Display the description of the use case.
	In the Select Attribute to DISPLAY list, under XDE_UseCase, click Description.

Click OK.
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	14.4.4 
	Apply a style to the text for the use case description.
	Position the insertion point just after the [DISPLAY6] comment, and use the Shift and Right arrow keys to select the text “<XDE_UseCase.Description>.”

Click Format > Style.

In the Styles list, select PjC Copy 

Click Apply.
	[image: image31.png]Brief-DescriptionT

iption






	14.4.5 
	Add a LIMIT command to the template.
	Press the Right arrow key twice to position the cursor after the [ENDDISP7] comment.

Click ProjectConsole > Add Command.

Click LIMIT Command, and click OK.
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	14.4.6 
	Display text only if the use case description is blank.
	In the Name box, type “NoBriefDescription.”

In the And Where list, do the following:

· In the Left Operand column, click Click here to add, expand the Self node in the list, and click Description.

· In the Right Operand column, click Click here to add, click Literal, and press Enter.

Click OK.
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	14.4.7 
	Enter the text to display if the use case has no description.
	Make sure the insertion point is between the [LIMIT8] and [ENDLIM9] comments.

Type “None.”
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Part 5 –  Displaying Interaction Instance Diagrams

In this exercise, you will add commands to display the interaction instance diagrams for the use case.

	
	Use case steps
	Details
	Display

	14.5.1 
	Establish the point in the template at which to add the commands that display the interaction instance diagrams for the use case. 
	Position the insertion point at the beginning of the second blank line under the text “Interaction Instance Diagrams.”
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	14.5.2 
	Add a REPEAT command to the template.
	Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.5.3 
	Iterate through the collaboration instances within the use case.
	In the Select Objects to REPEAT list, under XDE_UseCase, scroll and click Collaborations.

In the Where Is A list, select CollaborationInstance.

Select the Advanced check box.

In the Sort By table, in the Key column, click Click here to add, and click Name in the list.

Click OK.
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	14.5.4 
	Add a REPEAT command to the template.
	Make sure the insertion point is between the [REPEAT11] and [ENDREP12] comments added in steps 14.5.1 through 14.5.3. 

Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.5.5 
	Iterate through the interaction instances within the collaboration instances.
	In the Select Objects to REPEAT list, under CollaborationInstance, scroll and click InteractionInstances.

Select the Create Hyperlink Address check box.

Select the Advanced check box.

In the Sort By table, in the Key column, click Click here to add, and click Name in the list.

Click OK.
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	14.5.6 
	Add a label for the name of the interaction instance.
	Make sure the insertion point is between the [REPEAT13] and [ENDREP14] comments added in step 14.5.5.

Type “Interaction Instance:  ”, and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Labels 3.

Click Apply. 
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	14.5.7 
	Add a DISPLAY command to the template.
	Use the Right arrow key to position the insertion point just after the text “Interaction Instance: .”

Click ProjectConsole > Add Command.

Click DISPLAY Command.

Click OK.
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	14.5.8 
	Display the name of the interaction instance.
	In the Select Attribute to DISPLAY list, under InteractionInstance, click Name.

Click OK.
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	14.5.9 
	Apply a style to the text that shows the name of the interaction instance.
	Position the insertion point just after the [DISPLAY14] comment, and use the Shift and Right arrow keys to select the text “<InteractionInstance.Name>.”

Click Format > Style.

In the Styles list, select PjC Labels 3. 

Click Apply.
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	14.5.10 
	Insert a blank line after the text that displays the name of the interaction instance.
	Press the Right arrow key three times to position the insertion point at the end of the line.

Press the Enter key twice to insert a blank line.
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	14.5.11 
	Add a label for the name of the diagram within an interaction instance.
	Type “Diagram Name:  ,” and select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply. 
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	14.5.12 
	Add a DISPLAY command to the template.
	Press the Right arrow key to move the insertion point after the text “Diagram Name: .”

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.5.13 
	Display the name of the interaction instance diagram.
	In the Select Attribute to DISPLAY list, under InteractionInstance, expand MainDiagram, and under MainDiagram, click Name.

Click OK.
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	14.5.14 
	Apply a style to the text for the name of the interaction instance diagram.
	Position the insertion point just after the [DISPLAY16] comment, and use the Shift and Right arrow keys to select “<InteractionInstance.MainDiagram.Name>.”

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply.
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	14.5.15 
	Insert a blank line after the text that displays the name of the interaction instance diagram.
	Press the Right arrow key three times to position the insertion point at the end of the line.

Press the Down arrow key once to move to the next line.

Press Enter once to insert a blank line.
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	14.5.16 
	Add a DISPLAY command to the template.
	Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.5.17 
	Display the interaction instance diagram.
	In the Select Attribute to DISPLAY list, under InteractionInstance, expand MainDiagram and under MainDiagram, click Image.

In the Width box, type “4.”

In the Height box, type “3.”

Click OK.
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	14.5.18 
	Add a LIMIT command to the template.
	Position the insertion point immediately after the [ENDMAST21] comment.

Click ProjectConsole > Add Command.

Click Special LIMIT Command: OTHERWISE, and then click OK.
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	14.5.19 
	Specify the text to display if there are no interaction instances.
	Make sure the insertion point is between the [LIMIT22] and [ENDLIM23] comments added in step 14.5.18.

Type “There are no interaction instances”, and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply.

Press the Right arrow key to reposition the insertion point.
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Part 6 –  Displaying Participating Objects

In this exercise, you will add commands that display the participating objects for the use case.

	
	Use case steps
	Details
	Display

	14.6.1 
	Select the Participating Objects section. 
	Position the insertion point on the line above the text “Participating Objects.”

Press the Shift and Down arrow keys three times.
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	14.6.2 
	Cut and paste the Participating Objects section so that it is before the [ENDREP24] comment.
	Click Edit > Cut.

Position the insertion point above the [ENDREP24] comment.

Click Edit > Paste.
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	14.6.3 
	Add a REPEAT command to the template.
	Position the insertion point at the beginning of the second line after the text “Participating Objects.”

Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.6.4 
	Iterate through the contained elements within the collaboration instances.
	In the Select Objects to REPEAT list, under CollaborationInstance, click ContainedElements.

In the Where Is A list, select Object.

Select the Create Hyperlink Address check box.

Select the Advanced check box.

In the Sort By table, click Click here to add, and then click Label in the list.

Click OK.
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	14.6.5 
	Add a label to indicate what is being displayed.
	Make sure the insertion point is between the [REPEAT25] and [ENDREP26] comments added in step 14.6.4.

Type “Label:  ”, and select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Labels 3.

Click Apply. 
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	14.6.6 
	Add a DISPLAY command to the template.
	Press the Right  arrow key to position the insertion point just after the text “Label:  ”.

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.6.7 
	Display the object label.
	In the Select Attribute to DISPLAY list, under Object, click Label.

Click OK.
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	14.6.8 
	Apply a style to the text for the object label.
	Position the insertion point immediately after the [DISPLAY26] comment, and use the SHIFT and RIGHT ARROW keys to select the text “<Object.Label>.”

Click Format > Style.

In the Styles list, select PjC Labels 3.

Click Apply.
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	14.6.9 
	Insert a blank line after the text that displays the object label.
	Press the Right arrow key three times to position the insertion point at the end of the line.

Press Enter once to insert a blank line.
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	14.6.10 
	Add a DISPLAY command to the template.
	Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.6.11 
	Display the object description.
	In the Select Attribute to DISPLAY list, under Object, click Description.

Click OK.
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	14.6.12 
	Apply a style to the text for the object description.
	Position the insertion point immediately after the [DISPLAY28] comment, and then use the Shift and Right arrow keys to select the text “<Object.Description>”.

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply.
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	14.6.13 
	Add a LIMIT command to the template.
	Position the insertion point immediately after the [ENDMAST31] comment.

Click ProjectConsole > Add Command.

Click Special LIMIT Command: OTHERWISE, and click OK.
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	14.6.14 
	Display text only if there are no participating objects.
	Make sure the insertion point is between the [LIMIT32] and [ENDLIM33] comments added in step 14.6.13.

Type “There are no participating objects,” and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply.
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	14.6.15 
	Delete the extra white space.
	Press the Down arrow key.

Press Backspace.
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Part 7 –  Displaying Class Diagrams

In this exercise, you will add commands that display the class diagrams for the use case.

	
	Use Case Steps
	Details
	Display

	14.7.1 
	Add white space before the “Class Diagrams” label.
	Position the insertion point just before the text “Class Diagrams.”
Press the Enter key twice to insert two blank lines.
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	14.7.2 
	Establish the point in the template at which to add the commands that display the class diagrams for the use case. 
	Position the insertion point at the beginning of the second blank line under the text “Class Diagrams.”
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	14.7.3 
	Add a REPEAT command to the template.
	Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.7.4 
	Iterate through the class diagrams within the use case.
	In the Select Objects to REPEAT list, under XDE_UseCase, scroll and click OwnedDiagrams.

Select the Create Hyperlink Address check box.

Select the Advanced check box.

In the And Where list, do the following:

· In the Left Operand column, click Click here to add, expand the Self node in the list, and click Type.

· In the Right Operand column, click Click here to add on the first line, click Literal, type “1 – CLASS,” and press ENTER.

In the Sort By table, in the Key column, click Click here to add, and click Name in the list.

Click OK.
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	14.7.5 
	Add a label for the name of the class diagram.
	Make sure the insertion point is between the [REPEAT37] and [ENDREP38] comments added in steps 14.7.3 and 14.7.4.

Type “Class Diagram:  ”, and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Labels 3. 

Click Apply. 
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	14.7.6 
	Add a DISPLAY command to the template.
	Press the Right arrow key to position the insertion point immediately after the text “Class Diagram:  .”

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.7.7 
	Display the name of the class diagram.
	In the Select Attribute to DISPLAY list, under Diagram, click Name.

Click OK.
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	14.7.8 
	Apply the PjC Labels 3 style to the text for the name of the diagram.
	Position the insertion point immediately after the [DISPLAY38] comment, and then use the SHIFT and RIGHT ARROW keys to select the text “<Diagram.Name>.”

Click Format > Style.

In the Styles list, select PjC Labels 3. 

Click Apply.
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	14.7.9 
	Insert a blank line after the text that displays the name of the class diagram.
	Press the Right arrow key three times to position the insertion point at the end of the line.

Press Enter twice to insert a blank line.
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	14.7.10 
	Add a DISPLAY command to the template.
	Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.7.11 
	Display the class diagram.
	In the Select Attribute to DISPLAY list, under Diagram, click Image.

In the Width box, type “4.”

In the Height box, type “3.”

Click OK.
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	14.7.12 
	Add a LIMIT command to the template.
	Position the insertion point immediately after the [ENDMAST43] comment.

Click ProjectConsole > Add Command.

Click Special LIMIT Command: OTHERWISE, and then click OK.
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	14.7.13 
	Display text only if there are no class diagrams.
	Make sure the insertion point is between the [LIMIT44] and [ENDLIM45] comments added in step 14.7.12.

Type “There are no class diagrams,” and then select the text you just typed.

Click Format > Style.

In the Styles list, select PjC Copy.

Click Apply.

Press the Right arrow key to reposition the insertion point.
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Part 8 –  Adding Bookmarks

In this exercise, you will add bookmarks to sections that will be referenced in the table of contents.

	
	Use case steps
	Details
	Display

	14.8.1 
	Establish the point in the template at which to add the bookmark. 
	Position the insertion point immediately before the text “Brief Description.”
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	14.8.2 
	Insert a bookmark.
	Click Insert > Bookmark.

In the Bookmark name box, type “BriefDescription.”

Click Add.
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	14.8.3 
	Add bookmarks for the remaining report sections.
	Repeat step 14.8.2 using the following insertion points and bookmark names:

Position the insertion point immediately before the following text:

· “Interaction Instance Diagrams”

· “Participating Objects”

· “Class Diagrams”

Use the following bookmark names:

· “InteractionInstanceDiagrams”

· “ParticipatingObjects”

· “ClassDiagrams”
	


Part 9 –  Updating the Table of Contents

In this exercise, you will update the table of contents to include links to sections within the Use-Case Realization Report.

	
	Use Case Steps
	Details
	Display

	14.9.1 
	Establish the point in the template at which to add the table of contents. 
	Position the insertion point on the line under the text “Table of Contents.”
Press Enter to insert a blank line.
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	14.9.2 
	Insert a hyperlink to a bookmark.
	Click Insert > Hyperlink.

In the Text to display box, type “Brief Description.”

Click Bookmark.
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	14.9.3 
	
	The Select Place in Document window is displayed.

Expand the Bookmarks node, and click BriefDescription.

Click OK.
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	14.9.4 
	Close the window.
	In the Insert Hyperlink window, click OK.
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	14.9.5 
	Apply a style to the hyperlink.
	Select the “Brief Description” hyperlink. 

Click Format > Style.

In the Styles list, select PjC Destination Links.

Click Apply.
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	14.9.6 
	Insert a blank line after the hyperlink.
	Press the Right arrow key to deselect the hyperlink.

Press Enter to insert a blank line after the hyperlink.
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	14.9.7 
	Add hyperlinks for the remaining report sections.
	Repeat steps 14.9.2 through 14.9.6.

In the Insert Hyperlink window, type the following hyperlink names in the Text to display box:

· “Interaction Instance Diagrams”

· “Participating Objects”

· “Class Diagrams”

In the Select Place in Document window, select the following bookmark names.

· InteractionInstanceDiagrams

· ParticipatingObjects

· ClassDiagrams
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	14.9.8 
	Establish the point in the template at which to add the names of the interaction instances.
	Position the insertion point just before the “Participating Objects” hyperlink.
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	14.9.9 
	Add a repeat command to iterate through the collaboration instances in the use case.
	Repeat steps 14.5.2 and 14.5.3.
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	14.9.10 
	Add a REPEAT command to the template.
	Make sure the insertion point is between the [REPEAT5] and [ENDREP6] comments added in step 14.9.9.

Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.9.11 
	Iterate through the interaction instances within the collaboration instances.
	In the Select Objects to REPEAT list, under CollaborationInstance, click InteractionInstances.

Select the Advanced check box.

In the Sort By table, in the Key column, click Click here to add, and then click Name in the list.

Click OK.
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	14.9.12 
	Add a DISPLAY command to the template.
	Make sure the insertion point is between the [REPEAT7] and [ENDREP8] comments added in steps 14.9.10 and 14.9.11.

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.9.13 
	Display the name of the interaction instance as a link to the interaction instance in the report.
	In the Select Attribute to DISPLAY list, under InteractionInstance, click Name.

Under Create Hyperlink, click Artifact Section.

Click OK.
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	14.9.14 
	Apply a style to the text for the name of the interaction instance.
	Position the insertion point immediately after the [DISPLAY8] comment, and then use the SHIFT and RIGHT ARROW keys to select the text “<InteractionInstance.Name>”.

Click Format > Style.

In the Styles list, select PjC Destination Links.

Click Apply.
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	14.9.15 
	Indent the names of the interaction instances.
	Position the insertion point immediately before the [MASTER4] comment, and then use the Shift and Down arrow keys to select three lines ([MASTER4] through [ENDMAST13]).

On the Word toolbar, click Increase Indent.
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	14.9.16 
	Establish the point in the template at which to add the names of the participating objects.
	Position the insertion point immediately before the “Class Diagrams” hyperlink.


	[image: image99.png]Table-of-ContentsT

T

Brief: Description
Interaction:Instance: Diagrams§

ASTER A REREATS A ST B EPEATTIIDISIANA < 1121 Actinnstans 2. Nam > ENDDIEE 1
[ENDREP10][ENDMASTINIY
[ENDREP12][ENDMASTI3Y

Participating Objects

[Class DiagramsY

1

Use-Case-Realization-Report;-DissLitia<XDE_UseCase Name>Eioniri-1






	14.9.17 
	Add a repeat command to iterate through the collaboration instances in the use case.
	Repeat steps 14.5.2 and 14.5.3.
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	14.9.18 
	Add a REPEAT command to the template.
	Make sure the insertion point is between the [REPEAT15] and [ENDREP16] comments added in step 14.9.17.

Click ProjectConsole > Add Command.

Click REPEAT Command, and click OK.
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	14.9.19 
	Iterate through the objects within the collaboration instances.
	In the Select Objects to REPEAT list, under CollaborationInstance, click ContainedElements.

In the Where Is A list, select Object.

Select the Advanced check box.

In the Sort By table, in the Key column, click Click here to add, and then click Label in the list.

Click OK.
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	14.9.20 
	Add a DISPLAY command to the template.
	Make sure the insertion point is between the [REPEAT17] and [ENDREP18] comments added in steps 14.9.18 and 14.9.19.

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.9.21 
	Display the object name as a link to the object in the report.
	In the Select Attribute to DISPLAY list, under Object, click Label.

Under Create Hyperlink, click Artifact Section.

Click OK.
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	14.9.22 
	Apply a style to the text for the object label.
	Position the insertion point immediately after the [DISPLAY18] comment, and then use the Shift and Right arrow keys to select the text “<Object.Label>”.

Click Format > Style.

In the Styles list, select PjC Destination Links.
Click Apply.
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	14.9.23 
	Indent the object labels.
	Position the insertion point immediately before the [MASTER14] comment, and then use the Shift and Down arrow keys to select three lines ([MASTER14] through [ENDMAST23]).

On the Word toolbar, click Increase Indent.
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	14.9.24 
	Establish the point in the template at which to add the names of the class diagrams.
	Position the insertion point on the first line under the “Class Diagrams” hyperlink.

Click ProjectConsole > Add Command.
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	14.9.25 
	Add a REPEAT command to the template.
	Click REPEAT Command, and then click OK.
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	14.9.26 
	Iterate through the class diagrams within the use case.
	In the Select Objects to REPEAT list, under XDE_UseCase node, scroll down and click OwnedDiagrams.

Select the Advanced check box.

In the And Where list, do the following:

· In the Left Operand column, click Click here to add, expand the Self node in the list, and then click Type.

· In the Right Operand column, click Click here to add, click Literal, type “1 – CLASS,” and then press ENTER.

In the Sort By table, in the Key column, click Click here to add, and then click Name in the list.

Click OK.
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	14.9.27 
	Add a DISPLAY command to the template.
	Make sure the insertion point is between the [REPEAT25] and [ENDREP26] comments added in steps 14.9.25 and 14.9.26.

Click ProjectConsole > Add Command.

Leave DISPLAY Command selected and click OK.
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	14.9.28 
	Display the class diagram name as a link to the class diagram in the report.
	In the Select Attribute to DISPLAY list, under Diagram, click Name.

Under Create Hyperlink, click Artifact Section.

Click OK.
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	14.9.29 
	Apply a style to the text for the class diagram name.
	Position the insertion point immediately after the [DISPLAY26] comment, and use the Shift and Right arrow  keys to select the text “<Diagram.Name>”.

Click Format > Style.

In the Styles list, select PjC Destination Links.

Click Apply.
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	14.9.30 
	Indent the class diagrams names.
	Position the insertion point just before the [MASTER24] comment, and use the Shift and Down arrow keys to select two lines ([MASTER24] through [ENDMAST29]).

On the Word toolbar, click Increase Indent. 
	[image: image113.png]





Part 10 –  Testing the Use-Case Realization Report

In this exercise, you will test the report using Template Builder.

	
	Use case steps
	Details
	Display

	14.10.1 
	Save the template.
	Click File > Save.
	

	14.10.2 
	Save the template document that you created in Parts 1 through 9 as a Web page.
	Click ProjectConsole > Save Web Page.

Word displays a message to let you know that the RUP_UC_Realization_Tutorial.htm file has been created in the same directory as your template.

Click OK.
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	14.10.3 
	Start Rational XDE on the Rational ProjectConsole server.
	On the Rational ProjectConsole server, click Start > Programs > Rational Software > Rational XDE Developer for Java.
	

	14.10.4 
	Determine which model to use when testing the template.
	Either use Rational XDE to create a new use-case model or copy the Use-Case_ Model_Tutorial.mdx file included as part of the download to XDEModelsDir.

Note: If you choose to create a new use-case model, and you want the report to display class diagrams, you must add class diagrams to the use case.
	

	14.10.5 
	Display the template in a Web browser to determine what the report looks like.
	Click ProjectConsole > Test Web Page.

The Template Builder Progress Indicator window is displayed so that you can monitor the document initialization process.
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	14.10.6 
	Specify the use case to report on.
	The Identify XDE_UseCase, a Rational XDE UseCase window is displayed.

To the right of “Path,” click Browse.

Browse to and open the model containing the use case. For example, if you are using the test model, browse to:

XDEModelsDir\Use-Case_ Model_Tutorial.mdx
For FullyQualifiedName, type the use case name. For example, if you are using the test model, type “Use Cases::Use-Case Package 1::Use Case 1.”

Tip You may find it easier to copy and paste the text into FullyQualifiedName rather than typing the text.

Click OK.
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	14.10.7 
	Wait for the report to be generated.
	The Template Builder Progress Indicator window is displayed so that you can monitor the report generation process.

The report may take several minutes to generate.
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	14.10.8 
	View the report in the Web browser.
	The finished report is displayed in your default Web browser.

After you verify that the report is displayed as expected, close the Web browser.
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Conclusion

Congratulations!  You have successfully created a template that extracts data from a Rational XDE model.  Let’s review what you did.

You used Rational ProjectConsole Template Builder to:

· Create the template for reporting on the Rational XDE model.

· Add the commands that access a use case within a Rational XDE model and display the name of the use case.

· Define the sections in the Use-Case Realization template.

· Add the commands that display the brief description of a use case.

· Add the commands that display the interaction instance diagrams of a use case. 

· Add the commands that display the participating objects of a use case. 

· Add the commands that display the class diagrams of a use case. 

· Add bookmarks to mark the sections in the Use-Case Realization template. 

· Update the Table of Contents in the Use-Case Realization template. 

· Test the template.





























































PAGE  
ii
Rational Software

Introduction

