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Quick Start Scenario
Title: Using JDBC Enterprise Service Discovery to generate Wrapper Business Objects.
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1.0 Introduction

The JDBC Resource Adapter (RA) enables a new advanced feature known as Wrapper business object. Wrapper business object is a top level business object in business object hierarchy and used to relate unrelated child business objects. Wrapper object needs minimum two table business objects to wrap them together. Create, Update, Retrieve and Delete operation ignores the top level business objects if they are Wrapper and no processing done for Wrapper objects. 


The document demonstrates one scenario:
· Using JDBC Resource Adapter (RA) EMD to create a Wrapper business objects.  
2.0 Pre-requisites to run the scenario

2.1 Creating the tables
Create two database tables in any database and make sure each table have primary key defined. The sample has been created for Oracle database. The following tables needs to be created in the database to run the scenario
CREATE TABLE CUSTOMER  (



  PKEY VARCHAR2(10) NOT NULL PRIMARY KEY, 



  FNAME VARCHAR2(20) , 



  LNAME VARCHAR2(20) , 



  CCODE VARCHAR2(10) ) ;
CREATE TABLE ADDRESS (



ADDRID VARCHAR(10) NOT NULL PRIMARY KEY,



CUSTID VARCHAR2(10),



CITY VARCHAR2(15),



ZIPCODE VARCHAR2(10));

3.0 Creating the adapter project in WebSphere Integration Developer 
You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.
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Figure 1
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 2
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 3 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 4

2. In the Properties screen, select Java Build Path in the navigation sidebar. Click the Libraries tab.
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Figure 5

3. Click the “Add External JARs” button in the JAR Selection window that opens up, navigate to the driver jar then click Open.
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Figure 6

4. This adds the driver jar to the build path.
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Figure 7
5. Click OK. 
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Figure 8
5.0 Scenario:  Using JDBC Resource Adapter (RA) EMD to create Wrapper business objects.  
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the wrapper business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating wrapper business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 9
3. Select the JDBC EMD Adapter (version 6.0.2.2)
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Figure 10
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database URL and JDBC driver class. Please check the driver manual for the appropriate values for driver URL and driver class. Provide this information in the next wizard page.
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Figure 11
Click the NEXT> button.
5.1.1.2 Selecting the table business objects, wrapper business objects and services to be used with the adapter

1. In the Find and Discover Enterprise Services screen, there are the Execute Query and Edit Query buttons. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. 
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Figure 12


2. 
In order to create Wrapper business objects you should click Edit Query button this will bring below screen where you have to select Wrapper business object and specify Wrapper business object count you like to create. Then click OK button
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Figure 13
3.
Click the Execute Query button. This will list the tables, stored procedures, etc, sorted by schema name.
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Figure 14
4.   In the “Objects discovered by query” list, expand JABDULLA > Tables, choose the CUSTOMER table and click the Add to import list button. 
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Figure 15
     5.  The table would be listed in the ‘Objects to be imported:’ box. 
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          Figure 16
6. Similarly choose the ADDRESS table and click the Add to import list button. Remember Wrapper business objects needs minimum two table objects.

[image: image17.png]@ Enterprise Service Discovery &

Find and Discover Enterprise Services

To discover objects on the enterprise system, create a auery by pressing 'Edt Query’and | EIS!
then press Execute Query”. Once discovered, press "Add to import st” o specify the
objects to be mported, £

Query:
[Schems Name Fiter =il Types=Tabis Types=Vens Types=Stred Procedures Types:  Edit Query..

Exeaute Query

Objects discovered by query:

% crosts [
% e et Cloar ier
D avaren Oetais

D wmsts
@0

D) vrapper 0

| Addtoimport list
Objects to be imported:
© Aooress Romove
© cusroven

<Back x> Eiish Cancel





Figure 17
7. In the “Objects discovered by query” list, expand Wrapper BO, choose the Wrapper 1 and click the Add to import list button
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Figure 18
8. Check the CUSTOMER and ADDRESS and click OK. This will add Wrapper 1 in ‘Objects to be imported:’ box, then Click Next button.
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Figure 19
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields. 
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Figure 20
2. Click the Next > button. 
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 Figure 21
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next
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Figure 22
5. In the New Module screen, type TestWrapper in the Module Name field, then click Finish after the uncheck the Open module assembly diagram checkbox.
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Figure 23
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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 Figure 24
7. Fill in details for the required properties. From the non-required properties, enter values for Username and Password. The other non-required properties may be left blank. 
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Figure 25
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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 Figure 26
9. Click Finish.
10. Verify the results as given in the figure below.
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Figure 27
5.2 Deploying the scenario module to the test environment
Next, we install the SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, select WebSphere Process Server v6.0 and right-click on the server, and then select Start 
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 Figure 28
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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 Figure 29
4. In the Add and Remove Projects screen, select TestWrapperApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 30
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.2.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.3 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
[image: image31.png]EETR. °

CEEEE R
New ,
‘Open Assembly Diagram
Open Dependencies
Shou s
Bcory
B Paste
X oeiie
Refacor ,
R broperes] raiens|
g Import... Process se
o [3/25/07
i V924
&) Refresh (4/25/07
2= fesser
G} Generate User Interfaces. [4/25/07
& Generate Documentoton...  |14/25/97 162
Orestroie
Team » 5 o





Figure 31
2. Choose createWrapper1 from Operation list and set Create as verb. Enter 100 for wrapcustomerpkey and wrapaddressaddrid and right-click over customerobj and select ‘Add Element’.
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Figure 32
3. Enter 1 in the ‘Enter the number of new element to add:’ means you want create 1 new child element and click OK button. Repeat this process for addressobj also.
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Figure 33
4. Now you need to enter values for customerobj and addressobj. Enter the values as shown in the figure below and click Continue button. 
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Figure 34
5. 
Set the Deployment location as WebSphere Process Server v6.0 and check ‘Use this as the default and do not ask again’ and click Finish button. 
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Figure 35
6.   Check the data in the EIS to ensure it matches expected values.
6.0 Troubleshooting
6.1 Test connection failure

If the data source test connection fails, ensure that the Class path property in General properties set for the data source is proper. It should have the path of the driver jar file. 
6.2 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The username/password specified is not proper. 
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