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IBM WebSphere Adapter for JDBC 6.0.2
Quick Start Scenario
Title: Creating records in tables involved in a parent child relationship with a stored procedure associated with the child BO using the CreateSP verb ASI.
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1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Creating a record in tables in a parent child relationship. The scenario also demonstrates the use of a stored procedure attached to a BO. We associate a stored procedure with the child BO using the CreateSP verb ASI. The adapter will call the stored procedure to create the record in the child table instead of generating the insert sql statement.
2.0 Pre-requisites to run the scenario

2.1 Creating the authentication alias

The authentication alias needs to be set since the adapter uses the username/password set in the authentication alias to connect to the database. Here are the steps to set the authentication alias in WPS admin console. This authentication alias will be used later when generating the artifacts for the module. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

[image: image1.png]4+ Business Integration - 1BM WebSphere Integration Developer
Fle Edt Navigate Search Project Run | window Help

»

Custorize Perspective.
Save Perspective s,
Reset Perspective
Close Perspective
Close Al Perspectives

Navigation »

Breferences
TPropeTTES

Property

£ References 52 Outine | Visusl Snippets| = &

=85

Select an artfact in the Business Integratian view ta brawst

kil | |

New Window

[_[CIx]

15| Futness

- Busness Integrakion
2= outine Akishits, 0
5. Physical Resources

2. problems Akishitea, ¢
] Properties

£ References

5 Visual Sippets

other,




Figure 1
2. To set the authentication alias, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 
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Figure 4
5. Click on Security ( Global Security
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Figure 5

6. On the right, click on JAAS Configuration under the Authentication heading
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Figure 6
7. Click on the J2C Authentication data link. It gives the list of existing aliases.
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Figure 7
8. If the SCA_Auth_Alias entry does not exist, click New and create it; else, click on SCA_Auth_Alias and set the proper username/password that can connect to the database. Click OK.
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Figure 8
9. A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 9
10. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 10
Note: We have created an authentication alias that we will use when we configure the adapter properties. We need to re-start the server for the changes to take effect.

2.2  Creating the tables 
The following tables need to be created in the MS SQLServer database to run the scenario.

a. Script for creating the Customer and Address tables

CREATE TABLE CUSTOMER  (



  PKEY VARCHAR2(10) NOT NULL PRIMARY KEY, 



  FNAME VARCHAR2(20) , 



  LNAME VARCHAR2(20) , 



  CCODE VARCHAR2(10) ) ;
CREATE TABLE ADDRESS  (



  ADDRID VARCHAR2(10) NOT NULL PRIMARY KEY, 



  CUSTID VARCHAR2(10) , 



  CITY VARCHAR2(20) , 



  ZIPCODE VARCHAR2(10) ) ;

3.0 Creating the adapter project in WebSphere Integration Developer 

You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.
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Figure 11.
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file.
[image: image12.png]@wmpore Ty

Connector Import

mpert  Connecorproject fam the i system ®
) |,

Connector fle: [ C:\IDBC\CWYBC_JDBC rar =] Bromse...
Conectorproject [ CAvaC_oeC =

I Overuite existing resources wihout warring,

I™ Delete project on overyrite:
Targetseners  [Websphere roces Sever v = e
™ Add module to an EAR project.

= e

o |

[ | o |





Figure 12.
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 13 – Result of the import operation.

4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 14

2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 15.
3. Click the “Add External JARs” button; in the JAR Selection window that opens up, click the Browse button and navigate to the driver jar, then click Open.
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Figure 16.

4. This adds the driver jar to the build path.
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Figure 17.
5. Click OK. 
[image: image18.png]#2 Project Explorer 57 mB% v =0
(3 Entrprise Applcatons
(5 Appicaton Clent racts
= (g Comector Progecs
= S [GBE D8
& Delayment Descrptor: Connector 5N JBC A

@ connectorModule:

0 cvivec_ioaC.ar

0 cwes adspterroundaton

&) mut o - C:\DBCAGepterReatediis

&) mbese jr -CH\DECAzpterRelted o

&) mssdiserver.jr - C: DECAGepterRelatedo
A R Systen Lbrary [19S Server 6.0 Re]
= WebSphere Process Server v6.0 Runtime
(3 EBProeats

5 Dymame eb proects

) otrer Frojects

G Web services
(g Databases

(g atebase servers





Figure 18.
5.0 Scenario:  Creating a record using parent child BOs with a CreateSP associated with the child BO.
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 19.
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 20.
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. 
Make sure to add “Select Method=Cursor” in database url, e.g.

jdbc:microsoft:sqlserver://9.26.247.53:1433;databaseName=anitameh;SelectMethod=Cursor

Provide this information in the next wizard page.
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Figure 21.
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the Customer and Address business object:

1. In the Find and Discover Enterprise Services screen, click the Edit Query button. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. 
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Figure 22


2. In the Query Filter Properties window that opens up, check the Add business object ASI checkbox, click OK. Then whenever you add an object when you run the metadata query, a window is displayed for entering application-specific information (ASI).

[image: image23.png]Enterprise Service ry
QueryFiter Properties

et the uer s roperes, renress Ok

This property group encompasses properties used to filter the objects displayed by the EMD. /
S———
Tpes:
s

evs []
Stred procedres Ramove
s ==

IV Add busiess object AST
T~ Query business object

PP |






Figure 23

3. Now on the Find and Discover Enterprise Services window, click the Run Query button. This will list the tables, stored procedures, etc, sorted by schema name. 
4. In the “Objects discovered by query” list, expand anitameh > Tables, and choose the Address and Customer tables. 
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Figure 24.
5. Click on the >> Add button. It opens up a window for setting the Configuration Parameters for the Address and Customers tables. Select Address Table. We associate a stored procedure to this BO using this step. The Status Column Name is used only in case of logical deletes; so we leave it blank.
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Figure 25

6. Click on the Add… button in the Enterprise Service Discovery window. Select CreateSP and click OK. Here we associate the CreateSP ASI to the Address table. This effectively means that when a Create operation is called on the business object, the stored procedure specified in the CreateSP would be called, which will perform the insert operation. 
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Figure 26.
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Figure 27.
7. Enter values for Schema and Stored Procedure. When the Stored Procedure name is selected, it shows up the stored procedure parameters. We need to associate the BO attributes to the stored procedure parameters. The values entered for these attributes act as the input values for the stored procedure.
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Figure 28.
8. We won’t associate any stored procedure to Customer BO, click on OK.
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Figure 29
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields.
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Figure 30.
2. Click the Next > button. 
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Figure 31
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next
[image: image32.png]'@ New Integration Project

Integration Project
Select the type of ntegration project to reate.

& Create 2 module project.
" Create a mediation module project.

<Back, Next >

Fiish





Figure 32
5. In the New Module screen, type JDBCOutbound in the Module Name field, uncheck the Open module assembly diagram checkbox, then click Finish.
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Figure 33
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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Figure 34.
7. Fill in details for the required properties. From the non-required properties, enter values for J2C Authentication Data Entry, Username and Password. The other non-required properties may be left blank. You need to set the authentication alias created earlier in the J2C Authentication Data Entry field. The name is case-sensitive.
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Figure 35
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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Figure 36.
9. Click Finish.
10. Verify the results as given in figure 37.
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Figure 37.
5.1.2 Linking the BOs  

In this step, we will link the Customer and Address business objects in a parent child relationship and add additional ASIs to support the linking.

1. In figure 37, double click on the AnitamehCustomer BO listed under Data Types. This opens the BO in the BO designer.
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Figure 38.
2. Next we add an attribute whose type is the AnitamehAddress object. Click on the ‘Add an attribute to a business object’. 
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Figure 39
3. This creates a new attribute with the name attribute1. Re-name it to addrObj.
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Figure 40

4. Change the type of attribute. Click on the type, it opens up a list of types that can be associated with this attribute. 
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Figure 41


5. Choose AnitamehAddress as the type.
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Figure 42


6. Select the newly added attribute and in the Properties tab, click on Description. We want this Address child object to be of type multiple cardinality, i.e., one Customer object can have multiple Address objects; so, check the Array checkbox.
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Figure 43
7. Now we will add the attribute ASI for this attribute. Click on Application Info in the Properties tab and check the ASIAttributeTypeMetadata checkbox. This is needed to add any attribute type ASI to the newly added attribute.
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Figure 44
8. Under the ASI element properties, right click on jdbcasi:JDBCAttributeTypeMetadata and choose Add Child ( jdbcasi:Ownership.
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Figure 45
9. Set the Ownership value to true. Save the Customer BO. Set the ownership value to true to indicate that the parent owns the child i.e., the child cannot exist without the parent.  
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Figure 46
10. Open the AnitamehAddress business object. We will set the foreign key on this BO. Click on the custid attribute and in the Properties tab, click on Application Info. Right click on jdbcasi:JDBCAttributeTypeMetadata and choose Add Child ( jdbcasi:ForeignKey. Set the value to pkey, which is the attribute in the Customer object that refers to the primary key in the Customer table. 
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Figure 47
11. Save the BOs using the Save button on the toolbar.
5.2 Deploying the scenario module to the test environment
The result of running the enterprise service discovery wizard is an SCA module that contains an EIS import. Install this SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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Figure 48
4. In the Add and Remove Projects screen, select JDBCOutboundApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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     Figure 49
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.1.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.3 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
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Figure 50.
2. The create scenario is to create a record in the database. Choose createAnitamehCustomer as the Operation.
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Figure 51
3. Set the verb to Create and populate values for the parent BO.
4. Right click on the addrObj attribute and select Add Element to create the child object.
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Figure 52
5. In the Add Element window, set the value as 1, since we will enter only one address element. 
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Figure 53
6. Populate data for the child object
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Figure 54.
7. Execute the service by clicking Continue. 
8. In the “Select Deployment location” screen, select the server, then click Finish. 
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Figure 55
9. Check the output of the service, and check the data in the EIS to ensure it matches expected values.  
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Figure 56
6.0 Troubleshooting
6.1 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The authentication alias does not have the proper username/password that can connect to the database. 

6.2 Failure during adapter processing

If the adapter fails during processing, refer to the adapter log file to find the cause of the failure. 

1. Error: Primary key does not exist

Cause: The table does not have a primary key defined. Hence, the PrimaryKey ASI on the BO is not set to true.

2. Error: A record already exists 

Cause: A record with the primary key already exists in the database. Try inserting a record with a primary key that does not exist in the database.
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