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Title: Creating a business object for a stored procedure and executing the stored procedure using the Execute operation. 
Table of Contents

21.0
Introduction


22.0
Pre-requisites to run the scenario


22.1
Creating the authentication alias


92.2
Creating the tables and stored procedures


103.0
Creating the adapter project in WebSphere Integration Developer


124.0
Adding external software dependencies


165.0
Scenario:  Executing a BO created from a stored procedure.


165.1
Configuring the adapter for outbound processing


165.1.1
Generating business objects using the enterprise service discovery wizard


325.2
Deploying the scenario module to the test environment


345.3
Testing the assembled adapter application


396.0
Troubleshooting


396.1
Adapter fails to start up


396.2
Failure during adapter processing




1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Creating a business object for a stored procedure and executing the stored procedure using the Execute operation. The scenario also demonstrates the support for resultsets returned by the stored procedure. 
2.0 Pre-requisites to run the scenario

2.1 Creating the authentication alias

The authentication alias needs to be set since the adapter uses the username/password set in the authentication alias to connect to the database. Here are the steps to set the authentication alias in WPS admin console. This authentication alias will be used later when generating the artifacts for the module. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.
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Figure 1
2. To set the authentication alias, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 
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Figure 4
5. Click on Security ( Global Security
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Figure 5
6. On the right, click on JAAS Configuration under the Authentication heading
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Figure 6
7. Click on the J2C Authentication data link. It gives the list of existing aliases.
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Figure 7
8. If the SCA_Auth_Alias entry does not exist, click New and create it; else, click on SCA_Auth_Alias and set the proper username/password that can connect to the database. Click OK.
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Figure 8
9. A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 9
10. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 10
Note: We have created an authentication alias that we will use when we configure the adapter properties. We need to re-start the server for the changes to take effect.

2.2  Creating the tables and stored procedures
The following tables and stored procedure need to be created in the DB2 database to run the scenario.

a. Script for creating the Customer and Address tables

CREATE TABLE CUSTOMER  (



  "PKEY" VARCHAR(10) NOT NULL PRIMARY KEY, 



  "FNAME" VARCHAR(20) , 



  "LNAME" VARCHAR(20) , 



  "CCODE" VARCHAR(10) ) ;
CREATE TABLE ADDRESS  (



  "ADDRID" VARCHAR(10) NOT NULL PRIMARY KEY, 



  "CUSTID" VARCHAR(10) , 



  "CITY" VARCHAR(20) , 



  "ZIPCODE" VARCHAR(10) ) ;

Enter the following records in the two tables:

INSERT INTO CUSTOMER VALUES (‘100’, ‘fname1’, ‘lname1’, ‘IBM’);

INSERT INTO CUSTOMER VALUES (‘300’, ‘abc, ‘xyz, ‘IBM’);

INSERT INTO ADDRESS VALUES (‘100’, ‘100’, ‘cxxx, ‘xxxx);

INSERT INTO ADDRESS VALUES (‘120’, ‘100’, ‘city1’, ‘zipcode1);

b. Creating the stored procedure
The stored procedure can be created using the DB2 Development Center

1. In the development center, create a new java stored procedure using wizard. 

Create a stored procedure that has one input string and one output string parameter, and returns two result sets. Here’s the java stored procedure sample;
public class PROCEDURE1

{

    public static void pROCEDURE1 ( String var0, String[] var1,

                                    ResultSet[] rs1, ResultSet[] rs2 ) throws SQLException, Exception

    {

        // Get connection to the database

        Connection con = DriverManager.getConnection("jdbc:default:connection");

        PreparedStatement stmt = null;

        boolean bFlag;

        String sql;

        sql = "SELECT *  FROM ADDCUSER.CUSTOMER AS CUSTOMER";

        stmt = con.prepareStatement( sql );

        bFlag = stmt.execute();

        rs1[0] = stmt.getResultSet();

        sql = "SELECT * FROM ADDCUSER.ADDRESS AS ADDRESS";

        stmt = con.prepareStatement( sql );

        bFlag = stmt.execute();

        rs2[0] = stmt.getResultSet();

        // Set return parameter

        var1[0] = var0;

    }

}                     

3.0 Creating the adapter project in WebSphere Integration Developer 

You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.
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Figure 11.
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 12.
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 13 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 14

2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 15.
3. Click the “Add External JARs” button in the JAR Selection window that opens up, click the Browse button and navigate to the driver jar, then click Open.
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Figure 16.

4. This adds the driver jar to the build path.
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Figure 17.
5. Click OK. 
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Figure 18.
5.0 Scenario:  Executing a BO created from a stored procedure.
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 19.
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 20.
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. Provide this information in the next wizard page.
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Figure 21.
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the ‘Sample’ stored procedure:

1. In the Find and Discover Enterprise Services screen, there are the Execute Query and Edit Query buttons. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information.Clicking the Execute Query button will list the tables, stored procedures, etc, sorted by schema name. 
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Figure 22


2. Click the Execute Query button. 
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Figure 23.
3. In the “Objects discovered by query” list, expand ADDCUSER > Stored procedures and choose the PROCEDURE1 stored procedure and click the ‘Add to import list button’. This brings up the Configuration Parameter window. The Procedure1 stored procedure return two result sets; so, we set the Max Num RetRS to 2. The window also has the input and output parameters of the stored procedure as the attributes of the business object. 
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Figure 24.
4. Enter a dummy value for the VAR0 input type and check the ‘Execute the stored procedure with dummy values’ checkbox. It shows the attributes for the two result sets returned by the stored procedure. The adapter will create business objects for the two result sets and they will be child objects in the Procedure1 business object. 
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Figure 25
5. Click OK. 
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Figure 26
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields. There is only one operation supported for business objects generated for stored procedures, which is Execute. 
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Figure 27.
2. Click the Next > button. 
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Figure 28
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next
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Figure 29
5. In the New Module screen, type Tutorial2 in the Module Name field, then click Finish. Also, uncheck the Open module assembly diagram checkbox.
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Figure 30
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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Figure 31
7. Fill in details for the required properties. From the non-required properties, enter values for J2C Authentication Data Entry, Username and Password. The other non-required properties may be left blank. You need to set the authentication alias created earlier in the J2C Authentication Data Entry field. The name is case-sensitive.
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Figure 32
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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Figure 33.
9. Click Finish.
10. Verify the results as given in figure 36.
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Figure 34.
5.2 Deploying the scenario module to the test environment
The result of running the enterprise service discovery wizard is an SCA module that contains an EIS import. Install this SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 
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Figure 35
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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Figure 36
4. In the Add and Remove Projects screen, select JDBCOutboundApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 37
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.1.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.3 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
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Figure 38.
2. There is only one supported operation for BOs created for stored procedures; so, the executeAddcuserProcedure1 Operation is chosen by default.
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Figure 39
3. Populate data for the input type var0, unset the value for the output type var1. 
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Figure 40
4. Execute the service by clicking Continue. 
5. In the “Select Deployment location” screen, select the server, then click Finish. 
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Figure 41
6. Check the output of the service, and check the data in the EIS to ensure it matches expected values.  
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Figure 42
6.0 Troubleshooting
6.1 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The authentication alias does not have the proper username/password that can connect to the database. 

6.2 Failure during adapter processing

If the adapter fails during processing, refer to the adapter log file to find the cause of the failure. 

1. Error: Primary key does not exist

Cause: The table does not have a primary key defined. Hence, the PrimaryKey ASI on the BO is not set to true.

2. Error: A record already exists 

Cause: A record with the primary key already exists in the database. Try inserting a record with a primary key that does not exist in the database.
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