[image: image47.png]WehSphere.





IBM WebSphere Adapter for JDBC 6.0.2
Quick Start Scenario
Title: Creating a business object for a stored procedure and executing the stored procedure using the Execute operation. 
Table of Contents

21.0
Introduction


22.0
Pre-requisites to run the scenario


22.1
Creating the authentication alias


102.2
Creating the tables and stored procedures


113.0
Creating the adapter project in WebSphere Integration Developer


134.0
Adding external software dependencies


175.0
Scenario:  Executing a BO created from a stored procedure.


175.1
Configuring the adapter for outbound processing


175.1.1
Generating business objects using the enterprise service discovery wizard


355.2
Deploying the scenario module to the test environment


375.3
Testing the assembled adapter application


436.0
Troubleshooting


436.1
Adapter fails to start up


436.2
Failure during adapter processing




1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Creating a business object for a stored procedure and executing the stored procedure using the Execute operation. The scenario also demonstrates the support for array and struct data types. 
2.0 Pre-requisites to run the scenario

2.1 Creating the authentication alias

The authentication alias needs to be set since the adapter uses the username/password set in the authentication alias to connect to the database. Here are the steps to set the authentication alias in WPS admin console. This authentication alias will be used later when generating the artifacts for the module. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

[image: image1.png]4+ Business Integration - 1BM WebSphere Integration Developer
Fle Edt Navigate Search Project Run | window Help

»

Custorize Perspective.
Save Perspective s,
Reset Perspective
Close Perspective
Close Al Perspectives

Navigation »

Breferences
TPropeTTES

Property

£ References 52 Outine | Visusl Snippets| = &

=85

Select an artfact in the Business Integratian view ta brawst

kil | |

New Window

[_[CIx]

15| Futness

- Busness Integrakion
2= outine Akishits, 0
5. Physical Resources

2. problems Akishitea, ¢
] Properties

£ References

5 Visual Sippets

other,




Figure 1
2. To set the authentication alias, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 
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Figure 4
5. Click on Security ( Global Security
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Figure 5
6. On the right, click on JAAS Configuration under the Authentication heading
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Figure 6
7. Click on the J2C Authentication data link. It gives the list of existing aliases.
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Figure 7
8. If the SCA_Auth_Alias entry does not exist, click New and create it; else, click on SCA_Auth_Alias and set the proper username/password that can connect to the database. Click OK.
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Figure 8
9. A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 9
10. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 10
Note: We have created an authentication alias that we will use when we configure the adapter properties. We need to re-start the server for the changes to take effect.

2.2  Creating the tables and stored procedures
The sample has been created for an Oracle database. The following reference types, tables and stored procedure need to be created in the database to run the scenario. 
a. Script for creating the reference types

CREATE OR REPLACE TYPE ARRAYTYPE AS VARRAY(10) OF VARCHAR2(50);

/

Here, we have created a reference type of array that holds up to 10 records of type VARCHAR2. We will use this as an input type in our stored procedure. 

CREATE OR REPLCE TYPE STRUCTTYPE AS OBJECT (

EMPID VARCHAR2(10),

NAME VARCHAR2(20),

TITLE VARCHAR2(10)

);

/

Here, we have created a reference type of struct that has three columns. We will use this as an output type in our stored procedure. 
Note: To create reference types, we need to provide a forward slash (/) at the end and then press the Return key.
b. Script for creating the tables

We create two tables that will be used in the stored procedure. 

CREATE TABLE TABLE_ARRAY (



  ID VARCHAR2(10), 



  INFO ARRAYTYPE );
CREATE TABLE TABLE_STRUCT (



  ID VARCHAR2(10) , 



  INFO STRUCTTYPE ) ;

Enter the following record in TABLE_STRUCT  

INSERT INTO TABLE_STRUCT VALUES (‘100’, STRUCTTYPE(‘10’, ‘xyz’, ‘SE’);

c. Creating the stored procedure
The stored procedure takes an array type as an input parameter and returns a struct type as an output parameter
CREATE OR REPLACE PROCEDURE SAMPLE (

pkey IN VARCHAR, arr IN ARRAYTYPE, strt OUT STRUCTTYPE )

IS BEGIN

INSERT INTO TABLE_ARRAY VALUES (pkey, arr);

SELECT INFO INTO strt FROM TABLE_STRUCT WHERE ID = pkey;

END SAMPLE;

/

3.0 Creating the adapter project in WebSphere Integration Developer 

You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.

[image: image11.png]2 EEER ]
8 Enerre Aot
5 poptesir lst ot

New > |

3 £ Projects
55 Dynemic ieb Pr R
© OtherProjects | Expartoe b
6 WebServices | L
€D Databases

€D Database Servers

s It
Deploy 1T





Figure 11.
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 12.
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 13 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 14

2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 15.
3. Click the “Add External JARs” button in the JAR Selection window that opens up, click the Browse button and navigate to the driver jar, then click Open.
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Figure 16.

4. This adds the driver jar to the build path.
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Figure 17.
5. Click OK. 
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Figure 18.
5.0 Scenario:  Executing a BO created from a stored procedure.
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 19.
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 20.
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. Provide this information in the next wizard page.

[image: image21.png]4~ Enterprise Service Discovery

Configure Settings for Discovery Agent

Specify the properties to ntialize the resource adapter and the enterprise service
discovery agent.

Connection Configuratian

Miscelaneous

i T

User Credentials

Username: # [zt

bosonds+ [T

Machine Credentials

DatobaseURL:  * [FocoradeTn @R 157 112 15T 521 e

b rver lss: [orac b cwer radebrvel]

BDi Propeties
I~ iditransformetion

i crderngshema: [t

Tondredion [

¥ BDi Symmetric Siwapping

L Ll

s [Nl

i shapng: [Nl

Shaw Advanced >>

L Ll

<Back et > Eish Cancel





Figure 21.
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the ‘Sample’ stored procedure:

1. In the Find and Discover Enterprise Services screen, there are the Execute Query and Edit Query buttons. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. Clicking the Execute Query button will list the tables, stored procedures, etc, sorted by schema name. 
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Figure 22


2. Click the Execute Query button. 

[image: image23.png]Find and Discover Enterprise Services

ToGacoverchects o hecertis syt e » uery b resig ‘5 G IE;I?

and then press "Execute Query". Once discavered, press "Add to import st ta specky
the objects to be mported.

Query
[Sems s it

Executs Query.
Objects discovered by query:

B0 scoTT =
ae o

) ARRINVALLES
) ARRVALLES

) CUSTVALLES

) GETCUSTOUMMY

) GETCUSTS

) MIGARRINVALLES
) MISTRTINVALLES

0 Add to mport st

tored Procedures Ed Query.

Objects to be imperted:

e

o | o | ] el





Figure 23.
3. In the “Objects discovered by query” list, expand SCOTT > Stored procedures and choose the SAMPLE stored procedure and click the ‘Add to import list button’. This brings up the Configuration Parameter window. The Sample stored procedure does not return a result set; so, the Max Num RetRS is set to 0. The window also has the input and output parameters of the stored procedure as the attributes of the business object. 
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Figure 24.
4. For the ARR attribute of data type Array, we need to specify the Type Name, which is the actual reference type of the array data type. Refer to section 2.2 for the reference type. Once you enter the reference type, the JDBC EMD discovers the element contained by the array and generates an attribute for them. The ARRAYTYPE type contains one element and is named as Attribute1 by the EMD.  
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Figure 25.
5. Similarly, specify the type name for the struct attribute. It shows the attributes contained within the struct type.
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Figure 26.
6. Enter dummy values for the stored procedure input types, which are PKEY and ARR and check the ‘Execute the stored procedure with dummy values’ to verify if the stored procedure executes successfully. Check the ‘Execution Status’ to verify the result of execution.
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Figure 27
7. Click OK. 
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Figure 28
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields. There is only one operation supported for business objects generated for stored procedures, which is Execute. 
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Figure 29.
2. Click the Next > button. 
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Figure 30
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next

[image: image31.png]n Project

Integration Project
Select the type of integration project o create.

 Eieate smodle poject]

 Create a medistion module project,

<Bark. et > Eiish Cancel





Figure 31
5. In the New Module screen, type Tutorial2 in the Module Name field, then click Finish. Also, uncheck the Open module assembly diagram checkbox.
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Figure 32
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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Figure 33
7. Fill in details for the required properties. From the non-required properties, enter values for J2C Authentication Data Entry, Username and Password. The other non-required properties may be left blank. You need to set the authentication alias created earlier in the J2C Authentication Data Entry field. The name is case-sensitive.
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Figure 34
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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Figure 35.
9. Click Finish.
10. Verify the results as given in figure 36.
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Figure 36.
5.2 Deploying the scenario module to the test environment
The result of running the enterprise service discovery wizard is an SCA module that contains an EIS import. Install this SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 
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Figure 37
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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Figure 38
4. In the Add and Remove Projects screen, select JDBCOutboundApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 39
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.1.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.3 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
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Figure 40.
2. There is only one supported operation for BOs created for stored procedures; so, the executeScottSample Operation is chosen by default.
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Figure 41
3. Right click on the arr attribute and click Add Element. 

[image: image42.png]Inial request parameters

Name Ttpe Tvslue |
Elexeautestottsamplelnput  Scottsamplese
verh siring <nul>
Elscottsample ScottSample
pley string
ot vl T
it St to Unset
Set to ]

Sek to Defauie
Remove Element Defe

Show Change Summary
Enabe Logging

Copy Value ctrivc
paste Value iy
dd Valye to Poal

Use Yl from Po

Import from KL Fie,

Select Al




Figure 42
4. In the Add Element window enter a value of 2 to create two child objects. We will enter two values for the array object. 
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Figure 43
5. Populate data for the input types pkey and the two array child attributes. Unset the value for the strt attribute, which is an output type. 
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Figure 44
6. Execute the service by clicking Continue. 
7. In the “Select Deployment location” screen, select the server, then click Finish. 
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Figure 45
8. Check the output of the service, and check the data in the EIS to ensure it matches expected values.  
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Figure 46
6.0 Troubleshooting
6.1 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The authentication alias does not have the proper username/password that can connect to the database. 

6.2 Failure during adapter processing

If the adapter fails during processing, refer to the adapter log file to find the cause of the failure. 

1. Error: Primary key does not exist

Cause: The table does not have a primary key defined. Hence, the PrimaryKey ASI on the BO is not set to true.

2. Error: A record already exists 

Cause: A record with the primary key already exists in the database. Try inserting a record with a primary key that does not exist in the database.
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