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Quick Start Scenario
Title: Creating a business object for a user-defined query and using the RetrieveAll operation to retrieve the records returned by the user-defined query.
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1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Creating a business object for a user-defined query that does a join on two tables and using the RetrieveAll operation to retrieve the records returned by the user-defined query. 
2.0 Pre-requisites to run the scenario

2.1 Creating the authentication alias

The authentication alias needs to be set since the adapter uses the username/password set in the authentication alias to connect to the database. Here are the steps to set the authentication alias in WPS admin console. This authentication alias will be used later when generating the artifacts for the module. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.
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Figure 1
2. To set the authentication alias, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 
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Figure 4
5. Click on Security ( Global Security


[image: image5.png]Welcome

Guided Adtivtisz
Servars

Applications

Resources

B security

Global security
ssu

Enuiranmant
Integration Applications
System administration
Monitoring and Tuning
Traubleshaoting

Serice integration

uDI





Figure 5
6. On the right, click on JAAS Configuration under the Authentication heading
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Figure 6
7. Click on the J2C Authentication data link. It gives the list of existing aliases.
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Figure 7
8. If the SCA_Auth_Alias entry does not exist, click New and create it; else, click on SCA_Auth_Alias and set the proper username/password that can connect to the database. Click OK.


[image: image8.png]Global security > J2EE Connector Architecture (J2€) authentication data entries >
SCA_Auth_alias

Spedies 2 list of user IDs and passuords for Java 2 connactor sacurlty to uss,

Configuration

General Properties

+ aias
[scAut s

+ User1D

+ Password

Desaription





Figure 8
9. A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 9
10. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 10
Note: We have created an authentication alias that we will use when we configure the adapter properties. We need to re-start the server for the changes to take effect.

2.2  Creating the tables
The sample has been created for a DB2 database. The tables need to be created in the database to run the scenario. 
a. Script for creating the tables

CREATE TABLE CUSTOMER  (



  "PKEY" VARCHAR(10) NOT NULL PRIMARY KEY, 



  "FNAME" VARCHAR(20) , 



  "LNAME" VARCHAR(20) , 



  "CCODE" VARCHAR(10) ) ;
CREATE TABLE ADDRESS  (



  "ADDRID" VARCHAR(10) NOT NULL PRIMARY KEY, 



  "CUSTID" VARCHAR(10) , 



  "CITY" VARCHAR(20) , 



  "ZIPCODE" VARCHAR(10) ) ;

3.0 Creating the adapter project in WebSphere Integration Developer 

You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.
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Figure 11.
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 12.
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 13 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 14

2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 15.
3. Click the “Add External JARs” button in the JAR Selection window that opens up, click the Browse button and navigate to the driver jar, then click Open.

[image: image16.png]JAR Selection [21x]

Lookin: [306C — 5 «@mck

S abziecor
=] dbajec_lcense_cisuz.jar
] dbzjec_lcense_cu.jar
[ligdbcor
[Sligdbocior

() fdang jor

[Slifxsumn or
(Sicaljor

(D) etoos
[Slojdbetajor

e E =

Lo |
O —— |




Figure 16.

4. This adds the driver jar to the build path.
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Figure 17.
5. Click OK. 
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Figure 18.
5.0 Scenario:  Using a user-defined join on two tables to do a retrieve.
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 19.
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 20.
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. Provide this information in the next wizard page.
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Figure 21.
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the ‘Sample’ stored procedure:

1. In the Find and Discover Enterprise Services screen, click the Edit Query button. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. 
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Figure 22


2. In the Query Filter Properties window that opens up, check the Query business object checkbox. You can enter the number of user-defined queries that you want to enter. In the current scenario, we just enter one user-defined query. So, we keep the default value of 1. Click OK.
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Figure 23
3. Click the Execute Query button. This will list the tables, stored procedures, etc, sorted by schema name. It will also list ‘Query statements’ as a top level node for creation of user-defined query BOs.
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Figure 24.
4. In the “Objects discovered by query” list, expand ADDCUSER > Query Statements and choose the Select Statement 1 and click the Add to import list button. There is only one select statement since we entered a value of 1 for the Query business object count property. 
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Figure 25
5. This brings up the Configuration Parameter window. Enter the name for the query business object as QueryBO and the following query in the select statement property: select C.pkey, C.fname, A.city from customer C, address A WHERE (C.pkey = A.custid) AND (C.fname like ?). After the select statement in populated, EMD displays the list of where clause parameters. In the current scenario we have only one where clause parameter that needs to be provided at runtime. 
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Figure 26.
6. Enter dummy values for the Parameter value property and check the checkbox for the ‘Check specified select statement with dummy values’ to verify if the user-defined query executes successfully. 
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Figure 27
7. Click OK. 
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Figure 28.
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields. There is only one operation supported for business objects generated for user-defined queries, which is RetrieveAll. 
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Figure 29.
2. Click the Next > button. 

[image: image30.png]Generate Artifacts

Specify the properties fo the artfacts that il be generated n your workspace,

I

Propertis for service =

Modue: [ -
Hemespace Tetp 11 I0BCOMboundInterface

IV Use defaul namespace

Folder: Browse,
Name: * [I0BCOMboundInterface
Description

Service operations

1 you want to modlfy the names, or add a description to the operations R
to be generated n the interface fe, press the "Edt Operations button. EE Qe

Deployment propeties

[ Deplay connector with module

32C Authentication Data Entry:

Specify the connection praperties which willbe used to conniect ta the Enterprise Information System at runkime:
€ Use connection propertes specfied on server
 Use discovered connection properties

[ —— ]

R e




Figure 30
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next

[image: image31.png]n Project

Integration Project
Select the type of integration project o create.

 Eieate smodle poject]

 Create a medistion module project,

<Bark. et > Eiish Cancel





Figure 31
5. In the New Module screen, type Tutorial3 in the Module Name field, then click Finish. Also, uncheck the Open module assembly diagram checkbox.
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Figure 32
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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Figure 33.
7. Fill in details for the required properties. From the non-required properties, enter values for J2C Authentication Data Entry, Username and Password. The other non-required properties may be left blank. You need to set the authentication alias created earlier in the J2C Authentication Data Entry field. The name is case-sensitive.
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Figure 34
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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Figure 35.
9. Click Finish.
10. Verify the results as given in figure below.
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Figure 36.
5.2 Deploying the scenario module to the test environment
The result of running the enterprise service discovery wizard is an SCA module that contains an EIS import. Install this SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 
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Figure 37
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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Figure 38
4. In the Add and Remove Projects screen, select Tutorial3App, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 39
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.1.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.3 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
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Figure 40.
2. There is only one supported operation for BOs created for user-defined queries; so, the retrieveallQueryBO Operation is chosen by default.
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Figure 41
3. You only need to provide a value for parameter1 attribute. Unset all other properties. The jdbcwhereclause needs to be unset as well. If you want to use the jdbcwhereclause, you need to replace the ? in it with the value that you would otherwise set in the parameter1 attribute. 
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Figure 42
4. Execute the service by clicking Continue. 
5. In the “Select Deployment location” screen, select the server, then click Finish. 
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Figure 43
6. Check the output of the service, and check the data in the EIS to ensure it matches expected values.  
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Figure 44
6.0 Troubleshooting
6.1 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The authentication alias does not have the proper username/password that can connect to the database. 

6.2 Failure during adapter processing

If the adapter fails during processing, ensure that if the jdbcwhereclause value is provided, the value should not have any ? in it. The default jdbcwhereclause value has ?s in it, for which there are parameters named parameter1 to parameterN created as attributes of the BO. If you provide a value for the parameters, you need to unset the jdbcwhereclause value. Else you can provide the value in the jdbcwhereclause itself by replacing the ?s with the values that you would otherwise provide in the parameter1 to N attributes of the BO. The adapter will ignore the values provided in the parameter attributes if a value exists in the jdbcwhereclause attribute. 
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