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Title: Using an XA data source to perform XA transactions using the JDBC adapter.
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1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Using an XA data source to perform XA transactions using the JDBC adapter.  
2.0 Pre-requisites to run the scenario

2.1 Creating the data source
We will create a datasource created in WebSphere Application Server using which the adapter will connect to the database. The data source will be an XA data source. Here are the steps to create the data source in WPS admin console. This XA data source will be used later when generating the artifacts for the module. 

Note: We will be using DB2 as the database. Add db2java.zip to the runtimes lib folder. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.
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Figure 1
2. To create the data source, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 


[image: image4.png]@ B

The User ID does not require a password, and doas not nesd to be
3 User ID of a user In the local user registry. It s only used to track
User-spedic thanges to configuration data. Security is NOT enablad




Figure 4
5. Click on Resources ( JDBC Providers
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Figure 5
6. On the right, click on the New button on the JDBC providers window.
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Figure 6
7. Choose the values for steps 1 to 3 as shown in the figure below. We choose a db2 database with an XA data source for the legacy db2 type 2 driver. 
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Figure 7
8. Click Next. In the General Properties, enter the following value for Class path: $(WAS_LIBS_DIR)/db2java.zip, where $(WAS_LIBS_DIR) is the runtimes lib path. Since we’ve added the db2java.zip to this path, we specify that path here. Click the ‘Apply’ button.
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Figure 8
9. After you click on Apply, the Data sources links under the Additional Properties heading are enabled. Click on the first Data sources link. Click on the ‘New’ button.
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Figure 9
10. Enter the value for JNDI name as shown in the figure.
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Figure 10
11. Enter the value of the database name that you have configured. Click the OK button.
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Figure 11
12.  A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 12
13.  The next page shows the number of documents that have changed. Click on the Save button.
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Figure 13
14.  In the next window, click on the Test connection button.
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Figure 14
15.  The connection should succeed as indicated by the message shown in the figure below. For any problems with the Test connection, refer Troubleshooting section 6.1

[image: image15.png]B Mecsages

D Test connaction for dsts source DB Legacy CLI-bazed IDBC

Driver XA DatsSaurca an sarver sarverd at nads widNads vz
succassul,

IDBC providers > DB2 Leascy CLI-based Type 2 IDBC Driver (XA) > Data sources

A data source is used by the application to access data from the database. A data source is
creatad under 3 JDBC provider, which supplies the spacific JDBC driver implemantation dass.

Prefarences

(e | [Dstete | [ Test connection | [ manage state.

Select | Name &

NDI name ¢

|De2ieass
Clibssed JoBC

Driver % Datssource

jdbe/DB2RADS

Total 1




Figure 15
Note: We have created an XA data source, which will be used by the adapter to connect to the database. 

2.2  Creating the tables
The sample has been created for a DB2 database. The following table needs to be created in the database to run the scenario. 
a. Script for creating the tables

CREATE TABLE CUSTOMER  (



  "PKEY" VARCHAR(10) NOT NULL PRIMARY KEY, 



  "FNAME" VARCHAR(20) , 



  "LNAME" VARCHAR(20) , 



  "CCODE" VARCHAR(10) ) ;
3.0 Creating the adapter project in WebSphere Integration Developer 

You create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > Other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.

[image: image16.png]2 EEER ]
8 Enerre Aot
5 poptesir lst ot

New > |

3 £ Projects
55 Dynemic ieb Pr R
© OtherProjects | Expartoe b
6 WebServices | L
€D Databases

€D Database Servers

s It
Deploy 1T





Figure 16
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 17
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 18 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 19
2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 20
3. Click the “Add External JARs” button in the JAR Selection window that opens up, click the Browse button and navigate to the driver jar, then click Open.
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Figure 21
4. This adds the driver jar to the build path.
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Figure 22
5. Click OK. 
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Figure 23
5.0 Scenario:  Using an XA data source to perform XA transactions.
5.1 Configuring the adapter for outbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 24
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 25
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. Provide this information in the next wizard page.
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Figure 26
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the ‘Customer’ table:

1. In the Find and Discover Enterprise Services screen, there are the Execute Query and Edit Query buttons. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. Clicking the Execute Query button will list the tables, stored procedures, etc, sorted by schema name. 

[image: image27.png]Find and Discover Enterprise Services

To discaver cbi
and then press "Execute Query". Once dscovered, pres
the objects to be mported.

‘add o mport st to specify

1o e et syte, e » uery b resig g G IE;I?

Query:

[Sems s it

Executs Query.

Objects discovered by query:

tored Procedures

T <Execit 2 query to papulate this view with discovered cbiects, >

0 A o port

Objects to be imperted:

Edit Query,

Fiter
Clear Fiter

DELE

| OLLE B

Remove

o i

Cancel





Figure 27


2. Click the Execute Query button. This will list the tables, stored procedures, etc, sorted by schema name.
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Figure 28
3. In the “Objects discovered by query” list, expand ADDCUSER > Tables, choose the Customer table and click the Add to import list button. 
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Figure 29
4. The table is  listed in the ‘Objects to be imported:’ box. Click the Next > button.
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Figure 30
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Outbound, keep the default values for Namespace and Max Records fields. 
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Figure 31
2. Click the Next > button. 
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Figure 32
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next
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Figure 33
5. In the New Module screen, type JDBCXA in the Module Name field, then click Finish. Also, uncheck the Open module assembly diagram checkbox.
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Figure 34
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. For outbound processing, the properties are displayed for the Managed (J2C) connection factory and Resource adapter properties. Required property fields are marked with an asterisk.
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Figure 35
7. Fill in details for the required properties. From the non-required properties, enter values for Username and Password. The other non-required properties may be left blank. You need to set the JNDI name created earlier in the Data Source JNDI Name field. The name is case-sensitive.
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Figure 36
8. You need to provide values only the properties marked with an asterisk. All the properties can be left as it is. In addition, if you want the adapter log and trace files to be generated, you can enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. 
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Figure 37
9. Click Finish.
10. Verify the results as given in the figure below.
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Figure 38
5.2 Setting up the components to be part of the XA environment

Next, we add components and set transaction specific properties on them so that they form part of the XA environment. 
1. Open the Assembly Diagram. It shows the JDBCOutboundInterface that was generated when the artifacts were generated in section 5.1
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Figure 39
2. Now, we create two components. In the Assembly diagram window, click on the first icon in the panel, as shown in the figure below. Among the options available on clicking the first icon, choose ‘Component (with no implementation type)’ and click anywhere on the Assembly diagram window.
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Figure 40
3. A component named Component1 is created in the Assembly diagram. Similarly, add component2. 
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Figure 41
4. We need to wire Component1 to Component2 and Component2 to JDBCOutboundInterface. We need to create interface for Component1 and Component2. The interface for Component1 will have a method that takes in a data object of type Source, which we’ll create later. This BO named ‘Source’ will have all the attributes of the Customer BO we generated earlier. Also, it will have some additional attributes that will help decide the appropriate method to be called on the adapter. We will pass the Customer BO generated from the Source BO and pass it as an input parameter to interface method in Component2. This method takes the Customer BO as an input parameter. Component2 will then call the appropriate method on the JDBCOutboundInterface. 
5. Now, wire Component2 to the JDBCOutboundInterface by dragging the mouse pointer from the rear end of Component2 to the front end of JDBCOutboundInterface. 
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Figure 42
Note: Before the preceding screen, i.e., before wiring you will see the following screen. Click OK here.
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Figure 43


6. Right click on Component2 and click Add ( Interface
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Figure 44
7. In the Add Interface window, click New.
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Figure 45
8. In the New Interface Wizard, enter CustomerInterface as the interface name. Click Finish. Click on the Save button in the toolbar to save the CustomerInterface. 
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Figure 46
9. We have to add a method to the CustomerInterface, we’ll add it later.
10.  Next, wire Component1 to Component2.
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Figure 47
11. We need to create an interface for Component1 now. But before we do that, we’ll create the Source BO that will be used as the input for the Component1 interface method. 

12.  To create a new BO, in the Business Integration view, right click on Data Types ( New ( Business Object.
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Figure 48
13. Enter the name as Source in the New Business Object window.
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Figure 49
14.  The Source BO shows up on the right with no attributes in it. Click on the ‘Add an attribute to a business object.. ’ button. 
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Figure 50
15.  An attribute named attribute one is added to the BO. You can re-name it. 
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Figure 51
16.  Similarly, add all the attributes to the BO as shown in the figure BO. When all attributes have been added, click on the Save button in the toolbar to save the BO.
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Figure 52
Note: The attributes pkey, fname, lname and ccode are the attributes that exist in the Customer BO as well. The attribute ‘operation’ is to specify the method to be called on the adapter. For the current scenario, we only support the following values for this attribute: Create, Update, Delete, Retrieve. The namespace and objectName attributes are needed for the Component1 implementation to generate the Customer data object to be passed to Component2.
17.  Now create an interface for Component1 by right clicking on Component1 and choosing Add ( Interface. In the New Interface window, enter the name as TriggerInterface.
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Figure 53
18.  Next we’ll add a method to the TriggerInterface. Click on Component1 and in the Properties tab below, click on Details.
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Figure 54
19.  Expand Interfaces, right click on TriggerInterface and choose Open Interface.
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Figure 55
20.  The TriggerInterface window opens up.
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Figure 56
21.  Click on the ‘Add One Way Operation’ button
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Figure 57
22.  It shows the default method name as operation1. Re-name it to start and choose the type for input1 as Source. Save the TriggerInterface by clicking on the Save button in the toolbar.
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Figure 58
23.  Next, we’ll add a method to the CustomerInterface. Click on Component2 and in the Properties tab, click on Details. Expand Interfaces, right click on CustomerInterface and click Open Interface. Click on the ‘Add one way operation’ button, re-name the method to invoke and the type for input1 to AddcuserCustomerBG. Save CustomerInterface by clicking on the Save button.
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Figure 59
Note: The type AddcuserCustomerBG would have a different name depending on the schemaname. The current scenario has Addcuser as the schema name.

24.  Next, we generate java implementations for both Component1 and Component2. The java classes will contain the implementation for interface methods of Component1 and Component2 respectively.
25.  Right click on Component1 and choose Generate implementation ( Java. 
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Figure 60
26. In the Generate Implementation window, choose default package and click OK.

27. An Implement As… window comes up, click No. 
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Figure 61
28. The generated class contains a method named start(). We need to provide our implementation for this method. Replace the start method with the code given below. Also, add the following import statement in the java class: import com.ibm.j2ca.base.AdapterBOUtil;
public void start(DataObject input1) {


//TODO Needs to be implemented.


// Create CustomerBO


String adapterNamespace = input1.getString("namespace");


String objName = input1.getString("objectName");


DataObject customerBO = null;


try


{



customerBO = AdapterBOUtil.createBusinessObject(adapterNamespace, objName);


}


catch(Exception ex)


{



System.out.println("Invalid value provided for Namespace and/or ObjectName: " + ex.getMessage());



ex.printStackTrace();


}


if (customerBO != null)


{



DataObject customerBG = customerBO.getContainer();



System.out.println(" *** Customer Object Initialized *** ");



// Populate CustomerBO



String operation = input1.getString("operation");



if (operation.equalsIgnoreCase("create"))



{




customerBG.set("verb", operation);



}



if (operation.equalsIgnoreCase("update"))



{




customerBG.set("verb", operation);



}



if (operation.equalsIgnoreCase("delete"))



{




customerBG.set("verb", operation);



}



customerBO.set("pkey", input1.getString("pkey"));



customerBO.set("fname", input1.getString("fname"));



customerBO.set("lname", input1.get("lname"));



customerBO.set("ccode", input1.get("ccode"));



System.out.println(" *** Customer Object created *** ");





//Invoke Customer JDBC Outbound Adapter



Service customerService = locateService_CustomerInterfacePartner();



customerService.invoke("invoke", customerBG);


}



}

After replacing the code, click on the Save button to save the java class.

29. Now, generate java implementation for Component2 and replace the code for the invoke method with the one given below
public void invoke(DataObject input1) {


//TODO Needs to be implemented.


Service customerService = locateService_JDBCOutboundInterfacePartner();


//Check the verb and call the appropriate method


String verb = input1.getString("verb");


if (verb.equalsIgnoreCase("create"))


{



customerService.invoke("createAddcuserCustomer", input1);


}


if (verb.equalsIgnoreCase("update"))


{



customerService.invoke("updateAddcuserCustomer", input1);


}


if (verb.equalsIgnoreCase("delete"))


{



customerService.invoke("deleteAddcuserCustomer", input1);


}


if (verb == null || verb.equals(""))


{



customerService.invoke("retrieveAddcuserCustomer", input1);


}

}


After replacing the code, click on the Save button to save the java class.

30.  Next, we set the transaction properties for Component2 and JDBCOutboundInterface. 
31. Click on Compoent2 and in the Properties tab, click on Implementation.
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 Figure 62
32.  In the figure above, in the Qualifiers tab, click on the Add button. In the Add Qualifiers window, choose Transaction and click OK.
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Figure 63
33.  In the Qualifiers tab, click on Transaction and choose Global as the transaction type.
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Figure 64
34. Click on Component2 and in the Properties tab, click on Details. Expand Interfaces ( CustomerInterface

[image: image65.png]=] 53 Problems | Servers | Console

Description {7, Component: Component2 (No Implementation)

Dot = et [ Quelfirs vt Honker |

el =) Quality of Service (QUS) Qualifiers

& B References
3 Joacoutoundinte| 7

Properties




Figure 65
35.  In the figure above, in the Qualifiers tab, click on the Add button. In the Add Qualifier window that opens up, select Join transaction and click OK.
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Figure 66
36.  In the Qualifiers tab, click on Join transaction and choose the value as True.
37.  Now, click on the JDBCOutboundInterface and in the Properties tab, click on Details. Expand Interfaces ( JDBCOutboundInterface
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Figure 67
38. In the above figure, in the Qualifiers tab, click on Add button. In the Add Qualifier window, choose Join transaction and click OK.
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Figure 68
39.  In the Qualifiers tab, click on Join transaction and choose the value as True.
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Figure 69
40. This is how the module looks after adding the components and their interfaces. 
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Figure 70
5.3 Deploying the scenario module to the test environment
Next, we install the SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 
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Figure 71
3. When the server status is Started, right-click on the server, and then select Add and remove projects. 

[image: image72.png]Properties | Problems |41 B

N

Restart »
stop
&8 Disconnet
0 Publsh
Monitoring »

Run universaltest client

Restar uiversal est clnt
un adninsratve conscle
[ ——

) Creste tables and data sources




Figure 72
4. In the Add and Remove Projects screen, select JDBCXAApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 73
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.2.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
5.4 Testing the assembled adapter application  
Test the assembled adapter application using the WebSphere Integration Developer integration test client.  
 

1. Select the Module you want, right-click on it, and select Test > Test Module.
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Figure 74
2. Choose Component1. The interface and operation are chosen by default. 
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Figure 75
3. Enter the values as shown in the figure below. Set the operation value to ‘Create’  (This means the create operation would be called on the adapter.). Set the objectName value to AddcuserCustomerBG. This name will be different depending on the schema name. In this scenario, the schema name is Addcuser. Set the namespace attribute to the target namespace value for the AddcuserCustomerBG. You can open the AddcuserCustomerBG.xsd in a text editor and check the value for the target namespace. It should be something like http://www.ibm.com/xmlns/prod/websphere/j2ca/jdbc/addcusercustomerbg.
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Figure 76
4. Execute the service by clicking Continue. 
5. In the “Select Deployment location” screen, select the server, then click Finish. 
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Figure 77
6. Check the output of the service, and check the data in the EIS to ensure it matches expected values.
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Figure 78
6.0 Troubleshooting
6.1 Test connection failure

If the data source test connection fails, ensure that the Class path property in General properties set for the data source is proper. It should have the path of the driver jar file. 
6.2 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The username/password specified is not proper. 
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