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Title: Using Data Source with Prepared Statement cache in JDBC JCA Adapter.
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1.0 Introduction

The JDBC Resource Adapter (RA) enables the bi-directional connectivity for integration to any database application. The exchange of data for such applications happens at the database level. Updates to database may need to be applied to another EIS and changes in an EIS may need to be applied to a database. The JDBC RA can integrate with any database, as long as there is a JDBC driver that supports the JDBC 2.0 or higher Specification, available for the database. Examples of such databases include Oracle, Microsoft SQLServer, DB2, Sybase, Informix etc.  

The document demonstrates one scenario:

· Using Data Source with Prepared Statement cache in JDBC JCA Adapter.  
2.0 Pre-requisites to run the scenario

2.1 Creating the authentication alias

The authentication alias needs to be set since the data source created in the next section uses the username/password set in the authentication alias to connect to the database. Here are the steps to set the authentication alias in WPS admin console. 

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.
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Figure 1

2. To set the authentication alias, we need to start the server. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start
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Figure 2
3. When the server status is Started, right-click on the server, and then select Run administrative console.
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Figure 3
4. Log in to the administrative console by clicking the “Log in” button. 
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Figure 4
5. Click on Security ( Global Security
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Figure 5

6. On the right, click on JAAS Configuration under the Authentication heading
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Figure 6

7. Click on the J2C Authentication data link. It gives the list of existing aliases.
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Figure 7
8. If the SCA_Auth_Alias entry does not exist, click New and create it; else, click on SCA_Auth_Alias and set the proper username/password that can connect to the database. Click OK.
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Figure 8

9. A message appears asking to Save changes to the master configuration. Click on the Save link.

[image: image9.png]B Messages

& changes have been made to your local configuration. Click
Save'to 3pply thanges to the master configuration.

D The server may nesd to be rastarted for these changss to take
affect

Global security > J2EE Connector Architecture (J2€) authentication data entries

Spedfies a list of user IDs and passuords for Java 2 connactor sacurlty to uss,

Prefarences

Select Alias & User ID ¢ | Daseription ¢

[ | eecEsentCollectormsauthenticationalias widiiods serverd| vid Authenticstion
Slias for
Business
Pracass
Chorsographer
Evant Collactar

Scn auth alias tasser | This s the
=] alias used by
e ot

2 cacured
Steus

[ | sidCelyepeauthpatasliasins uidods servert wid Autharization
Alias for
Praces:

Chorasgrapher





Figure 9
10. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 10

Note: We have created an authentication alias that we will use when we configure the adapter properties. We need to re-start the server for the changes to take effect.

2.2 Creating the data source
We will create a datasource in WebSphere Application Server using which the adapter will connect to the database. Here are the steps to create the data source in WPS admin console. This data source will be used later when generating the artifacts for the module. 

Note: We will be using Oracle as the database and oracle thin driver, ojdbc.jar 
11. In the admin Console, click on Environment ( WebSphere Variables
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Figure 11

12. On the right, click ORACLE_JDBC_DRIVER_PATH and specify the path of ojdbc.jar in the value text field. Click Ok.
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Figure 12

13.  A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 13

14. The next page shows the number of documents that have changed. Click on the Save button.
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Figure 14

15. Now, click on Resources ( JDBC Providers
[image: image15.png]welcome

Guided Activtiss

servars

Applications
B Resources

M8 Providers

IDBC Providers

Resource Adaptars

Asynchronous beans
Schadulars

Cache instances

Object pool managers

Remate Artfacts
Wil Providers

URL Providers

Resource Enviranment Providsrs
Extended Messaging Provider
St plug-in provider

WebSphere Business Integration
Adapters

Comman Event Infrastructurs
Provider

Security

Enuiranmant





Figure 15
16. On the right, click on the New button on the JDBC providers window.
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Figure 16
17. Choose the values for steps 1 to 3 as shown in the figure below. Choose an Oracle database with Connection pool data source for the Oracle JDBC driver. 
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Figure 17
18. Click Next. In the General Properties, enter the following value for Class path: $(ORACLE_JDBC_DRIVER_PATH)/ojdbc14.jar, where $(ORACLE_JDBC_DRIVER_PATH) is the runtimes lib path. Since we’ve added the ojdbc14.jar to this path, we specify that path here. Click the ‘Apply’ button.
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Figure 18
19. After you click on Apply, the Data sources links under the Additional Properties heading are enabled. Click on the first Data sources link. Click on the ‘New’ button.
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Figure 19
20. Enter the value for JNDI name as shown in the figure. 
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Figure 20
21. Set the Component-managed authentication alias to the one created in the earlier section. Also provide the appropriate URL value in Oracle data source properties.  Click the OK button.
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Figure 21
22. Now, click on WebSphere Application Server data source properties under Additional Properties.
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Figure 22
23. Enter value 20 in Prepared Statement Cache and click OK.
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Figure 23
24.  A message appears asking to Save changes to the master configuration. Click on the Save link.
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Figure 24
25.  The next page shows the number of documents that have changed. Click on the Save button.
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Figure 25
26.  In the next window, choose the checkbox for the newly created data source and click on the Test connection button.
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Figure 26
27.  The connection should succeed as indicated by the message shown in the figure below. For any problems with the Test connection, refer Troubleshooting section 6.1
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Figure 27
Note: The data source is created with prepared statement cache value, which will be used by the adapter to connect to the database. 

2.3  Creating the tables
The sample has been created for Oracle database. The following table needs to be created in the database to run the scenario. 
a. Script for creating the tables

CREATE TABLE CUSTOMER  (



  PKEY VARCHAR2(10) NOT NULL PRIMARY KEY, 



  FNAME VARCHAR2(20), 



  LNAME VARCHAR(20) , 



  CCODE VARCHAR2(10) ) ;
CREATE SEQUENCE EVENT_SEQ INCREMENT BY 1 START WITH 1 MINVALUE 1 CACHE 20 ;
CREATE TABLE WBIA_JDBC_EVENTSTORE
(


EVENT_ID INTEGER NOT NULL 
PRIMARY KEY,


XID



VARCHAR2(200),


OBJECT_KEY


VARCHAR2(80)

NOT NULL,


OBJECT_NAME

VARCHAR2(40)

NOT NULL,


OBJECT_FUNCTION

VARCHAR2(40)

NOT NULL,


EVENT_PRIORITY    

INTEGER


NOT NULL,


EVENT_TIME


TIMESTAMP,



EVENT_STATUS

INTEGER


NOT NULL,


EVENT_COMMENT

VARCHAR2(100)

);

b. Script for creating triggers for Inbound 

CREATE OR REPLACE TRIGGER EVENT_CREATE AFTER INSERT ON CUSTOMER 

REFERENCING OLD AS OLD NEW AS N 

FOR EACH ROW 

BEGIN

INSERT INTO wbia_jdbc_eventstore (event_id,object_key, object_name,object_function, event_priority, event_status)

VALUES (event_seq.nextval,:N.pkey, 'RtasserCustomerBG', 'Create', 1, 0);

END;

CREATE OR REPLACE TRIGGER EVENT_DELETE AFTER DELETE ON CUSTOMER 

REFERENCING OLD AS OLD NEW AS N 

FOR EACH ROW 

BEGIN

INSERT INTO wbia_jdbc_eventstore (event_id,object_key, object_name,object_function, event_priority, event_status)

VALUES (event_seq.nextval,:N.pkey, 'RtasserCustomerBG', 'Delete', 1, 0);

END;
CREATE OR REPLACE TRIGGER EVENT_UPDATE AFTER UPDATE OF PKEY,  CCODE,    FNAME, LNAME ON CUSTOMER 

REFERENCING OLD AS OLD NEW AS N 

FOR EACH ROW 

BEGIN

INSERT INTO wbia_jdbc_eventstore (event_id,object_key, object_name, object_function, event_priority, event_status)

VALUES (event_seq.nextval,:N.pkey, 'RtasserCustomerBG', 'Update', 1, 0);

  END;

c. Inserting data in Customer table 
Insert/Update/Delete 100 or more records in Customer table. 
You can use Stored Procedure defined below to insert the data:

CREATE OR REPLACE PROCEDURE RTASSER.INSERTCUSTRECORDS AS

BEGIN

  FOR cntr in 1..100 LOOP

INSERT INTO RTASSER.CUSTOMER (pkey,ccode,fname,lname) values(to_char(cntr), 'ANITA','MEHTA','IBM');

 End Loop;

END;

 Verify that same numbers of event records are inserted into WBIA_JDBC_EVENTSTORE table.
3.0 Creating the adapter project in WebSphere Integration Developer 

Create an adapter project by importing the resource adapter archive (.RAR) file into the Connector Projects folder in WebSphere Integration Developer. The following steps describe how to do this. 
1. Launch WebSphere Integration Developer by clicking Start > Programs > IBM WebSphere > Integration Developer V6.0.2
2. In WebSphere Integration Developer, switch to the J2EE perspective. To do this, click Window > Open perspective > other. In the Select perspective screen, select “Show all,” then select J2EE from the list and click OK.

3. Next we import the connector rar file. Right-click the Connector Projects folder, then select Import > RAR file.
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Figure 28
4.  In the Connector Import screen, click the Browse button next to the “Connector file” field, then navigate to the adapter .RAR file. Uncheck the ‘Add module to an EAR project’ checkbox.
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Figure 29
5.  Accept all other defaults, then click Finish. A new connector project named CWYBC_JDBC appears under the Connector Projects folder.
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Figure 30 – Result of the import operation.
4.0 Adding external software dependencies 

The following instructions describe how to add the database driver to your adapter project in WebSphere Integration Developer. We need to add the driver so that the adapter can connect to the database and the business objects can be generated for the tables/stored procedures, etc.
1. In the J2EE perspective of WebSphere Integration Developer, right-click the CWYBC_JDBC adapter project, then select Properties.
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Figure 31
2. In the Properties screen, select Java Build Path in the navigation sidebar. 

Click the Libraries tab.
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Figure 32
3. Click the “Add External JARs” button in the JAR Selection window that opens up another window, navigate to the driver jar and then click Open.
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Figure 33
4. This adds the driver jar to the build path.
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Figure 34
5. Click OK. 
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Figure 35
5.0 Scenario:  Using Data Source with Prepared Statement cache in JDBC JCA Adapter.
5.1 Configuring the adapter for inbound processing 

Run the enterprise service discovery wizard. This process includes generating the business objects and setting adapter configuration properties via the enterprise service discovery wizard. 

5.1.1 Generating business objects using the enterprise service discovery wizard

Follow these instructions to launch the Enterprise Service Discovery wizard.
1. Make sure you are in the Business Integration perspective. To do this, select Window > Open Perspective > Other. In the Select Perspective screen, select Business Integration (default). 

2. In WebSphere Integration Developer, launch the Enterprise Service Discovery wizard by selecting File -> New -> Enterprise Service Discovery.
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 Figure 36
3. Select the JDBC EMD Adapter (version 6.0.2)
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Figure 37
4. Click the NEXT > button.
5.1.1.1 Setting connection properties for the enterprise service discovery wizard 

To connect to the database, the following information is necessary: username, password, database url and jdbc driver class. Please check the driver manual for the appropriate values for driver url and driver class. Provide this information in the next wizard page.
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Figure 38
Click the NEXT> button.
5.1.1.2 Selecting the business objects and services to be used with the adapter

Follow these steps to select the ‘Customer’ table:

1. In the Find and Discover Enterprise Services screen, there are the Execute Query and Edit Query buttons. You could use Edit Query to narrow the list of schemas, nodes, or objects displayed in the tree structure. For this scenario, you do not need to use filtering. Also, you can use Edit Query to add business object application specific information. Clicking the Execute Query button will list the tables, stored procedures, etc, sorted by schema name. 
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Figure 39


2. Click the Execute Query button. This will list the tables, stored procedures, etc, sorted by schema name.
3. In the “Objects discovered by query” list, expand RTASSER > Tables, choose the Customer table and click the Add to import list button. 

[image: image40.png]@ Enterprise Service Discovery

Find and Discover Enterprise Services

obijects an the enterprie system.

Query:

LUse "Bt Query” o create & query and press "Execute Query"to dcover matching IE;]?

[=chema Name FitermulTypes=Tale, Types=iens, 753

Executs Query.

Objects discovered by query:

tored Procedures, Ty Edit Query,

OET
0 eLoTaBLE
D
compLex
astiFo
{CilsTovER]
© CustovERTY
cusTomERs®
@ ourmy
EWPLOTEE
© EvpLoveEL

1 Addtoimport st

Objects ta be imperted:

]

<Back

(] e





Figure 40
4. The table is listed in the ‘Objects to be imported:’ box. Click the Next > button.
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Figure 41
5.1.1.3 Generating business object definitions and related artifacts

Follow these steps to generate the business object definitions.
1. In the Configure Objects screen, choose the service type as Inbound, and keep the default value for Namespace. 
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Figure 42
2. Click the Next > button. 
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Figure 43
3. In the Generate Artifacts screen, click the New button next to the Module field to create a new module.
4. If the New Project Integration screen appears, select Create a module project, then click Next
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Figure 44
5. In the New Module screen, type JDBInboundTest in the Module Name field. Uncheck the Open module assembly diagram checkbox and then click Finish.
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Figure 45
6. In the Generate Artifacts screen, select the Use discovered connection properties radio button.
This enables you to set configuration property values that will be used to connect to the enterprise information system at run time. 
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Figure 46
7. Scroll down and enter values in username, password under User Credential Properties, DataSourceJNDIName under Machine Credential Properties and  Event Order By, Event Table Name under Miscellaneous Properties as shown in the figure. 
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Figure 47
8. Now, scroll down to Resource Adapter Properties and enter values for the log and trace file properties. The log file gives the details of the exceptions that occur during the adapter processing. Also, specify the database vendor as oracle.
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Figure 48
9. Click Finish.
10. Verify the results as given in the figure below.
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5.2 Setting up the components to be part of the Inbound Environment
Next, we add components and set transaction specific properties on them so that they form part of the Inbound environment. 
1. Open the Assembly Diagram. It shows the JDBCInboundInterface that was generated when the artifacts were generated in section 5.1
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Figure 50
2. From the palette, select the Component (with no implementation type) icon, then select the Java Component and drop it on the Assembly Diagram.
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Figure 51
3. A component named Component1 is created in the Assembly diagram. 
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Figure 52
4. Now, wire JDBCOutboundInterface  to the Component1 by dragging the mouse pointer from the rear end of JDBCOutboundInterface to the front end of Component1.
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Figure 53
Note: Before the preceding screen, i.e., before wiring you will see the following screen. Click OK here.
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Figure 54


The Assembly diagram now looks like the figure below.
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Figure 55
5. Now generate the implementation for Java Component. Right click the Java Component1, select Generate Implementation from the context menu.
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Figure 56
6.  Highlight the default package and select OK.
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Figure 57
7.  The Java Editor will open with the Component1Impl.java file.
[image: image58.png]) #ssembly Diagram: JDECInboundTest | 1] Companenttimpl java &7

backage sca.component . Java. tmpl;
» import. common3 . sdo. Davaobiect:[]

“public class Componentilmpl {

v g
* Default constructor.
"
v public Componentilmpl(} {
super () ;
)
v g
* Return a reference to the component service instance for this implementation
* class. This wethod should be used vhen passing this service to a partner reference
® or if you uant to invoke this component service asynchronously.
* Bgenerated {com. ibm.ubit. java)
"
v private Object getHyService() (

return (Object] ServiceNanager.INSTANCE.locateService ("self"):





Figure 58
8. Scroll down and locate the createRtasserCustomer(DataObject createRtasserCustomerInput) method that needs to be implemented. Paste the following code into the method so the complete method looks as follows:
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Figure 59
9.  Scroll down and locate the updateAppCustomer(Object createCustomerInput) method that needs to be implemented. Paste the following code into the method so the complete method looks as follows:
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Figure 60
10. Scroll down and locate the deleteAppCustomer(Object createCustomerInput) method that needs to be implemented. Paste the following code into the method so the complete method looks as follows:
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Figure 61
11.  Save your work by selecting File -> Save from the top menu, or using the shortcut key sequence Ctrl + S. Close the file. 

12. Close and save the Assembly Diagram. Wait for the workspace to complete building.
5.3 Deploying and Testing the scenario module to the test environment
Next, we install the SCA module in the WebSphere Integration Developer integration test client. To do this, you must add the SCA module you created earlier to the server using the Servers View in WebSphere Integration Developer. 
Steps for adding the SCA module to the server:

1. In WebSphere Integration Developer, switch to the Servers View by selecting Windows > Show View > Servers.

2. In the Servers tab in the lower-right pane of the WebSphere Integration Developer screen, right-click on the server, and then select Start 

3. When the server status is Started, right-click on the server, and then select Add and remove projects. 
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Figure 62
4. In the Add and Remove Projects screen, select JDBCInboundTestApp, click Add. The project moves to the ‘Configured Projects’ list from the ‘Available Projects’ list.
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Figure 63
5. Click Finish. This deploys the project on the server. For any problems adding the project check Troubleshooting section 6.2.

The Console tab in the lower-right pane displays a log while the module is being added to the server.
6.  In the console view, you will see the messages that the application has successfully started and has received and processed the inbound events which were created in WBIA_JDBC_EVENTSTORE table. (These messages are also reflected in WPS_HOME\pf\wps\logs\server1\Systemout.log).

Logs for the first event delivered
3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O CREATE Customer

[3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O Customer Key:1

[3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O Customer Code:ANITA

[3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O Customer fname:MEHTA

[3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O Customer lname:IBM

[3/20/07 11:49:15:297 PDT] 00000056 SystemOut     O CREATE End

[3/20/07 11:49:15:297 PDT] 00000055 monitoring    I   Used cached MES:{http://www.ibm.com/xmlns/prod/websphere/scdl/6.0.0}Component
Logs for the last event delivered
[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O CREATE Customer

[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O Customer Key:100

[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O Customer Code:ANITA

[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O Customer fname:MEHTA

[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O Customer lname:IBM

[3/20/07 11:49:39:072 PDT] 00000055 SystemOut     O CREATE End

[3/20/07 11:49:39:172 PDT] 00000053 ResourceAdapt I com.ibm.j2ca.extension.eventmanagement.internal.EventSender sendEvent() CWYBS0505I: The event has been delivered.  Explanation=An event was delivered.  UserAction=No action is required
7. Note the time difference between first event and last event. In this case,

it is ~24 seconds. This is the approximate time to retrieve and update 100 records in the table.

8. Open the Assemble Diagram, click on JDBCInboundInterface and then the properties tab at the bottom. Select EndPoint configuration in the properties tab.
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Figure 64

9. Save the Assemble Diagram and build the workspace.

10.  Clean CUSTOMER and WBIA_JDBC_EVENT_STORE tables in database and insert/update/delete the 100 records in Customer table.

11. Click on Servers tab and Restart the server.

12. The similar log messages will shown as in step 6 in the console view. Repeat the step 7 to find out the time taken to get 100 events from database. Here, the time difference is ~57 seconds.
Logs for the first event delivered
[3/20/07 11:33:41:365 PDT] 00000057 ResourceAdapt I com.ibm.j2ca.extension.eventmanagement.internal.EventSender sendEvent() CWYBS0505I: The event has been delivered.  Explanation=An event was delivered.  UserAction=No action is required.

[3/20/07 11:33:41:375 PDT] 0000005a monitoring    I   Lookup MES:{http://www.ibm.com/xmlns/prod/websphere/scdl/6.0.0}Component

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O CREATE Customer

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O Customer Key:1

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O Customer Code:ANITA

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O Customer fname:MEHTA

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O Customer lname:IBM

[3/20/07 11:33:41:415 PDT] 00000059 SystemOut     O CREATE End

[3/20/07 11:33:41:435 PDT] 0000005a monitoring    I   Used cached MES:{http://www.ibm.com/xmlns/prod/websphere/scdl/6.0.0}Component
Logs for the last event delivered
       [3/20/07 11:34:38:677 PDT] 00000059 ResourceAdapt A com.ibm.j2ca.extension.eventmanagement.internal.EventSender deliverEvent() CWYBS0505I: Logging event before delivering to the endpoint.  Explanation=Logging event before delivering to the endpoint.  UserAction=No action is required.
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O CREATE Customer
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O Customer Key:99
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O Customer Code:ANITA
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O Customer fname:MEHTA
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O Customer lname:IBM
[3/20/07 11:34:38:728 PDT] 0000005c SystemOut     O CREATE End
13. Compare the time noted down in steps 7 and 12.

14. Clearly, time taken is less in the first case where Data Source with Prepared Statement Cache is used.

Note: Ensure that the database driver jar exists in the runtimes lib folder of WebSphere Process Server before starting the server. 
6.0 Troubleshooting
6.1 Test connection failure

If the data source test connection fails, ensure that the Class path property in General properties set for the data source is proper. It should have the path of the driver jar file. 
6.2 Adapter fails to start up 
If the adapter fails to start up, refer the adapter log file to find the cause of failure. Here are some of the common reasons why the adapter would fail to start up. 
1. Error: Driver class does not exist. 

Cause: The database driver jar does not exist in the runtimes lib folder. 

2. Error: Logon error; invalid username/password.

Cause: The username/password specified is not proper. 
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