
Welcome to IBM Screen Customizer Help

Click any help topic in the Table of Contents to the left. 

Click Basic Customization Steps for an overview of how to customize host screens and templates.

Click  in the top, right corner of any help topic to return to this overview. 

When you see this icon 
in the help: The associated information:

Displays how to use help.

Supplements important points in the main text.

Provides hints to help apply the techniques and procedures described in the main 
text.



Introducing Screen Customizer

The IBM Screen Customizer for Host Integration (Screen Customizer) provides a graphical user 
interface for IBM Host On-Demand or IBM Personal Communications 3270 and 5250 sessions. 
Extensive customization capability is provided that does not require programming or modification of 
host applications.

There are three components: 

l Administrator - is an active host session that lets you capture screens for customization by 
the Customization Studio, and test customizations made using the Customization Studio. 

The Administrator can be installed and run only on a Windows 95, 98 or NT workstation. It 
cannot be downloaded from a Web server.

l Customization Studio - lets you create customized versions of host screens captured by the 
Administrator. It enables you to add helpful objects (such as Web-link buttons, radio buttons, 
and choice boxes) to your host screens and to global templates, which creates extra, 
customizable space around your host screens and can be easily applied to all of your screens 
and updated. 

The Studio can be installed and run only on a Windows 95, 98 or NT workstation and does 
not require a host connection.

l Client - resides on a Web server or a client workstation and presents a default or customized 
graphical interface for host sessions. The Client is usually integrated with a Host On-Demand 
or Personal Communications session but can be started independently. 

To install the Administrator or Client, you must have either Host On-Demand or Personal 
Communications installed. The installation program detects which product you have and installs the 
appropriate files. Installation steps are provided in the Installation Guide.

Related topics:

l Basic Customization Steps 
l Introducing the Customization Studio 
l Introducing the Administrator 



Introducing the Administrator

The Administrator lets you do the following: 

Capture screens for customization by the Customization Studio.

Test customizations made using the Customization Studio.

Modify settings for this host session. You can set up this session for the following:

l Show/Hide the toolbar, keypad, hotspots, menu buttons and status bar 
l Customize the toolbar by adding buttons 
l Set file transfer defaults 
l Set host screen colors 
l Remap the keyboard 
l Set the tab-movement mode 
l Set the appearance of menu, valid-value, image and Web-link buttons 

Related topics:

l Basic Customization Steps 
l Introducing the Customization Studio 

Attention: 
The Administrator or Studio functions will not work properly if the Host On-Demand cached client is installed. 
To remove the cached client, follow the appropriate procedure in the Host On-Demand Getting Started 
Guide.



Basic Customization Steps

Welcome to the IBM Screen Customizer for Host Integration. Follow the steps to the left to get 
started with screen customization. The readme contains late-breaking product information.

1. Create a global template

With Screen Customizer V2.0, you can create a template that can be automatically associated with 
all of your host screens--customized or not. This template allows you to specify the area reserved 
for your host screen as well as providing additional space for buttons, Web-links, and other custom 
objects. Using a global template, you can also specify the color, font, and button styles for all of 
these screens.

Best of all, whenever you customize this template, all changes are automatically applied to all 
screens associated with that template. You no longer have to modify each screen individually, as 
you did with Screen Customizer V1.0; you simply customize a template and all screens will be 
displayed with these customizations at run time.

To create a global template:

1. Click Start > Programs > IBM Screen Customizer > Customization Studio. 
2. Customize the template by changing the position of the host screen area on the display, 

adding objects, such as buttons and web links around the host screen area, and defining 
common colors, fonts, and keyboard remappings to be used for the display. 

3. Click File > Save As 
4. Type sc_global.tpl to have this template used as the default global template and click Save. 

More information

2. Start an Administrator session

The Administrator is an active host session that is used to capture host screens so that they can be 
modified in the Customization Studio. It is also used to test customizations.

If you are running Screen Customizer with Host On-Demand

1. Click Start > Programs > IBM Screen Customizer > Administrator or click here. 
2. Click Add Sessions, then right-click on the type of session you want to use and click Copy 

(you can use only 3270 or 5250 sessions with Screen Customizer). 
3. Configure the session and click OK. 
4. Double-click the icon to start the session. 

If you are running Screen Customizer with Personal Communications

1. Click Start > Programs > IBM Screen Customizer > Administrator. A list of the WS files in 
your Personal Communications \private directory is displayed. If you have WS files in any 
other directory, click Add Sessions and follow the directions on the window to add them to the 

You must have sessions already defined in Personal Communications.



list. 
2. Select one or more WS files. 
3. Click Start Session or double-click the WS file to start the session. 

More information

3. Capture screens to be customized

1. In the Administrator session, go the the screen that you want to customize. 
2. On the Administrator toolbar, click the Customize button or click File > Customize Screen. 
3. Type a screen ID and, optionally, a description. 
4. Click OK. 

More information

4. Customize the screen and save it

Use the Studio to customize individual host screens. You can create graphical interfaces that hide 
complexity, provide user friendly objects (such as buttons, radio buttons, check boxes, choice 
boxes, and images) and link to Web data. 

How you customize the screen is up to you; there are many possibilities. Following are some 
common tasks that can be done with the Studio. 

1. Hide any fields or data that the user doesn’t need. Be careful not to hide elements that you 
may need for your customization. 

a. Choose View > Fields. This will show all fields on the screen. 
b. Select all fields that you want to hide by holding down the Control key and clicking on 

the fields with the left-mouse button. 
c. Right-click on any of the selected fields and choose Hide. 

2. Convert input fields to objects. For example, if your screen contains an input field that accepts 
only the values 1, 2, and 3 which correspond to ’Create a New Account’, ’Query Account 
Information’, and ’Change Account Information’, consider converting this field to a choice. 

a. Right-click on the input field and select Convert > to Choice. 
b. Right-click the choice and click All Properties. 
c. In the Set Item field, type a brief description of the first function followed by a ’~’ and the 

corresponding number to be sent to the original host input field. For example, type: 

Create a New Account~1

d. Click Add. 
e. Repeat the above steps for the other choices. At run-time, the choice displays the 

descriptions and when a selection is made, the value after the ’~’ is placed in the host 
input field. 

f. If one of the values is frequently used, make it the default by highlighting it in the list. 
g. Click OK to finish setting the Choice properties. 

For a different presentation of the same input field options, try using a list. The decision to use 
one over the other is a matter of style and space considerations. If there are only a few valid 
values, you could also use radio buttons or a button corresponding to each possible choice.



3. Add buttons to perform common functions. Use buttons to send text to various host input 
fields and to execute common host commands, for example, Enter or F1. 

a. Click Create > Button and then click the left mouse button to place the button on the 
screen. 

b. Right-click the button and click All Properties. 
c. Type a new caption. 
d. Click the Macro tab. 
e. Type Hello world in the Edit Source field and click Add. The text appears in the Field 

Values box. 
f. Select the text in the Field Values box. Notice that the Link to Input Field or Parameter 

list box on the right becomes enabled. 
g. Select the input field in the Link to Input Field or Parameter list where you want the text 

sent. 

h. Select a function, such as Enter, in the Function Key list to send to the host at the end 
of the macro. 

i. Click OK or Apply. 

If you want to add an image to a button or change the color of the button, use an Image
button instead. If you want your button to open a URL in a browser, use a Web-link button.

4. Modify the layout of the customized screens. Move, align, and resize objects to create a 
cleaner, more user-friendly interface. Read Moving an object and the subsequent sections for 
more information on moving, aligning and resizing objects. 

5. When you are done, save the screen customizations by clicking File > Save. 

More information

5. Test your customized screen

Return to the Administrator. If you named your template sc_global.tpl or if you customized an 
individual screen, your customizations will automatically be applied to the screen you are working 
on. If you named your template something else, you need to do the following to have your 
customizations appear:

1. Click Test > View with different template. 
2. Click Enable. 
3. Type the name of the template. 
4. Click OK. 

More information

6. Apply the global template

If necessary, repeat the previous three steps to send text to other input fields.

Get-to-the-Point and Web-link buttons appear but are not operational in the Administrator.



If you named your template sc_global.tpl, it will automatically be applied to all screens globally. If 
you named your template something else, apply the template by adding a parameter to the HTML 
you use to start Screen Customizer.

More information 



Accommodating DBCS input

If you want to see double-byte-character-set (DBCS) characters on the host screen, you must set a 
DBCS host code-page in the session configuration window. This option, and the corresponding 
button on the toolbar, as well as the Display SO/SI button on the toolbar, are displayed only when 
you have set a DBCS code-page.

To display the DBCS input field, click View > Show DBCS Input. 



Changing the font

1. Click Edit > Preferences > Font. 
2. Choose from the Font and Size lists. Your changes are reflected beneath the Sample 

heading. 
3. If you want to use these type styles, click Bold, Italic, or both. 
4. Click OK. 
5. The screen is resized to accommodate your changes. 

True type fonts can appear proportional or not. It is better to use a font that is not proportional so that 
every letter will have the same width.



Changing screen colors

The Color Remap option allows you to change the foreground and background colors for all screens 
in the host application. To change a color on the screen: 

1. Click Edit > Preferences > Color. 
2. Select the type of field for which you want to change the color. 
3. Select either Foreground (text) or Background. 
4. Select one of the colors available from the Basic Color palette or create a unique color and 

add it to the palette. To create a custom color: 
1. Click a color and then adjust the numbers that represent the color by clicking the arrows 

or entering a number. Color changes are reflected in the selected field box. 
2. Click Add to Custom Colors. 
3. Click one of the blank Custom Colors boxes. Now you can use this color for other 

objects on the screen. 

To create a sixth custom color, you have to overwrite one of the other custom colors on the 
palette. Objects that use the overwritten color retain their color, but that color is no longer 
available. 

5. Repeat the steps above for each color you want to change. 
6. Click Defaults to return to the default colors. 
7. Click Apply to apply changes. Click OK to apply changes and return to the screen. 



Customizing buttons

You can customize the appearance of menu buttons as Ball, Standard, or Dynamic. For Valid Value 
and Image buttons, the appearance can be either Standard or Dynamic. Web-Link Buttons can be 
viewed as Standard, Dynamic, or Label. 

To select the appearance of a button, click View > button type (for example, Menu Buttons), > style 
(for example, Standard).

Selecting Inherit means that the appearance of these buttons will be inherited from other levels.



Showing hotspots

Click View > Show Hotspots to show or hide hotspots. Many keyboard functions that appear only as 
text on your screen are automatically converted to Hotspots. Clicking on a hotspot performs the 
same operation as pressing the corresponding function key on the keyboard. That corresponding 
function appears as a label on a Hotspot button.



Showing menu buttons

Click View > Show Menu Buttons to show or hide menu buttons. If Show Menu Buttons is enabled, 
menu options that appear on the screen are automatically converted to buttons. In order for a 
screen to be recognized as a menu screen, it must meet certain requirements, for example, it has to 
have only one input field, the word menu must appear, the word select must appear before the list 
of options, and there must be a number in front of each option. Clicking on a menu button selects 
the corresponding menu option.



File Transfer

You can transfer files between your workstation and S/390 systems running MVS/TSO, VM/CMS or 
MVS/CICS. You can also transfer files between your workstation and the Integrated File System 
(IFS) of OS/400 V3R7 or later.

l Transferring files
l Working with transfer lists 
l Setting the default transfer options 

Transferring files

1. Start a session with the host. 
2. Make sure that the correct host system and other options have been specified. 
3. Click Transfer > Send Files to Host or Receive Files from Host on the menu bar, or the Send 

or Recv button on the toolbar. 

4. Fill in the names of the PC and host files. You can click a Browse button to find a PC file or an 
OS/400 file. When you click in the box for the target file, a filename is automatically 
generated. 
If you want to transfer an existing list of files, click Open List and choose the list. 

5. Set the transfer mode. 
6. If you want to change any of the transfer options (parameters), click Options. 

7. Click Add to List; the filenames and transfer mode appear in the list box. 
8. If you want to transfer several files, repeat steps 4 - 7. 
9. To transfer the files in the list, click Send or Receive. 

10. To save the list, click Save List and enter a name for the list. 

Working with file transfer lists 

You can update or delete lists when the Send or Receive windows are open.

Updating a transfer list 

1. Click Open List and select the list you want to update; its contents appear in the Transfer List 
box. 

2. If you want to change an entry in the list, select the entry; its parts are displayed in the Add 
File to Transfer List box. 

3. Make the changes and click Update in List. 
You can also add files to the list. 
To remove a file from the list, select it and click Remove. 

4. Click Save List. 

Deleting a list

When sending a file to an MVS/TSO host partitioned data set, the data set must already exist on 
the host. 

The change applies only to file that is currently in the Add File to Transfer List box.

A list can be used only for the purpose for which it was created; that is, you cannot use a send list 
to receive files and, likewise, you cannot use a list created for MVS/TSO for VM/CMS transfers. 
The reason is that the options are often specific to host type and direction of transfer. 



n Click Delete List, select the list you want to delete, then click OK. 

More about file transfer

For S/390, file transfer uses the IND$FILE (SBCS) or APVUFILE (DBCS) program; for AS/400, no 
extra software is required.

The interface is the same in all cases except that, for OS/400, there is a button that lets you browse 
the IFS.

You can transfer a single file or a list of files and you can save the list for repeated use. You can 
also modify and delete lists. The same interface is used in all cases.

File transfer will work only if the host system screen has a command line available. 

Setting file transfer default options

Each host system has its own transfer options. 

n General 
n MVS/TSO 
n VM/CMS 
n CICS 
n OS/400 

To get to the default options: on the menu bar, click Edit > Preferences > File Transfer Defaults. 

Then do the following:

n On the General tab, set the correct host system for this session. If the host system is 
incorrect, transfer will fail because the wrong options are used. Change the other parameters 
as necessary. 

n To change any of the file transfer options, click the tab for the appropriate host system. For 
OS/400, VM/CMS and CICS, the first option must be preceded by an open parenthesis ’ ( ’. 

n Click OK when you finish. 

MVS/TSO

l Text send options 
l Text receive options 
l Binary send options 
l Binary receive options 
l Default transfer mode 
l Clear before Transfer 

VM/CMS

l Text send options 
l Text receive options 
l Binary send options 



l Binary receive options 
l Default transfer mode 
l Clear before Transfer 

CICS

l Text send options 
l Text receive options 
l Binary send options 
l Binary receive options 
l Default transfer mode 
l Clear before Transfer 

OS/400

l Text send options 
l Text receive options 
l Binary send options 
l Binary receive options 
l Default transfer mode 

General

The general settings for each host type include:

Host Type 
The type of host to which this session will connect. This determines which set of default 
options are used. 

Timeout (in seconds) 
This option specifies the length of time (in seconds) that the workstation waits for a response 
from the host. Only numeric characters 0-9 are allowed. The acceptable range is from 20 to 
65535 or 0: (if you specify 0, a timeout will not be set). The default is 30. 

If the host does not respond within this time, the file transfer is canceled, and you receive an 
error message. You might need to increase the value if you have a slow connection. 

PC Code-Page 
The code-page is a table that translates EBCDIC codes to PC 1-byte codes, or vice versa, 
when files are transferred. The default corresponds to the host code-page that was set in the 
session configuration. 

Pause 
The number of seconds to pause between each transfer. 

Arabic or Hebrew only

Host-File Orientation 
This option applies if the session is configured for an Arabic or Hebrew host code-page and 
specifies whether the host files you transfer will be saved, in left-to-right or right-to-left format. 
The default is Left-to-Right. 

PC-File Orientation 
This option applies if the session is configured for an Arabic or Hebrew host code-page and 
specifies whether the PC files you transfer will be saved, in left-to-right or right-to-left format. 



The default is Left-to-Right. 
PC-File Type 

This option applies if the session is configured for an Arabic or Hebrew host code-page and 
specifies whether the PC files you transfer will be saved, in the format in which they are saved 
(Implicit) or in the format in which they should be displayed. The default is Implicit. 

Arabic only

Lam-Alef Expansion 
This option applies if the session is configured for an Arabic host code-page. When receiving 
files from the host, the character Lam_alef is expanded into two characters, Lam followed by 
Alef. This option is available for Windows PC code-page 1256 and AIX ISO code-page 1089. 
The default is to do expansion. 

Lam-Alef Compression 
This option applies if the session is configured for an Arabic host code-page. When sending 
files to the host, the characters Lam followed by Alef are compressed into one character, 
Lam_alef. This Option is available for Windows PC code-page 1256 and AIX ISO code-page 
1089. The default is to do compression. 

OS/400 only

file transfer destination address 
This option specifies the actual final destination address of the host to be used for the file 
transfer. 

file transfer User ID 
You must log on to an OS/400, specifically to do file transfer, even if you are already logged 
on to a display or printer session. The user ID that is specified here will be used to pre-fill the 
user ID field in the logon window when you initiate a file transfer. 

Text send options (MVS/TSO and VM/CMS)

The following options are used (by default) when sending files in text mode. For VM/CMS, 
remember to type an open parenthesis ’(’ before the first option. 

Options include:

ASCII 
Use this option for text files and for files that you want to be converted from ASCII to EBCDIC. 
This is valid for SBCS countries and Taiwan and Korea. PC 1-byte codes are converted into 
EBCDIC codes. For DBCS, inserts shift in/shift out (SI/SO) characters into DBCS fields. 

JISCII 
This option is valid for Japanese DBCS sessions only and converts 1-byte codes to EBCDIC 
and 2-byte codes to IBM Kanji. JISCII inserts shift in/shift out (SI/SO) characters into DBCS 
fields. 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is not removed from the end of each line. It is 
used as the delimiter of each record. EOF (x’1A’) is removed from the end of a file. 

NOSO 
This option is valid only for DBCS and only when used with the JISCII or ASCII option. NOSO 
prevents the conversion of SO (x’0E’) and SI (x’0F’) before and after the DBCS field. It also 
prevents the conversion of RS (x’1E’) and US (x’1F’) to SO (x’0E’) and SI (x’0F’). 

APPEND 



The transferred file will be appended to an existing host file that has the same name (and 
type and mode for VM/CMS), if one exists. If APPEND is not specified, the transferred file 
overwrites the existing host file. 

NEW 
The transfer stops if the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

RECFM 
Record Format. This option is not valid when APPEND is specified. Otherwise, you can 
choose one of the following options: 

l Default - The record format is automatically selected by the host system. 
l Fixed - Specifies the number of bytes in each host record. 
l Variable - When sending a file to VM/CMS, you can conserve host disk space by 

specifying a record format of variable. 
l Undefined - This option is available for MVS/TSO only. 

LRECL 
Logical Record Length. This is not valid if APPEND is specified. Otherwise, you can choose 
one of the following options: 

l Fixed - Specifies the number of bytes in each host record. 
l Variable - The logical record length is the length of the longest record in the file; the 

maximum value is 32767. 

The record length of a file sent from a PC to the host system might exceed the logical record 
length specified here. If so, the file transfer program divides the file by the logical record 
length.

To send a file containing long records to the host system, specify a length that is long enough 
to allow complete records to be sent. 

BLKSIZE(n) 
This option applies only to TSO and only when you are creating a new data set. The (n) value 
represents the block size in bytes. 

SPACE 
This option applies to TSO only. This value is the amount of space to be allocated for a new 
TSO data set. 
Quantity 

Units of space to be allocated initially. You must specify this value when the SPACE 
parameter is used. 

Increment 
Units of space to be added each time new space is required. 

The following parameters are only valid when the SPACE parameter is specified, and are 
mutually exclusive of each other.

AVBLOCK(n) 
Average block length used as the unit size by the SPACE parameter. The (n) value is 
the block length in bytes. 

TRACKS 
Specifies the unit of space is a track. 

CYLINDERS 
Specifies the unit of space is a cylinder. 

For other options that might be available to you, see your system administrator.



Text receive options (MVS/TSO and VM/CMS)

The following options are used (by default) when receiving files in text mode. For VM/CMS, 
remember to type an open parenthesis ’(’ before the first option. 

Options include:

ASCII 
Use this option for text files and for files that you want to be converted from EBCDIC to ASCII. 
This is valid for SBCS countries and Taiwan and Korea. EBCDIC codes are converted to PC 
1-byte codes. For DBCS, removes SO/SI characters from DBCS fields. 

JISCII 
This option is valid for Japanese DBCS sessions only and converts EBCDIC code to 1-byte 
codes and 2-byte codes to IBM Kanji. JISCII removes shift in/shift out (SI/SO) characters from 
DBCS fields. 

USER 
This option is valid only for DBCS and only when used with the ASCII (JISCII) and SO 
options. If USER is specified, SO (x’0E’) and SI (x’OF’) will not be converted to RS(x’1E’) and 
US(x’1F’). 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is added at the end of each record. 

EOF (x’1A’) is added at the end of the file. If APPEND is specified, EOF is removed from the 
end of an existing file and is added at the end of an appended file. 

NEW 
The transfer stops if the the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

SO 
This option is valid only for DBCS and only when used with the JISCII or ASCII option. It 
allows the conversion of SO (x’0E’) and SI (x’0F’) to RS (x’1E’) and US (x’1F’). 

APPEND 
The transferred file will be appended to an existing PC file that has the same name (and type 
and mode for VM/CMS), if one exists. If APPEND is not specified, the transferred file 
overwrites the existing PC file. 

For other options that might be available to you, see your system administrator.

Binary send options (MVS/TSO and VM/CMS)

Options include:

APPEND 
The transferred file will be appended to an existing host file that has the same name (and 
type and mode for VM/CMS), if one exists. If APPEND is not specified, the transferred file 
overwrites the existing host file. 

NEW 
The transfer stops if the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

RECFM 
Record Format. This is not valid when APPEND is specified. Otherwise, you can choose one 



of the following options: 

l Default - The record format is automatically selected by the host system. 
l Fixed - Specifies the number of bytes that will be in each host record. 
l Variable - When sending a file to VM/CMS, you can conserve host disk space by 

specifying a record format of variable. 
l Undefined - This option is available for MVS/TSO only. 

LRECL 
Logical Record Length 

This is not valid if APPEND is specified. You can choose one of the following options: 
l Fixed - Specifies the number of bytes that will be in each host record. 
l Variable - The logical record length is the length of the longest record in the file; the 

maximum value is 32767. 

The record length of a file sent from a PC to the host system might exceed the logical record 
length specified here. If so, the file transfer program divides the file by the logical record 
length.

To send a file containing long records to the host system, specify a length that is large 
enough to allow complete records to be sent. 

BLKSIZE(n) 
This option applies only to TSO and only when you are creating a new data set. The (n) value 
represents the block size in bytes. 

SPACE 
This option applies to TSO only. This value is the amount of space to be allocated for a new 
TSO data set. 
Quantity 

Units of space to be allocated initially. You must specify this value when the SPACE 
parameter is used. 

Increment 
Units of space to be added each time new space is required. 

The following parameters are only valid when the SPACE parameter is specified, and are 
mutually exclusive of each other.

AVBLOCK(n) 
Average block length used as the unit size by the SPACE parameter. (n) is the block 
length in bytes. 

TRACKS 
Specifies the unit of space is a track. 

CYLINDERS 
Specifies the unit of space is a cylinder. 

For other options that might be available to you, see your system administrator.

Binary receive options (MVS/TSO and VM/CMS)

Options include:

APPEND 



The transferred file will be appended to an existing host file that has the same name (and 
type and mode for VM/CMS), if one exists. If APPEND is not specified, the transferred file 
overwrites the existing host file. 

NEW 
The transfer stops if the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

For other options that might be available to you, see your system administrator.

Text send options (CICS)

Options include:

Binary 
Use this option for files that you do not want to be converted from ASCII to EBCDIC. 

ASCII 
Use this option for text files and for files that you want to be converted from ASCII to EBCDIC. 
This is valid for SBCS countries and Taiwan and Korea. EBCDIC codes are converted to PC 
1-byte codes. For DBCS, ASCII inserts shift in/shift out (SI/SO) characters into DBCS fields. 

JISCII 
This is valid for Japanese DBCS sessions only and converts EBCDIC code to 1-byte codes 
and 2-byte codes to IBM Kanji. JISCII inserts shift in/shift out (SI/SO) characters into DBCS 
fields. 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is not removed from the end of each line. It is 
used as the delimiter of each record. EOF (x’1A’) is removed from the end of a file. 

For other options that might be available to you, see your system administrator.

Text receive options (CICS)

Options include:

Binary 
Use this option for files that you do not want to be converted from EBCDIC to ASCII. 

ASCII 
Use this option for text files and for files that you want to be converted from EBCDIC to ASCII. 
This is valid for SBCS countries and Taiwan and Korea. EBCDIC codes are converted to PC 
1-byte codes. For DBCS, ASCII removes shift in/shift out (SI/SO) characters from DBCS 
fields. 

JISCII 
This option is valid for Japanese DBCS sessions only and converts EBCDIC code to 1-byte 
codes and 2-byte codes to IBM Kanji. JISCII removes shift in /shift out (SI/SO) characters 
from DBCS fields. 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is added at the end of each record. 

EOF (x’1A’) is added at the end of the file.

For other options that might be available to you, see your system administrator.



Binary send options (CICS)

There are no options that are applicable.

Send Binary (CICS)

There are no options that are applicable.

Text send options (OS/400)

Options include:

ASCII 
Use this option for text files and for files that you want to be converted from ASCII to EBCDIC. 
This option is valid for SBCS countries and Taiwan and Korea. PC 1-byte codes are 
converted into EBCDIC codes. For DBCS, inserts SO/SI characters into DBCS fields. 

JISCII 
This is valid for Japanese DBCS sessions only and converts 1-byte codes to EBCDIC and 2-
byte codes to IBM Kanji. JISCII inserts shift in/shift out (SI/SO) characters into DBCS fields. 

UNICODE (encoding) 
This option lets you send text files (saved in UNICODE) to the host and converts the data 
from UNICODE to EBCDIC. You can specify either UCS2 or UTF8 as the encoding option. If 
neither is specified, the default, UCS2, is used. 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is used as the delimiter of each record. This 
option is applicable only for the record-based files in the QSYS library system. 

NOSO 
This option is valid only for DBCS and only when used with the JISCII or ASCII option. NOSO 
prevents the conversion of SO (x’0E’) and SI (x’0F’) before and after the DBCS field. It also 
prevents the conversion of RS (x’1E’) and US (x’1F’) to SO (x’0E’) and SI (x’0F’). 

APPEND 
The transferred file will be appended to an existing host file that has the same name, if one 
exists. If APPEND is not specified, the transferred file overwrites the existing host file. 

NEW 
The transfer stops if the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

DSTADDR(dstaddr) 
This option specifies the destination address of the host to be used for the file transfer. 

USERID(usr) 
This option specifies the user ID to be used for the file transfer. 

PASSWORD(pwd) 
This option specifies the password to be used for the file transfer. 

SRC 
This option specifies the AS/400 file type to be used for the transfer. If the host file does not 
exist, then a new file is created with the file type "AS/400 Source physical file". This option is 
applicable only for the files in the QSYS library file system. 

DTA 
This option specifies the AS/400 file type to be used for the transfer. If the host file does not 
exist, then a new file is created with the file type "AS/400 Physical data file". This option is 
applicable only for the files in the QSYS library file system. 

SAVF 



This option specifies the AS/400 file type to be used for the transfer. If the host file does not 
exist, then a new file is created with the file type "AS/400 save file". If this option is specified, 
then the transfer mode must be BINARY. Also, this option is applicable, only for the files in 
the QSYS library-file system. 

LRECL(n) 
This option specifies the logical record length when creating a file on the OS/400. It can have 
the following values: 

l An integer from 1 through 32766 when Host File Type is set to Source physical file. 
l An integer from 1 through 32754 when Host File Type is set to Physical data file. 
l It is ignored when Host File Type is set to Save file. 

For other options that might be available to you, see your system administrator.

Text receive options (OS/400)

Options include:

ASCII 
Use this option for text files and for files that you want to be converted from EBCDIC to ASCII. 
This is valid for SBCS countries and Taiwan and Korea. EBCDIC codes are converted to PC 
1-byte codes. For DBCS, ASCII removes shift in/shift out (SI/SO) characters from DBCS 
fields. 

JISCII 
This is valid for Japanese DBCS sessions only and converts EBCDIC code to 1-byte codes 
and 2-byte codes to IBM Kanji. JISCII removes shift in/shift out (SI/SO) characters from 
DBCS fields. 

UNICODE (encoding) 
This option lets you receive text files from the host and converts the data from EBCDIC to 
UNICODE. You can specify either UCS2 or UTF8 as the encoding option. If neither is 
specified, the default, UCS2, is used. 

USER 
This option is valid only for DBCS and only when used with the ASCII (JISCII) and SO 
options. If USER is specified, SO (x’0E’) and SI (x’OF’) will not be converted to RS(x’1E’) and 
US(x’1F’). 

CRLF 
Carriage Return and Line Feed. CRLF (x’0D0A’) is added at the end of each record. If 
APPEND is specified, EOF is removed from the end of an existing file and is added at the end 
of an appended file. This option is applicable only to record-based files in the QSYS library 
system. 

SO 
This option is valid only for DBCS and only when used with the JISCII or ASCII option. It 
allows the conversion of SO (x’0E’) and SI (x’0F’) to RS (x’1E’) and US (x’1F’). 

APPEND 
The transferred file will be appended to an existing host file that has the same name, if one 
exists. If APPEND is not specified, the transferred file overwrites the existing host file. 

NEW 
The transfer stops if the file already exists. This option can be used to protect against 
accidentally erasing an existing file. 

DSTADDR(dstaddr) 
This option specifies the destination address of the host to be used for the file transfer. 

USERID(usr) 
This option specifies the user ID to be used for the file transfer. 

PASSWORD(pwd) 



This option specifies the password to be used for the file transfer. 

For other options that might be available to you, see your system administrator.

Binary send options (OS/400)

Options include:

APPEND 
The transferred file will be appended to an existing host file that has the same name, if one 
exists. If APPEND is not specified, the transferred file overwrites the existing host file. 

DTA 
The option specifies the AS/400 file type to be used for the transfer. If the host file does not 
exist, a new file is created with the file type "AS/400 Physical data file". This option is 
applicable only for the files in the QSYS library-file system. 

LRECL(n) 
This option specifies the logical record length when a file is created on the OS/400. It can 
have the following values: 

l An integer from 1 through 32766 when Host File Type is set to Source physical file. 
l An integer from 1 through 32754 when Host File Type is set to Physical data file. 

It is ignored when Host File Type is set to Save file. 

For other options that might be available to you, see your system administrator.

Binary receive options (OS/400)

Options include:

APPEND 
The transferred file will be appended to an existing host file that has the same name, if one 
exists. If APPEND is not specified, the transferred file overwrites the existing host file. 

For other options that might be available to you, see your system administrator.

Default transfer mode

Options include:

TEXT 
This option sets the default transfer mode to be Text (for text only files). 

BINARY 
This option sets the default transfer mode to be Binary. Binary files are files stored as a series 
of numbers and symbols that only computers can read. Applications and pictures are 
examples of binary files. 

Clear before Transfer

This option sends a Clear Presentation Space command before transferring a file. You should not 
change this setting unless you have a good reason because in nearly every case, CMS and CICS 
require that this command be sent, whereas TSO and OS/400 do not.



Using a light pen

To switch light pen mode on or off, click Screen > Appearance > Light Pen Fields. Then click the 
appropriate option.

Some host applications use a light pen as a pointer and operator. If you switch light pen mode on, 
you can use your mouse as a light pen. 

When light pen mode is switched on, all light pen fields appear as either check boxes or buttons. 
You can select these fields using a mouse. Light pen mode does not deactivate your mouse.

Use Default means that the availability of this feature will be determined by defaults set on other levels.



Default shortcut keys for the Screen Customizer 
Administrator

To access functions that are often used, the following default shortcut keys are available. 

Related topics

l Remapping the keyboard 

Because menu items and shortcut keys can be remapped using the Keyboard Remap function, shortcut 
keys might be different than what is listed here. 

Function Shortcut key
Screen Properties Ctrl+D
Capture Ctrl+E
Copy Ctrl+C
Customize Screen Ctrl+Z
Customize Template Ctrl+T
Cut Ctrl+X
Exit Ctrl+Q
Help Index Ctrl+H
JumpNext Ctrl+J
Paste Ctrl+V
Print Screen Ctrl+P
Receive File from Host... Ctrl+R
Run Applet Ctrl+U
Select All Ctrl+A
Send File to Host... Ctrl+S
View Screen IDs Ctrl+I



Viewing the Administrator toolbar

Click View > AdminToolbar to show or hide the administrator toolbar.

the Administrator toolbar enables you to more easily capture screens by providing the following 
buttons:

Customize 
Click this button to capture the current screen using the screen ID and description you 
entered on the tool bar, and then customize it using the Customization Studio. 

Capture 
Click this button to capture the current screen using the screen ID and description you 
entered on the tool bar. 

Properties 
Click this button to capture the current screen, give it a screen ID and extended description, 
and set up a tag, view its statistics, and then, optionally, customize it using the Studio. 

Screen IDs 
Click this button to view screen IDs. The IDs are displayed in the window, along with a 
description (if there is one), the number of fields on the screen, the tag and its position (if 
there is a tag). In this window, you can also delete screen IDs. 



Viewing the toolbar

Click View > Toolbar to show or hide the toolbar. The toolbar consists of shortcut buttons that 
correspond to menu options. When you hold the mouse pointer over a button, a description for the 
button is displayed in the status bar.

If you want identifying text to appear under the toolbar buttons, Click View > Toolbar Text.



Viewing the status bar

Click View > Status Bar to show or hide the status bar located at the bottom of the screen. It 
displays the following (from left to right): 

l Session information indicators (first letter indicates a type of control unit attachment, second 
letter indicates the connection type). 

l Session name and status of the host. Session names are displayed as a letter (for example, 
A, B, C). "x[ ]" is displayed if the host is busy. 

l Program message, tool tip or the meaning of the button being pointed at by the mouse. 
l Message waiting indicator (for example, MW). 
l Cursor mode (overwrite or insert). 
l Cursor position (rows and columns). 
l Screen ID. 
l Security icon to show whether your session is secure. 



Viewing the keypad

Click View > Keypad to show or hide the keypad, which is displayed at the bottom of your screen. 
The keypad contains buttons that correspond to the frequently used commands for host 
applications. Use the Next Pad button on the keypad to interchange the panels. The keypad for 
3270 sessions is different from that for 5250 sessions. 



Capturing screens

Before you can customize a screen, you need to capture it.

To capture a screen: 

1. Using the Administrator, start a session that contains the screens you want to customize.

2. Go to the screen you want to customize.

3. From the Administrator Toolbar, choose one of three options, depending upon what you want 
to do:

� If you want to capture the current screen and immediately customize it, click 
Customize. If you do not enter an ID and, optionally, a description in the toolbar fields 
that are provided, you will be asked to do this before you proceed, and then the 
Customization Studio will appear in a new window. 

� If you want to capture a screen quickly and customize it later, enter a screen ID and, 
optionally, a description in the appropriate fields on the toolbar and click Capture.

� If you want to capture a screen, give it a screen ID and extended description, set up a 
tag, view its statistics, and then, optionally, customize it using the Customization Studio, 
click Properties. A window then appears with several tabs that allow you to modify 
these things. When you are finished modifying, click Customize and the Customization 
Studio will appear in a new window or click OK to finish capturing the screen. 

You are now ready to use the Customization Studio to customize this screen.

If you enter an incorrect or invalid screen ID, a message will appear instructing you on what to change.

Once a screen has been captured, it cannot be recaptured. The capture button is therefore dimmed. To 
change the screen ID, description, or any other extended information, you user must click Screen 
Properties and make the change from the resulting window.



Closing the Administrator

Before closing the Administrator, make sure all customization changes are saved.

To close the Administrator, click File > Exit for each session. 

To disconnect a session without closing the Administrator, click Communication > Disconnect. The 
connection to the host will end for the selected session. However, the Administrator window for the 
disconnected session remains open. All other sessions will remain connected to the host.



Connecting to a host

Do one of the following:

l Click Communication > Connect. 
l Click the Connect button on the toolbar. 



Deleting or viewing a screen ID

1. Click File > Screen-IDs. 
The IDs are displayed in the window, along with a description (if there is one), the number of 
fields on the screen, the tag and its position (if there is a tag). 

2. To delete an ID, select it and click Delete. If you want to specify a new screen ID, use the 
Screen ID box on the Administrator toolbar to enter one. 



Disconnecting from a host

On the session you want to disconnect, do one of the following:

l Click Communication > Disconnect. 
l Click the Disconnect button. 

The connection to the host will be terminated for the active session. However, the window for the 
disconnected session will remain open. All other sessions will remain connected to the host.



Exiting a session

On the session you want to exit, do one of the following:

l Click File > Exit. 
l Click the Exit button on the toolbar. 

The active session will be disconnected and its window will close. You can also disconnect a 
session without closing your emulator. 



Getting host-provided help

If your host application provides field-sensitive help: 

1. Click the appropriate field. The position of the mouse pointer is recorded. 
2. Press the function key associated with host help. The help, when available, is displayed. Even 

if you later move the fields to somewhere else on the screen, help is still available because it 
is linked to the field. 



Printing screens

Do one of the following:

l Click File > Print Screen. 
l Click the Print Screen button on the toolbar. 



Using file transfer

File transfer is available for 3270 and 5250 sessions. Menu options are provided in the 
Administrator and the Clients, and you can create a macro button to start file transfer from a 
customized screen. 

Setting file transfer defaults

It is important to set the correct defaults, such as the host type, so that users do not have to be 
concerned with them. Because file transfer settings are specific to a particular host type (MVS/TSO, 
VM/CMS, CICS, OS/400), they are not saved as part of the global customizations made in the 
Administrator. To save file transfer defaults, you must save them using the Host On-Demand icon 
interface (HOD.html) or the Host On-Demand Administrator (HODAdmin.html) for each individual 
session. 

Hiding file transfer

To prevent users from trying to transfer files from screens that do not allow it, you can hide the 
menu options and toolbar buttons in customized screens. To do this, add the Disable parameter to 
the appropriate HTML file after you have set the file-transfer defaults. Even if you have removed file 
transfer from the menu and tool bars, you can add a macro button to a customized screen so that 
users can transfer files only where appropriate. 



Using the Screen Customizer Bundler

The Service Bundler is a tool that the IBM Service team may ask you to run if you need help 
troubleshooting a problem. The Screen Customizer Bundler helps the Service team gather 
important information for debugging problems quickly.

You can start the Screen Customizer Bundler one of two ways depending on your operating system:

l For Windows 32-bit environments (when running Screen Customizer on Personal 
Communucations, for instance), click Start > Programs > IBM Screen Customizer > Utility > 
Service Bundler.

l For non-Windows environments when running Screen Customizer on Host On-Demand, 
invoke the following from a command line from the hod publish directory (usually, <hod-
installpath>\HOD; a JRE is also required): 

"\ <hod-installpath>\bin\jre -classpath .;\<hod-publish-dirctory>\;\<ho



Testing customizations

You can use the Administrator to test the customizations you made to your templates and screens 
(maps) using the Customization Studio. This feature allows you view a template in context with a 
particular screen and see how other templates look with that screen.

To see what your customized templates look like click Test > View with different template.

To switch between viewing the original, unmodified and the customize screen, click Test > Show 
custom screens.

To run an applet:

1. Click Test > Run Applet, or click the Run Applet button on the toolbar. 
2. Type the fully qualified name of the applet you want to run, and click Run. 



Showing custom or default screens

This feature allows you to switch between viewing the screen with the default objects and viewing 
the customized screen. Viewing customized screen allows you to more easily fix any possible 
problems before your users actually see the customized screens.

To switch between the default interface and the customized version of the same screen, click Test > 
Show custom screens. 



Viewing screens with a different template

You can use the Administrator to test the customizations you made to your templates using the 
Customization Studio. This feature allows you view a template in context with a particular screen 
and see how other templates look with that screen.

To see what your customized templates look like with this screen:

1. Click Test > View with a different template. 
2. Click Enable. 
3. Type the name of the template you want to view temporarily with this screen. 
4. Click OK. 



Running an applet

To run an applet:

1. Click Test > Run Applet, or click the Run Applet button on the toolbar. 
2. Type the fully qualified name of the applet you want to run (for example, 

http://com.xyz.myapplet.class), and click Run. 
3. Click Run. 



Using customized screens with Host On-Demand

To use customized screens with Host On-Demand, enable Screen Customizer on the Screen tab of 
the appropriate Host On-Demand session configuration, then start the session. If the host screen is 
recognized, you will see the customized version; if not, you will see a default interface. To start 
sessions using the interface that is similar to the ResQ!Net interface, load 
HODCustomClientBasic.html. 



Using customized screens with Personal 
Communications

To use customized screens with Personal Communications, click Start > IBM Screen Customizer > 
Client. If a WS file has been specified using the Launch parameter, a session is started; if not, you 
are asked to choose one. Start the session. If the host screen is recognized, the customized version 
of the screen is displayed; if not, the default interface is used. 



Introducing the Customization Studio

A major benefit of adding a graphical interface to your host application is the flexibility to change the 
appearance and functionality of the screens. The Customization Studio (Studio) allows detailed 
screen customization which can be placed on the Web server (Host On-Demand), or a network 
drive (Personal Comminications) for distribution. The Customization Studio can be accessed from 
an Administrator session or by clicking Start > Programs > IBM Screen Customizer > Customization 
Studio.

The Customization Studio allows you to customize any host application screen on both the screen 
and object levels. Changes to templates made in Customization Studio apply to all screens using 
that template. This makes it easy to update many screens at once. 

Using the Customization Studio, you can:

l Create templates to customize many screens at once 
l Change the appearance of screens and individual objects 
l Copy, resize, and move existing screen objects 
l Reset the tab order 
l Create new labels and text fields and also edit existing ones 
l Delete or hide existing screen objects 
l Create buttons, check boxes, choices, frames, image buttons, lists, radio buttons, valid values 

buttons, and Web link buttons 
l Convert input fields to check boxes, radio buttons, choices, and lists 
l Convert labels to macro buttons 
l Move and change the colors and fonts of multiple fields simultaneously 
l Add facilities that allow the user to automatically navigate through the screens 
l Redirect action keys 
l Add customized buttons to the toolbar 
l Pass data from screen to screen using global variables 
l Manage the location of the files you create during the customization process 
l Erase customizations 
l Add help (valid values lists and help descriptions) 

Related topics:

l Basic Customization Steps 
l Introducing the Administrator 



Canceling changes

Click Edit > Undo to cancel up to ten of the most recent operations performed. 

Click Edit > Redo to redo up to ten of the most recent undo operations performed. 



Closing the Customization Studio

To close the Customization Studio, click File > Exit. 



Erasing all of your changes

1. Open the *.scm file containing the customization you want to erase. 
2. Click File > Erase. Click Close. The original file, <screenID>.scm, is deleted. 

Before selecting the Erase option, make sure that you want to erase all the customization for the screen. 
You might want to save the customization under a different name before erasing it because you cannot 
undo the deletion.



Saving changes

Click File > Save to save the customized screens as a *.scm file (* is the screen ID of the current 
screen). 

Use the Save As option to save additional customized maps you have created for the same screen. 
This allows you to save your current map with a different filename or in a different directory. 
However, only the customization map with the proper setup, extension, directory, and filename 
(which will match the screen ID) is visible in the Client and Administrators.



Default shortcut keys for the Screen Customizer 
Studio

To access functions that are often used, the following default shortcut keys are available. 

Related topics

l Remapping the keyboard 

Function Shortcut key
Screen Properties Ctrl+D
Duplicate Ctrl+C
Exit Ctrl+Q
Help Contents Ctrl+H
New Template Ctrl+N
Open Map Ctrl+M
Open Template Ctrl+T
Properties Alt+Enter
Redo Ctrl+Y
Save Ctrl+S
Undo Ctrl+Z
View Screen IDs Ctrl+I



Tips for the Screen Customizer Studio

To perform common Studio tasks more quickly, read the following tips. 

Tasks Tips 

To select multiple objects

Hold down 
the Ctrl key 
and then 
click each 
object you 
want to 
select, or 
hold down 
the Ctrl key 
and drag a 
rectangle 
around the 
objects you 
want to 
select.

To copy objects

Hold down 
the Ctrl key, 
click an 
object, and 
drag a copy 
of its to a 
new 
position.

To copy the selected object to a mouse pointer Press C

To move an object

Click an 
object and 
then drag it 
to a new 
position or 
click an 
object and 
then use the 
Shift+arrow 
keys to 
move an 
object to a 
new 
position.

To move a group of objects

Select the 
objects you 
want to 
move, and 
drag them 
to a new 
position or 
select the 
objects and 
then use 
Shift+arrow 
keys to 
move the 
objects to a 



Related topics

l Short-cut keys 

new 
position.

To move the selected object to a mouse pointer Press M

To resize an object

Click an 
object and 
then use the 
Ctrl+arrow 
keys to 
expand or 
contract the 
object.

To hide an object

Click an 
object and 
then press 
the Space 
bar.

To work with an object’s properties
Click the 
object and 
press P



Understanding templates

With Screen Customizer V2.0, you can use templates to specify and easily update much of the 
customization of host screens. These templates can be associated with many host screens at once-
-customized or not. They allow you to specify the area reserved for host screens as well as provide 
additional space for buttons, Web-links, and other custom objects. Using templates, you can also 
specify the colors, fonts, and button styles for these screens. 

Best of all, whenever you customize a template, all changes are automatically applied to all screens 
associated with that template at run time. Templates can be used in two ways: globally or 
associated with specific screens. 

The default global template is called sc_global.tpl and is applied automatically to all host screens 
that do not have a specific template associated with them. Templates by other names can be used, 
but setting them up as the global template requires that you edit the HTML file used to start the 
program.

You can create other templates for other situations. For instance, if your users used two 
applications--a database application and a timecard application--you could set up the global 
template for the application with the most screens and create another template for the other 
application. To use another templates, you must specify that template for each screen involved.

In addition, you can still use templates to manually import objects and settings into specific screens. 
Click here for more information.

To customize a template to be applied globally to all screens, follow these general steps:

1. Start the Customization Studio. 
2. Create a template, customizing it as you require. 
3. Apply the template to screens. 

Related topics:

l Applying a template 
l Changing templates 
l Creating a template 
l Customizing a template 
l Opening a template 

Certain attributes can be overridden for specific host screens and objects.

Profiles are no longer supported. Templates contain much of the information that was previously stored 
in profiles. Information from existing pre-Screen Customizer V2.0 profiles should have been migrated to 
templates during installation.

After you have applied a template globally, you can override that template for a given screen, using 
Template Options.



Creating a template

Templates are extremely versatile. With them, you can manually or automatically customize specific 
screens or all screens globally.

To create a template:

1. Click File > New Template. 

A blank screen appears where you can position the host screen area within the template, 
create objects, and otherwise modify this template for use with other screens.

2. Customize the template. (See Related Topics below for some objects you can add.) 

3. Click File > Save As to give your template a name and save it. 

Related topics:

l Adding a button 
l Adding a checkbox 
l Adding a choicebox 
l Adding a frame 
l Adding an image 
l Adding an image button 
l Adding a label 
l Adding a list 
l Adding a radio button 
l Adding a textfield 
l Adding a valid-values button 
l Adding a Web-link button 
l Changing screen colors 
l Changing screen font 
l Controlling tab-key movement 
l Customizing the host screen area 

Do not delete the host screen area. This is where the host screen appears.

If you want your users to be able to customize their own screen colors and fonts, check the Use 
Default Color and Use Default Font boxes.

If you name your template sc_global.tpl, your template will be applied globally by default.



Applying a template

If you named your global template sc_global.tpl, your template is already applied automatically by 
default. However, if you did not name your global template sc_global.tpl or want to apply a different 
template, you must edit a file manually to apply that template to Screen Customizer. The procedure 
is different depending on whether you are using Screen Customizer with Host On-Demand or 
Personal Communications.

If you are using Screen Customizer with Host On-Demand and want to apply a 
template globally to all screens:

1. Edit the HTML file you use to start Screen Customizer. 
2. Add the following in the parameters section: 

<PARAM NAME=template     VALUE=xxxxxxx.tpl> 

where xxxxxxx is your template name 

For example, you could add the following to HODCustom.html to use a template named 
"personnel":

<PARAM NAME=template     VALUE=personnel.tpl> 

3. Restart Screen Customizer using that HTML file. 

If you are using Screen Customizer with Personal Communications and want to apply 
a template globally to all screens:

1. In the private subdirectory, edit the parameters file. 
2. Add the following: 

"template=xxxxxxx.tpl"

where xxxxxxx is your template name 

For example, you could add the following to a parameters file to use a template named 
"personnel":

"template=personnel.tpl" 

3. Restart Screen Customizer using that parameters file. 

Related topics:

If you use different host screen sizes, you may want to set up a template for each supported host screen 
size. 

After you have applied a template globally, you can override that template for a given screen, using 
Template Options.



l Customizing the host screen area 



Changing templates

Specifying a different template
Specifying no template
Specifying a global template

You can specify that a screen use a global template, a different template, or no template at all. You 
can also specify that a screen use only the colors and fonts from a template.

Specifying a different template

To use a template other than the global template with this screen: 

1. Click Screen > Template Options. 
2. Click Show with specified template. 
3. Type the name of the different template. 
4. If you want the screen to use only the template’s colors and fonts, check Only apply template 

colors and fonts. 
5. Click OK. 

Specifying no template

To specify that a template not be used with this screen: 

1. Click Screen > Template Options. 
2. Click Do not show template. 
3. Click OK. 

Specifying a global template

To apply a global template to this screen:

1. Click Screen > Template Options. 
2. Click Show with global template. 
3. If you want the screen to use only the template’s colors and fonts, check Only apply template 

colors and fonts. 
4. Click OK. 

By default, all newly mapped screens are configured to show the global template if one is defined.



Customizing a template

Creating and customizing a new template
Editing or customizing a previously created template

Templates are extremely versatile. With them, you can manually or automatically customize specific 
screens or all screens globally.

Creating and customizing a new template

To create and customize a new template: 

1. Start the Customization Studio 
2. Click File > New Template. 

A blank screen appears where you can create objects and otherwise modify this template for 
use with other screens.

3. Customize the template. 

4. Click File > Save As to give your template a name and save it. 

Editing or customizing a previously created template

Customizing a previously created template changes every screen that uses that template 
automatically at run time.

To customize a previously created template:

1. Using the Administrator, open a screen that uses the template you want to modify. 
2. Click Customize screen to start the Customization Studio. 
3. Click File > Customize Template. 
4. Customize the template. (See Related Topics below for some objects you can add.) 

5. Click File > Save. 

Related topics:

l Adding a button 
l Adding a checkbox 
l Adding a choicebox 
l Adding a frame 
l Adding an image 
l Adding an image button 

Do not delete the host screen area. This is where the host screen appears.

Do not delete the host screen area. This is where the host screen appears.



l Adding a label 
l Adding a list 
l Adding a radio button 
l Adding a textfield 
l Adding a valid-values button 
l Adding a Web-link button 



Importing and exporting from a map

You can select a group of objects on the screen by dragging a frame around the objects. If you 
would like to select the frames that were created on this map to be part of the group that is going to 
be exported, press the control key before you finish creating the frame around the group of objects, 
and all created frames will be selected.

You can import any calculations from a screen to any other screen. This ensures consistency 
across screens, and also saves time during customization. While templates are allowed to store 
calculations, the Global Variable Viewer only shows how Variables are defined in maps, and not in 
templates.

To import only the objects you created or the original host fields matching in size and position to the 
host fields on your screen: 

1. Open the map or template where you want to import the customization. 
2. Click File > Import > from Map. 
3. Select the map from which you would like to export the customization and click Open. The 

map appears in the Export window behind the original screen. 
4. Go to the Export window. Choose the appropriate options from the Select menu or click the 

objects on the screen. You can select one object, all of one type of object (for example all 
Labels), as well as numerous types of objects on the screen (for example all labels, radio 
buttons, and images). 

5. Select File > Export. 
6. Select File > Close. The customization imported from the map appears on the original map or 

template. 



Importing and exporting from a template

To import any or all of the objects you created: 

1. Open the map or template where you want to import the customization to. 
2. Click File > Import > from Template. 
3. Select the template from which you would like to export the customization and click Open. 

The template appears in the Export window behind the original screen. 
4. Go to the newly opened template and select the appropriate options from the Select menu. 
5. Click File > Export. 
6. Click File > Close. The customization imported from the template appears on the original map 

or template. 

For similar screens, you can customize the common part of the screen once and then export the 
customization. Open the screen where you want to import the customization. Click File > Import and 
open the customized map. Select all objects on the map that you want to have on your screen and 
export them. Close the screen that you are exporting from. 



Opening a template

Templates are saved as *.tpl files in the /custom/map directory. To open a template:

1. Click File > Open Template. 
2. Select a template and click Open. 

To view the changes in context with a particular host screen, return to the Administrator and click 
View > Refresh. If the modified template is not the current template, select the modified template by 
clicking Test > View with different template. 

Related topics:

l Applying a template 
l Basic Customization Steps 
l Changing templates 
l Creating a template 
l Customizing a template 



Customizing individual host screens

You can use templates to specify the areas reserved for host screens and to control the custom 
objects around that screen. You can also customize individual host screens themselves.

Also, a template sets the default settings for all screens. However, you can override specific 
settings for individual screens. For example, if you want a specific screen to appear with a different 
background color, you can change the background color for that screen only. Other settings will 
continue to be controlled by the template. Only this element will continue to override the template 
settings. 

It is recommended that you use a template to set general settings and then make exceptions for 
individual screens.

To customize individual screens:

1. Using the Administrator, begin a session containing the screens you want to customize. 
2. Go to a screen you want to customize. 
3. Click File > Customize Screen and give the screen an ID. 

The Customization Studio appears with the screen displayed inside its window.

4. Customize the screen. (See Related Topics below for some objects you can add.) 
5. Click Save. 
6. Click Exit. 

Related topics:

l Changing screen colors 
l Changing the font 
l Controlling tabbed elements 
l Customizing the toolbar 
l Guiding users through screens (Get-to-the-Point) 
l Redirecting action keys 
l Remapping the keyboard 
l Setting tab order 
l Setting the tab key movement 



Opening a map

A map is a file associated with a customized screen. Click File > Open Map to open a map. You can 
open only one map at a time. Before you open another map, save the open file. Customized 
screens appear as *.scm files in the custom/map directory.



Changing screen colors

To use the default colors, check Use Default Color.

To use custom colors and change a color on the screen: 

1. Click Screen > Appearance > Colors. 
2. Clear Inherit Color. 

3. Select either Foreground (text) or Background. 
4. Select a field type. 
5. Select one of the colors available from the Basic Color palette or create a unique color and 

add it to the palette. To create a custom color: 
1. Click a color and then adjust the numbers that represent the color by clicking the arrows 

or entering a number. Color changes are reflected in the selected field box. 
2. Click Add to Custom Colors. 
3. Click one of the blank Custom Colors boxes. Now you can use this color for other 

objects on the screen. 

To create a sixth custom color, you have to overwrite one of the other custom colors on 
the palette. Objects that use the overwritten color retain their color, but that color is no 
longer available. 

4. Click Apply to apply changes. 
6. Repeat the steps above for every type of field that you want to change. 
7. Click Defaults to return to the default colors. 
8. Click Apply to apply changes. Click OK to apply changes and return to the current screen. 

Checking this box means the color settings will be inherited from another level.



Changing the font

1. Click Screen > Appearance > Font. 
2. Clear Inherit Font. 

3. Choose from the Font and Size lists. Your changes are reflected beneath the Sample 
heading. 

4. If you want to use these type styles, click Bold, Italic, or both. 
5. Click OK. 
6. The screen is resized to accommodate your changes. 

Checking this box means the font settings will be inherited from another level.

True type fonts can appear proportional or not. It is better to use a font that is not proportional so that 
every letter will have the same width.



Controlling AS/400 subfile customization

Subfiles are common presentation of lists of virtual objects that exist on AS/400 machines. These 
lists allow these users to perform actions easily and conveniently on these objects. They form the 
working interface to to the AS/400 system objects.

As a default, Screen Customizer automatically converts AS/400 subfile screens into a graphic 
interface that includes action buttons and a selectable list of files. These additional features allow 
users to click a file and then click a button to easily apply an action to it.

However, you can choose to exclude these action buttons and a selectable list. This means that 
your list of subfiles will function just as it did before customization by typing in a number beside a file 
and pressing enter. 

To turn off action buttons and selectable lists, click Screen > Appearance > Show Subfile Tables > 
Always Off.

To turn on action buttons and selectable lists, click Screen > Appearance > Show Subfile Tables > 
Always On.

In both cases, if More ... is presented at the bottom of the list, you can Page Down for the next set of 
subfiles.



Controlling tab-key movement

On host applications, the Tab key moves the cursor from one input field to the next whereas, in a 
Windows environment, pressing the Tab key can move the cursor to input fields and onto objects 
such as buttons and menu items. In customized host screens, from which unnecessary fields might 
have been removed, you usually want the cursor to move between all the objects on the screen, as 
in a Windows environment. You can set several preferences for tab key movement. 

To set the preferences:

1. Click Screen > Tab-Key Control. 

2. To set the Tab key so that it can move to any object (such as buttons, radio buttons, and 
checkboxes,as it would in Windows mode), clear the Host Mode box.

The Hotspots and Menu Buttons check boxes are activated. You can choose to exclude 
Hotspots and Menu Buttons from the Tab sequence by removing the check next to the 
appropriate box. 

To set the Tab key so that it can move only to input fields (host mode), click the Host Mode 
box. 

3. Click OK. 



Customizing screens for user groups

You can create a different customization for each user group. The default directory for 
customization is custom. It contains the following subdirectories: lang/help, map, img, lst, ref, wsp, 
and ps. To prepare different customizations, you can create a new directory at the same level as the 
custom directory. Save the customized screens in the new directory and then specify that directory 
name in the HTML file for Host On-Demand or the Parameters file for Personal Communications 
with the subdir parameter. If no value is set, then the user receives customization from the default 
directory, /custom. If a value is set, then the user receives the customization from the directory 
specified as the parameter’s value. 



Customizing the host screen area

You can change the area reserved for the host screen one of two ways:

l By right-clicking the area and selecting one of the predefined screen sizes 
l By dragging the one of the corners or sides of the area to increase or descrease the size of 

the area 

If the area is not large enough to display the entire host screen, the host screen will appear with 
scrollbars.



Customizing the toolbar

To add or change a button on the toolbar, click Screen > Customize Toolbar. 

l To add a new button to the toolbar, click Add New. 
l To insert a new button in the toolbar before another button, click Insert New. 
l To change the properties for a button, select the button and click Properties. 

Adding status bar text or image

To add status bar text or an image to a toolbar button: 

1. Click the button on the toolbar. 
2. Click the General tab. 
3. Enter text for the button status bar tip. 
4. To add an image to the button: 

1. Click Browse, select an image, and click open or enter the name of an image with a 
*.gif or *.jpg extension and click OK. Images must be located in the /custom/img 
directory. 

2. Click Delete Image to remove the image from the Toolbar Button. 
5. Click OK to save and exit. 

Adding a macro to a toolbar button

To modify the toolbar button macro:

1. Right-click the toolbar button. 
2. Click the Macro tab. 
3. To assign a macro, follow the steps for the Macro button. 

Adding global variables to a toolbar button

To modify global variables for a toolbar button:

1. Right-click the toolbar button. 
2. Click the Read/Write tab. 
3. Enter the name of the parameter (global variable) in the parameter fields. 

Do not use parameters that are already preset in the startup HTML file or Parameters file if 
you do not want to overwrite them. The parameters in the startup HTML file are global 
parameters with values that are preset at startup.

4. Click OK. 

Switching toolbar buttons

To switch the locations of two buttons:

1. Click Screen > Customize Toolbar. 
2. Click one button. 



3. Click Replace. 
4. Click another button. The two buttons will switch places in the toolbar. 

Removing toolbar buttons

To remove a button: 

1. Click Screen > Customize Toolbar. 
2. Select the button and click Remove. 

3. To remove all the toolbar buttons, click Remove All. 



Guiding users through screens

Get-to-the-Point can be added to an interface to automatically navigate the user through different 
screens. It can be used as an automatic log on, or an automatic log off button, but there are many 
other instances where it can be utilized. Get-to-the-Point can also be added to a series of screens 
of a Web enabled application to hide screens which require redundant input. It can automatically 
input data and execute function keys for the user. Get-to-the-Point can even dynamically input data 
that is user-specific, if used in conjunction with a Client HTML file for Host On-Demand or a 
parameter file for Personal Communications.

Get-to-the-Point is configured on a screen by screen basis. Every screen that you want to bypass 
has to have Get-to-the-Point. Get-to-the-Point has no associated button, frame or input field. To see 
if Get-to-the-Point is configured for a screen, click Screen > Get-to-the-Point. The Set Get-to-the-
Point Properties window appears where you can see the macros that are set up and if it has already 
been activated. Get-to-the-Point and Web Link buttons only work in the Client.

Frequently used Get-to-the-Point options are:

l Automatically enter data into fields (you can pre-enter the data or have this data dynamically 
extracted from an HTML or parameter file). 

l Execute assigned functions. 

To enable Get-to-the-Point: 

1. Click Screen > Get-to-the-Point. 
Get-to-the-Point is not an object so there is no button for you to resize or position on the 
screen. 

2. Click the Settings tab. 
3. Check On/Off to enable Get-to-the-Point (a check mark enables Get-to-the-Point). 
4. Check Suppress Display to prevent users from seeing screens that are bypassed. 
5. Click a Controlling Events. Get-to-the-Point can be activated on entrance (Initial Screen), on 

Every Update, and on exit (Transition to New Screen). 

Adding a macro

To link data to certain fields (field values) and functions, add a macro. Data (values and events) can 
be inserted manually or from an HTML or parameter file.

1. Click Screen > Get-to-the-Point. 
2. Click the Macro tab. 
3. You can either insert data manually or from a Client HTML file or parameter file. 

� To insert data manually, enter a value in the Edit Source field and click Add. The value 
appears in the Field Values field. 

� To insert data from a Client HTML or parameter file: 
1. Click Read HTML. 
2. Select the Client HTML and click Open. Variables are displayed in the 

Name/Tag/Default Value field. 
3. Select the data from Name/Tag/Default Value field. Your selection is displayed in 

the Edit Source field. 
4. Click Add. The data appears in the Field Values field. 

Below is a partial example of Client HTML file used by Get-to-the-Point. 



 <PARAM NAME="LASTINDEX" VALUE="100">
 <!-- ALL THE PARAMETERS BELOW ARE USED FOR Get-to-the-Point UTILITY  --> 
 <!-- PRM 1,2,3,4,11,15,21,31,41,SUBDIR ARE USED AS AN EXAMPLE -->
 <PARAM NAME=PRM1 VALUE="LCMN">
 <PARAM NAME=PRM2 VALUE="TAG~">
 <PARAM NAME=PRM3 VALUE="33333">
 <PARAM NAME=PRM4 VALUE="TAG">
 <PARAM NAME=PRM15 VALUE="L APPLID=CICSTES1">
 <PARAM NAME=PRM11 VALUE="0000">
 <PARAM NAME=PRM21 VALUE="21"> 
 <PARAM NAME=PRM31 VALUE="31F">
 <PARAM NAME=PRM41 VALUE="41DD">
 <PARAM NAME="SUBDIR" VALUE="XXXXXXXX">
 
 

The first line in this example shows the maximum number of Get-to-the-Point parameters that can 
be used in the program. The parameters can be entered into Client HTML dynamically from any 
script (for example, Perl script) or manually. 

1. In the Field Values box, select the data that you would like to link. 
2. Click the input field you want to link it to. 
3. To automatically send a function key to the host, select a function key from the scroll list and 

click Apply to save. 
4. To change information that you have already added to the Field Values field or linked to 

specific fields on the screen: 
1. Highlight the value and click Remove to remove the value. 
2. Click Replace to change variables for the same link. Click the variable in the Field 

Values field. 
3. Click the new variable in the Name/Tag/Default Value field and click Replace. 
4. Click Remove All to remove all selected variables and links. 

Adding read/write parameters

The Read/Write tab enables you to: 

l Automatically combine screens. You can choose a caption from one field on one screen and 
automatically insert it as a caption in a second field on another screen. 

l Automatically navigate the user through the second screen. This helps the user to avoid 
retyping the same information over and over again. 

1. Click Screen > Get-to-the-Point. 
2. Click the Read/Write tab. 
3. In the To Write To parameters field, enter the name of the parameter (global variable), for 

example, Prm5. The parameters in the startup HTML or a parameter file are global 
parameters with values that are preset at startup. 

4. Click OK. 
5. Click File > Save to save the map. 
6. Click File > Open Map. 
7. Select the map that you would like to pass the data to. 
8. When the map is opened, select the object in which you want the data to be displayed. Use 

an existing object or create a new one. 
9. Click File > Close. 



10. Right-click the Object. The Set Object Properties window appears. 
11. Click the Read/Write tab. 
12. In the To Read From parameters field, type the parameter name from step #3. 
13. Click OK. 
14. Click File > Save to save the map. 
15. Click File > Close. 
16. Restart a session. When you view the second screen, you will see the data from the first one 

displayed in the selected object. 

Example of using Get-to-the-Point

Your host application has three screens that you would like to bypass. On the first screen, the only 
input required from the user is a user name and then the pressing of the F4 key. On the second 
screen, there is only a company logo and no input is needed from the user. On the third screen, the 
only required input is a user name (the same one as on the first screen) and a two digit password. 
After the password is entered, the user must press the F4 key. Users find these screens redundant 
and management would rather not publicize the fact that their password consists of only two 
characters. So you want to try and bypass these three screens. Your manager has also asked if it is 
possible for the user to simply see the new company logo while the screens are bypassed.

1. Open the first screen that you want to bypass. 
2. Click Screen > Get-to-the-Point. 
3. Click the Settings tab. 
4. Make sure that there is a check mark next to the On/Off option. 
5. To show only the logo, put a check mark next to the Suppress Display option. If there is a 

check mark next to this option, the user will not know that any screens are being bypassed. 
6. Select Initial Screen as the Controlling Events. This means that Get-to-the-Point is enabled 

when the screen is first recognized and handles all input, including the function key, on this 
screen. 

7. Click the Macro tab. This is where the fields that are on the original host screen are linked to 
their inputs and required function keys. 

8. The only required input from the user is a user name and then the pressing of the F4 key. In 
the Edit Source field, enter the name Kevin and click Add. Kevin is added to the Field Values 
field. To link this input to a field, highlight the word and link it to the proper field from the Link 
to Input Field field (to see which field you have highlighted from the Field Values field, move 
the Set Get-to-the-Point Properties window, and see which field is blinking on the screen). To 
add a function key to be pressed after this linked field, choose a function key from the 
function key scroll menu. 

9. Click Apply to save and OK to exit. 

Now you are ready to add Get-to-the-Point to the next screen. 

The second screen only has a logo and requires no user input. However, you do not want users to 
see the bypassed screens, only the logo. Navigate to this screen and then click Screen > Get-to-
the-Point. Make sure that the check box next to the On/Off option is checked. Click Initial Screen as 
the Controlling Events. Leave the Suppress Display option unchecked so that the logo will be 
visible. Leaving this option unchecked allows users to see the contents of the screens that they are 
bypassing. In this case, the contents of the screen is a company logo. You do not have to do 
anything on the Macro tab because there are no required input fields. Therefore, there is no need to 
link data with fields and function keys. 

Add Get-to-the-Point to the third screen. The only required input from the user is the user name 
(same as on the first screen), a password, and then the pressing the function key F4 after entering 
the other information. 



1. Go to the next screen and click Screen > Get-to-the-Point. 
2. Enable Get-to-the-Point on the Settings tab. 
3. Check the Suppress Display option (to hide this screen leaving the logo on the user’s screen). 
4. Check the Initial Screen option for Controlling Events. 
5. Click the Macro tab. Instead of entering the users name (Kevin) into the Edit Source field, use 

the Client HTML file to add this data (you have to make sure to set up the user’s name as one 
of the parameters). 

6. Click Read HTML. 
7. Select the Client HTML file from the root directory and click Open. The parameter names and 

values are displayed in the Select Source/Event field. 
8. Double click parameter 50 (it assumes you set this value to be the word Kevin) which you will 

see it in the Edit Source field. 
9. Click Add to add the parameter to the Field Values field. 

10. Highlight it and choose a field from Link to Input Field to link it to that field. You do not have to 
link a function key here because you still have to add the password to the screen before you 
any function keys are activated. 

To add the two-digit password to the screen, type 11 (Kevin’s password) into the Edit Source 
field (you could also use the Client HTML file to add this data, but it is faster to enter it). 

11. Click Add to add it to Field Values. Highlight the number 11 in Field Values, and link it to an 
input field by highlighting that field in Link to Input Field. 

12. Choose a function key and click Apply and then OK to exit. 

You may have noticed that there is no object associated with Get-to-the-Point. There is no button to 
place on the screen, and nothing to resize. Get-to-the-Point is a screen-based function, which 
means that there is no way of seeing Get-to-the-Point on the screen. There are two ways to see if 
Get-to-the-Point is activated on the screen. 

l In the Customization Studio, click Screen > Get-to-the-Point. Click the Settings or Macro tab. 
If there is data in Field Values on the Macro Tab or if the defaults on the Settings tab have 
been changed and the On/Off option is checked, then Get-to-the-Point is activated on this 
screen. 

l Start a session. All of the functions and features are active (you would know that Get-to-the-
Point is active by recognizing the host screens that were bypassed). 



Redirecting action keys

To redirect an action key:

1. Click Screen > Redirect Action Keys. 
2. Select a function from the Redirect Action Keys list. 
3. Select a function from the Function Key list. 
4. Click Add. The selected Function Key appears next to the selected Redirected Action Key. 
5. Click OK to save your changes and to close the Redirect Action Keys window. 
6. Save the changes in the map. 

To remove a selection:

1. Click Screen > Redirect Action Keys. 
2. Select the Redirected Action Key you would like to remove. 
3. Click the Remove Button. 
4. Click OK. 
5. Save the changes in the map. 



Remapping the keyboard

To remap a key:

1. Start from a host session window. 
2. Click Screen > Remap Keyboard. 
3. Click Add. 
4. Press the key or combination of keys that you want to remap. 

You can remap the following single keys: the function keys, the scroll keys, and the 
nonnumeric keys on the keypad. You can also remap combinations of keys, such as 
Control+C, Shift+Alt+A, Alt+Shift+Ctrl+B. 

5. Choose a function for the key. 
6. Click OK 

Repeat this procedure for any other keys you want to remap.

To remove a key from the list, click a key in the Remap Keyboard window, and click Remove. 

Remapped keys are processed before redirected keys.



Setting tab order

You can reset the tab order to reflect changes you have made to the structure of the screen and the 
field positions. A tab can be set to move to an input field or a button.

To change a tab order:

1. Click Screen > Set Tab Order. The Set Tab Order window displays all of the visible fields on 
the screen and assigns each field a number in the tab order. To view hidden fields, click Show 
Hidden Fields. Red numbers are fields too small to fit the whole number so the fields are 
temporarily enlarged. 

2. Enter the sequence number in the Next Tab to be Set to start from. This is the number that 
will begin the tab order for the field you click in the next step. 

3. Hold down the Ctrl key and click the field you would like to start changing the order from (this 
field is assigned the number from the Next Tab to Set field). 

4. Hold down the Ctrl key and click the next field in the sequence. 
5. To assign the Next Tab to be Set back to 1, click Reset. Fields are changed back to what they 

were before you changed them. 
6. To eliminate a field in the tab order, select the field and click Skip. 
7. Click OK. 

For this function to be active in run-time mode, the Host Mode option for Tab Key Control in the 
Administrator must be cleared. 

Use the Set Cursor option in the Get-to-the-Point Macro tab to set the cursor to the correct field after you 
have resequenced a tab order. If you don’t set this option, the cursor will move to the first field set by the 
Host, regardless of the number assigned to it.



Using global variables

Adding arithmetic functionality and string concatenation
Recalculating global variables
Using the look-up function
Creating or updating a Look-up table
Viewing global variables set for a screen
Setting precedence for global variables 

The global-variables functionality is the basis for combining screens along with the Get-to-the-Point 
facility. Applet parameters from the HTML file and command line parameters are automatically 
stored as global variables. In addition, field values from one screen can be saved in global variables 
for subsequent use on other screens. The global-variables feature also provides extensions which 
allow arithmetic manipulations, string concatenation, and a look-up function before values are 
stored. 

Adding arithmetic functionality and string concatenation

To perform arithmetic manipulations or string concatenation on a global variable:

1. Click Screen > Global-Variable Extension. 
2. Select either Use Global Variable Name or Use Fixed Value (Constant) for Operand 1 

depending on which type of value you are looking up. 
3. In the text field next to Use Global Variable Name, enter the first value that you want to 

manipulate arithmetically. It can be either a numeric value, a string, or the name of a value 
already stored as a Global Variable. 

4. Check Perform Table Look-up to get Value label to have the look-up file searched. When this 
option is checked, the value that corresponds to the value that you entered in the text field is 
used. 

5. Choose the type of operation that you want to perform from the list box under Perform the 
Operation. You can choose either addition (+), subtraction (-), multiplication (x), division (/), 
percent (%), or (&) for string concatenation. 

6. In the list box next to Rounded to, choose the number of decimal places to which you would 
like the result of your mathematical operation rounded to. 

7. Select either the Use Global Variable Name or Use Fixed Value (Constant) for Operand 2 
depending on which type of value you are looking up. 

8. In the text field next to Use Global Variable Name for Operand 2, enter the second value that 
you want to manipulate. It can be either a numeric value, a string, or the name of a value 
already stored as a Global Variable. It can also be a look-up value. 

9. Check Perform Table Look-up to get Value label to have the look-up file searched. When this 
option is checked, the value that corresponds to the value that you entered in the text field is 
used. 

10. In the text field for the Store Results as Global Variable option, enter the name of the Global 
Variable in which you would like to save the result of your calculation. If this global-variable 
name has already been assigned a value, the value is over written. If this Global Variable 
name has not been created (prior to this calculation) the name and value is assigned now. 

11. Click Add to Add this formula to the box on the left side of this Window. Parenthesis () around 
a value means the value has been designated for a look-up. Brackets <> around a value 
means the value is a global variable. 

12. Follow the steps above for each formula you want to add. 
13. Click OK. 



To remove a formula, select the formula in the list box and click Remove. 

To remove all of the formulas from the list box, click Remove All.

To replace a formula with the formula that you have created in the text boxes on the right side of the 
Set Global Variables Calculation Extension Window, highlight the formula you want to remove from 
the list box, and click Replace.

To insert a formula in between two formulas in the list box, highlight the formula which you would 
like to insert a formula before, and click Insert. 

If you assign a global variable to a label and an input field in the Customization Studio, you must 
restart the Administrator and click the calculator button in order to view those values. If you refresh 
the screen, the value assigned to the label appears, but the one assigned to the input field will not. 

Recalculating global variables

A special button can be added to recalculate global variables. This may be required to ensure that 
the proper values of fields are calculated when data is entered out of sequence. When recalculation 
is performed, the following three steps required to synchronize the global variables are initiated: 

1. Global Variables are loaded from the fields on the screen. 
2. Calculation and look-up operations are performed. 
3. Global Variables are displayed on the assigned screen objects. 

To set-up a recalculation button, in the Macro Tab of a button, an image button, or a toolbar button, 
choose the Perform Calculation (<P_C>) Macro command. The equal.gif image is provided for use 
with a recalculation button.

Using the look-up function

The look-up function can be used to look up rates, such as exchange and tax rates, and use them 
with the values that are stored as Global Variables. A special utility maintains these look-up tables in 
order to ensure that the values are as current as possible. The look-up file is in XML format and is 
stored on the server. It is downloaded at the initial loading of the client applet. You can use any XML 
editor or use the latest versions of Database software that supports XML format, for example, IBM’s 
DB2 and Oracle 8i.

Creating or updating a look-up table

Look-up tables should be structured in XML format: name="value". For example, USD="1.3456."  
The look-up table file must include a header (<LOOKUPTABLE) and a trailer (/>). 

To create or update a Look-up Table: 

1. Open the a Look-up Table file in a text editor or create a new Look-up Table file by creating a 
new file in the text editor. 

2. Type in the appropriate header at the beginning of the table. 
3. Type in the Look-up Table information. The data should be in the name="value" format. Make 

sure that there are no extra spaces in these lines. 
4. Insert a trailer at the end of the table. 



5. Save the file in the custom/wsp directory (transfer the file, if necessary, to the Web server). 

The default name of this Look-up Table file is lookup.xml. The name of the Look-up Table file is 
specified as a parameter in the Administrator or Client HTML file or a parameter file for Personal 
Communications. To perform a look-up against a file with a different name, change the following 
parameter: 

<param name=lookupfile  value="lookup.xml">

Viewing global variables set for a screen

To view global variables by screen:

1. Click Screen > Global-Variable Extension. 
2. Click View Global Variables. 
3. Click View by Screen. 
4. Select a Screen from the list of screens or double click on one of the screen IDs from the list. 

The screen window appears. 
5. In the Screen window, you can see which Global Variables appear on the selected screen, 

what types of variables are used (Input (Parameter to write to...) or output (Parameter to read 
from...), what types of fields are associated with the variables and the positions of those 
fields. You can also see if any calculations have been set up on the screen. 

You can open more than one Variable or Screen window at a time. 

Setting Precedence for Global Variables

Global variables set in the HTML file are immediately available. Others are available on Screen 
Enter or Screen Exit.

Screen Enter: 
Global variables set on previous screens are still set and are available. Global variables new 
to the current screen are not written yet. They are written on screen exit or P_C (perform 
calculation). All labels and textfields are set to their global variables if the gvs are set. Global 
variables calculated from Global Variable Extension are not written yet. They are written on 
P_C. Lookup table is only accessed on P_C. 

Screen Exit: 
Global variables new to the current screen are written and available for future screens. 

When using Get-to-the-Point, global variables are set on screen enter and exit as listed above.



Understanding Screen modes and customization

Host applications can have more than one mode for the same screen. For example, the same 
screen might appear in different modes when you are creating, reviewing, or updating a common 
record for data entry. Even though the screen structure is the same for a screen in all modes, the 
status of specific fields may be different depending on the screen mode. For example, in one mode, 
the screen might have one or more specific fields displayed as labels, but a different mode of the 
same screen might have these fields displayed as input fields.

If your host application has screens running in different modes, carefully consider what changes you 
make before making them. To customize screens separately, use a tag. To use the same 
customization for all instances, be familiar with the host application because a field could have a 
changeable appearance. Know the status of the fields on the different host screens in all the modes 
these screens might have. For example, a label can appear empty and you will want to delete it or 
move it. However, that label might contain information such as an error message at a different time 
in the application.



Viewing global variables 

To view global variables:

1. Click Screen > Global-Variable Extension. 
2. Choose a Global Variable from the list of Global Variables. 
3. Click View by Variable, or double click on one of the Global Variables from the list. 
4. In the variable window, you can see on which maps the selected variable appears, whether it 

is used as input (Parameter to write to...) or output (Parameter to read from...), what type of 
field it is used in, and the position of that field. You can also see if any calculations have been 
set up using that variable. 



Viewing screen information

Click Screen > Customization Info to view information about a specific screen.



Adding a button

Buttons can be added to replace function keys. Most host applications have a list of commands and 
their associated shortcut keys at the bottom of the application screen. Instead of using function keys 
to move through the screens, you can use PF keys for buttons. The PF keys are still valid. Even 
though lists of PF keys are turned into hotspots, adding buttons is still valuable. Clicking buttons is 
faster, more intuitive and more convenient than searching through the list of PF keys for the proper 
function. Buttons can be placed anywhere on the screen, so users do not have to search through 
the list of PF keys on the bottom of the screen. You can also add Buttons to execute new functions.

To add a button: 

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. To change the properties of the button, right-click the button and select All Properties. 

Adding a disconnect session button

You can add a button to log the user off of the host system. This is very important in cases where 
the standard exit keys keep the session connected, wasting LUs on the host.

To add a disconnect button:

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Select the predefined Close window command from the Select Source or Event list (<C_W> - 

Close window). 
5. Click Add.

If you click the Disconnect Button in a session window, it will close the connection. 
6. Click OK. 

Adding a button to launch a macro file

To add a button that launches a macro file: 

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Select the predefined Launch Macro File command from the Select Source or Event list 

(<P_M> - Launch Macro File) and indicate the Macro File that should be launched. 
5. Click Add. 
6. Click OK. 

Click here for information about creating and updating a macro file. 

Adding a start new session button

To add a button that starts a new session:



1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Select the predefined Start New Terminal Session command from the Select Source/Event 

list (<N_S> - Start New Terminal Session). 
5. Click Add. 
6. Click OK. 

When you click Start New Terminal Session button, it starts a new host session using the same 
configuration as the first session. 

Adding a run user applet button

To add a button that runs a user-created class: 

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Select the predefined Run User Applet command from the Select Source/Event list (<R_A> - 

Run User Applet). 
5. Optionally, add the name of the class file to run. If no class is specified, when the button is 

clicked, a dialog appears that prompts for the class. 
6. Click Add. 
7. Click OK. 

When you click the Run User Applet button, the appropriate class will be constructed using the 
default constructor, and the init() method will be called. 

Classes which are run using the Run User Applet command must implement a default constructor 
and the com.ibm.eNetwork.ECL.ECLAppletInterface. The interface definition can be found in the 
Host Access Class Library (HACL) reference of either Host On-Demand or Personal 
Communications.

Adding a file transfer button

To add a button that shows either the send, receive or defaults window for File Transfer:

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Select one of the predefined File Transfer commands from the Select Source/Event list 

(<S_F> - Send files to host, <R_F> - Receive files from host, <F_D> - File-transfer defaults). 
5. If the button is a toolbar button or an image button, add the appropriate image to the button 

by right-clicking the button, selecting General, and completing the tab. The following images 
are provided: 

� ft_send16.gif - Send Files 
� ft_recv16.gif - Receive Files 
� ft_def16 - File Transfer Defaults 

6. Click Add. 
7. Click OK. 

When you click the File Transfer button, the appropriate window will be displayed.



Adding a check box

Check boxes can be added to replace an input field. They are especially valuable when the input in 
a particular field has to be one item from a short list of Valid Values. For example, if your host 
application has a field that requires the user to enter an age from a list of valid ranges, it is easier to 
have a check box associated with this range. Adding check boxes reduces invalid inputs and makes 
it easier for the user. 

To add a check box: 

1. Click Create > Checkbox. 
2. Place the check box on the screen by clicking the left mouse button. 
3. Right-click the check box and select a property or All Properties to change the properties. 

Linking a check box to a host field

1. Right-click the check box and select Settings. 
2. Enter a caption or change the current one. 
3. Link the check box to the proper input field by selecting it from the list of host fields displayed 

on the right. Input fields are displayed by their position, row, column, and length on the host 
screen. The length of the input field is displayed to indicate the maximum size of the string it 
can accept. 

4. The selected field blinks on the screen. 
5. Set the initial state (default) of the object as checked or unchecked (one check box can be set 

as the default to save time for users). 
6. Set the Strings to be sent to host. These are strings to be sent to the linked input field during 

a session depending on the state of the check box. 
7. Click OK. 



Adding a choice box

A list of choices can be added to the interface as input fields. Choice boxes can be used to replace 
input fields that accept one value from a short list of possible values. For example, a host field may 
require a one-letter input that represents the first letter of a word from an associated label. You can 
replace the input field and the associated label with a choice box. The user chooses the input from 
the choice box and it is sent to the host.

1. Click Create > Choice. 
2. Place the choice box on the screen by clicking the left mouse button. 
3. Right-click the choice box to change the properties. 

Changing choice box settings 

1. Right-click the choice box and select Settings. 
2. Add items to the choice list by entering them in the Set Item field and then clicking Add. 
3. Click OK. 

Annotated translations of values for choice boxes

This feature allows you to set up choice boxes to send a value to the host that is different than what 
is displayed. For example, the end user sees the word "Italian Lira", but only the characters "ITL" 
get sent to the host.

To set up annotated translations of values for choice boxes:

1. Click Create > Choice. 
2. Right-click the choice box and select Settings. 
3. In the Set Item box, enter a description, a tilde (~), and a name. For example, Italian 

Lira ~ ITL 
4. Click Add. 
5. Click Apply. 
6. Click the Host Link tab. 
7. Select a type of Link to Host field (All, Unprotected, or Protected). 
8. Select the Position, Row, Column, and Length of the Linked Field Value. The selected field 

will blink on the screen. 
9. Click Apply. 

10. Click OK. 
11. Click File > Save. 
12. Open an Administrator session. 
13. Click Actions > Refresh. 
14. Select the description from the choice list box and the value appears in the linked field. 



Adding a frame

Frames can be used to group objects. For example, if you replace an input field with a set of radio 
buttons, you may want to surround the group of radio buttons with a Frame to show the user that 
these buttons are related.

To add a frame: 

1. Make sure the space on the screen is clear for the Frame. To clear space, hide fields by 
selecting them and clicking Edit > Hide. 

2. Click Create > Frame. Your mouse pointer changes. 
3. Using the mouse, draw a frame on the screen. 
4. Click View > Frames to change the properties of the Frame. 

Editing frames

The Frame Properties window can only be accessed from the List of Frames. A frame can not be 
selected as an active component on the screen just by clicking on it. 

1. Click View > Frames to edit any of the frames on the screen. The List of Frames window is 
displayed. 

2. Select the frame you want to edit. Your selection appears on the customization screen with 
the sizing handles. You can only edit one frame at a time. 

3. Click Move or Resize. 
4. Click Up, Down, Left, and Right to move or resize the frame. To resize, click Up and Left to 

minimize the frame and Down and Right to enlarge the frame. 
5. Click Show or Hide to show or hide a frame on the screen. 
6. Click Delete to delete a frame. 
7. Click Properties. 

1. Click the General tab. 
2. If required, enter a caption. 
3. Choose the position of the caption by selecting from the Set Caption Alignment group. 
4. Choose the Frame style from the Set Frame Style group. 
5. Click OK. 

8. When finished, click Close. 



Adding an image

Images can be inserted to add visual appeal to your host application. Host applications are 
character-based programs and most images are made out of characters. You can add images to 
the screen or replace old green screen style images. Images can be used to clarify things on the 
screen and can be used in place of labels. Only image files with a .gif or .jpg extension are 
recognized and must be located in the /custom/img directory. 

To create an image: 

1. Click Create > Image. 
2. Select the image (*.gif or *.jpg) that you want to insert from the custom/img directory, and 

click Open. 
3. The image appears anchored to your mouse pointer. 
4. Place the image on the screen by clicking the left mouse button. 

Changing an image

1. Right-click the image and select General. 
2. To select an image, click Browse, select an image, and click Open or enter the name of an 

image. 
3. Click Delete Image to remove the image. 
4. Click OK to save and exit. 



Adding an image button

Image buttons add the same functionality as a regular button, but you can add an image to the 
button. You can change the colors of image buttons from the default gray to almost any color. This 
is useful if you are putting your application on the Web and allowing your clients to access it 
remotely. 

To create an image button: 

1. Click Create > Image Button. The image button appears anchored to your mouse pointer. 
2. Place the button on the screen by clicking the left mouse button. 
3. Right-click the image button to change the properties. 

Changing image button settings

1. Right-click the image button. 
2. Click the General tab. 
3. Enter a caption to appear on the image button. 
4. Choose the position of the caption in regard to the image on the button. 
5. To select an image, click Browse and select an image and click open or enter the name of an 

image from the /custom/img directory and click View. 
6. Click Delete Image to remove an existing button image. 
7. Click Top, Center, Bottom to position the caption within the button. Click Blend with Image to 

superimpose the caption in the image. 
8. Click OK. 



Adding a label

Label fields can be added to the host screen to replace or augment the host protected fields. They 
can also be used to add color to the screen. Adding a Label (or editing an existing Label’s caption) 
can clarify a confusing screen. Labels can be used to describe input fields, or to display valuable 
information on the screen. For example, if you are Web enabling your application, you can put the 
phone number of your help line on the bottom of the screen to show users where to call if they need 
help.

To create a label: 

1. Click Create > Label. 
2. Place the label on the screen by clicking the left mouse button. 
3. Right-click the label to change the properties. 



Adding a list

Lists, much like check boxes and choice boxes, can be added to replace input fields that have a 
certain number of Valid Values. A list graphically displays a list of strings and is scrollable if 
necessary. In addition, a user can change the size of the list. 

To create a list: 

1. Click Create > List. 
2. Place the list on the screen by clicking the left mouse button. 
3. Right-click the list to change the properties. 

Changing list settings

1. Right-click the list and select Settings. 
2. Select the input field you want to link the list to. The current value of the selected field is 

displayed in the Linked Field Value box. 
3. Click OK. 

Adding a host link

1. Right-click the list and select Host Link. 
2. To add a character string to the list of values, type this string into the Set Item box and click 

Add. 
3. To replace a string, select it from the list of values, type the new string in the Set Item box and 

click Replace. 
4. To remove a string, select it from the list of values and click Remove. 
5. To clear all values, click Clear All. 
6. Click OK. 

Annotated translations of values for list boxes

This feature allows you to set up list boxes to display a description that is different than the value 
sent to the host. For example, the user sees the word "Italian Lira", but the only characters "ITL" get 
sent to the host.

To add annotated translations of values for list boxes:

1. Click Create > List. 
2. Right-click the List box and select Settings. 
3. In the Set Item box, type a description, a tilde (~), and a name. For example, Italian Lira 

~ ITL. 
4. Click Add. Click Apply. 
5. Click the Host Link tab. 
6. Select a type of Link to Host field (All, Unprotected, or Protected). 
7. Select the Position, Row, Column, and Length of the Linked Field Value. The selected field 

will blink on the screen. 

If you are creating a list for Internet Explorer 4.0 users, you must adjust the list size to the font size 
of the list item. Otherwise, the list might appear in an unusual form and be disabled. It is 
recommended that you set the height of the list to at least two selected font sizes and width to the 
length of the longest entry.



8. Click Apply. 
9. Click OK. 

10. Click File > Save. 
11. Open an Administrator session. 
12. Click Assist > Refresh. The name appears in the linked field. 



Adding a radio button

Radio buttons can be added to the interface to replace an input field. These are useful for input 
fields that accept one value from a short list of possible values. For example, if the host requires the 
user to input a yes or no, two radio buttons can be used as the input field. Radio buttons let you set 
a default setting. For example, you can set Yes as the default. Radio buttons are very similar to 
check boxes. 

To create a radio button: 

1. Click Create > Radio Button. 
2. Place the button on the screen by clicking the left mouse button. 
3. Right-click the radio button to change its properties. 

Changing radio button settings

1. Right-click the radio button and select Settings. 
2. Select a field from the Link to Host Field box and its caption appears in the Linked-Field Value 

box. The Link to Host Field shows all the input fields, which are displayed according to their 
position, row, column, and length. The length of the field is shown to indicate the maximum 
size of the string it can accept. When you select a field it will blink on the screen. 

3. Set the number of radio buttons in the Number of Buttons box (default is 2, maximum is 48). 
4. Set the number of rows and columns in the Layout group of text boxes. A sample radio button 

layout, which is below the "Number of Columns" label in the Set Radio Button Properties 
window, will reflect the selected number of rows and columns. You can also select the 
number of columns and rows by dragging the bottom right corner of the sample radio button 
layout. 

5. Click OK. 



Adding a text field

Text fields can be added to the interface as input fields. They can be used to replace other Text 
fields or to replace previously customized objects. For example, you replace an input field with a 
group of radio buttons. During a review of the application, you notice that the screen with the radio 
buttons looks too busy and would be more effective using the text input field. Instead of searching 
through all of the hidden objects, you can add a text field and link it to the original text field.

To create a text field: 

1. Select Create > Text Field. A Text Field appears and is anchored to the mouse pointer. 
2. Place the text field on the screen by clicking the left mouse button. 
3. Click with the right mouse button to change the properties of the Text Field. 

To make an input field protected, create a label, link it to the input field and then hide the input field.



Adding valid values and field help

You can provide the user with field help descriptions and valid values lists. You can create a 
reference file to use help created for one field or many fields without retyping help or valid values 
files.

Valid values buttons can also be created to help the user navigate through the host application. You 
can either add valid values to the field itself, or insert a valid values button near the field to display 
the valid values list. If you give your valid values buttons the same look, users can recognize and 
use them to get help. 

To create help or valid values: 

1. Click the input field where you would like to attach help or valid values. 
2. Select File > Edit Field Help or File > Edit Valid Values. 

� To add field help, enter the help text in the window that appears. 
� To add a valid values list, enter the value followed by a tilde (~) and its description. In 

the Valid Values window, characters before the tilde appear as the value and 
characters after the tilde appear as the description. Every valid value with its description 
is displayed on a separate line. In the Client, you can highlight a value in the valid 
values list as a default value. Click Copy, and the value appears in the proper field. As 
an alternative, you can create a valid values button and position it next to the field to 
give the user help. 

3. Click Save. The file name contains a screen ID followed by row and column positions of the 
field. If you would like to use this file as a reference file later on, save it as a more appropriate 
name using the Save As button. Make sure that the valid values file is saved in the /custom/lst 
directory and that the field help file is saved in the /custom/lang/help directory. 

4. Close the window. 

The field help appears as What is it? and the valid values list appears as Valid Values in the 
Administrator or Client. 

To view field help: 

1. Click or tab to the field where you need help. 
2. Click Service > What Is It?. A small text box appears with information about this field (if one is 

available). 
3. Click Close on the field help window. 

To view a list of valid values: 

1. Click or tab to the field where you need to view Valid Values. 
2. Click Service > Values. A text box displays a list of Valid Values for this field if one is 

available. If you have a Valid Values button next to the input field, you can click on it to view 
the list of Valid Values available for this field. Every valid value appears on a separate line. If 
a description of a value is available, then you will see a value followed by a tilde "~" symbol 
and description. 

3. Select an item in the list and click Copy to enter the value into the field. 

If your keyboard is set to US(International), the tilde(~) does not display until the next 
character is typed. However, if the next character includes a tilde accent, then the accented 
character is displayed. 



Creating a reference file

1. Click the input field where you want to attach a reference file. 
2. Click File > Edit Reference File. Enter the name of the file that contains the valid values list or 

the field help description with the appropriate extension. If you want this file to refer to the 
valid values list and the field help description, enter the names of the files on separate lines. 

3. Make sure that the reference file is saved in the /custom/ref directory with the extension *.ref. 
4. Click Save. 

Adding a caption or image

1. Right-click the Valid Values Button and select General. 
2. Enter a caption that you want to appear as a tool tip for this button. 
3. Click Set Image to insert an image (*.gif or *.jpg) on top of a Valid Values Button. This image 

must be saved in the /custom/img directory. If you want to change an existing button image to 
a default image, click the Default Image Button. 

4. You can see how your Valid Values button will look from the Valid Values Button Properties 
window. You can also change the view from Standard to Dynamic. 

5. Click OK. 



Adding a Web-link button

A Web-link button brings users directly from the host application to the Web. The button must be 
linked to a Web site and can also be linked to a field on the screen. Web-link buttons can either link 
to a fixed Web site, or data from the screen can be used to create dynamic links.

To create a Web-link button: 

1. Click Create > Web-link Button. 
2. Place the Web-link button on the screen by clicking the left mouse button. 
3. Click the right mouse button to change the properties of the Web-link button. 

Changing a Web-link button caption or image

1. Right-click the Web-link button and select General. 
2. Enter a caption for the tool tip in the Statusbar Tip field. 
3. Enter a caption for the Web-link button in the Enter Caption field. 
4. Choose the position of the caption for the button. 
5. Optionally, insert an image on a Web-link button.

If you want to erase an existing button image, click Delete Image. 
6. You can see how your Web-link button will look from the Set Web-link Button Properties 

window. Change the position of the caption to see how it looks in each position. 
7. Click OK. 

Selecting a URL address and linking a button to a specific field

To link a button to a specific field, right-click the Web-link button and select Macro. 

Web-link Buttons must have something input directly into the Edit Source box for them to work, 
regardless of whether all users are automatically being sent to the same Web site or information is 
being taken from the screen and being used as part of the URL address. This is so that if all users 
are automatically sent to the same Web site, then that Web site’s URL address must be entered 
into the Edit Source box. In order to use dynamically changing host output or the user’s own input to 
determine the Web address, the partial URL address is used to activate the Link to Host Field box. 
A partial URL address can be anything from the base part of an address (http://www.) or an actual 
homepage (http://www.ibm.com/) to a forward slash (/), a period (.), or a "dot com" (.com). 

Putting data directly into the Edit Source field

There are two ways to input data directly into the Edit Source Box: 

l Type the whole URL address directly in the Edit Source box and click Add. The value appears 
in the Command Line Parameters field. 

l Insert data from a Client HTML file and click Read HTML. Select the HTML and click Open, 
and variables are displayed in the Select Source list box. Select the data from the Select 
Source list box and the parameter’s name are immediately displayed in the Edit Source box. 
Click Add and the data appears in the Command Line Parameters field. 

Make sure you have already set a URL address as a parameter in the HTML or parameter file. 



Linking the Web-link button to a field

You can take information from any field (user-defined or a system-defined field) on the screen and 
use it as another part of the URL address.

Fields can be linked to partial Web site addresses only from the Command Line Parameters field, 
so there has to be at least one partial address selected in the Command Line Parameters field 
before you can link the button to a field. The list contains the command line represented as a list of 
its parameters shown in their real order. A parameter can be some text or symbol or an HTML 
parameter name as well as a global variable. There can be more than one partial address in the 
Command Line Parameters field. When there is more than one address in the Command Line 
Parameters field, the Web-link Button will read all of the partial addresses from top to bottom, and 
construct the URL address in this order as well. The URL address is interpreted in this order: top 
partial address in the Command Line Parameters field-Field linked to this address, second partial 
address in the Command Line Parameters field-Field linked to this address.

For more informaation on using fragments and variables in URLs, click here.

HTML parameters can be selected from the Select Source list. To fill the Select Source window with 
the list of available HTML parameters, open the proper HTML file by clicking Read HTML. 

To add a new parameter to the Command Line Parameters list, enter it in the Edit Source field and 
click Add. 

To replace a parameter, select it from the Command Line Parameters window, change it in the Edit 
Source field and click Replace. If you click Add instead of Replace, the modified parameter will be 
added to the end of list without replacing the old one. 

All of the input fields are listed in the Link to Host Field field. Click the partial address in the 
Command Line Parameters window that you would like to link. Then, click the host field you want to 
link the partial address to. This field will blink on your screen. The value from this field is what is 
going to be added to the URL address and includes an equal sign (indicating that this is a 
parameter). 

For example, if you type http://www  in the Edit Source field (as the partial address), and then link 
the button to a label that reads ibm.com, your Web-link Button will point to the URL address 
http://www.=ibm.com. 

To prevent the equal sign from being added, add a blank line to the command-line parameters list 
and then link the blank line to the host field. Or, you can enter the full URL for the Web-link button. 

This is an example of how a Web-link Button can be used. A more useful way to use a Web-link 
button is to use data from the host to determine which URL address the user is going to be sent to. 
An example of this is in the next section.

Since the Command Line Parameters field reads information from top to bottom, you may find it 
necessary to reorder or change the information in this field to make the Web-link button functional: 

1. Click Insert to insert a value from the Edit Source field in between two already existing values 
in the Command Line Parameters field. 

2. Highlight the value and click Remove if you want to remove the value. 
3. Replace allows you to change variables for the same link. Click the variable in the Command 



Line Parameters field. Click the new variable in the Select Source field and click Replace. 
4. Click Remove All to remove all selected variables and links. 
5. Click Apply to save the changes, and OK to save the changes and exit. 

Example of using a Web-link button

You have a mainframe program that acts as an inventory ordering system for a cup supplying 
company. There is a screen titled "Mug Orders" that contains three user input fields, three host 
output fields and their associated labels: "What Type," "What color," and "What material." There is 
also a button labeled "Send Order."

The Valid Values for the "What Type" field are ’coffee’ or ’tea’. When the user inputs a word into the 
"What Type" field, that exact word is reproduced in the associated host output field. The Valid 
Values for the "What Color" field are ’yellow,’ ’green,’ or ’red.? The Valid Values for the "What 
Material" field are ’Ceramic’ or ’Styrofoam.’ In both the "What Color" and "What Material" fields, the 
system interprets the user’s input and translates it into a number which it outputs in the associated 
host output field. For example, if the user inputs information for a ceramic green tea mug, the output 
in the host fields are tea (tea) 2 (green) and 1 (ceramic).

There have been many problems with mug orders lately, and you have deduced that the problems 
are caused by people not knowing exactly what they are ordering. You believe that if you could 
show people a picture of what they are ordering before they actually send the order, that 90% of the 
mistakes will be corrected.

You know that all of the pictures are on your Web site (homepage: www.mug.com) according to 
their system-defined values (for example, a ceramic green tea mug can be found under 
www.mug.com/tea/2/1). You would like to link a Web-link button to the fields on this screen. Once 
you set up the Web-link button, users will be able to click it and go directly from the mainframe 
application to the specific URL address that is dependent on what they input on the screen. Then 
they can see what they are ordering before they actually send the order, and the problem with the 
mug orders will be solved.

Creating a Web-link button example

1. Click Create > Web-link Button. 
2. Position the Web-link Button on the screen. 
3. Right-click the button. 
4. Click the Macro tab. You can only link data that is already in the Command-Line Parameters 

box. The only way to get data into the Command Line Parameters box is through the Edit 
Source box. 

5. Type www.mug.com/ into the Edit Source box, and then click Add. That value is added into 
the Command Line Parameters box. 

6. To link the button to a field, highlight the value in the Command-Line Parameters box, and 
then choose the field from the Link to Host Field box. You want to link this data with the host 
field associated with the "What Type" input field. You can memorize the row and column 
position of the field, or you can move the Get-to-the-Point window aside to see which field is 
blinking (the field that you select in the Link to Host Field Box will blink on the screen). 

7. Enter a slash ’/’ into the Edit Source box, and click Add. The value is now added to the 
Command Line Parameters box. Click Add again, and that same value is added to the 
Command-Line Parameters field again. 

8. Select the top forward slash (/) in the Command Line Parameters box, and link it to the host 
field associated with the "What color" input field. 

9. Select the second forward slash and link it to the host output field associated with the "What 
Material" input field. You have to be careful that everything is in the correct order, or else the 



URL address may be invalid. Items are read from top to bottom and left to right in the 
Command-Line Parameters box. The URL address is built starting with the first item in the 
Command-Line Parameters box, then the data from the associated linked field, then the 
second item in the Command Line Parameters box, and then the data from the associated 
linked field.) 

10. Click Apply to save the changes to the macro tab or OK if you have finished. Click OK to 
close the Web-link Button. 

Using a Web-link button to request a separate window browser

Web-link buttons open the requested URL in either the active session or in a new browser session, 
which can be closed after it is used. A new browser window is always opened when using Personal 
Communications.

1. Open the Client HTML file in a text editor. 
2. Add the parameter, NewWindow, for determining how a new document will open. If the 

NewWindow value = false when you click the Web Link button, the link is opened in the active 
session browser window. If the NewWindow value = true, a new browser window is opened. 
true is the default value. Save your changes and close the browser. 

3. Click File > Customization. 
4. Click Create > Web-link Button. 
5. Right-click the Web-link Button and select Macro. 
6. In the Edit Source box, type the URL address of the browser you would like to use. 
7. Click Add. 
8. Click OK. 
9. Click File > Save. 

10. Open the Client to view the parameter change. 
11. Click the Web-link Button. The new browser window opens. 



Understanding the customization of objects

Customize on the screen level (font and color) before customizing objects. 

If a screen appears cluttered, hide the empty host fields by clicking Edit > Hide. Do not hide fields 
that may be used by the host at a later time (for example, fields that display error messages). 

If you select one object from the List of Objects window, you can change all of its properties 
(Caption, Font, Color, and Macro). If you select a group of objects from the List of Objects window, 
you can only change group properties (font and color). You can select groups of objects in screens, 
templates, and in the Import From window. 



Adding a macro to an object

Macro buttons can be used to send information to multiple fields on the same screen. In addition, 
these buttons can send information to be stored in the global parameters for use in combining 
screens, or in support of the Get-to-the-Point facility.

To create multi-field macro buttons: 

1. Click Create > Button. 
2. Place the button by dropping it on the screen. 
3. Right-click the Button and select Macro. 
4. Enter a Keystroke string to be sent. 

You can either insert data manually or from a Client HTML file for Host On-Demand or a 
parameter file for Personal Communications. 

To insert data manually: 
1. Type a value in the Edit Source field. 
2. Click Add. 

The value appears in the Field Values box.

To insert data from an HTML file: 
1. Click Read HTML. 
2. Select the Client HTML file. 
3. Click Open and variables are displayed in the Select Source or Event field. 
4. Select the data from the Select Source or Event box and it is immediately displayed in 

the Edit Source field. 
5. Click Add and the data appears in the Field Values field. 

Below is a part of an Client HTML file that a macro button uses:

<PARAM NAME="LASTINDEX" VALUE="100">
<!-- ALL THE PARAMETERS BELOW ARE USED FOR Get-to-the-Point UTILIT
<!-- PRM 1,2,3,4,11,15,21,31,41,SUBDIR ARE USED AS AN EXAMPLE -->
<PARAM NAME=PRM1 VALUE="LCMN">
<PARAM NAME=PRM2 VALUE="TAG~">
<PARAM NAME=PRM3 VALUE="33333">
<PARAM NAME=PRM4 VALUE="TAG">
<PARAM NAME=PRM15 VALUE="L APPLID=CICSTES1">
<PARAM NAME=PRM11 VALUE="0000"> 
<PARAM NAME=PRM21 VALUE="21"> 
<PARAM NAME=PRM31 VALUE="31F">
<PARAM NAME=PRM41 VALUE="41DD">
<PARAM NAME="SUBDIR" VALUE="XXXXXXXX">

The first line of this example shows the maximum number of macro parameters that 
can be used in the program. The parameters can be entered in the HTML file 
dynamically from any script (for example, Perl script) or manually. 

5. In the Field Values box: 



Creating or updating a macro file

Macro commands should be structured in these formats: <function key>* or keystroke string*. 
For example, <Enter>*

To create or update a macro file:

1. Open the macro file in a text editor. You can use any editor (for example Notepad) or, in the 
Customization Studio, you can use the editor that is used to edit Valid Values and Help files or 
create a new macro file in the text editor. 

2. Type in the macro commands. The data should be in the <function key>* or keystroke string* 
format. Each Macro command has to be on a separate line. 

You can use the following function keys: <Alt-f>, <Alt-r>, <ATTN>, <Backspace>, <Clear>, 
<Ctrl-Delete>, <Ctrl-F10>, <CursorDown>, <CursorLeft>, <CursorRight>, <CursorUp>, 
<Delete>, <End>, <Enter>, <ErsEOF>, <ErsInp>, <F1> through <F24>, <Home>, <Insert>, 
<NewLn>, <PA1>, <PA3>, <PgUp>, <PgDn>, <Reset>, <Shift-Tab>, <SysReq> and <Tab>

3. Save the file with a .kbt extension in the custom/map directory and transfer the file (if 
necessary) to the Web server. 

l Make sure that there are no extra spaces in these lines. 
l Commands must be typed exactly as shown. 
l Asterisk (*) must be included. 



1. Select the data that you would like to link. 
2. Click the input field you want to link it to. 
3. Select a "Link to Parameter" in the list of host fields to send a value to a global variable. 

6. Select the field you want to link the input to or link to a global parameter. To link the Button to 
the proper input field, use the list where all fields are displayed according to their position, 
row, column, and length on the screen. The length of the field is shown to indicate the 
maximum size of the string it can accept. The selected field will blink on the screen. If the 
Properties window is blocking certain fields, it can be moved. 

7. Select a function key you want executed. This key will be executed after data has been input 
into the selected field. 

8. Repeat steps 4-6 to send more than one string. You can send as many strings as there are 
Text fields. 

9. Click OK to save and exit. 

l Set the parameter name in the Read/Write tab. 

A macro button not only fills in fields, it can automatically send a function key to the host as well. 
After you have selected data from the Field Values box:

1. Select a function key from the scroll list. 
2. Click Apply to save. 

If you would like to change information that you have already added to the Field Values field, or 
linked to specific fields on the screen: 

1. Highlight the value. 
2. Click Remove if you want to remove the value. 

To change variables for the same link:

1. Click Replace. 
2. Click the variable in the Field Values field. 
3. Click the new variable in the Select Source or Event field. 
4. Click Replace. 

To remove all selected variables and links, click Remove All. 



Adding read/write function to an object

You can combine screens so that an object from one screen is displayed dynamically as an object 
in another screen. You can either read information from or write information to the global 
parameters in order to use this information on another screen. However, you cannot "read from" 
until you have "written to."

For example, a data entry clerk needs data from two different applications when speaking to a 
client. Usually the client must wait while the clerk navigates through two different applications. By 
adding a button, the customer’s address (which is currently displayed on screen A of application 1) 
can be displayed on screen B of application 2, along with the information that is regularly displayed 
on this screen.

Parameters are accessible as long as you do not close all sessions.

To combine screens:

1. Start an Administrator session. 
2. In the Administrator screen, select the object that you want to take data from (to pass to 

another screen). 
3. Click File > Customization to open the Studio. 
4. Right-click the object in the Studio window and select Read/Write. 
5. In the Parameter to Write To field, enter the name of the parameter (global variable), for 

example, Prm5. The parameters in the startup HTML file or parameter file are global 
parameters whose value is preset at startup. 

6. Click OK. 
7. Click File > Save to save the map. 
8. Click File > Open Map. 
9. Select the map that you would like to pass the data to. 

10. When the map is opened, select the object in which you want the data to be displayed. Use 
an existing object or create a new one. 

11. Right-click the Object and select Read/Write. 
12. In the Parameter to Read From filed, type the parameter name from step #6. 
13. Click OK. 
14. Click the File > Save to save the map. 
15. Click File > Close. 
16. Restart a session. When you view the second screen, you will see the data from the first 

screen displayed in the selected object. 



Adding a link to a host field

1. Right-click the object and select Host Link. 
2. Select a host field to link to from the list of host fields on the right. This host field will blink on 

the screen. Current values for the selected host field is displayed in Linked Field Value. 
3. Click OK. 



Changing object caption

Captions can consist of any number of characters. You can also replace, partially substitute, add, 
and delete captions. 

1. Right-click the object and select Caption. 
2. Type a new caption, or change a previous caption, in the New field. 
3. Click OK. 



Changing object font

1. Right-click an object, or group of objects, and select Font. 
2. Clear Use Default Font. 

3. Select a Font, Style, and Size. Your changes are reflected beneath the boxes. 
4. Click OK to save and exit. The screen is resized to accommodate the selected font. 

Checking this box means the font settings will be inherited from another level.



Changing object colors

1. Right-click the object, or group of objects, and select Color. 
2. Select either Foreground (text) or Background. 
3. Select one of the colors available from the Basic Color palette or create a unique color and 

add it to a palette. To create a custom color: 
1. Clear Inherit Color. 

2. Click a color and then adjust the numbers that represent the color by clicking the arrows 
or entering a number. Color changes are reflected in the selected field box. 

3. Click Add to Custom Colors. 
4. Click one of the blank Custom Colors boxes. Now you can use this color for other 

objects on the screen. 

To create a sixth custom color, you have to overwrite one of the other custom colors on the 
palette. Objects using the overwritten color retain their color, but that color is no longer 
available. 

4. Repeat the steps above for each color you want to change. 
5. Click Defaults to return to the default colors. 
6. Click Apply to apply changes. Click OK to apply changes and return to the screen. 
7. Click OK. 

Checking this box means the color settings will be inherited from another level.



Copying an object

You can only copy or replicate objects that were created. 

To copy an object on the same map:

1. Click the object, or select a group of objects, that you want to copy. 
2. Move the mouse to the place on the screen where you want the object duplicated. 
3. Press the c key on your keyboard and the object is copied to the new location. 

To copy an object and put it on a different map, import the object from the original map to a 
template, and then distribute the object from the template to the other maps. You may have more 
than one map and/or template open at the same time from which you are importing objects. If you 
can not see the whole object move or hide the field that is covering the new object. 



Converting an object

The Convert option allows you to convert text fields into check boxes, radio buttons, choices, and 
lists; and labels into buttons, check boxes, radio buttons, choices, and lists (created objects are not 
convertible). Converted objects use common settings from the object-parent, but all new properties 
are empty. 

1. Click or tab to the object you want to convert. 
2. Click Edit > Convert > the new object (for example, to Checkbox). 

To change values of a converted object: 

1. Right-click the object. 
2. Select the object property you want to change or select All Properties to see the object’s 

current properties. 
3. Make changes to the properties and click OK. 

If an object was converted and you want to undo the conversion, click View > Objects. Find the 
object-parent (from the list of objects), which was hidden during the original conversion. Delete the 
converted object and click Show to show the originally converted object-parent. 



Creating objects

You can create new objects or replace existing host fields. To create an object, click Create from 
the menu and choose the type of object.

Every object has properties associated with it. Right-click an object and select properties. The 
Properties window outlines the characteristics of the object that can be viewed and modified. It is 
organized by related functions, grouped by tabs. There are four tabs that define appearance: 
General, Font, Color, and Appearance. Macro, Settings, Host Link, and Read/Write tabs define the 
functionality of the object. Each properties window may include the following tabs:

l General/Caption - assigns a caption to the object. Can be used to translate screens into 
another language. 

l Font - sets the font, and an object’s style, and size 
l Color - sets the object’s background and foreground colors 
l Macro - assigns data to be inserted into an input field and/or a function key to be executed 
l Appearance - sets the position and size of the object 
l Settings - links a created object to a host field 
l Read/Write - reads data from the object on the screen and places it as a global variable or 

picks data from the global variable and writes it to the object on the screen 
l Host Link - links a newly created text field to the host application field 

All changes made in the Properties option are applied only to the chosen object. 

When you are in a Properties window, click Apply to see the results of customization and OK to save 
and exit.



Deleting an object

Original host objects cannot be deleted. To remove them, either hide them or shrink them to zero. 
To delete an object that was created:

1. Click the object you want to delete. 
2. Click Edit > Delete or press Delete on the keyboard. 



Hiding an object

1. Select the object you want to hide. 
2. Click Edit > Hide or use the space bar on the keyboard. 

If you hide an object by mistake, click Undo. To show a hidden object, click View > Objects, select 
the hidden object and click Show. 

To Hide a group of objects, select the group of objects, right-click the group and select Hide. 



Moving an object

Using the keyboard

1. Click the object you want to move. 
2. Hold the Shift key and use the arrow keys to move an object. 

OR

1. Click the object you want to move. 
2. Move the mouse to the place on the screen where you want to move the object. 
3. Press the m key on your keyboard and the object moves to the new location. 

Using the mouse

1. Click the object you want to move. 
2. Drag and drop the object to the new location. 

When you move an object with the mouse, only the frame of the object is moved when the mouse button 
is held down. When you drop it, the whole object moves from its original location to its new location.



Resizing an object

1. Right-click the object, or group of objects, and select Appearance. 
2. Enter values in pixels for the Horizontal Position, Vertical Position, Width, and Height of the 

Button. 
3. Click OK. 



Splitting a host field

You can split host fields into any number of objects and have those created objects input into 
specific areas of the original host field. For example, you can split a host input field that normally 
accepts the date in month/day/year format into three separate. This makes the application easier for 
the users and allows you to break-up long fields into manageable sections. 

When you use the split option, new fields are created on the screen to replace the original host field. 
The created fields have the same caption as the original host field and are in the same position on 
the screen, but the size (width) and number of fields is determined by the split that was chosen 
during customization. You cannot split fields that you have created. 

To split a host input field:

1. Right click the host field and select Split. 
2. The field that you have selected appears in the Split Window, along with the number of bytes 

that the field can accept.  Note that every fifth bytes is colored differently (green if you are 
changing a label, and blue if you are changing an input field). 

3. Select a place at which to split the original field by clicking on that position in the field in the 
Split window.  The field will automatically be split at that point, and the numbers of bytes that 
each of new fields can accept will be reflected in the split window. 

4. Split the field as many times as is needed by selecting other positions of the original field in 
the Split Window. 

5. Choose Hide Original Field to hide the original host field and show the created fields on the 
screen 

6. Choose Hide Created Field to show the original host field on the screen and hide the create 
fields. 

7. Choose Move Created Field to show the original host field, and to have all of the created 
fields selected so that they can be moved. To move the fields, move the mouse pointer to a 
new area of the screen, and press the control and "M" keys to place the created fields 
(CTRL+M). 

If you chose the wrong part of a field, and want to join a split field, click on the position in which 
you made the incorrect split. The dividing line will be removed, and the field will be reconstituted.



Viewing fields

Click View > Fields to see the positions of all objects on a screen. All objects on the screen have a 
border around them. 



Viewing objects

Click View > Objects. A window appears with a list of all of the existing objects on a screen. 
Minimize the list of objects to choose from by clicking the type of objects to view in the list. Click an 
object in the list to select it.



Viewing global variables 

To view global variables:

1. Click Screen > Global-Variable Extension. 
2. Choose a Global Variable from the list of Global Variables. 
3. Click View by Variable, or double click on one of the Global Variables from the list. 
4. In the variable window, you can see on which maps the selected variable appears, whether it 

is used as input (Parameter to write to...) or output (Parameter to read from...), what type of 
field it is used in, and the position of that field. You can also see if any calculations have been 
set up using that variable. 



Using fragments and variables in URLs

For Web-link buttons, you can also manually enter URL fragments into the Edit Source box and add 
them to the Command Line parameters list. 

You can construct dynamic URLs where part of the URL is a variable based on global variables, a 
label on the screen, or even text from a text field that the user has entered. There are two ways to 
insert screen data into the URL. If you connect the Command-line parameter directly to the host 
field, the macro inserts an equal sign (=) between the parameter and the user-supplied text. If you 
connect the URL fragment in Command-line parameter to a blank line and then connect the blank 
line to a host field, the macro does not insert an equal sign between the parameter and the user-
supplied text.

To insert screen data with an equal sign:

1. Double-click a Web-link button and select Macro. 
2. In the Edit Source box, type the URL you want to access. 
3. Click Add. 
4. In the Link to Host Field box, select the host field you want to link this URL to. Usually, this is 

a blank area where the user can enter text. 
5. Click OK. 

For example, if you wanted to add a Web-link button where users could check to see if there were 
any new IBM products that they wanted. To do this, you would complete the following: 

1. Add a Web-link button. 
2. Double-click the button and select Macro. 
3. In the Edit Source box, type www.ibm.com/products/?v. 
4. Click Add. 
5. In the Link to Host Field box, select the command line host field. 
6. Click OK. 

Using this button, users could then type the product they were interested in and click the Web-link 
button and the button would launch a new web browser window with information on their product 
(www.ibm.com/product/?v=product).

To insert screen data without an equal sign:

1. Double-click a Web-link button and select Macro. 
2. In the Edit Source box, type the URL you want to access. 
3. Click Add. 
4. In the Edit Source box, type a space. 
5. Click Add. 
6. In the Link to Host Field box, select the host field you want to link this blank space to. Usually, 

this is a blank area where the user can enter text. 
7. Click OK. 

Example?

In both cases, you can also link the parameter to an item on the screen, a label, or a text field.



You can also insert Global Variables read from an HTML:

1. Create a Web-link button. 
2. Double-click the button and select Macro. 
3. Click ’Read HTML’ to load HTML parameters into the Select Source box. The parameters will 

then appear in the Select Source box. 
4. Select and add the parameters to the Command-Line Parameters box. 
5. Click OK. 

For example, if you click Read HTML, and select an HTML file with the following lines in it: 

<Param name=LastIndex   value=5>
<Param name=Prm1        value=http://www.ibm.com/>
<Param name=Prm2        value=java>

The Select Source box will display two new parameters which can be used to create or amend a 
URL for a Web-link button. You could select Prm1 from the Select Source box and Add it to create 
a web link button that simply opens the URL http://www.ibm.com/. Note that the HTML used by the 
client must contain the above applet parameter lines for Prm1 and LastIndex. The Prmx values can 
be inserted or appended into the URL just like values from a linked label or textfield. 



Aligning a group of objects

1. Click View > Objects. 
2. Select the objects you want to align. 
3. Click Left, Right, Up or Down to align the objects. They are aligned according to the leftmost, 

rightmost, highest or lowest object from the selected group. 



Aligning a group of objects with an active object

The object that was selected before opening the List of Objects is designated the active object. 
Select another object to make it the active object. The objects that you choose subsequently are the 
objects that are going to be aligned with the original object. Click Left to align the left edge of the 
selected objects with the left edge of the active object or Right to align the right edge of the selected 
objects with the right edge of the active object. 



Moving a group of objects

To move a group of objects: 

1. Click View > Objects. 
2. Select the objects. 
3. Click Move and enter the number of pixels to move the objects. Enter a low number to move 

in small increments and a high number to move the objects in larger increments. 
4. Click Left, Right, Up or Down to move the objects. 



Resizing a group of objects with an active object

The object that was selected before opening the List of Objects is designated the active object. 
Select another object to make it the active object. 

1. Select the object (or group, including the active object, using multiple selection) that you 
would like to resize to the same size as the active object. 

2. Click Resize to Active. 



Understanding the Merge Screen Database Utility

The Merge Screen Database Utility is made for merging 2 or more screen.db files together.

This utility makes it possible for multiple people to customize screens simultaneously. A hash table 
(named screen.db) is used to match up the structure of the screen with the corresponding map file 
(map files have the extension of .scm, and contain the customization information). When someone 
captures a screen and assigns an ID to it, an entry is created in the hash table. If screens are 
captured on different workstations, then there is a screen.db file on each workstation, each of which 
only contains information about the screens captured on that workstation. Whereas the maps can 
all be moved to a single directory, the hash table (screen.db) must be one file. Hence the need for a 
merge utility. The merge utility will read the entries in a second table and add them to the entries in 
the first table, so you can now use the first table by itself. 

To open the Screen Database Merge Utility, click Start > Programs > IBM Screen Customizer > 
Merge Screen Databases. 



Merging screen databases

To merge screen databases, click Merge to combine both databases.

To view a list of screen IDs, click Check.

The Combined Screen Database window appears.

The Combined Set list displays all the screen IDs from both lists. The Excluded Items list displays 
screen IDs that were excluded because of one or more of the following:

l The item had the same screen ID as one in the Combined Set list. 
l The tags of the screens were the same. 
l The Statistics of the databases of the screens were the same. 

If you select the excluded screen ID, the Matching check boxes at the bottom will display why it was 
excluded.

For Example, if there is a Statistics conflict you can choose to replace the record in the Primary 
Screen Database with the record in the Secondary Screen Database by highlighting the records and 
clicking Swap. You cannot swap records with the same ID. 

To switch the screen ID from one list to the other list: 

1. Click Swap. 
2. Click Close. 

The Merge Screen Databases window is visible again.

To save the merged screen databases, click Save. It is saved in the directory of the Primary Screen 
Database.

To change the directory or the file name, click Save As.

To exit the Merge Screen Database, click Close.



Selecting the Primary Screen Database

To select the Primary Screen Database:

1. Type in the name of a file in the Primary Screen Database or click the Browse button. 
2. Select a file. 
3. Click Open. The name of the selected file appears in the Primary Screen Database field. This 

is the file to which the items in the second file are added. To preserve both databases, use 
"Save As" instead of "Save" after you merge the databases and save to a third file. 

4. Click Close to close the file. 

To select the Secondary Screen Database: 

1. Type in a filename in the Secondary Screen Database field or click the Browse button. 
2. Select a file. 
3. Click Open. 

The name of the selected file appears in the Secondary Screen Database field. This file will not be 
changed by the merge program.



Accommodating screen-structure changes

A screen is identified by a system-assigned ID, by a user-assigned ID (perhaps with a tag), or by 
the screen’s "fingerprint" (the number of fields and their respective positions and lengths). When a 
client connects to the host application, one of three things happens: 

l If the screen is recognized, and if there is a customized interface for it, that interface is 
presented. If there is no customization, the default interface is used. 

l If a screen is normally recognized by its fingerprint but that has changed (a change was made 
in the host application), the default interface is used. 

l If a screen is recognized by a built-in screen ID or by a tag, and if there is a customized 
interface for it, but a change was made in the host application, the customization is applied. 
The portion of the screen that matches will display in customized mode but the part that does 
not match the original screen uses the default interface. If that happens, use the 
Customization Studio to customize the part of the screen that has changed. 

When multiple screens share the same screen ID

If a single system-assigned screen ID in the host application applies to more than one screen, you 
must take this into account when customizing. This may happen if the host screens run in different 
modes (for example, when you are creating, reviewing, or updating a common record for data 
entry). Shared IDs may also occur on menu screens that have the same structure. In these cases, 
you must assign a tag to each form of the screen.



Moving a screen ID database

Because all user-created screen IDs are saved in a screen.db file, you must copy this file along with 
the customization files when transferring screens to a different location (for example, to the Web 
Server for distribution). The screen.db file is located in the /custom/map directory.

See the Merge Screen Database Utility for more information on merging multiple screen.db files. 



Saving a screen

After assigning a screen ID, you must save the screen as a map file so that it can be customized. 
Before you do so, you must erase any data in the input fields, otherwise this data becomes the 
default input for that field in the Customization Studio. Use the following buttons from the keypad: 

l ErInp - to erase input from all the fields 
l ErFld - to erase input from the selected field 
l ErEOF - to erase input from position of the cursor to the end of the field 

To save the screen with the same name as the ID, click File > Save Screen. The file is saved as a 
map file in the default directory, /custom/map directory and as a psd file in the /custom/ps directory. 
The psd file contains a presentation-space footprint that is used by the Studio when the screen is 
customized.

To save a screen in a directory other than the default or with a name different from the screen ID:

1. Click File > Save Screen As. 
2. Choose the directory. 
3. Enter the file name and click Save. 



Setting screen IDs and tags

A host screen is recognized by its structure, that is, by the number, position and length of its fields. 
Most screens are unique in that they have at least one field that makes them different from any 
other. For those screens, you can assign a unique ID that can be used as a reference for this 
screen. In some cases, screens are identical except that the text in a field is different. If that is the 
case, you can add a tag to the ID so that each version of the screen can be identified. 

Before you can customize a screen, you must assign it an ID and, if necessary, a tag. However, if 
an application provides IDs for its screens, you can use them. To do so, set the following 
parameters for Host On-Demand or Personal Communications IDFlag, IDFlagPos, IDPos in the 
Administrator and Client HTML files for Host On-Demand or the parameter file for Personal 
Communications. 

Tags are used to distinguish between screens that have the same structure if you want to customize 
them separately. If a screen appears in different modes, a tag allows each mode to be recognized 
independently, and a separate customization to be used for each mode.

You can also use tags in the reverse manner, to have a single customization for several screens 
that have different structures, for example, sub-file areas or error messages can change the 
structure of a screen. If you have such a screen, find a field that remains the same in every version 
of the screen, select it before assigning a screen ID and define it as a tag. Setting a tag for a screen 
with a changeable structure, in effect, gives each structure of the screen a different ID.

To set a screen ID: 

1. Click File > Set Up Screen ID. 
2. On the Screen ID tab, enter a 4-character screen ID (it must have 4 characters). The ID 

cannot be used for any other screen of the same application. You can browse previously 
created screen IDs from the View Screen IDs tab. 

3. Enter descriptions of the screen. 
4. To set a tag: 

1. Click the Tag tab. 
2. You must now select the field that is to act as the tag. In order to minimize the number 

of fields to choose from, click a type of host field (Unprotected, Protected, All). 
3. Select the field from the list on the right. The value of the selected field appears in the 

Content box. 

4. Click Select. 
5. Click OK. The new screen ID is saved in the screen.db file. 

A tag can have a maximum of eight characters. 

In the Content field, use the Shift and arrow keys or the mouse to highlight the characters of 
the chosen field that you want to use as the tag. The values in the Start and End fields 
change automatically to reflect the location of the characters you have highlighted. 

In the Start and End boxes at the bottom of the window, enter the positions of the first and 
last characters that you want to use as the tag. Click Select to see the tag, in the Content 
box, as a highlighted part of the field. 



Applet file names

The following applets are provided for Host On-Demand: 

To use the interface similar to ResQ!Net, load the Basic HTML files, for example, 
HODCustomClientBasic.html. 

HTML file Description Use with Type

HOD*.html 
Any Host On-Demand client. Provides 
an icon interface for starting client 
sessions. (Recommended) 

Host On-Demand Client

HODCustomAdmin.html 
Provides an icon interface for starting 
administrator sessions. 
(Recommended)

Host On-Demand Administrator

HODCustomClientBasic.html
Basic interface for starting client 
sessions. (Replaces 
ATTAppletH.html)

Host On-Demand Client

HODCustomAdminBasic.html 
Basic interface for starting 
administrator sessions. (Replaces 
ATTAdminH.html).

Host On-Demand Administrator

CustomStudio.html Applet for starting Customization 
Studio. (Replaces ATTStudio.html).

Host On-Demand and 
Personal 
Communications

Studio



Inheriting appearance settings

In Screen Customizer, the color, font, and certain other appearance customizations you see on your 
screen are determined according to the following inheritance hierarchy: 

1. Objects 
2. Screens or maps 
3. Templates 
4. User preferences

This means that customizations on the object level override those on the map level, customizations 
on the map level override those on the template level, and customizations on the template level 
override user preferences. Checking Inherit causes any customizations made on the next level to be 
used.

For instance, if an administrator uses the Customization Studio to create a Web-link button and sets 
the font to SansSerif, SansSerif will be the font for that button regardless of what fonts are set on 
the map or template level. However, if an administrator does not set the font for the Web-link button 
but instead checks Inherit Font, the font used for that button will be whatever font the administrator 
sets for the map.

If the administrator checks Inherit Font for the Web-link button as well as for the map, the font is 
then determined by whatever font the administrator specifies in the template. If the administrator 
checks Inherit Font on the button, map, and template level, only then is the font determined by the 
user preferences.

Inherited settings are not resolved until run-time. Therefore, what appears in the Studio may not be what 
appears in the client. 

By default, object, map, and template properties are automatically set to "Inherit"; therefore, if you do not 
make any changes, user preferences are enabled. 



Parameter list

Below is a list of parameters, descriptions, default values, and for which files they can be used:

l PCOMM - Personal Communications parameter file 
l Basic - HODCustomAdminBasic.html and HODCustomClientBasic.html 
l HOD - Host On-Demand applet files 

Parameter 
name Description Default value Use for

host

Sets the TCP/IP address of the host you want 
to use as a default to connect to the 
TN3270/TN5250 Server or the Personal 
Communications profile name.

none Basic

port Sets the default TCP port used by the applet 
when connecting to the server. 23 Basic

screenSize Sets the screen size.

Terminal
Types Values

3270 24x80 2 
(default)

3270 32x80 3
3270 43x80 4
3270 
27x132 5

5250 
24x132 6

Basic

sessionType Sets the session type.

Terminal
Types Values

3270 1 
(default)

5250 2
CICS 4

Basic

template24x80 The default template to be used for all 24x80 
host screens none

Basic, 
PCOMM, 
HOD

template32x80 The default template to be used for all 32x80 
host screens none

Basic, 
PCOMM, 
HOD

template43x80 The default template to be used for all 43x80 
host screens none

Basic, 
PCOMM, 
HOD

template27x132 The default template to be used for all 27x132 
host screens none

Basic, 
PCOMM, 
HOD

template

The default template to be used for all screens 
if no template for the specific screen size is 
set. Can be used by itself to set the default 
template for all screens regardless of host 
screen size. Click here for more general 
information about templates.

sc_global.tpl
Basic, 
PCOMM, 
HOD



Autoconnect

Sets the option to make the user connect to an 
administrator specified host or to a user 
defined host. If autoconnect is enabled, the 
user can still connect to another host by 
entering the parameters in the session 
configuration window and starting a session. 
To keep the user from doing that, edit the 
HTML file and set the length and height of the 
applet to 1.

0 (default) if you want 
the user to choose 
which host to connect 
to. 1 - if you want to 
connect the user to 
specific host.

Basic

SSL Enables SSL communications to the host.

0 (default) - if you want 
to disable SSL 
communications. 1 - if 
you want SSL enabled.

Basic

TNEnhanced Enables TN3270E functions.

1 (default)- if you want 
to enable TN3270 
Enhanced functions. 0 - 
if you want to disable 
TN3270 Enhanced 
functions.

Basic

LastIndex

Sets the highest number parameter that can 
be defined. This does not set the maximum 
amount of parameters, but the highest number 
you can assign to a parameter. To set more 
parameters than the amount in Last Index, 
reset the Last Index parameter. You can add 
parameters up to and including the number 
you have as a value in Param Name=Last 
index.

Parameters following "LastIndex" line (Prm1, 
Prm2, Prm3..) can be used for the Get-to-the-
Point facility or Web Link buttons. These 
parameters are global variables. The usage of 
these parameters reduces redundant input 
and allows for easier changes. For example, if 
parameter 11 is used in multiple Web Link 
Buttons, and you need to change it at some 
point in the future, then modifying this 
parameter is much faster than modifying 
multiple hard-coded strings in Web Link 
Buttons. 

100
Basic, 
PCOMM, 
HOD

subdir

Sets the name of the directory that contains 
user specific customization. During installation, 
two directories are created: /custom and /com. 
You create directories for special 
customizations that can be sent to specific 
users or user groups. These directories can 
include some or all of the /custom 
subdirectories (help, image, lst, maps, and 
ref). If no value is set, then the user receives 
customization from the default 
directory, /custom. If a value is set, then the 
user receives the customization from the 
directory specified as the parameter’s value.

none
Basic, 
PCOMM, 
HOD



IDFlag

Sets the prefix string used in identifying your 
Screen IDs. Typically, an eight-character string 
identifies screens: the first 4 characters of 
which are constant (prefix) and last 4 are 
unique (ID). If your application doesn’t have 
screens that can be identified by a prefix, 
ignore all parameters containing "ID."

Screen ID
Basic, 
PCOMM, 
HOD

IDFlagPos Sets the absolute position, where the screen 
ID flag is located. none

Basic, 
PCOMM, 
HOD

IDPos Sets the absolute position where the screen ID 
itself is located. none

Basic, 
PCOMM, 
HOD

NewWindow

Opens Web-links in a new browser window if 
the param value=1. If the param value=0, no 
new browser window is opened. 1 is the 
default value.

true Basic, 
HOD

DecimalSeparator 
Character that separates the result of a 
mathematical operation when it is rounded to a 
decimal place in the Global Variables Facility

decimal point (.)
Basic, 
PCOMM, 
HOD

lookupfile Sets the name of the look-up table file for the 
Global Variables Facility. lookup.xml

Basic, 
PCOMM, 
HOD

useHostColors Use host-defined text colors instead of default 
text colors. true

Basic, 
PCOMM, 
HOD

CustomURL
Allows you to change the user’s directory 
Website to indicate on which server the user-
customizable components reside.

none
Basic, 
PCOMM, 
HOD

AllowProportionalFonts Allows you to used proportional fonts

0 (default)- allows you 
to select fixed fonts 
only. 1 - all fonts are 
allowed.

Basic, 
PCOMM, 
HOD

RestrictedClient 

Allows you to restrict the the functions 
available to help functions (What is it?, Values, 
and About), language specific functions (Show 
DBCS input and SO/SI), and disables the 
close function to prevent the session window 
from being closed accidentally (buttons with a 
close macro function will still work, however) if 
the parm value is 1 (default is 0).

Basic, 
PCOMM, 
HOD

TypeAhead Allows you to type information for the next 
screen (if the param value=1). true

Basic, 
PCOMM, 
HOD

ColorPrint Allows you to change the print screen default 
to color (if the param value=1). false Basic

SSLServerAuthentication ’Enables server authentication for SSL 
connections.

The ’SSL’ parameter 
must be ’1’. The default 

value is ’0’.

Basic, 
PCOMM, 
HOD

Disable File transfer FILEXFER3270 or 
FILEXFER5250

Basic, 
PCOMM, 
HOD



Understanding bidirectional language functions

Understanding software requirements for bidirectional language support 
Listing tested platforms and browsers for Hebrew 
Listing tested platforms and browsers for Arabic 
Configuring a workstation for Arabic or Hebrew 
Activating bidirectional language support 
Customizing a screen as a right-to-left screen 
Using Arabic or Hebrew characters 
Setting Arabic or Hebrew text as a caption 
Understanding bidirectional support for unlinked text fields 
Understanding the backward compatibility of bidirectional support 

Understanding software requirements for bidirectional language 
support

To use bidirectional support, you need an Arabic operating system to support an Arabic Screen 
Customizer session and a Hebrew operating system to support a Hebrew Screen Customizer 
session.

Bidirectional support for Screen Customizer is not supported for IBM Personal Communications.

Listing tested platforms and browsers for Hebrew

For Screen Customizer clients, Administrator and Customization Studio:

Listing tested platforms and browsers for Arabic

For Screen Customizer clients, Administrator and Customization Studio:

Windows 95 Hebrew Enabled (for Screen 
Customizer client only)

Internet Explorer 5.01 
Netscape Navigator 4.7 
(English) 

Windows 98 Hebrew Enabled (for Screen 
Customizer client only) Internet Explorer 5.01 

Windows 98 Hebrew Translated (for Screen 
Customizer client only) Internet Explorer 5.01

Windows NT Workstation Hebrew Enabled
Internet Explorer 5.01 
Netscape Navigator 4.7 
(English) 

Windows 2000 Internet Explorer 5.01 
Netscape Navigator 4.7 



Configuring a workstation for Arabic or Hebrew

To configure a workstation for Arabic or Hebrew, set the appropriate code page:

1. Right-click a 3270 or 5250 configured session icon. 
2. Click Properties. 
3. Select one of the following for the Host Code Page: 

� 420 Arabic Speaking 
� 424 Hebrew (new code) 
� 803 Hebrew (old code) 

4. Click the Language tab and select BIDI options to enable copy and paste. 

Activating bidirectional language support

To activate bidirectional functions (language change, screen reverse, push, etc.), use the same 
bidirectional key combinations that Host On-Demand uses.

Language selection 
The key combination Ctrl+N or Ctrl+L allows you to change the language layer. If the 
language layer is Latin, pressing Ctrl+N changes the language layer to right-to-left (Arabic or 
Hebrew). If the language layer is right-to-left (Arabic or Hebrew), pressing Ctrl+L changes the 
language layer to Latin. 
 

Screen reverse 
The key combination Ctrl+S reverses the screen image. If the screen orientation is left-to-
right, pressing Ctrl+S reverses the screen image right-to-left. If the screen orientation is right-
to-left, pressing Ctrl+S reverses the screen image to left-to-right. 

When the screen orientation is changed, the language layer is changed to the default 
language of the new screen orientation. If the screen is reversed to right-to-left, the current 
language is changed to right-to-left (Arabic or Hebrew). If the screen is reversed to left-to-
right, then the language is changed to Latin.

For an Arabic 3270 session, if the swapping of symmetric characters is enabled, the inversion 
of the screen causes directional characters to be replaced by their counterparts.

If the swapping of numeric characters is enabled, the inversion of the screen causes Hindi 
numerals to be replaced by their Arabic counterparts and the Arabic numerals to be replaced 
by their Hindi counterparts.

The keys unique to bidirectional 3270 are:

Windows 98 Internet Explorer 5.0 (Arabic)

Windows 95 Internet Explorer 4.7 (Arabic)

Windows NT Workstation Netscape Navigator 4.7 (English)

Windows 2000 Internet Explorer 5.0 (Arabic) 
Netscape Navigator 4.61 and 4.7 

Screen reverse does not reverse the text in the operator information area.



Field reverse 
The key combination Ctrl+F toggles the field orientation to either opposite to or the same as 
the screen orientation. In most cases, the field direction is the same as the general screen 
direction. However, sometimes it is necessary to have a field whose direction is the opposite 
of the screen direction. The Field Reverse function allows such transitions. When this function 
is activated, the typing direction is reversed, but the existing text in the field and the screen 
image do not change. When activated, this function creates a temporary change that stays in 
effect as long as the cursor remains within the field, or until Field Reverse is activated again. 

If the function is activated while the cursor is at the beginning of a line or field, the cursor 
jumps to the end of the line or field, so that the reversed field begins logically from that 
position. Otherwise, the cursor remains in its position and allows natural and correct editing of 
existing texts whose direction is the opposite of the screen direction.

Auto field reverse 
The key combination Ctrl+R toggles the auto field reverse mode for the current screen 
orientation. 

Auto field reverse affects the automatic selection of the field orientation of unprotected fields:

l When auto field reverse is enabled, upon initial entry to an alphanumeric field, the field 
orientation will be set to right-to-left (for both left-to-right and right-to-left screen 
orientations). 

l When auto field reverse is enabled, upon initial entry to a numeric field, the field 
orientation will be set to left-to-right (for both left-to-right and right-to-left screen 
orientations). 

l When auto field reverse is disabled, upon initial entry to a field (whether numeric or 
alphanumeric), the field orientation is always set equal to the screen orientation. 

Push and end push 
This function is activated by the key combination Ctrl+P and allows the entering and editing of 
text whose direction is opposite from the field direction. When this function is activated, the 
cursor orientation is reversed, the language layer is changed accordingly, and a push 
segment is created. 

End push, activated by the Ctrl+O (the letter "O") key sequence, ends the push mode.

When you end the push mode, the cursor jumps to the end of the push segment, and its 
direction changes to the original direction. You can also perform end push by pressing any 
field exit keys (for example, Cursor Up or Cursor Down) or an aid key (for example, Enter).

The push function has two secondary modes:

Boundary mode 
This mode is activated upon entering push mode. In this mode, the cursor remains in its 
position, and the typing of additional characters pushes the text in the direction opposite 
from the field direction. To indicate this boundary mode, the cursor has a block shape. 

Edit mode 
This mode is activated when the cursor is moved from its boundary position into the 

In Windows mode, push is also activated by the Shift+NumLock key sequence. End push is also 
activated by the Shift+Numpad/ key sequence.



push segment area. In this mode, you can edit the text within the push segment, while 
typing in the field’s natural direction. 

AutoPush 
This function is activated by the key combination Ctrl+A and helps the terminal operator type 
mixed left-to-right and right-to-left text. When enabled, reversed segments are automatically 
started and ended, according to the entered character or the selected language layer. This 
mode relieves the operator from manually pressing Push, as it is automatically invoked. 

The keys unique to bidirectional 5250 are:

Field reverse 
This function is activated by the key combination Ctrl+F and toggles the field orientation to 
either left-to-right or right-to-left. The text in the field is not inverted. The cursor orientation is 
set equal to the new field orientation, and the language layer is selected accordingly. If the 
cursor is in the first logical position of a field or line, when selecting field reverse function, the 
cursor skips to the other side of that field or line, which now becomes the first logical position. 
If the cursor was not in the first position of the field or line, when selecting field reverse 
function, the cursor remains in its position and allows natural and correct editing of existing 
text. 

Close 
This function is activated by the key combination Ctrl+C and is provided so that the data 
entered in one keying direction can be concatenated with the data that was previously entered 
in the opposite direction. It operates as follows: 

l All embedded nulls are removed from the current line. 
l Concatenated text is moved to the right boundary of the field (if the field direction is 

right-to-left) or to the left boundary (if the field direction is left-to-right). 
l The cursor direction is set to the field direction. 
l The language layer is set to the default for the field direction. 
l If the screen orientation is now left-to-right, the cursor is positioned at the first null to the 

right of the concatenated text. 
l If the screen orientation is now right-to-left, the cursor is positioned at the first null to the 

left of the concatenated text. 
Base 

This function is activated by the key combination Ctrl+B and is a toggle that activates or 
deactivates the automatic shape determination function for Arabic right-to-left text. It is valid 
only when processing right-to-left Arabic text. If it is pressed in a left-to-right field, an operator 
error 0027 results. 

Customizing a screen as a right-to-left screen

To reverse a screen in the Administrator, follow these steps:

l In right-to-left fields, typing a digit or a Latin letter causes the automatic initiation of 
push, without language change. Further Latin letters or digits will continue the 
push mode; any other character automatically terminates push mode. This feature 
allows you to type text with embedded numbers or Latin words without using 
push/end push. 

l In left-to-right fields, typing a right-to-left character or special character causes the 
automatic initiation of push, without language change. Typing any digit or Latin 
character causes the automatic termination of the mode. This allows you to type 
Latin text with embedded Arabic or Hebrew words using language layer selection 
rather than push and end push. 



1. Open the screen you want to customize. 
2. Press Ctrl+S to apply the screen reverse function, which changes the screen orientation to 

right-to-left. 
3. Click File > Capture. 
4. Click File > Customize to start the studio. 

Because you captured the screen in right-to-left mode, the capture will open as a right-to-left 
screen.

5. Customize your right-to-left screen. 
6. Click File > Save Screen. 

Using Arabic or Hebrew characters

To use Arabic or Hebrew characters, press Alt+(right)Shift before typing.

To use Latin characters, press Alt+(left)Shift before typing.

Setting Arabic or Hebrew text as a caption

To set an Arabic or Hebrew caption to an object, follow these steps: 

1. Right-click the object and select Caption. 
2. Press Alt+(right)Shift to write Arabic or Hebrew Text. 
3. Type a new caption or change a previous caption in the New field. 
4. Click OK. 

Understanding bidirectional support for unlinked text fields

Unlinked text fields are those fields in a customized screen that are not necessarily connected with 
a host field. The unlinked text fields provide full bidirectional support. You can enter Arabic or 
Hebrew text in these fields using the same keyboard functions as in a 3270 linked field: 

l Field reverse 
l Push 
l End push 
l Automatic push initiation and termination (Autopush) 
l Language change 

In fields that are oriented right-to-left, you can use two levels of push. For the first level of push, you 
can enter left-to-right text in right-to-left-oriented fields. For example, you can type numbers within 
Arabic or Hebrew text. The second level of push does not allow you to enter left-to-right text in right-
to-left oriented fields.

The Autopush mechanism controls the first level of push. You need to manually begin and end the 
second level of push.

In runtime, screens always open in left-to-right mode, even if they were customized as right-to-
left. You must reverse the screen (Ctrl+S) to change the screen to right-to-left mode.



Understanding the backward compatibility of bidirectional 
support

You can re-customize the screens that you already customized before bidirectional support was 
available.
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Understanding supported platforms

Operating system

Hindi language is supported only on the Windows 2000 platform and only with Host On-Demand.

Hindi language is only supported for 5250 sessions.

Browser support

Any industry-standard browser is supported, such as Netscape 4.5, or later, or Internet Explorer 5.0, 
or later.

Web-server support

Any industry-standard Web server is supported, such as Lotus Go Web server, Apache or Microsoft 
IIS 4.0. 

Understanding the Hindi language support overview

The Hindi language consists of the following:

l 38 consonants 
l 15 vowels 
l 14 matras 
l 3 vowel modifiers 
l 1 halant 
l 1 nukta 

Hindi language uses the Devanagari Script. All details regarding Devanagari Script are available 
from the description of the Unicode Standard Version 2.0. 

Use the following key combinations to type vedic overlay characters:

http://www.unicode.org/unicode/standard/standard.html


Understanding Hindi language character composition

Character composition is in accordance with the Unicode ligation rules and ISCII (Indian Standard 
Code Information Interchange) ligation rules. This is achieved through the implicit character 
composition feature of Windows 2000 operating system.

Using Hindi monospaced font for Windows 2000

Screen Customizer provides Hindi monospaced font (Devanagari MT Narrow).

To install the Devanagari MT Narrow font file, Devanagari MT Narrow.ttf, complete the following 
steps: 

1. Download the font from the Host On-Demand CD or tape to your hard drive by right-clicking 
the link. 

2. Click Start > Settings > Control Panel. 
3. Double-click Fonts. 
4. From the File menu, select Install New Font.... 
5. Find the file Devanagari MT Narrow.ttf wherever you saved it, then select it and click OK. 

Installing Hindi support for Netscape Communicator

Edit the active font control file, \Program 
Files\Netscape\Communicator\Program\Java\Classes\font.properties, to accommodate the Hindi 
monospaced font. Add the following line to the font.properties file: 
Monospaced.0=Devanagari MT Narrow.

If the font.properties file does not include the Hindi character set, download font.properties from the 
server to replace the active font control file (font.properties). This file is located in 
the /samples/fonts/hindi directory.

Installing Hindi support for Internet Explorer

Host On-Demand uses Monospaced Devanagari font for a Hindi session on Windows 2000. To 
install Monospaced Devanagari font on the client:

1. Download the font file to the client in the Windows font directory. 
2. Assign the browser registry entry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Java 

VM\Font Alias\Courier the key value of Devanagari MT Narrow. 

Character Key combination (based on 
vedic overlay)

Udatta (U+0951) Alt+Ctrl+F

Anudatta (U+0952) Alt+Ctrl+D

Abbreviation Sign 
(U+0970) Alt+Ctrl+, (comma)

Avagraha (U+093D) Alt+Ctrl+. (period)

OM (U+0950) Alt+Ctrl+/ (forward slash)



Configuring a workstation for Hindi language

To configure a workstation session for Hindi, complete the following steps: 

1. Right-click a configured session icon. 
2. Click Properties. 
3. Select 1137 Hindi Code Page for 5250 session. 
4. Click OK. 

Switching keyboards between Hindi and Latin

Language selection is activated by the key combination Ctrl+N or Ctrl+L, which changes the 
language layer. If the language layer is Latin, pressing the Ctrl+N key combination changes the 
language layer to Hindi. If the language layer is Hindi, pressing the Ctrl+L key combination changes 
the language layer to Latin. 

Use the following key combinations: 

Understanding language shift status

Screen Customizer Hindi support indicates the language currently in use in the Operator Information 
Area (OIA). If keyboard support is in Hindi language mode, the indicator HI appears in the OIA. 
There is no indicator when the keyboard is in the default Latin mode.

Using cut, copy and paste support

Clipboard operations such as copy, cut and paste are supported. 

Understanding the behavior of the arrow, Delete and Insert keys

The key font alias may not exist in your system. Use the following steps to create a font 
alias:

1. Under the registry entry Java VM, create a KEY called Font Alias. 
2. For the KEY Font Alias, create a VALUE called Courier. 
3. For the VALUE Courier, update the data with the hindi font name Devanagari MT 

Narrow. 
4. Reboot your system. 

Default key mapping Language

Ctrl+N Hindi

Ctrl+L Latin

Key combination Function

Ctrl+C Copy

Ctrl+X Cut

Ctrl+V Paste

Ctrl+A Select all



The Insert, Delete, and Backspace keys have some special behaviors in Hindi sessions. This 
unexpected behavior is because the internal representation of the characters is different compared 
to what gets displayed on the screen. 

Some of the terms used to describe these behaviors include:

Character 
The smallest component of written language that has semantic value 

Glyph 
The shape that characters can have when they are displayed 

A single glyph can correspond to a single character or to a number of characters.

Arrows

To move the cursor from one glyph to another on the screen using the left and right arrow keys, you 
need to press the arrow key more than once for composed characters.

Example

You type three characters: Devanagari letter KA, Devanagari sign Virama and Devanagari letter 
SSHA. These three characters form a single glyph Devanagari letter K.SSHA. If the cursor is 
positioned after this glyph and you want to move the cursor to the character before the Devanagari 
letter K.SSHA, you need to press the left arrow three times.

Delete

For certain composed characters, the expected character will not be deleted from the screen when 
the Delete key is pressed. 

Examples

You enter the Devanagari letter KA followed Devanagari vowel sign I. The glyph corresponding to 
Devanagari vowel sign I is displayed before the glyph corresponding to Devanagari Letter KA. 
When you press the Delete key, you expect the Devanagari letter KA to be deleted from the screen. 
However, the glyph corresponding to Devanagari vowel sign I is deleted from the screen.

In another example, you type three characters: Devanagari letter KA, Devanagari sign Virama and 
Devanagari letter SSHA. These three characters form a single glyph Devanagari letter K.SSHA. 
You reach the glyph Devanagari letter K.SSHA by pressing the right arrow key and when the cursor 
reaches Devanagari letter K.SSHA, you press the Delete key. Devanagari Letter KA is deleted. But, 
if you reach the glyph Devanagari letter K.SSHA by pressing the left arrow key and then you press 
the Delete key when the cursor reaches Devanagari letter K.SSHA, the Devanagari letter SSHA is 
deleted.

Insert

For composed characters, the insert function works differently than with standard characters.

Example



You type three characters: Devanagari letter KA, Devanagari sign Virama and Devanagari letter 
SSHA. These three characters form a single glyph Devanagari letter K.SSHA. You reach the glyph 
Devanagari letter K.SSHA by pressing the right arrow key. If you insert some characters at this 
position, the inserted characters will be displayed before the glyph Devanagari letter K.SSHA. If you 
press the right arrow key one more time and then insert some characters, the entered characters 
are inserted after the first character Devanagari letter KA. The glyph Devanagari letter K.SSHA 
might disappear, depending on what character you insert. 

Understanding the limitations of Hindi support

Following are limitations of Hindi support for Screen Customizer: 

l VT and CICS emulations are not supported in this release. 
l If a field in a 5250 session in Screen Customizer wraps to more than one line, Screen 

Customizer composes the first 80 characters and displays the composite string in the second 
line and each subsequent line as needed. The column length in Host On-Demand is fixed at 
80 characters, so the end user cannot input more than 80 characters per row. 

l Screen Customizer Hindi support is available only for Host On-Demand, and it supports only 
5250 session type. Personal Communications support is not available. 

l 3270 printer sessions and 5250 printer sessions are not supported for Hindi. 



Understanding Thai language functions

Understanding software requirements for Thai language support 
Listing tested platforms and browsers for Thai language support 
Using Thai monospaced font 
Configuring Internet Explorer Thai 
Configuring Netscape Communicator 
Configuring a workstation for Thai 
Selecting Thai display modes 
Configuring Thai display mode 
Switching the keyboard between Thai and Latin 
Understanding language shift status 
Understanding the limitations of Thai support 

Understanding software requirements for Thai language 
support

To use Thai language support, you need a Thai operating system to support a Thai Screen 
Customizer session.

Thai support for Screen Customizer is not supported for IBM Personal Communications.

Listing tested platforms and browsers for Thai language 
support

For Screen Customizer clients, Administrator and Customization Studio:

Using Thai monospaced font

Host On-Demand provides the Thai monospaced font Courier Thai for Windows Thai edition. To 
install the Courier Thai font file (courth.ttf): 

1. Download the file to your client. Right-click the link to download the file. 
2. Copy the file to the fonts folder located in the Windows control panel. 

Host On-Demand provides the Thai monospaced font Thai Phuket for OS/2 Warp 4.0 Thai and AIX 
4.3 Thai Edition. 

Configuring Internet Explorer Thai

Platform Browser

Windows 95 Thai Edition, Windows 98 Thai Edition Internet Explorer 4.0 / 5.0 Thai  
Netscape Communicator 4.5 or later

Windows NT 4.0 Thai Edition Internet Explorer 4.0 / 5.0 Thai 
Netscape Communicator 4.5 or later

Windows 2000 Internet Explorer 4.0 / 5.0 Thai 
Netscape Communicator 4.5 or later



Microsoft Internet Explorer on Windows Thai Edition does not specify the correct font for Thai. To fix 
this: 

1. Run regedit.exe. 
2. Replace Courier with Courier Thai in the following registry entry: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Java VM\Font Alias\Courier 

Configuring Netscape Communicator

If the active font control file (font.properties) in Netscape Communicator 
(\Program Files\Netscape\Communicator\Program\Java\classes) does not include the Thai 
character set, do the following: 

1. Download font.properties.win from the server. Right-click the link to download the file. 
2. Replace the active font control file (font.properties) with this new font.properties file. 

Thai font control file (f_th.prp) is provided for Netscape Communicator for OS/2 Warp 4.0 Thai.

No Thai font control file is provided with Netscape Communicator for AIX 4.3 Thai.

To display Thai on Host On-Demand using a Netscape browser, use Thai raster font (THA3270) for 
the font name.

Configuring a workstation for Thai

To configure a workstation session for Thai language, set the appropriate code page:

1. Right-click a 3270 or 5250 configured session icon. 
2. Click Properties. 
3. Select 838 Thai or 1160 Thai Euro for the Host Code Page. 

Selecting Thai display modes

You can specify the character composition and alignment for your text windows by indicating the 
display composed mode on the Thai Display Mode window. The selected Thai display mode effects 
the fields that use monospaced font only. For the fields that use proportional font, Thai text is 
displayed in Mode 2 (composed mode without column alignment).

Specify one of the following modes:

Mode 1 - Non-compose mode 
No character composition occurs in this mode. 

Mode 2 - Composed mode 
Thai characters are auto-composed in this mode. No column realignment is performed. 

Mode 3 - Composed with space alignment 
In this mode of composing, three consecutive spaces cause column realignment. The 
realignment occurs whenever the composing routine finds three consecutive spaces. If all 
fields have at least three trailing spaces, all fields of all records will be properly aligned. 

Mode 4 - Composed with EOF alignment 



In this mode of composing, the EOF character (hexadecimal ’EA’) also causes column 
realignment. Whenever the composing routine finds a single EOF, it deletes the EOF and 
performs column realignment. If two consecutive EOFs are found, no realignment occurs, one 
EOF is deleted, and one EOF is treated as data. 

Mode 5 - Composed with space and EOF alignment 
This mode of composing performs the column realignment function of both mode 3 and mode 
4. 

Configuring Thai display mode

You can configure the Thai display mode from your session panel by doing the following:

1. Right-click a configured session icon. 
2. Click Properties. 
3. Select a Host Code Page for Thai. 
4. Click on the Language tab. 
5. Select Thai display mode from Thai Options. 
6. Click OK. 

You can also change the Thai display mode settings in an active session:

1. On the View menu, click Thai Display Mode. 
2. Select Thai display mode from Thai Display Mode window. 
3. Click OK. 

Switching the keyboard between Thai and Latin

To switch the keyboard between Thai and Latin, use the following key combinations:

Understanding language shift status

Screen Customizer indicates the language currently in use in the Operator Information Area (OIA). 
If keyboard is in Thai language mode, the indicator TH appears in the OIA. There is no indicator 
when the keyboard is in the default Latin mode.

Understanding the limitations of Thai support

l Thai support for Screen Customizer is available for Host On-Demand only. Personal 
Communications support is not available. 

l Thai support for Screen Customizer requires a version of the operating system that supports 
Thai. 

Shortcut key Function

CTRL+N Switch keyboard layout to Thai

CTRL+L Switch keyboard layout to Latin
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