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Administrator's Guide
IBM WebSphere(TM) Transcoding Publisher (referred to from now on as Transcoding Publisher or
WTP) enables you to tailor Web-based information to match the needs of your users. This Guide gives an
overview of Transcoding Publisher's functions and capabilities and describes how to administer it.

The Contents view on the left of this page shows the chapters in this Guide. To open a chapter and
expand its subheadings, click the chapter name. You can click a subheading to go directly to that topic.

Before using this information and the product it supports, read the information in Notices.

What's new in this release
Version 4.0 of Transcoding Publisher includes these new features:

The VoiceXML transcoder converts HTML to VoiceXML for voice applications.●   

The Machine Translation transcoder works with WebSphere Translation Server to translate content
into different languages.

●   

The Palm transcoder converts HTML to PalmOS HTML for display on Palm VII devices.●   

The WTP server can be deployed as a plugin in WebSphere Edge Server Caching Proxy, IBM's
high-performance caching proxy. This configuration replaces the proxy with an external cache.

●   

The External Annotation Editor makes it easier to create external annotation files to customize the
information returned to small devices. Several other improvements extend the functions you can
perform with annotations.

●   

The Stylesheet Editor makes it easier to create your own stylesheets to convert XML documents.●   

You can specify, within an XML document, the names of one or more stylesheets to be applied to
that document.

●   

You can import and export WTP configuration information to XML files to copy configurations
from one machine to another. You can manipulate configuration information outside the
Administration Console.

●   

You can search within your stylesheet selectors to find the resources you want to work with.●   

WTP can incorporate user preferences when it is operating in an environment where users are
identified and user preference information is available, such as the WebSphere Everyplace(TM)
Suite.

●   

The Administration Console and other interfaces use JavaHelp, which enables you to search for
the information you need.

●   

You can use the Request Viewer as an independent tool to monitor a remote WTP server that is
deployed as a proxy or reverse proxy.

●   

We have made a variety of improvements to the usability and accessibility of the user interfaces
and to the performance of the WTP server.

●   

Welcome to IBM WebSphere Transcoding Publisher
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Visit the WTP Web page
Be sure to visit the WTP Web page at http://www.ibm.com/software/webservers/transcoding. The Web
page contains information on the latest updates to WTP, including new transcoders, tools, and device
profiles.

Welcome to IBM WebSphere Transcoding Publisher
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What does Transcoding Publisher do?
Transcoding Publisher gives you the ability to tailor Web-based information to the needs of users. For
example, you can make Web pages available on handheld and other devices economically and
efficiently. You can format XML-based information for HTML browsers and other uses. You can
convert data to voice output. Working with WebSphere Translation Server, WTP can translate
information into the user's preferred language.

With WTP, your users receive information tailored to the capabilities of the devices they are using. For
example, users with small-screen devices access a scaled version of the information, while users of a
specialized markup language access the same information in a format suitable for their devices. By
providing a single dissemination point for multiple renderings of information, Transcoding Publisher
eliminates the expense of re-authoring or porting data or applications for multiple networks and devices.
Transcoding Publisher improves the communications and effectiveness of your mobile employees and
extends the reach of your information to a new class of users.

Transcoding Publisher transforms content based on what the requesting device can handle, and on the
capacity of the network being used. Web content can be transformed differently for different devices and
networks. When used as part of WebSphere EveryPlace Suite, Transcoding Publisher can also transform
content according to user preferences. Transcoding Publisher supports your existing applications and
data without requiring that you redesign corporate systems for the different standards found in each
device. Transcoding Publisher can support all common types of Web data, including HTML pages from
a Web server, HTML output from a host application (such as that produced by IBM's Host
Publisher(TM)), and Extensible Markup Language (XML) data from a back-end transaction system.
Transcoding Publisher also tailors images to adjust screen size, file size, and numbers of colors.

 

Transcoding Publisher provides standard transformations for several leading pervasive devices. You can
modify transformations based on criteria important to you or your users. For example, if your users on
the road want to sacrifice aesthetics for download speed, you can tell Transcoding Publisher to reduce
image file size (or remove images, or convert them to links) and transform table formats to simpler list

Overview
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formats. As new devices emerge in this fast-growing market, new transformations can be added easily.
For specific or unique format requirements, Transcoding Publisher provides a pluggable framework for
adding new device and network profiles and content type transformations.

Transcoding Publisher transforms data before transferring it, which saves connect time and cost. Data
manipulation is done on the network side of a connection, rather than in the device browser. This gives
you more control over the data transformation as well as the amount of data transferred and reduces
processing on the device itself.

Transcoding Publisher can be deployed in your network as a network proxy, as a reverse proxy, as a filter
running in IBM WebSphere Application Server, as a plugin in IBM WebSphere Edge Server Caching
Proxy, or as JavaBean components in your own application. See Choosing a deployment model for
information about each of these options.

Transcoding Publisher scenarios
These scenarios illustrate some of the ways Transcoding Publisher can be used in your organization.

Web pages modified for pervasive devices
Many of your users already possess handheld devices, and some have more than one type of
device. With Transcoding Publisher installed as a proxy, users configure their device browsers to
access content through a Transcoding Publisher server. Transcoding Publisher's default image and
text transforms modify content from a variety of Web servers into formats that your users' devices
can display.

Reverse proxy
Your employees use telephones whose browsers cannot specify a proxy server. You configure
Transcoding Publisher to run as a reverse proxy for your company's Web server. Your employees
receive your information transcoded appropriately by accessing the content as if it resided on the
WTP server.

Web application output tailored for road warriors
Your sales force uses monochrome handheld devices to access a Web-based product catalog. The
Web pages contain full-color graphics, text descriptions, and order forms. You configure a
Transcoding Publisher server to perform the following operations before transmitting Web pages
to these users:

Format tables to lists❍   

Change paragraph tags to line breaks to save space by eliminating blank lines between
paragraphs

❍   

Convert images to text links, speeding the page download, but still providing access to
images

❍   

Convert images to grayscale and reduce their resolution to speed download time❍   

The result is that the forms are intact but sized for the screen. The sales force can place orders
faster and with fewer problems in displaying the relevant data.

Host data transformed in secure environment

Overview
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A host transaction system generates financial data for a secure Web server. Your market finance
group needs access to this data from their office desktops as well as from their mobile devices.
You configure Transcoding Publisher as a WebSphere Application Server filter. Transcoding
Publisher transcodes the output of Web applications to the proper formats, and the Web server
encrypts and returns the data.

Multi-version support for devices
Transcoding Publisher transforms content for a device that does not support JavaScript by
removing the JavaScript from any document that contains it. A vendor upgrades the device to
support JavaScript. You obtain a new device preference profile from the vendor. You configure
Transcoding Publisher to recognize the new device and Transcoding Publisher stores preferences
indicating the upgraded capability. Any user who accesses Transcoding Publisher with the new
device receives content containing JavaScript. Users with back-level devices continue to get
content without JavaScript.

Converting text to speech
Some of your users require information in audible format. Using WTP with IBM WebSphere
Voice Server, you assemble a solution to convert Web-based information to the audible format you
need.

Translating content
Some of your users speak languages other than the language in which your information is created.
Using WTP with IBM WebSphere Translation Server, you translate Web-based content to the
desired languages.

Deck fragmentation for smaller devices
Your employees use handheld devices with screens that display small amounts of data received
using the WML, HDML, or Compact HTML formats. Transcoding Publisher converts the original
HTML to the appropriate markup language and then breaks the information into fragments of the
size the phone can store. This means that application developers do not have to write different
versions to support phones with different capacities.

Centralized configuration
You use several Transcoding Publisher servers to support many customers. You want your
Transcoding Publisher servers configured in the same way, and you don't want to have to update
each one separately. You store a configuration in a server model in a central directory and
configure all your servers to use that server model. When you add new device profiles and
stylesheets to the server model, they are immediately available to all the servers.

Easy repeated installations
You want to install several identical servers without using a central directory. You create a
response file while installing the first server. After configuring the server, you export its
configuration data to an XML file. You transfer the XML configuration data and the installation
response file to your other server machines and use them to easily install and configure identical
WTP servers.

Caching improves responsiveness
Your users access pages repeatedly, so you configure WTP as a plugin in IBM's high-performance
proxy server, WebSphere Edge Server Caching Proxy. When a user requests a page, WTP can
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return it immediately if it is cacheable and it has already been requested by a similar device.

How does Transcoding Publisher transform
content?

Transcoding Publisher transforms data by intercepting
and transforming requests and responses to deliver a
targeted response to a user. Transcoding Publisher tailors
HTTP requests, generates responses, and transforms and
filters the responses.

Transcoding Publisher helps you ensure that Web data delivered to a device is appropriate for the device,
the network, and your administrative policy in terms of:

Size - scaled presentation of images and compression of text, which could, for example, reduce the
size of files that are downloaded

●   

Detail - specifically tailored to the amount and kind of information your users need●   

Format - data presented in the format supported by your users' device types●   

Language - data translated into your users' languages●   

Transcoding Publisher consists of two main parts: the Administration Console, which enables you to
administer Transcoding Publisher, and the transcoding server, which performs the work of receiving
requests, transcoding data, and returning the data to the user in an appropriate format. The use of the
Administration Console is described in Administering Transcoding Publisher. This page will focus on
how the transcoding server works with documents.

Transcoding Publisher also includes a developer's toolkit that you can use to extend Transcoding
Publisher's functions. Refer to the Developer's Guide for information about the WTP toolkit.

Overview
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Transcoding Publisher resources
Transcoding Publisher uses four types of resources to process documents. This section describes each
resource and how Transcoding Publisher uses it.

Preference profiles

Transcoding Publisher uses preference profiles to represent the characteristics of devices, networks, and
users, as well as a default user profile to represent organizational policies. Each profile tells Transcoding
Publisher how to treat documents that will be delivered to that device, over that network, or for that user.

A preference profile can represent a particular type of device, such as an IBM WorkPad, a particular
network type, such as a wireless network, or a particular user or group of users. For example, on a
wireless network, you might want to specify that images should be converted to text links, allowing the
page to load faster. On a device with a small screen, you might want to convert tables to lists to reduce
horizontal scrolling. For a particular user, you might want to eliminate images altogether.

When Transcoding Publisher processes a document, it selects a device profile, a network profile, and a
user profile to apply to the document.

If the X-IBM-PVC-Device-Type field is present in the HTTP header, WTP uses the device profile
whose file name matches the value specified for that field. Otherwise WTP uses the device profile whose
user-agent value matches the value of the user-agent field in the HTTP header. If no matching profile is
found, WTP uses the default device profile. You can view and modify the user-agent field in a device
preference profile by selecting the profile in the tree and selecting Advanced in the right pane.

If the X-IBM-PVC-Network-Type field is present in the HTTP header, WTP uses the network profile
whose file name matches the value specified for that field. If this field is not specified and WTP is
deployed as a network proxy, the network profile is determined by the port on which WTP receives the
request. This method of choosing a network profile is not used with other WTP deployment models. If no
matching profile is found, WTP uses the default network profile.

User resources are not maintained through WTP. However, other programs can pass information to WTP
specifying the use of a user profile. A user profile is selected for a request following these steps:

If a value is specified for userAndSessionExtractor in etc/localConfig.prop, WTP tries to execute
the referenced implementation of the UserAndSessionExtractor interface to obtain user and session
names and select the user profile that matches the user name. Please refer to the Developer's Guide
for information about implementing a UserAndSessionExtractor interface.

1.  

You can specify a field in the HTTP header to be used to select a user profile by setting the
httpUserIdField value in etc/localConfig.prop. For example, if you specify
httpUserIdField=X-UserField then WTP would find the value of the X-UserField keyword in the
HTTP header and select the user profile that matches that value.

2.  

If the X-IBM-PVC-User field is present in the HTTP header, WTP uses the user profile that
matches the value specified for that field.

3.  

If none of these checks identifies a user profile, then WTP does not use a specific user profile. If one of
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these methods is used to specify a user profile and the specified file is not found, WTP does not try the
other methods; it does not use a specific user profile. For example, if you specify
httpUserIdField=myUserField but myUserField is not specified in the HTTP header, WTP would not
look for the X-IBM-PVC-User field.

If more than one device or network preference profile matches the incoming request, it is impossible to
predict which of the matching profiles would be selected. For example, if you create two device profiles
with expressions that could match the same user-agent value, either one could be selected for a request
that specifies that user-agent value. Be sure to specify unique values for any new profiles you create.

Each profile contains values for the preferences that are important to the device or network that the
profile represents. If a preference is not important to the device or network, it can be omitted so that a
value can be chosen from a different profile. For most preferences, Transcoding Publisher will check
profiles for a value in this order:

Specific user1.  

Specific network2.  

Specific device3.  

Default user4.  

Default network5.  

Default device6.  

If a value is not specified for a preference in one profile, Transcoding Publisher will work down the list
until it finds a value. The transcoders that will be applied to the document are selected based on the
combined profiles.

Transcoding Publisher provides profiles for several common pervasive devices and for several network
types. There are default profiles to be used if none of the existing profiles matches the device or network
being used. These profiles are listed in the tree area of the Administration Console. You can view the
details of a preference profile by clicking it in the tree. The details will be displayed in the right pane.
You can modify the profile if you wish. Note that user profiles do not appear in the tree and cannot be
modified through the Administration Console.

In addition to determining which transcoders will be used, a profile can be used to select a stylesheet or
annotator. For details, see Modifying resources. You can also specify parameters to be used by
stylesheets that accept parameters.

XML stylesheets

When Transcoding Publisher processes documents composed in Extensible Markup Language (XML), it
uses XSL stylesheets to convert these documents. XML documents can be converted to any markup
language, including:

A different dialect of XML, as defined by an output DTD (document type definition)●   

HTML, for display on a Web browser●   

WML (wireless markup language), for display on devices using WAP (wireless access protocol).●   
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Each stylesheet is represented by a stylesheet selector, which contains conditions for the selection of the
stylesheet for use by Transcoding Publisher. Stylesheet selectors are listed in the tree view of the
Administration Console. You can organize them into folders for easy access.

A stylesheet is selected to process a document based on the values of one or more fields in the HTTP
header, including the URL, and on the name or URL of the input DTD. A stylesheet can also be selected
based on criteria that match a preference profile, as described in Modifying resources.

You can view the details of a stylesheet selector by selecting it in the tree. The details will be displayed
in the right pane. You can modify the stylesheet selector if you wish.

Some stylesheets accept parameters that affect how they operate on documents. A stylesheet that accepts
parameters can retrieve values for the parameters from:

The HTTP Header of the request●   

Values specified on the Stylesheet parameters dialog●   

Values specified in a preference profile●   

Stylesheets that support internationalization can use a translation file to retrieve strings to be substituted
for words in a document. You can identify a translation file for this purpose on the Stylesheet
parameters dialog.

For more details about stylesheets, visit the World Wide Web Consortium page about XSL stylesheets.

IBM ships several stylesheets with Transcoding Publisher. These stylesheets are samples and are not
supported for use in a production environment.

Annotators

You might want to present only the subset of a Web page that is most pertinent for your mobile users.
For example, there might be one key piece of information, such as a stock price or weather forecast, that
you want to present without all the graphics and other information on the page. You can use an annotator
to specify which portions of a Web page to include or discard when the page is transcoded.

Each annotator is based on knowledge of the structure of HTML or other tags used in a Web page. An
annotator typically is applied to one Web page or a group of pages with similar tagging.

Each annotator is represented by an annotator selector, which contains conditions for the selection of the
annotator for use by Transcoding Publisher. Annotator selectors are listed in the tree view of the
Administration Console. You can organize them into folders for easy access.

An annotator is selected to process a document based on the values of one or more fields in the HTTP
header, including the URL. An annotator can also be selected based on criteria that match a preference
profile, as described in Modifying resources.

You can view the details of an annotator selector by selecting it in the tree. The details will be displayed
in the right pane. You can modify the selector if you wish to change the conditions under which the
annotator will be used by Transcoding Publisher. These conditions can include the requested URL and
the device type.

Overview
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IBM ships several annotators with Transcoding Publisher. These annotators are samples and are not
supported for use in a production environment.

Transcoders

A transcoder is a program that modifies the content of a document. Transcoders are selected to process a
document based on conditions specified when the transcoder is created. Refer to the Developer's Guide
for more information.

The transcoders included with Transcoding Publisher can be divided into two types:

Text editors, which translate text from one tagging language to another or modify the tagging
within a language. Text editors make changes such as changing tables to lists and changing
paragraph tags to line breaks.

●   

Image editors, which change images from one type to another (JPEG to GIF or WBMP) or
change the screen size, file size, or other characteristics of images contained within the document
being processed. The image engine transcodes common image formats JPEG and GIF to perform:

format conversion❍   

scaling❍   

conversion to grayscale❍   

quality reduction (JPEG) or color depth reduction (GIF)❍   

●   

Several transcoders are provided with Transcoding Publisher, and you can obtain or develop others.

Transcoder     Function     

Image transcoder Modifies size and quality of GIF, JPEG, WBMP, and PNG images

Text transcoder Modifies HTML or XML documents

Fragmentation Transcoder
Fragments documents into pieces that can be accepted by the
receiving device

Some of the transcoders provided with WTP have special functions, which many users will not want to
use. These transcoders are initially not enabled, so that they will not be executed if you do not need them.
Review these descriptions to determine whether you want to enable these transcoders. See Enabling and
disabling resources for information about enabling transcoders.

The HDML transcoder transcodes HTML data into HDML format.●   

The i-mode transcoder transcodes HTML data to content that can be displayed on i-mode devices.
The i-mode transcoder is in the file IModeTranscoder.jar, in the plugins directory.

●   

The VoiceXML Transcoder transcodes Web content into the format needed for
VoiceXML-capable browsers. The transcoder converts HTML input into VoiceXML which can, in
turn, be converted to speech by a voice browser such as the one provided with the IBM

●   
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WebSphere Voice Server. Refer to the Developer's Guide for information about setting up this
transcoder.

The Palm Transcoder extends Web content to Palm VII users without requiring the installation of a
separate Web browser on the device. The transcoder converts HTML input into PalmOS HTML
(also called Palm Web Clipping Application format) which can be viewed directly using the
built-in support provided by the device's PalmOS. Refer to the Developer's Guide for information
about setting up this transcoder.

●   

The following special-purpose transcoders are provided with WTP but are not registered. You must
register and enable them if you want to use them. See Adding new resources for information about
registering transcoders.

The Machine Translation transcoder can be used with IBM WebSphere Translation Server to
translate content into different languages. Refer to the Developer's Guide for information about
setting up this transcoder.

●   

The Reverse Proxy Cookie transcoder solves a problem created when a Web site use Set-Cookie
HTTP objects specifying a domain for one or more responses. See Problems with cookies when
deployed as a reverse proxy for a description of this transcoder and the problem it solves.

●   

The HTML DOM Generator transcoder creates a Document Object Model (DOM) from HTML
documents. This enables you to apply clippers to the DOM to select portions of a document for
presentation to users. This transcoder is not registered; you must register it through the
Administration Console if you want to apply clippers to documents that are transcoded into
HTML.

●   

The transcoders provided with Transcoding Publisher are also provided as JavaBean components, which
can be used independently of the Transcoding Publisher transcoding server. This provides a means for
other server programs, such as servlets, independent content-providing programs, or JavaServer (TM)
Pages (JSP), to invoke single transcoders directly. The JavaBean wrapper provides the transcoder with
the same information about the system and request that it receives inside the transcoding server, so that it
operates the same way in both contexts. Refer to the Developer's Guide for more information about using
the JavaBean transcoders.

If you use a central directory to store server models for use by your Transcoding Publisher servers, your
preference profiles, stylesheet selectors, annotation selectors, and transcoder definitions are stored in the
server model. See Using a central directory for information about using server models.

Steps in transcoding a document
When Transcoding Publisher receives a request from a user for a document, it follows these steps:

Select device, network, and user preference profiles as described in Preference profiles.1.  

Resolve any preference conflicts.2.  

Edit the request, modifying device restrictions that can be accommodated by transcoding. For
example, for a device that does not support JPEG images, indicate that JPEG images are
supported, because Transcoding Publisher can convert them to GIF images.

3.  
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Retrieve the document from the firewall or Web server.4.  

Schedule transcoders that match the preferences and document.5.  

Execute the transcoders.6.  

Return the transcoded document to the requesting user.7.  

The steps are slightly different if you have deployed WTP as a plugin in WebSphere Edge Server
Caching Proxy. In this model, WTP gains control at two steps in the Caching Proxy cycle:

At the PostAuthentication step, WTP determines whether transcoding is needed for this
document and whether an appropriately transcoded variant already exists within the cache. If
transcoding is required and a usable variant is not found, WTP chooses preferences and edits the
request.

1.  

At the Transmogrify step, WTP will transcode the document according to the preferences in
effect and store a transcoded copy of the document in the cache.

2.  

For more information about the Caching Proxy, refer to the WebSphere Edge Server Library, especially
the Web Traffic Express Programming Guide (Web Traffic Express is the former name of the Edge
Server Caching Proxy).

Overview
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Planning for Transcoding Publisher
Before you install and configure Transcoding Publisher, there are several decisions you must make about
how Transcoding Publisher will run. By reviewing these items now, you will be prepared to answer
questions during installation and configuration.

Choosing a deployment model
Each WTP server can run in any of these deployment models:

As a network proxy●   

As a reverse proxy●   

As a filter in WebSphere Application Server●   

As a plugin in WebSphere Edge Server Caching Proxy (formerly called Web Traffic Express)●   

You can also implement individual WTP transcoders within your own applications. See As JavaBean
components for more information.

As a network proxy

In this deployment model WTP is a single service that tailors content coming from many different Web
servers. Client browsers are configured to use the WTP server as a proxy. The proxy intercepts HTTP
requests and responses as they flow between the client and the Web server. A WTP server deployed as a
network proxy does not tailor content that is encrypted between the user and the Web server.

If you run Transcoding Publisher as a network proxy and your network uses a firewall server, you will
need to supply the address and port number used by the firewall server when you configure Transcoding
Publisher.

As a reverse proxy

When you deploy Transcoding Publisher as a network proxy, it acts on behalf of your client devices,
which are configured so that their HTTP traffic is routed through the proxy. You can also deploy
Transcoding Publisher as a surrogate or reverse proxy, which means that it acts as a proxy on behalf of a
single Web server or several Web servers, rather than on behalf of clients. In this deployment model,
client browsers or wireless gateways are not configured to use the Transcoding Publisher server as a
proxy. Instead, you supply links to your clients in which the hostname of the Transcoding Publisher
server is substituted for the hostname of the Web server for which Transcoding Publisher serves as a
reverse proxy. When Transcoding Publisher receives a request for a document from the server for which
it is acting as a reverse proxy, Transcoding Publisher will:

Redirect the request to retrieve the proper document1.  

Transcode the document appropriately for the device and network types2.  

Modify the links in the document so that when a user selects a link, the request will be routed
through Transcoding Publisher

3.  

Planning IBM Transcoding
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Return the document to the user4.  

When you use Transcoding Publisher as a reverse proxy, links in the source document must be included
in the source document and not generated by scripts or other means. Otherwise the links will not be
modified to direct traffic through the reverse proxy.

When you deploy WTP as a reverse proxy, you cannot use the same WTP server as a network proxy. If
your WTP server is configured as a reverse proxy, do not configure clients to use it as a proxy.

As a filter running in IBM WebSphere Application Server

In this deployment model, WTP tailors the content generated by a single WebSphere Application Server
(WAS). When deployed as a filter, WTP can tailor content before it is encrypted and sent to a user. This
deployment model is not supported on Linux. When you deploy WTP as a filter, you cannot use ports to
select network preference profiles.

WTP Version 4.0 works with WebSphere Application Server Version 3.5 or Version 4.0. If you use
WAS in your network, running WTP as a filter enables it to tailor the output of Web applications for
your pervasive devices. If you use encryption within the WebSphere Application Server, then you must
use Transcoding Publisher as a filter so that it can modify content before it is encrypted. If you do not use
encryption, then you could run Transcoding Publisher either as a filter or as a proxy. Running as a proxy,
Transcoding Publisher can transcode non-encrypted documents from any version of WebSphere
Application Server or another Web application server.

If you run Transcoding Publisher as a WAS filter, you must identify the Web applications whose output
you want Transcoding Publisher to transcode. If your Web application processes or creates XML
documents and it will be used with Transcoding Publisher, use the Xerces parsing library that is shipped
with Transcoding Publisher, rather than the older XML4J library in WebSphere Application Server. This
will ensure compatibility with Transcoding Publisher.

If you will use Transcoding Publisher as a WAS filter, IBM recommends that you not install WebSphere
Application Server with the InstantDB database. Use an external database such as DB/2. If you use a
cloned WAS configuration, Transcoding Publisher cannot be part of the cloned configuration. You must
install and configure Transcoding Publisher on each server where it will run.

As a plugin running in IBM WebSphere Edge Server Caching Proxy

When you deploy WTP as a plugin in the Edge Server Caching Proxy (formerly known as Web Traffic
Express), you can take advantage of these Caching Proxy features:

Frequently requested documents can be supplied from the cache instead of being retrieved from
the Web server and re-transcoded.

●   

Clients can have persistent connections based on the Caching Proxy's HTTP 1.1 support.●   

If you use the Caching Proxy as a reverse proxy, it provides SSL support. This is not the same
thing as using WTP as a reverse proxy.

●   

If you require SSL endpoint function, you must run Caching Proxy as a reverse proxy. In this model,
Caching Proxy acts as a surrogate for sites that provide secure content, and WTP can transcode the
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content. Refer to the WebSphere Edge Server Library, especially the Web Traffic Express User's Guide,
for information about using the Caching Proxy as a reverse proxy. When Caching Proxy is configured as
a forward proxy, it will pass encrypted content through with no modifications. WTP cannot transcode the
encrypted content, but it can transcode unencrypted content.

By default, any document processed by the Caching Proxy is transcoded. You can specify that
documents should not be transcoded by using the disableTranscoding preference. See Configuring WTP
as a plugin for more information.

As JavaBean components

The programs inside the Transcoding Publisher transcoding server that modify content are called
transcoders. The transcoders are also provided as JavaBean components, which can be run independently
of Transcoding Publisher. This provides a means for other server programs, such as servlets, independent
content-providing programs, or JavaServer (TM) Pages (JSP), to invoke single transcoders directly. The
JavaBean wrapper provides the transcoder with the same information about the system and request that it
receives inside the Transcoding Publisher transcoding server, so that it operates the same way in both
contexts.

This table summarizes the features and considerations of each deployment model:

Deployment model Features Considerations

Network proxy

Transcodes content from any
Web server
Uses multiple ports to enable
network profiles

Does not transcode encrypted content
Requires client proxy configuration

Reverse proxy

Does not require client proxy
configuration
Uses multiple ports to enable
network profiles

Transcodes content from a specified set
of Web servers
Does not transcode encrypted content

WebSphere Application
Server filter

Transcodes dynamically
generated content from a single
Web application server
Can transcode content before it
is encrypted
Does not require client proxy
configuration

Not supported on Linux
Does not use multiple ports to enable
network profiles

WebSphere Edge Server
Caching Proxy plugin

Uses caching to improve
performance
SSL support (when run as
reverse proxy)
HTTP 1.1 support

Requires client proxy configuration
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JavaBean transcoders Most flexibility and control
Your application must provide
scaffolding

Using a central directory
If you have several Transcoding Publisher servers in your network, you can choose to store the
configuration information for each Transcoding Publisher server on that server's machine, or you can use
a central directory, IBM SecureWay(R) Directory, Version 3.2, to store one or more server models to be
used by your Transcoding Publisher servers. A server model contains configuration information that can
be used by any number of Transcoding Publisher servers in your network.

Using a central directory enables you to define common configurations to be used by several servers and
to maintain them from an Administration Console anywhere in your network. Then, if you need to make
a change to the shared information (for example, to add a new stylesheet or modify a device profile), you
can make the change to the server model and all Transcoding Publisher servers that use that server model
will recognize the change. See Using a central directory for information about using a central directory.

Security
Users must log on to the Administration Console if a central directory is being used; the login is verified
by the directory server. Users can edit local settings without logging in, and they can access all data at an
Administration Console when a central directory is not being used.

The transcoding server does not provide a log-in mechanism. It will be accessible to any user with
permission to log on to the machine (either locally or by telnet) and execute commands in the
Transcoding Publisher directories. If you want to limit access to Transcoding Publisher, consider
installing it on a machine with limited access or in a file system with limited permissions.

Hardware and software prerequisites
Transcoding Publisher Server is a Java product that performs best on machines that are designed to be
servers. These machines are generally built for improved scalability and performance. For example,
server machines usually have room for large amounts of memory and offer large L1 and L2 caches. The
following table shows the minimum system hardware requirements for each platform operating as a
standalone Transcoding Publisher server. You can install and run Transcoding Publisher on a machine
with less power or memory, but this might not provide the desired response time and user capacity.

In each configuration, Transcoding Publisher requires about 60MB of free space. Up to 100MB might be
required to download and install product updates.

To use centralized configuration data, you must have SecureWay Directory, Version 3.2, installed in
your network.

To deploy Transcoding Publisher as a filter in WebSphere Application Server, you must have WAS
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Version 3.5.4 or a later 3.5 fix pack on the machine where you install WTP. Visit the WTP Web page for
updated information about supported WAS versions. The prerequisites for Transcoding Publisher in this
model are the same as those for WebSphere Application Server, except that you'll need another 60MB of
disk space.

To deploy Transcoding Publisher as a plugin in WebSphere Edge Server Caching Proxy, you must have
Edge Server Caching Proxy Version 3.6.0.1 on the machine where you install WTP. The prerequisites for
Transcoding Publisher in this model are the same as those for Caching Proxy, except that you'll need
another 60MB of disk space.

To run Transcoding Publisher as a network proxy, use one of these configurations:

Platform Software Recommended Hardware

Windows NT Server: Version
4 with Service Pack 5 or 6a

JDK 1.3 (available on
the installation CD)

Pentium II system, 350 MHz or
higher, with at least 512MB of
memory

Windows 2000 Server (with
or without Service Pack 1)

JDK 1.3 (available on
the installation CD)

Pentium II system, 350 MHz or
higher, with at least 512MB of
memory (or the minimum required
by the operating system)

AIX: Version 4.3.3.10 or
higher Version 4 release

JDK 1.3 (available on
the installation CD)

RS6000 Power PC, 375 MHz for
uni-processor, 332 MHz for
multi-processor, with 1GB of
memory

Sun Solaris: Version 7 or
higher

JDK 1.3
Ultra Sparc, 333 MHz, with 1GB of
memory

Linux (refer to the WTP Web
page for supported Linux
distributions)

JDK 1.3
Pentium II system, 350 MHz or
higher, with at least 512MB of
memory
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Using a central directory
Depending on the needs of your network, you can choose to store the configuration information for each
Transcoding Publisher server on that server's machine, or you can use a central directory, IBM
SecureWay(R) Directory, to store one or more server models to be used by your Transcoding Publisher
servers. A server model is a data structure, stored in a central database, that defines a set of configuration
parameters for a WTP server. See Where information is stored to learn what information is stored in a
server model.

Using a central directory enables you to define common configurations to be used by several WTP
servers and to maintain them from an Administration Console anywhere in your network. Then, if you
need to make a change to the shared information (for example, to add a new stylesheet or modify a
device profile), you can make the change to the server model and all Transcoding Publisher servers that
use that server model will recognize the change.

You can have Version 3.5 WTP server models and WTP Version 4 server models in the same directory.
Each WTP server model is specific to a particular release; you cannot have a WTP Version 3.5 server
that uses a Version 4 server model. If you have a Version 3.5 server model that you want to use for a
Version 4 WTP server, when you install the server, choose to create a new server model from an existing
one, and create a Version 4 server model from the Version 3.5 server model.

When you store information in a central directory, the information is not associated with a particular
Transcoding Publisher server. Instead, the directory contains one or more server models, each describing
a different set of configuration information, and each Transcoding Publisher server identifies which
server model it uses. For example, you might want to have one server model to be used by Transcoding
Publisher servers whose users want to have high-quality graphical images, and another to be used by
servers whose users want to emphasize speed over image quality. Each server model is configured for
one of the WTP deployment models (proxy, reverse proxy, filter, or plugin), so you will need at least one
server model for each WTP deployment model that you use in your network.

Using a central directory
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Use the central directory model if:

You have several Transcoding Publisher servers and want to use common server models rather
than maintaining each server's configuration separately.

●   

You want to enable an administrator to modify the characteristics of any Transcoding Publisher
server, not just the server on the administrator's local machine.

●   

You have IBM SecureWay Directory installed in your network.●   

Use the local data storage model if:

You have few Transcoding Publisher servers and prefer to manage each server separately.●   

You do not want to share configuration information between servers.●   

Where information is stored
This section explains where different types of configuration data are stored when you use a central
directory. For more information about the configuration data used by Transcoding Publisher, see
Transcoding Publisher resources and Administering Transcoding Publisher.

The following information is always stored on the machine where the Transcoding Publisher server runs:

Deployment model (proxy, reverse proxy, filter, or plugin)●   

Using a central directory
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Trace and log settings and files●   

Information needed to access the central directory (if one is in use)●   

The server model used by this server (if any)●   

The list of hosts from which a Request Viewer can monitor this server●   

For the filter deployment model, the list of Web applications whose output this Transcoding
Publisher server will transcode

●   

If you use a central directory, the following information is stored in server models in the central
directory:

Deployment model (proxy, reverse proxy, filter, or plugin)●   

All network, device, and user profiles●   

All stylesheet selectors●   

All annotator selectors●   

All transcoder definitions●   

For the proxy deployment model, all firewall and network port settings●   

For the reverse proxy deployment model, all firewall, reverse proxy, and network port settings●   

The folder structures defined for each type of resource●   

If you do not use a central directory, all information is stored on the machine where the Transcoding
Publisher server runs.

When you install a Transcoding Publisher server, you must specify whether it will use locally stored
configuration information or a server model from a directory. If you will use a server model from a
directory, you will need to provide this information when you install Transcoding Publisher:

The hostname or IP address of the directory server●   

The port number on which SecureWay Directory listens for messages (the default is port 389)●   

The Directory Suffix, which is the root of the directory tree where server models are defined●   

The server access ID and password that this Transcoding Publisher server will use to access the
central directory.

●   

When you install a Transcoding Publisher server that uses a server model, the server subscribes to
notifications issued by the central directory. Whenever an administrator anywhere in your network
updates a server model, all the servers using that server model will be notified of the change.
Notifications are issued through your network's RMI Registry server.

Creating server models
Transcoding Publisher provides four server model templates, one for each deployment model (proxy,
reverse proxy, filter, or plugin). You cannot use these templates as server models; you must use them as
starting points from which to create server models. When you install a Transcoding Publisher server that
uses a server model, you can either choose an existing server model or create a new server model from an
existing one or from a template.

Using a central directory
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One approach to creating server models is to install one Transcoding Publisher server or a standalone
Administration Console, and then use that Administration Console to create the server models you need
for your network. Then when you install other servers, you can choose which server model to use for
each server. Another approach is to install all of your servers, creating each server model as you install a
server that needs it. When you create a server model during the installation process, the wizard will
prompt you for the minimum set of information required to create the server model. When you create a
server model from an Administration Console, you can create a more complete definition than you can
when you create a server model during the installation process.

After you create a server model, using either method, you can edit it from an Administration Console.
You can modify any of its resources and settings. You can also add new resources by using the Register
menu items. The changes you make will affect all servers that use that server model.

Modifying server models
When you have logged on to an Administration Console, you can modify any server model by clicking
Models->Edit. Select from the list the server model you want to modify. You can modify any of its
resources by selecting them from the tree. You can also modify server model settings by clicking
Models->Settings and then selecting the type of settings you want to modify.

When you modify resources or settings in a server model, the changes are made immediately in the
central directory. However, in order to minimize disruptions to active servers, the servers using that
server model are not notified of each change as it is made. When you have finished modifying a server
model, click File->Refresh server. This will cause the RMI Registry server to issue a notification to all
the servers using the server model that you have modified. The servers will re-read the configuration
information from the central directory.

Another approach to making a lot of changes to a server model is to create a new server model based on
the one you want to modify. Then make all your changes to the new server model and switch one server
to use the new server model. If you are satisfied with the changes, you can switch the remaining servers
to use the new server model. This must be done at each server by clicking Settings->Server setup.

Dynamic notification
When you select a server model for a WTP server to use, the server is registered with the RMI Registry
that you have designated to perform dynamic notification for your network. The Registry maintains a list
of which servers use each server model.

When you use an Administration Console to modify a server model, the change is stored immediately in
the central directory. A notification is issued to the RMI registry that you have designated to perform
dynamic notification. The registry will forward the notification to all WTP servers that use the modified
server model.

If you need to change the location of your RMI registry, you can do so from an Administration Console
by clicking Settings->Notification.

Using a central directory
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Installing Transcoding Publisher

Before you install
Before you install Transcoding Publisher, be sure that your computer satisfies all the hardware and
software prerequisites.

If you use a central directory to store server configuration data, you will need to provide this information
during installation:

The hostname or IP address of the directory server●   

The port number on which SecureWay Directory listens for messages (the default is port 389)●   

The root directory of the directory tree where server models are defined●   

The read-only server access ID and password that this Transcoding Publisher server will use to
access the central directory.

●   

A read-write server access ID and password that the installation process will use to update the
central directory if necessary.

●   

To learn about using a central directory to store server configuration data, see Centralizing configuration
data.

The installation process creates log files, which you can examine if a problem occurs while installing
Transcoding Publisher. Install Manager creates a log file called IBMTransTrace.log in the Temp
directory. The native installation process on Windows creates tp_install.log, which is first created in the
Temp directory but after a successful installation is copied to the log directory under the directory in
which Transcoding Publisher is installed. The native installation process on AIX or Sun Solaris creates a
log file called TPinstall.log. The uninstall process on Windows creates a log file called tp_uninst.log in
the Temp directory.

Choose the platform on which you will install Transcoding Publisher:

Windows NT or Windows 2000●   

AIX or Sun Solaris●   

Linux●   

Installing Transcoding Publisher on Windows NT or
Windows 2000
You must be logged on with Administrator privileges to install Transcoding Publisher.

To install Transcoding Publisher, insert the installation CD. If you have autostart enabled, your computer
will display the Install Manager window. Otherwise run setupwin.exe. From this window you can review
product prerequisites, view the documentation, register the product, visit the product support Web site, or
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install Transcoding Publisher.

When you choose to install Transcoding Publisher, Install Manager will present the License Agreement
for Transcoding Publisher. You must accept the agreement before installing the product.

Install Manager will check for the presence of the required Java Development Kit (JDK). If the required
JDK is not found, Install Manager will add it to the list of programs to be installed from the installation
CD. The JDK is installed as IBM Cross Platform Technologies for Windows, v 2.0 and will appear in the
Windows Registry and under Add/Remove Programs under that name.

Note: When you install Transcoding Publisher, the environment variable TP_JAVA_HOME is set to the
location of the JDK. If you move the JDK after installing Transcoding Publisher, click
Settings->Control Panel->System->Environment to update this variable to the new location.

Install Manager will prompt you to choose an installation directory. The default location is \(Program
Files)\IBMTrans, where (Program Files) represents the default Program Files directory defined in the
registry. You can change to a different directory of your choice. If you are installing the JDK, Install
Manager will prompt you to choose an installation directory for the JDK. The default location is
\(Program Files)\IBM\Java13, where (Program Files) represents the default Program Files directory
defined in the registry.

Install Manager will determine whether you have enough free space to perform the installation. If not,
you will be given the option to change the target directory or exit. Next you will choose a destination
folder.

Install Manager will ask whether you want to store your server's configuration data on the local machine
or use a server model from a central directory.

If you choose a central directory, Install Manager will ask whether you want to install the full product or
only the Administration Console. If you install only the Administration Console, you can work with
server models in the central directory, but this machine will not transcode documents.

If you choose a central directory, Install Manager will present a panel to gather information about your
central directory:

The hostname or IP address of the directory server●   

The port number on which SecureWay Directory listens for messages (the default is port 329)●   

The root directory of the directory tree where server models are defined (the default is
o=ibm,c=us)

●   

The server access ID and password that this Transcoding Publisher server will use to access the
central directory. Note: the password is stored on the Transcoding Publisher server in encrypted
form, but it is sent to the directory server unencrypted. You should supply a user ID and password
that have read-only access to the directory server.

●   

Install Manager will attempt to connect to the directory server using the information you supply. If the
connection cannot be made, you can choose to try another directory server, exit the installation process,
or continue without making the connection. If you continue without making the connection, you will
have to connect later to finish configuring your server.
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Next Install Manager will ask for a user ID and password that have read-write access to the directory
server. This user ID and password are not stored for future use; they are used only if Install Manager
needs to update the central directory. If the connection is successful, the program will check whether the
Transcoding Publisher Version 4 server model data structures have been defined in the central directory.
If not, the data structures will be loaded into the directory. This might take several minutes, but it only
needs to be done once for each directory server. A progress bar will show the progress of this task.

When you install your first server that uses a server model, Install Manager will display a panel on which
you can enter the hostname and port number used by your RMI registry for dynamic notification. This
registry will be used by all WTP servers in your network that use server models. The registry information
is stored in the central directory. You can change it later from an Administration Console. See Dynamic
notification for more information about the notification server.

If you have a previous version of Transcoding Publisher on your machine, the installation process will
ask whether you want to save your configuration using the new export utility. You can choose to:

Save the configuration information and reimport it at the end of the installation process●   

Save the configuration information but not reimport it●   

Not save the configuration information●   

If you save the configuration information, you must choose the file in which the data will be saved.

At this point, Install Manager will display all your installation options and ask you to change them or
proceed. You can also choose to create a response file for use in subsequent installations. When you
proceed, Install Manager will invoke the native install program, InstallShield. InstallShield will uninstall
the previous version of WTP if one was detected, install Transcoding Publisher (and the JDK if needed),
create registry entries, and create Start Menu shortcuts for installed components.

If you had a previous version of WTP on your machine and chose to save and reimport the configuration
information, it will be reimported.

After installation is complete, the install process might instruct you to reboot your machine. Be sure to
reboot if so instructed; otherwise the WTP server will not run properly. The install process will display a
completion message and give you the chance to view the Readme file and start the Server Setup wizard.
Now it's time for configuration.

Installing Transcoding Publisher on AIX or Sun
Solaris
You must be logged on as root to install Transcoding Publisher.

Be sure that the environment variable JAVA_HOME is set to the location where Java is installed. If
JAVA_HOME is not set, Transcoding Publisher will expect it to be installed in /usr/jdk_base on AIX or
/usr/java on Sun Solaris. If you move the JDK after installing Transcoding Publisher, update the value of
JAVA_HOME to reflect the new location.

If you are using AIX with a double-byte language, install the x11.fnt.ucs.ttf package before installing
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Transcoding Publisher. Including this package improves the fonts and fixes problems with punctuation.

To install Transcoding Publisher, mount the CD file system, insert the installation CD and run
setupaix.sh on AIX or setupsun.sh on Solaris to display the Install Manager window. From this screen
you can review product prerequisites, view the documentation, register the product on AIX, visit the
product support Web site, or install Transcoding Publisher.

When you choose to install Transcoding Publisher on AIX, Install Manager will present the License
Agreement for Transcoding Publisher. You must accept the agreement before installing the product.

Install Manager will check for the presence of the required Java Development Kit (JDK). If the required
JDK is not found on AIX, Install Manager will add it to the list of programs to be installed from the
installation CD. If the required JDK is not found on Solaris, Install Manager will issue an error message
and exit. You must install the appropriate JDK before returning to the installation of Transcoding
Publisher.

Next, Install Manager will ask whether you want to store your server's configuration data on the local
machine or use a server model from a central directory.

If you choose a central directory, Install Manager will ask whether you want to install the full product or
only the Administration Console. If you install only the Administration Console, you can work with
server models in the central directory, but this machine will not transcode documents.

If you choose a central directory, Install Manager will present a panel to gather information about your
central directory:

The hostname or IP address of the directory server●   

The port number on which SecureWay Directory listens for messages (the default is port 389)●   

The root directory of the directory tree where server models are defined●   

The server access ID and password that this Transcoding Publisher server will use to access the
central directory. Note: the password is stored on the Transcoding Publisher server in encrypted
form, but it is sent to the directory server unencrypted. You should supply a user ID and password
that have read-only access to the directory server.

●   

Install Manager will attempt to connect to the directory server using the information you supply. If the
connection cannot be made, you can choose to try another directory server, exit the installation process,
or continue without making the connection. If you continue without making the connection, you will
have to connect later to finish configuring your server.

Next Install Manager will ask for a user ID and password that have read-write access to the directory
server. This user ID and password are not stored for future use; they are used only if Install Manager
needs to update the central directory. If the connection is successful, the program will check whether the
Transcoding Publisher Version 4 server model data structures have been defined in the central directory.
If not, the data structures will be loaded into the directory. This might take several minutes, but it only
needs to be done once for each directory server. A progress bar will show the progress of this task.

When you install your first server that uses a server model, Install Manager will display a panel on which
you can enter the hostname and port number used by your RMI registry for dynamic notification. This
registry will be used by all WTP servers in your network that use server models. The registry information
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is stored in the central directory. You can change it later from an Administration Console. See Dynamic
notification for more information about the notification server.

If you have a previous version of Transcoding Publisher on your machine, the installation process will
ask whether you want to save your configuration using the new export utility. If you say yes, you must
choose the file in which the data will be saved.

You can choose to create a response file for use in subsequent installations. At this point, Install Manager
will invoke the native install program, installp for AIX or pkgadd for Solaris. This native install program
will uninstall the previous version of WTP if one was detected. Transcoding Publisher will be installed in
/usr/IBMTrans on AIX and in /opt/IBMTrans on Sun Solaris.

If you had a previous version of WTP on your machine and chose to save and reimport the configuration
information, it will be reimported.

Upon completion of the installation process, the native install program will display a completion message
on the console. You can view the Readme file and start the Server Setup wizard. Now it's time for
configuration.

Installing Transcoding Publisher on Linux
You must be logged on as root to install Transcoding Publisher.

The Linux install image is a tar file on the Transcoding Publisher installation CD. To install Transcoding
Publisher on Linux, follow these steps:

Insert the installation CD.1.  

Change directory (cd) to /usr.2.  

Use the tar command to expand the files from the CD:

tar -xf /mnt/cdrom/linux/TransPubLinux.tar

3.  

This will install Transcoding Publisher in /usr/IBMTrans. If you install it elsewhere, set the environment
variable TRANSPUB to the directory where you install Transcoding Publisher.

You must have the appropriate JDK on your machine before starting any components of Transcoding
Publisher. Transcoding Publisher requires that the environment variable JAVA_HOME be set to the
location of your Java Development Kit (JDK). Be sure to set this variable before starting any components
of Transcoding Publisher. If you move the JDK after installing Transcoding Publisher, update the value
of JAVA_HOME to reflect the new location.

Using response files for repeated installations
If you want to install similar Transcoding Publisher configurations on several machines with the same
operating system, you can record an installation response file to store your responses to all the prompts
presented during installation. All responses must be identical; for example, if a JDK was installed when
the response file was created, it will be installed on other machines that use the response file. Then you
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can use this response file when you install Transcoding Publisher on the other machines.

You can use these functions with similar installations:

Record a response file: creates a file that you can later load or play.●   

Load a response file: runs a regular install, using the specified file to provide answers as you
progress through the installation screens.

●   

Play a response file: runs a silent installation, with no screens displayed, using the specified file.●   

To record a response file, you will proceed through the installation screens and on the final screen, before
you click Install, click Record Response File... and specify a file. The response file will be created and
the installation will be completed. After creating a response file, you can use the load function to review
your responses as you install the product, or you can use the play function to bypass the installation
screens and install using your responses.

All the commands described here must be run from the \instmgr directory on the CD-ROM. You can
supply any valid filename in place of install.script in the commands.

To load a response file, issue the command for your operating system:

Windows NT/ Windows 2000 instwin /l install.script

AIX ./instaix.sh /l install.script

Solaris ./instsun.sh /l install.script

To play a response file, issue the command for your operating system:

Windows NT, Windows 2000 instwin /p install.script

AIX ./instaix.sh /p install.script

Solaris ./instsun.sh /p install.script

For example, to install WTP silently on several Windows NT machines:

Install WTP on the first machine. Click the box to create a response file.1.  

Review the file if desired: instwin /l C:\temp\install.script2.  

Copy the response file to each Windows NT machine where you want to install Transcoding
Publisher.

3.  

Play the response file on each machine: instwin /p C:\temp\install.script4.  

When the install has finished, you can review any error messages by reading InstmgrTrace.log in the
TEMP directory. Also check the native install log file for your operating system:

Windows NT, Windows 2000 TP_install.log

AIX, Solaris TPinstall.log
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After you have installed Transcoding Publisher
The documentation files (help, Administrator's Guide, and Developer's Guide) for Transcoding Publisher
are stored in ten language directories under doc/source. Each language directory takes up over 1MB of
disk space. If you are concerned about disk space, you can delete the directories for the languages you do
not use.

Now it's time for configuration.

Uninstalling Transcoding Publisher
If you have deployed WTP as a filter in WebSphere Application Server, the WAS AdminServer must be
running when you uninstall WTP. Otherwise the WAS configuration performed by WTP will not be
removed and WAS will try to invoke WTP to transcode documents.

If you have deployed WTP as a plugin in WebSphere Edge Server Caching Proxy, you must stop
Caching Proxy before uninstalling WTP.

The standard way to uninstall WTP from Windows NT or Windows 2000 is to use the Add/Remove
Programs applet from the Control Panel. The registration of WTP for uninstallation via Add/Remove
Programs on Windows NT and Windows 2000 sometimes fails. If for any reason you are unable to
uninstall WTP from the Windows Add/Remove Programs menu, or if you want a way to uninstall from a
command line rather than through the Windows GUI, you can follow these steps to uninstall WTP:

Insert the WTP CD.1.  

Open up a DOS command prompt.2.  

In the DOS window, type the following: x:\win\ibmtrans\Setup.exe Uninstall Where x is the CD
drive letter.

3.  

The InstallShield Wizard will launch and enable you to uninstall WTP.

To uninstall WTP on AIX or Sun Solaris, use these commands:

AIX: installp -u IBMTrans●   

Sun Solaris: pkgrm IBMWTPsvr IBMWTPadm (if you installed the full product) or pkgrm
IBMWTPadm (if you installed only the Administration Console)

●   

If you uninstall Transcoding Publisher on AIX or Sun Solaris, and your JDK is not in the standard
location:

AIX: /usr/jdk_base●   

Sun Solaris: /usr/java●   

then issue the command for your operating system to unlink the now removed libDistiller.so:

AIX: rm $JAVA_HOME/lib/aix/native_threads/libDistiller.so●   

Sun Solaris: rm $JAVA_HOME/lib/libDistiller.so●   
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Configuring Transcoding Publisher
After you have installed Transcoding Publisher, the Server Setup wizard enables you to implement the
decisions you made in Planning. If your server's configuration is stored locally, and you will deploy
Transcoding Publisher as a network proxy with no firewall server, you do not need to complete the
Server Setup wizard that is presented at the end of the installation process. However, you must complete
the wizard if:

You want to deploy Transcoding Publisher as a reverse proxy●   

You want to deploy Transcoding Publisher as a WebSphere Application Server filter●   

You want to deploy Transcoding Publisher as an Edge Server Caching Proxy plugin●   

Your network uses a firewall server●   

You are using a server model from a central directory to define the server's configuration●   

The Server Setup wizard will guide you through a series of panels that will gather the basic information
needed to configure your server. First you must specify how you will deploy the Transcoding Publisher
server:

As a network proxy●   

As a reverse proxy●   

As a filter in WebSphere Application Server (WAS)●   

As a plugin in Edge Server Caching Proxy●   

After that, the steps you will use to configure Transcoding Publisher depend on whether your server's
configuration will be stored on the local machine or as a server model in a central directory.

Choosing a server model
If you specified during installation that you will use a server model to define the server's configuration,
the Server Setup wizard will present a list of the server models for your deployment model (proxy,
reverse proxy, filter, or plugin). You can either select a server model to use for this server, or select a
server model to use as a base to create a new server model. If no server models have been defined yet for
your deployment model, you will need to create one based on the server model template for your
deployment model. See Using a central directory for more information about using server models.

If you create a new server model, the wizard will ask you for information appropriate to your deployment
model, possibly including firewall settings and reverse proxy settings. Finally, you must provide a name
and description for the server model. This is the server model that will be used for the server on this
machine, and it will be available for use by other Transcoding Publisher servers that use the same
deployment model.

If your server will run as a network proxy, a reverse proxy, or a plugin, you are finished with server
setup. If your server will run as a filter in WebSphere Application Server, there is one more step, which
is described in Configuring Transcoding Publisher as a WebSphere filter.

Configuring Transcoding Publisher
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Configuring Transcoding Publisher locally
If you specified during installation that you will store your server's configuration on the local machine,
use the Server Setup wizard to configure the server:

As a network proxy●   

As a reverse proxy●   

As a filter in WebSphere Application Server (WAS)●   

As a plugin in Edge Server Caching Proxy●   

Configuring Transcoding Publisher as a network proxy

When you run Transcoding Publisher as a network proxy, you must specify the other network servers
with which it will need to interact. These may include a firewall server.

Setting up the firewall

Many companies use a firewall to protect their networks from intrusion by outside parties. The firewall
might be a proxy server or a socks server. All communications with addresses outside their networks are
routed through the firewall. If your network uses a firewall to communicate with Web servers outside
your network, you must configure Transcoding Publisher to use the firewall.

In the Server Setup wizard, identify the type of firewall used in your network:

None: your network does not use a firewall●   

Proxy server●   

Socks server (Transcoding Publisher supports Versions 4 and 5 socks servers)●   

Specify the address and listening port of the firewall. You can specify the address in dotted decimal
format or as a hostname. If you enter a hostname, Transcoding Publisher will attempt to validate the
hostname through your Domain Name Server (DNS). This may cause a slight delay in processing the
address.

This is the minimum configuration required for Transcoding Publisher to work with a firewall. To
specify more settings, use the Firewall Settings panel on the Administration Console.

Configuring Transcoding Publisher as a reverse proxy

You can use Transcoding Publisher as a reverse proxy to transcode HTML output from a single Web
server or from several Web servers. In this configuration, Transcoding Publisher acts as a proxy on
behalf of the Web servers rather than on behalf of clients. Therefore, client browsers and wireless
gateways are not configured to use the Transcoding Publisher server as a proxy. Instead, the hostname of
the Transcoding Publisher server is substituted for the hostname of the Web server for which
Transcoding Publisher serves as a reverse proxy.

For example, you have a Web server on www.yxorp.com, and you want your users to access
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http://www.yxorp.com/index.html as a starting page. You have a Transcoding Publisher server on
www.yxorp-wtp.com, which you want to use to transcode the output of this Web server. After
configuring www.yxorp-wtp.com as a reverse proxy for www.yxorp.com, you would give your users a
link to http://www.yxorp-wtp.com/index.html. When a user accesses this URL, he will receive the
contents of www.yxorp.com/index.html, transcoded for his device and network types. Any time he
follows a link from index.html, he will receive the contents of the new page, again transcoded
appropriately.

To configure Transcoding Publisher to run as a reverse proxy for a single Web server:

In the Server Setup wizard, on the panel where you select your deployment model, select Reverse
proxy. Click Next.

1.  

On the next panel, specify that you want to run WTP as a reverse proxy for a single Web server.
Enter the hostname for the Transcoding Publisher server. This is the host name that will resolve to
the Transcoding Publisher server in the Internet or intranet Domain Name Server. Enter a fully
qualified hostname, even if the Web server and the WTP server are in the same domain.

2.  

Enter the hostname of the Web server. Click Next.3.  

When you use a Transcoding Publisher server as a reverse proxy, it can be located on the same machine
as your Web server, or on a different machine. If the two servers are on the same machine, you must
specify a port number for one server or both. For example, if your Web server is on www.yxorp.com,
and you install Transcoding Publisher on the same machine, with port 8088 defined as its default
listening port, link your users to http://www.yxorp.com:8088/index.html as their starting page. Requests
arriving on this port will be transcoded. Other traffic that uses http://www.yxorp.com/index.html
(without the port designation) will arrive on the default port and access the Web server directly, without
transcoding.

To configure Transcoding Publisher to act as a reverse proxy for several Web servers:

Create an HTML page providing links to all the servers, providing the text you want to use for
each link. A sample page is provided in reverseProxy\index.html. Your users will see this page,
transcoded for their device and network types, when they connect to this Transcoding Publisher
server.

1.  

In the Server Setup wizard, on the panel where you select your deployment model, select Reverse
proxy. Click Next.

2.  

On the next panel, specify that you want to run WTP as a reverse proxy for a several Web servers.3.  

Enter the hostname for the Transcoding Publisher server. This is the host name that will resolve to
the Transcoding Publisher server in the Internet or Intranet Domain Name Server. Enter a fully
qualified hostname.

4.  

Enter the name and location of your HTML page: either enter a fully qualified file name or a URL,
or use the Browse button to locate the file. Note: if you use a central database, this file location is
stored in a server model, so the file must be accessible in the same way to all Transcoding
Publisher servers using this server model. See Using a central directory for more information about
server models. Click Next.

5.  

Configuring Transcoding Publisher

file:///D|/cmvcbase/transproxyinfo/source/agcfgbdy.htm (3 of 7) [06/28/2001 1:14:38 PM]



Using Transcoding Publisher as a reverse proxy

When you use Transcoding Publisher as a reverse proxy, it is not necessary to configure your users'
browsers to use a proxy server. They will receive transcoded pages by starting with the URL that
contains the Transcoding Publisher server's hostname.

If you will use your Transcoding Publisher server as a reverse proxy for a single Web server, give your
users the URL of the Web server's start page with the hostname of the Transcoding Publisher server
substituted for the Web server's hostname, as in the example above. If you will use your Transcoding
Publisher server as a reverse proxy for multiple servers, give your users the URL consisting of the
hostname of the Transcoding Publisher server, for example, http://www.yxorp-wtp.com. When the
Transcoding Publisher server receives a request for this resource, it will present the HTML page you
supplied, with all the links modified to be routed through the Transcoding Publisher server. Your users
can link to all the designated servers, and the responses will be transcoded.

Configuring Transcoding Publisher as a WebSphere filter

If global security is enabled on the WebSphere Application Server (WAS) server that Transcoding
Publisher is configuring, you will be prompted for a username and password for each operation that
Transcoding Publisher performs. You may wish to temporarily disable global security (see the Configure
Global Security Settings Wizard in the Application Server Administrator's Console) to expedite the
configuration process.

The WAS AdminServer on the server machine must be running so that the configuration change can be
processed by the AdminServer.

To configure Transcoding Publisher as a filter in the WebSphere Application Server (WAS), click that
button in the Server Setup wizard. You will not need to configure Transcoding Publisher to communicate
with the firewall or other servers, because WAS will manage those communications.

When you configure Transcoding Publisher as a WAS filter, it can transcode the output of any of the
Web applications defined to WAS. The Server Setup wizard will present a list of the available Web
applications. The panel displays a list of names and descriptions of all the Web applications defined to
WebSphere Application Server on your machine. There is a check box next to each name. Web
applications that are selected will have their output transcoded by Transcoding Publisher; Web
applications that are not selected will not. Initially none of the Web applications are selected.

To specify that a Web application's output should be transcoded by Transcoding Publisher, click it. To
specify that a Web application's output should not be transcoded by Transcoding Publisher, clear it. After
making all your choices, click Next. This completes the configuration of Transcoding Publisher as a
WebSphere filter.

The list of Web applications whose output Transcoding Publisher will transcode is a local setting; it is
not stored in a server model. You can change the list later from the Administration Console by clicking
Settings->Web applications. You can make other changes by clicking the Advanced button from the
Web application settings panel.

If you have an active WAS Administrator's Console when you update Transcoding Publisher's
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configuration, you may need to use the refresh option in the console on affected application servers to see
the changes. In some cases, it will be necessary to stop and restart the WAS Administrator's Console to
fully synchronize the view with the state of the WAS AdminServer. Neither of these operations affects
the operation of Transcoding Publisher; they will simply synchronize the console view with the actual
WAS AdminServer configuration information.

Configuring Transcoding Publisher as an Edge Server Caching
Proxy plugin

To configure Transcoding Publisher as a plugin in the WebSphere Edge Server Caching Proxy, click that
button in the Server Setup wizard. You will not need to configure Transcoding Publisher to communicate
with the firewall or other servers, because the Caching Proxy will manage those communications. There
are no options to specify in this deployment model. You must restart the Caching Proxy after completing
the Server Setup wizard.

By default, all documents processed by the Caching Proxy will be transcoded. If you want some
documents not to be transcoded, you can use the disableTranscoding preference for this purpose. This
preference defaults to false; set it to true for documents that you do not want transcoded. For example, if
you do not want documents requested from a certain device type to be transcoded, add
disableTranscoding=true to the appropriate device preference profile.

Configuring Transcoding Publisher to start
automatically
The following information applies only when Transcoding Publisher is configured as a network proxy or
as a reverse proxy. When WTP is configured as a WAS filter, the WebSphere Application Server will
start and stop Transcoding Publisher. When WTP is configured as a plugin in Edge Server Caching
Proxy, the Caching Proxy will start and stop Transcoding Publisher.

On Windows NT and Windows 2000, the Transcoding Publisher transcoding server is installed as a
Windows NT service or Windows 2000 service. It is set to be started manually. To have Transcoding
Publisher start automatically when your system is started, use the Services utility on the Control Panel.
Select IBM Transcoding Publisher in the list of services, then click Startup. Change the startup type to
automatic. Transcoding Publisher will be started automatically when the machine is started.

On AIX, the file /etc/inittab contains entries used to start programs when AIX is started. When
Transcoding Publisher is installed on AIX, a line is added to this file with the command to start
Transcoding Publisher. The line is added as a comment so that you can decide whether you want
Transcoding Publisher to be started when AIX is started. If you want Transcoding Publisher to be started
when AIX is started, remove the comment delimiter from the front of this line.

On Sun Solaris, the directory /etc/init.d/ contains commands to be used to start or stop programs when
the operating system is started in different modes. The TransPub shell script is copied to this directory
by the install process. To invoke this script to start or stop Transcoding Publisher, add links to the /etc
subdirectories that represent different types of startups. For example,
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chmod 744 /etc/init.d/TransPub
cd /etc/rc3
ln -s /etc/init.d/TransPub S99TransPub
cd /etc/rc0
ln -s /etc/init.d/TransPub K01TransPub

This is just an example; be sure to comply with your system policies and procedures for starting
programs automatically.

On Linux, the directory /etc/rc.d/ contains subdirectories representing different types of startups. Each
subdirectory contains commands to be used to start or stop programs when the operating system is started
in different modes.

Move or copy the TransPub script from /usr/IBMTrans to /etc/rc.d/init.d. Add links to the subdirectories
that correspond to the system runlevel (see file /etc/inittab). For example, for a system starting in the full
multiuser mode (runlevel 3):

cd /etc/rc.d/rc3.d
ln -s /etc/rc.d/init.d/TransPub S99TransPub

Configuring clients
If you add Transcoding Publisher as a filter in a network that already uses WebSphere Application
Server, or as a plugin in Edge Server Caching Proxy, you do not need to change the configuration of your
client devices. If you deploy Transcoding Publisher as a reverse proxy, you do not need to configure your
client devices to use Transcoding Publisher.

If you use Transcoding Publisher as a network proxy, you must configure your client devices or wireless
gateway to use your Transcoding Publisher server as an HTTP proxy. Your clients may already be
configured to use your firewall as a proxy server; in that case, you can simply replace the firewall's
address with the address of the machine where you installed Transcoding Publisher. If you want to use
network preference profiles, be sure to configure each client to access Transcoding Publisher on the port
corresponding to the type of network it uses.

If, when you configure your client devices using the hostname of your Transcoding Publisher server, you
receive a message saying that the hostname does not exist or could not be found, this might indicate a
problem with your Domain Name Server (DNS). If you see this message, try configuring your devices
using the IP address of your Transcoding Publisher server.

Changing your configuration
If, after you have configured and run a Transcoding Publisher server in one way, you want to change to a
different deployment model, you can make this change by invoking the Server Setup wizard. You can
start the wizard from the Administration Console by clicking Settings->Server setup. You can start the
wizard from the command line on AIX, Sun Solaris, and Linux by typing SetupWizard.sh.

Use the Server Setup wizard for these changes:
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To change your deployment model (proxy, reverse proxy, filter, or plugin)●   

To select a different server model for your server to use.●   

All other changes can be made from within the Administration Console.

If you want to switch the deployment model of a Transcoding Publisher server to or from the filter
configuration, or uninstall a Transcoding Publisher server running as a WAS filter, the WebSphere
Application Server AdminServer on the server machine must be running so that the configuration change
can be processed by the AdminServer.

If you change your deployment model using the server setup wizard, the wizard will ask for new
information appropriate for your new deployment model. After you have completed the Server Setup
wizard, restart the server to enact the changes.

If you change your server's deployment model to filter or to plugin, shut the server down completely.
WebSphere Application Server or Edge Server Caching Proxy will start Transcoding Publisher when it is
needed.

If your reconfigured Transcoding Publisher will run as a network proxy or a reverse proxy, and the
transcoding server is running, the method to restart it depends on your operating system. On Windows
NT and Windows 2000, use the Services utility on the Control Panel to stop and restart the IBM
Transcoding Publisher service. On AIX, Sun Solaris, and Linux, enter TransPub restart on the command
line.
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Administering Transcoding Publisher
Your primary tool for administering Transcoding Publisher is the Administration Console. The
Administration Console is a flexible program that adapts itself to your server configuration and the
location of your configuration data. There are three Administration Console environments:

An Administration Console on a machine with a Transcoding Publisher server whose
configuration is stored on the local machine. In this case you will use the Administration Console
to administer all aspects of the local server.

●   

An Administration Console on a machine with a Transcoding Publisher server whose
configuration is stored in a server model in a central directory. In this case you will use the
Administration Console to work with server models in the central directory and to administer some
aspects of the local server.

●   

An Administration Console on a machine with no Transcoding Publisher server, in a network that
uses a central directory. In this case you will use the Administration Console to work with server
models in the central directory. There is no local server to administer.

●   

The online help for the Administration Console provides both conceptual material and detailed
step-by-step instructions. The help also has an index and a search tool. Click Help->Help to get started.

This page describes the console and its functions, and provides instructions for many common tasks,
such as:

Working with server models●   

Working with resources

Enabling and disabling preference profiles, transcoders, annotators, and stylesheets❍   

Modifying preference profiles and stylesheet and annotator selectors❍   

Adding new preference profiles, transcoders, annotators, and stylesheets❍   

Organizing resources into folders❍   

●   

Working with settings

Modifying central directory settings❍   

Modifying firewall settings❍   

Modifying notification settings❍   

Modifying port settings for network types❍   

Modifying Request Viewer hosts❍   

Modifying reverse proxy settings❍   

Modifying Web application settings❍   

●   

Refreshing the server●   

Working with logging and tracing●   

Importing and exporting configuration data●   

Administering Transcoding Publisher

file:///D|/cmvcbase/transproxyinfo/source/agadmbdy.htm (1 of 14) [06/28/2001 1:14:43 PM]



Starting and stopping Transcoding Publisher●   

Using the Administration Console
The Transcoding Publisher Administration Console is a graphical interface for many of your
administrative tasks. It provides:

A tree view of your resources (preference profiles, annotators transcoders, and stylesheets)●   

The ability to edit individual resources●   

A menu structure to provide access to other tasks●   

Help for each panel, as well as a list of other help topics●   

Accessibility

The Administration Console incorporates several accessibility features to help a user who has a physical
disability, such as restricted mobility or limited vision, to use it successfully. Keyboard equivalents are
provided for all actions so that you are not required to use a mouse or other tracking device. You can
change the appearance of your Administration Console from its platform-independent look (the Java
Look and Feel) to the standard appearance for applications that run on your platform. Click
File->Options to modify your Administration Console's appearance. If you choose the platform-standard
appearance, the Administration Console will inherit the appearance (size, color, and font settings) you
have defined for your platform. This function is not supported on Linux.

Starting the Administration Console

To start the Administration Console:

Windows NT and Windows 2000: click Start->Programs->IBM Transcoding Publisher->
Administration Console.

●   

AIX, Sun Solaris, and Linux: change directory (cd) to the WTP install directory and enter
./AdminConsole.sh at the command line.

●   

If you are using a central directory to store server models, you must log in when you start the
Administration Console. The userid and password will be verified by the central directory. If your login
fails, you cannot work with server models. However, you can work with local server settings without
logging in.

If you are using a central directory to store server models, the main panel of the Administration Console
will be empty when you start it. The Edit a Server Model dialog appears so that you can choose a server
model from the central directory. If you do not want to edit a server model, click Cancel to dismiss the
dialog. If you want to edit a server model, select it from the list. The server model's resources will be
displayed in the main panel. If your server's configuration is stored on the local machine, the server's
resources will be displayed when you start the Administration Console.

The main panel of the Administration Console has two panes. The left pane shows a tree view of your

resources. A turner icon appears to the left of each folder name.  indicates a collapsed category, while
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 indicates an expanded list. You can use these icons to expand and collapse folders.

Each transcoder, preference profile, annotator, and stylesheet resource is represented by a colored icon.

Transcoder Disabled transcoder

Device preference profile Disabled device preference profile

Network preference profile Disabled network preference profile

User preference profile Disabled user preference profile

Stylesheet Disabled stylesheet

Annotator Disabled annotator

When you select a resource in the left pane, its properties will be displayed in the right pane, where you
can view and modify them. When you click a folder in the left pane, the names and descriptions of the
resources in that folder are displayed as a list in the right pane. You can then double-click a list item to
work with it.

If you right-click a resource or a folder in the tree, a pop-up menu appears with options specific to that
type of resource or folder.

The status area at the bottom of the Administration Console displays the basic configuration you are
using, either network proxy, reverse proxy, WAS filter, or Edge Server - Caching Proxy plugin.

Working with server models
If you are using a central directory to store server models, you can use the items in the Models menu to
work with them. You can edit an existing server model to make changes to it, delete a server model that
is no longer needed, or create a new server model based either on an existing one or on a server model
template.

When you modify a server model, all servers using that server model will be notified of the changes. If
you create a new server model, you can use the Server Setup wizard to select the new model to be used
by your server. To have other servers use the new server model, you must use the Server Setup wizard on
those machines.

Working with resources
Transcoding Publisher uses four kinds of resources:

Preference profiles●   

Stylesheets●   

Annotators●   

Transcoders●   
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Each type of resource plays a different role in transcoding documents. These roles are described in WTP
resources. You can use the Administration Console to work with your resources in several ways.

If you are using server models to store server configurations in a central directory, you will work with
resources in a server model. If your server's configuration is stored on the local machine, you will work
with the resources on your server.

Enabling and disabling resources

If you have a preference profile, transcoder, annotator, or stylesheet that you don't want Transcoding
Publisher to use, you can disable it. It will still be registered and available for Transcoding Publisher to
use whenever you want to resume using it. To disable a resource, click it in the tree view to display its
properties in the right pane. Click the Enabled checkbox to clear it. After you click Save and refresh the
server, this resource will not be used by Transcoding Publisher.

To enable a resource that you have disabled, or to begin using a resource if you did not enable it when
you added it to Transcoding Publisher, click the resource in the tree view to display its properties in the
right pane. Click the Enabled checkbox to select it. After you click Save and refresh the server, this
resource will be used by Transcoding Publisher.

When you disable a resource, its icon is changed to contain a red X in a white box, as shown in the table
above. This makes it easy to identify disabled resources.

Modifying resources

You might want to modify an existing preference profile to change how Transcoding Publisher handles
documents requested by a particular device or network. For example, you might decide you want to
change image processing to favor smaller size over image quality more than the profile currently
specifies. To modify a profile, click it in the tree view to display its properties in the right pane. The
preferences included in this profile are displayed on two tabs:

Edit, which enables you to view and modify those preferences that are defined as user-editable for
this profile.

●   

View only, which enables you to review preferences that are defined for this profile, but which
cannot be modified through the Administration Console.

●   

Click Advanced for more options.

You may want to modify the conditions under which a stylesheet or annotator is selected to process
documents. To modify a stylesheet or annotator selector, select it in the tree view to display its properties
in the right pane. You can modify any of the displayed properties. Click Advanced for more options.

The set of selection criteria for each stylesheet and annotator must be unique.

From the advanced panel you can specify two types of additional criteria for selecting a stylesheet:

Use the Criteria matching HTTP header box to enter a formula that must be true for this
stylesheet to be used. You can use any information in the HTTP header.

●   
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Use the Criteria matching preferences box to specify criteria that will cause this XML stylesheet
to be associated with a preference profile. Enter the same values here and on the Advanced
Preference Profile Properties dialog box for the profile with which you want this stylesheet to be
used. These keys and values are not related to the incoming document; they can be any text strings
meaningful to you.

●   

For more information on these options, see the Help.

Adding new resources

You can extend Transcoding Publisher's capabilities by adding new stylesheets, transcoders, annotators,
or preference profiles. To add a new resource for Transcoding Publisher to use, you must register the
resource using the Register menu.

If you use a central directory to store server models, you must choose a server model to edit and add your
new resources to the server model. To learn more about using server models, see Centralizing
configuration data.

Adding preference profiles

When you acquire or create a new profile, place it in a temporary directory on your Transcoding
Publisher machine or on a mapped network drive or mounted file system. Do not try to place the profile
in the Transcoding Publisher directory structure; the registration process will copy it to the appropriate
location.

Register the new preference profile by clicking Register->Preference Profile. This will start the
Register a Preference Profile wizard. Answer the questions in the wizard to complete the registration.
You can change the name or description to your own language or to be more meaningful to you.

Adding XML stylesheets

When you acquire or create a new stylesheet, click the folder in the tree in which you want to store it,
then register it by clicking Register->XML Stylesheet. This will start the Register an XML Stylesheet
wizard. Answer the questions in the wizard to complete the registration. You can change the name or
description to your own language or to be more meaningful to you.

A crucial part of adding a stylesheet is to specify the criteria for using it with an XML document. You
must always specify the output content type, and you can specify other criteria to narrow the conditions
under which the stylesheet will be used. Every stylesheet that is registered with Transcoding Publisher
must have a unique set of selection criteria.

Note: When you deploy WTP as a reverse proxy, it appends the WTP server name at the beginning of
each URL that it finds in the document. When a user clicks on a link, the request will be routed through
the WTP server. This means that the URL in the request will not exactly match the true URL of the page.
If you use stylesheets with reverse proxy, you should add a wildcard character (*) at the beginning of
each URL that is used to select a stylesheet. That way the stylesheet will be selected even after the WTP
server name has been added to the beginning of the URL.
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Adding annotators

When you acquire or create a new annotator, click the folder in the tree in which you want to store it,
then register it by clicking Register->Annotator. This will start the Register an Annotator wizard.
Answer the questions in the wizard to complete the registration. You can change the name or description
to your own language or to be more meaningful to you.

A crucial part of adding an annotator is to specify the criteria for using it with a document. Every
annotator that is registered with Transcoding Publisher must have a unique set of selection criteria.

Note: When you deploy WTP as a reverse proxy, it appends the WTP server name at the beginning of
each URL that it finds in the document. When a user clicks on a link, the request will be routed through
the WTP server. This means that the URL in the request will not exactly match the true URL of the page.
If you use annotations with reverse proxy, you should add a wildcard character (*) at the beginning of
each URL that is used to select an annotator. That way the annotator will be selected even after the WTP
server name has been added to the beginning of the URL.

Adding transcoders

When you acquire or create a new transcoder, place the transcoder (typically a jar file) on your
Transcoding Publisher machine or on a mapped network drive or mounted file system. Do not try to
place the transcoder in the Transcoding Publisher directory structure; the registration process will copy it
into the correct location.

Register the transcoder by clicking Register->Transcoder. This will start the Register a Transcoder
wizard. Answer the questions in the wizard to complete the registration. You can change the name or
description to your own language or to be more meaningful to you.

Deleting resources

If you wish to completely delete a resource that you have added to Transcoding Publisher, select the
resource in the tree view and click File->Delete. You cannot delete the four base folders (Stylesheets,
Transcoders, Annotators, and Preference Profiles) or resources such as transcoders provided with
Transcoding Publisher.

Organizing and locating resources

Some organizations use a large number of stylesheets and annotators to control processing for specific
documents. The Administration Console provides assistance in organizing and locating your stylesheet
and annotator selectors. All the functions described in this section apply to these two resource types.

Organizing resources into folders

You may find it useful to organize your resources into folders. This arrangement of resources and folders
is solely for your convenience in finding and working with stylesheet and annotator selectors. Moving a
resource to a different folder does not affect its selection criteria.

The two operations you can use to organize your resources are creating new folders and moving a
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resource or a folder from one location to another.

A new folder must be created within an existing folder, which can be the base folder of a resource type or
any other folder. To create a new folder, click the folder under which you want to create the new folder,
then click File->New folder. Enter a name for the new folder and click OK. The new folder will appear
in the tree.

After you have set up your folders, you can move resources or folders from one folder to another. To do
this, click the resource or folder, then click File->Move. In the Move Resource dialog box, click the
location in the tree to which you want to move the resource or folder.

Locating resources

You can search among your stylesheet selectors to find those that contain any text string. You can search
by clicking File->Find or by clicking Find on the drop-down menu on any folder in the stylesheet
selector portion of the resource tree. If you use the drop-down menu, by default the search will be
restricted to that folder and any folders contained within it.

The Find dialog will display the stylesheet selector portion of the resource tree, so that you can select a
starting point for your search. A drop-down list saves the last ten strings that you have searched for so
that you can reuse them. On the Advanced tab, you can restrict your search criteria to specific properties
such as name, description, or a key-value pair. When you search, the results will be displayed at the
bottom of the Find dialog. You can double-click an entry in the results list to open that resource in the
Administration Console. To begin another search, click New.

Working with settings
Depending on your deployment model, you may be able to modify your firewall settings, proxy port
settings, Web applications, central directory settings, and server setup.

If your deployment model is...     You can modify...     

Network proxy

central directory settings*
firewall settings
notification settings
proxy port settings
Request Viewer hosts
server setup
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Reverse proxy

central directory settings*
firewall settings
notification settings
proxy port settings
Request Viewer hosts
reverse proxy settings
server setup

WebSphere Application Server filter

central directory settings*
notification settings
Web applications
server setup

Edge Server Caching Proxy plugin
central directory settings*
notification settings
server setup

* Central directory settings will be available only if you specified while installing WTP that you are
using a central directory.

If you want to change from one deployment model to another, or select a different server model for your
server to use, you must use the Server Setup wizard. See Changing your configuration for details.

Modifying central directory settings

If your server uses a server model from a central directory, or if you are using a standalone
Administration Console in a network that uses a central directory, you can use this panel to modify
parameters associated with connecting to the central directory. See the Help for details about each field
on the panel.

Modifying firewall settings

If you use a firewall in your network and WTP is deployed as a network proxy or a reverse proxy, you
must supply the address of your firewall server and the port number on which Transcoding Publisher will
communicate with it. You can specify the address in dotted decimal format or as a hostname. If you enter
a hostname, Transcoding Publisher will attempt to validate the hostname through your Domain Name
Server (DNS). This may cause a slight delay in processing the address. You can change the type of
firewall server as well as the address or port number.

Click Settings->Firewall to use the Firewall Settings panel to modify the address and port number. On
this panel you can also list addresses within your network with which Transcoding Publisher can
communicate directly, without going through the firewall server.
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If your server's configuration is stored on the local machine, you will use this panel to modify your
server's firewall settings. If you are using server models, you will use this panel to update the firewall
settings in the server model that you are editing.

Modifying notification settings

This panel will differ depending on where your server's configuration information is stored:

If your server's configuration is stored on the local machine, this panel is used to determine whether the
server will listen for notifications from the Administration Console. By default this function is enabled,
so that when the user clicks File->Refresh Server the server will receive the notification. You can turn
this function off if you have trouble (see Troubleshooting for a description of a situation in which you
might want to disable notification).

If your server's configuration is stored in a server model in a central directory, this panel is used to
determine whether your network will use dynamic notification. If you disable notification, then servers
will not be notified when a server model is updated.

Modifying port settings for network types

When you deploy Transcoding Publisher as a network proxy or a reverse proxy, you can use network
preference profiles to tell Transcoding Publisher how to transcode documents requested over different
types of networks. Transcoding Publisher provides profiles for some network types, and you can add
others. Transcoding Publisher determines the network type according to the port on which the request is
received.

Use the Proxy Port Settings panel to specify port numbers for each network type for which you have a
preference profile. To open this panel, click Settings->Proxy Port. To use network preferences,
configure each client device to use the port number corresponding to the type of network it uses.

If your server's configuration is stored on the local machine, you will use this panel to modify your
server's port settings. If you are using server models, you will use this panel to update the port settings in
the server model that you are editing.

Even if you are not adding any network preference profiles, you should review the default port settings
for the network preference profiles provided with Transcoding Publisher to ensure that they do not
conflict with existing port settings on your system. If there is a conflict, you can use the Proxy Port
Settings panel to change the port settings for the networks, or, if there is a network type you do not use,
you can disable that network preference profile.

If you want to use network preferences, each network must use a separate port to communicate with
Transcoding Publisher. If you do not want to use network preferences, disable all but the default network
preference profile.

Be sure to alert your users to reconfigure their devices to use the port numbers for their network types to
access Transcoding Publisher.
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Modifying Request Viewer hosts

The WTP Request Viewer tool, which is described in the Developer's Guide, can monitor the behavior of
a remote WTP server, but only if that server has specified that it can do so. To enable the Request Viewer
on a different machine to monitor your WTP server, click Settings->Request Viewer Hosts. You must
click the checkbox to enable remote Request Viewers to monitor this server. Then add the hostname of
the Request Viewer and click Add to list. You can delete hosts from the list, and you can turn off all
access by remote Request Viewers by deselecting the checkbox.

Modifying reverse proxy settings

If your WTP server is deployed as a reverse proxy, or surrogate, you can use this panel to modify
information about the servers for which it acts as a reverse proxy. You can:

Change the name or address of the single server for which it acts as a reverse proxy●   

Change the location of the HTML page that contains links to multiple servers●   

Change the server from a reverse proxy for a single server to a reverse proxy for multiple servers
or vice versa.

●   

To open this panel, click Settings->Reverse Proxy.

Modifying Web application settings

If you run Transcoding Publisher as a filter in WebSphere Application Server (WAS), you must indicate
which WAS Web applications will have their output transcoded. The list is created during initial server
configuration, but you can modify it from the Web Application Settings panel. To open this panel, click
Settings->Web Applications.

The panel displays a list of names and descriptions of all the Web applications defined to WebSphere
Application Server on your machine. There is a check box next to each name. Web applications whose
check boxes contain checks will have their output transcoded by Transcoding Publisher; Web
applications with empty boxes will not. Click the boxes to make the changes you want. After you have
made all your changes, click OK to save your changes or Cancel to cancel them.

Use the Advanced button to use two additional functions:

A document created by a Web application might reference one or more images that were not
generated by the Web application. These are called static images. You can specify that
Transcoding Publisher should:

Retrieve static images and transcode them according to the preferences in effect for this
request

❍   

Do not transcode static images❍   

Retrieving these images and transcoding them can affect the performance of Transcoding
Publisher.

This choice does not affect how Transcoding Publisher treats images that are generated by a Web

1.  
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application. Transcoding Publisher will always transcode generated images according to the
preferences in effect. This choice affects only static images that are referenced in a document, but
which were not generated by the Web application.

You can modify the list of MIME types that Transcoding Publisher will filter. This is a rarely used
feature that you would use if you register a new transcoder that processes a new MIME type.

2.  

Web application settings are always stored on the machine with the server; they are not included in
server models.

Refreshing the server
When you make changes through the Administration Console that affect the local server, they will take
effect only after you refresh the transcoding server.

If your server's configuration is stored on the local machine, the server must be refreshed when you make
any of these changes:

Enable or disable a resource●   

Modify a resource●   

Register a new resource●   

Delete a resource●   

Modify firewall, reverse proxy, or proxy port settings●   

Modify Web application settings●   

Change tracing or message logging options●   

Enable or disable tracing or message logging●   

If you modify a server model, changes are made immediately in the central directory. However, in order
to minimize disruptions to active servers, the servers using that server model are not notified of each
change as it is made. When you have finished modifying a server model, click File->Refresh server.
This will cause the RMI Registry server to issue a notification to all the servers using the server model
that you have modified. The servers will re-read the configuration information from the central directory.

You do not need to refresh the server when you reorganize resources by creating new folders or moving
resources or folders.

When you make changes that require that the server be refreshed, Transcoding Publisher will display a
message at the bottom of the Administration Console that says XX changes have been made. Select File
... Refresh Server to make these changes take effect., where XX is the number of changes you have made
since the server was last refreshed. The number is not important; what matters is that you must refresh
the server for your changes to take effect.

When you refresh the server, it must reload configuration information and reinitialize transcoding
functions. During this process, transcoding of documents can be delayed. If you are making several
changes, do not refresh the server after each change; instead, make all your changes and then refresh the
server to implement all your changes.
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To refresh the server, click File->Refresh server. After you do this, you may want to review the
message log to verify that the changes took place. If you close the Administration Console after making
changes that require that the server be refreshed, the server will be refreshed automatically to pick up the
changes that you made. If you close the Administration Console after making changes to a server model,
a notification will be sent to the RMI Registry instructing it to notify the servers that use the modified
server model.

Working with logging and tracing
Message logging and tracing are tools provided as part of Transcoding Publisher to help you recognize
and debug problems. Logging and tracing are described in Troubleshooting Transcoding Publisher.

Importing and exporting configuration data
You can use the Administration Console to import and export XML-based information about your
server's configuration. This enables you to copy information from one server to another, add or modify
large numbers of resources without using the Administration Console, and preserve configuration
information when you migrate to a new version of WTP. You can also back up and restore configuration
information in a non-readable format. The following functions are available:

File->Export: Creates a file containing an XML representation of a set of WTP resources. You
can select which resource types or specific resources to include.

●   

File->Export All: Creates a file containing an XML representation of all the WTP resources
defined for this server or server model, plus the local settings defined for the server.

●   

File->Import: Imports a file containing an XML representation of a set of WTP resources. By
default the XML tagging will be validated as the file is read. You can specify whether to overwrite
WTP's current information.

●   

Settings->Backup: Creates a non-readable file with all the configuration information for the local
server or the open server model. This information includes all WTP resources and settings. You
could use this for regularly scheduled server backups.

●   

Settings->Restore: Restores a server or server model configuration that was created using the
Backup function.

●   

In addition to using these menu options, you can select Export from the pop-up menu on any leaf or root
node in the resource tree to export all the resources under that node. This option applies only to exporting
resources; when you import resources, all the resources in the specified file are imported.

View the Help to see details about how you can tailor each function to meet your needs.

In addition to the import and export functions available through the Administration Console, WTP
provides a command-line interface that offers more specific control of these functions. Refer to the
Developer's Guide for information about the command-line interface.
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Examples of using import and export

If you are comfortable with editing XML property files, you can use these functions to export existing
resources and to re-import them after they have been modified. For example, if you have created a group
of stylesheets that will be applied in similar but not identical situations, you could:

Define one stylesheet through the WTP Administration Console.1.  

Click File->Export to export your stylesheet resources to an XML file.2.  

Use an XML or text editor to make several copies of the stylesheet definition and modify each one
to represent one of your new stylesheets.

3.  

Click File->Import to import your updated stylesheet resources into WTP.4.  

For another example, suppose you have already registered a set of annotators to be applied to a set of
documents on a certain Web server, and the documents are moved to a different domain, or even to a
new directory on the server. You need to make the same change to each URL used to select one of these
annotators. Rather than modifying each annotator in the Administration Console, you could:

Click File->Export to export your annotator resources to an XML file.1.  

Use an XML or text editor to find and replace the necessary strings in the URLs.2.  

Click File->Import to import your updated annotator resources into WTP.3.  

If you have a set of new stylesheets to add to several server models, you could:

Edit the first server model.1.  

Define your new stylesheets using the Administration Console or by using the method described
above. This defines them in this server model.

2.  

Click File->Export to export your stylesheet resources to an XML file.3.  

Edit the next server model.4.  

Click File->Import to import your stylesheet resources into this server model.5.  

Repeat steps 4 and 5 for each server model to which you want to add the stylesheets.6.  

Starting and Stopping Transcoding Publisher
If you have configured Transcoding Publisher as a filter in WebSphere Application Server (WAS), WAS
will control the starting and stopping of Transcoding Publisher. WAS will start Transcoding Publisher
when it is needed to transcode the output of a Web application.

If you have configured Transcoding Publisher as a plugin in WebSphere Edge Server - Caching Proxy,
Caching Proxy will control the starting and stopping of Transcoding Publisher. Transcoding Publisher is
always started when Caching Proxy is started.

If you have configured Transcoding Publisher as a network proxy or reverse proxy, the method for
starting and stopping it depends on the operating system. To stop or start Transcoding Publisher on
Windows NT or Windows 2000, use the Services utility from the Control Panel, or the Start and Stop
entries under IBM Transcoding Publisher in the Windows Start menu. You must be logged on with
Administrator or PowerUser privileges to start the server. On AIX, Sun Solaris, or Linux, use the
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TransPub script to start, stop, or restart Transcoding Publisher.

When the Transcoding Publisher server is started, it reads in all its configuration data. If the server's
configuration is stored on the local machine, this process takes a few seconds. If the server's
configuration is stored in a server model in a centralized database, it might take a few minutes to read the
configuration data. The time will depend on the speed of your central database server and of your
network. To determine when the server is ready to process requests, you can retrieve a page through the
server and see whether it is transcoded. If you prefer, you can look for a message in the message log that
says, "IBM Transcoding Publisher started successfully and is ready to process requests."
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Troubleshooting Transcoding Publisher
Transcoding Publisher sends events to the message and trace logs. Message logging records
informational messages about normal operations as well as warnings and error messages. Tracing
provides more detailed information for troubleshooting problems. Tracing is normally run at the Low
level. Tracing at higher levels is normally used only at the request of a service representative. Messages
are translated into the language specified for your machine. Trace records are not translated.

Normally tracing will be turned on at the Low level and message logging will be turned on. This enables
you to monitor the behavior of Transcoding Publisher without affecting its performance. You can turn
logging and tracing on and off and control the types of messages that are logged.

Message logging

Message categories

Three categories of messages are written to the message log file:

Information: records normal events. Use these messages to determine whether expected
operations occur, for example, to verify that a configuration change takes place as expected.

●   

Warning: indicates a possible problem. Requests might still be handled successfully.●   

Error: indicates a definite problem requiring administrator attention. Requests will probably not
be handled successfully.

●   

The categories are enabled separately; enabling Error messages does not automatically enable
Information or Warning messages. By default, all categories of messages are logged.

Message files

Message files are created in the /log directory. You can specify how many message files can be created
and the maximum size for each message file.

When Transcoding Publisher is running as a proxy, there are two sets of message files, one for the server
and one for the Administration Console. Each set can have up to the number of files you specify, so there
could be twice that many files. For example, if you specify a maximum of four files, there can be up to
four server message files and up to four console message files.

The first server message file created is named TranscoderMessages1.log. When the maximum size is
reached, this file will be renamed to TranscoderMessages.log and a new TranscoderMessages1.log file
created for new messages. TranscoderMessages1.log is always the newest file.

The second set of message files, containing messages from the Administration Console, are called
ConsoleMessages1.log and so on, following the same procedure described above.

When the maximum number of files in a set have been filled, the oldest file will be deleted, the suffix
number of each remaining file will be increased by one, and a new TranscoderMessages1.log will be
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created for new messages. A new file is begun when Transcoding Publisher is restarted.

Controlling message logging

To control message logging, click Logs->Message. You can start or stop message logging by selecting
or clearing the Enabled checkbox.

To view and modify the types of messages that will be logged, click Logs->Message->Properties. This
will invoke the Message Properties dialog box. Use the checkboxes to specify which categories of
messages should be logged. Remember that messages will be logged only if the Enabled checkbox on
the Message sub-menu is checked.

After saving your new options, you must refresh the server to put them into effect.

Viewing messages

To view the messages in the active log file, TranscoderMessages1.log, click Logs->Message->View.
The message viewer does not automatically update the display when new messages are issued; use the
Refresh button to see new messages. You can also open the other message files with your favorite editor.

Tracing
Tracing records the specific behavior of Transcoding Publisher, recording information useful in the
diagnosis of problems. Tracing above the Low level affects the performance of Transcoding Publisher
and is usually performed only at the request of a service representative.

Trace levels

Three levels of trace messages are available.

Low: includes error messages and external API calls.●   

Medium: includes Low messages plus more trace records, but less detail than High; causes
moderate performance degradation.

●   

High: includes Low and Medium messages plus extensive intermediate results of operations;
causes serious performance degradation. Typically used for one or two requests.

●   

Trace files

Trace files are created in the /log directory. You can specify how many trace files can be created and the
maximum size for each trace file.

When Transcoding Publisher is running as a proxy, reverse proxy, or plugin, there are two sets of trace
files, one for the server and one for the Administration Console. Each set can have up to the number of
files you specify, so there could be twice that many files. For example, if you specify a maximum of four
files, there can be up to four server trace files and up to four console trace files.

The first server trace file created is named TranscoderTrace1.log. When the maximum size is reached,
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this file will be renamed to TranscoderTrace2.log and a new TranscoderTrace1.log file created for new
messages. TranscoderTrace1.log is always the newest file.

The second set of trace files, containing messages from the Administration Console, are called
ConsoleTrace1.log and so on, following the same procedure described above.

When the maximum number of files in a set have been filled, the oldest file will be deleted, the suffix
number of each remaining file will be increased by one, and a new TranscoderTrace1.log will be created
for new messages. A new file is begun when Transcoding Publisher is restarted.

When you deploy Transcoding Publisher as a filter in WebSphere Application Server, it is possible to
have more than one instance of Transcoding Publisher running at a time (one for each Web application
whose output is being transcoded). To eliminate trace file conflicts and provide specific information, a
separate set of trace files is created by each instance of Transcoding Publisher. The name of the Web
application is added to the beginning of the name of the log file. For example, if you have a Web
application named MyWebApp, when Transcoding Publisher transcodes its output, it will write trace
records to MyWebAppTranscodingTrace1.log. Each set of server trace files can contain the number of
files you specify. For example, if you specify four trace files, and your server transcodes the output of
three Web applications, you could have up to twelve server trace files. There is still only one set of
Administration Console trace files.

Controlling tracing

When you install Transcoding Publisher, the trace function is turned on at the Low level. This will enable
you to gather information on the installation and configuration processes in case you have any problems.
We recommend that you leave this level of tracing on when you run Transcoding Publisher, so that
information can be gathered about any problem that you encounter. Running tracing at the Low level
does not affect Transcoding Publisher's performance.

To control tracing, click Logs->Trace. You can start or stop tracing by selecting or clearing the Enabled
checkbox.

To view and modify the levels of messages that will be logged, click Logs->Trace->Properties. This
will invoke the Trace Properties dialog box. Select a radio button to specify which levels of trace
messages should be logged. Remember that trace messages will be logged only if the Enabled checkbox
on the Trace sub-menu is checked.

You can also use the Trace Properties dialog box to change the number or the size of trace files.

After saving your new options, you must refresh the server to put them into effect.

Gathering troubleshooting data
If you have a problem while running Transcoding Publisher, there is a certain set of information that will
be useful in troubleshooting. The RASCollect program will package the necessary files and settings to
make it easy to gather diagnostic information. If you need to use this function, click Logs->Collect from
the Administration Console, or execute RASCollect.bat on Windows NT or Windows 2000 or
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RASCollect.sh on AIX, Solaris, or Linux. This will create a zip or tar file that you can send to your
service representative. The file will be created in the Transcoding Publisher log directory. It will be
named RASCollect.zip on Windows NT, Windows 2000, or Linux and RASCollect.tar on AIX or
Solaris.

If your server uses a server model from a central directory, the RASCollect program will copy some
configuration information from the central directory. This might cause the program to take a few minutes
to complete. If your server is running as a filter in WebSphere Application Server (WAS), the
RASCollect program will include information about WAS configuration.

Miscellaneous tips
Click Help->Product Support Site to visit the support portion of the Transcoding Publisher Web page,
which contains an updated list of hints and tips.

If your users see messages saying "unable to find route to server," this means that one of the servers
being used to retrieve data is not responding. Depending on your configuration, this could be the
Transcoding Publisher transcoding server, the cache server, the firewall, or the Web server providing the
desired information.

To check whether Transcoding Publisher is running properly as a network proxy, look for log messages
suggesting problems. Use the method appropriate to your operating system to verify that the transcoding
server is running:

Windows NT or Windows 2000: use the Services utility from the Control Panel to verify that
IBM Transcoding Publisher is running, and start it if it is stopped.

●   

AIX, Sun Solaris, or Linux: use the ps command to list running processes and pipe the results to
the grep command to look for the RunTranscoding process: ps -ef | grep RunTran If
RunTranscoding is not found, use the TransPub restart command to restart Transcoding Publisher.

●   

To check the cache server, configure a browser to use the cache server as a proxy, then use the browser
to view a page on your local machine. If the page is loaded successfully, the cache server is functioning
properly. If the page is not loaded successfully, use the ping command to check the network connection
of the cache server machine. If ping returns data, you will need to investigate the caching process on the
cache server.

To check the firewall server, configure a browser to use the firewall server as a proxy, then use the
browser to view a page on your local machine. If the page is loaded successfully, the firewall server is
functioning properly. If the page is not loaded successfully, use the ping command to check the network
connection of the firewall machine. If ping returns data, you will need to investigate the firewall server
process.

To check the operation of the transcoding server as a WebSphere filter, use the WebSphere Application
Administrative Console. Verify that your Web applications are active and that Transcoding Publisher has
been configured to act as a filter for the types of data that your applications return.

Note for Sun Solaris users: if you see repeated "file not found" errors, the number of files that you can
have open may be too low. Check the value of ulimit -n and increase it.

Troubleshooting
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If you cannot view the documentation on Sun

On the Sun Solaris platform, you may experience a problem when you click Help->Administrator's
Guide. If you have this problem, you can view the Administrator's Guide by opening a browser and
pointing it to the file doc/source/en/index.htm under the Transcoding Publisher install directory.

Change server refresh to avoid Windows CPU problem

On some Windows NT and Windows 2000 systems, the Refresh Server function has been found to cause
the CPU to run at 100%, effectively stopping the system. The Refresh Server function is also
incompatible with some Virtual Private Networks (VPNs). If you experience this CPU problem, or if you
use a VPN, you can disable the Refresh Server function to eliminate the problem.

Before disabling the Refresh Server function, check to be sure that any problem is not the result of a port
conflict. The default port used by the Transcoding Publisher server to listen for refresh messages from
the Administration Console is port 1099. If this port is in use by another program on your machine, the
results are unpredictable.

The port number on which the server listens for refresh messages is specified in the file
etc\localConfig.prop. If you need to change this port number, modify the value of RMIPort. The new port
number must be available for use. Restart the server to begin using the new port.

The enablement of server refreshing is specified in the file etc\localConfig.prop. The variable
EnableRMI governs the enablement of the Refresh Server function. To disable server refresh, set this to:
EnableRMI = false

If you make configuration changes after disabling the Refresh Server function, you must restart the
Transcoding Publisher server to implement the configuration changes.

What happened to the JavaScript?

While most full-function Web browsers such as Netscape and Internet Explorer support JavaScript as a
scripting language, most browsers for handheld and wireless devices do not. This includes Wireless
Access Protocol (WAP) devices and Handheld Device Markup Language (HDML) and i-mode devices,
as well as Personal Digital Assistant (PDA) devices that use Simplified HTML. Many web sites are
written assuming that a JavaScript-enabled browser like Netscape or Internet Explorer will be used.
When users view these Web sites on a handheld device, the JavaScript function is missing.

When WTP transcodes content containing JavaScript for devices that do not support JavaScript, such as
WAP devices, it will discard the JavaScript. Although recent releases of the WAP protocol support a
limited scripting language called WMLScript, this has much less capability than JavaScript and it is not
possible to map from JavaScript to WMLScript. It is also not possible to try to "understand" what the
JavaScript is attempting to do and try to perform equivalent function in WMLScript. Therefore, as stated
above, WTP discards the JavaScript.

Fortunately, in many cases the loss of the JavaScript does not materially affect the ability to use the site
on the handheld device, since often JavaScript is used to improve the user interface (for example, to
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display information when the mouse is moved over some object), but does not in itself provide critical
function or information. Also, many sites that contain JavaScript are purposely written in such a way that
they can function in an environment that does not support JavaScript.

Concurrent requests and memory usage

Transcoding Publisher limits the number of concurrently active requests, in order to limit memory
requirements under heavy load conditions. While the configured value should be appropriate for most
conditions, administrators may wish to adjust the number used in some circumstances. Decreasing the
number can help overall system performance and reduce potential out-of-memory conditions in a
low-memory configuration. Conversely, the responsiveness of Transcoding Publisher may be improved
by increasing the number if you have a lot of traffic and adequate memory.

The maximum number of concurrent requests is specified in the file etc\localConfig.prop. Adjust the
value of MaxConcurrentRequests as needed. We recommend that you use a value of at least 10 and no
more than 150. It may also be necessary to increase the swap space available to the system when these
adjustments are made, particularly if out-of-memory conditions occur or persist.

Character sets on i-mode devices

The preference profiles for i-mode phones specify a default character set of Shift-JIS, the most common
character set used in Japan. If you view a document, especially a non-Japanese document, on an i-mode
device and see question marks and other stray characters in the links on the page, the document might be
using a different character set. If you see this problem you can try modifying the device profile in use to
set defaultCharset=iso-8859-1. This will cause WTP to default the character set to standard US ASCII.
Making this change will cause WTP to be unable to process documents that use the Shift-JIS character
set, unless they specify the character set in the file.

Problems with cookies when deployed as a reverse proxy

Some sites use Set-Cookie HTTP objects specifying a domain for one or more responses. A Set-Cookie
object in the HTTP response header tells the browser to store a cookie with the given set of information.
Cookies are often used to allow a web server application to recognize that a request from a given user is
from the same user as one or more earlier requests. One of the fields in a Set-Cookie, and thus in the
corresponding cookie stored with the browser, can be the domain field, which is optional. If specified,
the domain field specifies the server with which the cookie is to be associated. For example, if the
domain is specified as ".ibm.com", any addresses ending in ".ibm.com" would be associated with that
cookie. This means that the browser should send the cookie on any requests made by the browser to
addresses ending in ".ibm.com".

When Transcoding Publisher is set up to operate as a Reverse Proxy, all requests go through Transcoding
Publisher. This means that all requests made by the browser actually go to Transcoding Publisher, and
Transcoding Publisher makes the requests to the actual destination, such as www.ibm.com. In a Reverse
Proxy environment, therefore, if a Set-Cookie specifies a domain like ".ibm.com", the browser will never
put the cookie in the request because as far as it is concerned, the request is being made to Transcoding
Publisher, not some address ending in ".ibm.com".

Troubleshooting
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One way to solve this problem is to change the domain in Set-Cookie objects to specify the Transcoding
Publisher address. When this is done, since the Set-Cookie object specifies the Transcoding Publisher
address and since the browser is making requests to the Transcoding Publisher address, the browser
inserts the cookie into the request. The Reverse Proxy Cookie Transcoder, when enabled, intercepts
Set-Cookie objects and modifies the domain, if present, before it is received by the browser.

In order to make Set-Cookie objects specifying domains to work at all, this Transcoder changes the
domain fields to specify the Transcoding Publisher address. Because all requests go through Transcoding
Publisher, this means that all cookies can be put on every request, even if their final destinations differ.
For example, if one Set-Cookie object specified a domain of ".ibm.com" and another specified
".apache.org", the browser (because this Transcoder changed the domain address), would put both
cookies on each request, regardless of the final destination. If the user visits many sites which generate
cookies, this could become problematic as more and more different cookies are added to each request.
So, while this Transcoder provides an approach to deal with sites that rely on using cookies, the way in
which it addresses the issue may cause problems, such as HTTP request headers having too many
cookies. If you believe the number of cookies being put in requests is causing a problem, please contact
IBM Support for possible solutions or workarounds.

How to Know if You Need This Transcoder

It is not a trivial process to determine if you need to enable this Transcoder, because you need to
determine if a problem that is occurring is due to the lack of cookies. First of all, this Transcoder is only
applicable to running as a Reverse Proxy. If you are running as a Reverse Proxy and encounter a
problem, you can use the Request Viewer to monitor the flow of a request through the Transcoding
Publisher. First select the Request Processing tab. Then make the request to the site causing the
problem. Expand each request that is made, and look at the Default Generator output (expand it and you
should see Meg Input and Meg Output). Look in the Transaction Header View (the top window on
the right). If you see a Set-Cookie object included there, check to see if it specifies a domain (you will
see "domain=..."). If it does, then you should enable the Reverse Proxy Cookie Transcoder to see if it
solves your problem.

Log files used by WAS and Edge Server Caching Proxy

If you have deployed WTP as a filter or as a plugin, there might be messages recorded to log files owned
by WebSphere Application Server or WebSphere Edge Server Caching Proxy. If you have trouble with
WTP in either of these deployment models, you can consult the following log files:

If your deployment model
is...     Look at these log files.     

WebSphere Application
Server filter

In WebSphere/AppServer/logs, look for files called
XXX_stdout.log, where XXX is a prefix made up from the
application server and web applications being run.

Troubleshooting
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Edge Server Caching Proxy
plugin

In the Logs directory under the Caching Proxy install directory,
problems with starting plugins will be written to stderr.date. Look
for a file whose date matches the date when the problem occurred.

Troubleshooting
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Edition notice
Third Edition (August 2001)

This edition applies to Version 4 of IBM WebSphere Transcoding Publisher and to all subsequent
releases and modifications until otherwise indicated in new editions.

(C) Copyright International Business Machines Corporation 2001. All rights reserved. Note to U.S.
Government Users Restricted Rights -- Use, duplication or disclosure restricted by GSA ADP Schedule
Contract with IBM Corp.

Notices
This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that
only that IBM product, program, or service may be used. Any functionally equivalent product, program,
or service that does not infringe any IBM intellectual property right may be used instead. However, it is
the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or
service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not give you any license to these patents. You can send
license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
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MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore, this statement may not
apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not
in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part
of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:
IBM Corporation
Department TL3B/062
P.O. Box 12195
Research Triangle Park, NC 27709-2195
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided
by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or
any equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrates
programming techniques on various operating platforms. You may copy, modify, and distribute these
sample programs in any form without payment to IBM, for the purposes of developing, using, marketing
or distributing application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples have not been thoroughly
tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or
function of these programs. You may copy, modify, and distribute these sample programs in any form
without payment to IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM's application programming interfaces.
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Trademarks
IBM, SecureWay, WebSphere, Everyplace, and WorkPad are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other
countries, or both.

Pentium is a registered trademark of Intel Corporation in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in
the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of others.
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