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Before you begin

Conventions used in this book

This book uses the following highlighting conventions:

Boldface type indicates commands or graphical user interface (GUI) controls such
as names of fields, buttons, or menu choices.

Monospaced type indicates examples of text you enter exactly as shown. It is also
used for directory paths and file names.

Italic type is used for emphasis and variables for which you substitute your own
values.

This icon marks a Tip — additional information that can help you
complete a task.

Where to find more information

For information related to WebSphere® Commerce, refer to the following Web sites:
* For Business Edition:

http://www.ibm.com/software/webservers/commerce/wc_be/
1it-tech-general.html

e For Professional Edition:

http://www.ibm.com/software/webservers/commerce/wc_pe/
lit-tech-general.html

For information related to WebSphere Commerce Studio, refer to the following
Web site:

http://www.ibm.com/software/webservers/commerce/commercestudio/
lit-tech-general.html

© Copyright IBM Corp. 2002, 2005 \%
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Chapter 1. Introduction

Reasons to transition to the WC_5407.dat code repository

When you originally set up your development environment, you probably
performed the following steps:

1. On the development machine, installed WebSphere Commerce Studio and
selected to create back-office business logic. This installs VisualAge® for Java'".

2. Configured the WebSphere Test Environment in VisualAge for Java. As part of
the configuration steps, you imported the WC_54.dat, WC_5401.dat, WC_5402.dat,
WC_5403.dat, WC_5404.dat, WC_5405.dat or WC_5406.dat file. You then
successfully ran your store within the WebSphere Test Environment.

3. Separately installed WebSphere Commerce 5.4.0.7. This acts as the target
WebSphere Commerce Server to which customized code can be deployed.

Equivalency between the code contained in VisualAge for Java and the WebSphere
Commerce Server to which you deploy customized code is required. If the code
contained in the VisualAge for Java workspace is an earlier version than
WebSphere Commerce Server to which you deploy code, it is possible to bring
some features and functions in the target machine back to the earlier level by
deploying customized code. This is not a desired outcome. As a result you should
only upgrade the level of code in your VisualAge for Java workspace to the
WebSphere Commerce 5.4.0.7 level if you are deploying your code to a target
WebSphere Commerce server that is already at the WebSphere Commerce 5.4.0.7
level.

After you have applied WebSphere Commerce 5.4.0.7 to your target WebSphere
Commerce Server, the code in the WebSphere Commerce Server has been upgraded
to the WebSphere Commerce 5.4.0.7 level. The corresponding WebSphere
Commerce code repository to be used within VisualAge for Java is the WC_5407.dat
repository. Since applying WebSphere Commerce 5.4.0.7 to your development
machine does not automatically upgrade the level of code within VisualAge for
Java, you must follow the instructions contained in this document to do so.

Transitioning to the WC_5407.dat repository within VisualAge for Java will enable
you to create customized code that can be deployed to WebSphere Commerce
Servers running at the WebSphere Commerce 5.4.0.7 level.

Pre-requisites
Before you complete the steps outlined in this document, you should have
completed the following tasks:

1. The WebSphere Commerce fix pack 5.4.0.7 needs to be installed on your
development machine. For more information on how to accomplish this, refer
to the IBM® WebSphere Commerce Fix Pack Version 5.4.0.7 Installation Guide.

2. Ensure that your target WebSphere Commerce server to which you will deploy
customized code is also at the WebSphere Commerce 5.4.0.7 level.

© Copyright IBM Corp. 2002, 2005 1



Transitioning scenarios

The steps to upgrade the repository of code are different, depending upon whether
or not you have started to create customized code using the WC_54.dat,
WC_5401.dat, WC_5402.dat, WC_5403.dat, WC_5404.dat, WC_5405.dat or WC_5406.dat
code repository. This document describes the following scenarios:

 If you have imported the WC_54.dat, WC_5401.dat, WC_5402.dat, WC_5403.dat,
WC_5404.dat, WC_5405.dat or WC_5406.dat code repository but not created any
customized code that you want to transition to the new repository, perform the
steps outlined in [Chapter 3, “Upgrading your repository without transitioning]
[customized code,” on page 5|

 If you have imported the WC_54.dat, WC_5401.dat, WC_5402.dat, WC_5403.dat,
WC_5404.dat, WC_5405.dat or WC_5406.dat code repository and have created

customized code, perform the steps outlined in |[Chapter 4, “Upgrading your]
[repository and transitioning customized code,” on page 7|
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Chapter 2. Preparing your development machine

Backing up WebSphere Commerce Studio assets

Back up the following WebSphere Commerce Studio assets:

* VisualAge for Java assets

e Studio assets

Preparing VisualAge for Java

If your workspace contains any customized code, you must prepare your
VisualAge for Java environment before upgrading to the new WebSphere
Commerce repository. To prepare your environment, complete the following steps:

_ 1.

© Copyright IBM Corp. 2002, 2005

Perform the following steps to back up your user data. Create backup copies
of your repository and resource files in case problems occur during the
transition.

__a. Save your workspace repository file (ivj.dat) as well as the IDE
workspace file ide.icx to a new location outside your VisualAge for
Java directory tree.
The path of the workspace repository file, ivj.dat, is
drive:\VAJava\ide\repository. The path for the IDE workspace file,
ide.icx, is drive:\IBM\VAJava\ide\program. In the above path names,
drive:\VAJava is the VisualAge for Java installation directory.

Start VisualAge for Java.

Ensure that the workspace owner is set to WC Developer, by doing the

following:

a. From the Workspace menu, select Change Workspace Owner.

b. Select WC Developer and click OK.

If you have created any of the following types of code, you must version the

projects containing that code:

* Your own commands and data beans

+ Extensions to WebSphere Commerce commands and data beans

* Your own entity beans

Examples of such projects are MyProject, _WCSamples, and
_WCSamples EntityBeans.

Creating a version of the project creates a snapshot of your code in its
current state. In the future, if you need to revert to this state, you can
replace the project in your workspace with code that you have explicitly
versioned. For more information about switching between versions of code,
refer to the VisualAge for Java documentation.

Version all of your code that is packaged separately from the WebSphere
Commerce projects and remove these projects from the workspace, by doing
the following:

a. Click the Projects tab.

b. Right-click your project(s) (for example, MyProject, _WCSamples, or
_WCSamplesEntityBeans), and select Manage > Version.
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If the Version option is not available, you must create an open edition for
your project and its contents before versioning.

Select the One Name radio button and enter an appropriate name for
your version. For example, enter Transition_new_logic. Click OK.

Right-click your project(s) and select Delete. Confirm your selection
when prompted.

. If you have modified any of the WebSphere Commerce public entity beans,

version the IBM WC Enterprise Beans project, by doing the following;:

a.
b.

e.
. Remove the IBM WC Commerce Server and IBM WC Enterprise Beans projects

Expand the IBM WC Enterprise Beans project.

For any package that is marked as a scratch edition, right-click the
package and select Manage > Create Open Edition.

Right-click the IBM WC Enterprise Beans project and select Manage >
Create Open Edition.

Right-click the IBM WC Enterprise Beans project and select Manage >
Version.

Select One Name, enter Transition EJB and click OK.

from the workspace, by doing the following:

a.

b.

Select both the IBM WC Commerce Server and IBM WC Enterprise
Beans projects.

With both projects highlighted, right-click and select Delete. Click Yes to
confirm the delete. Note, do not purge the projects from the workbench.

. Remove the original EJB server configuration, by doing the following:
a.
b.

Click the EJB tab.

From the EJB menu, select Open To > Server Configuration.
The EJB Server Configuration window opens.

Right-click the EJB server that you have configured for the WebSphere
Commerce entity bean groups (for example,EJB Server (server 1)) and
select Remove Server.

. Save your workspace by clicking File > Save Workspace.



Chapter 3. Upgrading your repository without transitioning
customized code

This section describes how to upgrade the level of WebSphere Commerce code
within your VisualAge for Java workspace if you have not started to create
customized code using the WC_54.dat, WC_5401.dat, WC_5402.dat, WC_5403.dat,
WC_5404.dat, WC_5405.dat or WC_5406.dat code repository.

Extracting the code repository

Before upgrading to the WC_5407.dat code repository, you need to extract it to your
WebSphere Commerce Studio, Version 5.4 machine. You are required to have at
least 200 MB of disk space on one of your drives for the repository to extract
successfully. To extract the code repository to your WebSphere Commerce Studio
machine, do the following:

1. Download the WebSphere Commerce repository from the following Web site:
http://www.ibm.com/software/webservers/commerce/support.html

Upgrading the code repository

To upgrade to the WC_5407.dat repository, do the following:
1. Start VisualAge for Java.
2. Import the WC_5407.dat file by doing the following:

a. From the File menu, select Import.
The Import SmartGuide opens.

b. Select the Repository radio button and click Next.

C. Select the Local repository radio button, then in the Repository name field,
enter the fully qualified name of the WC_5407.dat code repository on your
machine. For example, drive:\repository\WC_5407.dat

d. Select the Projects radio button and click Details.

The Project import window opens.

e. Select the IBM WC Commerce Server project and select the available

version.

f. Select the IBM WC Enterprise Beans project and select the available version.
Click OK.

g. Ensure that the Add most recent project edition to workspace check box is
selected.

h. Click Finish.
Importing the code takes several minutes.

3. When the import is complete, ensure that your workspace owner is set to WC
Developer, by doing the following;:

a. From the Workspace menu, select Change Workspace Owner.
b. Select WC Developer and click OK.

4. Configure an EJB server for the WebSphere Commerce entity beans, by doing
the following:

a. Click the EJB tab.

b. Highlight all of the WebSphere Commerce EJB groups (the names begin
with WC).

© Copyright IBM Corp. 2002, 2005 5
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c. With all of the WebSphere Commerce EJB groups highlighted, right-click
and select Add To > Server Configuration.
The EJB Server Configuration window opens.

d. Right-click your new E]B server, for example, EJB Server (server 1), and

select Properties.

e. Set the properties for the server as follows, and click OK.

Table 1. EJB server properties

Property

DB2® value (enter exactly as
shown)

Oracle® value (enter exactly
as shown)

Data Source

WebSphere Commerce DB2
DataSource instance_name

WebSphere Commerce Oracle
DataSource instance_name

Connection Type

<DataSource>

<DataSource>

Database User Id

database_user

database_user

Database Password

database_user_password

database_user_password

5. Modify the class path for the servlet engine component of the WebSphere Test
Environment, by doing the following:

a. From the Workspace menu, select Tools > WebSphere Test Environment.
The WebSphere Test Environment Control Center opens.

b. In the Servers pane, click Servlet Engine.

C. In the Servlet Engine pane, click Edit Class Path.

d. Click Select All » OK.

6. Start the WebSphere Test Environment, as described in the WebSphere Commerce
Suite 5.4 Programmer’s Guide.

7. If you had previously configured a store to run in the WebSphere Test
Environment, launch your sample store to ensure the WebSphere Test
Environment is configured properly.

8. Save your workspace by clicking File > Save Workspace.

Note that you are not required to drop and recreate the PNS database.

The WebSphere Commerce code repository is now upgraded and you can use it to
create customized code for your WebSphere Commerce application. Refer to the
WebSphere Commerce Suite 5.4 Programmer’s Guide for further details.

Note: When starting the WebSphere Test Environment, ensure that the Commerce
projects are included in the class path for the servlet engine in the
WebSphere Test Environment. Information about setting up the servlet
engine is included in the WebSphere Commerce Studio 5.4 Installation Guide,
which is available on the following Web site:

http://www.ibm.com/software/webservers/commerce/commercestudio/

1it-tech-general.html




Chapter 4. Upgrading your repository and transitioning
customized code

This section describes how to upgrade the level of WebSphere Commerce code
within your VisualAge for Java workspace when you used the WC_54.dat,
WC_5401.dat, WC_5402.dat, WC_5403.dat, WC_5404.dat, WC_5405.dat or WC_5406.dat
repository to create customized code. This scenario covers how to transition
customized code that is packaged separately from the WebSphere Commerce
projects as well as how to transition modifications to existing WebSphere
Commerce public entity beans.

The type of customized code that is packaged separately from the WebSphere
Commerce projects (IBM WC Commerce Server and IBM WC Enterprise Beans
projects) includes:

* New commands
* New data beans
* New entity beans

* Extensions to existing commands and data beans created by subclassifying the
existing classes. These new classes must be packaged in your own project, for
example MyProject or _WCSamples.

Modifications to existing WebSphere Commerce public entity beans are packaged
in the IBM WC Enterprise Beans project.

Extracting the code repository

Before upgrading to the WC_5407.dat code repository, you need to extract it to your
WebSphere Commerce Studio, Version 5.4 machine. You are required to have at
least 200 MB of disk space on one of your drives for the repository to extract
successfully. To extract the code repository to your WebSphere Commerce Studio
machine, do the following:

1. Download the WebSphere Commerce repository from the following Web site:
http://www.ibm.com/software/webservers/commerce/support.html

Transitioning customized code

This section provides the details on how to transition your customized code to the
WebSphere Commerce 5.4.0.7 level.

To transition your code, do the following:
1. Start VisualAge for Java.
2. Import the WC_5407.dat file by doing the following:

a. From the File menu, select Import.
The Import SmartGuide opens.

b. Select the Repository radio button and click Next.

C. Select the Local repository radio button, then in the Repository name
field, enter the fully qualified name of the WC_5407.dat code repository. For
example:
drive:\repository\WC 5407.dat

© Copyright IBM Corp. 2002, 2005 7
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d. Select the Projects radio button and click Details.
The Project import window opens.

e. Select the IBM WC Commerce Server project and select the available
version.

f. Select the IBM WC Enterprise Beans project and select the available
version. Click OK.

g. Ensure that the Add most recent project edition to workspace check box
is selected.

h. Click Finish.
Importing the code takes several minutes.

. When the import is complete, ensure that your workspace owner is set to WC

Developer, by doing the following:
a. From the Workspace menu, select Change Workspace Owner.
b. Select WC Developer and click OK.

. Import all of your projects that were removed in step by doing

the following:
a. Click the Projects tab.

b. From the Selected menu, select Add > Project.
The Add Project SmartGuide opens.

C. Select Add projects from the repository.

d. From the Available project names list, select your projects. For example,
select _'WCSamples or _WCSamplesEntityBeans. From the Available
editions list, select the appropriate version of the project.

e. Click Finish.

. If you have modified any of the WebSphere Commerce entity beans, do the

following to merge your customized code back into the workspace:

a. Expand the IBM WC Enterprise Beans project.

b. For each of the packages where you created an open edition in step
plus any package that was already an open edition before that
step, right-click the package and select Compare With > Another Edition.
Select the version name used in step |5 as the edition to compare it with
and click OK.

For example, compare the new version of the
com. ibm.commerce.user.objects package with the Transition EJB version.

c. When differences are found between the two versions of code, a window
opens displaying the exact differences.

d. Right-click a displayed class and select Load Right or Load Left, as
appropriate, to merge the customized code into the workspace.

e. Merge the metadata within VisualAge for Java, in the following three
places:

1) The CMP field list.
2) The Schema browser.
3) The Map browser.

f. Repeat the compare and merge steps, until you have merged all
customized code into the IBM WC Enterprise Beans project.

. Configure an E]JB server for the WebSphere Commerce entity beans and your

own entity beans, by doing the following:
a. Click the EJB tab.



b. Highlight all of the WebSphere Commerce EJB groups (the names begin
with WC) as well as your own EJB groups.

c. With all of the WebSphere Commerce and your own EJB groups
highlighted, right-click and select Add To > Server Configuration.
The EJB Server Configuration window opens.

d. Right-click your new EJ]B server, for example, EJB Server (server 1), and

select Properties.

e. Set the properties for the server as follows, and click OK.

Table 2. EJB server properties

Property

DB2 value (enter exactly as
shown)

Oracle value (enter exactly
as shown)

Data Source

WebSphere Commerce DB2
DataSource instance_name

WebSphere Commerce Oracle
DataSource instance_name

Connection Type

<DataSource>

<DataSource>

Database User Id

database_user

database_user

Database Password

database_user_password

database_user_password

7. Regenerate the deployed code and access beans for your own enterprise
beans, by doing the following:

a. Click the EJB tab.

b. Expand your EJB group. For example, expand the
_WCSamplesEntityBeans EJB group.

c. Right-click your enterprise bean (for example, Bonus) and select Generate

Deployed Code.

d. Right-click your enterprise bean again and select Add > Access Bean. The

Create Access Bean SmartGuide opens. It should contain the values that
you used when originally creating the access bean for your enterprise
bean. Accept the values and create the access bean.

e. Repeat steps|/qand |7d|for all of your enterprise beans.

8. Regenerate the deployed code and access beans for the modified WebSphere
Commerce public entity beans, by doing the following:

a. Click the EJB tab.

b. Expand the E]JB group that contains the modified WebSphere Commerce
public entity bean. For example, expand the WCUser E]JB group.

c. Right-click your enterprise bean (for example, User) and select Generate

Deployed Code.

d. Right-click the enterprise bean again and select Add > Access Bean. The
Create Access Bean SmartGuide opens. Accept the values and create the

access bean.

e. Repeat steps [8c|and [8d| for all modified WebSphere Commerce public

entity beans.

9. Modify the class path for the servlet engine component of the WebSphere Test
Environment, by doing the following;:

a. From the Workspace menu, select Tools > WebSphere Test Environment.

The WebSphere Test Environment Control Center opens.

b. In the Servers pane,

click Servlet Engine.

. In the Servlet Engine pane, click Edit Class Path.
d. Click Select All » OK.

Chapter 4. Upgrading your repository and transitioning customized code
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10. Start the WebSphere Test Environment, as described in Appendix A of the
WebSphere Commerce Suite 5.4 Programmer’s Guide.

11. Test your customized code using the WebSphere Test Environment.
12. Save your VisualAge for Java workspace (Click File > Save Workspace).

Redeployment of customized code

After you have completed testing your customized code within the WebSphere Test
Environment, you must redeploy the code to your store running on the target
WebSphere Commerce Server. For deployment details, refer to the WebSphere
Commerce Suite 5.4 Programmer’s Guide.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

Any reference to an IBM licensed program in this publication is not intended to
state or imply that only IBM’s licensed program may be used. Any functionally
equivalent product, program, or service that does not infringe any of IBM’s
intellectual property rights may be used instead of the IBM product, program, or
service. Evaluation and verification of operation in conjunction with other
products, except those expressly designated by IBM, is the user’s responsibility.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Canada Ltd.

Office of the Lab Director
8200 Warden Avenue
Markham, Ontario

L6G 1C7

Canada

Such information may be available, subject to appropriate terms and conditions,
including in some cases payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
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names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

Credit card images, trademarks and trade names provided in this product should
be used only by merchants authorized by the credit card mark’s owner to accept
payment via that credit card.

Trademarks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States, other countries, or both:

DB2 IBM VisualAge
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks or
registered trademarks of Microsoft Corporation in the United States, other
countries, or both.

Oracle is a registered trademark of Oracle Corporation in the United States, other
countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Other company, product or service names may be the trademarks or service marks
of others.
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