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Tutorials

The IBM® ILOG® Gantt for .NET tutorials provide step-by-step introductions to the 
fundamental areas of programming for the IBM ILOG Gantt for .NET framework. Each 
tutorial provides a detailed walkthrough of the steps required to write, build and run small 
sample applications.

In This Section

Creating a Windows Forms Gantt Application

Walks you through the process of creating a simple Gantt application using 
Windows® Forms.

Creating a Web Forms Gantt Application

Walks you through the process of creating a simple Gantt application using Web 
Forms.

Synchronizing a Schedule Chart with a Load Chart (Windows Forms Tutorial)

Walks you through the process of synchronizing a Schedule chart with a Load chart.

Creating a Custom Gantt Representation (Windows Forms Tutorial)

Walks you through the process of creating a custom Gantt chart representation made 
of an activity table and two scroll activity sheets.

Related Sections

Getting Started
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Provides a hands-on introduction and overview to the IBM ILOG Gantt for .NET 
framework.
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Creating a Windows Forms Gantt
Application

In this tutorial you will learn how to create a simple Windows® Forms Gantt application.

See Also Creating the Gantt Chart | Associating the Gantt Data Model With the Gantt Chart | Filling 
the Gantt Chart With XML Data

Creating the Gantt Chart

The Gantt chart is one of the controls that IBM® ILOG® Gantt for .NET provides to display 
scheduling information. The Gantt chart is divided in three parts: 

◆ A table view, an instance of GanttTable, which displays activity information from the 
data model.

◆ A Gantt Sheet (an instance of the class GanttSheet) which displays how activities are 
positioned on the time scale.

◆ A zoomable time scale, which is an instance of the class TimeScale. 

A standard, adjustable splitter separates the left part from the right part.

To create the Gantt application, proceed as follows:
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 1
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1. Create a project of type Windows® Forms.

On the File menu, click New, and then click Project.

The New Project window appears.

2. In the left window, click Visual C# > Windows.

3. In the right window, click Windows Application.

4. Name the project GanttApplication.

5. Place the project in C:\Gantt.

Visual Studio®.NET creates a form named Form1 and stores it by default in the file 
Form1.cs.
2 I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S
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6. Resize the window.

From the menu bar, select View > Properties Window and from the Properties explorer 
choose Layout > Size. Expand the property and enter the following values:

Width: 800

Height: 600
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 3
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7. From the IBM ILOG Gantt for .NET toolbox select the GanttChart object and drag it to 
Form1.
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8. Change the Dock property to make the Gantt chart occupy the entire form.

Click the Gantt chart in Form1and from the Properties explorer choose Layout > Dock. 
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Clicking the arrow next to the Dock property shows the following control:

9. Select the area corresponding to the Fill option.

Fill
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Form1 now looks like this:

10. Rename the Gantt chart.

Click the Gantt chart in Form1. From the Properties explorer choose Design > Name 
and enter the new name: myGanttChart.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 7
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The appearance of the Gantt chart can be completely customized to fit your needs.

11. Define a style for the Gantt chart you have just created.

You can either right-click the Gantt chart in Form1 and select AutoFormat in the 
contextual menu, or click AutoFormat at the bottom of the Properties explorer.
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The Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
Gantt chart.

12. Save the file Form1.cs.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 9
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Associating the Gantt Data Model With the Gantt Chart

The Gantt data model contains the scheduling information you want to display in the chart. 
In the following steps, you will learn how to bind a simple Gantt data model to the Gantt 
chart.

1. From the IBM® ILOG® Gantt for .NET toolbox select the SimpleGanttModel object 
and drag it to Form1.

2. Rename the simple Gantt model. 

Click the SimpleGanttModel1 object in Form1. From the Properties explorer choose 
Design > Name and enter the new name: mySimpleGanttModel.

3. Associate mySimpleGanttModel with myGanttChart.

Click the Gantt chart in Form1 and from the Properties explorer select 
Data > GanttModel.

Click the arrow of the drop-down list next to the GanttModel property and choose 
mySimpleGanttModel.
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Filling the Gantt Chart With XML Data

IBM® ILOG® Gantt for .NET allows you to serialize and deserialize scheduling data to and 
from Scheduling Data Exchange Language (SDXL) files. This is accomplished through the 
GanttModelXmlSerializer class.

To deserialize scheduling data from SDXL files and use this information to fill the Gantt 
chart, perform the following steps.

1. From the IBM ILOG Gantt for .NET toolbox select the GanttModelXmlSerializer 
object and drag it to Form1.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 11
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2. Rename the Gantt model XML serializer.

Click the object ganttModelXmlSerializer1 in Form1. From the Properties explorer 
choose Design > Name and enter the new name: myGanttModelXmlSerializer.

3. Click mySimpleGanttModel. 

You will notice that a new property named FileName on myGanttModelXmlSerializer 
has been created.
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4. Select the property FileName on myGanttModelXmlSerializer and click the three-dots 
button next to it. Choose an SDXL file to fill the Gantt chart.

Note: Examples of SDXL files can be found in <install-dir>\Data.
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Data contained in the SDXL file are displayed in the Gantt chart.

5. Save the file Form1.cs.

6. Run the application using the command Debug > Start. 

The Gantt application named Form1 should appear as follows:
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Creating a Web Forms Gantt Application

In this tutorial you will learn how to create a simple Web Forms Gantt application.

See Also Creating the Gantt Chart | Associating the Gantt Data Model With the Gantt Chart | Filling 
the Gantt Chart With XML Data | Adding Controls to Interact with the Gantt Chart | Adding 
Controls to Modify the Gantt Data Model | Saving Modifications Across Requests

Creating the Gantt Chart

The Gantt chart is one of the controls that IBM® ILOG® Gantt for .NET provides to display 
scheduling data. The Gantt chart is divided in three parts:

◆ A table view, an instance of GanttTable, that displays activity information from the data 
model.

◆ A Gantt Sheet (an instance of GanttSheet) that displays how activities are positioned on 
the time scale.

◆ A zoomable time scale (an instance of TimeScale).

A standard, adjustable splitter separates the left part from the right part.

To create the Gantt application, proceed as follows:

1. Create a project of type ASP.NET Web Application.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 15
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On the File menu, click New, and then click WebSite.

The New Project window appears.

2. Select ASP.NET Web Site.

3. Click in the location text box.

4. Name the project C:\WebGanttApplication.

5. Click the OK button.

Visual Studio®.NET creates a empty form and stores it by default in the file 
Default.aspx.
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6. From the IBM ILOG Gantt for .NET toolbox tab select the GanttChart object and drag 
it to the web form.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 17



tutgnt.book  Page 18  Monday, July 20, 2009  2:58 PM
7. Rename the Gantt chart.

Select the Gantt chart in the web form. From the Properties explorer choose Misc > ID 
and enter the new name: MyGanttChart.
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8. Resize the Gantt chart to make it larger.

9. Define a style for the Gantt chart you have just created.

You can either right-click the Gantt chart in Default and select AutoFormat in the 
contextual menu, or click AutoFormat at the bottom of the Properties explorer. The 
Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
Gantt chart.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 19
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10. Save the file Default.aspx.

Associating the Gantt Data Model With the Gantt Chart

The Gantt data model contains the scheduling data you want to display in the chart. In the 
following steps, you will learn how to bind a simple Gantt data model to the Gantt chart.

1. Open the Default.aspx.cs file and adds the following variable declarations:

2. Override the OnInit method to create the Gantt model:

3. Override the OnLoad method to set the Gantt model of the Gantt chart:

Filling the Gantt Chart With XML Data

IBM® ILOG® Gantt for .NET allows you to serialize and deserialize scheduling data to and 
from Scheduling Data Exchange Language (SDXL) files. This is accomplished through the 
GanttModelXmlSerializer class.

To deserialize scheduling data from SDXL files and use this information to fill the Gantt 
chart, perform the following steps.

1. Open the Default.aspx.cs file and adds the following variable declaration:

2. Modify the OnInit method to create the serializer:

private ILOG.Views.Gantt.Data.SimpleGanttModel ganttModel;

protected override void OnInit(EventArgs e)
{
    ganttModel = new ILOG.Views.Gantt.Data.SimpleGanttModel;
    base.OnInit(e);
}

protected override void OnLoad(EventArgs e)
{
    MyGanttChart.GanttModel = ganttModel;
    base.OnLoad(e);
}

private ILOG.Views.Gantt.Data.GanttModelXmlSerializer ganttSerializer;
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3. Modify the OnLoad method to load a SDXL file into the Gantt model:

filename should be replaced by the location of a SDXL file.

4. Save all the files.

5. Run the application using the command Debug > Start.

The Gantt application named WebGanttApplication should appear as follows:

protected override void OnInit(EventArgs e)
{
    ganttModel = new ILOG.Views.Gantt.Data.SimpleGanttModel;
    ganttSerializer = new ILOG.Views.Gantt.Data.GanttModelXmlSerializer();
    base.OnInit(e);
}

protected override void OnLoad(EventArgs e)
{
    MyGanttChart.GanttModel = ganttModel;
    ganttSerializer.SetFileName(ganttModel, filename);
    base.OnLoad(e);
}

Note: Examples of SDXL files can be found in <install-dir>\Data.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 21
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Use the scroll bars of the Gantt to navigate in the time line. You can also select rows, or 
collapse and expand rows by clicking the expand/collapse button of parent rows.

Adding Controls to Interact with the Gantt Chart

This section describes how to add some standard Web Forms controls to interact with the 
Gantt Chart.

In particular, we’ll see how to change the zoom level of the Gantt Chart using buttons.

1. Select a button from the Web Form toolbox tab and drag it onto the web form.

2. From the Properties explorer choose Appearance > Text and enter the new text: Zoom 
In.

3. Double-click the button to add an event handler. This opens the source code editor. Add 
a call to the ZoomIn method of the GanttChart into the button event handler:

private void Button1_Click(object sender, System.EventArgs e)
{
    MyGanttChart.ZoomIn();
}

Select the Default.aspx tab to switch back to design view.

1. Select another button from the Web Form toolbox tab and drag it onto the web form.

2. From the Properties explorer choose Appearance > Text and enter the new text: Zoom 
Out.

3. Double-click the button to add an event handler. This opens the source code editor. Add 
a call to the ZoomOut method of the GanttChart into the button event handler:

private void Button2_Click(object sender, System.EventArgs e)
{
    MyGanttChart.ZoomOut();
}

Select the Default.aspx tab to switch back to design view.

4. Save the file Default.aspx.

5. Run the application using the command Debug > Start.

Use the scroll bars of the Gantt Chart and the Zoom In and Zoom Out buttons to 
navigate in the time line.
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Adding Controls to Modify the Gantt Data Model

This section describes how to add some standard Web Forms controls to modify the Gantt 
Data Model loaded by the Gantt Chart.

In particular, we’ll see how to add an activity to the Gantt Data Model.

1. Select a button from the Web Form toolbox tab and drag it onto the web form.

2. From the Properties explorer choose Appearance > Text and enter the new text: New 
Activity.

3. Double-click the button to add an event handler. This opens the source code editor. Add 
the following code into the button event handler:

private void Button3_Click(object sender, System.EventArgs e)
{
    int index = MyGanttChart.NewActivity(
        null,
        “New Activity”,
        MyGanttChart.VisibleTimeInterval);
    if (index != -1)
        MyGanttChart.EnsureRowVisible(index);
}

Select the Default.aspx tab to switch back to design view.

4. Run the application using the command Debug > Start.

Click the New Activity button and notice the new added activity.

Click one more time the New Activity button and notice that only one activity has been 
added. This is because the model is reloaded from the SDXL file at each round-trip. The 
next step of this tutorial shows how to keep the modifications made to a model between 
round-trips.

Saving Modifications Across Requests

Each time a client requests the page, a new instance of the page is created to handle the 
request. This means that everything in the page is re-created including the controls and the 
data. The ability of ASP.NET to give the illusion that its pages and controls are maintaining 
some kind of state between different requests relies on the phases the page is put through 
upon each request. Let’s focus onto two phases of the page life cycle: The LoadViewState 
phase, and the SaveViewState phase.

The LoadViewState phase of a control life cycle initializes the control with data present in 
the request. This data is called the ViewState.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 23
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The SaveViewState phase of a control life cycle saves the state of the control into the 
ViewState, making it available for the next request.

This section describes how to store the Gantt Data Model into the ViewState. Of course, a 
real application would have used a database instead of storing the model in the ViewState, 
but this goes away from the scope of this tutorial.

1. Change the code of the load event handler to load the SDXL file only the first time the 
page is requested.

 To do this, double-click in an empty area of the web form. The source code editor opens. 
Replace the existing code with the following code:

protected override void OnLoad(EventArgs e)
{
    MyGanttChart.GanttModel = ganttModel;
    if (!IsPostBack)
      ganttSerializer.SetFileName(ganttModel, filename);
   base.OnLoad(e);
}

filename should be replaced by the location of a SDXL file.

2. Run the application using the command Debug > Start.

Click the New Activity button and notice that the model now contains only the added 
activity. This is because the SDXL file is now loaded only during the first page request, 
and not during postback requests.

3. Switch to code view by right-clicking in the web form and choose View Code.

4. Override the SaveViewState method by adding the following code:

protected override object SaveViewState() {
    System.IO.StringWriter writer = new System.IO.StringWriter();
    ganttSerializer.Serialize(writer, ganttModel);
    ViewState["GanttModelDescription"] = writer.ToString();
    writer.Close();
    return base.SaveViewState();
}

The code above serializes the Gantt Data Model to an XML string, and stores it into the 
page ViewState.

5. Override the LoadViewState method by adding the following code:

protected override void LoadViewState(object savedState) {
    base.LoadViewState(savedState);
    string xml = ViewState["GanttModelDescription"] as string;
    if (xml != null) {
        System.IO.StringReader reader = new System.IO.StringReader(xml);
        ganttSerializer.Deserialize(reader, ganttModel);

Note: Examples of SDXL files can be found in <install-dir>\Data.
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        reader.Close();
    }
}

The code above retrieves the XML description of the scheduling data from the 
ViewState, and populates the Gantt Data Model.

6. Run the application using the command Debug > Start.

Click the New Activity button several times, and notice that now the modifications made 
between several requests are saved.
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Synchronizing a Schedule Chart with a
Load Chart (Windows Forms Tutorial)

This tutorial walks you through the process of synchronizing a Schedule chart with a Load 
chart. You will start with the creation of the two charts and then work on the synchronization 
of their components.

See Also Creating a Schedule Chart | Associating a Gantt Data Model With the Schedule Chart | 
Filling the Schedule Chart With XML Data | Adding a Load Chart | Synchronizing the 
Charts | Making Reservations Visible at Launch Time

Creating a Schedule Chart

The Schedule chart is one of the controls that IBM® ILOG® Gantt for .NET provides to 
display scheduling information. The Schedule chart is divided in three parts: 

◆ The left part is a resource table (an instance of the class GanttTable) which displays 
resource information from the data model.

◆ The right part is a Gantt Sheet (an instance of the class GanttSheet) which displays the 
resource reservations. 

◆ Just above the Gantt sheet appears a zoomable time scale (an instance of the class 
TimeScale). 
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A standard, adjustable splitter separates the left part from the right part.

To create a Schedule chart, perform the following steps:

1. Create a project of type Windows® Forms.

On the File menu, click New, and then click Project.

The New Project window appears.

2. In the left window, click Visual C# > Windows.

3. In the right window, click Windows Application.

4. Name the project DualChart.

5. Place the project in C:\Gantt.

Visual Studio®.NET creates a Form1 and stores it by default in a file named Form1.cs.
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6. Resize the window.

Click Form1 and select the Properties tab at the bottom right of the window.

From the Properties explorer choose Layout > Size. Expand the property and enter the 
following values:

Width: 800

Height: 600
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7. From the IBM ILOG Gantt for .NET toolbox select a ScheduleChart object and drag it 
to Form1.
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8. Change the Dock property to make the schedule chart occupy the entire form.

Click the schedule chart in Form1and from the Properties explorer choose Layout > 
Dock. 
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9. Clicking the arrow next to the Dock property opens the following box:

10. Select the area corresponding to the Fill option.

The schedule chart now occupies the entire form and appears as illustrated below:

Fill
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11. Rename the schedule chart.

Click the schedule chart in Form1. From the Properties explorer choose Design > Name 
and enter the new name: scheduleChart.
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The appearance of the schedule chart can be completely customized to fit your needs. 

12. Define a style for the schedule chart you have just created.

You can either right-click the schedule chart and select AutoFormat in the contextual 
menu, or click AutoFormat at the bottom of the Properties explorer.
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The Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
schedule chart.

13. Save the file Form1.cs.
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Associating a Gantt Data Model With the Schedule Chart

The data model contains the scheduling information you want to display in the schedule 
chart. In the following steps, you will learn how to bind a simple Gantt data model to the 
schedule chart.

1. From the IBM® ILOG® Gantt for .NET toolbox select the SimpleGanttModel object 
and drag it to Form1.

2. Rename the simpleGanttModel object.

Click the SimpleGanttModel1 object in Form1. From the Properties explorer choose 
Design > Name and enter the following name: mySimpleGanttModel.
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3. Associate mySimpleGanttModel with scheduleChart.

Click the schedule chart in Form1 and from the Properties explorer select 
Data > GanttModel. 

Click the arrow of the drop-down list next to the GanttModel property and choose 
mySimpleGanttModel.
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Filling the Schedule Chart With XML Data

IBM® ILOG® Gantt for .NET allows you to serialize and deserialize scheduling data to and 
from Scheduling Data Exchange Language (SDXL) files. This is accomplished through the 
GanttModelXmlSerializer class.

To deserialize scheduling data from SDXL files and use this information to fill the schedule 
chart, perform the following steps.

1. From the IBM ILOG Gantt for .NET toolbox select the GanttModelXmlSerializer 
object and drag it to Form1.
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2. Rename the Gantt model XML serializer.

Click the ganttModelXmlSerializer1 object in Form1. From the Properties explorer 
choose Design > Name and enter the new name: myGanttModelXmlSerializer.

3. Click mySimpleGanttModel. You will notice that a new property named 
FileName on myGanttModelXmlSerializer has been created.
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4. Select the property FileName on ganttModelXmlSerializer and click the three-dots 
button next to it. Choose an SDXL file to fill the schedule chart.

Note: Examples of SDXL files can be found in <install-dir>\Data.
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Data contained in the Engineering.sdxl file are displayed in the schedule chart.

5. Save the file Form1.cs.

6. Run the application using the command Debug > Start. 

The application will appear as follows:

7. Close the application you have just executed and go back to Form1.cs.
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Adding a Load Chart

Now you will learn how to create a Load chart and associate it with the Schedule chart. 

The Load chart is the graphical representation of the load of a resource over the time. It is 
composed of a chart area where the x-axis represents the time and the y-axis represents the 
load of the resource.

To create the Load chart, perform the following steps:

1. From the IBM® ILOG® Gantt for .NET toolbox select the LoadChart object and drag 
it to Form1.

2. Rename the Load chart.

Click the Load chart in Form1. From the Properties explorer choose Design > Name and 
enter the new name: loadChart.

3. Change the height of the Load chart.

From the Properties explorer choose Layout > Size > Height and enter 200.
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4. Change the Dock property to make the Load chart occupy the bottom of the Form.

Click the Load chart and from the Properties explorer choose Layout > Dock. 
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Clicking the arrow next to the Dock property shows the following control:

5. Select the area corresponding to the Bottom option.

6. Right-click the schedule chart and select Bring to Front.

7. Align the Load chart with the splitter of the Schedule chart.
Click the Load chart in Form1. From the Properties explorer choose Layout > 
ChartPosition and enter 260.

Bottom
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Now that you have added the Load chart, the application appears as follows:

8. Close the application you have just executed and go back to Form1.cs.
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Synchronizing the Charts

Now that you have created the Schedule chart and the Load chart, you will learn how to 
synchronize them. 

See Also Synchronizing the Visible Time Range | Synchronizing the Grids | Synchronizing the Charts 
Splitter | Synchronizing the Resource Selection

Synchronizing the Visible Time Range

The display of the time information is controlled by an object called time line of the 
TimeControl. This object defines the first visible time of the TimeControl instance as well 
as the way to convert time information to pixels on the screen. 

The Schedule chart and Load chart are synchronized when they share the same time line, so 
that any modification of the visible time of the Schedule chart applies simultaneously to the 
Load chart.

To synchronize the visible time range, perform the following steps:

1. Select the Load chart.

2. From the Properties explorer choose TimeLine and from the drop-down list select 
scheduleChart.
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Synchronizing the Grids

When the Schedule chart is used in sync with another control displaying time information, 
for example the Load chart, it is interesting to synchronize the vertical grid lines of the 
control (the Time grid) with the ticks of the Time Scale. 

To synchronize the grids, perform the following steps:

1. Select the Schedule chart.

2. From the Properties explorer select the Events page by clicking the  icon.

3. Double-click the TimeScale > TimeScaleRowsChanged event. 
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The code editor opens with the cursor placed automatically at the appropriate location.

4. Insert the following code:

5. Save the file Form1.cs and go back to Design mode by selecting View > Designer on 
the menu bar.

Synchronizing the Charts Splitter

The Schedule chart contains a splitter that separates the Gantt table from the Gantt sheet. A 
double click on the splitter will make the table fully visible. The splitter can be controlled by 
means of the following properties: SplitterPosition and SplitterWidth.

To synchronize the position of the splitter between the Schedule chart and Load chart, 
perform the following steps:

1. Select the Schedule chart.

2. Got to the Properties explorer and select the Events page by clicking the  icon.

3. Double-click the SplitterPositionChanged event.

loadChart.TimeGrids.Synchronize(scheduleChart.TimeGrids);
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The code editor opens with the cursor automatically placed at the appropriate location.

4. Insert the following code:

5. Save the file Form1.cs and go back to Design mode by selecting View > Designer on 
the menu bar.

Synchronizing the Resource Selection

The resource selection is synchronized between the Schedule chart and Load chart when the 
resource, once selected, is displayed in both charts.

To obtain this, the Load chart must be connected to a resource using its Resource property. 
Once connected to a resource, the Load chart listens to events in the Gantt data model and 
updates himself when the resource changes or when the reservation changes.

To synchronize the resource selection, perform the following steps:

1. Select the Schedule chart.

2. From the Properties explorer select the Events page by clicking the  icon.

loadChart.ChartPosition = scheduleChart.SplitterPosition + 
scheduleChart.SplitterWidth;
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3. Double-click the Behavior > SelectionChanged event.

The code editor opens with the cursor placed automatically at the appropriate location.

4. Insert the following code:

ILOG.Views.Gantt.Data.IResource[] resources = 
scheduleChart.GetSelectedResources();
if (resources.Length == 1)
   loadChart.Resource = resources[0];
else
    loadChart.Resource = null;

5. Save the file Form1.cs.

6. Run the application using the command Debug > Start. 
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The application should appear as follows:

7. Close the application you have just executed.

Making Reservations Visible at Launch Time

When the application is launched, rows and columns appear empty. The scheduling 
information is there but you have to scroll to view it. 

In the following steps you will learn how to make the reservations immediately visible in the 
chart when the application is launched.

1. Select Form1.

2. From the Properties explorer select the Events page by clicking the  icon.

3. Double-click the Behavior > Load event.
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The code editor opens with the cursor placed automatically at the appropriate location.

4. Insert the following code:

5. Save the file Form1.cs.

6. Run the application using the command Debug > Start. 

scheduleChart.GanttSheet.ZoomToFit(false);
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The application should appear as follows:
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 53



Synchronizing a Schedule Chart with a Load Chart (Windows Forms Tutorial)

tutgnt.book  Page 54  Monday, July 20, 2009  2:58 PM
54 I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S



tutgnt.book  Page 55  Monday, July 20, 2009  2:58 PM
Creating a Custom Gantt Representation
(Windows Forms Tutorial)

This tutorial will walk you through the process of creating a custom Gantt chart 
representation made of an activity table and two scroll activity sheets. You will start with the 
creation of the table and then add one by one the scroll activity sheets.

See Also Creating the Activity Table | Associating a Gantt Model With the Activity Table | Filling the 
Activity Table With XML Data | Adding the Scroll Activity Sheets | Making Reservation 
Visible at Launch Time

Creating the Activity Table

The Activity table is one of the controls that IBM® ILOG® Gantt for .NET provides to 
display scheduling information. The custom representation you are going to create is 
composed of three main parts: an activity table (instance of the class GanttTable) on the left 
part displays information from the data model; two scroll activity sheets (instances of the 
class GanttSheet) on the right part display the activity reservations.

To create an Activity table, perform the following steps:

1. Create a project of type Windows® Forms.

On the File menu, click New, and then click Project.
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The New Project window appears.

2. In the left window, click Visual C# > Windows.

3. In the right window, click Windows Application.

4. Name the project DualSheet.

5. Place the project in C:\Gantt.

Visual Studio®.NET creates a form named Form1 and stores it by default in the file 
Form1.cs.
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6. Resize the window.

Click Form1 and select the Properties tab at the bottom right of the window.

From the Properties explorer choose Layout > Size. Expand the property and enter the 
following values:

Width: 800

Height: 600
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7. From the IBM ILOG Gantt for .NET toolbox select the ActivityTable object and drag it 
to Form1.
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8. Change the Dock property to make the Activity Table occupy the entire form.

Click the Activity Table and from the Properties explorer choose Layout > Dock. 
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Clicking the arrow next to the Dock property shows the following control:

9. Select the area corresponding to the Fill option.

Form1 now looks like this:

Fill
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10. Rename the Activity Table.

Click the activity table in Form1. From the Properties explorer choose Design > Name 
and enter the new name: activityTable.
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The appearance of the Activity Table can be completely customized to fit your needs.

11. Define a style for the Activity Table you have just created.

You can either right-click the activity table in Form1 and select AutoFormat in the 
contextual menu, or click AutoFormat at the bottom of the Properties explorer.
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The Table Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
Activity Table.

12. Save the file Form1.cs.
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Associating a Gantt Model With the Activity Table

The Gantt data model contains the scheduling information you want to display in the activity 
table. In the following steps, you will learn how to bind a simple Gantt data model to the 
activity table.

1. From the IBM® ILOG® Gantt for .NET toolbox select the SimpleGanttModel object 
and drag it to Form1.

2. Rename the simple Gantt model. 

Click the SimpleGanttModel1 object in Form1. From the Properties explorer choose 
Design > Name and enter the new name: simpleGanttModel.
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3. Associate the Gantt model with the Activity Table.

Click the activity table in Form1 and from the Properties explorer select 
Data > GanttModel.

Click the arrow of the drop-down list next to the GanttModel property and choose 
simpleGanttModel.
I B M  I L O G  G A N T T  F O R  . N E T  4 . 0  —  T U T O R I A L S 65



tutgnt.book  Page 66  Monday, July 20, 2009  2:58 PM
Now the simple Gantt model is associated with the activity table displayed in Form1.

Filling the Activity Table With XML Data

IBM® ILOG® Gantt for .NET allows you to serialize and deserialize scheduling data to and 
from Scheduling Data Exchange Language (SDXL) files. This is accomplished through the 
GanttModelXmlSerializer class.

To deserialize scheduling data from SDXL files and use this information to fill the Activity 
table, perform the following steps.

1. From the IBM ILOG Gantt for .NET toolbox select the GanttModelXmlSerializer 
object and drag it to Form1.
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2. Rename the Gantt model XML serializer.

Click the object ganttModelXmlSerializer1 in Form1. From the Properties explorer 
choose Design > Name and enter the new name: ganttModelXmlSerializer.

3. Go back to simpleGanttModel and select it.

You will notice that a new property named FileName on ganttModelXmlSerializer has 
been created.
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4. Select the property FileName on ganttModelXmlSerializer and click the three-dots 
button next to it. Choose an SDXL file to fill the activity table.

Data contained in the SDXL file are displayed in the Activity Table.

Note: Examples of SDXL files can be found in <install-dir>\Data.
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5. Save the file Form1.cs.

6. Run the application using the command Debug > Start. 

At this stage, the Activity Table contains only a table and appears as follows:

7. Close the application you have just executed.
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Adding the Scroll Activity Sheets

Now you will learn how to associate and synchronize the scroll activity sheets with the table 
you have just created.

Adding the First Scroll Activity Sheet

1. From the IBM® ILOG® Gantt for .NET toolbox select the ScrollActivitySheet object 
and drag it to Form1.

2. Resize the scroll activity sheet.

Click the scroll activity sheet in Form1. From the Properties explorer choose 
Layout > Size. Expand the property and enter the following value:

Width: 300

Height: leave the default value.

3. Change the Dock property to align the scroll activity sheet to the right of the Activity 
Table.

Click the scrollActivitySheet1 object in Form1 and from the Properties explorer choose 
Layout > Dock. 
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Clicking the arrow next to the Dock property shows the following control:

4. Select the area corresponding to the Right option.

The scroll activity sheet is now aligned to the right of the Activity Table. If necessary, 
scroll horizontally to view it.

Right
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5. Define a style for the scroll activity sheet you have just created.

You can either right-click the scroll activity sheet in Form1 and select AutoFormat in the 
contextual menu, or click AutoFormat at the bottom of the Properties explorer.

The Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
scroll activity sheet.

6. Go back to the activity table. Right-click it and choose Bring to Front.
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7. Synchronize the table header with the time scale.

With the activity table selected, from the Properties explorer choose 
Layout > ColumnHeaderHeight and enter 36.

8. Synchronize vertically the activity table with the scroll activity sheet.

With the scroll activity sheet selected, from the Properties explorer choose 
Data > RowController. Click the arrow of the drop-down list next to the RowController 
property and choose activityTable.
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9. Save the file Form1.cs.

10. Run the application using the command Debug > Start. 

At this stage, the Gantt chart application contains a table and a sheet, and appears as 
follows:
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11. Close the application you have just executed.

Adding the Second Scroll Activity Sheet

1. From the IBM ILOG Gantt for .NET toolbox select the ScrollActivitySheet object and 
drag it to Form1.

2. Resize the second scroll activity sheet.

Click the scroll activity sheet in Form1. From the Properties explorer choose 
Layout > Size, expand the property and enter the following value:

Width: 300

Height: leave the default value.

3. Change the Dock property to align the scroll activity sheet to the right of the activity 
table.

Click the second scroll activity sheet in Form1 and from the Properties explorer choose 
Layout  > Dock. 

4. Select the area corresponding to the Right option.

The second scroll activity sheet is now aligned to the right of the activity table. 
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5. Define a style for the scroll activity sheet you have just created.

You can either right-click the scroll activity sheet in Form1 and select AutoFormat in the 
contextual menu, or click AutoFormat at the bottom of the Properties explorer.

The Styles window appears:

Select a style and click OK. The style that you selected is automatically applied to the 
scroll activity sheet.

6. Go back to the activity table. Right-click it and choose Bring to Front.
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7. Synchronize vertically the Activity Table with the second scroll activity sheet.

With the second scroll activity sheet selected, from the Properties explorer choose 
Data > RowController. Click the arrow of the drop-down list next to the RowController 
property and choose activityTable.

8. Save the file Form1.cs.

9. Run the application using the command Debug > Start.

Now that you have added the second scroll activity sheet, the application appears as 
follows:

10. Close the application you have just executed.

Making Reservation Visible at Launch Time

When the application is launched, the scroll activity sheets appear empty because their 
default visible time interval may not contain data, depending on the SDXL file you want to 
load. The scheduling information is there but you have to scroll to view it. The following 
steps illustrate how to make the reservations immediately visible in the sheets when the 
application is launched. The first scroll activity sheet will display the first half of the 
scheduling information, and the second scroll activity sheet will display the second half.

1. In Design mode, double-click the header of Form1.

The code editor opens with the cursor placed automatically at the appropriate location.
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2. Insert the following code:

3. Save the file Form1.cs.

4. Run the application using the command Debug > Start. 

Now the reservations are immediately visible in the table when the application is launched, 
as illustrated below:

ILOG.Views.Gantt.DateTimeInterval interval = 
scrollActivitySheet1.TimeBounds.TimeInterval;
scrollActivitySheet2.VisibleTimeInterval = new 
ILOG.Views.Gantt.DateTimeInterval(interval.Start, 
TimeSpan.FromTicks((long)(interval.Duration.Ticks / 2)));
scrollActivitySheet1.VisibleTimeInterval = new 
ILOG.Views.Gantt.DateTimeInterval(scrollActivitySheet2.LastVisibleTime,  
TimeSpan.FromTicks((long)(interval.Duration.Ticks / 2)));
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