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Chapter 1. Purpose and description

This document describes the procedure for upgrading the following systems to the
TS7500 V3 R2 level using the TS7500 V3.2 Software Upgrade CD:
v TS7520 system running TS7500 V2 R1, TS7500 V2 R2, TS7500 V3 R1 software

level
v TS7530 system running TS7500 V3 R1 software level

Note: You cannot load the TS7500 V3 R1 or V3 R2 software level on a TS7510
system.

Who should read this document
This publication is intended for use by customers who are using the TS7500 V3.2
Software Upgrade CD to upgrade either of the following:
v TS7520 system running TS7500 V2 R1, TS7500 V2 R2, TS7500 V3 R1 software

level
v TS7530 system running TS7500 V3 R1 software level

Installation time
The estimated installation time for this procedure is three to six hours, depending
on the experience level of the installer. The server and storage firmware updates in
Chapter 6, “Firmware,” on page 35 can be performed as a separate outage after the
TS75200 V3.2 software is installed.

What's new in this edition
Technical changes occurring in this edition are identified with a vertical bar ( | ) in
the left margin of the page.

Major changes and additions to this document since the last edition include the
following:
v A new step was added to Chapter 4, “Installing the TS7500 V3.2 Software

Upgrade CD,” on page 21.

© Copyright IBM Corp. 2008, 2011 1
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Chapter 2. Prerequisites

The following prerequisites are to be met prior to performing the upgrade
procedure.

Note: For general TS7500 operating procedures, refer to the IBM Virtualization
Engine for Tape TS7500 User's Guide, publication number GC27-2179.
v Empty the virtual vault. If there are tapes inside the virtual vault before software

upgrade, move them to a virtual library before proceeding. (Refer to the IBM
Virtualization Engine for Tape TS7500 User's Guide for detailed procedures.)

v Complete all necessary software upgrades:
– System is at the TS7500 V2 R2 or TS7500 V3 R1 software level (minimum)
– System has a minimum of 4GB of RAM.

- If the Virtualization Engine is a 3954-CV7, it already has 4GB of RAM.
- If the Virtualization Engine is a 3954-CV6, you must add FC 3460.

– System is updated with all released patches. (To download the patches, go to:
http://www-01.ibm.com/support/search.wss?rs=1174&tc=HW29K&q=ssg1*
&dc=D420&dtm)

v Take all defined drives in the application offline. (Refer to your backup
application documentation for more information.)

v Stop any replication processes that are running.
v Suspend I/O to the server.
v Ensure that no tapes are loaded into any physical or virtual drives.
v Record all customer-created user IDs. You will need to recreate them after your

upgrade (see TS7500 User's Guide for instructions).

Attention: This document includes occurrences of root passwords that are used to
manage and configure the product. Improper use of these commands and
passwords poses significant risk to the product and your data. Use these
commands and passwords only as documented.

Verifying correct software level
To determine whether the IBM® Virtualization Engine TS7500 is at the correct level
on each server (both the upper and lower server if in an HA environment),
perform the following steps:

Procedure
1. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY. For

instructions on how to install PuTTY on the VE Console workstation, see
Appendix A, “Installing PuTTY on the VE console workstation,” on page 65.

2. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
3. Click Open.
4. Click Yes at the PuTTY Security Alert screen (see Figure 1 on page 4).

© Copyright IBM Corp. 2008, 2011 3
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5. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

6. At the command prompt, enter the following command:
cat /var/log/IBMApplianceType

The output may look like the following, depending on your configuration:

CVTx HA Lower Server (CVT2.2 HA Lower Server)
x366

where x is the software version. In this example, the software level is TS7500
V2 R2 indicated by CVT2.2. The TS7500 should be at the v2.2 software level or
greater as indicated by CVT2.2 above.

Note: If the output from the IBMApplianceType command reads CVT3.0, this
actually indicates version 3.1.

7. If your system is at or above the 2.2 level, skip to step 8 on page 5. Otherwise,
you must upgrade it to the 2.2 software level before continuing. Perform the
following steps:
a. Ensure that SMcli can resolve hostname on the system (see “Ensuring that

SMcli can resolve hostname” on page 6.

Figure 1. PuTTy Security Alert
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b. Perform the configuration backup and diagnostic summary on the system
(see “Configuration backup and diagnostic summary” on page 7).

c. Locate a copy of the TS7520 2.2 Software Upgrade CD and CVT Console
Installation Disk v2.2.3 that was included in this ship group.

d. Go to the following Virtualization Engine patch download page:
http://www-01.ibm.com/support/search.wss?rs=1174&tc=HW29K
&q=ssg1*&dc=D400&dtm

e. Scroll down and click the link TS7520 Patch update-ve13821201.
f. Scroll down and open the TS7520 Patch update-ve13821201 Installation

Instruction for information on installing this software.

Note: You may have to uninstall a previous version of the VE console
workstation in order to install a new version.

g. After the upgrade is complete, continue to step 8.
8. If your system is at or above the 3.1 level, skip to step 9. If your system is not

at or above the 3.1 level, you must upgrade it to the 3.1 software level before
continuing. Perform the following steps:

Note: Remember that a result of CVT3.0 in step 6 on page 4 actually indicates
level 3.1, meaning that you should skip to step 9.
a. Ensure that SMcli can resolve hostname on the system (see “Ensuring that

SMcli can resolve hostname” on page 6.
b. Perform the configuration backup and diagnostic summary on the system

(see “Configuration backup and diagnostic summary” on page 7).
c. Locate the TS7520 3.1 Software Upgrade CD and the TS7500 Console

Installation Disk Version 3.1.0 that were included in this ship group.
d. Upgrade the system to the 3.1 software level (see Chapter 3, “Installing the

TS7500 V3.1 Software Upgrade CD,” on page 13).
e. Using the TS7500 User's Guide that shipped with the system and the

TS7500 Console Installation Disk Version 3.1.0, update the VE Console
workstation.

Note: You may have to uninstall a previous version of the VE console
workstation in order to install a new version.

f. After the upgrade is complete, continue to step 9.
9. If your system is at the 3.2 level, skip to step 10. Otherwise, you must

upgrade it to the 3.2 software level before continuing. Perform the following
steps:
a. Ensure that SMcli can resolve hostname on the system (see “Ensuring that

SMcli can resolve hostname” on page 6.
b. Perform the configuration backup and diagnostic summary on the system

(see “Configuration backup and diagnostic summary” on page 7).
c. Locate the TS7500 3.2 Software Upgrade CD and the TS7500 Console

Installation Disk Version 3.2 that were included in this ship group.
d. Upgrade the system to the 3.2 software level (see Chapter 4, “Installing the

TS7500 V3.2 Software Upgrade CD,” on page 21).
10. If your system is at the 3.2 software level, continue to Chapter 5, “Verifying

that required patches have been installed,” on page 31 to make sure all the
available patches have been installed.

11. At the command prompt, enter exit to exit from PuTTY.
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Ensuring that SMcli can resolve hostname

About this task

Ensure that the SMcli can resolve your hostname by completing the following
procedure.

Note: Refer to “Verifying correct software level” on page 3 to use PuTTY to log in
to your system.

Procedure
1. At the command prompt, type the following command:

nslookup hostname

where hostname is the hostname specific to your configuration.

Note: You can use the hostname command to identify your hostname:
#hostname

The output of this command varies for 2.x and 3.x systems, but will resemble
the following:

#nslookup hostname
Server: 9.47.64.191
Address: 9.47.64.191 abc102.abc.beaverton.ibm.com

Name: hostname
Address: 10.0.0.1 hostname.abc.beaverton.ibm.com

You must correct your settings if your output does not include the following
line (specific to your network environment):
Address: 10.0.0.1 hostname.abc.beaverton.ibm.com

You might also need to correct your settings if the command returns error
output similar to the following:

#nslookup hostname
Server: 9.47.64.191
Address: 9.47.64.191 abc102.abc.beaverton.ibm.com

nslookup: getaddrinfo(’hostname’) failed: Name or service not known

2. Using a vi editor (or similar type of editor), correct your settings by adding the
IP address and host name to your /etc/hosts file as seen below, where
hostname is the hostname specific to your environment:
10.0.0.1 hostname.abc.beaverton.ibm.com

Note: You might need to type cd .. to change to the proper directory prior to
entering the vi /etc/hosts command.

3. At the command prompt, type the following command:
SMcli -d

The output is similar to the following:
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# SMcli -d
Base1-SV7Upper localhost hostname.abc.beaverton.ibm.com
Base1-SV7Lower localhost hostname.abc.beaverton.ibm.com

SMcli completed successfully.

In the event of an incorrect configuration, the error message resembles the
following:

#SMcli -d
There are currently no storage subsystems listed in the configuration file. Add
storage subsystems using the Add Storage Subsystem option in the storage
management software or by command line.

SMcli failed.

You must correct your settings if your output looks different. Using a vi editor
(or similar editor), correct your settings by editing the file /etc/hostsas seen
below:
v where the loopback address is resolved to localhost

127.0.0.1 localhost

v where the system hostname (determined by the command hostname is
resolved to the ip address of eth0 (determined by command ifconfig eth0)
10.0.0.1 hostname.abc.beaverton.ibm.com

Note: You might need to issue cd .. to change to the proper directory before
typing the vi /etc/hosts command.
After modifying the /etc/hosts file, type the following command:
SMcli -A

The output is similar to the following:

# SMcli -A
Starting auto discovery..................................................

.............................................................................

..................................................
Auto discovery operation successful.
SMcli completed successfully.

Type the following command to verify that your system is correctly
configured:
SMcli -d

Configuration backup and diagnostic summary
Attention: If the upgrade does not complete successfully, you will need a
configuration backup and diagnostic summary for recovery operations. The
configuration backup and diagnostic summary must be created before the software
upgrade.

Saving a configuration backup
To save a configuration backup, perform the following steps:
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Procedure
1. Start the TS7500 Virtualization Engine management console (VE console)

workstation by performing one of the following:
v If there is a desktop shortcut for the VE for Tape Console application,

double-click it.
v If there is not a desktop shortcut for the VE for Tape Console application,

click Start > Programs > IBM > VE for Tape > VE for Tape Console.

Note: This is the default installation location for the VE for Tape Console
application. The location of the application might differ for you.

2. Double-click VE for Tape Servers to expand the server list.
3. Double-click any server icon.
4. In the VE for Tape User Login window, enter the following user name and

password.
User name: vetapeuser
Password: veuserpassword

Note: The user name and password are case-sensitive.
5. From the menu bar, select Tools > Save Configuration.
6. Select a location to save the file and give it a filename. Click the Save button.

7. Wait for the configuration to save.

Figure 2. Save configuration
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8. When the configuration save finishes, click OK on the pop-up window.

9. Do not exit the VE console.

Saving a diagnostic summary
To save a diagnostic summary, perform the following steps:

Procedure
1. In the VE console, right-click the server icon and select Diagnostic Summary

Data. See Figure 5 on page 10.

Figure 3. Saving configuration message

Figure 4. Configuration saved successfully

Chapter 2. Prerequisites 9



2. Click Yes in the pop-up window.
The Diagnostic Summary Data Options window is displayed.

3. Click the ... button (or Browse when using the console v3.1) and choose a
location to save the diagnostic data file.

Note: Select the location that you used for the configuration file in “Saving a
configuration backup” on page 7

Figure 5. Diagnostic Summary Data selection

Figure 6. Choosing to create summary data
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4. Click OK.

Figure 7. Diagnostic Summary Data Options window
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5. Without changing the defaults in the Diagnostic Summary Data Options
window, click the Create Diagnostic Summary Data button. A dialog indicates
that the diagnostic summary data is being collected.

6. Wait for the data collection to complete. This might take several minutes. After
the data collection is complete, the Diagnostic Summary Data Options window
closes.

7. Select File > Exit to close the VE console
8. Return to the step following the one that sent you here.

Figure 8. Diagnostic data location

Figure 9. Diagnostic summary data message
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Chapter 3. Installing the TS7500 V3.1 Software Upgrade CD

To install the TS7500 V3.1 Software Upgrade CD, perform the following steps.

Before you begin

If you have reached this point without performing the steps in Chapter 2,
“Prerequisites,” on page 3, then you must perform them prior to continuing in this
section.
v If you are upgrading from TS7500 V2.2 to TS7500 V3.2, you must first perform

the installation procedures in this chapter to bring the system up to V3.1.
v If you are upgrading from TS7400 v2.2 to TS7500 v3.2, your system must be at

TS7500 v3.1.

Refer to “Verifying correct software level” on page 3 to determine the current
software level of your system.

Procedure
1. Obtain the TS7500 V3.1 Software Upgrade CD with part number PN 45E3010.

Note: If you have a TS7500 V3.1 software upgrade CD with a different part
number, discard it. Use the disc included in this ship group instead.

2. Do one of the following, depending the number of installed servers.
v If one server is installed, skip to step 8.
v If two servers are installed, continue to step 3.

3. Start the TS7500 Virtualization Engine management console (VE console)
workstation by performing one of the following:
v If there is a desktop shortcut for the VE for Tape Console application,

double-click it.
v If there is not a desktop shortcut for the VE for Tape Console application,

click Start > Programs > IBM > VE for Tape > VE for Tape Console.

Note: This is the default installation location for the VE for Tape Console
application. The location of the application might differ for you.

4. Double-click VE for Tape Servers to expand the server list.
5. Double-click any server icon.
6. In the VE for Tape User Login window, enter the following user name and

password.
User name: vetapeuser
Password: veuserpassword

Note: The user name and password are case-sensitive.
7. If two servers are installed and failover has been configured, remove failover

on both the lower and the upper servers (Appendix B, “Removing failover,”
on page 67).

8. Place the TS7500 V3.1 Software Upgrade CD (PN 45E3010) into the DVD drive
of the lower server.

9. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
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10. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
11. Click Open.
12. Click Yes at the PuTTY Security Alert screen (see Figure 10).

13. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

14. Verify that the VE services are running, by entering the following command at
the command line:
ve status

All the services should indicate a status of RUNNING.
v If the VE services are not running, start them by entering the command

ve start

and repeat this step.
v If the command cannot be found, exit PuTTY, log back into PuTTY and

repeat this step.
v If the problem persists, contact your next level of support.

Figure 10. PuTTy Security Alert
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15. Mount the TS7500 V3.1 Software Upgrade CD by running the following
command at the command prompt:
mount /dev/hda /media/cdrom

16. Run the Software Upgrade by running the following command at the
command prompt:
/media/cdrom/SW_CVT2_to_CVT3

Attention: The system checks for the amount of RAM available (with 4GB
being the minimum). If the amount of RAM installed is inadequate, do not
continue with installation until the minimum amount of RAM has been
installed.

Note: The following messages are displayed:

zelda:~ # /media/cdrom/SW_CVT2_to_CVT3
Total Memory=3630008 Used=%used Free=2683032

IBM VE for Tape Server v2.00 (Build 1382)
Copyright (c) 2001-2007 FalconStor Software. All Rights Reserved.

Starting VE for Tape Configuration Module [RUNNING]
Starting VE for Tape Base Module [RUNNING]
Starting VE for Tape HBA Module [RUNNING]
Starting VE for Tape SNMPD Module [RUNNING]
Starting VE for Tape Authentication Module [RUNNING]
Starting VE for Tape Server (Compression) Module [RUNNING]
Starting VE for Tape Server (HW Compression) Module [RUNNING]
Starting VE for Tape Server (Application Upcall) Module [RUNNING]
Starting VE for Tape Server (FSNBase) Module [RUNNING]
Starting VE for Tape Server (Upcall) Module [RUNNING]
Starting VE for Tape Server (Application) Module [RUNNING]
Starting VE for Tape Server (Application IOCTL) Module [RUNNING]
Starting VE for Tape Server (User) [RUNNING]
Starting VE for Tape Target Module [RUNNING]
Loading VE for Tape Resources [SKIPPED]
Starting VE for Tape Communication Module [RUNNING]
Starting VE for Tape Logger Module [RUNNING]
Starting VE for Tape Self Monitor Module [RUNNING]
Verify the Tape in the drive.

WARNING: The CD will format the LUN0 and update OS.
Do you want to continue (yes/no)?

yes
Starting...
SOFTWARE UPGRADE CVT3.0.
/dev/mem: munmap: Invalid argument
Save repository. Please wait...
The Repository saved.
populate_vtapes finished.
**********************************
* rebooting now with the CD... *
**********************************

17. When prompted, type yes to proceed.

Note: During the upgrade process, status messages indicate the progress of
installing various software packages. This is normal.
After the installation is complete and the CD ejects, the system reboots. You
lose connectivity to the server as it reboots. Wait approximately 15 minutes
before continuing.

18. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
19. Enter the IP address of the server you are connecting to where specified. The

IP address should be on the top of the server.
20. Click Open.
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21. Click Yes at the PuTTY Security Alert screen (see Figure 11).

22. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

23. Run the following command at the command prompt:
/var/tmp/set_ve_type

The server begins to finish updating itself and reboots again. You lose
connection to the server as it reboots. Wait approximately 15 minutes before
continuing.

Note: The following messages are displayed:
zelda:/ # /var/tmp/set_ve_type
Software Uprade CVT2.x to CVT3.0.
Copying, Please wait...

Shutting down syslog services done
Starting syslog services done
Start installation VE for Tape....
Installing SM packages.
SMagent started.
SMmonitor started.
Starting mcpConfig script.
untarring files from mcpConfig.tgz:
usr/
usr/share/
usr/share/fluxbox/

Figure 11. PuTTy Security Alert
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usr/share/fluxbox/init
usr/share/fluxbox/keys
usr/share/fluxbox/menu
etc/
etc/X11/
etc/X11/xdm/
etc/X11/xdm/Xsetup
etc/X11/XF86Config.x346
etc/X11/XF86Config.x366
etc/X11/XF86Config.x3755
configuring /etc/X11/XF86Config
Adding SMClient to /usr/share/fluxbox/menu file
Adding SMClient to /etc/X11/twm/system.twmrc file
creating isadmin group
Create ServiceAgent group and user
Creating CVT3.0 userids
Adding root dirs to vetapeservice path setting
Setting default window manager in /etc/X11/xinit/xinitrc
Modifying /etc/sudoers
Creating /var/log/lastlog file
done with mcp configuration
Installing VE Console GUI.
IBM TotalStorage TS7500 V3 R1 Virtualization Engine for Tape Console installation
completed.
Adding VE Console GUI to fluxbox menu.
Verifying archive integrity... All good.
Uncompressing Open iSCSI initiator 2.0-754..........
Stopping iSCSI service...
Uninstalling iscsi-initiator...
Installing open iSCSI initiator 2.0-754...
Adding swap.
mke2fs 1.38 (30-Jun-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
488640 inodes, 976896 blocks
48844 blocks (5.00%) reserved for the super user
First data block=0
30 block groups
32768 blocks per group, 32768 fragments per group
16288 inodes per group
Superblock backups stored on blocks:

32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done
Creating journal (16384 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 36 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
mke2fs 1.38 (30-Jun-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
727200 inodes, 1454080 blocks
72704 blocks (5.00%) reserved for the super user
First data block=0
45 block groups
32768 blocks per group, 32768 fragments per group
16160 inodes per group
Superblock backups stored on blocks:

32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 28 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
Install IBM package for 3494 Library support.
Adding lmcpd 3494 port to /etc/services file...
Adding lmcpd entry to /etc/inittab file...
Finish to the installation
Install IBM package for 3494 Library support done.
Found xSeries 366.
Change rotation policy of messages.

Change rotation policy [ OK ]
Shutting down syslog services done
Starting syslog services done
Change rotation policy of messages done.
Starting the DS4100 agent.
Running...

SMagent Started successfully [ OK ]
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New storage subsystem was discovered at address 127.0.0.1.

SMcli completed successfully.

Starting SMmonitor.
Cannot start SMmonitor because SMmonitor is already running.
SMcli completed successfully.

Starting the DS4100 agent done.
Running PreferredPath, Please wait...
Setting VE Engine type.
Adding the application LUN.

The number of cylinders for this disk is set to 26108.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs

(e.g., DOS FDISK, OS/2 FDISK)
mke2fs 1.38 (30-Jun-2005)
100+0 records in
100+0 records out
104857600 bytes (105 MB) copied, 0.480608 seconds, 218 MB/s
Repository sdb.
100+0 records in
100+0 records out
104857600 bytes (105 MB) copied, 0.46492 seconds, 226 MB/s
Mirror of the Repository sdo.
Installing VE RPM package.
Initialize IMA configuration file ......... [ OK ]
Preparing... ########################################### [100%]
1:ve ########################################### [100%]
International Business Machines, Inc. TotalStorage TS7500 V3 R1 Virtualization Engine
for Tape Server
v3.00 (Build 1465) Setup
Copyright (c) 2001-2008 FalconStor Software. All Rights Reserved.

Supported SCSI device(s) found: 48

TotalStorage TS7500 V3 R1 Virtualization Engine for Tape configuration created.
International Business Machines, Inc. TotalStorage TS7500 V3 R1 Virtualization Engine
for Tape
installation completed.
Update VE
Installing VE RPM package done.
Configure the FC drivers.

IBM VE for Tape Server v3.00 (Build 1465)
Copyright (c) 2001-2008 FalconStor Software. All Rights Reserved.

Starting VE for Tape SNMPD Module [ OK ]
Starting VE for Tape Authentication Module [ OK ]
Starting VE for Tape Server (Compression) Module [ OK ]
Starting VE for Tape Server (Hifn HW Compression) Module [ OK ]
Starting VE for Tape Server (Application Upcall) Module [ OK ]
Starting VE for Tape Server (FSNBase) Module [ OK ]
Starting VE for Tape Server (Upcall) Module [ OK ]
Starting VE for Tape Server (Application) Module [ OK ]
Starting VE for Tape Server (Application IOCTL) Module [ OK ]
Starting VE for Tape Server (User) [ OK ]
Starting VE for Tape Target Module [ OK ]
Starting VE for Tape Local Client (VBDI) [ OK ]
Loading VE for Tape Resources [ OK ]
Starting VE for Tape Server IMA Daemon [ OK ]
Starting VE for Tape Server RDE Daemon [ OK ]
Starting VE for Tape Communication Module [ OK ]
Starting VE for Tape Logger Module [ OK ]
Starting VE for Tape Self Monitor Module [ OK ]
Please wait...
virtualization of LUN 0.0.0.1 done.
Making new kernel image....
Root device: /dev/sda1 (mounted on / as ext3)
Module list: fsbase fsconf fshba tg3 bonding ()

Kernel image: /boot/vmlinuz-2.6.16.46-229-smp
Initrd image: /boot/initrd-2.6.16.46-229-smp.img
Shared libs: lib64/ld-2.4.so lib64/libacl.so.1.1.0 lib64/libattr.so.1.1.0 lib64/libblkid
.so.1.0 lib64/libc-2.4.so lib64/libcom_err.so.2.1 lib64/libdl-2.4.so lib64/libext2fs.so.
2.4 lib64/libhistory.so.5.1lib64/libncurses.so.5.5 lib64/libpthread-2.4.so lib64/libread
line.so.5.1 lib64/librt-2.4.so lib64/libuuid.so.1.2lib64/libnss_files-2.4.so lib64/libns
s_files.so.2 lib64/libgcc_s.so lib64/libgcc_s.so.1

Driver modules: scsi_mod sd_mod fsbase fsconf fshba tg3 bonding libata pata_serverworks
Filesystem modules:
Including: initramfs fsck.ext3
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23938 blocks

You may now have to update your boot loader configuration.
New kernel image made successfully [ OK ]

making a new kernel image done.
Adding VE auto start.
CVT3 SOFTWARE UPGRADE COMPLETED SUCCESSFULLY..
Rebooting...

24. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
25. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
26. Click Open.
27. Click Yes at the PuTTY Security Alert screen (see Figure 12).

28. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

29. At the command prompt, make sure all services are running by entering the
following command:
ve status

Note: The following messages are displayed:

Figure 12. PuTTy Security Alert
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zelda:~ # ve status
IBM VE for Tape Server v3.00 (Build 1465)
Copyright (c) 2001-2008 FalconStor Software. All Rights Reserved.
Status of VE for Tape SNMPD Module [RUNNING]
Status of VE for Tape Configuration Module [RUNNING]
Status of VE for Tape Base Module [RUNNING]
Status of VE for Tape HBA Module [RUNNING]
Status of VE for Tape Authentication Module [RUNNING]
Status of VE for Tape Server (Compression) Module [RUNNING]
Status of VE for Tape Server (Hifn HW Compression) Module [RUNNING]
Status of VE for Tape Server (Application Upcall) Module [RUNNING]
Status of VE for Tape Server (FSNBase) Module [RUNNING]
Status of VE for Tape Server (Upcall) Module [RUNNING]
Status of VE for Tape Server (Application) Module [RUNNING]
Status of VE for Tape Server (Application IOCTL) Module [RUNNING]
Status of VE for Tape Server (User) [RUNNING]
Status of VE for Tape Target Module [RUNNING]
Status of VE for Tape Server IMA Daemon [RUNNING]
Status of VE for Tape Server RDE Daemon [RUNNING]
Status of VE for Tape Communication Module [RUNNING]
Status of VE for Tape Logger Module [RUNNING]
Status of VE for Tape Local Client (VBDI) [RUNNING]
Status of VE for Tape Self Monitor Module [RUNNING]
zelda:~ #

Note: If any status is not shown as [RUNNING], type ve restart at the
command line. If the problem persists, contact IBM support

30. Repeat step 14 on page 14 through step 29 on page 19 for all other servers in
all base frames.

31. Remove the CD from the drive.
32. Return to the step following the one that sent you here.
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Chapter 4. Installing the TS7500 V3.2 Software Upgrade CD

Before you begin

If you are upgrading from TS7500 V2.2 to TS7500 V3.2, you must perform the
installation procedures in Chapter 3, “Installing the TS7500 V3.1 Software Upgrade
CD,” on page 13 before performing the installation steps in this section. If you
have reached this point without performing the steps in Chapter 2, “Prerequisites,”
on page 3, then you must perform them prior to continuing in this section. If you
are upgrading from TS7400 v2.2 to TS7500 v3.2, your system must be at TS7500
v3.1. Refer to “Verifying correct software level” on page 3 to determine the current
software level of your system.

About this task

To install the TS7500 V3.2 Software Upgrade CD, perform the following steps:

Procedure
1. Obtain the TS7500 V3.2 Software Upgrade CD.
2. Do one of the following, depending the number of installed servers.
v If one server is installed, skip to step 8.
v If two servers are installed, continue to step 3.

3. Start the TS7500 Virtualization Engine management console (VE console)
workstation by performing one of the following:
v If there is a desktop shortcut for the VE for Tape Console application,

double-click it.
v If there is not a desktop shortcut for the VE for Tape Console application,

click Start > Programs > IBM > VE for Tape > VE for Tape Console.

Note: This is the default installation location for the VE for Tape Console
application. The location of the application might differ for you.

4. Double-click VE for Tape Servers to expand the server list.
5. Double-click any server icon.
6. In the VE for Tape User Login window, enter the following user name and

password.
User name: vetapeuser
Password: veuserpassword

Note: The user name and password are case-sensitive.
7. If two servers are installed and failover has been configured, remove failover

on both the lower and the upper servers (see Appendix B, “Removing
failover,” on page 67).

8. Place the TS7500 V3.2 Software Upgrade CD into the DVD drive of the lower
server.

9. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
10. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
11. Click Open.
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12. Click Yes at the PuTTY Security Alert screen (see Figure 13).

13. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

14. Verify that the VE services are running, by entering the following command at
the command line:
ve status

(If the command cannot be found, exit PuTTY, log back into PuTTY and
repeat this step.) All the services should indicate a status of RUNNING. If the
VE services are not running, start them by entering the command
ve start

and repeat this step. If the problem persists, contact your next level of
support.

15. Mount the TS7500 V3.2 Software Upgrade CD by running the following
command at the command prompt:
mount /dev/hda /media/cdrom

16. Run the Software Upgrade by running the following command at the
command prompt:
/media/cdrom/SW_CVT3.0_to_CVT3.2

Figure 13. PuTTy Security Alert
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Attention: The system checks for the amount of RAM available (with 4GB
being the minimum). If the amount of RAM installed is inadequate, do not
continue with installation until the minimum amount of RAM has been
installed.

17. When prompted, type yes and press Enter. The following messages are
displayed:

cvtras14:~ # mount /dev/hda /media/cdrom
mount: block device /dev/hda is write-protected, mounting read-only
cvtras14:~ # /media/cdrom/SW_CVT3.0_to_CVT3.2
Total Memory=4052292 Used=%used Free=3394196

WARNING: The CD will format the LUN0 and update OS.
Do you want to continue (yes/no)?

yes
Starting...
SOFTWARE UPGRADE CVT3.2.

IBM VE for Tape Server v3.00 (Build 1465)
Copyright (c) 2001-2008 FalconStor Software. All Rights Reserved.

Stopping VE for Tape Self Monitor Module [ OK ]
Stopping VE for Tape Logger Module [ OK ]
Stopping VE for Tape Server RDE Daemon [ OK ]
Stopping VE for Tape Server IMA Daemon [ OK ]
Stopping VE for Tape Communication Module [ OK ]
Stopping VE for Tape Target Module [ OK ]
Stopping VE for Tape Local Client (VBDI) [ OK ]
Stopping VE for Tape Server (User) [ OK ]
Stopping VE for Tape Server (Application IOCTL) Module [ OK ]
Stopping VE for Tape Server (Application) Module [ OK ]
Stopping VE for Tape Server (Upcall) Module [ OK ]
Stopping VE for Tape Server (FSNBase) Module [ OK ]
Stopping VE for Tape Server (Application Upcall) Module [ OK ]
Stopping VE for Tape Server (Compression) Module [ OK ]
Stopping VE for Tape Server (Hifn HW Compression) Module [ OK ]
Stopping VE for Tape Authentication Module [ OK ]
Stopping VE for Tape SNMPD Module [ OK ]

IBM VE for Tape Server v3.00 (Build 1465)
Copyright (c) 2001-2008 FalconStor Software. All Rights Reserved.

Starting VE for Tape SNMPD Module [ OK ]
Starting VE for Tape Authentication Module [ OK ]
Starting VE for Tape Server (Compression) Module [ OK ]
Starting VE for Tape Server (Hifn HW Compression) Module [ OK ]
Starting VE for Tape Server (Application Upcall) Module [ OK ]
Starting VE for Tape Server (FSNBase) Module [ OK ]
Starting VE for Tape Server (Upcall) Module [ OK ]
Starting VE for Tape Server (Application) Module [ OK ]
Starting VE for Tape Server (Application IOCTL) Module [ OK ]
Starting VE for Tape Server (User) [ OK ]
Starting VE for Tape Target Module [ OK ]
Starting VE for Tape Local Client (VBDI) [ OK ]
Loading VE for Tape Resources [ OK ]
Starting VE for Tape Server IMA Daemon [ OK ]
Starting VE for Tape Server RDE Daemon [ OK ]
Starting VE for Tape Communication Module [ OK ]
Starting VE for Tape Logger Module [ OK ]
Starting VE for Tape Self Monitor Module [ OK ]
Verify the Tape in the drive.
**********************************
* rebooting now with the CD... *
**********************************

Note: During the upgrade process, status messages indicate the progress of
installing various software packages. This is normal.
After the installation is complete and the CD ejects, the system reboots. You
lose connectivity to the server as it reboots.

18. Wait approximately 15 minutes before continuing.
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19. Remove the CD from the drive.
20. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
21. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
22. Click Open.
23. Click Yes at the PuTTY Security Alert screen (see Figure 14).

24. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

25. Run the following command at the command prompt:
/var/tmp/set_ve_type

The server begins to finish updating itself and reboots again. You lose
connection to the server as it reboots. Wait approximately 15 minutes before
continuing.

Note: The following messages are displayed:
Shutting down syslog services done
Starting syslog services done
Software Uprade CVT3.0 to CVT3.2.
Copying, Please wait...

Figure 14. PuTTy Security Alert
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Start installation VE for Tape....
Installing SM packages.
SMagent started.
ls: /var/opt/SM/emwdata*.bin: No such file or directory
ls: /var/opt/SM/emwback*.bin: No such file or directory
SMmonitor started.
Starting mcpConfig script.
untarring files from mcpConfig.tgz:
usr/
usr/share/
usr/share/fluxbox/
usr/share/fluxbox/init
usr/share/fluxbox/keys
usr/share/fluxbox/menu
etc/
etc/X11/
etc/X11/xdm/
etc/X11/xdm/Xsetup
etc/X11/XF86Config.x346
etc/X11/XF86Config.x366
etc/X11/XF86Config.x3755
configuring /etc/X11/XF86Config
Adding SMClient to /usr/share/fluxbox/menu file
Adding SMClient to /etc/X11/twm/system.twmrc file
creating isadmin group
Create ServiceAgent group and user
Creating CVT3.2 userids
Adding root dirs to vetapeservice path setting
Setting default window manager in /etc/X11/xinit/xinitrc
Modifying /etc/sudoers
Creating /var/log/lastlog file
done with mcp configuration
Installing VE Console GUI.
IBM TotalStorage TS7500 V3 R2 Virtualization Engine for Tape Console installation completed.
Adding VE Console GUI to fluxbox menu.
Verifying archive integrity... All good.
Uncompressing Open iSCSI initiator 2.0-754..........
Stopping iSCSI service...
Uninstalling iscsi-initiator...
Installing open iSCSI initiator 2.0-754...
Adding swap.
mke2fs 1.38 (30-Jun-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
488640 inodes, 976896 blocks
48844 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1002438656
30 block groups
32768 blocks per group, 32768 fragments per group
16288 inodes per group
Superblock backups stored on blocks:

32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done
Creating journal (16384 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 29 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
mke2fs 1.38 (30-Jun-2005)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
727200 inodes, 1454080 blocks
72704 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1488977920
45 block groups
32768 blocks per group, 32768 fragments per group
16160 inodes per group
Superblock backups stored on blocks:

32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 36 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
SMagent start.
Install IBM package for 3494 Library support.
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Adding lmcpd 3494 port to /etc/services file...
Adding lmcpd entry to /etc/inittab file...
Finish to the installation
Install IBM package for 3494 Library support done.
Found xSeries 366.
Change rotation policy of messages.

Change rotation policy [ OK ]
Shutting down syslog services done
Starting syslog services done
Change rotation policy of messages done.
Starting the DS4100 agent.
Running...

SMagent Started successfully [ OK ]
New storage subsystem was discovered at address 127.0.0.1.

SMcli completed successfully.

Starting SMmonitor.
Cannot start SMmonitor because SMmonitor is already running.
SMcli completed successfully.

Starting the DS4100 agent done.
Running PreferredPath, Please wait...
Setting VE Engine type.
Adding the application LUN.

The number of cylinders for this disk is set to 26108.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs

(e.g., DOS FDISK, OS/2 FDISK)
mke2fs 1.38 (30-Jun-2005)
mount: special device /dev/mapper/application-part1 does not exist
25283 blocks
10:04:40 up 21 min, 2 users, load average: 2.56, 1.82, 1.29
USER TTY LOGIN@ IDLE JCPU PCPU WHAT
root tty1 09:51 13:28 0.05s 0.05s -bash
root pts/0 09:54 10:14 12.42s 0.00s /bin/sh ./set_ve_type
Installing VE RPM package.
Initialize IMA configuration file ......... [ OK ]
Preparing... ########################################### [100%]

1:ve ########################################### [100%]

International Business Machines, Inc. TotalStorage TS7500 V3 R2 Virtualization Engine for
Tape Server v3.2.0 (Build 1507) Setup
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Supported SCSI device(s) found: 40

TotalStorage TS7500 V3 R2 Virtualization Engine for Tape configuration created.
International Business Machines, Inc. TotalStorage TS7500 V3 R2 Virtualization Engine for
Tape installation completed.
Installing VE RPM package done.
Configure the FC drivers.
Update VE
Upgrade CVT3.2 system, please wait ...
Recover from 0:0:0:1 and 1:0:0:2.
Recover from 0:0:0:1.
NEW_HOSTNAME is cvtras14.

International Business Machines, Inc. TotalStorage TS7500 V3 R2 Virtualization Engine for
Tape Server v3.2.0
(Build 1507) Setup
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Supported SCSI device(s) found: 40

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (Compression) Module [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (Hifn HW Compression) Module [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (Application Upcall) Module [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
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Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (FSNBase) Module [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (Upcall) Module [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Starting VE for Tape Server (Application) Module [ OK ]
Starting VE for Tape Server (Application IOCTL) Module [ OK ]
Starting VE for Tape Server (User) [ OK ]

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Stopping VE for Tape Self Monitor Module [STOPPED]
Stopping VE for Tape Logger Module [STOPPED]
Stopping VE for Tape Server RDE Daemon [STOPPED]
Stopping VE for Tape Server IMA Daemon [STOPPED]
Stopping VE for Tape Communication Module [STOPPED]
Stopping VE for Tape Target Module [STOPPED]
Stopping VE for Tape Local Client (VBDI) [STOPPED]
Stopping VE for Tape Server (User) [ OK ]
Stopping VE for Tape Server (Application IOCTL) Module [ OK ]
Stopping VE for Tape Server (Application) Module [ OK ]
Stopping VE for Tape Server (Upcall) Module [ OK ]
Stopping VE for Tape Server (FSNBase) Module [ OK ]
Stopping VE for Tape Server (Application Upcall) Module [ OK ]
Stopping VE for Tape Server (Compression) Module [ OK ]
Stopping VE for Tape Server (Hifn HW Compression) Module [ OK ]
Stopping VE for Tape Authentication Module [STOPPED]
Stopping VE for Tape SNMPD Module [STOPPED]
Recovering WWPN.
Recovered Persistence Binding
Making a new kernel image.
Root device: /dev/mapper/root-part1 (mounted on / as ext3)
Module list: fsbase fsconf fshba tg3 bonding dm-multipath dm-rdac dm-mod dm-snapshot
dm-round-robin dm-emc ( dm-mod dm-snapshot)

Kernel image: /boot/vmlinuz-2.6.16.46-229-smp
Initrd image: /boot/initrd-2.6.16.46-229-smp.img
Shared libs: lib64/ld-2.4.so lib64/libacl.so.1.1.0 lib64/libattr.so.1.1.0 lib64/
libblkid.so.1.0 lib64/libc-2.4.so lib64/libcom_err.so.2.1 lib64/libdevmapper.so.1.02 lib64/
libdl-2.4.so lib64/libext2fs.so.2.4 lib64/libhistory.so.5.1 lib64/libncurses.so.5.5 lib64/
libpthread-2.4.so lib64/libreadline.so.5.1 lib64/librt-2.4.so lib64/libsysfs.so.1.0.3 lib64/
libuuid.so.1.2 lib64/libnss_files-2.4.so lib64/libnss_files.so.2 lib64/libgcc_s.so lib64/
libgcc_s.so.1

Driver modules: scsi_mod sd_mod fsbase fsconf fshba tg3 bonding dm-mod dm-multipath dm-rdac
dm-snapshot dm-round-robin dm-emc libata pata_serverworks
Filesystem modules:
Including: initramfs dm/mpath fsck.ext3
25284 blocks

You may now have to update your boot loader configuration.
New kernel image made successfully [ OK ]

Making a new kernel image done.
Adding VE auto start.
CVT3.2 SOFTWARE UPGRADE COMPLETED SUCCESSFULLY..
VE UPGRADE COMPLETED SUCCESSFULLY
Please wait, system will reboot
cvtras14:/var/tmp #
Broadcast message from root (pts/0) (Wed Aug 19 10:09:49 2009):

The system is going down for reboot NOW!

26. Wait approximately 15 minutes before continuing.
27. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
28. Enter the IP address of the server you are connecting to where specified.

Note: The IP address should be on the top of the server.
29. Click Open.
30. Click Yes at the PuTTY Security Alert screen (see Figure 15 on page 28).

Chapter 4. Installing the TS7500 V3.2 Software Upgrade CD 27



31. Enter the following user name and password.
User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

32. At the command prompt, make sure all services are running by entering the
following command:
ve status

Note: The following messages are displayed:

Figure 15. PuTTy Security Alert
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cvtras14:~ # ve status

IBM VE for Tape Server v3.2.0 (Build 1507)
Copyright (c) 2003-2009 FalconStor Software. All Rights Reserved.

Status of VE for Tape SNMPD Module [RUNNING]
Status of VE for Tape Configuration Module [RUNNING]
Status of VE for Tape Base Module [RUNNING]
Status of VE for Tape HBA Module [RUNNING]
Status of VE for Tape Authentication Module [RUNNING]
Status of VE for Tape Server (Compression) Module [RUNNING]
Status of VE for Tape Server (Hifn HW Compression) Module [RUNNING]
Status of VE for Tape Server (Application Upcall) Module [RUNNING]
Status of VE for Tape Server (FSNBase) Module [RUNNING]
Status of VE for Tape Server (Upcall) Module [RUNNING]
Status of VE for Tape Server (Application) Module [RUNNING]
Status of VE for Tape Server (Application IOCTL) Module [RUNNING]
Status of VE for Tape Server (User) [RUNNING]
Status of VE for Tape Target Module [RUNNING]
Status of VE for Tape Server IMA Daemon [RUNNING]
Status of VE for Tape Server RDE Daemon [RUNNING]
Status of VE for Tape Communication Module [RUNNING]
Status of VE for Tape Logger Module [RUNNING]
Status of VE for Tape Local Client (VBDI) [RUNNING]
Status of VE for Tape Self Monitor Module [RUNNING]

Note: If any status is not shown as running, issue a ve restart command at
the command line. If the problem persists, contact your next level of support.

33. Repeat steps 14 on page 22 through 30 on page 27 for all other servers in all
base frames.

34. Using the IBM Virtualization Engine for Tape TS7500 User's Guide that shipped
with the system and the TS7500 Console Installation Disk Version 3.2, update
the VE Console workstation.

Note: You might have to uninstall a previous version of the VE console
workstation in order to install a new version.

35. Create a new virtual library to update the repository to the CVT3.2 version.
This new library can be deleted if not needed.

36. Continue to Chapter 5, “Verifying that required patches have been installed,”
on page 31 to verify and download, if needed, the latest software service
updates (patches) from the IBM Support Web site.
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Chapter 5. Verifying that required patches have been installed

Use the following procedure to verify that all the required patches have been
installed on each server (both the upper and lower server if in an HA
environment). It is critical and mandatory that you install all the latest patches
after the software upgrade has been performed and prior to operating the
virtualization engine(s).

About this task

This is a very important step and should not be ignored. All steps should be
performed immediately after the software upgrade has been completed.

Procedure
1. At the VE console workstation, open a Web browser window.
2. In the Web browser address bar, type the following address:

http://www.ibm.com/support
3. In the Search all of support search box, type TS7530 and click the arrow. A list

of search results is displayed.
4. In the Document type menu, select Downloads and drivers and click the

arrow.
5. In the Versions menu, select 3.2 and click the arrow. A list of downloads is

displayed.
6. Write down all the patch numbers present. Example: Patch update-ve146501.

Note: Patches are not hardware dependent, meaning that the TS7500 you are
working on could be using TS7520 hardware but running V3 software.

7. Start the TS7500 Virtualization Engine management console (VE console)
workstation by performing one of the following:
v If there is a desktop shortcut for the VE for Tape Console application,

double-click it.
v If there is not a desktop shortcut for the VE for Tape Console application,

click Start > Programs > IBM > VE for Tape > VE for Tape Console.

Note: This is the default installation location for the VE for Tape Console
application. The location of the application might differ for you.

8. Double-click VE for Tape Servers to expand the server list.
9. Double-click any server icon.

10. In the VE for Tape User Login window, enter the following user name and
password.

User name: vetapeuser
Password: veuserpassword

Note: The user name and password are case-sensitive.
11. Click the Version Info tab to confirm what patches are installed on the

servers. There should be a Version Info entry stating update-vexxxxxxx, where
xxxxxxx is the patch number (see Figure 16 on page 32).

© Copyright IBM Corp. 2008, 2011 31

http://www.ibm.com/support


Note: You might have to scroll through the log in order to find these entries
depending on the configuration of the TS7500.

12. Verify that the patches are present. If any patches are not present, install them.
Refer to the IBM Virtualization Engine for Tape TS7500 User's Guide that came
with your system for instructions on how to install patches.

Note: Always check the IBM Systems Support Web site (http://
www.ibm.com/support) for the latest patches available. To receive automatic
notification of all new patches, you can subscribe to the My notifications
feature of the site (see Figure 17 on page 33).

Figure 16. Confirming installed patches
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13. Continue to “Updating Storage Manager on the VE console workstation” on
page 35.

Figure 17. Subscribing to My notifications
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Chapter 6. Firmware

This chapter provides procedures for updating server and controller firmware, and
for verifying firmware levels after an update.

Updating Storage Manager on the VE console workstation

About this task

If the Storage Manager (on the workstation where your VE console application is
installed) is not at level 10.50.35.19 for V3R2, then you must perform the steps
outlined in this chapter.

Procedure
1. To identify the level of your Storage Manager, do the following:

a. From the VE Console workstation, select Start > Programs > Storage
Manager 10 Client > Storage Manager 10 Client.

b. Select Close (see Figure 18 on page 36).
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c. Select Help > About.
2. Click OK.
3. If the Storage Manager is at level 10.50.x.x for V3R2, go to step 22 on page 44.

Otherwise, continue to step 4.
4. Uninstall the current version of Storage Manager by performing the following

steps:
a. Click Start > Settings > Control Panel

b. Double click Add or Remove Programs.
c. Locate and click IBM DS4000/FastT Storage Manager Host Software

version aa.bb.cc.dd.
d. Click Change/Remove.
e. Click Next.
f. Click Complete Uninstall.
g. Click Next.

Figure 18. Enterprise Management Window Task Assistant
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h. Click Done.
i. Close the Add or Remove Programs and Control Panel windows.

5. Load the Virtualization Engine TS7500 Base Firmware Update Disk into the
CD-ROM drive of the workstation with the VE console application.

Note: If you have a previous version of the TS7500 firmware CD, discard it.
Use the disc included in this ship group instead.

6. If the installation wizard does not start automatically, go to the
x:\Tools/TS7500–disks\StorageManagerWin\
ibm_sw_ds4kfc_10.50.xx.19_windows_intl386\WS03WS08_10p50_IA32\Windows
folder on the CD and double-click SMIA-WS32-10.50.35.19.exe. The Storage
Manager Installation wizard starts.

7. Select Language and click OK.
8. In the Introduction page of the wizard, click Next.

9. In the Copyright Statement page of the wizard, click Next.

Figure 19. Storage Manager installation wizard Welcome page
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10. In the License Agreement page of the wizard, click I accept the terms of the
License Agreement and then click Next.

11. In the Choose Install Folder page of the wizard, click Next .

Figure 20. Storage Manager installation wizard Copyright Statement page

Figure 21. Storage Manager installation wizard License Agreement page
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12. In the Select Installation Type page of the wizard, click Management Station
and then click Next.

13. In the Automatically Start Monitor? page of the wizard, click Do not
Automatically Start the Monitor and then click Next.

Figure 22. Storage Manager installation wizard Choose Install Folder page

Figure 23. Storage Manager installation wizard Select Installation Type page
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14. In the Pre-Installation Summary page of the wizard, click Install.

15. In the Install Complete page of the wizard, click Done.

Figure 24. Storage Manager installation wizard Automatically Start Monitor? page

Figure 25. Storage Manager installation wizard Pre-Installation Summary page
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16. Eject the Virtualization Engine Base Firmware Update Disk from the
workstation's CD-ROM drive.

17. Start the Storage Manager application by clicking Start > Programs > Storage
Manager 10 Client > DS Storage Manager 10 Client.

18. In the Select Addition Method window, click Manual: and then click OK.

19. In the Add Storage Subsystem window:
a. Click In-band management:.
b. In the Host: field, enter the eth0 IP address (the IP address of Ethernet

port 1) of the Server to be added.

Figure 26. Storage Manager installation wizard Install Complete page

Figure 27. Select Addition Method window
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Note: The IP address can be found on a label on the top of the server.
c. Click Add.

20. In the Storage Subsystem Added window, perform one of the following:
v Click Yes and repeat step 19 on page 41 if other servers are present.
v Click No if there are no other servers present or all servers that are present

have been added

Figure 28. Add Storage Subsystem window
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21. If the Enterprise Management Window Task Assistant window is open, click
Close.

Figure 29. Storage Subsystem Added window
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22. After Storage Manager has been verified or updated to the required level on
the VE console workstation, continue to “Updating firmware on the servers.”

Updating firmware on the servers
Before you begin

Before starting the firmware upgrade procedure, make sure that:
v The system is at the TS7500 V3 R2 software level
v All defined drives in the application are offline.
v All replication processes have been stopped.

Attention: Do not attempt to update the firmware on the servers unless the
system is at the TS7500 V3 R2 software level. Doing so poses significant risk to the
product and your data.

Figure 30. Enterprise Management Window Task Assistant
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Procedure
1. Obtain the TS7500 Base Firmware Update Disk that shipped with this ship

group.
2. Do one of the following, depending the number of installed servers.
v If one server is installed, skip to step 8.
v If two servers are installed, continue to step 3.

3. Start the TS7500 Virtualization Engine management console (VE console)
workstation by performing one of the following:
v If there is a desktop shortcut for the VE for Tape Console application,

double-click it.
v If there is not a desktop shortcut for the VE for Tape Console application,

click Start > Programs > IBM > VE for Tape > VE for Tape Console.

Note: This is the default installation location for the VE for Tape Console
application. The location of the application might differ for you.

4. Double-click VE for Tape Servers to expand the server list.
5. Double-click any server icon. The VE for Tape User Login dialog is displayed.
6. Enter the following user name and password.

User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

7. If two servers are installed and failover has been configured, remove failover
on both the lower and the upper servers (Appendix B, “Removing failover,”
on page 67).

8. Insert the Virtualization Engine Base Firmware Update Disk into the
DVD-ROM drive of the first TS7500 Server.

9. Log into PuTTY by selecting Start > Programs > PuTTY > PuTTY.
10. Enter the IP address of the first TS7500 server where specified.
11. Select Open.
12. Enter the following user name and password.

User name: root
Password: warning2use

Note: The user name and password are case-sensitive.
Attention: Improper use of this password and command poses significant
risk to the product and your data. Use this password and command only as
documented.

13. In the PuTTY window, type the following command: reboot
The Virtualization Engine Base Firmware Update Disk automatically updates
the firmware on the system reboot. You lose connection to the server as it
reboots.

Note: If the Virtualization Engine Base Firmware Update Disk ejects, remove
the firmware CD from the DVD-ROM and manually power cycle the server
by pressing and holding the white recessed power-control button on the
server operator panel until the power-on LED is flashing. When the power-on
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LED is flashing, press the white recessed power-control button again to power
on the server. You do not need to hold the button to restart the server.

14. Wait approximately 15 minutes before continuing.
15. Repeat steps 8 on page 45 through 14 for each server present, placing the

Virtualization Engine Base Firmware Update Disk in the server being updated.
16. After the firmware has been verified or updated to the required level on the

servers, continue to “Updating the SV6 controller firmware level” on page 53.

Identifying the controller firmware level
To determine the firmware level of your controllers, perform the following:

Procedure
1. If the Storage Manager application is not already running, start it by clicking

Start > Programs > DS Storage Manager 10 Client > Storage Manager 10
Client

2. If the Select Addition Method dialog is displayed, perform the following
steps. Otherwise, skip to step 3 on page 49.

a. In the Select Addition Method dialog, select Manual:. Click OK.

Figure 31. Select Addition Method dialog
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b. In the Add Storage Subsystem dialog, select In-band management:.

Figure 32. Select Addition Method dialog
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c. In the Host: field, enter the eth0 IP address (the IP address of Ethernet port
1) of the Server to be added.

Note: The IP address can be found on a label on the top of the server.
d. Click Add.
e. In the Storage Subsystem Added dialog, perform one of the following:
v Click Yes and repeat step 2 on page 46 if other servers are present.
v Click No if no other servers are present or all servers have been added.

Figure 33. Add Storage Subsystem dialog
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f. If the Enterprise Management Window Task Assistant window is open,
click Close.

3. If there are multiple subsystems on your network, perform the following steps
to select the one you want:
a. Right-click a subsystem.
b. Select Locate Storage Subsystem. After a few seconds, the Global Locate

LED �3�comes on.
c. Verify that you have selected the right subsystem.
d. Select OK to turn off the LED.

4. Double-click the subsystem you selected.
5. In the Subsystem Management Window Task Assistant dialog, determine

whether the subsystem is in an optimal state or needs attention. Record this
information for use in step 11 on page 51.

Figure 34. Storage Subsystem Added dialog
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Figure 35. Global Locate LED
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6. Select Close.
7. Right-click controller A and select Properties

Figure 36. Subsystem Management Window Task Assistant dialog
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8. On a piece of paper, record the firmware level of the controller.
9. Select Close.

10. Repeat steps 5 on page 49 through 9 for controller B.
11. If the subsystem was in an optimal state during step 5 on page 49, skip to step

12 on page 52. If the subsystem needed attention, perform the following steps:
a. Select Storage Subsystem > Recovery Guru

Figure 37. Selecting Properties
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b. Perform the recommended recovery steps to fix the problems.

Note: If, after you perform the recovery steps, the subsystem still needs
attention, contact IBM service at www.ibm.com/planetwide. The machine
type is 3955 model SV6 or SX6 and the serial number is found on the
drawer label. You must eliminate all storage fault conditions before you
continue with the SV6 firmware update.

c. If the state of the subsystem becomes optimal, go to step 12.
12. Exit from the Subsystem Management window by selecting Storage

Subsystem > Exit.
13. Repeat steps 3 on page 49 through 12 for each controller that is connected to

the system you upgraded or is running V3.2 code.

What to do next
v If the controller firmware level you recorded in step 8 on page 51 is 7.36, go to

“Updating the SX6 expansion firmware level” on page 60.
v If the controller firmware level in not at 7.36, go to “Updating the SV6 controller

firmware level” on page 53.

Figure 38. Selecting Recovery Guru
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Updating the SV6 controller firmware level
For controller firmware level 6.x, you must update the controller firmware with the
controller firmware upgrade utility.

Before you begin

Before you start, make sure that you have an adequate maintenance window to do
the upgrade. The upgrade utility provides an estimate of the time required to
upgrade your specific configuration. The microcode of the DS4000 storage server
controllers consists of two packages:
v Controller firmware
v NVSRAM

The NVSRAM is similar to the settings in the BIOS of a host system. The firmware
and the NVSRAM are closely tied to each other and are therefore not independent.
Be sure to install the correct combination of the two packages.

Important: Before upgrading the storage server firmware and NVSRAM, make
sure that the system is in an optimal state. If not, run the Recovery Guru to
diagnose and fix the problem before you proceed with the upgrade. Always read
the readme before upgrading any firmware to check for compatibility with your
system.

About this task

To update the controller firmware with the firmware upgrade utility, perform the
following steps.

Procedure
1. If the firmware upgrade utility is not already installed, perform the following

steps.
a. Load the Virtualization Engine TS7500 Base Firmware Update Disk into

the CD-ROM drive of the workstation with the VE console application.

Note: If you have a previous version of the software upgrade CD with a
different part number, discard it. Use the disc included in this ship group
instead.

b. If the CD does not automatically run, go to My computer and double click
the CD-ROM drive where the CD was inserted.

c. Open the following folder: Tools\TS7500-Disks\StorageManagerWin\
ibm_sw_ds4kfc_10.50.xx.19_windows_intl386\WS03WS08_10p50_IA32\
Controller_Firmware_Upgrade_Tool

d. Double-click the file SMFWUpgInstaller-WS32-10.36.35.10.exe and follow
the prompts. The firmware upgrade utility is installed.

e. Do not remove the firmware CD from the CD-ROM
2. To start the upgrade utility program, select Start > Programs > Storage

Manager 10 Firmware Upgrade > Storage Manager 10 Firmware Upgrade. A
dialog similar to the one shown in Figure 39 on page 54 is displayed.
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3. If the Select Addition Method dialog is not automatically displayed as shown
in Figure 39, click Add....

4. Select Manual: and click OK.
5. In the Add Storage Subsystem dialog, perform the following steps:

a. Click In-band management:.
b. In the Host: field, enter the eth0 IP address (the IP address of Ethernet

port 1) of the Server.

Note: The IP address can be found on a label on the top of the server.
c. Click Add.

6. In the Storage Subsystem Added dialog, perform one of the following:
v Click Yes and repeat step 5 if other servers are present.
v Click No if no other servers are present or all servers have been added

Note: You can add multiple DS4000 systems in the upgrade utility. Install one
first, and then, if the operation was successful, continue with others in a single
pass. The utility program can download and activate firmware images to the
same DS4000 model and controller type in a parallel fashion.

7. If prompted for a password, type warning2use.
Attention: Improper use of these commands and passwords poses significant
risk to the product and your data. Use them only as documented.

Figure 39. Firmware upgrade utility
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8. Click OK.

Note: You will be prompted to enter a password for each storage subsystem
present.
If multiple systems are added or automatically discovered, they are presented
in the graphical interface and sorted by controller types and grouped as
upgradeable or non-upgradeable, as shown in Figure 41. After the DS4000
system is added successfully, the upgrade utility performs an automatic check
for any non-optimal condition that would prevent the upgrade from
succeeding.

Figure 40. Entering password

Figure 41. Firmware upgrade utility: Status window
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9. Check the status detected by the upgrade utility for your specific DS4000 to
upgrade. The status column shows different values depending on the version
found in the storage system and the system itself, since not all the models are
compatible with Version 7.xx and later. Models not supported by this
firmware continue to use the Storage Manager to install upgrades up to the
latest level available for the particular model. The only status that allows you
to proceed with the firmware upgrade is Upgradeable:Optimal, as shown in
Figure 41 on page 55.

10. If the status is not optimal, you can use the view log option to find the reason
detected by the utility.
a. Select a storage subsystem.
b. Click the View Log icon

The conditions as checked by the utility for a system to be upgradeable and
optimal are:
v Status upgradeable if all of the following are true:

– The storage subsystem supports Version 7.10 or later and is a DS4200,
DS4700, or DS4800

– The current version is equal to or later than 6.14 (minimum) and earlier
than 7.10 (already upgraded)

v Status optimal if all of the following are true:
– No failed assigned drives are found
– No hot spares replacing failed drives are found
– No volumes are missing
– Both controllers are in optimal status
– No operations are in progress

If there is a problem with any of the above conditions, the utility program
does not allow the upgrade of the affected DS4000 subsystem. Other
non-optimal conditions are indicated, and you should correct them before
proceeding with the upgrade. (The upgrade utility will perform the upgrade
even if you do not.)
A common reason for a status of “Not upgradeable” (Figure 42 on page 57) is
that the event log is full and needs to be cleared and all event entries deleted.
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The event log is cleared by using the Storage Manager. Highlight the storage
subsystem (repeat this procedure for each storage subsystem) and then select
menu option Advanced > Troubleshooting > View Event Log. Click Clear All
and type yes to confirm that you want to clear all the event log entries. Close
the Event Log window and go back to the Firmware Upgrade Tool. Click
Refresh to recheck your storage subsystem status.

Important:

v Make sure to install the firmware for each of the DS4000 components (ESM,
drives, controller, NVSRAM) in the sequence described in the readme file
for that version.

v Update the controller firmware first, and then the NVSRAM.
v Any power or network/SAN interruption during the update process might

lead to configuration corruption or extended downtime. Therefore, do not
power off the DS4000 storage server or the management station during the
update. If you are using in-band management and have Fibre Channel hubs
or managed hubs, then make sure that no SAN-connected devices are
powered up during the update. Otherwise, this can cause a loop
initialization process and interrupt the process.

11. Click the Download button in the left margin (Figure 41 on page 55) under
Firmware. A dialog is displayed (Figure 43 on page 58).

Figure 42. Not upgradeable status
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Note: The utility window is the same as the one obtained when updating
through the Storage Manager, although the utility and background process are
different.

12. Click Browse next to the Selected firmware file text box and navigate to
X:\Firmware\SV6\Controller_Code_07361700\ FIRMWARE\DS4200, where X is the
drive letter of the CD-ROM drive.

13. Select FW_DS4200_07361700.dlp and click OK.
14. In the Select Files window, click Browse next to the Selected NVSRAM file

text box and navigate to X:\Firmware\SV6\Controller_Code_07361700\
NVSRAM\DS4200, where X is the drive letter of the CD-ROM drive.

15. Select N1814D420R1036V12.dlp, and click OK. The dialog shown in Figure 44
on page 59 is displayed.

Figure 43. Selecting downloads and source files
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16. Click Yes to continue.
17. Observe the progress indication during the file transfer and activation. After

these operations are complete, the utility indicates the result of the operation.
If the transfer and activation were successful, the window shown in Figure 45
on page 60 is displayed.

Figure 44. Confirming download
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If the operation finishes with an error, the utility displays failure details in the
notification field. Check additional details for all the process using the view
log option.

18. Close the Controller Firmware Upgrade tool.
19. Continue to “Updating the SX6 expansion firmware level.”

Updating the SX6 expansion firmware level

About this task

Perform the following steps if there are SX6s in the frames of system you
upgraded. If no SX6s are present, go to “Configuring the Call Home functionality
installed during migration” on page 63.

Procedure
1. If the Virtualization Engine Base Firmware Update Disk is not already in the

CD-ROM drive on the VE console workstation, insert it.
2. If Storage Manager 10 Client is already running, skip to step 4 on page 61.

Otherwise, select Start -> Programs -> Storage Manager 10 Client -> Storage
Manager 10 Client.

Figure 45. Firmware upgraded
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3. Click Close.
4. From the Subsystem Management window, select Advanced -> Maintenance ->

Download -> ESM Firmware.

Figure 46. Enterprise Management Window Task Assistant
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5. Select one or more enclosures.
6. In the Select Files window, click Browse next to the File text box and navigate

to [X]:\Firmware\SX6, where [X] is the drive letter of the CD-ROM drive.
7. Select esm98C5.esm and click Start.
8. Confirm the selection and click Yes.
9. In the status field in the Select enclosures table, wait for the download for

each enclosure to complete.
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Figure 47. ESM Firmware Menu

Figure 48. Select enclosures table
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Configuring the Call Home functionality installed during migration
Complete this section if you would like Call Home installed and set up on the
system. This setup can be done at a later time.

For instructions on how to configure Call Home functionality, refer to the IBM
Virtualization Engine TS7530 Call Home Function Installation and Setup Guide.

Note: Copies of the Call Home guides and CDs are included in this migration ship
group.

Continue to “Verifying the migration on SV6 controllers.”

Verifying the migration on SV6 controllers
Perform the following steps to verify that the migration was successful.

Before you begin

If you closed Storage Manager 10 Client after you updated the firmware on the
controllers, repeat steps 1 on page 46 through 9 on page 51 to verify the firmware
levels.

Procedure
1. Right-click Controller A under Enclosure 85 and select Properties.
2. Verify that Firmware version: 07.36.17.00 and NVSRAM version:

N1814D420R1036V12 are listed under current configuration for SV6 controllers.
3. Right-click Controller B under Enclosure 85 and select Properties.
4. Verify that Firmware version: 07.36.17.00 and NVSRAM version:

N1814D420R1036V12 are listed under current configuration for SV6 controllers.
5. Repeat for each storage subsystem.

What to do next

Continue to “Verifying the migration on SX6 expansion units” on page 64.
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Verifying the migration on SX6 expansion units
Perform the following steps to verify that the migration was successful.

Before you begin

If you closed Storage Manager 10 Client after you updated the firmware on the
controllers, repeat steps 1 on page 46 through 9 on page 51 to verify the firmware
levels.

Procedure
1. Double-click the storage subsystem you want to select.
2. Click Storage Subsystem -> View -> Profile.
3. Select the Enclosures tab at the top of the window.
4. Using the scroll bar, verify that the ESM Firmware version is 98C5 for each

enclosure.
5. If failover was removed, then reinstall failover on both servers by following the

steps in Appendix C, “Reinstalling failover,” on page 71.

Conclusion
You have finished the upgrade of your system to the TS7500 V3.2 software level.
v If failover was removed, and you haven't already done so in another step,

reinstall failover on both servers by following the steps in Appendix C,
“Reinstalling failover,” on page 71.

v Store the CDs that shipped in this ship group securely for possible later use.
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Appendix A. Installing PuTTY on the VE console workstation

Perform this procedure to install the PuTTY on the VE Console workstation if not
previously installed on the VE console workstation.

Procedure
1. Locate and insert the Virtualization Engine Base Firmware Update Disk into

the CD-Rom drive of the VE console workstation.

Note: Start Windows Explorer if it does not automatically start and navigate
to X:Tools, where X is the letter of the CD-ROM drive.

2. Click the TOOLS folder.
3. Click the PuTTY folder.
4. Click the INSTALLER folder.
5. Click the PuTTY – 0.58-Installer folder.
6. At the PuTTY Wizard, click Next.
7. Click Next.
8. Click Next.
9. Click Next.

10. Click Install.
11. Click Finish.
12. Read and close the Read Me window.
13. Close the Windows explorer window.
14. Remove the Virtualization Engine Base Firmware Update Disk from the

CD-ROM drive of the workstation.
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Appendix B. Removing failover

Procedure
1. Right-click the failover group name icon and click Failover > Remove. See

Figure 49.

Note: This procedure assumes that you selected the hostname of the lower
server and ran the wizard on the lower server. Example screens in this
procedure show the wizard running on the lower server.

Note: You might have to log in to each failover partner (server) to perform this
step.

2. At the Remove Failover Server screen, perform the following substeps (see
Figure 50 on page 68):
__ a. Record the lower server hostname (1 in Figure 50 on page 68) in row 1 of

Table 1 on page 68.
__ b. Record the upper server hostname (2 in Figure 50 on page 68) in row 1

of Table 1 on page 68.
__ c. Record the lower server Adapter 1 (eth0) network interface IP address

(3a in Figure 50 on page 68) in row 2 of Table 1 on page 68.
__ d. Record the upper server Adapter 1 (eth0) network interface IP address

(3b in Figure 50 on page 68) in row 2 of Table 1 on page 68.
__ e. Record the lower server Adapter 2 (eth1) network interface IP address

(4a in Figure 50 on page 68) in row 3 of Table 1 on page 68.
__ f. Record the upper server Adapter 2 (eth1) network interface IP address

(4b in Figure 50 on page 68) in row 3 of Table 1 on page 68.
__ g. Record the lower server Adapter 1 (eth0) service interface IP address (5a

in Figure 50 on page 68) in row 4 of Table 1 on page 68.
__ h. Record the upper server Adapter 1 (eth0) service interface IP address (5b

in Figure 50 on page 68) in row 4 of Table 1 on page 68.
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Figure 49. Selecting the failover group to remove failover
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__ i. Record the lower server Adapter 2 (eth1) service interface IP address (6a
in Figure 50) in row 5 of Table 1.

__ j. Record the upper server Adapter 2 (eth1) service interface IP address (6b
in Figure 50) in row 5 of Table 1.

Table 1. Failover setup information

Row Item Lower Server Upper Server

1 Hostname

2 Adapter 1 (eth0 port) network
interface IP address

3 Adapter 2 (eth1 port) network
interface IP address

4 Adapter 1 (eth0 port) service
interface IP address

5 Adapter 2 (eth0 port) service
interface IP address

3. After Table 1 has been filled out, click Remove. Refer to Figure 50.
4. After failover has been removed, click OK. Refer to Figure 51 on page 69
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Figure 50. Removing Failover Server
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5. If required, click OK at the Root Information window (see Figure 52).

What to do next

Return to the step following the one that sent you here.
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Figure 51. Remove Failover Server confirmation
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Figure 52. Root information window
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Appendix C. Reinstalling failover

About this task

Attention: During this procedure, two types of IP address are assigned to the two
Ethernet ports for each server. This procedure assumes that you run the wizard on
the lower server. Example screens in this procedure show the wizard running on
the lower server.

Procedure
__ 1. If not already connected, connect to both servers.
__ 2. Ensure that the following services and features are set the same for both

servers. (For example, if iSCSI is enabled for the lower server, it must also
be enabled for the upper server. If Email Notification is disabled for the
lower server, it must also be disabled for the upper server.)
__ iSCSI
__ Email Notification
__ Hosted Backup
__ NDMP

__ 3. Right-click the lower TS7530 Server icon.
__ 4. Click Failover > Failover Setup Wizard. The Failover Setup Wizard starts.

Figure 53 shows this result for the lower server.
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Figure 53. Starting the Failover Setup Wizard
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__ 5. In the Select the Secondary Server window (see Figure 54), do the
following:

__ a. From the VE for Tape Server list, select the hostname of the
secondary server. The secondary server is the other server in the
frame. For instance, if you started the Failover Setup Wizard on the
lower server in the frame, the secondary server is the upper server.
You recorded the hostname for both servers in row 1 of the table
when you recorded the server information.

__ b. Click Next.
__ 6. Do one of the following:

v If the Rescanning Physical Devices is required window (Figure 55 on
page 73) opens, proceed to step 7 on page 73
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Figure 54. Select the Secondary Server window
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v If the Enter the IP addresses of the Servers (Adapter 1) window
(Figure 60 on page 77) opens, proceed to step 11 on page 75

__ 7. In the Rescanning Physical Devices is required window (Figure 55), click
OK.

__ 8. In the Virtual Device or Service Enabled Device... window (Figure 56 on
page 74), click OK.
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Figure 55. Rescanning Physical Devices is required window
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__ 9. In the VE console (Figure 57), do the following:

__ a. Expand the icon for the lower server.
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Figure 56. Summary of inconsistent device information
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Figure 57. Rescanning physical devices
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__ b. Right-click Physical Devices and then click Rescan.
__ c. In the Specify Adapter, SCSI ID and LUN ranges to scan window

(Figure 58), select Scan Existing Devices, then click OK.

__ 10. Return to the Failover Setup Wizard.
Attention: If the Rescanning Physical Devices is required window
(Figure 57 on page 74) reopens, do not rescan. You must wait at least 10
minutes before rescanning again. If after rescanning a second time, the
Rescanning Physical Devices is required window reopens, contact your
next level of support.

__ 11. In the Enter the IP addresses of the Servers (Adapter 1) window (Figure 59
on page 76), do the following:
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Figure 58. Scan existing devices
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__ a. In the IP address fields, confirm that the wizard retrieved and filled
in the network interface IP addresses for adapter 1 (eth0) for the
servers. You recorded the hostname for both servers in row 2 of the
table when you recorded the server information. If the wizard did
not automatically fill in these values, enter them into the IP address
fields of the Failover Setup Wizard screen.

__ b. Click Next.
__ 12. In the Enter Service IP addresses for the Servers (Adapter 1) window

(Figure 60 on page 77), do the following:
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Figure 59. Entering or confirming network interface IP addresses for adapter 1
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__ a. In the IP address fields, type the service IP addresses for adapter 1
(eth0) for the lower and upper servers. You recorded the hostname
for both servers in row 4 of the table when you recorded the server
information.

__ b. Click Next.
__ 13. In the Enter the IP addresses of the Servers (Adapter 2) window (Figure 61

on page 78), do the following:
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Figure 60. Entering or confirming service IP addresses for adapter 1
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__ a. In the IP address fields, confirm that the wizard retrieved and filled
in the network interface IP addresses for adapter 2 (eth1) for the
lower and upper servers. You recorded the hostname for both
servers in row 3 of the table when you recorded the server
information. If the wizard did not automatically fill in these values,
type them in the IP address fields.

__ b. Click Next.
__ 14. In the Enter Service IP addresses for the Servers (Adapter 2) window

(Figure 62 on page 79), do the following:
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Figure 61. Entering or confirming network interface IP addresses for adapter 2
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__ a. In the IP address fields, type the service IP addresses for adapter 2
(eth1) for the lower and upper servers. You recorded the hostname
for both servers in row 5 of the table when you recorded the server
information.

__ b. Click Next.
__ 15. In the Confirm the Failover Configuration window (Figure 63 on page 80),

verify that the entered information is correct and click Finish.
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Figure 62. Entering or confirming service IP addresses for adapter 2
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__ 16. In the Successful Configuration Notification window, click OK.
__ 17. Verify successful configuration by performing the following substeps for

each server:
__ a. In the VE console, click a server icon.
__ b. Click the General tab.
__ c. Verify that the server status is Online.
__ d. Click the Failover Information tab.
__ e. Verify that the Failover State is Normal.
__ f. Verify that the Failover Removed value is No.
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Figure 63. Confirm the Failover Configuration window
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